src/3rdparty/libgq/debian/rules
changeset 37 758a864f9613
equal deleted inserted replaced
36:ef0373b55136 37:758a864f9613
       
     1 #! /usr/bin/make -f
       
     2 
       
     3 # Sanitize build environment when running inside Scratchbox 1
       
     4 ifneq (,$(wildcard /targets))
       
     5    ifeq (,$(SBOX_DONT_SANITIZE))
       
     6      export PATH:=/bin:/usr/bin
       
     7      export MAKE:=make
       
     8      ifeq (,$(FAKEROOTKEY))
       
     9        export SBOX_REDIRECT_TO_DIRS:=/scratchbox/compilers/bin
       
    10      else
       
    11        export SBOX_REDIRECT_TO_DIRS:=
       
    12      endif
       
    13      ifneq (,$(shell debian/fixup-scratchbox))
       
    14         $(error Error)
       
    15      endif
       
    16   endif
       
    17 endif
       
    18 
       
    19 override_dh_auto_configure:
       
    20 	./autogen.sh
       
    21 	dh_auto_configure
       
    22 
       
    23 override_dh_auto_build:
       
    24 	dh_auto_build
       
    25 	cd gconf && doxygen
       
    26 
       
    27 override_dh_strip:
       
    28 	dh_strip -plibgq-gconf0 --dbg-package=libgq-gconf0-dbg
       
    29 	dh_strip
       
    30 
       
    31 %:
       
    32 	dh $@