src/3rdparty/libgq/gconf/Makefile.am
changeset 37 758a864f9613
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/src/3rdparty/libgq/gconf/Makefile.am	Mon Oct 04 01:19:32 2010 +0300
@@ -0,0 +1,37 @@
+AM_CXXFLAGS = $(QT_CFLAGS) $(GLIB_CFLAGS) $(GCONF_CFLAGS)
+LIBS += $(QT_LIBS) $(GLIB_LIBS) $(GCONF_LIBS)
+
+lib_LTLIBRARIES = libgq-gconf.la
+
+libgq_gconf_la_SOURCES = GConfItem \
+                         gconfitem.h \
+                         gconfitem.cpp \
+                         gconfitem_moc.cpp
+
+gqincludedir=$(includedir)/gq
+gqinclude_HEADERS = gconfitem.h GConfItem
+
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = gq-gconf.pc
+
+# Tests
+
+check_PROGRAMS = test-gconf
+
+test_gconf_SOURCES = test-gconf.h test-gconf.cpp test-gconf_moc.cpp
+test_gconf_CFLAGS = $(QTEST_CFLAGS)
+test_gconf_LDADD = libgq-gconf.la $(QTEST_LIBS)
+
+TESTS = run-test-gconf
+
+EXTRA_DIST = run-test-gconf
+
+# Moccing
+
+%_moc.cpp: %.h
+	$(MOC) -o "$@" "$<"
+
+clean-moc:
+	rm -f *_moc.cpp *_moc.lo
+
+clean-local: clean-moc