|
1 %define MAKEFILE gcc-linux.mak |
|
2 |
|
3 Summary: Complete C++ standard library |
|
4 Name: STLport |
|
5 Version: 4.5.3 |
|
6 Release: 1 |
|
7 Copyright: free (see license), see /usr/share/doc/%{name}-%{version}/license.html |
|
8 URL: http://www.stlport.org/ |
|
9 Packager: Levente Farkas <lfarkas@mindmaker.hu> |
|
10 Group: System Environment/Languages |
|
11 Icon: stlport_powered_white.gif |
|
12 Source0: http://www.stlport.org/archive/%{name}-%{version}.tar.gz |
|
13 #Patch0: STLport-rename.patch |
|
14 #Patch1: STLport-rules.patch |
|
15 #Patch2: STLport-install-dir.patch |
|
16 Buildroot: %{_tmppath}/%{name}-%{version}-%(id -u -n) |
|
17 |
|
18 %description |
|
19 STLport is a multiplatform STL implementation based on SGI STL. |
|
20 This package contains the runtime library for STLport. |
|
21 |
|
22 %package -n STLport-devel |
|
23 Summary: Complete C++ standard library header files and libraries |
|
24 Group: Development/Libraries |
|
25 Requires: STLport = %{version} |
|
26 |
|
27 %description -n STLport-devel |
|
28 STLport is a multiplatform STL implementation based on SGI STL. Complete |
|
29 C++ standard library, including <complex> and SGI STL iostreams. If you |
|
30 would like to use your code with STLport add |
|
31 "-nostdinc++ -I/usr/include/stlport" when compile and -lstlport_gcc when |
|
32 link (eg: gcc -nostdinc++ -I/usr/include/stlport x.cc -lstlport_gcc). |
|
33 |
|
34 %prep |
|
35 %setup |
|
36 %patch0 -p1 |
|
37 #%patch1 -p1 |
|
38 #%patch2 -p1 |
|
39 |
|
40 %build |
|
41 cd src |
|
42 make -f %{MAKEFILE} INSTALLDIR=$RPM_BUILD_ROOT/usr clean all |
|
43 |
|
44 %install |
|
45 rm -rf $RPM_BUILD_ROOT |
|
46 cd src |
|
47 make -f %{MAKEFILE} INSTALLDIR=$RPM_BUILD_ROOT/usr install |
|
48 cd $RPM_BUILD_ROOT/usr/include/stlport |
|
49 ln -s . ext |
|
50 |
|
51 %clean |
|
52 rm -rf $RPM_BUILD_ROOT |
|
53 |
|
54 %post -p /sbin/ldconfig |
|
55 |
|
56 %postun -p /sbin/ldconfig |
|
57 |
|
58 %post -n STLport-devel |
|
59 /sbin/ldconfig |
|
60 |
|
61 %postun -n STLport-devel |
|
62 /sbin/ldconfig |
|
63 |
|
64 %files |
|
65 %defattr(-,root,root) |
|
66 %doc doc/license.html |
|
67 /usr/lib/libstlport_gcc.so |
|
68 #/usr/lib/libstlport_gcc.so.%{version} |
|
69 /usr/lib/libstlport_gcc.so.4.5 |
|
70 |
|
71 %files -n STLport-devel |
|
72 %defattr(-,root,root) |
|
73 %doc INSTALL README doc etc test |
|
74 /usr/lib/libstlport_gcc*.a |
|
75 /usr/lib/libstlport_gcc_*debug.so* |
|
76 /usr/include/* |
|
77 |
|
78 %changelog |
|
79 * Mon Dec 10 2001 Levente Farkas <lfarkas@mindmaker.hu> |
|
80 - upgrade to 4.5.1 |
|
81 |
|
82 * Fri Nov 16 2001 Levente Farkas <lfarkas@mindmaker.hu> |
|
83 - merge with Harold's changes |
|
84 |
|
85 * Thu Nov 15 2001 <stlport@lanceerplaats.nl> |
|
86 - rebuild for RedHat 7.2, spec file fixes. |
|
87 |
|
88 * Tue Oct 2 2001 Levente Farkas <lfarkas@mindmaker.hu> |
|
89 - upgrade to 4.5 |
|
90 |
|
91 * Thu Oct 26 2000 Levente Farkas <lfarkas@mindmaker.hu> |
|
92 - upgrade to 4.1-b3 |
|
93 |
|
94 * Thu Jul 17 2000 Levente Farkas <lfarkas@mindmaker.hu> |
|
95 - initial release use STLport-4.0 |
|
96 |