configurationengine/debian/rules
changeset 0 2e8eeb919028
equal deleted inserted replaced
-1:000000000000 0:2e8eeb919028
       
     1 #!/usr/bin/make -f
       
     2 # -*- makefile -*-
       
     3 # Sample debian/rules that uses debhelper.
       
     4 # This file was originally written by Joey Hess and Craig Small.
       
     5 # As a special exception, when this file is copied by dh-make into a
       
     6 # dh-make output file, you may use that output file without restriction.
       
     7 # This special exception was added by Craig Small in version 0.37 of dh-make.
       
     8 
       
     9 # Uncomment this to turn on verbose mode.
       
    10 #export DH_VERBOSE=1
       
    11 
       
    12 
       
    13 PYVERS=$(shell pyversions -vr)
       
    14 
       
    15 CONE_SOURCES=source source/scripts
       
    16 
       
    17 build: build-stamp
       
    18 
       
    19 build-stamp:
       
    20 	dh_testdir
       
    21 
       
    22 	# Add here commands to compile the package.
       
    23 	#docbook-to-man debian/cone.sgml > cone.1
       
    24 	for i in $(CONE_SOURCES); do cd $(CURDIR)/$$i && python setup.py build; done
       
    25 	cd $(CURDIR)
       
    26 	touch $@
       
    27 
       
    28 clean: 
       
    29 	dh_testdir
       
    30 	dh_testroot
       
    31 	rm -f build-stamp
       
    32 	# Add here commands to clean up after the build process.
       
    33 	dh_clean 
       
    34 
       
    35 install: build
       
    36 	dh_testdir
       
    37 	dh_testroot
       
    38 	dh_clean -k 
       
    39 	dh_installdirs
       
    40 	# Add here commands to install the package into debian/cone.
       
    41 	#$(MAKE) DESTDIR=$(CURDIR)/debian/cone install
       
    42 	for i in $(CONE_SOURCES); do cd $(CURDIR)/$$i && python setup.py install --root=$(CURDIR)/debian/tmp; done
       
    43 	cd $(CURDIR)
       
    44 	dh_install --sourcedir=debian/tmp
       
    45 
       
    46 
       
    47 # Build architecture-independent files here.
       
    48 binary-indep: build install
       
    49 # We have nothing to do by default.
       
    50 
       
    51 # Build architecture-dependent files here.
       
    52 binary-arch: build install
       
    53 	dh_testdir
       
    54 	dh_testroot
       
    55 	dh_installchangelogs 
       
    56 	dh_installdocs
       
    57 	dh_installexamples
       
    58 #	dh_installmenu
       
    59 #	dh_installdebconf	
       
    60 #	dh_installlogrotate
       
    61 #	dh_installemacsen
       
    62 #	dh_installpam
       
    63 #	dh_installmime
       
    64 #	dh_python
       
    65 #	dh_installinit
       
    66 #	dh_installcron
       
    67 #	dh_installinfo
       
    68 #	dh_installman
       
    69 	dh_link
       
    70 #	dh_strip
       
    71 	dh_pycentral
       
    72 #	dh_install
       
    73 	dh_compress -X.py
       
    74 	dh_fixperms
       
    75 #	dh_perl
       
    76 #	dh_makeshlibs
       
    77 	dh_installdeb
       
    78 #	dh_shlibdeps
       
    79 	dh_gencontrol
       
    80 	dh_md5sums
       
    81 	dh_builddeb
       
    82 
       
    83 binary: binary-indep binary-arch
       
    84 .PHONY: build clean binary-indep binary-arch binary install