configurationengine/source/plugins/common/ConeCommandPlugin/setup.py
changeset 0 2e8eeb919028
child 3 e7e0ae78773e
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/configurationengine/source/plugins/common/ConeCommandPlugin/setup.py	Thu Mar 11 17:04:37 2010 +0200
@@ -0,0 +1,38 @@
+#
+# Copyright (c) 2009 Nokia Corporation and/or its subsidiary(-ies).
+# All rights reserved.
+# This component and the accompanying materials are made available
+# under the terms of "Eclipse Public License v1.0"
+# which accompanies this distribution, and is available
+# at the URL "http://www.eclipse.org/legal/epl-v10.html".
+#
+# Initial Contributors:
+# Nokia Corporation - initial contribution.
+#
+# Contributors:
+#
+# Description: 
+#
+
+import os, os.path
+from setuptools import setup, find_packages
+from commandplugin import __version__
+
+setup(
+    name = "conecommandplugin",
+    version = __version__,
+    packages = find_packages(exclude=["*.tests"]),
+    test_suite = "commandplugin.tests.collect_suite",
+
+    # metadata for upload to PyPI
+    author = "Teemu Rytkonen",
+    author_email = "teemu.rytkonen@nokia.com",
+    description = "Configuration Engine Configuration Tool Command plugin",
+    license = "Eclipse Public License v1.0",
+    keywords = "cone",
+    url = "http://developer.symbian.org/wiki/index.php/Software_Configuration_Middleware", 
+    zip_safe = True,
+    
+    # entrypoint info
+    entry_points={'cone.plugins.implmlreaders': ['commandml = commandplugin.commandml:CommandImplReader']}
+)