Main Page

HTTP Transport Framework Internal Documentation Documentation

Author : Technical Architect (Browsing),
API documentation auto-generated by Doxygen from the latest commented source.
Copyright © 2001 Symbian Ltd. All rights reserved.


File Index

HTTP Transport Framework Internal Documentation File List

Here is a list of all files with brief descriptions:
Authentication.h [code] |
CAliasAddress.h [code] |
CAuthenticationFilterInterface.h [code] | @public
CConnectionTimer.h [code] |
CEComFilter.h [code] | @public
CExtendedMethod.h [code] |
cheadercodec.h [code] |
CHeaderCodePage.h [code] |
CHeaderField.h [code] |
CHeaders.h [code] |
CHttpConnector.h [code] |
chttpformencoder.h [code] |
CHTTPManager.h [code] |
CHTTPSession.h [code] |
chttpsocket.h [code] |
CHttpTcpCli.h [code] |
CHttpTcpReader.h [code] |
chttptcpserverlocation.h [code] |
CHttpTcpWriter.h [code] |
CMessage.h [code] |
CNwssConnectGuard.h [code] |
CNwssTransLookUpTable.h [code] | @public
CNwssWspCOEventDispatcher.h [code] | @private
CNwssWspCOSession.h [code] | @public
CNwssWspSession.h [code] | @public
CNwssWspSessionEventFilter.h [code] |
CNwssWspTransactionEventFilter.h [code] |
CNwssWspTransportHandler.h [code] |
CNwssWspTrHndDataSupplier.h [code] | @public
corefilterspanic.h [code] |
cprotocolhandler.h [code] |
CProtTransaction.h [code] | @public
CRequest.h [code] |
CResponse.h [code] |
crxdata.h [code] |
csecuritypolicy.h [code] | @public
CTcpClientFactory.h [code] |
CTextModeHeaderCodec.h [code] |
ctextmodeheadersfilter.h [code] |
CTextModeHttpProt.h [code] | @public
ctextmodeprottransaction.h [code] |
CTextModeRxData.h [code] |
CTextModeTxData.h [code] |
CTransaction.h [code] |
ctxdata.h [code] |
CUnknownCapability.h [code] |
CWspAliasAddresses.h [code] |
CWspCapabilityInfo.h [code] |
CWspCOProtocolHandler.h [code] |
CWspCORxData.h [code] |
CWspCOTransaction.h [code] |
CWspCOTxData.h [code] |
CWspExtendedMethods.h [code] |
CWspHeaderCodec.h [code] |
CWspHeaderCodePages.h [code] |
CWspHeaderReader.h [code] |
CWspHeaderUtils.h [code] |
CWspHeaderWriter.h [code] |
CWspPrimitiveSender.h [code] |
CWspProxyInfoProvider.h [code] |
CWspTransportHandler.h [code] | @public
CWspUnknownCapabilities.h [code] |
http.h [code] | @public
httperr.h [code] | @public
httpexampleclient.h [code] |
httpexampleutils.h [code] |
httplogger.h [code] | @public
logging.h [code] | @public
MConnectInvokerCallback.h [code] |
MConnectionInfoProvider.h [code] | @public
MConnectionTimerCallback.h [code] |
mhttpauthenticationcallback.h [code] |
mhttpdatasupplier.h [code] |
mhttpfilter.h [code] |
mhttpfilterbase.h [code] |
MHTTPFilterCreationCallback.h [code] | @public
mhttpsessioneventcallback.h [code] |
mhttptransactioncallback.h [code] |
MNwssOomHandler.h [code] | @public
MNwssSessionEventHandler.h [code] | @public
MNwssTransactionEventHandler.h [code] | @public
MNwssWapServer.h [code] | @public
MRxDataObserver.h [code] | @public
MSessionPropertiesProvider.h [code] |
MTcpSocketObserver.h [code] |
MTextModeTransportHandler.h [code] |
mtransporthndobs.h [code] |
MWspAliasAddresses.h [code] |
MWspCapabilityProvider.h [code] | @public
MWspCapabilitySetter.h [code] | @public
MWspCapabilityViewer.h [code] | @public
MWspCLMethodCallback.h [code] | @public
MWspCLMethodInvoker.h [code] | @public
MWspCLPushCallback.h [code] | @public
MWspCLPushInvoker.h [code] | @public
MWspCOMethodCallback.h [code] | @public
MWspCOMethodInvoker.h [code] | @public
MWspCOMethodObserver.h [code] |
MWspCOPushCallback.h [code] | @public
MWspCOPushInvoker.h [code] | @public
MWspCORxDataCallback.h [code] |
MWspCOSessionCallback.h [code] | @public
MWspCOSessionInvoker.h [code] | @public
MWspCOTxDataCallback.h [code] |
MWspExtendedMethods.h [code] | @public
MWspHeaderCodePages.h [code] | @public
MWspPrimitiveSenderCallback.h [code] |
MWspProxyInfoProvider.h [code] | @public
MWspSessionHeadersProvider.h [code] | @public
MWspUnknownCapabilities.h [code] | @public
redirect.h [code] |
RHeaderField.h [code] | @public
rhttpconnectioninfo.h [code] |
rhttpfiltercollection.h [code] |
rhttpheaders.h [code] |
rhttpmessage.h [code] |
rhttppropertyset.h [code] |
rhttprequest.h [code] |
rhttpresponse.h [code] |
rhttpsession.h [code] |
RHTTPTransaction.h [code] | @public
rhttptransactionpropertyset.h [code] |
TClientFilter.h [code] |
TestOom.h [code] | @public
TEventRegistration.h [code] |
textmodestd.h [code] |
TFilterConfigurationIter.h [code] | @public
TFilterInformation.h [code] | @public
TFilterRegistration.h [code] |
thttpevent.h [code] |
thttpfilterhandle.h [code] |
thttpfilteriterator.h [code] |
thttpfilterregistration.h [code] |
thttphdrfielditer.h [code] |
thttphdrval.h [code] |
TNwssWspTrHndPanic.h [code] | @public
TProxyInfo.h [code] |
TTextHeaderUtils.h [code] | @public
ValidationFilter.h [code] |
wsp.h [code] | @public
WspError.h [code] |
WspPanic.h [code] |
WspTypes.h [code] | @public


Authentication.h File Reference

#include <http\CAuthenticationFilterInterface.h>
#include <http\MHTTPFilter.h>

Include dependency graph for Authentication.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | CAuthenticationFilter
class | TCredentials
Container for holding an internal storage of credentials. More...


Authentication.h Source File

Authentication.h

Go to the documentation of this file.
00001 // Copyright (c) Symbian Ltd 2001
00002
00003 #ifndef __AUTHENTICATION_H__
00004 #define __AUTHENTICATION_H__
00005
00006
00013 // System includes
00014 #include <http\CAuthenticationFilterInterface.h>
00015 #include <http\MHTTPFilter.h>
00016
00017 // Forward declarations
00018 class MHTTPAuthenticationCallback;
00019 class CMD5;
00020
00021 //##ModelId=3A3A17590238
00022 class CAuthenticationFilter : public CAuthenticationFilterInterface, public MHTTPFilter
00023     {
00024 public:
00025     static CAuthenticationFilterInterface* InstallFilterL(TAny* aAuthenticationParams);
00027     //##ModelId=3B1E68290061
00028     ~CAuthenticationFilter();
00029
00030 public: // Methods from MHTTPFilterBase
00031
00033     //##ModelId=3B1E682801E6
00034     virtual void MHFRunL(RHTTPTransaction aTransaction, const THTTPEvent& aEvent);
00035
00037     virtual void MHFSessionRunL(const THTTPSessionEvent& aEvent);
00038
00040     //##ModelId=3B1E682702AD
00041     virtual TInt MHFRunError(TInt aError, RHTTPTransaction aTransaction,
00042                              const THTTPEvent& aEvent);
00043
00045     virtual TInt MHFSessionRunError(TInt aError, const THTTPSessionEvent& aEvent);
00046
00047 public: // Methods from MHTTPFilter
00048
00050     //##ModelId=3B1E68270072
00051     virtual void MHFUnload(RHTTPSession aSession, THTTPFilterHandle aHandle);
00052
00054     //##ModelId=3B1E68260229
00055     virtual void MHFLoad(RHTTPSession aSession, THTTPFilterHandle aHandle);
00056
00057  private:
00059     //##ModelId=3B1E68260107
00060     CAuthenticationFilter(MHTTPAuthenticationCallback* aCallback);
00062     //##ModelId=3B1E682503D6
00063     void ConstructL(RHTTPSession aSession);
00064
00067     //##ModelId=3B1E6825006F
00068     void SubmitL(RHTTPTransaction aTransaction);
00069
00071     //##ModelId=3B1E6824033F
00072     void HandleTransactionL(RHTTPTransaction aTransaction);
00073
00075     //##ModelId=3B1E68240186
00076     TInt FindCredentials(const RString& aRealm, TInt aAuthType,
00077                          const TUriC8& aURI) const;
00078
00079     // Searches list for credentials that can be used with this URI
00080     // without knowing the realm.
00081     //##ModelId=3BA6004600A7
00082     TInt FindCredentialsForURI(const TUriC8& aURI) const;
00083
00086     //##ModelId=3BA600460007
00087     TInt FindHeaderPartToUseL(RHTTPTransaction aTransaction) const;
00088
00090     //##ModelId=3B1E6823030B
00091     void EncodeBasicAuthL(const RString& aUsername,const RString& aPW,
00092                           RHTTPTransaction& aTransaction);
00093
00095     //##ModelId=3B1E682300BC
00096     void EncodeDigestAuthL(const RString& aUsername,const RString& aPW,
00097                            RHTTPTransaction& aTransaction, TInt headerPart,
00098                            const THTTPHdrVal& aRequestUri);
00099
00103
00104     //##ModelId=3BA600450237
00105     TInt HA1L(const RString& aUsername,const RString& aPW,
00106              const RString& aRealm, TDes8& aResult);
00107
00108
00110     //##ModelId=3BA600450178
00111     TInt HA2L(const RStringF& aMethod, const RString& aRequestUri, TDes8& aResult);
00112
00114     //##ModelId=3BA6004500C4
00115     void Hash(const TDesC8& aMessage, TDes8& aHash);
00116
00117     //##ModelId=3BA600450056
00118     void GenerateCNonce(TDes8& aNonce);
00119
00120     //##ModelId=3BA6004403A8
00121     TBool FindAuth(const TDesC8& aQop) const;
00123
00124
00126     class TCredentials
00127         {
00128     public:
00129         RStringToken iRealm;
00130         RStringToken iUser;
00131         RStringToken iPassword;
00132         RStringTokenF iURI;
00133         TInt iAuthType;
00134         TInt iID;
00135         };
00136
00138     //##ModelId=3B1E6823008A
00139     MHTTPAuthenticationCallback*       iCallback;
00141     //##ModelId=3B1E6823004E
00142     RArray<TCredentials>              iCredentials;
00144     //##ModelId=3B1E68230012
00145     RStringPool                        iStringPool;
00146
00148     //##ModelId=3B1E682203D4
00149     TInt iLoadCount;
00150
00152     //##ModelId=3BA600440394
00153     TInt iNextID;
00154
00156     //##ModelId=3BA600440380
00157     CMD5* iMD5Calculator;
00158
00160     //##ModelId=3BA600440362
00161     TInt64 iSeed;
00162     };
00163
00164
00165 #endif //__AUTHENTICATION_H_


CAliasAddress.h File Reference

#include <e32base.h>
#include <wsp/wsptypes.h>
#include "CAliasAddress.inl"

Include dependency graph for CAliasAddress.h:

Include dependency graph

Go to the source code of this file.

Compounds

class CAliasAddress
The CAliasAddress class represents the Alias Address capability as defined by the WSP Specification, July 2001. More...


CAliasAddress.h Source File

CAliasAddress.h

Go to the documentation of this file.
00001 // CAliasAddress.h
00002 //
00003 // Copyright (C) 2001 Symbian Ltd
00004 //
00005
00006 #ifndef __CALIASADDRESS_H__
00007 #define __CALIASADDRESS_H__
00008
00009 #include <e32base.h>
00010 #include <wsp/wsptypes.h>
00011
00012 // Types used for arguments in this file (e.g. TWspBearer) are from the Wap namespace
00013 using namespace Wap;
00014
00018 //##ModelId=3C4C41B2035E
00019 class CAliasAddress : public CBase
00020     {
00021 public: // Methods
00022
00031     //##ModelId=3C4C41B203BA
00032     static CAliasAddress* NewL(TWspBearer aBearer, TUint16 aPort, const TDesC8& aAddress);
00033
00038     //##ModelId=3C4C41B203B9
00039     ~CAliasAddress();
00040
00046     //##ModelId=3C4C41B203B8
00047     inline TWspBearer GetBearer() const;
00048
00055     //##ModelId=3C4C41B203B0
00056     inline TUint16 GetPort() const;
00057
00063     //##ModelId=3C4C41B203AF
00064     inline const TDesC8& GetAddress() const;
00065
00066 private:    // Methods
00067
00074     //##ModelId=3C4C41B203A4
00075     CAliasAddress(TWspBearer aBearer, TUint16 aPort);
00076
00082     //##ModelId=3C4C41B2039A
00083     void ConstructL(const TDesC8& aAddress);
00084
00085 private:    // Attributes
00086
00089     //##ModelId=3C4C41B20392
00090     TWspBearer      iBearer;
00091
00094     //##ModelId=3C4C41B20386
00095     TUint16         iPort;
00096
00099     //##ModelId=3C4C41B20375
00100     HBufC8*         iAddress;
00101
00102     };
00103
00104 #include "CAliasAddress.inl"
00105
00106 #endif  // __CALIASADDRESS_H__


CAuthenticationFilterInterface.h File Reference

@public More...

#include <e32base.h>
#include <ecom.h>
#include <http/rhttpsession.h>

Include dependency graph for CAuthenticationFilterInterface.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class | CAuthenticationFilterInterface
@public
Since:
7.0 @dependencies CBase, REComSession, RHTTPSession @lib euser.lib ecom.lib The ECOM interface definition for an HTTP authentication filter.
 More...

struct | TAuthenticationParams

Detailed Description

@public

Warning:
: This file contains Rose Model ID comments - please do not delete

Definition in file CAuthenticationFilterInterface.h.


CAuthenticationFilterInterface.h Source File

CAuthenticationFilterInterface.h

Go to the documentation of this file.
00001 // CAuthenticationFilterInterface.h
00002 //
00003 // Copyright (C) 2001 Symbian Ltd.
00004
00011 #ifndef __CAUTHENTICATIONFILTERINTERFACE_H__
00012 #define __CAUTHENTICATIONFILTERINTERFACE_H__
00013
00014 // System includes
00015 #include <e32base.h>
00016 #include <ecom.h>
00017 #include <http/rhttpsession.h>
00018
00019 // Forward declarations
00020 class MHTTPAuthenticationCallback;
00021
00032 class CAuthenticationFilterInterface : public CBase
00033     {
00034 public: // Methods
00047     inline static void InstallFilterL(RHTTPSession& aSession, MHTTPAuthenticationCallback* aCallback);
00048
00056     inline ~CAuthenticationFilterInterface();
00057
00058 public:
00059     struct TAuthenticationParams
00060         {
00061         RHTTPSession* iSession;
00062         MHTTPAuthenticationCallback* iCallback;
00063         };
00064
00065 private: // Attributes
00067     TUid iEcomDtorID;
00068     };
00069
00070 //----------------------------------------------------------------------------------------
00071
00072 inline void CAuthenticationFilterInterface::InstallFilterL(RHTTPSession& aSession, MHTTPAuthenticationCallback* aCallback)
00073     {
00074     const TUid KUidAuthenticationFilter = {0x101F447C};
00075     TAuthenticationParams authParams;
00076     authParams.iSession = &aSession;
00077     authParams.iCallback = aCallback;
00078     REComSession::CreateImplementationL(KUidAuthenticationFilter, _FOFF(CAuthenticationFilterInterface,iEcomDtorID), &authParams);
00079     }
00080
00081 inline CAuthenticationFilterInterface::~CAuthenticationFilterInterface()
00082     {
00083     REComSession::DestroyedImplementation(iEcomDtorID);
00084     }
00085
00086 #endif // __CAUTHENTICATIONFILTERINTERFACE_H__


CConnectionTimer.h File Reference

#include <e32base.h>

Include dependency graph for CConnectionTimer.h:

Include dependency graph

Go to the source code of this file.

Compounds

class CConnectionTimer
The class CConnectionTimer is used by the Wsp Protocol Handler to ensure that a WSP session establishment times-out. More...


CConnectionTimer.h Source File

CConnectionTimer.h

Go to the documentation of this file.
00001 // CConnectionTimer.h
00002 //
00003 // Copyright (c) Symbian Ltd 2001
00004 //
00005
00006 #ifndef __CCONNECTIONTIMER_H__
00007 #define __CCONNECTIONTIMER_H__
00008
00009 #include <e32base.h>
00010
00011 class MConnectionTimerCallback;
00012
00016 //##ModelId=3C4C41AE014F
00017 class CConnectionTimer : public CTimer
00018     {
00019 public: // Methods
00020
00028     //##ModelId=3C4C41AE018D
00029     static CConnectionTimer* NewL(MConnectionTimerCallback& aCallback);
00030
00035     //##ModelId=3C4C41AE018C
00036     ~CConnectionTimer();
00037
00045     //##ModelId=3C4C41AE0184
00046     void Start(TInt aDelayTime);
00047
00048 private:    // Methods from CActive
00049
00057     //##ModelId=3C4C41AE0183
00058     virtual void RunL();
00059
00069     //##ModelId=3C4C41AE0181
00070     virtual TInt RunError(TInt aError);
00071
00072 private:    // Methods
00073
00080     //##ModelId=3C4C41AE0178
00081     CConnectionTimer(MConnectionTimerCallback& aCallback);
00082
00089     //##ModelId=3C4C41AE0177
00090     void ConstructL();
00091
00092 private:    // Attributes
00093
00096     //##ModelId=3C4C41AE016F
00097     MConnectionTimerCallback&       iCallback;
00098
00099     };
00100
00101 #endif  // __CCONNECTIONTIMER_H__


CEComFilter.h File Reference

@public More...

#include <e32base.h>
#include <ecom/ecom.h>
#include <http/rhttpsession.h>

Include dependency graph for CEComFilter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | CEComFilter
@public
Since:
7.0 This class serves as the base class for ECom filter plugins.
 More...

Variables

const TUid | KUidFilterPluginInterface = {0x101F446D}

Detailed Description

@public

Warning:
: This file contains Rose Model ID comments - please do not delete

Definition in file CEComFilter.h.

Variable Documentation

const TUid KUidFilterPluginInterface = {0x101F446D}

Definition at line 20 of file CEComFilter.h.

Referenced by CEComFilter::InstallFilterL().


CEComFilter.h Source File

CEComFilter.h

Go to the documentation of this file.
00001 // CEComFilter.h
00002 //
00003 // Copyright (C) 2001 Symbian Ltd.
00004
00011 #ifndef __CECOMFILTER_H__
00012 #define __CECOMFILTER_H__
00013
00014 // System includes
00015 #include <e32base.h>
00016 #include <ecom/ecom.h>
00017 #include <http/rhttpsession.h>
00018
00019 // The ECom filter interface UID
00020 const TUid KUidFilterPluginInterface = {0x101F446D};
00021
00032 //##ModelId=3C4C0F400280
00033 class CEComFilter : public CBase
00034     {
00035 public: // Methods
00049     //##ModelId=3C4C0F4002A8
00050     inline static CEComFilter* InstallFilterL(RHTTPSession aSession, const TUid aEComFilterUid);
00051
00065     //##ModelId=3C4C0F4002AB
00066     inline static CEComFilter* InstallFilterL(RHTTPSession aSession, const TDesC8& aEComFilterDataType);
00067
00075     //##ModelId=3C4C0F40029E
00076     inline ~CEComFilter();
00077
00078 private: // Attributes
00080     //##ModelId=3C4C0F400297
00081     TUid iEcomDtorID;
00082     };
00083
00084 //----------------------------------------------------------------------------------------
00085
00086 inline CEComFilter* CEComFilter::InstallFilterL(RHTTPSession aSession, const TUid aEComFilterUid)
00087     {
00088     TAny* filterPlugin = REComSession::CreateImplementationL(aEComFilterUid, _FOFF(CEComFilter,iEcomDtorID), &aSession);
00089     return REINTERPRET_CAST(CEComFilter*, filterPlugin);
00090     }
00091
00092 inline CEComFilter* CEComFilter::InstallFilterL(RHTTPSession aSession,const TDesC8& aEComFilterDataType)
00093     {
00094     TEComResolverParams resolverParams;
00095     resolverParams.SetDataType(aEComFilterDataType);
00096     // This will leave if the plugin is not found
00097     TAny* filterPlugin = REComSession::CreateImplementationL(KUidFilterPluginInterface,
00098                                             _FOFF(CEComFilter,iEcomDtorID),
00099                                             &aSession, resolverParams);
00100     return REINTERPRET_CAST(CEComFilter*, filterPlugin);
00101     }
00102
00103 inline CEComFilter::~CEComFilter()
00104     {
00105     REComSession::DestroyedImplementation(iEcomDtorID);
00106     }
00107
00108 #endif // __CECOMFILTER_H__


CExtendedMethod.h File Reference

#include <e32base.h>
#include "CExtendedMethod.inl"

Include dependency graph for CExtendedMethod.h:

Include dependency graph

Go to the source code of this file.

Compounds

class CExtendedMethod
The CExtendedMethod class represents the Extended Method capability as defined by the WSP Specification, July 2001. More...


CExtendedMethod.h Source File

CExtendedMethod.h

Go to the documentation of this file.
00001 // CExtendedMethod.h
00002 //
00003 // Copyright (c) Symbian Ltd 2001
00004 //
00005
00006 #ifndef __CEXTENDEDMETHOD_H__
00007 #define __CEXTENDEDMETHOD_H__
00008
00009 #include <e32base.h>
00010
00014 //##ModelId=3C4C41A0005F
00015 class CExtendedMethod : public CBase
00016     {
00017 public: // Methods
00018
00026     //##ModelId=3C4C41A0009D
00027     static CExtendedMethod* NewL(TUint8 aPDUType, const TDesC8& aMethodName);
00028
00033     //##ModelId=3C4C41A0009C
00034     ~CExtendedMethod();
00035
00041     //##ModelId=3C4C41A0009B
00042     inline TUint8 GetPDUType() const;
00043
00049     //##ModelId=3C4C41A00095
00050     inline const TDesC8& GetMethodName() const;
00051
00052 private:    // Methods
00053
00059     //##ModelId=3C4C41A00093
00060     CExtendedMethod(TUint8 aPDUType);
00061
00067     //##ModelId=3C4C41A00091
00068     void ConstructL(const TDesC8& aMethodName);
00069
00070 private:    // Attributes
00071
00074     //##ModelId=3C4C41A00089
00075     TUint8      iType;
00076
00079     //##ModelId=3C4C41A0007F
00080     HBufC8*     iName;
00081
00082     };
00083
00084 #include "CExtendedMethod.inl"
00085
00086 #endif  // __CEXTENDEDMETHOD_H__


cheadercodec.h File Reference

#include <e32base.h>
#include <http/framework/rheaderfield.h>

Include dependency graph for cheadercodec.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | CHeaderCodec
@public
Since:
7.0 An abstract HTTP header codec.
 More...

class | CHeaderReader
@public
Since:
7.0 An abstract HTTP header decoder.
 More...

class | CHeaderWriter
@public
Since:
7.0 An abstract HTTP header encoder.
 More...


cheadercodec.h Source File

cheadercodec.h

Go to the documentation of this file.
00001 // CHeaderCodec.h
00002 //
00003 // Copyright (C) 2001 Symbian Ltd
00004
00011 #ifndef __CHEADERCODEC_H__
00012 #define __CHEADERCODEC_H__
00013
00014 // System includes
00015 #include <e32base.h>
00016 #include <http/framework/rheaderfield.h>
00017
00018 // Forward declarations
00019 class CHeaderWriter;
00020 class CHeaderReader;
00021
00042 //##ModelId=3C4C18850126
00043 class CHeaderCodec : public CBase
00044     {
00045 public: // methods
00046
00051     //##ModelId=3C4C18850194
00052     IMPORT_C virtual ~CHeaderCodec();
00053
00064     //##ModelId=3C4C1885018C
00065     IMPORT_C void EncodeHeaderL(RHeaderField& aHeader) const;
00066
00077     //##ModelId=3C4C1885018A
00078     IMPORT_C void DecodeHeaderL(RHeaderField& aHeader) const;
00079
00089     //##ModelId=3C4C18850181
00090     virtual TBool CanEncode(RStringF aHeaderField) const = 0;
00091
00101     //##ModelId=3C4C18850178
00102     virtual TBool CanDecode(RStringF aHeaderField) const = 0;
00103
00118     //##ModelId=3C4C18850176
00119     virtual CHeaderCodec* FindDelegateCodecL(RStringF aHeaderField) const = 0;
00120
00121 protected: // methods
00122
00128     //##ModelId=3A914DF20273
00129     IMPORT_C CHeaderCodec();
00130
00137     //##ModelId=3C4C1885016E
00138     IMPORT_C void ConstructL();
00139
00140 protected: // attributes
00141
00144     //##ModelId=3C4C18850164
00145     CHeaderWriter* iWriter;
00146
00149     //##ModelId=3C4C1885015A
00150     CHeaderReader* iReader;
00151
00152 private: // methods
00153
00158     //##ModelId=3C4C1885016D
00159     inline virtual void Reserved1();
00160
00165     //##ModelId=3C4C1885016C
00166     inline virtual void Reserved2();
00167
00168 private: // attributes
00169
00172     //##ModelId=3C4C18850150
00173     mutable CHeaderCodec* iDelegateCodec;
00174     };
00175
00176
00187 //##ModelId=3C4C188601D1
00188 class CHeaderWriter : public CBase
00189     {
00190 public: // methods
00191
00196     //##ModelId=3C4C188601FC
00197     IMPORT_C virtual ~CHeaderWriter();
00198
00210     //##ModelId=3C4C188601FA
00211     virtual void EncodeHeaderL(RHeaderField& aHeader) = 0;
00212
00213 protected: // methods
00214
00220     IMPORT_C CHeaderWriter();
00221
00228     //##ModelId=3C4C188601F9
00229     IMPORT_C void ConstructL();
00230
00231 private: // methods
00232
00237     //##ModelId=3C4C188601F1
00238     inline virtual void Reserved1();
00239
00244     //##ModelId=3C4C188601F0
00245     inline virtual void Reserved2();
00246     };
00247
00248
00260 //##ModelId=3C4C188602FE
00261 class CHeaderReader : public CBase
00262     {
00263 public: // methods
00264
00269     //##ModelId=3C4C1886031E
00270     IMPORT_C virtual ~CHeaderReader();
00271
00283     //##ModelId=3C4C1886031C
00284     virtual void DecodeHeaderL(RHeaderField& aHeader) = 0;
00285
00286 protected: // methods
00287
00293     IMPORT_C CHeaderReader();
00294
00301     //##ModelId=3C4C18860315
00302     IMPORT_C void ConstructL();
00303
00304 private: // methods
00305
00310     //##ModelId=3C4C18860314
00311     inline virtual void Reserved1();
00312
00317     //##ModelId=3C4C18860313
00318     inline virtual void Reserved2();
00319     };
00320
00321
00322 inline void CHeaderCodec::Reserved1()
00323     {}
00324 inline void CHeaderCodec::Reserved2()
00325     {}
00326 inline void CHeaderWriter::Reserved1()
00327     {}
00328 inline void CHeaderWriter::Reserved2()
00329     {}
00330 inline void CHeaderReader::Reserved1()
00331     {}
00332 inline void CHeaderReader::Reserved2()
00333     {}
00334
00335 #endif /* __CHEADERCODEC_H__ */
00336


CHeaderCodePage.h File Reference

#include <e32base.h>
#include "CHeaderCodePage.inl"

Include dependency graph for CHeaderCodePage.h:

Include dependency graph

Go to the source code of this file.

Compounds

class CHeaderCodePage
The CHeaderCodePage class represents the Header Code Page capability as defined by the WSP Specification, July 2001. More...


CHeaderCodePage.h Source File

CHeaderCodePage.h

Go to the documentation of this file.
00001 // CHeaderCodePage.h
00002 //
00003 // Copyright (c) Symbian Ltd 2001
00004 //
00005
00006 #ifndef __CHEADERCODEPAGE_H__
00007 #define __CHEADERCODEPAGE_H__
00008
00009 #include <e32base.h>
00010
00014 //##ModelId=3C4C41B300FC
00015 class CHeaderCodePage : public CBase
00016     {
00017 public: // Methods
00018
00026     //##ModelId=3C4C41B30143
00027     static CHeaderCodePage* NewL(TUint8 aPageCode, const TDesC8& aPageName);
00028
00033     //##ModelId=3C4C41B30142
00034     ~CHeaderCodePage();
00035
00041     //##ModelId=3C4C41B3013A
00042     inline TUint8 GetPageCode() const;
00043
00049     //##ModelId=3C4C41B30139
00050     inline const TDesC8& GetPageName() const;
00051
00052 private:    // Methods
00053
00059     //##ModelId=3C4C41B30130
00060     CHeaderCodePage(TUint8 aPageCode);
00061
00068     //##ModelId=3C4C41B3012E
00069     void ConstructL(const TDesC8& aPageName);
00070
00071 private:    // Attributes
00072
00075     //##ModelId=3C4C41B30126
00076     TUint8      iCode;
00077
00080     //##ModelId=3C4C41B3011A
00081     HBufC8*     iName;
00082
00083     };
00084
00085 #include "CHeaderCodePage.inl"
00086
00087 #endif  // __CHEADERCODEPAGE_H__


CHeaderField.h File Reference

#include <e32base.h>
#include "http/thttphdrval.h"
#include "http/rhttppropertyset.h"
#include "http/rhttpheaders.h"

Include dependency graph for CHeaderField.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | CHeaderField
Generalised internal representation of a single HTTP header field. More...

class | CHeaderFieldParam
Generalised representation of a single HTTP header parameter. More...

class | THeaderFieldParamIter
Iterator class to iterate the parameters contained within a header part. More...

class | CHeaderFieldPart
Generalised representation of a single HTTP header value part. More...

class | THeaderFieldPartIter
Iterator class to iterate the parts contained within a header field. More...

Variables

const TInt | KHttpDefaultRawChunkSize = 32

Variable Documentation

const TInt KHttpDefaultRawChunkSize = 32

Definition at line 22 of file CHeaderField.h.


CHeaderField.h Source File

CHeaderField.h

Go to the documentation of this file.
00001 // CHeaderField.h
00002 //
00003 // Copyright (c) Symbian Ltd 2001
00004
00005 //
00006 // Declaration of CHeaderField, CHeaderFieldPart, THeaderFieldPartIter, CHeaderFieldParam,
00007 // and THeaderFieldParamIter classes.
00008 //
00009
00010 #ifndef __CHEADERFIELD_H__
00011 #define __CHEADERFIELD_H__
00012
00013 #include <e32base.h>
00014 #include "http/thttphdrval.h"
00015 #include "http/rhttppropertyset.h"
00016 #include "http/rhttpheaders.h"
00017
00018
00019
00020 // The default chunk size for Raw data should be set to the average length of a header field when encoded in
00021 // plaintext
00022 const TInt KHttpDefaultRawChunkSize= 32;
00023
00024
00025 class CHeaders;
00026 class CHeaderFieldPart;
00027 class THeaderFieldPartIter;
00028 class CHeaderFieldParam;
00029 class THeaderFieldParamIter;
00030 class CHeaderCodec;
00031 class RHTTPPropertySet;
00032
00033
00082 //##ModelId=3C4C186D030C
00083 class CHeaderField : public CBase
00084     {
00085 friend class THeaderFieldPartIter;
00086 friend class RHeaderField;
00087 public:
00088     //
00089     // Getters
00090     //
00091
00095     //##ModelId=3C4C186E008D
00096     RStringF Name() const;
00097
00103     //##ModelId=3C4C186E008C
00104     THeaderFieldPartIter PartsL();
00105
00112     IMPORT_C
00113     //##ModelId=3C4C186E0082
00114     void RawDataL(TPtrC8& aRawData);
00115
00116     //
00117     // Setters
00118     //
00119
00126     //##ModelId=3C4C186E006F
00127     void SetPartL(CHeaderFieldPart* aPart, TInt aIndex);
00128
00134     //##ModelId=3C4C186E0066
00135     void BeginRawDataL(TInt aChunkSize = KHttpDefaultRawChunkSize);
00136
00142     //##ModelId=3C4C186E005A
00143     void WriteRawDataL(const TDesC8& aData);
00144
00150     //##ModelId=3C4C186E0064
00151     void WriteRawDataL(TChar aData);
00152
00156     //##ModelId=3C4C186E0051
00157     void CommitRawData();
00158
00159
00160
00166     //##ModelId=3C4C186E0050
00167     TInt NumPartsL();
00168
00169
00175     //##ModelId=3C4C186E0015
00176     static CHeaderField* NewL(RStringF aHeaderFieldName, CHeaders& aOwner);
00177
00185     //##ModelId=3C4C186E0028
00186     static CHeaderField* NewL(RStringF aHeaderFieldName, CHeaders& aOwner, THTTPHdrVal aVal);
00187
00195     //##ModelId=3C4C186E003C
00196     static CHeaderField* NewL(RStringF aHeaderFieldName, CHeaders& aOwner, const TDesC8& aRawData);
00197
00199     //##ModelId=3C4C186E0014
00200     virtual ~CHeaderField();
00207     //##ModelId=3C4C186E000A
00208     CHeaderFieldPart* PartL(TInt aIndex);
00209
00210
00217     //##ModelId=3C4C186E0000
00218     void AddPartL(CHeaderFieldPart* aPart);
00219
00227     //##ModelId=3C4C186D03D4
00228     void InsertPartL(CHeaderFieldPart* aPart, TInt aIndex);
00229
00230
00237     //##ModelId=3C4C186D03C2
00238     TInt RemovePartL(CHeaderFieldPart* aPart);
00239
00240
00247     //##ModelId=3C4C186D03CB
00248     TInt RemovePartL(TInt aIndex);
00249 private: // methods
00250
00251     //
00252     // Internal format conversion
00253     //
00254
00260     //##ModelId=3C4C186D03C1
00261     void ConvertToRawFormatL();
00262
00268     //##ModelId=3C4C186D03C0
00269     void ConvertToParsedFormatL();
00270
00276     //##ModelId=3C4C186D03AC
00277     CHeaderField(RStringF aHeaderFieldName, CHeaders& aOwner);
00278
00282     //##ModelId=3C4C186D03A3
00283     void ConstructL(const TDesC8& aRawData);
00284
00286     //##ModelId=3C4C186D03A2
00287     void ClearParsedData();
00288
00290     //##ModelId=3C4C186D0398
00291     void ClearRawData();
00292
00293 private: // types and enums
00294
00297     enum TDataState
00298         {
00299         ENoDataSupplied = 0x00,
00300         EDataInRawForm  = 0x01,
00301         EDataParsedOK   = 0x02,
00302         EDataParseError = 0x03
00303         };
00304
00305 private: // attributes
00306
00309     //##ModelId=3C4C186D037C
00310     RStringF iName;
00311
00314     //##ModelId=3C4C186D0372
00315     TDataState iDataParseState;
00316
00319     //##ModelId=3C4C186D0366
00320     CHeaders* iOwner;
00321
00325     //##ModelId=3C4C186D0355
00326     HBufC8* iRawData;
00327
00331     //##ModelId=3C4C186D034A
00332     RPointerArray<CHeaderFieldPart> iParts;
00333
00336     //##ModelId=3C4C186D032C
00337     const CHeaderCodec& iCodec;
00338
00341     //##ModelId=3C4C186D0323
00342     TInt iRawChunkSize;
00343     };
00344
00345
00346
00347
00359 //##ModelId=3C4C186B034F
00360 class CHeaderFieldPart : public CBase
00361     {
00362 friend class THeaderFieldParamIter;
00363
00364 public:
00369     IMPORT_C
00370     //##ModelId=3C4C186B03D3
00371     static CHeaderFieldPart* NewL(THTTPHdrVal aVal);
00372
00374     //##ModelId=3C4C186B03D2
00375     virtual ~CHeaderFieldPart();
00376
00377     // Makes a property set from this object. (Property sets are implemented as
00378     // CHeaderFieldPart objects)
00379     //##ModelId=3C4C186B03CA
00380     inline void SetPropertySet(RHTTPPropertySet& aPropertySet);
00381     //##ModelId=3C4C186B03C8
00382     inline static void ClosePropertySet(RHTTPPropertySet& aPropertySet);
00383
00384     //
00385     // Getters
00386     //
00387
00392     IMPORT_C
00393     //##ModelId=3C4C186B03C7
00394     THTTPHdrVal Value() const;
00395
00399     IMPORT_C
00400     //##ModelId=3C4C186B03BE
00401     TInt NumParameters() const;
00402
00406     IMPORT_C
00407     //##ModelId=3C4C186B03BD
00408     THeaderFieldParamIter Parameters() const;
00409
00414     //##ModelId=3C4C186B03B3
00415     CHeaderFieldParam* Parameter(TInt aIndex) const;
00416
00421     //##ModelId=3C4C186B03B5
00422     CHeaderFieldParam* Parameter(RStringF aParamName) const;
00423
00424     //
00425     // Setters
00426     //
00427
00431     //##ModelId=3C4C186B03AC
00432     void SetValue(THTTPHdrVal aVal);
00433
00439     IMPORT_C
00440     //##ModelId=3C4C186B03AA
00441     void AddParamL(CHeaderFieldParam* aParam);
00442
00449     //##ModelId=3C4C186B03A1
00450     TInt RemoveParam(CHeaderFieldParam* aParam);
00451
00452 private: // methods
00453
00455     //##ModelId=3C4C186B039F
00456     CHeaderFieldPart(THTTPHdrVal aVal);
00457
00458 private: // attributes
00459
00461     //##ModelId=3C4C186B0397
00462     THTTPHdrVal iValue;
00463
00465     //##ModelId=3C4C186B038D
00466     RPointerArray<CHeaderFieldParam> iParams;
00467     };
00468
00469
00499 //##ModelId=3C4C186F00B6
00500 class CHeaderFieldParam : public CBase
00501     {
00502 public: // methods
00503
00510     IMPORT_C
00511     //##ModelId=3C4C186F00F2
00512     static CHeaderFieldParam* NewL(RStringF aParamName, THTTPHdrVal aVal);
00513
00515     //##ModelId=3C4C186F00EB
00516     virtual ~CHeaderFieldParam();
00517
00518     //
00519     // Getters
00520     //
00521
00525     IMPORT_C
00526     //##ModelId=3C4C186F00EA
00527     RStringF Name() const;
00528
00533     IMPORT_C
00534     //##ModelId=3C4C186F00E9
00535     THTTPHdrVal Value() const;
00536
00537     //
00538     // Setters
00539     //
00540
00544     //##ModelId=3C4C186F00E1
00545     void SetValue(THTTPHdrVal aVal);
00546
00547 private: // methods
00548
00551     //##ModelId=3C4C186F00DE
00552     CHeaderFieldParam(RStringF aName, THTTPHdrVal aVal);
00553
00554 private: // attributes
00555
00557     //##ModelId=3C4C186F00D6
00558     RStringF iName;
00559
00561     //##ModelId=3C4C186F00CC
00562     THTTPHdrVal iValue;
00563     };
00564
00568 //##ModelId=3C4C187D005C
00569 class THeaderFieldPartIter
00570     {
00571 public:
00575     //##ModelId=3C4C187D0098
00576     THeaderFieldPartIter(const CHeaderField* aHeader);
00582     IMPORT_C
00583     //##ModelId=3C4C187D0091
00584     void First();
00589     IMPORT_C
00590     //##ModelId=3C4C187D0090
00591     TBool AtEnd();
00592
00595     IMPORT_C
00596     //##ModelId=3C4C187D008F
00597     void operator++();
00601     IMPORT_C
00602     //##ModelId=3C4C187D008E
00603     const CHeaderFieldPart* operator()();
00604
00605 private:
00606
00609     //##ModelId=3C4C187D0084
00610     void CheckInvalidation();
00611
00614     //##ModelId=3C4C187D007C
00615     const CHeaderField* iHeader;
00616
00619     //##ModelId=3C4C187D0072
00620     TInt iPosIdx;
00621     };
00622
00626 //##ModelId=3C4C187C0105
00627 class THeaderFieldParamIter
00628     {
00629 public:
00633     //##ModelId=3C4C187C0144
00634     THeaderFieldParamIter(const CHeaderFieldPart* aHeaderPart);
00637     IMPORT_C
00638     //##ModelId=3C4C187C0143
00639     ~THeaderFieldParamIter();
00640
00643     IMPORT_C
00644     //##ModelId=3C4C187C0142
00645     void First();
00649     IMPORT_C
00650     //##ModelId=3C4C187C0141
00651     TBool AtEnd();
00652
00656     IMPORT_C
00657     //##ModelId=3C4C187C0139
00658     void operator++();
00662     IMPORT_C
00663     //##ModelId=3C4C187C0138
00664     const CHeaderFieldParam* operator()();
00665
00666 private:
00667
00670     //##ModelId=3C4C187C0137
00671     void CheckInvalidation();
00672
00675     //##ModelId=3C4C187C0125
00676     const CHeaderFieldPart* iHeaderPart;
00679     //##ModelId=3C4C187C011B
00680     TInt iPosIdx;
00681     };
00682
00683 inline void CHeaderFieldPart::SetPropertySet(RHTTPPropertySet& aPropertySet)
00684     {
00685     aPropertySet.iImplementation = this;
00686     }
00687
00688 inline void CHeaderFieldPart::ClosePropertySet(RHTTPPropertySet& aPropertySet)
00689     {
00690     delete aPropertySet.iImplementation;
00691     aPropertySet.iImplementation = 0;
00692     }
00693
00694 #endif // __CHEADERFIELD_H__


CHeaders.h File Reference

#include <e32base.h>
#include <stringpool.h>

Include dependency graph for CHeaders.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | THeaderFieldNamePair
Structure which contains the headerfield and the associated name. More...

class | CHeaders
The CHeaders class provides the internal implementation of the RHTTPHeaders interface, which is documented in <http.h>. More...


CHeaders.h Source File

CHeaders.h

Go to the documentation of this file.
00001 // CHeaders.h
00002 //
00003 // Copyright (c) Symbian 2001
00004
00005 #ifndef __CHEADERS_H__
00006 #define __CHEADERS_H__
00007
00008 #include <e32base.h>
00009 #include <stringpool.h>
00010
00011
00012 class CHeaderField;
00013 class CHeaderFieldPart;
00014 class CHeaderFieldParam;
00015 class CHeaderCodec;
00016 class RHTTPHeaders;
00017 class THTTPHdrVal;
00018
00019
00027 //##ModelId=3C4C18810347
00028 class CHeaders : public CBase
00029     {
00030 friend class THTTPHdrFieldIter;
00031 public:
00032
00034     //##ModelId=3C4C18820032
00035     static CHeaders* NewL(CHeaderCodec& aCodec);
00036
00038     //##ModelId=3C4C18820031
00039     ~CHeaders();
00040
00041     // Creates a handle that is an abstraction of the interface
00042     //##ModelId=3C4C1882002B
00043     RHTTPHeaders Handle();
00044
00045 public: // methods proxied from RHTTPHeaders
00046
00048     //##ModelId=3C4C1882001D
00049     void SetFieldL(RStringF aFieldName, THTTPHdrVal aFieldValue);
00050
00052     //##ModelId=3C4C18820020
00053     void SetFieldL(RStringF aFieldName, THTTPHdrVal aFieldValue,
00054                    RStringF aParamName, THTTPHdrVal aParamValue);
00055
00057     //##ModelId=3C4C1882000D
00058     void SetParamL(RStringF aFieldName, RStringF aParamName,THTTPHdrVal aParamValue,  TInt aPartIdx);
00059
00062     //##ModelId=3C4C18820009
00063     void SetRawFieldL(RStringF aFieldName, const TDesC8& aOtaFieldData, const TDesC8& aFieldSeparator);
00064
00067     //##ModelId=3C4C188103E9
00068     TInt RemoveField(RStringF aFieldName);
00069
00072     //##ModelId=3C4C188103E0
00073     TInt RemoveFieldPartL(RStringF aFieldName, TInt aIndex);
00074
00075
00077     //##ModelId=3C4C188103DF
00078     void RemoveAllFields();
00079
00083     //##ModelId=3C4C188103DD
00084     TInt FieldPartsL(RStringF aFieldName) const;
00085
00088     //##ModelId=3C4C188103CC
00089      TInt GetField(RStringF aFieldName, TInt aPartIdx, THTTPHdrVal& aHeaderValue) const;
00090
00092     //##ModelId=3C4C188103C9
00093     TInt GetRawField(RStringF aFieldName, TPtrC8& aRawFieldData) const;
00094
00095
00098     //##ModelId=3C4C188103B8
00099     THTTPHdrVal GetParam(RStringF aFieldName, RStringF aParamName, THTTPHdrVal& aValue, TInt aPartIdx) const;
00100
00102     //##ModelId=3C4C188103B7
00103     THTTPHdrFieldIter Fields() const;
00104
00106     //##ModelId=3C4C188103B6
00107     CHeaderCodec& Codec() const;
00108
00109 private:
00110
00112     class THeaderFieldNamePair
00113         {
00114     public:
00115         static TInt CompareFieldNames(const THeaderFieldNamePair& aField1, const THeaderFieldNamePair& aFieldName2);
00116     public:
00117         RStringF iFieldName;
00118         CHeaderField* iField;
00119         };
00120
00121
00123     //##ModelId=3C4C188103AE
00124     CHeaders(CHeaderCodec& aCodec);
00125
00127     //##ModelId=3C4C188103AC
00128     TInt LocateFieldName(RStringF aHeaderName) const;
00129
00132     //##ModelId=3C4C188103A4
00133     CHeaderField& CreateOrLookupFieldL(RStringF aHeaderName);
00134
00136     //##ModelId=3C4C188103A1
00137     CHeaderFieldPart* GetFieldPartL(RStringF aFieldName, TInt aPartIdx) const;
00138
00140     //##ModelId=3C4C18810397
00141     CHeaderFieldParam* GetFieldParameter(RStringF aFieldName, RStringF aParamName, TInt aPartIdx) const;
00142
00144     //##ModelId=3C4C1881038E
00145     void DoInsertInNameOrderL(CHeaderField* aHeader, RStringF aHeaderName);
00146
00148     //##ModelId=3C4C1881038D
00149     void PurgeFields();
00150
00151 private:
00152
00154     //##ModelId=3C4C18810383
00155     RArray<THeaderFieldNamePair> iFields;
00156
00158     //##ModelId=3C4C1881035E
00159     CHeaderCodec& iCodec;
00160     };
00161
00162
00163 inline CHeaders::CHeaders(CHeaderCodec& aCodec)
00164     : iCodec(aCodec)
00165     {
00166     }
00167
00168 inline CHeaderCodec& CHeaders::Codec() const
00169     {
00170     return iCodec;
00171     }
00172
00173 #endif // CMESSAGE_H


CHttpConnector.h File Reference

#include <e32base.h>
#include <in_sock.h>

Include dependency graph for CHttpConnector.h:

Include dependency graph

Go to the source code of this file.

Compounds

class CHttpConnector


CHttpConnector.h Source File

CHttpConnector.h

Go to the documentation of this file.
00001 // CHttpConnector.h
00002 //
00003 // Copyright (c) 2001 Symbian Ltd.  All rights reserved.
00004 //
00005
00006 #ifndef __CHTTPCONNECTOR_H__
00007 #define __CHTTPCONNECTOR_H__
00008
00009 #include <e32base.h>
00010 #include <in_sock.h>
00011
00012 //Forward declarations
00013 class CHttpSocket;
00014 class CHttpTcpServerLocation;
00015 class MTransportHndObs;
00016
00017 //##ModelId=3C4C405F0107
00018 class CHttpConnector : public CActive
00019     {
00020 public:
00022     //##ModelId=3C4C405F01E4
00023     static CHttpConnector* NewL(CHttpSocket& aSocket,
00024                                 CHttpTcpServerLocation& aLocation,
00025                                 MTransportHndObs& aObserver);
00026
00028     //##ModelId=3C4C405F01DA
00029     virtual ~CHttpConnector();
00030
00031     //##ModelId=3C4C405F01C7
00032     void ConnectL(TInetAddr aRemoteAddr, TRequestStatus* aTcpTHStatus);
00033
00034     // Get the HTTP status code of the proxy CONNECT request
00035     TInt GetProxyCONNECTStatus() const;
00036
00037     // Take ownership of the data buffer
00038     void TranferDataBufferOwnership(HBufC8*& aNewOwner);
00039
00040 protected: // methods inherited from CActive
00042     //##ModelId=3C4C405F01C6
00043     virtual void RunL();
00044
00046     //##ModelId=3C4C405F01B3
00047     virtual TInt RunError(TInt aError);
00048
00050     //##ModelId=3C4C405F01B2
00051     virtual void DoCancel();
00052
00053 private:
00054     enum TConnectState
00055         {
00056         EPendingSocketConnect,
00057         ESocketConnected,
00058         ETunneling,
00059         EPendingTunnel,
00060         ETunnelCreated,
00061         ESecureEstablished
00062         };
00063
00065     //##ModelId=3C4C405F0194
00066     CHttpConnector(CHttpSocket& aSocket, CHttpTcpServerLocation& aLocation, MTransportHndObs& aObserver);
00067
00069     //##ModelId=3C4C405F0193
00070     void ConstructL();
00071     //##ModelId=3C4C405F018C
00072     void CompleteSelf();
00073
00074     // Check Uri if the host is a numeric IP address
00075     TBool IsHostIPAddress(const TDesC8& aUri) const;
00076
00077 private:
00079     //##ModelId=3C4C405F0189
00080     CHttpSocket& iSocket;
00081
00083     //##ModelId=3C4C405F0177
00084     CHttpTcpServerLocation& iLocation;
00085
00087     //##ModelId=3C4C405F016B
00088     TRequestStatus* iTcpTHStatus;
00089
00091     //##ModelId=3C4C405F0159
00092     TConnectState iConnectState;
00093
00095     //##ModelId=3C4C405F014F
00096     TInetAddr iRemoteAddr;
00097
00099     //##ModelId=3C4C405F0145
00100     HBufC8* iSendBuffer;
00101
00104     //##ModelId=3C4C405F013B
00105     TSockXfrLength iNumBytesRcvd;
00106
00108     //##ModelId=3C4C405F0131
00109     HBufC8* iRecvBuffer;
00110
00112     //##ModelId=3C4C405F0127
00113     TPtr8 iRecvBufferPtr;
00114
00117     //##ModelId=3C4C405F011D
00118     MTransportHndObs& iObserver;
00119
00120     // Status code for Proxy CONNECT
00121     TInt iProxyCONNECTStatus;
00122     };
00123
00124 #endif // __CHTTPCONNECTOR_H__


chttpformencoder.h File Reference

#include <http/mhttpdatasupplier.h>

Include dependency graph for chttpformencoder.h:

Include dependency graph

Go to the source code of this file.

Compounds

class CHTTPFormEncoder
@public
Since:
7.0 A data supplier class that is used to build up data that is to be encoded to application/x-www-form-urlencoded.
 More...


chttpformencoder.h Source File

chttpformencoder.h

Go to the documentation of this file.
00001 // CHTTPFormEncoder.h
00002 //
00003 // Copyright (C) 2001 Symbian Ltd
00004
00011 #ifndef __CHTTPFORMENCODER__
00012 #define __CHTTPFORMENCODER__
00013
00014 // System includes
00015 #include <http/mhttpdatasupplier.h>
00016
00030 //##ModelId=3C4C187902EB
00031 class CHTTPFormEncoder : public CBase, public MHTTPDataSupplier
00032     {
00033 public:
00034     //##ModelId=3C4C18790347
00035     IMPORT_C static CHTTPFormEncoder* NewL();
00036     //##ModelId=3C4C18790346
00037     IMPORT_C  ~CHTTPFormEncoder();
00038
00039     // from MHTTPDataSupplier
00040     //##ModelId=3C4C1879033D
00041     virtual TBool GetNextDataPart(TPtrC8& aDataPart);
00042     //##ModelId=3C4C1879033C
00043     virtual void ReleaseData();
00044     //##ModelId=3C4C1879033B
00045     virtual TInt OverallDataSize();
00046     //
00047     //##ModelId=3C4C18790335
00048     virtual TInt Reset();
00049
00058     //##ModelId=3C4C18790332
00059     IMPORT_C void AddFieldL(const TDesC8& aFieldName, const TDesC8& aFieldValue);
00060
00061
00062 private:
00063     //##ModelId=3C4C18790331
00064     CHTTPFormEncoder();
00065     //##ModelId=3C4C1879032A
00066     void ConstructL();
00067
00068     //##ModelId=3C4C18790328
00069     TBool IsAlphaNumeric(TUint8 aChar);
00070     //##ModelId=3C4C1879031F
00071     void AppendSpecialChar(TUint8 aChar);
00072     //##ModelId=3C4C1879031D
00073     void AppendData(const TDesC8& aData);
00074
00075 private:
00076     enum THTTPFormEncoderState
00077         {
00078         EAllowAppendData, // when first constructed
00079         ESuppliedSize,
00080         ESupplyingData,    // GetDataChunk has been called but ReleaseData has not
00081         EDataReleased
00082         };
00083
00084     //##ModelId=3C4C18790315
00085     THTTPFormEncoderState iState;
00086     //##ModelId=3C4C1879030D
00087     HBufC8* iData;      // data is ALWAYS kept in the form-url-encoded format
00088     };
00089
00090 #endif // __CHTTPFORMENCODER__


CHTTPManager.h File Reference

#include <e32base.h>
#include <stringpool.h>
#include "chttpmanager.inl"

Include dependency graph for CHTTPManager.h:

Include dependency graph

Go to the source code of this file.

Compounds

class CHTTPManager
A singleton manager for HTTP Client. More...


CHTTPManager.h Source File

CHTTPManager.h

Go to the documentation of this file.
00001 // CHTTPManager.h
00002 //
00003 // Copyright (C) 2001 Symbian Ltd
00004 //
00005
00006 #ifndef __CHTTPMANAGER_H__
00007 #define __CHTTPMANAGER_H__
00008
00009 #include <e32base.h>
00010 #include <stringpool.h>
00011
00012
00019 //##ModelId=3C4C188001C9
00020 class CHTTPManager : public CBase
00021     {
00022 public:
00023
00028     //##ModelId=3C4C188001FE
00029     static CHTTPManager* CreateOrFindL();
00030
00034     //##ModelId=3C4C188001FD
00035     void Release();
00036
00039     //##ModelId=3C4C188001FB
00040     RStringPool& StringPool();
00041
00044     //##ModelId=3C4C188001FC
00045     const RStringPool& StringPool()const ;
00046
00047  private:
00048
00051     //##ModelId=3C4C188001F3
00052     CHTTPManager();
00053
00056     //##ModelId=3C4C188001F2
00057     void ConstructL();
00058
00061     //##ModelId=3C4C188001F1
00062     ~CHTTPManager();
00063
00064 private:
00065
00068     //##ModelId=3C4C188001E9
00069     RStringPool iPool;
00070
00073     //##ModelId=3C4C188001E0
00074     TUint iUseCount;
00075 };
00076
00077 #include "chttpmanager.inl"
00078
00079 #endif // __CHTTPMANAGER_H__
00080


CHTTPSession.h File Reference

#include <e32base.h>
#include <ecom/ImplementationInformation.h>
#include "http/RHTTPConnectionInfo.h"
#include "http/RHTTPSession.h"
#include "http/mhttptransactioncallback.h"
#include "http/framework/cprotocolhandler.h"
#include "TClientFilter.h"
#include "CHTTPSession.inl"

Include dependency graph for CHTTPSession.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class | TDummyTransactionCallback
class | CHTTPSession
Implementation class for the session
See also:
RHTTPSession.
 More...

class | TSessionFilterInfo
Struct for containing a session's filter information. More...


CHTTPSession.h Source File

CHTTPSession.h

Go to the documentation of this file.
00001 // CHTTPSession.h
00002 //
00003 // Copyright (c) Symbian Ltd 2001
00004
00005 #ifndef __CSESSION_H__
00006 #define __CSESSION_H__
00007
00008 #include <e32base.h>
00009 #include <ecom/ImplementationInformation.h>
00010 #include "http/RHTTPConnectionInfo.h"
00011 #include "http/RHTTPSession.h"
00012 #include "http/mhttptransactioncallback.h"
00013 #include "http/framework/cprotocolhandler.h"
00014 #include "TClientFilter.h"
00015
00016 class CHTTPManager;
00017 class CTransaction;
00018 class CHTTPTransactionCodec;
00019 class THTTPFilterRegistration;
00020 class CHeaders;
00021 class MHTTPFilterCreationCallback;
00022 class TFilterConfigurationIterator;
00023 class CEComFilter;
00024
00025 //##ModelId=3C4C0F4800BF
00026 class TDummyTransactionCallback: public MHTTPTransactionCallback
00027     {
00028 public: // Methods from MHTTPTransactionCallback
00029
00034     //##ModelId=3C4C0F4800D8
00035     virtual void MHFRunL(RHTTPTransaction aTransaction, const THTTPEvent& aEvent);
00036
00041     //##ModelId=3C4C0F4800D4
00042     virtual TInt MHFRunError(TInt aError, RHTTPTransaction aTransaction, const THTTPEvent& aEvent);
00043
00044     };
00045
00047 //##ModelId=3C4C0F37027D
00048 class TSessionFilterInfo
00049     {
00050 public: // enumerations
00052     enum TFilterCategory
00053         {
00054         EMandatory, // Mandatory filter
00055         EImplicit,  // Implicit filter
00056         EExplicit   // Explicit filter
00057         };
00058 public: // data members
00059     //##ModelId=3C4C0F3702B1
00060     CImplementationInformation* iFilterInfo;    // ECom filter implementation info
00061     //##ModelId=3C4C0F3702A7
00062     TFilterCategory iCategory;                  // The filter category
00063     //##ModelId=3C4C0F37029D
00064     CEComFilter* iFilterPlugin;                 // Pointer to the filter plugin if installed
00065     };
00066
00068 //##ModelId=3C4C187700D5
00069 class CHTTPSession : public CBase
00070     {
00071  public:
00073     //##ModelId=3C4C187802AD
00074     static CHTTPSession* NewL();
00076     //##ModelId=3C4C187802B7
00077     static CHTTPSession* NewL(const TDesC8& aProtocol);
00083     //##ModelId=3C4C187802CB
00084     static CHTTPSession* NewL(const TDesC8& aProtocol, MHTTPFilterCreationCallback* aSessionCallback);
00090     //##ModelId=3C4C187702E8
00091     static void ListAvailableProtocolsL(RPointerArray<HBufC8>& aProtocolArray);
00093     //##ModelId=3C4C187702E0
00094     ~CHTTPSession();
00096     //##ModelId=3C4C187702DE
00097     CHTTPManager& Manager();
00099     //##ModelId=3C4C187702DF
00100     const CHTTPManager& Manager() const;
00102     //##ModelId=3C4C187702D5
00103     RArray<THTTPFilterRegistration>& FilterQueue();
00105     //##ModelId=3C4C187702D6
00106     const RArray<THTTPFilterRegistration>& FilterQueue() const;
00108     //##ModelId=3C4C187702D4
00109     TInt NextFilterHandle();
00111     //##ModelId=3C4C187702CA
00112     TInt NextTransactionID();
00113
00115     //##ModelId=3C4C187702C0
00116     void AddTransactionL(CTransaction* aTransaction);
00118     //##ModelId=3C4C187702AC
00119     void RemoveTransaction(CTransaction* aTransaction);
00120
00122     //##ModelId=3C4C187702A5
00123     CHeaderCodec* Codec() const;
00125     //##ModelId=3C4C187702A4
00126     RHTTPConnectionInfo ConnectionInfo() const;
00127
00128     //##ModelId=3C4C187702A3
00129     inline RHTTPSession Handle();
00130
00134     //##ModelId=3C4C187702A2
00135     RHTTPHeaders RequestSessionHeadersL();
00136
00140     //##ModelId=3C4C18770298
00141     RHTTPHeaders ResponseSessionHeadersL();
00142
00144     //##ModelId=3C4C18770285
00145     void CreateProtocolHandlerL();
00146
00147     //##ModelId=3C4C18770284
00148     inline TBool CanAddFilters() const;
00149
00151     //##ModelId=3C4C1877027A
00152     TFilterConfigurationIterator* FilterConfigIterator() const;
00153
00155     //##ModelId=3C4C18770270
00156     void SetSessionEventCallback(MHTTPSessionEventCallback* aSessionEventCallback);
00157
00159     //##ModelId=3C4C1877023E
00160     void SendSessionEventL(THTTPSessionEvent aStatus, THTTPSessionEvent::TDirection aDirection,
00161                              THTTPFilterHandle aStart = THTTPFilterHandle::EClient);
00162
00164     void FailSessionEvent(THTTPFilterHandle aStart = THTTPFilterHandle::EClient);
00165
00190
00191     //##ModelId=3C4C18770236
00192     inline TBool IsBlocking() const;
00194     //##ModelId=3C4C18770235
00195     inline void TransactionHasBlocked();
00197     //##ModelId=3C4C18770234
00198     inline void Block();
00202     //##ModelId=3C4C1877022B
00203     void Unblock();
00205
00211     TInt SessionServerCert(TCertInfo& aServerCert);
00212
00219     TInt TransactionServerCert(TCertInfo& aServerCert, RHTTPTransaction aTransaction);
00220
00221  private:
00223     //##ModelId=3C4C1877022A
00224     CHTTPSession();
00225
00227     //##ModelId=3C4C1877020C
00228     void ConstructL(const TDesC8& aProtocol, MHTTPFilterCreationCallback* aSessionCallback);
00229
00231     //##ModelId=3C4C187701F8
00232     void InitializeFiltersL(const TDesC8& aProtocol);
00233
00235     //##ModelId=3C4C1877028E
00236     void CreateProtocolHandlerL(const TDesC8& aProtocol);
00237
00239     static void CleanListImplementationArray(TAny* aArray);
00240
00241  private:
00242     // Friend class
00243     friend class TFilterConfigurationIterator;
00244
00245     enum TBlockingStates
00246         {
00247         ENormal = 0,    // Filters can run
00248         EShouldBlock,   // Blocking (Filters should not run)
00249         EHasBlocked     // Blocking, and a transaction has failed to run due to the blocked state.
00250         };
00251
00253     //##ModelId=3C4C187701EE
00254     CHeaderFieldPart* iConnectionInfo;
00256     //##ModelId=3C4C187701DA
00257     CHTTPManager* iManager;
00259     //##ModelId=3C4C187701C8
00260     RArray<THTTPFilterRegistration> iFilterQueue;
00262     //##ModelId=3C4C18770194
00263     RArray<CTransaction*> iTransactions;
00265     //##ModelId=3C4C18770178
00266     CProtocolHandler* iProtocolHandler;
00268     //##ModelId=3C4C1877016E
00269     TInt iNextFilterHandle;
00271     //##ModelId=3C4C18770162
00272     TInt iTransCount;
00273     // The blocking state of the session
00274     //##ModelId=3C4C18770158
00275     TBlockingStates iBlockingState;
00276
00277     // The 'client filter'
00278     //##ModelId=3C4C18770145
00279     TClientFilter iClientFilter;
00280
00281     // Session request headers that will get added to each request
00282     //##ModelId=3C4C1877013B
00283     CHeaders* iRequestSessionHeaders;
00284
00285     // Session response headers that will get added to each response
00286     //##ModelId=3C4C18770131
00287     CHeaders* iResponseSessionHeaders;
00288
00289     // A dummy transaction used to send and receive session events
00290     //##ModelId=3C4C1877011D
00291     CTransaction* iSessionEventTransaction;
00292
00293     // A dummy transaction callback
00294     //##ModelId=3C4C18770113
00295     TDummyTransactionCallback iDummyTransactionCallback;
00296
00297     // ECom implementation info array (RPointerArray), contains the plugin information
00298     //##ModelId=3C4C18770109
00299     RImplInfoPtrArray iEComFilterInfoArray;
00300
00301     // Array to extend the information on the filters used for easier managing
00302     //##ModelId=3C4C187700FF
00303     RPointerArray<TSessionFilterInfo> iFilterInfoList;
00304
00305     // A filter configuration iterator that can be passed to clients to congiure the
00306     // installed filters
00307     //##ModelId=3C4C187700EC
00308     TFilterConfigurationIterator* iFilterConfigIter;
00309     };
00310
00311 #include "CHTTPSession.inl"
00312
00313 #endif // __CSESSION_H


chttpsocket.h File Reference

#include <e32base.h>
#include <e32std.h>
#include <ssl.h>
#include <securesocket.h>
#include "msessionpropertiesprovider.h"

Include dependency graph for chttpsocket.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class CHttpSocket
CHttpSocket is an abstraction of a socket. More...


chttpsocket.h Source File

chttpsocket.h

Go to the documentation of this file.
00001 // CHttpSocket.h
00002 //
00003 // Copyright (c) 2001 Symbian Ltd.  All rights reserved.
00004 //
00005
00006 #ifndef __CHTTPSOCKET_H__
00007 #define __CHTTPSOCKET_H__
00008
00009 // System includes
00010 #include <e32base.h>
00011 #include <e32std.h>
00012 #include <ssl.h>
00013 #include <securesocket.h>
00014
00015 // User includes
00016 #include "msessionpropertiesprovider.h"
00017
00018 // Forward declarations
00019 class MSecurityPolicy;
00020
00021
00026 //##ModelId=3B1E6DA10096
00027 class CHttpSocket : public CBase
00028     {
00029 public:
00030     //##ModelId=3B1E6DA10188
00031     static CHttpSocket* NewL(MSecurityPolicy* aSecurityPolicy, TSecureDialogPref aPref);
00032     //##ModelId=3B1E6DA10187
00033     ~CHttpSocket();
00034
00035     //##ModelId=3B1E6DA10186
00036     inline TBool IsOpen();
00037     //##ModelId=3B1E6DA10169
00038     TInt Open(RSocketServ& aServer,TUint addrFamily,TUint sockType,TUint protocol, RConnection& aConnection);
00039     //##ModelId=3B1E6DA10168
00040     void Close();
00041     //##ModelId=3B1E6DA1015F
00042     inline void SetRemoteClose();
00043     //##ModelId=3B1E6DA10155
00044     void Connect(TSockAddr& anAddr,TRequestStatus& aStatus);
00045     //##ModelId=3B1E6DA10154
00046     void CancelConnect();
00047
00048     //##ModelId=3B1E6DA10141
00049     void Write(const TDesC8& aDesc,TRequestStatus& aStatus);
00050     //##ModelId=3B1E6DA10140
00051     void CancelWrite();
00052
00053     //##ModelId=3B1E6DA10123
00054     void RecvOneOrMore(TDes8& aDesc,TUint flags,TRequestStatus& aStatus,TSockXfrLength& aLen);
00055     //##ModelId=3BA6211F03C0
00056     void Recv(TDes8& aDesc,TUint flags,TRequestStatus& aStatus,TSockXfrLength& aLen);
00057     //##ModelId=3BA6211F03AD
00058     void Read(TDes8& aDesc, TRequestStatus& aStatus);
00059
00060     //##ModelId=3B1E6DA10122
00061     void CancelRecv();
00062
00063     //##ModelId=3BA6211F03AC
00064     TBool IsDisconnected();
00065
00066     //##ModelId=3C4C406400C8
00067     TBool IsSecure() const;
00068     //##ModelId=3C4C406400AA
00069     void GoSecureL(TRequestStatus& aStatus, const TDesC8& aDomainName);
00070
00076     TInt ServerCert(TCertInfo& aServerCert);
00077     void GetCertInfoL(const CX509Certificate& aSource,TCertInfo& aDest);
00078     void GetDNInfo(const CX500DistinguishedName& aSource,TDNInfo& aDest);
00079
00080 private:
00081     //##ModelId=3C4C4064008C
00082     CHttpSocket(MSecurityPolicy* aSecurityPolicy, TSecureDialogPref aPref);
00083
00084 private:
00085     //##ModelId=3C4C40640082
00086     CSecureSocket* iTlsSocket;
00087
00088     //##ModelId=3B1E6DA100E8
00089     RSocket iSocket;
00090     //##ModelId=3B1E6DA100CA
00091     TBool iIsSocketOpen;
00092
00093     //##ModelId=3C4C40640070
00094     MSecurityPolicy* iSecurityPolicy;
00095
00096     //Holds the secure dialog session property
00097     TSecureDialogPref iSecureDialogPref;
00098     };
00099
00100 inline TBool CHttpSocket::IsOpen()
00101     {
00102     return iIsSocketOpen;
00103     }
00104
00105 inline void CHttpSocket::SetRemoteClose()
00106     {
00107     if(iTlsSocket)
00108         {
00109         delete iTlsSocket;
00110         iTlsSocket = NULL;
00111         }
00112     iIsSocketOpen = EFalse;
00113     }
00114
00115
00116 #endif


CHttpTcpCli.h File Reference

#include <e32base.h>
#include <e32std.h>
#include <in_sock.h>
#include <http/framework/httplogger.h>
#include "mtextmodetransporthandler.h"
#include "mtcpsocketobserver.h"

Include dependency graph for CHttpTcpCli.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | CHttpTcpClient
The TCP client class is a dedicated client end-point for TCP comms with one particular HTTP origin server or proxy server. More...

class | CSubmissionDetails

Enumerations

enum TTcpCliPanicCode {
EBadState = 1, ENoSubmissions, ERequestingServerLocationWhenNotConnected, EIncorrectObserver,
EReadCompletedUnexpectedly, EWriteCompletedUnexpectedly, ESubmitLWithActiveSubmission
}

Enumeration Type Documentation

enum TTcpCliPanicCode

Enumeration values:
EBadState
ENoSubmissions
ERequestingServerLocationWhenNotConnected
EIncorrectObserver
EReadCompletedUnexpectedly
EWriteCompletedUnexpectedly
ESubmitLWithActiveSubmission

Definition at line 32 of file CHttpTcpCli.h.


CHttpTcpCli.h Source File

CHttpTcpCli.h

Go to the documentation of this file.
00001 // CHttpTcpCli.h
00002 //
00003 // Copyright (c) 2001 Symbian Ltd.  All rights reserved.
00004 //
00005
00006 #ifndef __CHTTPTCPCLI_H__
00007 #define __CHTTPTCPCLI_H__
00008
00009 // System includes
00010 #include <e32base.h>
00011 #include <e32std.h>
00012 #include <in_sock.h>
00013 #include <http/framework/httplogger.h>
00014
00015 // User includes
00016 #include "mtextmodetransporthandler.h"
00017 #include "mtcpsocketobserver.h"
00018
00019
00020 // Forward declarations
00021 class CHttpSocket;
00022 class CTxData;
00023 class CSubmissionDetails;
00024 class CHttpTcpServerLocation;
00025 class CHttpTcpReader;
00026 class CHttpTcpWriter;
00027 class CHttpConnector;
00028 class MSecurityPolicy;
00029 class MSessionPropertiesProvider;
00030
00031
00032 enum TTcpCliPanicCode
00033     {
00034     EBadState = 1,
00035     ENoSubmissions,
00036     ERequestingServerLocationWhenNotConnected,
00037     EIncorrectObserver,
00038     EReadCompletedUnexpectedly,
00039     EWriteCompletedUnexpectedly,
00040     ESubmitLWithActiveSubmission
00041     };
00042
00063 //##ModelId=3A360B6E017D
00064 class CHttpTcpClient : public CActive, public MTextModeTransportHandler, public MHttpSocketObserver
00065     {
00066
00067 public:
00068     //##ModelId=3C4C406103C7
00069     virtual void Close();
00070     //##ModelId=3C4C4061039F
00071     virtual TServerConnectionStatus Status() const;
00072     //##ModelId=3C4C4061036D
00073     virtual const CHttpTcpServerLocation& ServerLocation() const;
00074
00076     //##ModelId=3A925C01036A
00077     static CHttpTcpClient* NewL(MSecurityPolicy* aSecurityPolicy, MSessionPropertiesProvider& aSessionPropertiesProvider, RSocketServ& aSocketServ, RConnection& aConnection);
00078
00080     //##ModelId=3A925C020195
00081     virtual ~CHttpTcpClient();
00082
00083
00084     // from MTextModeTransportHandler
00085
00090     //##ModelId=3A925C0102C0
00091
00092     virtual void SubmitL(CHttpTcpServerLocation* aServerLocation, CTxData& aData, MTransportHndObs& aObs);
00093
00096     //##ModelId=3B1E6DA0008B
00097     virtual void CancelSubmission(CTxData& aDataToCancel);
00098
00101     //##ModelId=3A925C0102AC
00102     virtual void AckData();
00103
00106     //##ModelId=3B1E6DA00077
00107     virtual void NotifyRequestDataAvailable();
00108
00114     virtual TInt ServerCert(TCertInfo& aServerCert);
00115
00116 protected: // methods inherited from CActive
00117
00119     //##ModelId=3A925C010298
00120     virtual void RunL();
00121
00123     //##ModelId=3A925C010234
00124     virtual TInt RunError(TInt aError);
00125
00127     //##ModelId=3A925C01022A
00128     virtual void DoCancel();
00129
00130 private:
00132     enum THttpState
00133         {
00134         EDisconnected,
00135         EReadyForDNS,
00136         EAwaitingDNS,
00137         EReadyToConnect,
00138         EMadeCONNECT,
00139         EDoSecureHandshake,
00140         EConnected,
00141         EPendingRequest,
00142         ERequesting,
00143         EPendingReply,
00144         EReplying,
00145         EPendingAck,
00146         EIdleListening,
00147         EIdle
00148         };
00149
00150
00151
00153     //##ModelId=3A925C0100B7
00154     CHttpTcpClient(TInt aPriority, MSecurityPolicy* aSecurityPolicy, RSocketServ& aSocketServ, RConnection& aConnection);
00155
00157     //##ModelId=3A925C010017
00158     void ConstructL(MSessionPropertiesProvider& aSessionPropertiesProvider);
00159
00161     //##ModelId=3A925C01000D
00162     void LeaveOnRequestErrL();
00163
00165     //##ModelId=3A925C010003
00166     void CompleteSelf();
00167
00170     //##ModelId=3B1E6D9F030A
00171     void DetermineNextState();
00172
00173     //##ModelId=3BA6211E007F
00174     static void Panic(TTcpCliPanicCode aPanic);
00175
00176     // From MHttpSocketObserver
00177     //##ModelId=3C4C406101BE
00178     void ReadCompletedL(TInt aErrorCode);
00179     //##ModelId=3C4C40610146
00180     void WriteCompletedL(TInt aErrorCode);
00181
00182     //##ModelId=3C4C40610114
00183     void SubmitDataToObserverL();
00184
00185 private:
00187     //##ModelId=3C4C4061010A
00188     CSubmissionDetails* iActiveSubmission;
00189
00191     //##ModelId=3A925C00028D
00192     TBool iTxLastChunk;
00193
00195     //##ModelId=3A925C00025A
00196     THttpState iTransmissionState;
00197
00199     //##ModelId=3A925C000228
00200     RSocketServ& iSockSrvHnd;
00201
00202     //Handle to RConnection
00203     RConnection& iConnHnd;
00204
00206     //##ModelId=3B1E6D9F01B6
00207     CHttpSocket* iSocket;
00208
00210     //##ModelId=3A925C0001CE
00211     RHostResolver iDnsHnd;
00212
00214     //##ModelId=3B1E6D9F013D
00215     TBool iDnsHndOpen;
00216
00218     //##ModelId=3A925C0001A6
00219     TNameEntry iHostAddrDnsEntry;
00220
00222     //##ModelId=3A925C000161
00223     TInetAddr iRemoteAddr;
00224
00227     //##ModelId=3A925C000110
00228     TSockXfrLength iNumBytesRcvd;
00229
00232     //##ModelId=3A925C0000F2
00233     HBufC8* iRecvBuffer;
00234
00236     //##ModelId=3A925C0000D4
00237     TPtr8 iRecvBufferPtr;
00238
00240     //##ModelId=3A925C0000B8
00241     TPtrC8 iSendBuffer;
00242
00243
00244     // The server location if the last submission. If we are using a persistent connection then when we begin the next
00245     // submission check to see if we are connected to the correct server
00246     //##ModelId=3C4C406100E2
00247     CHttpTcpServerLocation* iLastServerLocation;
00248
00249     //##ModelId=3C4C406100C4
00250     CHttpTcpReader* iSocketReader;
00251     //##ModelId=3C4C406100A6
00252     CHttpTcpWriter* iSocketWriter;
00253     //##ModelId=3C4C40610092
00254     CHttpConnector* iHttpConnector;
00255
00257     __DECLARE_LOG
00258
00259     //##ModelId=3C4C40610074
00260     MSecurityPolicy* iSecurityPolicy;
00261
00262     };
00263
00264
00265 //##ModelId=3B41A32D02F6
00266 class CSubmissionDetails : public CBase
00267     {
00268 public:
00269     //##ModelId=3C4C4063015D
00270     static CSubmissionDetails* NewL(CHttpTcpServerLocation* aServerLocation,
00271                                     CTxData& aSubmitData,
00272                                     MTransportHndObs& aObserver);
00273     //##ModelId=3C4C40630149
00274     CHttpTcpServerLocation* TakeOwnershipOfServerLocation();
00275     //##ModelId=3BA6211F0135
00276     ~CSubmissionDetails();
00277     //##ModelId=3BA6211F0103
00278     inline CTxData& SubmissionData() const;
00279     //##ModelId=3BA6211F00F9
00280     inline MTransportHndObs& Observer() const;
00281     //##ModelId=3C4C4063012B
00282     inline CHttpTcpServerLocation& ServerLocation() const;
00283
00284 private:
00285     //##ModelId=3C4C406300B3
00286     CSubmissionDetails(CHttpTcpServerLocation* aServerLocation, CTxData& aSubmitData,
00287                                        MTransportHndObs& aObserver);
00288 private:
00289     //##ModelId=3C4C406300A9
00290     CHttpTcpServerLocation* iServerLocation;
00291     //##ModelId=3BA6211F001D
00292     CTxData& iSubmitData;
00293     //##ModelId=3BA6211F0013
00294     MTransportHndObs& iObserver;
00295     };
00296
00297 inline CHttpTcpServerLocation& CSubmissionDetails::ServerLocation() const
00298     {
00299     return *iServerLocation;
00300     }
00301
00302 inline CTxData& CSubmissionDetails::SubmissionData() const
00303     {
00304     return iSubmitData;
00305     }
00306
00307 inline MTransportHndObs& CSubmissionDetails::Observer() const
00308     {
00309     return iObserver;
00310     }
00311
00312 #endif // __CHTTPTCPCLI_H__


CHttpTcpReader.h File Reference

#include <e32base.h>
#include "chttpsocket.h"
#include "mtcpsocketobserver.h"

Include dependency graph for CHttpTcpReader.h:

Include dependency graph

Go to the source code of this file.

Compounds

class CHttpTcpReader
Reads data from a CHttpSocket informing its observer when the read is completed. More...


CHttpTcpReader.h Source File

CHttpTcpReader.h

Go to the documentation of this file.
00001 // CHttpTcpReader.h
00002 //
00003 // Copyright (c) 2001 Symbian Ltd.  All rights reserved.
00004 //
00005
00006 #ifndef __CHTTPTCPREADER_H__
00007 #define __CHTTPTCPREADER_H__
00008
00009 #include <e32base.h>
00010
00011 #include "chttpsocket.h"
00012 #include "mtcpsocketobserver.h"
00013
00016 //##ModelId=3C4C405E035F
00017 class CHttpTcpReader : public CActive
00018     {
00019 public:
00021     //##ModelId=3C4C405E039E
00022     static CHttpTcpReader* NewL(CHttpSocket& aSocket, MHttpSocketObserver& aObserver);
00023
00025     //##ModelId=3C4C405E039D
00026     virtual ~CHttpTcpReader();
00027
00028     //##ModelId=3C4C405E0393
00029     void RecvOneOrMore(TDes8& aRecvBuffer, TSockXfrLength& aLen);
00030
00031 protected: // methods inherited from CActive
00033     //##ModelId=3C4C405E0392
00034     virtual void RunL();
00035
00037     //##ModelId=3C4C405E038A
00038     virtual TInt RunError(TInt aError);
00039
00041     //##ModelId=3C4C405E0389
00042     virtual void DoCancel();
00043
00044 private:
00046     //##ModelId=3C4C405E0380
00047     CHttpTcpReader(CHttpSocket& aSocket, MHttpSocketObserver& aObserver);
00048
00049 private:
00051     //##ModelId=3C4C405E037D
00052     CHttpSocket& iSocket;
00054     //##ModelId=3C4C405E0373
00055     MHttpSocketObserver& iObserver;
00056     };
00057
00058 #endif // __CHTTPTCPREADER_H__


chttptcpserverlocation.h File Reference

#include <e32base.h>
#include <e32std.h>

Include dependency graph for chttptcpserverlocation.h:

Include dependency graph

Go to the source code of this file.

Compounds

class CHttpTcpServerLocation


chttptcpserverlocation.h Source File

chttptcpserverlocation.h

Go to the documentation of this file.
00001 // CHttpTcpServerLocation.h
00002 //
00003 // Copyright (c) 2001 Symbian Ltd.  All rights reserved.
00004 //
00005
00006
00007 #ifndef     __CHTTPTCPSERVERLOCATION_H__
00008 #define     __CHTTPTCPSERVERLOCATION_H__
00009
00010
00011 #include <e32base.h>
00012 #include <e32std.h>
00013
00014 //##ModelId=3C4C40620238
00015 class CHttpTcpServerLocation : public CBase
00016     {
00017 public:
00022     //##ModelId=3C4C406202D9
00023     IMPORT_C static CHttpTcpServerLocation* NewL(const TDesC& aHostAddress, TUint aHostPort);
00024     //##ModelId=3C4C406202D8
00025     IMPORT_C ~CHttpTcpServerLocation();
00026     //##ModelId=3C4C406202CE
00027     IMPORT_C TBool LocationMatches(const CHttpTcpServerLocation& aLocation) const;
00028     //##ModelId=3C4C406202C6
00029     inline const TDesC& HostAddress() const;
00030     inline const TDesC8& HostAddress8() const;
00031     //##ModelId=3C4C406202C5
00032     inline TUint HostPort() const;
00033     //##ModelId=3C4C406202C4
00034     inline TBool IsPersistentConnection() const;
00035     //##ModelId=3C4C406202BA
00036     inline void SetPersistentConnection(TBool aIsPersistentConnection);
00037     //##ModelId=3C4C406202B2
00038     inline TBool IsSecure() const;
00039     //##ModelId=3C4C406202B0
00040     inline void SetSecure(TBool aIsSecure);
00041     //##ModelId=3C4C406202A7
00042     inline TBool UsesProxy() const;
00043     //##ModelId=3C4C4062029D
00044     inline void SetProxy(HBufC8* aProxy, TUint aProxyPort);
00045     //##ModelId=3C4C4062029C
00046     inline const TDesC8& ProxiedHost() const;
00047
00048     inline const TUint ProxiedPort() const;
00049
00050 private:
00051     //##ModelId=3C4C40620293
00052     void ConstructL(const TDesC& aHostAddress);
00053     //##ModelId=3C4C4062028B
00054     CHttpTcpServerLocation(TUint aHostPort);
00055 private:
00056     //##ModelId=3C4C40620288
00057     HBufC* iHostAddress;
00058     HBufC8* iHostAddress8;
00059     //##ModelId=3C4C40620276
00060     TUint iHostPort;
00061     //##ModelId=3C4C4062026C
00062     TBool iPersistentConn;
00063     //##ModelId=3C4C40620262
00064     TBool iIsSecure;
00065     //##ModelId=3C4C40620258
00066     HBufC8* iProxiedHost;
00067     TUint iProxiedPort;
00068     };
00069
00070
00071 inline const TDesC& CHttpTcpServerLocation::HostAddress() const
00072     {
00073     return *iHostAddress;
00074     }
00075
00076 inline const TDesC8& CHttpTcpServerLocation::HostAddress8() const
00077     {
00078     return *iHostAddress8;
00079     }
00080
00081 inline TUint CHttpTcpServerLocation::HostPort() const
00082     {
00083     return iHostPort;
00084     }
00085
00086 inline TBool CHttpTcpServerLocation::IsPersistentConnection() const
00087     {
00088     return iPersistentConn;
00089     }
00090
00091 inline void CHttpTcpServerLocation::SetPersistentConnection(TBool aIsPersistentConnection)
00092     {
00093     iPersistentConn = aIsPersistentConnection;
00094     }
00095
00096 inline TBool CHttpTcpServerLocation::IsSecure() const
00097     {
00098     return iIsSecure;
00099     }
00100
00101 inline void CHttpTcpServerLocation::SetSecure(TBool aIsSecure)
00102     {
00103     iIsSecure = aIsSecure;
00104     }
00105
00106 inline TBool CHttpTcpServerLocation::UsesProxy() const
00107     {
00108     return iProxiedHost != NULL;
00109     }
00110
00111 inline void CHttpTcpServerLocation::SetProxy(HBufC8* aProxy, TUint aProxyPort)
00112     {
00113     __ASSERT_DEBUG(!iProxiedHost, User::Invariant());
00114     iProxiedHost = aProxy;
00115     iProxiedPort = aProxyPort;
00116     }
00117
00118 inline const TDesC8& CHttpTcpServerLocation::ProxiedHost() const
00119     {
00120     __ASSERT_DEBUG(iProxiedHost, User::Invariant());
00121     return *iProxiedHost;
00122     }
00123
00124 inline const TUint CHttpTcpServerLocation::ProxiedPort() const
00125     {
00126     __ASSERT_DEBUG(iProxiedHost, User::Invariant());
00127     return iProxiedPort;
00128     }
00129
00130 #endif  //  __CHTTPTCPSERVERLOCATION_H__


CHttpTcpWriter.h File Reference

#include <e32base.h>
#include "chttpsocket.h"
#include "mtcpsocketobserver.h"

Include dependency graph for CHttpTcpWriter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class CHttpTcpWriter
Writes data to a CHttpSocket informing its observer when the write is completed. More...


CHttpTcpWriter.h Source File

CHttpTcpWriter.h

Go to the documentation of this file.
00001 // CHttpTcpWriter.h
00002 //
00003 // Copyright (c) 2001 Symbian Ltd.  All rights reserved.
00004 //
00005
00006 #ifndef __CHTTPTCPWRITER_H__
00007 #define __CHTTPTCPWRITER_H__
00008
00009 #include <e32base.h>
00010
00011 #include "chttpsocket.h"
00012 #include "mtcpsocketobserver.h"
00013
00016 //##ModelId=3C4C405E021E
00017 class CHttpTcpWriter : public CActive
00018     {
00019 public:
00021     //##ModelId=3C4C405E028D
00022     static CHttpTcpWriter* NewL(CHttpSocket& aSocket, MHttpSocketObserver& aObserver);
00023
00025     //##ModelId=3C4C405E028C
00026     virtual ~CHttpTcpWriter();
00027
00028     //##ModelId=3C4C405E0284
00029     void Write(TDesC8& aBuffer);
00030
00031 protected: // methods inherited from CActive
00033     //##ModelId=3C4C405E0283
00034     virtual void RunL();
00035
00037     //##ModelId=3C4C405E027A
00038     virtual TInt RunError(TInt aError);
00039
00041     //##ModelId=3C4C405E0279
00042     virtual void DoCancel();
00043
00044 private:
00046     //##ModelId=3C4C405E026E
00047     CHttpTcpWriter(CHttpSocket& aSocket, MHttpSocketObserver& aObserver);
00048
00049 private:
00051     //##ModelId=3C4C405E0266
00052     CHttpSocket& iSocket;
00054     //##ModelId=3C4C405E025C
00055     MHttpSocketObserver& iObserver;
00056     };
00057
00058 #endif // __CHTTPTCPWRITER_H__


CMessage.h File Reference

#include <e32base.h>
#include "http/rhttpheaders.h"
#include "ctransaction.h"
#include "cheaders.h"
#include "cmessage.inl"

Include dependency graph for CMessage.h:

Include dependency graph

Go to the source code of this file.

Compounds

class CMessage
Abstract base class for implementation of HTTP requests and responses. More...


CMessage.h Source File

CMessage.h

Go to the documentation of this file.
00001 // CMessage.h
00002 //
00003 // Copyright (C) 2001 Symbian Ltd
00004 //
00005
00006 #ifndef __CMESSAGE_H__
00007 #define __CMESSAGE_H__
00008
00009 #include <e32base.h>
00010 #include "http/rhttpheaders.h"
00011 #include "ctransaction.h"
00012 #include "cheaders.h"
00013
00014
00017 //##ModelId=3C4C188200EF
00018 class CMessage : public CBase
00019     {
00020 public:
00024     //##ModelId=3C4C18820153
00025     ~CMessage() = 0;
00026
00030     //##ModelId=3C4C1882014B
00031     inline void AddBody(MHTTPDataSupplier* aBody);
00032
00036     //##ModelId=3C4C1882014A
00037     inline TBool HasBody() const;
00038
00042     //##ModelId=3C4C18820149
00043     inline MHTTPDataSupplier* Body() const;
00044
00047     //##ModelId=3C4C18820141
00048     inline RHTTPHeaders Headers() const;
00049
00050 protected:
00051
00054     //##ModelId=3C4C1882013F
00055     inline void ConstructL(CTransaction* aTransaction);
00056
00057 private:
00058
00061     //##ModelId=3C4C1882012D
00062     CHeaders* iHeaders;
00063
00066     //##ModelId=3C4C18820123
00067     CTransaction* iTransaction;
00068
00071     //##ModelId=3C4C18820110
00072     MHTTPDataSupplier* iDataSupplier;
00073
00074     friend class RHTTPMessage;
00075     friend class RHTTPRequest;
00076     friend class RHTTPResponse;
00077     };
00078
00079 #include "cmessage.inl"
00080
00081
00082 #endif // __CMESSAGE_H__


CNwssConnectGuard.h File Reference

#include <e32base.h>
#include <stringpool.h>
#include <wsp/wsptypes.h>

Include dependency graph for CNwssConnectGuard.h:

Include dependency graph

Go to the source code of this file.

Compounds

class CNwssConnectGuard
Since:
7.0 This class encapsulates the functionality to ensure that the Wsp CO Session states tables are honoured by the NWSS WAP Stack.
 More...


CNwssConnectGuard.h Source File

CNwssConnectGuard.h

Go to the documentation of this file.
00001 // CNwssConnectGuard.h
00002 //
00003 // Copyright (C) 2002 Symbian Ltd.
00004
00010 #ifndef __CNWSSCONNECTGUARD_H__
00011 #define __CNWSSCONNECTGUARD_H__
00012
00013 // System includes
00014 #include <e32base.h>
00015 #include <stringpool.h>
00016 #include <wsp/wsptypes.h>
00017
00018 class CUri8;
00019 class TUriC8;
00020 class MWspCOMethodInvoker;
00021 class MWspCOMethodCallback;
00022 class MWspCOSessionCallback;
00023
00043 //##ModelId=3C9B094D0363
00044 class CNwssConnectGuard : public CActive
00045     {
00046 public: // Methods
00047
00054     //##ModelId=3C9B094E0094
00055     static CNwssConnectGuard* NewL(MWspCOMethodInvoker& aMethodInvoker, MWspCOSessionCallback& aSessionCallback);
00056
00061     //##ModelId=3C9B094E008A
00062     ~CNwssConnectGuard();
00063
00072     //##ModelId=3C9B094E0082
00073     void SendDisconnectInd(Wap::TWspReason aReason);
00074
00079     //##ModelId=3C9B094E0081
00080     void SendMethodInvokeReq();
00081
00086     //##ModelId=3C9B094E0080
00087     void SendMethodAbortInd();
00088
00100     //##ModelId=3C9B094E004E
00101     void ReceivedMethodInvokeReqL(
00102                                  MWspCOMethodCallback&      aMethodCallback,
00103                                  RStringF                   aMethod,
00104                                  const TUriC8&              aRequestUri,
00105                                  const TDesC8&              aRequestHeaders,
00106                                  const TDesC8&              aRequestBody
00107                                  );
00108
00109 private:    // Methods from CActive
00110
00111     //##ModelId=3C9B094E0045
00112     virtual void RunL();
00113
00114     //##ModelId=3C9B094E0044
00115     virtual void DoCancel();
00116
00117 private:    // Methods
00118
00125     //##ModelId=3C9B094E0031
00126     CNwssConnectGuard(MWspCOMethodInvoker& aMethodInvoker, MWspCOSessionCallback& aSessionCallback);
00127
00132     //##ModelId=3C9B094E0030
00133     void ResetMethodInfo();
00134
00139     //##ModelId=3C9B094E0026
00140     void CompleteSelf();
00141
00142 private:    // Attributes
00143
00146     //##ModelId=3C9B094E001E
00147     MWspCOMethodInvoker&            iMethodInvoker;
00148
00151     //##ModelId=3C9B094D03E6
00152     MWspCOSessionCallback&          iSessionCallback;
00153
00156     //##ModelId=3C9B094D03D3
00157     MWspCOMethodCallback*           iMethodCallback;
00158
00161     //##ModelId=3C9B094D03C9
00162     RStringF                        iMethod;
00163
00166     //##ModelId=3C9B094D03BD
00167     CUri8*                          iRequestUri;
00168
00171     //##ModelId=3C9B094D03AB
00172     HBufC8*                         iRequestHeaders;
00173
00176     //##ModelId=3C9B094D03A1
00177     HBufC8*                         iRequestBody;
00178
00181     //##ModelId=3C9B094D0397
00182     TBool                           iSendDisconnect;
00183
00186     //##ModelId=3C9B094D038D
00187     Wap::TWspReason                 iDisconnectReason;
00188
00189     };
00190
00191 #endif  // __CNWSSCONNECTGUARD_H__


CNwssTransLookUpTable.h File Reference

@public More...

#include <e32base.h>
#include <wapcli.h>

Include dependency graph for CNwssTransLookUpTable.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | CNwssTransLookUpTable
@private
Since:
7.0 This class implements a simple, pre-allocated look-up table that is used in the WSP Transport Handler to associate the transaction-related items stored in instances of the embedded class CNwssTransLUTEntry.
 More...

class | CNwssTransLUTEntry
@private
Since:
7.0 This class implements a single entry in the transaction look-up table.
 More...

Detailed Description

@public

Warning:
: This file contains Rose Model ID comments - please do not delete

Definition in file CNwssTransLookUpTable.h.


CNwssTransLookUpTable.h Source File

CNwssTransLookUpTable.h

Go to the documentation of this file.
00001 // CNwssTransLookUpTable.h
00002 //
00003 // Copyright (C) 2002 Symbian Ltd.
00004
00011 #ifndef __CNWSSTRANSLOOKUPTABLE_H__
00012 #define __CNWSSTRANSLOOKUPTABLE_H__
00013
00014 // System includes
00015 #include <e32base.h>
00016 #include <wapcli.h>
00017
00018
00019 // Forward declarations
00020 class MWspCOMethodCallback;
00021 class MHTTPDataSupplier;
00022 class CNwssWspTrHndDataSupplier;
00023
00024
00034 //##ModelId=3BBD8D0600BB
00035 class CNwssTransLookUpTable : public CBase
00036     {
00037 public: // embedded classes
00038
00051     //##ModelId=3BBD8D150198
00052     class CNwssTransLUTEntry : public CBase
00053         {
00054     public: // methods
00055
00060         static CNwssTransLUTEntry* NewL();
00061
00066         virtual ~CNwssTransLUTEntry();
00067
00068     private: // methods
00069
00074         //##ModelId=3C4C49C30046
00075         CNwssTransLUTEntry();
00076
00077     public: // attributes
00078
00082         //##ModelId=3C4C49C3003C
00083         MWspCOMethodCallback* iCallback;
00084
00087         //##ModelId=3C4C49C30014
00088         RWSPCOTrans iStackTrans;
00089
00092         //##ModelId=3C4C49C30002
00093         RWSPCOTrans::TTransID iStackTransID;
00094
00097         //##ModelId=3C4C49C203DE
00098         CNwssWspTrHndDataSupplier* iResponseBodyHandler;
00099
00103         TBool iAborted;
00104         };
00105
00106 public: // methods
00107
00116     //##ModelId=3C4C49D601AC
00117     static CNwssTransLookUpTable* NewL(TInt aTableSize);
00118
00123     //##ModelId=3C4C49D6015C
00124     virtual ~CNwssTransLookUpTable();
00125
00131     //##ModelId=3C4C49D60101
00132     CNwssTransLUTEntry& NewEntry();
00133
00145     //##ModelId=3C4C49D50345
00146     CNwssTransLUTEntry& LookUpByTransId(RWSPCOTrans::TTransID aTransId, TBool& aFound);
00147
00162     //##ModelId=3C4C49D501AA
00163     CNwssTransLUTEntry& LookUpByCallback(MWspCOMethodCallback& aCallback, TBool& aFound);
00164
00174     //##ModelId=3C4C49D500B0
00175     void RemoveEntry(MWspCOMethodCallback& aCallback);
00176
00186     //##ModelId=3C591A9A038E
00187     void ResizeTableL(TInt aNewSize);
00188
00193     //##ModelId=3C9B095601B8
00194     TBool IsEmpty() const;
00195
00202     //##ModelId=3C9B09560186
00203     CNwssTransLUTEntry& Head(TBool& aFound);
00204
00205 private: // methods
00206
00211     //##ModelId=3C4C49D5004C
00212     CNwssTransLookUpTable();
00213
00221     //##ModelId=3C4C49D40325
00222     void ConstructL(TInt aTableSize);
00223
00231     //##ModelId=3C9B0956012B
00232     CNwssTransLUTEntry* LookUp(MWspCOMethodCallback& aCallback, TInt& aIndex);
00233
00234 private: // attributes
00235
00239     //##ModelId=3C4DA52D0338
00240     TInt iNumActiveLUTEntries;
00241
00245     //##ModelId=3C4C49D402AD
00246     RPointerArray<CNwssTransLUTEntry> iEntries;
00247     };
00248
00249
00250 #endif // __CNWSSTRANSLOOKUPTABLE_H__


CNwssWspCOEventDispatcher.h File Reference

@private More...

#include <e32base.h>
#include <wapcli.h>

Include dependency graph for CNwssWspCOEventDispatcher.h:

Include dependency graph

Go to the source code of this file.

Compounds

class CNwssWspCOEventDispatcher
@private
Since:
7.0 This class acts as a hub for the receipt of Connection-Oriented WSP session and transaction events.
 More...

Detailed Description

@private

Warning:
: This file contains Rose Model ID comments - please do not delete

Definition in file CNwssWspCOEventDispatcher.h.


CNwssWspCOEventDispatcher.h Source File

CNwssWspCOEventDispatcher.h

Go to the documentation of this file.
00001 // CNwssWspCOEventDispatcher.h
00002 //
00003 // Copyright (C) 2001 Symbian Ltd.
00004
00011 #ifndef __CNWSSWSPCOEVENTDISPATCHER_H__
00012 #define __CNWSSWSPCOEVENTDISPATCHER_H__
00013
00014 // System includes
00015 #include <e32base.h>
00016 #include <wapcli.h>
00017
00018
00019 // Forward declarations
00020 class MNwssSessionEventHandler;
00021 class MNwssTransactionEventHandler;
00022 class MNwssOomHandler;
00023
00039 //##ModelId=3BBD8CBA0288
00040 class CNwssWspCOEventDispatcher : public CActive
00041     {
00042 public: // methods
00043
00060     //##ModelId=3C4C49B90178
00061     static CNwssWspCOEventDispatcher* NewL(RWSPCOConn& aWspSession,
00062                                            MNwssSessionEventHandler& aSessEventHnd,
00063                                            MNwssTransactionEventHandler& aTransEventHnd,
00064                                            MNwssOomHandler& aOutOfMemoryHnd);
00065
00070     //##ModelId=3C4C49B900E2
00071     virtual ~CNwssWspCOEventDispatcher();
00072
00079     //##ModelId=3C4C49B9007D
00080     void Start();
00081
00082 private: // methods from CActive
00083
00091     //##ModelId=3C4C49B803BB
00092     virtual void RunL();
00093
00102     //##ModelId=3C4C49B8025D
00103     virtual TInt RunError(TInt aError);
00104
00111     //##ModelId=3C4C49B801B2
00112     virtual void DoCancel();
00113
00114 private: // methods
00115
00130     //##ModelId=3C4C49B70324
00131     CNwssWspCOEventDispatcher(RWSPCOConn& aWspSession,
00132                               MNwssSessionEventHandler& aSessEventHnd,
00133                               MNwssTransactionEventHandler& aTransEventHnd,
00134                               MNwssOomHandler& aOutOfMemoryHnd);
00135
00136 private: // attributes
00137
00140     //##ModelId=3C4C49B702AD
00141     RWSPCOConn& iWspSession;
00142
00145     //##ModelId=3C4C49B702A1
00146     MNwssSessionEventHandler& iSessEventHnd;
00147
00150     //##ModelId=3C4C49B7028D
00151     MNwssTransactionEventHandler& iTransEventHnd;
00152
00155     //##ModelId=3C9B09460197
00156     MNwssOomHandler& iOutOfMemoryHnd;
00157
00160     //##ModelId=3C4C49B70279
00161     RWSPCOConn::TEvent iWspEvent;
00162
00165     //##ModelId=3C4C49B70215
00166     RWSPCOTrans iTransaction;
00167
00170     //##ModelId=3C9B09460183
00171     RWSPCOTrans::TTransID iTrId;
00172     };
00173
00174
00175 #endif // __CNWSSWSPCOEVENTDISPATCHER_H__


CNwssWspCOSession.h File Reference

@public More...

#include <wapcli.h>
#include <wsp/mwspcosessioninvoker.h>
#include <wsp/mwspcomethodinvoker.h>
#include "cnwsswspsession.h"
#include "cnwsstranslookuptable.h"
#include "mnwsssessioneventhandler.h"
#include "mnwsstransactioneventhandler.h"
#include "mnwssoomhandler.h"
#include "logging.h"

Include dependency graph for CNwssWspCOSession.h:

Include dependency graph

Go to the source code of this file.

Compounds

struct | TDelayedDisconnectPckg
struct | TDelayedMethodAbortPckg
class | CNwssWspCOSession
@public
Since:
7.0 This class encapsulates a Connection-Oriented WSP session by specialising CNwssWspSession.
 More...

Detailed Description

@public

Warning:
: This file contains Rose Model ID comments - please do not delete

Definition in file CNwssWspCOSession.h.


CNwssWspCOSession.h Source File

CNwssWspCOSession.h

Go to the documentation of this file.
00001 // CNwssWspCOSession.h
00002 //
00003 // Copyright (C) 2002 Symbian Ltd.
00004
00011 #ifndef __CNWSSWSPCOSESSION_H__
00012 #define __CNWSSWSPCOSESSION_H__
00013
00014 // System includes
00015 #include <wapcli.h> // NWSS Wap Stack
00016 #include <wsp/mwspcosessioninvoker.h>
00017 #include <wsp/mwspcomethodinvoker.h>
00018
00019 // Local includes
00020 #include "cnwsswspsession.h"
00021 #include "cnwsstranslookuptable.h"
00022 #include "mnwsssessioneventhandler.h"
00023 #include "mnwsstransactioneventhandler.h"
00024 #include "mnwssoomhandler.h"
00025 #include "logging.h"
00026
00027 // Forward declarations
00028 class MNwssWapServer;
00029 class MConnectionInfoProvider;
00030 class MWspCOSessionCallback;
00031 class CNwssWspCOEventDispatcher;
00032 class CCapCodec;
00033 class CNwssConnectGuard;
00034 class CNwssWspTransactionEventFilter;
00035 class CNwssWspSessionEventFilter;
00036
00062 //##ModelId=3BBDCF00036A
00063 class CNwssWspCOSession : public CNwssWspSession,
00064                           public MWspCOSessionInvoker,
00065                           public MWspCOMethodInvoker,
00066                           public MNwssSessionEventHandler,
00067                           public MNwssTransactionEventHandler,
00068                           public MNwssOomHandler
00069     {
00070 // Unit testing only - give friendship to a public state accessor
00071 #ifdef __UNIT_TESTING__
00072     friend class TNwssWspCOSession_StateAccessor;
00073 #endif
00074
00075 public: // methods
00076
00094     //##ModelId=3C4C49D202E6
00095     static CNwssWspCOSession* NewL(RStringPool& aStringPool,
00096                                    MNwssWapServer& aWapStackProvider,
00097                                    MConnectionInfoProvider& aConnInfoProvider,
00098                                    MSecurityPolicy& aSecurityPolicy,
00099                                    MWspCOSessionCallback& aSessionCB);
00100
00105     //##ModelId=3C4C49D2021E
00106     virtual ~CNwssWspCOSession();
00107
00108 private: // methods inherited from CNwssWspSession
00109
00127     //##ModelId=3C4C49D10014
00128     virtual TInt OpenWspSession(const TDesC8& aRemoteHost,
00129                                 RWAPConn::TPort aRemotePort,
00130                                 RWAPConn::TPort aLocalPort,
00131                                 TBearer aBearer,
00132                                 TBool aSecureConn);
00133
00140     //##ModelId=3C591A9A0171
00141     virtual TInt CloseWspSession();
00142
00155     //##ModelId=3C4C49D002F7
00156     virtual void CompleteProxyConnectionL();
00157
00165     //##ModelId=3C4C49D001FD
00166     virtual RWTLS WtlsHnd();
00167
00179     //##ModelId=3C4C49D0001C
00180     virtual void DoRunError(TInt aError);
00181
00190     //##ModelId=3C591A9A0103
00191     virtual TBool SubDoCancel();
00192
00193 private: // methods inherited from MWspCOSessionInvoker
00194
00198     //##ModelId=3C4C49CF030A
00199     virtual void ConnectReq();
00200
00204     //##ModelId=3C4C49CF0133
00205     virtual void DisconnectReq(TWspReason aReason);
00206
00210     //##ModelId=3C4C49CF0043
00211     virtual void SuspendReq();
00212
00216     //##ModelId=3C4C49CE0345
00217     virtual void ResumeReq();
00218
00219 private: // methods inherited from MWspCOMethodInvoker
00220
00224     //##ModelId=3C4C49CD01D1
00225     virtual void MethodInvokeReq(
00226                                 MWspCOMethodCallback&       aTransactionCallback,
00227                                 RStringF                    aMethod,
00228                                 const TUriC8&               aRequestUri,
00229                                 const TDesC8&               aRequestHeaders,
00230                                 const TDesC8&               aRequestBody,
00231                                 TBool                       aMoreData
00232                                 );
00233
00237     //##ModelId=3C4C49CC031A
00238     virtual void MethodInvokeDataReq(
00239                                     MWspCOMethodCallback&   aTransactionCallback,
00240                                     const TDesC8&           aRequestBody,
00241                                     const TDesC8&           aTrailerHeaders,
00242                                     TBool                   aMoreData
00243                                     );
00244
00248     //##ModelId=3C4C49CC0161
00249     virtual void MethodAbortReq(MWspCOMethodCallback& aTransactionCallback);
00250
00254     //##ModelId=3C4C49CB02BE
00255     virtual void MethodResultRes(
00256                                 MWspCOMethodCallback&   aTransactionCallback,
00257                                 const TDesC8&               aAckHeaders
00258                                 );
00259
00263     //##ModelId=3C4C49CB0047
00264     virtual void MethodResultDataRes(
00265                                     MWspCOMethodCallback&   aTransactionCallback,
00266                                     const TDesC8&               aAckHeaders
00267                                     );
00268
00269
00270 private: // methods inherited from MNwssSessionEventHandler,
00271
00275     //##ModelId=3C4C49CA035D
00276     virtual void HandleDisconnectIndL();
00277
00281     //##ModelId=3C4C49CA0231
00282     virtual void HandleSuspendIndL();
00283
00287     //##ModelId=3C4C49CA0168
00288     virtual void HandleResumeCnfL();
00289
00293     //##ModelId=3C4C49CA00AA
00294     virtual void HandleConnectCnfL();
00295
00299     //##ModelId=3C4C49C903D4
00300     virtual void HandleRedirectIndL();
00301
00305     //##ModelId=3C4C49C9031F
00306     virtual void HandleExceptionIndL();
00307
00308 private: // methods inherited from MNwssTransactionEventHandler
00309
00313     //##ModelId=3C4C49C901AD
00314     virtual void HandleMethodInvokeCnfL(RWSPCOTrans::TTransID aTransId);
00315
00319     //##ModelId=3C4C49C90044
00320     virtual void HandleMethodResultIndL(RWSPCOTrans::TTransID aTransId);
00321
00325     //##ModelId=3C4C49C802CE
00326     virtual void HandleAbortIndL(RWSPCOTrans::TTransID aTransId);
00327
00328 private: // structure used to hold items sent to the delayed OOM handling for methodabort below
00329
00330     struct TDelayedMethodAbortPckg
00331         {
00332         CNwssWspCOSession* iSession;
00333         MWspCOMethodCallback* iCallback;
00334         TBool iAbortOnStack;
00335         };
00336     //##ModelId=3C9B09540101
00337     void ScheduleDelayedOomMethodAbort(MWspCOMethodCallback& aMethodToAbort, TBool aAbortOnStack);
00338     //##ModelId=3C9B0954001A
00339     static TInt DelayedSendOomMethodAbort(TAny* aPtr);
00340
00341 private: // structure used to hold items sent to the delayed OOM handling for disconnect below
00342
00343     struct TDelayedDisconnectPckg
00344         {
00345         CNwssWspCOSession* iSession;
00346         TBool iDisconnectOnStack;
00347         };
00348     //##ModelId=3C9B09530344
00349     void ScheduleDelayedOomDisconnect(TBool aDisconnectOnStack);
00350     //##ModelId=3C9B09530268
00351     static TInt DelayedSendOomDisconnect(TAny* aPtr);
00352
00353 private: // methods inherited from MNwssOomHandler
00354
00363     //##ModelId=3C9B095203C5
00364     virtual void SendOomMethodAbort(MWspCOMethodCallback& aMethodToAbort, TBool aAbortOnStack);
00365
00375     //##ModelId=3C9B09530131
00376     virtual void SendOomMethodAbort(RWSPCOTrans::TTransID aTransId, TBool aAbortOnStack);
00377
00385     //##ModelId=3C9B095202F2
00386     virtual void SendOomDisconnect(TBool aDisconnectOnStack);
00387
00388 private: // methods
00389
00405     //##ModelId=3C4C49C702A4
00406     CNwssWspCOSession(RStringPool& aStringPool,
00407                       MNwssWapServer& aWapStackProvider,
00408                       MConnectionInfoProvider& aConnInfoProvider,
00409                       MSecurityPolicy& aSecurityPolicy,
00410                       MWspCOSessionCallback& aSessionCB);
00411
00417     //##ModelId=3C4C49C70236
00418     void ConstructL();
00419
00425     //##ModelId=3C4C49C701C8
00426     void PrepareClientCapabilities();
00427
00434     //##ModelId=3C4C49C7015A
00435     void SetNegotiatedCapabilitiesL();
00436
00449     //##ModelId=3C4C49C6037F
00450     TInt GetSessionData(TDes8& aBuffer, RWSPCOConn::TSessionDataType aType);
00451
00463     //##ModelId=3C4C49C6025D
00464     HBufC8* GetAllSessionDataLC(RWSPCOConn::TSessionDataType aType);
00465
00481     //##ModelId=3C4C49C503CE
00482     TInt GetTransactionData(RWSPCOTrans aTransaction,
00483                             TDes8& aBuffer,
00484                             RWSPCOTrans::TDataType aType);
00485
00499     //##ModelId=3C4C49C5020B
00500     HBufC8* GetAllTransactionDataLC(RWSPCOTrans aTransaction,
00501                                     RWSPCOTrans::TDataType aType);
00502
00512     //##ModelId=3C591A9A0027
00513     void ExtractRedirectedProxyInfoL(const TDesC8& aRedirectedAddresses);
00514
00515     //##ModelId=3C9B0952008F
00516     void DoSendDisconnectInd(Wap::TWspReason            aReason,
00517                               TBool                     aRedirectSecurity,
00518                               TWspRedirectedAddress&    aRedirectAddress,
00519                               const TDesC8&             aErrorHeader,
00520                               const TDesC8&             aErrorBody);
00521
00522 private: // type definitions
00523
00528     enum TAbortReason
00529         {
00530         EUnknown = -1,
00531         EWapStackTimeout = 8,
00532         // abort reason code assignments - taken from NWSS source file wps/source/wsp/common/common_dmu,h)
00533         EProtoErr      =  0xe0,
00534         EDisconnect    =  0xe1,
00535         ESuspend       =  0xe2,
00536         EResume        =  0xe3,
00537         ECongestion    =  0xe4,
00538         EConnectErr    =  0xe5,
00539         EMRUExceeded   =  0xe6,
00540         EMORExceeded   =  0xe7,
00541         EPeerReq       =  0xe8,
00542         ENetErr        =  0xe9,
00543         EUserReq       =  0xea
00544         };
00545
00546 private: // attributes
00547
00550     //##ModelId=3C4C49C50201
00551     RWSPCOConn iWspCOSession;
00552
00555     //##ModelId=3C4C49C501ED
00556     CNwssTransLookUpTable* iCOTransTable;
00557
00560     //##ModelId=3C4C49C501D9
00561     MWspCOSessionCallback& iSessionCB;
00562
00565     //##ModelId=3C4C49C501C5
00566     CNwssWspCOEventDispatcher* iEventDispatcher;
00567
00570     //##ModelId=3C4C49C501B1
00571     CCapCodec* iCapabilityCodec;
00572
00576     //##ModelId=3C4D9875006F
00577     HBufC* iUriBuffer;
00578
00581     //##ModelId=3C4D9865036F
00582     HBufC8* iSessDataBuffer;
00583
00586     //##ModelId=3C4D984301D6
00587     TUint8 iMethodMOR;
00588
00591     //##ModelId=3C4D982503C7
00592     TBool iUseAckHdrs;
00593
00596     //##ModelId=3C591A9903C9
00597     TWspRedirectedAddress iRedirectAddr;
00598
00602     //##ModelId=3C9B0952007B
00603     TBool   iInConnectLimbo;
00604
00607     //##ModelId=3C9B09520053
00608     CNwssConnectGuard*  iConnectGuard;
00609
00613     //##ModelId=3C9B0952002B
00614     CNwssWspTransactionEventFilter* iTransEventFilter;
00615
00619     //##ModelId=3C9B0952000D
00620     CNwssWspSessionEventFilter* iSessionEventFilter;
00621
00625     //##ModelId=3C9B095103CD
00626     CAsyncCallBack* iOOMCallBack;
00627
00631     //##ModelId=3C9B095103A5
00632     TDelayedMethodAbortPckg iAbortPckg;
00633
00637     //##ModelId=3C9B09510387
00638     TDelayedDisconnectPckg iDisconnectPckg;
00639     };
00640
00641
00642 #endif // __CNWSSWSPCOSESSION_H__


CNwssWspSession.h File Reference

@public More...

#include <e32base.h>
#include <wapcli.h>
#include <ssl.h>
#include "mnwsswapserver.h"
#include "logging.h"

Include dependency graph for CNwssWspSession.h:

Include dependency graph

Go to the source code of this file.

Compounds

class CNwssWspSession
@public
Since:
7.0 This abstract class encapsulates a WSP session as implemented by the NWSS WAP Stack.
 More...

Detailed Description

@public

Warning:
: This file contains Rose Model ID comments - please do not delete

Definition in file CNwssWspSession.h.


CNwssWspSession.h Source File

CNwssWspSession.h

Go to the documentation of this file.
00001 // CNwssWspSession.h
00002 //
00003 // Copyright (C) 2002 Symbian Ltd.
00004
00011 #ifndef __CNWSSWSPSESSION_H__
00012 #define __CNWSSWSPSESSION_H__
00013
00014 // System includes
00015 #include <e32base.h>
00016 #include <wapcli.h>
00017 #include <ssl.h>
00018
00019 // Local includes
00020 #include "mnwsswapserver.h"
00021 #include "logging.h"
00022
00023 // Forward declarations
00024 class MNwssWapServer;
00025 class MConnectionInfoProvider;
00026 class MSecurityPolicy;
00027
00028
00040 //##ModelId=3C4C46CF020B
00041 class CNwssWspSession : public CActive
00042     {
00043 // Unit testing only - give friendship to a public state accessor
00044 #ifdef __UNIT_TESTING__
00045     friend class TNwssWspCOSession_StateAccessor;
00046 #endif
00047
00048 public: // type defections / enumerations
00049
00053     enum TState
00054         {
00055         EDisconnected,
00056         ESessionOpen,
00057         EDoingWtlsPhase1,
00058         ECheckingServerCert,
00059         EDoingWtlsPhase2,
00060         ECheckingNegotiated,
00061         EReady
00062         };
00063
00064 public: // methods
00065
00070     //##ModelId=3C4C46CF0311
00071     virtual ~CNwssWspSession();
00072
00078     //##ModelId=3C9B094B0393
00079     TInt ServerCert(TCertInfo& aCertInfo);
00080
00081 protected: // methods
00082
00095     //##ModelId=3C4C46CF02F3
00096     CNwssWspSession(RStringPool& aStringPool,
00097                     MNwssWapServer& aWapStackProvider,
00098                     MConnectionInfoProvider& aConnInfoProvider,
00099                     MSecurityPolicy& aSecurityPolicy);
00100
00107     //##ModelId=3C4C46CF02F2
00108     void BaseConstructL();
00109
00116     //##ModelId=3C4C46CF02EA
00117     void InitiateProxyConnection();
00118
00124     //##ModelId=3C591A970069
00125     TState State() const;
00126
00134     //##ModelId=3C4C46CF02E9
00135     TInt SessionDisconnectedCallback();
00136
00142     //##ModelId=3C4C46CF02DF
00143     void MapToPanic(TInt aErrorCode) const;
00144
00145 private: // methods inherited from CActive
00146
00154     //##ModelId=3C4C46CF02DE
00155     virtual void RunL();
00156
00165     //##ModelId=3C4C46CF02D5
00166     virtual TInt RunError(TInt aError);
00167
00173     //##ModelId=3C4C46CF02D4
00174     virtual void DoCancel();
00175
00176 private: // methods to be implemented in derived classes
00177
00196     //##ModelId=3C4C46CF02AC
00197     virtual TInt OpenWspSession(const TDesC8& aRemoteHost,
00198                                 RWAPConn::TPort aRemotePort,
00199                                 RWAPConn::TPort aLocalPort,
00200                                 TBearer aBearer,
00201                                 TBool aSecureConn) = 0;
00202
00210     //##ModelId=3C591A97000E
00211     virtual TInt CloseWspSession() = 0;
00212
00222     //##ModelId=3C4C46CF02A3
00223     virtual void CompleteProxyConnectionL() = 0;
00224
00232     //##ModelId=3C4C46CF02A2
00233     virtual RWTLS WtlsHnd() = 0;
00234
00244     //##ModelId=3C4C46CF029A
00245     virtual void DoRunError(TInt aError) = 0;
00246
00254     //##ModelId=3C591A9603A6
00255     virtual TBool SubDoCancel() = 0;
00256
00257 private: // methods called from the RunL state machine
00258
00266     //##ModelId=3C4C46CF0299
00267     TBool OpenWapProxyL();
00268
00269
00277     //##ModelId=3C4C46CF0298
00278     void DoWTLSConnectionPreHandshakeL();
00279
00286     //##ModelId=3C4C46CF028E
00287     void DoWTLSConnectionPhaseOne(TBool aTwoPhaseHandshake);
00288
00295     //##ModelId=3C4C46CF0287
00296     void CancelWTLSConnectionPhaseOne();
00297
00307     //##ModelId=3C4C46CF0286
00308     void ValidateUntrustedServerCertL();
00309
00316     //##ModelId=3C9B094B0310
00317     void GetServerCertL();
00318
00323     //##ModelId=3C591A96036A
00324     void CancelValidateUntrustedServerCert();
00325
00331     //##ModelId=3C4C46CF0285
00332     void DoWTLSConnectionPhaseTwo();
00333
00340     //##ModelId=3C4C46CF0284
00341     void CancelWTLSConnectionPhaseTwo();
00342
00349     //##ModelId=3C4C46CF027C
00350     void DoWTLSConnectionPostHandshakeL();
00351
00359     //##ModelId=3C4C46CF027B
00360     TBool AnonymousAuthenticationAllowed();
00361
00366     //##ModelId=3C4C46CF027A
00367     void CompleteSelf();
00368
00369 #ifdef _DEBUG
00370 private: // Debug-only methods that dump negotiated WTLS parameters
00371
00379     //##ModelId=3C9B094B01BC
00380     void DumpCipherSuite(RWTLS::TCipherSuite aCipherSuite, TBool aRequested);
00381
00390     //##ModelId=3C9B094A03E1
00391     void DumpKeyExchangeSuite(RWTLS::TKeyExchangeSuite aKeyExchSuite, RWTLS::TIdType aStackIdType, TBool aRequested);
00392
00400     //##ModelId=3C9B094A0297
00401     void DumpSequenceNumberMode(RWTLS::TSequenceNumberMode aSeqNumMode, TBool aRequested);
00402
00403     //##ModelId=3C9B094A0156
00404     void DumpKeyRefreshRate(TUint8 aKeyRefreshRate, TBool aRequested);
00405     //##ModelId=3C9B094A0098
00406     void DumpSharedSecret(const TDesC8& aSharedSecret);
00407     //##ModelId=3C9B09490340
00408     void DumpRecordLengthUsage(TBool aRecordLengthUsage, TBool aRequested);
00409
00410 #endif
00411
00412 protected: // attributes
00413
00416     __DECLARE_LOG
00417
00420     //##ModelId=3C4C46CF0272
00421     RStringPool& iStringPool;
00422
00425     //##ModelId=3C4C46CF0265
00426     MNwssWapServer& iWapStackProvider;
00427
00430     //##ModelId=3C4C46CF0253
00431     MConnectionInfoProvider& iConnInfoProvider;
00432
00433 private: // attributes
00434
00437     //##ModelId=3C4D961900D5
00438     TState iState;
00439
00442     //##ModelId=3C4C46CF023D
00443     MSecurityPolicy& iSecurityPolicy;
00444
00448     //##ModelId=3C9B09490321
00449     TBool iHandshakeWasAnonymous;
00450
00454     //##ModelId=3C4D95A40325
00455     TCertInfo iServerCert;
00456
00458     //##ModelId=3C9B09490303
00459     TBool iServerCertValid;
00460     };
00461
00462
00463 #endif // __CNWSSWSPSESSION_H__


CNwssWspSessionEventFilter.h File Reference

#include <e32base.h>
#include "mnwsssessioneventhandler.h"

Include dependency graph for CNwssWspSessionEventFilter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class CNwssWspSessionEventFilter


CNwssWspSessionEventFilter.h Source File

CNwssWspSessionEventFilter.h

Go to the documentation of this file.
00001 // CNwssWspSessionEventFilter.h
00002 //
00003 // Copyright (C) 2002 Symbian Ltd.
00004
00005 #ifndef __CNWSSWSPSESSIONEVENTFILTER_H__
00006 #define __CNWSSWSPSESSIONEVENTFILTER_H__
00007
00008 #include <e32base.h>
00009
00010 #include "mnwsssessioneventhandler.h"
00011
00012 class CNwssTransLookUpTable;
00013 class MNwssTransactionEventHandler;
00014
00015 //##ModelId=3C9B094C023F
00016 class CNwssWspSessionEventFilter : public CActive, public MNwssSessionEventHandler
00017     {
00018 public: // Methods
00019
00030     //##ModelId=3C9B094C02B8
00031     static CNwssWspSessionEventFilter* NewL(
00032                                            CNwssTransLookUpTable&           aTransTable,
00033                                            MNwssSessionEventHandler&        aSessionEventHandler,
00034                                            MNwssTransactionEventHandler&    aTransEventHandler
00035                                            );
00036
00041     //##ModelId=3C9B094C02B1
00042     virtual ~CNwssWspSessionEventFilter();
00043
00044 private: // methods inherited from MNwssSessionEventHandler
00045
00049     //##ModelId=3C9B094C02B0
00050     virtual void HandleDisconnectIndL();
00051
00055     //##ModelId=3C9B094C02AF
00056     virtual void HandleSuspendIndL();
00057
00061     //##ModelId=3C9B094C02AE
00062     virtual void HandleResumeCnfL();
00063
00067     //##ModelId=3C9B094C02A5
00068     virtual void HandleConnectCnfL();
00069
00073     //##ModelId=3C9B094C02A4
00074     virtual void HandleRedirectIndL();
00075
00079     //##ModelId=3C9B094C029C
00080     virtual void HandleExceptionIndL();
00081
00082 private: // methods from CActive
00083
00091     //##ModelId=3C9B094C029B
00092     virtual void RunL();
00093
00102     //##ModelId=3C9B094C0293
00103     virtual TInt RunError(TInt aError);
00104
00111     //##ModelId=3C9B094C0292
00112     virtual void DoCancel();
00113
00114 private:    // Methods
00115
00120     //##ModelId=3C9B094C0287
00121     CNwssWspSessionEventFilter(
00122                               CNwssTransLookUpTable&            aTransTable,
00123                               MNwssSessionEventHandler&         aSessionEventHandler,
00124                               MNwssTransactionEventHandler&     aTransEventHandler
00125                               );
00126
00127
00132     //##ModelId=3C9B094C0286
00133     void CompleteSelf();
00134
00135 private:    // Attributes
00136
00139     //##ModelId=3C9B094C027C
00140     CNwssTransLookUpTable&          iTransTable;
00141
00144     //##ModelId=3C9B094C026A
00145     MNwssSessionEventHandler&       iSessionEventHandler;
00146
00149     //##ModelId=3C9B094C0262
00150     MNwssTransactionEventHandler&   iTransEventHandler;
00151
00152     };
00153
00154 #endif // __CNWSSWSPSESSIONEVENTFILTER_H__


CNwssWspTransactionEventFilter.h File Reference

#include <e32base.h>
#include <wapcli.h>
#include "mnwsstransactioneventhandler.h"

Include dependency graph for CNwssWspTransactionEventFilter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class CNwssWspTransactionEventFilter


CNwssWspTransactionEventFilter.h Source File

CNwssWspTransactionEventFilter.h

Go to the documentation of this file.
00001 // CNwssWspTransactionEventFilter.h
00002 //
00003 // Copyright (C) 2002 Symbian Ltd.
00004
00005 #ifndef __CNWSSWSPTRANSACTIONEVENTFILTER_H__
00006 #define __CNWSSWSPTRANSACTIONEVENTFILTER_H__
00007
00008 #include <e32base.h>
00009 #include <wapcli.h>
00010
00011 #include "mnwsstransactioneventhandler.h"
00012
00013 class CNwssTransLookUpTable;
00014
00015 //##ModelId=3C9B095501DE
00016 class CNwssWspTransactionEventFilter : public CActive, public MNwssTransactionEventHandler
00017     {
00018 public: // Methods
00019
00028     //##ModelId=3C9B095502B2
00029     static CNwssWspTransactionEventFilter* NewL(
00030                                                CNwssTransLookUpTable&           aTransTable,
00031                                                MNwssTransactionEventHandler&    aTransEventHandler,
00032                                                TInt                         aTableSize
00033                                                );
00034
00039     //##ModelId=3C9B095502B1
00040     virtual ~CNwssWspTransactionEventFilter();
00041
00049     //##ModelId=3C9B095502A9
00050     void SendMethodAbortIndEvent(RWSPCOTrans::TTransID aTransId);
00051
00057     //##ModelId=3C9B095502A8
00058     void SessionDisconnectRequested();
00059
00064     //##ModelId=3C9B095502A7
00065     void SessionDisconnected();
00066
00076     //##ModelId=3C9B0955029D
00077     void ResizeTableL(TInt aNewSize);
00078
00079 private: // methods inherited from MNwssTransactionEventHandler
00080
00084     //##ModelId=3C9B09550293
00085     virtual void HandleMethodInvokeCnfL(RWSPCOTrans::TTransID aTransId);
00086
00090     //##ModelId=3C9B09550289
00091     virtual void HandleMethodResultIndL(RWSPCOTrans::TTransID aTransId);
00092
00096     //##ModelId=3C9B0955027E
00097     virtual void HandleAbortIndL(RWSPCOTrans::TTransID aTransId);
00098
00099 private: // methods from CActive
00100
00108     //##ModelId=3C9B09550275
00109     virtual void RunL();
00110
00119     //##ModelId=3C9B0955026B
00120     virtual TInt RunError(TInt aError);
00121
00128     //##ModelId=3C9B0955026A
00129     virtual void DoCancel();
00130
00131 private:    // Methods
00132
00137     //##ModelId=3C9B09550257
00138     CNwssWspTransactionEventFilter(CNwssTransLookUpTable& aTransTable, MNwssTransactionEventHandler& aTransEventHandler);
00139
00144     //##ModelId=3C9B0955024D
00145     void ConstructL(TInt aTableSize);
00146
00151     //##ModelId=3C9B0955024C
00152     void CompleteSelf();
00153
00154 private:    // Attributes
00155
00158     //##ModelId=3C9B09550244
00159     CNwssTransLookUpTable&          iTransTable;
00160
00163     //##ModelId=3C9B09550230
00164     MNwssTransactionEventHandler&   iTransEventHandler;
00165
00168     //##ModelId=3C9B09550226
00169     TInt                            iHighWaterMark;
00170
00173     //##ModelId=3C9B0955021A
00174     RArray<RWSPCOTrans::TTransID>   iEntries;
00175
00178     //##ModelId=3C9B09550209
00179     TBool                           iSessionClosing;
00180
00181     };
00182
00183 #endif // __CNWSSWSPTRANSACTIONEVENTFILTER_H__


CNwssWspTransportHandler.h File Reference

#include <wsp/cwsptransporthandler.h>
#include <wsp/mwspcosessioninvoker.h>
#include <wsp/mwspcomethodinvoker.h>
#include <wapcli.h>
#include "cnwsswspsession.h"
#include "mnwsswapserver.h"
#include "mconnectioninfoprovider.h"
#include "cnwsswspcosession.h"

Include dependency graph for CNwssWspTransportHandler.h:

Include dependency graph

Go to the source code of this file.

Compounds

class CNwssWspTransportHandler
@public
Since:
7.0 This class provides a concrete implementation of the CWspTransportHandler interface, specifically for the NWSS Rainbow 2.1 WAP Stack, which is used on the Hurricane release of Symbian OS.
 More...


CNwssWspTransportHandler.h Source File

CNwssWspTransportHandler.h

Go to the documentation of this file.
00001 // CNwssWspTransportHandler.h
00002 //
00003 // Copyright (C) 2001 Symbian Ltd
00004
00005 #ifndef __CNWSSWSPTRANSPORTHANDLER_H__
00006 #define __CNWSSWSPTRANSPORTHANDLER_H__
00007
00008 // System includes
00009 #include <wsp/cwsptransporthandler.h>
00010 #include <wsp/mwspcosessioninvoker.h>
00011 #include <wsp/mwspcomethodinvoker.h>
00012 #include <wapcli.h>
00013
00014 // Local includes
00015 #include "cnwsswspsession.h"
00016 #include "mnwsswapserver.h"
00017 #include "mconnectioninfoprovider.h"
00018 #include "cnwsswspcosession.h"
00019
00020 // Forward declarations
00021 class MWspCOPushInvoker;
00022 class MWspCLMethodInvoker;
00023 class MWspCLPushInvoker;
00024
00052 //##ModelId=3BBD8B17018B
00053 class CNwssWspTransportHandler : public CWspTransportHandler,
00054                                  public MNwssWapServer,
00055                                  public MConnectionInfoProvider
00056     {
00057 public: // creation/deletion
00058
00068     //##ModelId=3C4C49C0033B
00069     static CNwssWspTransportHandler* NewL(TAny* aInstantiationParams);
00070
00075     //##ModelId=3C4C49C00286
00076     virtual ~CNwssWspTransportHandler();
00077
00078 public: // API methods inherited from CWspTransportHandler
00079
00087     //##ModelId=3C4C49BF0112
00088     virtual CWspTransportHandler::TWspSupportedServices SupportedServices() const;
00089
00097     //##ModelId=3C4C49BF005E
00098     virtual MWspCOSessionInvoker& COSessionInvoker();
00099
00107     //##ModelId=3C4C49BE0392
00108     virtual MWspCOMethodInvoker& COTransactionInvoker();
00109
00117     //##ModelId=3C4C49BE02DE
00118     virtual MWspCOPushInvoker& COPushInvoker();
00119
00127     //##ModelId=3C4C49BE0229
00128     virtual MWspCLMethodInvoker& CLMethodInvoker();
00129
00137     //##ModelId=3C4C49BE0175
00138     virtual MWspCLPushInvoker& CLPushInvoker();
00139
00145     //##ModelId=3C9B0947024C
00146     virtual TInt ServerCert(TCertInfo& aCertInfo) const;
00147
00148 private: // methods inherited from MNwssWapServer
00149
00155     //##ModelId=3C4C49BE00AD
00156     virtual RWAPServ& WapStack();
00157
00158 private: // methods inherited from MConnectionInfoProvider
00159
00166     //##ModelId=3C4C49BD03C2
00167     virtual MWspProxyInfoProvider& ProxyInfoProvider() const;
00168
00175     //##ModelId=3C4C49BD0304
00176     virtual MWspCapabilityProvider& CapabilityProvider() const;
00177
00185     //##ModelId=3C4C49BD023C
00186     virtual MWspSessionHeadersProvider& SessionHeadersProvider() const;
00187
00188 private: // methods inherited from MSecurityPolicy
00189
00199     //##ModelId=3C4C49BC03DF
00200     virtual void ValidateUntrustedServerCert(TCertInfo& aServerCert, TRequestStatus& aStatus) const;
00201
00207     //##ModelId=3C4C49BC032B
00208     virtual void CancelValidateUntrustedServerCert();
00209
00217     //##ModelId=3C4C49BC026D
00218     virtual const RArray<TWtlsCipherSuite>& GetWtlsCipherSuites();
00219
00226     //##ModelId=3C4C49BC01B8
00227     virtual const TDesC8& GetTlsCipherSuites();
00228
00238     //##ModelId=3C4C49BC010E
00239     virtual const RArray<TWtlsKeyExchangeSuite>& GetWtlsKeyExchangeSuites();
00240
00252     //##ModelId=3C4C49BB02E3
00253     virtual TInt GetNamedPolicyProperty(RStringF aPropertyName, RString& aPropertyValue);
00254
00259     //##ModelId=3C4C49BB0239
00260     virtual void Reserved1();
00261
00266     //##ModelId=3C4C49BB0199
00267     virtual void Reserved2();
00268
00269 private: // methods
00270
00278     //##ModelId=3C4C49BB0080
00279     CNwssWspTransportHandler(TAny* aInstantiationParams);
00280
00287     //##ModelId=3C4C49BB001C
00288     void ConstructL();
00289
00290 private: // attributes
00291
00294     //##ModelId=3C4C49BB0012
00295     RWAPServ iWapStackHnd;
00296
00299     //##ModelId=3C4C49BA03E6
00300     CNwssWspCOSession* iWspCOSession;
00301
00304     //##ModelId=3C4C49BA03D2
00305     RArray<TWtlsCipherSuite> iDefSecPolCipherSuites;
00306
00309     //##ModelId=3C4C49BA03BE
00310     RArray<TWtlsKeyExchangeSuite> iDefSecPolKeyExchSuite;
00311     };
00312
00313
00314 #endif // __CNWSSWSPTRANSPORTHANDLER_H__


CNwssWspTrHndDataSupplier.h File Reference

@public More...

#include <e32base.h>
#include <http/mhttpdatasupplier.h>
#include "mnwssoomhandler.h"
#include "logging.h"

Include dependency graph for CNwssWspTrHndDataSupplier.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | CNwssWspTrHndDataSupplier
@private
Since:
7.0 This class acts as a data supplier for WSP response bodies.
 More...

Variables

const TInt | KNwssResponseDataBufferSize = 2048

Detailed Description

@public

Warning:
: This file contains Rose Model ID comments - please do not delete

Definition in file CNwssWspTrHndDataSupplier.h.

Variable Documentation

const TInt KNwssResponseDataBufferSize = 2048

Definition at line 23 of file CNwssWspTrHndDataSupplier.h.


CNwssWspTrHndDataSupplier.h Source File

CNwssWspTrHndDataSupplier.h

Go to the documentation of this file.
00001 // CNwssWspTrHndDataSupplier.h
00002 //
00003 // Copyright (C) 2002 Symbian Ltd
00004
00011 #ifndef __CNWSSWSPTRHNDDATASUPPLIER_H__
00012 #define __CNWSSWSPTRHNDDATASUPPLIER_H__
00013
00014 // System includes
00015 #include <e32base.h>
00016 #include <http/mhttpdatasupplier.h>
00017
00018 // User includes
00019 #include "mnwssoomhandler.h"
00020 #include "logging.h"
00021
00022 // Constants
00023 const TInt KNwssResponseDataBufferSize = 2048;
00024
00025 // Forward class declarations
00026 class RWSPCOTrans;
00027
00037 //##ModelId=3C4C46D00163
00038 class CNwssWspTrHndDataSupplier : public CBase, public MHTTPDataSupplier
00039     {
00040 public: // methods
00041
00052     //##ModelId=3C4C46D001C8
00053     static CNwssWspTrHndDataSupplier* NewL(RWSPCOTrans& aStackTrans, MNwssOomHandler& aOomHandler);
00054
00059     //##ModelId=3C4C46D001C7
00060     virtual ~CNwssWspTrHndDataSupplier();
00061
00062 private: // methods inherited from MHTTPDataSupplier
00063
00071     //##ModelId=3C4C46D001BE
00072     virtual TBool GetNextDataPart(TPtrC8& aDataPart);
00073
00081     //##ModelId=3C4C46D001BD
00082     virtual void ReleaseData();
00083
00094     //##ModelId=3C4C46D001B4
00095     virtual TInt OverallDataSize();
00096
00109     //##ModelId=3C4C46D001B3
00110     virtual TInt Reset();
00111
00112 private: // methods
00113
00122     //##ModelId=3C4C46D001AA
00123     CNwssWspTrHndDataSupplier(RWSPCOTrans& aStackTrans, MNwssOomHandler& aOomHandler);
00124
00129     //##ModelId=3C4C46D001A9
00130     void ConstructL();
00131
00137     //##ModelId=3C9B094D0100
00138     TInt ExtractBodyData();
00139
00140 private:
00141
00144     __DECLARE_LOG
00145
00148     //##ModelId=3C4C46D00197
00149     RWSPCOTrans& iStackTrans;
00150
00153     //##ModelId=3C9B094D00F6
00154     MNwssOomHandler& iOomHandler;
00155
00158     //##ModelId=3C9B094D00E2
00159     RWSPCOTrans::TTransID iStackTransId;
00160
00163     //##ModelId=3C4DA474022E
00164     TBuf8<KNwssResponseDataBufferSize> iBuffer;
00165
00168     //##ModelId=3C4DA4630297
00169     TInt iOverallDataSize;
00170
00174     //##ModelId=3C4DA44F0375
00175     TInt iRemainingBytes;
00176     };
00177
00178
00179 #endif // __CNWSSWSPTRHNDDATASUPPLIER_H__


corefilterspanic.h File Reference

#include <e32std.h>

Include dependency graph for corefilterspanic.h:

Include dependency graph

Go to the source code of this file.

Compounds

class TFCoreFiltersPanic


corefilterspanic.h Source File

corefilterspanic.h

Go to the documentation of this file.
00001 // Corefilterspanic.h
00002 // Copyright (c) 2001 Symbian Ltd
00003 //
00004
00005 #ifndef     __COREFILTERSPANIC_H__
00006 #define     __COREFILTERSPANIC_H__
00007
00008 #include <e32std.h>
00009
00010 class TFCoreFiltersPanic
00011     {
00012 public:
00013
00014     enum TPanic
00015         {
00016         EInvalidRedirectCountProperty,
00017         EInvalidMaxRedirectProperty,
00018         EValidationFilterFailure,
00019         EAuthenticationFilterBadState
00020         };
00021
00022
00023     static void Panic(TInt aPanicCode);
00024     };
00025
00026
00027 #endif //   __COREFILTERSPANIC_H__


cprotocolhandler.h File Reference

#include <e32base.h>
#include <http/framework/httplogger.h>
#include <http/mhttpfilter.h>
#include <http/rhttpsession.h>

Include dependency graph for cprotocolhandler.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | CProtocolHandler
@public
Since:
7.0 An abstract protocol handler.
 More...

Variables

const TUid | KUidProtocolHandlerPluginInterface = {0x1000A449}
const TInt | KProtocolHandlerActivePriority = CActive::EPriorityStandard
const TInt | KTransactionActivePriority = KProtocolHandlerActivePriority+1

Variable Documentation

const TInt KProtocolHandlerActivePriority = CActive::EPriorityStandard

Definition at line 30 of file cprotocolhandler.h.

const TInt KTransactionActivePriority = KProtocolHandlerActivePriority+1

Definition at line 31 of file cprotocolhandler.h.

const TUid KUidProtocolHandlerPluginInterface = {0x1000A449}

Definition at line 27 of file cprotocolhandler.h.


cprotocolhandler.h Source File

cprotocolhandler.h

Go to the documentation of this file.
00001 // CProtocolHandler.h
00002 //
00003 // Copyright (C) 2001 Symbian Ltd
00004
00012 #ifndef __CPROTOCOLHANDLER_H__
00013 #define __CPROTOCOLHANDLER_H__
00014
00015 // System includes
00016 #include <e32base.h>
00017 #include <http/framework/httplogger.h>
00018 #include <http/mhttpfilter.h>
00019 #include <http/rhttpsession.h>
00020
00021 // Forward declarations
00022 class CHeaderCodec;
00023 class CProtTransaction;
00024 class CSecurityPolicy;
00025
00026 // The ECom protocol handler plugin interface UID
00027 const TUid KUidProtocolHandlerPluginInterface = {0x1000A449};
00028
00029 // Defined active object priorities
00030 const TInt KProtocolHandlerActivePriority = CActive::EPriorityStandard;
00031 const TInt KTransactionActivePriority = KProtocolHandlerActivePriority+1;
00032
00061 //##ModelId=3C4C186A02A3
00062 class CProtocolHandler : public CActive, public MHTTPFilter
00063     {
00064 public: // Methods
00065
00077     //##ModelId=3C4C186B007E
00078     static CProtocolHandler* NewL(const TDesC8& aProtocol, RHTTPSession aSession);
00079
00084     //##ModelId=3C4C186B0075
00085     IMPORT_C virtual ~CProtocolHandler();
00086
00094     //##ModelId=3C4C186B0074
00095     IMPORT_C CHeaderCodec* Codec() const;
00096
00097 public: // Methods to be implemented in specific protocol handlers
00103     virtual TInt SessionServerCert(TCertInfo& aServerCert) = 0;
00104
00111     virtual TInt TransactionServerCert(TCertInfo& aServerCert, RHTTPTransaction aTransaction) = 0;
00112
00113 public: // Methods from MHTTPFilterBase
00114
00120     //##ModelId=3C4C186B0061
00121     IMPORT_C virtual void MHFRunL(RHTTPTransaction aTransaction, const THTTPEvent& aEvent);
00122
00128     //##ModelId=3C4C186B0057
00129     IMPORT_C virtual void MHFSessionRunL(const THTTPSessionEvent& aEvent);
00130
00135     //##ModelId=3C4C186B0043
00136     IMPORT_C virtual TInt MHFRunError(TInt aError, RHTTPTransaction aTransaction, const THTTPEvent& aEvent);
00137
00142     //##ModelId=3C4C186B0038
00143     IMPORT_C virtual TInt MHFSessionRunError(TInt aError, const THTTPSessionEvent& aEvent);
00144
00145 public: // Methods from MHTTPFilter
00146
00151     //##ModelId=3C4C186B0025
00152     IMPORT_C virtual void MHFUnload(RHTTPSession aSession, THTTPFilterHandle aHandle);
00153
00158     //##ModelId=3C4C186B001A
00159     IMPORT_C virtual void MHFLoad(RHTTPSession aSession, THTTPFilterHandle aHandle);
00160
00161 protected: // callbacks/methods for sub-classes
00162
00176     //##ModelId=3C4C186B0010
00177     IMPORT_C void TransactionCompletedL(RHTTPTransaction aTrans, THTTPEvent aEventStatus);
00178
00184     //##ModelId=3C4C186B0006
00185     IMPORT_C TInt NumActiveTransactions() const;
00186
00195     //##ModelId=3C4C186A03E5
00196     IMPORT_C void TransactionFailed(RHTTPTransaction aTrans);
00197
00204     //##ModelId=3C4C186A03E4
00205     IMPORT_C void CompleteSelf();
00206
00218     IMPORT_C TInt FindTransaction(RHTTPTransaction aTransaction, const CProtTransaction*& aProtTransaction) const;
00219
00220 private: // methods to be implemented in specific protocol handlers
00221
00230     //##ModelId=3C4C186A03DC
00231     virtual void CreateCodecL() = 0;
00232
00251     //##ModelId=3C4C186A03DA
00252     virtual CProtTransaction* CreateProtTransactionL(RHTTPTransaction aTransaction) = 0;
00253
00267     //##ModelId=3C4C186A03D0
00268     virtual TBool ServiceL(CProtTransaction& aTrans) = 0;
00269
00288     //##ModelId=3C4C186A03C6
00289     virtual void ClosedTransactionHook(CProtTransaction* aTrans) = 0;
00290
00301     //##ModelId=3C4C186A03B3
00302     virtual void CancelTransactionHook(CProtTransaction& aTransaction) = 0;
00303
00313     //##ModelId=3C4C186A03A8
00314     virtual void NotifyNewRequestBodyPart(CProtTransaction& aTransaction) = 0;
00315
00316 protected: // Methods inherited from CActive
00317
00324     //##ModelId=3C4C186A0377
00325     IMPORT_C virtual void RunL();
00326
00334     //##ModelId=3C4C186A036E
00335     IMPORT_C virtual TInt RunError(TInt aError);
00336
00341     //##ModelId=3C4C186A036D
00342     IMPORT_C virtual void DoCancel();
00343
00344 protected:  // Methods
00345
00353     IMPORT_C CProtocolHandler(RHTTPSession aSession);
00354
00361     //##ModelId=3C4C186A036C
00362     IMPORT_C void ConstructL(RHTTPSession aSession);
00363
00364 protected: // Attributes
00365
00368     //##ModelId=3C4C186A033C
00369     RHTTPSession iSession;
00370
00373     //##ModelId=3C4C186A032F
00374     CHeaderCodec* iCodec;
00375
00378     __DECLARE_LOG
00379
00381     //##ModelId=3C4C186A031D
00382     CSecurityPolicy* iSecurityPolicy;
00383
00384 private: // Methods
00385
00406     //##ModelId=3C4C186A0362
00407     void SubmitTransactionL(RHTTPTransaction aTransaction);
00408
00419     //##ModelId=3C4C186A0359
00420     void HandleCancelTransaction(RHTTPTransaction aTrans);
00421
00430     //##ModelId=3C4C186A034F
00431     void HandleClosedTransaction(RHTTPTransaction aTrans);
00432
00442     //##ModelId=3C4C186A0346
00443     TInt FindTransaction(RHTTPTransaction aTransaction) const;
00444
00449     //##ModelId=3C4C186A0345
00450     inline virtual void Reserved1();
00451
00456     //##ModelId=3C4C186A0344
00457     inline virtual void Reserved2();
00458
00459 private: // Attributes
00460
00464     //##ModelId=3C4C186A0313
00465     RPointerArray<CProtTransaction>     iTransactions;
00466
00470     //##ModelId=3C4C186A02FF
00471     RHTTPTransaction                    iCurrentTransaction;
00472
00475     //##ModelId=3C4C186A02F5
00476     TUid iDtor_ID_Key;
00477     };
00478
00479
00480
00481 inline void CProtocolHandler::Reserved1()
00482     {}
00483 inline void CProtocolHandler::Reserved2()
00484     {}
00485
00486 #endif // __CPROTOCOLHANDLER_H__
00487


CProtTransaction.h File Reference

@public More...

#include <e32base.h>
#include <http/rhttptransaction.h>

Include dependency graph for CProtTransaction.h:

Include dependency graph

Go to the source code of this file.

Compounds

class CProtTransaction
@public
Since:
7.0 A representation of a transaction used by protocol handlers.
 More...

Detailed Description

@public

Warning:
: This file contains Rose Model ID comments - please do not delete

Definition in file CProtTransaction.h.


CProtTransaction.h Source File

CProtTransaction.h

Go to the documentation of this file.
00001 // CProtTransaction.h
00002 //
00003 // Copyright (C) 2001 Symbian Ltd
00004
00011 #ifndef __CPROTTRANSACTION_H__
00012 #define __CPROTTRANSACTION_H__
00013
00014 // System includes
00015 #include <e32base.h>
00016 #include <http/rhttptransaction.h>
00017
00018 // Forward declarations
00019 class CTxData;
00020 class CRxData;
00021 class MRxDataObserver;
00022
00033 //##ModelId=3B1E52B30382
00034 class CProtTransaction : public CBase
00035     {
00036 public: // Enums
00037
00040     enum TTransactionState
00041         {
00044         EPending        = 0,
00047         EActive,
00050         ECancelled,
00053         ECompleted
00054         };
00055
00056 public:
00057
00062     //##ModelId=3B1E52B40031
00063     IMPORT_C virtual ~CProtTransaction();
00064
00065 public: // accessors
00066
00073     //##ModelId=3C4C37E50306
00074     TTransactionState TransactionState() const;
00075
00082     //##ModelId=3C4C37E502D4
00083     void SetTransactionState(TTransactionState aState);
00084
00091     //##ModelId=3C4C37E502CA
00092     IMPORT_C void ResetRxData();
00093
00100     //##ModelId=3C4C37E502C0
00101     IMPORT_C void ResetTxData();
00102
00109     //##ModelId=3B1E52B40013
00110     IMPORT_C RHTTPTransaction Transaction() const;
00111
00117     //##ModelId=3B1E52B40012
00118     IMPORT_C CTxData& TxData() const;
00119
00125     //##ModelId=3B1E52B40009
00126     IMPORT_C CRxData& RxData() const;
00127
00128 public: // Methods to be implemented by derived classes
00129
00136     //##ModelId=3C4C37E502AC
00137     virtual void CreateTxDataL() =0;
00138
00146     //##ModelId=3C4C37E50284
00147     virtual void CreateRxDataL(MRxDataObserver& aObserver) =0;
00148
00149 protected: // Methods
00150
00155     //##ModelId=3B1E52B303E6
00156     CProtTransaction();
00157
00164     //##ModelId=3B1E52B303E7
00165     IMPORT_C CProtTransaction(RHTTPTransaction aTrans);
00166
00167 protected:  // Attributes
00168
00171     //##ModelId=3B1E52B303D4
00172     RHTTPTransaction iTrans;
00173
00176     //##ModelId=3B1E52B303CA
00177     CTxData* iTxData;
00178
00181     //##ModelId=3B1E52B303C0
00182     CRxData* iRxData;
00183
00186     //##ModelId=3C4C37E50247
00187     TTransactionState   iTransactionState;
00188
00189 private: // methods
00190
00195     //##ModelId=3C4C37E5026F
00196     inline virtual void Reserved1();
00197
00202     //##ModelId=3C4C37E50251
00203     inline virtual void Reserved2();
00204     };
00205
00206
00207 inline void CProtTransaction::Reserved1()
00208     {}
00209 inline void CProtTransaction::Reserved2()
00210     {}
00211
00212
00213 #endif // __CPROTTRANSACTION_H__
00214


CRequest.h File Reference

#include "cmessage.h"
#include "crequest.inl"

Include dependency graph for CRequest.h:

Include dependency graph

Go to the source code of this file.

Compounds

class CRequest
An HTTP Request. More...


CRequest.h Source File

CRequest.h

Go to the documentation of this file.
00001 // CRequest.h
00002 //
00003 // Copyright (C) 2001 Symbian Ltd
00004 //
00005
00006 #ifndef __CREQUEST_H__
00007 #define __CREQUEST_H__
00008
00009 #include "cmessage.h"
00010
00015 //##ModelId=3C4C186E030D
00016 class CRequest : public CMessage
00017     {
00018 public:
00019
00022     //##ModelId=3C4C186E034B
00023     static CRequest* NewL(RStringF aMethod, const TUriC8& aURI,
00024                           CTransaction* aTransaction);
00027     //##ModelId=3C4C186E034A
00028     ~CRequest();
00029
00032     //##ModelId=3C4C186E0342
00033     const RStringF& Method() const;
00034
00037     //##ModelId=3C4C186E0349
00038     RStringF& Method();
00039
00042     //##ModelId=3C4C186E0341
00043     CUri8*& URI();
00044
00047     //##ModelId=3C4C186E0340
00048     inline RHTTPRequest Handle();
00049
00050 private:
00051
00054     //##ModelId=3C4C186E033F
00055     CRequest();
00056
00059     //##ModelId=3C4C186E0335
00060     void ConstructL(RStringF aMethod, const TUriC8& aURI,
00061                     CTransaction* aTransaction);
00062
00063 private:
00064
00067     //##ModelId=3C4C186E032D
00068     CUri8* iURI;
00069
00072     //##ModelId=3C4C186E0323
00073     RStringF iMethod;
00074     };
00075
00076 #include "crequest.inl"
00077
00078 #endif // __CREQUEST_H__


CResponse.h File Reference

#include "cmessage.h"
#include "cresponse.inl"

Include dependency graph for CResponse.h:

Include dependency graph

Go to the source code of this file.

Compounds

class CResponse
An HTTP Response. More...


CResponse.h Source File

CResponse.h

Go to the documentation of this file.
00001 // CResponse.h
00002 //
00003 // Copyright (C) 2001 Symbian Ltd
00004 //
00005
00006 #ifndef __CRESPONSE_H__
00007 #define __CRESPONSE_H__
00008
00009 #include "cmessage.h"
00010
00015 //##ModelId=3C4C187F0177
00016 class CResponse : public CMessage
00017     {
00018  public:
00021     //##ModelId=3C4C187F01C8
00022     inline static CResponse* NewL(CTransaction* aTransaction);
00023
00026     //##ModelId=3C4C187F01C7
00027     ~CResponse();
00028
00031     //##ModelId=3C4C187F01BF
00032     inline TInt& Status();
00033
00036     //##ModelId=3C4C187F01C0
00037     inline const TInt& Status() const;
00038
00041     //##ModelId=3C4C187F01BD
00042     inline RStringF& StatusString();
00043
00046     //##ModelId=3C4C187F01BE
00047     inline const RStringF& StatusString() const;
00048
00051     //##ModelId=3C4C187F01B5
00052     inline TVersion& Version();
00053
00056     //##ModelId=3C4C187F01B6
00057     inline const TVersion& Version() const;
00058
00061     //##ModelId=3C4C187F01B4
00062     inline RHTTPResponse Handle();
00063
00064  private:
00067     //##ModelId=3C4C187F01B3
00068     CResponse();
00069
00070  private:
00071
00074     //##ModelId=3C4C187F01A1
00075     TInt iStatus;
00076
00079     //##ModelId=3C4C187F0197
00080     RStringF iStatusString;
00081
00084     //##ModelId=3C4C187F018E
00085     TVersion iVersion;
00086     };
00087
00088 #include "cresponse.inl"
00089
00090
00091 #endif // __CRESPONSE_H__


crxdata.h File Reference

#include <e32base.h>
#include <http/framework/cprottransaction.h>
#include <http/mhttpdatasupplier.h>
#include <http/rhttpsession.h>

Include dependency graph for crxdata.h:

Include dependency graph

Go to the source code of this file.

Compounds

class CRxData
@public
Since:
7.0 An abstract base class for the decoding of response data received by a protocol handler.
 More...


crxdata.h Source File

crxdata.h

Go to the documentation of this file.
00001 // CRxData.h
00002 //
00003 // Copyright (C) 2001 Symbian Ltd
00004
00011 #ifndef __CRXDATA_H__
00012 #define __CRXDATA_H__
00013
00014 // System includes
00015 #include <e32base.h>
00016 #include <http/framework/cprottransaction.h>
00017 #include <http/mhttpdatasupplier.h>
00018 #include <http/rhttpsession.h> // this include is needed to ensure that the <rhttp.inl> is compiled by gcc...
00019
00020 // Forward declarations
00021 class MRxDataObserver;
00022
00031 //##ModelId=3B1E52AB0087
00032 class CRxData : public CBase, public MHTTPDataSupplier
00033     {
00034 public:
00035
00040     IMPORT_C
00041     //##ModelId=3B1E52AB00ED
00042     virtual ~CRxData();
00043
00050     IMPORT_C
00051     //##ModelId=3B1E52AB00EC
00052     CProtTransaction& ProtTrans();
00053
00054 public:
00055
00063     //##ModelId=3BA60048014B
00064     virtual void ResetRxData() = 0;
00065
00066 protected:
00067
00073     IMPORT_C
00074     //##ModelId=3A914E5F008F
00075     CRxData();
00076
00086     IMPORT_C CRxData(CProtTransaction& aProtTrans, MRxDataObserver& aObserver);
00087
00092     IMPORT_C
00093     //##ModelId=3B1E52AB00BA
00094     void ConstructL();
00095
00096 protected:
00097
00100     //##ModelId=3B1E52AB00B2
00101     CProtTransaction* iProtTrans;
00102
00105     //##ModelId=3B1E7738028B
00106     MRxDataObserver* iObserver;
00107
00108 private: // methods
00109
00114     //##ModelId=3C4C37DA0007
00115     inline virtual void Reserved1();
00116
00121     //##ModelId=3C4C37D903DB
00122     inline virtual void Reserved2();
00123     };
00124
00125
00126 inline void CRxData::Reserved1()
00127     {}
00128 inline void CRxData::Reserved2()
00129     {}
00130
00131
00132 #endif // __CRXDATA_H__
00133


csecuritypolicy.h File Reference

@public More...

#include <e32base.h>
#include <ecom/ecom.h>
#include <stringpool.h>
#include <ssl.h>
#include <wsp/wsptypes.h>
#include <http/framework/csecuritypolicy.inl>

Include dependency graph for csecuritypolicy.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | CSecurityPolicy
@public
Since:
7.0 The Security Policy Plug-in API.
 More...

class | MSecurityPolicy
@public
Since:
7.0 The Security Policy Interface.
 More...

Detailed Description

@public

Warning:
: This file may contain Rose Model ID comments - please do not delete

Definition in file csecuritypolicy.h.


csecuritypolicy.h Source File

csecuritypolicy.h

Go to the documentation of this file.
00001 // csecuritypolicy.h
00002 //
00003 // Copyright (C) 2002 Symbian Ltd
00004
00011 #ifndef __CSECURITYPOLICY_H__
00012 #define __CSECURITYPOLICY_H__
00013
00014 // System includes
00015 #include <e32base.h>
00016 #include <ecom/ecom.h>
00017 #include <stringpool.h>
00018 #include <ssl.h>
00019 #include <wsp/wsptypes.h>
00020
00021
00029 //##ModelId=3C4C37E401CE
00030 class MSecurityPolicy
00031     {
00032 public:
00033
00043     //##ModelId=3C4C37E4020B
00044     virtual void ValidateUntrustedServerCert(TCertInfo& aServerCert, TRequestStatus& aStatus) const = 0;
00045
00051     //##ModelId=3C4C37E4020A
00052     virtual void CancelValidateUntrustedServerCert() = 0;
00053
00054
00062     //##ModelId=3C4C37E40201
00063     virtual const RArray<TWtlsCipherSuite>& GetWtlsCipherSuites() =0;
00064
00071     //##ModelId=3C4C37E40200
00072     virtual const TDesC8& GetTlsCipherSuites() = 0;
00073
00083     //##ModelId=3C4C37E401FA
00084     virtual const RArray<TWtlsKeyExchangeSuite>& GetWtlsKeyExchangeSuites() = 0;
00085
00097     //##ModelId=3C4C37E401F7
00098     virtual TInt GetNamedPolicyProperty(RStringF aPropertyName, RString& aPropertyValue) = 0;
00099
00100 protected:
00105     //##ModelId=3C4C37E401F6
00106     virtual void Reserved1() =0;
00107
00112     //##ModelId=3C4C37E401EC
00113     virtual void Reserved2() =0;
00114     };
00115
00123 //##ModelId=3C4C37C50300
00124 class CSecurityPolicy : public CBase, public MSecurityPolicy
00125     {
00126 public: // methods
00127
00134     //##ModelId=3C4C37C503C8
00135     inline static CSecurityPolicy* NewL(RStringPool aStringPool);
00136
00141     //##ModelId=3C4C37C503BE
00142     inline virtual ~CSecurityPolicy();
00143
00144
00145 protected: // methods
00146
00153     //##ModelId=3C4C37C503B5
00154     inline CSecurityPolicy(RStringPool aStrPool);
00155
00156
00161     //##ModelId=3C4C37C503B4
00162     inline virtual void Reserved1();
00163
00168     //##ModelId=3C4C37C503AD
00169     inline virtual void Reserved2();
00170
00171 protected: // attributes
00172
00175     //##ModelId=3C4C37C503AA
00176     RStringPool iStrPool;
00177
00178 private: // attributes
00179
00183     //##ModelId=3C4C37C50396
00184     TUid iDtor_ID_Key;
00185     };
00186
00187 #include <http/framework/csecuritypolicy.inl>
00188
00189 #endif // __CSECURITYPOLICY_H__


CTcpClientFactory.h File Reference

#include <e32base.h>
#include <http/framework/csecuritypolicy.h>
#include <http/framework/httplogger.h>

Include dependency graph for CTcpClientFactory.h:

Include dependency graph

Go to the source code of this file.

Compounds

class CTCPClientFactory
CTCPClientFactory is responsible for creating Transport Handlers (TH) sharing the same RSocketServ session and RConnection sub-session. More...


CTcpClientFactory.h Source File

CTcpClientFactory.h

Go to the documentation of this file.
00001 // CTcpClientFactory.h
00002 //
00003 // Copyright (c) 2002 Symbian Ltd.  All rights reserved.
00004 //
00005
00006 #ifndef __CTCPCLIENTFACTORY_H__
00007 #define __CTCPCLIENTFACTORY_H__
00008
00009 // System includes
00010 #include <e32base.h>
00011 #include <http/framework/csecuritypolicy.h>
00012 #include <http/framework/httplogger.h>
00013
00014 // Forward declarations
00015 class MSessionPropertiesProvider;
00016
00017
00027 class CTCPClientFactory : public CBase
00028     {
00029     public:
00030
00032         IMPORT_C static CTCPClientFactory* NewL(MSessionPropertiesProvider& aSessionPropertiesProvider);
00033
00034         ~CTCPClientFactory();
00035
00037         IMPORT_C MTextModeTransportHandler* NewTransportHandlerL(MSecurityPolicy* aSecurityPolicy);
00038
00039
00040     private:
00041
00043         CTCPClientFactory(MSessionPropertiesProvider& aSessionPropertiesProvider);
00044
00047         void ConstructL();
00048
00049     private:
00050
00052         RSocketServ iSocketServer;
00053
00055         RConnection* iConnection;
00056
00058         TBool iOwnsCommsSession;
00059
00061         MSessionPropertiesProvider& iSessionPropertiesProvider;
00062
00064         __DECLARE_LOG
00065
00066     };
00067
00068 #endif // __CTCPCLIENTFACTORY_H__


CTextModeHeaderCodec.h File Reference

#include <http.h>
#include <http/framework/cheadercodec.h>

Include dependency graph for CTextModeHeaderCodec.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | CTextModeDefaultCodec
A default codec that will be instantiated as a delegate codec to handle any unrecognised header field by copying directly between raw data or string header field values. More...

class | CTextModeDefHdrReader
A default header reader that just copies received raw data directly into single part string header fields. More...

class | CTextModeDefHdrWriter
A default header writer that just copies single part string header fields directly into raw data. More...

class | CTextModeHeaderCodec
An HTTP header codec specialized for the plain-text encoding of HTTP headers used by origin servers. More...

class | CTextModeHeaderReader
CHTTPHeaderReader is used by its owning codec to do conversion of header data from the plain-text raw representation to the generic format (of parts and parameters). More...

class | CTextModeHeaderWriter
CTextModeHeaderWriter is used by its owning codec to do conversion of header data from the generic format (of parts and parameters) to the plain-text representation. More...


CTextModeHeaderCodec.h Source File

CTextModeHeaderCodec.h

Go to the documentation of this file.
00001 // CTEXTMODEHEADERCODEC.H
00002 //
00003 // Copyright (c) 2001 Symbian Ltd.  All rights reserved.
00004 //
00005
00006 #ifndef __CTEXTMODEHEADERCODEC_H__
00007 #define __CTEXTMODEHEADERCODEC_H__
00008
00009 #include <http.h>
00010 #include <http/framework/cheadercodec.h>
00011
00012 class CTextModeHeaderWriter;
00013 class CTextModeHeaderReader;
00014 class CHeaderFieldPart;
00015 class CHeaderFieldParam;
00016
00034 //##ModelId=3A914E5F02FB
00035 class CTextModeHeaderCodec : public CHeaderCodec
00036     {
00037 public: // methods
00038
00042     //##ModelId=3A914E5F0343
00043     static CTextModeHeaderCodec* NewL(RStringPool aStrPool);
00044
00047     //##ModelId=3A914E5F0342
00048     virtual ~CTextModeHeaderCodec();
00049
00052     //##ModelId=3B1E6B47028F
00053     virtual TBool CanEncode(RStringF aHeaderField) const;
00054
00057     //##ModelId=3A914E5F033B
00058     virtual TBool CanDecode(RStringF aHeaderField) const;
00059
00063     //##ModelId=3A914E5F0339
00064     virtual CHeaderCodec* FindDelegateCodecL(RStringF aHeaderField) const;
00065
00066 protected: // methods
00067
00070     //##ModelId=3A914E5F032F
00071     CTextModeHeaderCodec(RStringPool aStrPool);
00072
00075     //##ModelId=3A914E5F032E
00076     void ConstructL();
00077
00078 private: // methods
00079
00082     //##ModelId=3A914E5F0338
00083     CTextModeHeaderCodec();
00084
00085 private: // attributes
00086
00089     //##ModelId=3A914E5F0323
00090     RStringPool iStrPool;
00091     };
00092
00093
00097 //##ModelId=3A914E5703C2
00098 class CTextModeHeaderWriter : public CHeaderWriter
00099     {
00100 public: // methods
00101
00104     //##ModelId=3A914E58000D
00105     virtual ~CTextModeHeaderWriter();
00106
00110     //##ModelId=3A914E580006
00111     static CTextModeHeaderWriter* NewL(RStringPool aStrPool);
00112
00116     //##ModelId=3C4C3F0D0364
00117     static CTextModeHeaderWriter* NewLC(RStringPool aStrPool);
00118
00122     //##ModelId=3A914E580004
00123     virtual void EncodeHeaderL(RHeaderField& aHeader);
00124
00125 protected: // methods
00126
00129     //##ModelId=3A914E580002
00130     CTextModeHeaderWriter(RStringPool aStrPool);
00131
00132 private: // methods
00133
00136     //##ModelId=3B1E6B3A034F
00137     void DoAcceptL(RHeaderField& aHeader) const;
00138
00141     //##ModelId=3B1E6B3A029B
00142     void DoAcceptCharsetL(RHeaderField& aHeader) const;
00143
00146     //##ModelId=3B1E6B3A01FA
00147     void DoAuthorizationL(RHeaderField& aHeader) const;
00148
00151     //##ModelId=3B1E6B3A015A
00152     void DoConnectionL(RHeaderField& aHeader) const;
00153
00156     //##ModelId=3B1E6B3A00B0
00157     void DoContentLengthL(RHeaderField& aHeader) const;
00158
00161     //##ModelId=3B1E6B3A0010
00162     void DoContentTypeL(RHeaderField& aHeader) const;
00163
00166     //##ModelId=3B1E6B39034D
00167     void DoDateL(RHeaderField& aHeader) const;
00168
00169     //##ModelId=3C4C3F0D0242
00170     void EncodeCookieL(RHeaderField& aHeader) const;
00171     //##ModelId=3C4C3F0D0147
00172     void EncodeOneCookieL(RHeaderField& aHeader, const CHeaderFieldPart& aCookieFieldPart,
00173                             TBool aIsNetscapeStyleCookie) const;
00174     //##ModelId=3C4C3F0D009D
00175     void EncodeOneCookieAttributeL(RHeaderField& aHeader, const CHeaderFieldParam& aAttribute) const;
00176
00177     //##ModelId=3C4C3F0D0025
00178     void EncodeCacheControlL(RHeaderField& aHeader) const;
00179     //##ModelId=3C4C3F0C0395
00180     void EncodePragmaL(RHeaderField& aHeader) const;
00181
00184     //##ModelId=3B1E6B3902AD
00185     void DoHostL(RHeaderField& aHeader) const;
00186
00189     //##ModelId=3B1E6B39020D
00190     void DoTransferEncodingL(RHeaderField& aHeader) const;
00191
00194     //##ModelId=3B1E6B39016D
00195     void DoUserAgentL(RHeaderField& aHeader) const;
00196
00197
00204     //##ModelId=3B1E6B390018
00205     void DoGeneralAcceptHeaderL(RHeaderField& aHeader, RStringF aFieldType, TInt aErrorCode) const;
00206
00212     //##ModelId=3B1E6B380298
00213     void DoTokenCsvListHeaderL(RHeaderField& aHeader, TInt aErrorCode) const;
00214
00220     //##ModelId=3B1E6B3800DF
00221     void DoTokenListHeaderL(RHeaderField& aHeader, const TDesC8& aSep, TInt aErrorCode) const;
00222
00223     //##ModelId=3C4C3F0C0236
00224     const CHeaderFieldPart* WriteRawStrFPartL(RHeaderField& aHeader, THeaderFieldPartIter& aIter, TInt aErrorCode) const;
00225
00226     //##ModelId=3C4C3F0C01B4
00227     void EncodeGenericDateL(RHeaderField& aHeader, TInt aErrorCodeToUseOnFailure) const;
00228     //##ModelId=3C4C3F0C0132
00229     void EncodeGenericNumberHeaderL(RHeaderField& aHeader, TInt aErrorCodeToUseOnFailure) const;
00230 private: // attributes
00231
00234     //##ModelId=3A914E5703D6
00235     RStringPool iStrPool;
00236     };
00237
00241 //##ModelId=3B45CB1E0340
00242 class CTextModeHeaderReader : public CHeaderReader
00243     {
00244 public: // methods
00245
00248     //##ModelId=3C4C3F140242
00249     virtual ~CTextModeHeaderReader();
00250
00254     //##ModelId=3C4C3F1401C0
00255     static CTextModeHeaderReader* NewL(RStringPool aStrPool);
00256
00260     //##ModelId=3C4C3F140151
00261     static CTextModeHeaderReader* NewLC(RStringPool aStrPool);
00262
00267     //##ModelId=3C4C3F13036D
00268     virtual void DecodeHeaderL(RHeaderField& aHeader);
00269
00270 protected: // methods
00271
00274     //##ModelId=3C4C3F1302F5
00275     CTextModeHeaderReader(RStringPool aStrPool);
00276
00277
00278 private: // methods
00279
00282     //##ModelId=3C4C3F130272
00283     void DoCacheControlL(RHeaderField& aHeader) const;
00284
00287     //##ModelId=3C4C3F1301E6
00288     void DoConnectionL(RHeaderField& aHeader) const;
00289
00290
00293     //##ModelId=3C4C3F13016E
00294     void DoContentTypeL(RHeaderField& aHeader) const;
00295
00298     //##ModelId=3C4C3F1300F6
00299     void DoDateL(RHeaderField& aHeader) const;
00300
00303     //##ModelId=3C4C3F13007E
00304     void DoTransferEncodingL(RHeaderField& aHeader) const;
00305
00308     //##ModelId=3C4C3F1203D9
00309     void DoWWWAuthenticateL(RHeaderField& aHeader) const;
00310
00312     //##ModelId=3C4C3F120339
00313     void DecodeSetCookieL(RHeaderField& aHeader) const;
00314     //##ModelId=3C4C3F120271
00315     void DecodeOneCookieL(RHeaderField& aHeader, const TDesC8& aCookieData, TInt aCookieNumber) const;
00316     //##ModelId=3C4C3F1201DB
00317     void SetCookieNameAndValueL(CHeaderFieldPart& aCookie, const TDesC8& aNameValue) const;
00318     //##ModelId=3C4C3F120159
00319     void SetCookieParamL(CHeaderFieldPart& aCookie, const TDesC8& aCookieParam) const;
00320
00321     //##ModelId=3C4C3F1200F4
00322     void DecodeCacheControlL(RHeaderField& aHeader) const;
00323     //##ModelId=3C4C3F12009A
00324     void DecodeAgeL(RHeaderField& aHeader) const;
00325     //##ModelId=3C4C3F12004A
00326     void DecodeETagL(RHeaderField& aHeader) const;
00327
00329     //##ModelId=3C4C3F1103BA
00330     void DecodeGenericL(RHeaderField& aHeader, const TDesC8& aSeparator) const;
00331
00333     //##ModelId=3C4C3F11036A
00334     void DecodeGenericNumberL(RHeaderField& aHeader) const;
00335
00336
00341     //##ModelId=3C4C3F1102DE
00342     CHeaderFieldPart* SetNewIntegerPartL(RHeaderField& aHeader, TInt aPartIndex, TInt aValue) const;
00343
00348     //##ModelId=3C4C3F11025C
00349     CHeaderFieldPart* SetNewDatePartL(RHeaderField& aHeader, TInt aPartIndex, TDateTime& date) const;
00350
00355     //##ModelId=3C4C3F1101CF
00356     CHeaderFieldPart* SetNewFStringPartL(RHeaderField& aHeader, TInt aPartIndex, TPtrC8 aValue) const;
00357     //##ModelId=3C4C3F110161
00358     CHeaderFieldPart* SetNewStringPartL(RHeaderField& aHeader, TInt aPartIndex, TPtrC8 aValue) const;
00359
00363     //##ModelId=3C4C3F1100F3
00364     CHeaderFieldPart* SetNewPartL(RHeaderField& aHeader, TInt aPartIndex, THTTPHdrVal& aValue) const;
00365
00369     //##ModelId=3C4C3F110085
00370     CHeaderFieldParam* SetNewFStringParamL(CHeaderFieldPart& aHeaderPart, TPtrC8 aParamName, TPtrC8 aParamValue) const;
00371     //##ModelId=3C4C3F11002B
00372     CHeaderFieldParam* SetNewStringParamL(CHeaderFieldPart& aHeaderPart, TPtrC8 aParamName, TPtrC8 aParamValue) const;
00373
00374 private: // attributes
00375
00378     //##ModelId=3C4C3F110021
00379     RStringPool iStrPool;
00380
00383     //##ModelId=3C4C3F11000F
00384     RStringF iFieldName;
00385     };
00386
00387
00388 class CTextModeDefHdrWriter;
00389 class CTextModeDefHdrReader;
00390
00394 //##ModelId=3A914E620011
00395 class CTextModeDefaultCodec : public CHeaderCodec
00396     {
00397 public:
00398
00402     //##ModelId=3A914E62004F
00403     static CTextModeDefaultCodec* NewL(RStringPool aStrPool);
00404
00407     //##ModelId=3A914E62004E
00408     virtual ~CTextModeDefaultCodec();
00409
00413     //##ModelId=3B1E6B5B002B
00414     virtual TBool CanEncode(RStringF aHeaderField) const;
00415
00419     //##ModelId=3A914E620045
00420     virtual TBool CanDecode(RStringF aHeaderField) const;
00421
00425     //##ModelId=3A914E620043
00426     virtual CHeaderCodec* FindDelegateCodecL(RStringF aHeaderField) const;
00427
00428 protected: // methods
00429
00432     //##ModelId=3A914E62003A
00433     CTextModeDefaultCodec(RStringPool aStrPool);
00434
00437     //##ModelId=3A914E620039
00438     void ConstructL();
00439
00440 private:// methods
00441
00444     //##ModelId=3A914E62003E
00445     CTextModeDefaultCodec();
00446
00447 private: // attributes
00448
00451     //##ModelId=3A914E620031
00452     RStringPool iStrPool;
00453     };
00454
00459 //##ModelId=3A914E610087
00460 class CTextModeDefHdrWriter : public CHeaderWriter
00461     {
00462 public: // methods
00463
00466     //##ModelId=3A914E6100B0
00467     virtual ~CTextModeDefHdrWriter();
00468
00472     //##ModelId=3A914E6100A9
00473     static CTextModeDefHdrWriter* NewL(RStringPool aStrPool);
00474
00478     //##ModelId=3C4C3F1D0190
00479     static CTextModeDefHdrWriter* NewLC(RStringPool aStrPool);
00480
00485     //##ModelId=3A914E6100A7
00486     virtual void EncodeHeaderL(RHeaderField& aHeader);
00487
00488 protected: // methods
00489
00492     //##ModelId=3A914E6100A5
00493     CTextModeDefHdrWriter(RStringPool aStrPool);
00494
00495
00496 private: // attributes
00497
00500     //##ModelId=3A914E610094
00501     RStringPool iStrPool;
00502     };
00503
00509 //##ModelId=3A914E6101D2
00510 class CTextModeDefHdrReader : public CHeaderReader
00511     {
00512 public: // methods
00513
00516     //##ModelId=3A914E610218
00517     virtual ~CTextModeDefHdrReader();
00518
00522     //##ModelId=3A914E610210
00523     static CTextModeDefHdrReader* NewL(RStringPool aStrPool);
00524
00528     //##ModelId=3C4C3F1D0335
00529     static CTextModeDefHdrReader* NewLC(RStringPool aStrPool);
00530
00535     //##ModelId=3A914E61020E
00536     virtual void DecodeHeaderL(RHeaderField& aHeader);
00537
00538 protected: // methods
00539
00542     //##ModelId=3A914E610205
00543     CTextModeDefHdrReader(RStringPool aStrPool);
00544
00545 private: // attributes
00546
00549     //##ModelId=3A914E6101FC
00550     RStringPool iStrPool;
00551
00554     //##ModelId=3A914E6101F2
00555     RStringF iFieldName;
00556     };
00557
00558 #endif /* __CTextModeHeaderCodec_H__ */
00559


ctextmodeheadersfilter.h File Reference

#include <http/mhttpfilter.h>
#include <http/rhttpsession.h>
#include <stringpool.h>

Include dependency graph for ctextmodeheadersfilter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class CTextModeHeadersFilter
Acts as a filter above the HTTP Protocol Handler. More...


ctextmodeheadersfilter.h Source File

ctextmodeheadersfilter.h

Go to the documentation of this file.
00001 // CTextModeHeadersFilter.j
00002 //
00003 // Copyright (c) Symbian Ltd 2001
00004
00005
00006 #ifndef __CTEXTMODEHEADERSFILTER_H__
00007 #define __CTEXTMODEHEADERSFILTER_H__
00008
00009 #include <http/mhttpfilter.h>
00010 #include <http/rhttpsession.h>
00011 #include <stringpool.h>
00012
00013
00014 //##ModelId=3B1E6B5A0142
00020 //##ModelId=3B1E6B5A0142
00021 class CTextModeHeadersFilter : public CBase, public MHTTPFilter
00022     {
00023 public:
00024     //##ModelId=3B1E6B5A019C
00025     static CTextModeHeadersFilter* NewL(RHTTPSession aSession);
00026     //##ModelId=3B1E6B5A0196
00027     ~CTextModeHeadersFilter();
00028
00029 public: // Methods from MHTTPFilterBase
00030
00033
00034
00035     //##ModelId=3B1E6B5A0193
00036     virtual void MHFRunL(RHTTPTransaction aTransaction, const THTTPEvent& aEvent);
00037
00039     //##ModelId=3C4C3F1F0003
00040     virtual void MHFSessionRunL(const THTTPSessionEvent& aEvent);
00041
00043     //##ModelId=3B1E6B5A018B
00044     virtual TInt MHFRunError(TInt aError, RHTTPTransaction aTransaction, const THTTPEvent& aEvent);
00045
00047     //##ModelId=3C4C3F1E0373
00048     virtual TInt MHFSessionRunError(TInt aError, const THTTPSessionEvent& aEvent);
00049
00050 public: // Methods from MHTTPFilter
00051
00053     //##ModelId=3B1E6B5A0188
00054     virtual void MHFUnload(RHTTPSession aSession, THTTPFilterHandle aHandle);
00055
00057     //##ModelId=3B1E6B5A0180
00058     virtual void MHFLoad(RHTTPSession aSession, THTTPFilterHandle aHandle);
00060
00061  private:
00062     //##ModelId=3B1E6B5A017F
00063     CTextModeHeadersFilter();
00064     // ConstructL also installs the filter.
00065     //##ModelId=3B1E6B5A0179
00066     void ConstructL(RHTTPSession aSession);
00067
00068     //##ModelId=3B1E6B5A0177
00069     void AlterRequestHeadersL(RHTTPTransaction aTransaction);
00070     //##ModelId=3B1E6B5A0175
00071     void AlterResponseHeadersL(RHTTPTransaction aTransaction);
00072
00073
00074     // Checks that there is a content-type header when we receive body data, if its not set then set it to
00075     // application/octet-stream
00076     //##ModelId=3B1E6B5A016E
00077     void EnsureContentTypePresentL(RHTTPTransaction aTransaction);
00078
00079     // ensures that there is a path in the uri for the transaction
00080     //##ModelId=3B1E6B5A016C
00081     void EnsurePathExistsL(RHTTPTransaction aTransaction);
00082
00083     //##ModelId=3B1E6B5A016A
00084     void EnsureContentLengthL(RHTTPTransaction aTransaction);
00085
00086     // Ensure that if there is a connection header it doesn't contain end to end header parts
00087     //##ModelId=3B1E6B5A0162
00088     void EnsureNoEndToEndHeadersInConnectionHeaderL(RHTTPTransaction aTransaction);
00089     //##ModelId=3B1E6B5A0160
00090     TBool IsHopByHopHeader(RStringF aHeaderName);
00091
00092     //##ModelId=3C4C3F1E0304
00093     void AddExpect100ContinueL(RHTTPTransaction aTransaction);
00094
00095     //##ModelId=3C4C3F1E028C
00096     void AddSessionHeadersL(RHTTPHeaders aTransactionHeaders, RHTTPHeaders aSessionHeaders);
00097  private:
00099     //##ModelId=3B1E6B5A0159
00100     TInt iLoadCount;
00101     //##ModelId=3C4C3F1E0282
00102     RStringPool iStringPool;
00103     //##ModelId=3C4C3F1E026E
00104     RHTTPSession iSession;
00105     };
00106
00107 // Inlined as it's only called in 1 place.
00108 inline CTextModeHeadersFilter* CTextModeHeadersFilter::NewL(RHTTPSession aSession)
00109     {
00110     CTextModeHeadersFilter* filter = new (ELeave) CTextModeHeadersFilter;
00111     CleanupStack::PushL(filter);
00112     filter->ConstructL(aSession);
00113     CleanupStack::Pop(filter);
00114     return filter;
00115     }
00116
00117 #endif //__CTEXTMODEHEADERSFILTER_H_


CTextModeHttpProt.h File Reference

@public More...

#include <http/framework/cprotocolhandler.h>
#include <http/framework/mrxdataobserver.h>
#include <http/framework/httplogger.h>
#include "mtextmodetransporthandler.h"
#include "ctextmodeprottransaction.h"
#include "textmodestd.h"
#include "msessionpropertiesprovider.h"

Include dependency graph for CTextModeHttpProt.h:

Include dependency graph

Go to the source code of this file.

Compounds

class CTextModeHttpProt
The CTextModeHttpProt class is a specialisation of CProtocolHandler for plain-text HTTP - i.e. More...

Detailed Description

@public

Warning:
: This file contains Rose Model ID comments please do not delete

Definition in file CTextModeHttpProt.h.


CTextModeHttpProt.h Source File

CTextModeHttpProt.h

Go to the documentation of this file.
00001 // CTextModeHttpProt.h
00002 //
00003 // Copyright (C) 2001 Symbian Ltd
00004 //
00012 #ifndef __CTEXTMODEHTTPPROT_H__
00013 #define __CTEXTMODEHTTPPROT_H__
00014
00015
00016 // System includes
00017 #include <http/framework/cprotocolhandler.h>
00018 #include <http/framework/mrxdataobserver.h>
00019 #include <http/framework/httplogger.h>
00020
00021 // User includes
00022 #include "mtextmodetransporthandler.h"
00023 #include "ctextmodeprottransaction.h"
00024 #include "textmodestd.h"
00025 #include "msessionpropertiesprovider.h"
00026
00027 // Forward declarations
00028 class CTextModeRxData;
00029 class CTextModeTxData;
00030 class CTextModeHeadersFilter;
00031 class CTCPClientFactory;
00032
00033
00066 //##ModelId=3A360B66017C
00067 class CTextModeHttpProt : public CProtocolHandler, public MRxDataObserver, public MSessionPropertiesProvider
00068 {
00069 public: // methods
00070
00073     //##ModelId=3A925B3D02DC
00074     static CTextModeHttpProt* NewL(TAny* aSession);
00075
00077     //##ModelId=3B1E6B5502AD
00078     virtual ~CTextModeHttpProt();
00079
00080 public: // methods inherited from MRxDataObserver
00081
00084     //##ModelId=3B1E6B5403E2
00085     virtual void SetStatusL(CRxData& aRxData, TInt aStatus);
00086
00087 private: // Methods inherited from CProtocolHandler
00088
00094     //##ModelId=3A925B3D00C9
00095     virtual void CreateCodecL();
00096
00101     //##ModelId=3C4C3F1C0045
00102     virtual CProtTransaction* CreateProtTransactionL(RHTTPTransaction aTransaction);
00103
00108     //##ModelId=3A925B3D0051
00109     virtual TBool ServiceL(CProtTransaction& aTrans) ;
00110
00115     //##ModelId=3C4C3F1B0314
00116     virtual void ClosedTransactionHook(CProtTransaction* aTrans);
00117
00122     //##ModelId=3C4C3F1B024C
00123     virtual void CancelTransactionHook(CProtTransaction& aTransaction);
00124
00129     //##ModelId=3B1E6B530264
00130     virtual void NotifyNewRequestBodyPart(CProtTransaction& aTransaction);
00131
00132     //##ModelId=3C4C3F1B01A2
00133     void SetupProxyInformation();
00134
00140     TInt SessionServerCert(TCertInfo& aServerCert);
00141
00148     TInt TransactionServerCert(TCertInfo& aServerCert, RHTTPTransaction aTransaction);
00149
00150 private:   // Methods from MSessionPropertiesProvider
00151
00156     virtual TBool GetCommsPrefs(TInt& aSocketServHandle, TInt& aConnectionPtr);
00157
00162     virtual void SetCommsPrefs(TInt aSocketServHandle, TInt aConnectionPtr);
00163
00168     virtual TSecureDialogPref GetSecureDialogPref() const;
00169
00170 private: // Methods
00171
00173     //##ModelId=3B1E6B4C032D
00174     CTextModeHttpProt(RHTTPSession aSession);
00175
00177     //##ModelId=3B1E6B4C01C4
00178     void ConstructL(RHTTPSession aSession);
00179
00183     //##ModelId=3B1E6B510153
00184     TBool PrepareRequestForTransL(RHTTPTransaction aTrans,
00185                                   RStringF& aAddress,
00186                                   RStringF& aHost,
00187                                   TInt& aPort,
00188                                   TInt& aHostPort,
00189                                   TBool& aIsSecure);
00190
00192     //##ModelId=3B1E6B5000BB
00193     void PrepareUriForTransL(RHTTPTransaction aTrans,
00194                              RStringF& aAddress,
00195                              RStringF& aHost,
00196                              TInt& aPort,
00197                              TInt& aHostPort,
00198                              TBool aIsHttp10,
00199                              TBool& aIsSecure);
00200
00205     //##ModelId=3B1E6B4F0150
00206     TBool SelectTransportHandlerL(MTextModeTransportHandler*& aTransportHandler,
00207                                   CHttpTcpServerLocation& aServerLocation);
00208
00212     //##ModelId=3B1E6B4E011D
00213     TBool LookUpProtTrans(RHTTPTransaction aTrans, CTextModeProtTransaction*& aProtTrans) const;
00214
00217     //##ModelId=3B1E6B4C0138
00218     TInt MaxNumTransportHandlers() const;
00219
00222     //##ModelId=3B1E6B4C0048
00223     TInt MaxNumTransPerTranspHndlr() const;
00224
00225     //##ModelId=3B1E6B4B0140
00226     TBool IsHostIPAddress(const TDesC8& aUri) const;
00227
00228 private: // attributes
00229
00231     //##ModelId=3B1E6B49015C
00232     RArray<MTextModeTransportHandler*> iTransportHnds;
00233
00236     //##ModelId=3B1E6B490101
00237     TBool iSessionUsesWebProxy;
00238
00241     //##ModelId=3B1E6B4900D9
00242     TBool iUseNamedProxy;
00243
00246     //##ModelId=3B1E6B49009D
00247     RStringF iProxyAddress;
00248
00251     //##ModelId=3B1E6B49006B
00252     mutable TInt iMaxNumTransportHandlers;
00253
00256     //##ModelId=3B1E6B490043
00257     mutable TInt iMaxNumTransPerTranspHndlr;
00258
00259     // Filter that looks at the headers of the requests and responses and alters them to ensure we conform to the proper
00260     // rules for particular headers as defined by the http RFC. This sits directly above the text mode protocol as the first
00261     // filter
00262     //##ModelId=3B1E6B49001B
00263     CTextModeHeadersFilter* iHeadersFilter;
00264
00265     //##ModelId=3C4C3F1A0272
00266     TBool iFirstTransaction;
00267
00268     //TCP Client Factory used to create Transport Handlers
00269     CTCPClientFactory* iTCPClientFactory;
00270     };
00271
00272 #endif // __CTEXTMODEHTTPPROT_H__
00273


ctextmodeprottransaction.h File Reference

#include <http/framework/cprottransaction.h>

Include dependency graph for ctextmodeprottransaction.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class CTextModeProtTransaction


ctextmodeprottransaction.h Source File

ctextmodeprottransaction.h

Go to the documentation of this file.
00001 // CTextModeProtTransaction.h
00002 //
00003 // Copyright (c) Symbian Ltd 2001
00004
00005
00006 #ifndef     __CTEXTMODEPROTTRANSACTION_H__
00007 #define     __CTEXTMODEPROTTRANSACTION_H__
00008
00009 // System includes
00010 #include <http/framework/cprottransaction.h>
00011
00012 // Forward declarations
00013 class MTextModeTransportHandler;
00014
00015 //##ModelId=3C4C3F0A0356
00016 class CTextModeProtTransaction: public CProtTransaction
00017     {
00018 public: // Methods
00019
00020     //##ModelId=3C4C3F0A03C6
00021     static CTextModeProtTransaction* NewL(RHTTPTransaction aTransaction);
00022
00023     //##ModelId=3C4C3F0A03C5
00024     ~CTextModeProtTransaction();
00025
00026     //##ModelId=3C4C3F0A03C4
00027     MTextModeTransportHandler& TextModeTransportHandler() const;
00028
00029     //##ModelId=3C4C3F0A03BD
00030     void SetTextModeTransportHandler(MTextModeTransportHandler& aTextModeTransportHandler);
00031
00032 private:    // Methods from CProtTransaction
00033
00038     //##ModelId=3C4C3F0A03BC
00039     virtual void CreateTxDataL();
00040
00045     //##ModelId=3C4C3F0A03BA
00046     virtual void CreateRxDataL(MRxDataObserver& aObserver);
00047
00048 private:    // Methods
00049
00050     //##ModelId=3C4C3F0A03B0
00051     CTextModeProtTransaction(RHTTPTransaction aTransaction);
00052
00053 private:
00054     // The transport handler. Stored as a pointer as it is only set once the transaction is given one
00055     // This might be sometime after the transaction has been submitted if there are lots of other transactions
00056     // in front of a newly created one
00057     //##ModelId=3C4C3F0A03A8
00058     MTextModeTransportHandler*  iTextModeTransportHandler;
00059
00060     };
00061
00062
00063
00064
00065
00066
00067
00068 #endif // __CTEXTMODEPROTTRANSACTION_H__


CTextModeRxData.h File Reference

#include <e32base.h>
#include <http/framework/crxdata.h>
#include "mtransporthndobs.h"
#include "mtextmodetransporthandler.h"
#include "textmodestd.h"

Include dependency graph for CTextModeRxData.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | TResponseParser
This class is an HTTP response parser. More...

class | CTextModeRxData
A representation of over-the-air received data for Text-Mode HTTP. More...

Enumerations

enum TRespParseStat {
ECompleteNoError = 0, EEmptyLine = 1, EFoundStatusLine = 2, EFoundHeaderField = 3,
EFoundBody = 4, EFoundChunkHeader = 5, ENoData = 6, EPartialData = 7,
EParseError = 8, ELineBuffOverrun = 9, EFoundHeaderFieldContinuation = 10
}
Status codes sent by the TResponseParser line extracter. More...

Enumeration Type Documentation

enum TRespParseStat

Status codes sent by the TResponseParser line extracter.

Enumeration values:
ECompleteNoError | Parser has exhausted its data buffer and completed with no error.
EEmptyLine | Parser has encountered an empty line.
EFoundStatusLine | Parser has identified the HTTP Response's status line.
EFoundHeaderField | Parser has identified an HTTP header field.
EFoundBody | Parser has encountered the HTTP Response body.
EFoundChunkHeader | Parser has identified an HTTP body chunk header field.
ENoData | Parser has run out of data in its working buffer.
EPartialData | Parser has got to the end of its working buffer with data left and needs more to extract a complete line.
EParseError | Parser has hit some error condition.
ELineBuffOverrun | Parser requires a reallocation of its line buffer to continue parsing.
EFoundHeaderFieldContinuation | Parser has found a line after a header line that has no header ':' separator.

Definition at line 19 of file CTextModeRxData.h.


CTextModeRxData.h Source File

CTextModeRxData.h

Go to the documentation of this file.
00001 // CTextModeRxData.h
00002 //
00003 // Copyright (C) 2000 Symbian Ltd
00004 //
00005
00006 #ifndef __CTEXTMODERXDATA_H__
00007 #define __CTEXTMODERXDATA_H__
00008
00009 // System includes
00010 #include <e32base.h>
00011 #include <http/framework/crxdata.h>
00012
00013 // User includes
00014 #include "mtransporthndobs.h"
00015 #include "mtextmodetransporthandler.h"
00016 #include "textmodestd.h"
00017
00019 enum TRespParseStat
00020     {
00021     ECompleteNoError = 0,
00022     EEmptyLine       = 1,
00023     EFoundStatusLine = 2,
00024     EFoundHeaderField= 3,
00025     EFoundBody       = 4,
00026     EFoundChunkHeader= 5,
00027     ENoData          = 6,
00028     EPartialData     = 7,
00029     EParseError      = 8,
00030     ELineBuffOverrun = 9,
00031     EFoundHeaderFieldContinuation = 10
00032     };
00033
00034 class MRxDataObserver;
00035
00036
00044 //##ModelId=3A914E59002C
00045 class TResponseParser
00046     {
00048     friend class TTResponseParser_StateAccessor;
00049 public: // Enumerated types
00050
00052     enum TSuperState
00053         {
00054         EUndefSuper,
00055         ERespBuffPopulated,
00056         ERespBuffEmpty,
00057         ERespBuffCarryOver
00058         };
00059     // Main states of the response parser. Actually substates of ERespBuffPopulated.
00060     enum TState
00061         {
00062         EUndefined,
00063         EParsingStatusLine,
00064         EParsingHeaders,
00065         EReadingNormalBody,
00066         EReadingChunkedBody,
00067         EParsingPostChunkedEntityHeaders
00068         };
00069     // Sub-states of the 'EReadingChunkedBody' main state
00070     enum TSubState
00071         {
00072         EUndefSub,
00073         EParsingChunkHeader,
00074         EReadingChunkBodyData
00075         };
00076
00077 public: // methods
00078
00080     //##ModelId=3A914E590162
00081     TResponseParser();
00082
00085     //##ModelId=3A914E590163
00086     TResponseParser(TPtr8 aLineBuffer);
00087
00090     //##ModelId=3A914E590158
00091     TInt ParseMoreData();
00092
00094     //##ModelId=3A914E590144
00095     void SetRespBuffer(const TDesC8& aRespBuffer);
00096
00098     //##ModelId=3A914E59013B
00099     void SetLineBuffer(const TPtr8& aLineBuffer);
00100
00102     //##ModelId=3A914E59013A
00103     const TDesC8& CurrentLine() const;
00104
00106     //##ModelId=3A914E590130
00107     void Reset(TBool aDoResetResponseBuffer= ETrue);
00108
00110     //##ModelId=3B1E6B3F02F2
00111     TInt GetLineBufferOverrunSize() const;
00112
00115
00119     //##ModelId=3A914E590108
00120     TInt StatusLine(TInt& aMajVers, TInt& aMinVers, TPtrC8& aStatDesc) const;
00121
00125     //##ModelId=3A914E5900EA
00126     void Header(TPtrC8& aFieldName, TPtrC8& aFieldVal) const;
00127
00131     //##ModelId=3A914E5900D9
00132     void Body(TPtrC8& aBodyData);
00133
00134 private: // methods
00135
00138     //##ModelId=3B1E6B3F028E
00139     TInt TryParseMoreDataL();
00140
00144     //##ModelId=3A914E5900D8
00145     TInt ExtractALineL();
00146
00148     //##ModelId=3A914E5900D7
00149     TInt ExtractBody();
00150
00152     //##ModelId=3A914E5900D6
00153     TInt ExtractBodyChunk();
00154
00157     //##ModelId=3A914E5900CE
00158     TInt ParseLine();
00159
00161     //##ModelId=3A914E5900CD
00162     TInt ParseStatusLine();
00163
00165     //##ModelId=3A914E5900CC
00166     TInt ParseHeaders();
00167
00169     //##ModelId=3A914E5900C5
00170     TInt ParseChunkHeader();
00171
00173     //##ModelId=3B1E6B3F01C5
00174     void TryAppendLineBufferL(const TDesC8& aAppendData);
00175
00177     //##ModelId=3B1E6B3F0111
00178     void TrySetLineBufferL(const TDesC8& aSetData);
00179
00180 private: // attributes
00181
00183     //##ModelId=3A914E5900C2
00184     TPtrC8 iRespBuffer;
00185
00187     //##ModelId=3A914E5900B8
00188     TPtr8 iLineBuffer;
00189
00191     //##ModelId=3A914E5900A6
00192     TSuperState iSuperState;
00193
00195     //##ModelId=3A914E59009C
00196     TState iMainState;
00197
00199     //##ModelId=3A914E590092
00200     TSubState iSubState;
00201
00203     //##ModelId=3A914E590088
00204     TInt iStatCode;
00205
00207     //##ModelId=3A914E59007E
00208     TInt iMajorVersion;
00209
00211     //##ModelId=3A914E590074
00212     TInt iMinorVersion;
00213
00215     //##ModelId=3A914E59006A
00216     TPtrC8 iStatDesc;
00217
00219     //##ModelId=3A914E590060
00220     TPtrC8 iFieldName;
00221
00223     //##ModelId=3A914E590056
00224     TPtrC8 iFieldValue;
00225
00227     //##ModelId=3A914E59004C
00228     TPtrC8 iBodyData;
00229
00231     //##ModelId=3A914E590045
00232     TBool iIsChunked;
00233
00235     //##ModelId=3A914E590040
00236     TInt iChunkSize;
00237
00240     //##ModelId=3A914E590038
00241     TInt iChunkBytesReadSoFar;
00242
00244     //##ModelId=3B1E6B3F00F3
00245     TInt iLineBufferOverrunSize;
00246
00249     //##ModelId=3B1E6B3F00C1
00250     TBool iPreviousLineFitExactly;
00251     };
00252
00253
00254
00255
00256
00262 //##ModelId=3A914E5F0002
00263 class CTextModeRxData : public CRxData, public MTransportHndObs
00264 {
00265 public:
00268     //##ModelId=3A914E5F00EA
00269     static CTextModeRxData* NewL(CProtTransaction& aProtTrans, MTextModeTransportHandler& aTransportHnd,
00270                                     MRxDataObserver& aObserver);
00271
00273     //##ModelId=3A914E5F00E9
00274     virtual ~CTextModeRxData();
00275
00277     //##ModelId=3C4C3F19016D
00278     void ResetRxData();
00279
00280
00281 public: // methods from MTransportHndObs
00282
00284     //##ModelId=3A914E5F00CB
00285     virtual void SetStatusL(CTxData& aTrans, TInt aStatus);
00286
00289     //##ModelId=3A914E5F00B7
00290     virtual THttpRxDataStat DataL(CTxData& aTrans, const TDesC8& aData);
00291
00293     //##ModelId=3B1E6B57018E
00294     virtual void HandleError(CTxData& aTrans, TInt aError);
00295
00302     //##ModelId=3C4C3F19013B
00303     virtual TInt CheckConnectResponseL(TDesC8& aBuffer);
00304
00305
00306 public: // Methods inherited from MHTTPDataSupplier, to obtain the response body data
00307
00309     //##ModelId=3A914E5F00AD
00310     virtual TBool GetNextDataPart(TPtrC8& aDataChunk);
00311
00314     //##ModelId=3A914E5F00A4
00315     virtual void ReleaseData();
00316
00319     //##ModelId=3A914E5F00A3
00320     virtual TInt OverallDataSize();
00321
00324     //##ModelId=3A914E5F00E1
00325     virtual TInt Reset();
00326
00327 private:
00328
00329     enum EBlankLineCount
00330         {
00331         EFirstBlankLine = 1,
00332         ESecondBlankLine = 2
00333         };
00334
00336     //##ModelId=3A914E5F008F
00337     CTextModeRxData();
00338
00341     //##ModelId=3A914E5F0090
00342     CTextModeRxData(CProtTransaction& aProtTrans, MTextModeTransportHandler& aTransportHnd, MRxDataObserver& aObserver);
00343
00345     //##ModelId=3A914E5F0085
00346     void ConstructL();
00347
00348
00350     //##ModelId=3C4C3F1900EA
00351     void HandleStatusLineL(CTxData& aTrans);
00352
00353     //##ModelId=3C4C3F190090
00354     void DoFoundHeaderFieldL(CTxData& aTrans, THttpRxDataStat& aDataFlags);
00355     //##ModelId=3C4C3F190068
00356     void DoFoundHeaderFieldContinuationL(CTxData& aTrans);
00357     //##ModelId=3C4C3F190040
00358     void DoFoundBodyL(CTxData& aTrans);
00359     //##ModelId=3C4C3F190018
00360     void DoFoundLineSeparatorL(CTxData& aTrans);
00361
00362     //##ModelId=3C4C3F190004
00363     inline MTextModeTransportHandler& TextModeTransportHandler();
00364 private:
00365
00367     //##ModelId=3A914E5F005E
00368     TBool iGotAllHeaders;
00369
00371     //##ModelId=3B1E6B570025
00372     TBool iReplyComplete;
00373
00377     //##ModelId=3A914E5F0040
00378     TResponseParser iParse;
00379
00382     //##ModelId=3A914E5F0036
00383     HBufC8* iLineBuffer;
00384
00386     //##ModelId=3C4C3F1803D8
00387     RArray<TPtrC8> iFoundBodyParts;
00388
00390     //##ModelId=3B1E6B5603E5
00391     TInt iOverallDataSize;
00392
00394     //##ModelId=3B1E6B5603BD
00395     TInt iBodyDataSizeSoFar;
00396
00398     //##ModelId=3B1E6B560395
00399     TInt iEmptyLineCount;
00400
00402     //##ModelId=3B1E6B56036D
00403     TBool iHaveReadContentLengthHeader;
00404
00407     //##ModelId=3C4C3F18039C
00408     RStringF iLastHeaderName;
00409
00411     //##ModelId=3C4C3F180388
00412     TBool iConsumingResponse;
00413
00414     //##ModelId=3C4C3F180374
00415     MTextModeTransportHandler* iTextModeTransportHandler; // not owned
00416
00418     TBool iFoundConnectionClose;
00419
00420 };
00421
00422 inline MTextModeTransportHandler& CTextModeRxData::TextModeTransportHandler()
00423     {
00424     __ASSERT_DEBUG(iTextModeTransportHandler, Panic(ETextModeTransportHandlerNotSet));
00425     return *iTextModeTransportHandler;
00426     }
00427
00428
00429 #endif /* __CTextModeRxData_H__ */
00430


CTextModeTxData.h File Reference

#include <e32base.h>
#include <http/framework/ctxdata.h>
#include "textmodestd.h"

Include dependency graph for CTextModeTxData.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | TChunkEncoder
Private Embedded class is used for internal chunking data, it formats the data using a state variable and a small buffer, a cached body. More...

class | MComposerObserver
class | TRequestComposer
This class is a simple HTTP request composer. More...

class | CTextModeTxData
A representation of over-the-air transmitted data for Text-Mode HTTP. More...

Variables

const TInt | KChunkHeaderSize = 10

Variable Documentation

const TInt KChunkHeaderSize = 10

Definition at line 17 of file CTextModeTxData.h.


CTextModeTxData.h Source File

CTextModeTxData.h

Go to the documentation of this file.
00001 // CTextModeTxData.h
00002 //
00003 // Copyright (C) 2001 Symbian Ltd
00004
00005 #ifndef __CTEXTMODETXDATA_H__
00006 #define __CTEXTMODETXDATA_H__
00007
00008 // System includes
00009 #include <e32base.h>
00010 #include <http/framework/ctxdata.h>
00011
00012 // User includes
00013 #include "textmodestd.h"
00014
00015
00016 // Size for a small buffer for sending size and termination data
00017 const TInt KChunkHeaderSize = 10;
00018
00021 class MComposerObserver
00022     {
00023 public: // methods
00024
00035     virtual void ReAllocBufferL(TInt aRequiredLength, TPtr8& aBuffer) =0;
00036
00037     };
00038
00045 //##ModelId=3A914E5D0208
00046 class TRequestComposer
00047 {
00048 private:
00049
00067         class TChunkEncoder
00068         {
00069     public:
00071         TChunkEncoder();
00072
00074         void Reset();
00075
00082         void EncodeDataL(MHTTPDataSupplier& aBodySupplier,
00083                             TPtrC8& aChunkData,
00084                             TBool& aMustReleaseDataSupplier,
00085                             TBool& aSentLast);
00086
00087         inline TBool IsLastChunk() const;
00088
00089     private:
00090
00092         enum TChunkState
00093             {
00094             ESendNumBytesFirst,
00095             ESendNumBytes,
00096             ESendBody,
00097             ESendLast
00098             };
00099
00100         // Indicator for when it is time to send the chunk terminator
00101         TBool iLastChunkToEncode;
00102
00104         TPtrC8 iChunkBodyHolder;
00105
00107         TChunkState iChunkState;
00108
00110         TBuf8<KChunkHeaderSize> iScratchBuf;
00111         };
00112
00113
00114 public: // methods
00115
00117     //##ModelId=3A914E5D028C
00118     TRequestComposer();
00119
00127     //##ModelId=3A914E5D0294
00128     TRequestComposer(TPtr8 aWorkingBuffer, MComposerObserver& aObserver, RHTTPRequest aRequest, RStringPool aStrPool);
00129
00135     //##ModelId=3A914E5D0282
00136     TBool ComposeMoreDataL(TPtrC8& aChunkData, TBool& aMustReleaseDataSupplier);
00137
00141     //##ModelId=3A914E5D0280
00142     inline  void SetWorkingBuffer(TPtr8 aWorkingBuffer, MComposerObserver& aObserver);
00143
00146     //##ModelId=3A914E5D0276
00147     inline  void SetRequest(RHTTPRequest aRequest);
00148
00151     //##ModelId=3A914E5D026D
00152     inline void SetStringPool(RStringPool aStrPool);
00153
00155     //##ModelId=3B1E6B45001F
00156     inline void SetConnectionInfo(RHTTPConnectionInfo aConnectionInfo);
00157
00159     //##ModelId=3C4C3F15024D
00160     inline void SetURI(RString aURI);
00161
00163     //##ModelId=3A914E5D026C
00164     void Reset();
00165
00166     // Check if we need to terminate our chunk encoding
00167     //##ModelId=3B1E6B4403DF
00168     inline TBool IsTimeToTerminateChunkEncoding() const;
00169
00170 private: // methods
00171
00173     //##ModelId=3B1E6B4403B7
00174     void ComposeReqHeadersL();
00175
00176     // Format the start of the HTTP Request Header
00177     //##ModelId=3B1E6B44038F
00178     void FormatRequestLineBeginningL();
00179
00180     // Append a Request Header to a Buffer with safe allocation
00181     //##ModelId=3B1E6B44028B
00182     void AppendDataL(const TDesC8& aHeader, const TDesC8& aTailingPattern);
00183
00184     // Check to see if data needs to be TransformEncoding: chunked
00185     //##ModelId=3B1E6B440259
00186     TBool IsChunkEncoding();
00187
00188
00189 private: // attributes
00190
00192     //##ModelId=3A914E5D025A
00193     RStringPool iStrPool;
00194
00195     //##ModelId=3B1E6B440231
00196     RHTTPConnectionInfo iConnectionInfo;
00197
00200     //##ModelId=3A914E5D0250
00201     TPtr8 iWorkingBuffer;
00202
00203     MComposerObserver*  iObserver;
00204
00206     //##ModelId=3A914E5D023C
00207     RHTTPRequest iRequest;
00208
00210     //##ModelId=3C4C3F15021B
00211     RString iURI;
00212
00214     //##ModelId=3A914E5D0232
00215     TBool iSentLastChunk;
00216
00218     //##ModelId=3A914E5D0226
00219     TInt iChunksSent;
00220
00221     // Flag to tell us this data is going to be chunk enoded here
00222     //##ModelId=3B1E6B440209
00223     mutable TBool iChunkEncode;
00224
00225     // A Chunk encoder to do the chunking
00226     //##ModelId=3B1E6B4401EB
00227     TChunkEncoder iChunkEncoder;
00228     };
00229
00230
00231 // Forward declarations
00232 class MTextModeTransportHandler;
00233
00240 //##ModelId=3A375629018A
00241 class CTextModeTxData : public CTxData,
00242                         public MComposerObserver
00243 {
00244 public: // methods
00245
00248     //##ModelId=3A925A4401DA
00249     static CTextModeTxData* NewL(CProtTransaction& aTrans, MTextModeTransportHandler& aTransportHnd);
00250
00253     //##ModelId=3A925A4401EE
00254     static CTextModeTxData* NewL(const TDesC8& aEncodedData);
00255
00257     //##ModelId=3A925A4401D2
00258     virtual ~CTextModeTxData();
00259
00260     //##ModelId=3C4C3F160349
00261     void NotifyNewRequestBodyPart();
00262
00263 public: // Methods from MHTTPDataSupplier
00264
00268     //##ModelId=3C4C3F160321
00269      virtual TBool GetNextDataPart(TPtrC8& aDataPart);
00270
00274     //##ModelId=3C4C3F160317
00275     virtual void ReleaseData();
00276
00280     //##ModelId=3C4C3F160303
00281     virtual TInt OverallDataSize();
00282
00286     //##ModelId=3A925A4401D1
00287     virtual TInt Reset();
00288
00289 private:    // Methods from MComposerObserver
00290
00294     virtual void ReAllocBufferL(TInt aRequiredLength, TPtr8& aBuffer);
00295
00296 private: // methods
00297
00299     //##ModelId=3A925A4401B2
00300     void PrepareMessageL();
00301
00303     //##ModelId=3A925A44019E
00304     CTextModeTxData();
00305
00307     //##ModelId=3A925A44019F
00308     CTextModeTxData(CProtTransaction& aTrans, MTextModeTransportHandler& aTextModeTransportHnd);
00309
00311     //##ModelId=3A925A440180
00312     void ConstructL();
00313
00315     //##ModelId=3A925A44018A
00316     void ConstructL(const TDesC8& aEncodedData);
00317
00318     //##ModelId=3C4C3F1602DB
00319     inline MTextModeTransportHandler& TextModeTransportHandler();
00320
00321 private: // attributes
00322
00324     //##ModelId=3A925A44013A
00325     TRequestComposer iComposer;
00326
00328     //##ModelId=3A925A44010A
00329     TBool iTransSet;
00330
00332     //##ModelId=3A925A44011E
00333     HBufC8* iEncodedData;
00334
00337     //##ModelId=3A925A4400F3
00338     TBool iLastChunk;
00339
00341     //##ModelId=3A925A4400DF
00342     TInt iChunksSent;
00343
00345     //##ModelId=3B1E6B4601EE
00346     TBool iMustReleaseDataSupplier;
00347
00348     //##ModelId=3C4C3F1602D1
00349     MTextModeTransportHandler* iTextModeTransportHandler; // not owned
00350     };
00351
00352
00353 // inlines
00354
00355 inline TBool TRequestComposer::TChunkEncoder::IsLastChunk() const
00356     {
00357     return iLastChunkToEncode;
00358     }
00359
00360 inline void TRequestComposer::SetWorkingBuffer(TPtr8 aWorkingBuffer, MComposerObserver& aObserver)
00361     {
00362     iWorkingBuffer.Set(aWorkingBuffer);
00363     iObserver = &aObserver;
00364     }
00365
00366 inline void TRequestComposer::SetRequest(RHTTPRequest aRequest)
00367     {
00368     iRequest = aRequest;
00369     }
00370
00371 inline void TRequestComposer::SetStringPool(RStringPool aStrPool)
00372     {
00373     iStrPool = aStrPool;
00374     }
00375
00376 inline void TRequestComposer::SetConnectionInfo(RHTTPConnectionInfo aConnectionInfo)
00377     {
00378     iConnectionInfo = aConnectionInfo;
00379     }
00380
00381 inline void TRequestComposer::SetURI(RString aURI)
00382     {
00383     iURI = aURI;
00384     }
00385
00386 inline TBool TRequestComposer::IsTimeToTerminateChunkEncoding() const
00387     {
00388     return (iChunkEncode && iChunkEncoder.IsLastChunk());
00389     }
00390
00391
00392 inline MTextModeTransportHandler& CTextModeTxData::TextModeTransportHandler()
00393     {
00394     __ASSERT_DEBUG(iTextModeTransportHandler, Panic(ETextModeTransportHandlerNotSet));
00395     return *iTextModeTransportHandler;
00396     }
00397
00398
00399
00400 #endif /* __CTEXTMODETXDATA_H__ */
00401


CTransaction.h File Reference

#include <e32base.h>
#include "TEventRegistration.h"
#include "CHTTPSession.h"
#include "http/framework/httplogger.h"
#include "http/framework/cprotocolhandler.h"
#include "CTransaction.inl"

Include dependency graph for CTransaction.h:

Include dependency graph

Go to the source code of this file.

Compounds

class CTransaction
Implementation class for the transaction
See also:
RHTTPTransaction.
 More...


CTransaction.h Source File

CTransaction.h

Go to the documentation of this file.
00001 // Copyright (c) Symbian Ltd 2001
00002
00003 #ifndef CTRANSACTION_H
00004 #define CTRANSACTION_H
00005
00006 #include <e32base.h>
00007 #include "TEventRegistration.h"
00008 #include "CHTTPSession.h"
00009 #include "http/framework/httplogger.h"
00010 #include "http/framework/cprotocolhandler.h"
00011
00012 class THTTPProxy;
00013 class CRequest;
00014 class CResponse;
00015
00017 // Private inheritance as this class should be deleted via the Close function.
00018 //##ModelId=3C4C18840174
00019 class CTransaction : private CActive
00020     {
00021  public:
00023     //##ModelId=3C4C188403B9
00024     static CTransaction* NewL(MHTTPTransactionCallback& aCallback,
00025                               const TUriC8& aURI,
00026                               CHTTPSession& aSession,
00027                               RStringF aMethod);
00028
00030     //##ModelId=3C4C18840391
00031     void SendEventL(THTTPEvent& aEvent, TInt aDirection,
00032                     THTTPFilterHandle aStart);
00037     //##ModelId=3C4C18840369
00038     void SynchronousSendEvent(THTTPEvent aEvent, TInt aDirection,
00039                     THTTPFilterHandle aStart);
00041     //##ModelId=3C4C18840360
00042     RHTTPSession Session() const;
00043
00045     //##ModelId=3C4C1884035F
00046     CHeaderCodec& Codec() const;
00047
00049     //##ModelId=3C4C18840357
00050     inline CRequest& Request() const;
00051
00053     //##ModelId=3C4C18840356
00054     inline CResponse& Response() const;
00055
00057     //##ModelId=3C4C18840355
00058     inline TInt Id() const;
00059
00061     //##ModelId=3C4C1884034B
00062     inline RHTTPTransactionPropertySet PropertySet() const;
00063
00067     //##ModelId=3C4C18840341
00068     void CancelTransaction(THTTPFilterHandle aStart);
00069
00076     //##ModelId=3C4C18840337
00077     void Close();
00078
00083     //##ModelId=3C4C1884032D
00084     inline void Fail(THTTPFilterHandle aStart);
00085
00087     //##ModelId=3C4C1884031A
00088     inline static CTransaction* Implementation(RHTTPTransaction aHandle);
00089
00091     //##ModelId=3C4C18840319
00092     inline MHTTPTransactionCallback& Callback() const;
00093
00096     //##ModelId=3C4C18840311
00097     inline void Unblock();
00098
00100     //##ModelId=3C4C18840310
00101     inline RHTTPTransaction Handle();
00102
00103     //##ModelId=3C4C1884030F
00104     inline TBool SyncMode() const;
00105
00111     TInt ServerCert(TCertInfo& aServerCert);
00112
00113  private:
00114
00116     //##ModelId=3C4C18840306
00117     virtual void RunL();
00118
00120     //##ModelId=3C4C18840305
00121     virtual void DoCancel();
00122
00124     //##ModelId=3C4C188402F1
00125     virtual TInt RunError(TInt aError);
00126
00127  private:
00129     enum TTransactionStates
00130         {
00131         EPassive = 0,
00132         EFilter,
00133         EInFilter,
00134
00139         EExiting,
00144         EBlocked,
00145         ECancelled
00146         };
00147
00149     //##ModelId=3C4C188402D3
00150     CTransaction(MHTTPTransactionCallback& aCallback, CHTTPSession& aSession);
00151
00153     //##ModelId=3C4C188402B5
00154     void ConstructL(const TUriC8& aURI, RStringF aMethod);
00155
00157     //##ModelId=3C4C1884028F
00158     TInt AddEvent(THTTPEvent& aEvent, TInt aDirection,
00159                     THTTPFilterHandle aStart);
00160
00163     //##ModelId=3C4C1884028E
00164     TTransactionStates FindFilterForThisEvent();
00165
00168     //  ##ModelId=3A914E0202C6
00169     //##ModelId=3C4C1884028D
00170     TTransactionStates FindNextFilter();
00171
00173     //##ModelId=3C4C1884027A
00174     void Activate(TTransactionStates aStatus);
00175
00177     //##ModelId=3C4C18840279
00178     TBool RunOneFilterL();
00179
00181     //##ModelId=3C4C18840271
00182     void NextFilter();
00183
00184     // Returns the current event
00185     //##ModelId=3C4C18840270
00186     const TEventRegistration& CurrentEvent() const;
00187
00188     // Returns TRUE if there is an event
00189     //##ModelId=3C4C1884026F
00190     TBool EventAvailable() const;
00191
00192     // Appends the selected event
00193     //##ModelId=3C4C1884025C
00194     TInt AppendEvent(TEventRegistration& aEvent);
00195
00196     // Removes the current event
00197     //##ModelId=3C4C1884025B
00198     void RemoveEvent();
00199
00200  private:
00202     //##ModelId=3C4C18840251
00203     CRequest* iRequest;
00205     //##ModelId=3C4C18840235
00206     CResponse* iResponse;
00208     //##ModelId=3C4C18840229
00209     CHTTPTransactionCodec* iCodec;
00211     //##ModelId=3C4C18840216
00212     MHTTPTransactionCallback& iCallback;
00214     //##ModelId=3C4C18840202
00215     CHTTPSession& iSession;
00217     //##ModelId=3C4C188401F8
00218     TInt iId;
00220     //##ModelId=3C4C188401E4
00221     TInt iCurrentFilter;
00222
00225     //##ModelId=3C4C188401D8
00226     THTTPEvent iASyncEvent;
00227
00230     //##ModelId=3C4C188401CE
00231     TInt iCurrentASyncFilter;
00232
00234     //##ModelId=3C4C188401BC
00235     TInt iNextFilter;
00236
00238     //##ModelId=3C4C188401B2
00239     TBool iProcessingSyncEvent;
00241     //##ModelId=3C4C188401A7
00242     RArray<TEventRegistration> iEventQueue;
00243
00245     //##ModelId=3C4C18840194
00246     TEventRegistration iCurrentSyncEvent;
00247
00248     //##ModelId=3C4C1884018B
00249     RHTTPTransactionPropertySet iPropertySet;
00250
00251     __DECLARE_LOG
00252     };
00253
00254 #include "CTransaction.inl"
00255
00256 #endif // CSESSION_H


ctxdata.h File Reference

#include <e32base.h>
#include <http/framework/cprottransaction.h>
#include <http/mhttpdatasupplier.h>
#include <http/rhttpsession.h>

Include dependency graph for ctxdata.h:

Include dependency graph

Go to the source code of this file.

Compounds

class CTxData
@public
Since:
7.0 An abstract base class for the encoding of request data to be transmitted by a protocol handler.
 More...


ctxdata.h Source File

ctxdata.h

Go to the documentation of this file.
00001 // CTxData.h
00002 //
00003 // Copyright (C) 2001 Symbian Ltd
00004
00011 #ifndef __CTXDATA_H__
00012 #define __CTXDATA_H__
00013
00014 // System includes
00015 #include <e32base.h>
00016 #include <http/framework/cprottransaction.h>
00017 #include <http/mhttpdatasupplier.h>
00018 #include <http/rhttpsession.h> // this include is needed to ensure that the <rhttp.inl> is compiled by gcc...
00019
00028 //##ModelId=3B1E52A8001F
00029 class CTxData : public CBase, public MHTTPDataSupplier
00030     {
00031 public: // methods
00032
00037     IMPORT_C
00038     //##ModelId=3B1E52A80051
00039     virtual ~CTxData();
00040
00047     IMPORT_C
00048     //##ModelId=3B1E52A80049
00049     CProtTransaction& ProtTrans();
00050
00051 protected:
00052
00058     IMPORT_C
00059     //##ModelId=3A925A44019E
00060     CTxData();
00061
00069     IMPORT_C CTxData(CProtTransaction& aProtTransaction);
00070
00075     IMPORT_C
00076     //##ModelId=3B1E52A8003D
00077     void ConstructL();
00078
00079 protected: // attributes
00080
00084     //##ModelId=3B1E52A80035
00085     CProtTransaction* iProtTrans;
00086
00087 private: // methods
00088
00093     //##ModelId=3C4C37D6010F
00094     inline virtual void Reserved1();
00095
00100     //##ModelId=3C4C37D600FB
00101     inline virtual void Reserved2();
00102     };
00103
00104
00105 inline void CTxData::Reserved1()
00106     {}
00107 inline void CTxData::Reserved2()
00108     {}
00109
00110
00111 #endif // __CTXDATA_H__


CUnknownCapability.h File Reference

#include <e32base.h>
#include "CUnknownCapability.inl"

Include dependency graph for CUnknownCapability.h:

Include dependency graph

Go to the source code of this file.

Compounds

class CUnknownCapability
The CUnknownCapability class represents the Unknown capability as defined by the WSP Specification, July 2001. More...


CUnknownCapability.h Source File

CUnknownCapability.h

Go to the documentation of this file.
00001 // CUnknownCapability.h
00002 //
00003 // Copyright (c) Symbian Ltd 2001
00004 //
00005
00006 #ifndef __CUNKNOWNCAPABILITY_H__
00007 #define __CUNKNOWNCAPABILITY_H__
00008
00009 #include <e32base.h>
00010
00014 //##ModelId=3C4C41B40112
00015 class CUnknownCapability : public CBase
00016     {
00017 public: // Methods
00018
00027     //##ModelId=3C4C41B40150
00028     static CUnknownCapability* NewL(const TDesC8& aIdentifier, const TDesC8& aValue);
00029
00034     //##ModelId=3C4C41B4014F
00035     ~CUnknownCapability();
00036
00043     //##ModelId=3C4C41B4014E
00044     inline const TDesC8& GetIdentifier() const;
00045
00052     //##ModelId=3C4C41B40147
00053     inline const TDesC8& GetValue() const;
00054
00055 private:    // Methods
00056
00061     //##ModelId=3C4C41B40146
00062     CUnknownCapability();
00063
00072     //##ModelId=3C4C41B4013A
00073     void ConstructL(const TDesC8& aIdentifier, const TDesC8& aValue);
00074
00075 private:    // Attributes
00076
00079     //##ModelId=3C4C41B40132
00080     HBufC8*     iIdentifier;
00081
00084     //##ModelId=3C4C41B40128
00085     HBufC8*     iValue;
00086
00087     };
00088
00089 #include "CUnknownCapability.inl"
00090
00091 #endif  // __CUNKNOWNCAPABILITY_H__


CWspAliasAddresses.h File Reference

#include <e32base.h>
#include <wsp/mwspaliasaddresses.h>

Include dependency graph for CWspAliasAddresses.h:

Include dependency graph

Go to the source code of this file.

Compounds

class CWspAliasAddresses
The CWspAliasAddresses class represents a set of Alias Address capabilities. More...


CWspAliasAddresses.h Source File

CWspAliasAddresses.h

Go to the documentation of this file.
00001 // CWspAliasAddresses.h
00002 //
00003 // Copyright (C) 2001 Symbian Ltd
00004 //
00005
00006 #ifndef     __CWSPALIASADDRESSES_H__
00007 #define     __CWSPALIASADDRESSES_H__
00008
00009 #include <e32base.h>
00010 #include <wsp/mwspaliasaddresses.h>
00011
00012 class CAliasAddress;
00013
00018 //##ModelId=3C4C419D017D
00019 class CWspAliasAddresses : public CBase, public MWspAliasAddresses
00020     {
00021 public: // Methods
00022
00027     //##ModelId=3C4C419D01E1
00028     static CWspAliasAddresses* NewL();
00029
00034     //##ModelId=3C4C419D01DB
00035     ~CWspAliasAddresses();
00036
00037 public: // Methods from MWspAliasAddresses
00038
00042     //##ModelId=3C4C419D01DA
00043     virtual TInt Start() const;
00044
00048     //##ModelId=3C4C419D01CE
00049     virtual TInt GetNext(TWspBearer& aBearer, TUint16& aPort, TPtrC8& aAddress) const;
00050
00054     //##ModelId=3C4C419D01CD
00055     virtual void Reset();
00056
00060     //##ModelId=3C4C419D01C3
00061     virtual void AddAddressL(TWspBearer aBearer, TUint16 aPort, const TDesC8& aAddress);
00062
00063 private:    // Methods
00064
00069     //##ModelId=3C4C419D01BA
00070     CWspAliasAddresses();
00071
00072 private:    // Attributes
00073
00076     //##ModelId=3C4C419D01B1
00077     RPointerArray<CAliasAddress>        iAddresses;
00078
00082     //##ModelId=3C4C419D0195
00083     mutable TInt                        iIndex;
00084
00085     };
00086
00087 #endif  // __CWSPALIASADDRESSES_H__


CWspCapabilityInfo.h File Reference

#include <e32base.h>
#include <wsp/mwspcapabilityviewer.h>
#include <wsp/mwspcapabilitysetter.h>

Include dependency graph for CWspCapabilityInfo.h:

Include dependency graph

Go to the source code of this file.

Compounds

class CWspCapabilityInfo
The CWspCapabilityInfo class implements the MWspCapabilityViewer and MWspCapabilitySetter APIs. More...


CWspCapabilityInfo.h Source File

CWspCapabilityInfo.h

Go to the documentation of this file.
00001 // CWspCapabilityInfo.h
00002 //
00003 // Copyright (C) 2001 Symbian Ltd
00004 //
00005
00006 #ifndef __CWSPCAPABILITYINFO_H__
00007 #define __CWSPCAPABILITYINFO_H__
00008
00009 #include <e32base.h>
00010 #include <wsp/mwspcapabilityviewer.h>
00011 #include <wsp/mwspcapabilitysetter.h>
00012
00013 class CWspAliasAddresses;
00014 class CWspExtendedMethods;
00015 class CWspHeaderCodePages;
00016 class CWspUnknownCapabilities;
00017
00018 // Types used for arguments in this file (e.g. TWspBearer) are from the Wap namespace
00019 using namespace Wap;
00020
00026 //##ModelId=3C4C419F0099
00027 class CWspCapabilityInfo : public CBase, public MWspCapabilityViewer,
00028                                          public MWspCapabilitySetter
00029     {
00030 public: // Methods
00031
00038     //##ModelId=3C4C419F0252
00039     static CWspCapabilityInfo* NewL();
00040
00045     //##ModelId=3C4C419F0249
00046     ~CWspCapabilityInfo();
00047
00048 public: // Methods from MWspCapabilityViewer
00049
00053     //##ModelId=3C4C419F0248
00054     virtual const MWspAliasAddresses& GetAliasAddresses() const;
00055
00059     //##ModelId=3C4C419F0240
00060     virtual const MWspExtendedMethods& GetExtendedMethods() const;
00061
00065     //##ModelId=3C4C419F023F
00066     virtual const MWspHeaderCodePages& GetHeaderCodePages() const;
00067
00071     //##ModelId=3C4C419F023E
00072     virtual TUint8 GetMethodMOR() const;
00073
00077     //##ModelId=3C4C419F0235
00078     virtual TUint8 GetPushMOR() const;
00079
00083     //##ModelId=3C4C419F0234
00084     virtual TUint8 GetProtocolOptions() const;
00085
00089     //##ModelId=3C4C419F022B
00090     virtual TUint32 GetClientSDUSize() const;
00091
00095     //##ModelId=3C4C419F022A
00096     virtual TUint32 GetServerSDUSize() const;
00097
00101     //##ModelId=3C4C419F0221
00102     virtual TUint32 GetClientMessageSize() const;
00103
00107     //##ModelId=3C4C419F0220
00108     virtual TUint32 GetServerMessageSize() const;
00109
00113     //##ModelId=3C4C419F0216
00114     virtual const MWspUnknownCapabilities& GetUnknownCapabilities() const;
00115
00116 public: // Methods from MWspCapabilitySetter
00117
00121     //##ModelId=3C4C419F020C
00122     virtual void Reset(TWspCapability aCapability = EAllCapabilities);
00123
00127     //##ModelId=3C4C419F01E4
00128     virtual void AddAliasAddressL(TWspBearer aBearer, TUint16 aPort, const TDesC8& aAddress);
00129
00133     //##ModelId=3C4C419F01D0
00134     virtual void AddExtendedMethodL(TUint8 aPDUType, const TDesC8& aMethodName);
00135
00139     //##ModelId=3C4C419F01B2
00140     virtual void AddHeaderCodePageL(TUint8 aPageCode, const TDesC8& aPageName);
00141
00145     //##ModelId=3C4C419F01A8
00146     virtual void SetMethodMOR(TUint8 aMOR);
00147
00151     //##ModelId=3C4C419F019E
00152     virtual void SetPushMOR(TUint8 aMOR);
00153
00157     //##ModelId=3C4C419F018A
00158     virtual void SetProtocolOptions(TUint8 aProtocolOptions);
00159
00163     //##ModelId=3C4C419F0180
00164     virtual void SetClientSDUSize(TUint32 aSize);
00165
00169     //##ModelId=3C4C419F016C
00170     virtual void SetServerSDUSize(TUint32 aSize);
00171
00175     //##ModelId=3C4C419F0162
00176     virtual void SetClientMessageSize(TUint32 aSize);
00177
00181     //##ModelId=3C4C419F0158
00182     virtual void SetServerMessageSize(TUint32 aSize);
00183
00187     //##ModelId=3C4C419F013B
00188     virtual void AddUnknownCapabilityL(const TDesC8& aIdentifier, const TDesC8& aValue);
00189
00190 private:    // Methods
00191
00196     //##ModelId=3C4C419F013A
00197     CWspCapabilityInfo();
00198
00204     //##ModelId=3C4C419F0139
00205     void ConstructL();
00206
00207 private:    // Attributes
00208
00211     //##ModelId=3C4C419F012F
00212     CWspAliasAddresses*         iAliasAddresses;
00213
00216     //##ModelId=3C4C419F011D
00217     CWspExtendedMethods*        iExtendedMethods;
00218
00221     //##ModelId=3C4C419F0111
00222     CWspHeaderCodePages*        iHeaderCodePages;
00223
00226     //##ModelId=3C4C419F0107
00227     TUint8                      iMethodMOR;
00228
00231     //##ModelId=3C4C419F00F5
00232     TUint8                      iPushMOR;
00233
00236     //##ModelId=3C4C419F00EB
00237     TUint8                      iProtocolOptions;
00238
00241     //##ModelId=3C4C419F00DF
00242     TUint32                     iClientSDUSize;
00243
00246     //##ModelId=3C4C419F00CD
00247     TUint32                     iServerSDUSize;
00248
00251     //##ModelId=3C4C419F00C3
00252     TUint32                     iClientMessageSize;
00253
00256     //##ModelId=3C4C419F00B9
00257     TUint32                     iServerMessageSize;
00258
00261     //##ModelId=3C4C419F00B0
00262     CWspUnknownCapabilities*    iUnknownCapabilities;
00263
00264     };
00265
00266 #endif  // __CWSPCAPABILITYINFO_H__


CWspCOProtocolHandler.h File Reference

#include <e32base.h>
#include <http/framework/cprotocolhandler.h>
#include <wsp/mwspcosessioncallback.h>
#include <wsp/mwspcapabilityprovider.h>
#include <wsp/mwspsessionheadersprovider.h>
#include "mconnectiontimercallback.h"
#include "mwspprimitivesendercallback.h"
#include "mwspcomethodobserver.h"

Include dependency graph for CWspCOProtocolHandler.h:

Include dependency graph

Go to the source code of this file.

Compounds

class CWspCOProtocolHandler


CWspCOProtocolHandler.h Source File

CWspCOProtocolHandler.h

Go to the documentation of this file.
00001 // CWspCOProtocolHandler.h
00002 //
00003 // Copyright (c) Symbian Ltd 2001
00004 //
00005
00006 #ifndef __CWSPCOPROTOCOLHANDLER_H__
00007 #define __CWSPCOPROTOCOLHANDLER_H__
00008
00009 // System includes
00010 #include <e32base.h>
00011 #include <http/framework/cprotocolhandler.h>
00012 #include <wsp/mwspcosessioncallback.h>
00013 #include <wsp/mwspcapabilityprovider.h>
00014 #include <wsp/mwspsessionheadersprovider.h>
00015
00016 // User includes
00017 #include "mconnectiontimercallback.h"
00018 #include "mwspprimitivesendercallback.h"
00019 #include "mwspcomethodobserver.h"
00020
00021 // Forward declarations
00022 class CWspCapabilityInfo;
00023 class CWspProxyInfoProvider;
00024 class CWspTransportHandler;
00025 class MWspCOSessionInvoker;
00026 class MWspCOMethodInvoker;
00027 class CConnectionTimer;
00028 class CWspPrimitiveSender;
00029 class CRxData;
00030 class CWspHeaderUtils;
00031
00033 //##ModelId=3BBD7DB402C4
00034 class CWspCOProtocolHandler : public CProtocolHandler, public MWspCOSessionCallback,
00035                                                        public MWspCapabilityProvider,
00036                                                        public MWspSessionHeadersProvider,
00037                                                        public MConnectionTimerCallback,
00038                                                        public MWspPrimitiveSenderCallback,
00039                                                        public MWspCOMethodObserver
00040     {
00041 public: // Methods
00042
00051     //##ModelId=3C4C439101F4
00052     static CWspCOProtocolHandler* NewL(TAny* aSession);
00053
00058     //##ModelId=3C4C439101D6
00059   ~CWspCOProtocolHandler();
00060
00061 private:    // Methods from CProtocolHandler
00062
00066     //##ModelId=3C4C43910172
00067     virtual void CreateCodecL();
00068
00072     //##ModelId=3C4C439100BD
00073     virtual CProtTransaction* CreateProtTransactionL(RHTTPTransaction aTransaction);
00074
00078     //##ModelId=3C4C43910009
00079     virtual TBool ServiceL(CProtTransaction& aTrans);
00080
00084     //##ModelId=3C4C4390033D
00085     virtual void ClosedTransactionHook(CProtTransaction* aTrans);
00086
00090     //##ModelId=3C4C4390029D
00091     virtual void CancelTransactionHook(CProtTransaction& aTransaction);
00092
00096     //##ModelId=3C4C439001F2
00097     virtual void NotifyNewRequestBodyPart(CProtTransaction& aTransaction);
00098
00104     TInt SessionServerCert(TCertInfo& aServerCert);
00105
00112     TInt TransactionServerCert(TCertInfo& aServerCert, RHTTPTransaction aTransaction);
00113
00114 private:    // Methods from MHTTPFilterBase
00115
00119     //##ModelId=3C4C43900152
00120     virtual void MHFSessionRunL(const THTTPSessionEvent& aEvent);
00121
00125     //##ModelId=3C4C43900076
00126     virtual TInt MHFSessionRunError(TInt aError, const THTTPSessionEvent& aEvent);
00127
00128 private:    // Methods from MWspCOSessionCallback
00129
00133     //##ModelId=3C4C43900026
00134     virtual void ConnectCnf();
00135
00139     //##ModelId=3C4C438F03B4
00140     virtual void ResumeCnf();
00141
00145     //##ModelId=3C4C438F0223
00146     virtual void DisconnectInd(
00147                               TWspReason                aReason,
00148                               TBool                     aRedirectSecurity,
00149                               TWspRedirectedAddress&    aRedirectAddress,
00150                               const TDesC8&             aErrorHeader,
00151                               const TDesC8&             aErrorBody
00152                               );
00153
00157     //##ModelId=3C4C438F0197
00158     virtual void SuspendInd(TWspReason aReason);
00159
00163     //##ModelId=3C4C438F0115
00164     virtual void ExceptionInd(const TDesC8& aExceptionData);
00165
00166 private:    // Methods from MWspCapabilityProvider
00167
00171     //##ModelId=3C4C438F00CF
00172     virtual const MWspCapabilityViewer& ClientCapabilities() const;
00173
00177     //##ModelId=3C4C438F0092
00178     virtual MWspCapabilitySetter& ServerCapabilities() const;
00179
00180 private:    // Methods from MWspSessionHeadersProvider
00181
00185     //##ModelId=3C4C438F004C
00186     virtual const TDesC8& ClientHeaders() const;
00187
00191     //##ModelId=3C4C438E03C6
00192     virtual void SetServerHeadersL(const TDesC8& aBuffer);
00193
00194 private:    // Methods from MConnectionTimerCallback
00195
00199     //##ModelId=3C4C438E038A
00200     virtual void HandleConnectionTimedOut();
00201
00202 private:    // Methods from MWspPrimitiveSenderCallback
00203
00207     //##ModelId=3C4C438E0326
00208     virtual void SendPrimitiveL(TWspPrimitive aPrimitive);
00209
00213     //##ModelId=3C4C438E02C2
00214     virtual TInt WspPrimitiveSenderCallbackError(TInt aError);
00215
00216 private:    // Methods from MWspCOMethodObserver
00217
00221     //##ModelId=3C4C438E025E
00222     virtual void HandleMethodAbort(CWspCOTransaction& aTransaction);
00223
00227     virtual void NotifyPendingCompletingMethod();
00228
00232     virtual void NotifyMethodComplete();
00233
00234 private:    // Methods from MRxDataObserver, inherited via MWspCOMethodObserver
00235
00239     //##ModelId=3C4C438E01DC
00240     virtual void SetStatusL(CRxData& aRecv, TInt aStatus);
00241
00242 private:    // Methods
00243
00248     //##ModelId=3C4C438E013B
00249     CWspCOProtocolHandler(RHTTPSession aSession);
00250
00257     //##ModelId=3C4C438E0127
00258     void ConstructL();
00259
00270     //##ModelId=3C4C438E0109
00271     void SessionConnectL();
00272
00285     //##ModelId=3C4C438E00EB
00286     void SessionResumeL();
00287
00299     //##ModelId=3C4C438E00A5
00300     void SessionDisconnect(TWspReason aReason);
00301
00313     //##ModelId=3C4C438E0087
00314     void SessionSuspend();
00315
00322     //##ModelId=3C4C438E0073
00323     void DoSessionConnectedL();
00324
00332     void DoSessionConnected();
00333
00342     //##ModelId=3C4C438E0037
00343     void SendSessionEvent(THTTPSessionEvent aEvent);
00344
00355     //##ModelId=3C4C438D03BB
00356     void CreateWspTransportHandlerL();
00357
00366     //##ModelId=3C4C438D039D
00367     void UpdateClientSessionHeadersL();
00368
00377     //##ModelId=3C4C438D0389
00378     void CheckClientCapabilities();
00379
00395     //##ModelId=3C4C438D0375
00396     TBool UpdateNegotiatedCapabilitiesL();
00397
00404     //##ModelId=3C4C438D0361
00405     void HandleConnectRequestL();
00406
00412     //##ModelId=3C4C438D034D
00413     void HandleDisconnectRequest();
00414
00420     //##ModelId=3C4C438D0339
00421     void CheckWaitingMethod();
00422
00430     //##ModelId=3C4C438D0325
00431     TBool SupportSuspendResume() const;
00432
00441     //##ModelId=3C4C438D0311
00442     TBool CanResume() const;
00443
00451     //##ModelId=3C4C438D02F2
00452     TBool CanSuspend() const;
00453
00460     //##ModelId=3C4C438D02E8
00461     void ResetAll();
00462
00463 private:    // Attributes
00464
00467     //##ModelId=3C4C438D02CA
00468     CWspTransportHandler*       iTransportHandler;
00469
00473     //##ModelId=3C4C438D02B6
00474     MWspCOSessionInvoker*       iSessionInvoker;
00475
00479     //##ModelId=3C4C438D02A2
00480     CWspCapabilityInfo*         iNegotiatedCapInfo;
00481
00484     //##ModelId=3C4C438D0284
00485     CWspCapabilityInfo*         iClientCapInfo;
00486
00489     //##ModelId=3C4C438D0272
00490     CWspProxyInfoProvider*      iProxyInfoProvider;
00491
00494     //##ModelId=3C4C438D0266
00495     TWspSessionState            iSessionState;
00496
00501     //##ModelId=3C4C438D0252
00502     TInt                        iTimedOutValue;
00503
00506     //##ModelId=3C4C438D023E
00507     CConnectionTimer*           iConnectionTimer;
00508
00512     //##ModelId=3C4C438D022A
00513     CWspPrimitiveSender*        iPrimitiveSender;
00514
00517     //##ModelId=3C4C438D0218
00518     HBufC8*                     iClientSessionHeaders;
00519
00522     //##ModelId=3C4C438D020C
00523     TBool                       iConnectTimedOut;
00524
00528     //##ModelId=3C4C438D01F8
00529     TBool                       iWaitingMethod;
00530
00533     //##ModelId=3C4C438D01E4
00534     CWspHeaderUtils*            iHdrUtils;
00535
00539     TInt                        iPendingCompletingMethods;
00540
00543     TBool                       iDisconnectRequested;
00544
00545     };
00546
00547 #endif  // __CWSPCOPROTOCOLHANDLER_H__


CWspCORxData.h File Reference

#include <e32base.h>
#include <http/framework/crxdata.h>

Include dependency graph for CWspCORxData.h:

Include dependency graph

Go to the source code of this file.

Compounds

class CWspCORxData


CWspCORxData.h Source File

CWspCORxData.h

Go to the documentation of this file.
00001 // CWspCORxData.h
00002 //
00003 // Copyright (c) Symbian Ltd 2001
00004 //
00005
00006 #ifndef __CWSPCORXDATA_H__
00007 #define __CWSPCORXDATA_H__
00008
00009 // System includes
00010 #include <e32base.h>
00011 #include <http/framework/crxdata.h>
00012
00013 // Forward declarations
00014 class MWspCORxDataCallback;
00015
00016
00017 //##ModelId=3BBD80690108
00018 class CWspCORxData : public CRxData
00019     {
00020 public: // Methods
00021
00034     //##ModelId=3C4C41AD03E3
00035     static CWspCORxData* NewL(
00036                              CProtTransaction&      aTrasaction,
00037                              MRxDataObserver&       aObserver,
00038                              MWspCORxDataCallback&  aMethodCallback
00039                              );
00040
00045     //##ModelId=3C4C41AD03D9
00046     ~CWspCORxData();
00047
00081     //##ModelId=3C4C41AD0392
00082     void SetResponseDataL(const TDesC8& aResponseHeaders, MHTTPDataSupplier& aResponseBody, TBool aMoreResponseData);
00083
00123     //##ModelId=3C4C41AD036A
00124     void UpdateResponseDataL(const TDesC8& aTrailerHeaders, TBool aMoreResponseData);
00125
00126 private:    // Methods from CRxData
00127
00131     //##ModelId=3C4C41AD034C
00132     virtual void ResetRxData();
00133
00134 private:    // Methods from MHTTPDataSupplier
00135
00139     //##ModelId=3C4C41AD0324
00140     virtual TBool GetNextDataPart(TPtrC8& aDataPart);
00141
00145     //##ModelId=3C4C41AD0310
00146     virtual void ReleaseData();
00147
00151     //##ModelId=3C4C41AD02FC
00152     virtual TInt OverallDataSize();
00153
00157     //##ModelId=3C4C41AD02E8
00158     virtual TInt Reset();
00159
00160 private:    // Methods
00161
00171     //##ModelId=3C4C41AD02AC
00172     CWspCORxData(
00173                 CProtTransaction&       aTransaction,
00174                 MRxDataObserver&        aObserver,
00175                 MWspCORxDataCallback&   aMethodCallback
00176                 );
00177
00188     //##ModelId=3C4C41AD0298
00189     void SetHeaderDataL(const TDesC8& aResponseHeaders);
00190
00201     //##ModelId=3C4C41AD027A
00202     void SetBodyDataL(MHTTPDataSupplier& aResponseBody);
00203
00216     //##ModelId=3C4C41AD0266
00217     void UpdateHeaderDataL(const TDesC8& aTrailerHeaders);
00218
00226     //##ModelId=3C4C41AD025C
00227     void UpdateBodyDataL();
00228
00238     void ResponseCompleteL();
00239
00240 private:    // Attributes
00241
00244     //##ModelId=3C4C41AD0252
00245     MWspCORxDataCallback&   iMethodCallback;
00246
00249     //##ModelId=3C4C41AD0240
00250     MHTTPDataSupplier*      iBodyDataSupplier;
00251
00255     //##ModelId=3C4C41AD0236
00256     TBool                   iMoreData;
00257
00261     TBool                   iLastChunk;
00262
00265     //##ModelId=3C4C41AD022A
00266     TBool                   iGotBodyData;
00267
00271     //##ModelId=3C4C41AD0204
00272     TPtrC8                  iBodyData;
00273
00278     //##ModelId=3C4C41AD01F8
00279     TInt                    iOverallDataSize;
00280
00283     TBool                   iHasTrailer;
00284
00285     };
00286
00287 #endif  // __CWSPCORXDATA_H__


CWspCOTransaction.h File Reference

#include <e32base.h>
#include <wsp/mwspcomethodcallback.h>
#include <wsp/wsptypes.h>
#include <http/framework/cprottransaction.h>
#include <http/framework/httplogger.h>
#include "mwspprimitivesendercallback.h"
#include "mwspcorxdatacallback.h"
#include "mwspcotxdatacallback.h"
#include "cwspheaderutils.h"

Include dependency graph for CWspCOTransaction.h:

Include dependency graph

Go to the source code of this file.

Compounds

class CWspCOTransaction


CWspCOTransaction.h Source File

CWspCOTransaction.h

Go to the documentation of this file.
00001 // CWspCOTransaction.h
00002 //
00003 // Copyright (c) Symbian Ltd 2001
00004 //
00005
00006 #ifndef __CWSPCOTRANSACTION_H__
00007 #define __CWSPCOTRANSACTION_H__
00008
00009 // System includes
00010 #include <e32base.h>
00011 #include <wsp/mwspcomethodcallback.h>
00012 #include <wsp/wsptypes.h>
00013 #include <http/framework/cprottransaction.h>
00014 #include <http/framework/httplogger.h>
00015
00016 // User includes
00017 #include "mwspprimitivesendercallback.h"
00018 #include "mwspcorxdatacallback.h"
00019 #include "mwspcotxdatacallback.h"
00020 #include "cwspheaderutils.h"
00021
00022 // Forward declarations
00023 class MWspCapabilityViewer;
00024 class MWspCOMethodInvoker;
00025 class CWspPrimitiveSender;
00026 class MWspCOMethodObserver;
00027
00028 // Types used for arguments in this file (e.g. TWspBearer) are from the Wap namespace
00029 using namespace Wap;
00030
00032
00033 //##ModelId=3BBD80610048
00034 class CWspCOTransaction : public CProtTransaction, public MWspCOMethodCallback,
00035                                                    public MWspPrimitiveSenderCallback,
00036                                                    public MWspCORxDataCallback,
00037                                                    public MWspCOTxDataCallback
00038     {
00039 public: // Methods
00040
00055     //##ModelId=3C4C41A3032A
00056     static CWspCOTransaction* NewL(
00057                                    RHTTPTransaction         aTransaction,
00058                                    MWspCOMethodInvoker&     aMethodInvoker,
00059                                    MWspCapabilityViewer&    aNegotiatedCapInfo,
00060                                    MWspCOMethodObserver&    aObserver,
00061                                    CWspHeaderUtils&         aHdrUtils
00062                                    );
00063
00068     //##ModelId=3C4C41A3030C
00069     ~CWspCOTransaction();
00070
00075     void InitRequestL();
00076
00081     void NotifyMoreRequestData();
00082
00087     void AbortRequest();
00088
00108     //##ModelId=3C4C41A3029E
00109     void Suicide();
00110
00116     //##ModelId=3C4C41A30276
00117     CWspHeaderUtils& GetWspHeaderUtils() const;
00118
00119 private:    // Methods from CProtTransaction
00120
00124     //##ModelId=3C4C41A3023A
00125     virtual void CreateTxDataL();
00126
00130     //##ModelId=3C4C41A301D5
00131     virtual void CreateRxDataL(MRxDataObserver& aObserver);
00132
00133 private:    // Methods from MWspCOMethodCallback
00134
00138     //##ModelId=3C4C41A30199
00139     virtual void MethodInvokeCnf();
00140
00144     //##ModelId=3C4C41A30059
00145     virtual void MethodInvokeDataCnf();
00146
00150     //##ModelId=3C4C41A203E7
00151     virtual void MethodAbortInd(TWspReason aReason);
00152
00156     //##ModelId=3C4C41A2033D
00157     virtual void MethodResultInd(
00158                                 TInt                    aStatus,
00159                                 const TDesC8&           aResponseHeaders,
00160                                 MHTTPDataSupplier&      aResponseBody,
00161                                 TBool                   aMoreData
00162                                 );
00163
00167     //##ModelId=3C4C41A202EC
00168     virtual void MethodResultDataInd(const TDesC8& aTrailerHeaders, TBool aMoreData);
00169
00170 private:    // Methods from MWspPrimitiveSenderCallback
00171
00175     //##ModelId=3C4C41A2029C
00176     virtual void SendPrimitiveL(TWspPrimitive aPrimitive);
00177
00181     //##ModelId=3C4C41A20256
00182     virtual TInt WspPrimitiveSenderCallbackError(TInt aError);
00183
00184 private:    // Methods from MWspCORxDataCallback
00185
00189     //##ModelId=3C4C41A20210
00190     virtual void AbortResponse();
00191
00195     //##ModelId=3C4C41A201F2
00196     virtual void SendResponsePrimitive();
00197
00198 private:    // Methods from MWspCOTxDataCallback
00199
00205     virtual void SendInvokePrimitive();
00206
00211     virtual void AbortInvoke();
00212
00213 private:    // Methods
00214
00226     //##ModelId=3C4C41A20120
00227     CWspCOTransaction(
00228                       RHTTPTransaction          aTransaction,
00229                       MWspCOMethodInvoker&      aMethodInvoker,
00230                       MWspCapabilityViewer&     aNegotiatedCapInfo,
00231                       MWspCOMethodObserver&     aObserver,
00232                       CWspHeaderUtils&          aHdrUtils
00233                       );
00234
00241     //##ModelId=3C4C41A20116
00242     void ConstructL();
00243
00254     //##ModelId=3C4C41A302F8
00255     void MethodInvoke();
00256
00265     //##ModelId=3C4C41A302D0
00266     void MethodInvokeData();
00267
00277     //##ModelId=3C4C41A302BC
00278     void MethodAbort();
00279
00291     void MethodResultRes();
00292
00304     void MethodResultDataRes();
00305
00318     void ProcessResponseDataL(const TDesC8& aResponseHeaders, MHTTPDataSupplier& aResponseBody, TBool aMoreData);
00319
00332     void PostResProcessing();
00333
00339     //##ModelId=3C4C41A20057
00340     void ResetFlags();
00341
00342 private:    // Attributes
00343
00346     __DECLARE_LOG
00347
00351     //##ModelId=3C4C41A2004D
00352     MWspCOMethodInvoker&        iMethodInvoker;
00353
00357     //##ModelId=3C4C41A20039
00358     MWspCapabilityViewer&       iNegotiatedCapInfo;
00359
00362     //##ModelId=3C4C41A20025
00363     MWspCOMethodObserver&       iObserver;
00364
00367     //##ModelId=3C4C438001E5
00368     CWspHeaderUtils&            iHdrUtils;
00369
00372     //##ModelId=3C4C41A20007
00373     TWspMethodState             iMethodState;
00374
00378     //##ModelId=3C4C41A103DB
00379     TBool                       iMoreRequestData;
00380
00383     TBool                       iSentMethodResultRes;
00384
00387     //##ModelId=3C4C41A1039F
00388     TBool                       iClientMethodAbort;
00389
00393     TBool                       iFinalResPending;
00394
00399     //##ModelId=3C4C41A10383
00400     TBool                       iSuicide;
00401
00405     //##ModelId=3C4C41A10377
00406     CWspPrimitiveSender*        iPrimitiveSender;
00407
00408     };
00409
00410 #endif  // __CWSPCOTRANSACTION_H__


CWspCOTxData.h File Reference

#include <e32base.h>
#include <http/framework/ctxdata.h>

Include dependency graph for CWspCOTxData.h:

Include dependency graph

Go to the source code of this file.

Compounds

class CWspCOTxData


CWspCOTxData.h Source File

CWspCOTxData.h

Go to the documentation of this file.
00001 // CWspCOTxData.h
00002 //
00003 // Copyright (c) Symbian Ltd 2001
00004 //
00005
00006 #ifndef __CWSPCOTXDATA_H__
00007 #define __CWSPCOTXDATA_H__
00008
00009 // System includes
00010 #include <e32base.h>
00011 #include <http/framework/ctxdata.h>
00012
00013 // Forward declarations
00014 class MWspCOTxDataCallback;
00015 class MWspCapabilityViewer;
00016 class MHTTPDataSupplier;
00017
00019
00020 //##ModelId=3BBD80700021
00021 class CWspCOTxData : public CTxData
00022     {
00023 public: // Methods
00024
00037     //##ModelId=3C4C41A801D3
00038     static CWspCOTxData* NewL(
00039                              CProtTransaction&      aTransaction,
00040                              MWspCOTxDataCallback&  aObserver,
00041                              MWspCapabilityViewer&  aNegotiatedCapInfo
00042                              );
00043
00048     //##ModelId=3C4C41A801C9
00049     ~CWspCOTxData();
00050
00057     //##ModelId=3C4C41A801B5
00058     const TDesC8& RequestHeadersData();
00059
00068     //##ModelId=3C4C41A801AB
00069     MHTTPDataSupplier& RequestBodyData();
00070
00076     //##ModelId=3C4C41A80197
00077     void SetRequestDataL();
00078
00094     void ReceivedCnf();
00095
00101     //##ModelId=3C4C41A80179
00102     void NotifyMoreRequestData();
00103
00104 private:    // Methods from MHTTPDataSupplier
00105
00109     //##ModelId=3C4C41A8013C
00110     virtual TBool GetNextDataPart(TPtrC8& aDataPart);
00111
00115     //##ModelId=3C4C41A80128
00116     virtual void ReleaseData();
00117
00121     //##ModelId=3C4C41A80114
00122     virtual TInt OverallDataSize();
00123
00127     //##ModelId=3C4C41A80100
00128     virtual TInt Reset();
00129
00130 private:    // Methods
00131
00141     //##ModelId=3C4C41A8009C
00142     CWspCOTxData(
00143                 CProtTransaction&       aTransaction,
00144                 MWspCOTxDataCallback&   aObserver,
00145                 MWspCapabilityViewer&   aNegotiatedCapInfo
00146                 );
00147
00157     //##ModelId=3C4C41A80056
00158     void SetSessionPropertyL(TInt aProperty, THTTPHdrVal aFieldValue);
00159
00168     //##ModelId=3C4C41A8002E
00169     void SetHeaderDataL(RHTTPRequest aRequest);
00170
00179     //##ModelId=3C4C41A80006
00180     void EncodeHeadersL(RHTTPHeaders aHeaders);
00181
00190     //##ModelId=3C4C41A703D0
00191     void SetBodyDataL(MHTTPDataSupplier& aRequestBody);
00192
00200     //##ModelId=3C4C41A703C6
00201     void UpdateBodyData();
00202
00213     //##ModelId=3C4C41A70394
00214     TInt CalculateUIntVarLength(TUint32 aUint);
00215
00220     void UpdateState();
00221
00226     void CheckTrailer();
00227
00232     void DecideObserverAction();
00233
00238     void Cleanup();
00239
00240 private:    // Enums
00241
00245     enum TRequestState
00246         {
00249         EIdle                   = 0,
00252         EDone,
00255         EGotMoreData,
00258         EWaitForMoreData,
00261         EAbortMethod
00262         };
00263
00264 private:    // Attributes
00265
00268     TRequestState           iState;
00269
00272     //##ModelId=3C4C41A7038A
00273     MWspCOTxDataCallback&   iObserver;
00274
00277     //##ModelId=3C4C41A70376
00278     MWspCapabilityViewer&   iNegotiatedCapInfo;
00279
00282     //##ModelId=3C4C41A70362
00283     MHTTPDataSupplier*      iBodyDataSupplier;
00284
00287     //##ModelId=3C4C41A70350
00288     HBufC8*                 iHeaderData;
00289
00292     //##ModelId=3C4C41A70344
00293     HBufC8*                 iTrailerData;
00294
00297     HBufC8*                 iBodyData;
00298
00301     //##ModelId=3C4C41A70312
00302     TBool                   iHasTrailer;
00303
00307     //##ModelId=3C4C41A702F4
00308     TBool                   iRequestComplete;
00309
00312     //##ModelId=3C4C41A702D6
00313     TBool                   iGotBodyData;
00314
00318     //##ModelId=3C4C41A702C4
00319     TPtrC8                  iDataPart;
00320
00325     //##ModelId=3C4C41A702B8
00326     TInt                    iOverallDataSize;
00327
00330     //##ModelId=3C4C41A702A6
00331     TUint32                 iRemainingSDUSpace;
00332
00335     //##ModelId=3C4C41A7029A
00336     TUint32                 iRemainingMessageSpace;
00337
00340     //##ModelId=3C4C41A70287
00341     TBool                   iSupportLDT;
00342
00345     TUint32                 iTrailerInfoLength;
00346
00349     TBool                   iLimitedMessageSize;
00350
00351     };
00352
00353 #endif  // __CWSPCOTXDATA_H__


CWspExtendedMethods.h File Reference

#include <e32base.h>
#include <wsp/mwspextendedmethods.h>

Include dependency graph for CWspExtendedMethods.h:

Include dependency graph

Go to the source code of this file.

Compounds

class CWspExtendedMethods
The CWspExtendedMethods class represents a set of Extended Methods capabilities. More...


CWspExtendedMethods.h Source File

CWspExtendedMethods.h

Go to the documentation of this file.
00001 // CWspExtendedMethods.h
00002 //
00003 // Copyright (c) Symbian Ltd 2001
00004 //
00005
00006 #ifndef __CWSPEXTENDEDMETHODS_H__
00007 #define __CWSPEXTENDEDMETHODS_H__
00008
00009 #include <e32base.h>
00010 #include <wsp/mwspextendedmethods.h>
00011
00012 class CExtendedMethod;
00013
00018 //##ModelId=3C4C419D03CC
00019 class CWspExtendedMethods : public CBase, public MWspExtendedMethods
00020     {
00021 public: // Methods
00022
00027     //##ModelId=3C4C419E003F
00028     static CWspExtendedMethods* NewL();
00029
00034     //##ModelId=3C4C419E003E
00035     ~CWspExtendedMethods();
00036
00037 public: // Methods from MWspExtendedMethods
00038
00042     //##ModelId=3C4C419E0037
00043     virtual TInt Start() const;
00044
00048     //##ModelId=3C4C419E0034
00049     virtual TInt GetNext(TUint8& aPDUType, TPtrC8& aMethodName) const;
00050
00054     //##ModelId=3C4C419E002D
00055     virtual void Reset();
00056
00060     //##ModelId=3C4C419E002A
00061     virtual void AddExtendedMethodL(TUint8 aPDUType, const TDesC8& aMethodName);
00062
00063 private:    // Methods
00064
00069     //##ModelId=3C4C419E0021
00070     CWspExtendedMethods();
00071
00072 private:    // Attributes
00073
00076     //##ModelId=3C4C419E0018
00077     RPointerArray<CExtendedMethod>      iMethods;
00078
00082     //##ModelId=3C4C419D03E4
00083     mutable TInt                        iIndex;
00084
00085     };
00086
00087 #endif  // __CWSPEXTENDEDMETHODS_H__


CWspHeaderCodec.h File Reference

#include <e32std.h>
#include <http.h>
#include <http/framework/cheadercodec.h>

Include dependency graph for CWspHeaderCodec.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | CWspDefaultHeaderCodec
@dependancies CHeaderCodec, RStringPool, RStringF
Since:
7.0 This class is the default WSP Header Codec that is used if no codec can encode/ decode a particular header.
 More...

class | CWspHeaderCodec
@dependancies CHeaderCodec, RStringPool, RStringF
Since:
7.0 This class is the WSP specific header codec that is required to encode and decode WSP headers between a usable form and the form required for transport.
 More...


CWspHeaderCodec.h Source File

CWspHeaderCodec.h

Go to the documentation of this file.
00001 //
00002 // CWspHeaderCodec.h
00003 //
00004 // Copyright (C) 2001 Symbian Ltd
00005 //
00006
00007 #ifndef __CWSPHEADERCODEC_H__
00008 #define __CWSPHEADERCODEC_H__
00009
00010 // System Includes
00011 #include <e32std.h>
00012 #include <http.h>
00013 #include <http/framework/cheadercodec.h>
00014
00015
00027 //##ModelId=3C4C41B30305
00028 class CWspHeaderCodec : public CHeaderCodec
00029     {
00030 public: // enums
00036     enum TWspVersion
00037         {
00038         EVersion1_1, // Version 1.1
00039         EVersion1_2, // Version 1.2
00040         EVersion1_3, // Version 1.3
00041         EVersion1_4  // Version 1.4
00042         };
00043
00044 public: // methods
00045
00059     //##ModelId=3C4C41B3037D
00060     static CWspHeaderCodec* NewL(RStringPool aStrPool, const TStringTable& aStrTable);
00061
00069     //##ModelId=3C4C41B30375
00070     virtual ~CWspHeaderCodec();
00071
00080     //##ModelId=3C4C41B30373
00081     virtual TBool CanEncode(RStringF aHeaderField) const;
00082
00091     //##ModelId=3C4C41B3036A
00092     virtual TBool CanDecode(RStringF aHeaderField) const;
00093
00105     //##ModelId=3C4C41B30360
00106     virtual CHeaderCodec* FindDelegateCodecL(RStringF aHeaderField) const;
00107
00115     //##ModelId=3C4C41B3035F
00116     TWspVersion GetWspVersion() const;
00117
00126     //##ModelId=3C4C41B30357
00127     void SetWspVersion(TWspVersion aWspVersion);
00128
00140     //##ModelId=3C4C41B30355
00141     TInt EncodeFieldName(RStringF aFieldName) const;
00142
00143 protected: // methods
00144
00156     //##ModelId=3C4C41B30342
00157     CWspHeaderCodec(RStringPool aStrPool, const TStringTable& aStrTable);
00158
00169     //##ModelId=3C4C41B30341
00170     void ConstructL();
00171
00172 private: // methods
00173
00182     //##ModelId=3C4C41B3034D
00183     CWspHeaderCodec();
00184
00185 private: // attributes
00186
00188     //##ModelId=3C4C41B30339
00189     RStringPool iStrPool;
00190
00192     //##ModelId=3C4C41B3032D
00193     const TStringTable& iStrTable;
00194
00196     //##ModelId=3C4C41B3031C
00197     TWspVersion iWspVersion;
00198     };
00199
00210 class CWspDefaultHeaderCodec : public CHeaderCodec
00211     {
00212 public:
00213
00226     static CWspDefaultHeaderCodec* NewL(RStringPool aStrPool);
00227
00235     virtual ~CWspDefaultHeaderCodec();
00236
00247     virtual TBool CanEncode(RStringF aHeaderField) const;
00248
00259     virtual TBool CanDecode(RStringF aHeaderField) const;
00260
00272     virtual CHeaderCodec* FindDelegateCodecL(RStringF aHeaderField) const;
00273
00274 protected: // methods
00275
00286     CWspDefaultHeaderCodec(RStringPool aStrPool);
00287
00298     void ConstructL();
00299
00300 private:// methods
00301
00310     CWspDefaultHeaderCodec();
00311
00312 private: // attributes
00313
00315     RStringPool iStrPool;
00316     };
00317
00318 #endif // __CWSPHEADERCODEC_H__


CWspHeaderCodePages.h File Reference

#include <e32base.h>
#include <wsp/mwspheadercodepages.h>

Include dependency graph for CWspHeaderCodePages.h:

Include dependency graph

Go to the source code of this file.

Compounds

class CWspHeaderCodePages
The CWspHeaderCodePages class represents a set of Extended Methods capabilities. More...


CWspHeaderCodePages.h Source File

CWspHeaderCodePages.h

Go to the documentation of this file.
00001 // CWspHeaderCodePages.h
00002 //
00003 // Copyright (c) Symbian Ltd 2001
00004 //
00005
00006 #ifndef __CWSPHEADERCODEPAGES_H__
00007 #define __CWSPHEADERCODEPAGES_H__
00008
00009 #include <e32base.h>
00010 #include <wsp/mwspheadercodepages.h>
00011
00012 class CHeaderCodePage;
00013
00018 //##ModelId=3C4C41B201CD
00019 class CWspHeaderCodePages : public CBase, public MWspHeaderCodePages
00020     {
00021 public: // Methods
00022
00027     //##ModelId=3C4C41B20232
00028     static CWspHeaderCodePages* NewL();
00029
00034     //##ModelId=3C4C41B20231
00035     ~CWspHeaderCodePages();
00036
00037 public: // Methods from MWspHeaderCodePages
00038
00042     //##ModelId=3C4C41B2022A
00043     virtual TInt Start() const;
00044
00048     //##ModelId=3C4C41B20227
00049     virtual TInt GetNext(TUint8& aPageCode, TPtrC8& aPageName) const;
00050
00054     //##ModelId=3C4C41B2021F
00055     virtual void Reset();
00056
00060     //##ModelId=3C4C41B20215
00061     virtual void AddHeaderCodePageL(TUint8 aPageCode, const TDesC8& aPageName);
00062
00063 private:    // Methods
00064
00069     //##ModelId=3C4C41B20214
00070     CWspHeaderCodePages();
00071
00072 private:    // Attributes
00073
00076     //##ModelId=3C4C41B2020B
00077     RPointerArray<CHeaderCodePage>      iCodePages;
00078
00082     //##ModelId=3C4C41B201EB
00083     mutable TInt                        iIndex;
00084
00085     };
00086
00087 #endif  // __CWSPHEADERCODEPAGES_H__


CWspHeaderReader.h File Reference

#include <e32std.h>
#include <wspdecoder.h>
#include <http/framework/cheadercodec.h>
#include "cwspheadercodec.h"

Include dependency graph for CWspHeaderReader.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | CWspDefaultHdrReader
@dependancies CHeaderCodec, CHeaderReader, CHeaderFieldPart, RStringPool, RStringF
Since:
7.0 This class is the by the WSP header codec to provide the decoding functionality required by WSP to decode header fields from a raw binary format to a useful parsed format.
 More...

class | CWspHeaderReader
@dependancies CHeaderCodec, CHeaderReader, CHeaderFieldPart, RStringPool, RStringF
Since:
7.0 This class is the by the WSP header codec to provide the decoding functionality required by WSP to decode header fields from a raw binary format to a useful parsed format.
 More...


CWspHeaderReader.h Source File

CWspHeaderReader.h

Go to the documentation of this file.
00001 //
00002 // CWspHeaderReader.h
00003 //
00004 // Copyright (C) 2001 Symbian Ltd
00005 //
00006
00007 #ifndef __CWSPHEADERREADER_H__
00008 #define __CWSPHEADERREADER_H__
00009
00010 // System Includes
00011 #include <e32std.h>
00012 #include <wspdecoder.h>
00013 #include <http/framework/cheadercodec.h>
00014
00015 // User Includes
00016 #include "cwspheadercodec.h"
00017
00018 // Forward declarations
00019 class CHeaderFieldPart;
00020 class CHeaderFieldParam;
00021
00022
00032 //##ModelId=3C4C41AB029F
00033 class CWspHeaderReader : public CHeaderReader
00034     {
00035 public: // methods
00036
00045     //##ModelId=3C4C41AC0108
00046     virtual ~CWspHeaderReader();
00047
00062     //##ModelId=3C4C41AC00FD
00063     static CWspHeaderReader* NewL(RStringPool aStrPool, const TStringTable& aStrTable, CWspHeaderCodec& aCodec);
00064
00079     //##ModelId=3C4C41AC00F3
00080     static CWspHeaderReader* NewLC(RStringPool aStrPool, const TStringTable& aStrTable, CWspHeaderCodec& aCodec);
00081
00095     //##ModelId=3C4C41AC00EA
00096     virtual void DecodeHeaderL(RHeaderField& aHeader);
00097
00098 protected: // methods
00099
00112     //##ModelId=3C4C41AC00DF
00113     CWspHeaderReader(RStringPool aStrPool, const TStringTable& aStrTable, CWspHeaderCodec& aCodec);
00114
00115 private: // methods
00116
00119     //##ModelId=3C4C41AC00D6RS
00120     void DecodeContentTypeL(RHeaderField& aHeader) const;
00121
00124     //##ModelId=3C4C41AC00D4
00125     void DecodeDateL(RHeaderField& aHeader) const;
00126
00129     //##ModelId=3C4C41AC00CC
00130     void DecodeLastModifiedL(RHeaderField& aHeader) const;
00131
00134     //##ModelId=3C4C41AC00CA
00135     void DecodePragmaL(RHeaderField& aHeader) const;
00136
00139     //##ModelId=3C4C41AC00C1
00140     void DecodeVaryL(RHeaderField& aHeader) const;
00141
00144     //##ModelId=3C4C41AC00B8
00145     void DecodeWWWAuthenticateL(RHeaderField& aHeader) const;
00146
00149     //##ModelId=3C4C41AC00B6
00150     void DecodeSetCookieL(RHeaderField& aHeader) const;
00151
00154     //##ModelId=3C4C41AC00AC
00155     void DecodeContentLocationL(RHeaderField& aHeader) const;
00156
00159     //##ModelId=3C4C41AC00A4
00160     void DecodeLocationL(RHeaderField& aHeader) const;
00161
00164     //##ModelId=3C4C41AC00A2
00165     void DecodeEncodingVersionL(RHeaderField& aHeader) const;
00166
00169     //##ModelId=3C4C41AC0099
00170     void DecodeAcceptRangesL(RHeaderField& aHeader) const;
00171
00174     //##ModelId=3C4C41AC0090
00175     void DecodeContentEncodingL(RHeaderField& aHeader) const;
00176
00179     //##ModelId=3C4C41AC008E
00180     void DecodeContentLanguageL(RHeaderField& aHeader) const;
00181
00184     //##ModelId=3C4C41AC0085
00185     void DecodeContentMD5L(RHeaderField& aHeader) const;
00186
00189     //##ModelId=3C4C41AC007C
00190     void DecodeProxyAuthenticateL(RHeaderField& aHeader) const;
00191
00194     //##ModelId=3C4C41AC007A
00195     void DecodeServerL(RHeaderField& aHeader) const;
00196
00199     //##ModelId=3C4C41AC0071
00200     void DecodeRetryAfterL(RHeaderField& aHeader) const;
00201
00204     //##ModelId=3C4C41AC0068
00205     void DecodeViaL(RHeaderField& aHeader) const;
00206
00209     //##ModelId=3C4C41AC0066
00210     void DecodeTrailerL(RHeaderField& aHeader) const;
00211
00214     //##ModelId=3C4C41AC005E
00215     void DecodeContentRangeL(RHeaderField& aHeader) const;
00216
00219     //##ModelId=3C4C41AC005C
00220     void DecodeXWapApplicationIdL(RHeaderField& aHeader) const;
00221
00224     //##ModelId=3C4C41AC0053
00225     void DecodeXWapInitiatorURIL(RHeaderField& aHeader) const;
00226
00229     //##ModelId=3C4C41AC0049
00230     void DecodePushFlagL(RHeaderField& aHeader) const;
00231
00234     //##ModelId=3C4C41AC0040
00235     void DecodeAllowL(RHeaderField& aHeader) const;
00236
00239     //##ModelId=3C4C41AC003E
00240     void DecodeUpgradeL(RHeaderField& aHeader) const;
00241
00244     //##ModelId=3C4C41AC0035
00245     void DecodeWarningL(RHeaderField& aHeader) const;
00246
00247 // utility helper methods
00248
00251     //##ModelId=3C4C41AC002C
00252     void DecodeGenericWarnCodeL(RHeaderField& aHeader, TWspPrimitiveDecoder& aDecoder) const;
00253
00256     //##ModelId=3C4C41AB03CE
00257     TBool CheckForNullStringL(TPtrC8& aRawData, TInt& aBytesRead, TWspPrimitiveDecoder& aDecoder) const;
00258
00261     //##ModelId=3C4C41AB03C3
00262     void DecodeGenericVersionL(RHeaderField& aHeader, TWspPrimitiveDecoder& aDecoder, TInt aIndex) const;
00263
00266     //##ModelId=3C4C41AB03B9
00267     inline void CheckLengthL(TPtrC8& aRawData, TInt aMinLength) const;
00268
00271     //##ModelId=3C4C41AB03AE
00272     TBool CheckNullDesPartL(RHeaderField& aHeader, TPtrC8& aRawData, TInt aPartIndex) const;
00273
00276     //##ModelId=3C4C41AB039C
00277     TInt AddNewDecoderStringPartL(RHeaderField& aHeader, TWspPrimitiveDecoder& aDecoder, TInt aIndex=0) const;
00278
00279 // generic encoding methods
00280
00283     //##ModelId=3C4C41AB039A
00284     void DecodeGenericIntegerValueL(RHeaderField& aHeader) const;
00285
00288     //##ModelId=3C4C41AB0390
00289     void DecodeGenericNewStringValueL(RHeaderField& aHeader) const;
00290
00293     //##ModelId=3C4C41AB0387
00294     void DecodeGenericDateValueL(RHeaderField& aHeader) const;
00295
00298     //##ModelId=3C4C41AB037E
00299     void DecodeGenericFieldNameL(RHeaderField& aHeader) const;
00300
00303     //##ModelId=3C4C41AB0374
00304     TInt DecodeGenericSingleParameterL(TPtrC8& aRawParam, CHeaderFieldPart& aHeaderFieldPart) const;
00305
00308     //##ModelId=3C4C41AB0368
00309     void DecodeWellKnownParamTokenL(TWspPrimitiveDecoder& aDecoder, TInt& aBytesRead,
00310                                     TPtrC8& aRawParamBlock, CHeaderFieldPart& aHeaderFieldPart) const;
00311
00314     //##ModelId=3C4C41AB0355
00315     void DecodeUntypedParamL(TWspPrimitiveDecoder& aDecoder, TInt& aBytesRead,
00316                                     TPtrC8& aRawParamBlock, CHeaderFieldPart& aHeaderFieldPart) const;
00317
00320     //##ModelId=3C4C41AB034A
00321     TInt DecodeGenericParamTokenL(TWspPrimitiveDecoder& aDecoder, const TStringTable& aStrTable,
00322                               THTTPHdrVal& aParamValue, RStringF& aParamDesValue) const;
00323
00326     //##ModelId=3C4C41AB033F
00327     void GetCharacterSetFromValueL(TInt aValue, RStringF& aCharSetStr) const;
00328
00331     //##ModelId=3C4C41AB0335
00332     void DecodeGenericChallengeL(RHeaderField& aHeader) const;
00333
00334 // generic part methods
00335
00338     //##ModelId=3C4C41AB032B
00339     CHeaderFieldPart& SetNewPartL(RHeaderField& aHeader, TInt aPartIndex, THTTPHdrVal& aPartVal) const;
00340
00343     //##ModelId=3C4C41AB0318
00344     CHeaderFieldPart& SetNewIntegerPartL(RHeaderField& aHeader, TInt aPartIndex, TInt aValue) const;
00345
00348     //##ModelId=3C4C41AB030D
00349     CHeaderFieldPart& SetNewFStringPartL(RHeaderField& aHeader, TInt aPartIndex, TPtrC8 aValue) const;
00350
00353     //##ModelId=3C4C41AB02FB
00354     CHeaderFieldPart& SetNewStringPartL(RHeaderField& aHeader, TInt aPartIndex, TPtrC8 aValue) const;
00355
00358     //##ModelId=3C4C41AB02F0
00359     CHeaderFieldPart& SetFStringPartL(RHeaderField& aHeader, TInt aPartIndex, RStringF aStrVal) const;
00360
00363     //##ModelId=3C4C41AB02E5
00364     CHeaderFieldPart& SetNewDatePartL(RHeaderField& aHeader, TInt aPartIndex, TDateTime& aValue) const;
00365
00368     //##ModelId=3C4C41AB02D1
00369     CHeaderFieldParam& SetNewParamL(CHeaderFieldPart& aHeaderPart, TPtrC8 aParamName, THTTPHdrVal aParamValue) const;
00370
00371 private: // attributes
00372
00375     //##ModelId=3C4C41AB02C9
00376     RStringPool iStrPool;
00377
00380     //##ModelId=3C4C41AB02BF
00381     const TStringTable& iStrTable;
00382
00385     //##ModelId=3C4C41AB02B3
00386     CWspHeaderCodec& iCodec;
00387     };
00388
00389 inline void CWspHeaderReader::CheckLengthL(TPtrC8& aRawData, TInt aMinLength) const
00390     {
00391     if(aRawData.Length() < aMinLength)
00392         User::Leave(KErrCorrupt);
00393     }
00394
00405 class CWspDefaultHdrReader : public CHeaderReader
00406     {
00407 public: // methods
00408
00417     //##ModelId=3C4C41AC0108
00418     virtual ~CWspDefaultHdrReader();
00419
00432     static CWspDefaultHdrReader* NewL(RStringPool aStrPool);
00433
00446     static CWspDefaultHdrReader* NewLC(RStringPool aStrPool);
00447
00461     virtual void DecodeHeaderL(RHeaderField& aHeader);
00462
00463 protected: // methods
00464
00475     //##ModelId=3C4C41AC00DF
00476     CWspDefaultHdrReader(RStringPool aStrPool);
00477
00478 private: // attributes
00479
00481     RStringPool iStrPool;
00482     };
00483
00484 #endif // __CWSPHEADERREADER_H__


CWspHeaderUtils.h File Reference

#include <e32base.h>
#include <stringpool.h>
#include "http/rhttpheaders.h"
#include "cwspheadercodec.h"

Include dependency graph for CWspHeaderUtils.h:

Include dependency graph

Go to the source code of this file.

Compounds

class CWspHeaderUtils


CWspHeaderUtils.h Source File

CWspHeaderUtils.h

Go to the documentation of this file.
00001 // CWspHeaderUtils.h
00002 //
00003 // Copyright (c) Symbian Ltd 2001
00004 //
00005
00006 #ifndef __CWSPHEADERUTILS_H__
00007 #define __CWSPHEADERUTILS_H__
00008
00009 #include <e32base.h>
00010 #include <stringpool.h>
00011
00012 #include "http/rhttpheaders.h"
00013 #include "cwspheadercodec.h"
00014
00016
00017 //##ModelId=3C022B5D02CD
00018 class CWspHeaderUtils : public CBase
00019     {
00020 public: // Methods
00021
00022     //##ModelId=3C4C438502DE
00023     static CWspHeaderUtils* NewL(CWspHeaderCodec& aCodec);
00024
00025     //##ModelId=3C4C438502DD
00026     ~CWspHeaderUtils();
00027
00028     //##ModelId=3C022B6E01CD
00029     HBufC8* EncodeHeadersL(RStringPool aStringPool, RHTTPHeaders aHeaders);
00030
00031     //##ModelId=3C4C438502B5
00032     HBufC8* EncodeNoTrailerHeadersL(RStringPool aStringPool, RHTTPHeaders aHeaders, HBufC8*& iTrailerData);
00033
00034     //##ModelId=3C4C4385028D
00035     void DecodeReplyHeadersL(RStringPool aStringPool, const TDesC8& aEncodedData, RHTTPHeaders& aHeaders);
00036
00037     //##ModelId=3C4C43850265
00038     void DecodeHeadersL(RStringPool aStringPool, const TDesC8& aEncodedData, RHTTPHeaders& aHeaders);
00039
00040 private:    // Methods
00041
00042     //##ModelId=3C4C43850252
00043     CWspHeaderUtils(CWspHeaderCodec& aCodec);
00044
00045     //##ModelId=3C4C43850233
00046     TBool EncodeContentTypeL(RStringPool aStringPool, RHTTPHeaders aHeaders, HBufC8*& aBuf);
00047
00048     //##ModelId=3C4C43850215
00049     void EncodeHeaderFieldL(RHTTPHeaders aHeaders, RStringF aHeaderField, HBufC8*& aBuf);
00050
00051     //##ModelId=3C4C43850201
00052     TBool IsTrailerHeader(RArray<RStringF> aTrailerHeaders, RStringF aHeaderField);
00053
00054 private:    // Attributes
00055
00056     //##ModelId=3C4C438501F9
00057     CWspHeaderCodec& iCodec;
00058     };
00059
00060 #endif  // __CWSPHEADERUTILS_H__


CWspHeaderWriter.h File Reference

#include <e32std.h>
#include <wspencoder.h>
#include <http/framework/cheadercodec.h>
#include "cwspheadercodec.h"

Include dependency graph for CWspHeaderWriter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | CWspDefaultHdrWriter
@public @dependancies CHeaderWriter, CWspHeaderCodec, RStringPool, RHeaderField
Since:
7.0 This class provides the encoding functionality for headers that are supported by the WSP Header Codec.
 More...

class | CWspHeaderWriter
@public @dependancies CHeaderWriter, CWspHeaderCodec, RStringPool, RHeaderField
Since:
7.0 This class provides the encoding functionality for encoding all of the supported headers.
 More...


CWspHeaderWriter.h Source File

CWspHeaderWriter.h

Go to the documentation of this file.
00001 //
00002 // CWspHeaderWriter.h
00003 //
00004 // Copyright (C) 2001 Symbian Ltd
00005 //
00006
00007 #ifndef __CWSPHEADERWRITER_H__
00008 #define __CWSPHEADERWRITER_H__
00009
00010 // System Includes
00011 #include <e32std.h>
00012 #include <wspencoder.h>
00013 #include <http/framework/cheadercodec.h>
00014
00015 // User Includes
00016 #include "cwspheadercodec.h"
00017
00018 // Forward declarations
00019 class CHeaderFieldParam;
00020
00030 //##ModelId=3C4C41A600FD
00031 class CWspHeaderWriter : public CHeaderWriter
00032     {
00033 public: // methods
00034
00043     //##ModelId=3C4C41A6027C
00044     virtual ~CWspHeaderWriter();
00045
00059     //##ModelId=3C4C41A60272
00060     static CWspHeaderWriter* NewL(RStringPool aStrPool, const TStringTable& aStrTable, CWspHeaderCodec& aCodec);
00061
00075     //##ModelId=3C4C41A60267
00076     static CWspHeaderWriter* NewLC(RStringPool aStrPool, const TStringTable& aStrTable, CWspHeaderCodec& aCodec);
00077
00091     //##ModelId=3C4C41A6025E
00092     virtual void EncodeHeaderL(RHeaderField& aHeader);
00093
00105     //##ModelId=3C4C41A6025C
00106     TInt EncodeFieldName(RStringF aFieldName) const;
00107
00108 protected: // methods
00109
00120     //##ModelId=3C4C41A60252
00121     CWspHeaderWriter(RStringPool aStrPool, const TStringTable& aStrTable, CWspHeaderCodec& aCodec);
00122
00123 private: // methods
00124
00128     //##ModelId=3C4C41A60249
00129     void EncodeAcceptL(RHeaderField& aHeader) const;
00130
00134     //##ModelId=3C4C41A60240
00135     void EncodeAcceptCharsetL(RHeaderField& aHeader) const;
00136
00140     //##ModelId=3C4C41A6023E
00141     void EncodeAcceptEncodingL(RHeaderField& aHeader) const;
00142
00146     //##ModelId=3C4C41A60235
00147     void EncodeAcceptLanguageL(RHeaderField& aHeader) const;
00148
00152     //##ModelId=3C4C41A6022C
00153     void EncodeAllowL(RHeaderField& aHeader) const;
00154
00158     //##ModelId=3C4C41A6022A
00159     void EncodeAuthorizationL(RHeaderField& aHeader) const;
00160
00164     //##ModelId=3C4C41A60222
00165     void EncodeContentEncodingL(RHeaderField& aHeader) const;
00166
00170     //##ModelId=3C4C41A60220
00171     void EncodeContentLanguageL(RHeaderField& aHeader) const;
00172
00176     //##ModelId=3C4C41A60217
00177     void EncodeContentLocationL(RHeaderField& aHeader) const;
00178
00182     //##ModelId=3C4C41A6020E
00183     void EncodeContentMD5L(RHeaderField& aHeader) const;
00184
00188     //##ModelId=3C4C41A6020C
00189     void EncodeContentRangeL(RHeaderField& aHeader) const;
00190
00194     //##ModelId=3C4C41A60203
00195     void EncodeContentTypeL(RHeaderField& aHeader) const;
00196
00200     //##ModelId=3C4C41A601FA
00201     void EncodeCookieL(RHeaderField& aHeader) const;
00202
00206     //##ModelId=3C4C41A601F8
00207     void EncodeDateL(RHeaderField& aHeader) const;
00208
00212     //##ModelId=3C4C41A601F0
00213     void EncodeEncodingVersionL(RHeaderField& aHeader) const;
00214
00218     //##ModelId=3C4C41A601EE
00219     void EncodeExpectL(RHeaderField& aHeader) const;
00220
00224     //##ModelId=3C4C41A601E4
00225     void EncodeFromL(RHeaderField& aHeader) const;
00226
00230     //##ModelId=3C4C41A601DA
00231     void EncodeLastModifiedL(RHeaderField& aHeader) const;
00232
00236     //##ModelId=3C4C41A601D2
00237     void EncodePragmaL(RHeaderField& aHeader) const;
00238
00242     //##ModelId=3C4C41A601D0
00243     void EncodeRangeL(RHeaderField& aHeader) const;
00244
00248     //##ModelId=3C4C41A601C7
00249     void EncodeRefererL(RHeaderField& aHeader) const;
00250
00254     //##ModelId=3C4C41A601BE
00255     void EncodeTEL(RHeaderField& aHeader) const;
00256
00260     //##ModelId=3C4C41A601BC
00261     void EncodeTrailerL(RHeaderField& aHeader) const;
00262
00266     //##ModelId=3C4C41A601B2
00267     void EncodeUpgradeL(RHeaderField& aHeader) const;
00268
00272     //##ModelId=3C4C41A601A9
00273     void EncodeUserAgentL(RHeaderField& aHeader) const;
00274
00278     //##ModelId=3C4C41A601A0
00279     void EncodeViaL(RHeaderField& aHeader) const;
00280
00284     //##ModelId=3C4C41A6019E
00285     void EncodeWarningL(RHeaderField& aHeader) const;
00286
00290     //##ModelId=3C4C41A60195
00291     void EncodeXWapApplicationIdL(RHeaderField& aHeader) const;
00292
00293 // Generic encoding methods
00294
00298     //##ModelId=3C4C41A6018C
00299     void GenericEncodeDateL(RHeaderField& aHeader) const;
00300
00304     //##ModelId=3C4C41A6018A
00305     void GenericEncodeTextStringL(RHeaderField& aHeader) const;
00306
00307 // Helper methods
00308
00313     //##ModelId=3C4C41A60180
00314     void EncodeParameterL(const CHeaderFieldParam& aHeaderFieldParam, CWspHeaderEncoder& aEncoder) const;
00315
00320     //##ModelId=3C4C41A60177
00321     HBufC8* EncodeQValueL(RStringF aQValue) const;
00322
00328     //##ModelId=3C4C41A6016E
00329     TUint8 EncodeVersionValueL(RStringF aVersionValue) const;
00330
00335     //##ModelId=3C4C41A60164
00336     TInt EncodeHeaderNameL(RHeaderField& aHeader) const;
00337
00342     //##ModelId=3C4C41A60150
00343     TInt GetCharacterSetValue(RStringF aCharSet) const;
00344
00348     //##ModelId=3C4C41A6014E
00349     TInt CheckTokenText(RStringF aTokenText) const;
00350
00354     //##ModelId=3C4C41A60144
00355     TInt CheckTextString(RStringF aTextString) const;
00356
00361     TInt EncodeContentTypeValue(THTTPHdrVal& aContentType) const;
00362
00363     TInt EncodeParameterTokenValue(RStringF aParameterName) const;
00364
00365
00366 private: // attributes
00367
00368     //##ModelId=3C4C41A6013C
00369     RStringPool iStrPool;
00370
00371     //##ModelId=3C4C41A60130
00372     const TStringTable& iStrTable;
00373
00374     //##ModelId=3C4C41A6011F
00375     CWspHeaderCodec& iCodec;
00376     };
00377
00388 class CWspDefaultHdrWriter : public CHeaderWriter
00389     {
00390 public: // methods
00391
00400     virtual ~CWspDefaultHdrWriter();
00401
00413     static CWspDefaultHdrWriter* NewL(RStringPool aStrPool);
00414
00426     static CWspDefaultHdrWriter* NewLC(RStringPool aStrPool);
00427
00441     virtual void EncodeHeaderL(RHeaderField& aHeader);
00442
00443 protected: // methods
00444
00453     CWspDefaultHdrWriter(RStringPool aStrPool);
00454
00455 private: // attributes
00456
00457     RStringPool iStrPool;
00458     };
00459
00460 #endif // __CWSPHEADERWRITER_H__


CWspPrimitiveSender.h File Reference

#include <e32base.h>
#include <wsp/wsptypes.h>

Include dependency graph for CWspPrimitiveSender.h:

Include dependency graph

Go to the source code of this file.

Compounds

class CWspPrimitiveSender


CWspPrimitiveSender.h Source File

CWspPrimitiveSender.h

Go to the documentation of this file.
00001 // CWspPrimitiveSender.h
00002 //
00003 // Copyright (c) Symbian Ltd 2001
00004 //
00005
00006 #ifndef __CWSPPRIMITIVESENDER_H__
00007 #define __CWSPPRIMITIVESENDER_H__
00008
00009 #include <e32base.h>
00010 #include <wsp/wsptypes.h>
00011
00012 class MWspPrimitiveSenderCallback;
00013
00014 // Types used for arguments in this file (e.g. TWspBearer) are from the Wap namespace
00015 using namespace Wap;
00016
00018 //##ModelId=3C4C41B4025C
00019 class CWspPrimitiveSender : public CActive
00020     {
00021 public: // Methods
00022
00030     //##ModelId=3C4C41B402A5
00031     static CWspPrimitiveSender* NewL(MWspPrimitiveSenderCallback& aCallback);
00032
00037     //##ModelId=3C4C41B402A4
00038     ~CWspPrimitiveSender();
00039
00049     //##ModelId=3C4C41B402A2
00050     void InitiateSend(TWspPrimitive aPrimitive);
00051
00052 private:    // Methods from CActive
00053
00063     //##ModelId=3C4C41B4029A
00064     virtual void RunL();
00065
00075     //##ModelId=3C4C41B40298
00076     virtual TInt RunError(TInt aError);
00077
00083     //##ModelId=3C4C41B40291
00084     virtual void DoCancel();
00085
00086 private:    // Methods
00087
00094     //##ModelId=3C4C41B4028F
00095     CWspPrimitiveSender(MWspPrimitiveSenderCallback& aCallback);
00096
00103     //##ModelId=3C4C41B4028E
00104     void ConstructL();
00105
00106 private:    // Attributes
00107
00110     //##ModelId=3C4C41B4027C
00111     MWspPrimitiveSenderCallback&    iCallback;
00112
00115     //##ModelId=3C4C41B40273
00116     TWspPrimitive                   iPrimitive;
00117
00118     };
00119
00120 #endif  // __CWSPPRIMITIVESENDER_H__


CWspProxyInfoProvider.h File Reference

#include <e32base.h>
#include <wsp/mwspproxyinfoprovider.h>
#include <wsp/wsptypes.h>
#include <http/rhttpsession.h>
#include "tproxyinfo.h"

Include dependency graph for CWspProxyInfoProvider.h:

Include dependency graph

Go to the source code of this file.

Compounds

class CWspProxyInfoProvider
The CWspProxyInfoProvider class implements the MWspProxyInfoProvider API. More...


CWspProxyInfoProvider.h Source File

CWspProxyInfoProvider.h

Go to the documentation of this file.
00001 // CWspProxyInfoProvider.h
00002 //
00003 // Copyright (C) 2001 Symbian Ltd
00004 //
00005
00006 #ifndef __CWSPPROXYINFOPROVIDER_H__
00007 #define __CWSPPROXYINFOPROVIDER_H__
00008
00009 // System includes
00010 #include <e32base.h>
00011 #include <wsp/mwspproxyinfoprovider.h>
00012 #include <wsp/wsptypes.h>
00013 #include <http/rhttpsession.h>
00014
00015 // User includes
00016 #include "tproxyinfo.h"
00017
00060 //##ModelId=3BBDAFC80354
00061 class CWspProxyInfoProvider : public CBase, public MWspProxyInfoProvider
00062     {
00063 public: // Methods
00064
00071     //##ModelId=3C4C419D0014
00072     static CWspProxyInfoProvider* NewL(RHTTPSession aSession);
00073
00078     //##ModelId=3C4C419D0000
00079     ~CWspProxyInfoProvider();
00080
00092     //##ModelId=3C4C419C03CA
00093     void UpdateProxyInfoL();
00094
00111     //##ModelId=3C4C419C0384
00112     void SetTemporaryRedirectedProxyL(TWspRedirectedAddress& aRedirectAddress);
00113
00135     //##ModelId=3C4C419C0348
00136     void SetPermanentRedirectedProxyL(TWspRedirectedAddress& aRedirectAddress);
00137
00153     //##ModelId=3C4C419C032A
00154     TBool ProxyInfoChangedAndUpdateL();
00155
00163     //##ModelId=3C4C419C0316
00164     void UnlockProxyInfo();
00165
00171     //##ModelId=3C4C419C0302
00172     void ResetProxyInfo();
00173
00174 private:    // Methods from MWspProxyInfoProvider
00175
00179     //##ModelId=3C4C419C02D0
00180     virtual const TDesC8& ProxyAddress() const;
00181
00185     //##ModelId=3C4C419C028A
00186     virtual TUint16 RemotePort() const;
00187
00191     //##ModelId=3C4C419C0262
00192     virtual TUint16 LocalPort() const;
00193
00197     //##ModelId=3C4C419C0230
00198     virtual TWspBearer Bearer() const;
00199
00203     //##ModelId=3C4C419C0207
00204     virtual const TDesC8& ServiceCentreNumber() const;
00205
00209     //##ModelId=3C4C419C01DF
00210     virtual TWspSession WspSessionService() const;
00211
00215     //##ModelId=3C4C419C01C1
00216     virtual TBool SecureConnection() const;
00217
00218 private:    // Methods
00219
00224     //##ModelId=3C4C419C018F
00225     CWspProxyInfoProvider(RHTTPSession aSession);
00226
00238     //##ModelId=3C4C419C015D
00239     void ChangeToRedirectedProxyInfoL(TWspRedirectedAddress& aRedirectAddress);
00240
00255     //##ModelId=3C4C419C013F
00256     TProxyInfo GetProxyInfoL() const;
00257
00258 private:    // Static methods
00259
00270     //##ModelId=3C4C419C00F9
00271     static TWspSession ExtractSessionTypeFromSession(RHTTPConnectionInfo aConnInfo, RStringPool aStringPool);
00272
00282     //##ModelId=3C4C419C00B3
00283     static TWspBearer ExtractBearerInfoFromSession(RHTTPConnectionInfo aConnInfo, RStringPool aStringPool);
00284
00295     //##ModelId=3C4C419C0077
00296     static TBool ExtractSecurityInfoFromSession(RHTTPConnectionInfo aConnInfo, RStringPool aStringPool);
00297
00310     //##ModelId=3C4C419C0031
00311     static TUint16 ExtractPortInfoFromSession(TInt aPortType, RHTTPConnectionInfo aConnInfo, RStringPool aStringPool);
00312
00323     //##ModelId=3C4C419C0009
00324     static TUint16 DefaultRemotePort(TBool aSecureConnection, TBool aCOConnection);
00325
00343     //##ModelId=3C4C419B038D
00344     static void ReadWapAccessPointInfoL(
00345                                        RStringPool      aStringPool,
00346                                        TWspBearer&      aBearer,
00347                                        RStringF&        aProxyAddress,
00348                                        TBool&           aSecureConnection,
00349                                        RStringF&        aServiceCentreNumber,
00350                                        TWspSession&     aSessionServiceType
00351                                        );
00352
00369     //##ModelId=3C4C419B036F
00370     static TWspRedirectedAddress ExtractRedirectedProxyInfoL(RStringPool aStringPool, const TDesC8& aRedirectedAddresses);
00371
00379     //##ModelId=3C4C419B0351
00380     static void ReadServiceCentreNumberL(RStringPool aStringPool, RStringF& aServiceCentreNumber);
00381
00382 private:    // Attributes
00383
00386     //##ModelId=3C4C419B0346
00387     RHTTPSession        iSession;
00388
00391     //##ModelId=3C4C419B033C
00392     TProxyInfo          iProxyInfo;
00393
00397     //##ModelId=3C4C419B032A
00398     TBool               iProxyInfoLocked;
00399
00400     };
00401
00402 #endif  // __CWSPPROXYINFOPROVIDER_H__


CWspTransportHandler.h File Reference

@public More...

#include <e32base.h>
#include <stringpool.h>
#include <http/framework/csecuritypolicy.h>
#include <wsp/cwsptransporthandler.inl>

Include dependency graph for CWspTransportHandler.h:

Include dependency graph

Go to the source code of this file.

Compounds

struct | SInstantiationParams
A structure containing the instantiation parameters to NewL, passed across via ECOM to the sub-class NewL. More...

class | CWspTransportHandler
@public
Since:
7.0 The WSP Transport Handler API.
 More...

Detailed Description

@public

Warning:
: This file contains Rose Model ID comments - please do not delete

Definition in file CWspTransportHandler.h.


CWspTransportHandler.h Source File

CWspTransportHandler.h

Go to the documentation of this file.
00001 // CWspTransportHandler.h
00002 //
00003 // Copyright (C) 2001 Symbian Ltd
00004
00011 #ifndef __CWSPTRANSPORTHANDLER_H__
00012 #define __CWSPTRANSPORTHANDLER_H__
00013
00014 // System includes
00015 #include <e32base.h>
00016 #include <stringpool.h>
00017 #include <http/framework/csecuritypolicy.h>
00018
00019 // Forward class declarations
00020 class MWspCOSessionCallback;
00021 class MWspProxyInfoProvider;
00022 class MWspCapabilityProvider;
00023 class MWspSessionHeadersProvider;
00024 class MWspCOSessionInvoker;
00025 class MWspCOMethodInvoker;
00026 class MWspCOPushInvoker;
00027 class MWspCLMethodInvoker;
00028 class MWspCLPushInvoker;
00029
00059 //##ModelId=3BBD849A0269
00060 class CWspTransportHandler : public CBase, public MSecurityPolicy
00061     {
00062 public: // type definitions and enumerations
00063
00067     typedef TUint8 TWspSupportedServices;
00068
00071     enum TWspService
00072         {
00073         ECOSessionService = 0x01,
00074         ECOMethodInvocationService = 0x02,
00075         ECOPushService = 0x04,
00076         ECLSessionService = 0x08,
00077         ECLPushService = 0x10
00078         };
00079
00080 public: // methods
00081
00100     //##ModelId=3C4C453103DD
00101     inline static CWspTransportHandler* NewL(RStringPool aStringPool,
00102                                                MSecurityPolicy* aSecurityPolicy,
00103                                                MWspCOSessionCallback& aSessionCB,
00104                                                MWspProxyInfoProvider& aProxyInfoProv,
00105                                                MWspCapabilityProvider& aCapProv,
00106                                                MWspSessionHeadersProvider& aSessHdrProv);
00107
00112     //##ModelId=3C4C453103AB
00113     inline virtual ~CWspTransportHandler();
00114
00115 public: // General API methods
00116
00124     //##ModelId=3C4C45310256
00125     virtual TWspSupportedServices SupportedServices() const = 0;
00126
00132     virtual TInt ServerCert(TCertInfo& aCertInfo) const = 0;
00133
00134 public: // Connection-Oriented WSP API methods
00135
00144     //##ModelId=3BC577C202B2
00145     virtual MWspCOSessionInvoker& COSessionInvoker() = 0;
00146
00155     //##ModelId=3BC577C70165
00156     virtual MWspCOMethodInvoker& COTransactionInvoker() = 0;
00157
00166     //##ModelId=3C4C45310206
00167     virtual MWspCOPushInvoker& COPushInvoker() = 0;
00168
00169 public: // Connection-Less WSP API methods
00170
00179     //##ModelId=3C4C453101DE
00180     virtual MWspCLMethodInvoker& CLMethodInvoker() = 0;
00181
00190     //##ModelId=3C4C453101CA
00191     virtual MWspCLPushInvoker& CLPushInvoker() = 0;
00192
00193 protected: // type definitions
00200     struct SInstantiationParams
00201         {
00203         RStringPool* iStringPool;
00205         MSecurityPolicy* iSecurityPolicy;
00207         MWspCOSessionCallback* iSessionCB;
00209         MWspProxyInfoProvider* iProxyInfoProv;
00211         MWspCapabilityProvider* iCapProv;
00213         MWspSessionHeadersProvider* iSessHdrProv;
00214         };
00215
00216 protected: // methods
00217
00233     inline CWspTransportHandler(RStringPool aStringPool,
00234                                   MSecurityPolicy* aSecurityPolicy,
00235                                   MWspCOSessionCallback& aSessionCB,
00236                                   MWspProxyInfoProvider& aProxyInfoProv,
00237                                   MWspCapabilityProvider& aCapProv,
00238                                   MWspSessionHeadersProvider& aSessHdrProv);
00239
00240 protected: // attributes
00241
00245     //##ModelId=3C4C453101A2
00246     RStringPool iStringPool;
00247
00251     //##ModelId=3C4C4531018E
00252     MSecurityPolicy* iSecurityPolicy;
00253
00256     //##ModelId=3C4C4531017C
00257     MWspCOSessionCallback& iSessionCB;
00258
00261     //##ModelId=3C4C45310170
00262     MWspProxyInfoProvider& iProxyInfoProv;
00263
00266     //##ModelId=3C4C4531015C
00267     MWspCapabilityProvider& iCapProv;
00268
00271     //##ModelId=3C4C45310148
00272     MWspSessionHeadersProvider& iSessHdrProv;
00273
00274 private: // attributes
00275
00280     //##ModelId=3C4C45310134
00281     TUid iDtor_ID_Key;
00282     };
00283
00284 #include <wsp/cwsptransporthandler.inl>
00285
00286 #endif // __CWSPTRANSPORTHANDLER_H__


CWspUnknownCapabilities.h File Reference

#include <e32base.h>
#include <wsp/mwspunknowncapabilities.h>

Include dependency graph for CWspUnknownCapabilities.h:

Include dependency graph

Go to the source code of this file.

Compounds

class CWspUnknownCapabilities
The CWspUnknownCapabilities class represents a set of Extended Methods capabilities. More...


CWspUnknownCapabilities.h Source File

CWspUnknownCapabilities.h

Go to the documentation of this file.
00001 // CWspUnknownCapabilities.h
00002 //
00003 // Copyright (c) Symbian Ltd 2001
00004 //
00005
00006 #ifndef __CWSPUNKNOWNCAPABILITIES_H__
00007 #define __CWSPUNKNOWNCAPABILITIES_H__
00008
00009 #include <e32base.h>
00010 #include <wsp/mwspunknowncapabilities.h>
00011
00012 class CUnknownCapability;
00013
00018 //##ModelId=3C4C41AC02B5
00019 class CWspUnknownCapabilities : public CBase, public MWspUnknownCapabilities
00020     {
00021 public: // Methods
00022
00027     //##ModelId=3C4C41AC031A
00028     static CWspUnknownCapabilities* NewL();
00029
00034     //##ModelId=3C4C41AC0319
00035     ~CWspUnknownCapabilities();
00036
00037 public: // Methods from MWspUnknownCapabilities
00038
00042     //##ModelId=3C4C41AC0311
00043     virtual TInt Start() const;
00044
00048     //##ModelId=3C4C41AC0308
00049     virtual TInt GetNext(TPtrC8& aIdentifier, TPtrC8& aValue) const;
00050
00054     //##ModelId=3C4C41AC0307
00055     virtual void Reset();
00056
00060     //##ModelId=3C4C41AC02FC
00061     virtual void AddUnknownCapabilityL(const TDesC8& aIdentifier, const TDesC8& aValue);
00062
00063 private:    // Methods
00064
00069     //##ModelId=3C4C41AC02FB
00070     CWspUnknownCapabilities();
00071
00072 private:    // Attributes
00073
00076     //##ModelId=3C4C41AC02F1
00077     RPointerArray<CUnknownCapability>       iUnknownCapabilities;
00078
00082     //##ModelId=3C4C41AC02CD
00083     mutable TInt                            iIndex;
00084
00085     };
00086
00087 #endif  // __CWSPUNKNOWNCAPABILITIES_H__


http.h File Reference

@public More...

#include <httpstringconstants.h>
#include <http/mhttpdatasupplier.h>
#include <http/mhttpfilter.h>
#include <http/mhttpfilterbase.h>
#include <http/mhttptransactioncallback.h>
#include <http/rhttpconnectioninfo.h>
#include <http/rhttpfiltercollection.h>
#include <http/rhttpheaders.h>
#include <http/rhttpmessage.h>
#include <http/rhttppropertyset.h>
#include <http/rhttprequest.h>
#include <http/rhttpresponse.h>
#include <http/rhttpsession.h>
#include <http/rhttptransaction.h>
#include <http/rhttptransactionpropertyset.h>
#include <http/thttpevent.h>
#include <http/thttpfilterhandle.h>
#include <http/thttpfilteriterator.h>
#include <http/thttpfilterregistration.h>
#include <http/thttphdrfielditer.h>
#include <http/thttphdrval.h>
#include <httperr.h>

Include dependency graph for http.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Detailed Description

@public

Warning:
: This file contains Rose Model ID comments - please do not delete

Definition in file http.h.


http.h Source File

http.h

Go to the documentation of this file.
00001 // http.h
00002 //
00003 // Copyright (C) 2001 Symbian Ltd
00004 //
00005
00012 #ifndef __HTTP_H__
00013 #define __HTTP_H__
00014
00015 // System includes
00016 #include <httpstringconstants.h>
00017 #include <http/mhttpdatasupplier.h>
00018 #include <http/mhttpfilter.h>
00019 #include <http/mhttpfilterbase.h>
00020 #include <http/mhttptransactioncallback.h>
00021 #include <http/rhttpconnectioninfo.h>
00022 #include <http/rhttpfiltercollection.h>
00023 #include <http/rhttpheaders.h>
00024 #include <http/rhttpmessage.h>
00025 #include <http/rhttppropertyset.h>
00026 #include <http/rhttprequest.h>
00027 #include <http/rhttpresponse.h>
00028 #include <http/rhttpsession.h>
00029 #include <http/rhttptransaction.h>
00030 #include <http/rhttptransactionpropertyset.h>
00031 #include <http/thttpevent.h>
00032 #include <http/thttpfilterhandle.h>
00033 #include <http/thttpfilteriterator.h>
00034 #include <http/thttpfilterregistration.h>
00035 #include <http/thttphdrfielditer.h>
00036 #include <http/thttphdrval.h>
00037 #include <httperr.h>
00038
00039 #endif // __HTTP_H__
00040
00041


httperr.h File Reference

@public More...

#include <e32std.h>
#include <e32base.h>

Include dependency graph for httperr.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class | HTTPPanic
class | HTTPStatus
@public
Since:
7.0 The complete set of HTTP Status codes, as defined in RFC2616.
 More...

Variables

const TInt | KHttpErrorBase = -7200
const TInt | KHttpHeaderEncodeErrorBase = KHttpErrorBase
Codec encoding errors for HTTP headers.

const TInt | KErrHttpEncodeDefault = KHttpHeaderEncodeErrorBase
error making a default encoding of unrecognised headers

const TInt | KErrHttpEncodeAccept = KHttpHeaderEncodeErrorBase - 1
error encoding the Accept field

const TInt | KErrHttpEncodeAcceptCharset = KHttpHeaderEncodeErrorBase - 2
error encoding the Accept-Charset field

const TInt | KErrHttpEncodeQValue = KHttpHeaderEncodeErrorBase - 3
error encoding a q-value parameter

const TInt | KErrHttpEncodeAuthorization = KHttpHeaderEncodeErrorBase - 4
error encoding the Authorization field

const TInt | KErrHttpEncodeBasicAuth = KHttpHeaderEncodeErrorBase - 5
error encoding Basic credentials

const TInt | KErrHttpEncodeDigestAuth = KHttpHeaderEncodeErrorBase - 6
error encoding Digest credentials

const TInt | KErrHttpEncodeConnection = KHttpHeaderEncodeErrorBase - 7
error encoding the Connection field

const TInt | KErrHttpEncodeContentLength = KHttpHeaderEncodeErrorBase - 8
error encoding the Content-Length field

const TInt | KErrHttpEncodeContentType = KHttpHeaderEncodeErrorBase - 9
error encoding the Content-Type field

const TInt | KErrHttpEncodeHost = KHttpHeaderEncodeErrorBase - 10
error encoding the Host field

const TInt | KErrHttpEncodeHostPort = KHttpHeaderEncodeErrorBase - 11
error encoding the Host field's port parameter

const TInt | KErrHttpEncodeTransferEncoding = KHttpHeaderEncodeErrorBase - 12
error encoding the Transfer-Encoding field

const TInt | KErrHttpEncodeUserAgent = KHttpHeaderEncodeErrorBase - 13
error encoding the User-Agent field

const TInt | KErrHttpEncodeDate = KHttpHeaderEncodeErrorBase - 14
error encoding the Date field

const TInt | KErrHttpEncodeCookie = KHttpHeaderEncodeErrorBase - 15
error encoding the Cookie field

const TInt | KErrHttpEncodeCacheControl = KHttpHeaderEncodeErrorBase - 16
error encoding the Cache-Control field

const TInt | KErrHttpEncodePragma = KHttpHeaderEncodeErrorBase - 17
error encoding the Pragma field

const TInt | KErrHttpEncodeIfMatch = KHttpHeaderEncodeErrorBase - 18
error encoding the if match field

const TInt | KErrHttpEncodeIfNoneMatch = KHttpHeaderEncodeErrorBase - 19
error encoding the if none match field

const TInt | KErrHttpEncodeIfModifiedSince = KHttpHeaderEncodeErrorBase - 20
error encoding the if modified since field

const TInt | KErrHttpEncodeIfUnmodifiedSince = KHttpHeaderEncodeErrorBase - 21
error encoding the if unmodified since field

const TInt | KErrHttpEncodeCookie2 = KHttpHeaderEncodeErrorBase - 22
error encoding the Cookie2 field

const TInt | KHttpValueDecodeErrorBase = KHttpErrorBase - 60
const TInt | KErrHttpDecodeMalformedDate = KHttpValueDecodeErrorBase
general formatting error for date values

const TInt | KErrHttpDecodeMalformedYear = KHttpValueDecodeErrorBase - 1
malformed year

const TInt | KErrHttpDecodeMalformedMonth = KHttpValueDecodeErrorBase - 2
malformed short month name

const TInt | KErrHttpDecodeMalformedDay = KHttpValueDecodeErrorBase - 3
malformed number of day in month

const TInt | KErrHttpDecodeMalformedWkDay = KHttpValueDecodeErrorBase - 4
malformed short day name

const TInt | KErrHttpDecodeMalformedWeekDay = KHttpValueDecodeErrorBase - 5
malformed long day name

const TInt | KErrHttpDecodeMalformedInteger = KHttpValueDecodeErrorBase - 6
malformed integer value

const TInt | KErrHttpDecodeMalformedQuotedStr = KHttpValueDecodeErrorBase - 7
malformed quoted string

const TInt | KHttpHeaderDecodeErrorBase = KHttpErrorBase - 70
const TInt | KErrHttpDecodeAccept = KHttpHeaderDecodeErrorBase
const TInt | KErrHttpDecodeConnection = KHttpHeaderDecodeErrorBase - 1
error decoding the Connection field

const TInt | KErrHttpDecodeContentLength = KHttpHeaderDecodeErrorBase - 2
error decoding the Content-Length field

const TInt | KErrHttpDecodeContentType = KHttpHeaderDecodeErrorBase - 3
error decoding the Content-Type field

const TInt | KErrHttpDecodeTransferEncoding = KHttpHeaderDecodeErrorBase - 4
error decoding the Transfer-Encoding field

const TInt | KErrHttpDecodeWWWAuthenticate = KHttpHeaderDecodeErrorBase - 5
error decoding the WWWAuthenticate field

const TInt | KErrHttpDecodeUnknownAuthScheme = KHttpHeaderDecodeErrorBase - 6
the WWWAuthenticate field contained an unrecognised authentication scheme

const TInt | KErrHttpDecodeBasicAuth = KHttpHeaderDecodeErrorBase - 7
error decoding a Basic WWWAuthenticate challenge

const TInt | KErrHttpDecodeDigestAuth = KHttpHeaderDecodeErrorBase - 8
error decoding a Digest WWWAuthenticate challenge

const TInt | KErrHttpDecodeCookie = KHttpHeaderDecodeErrorBase - 9
error decoding a Set-Cookie field

const TInt | KErrHttpResponseFailureBase = KHttpErrorBase - 100
const TInt | KErrHttpRedirectExceededLimit = KErrHttpResponseFailureBase
a uri redirected too many times, possibly indicating a circular redirection

const TInt | KErrHttpRedirectUseProxy = KErrHttpResponseFailureBase - 1
a server responded that the uri must be fetched via a proxy

const TInt | KErrHttpRedirectNoLocationField = KErrHttpResponseFailureBase - 2
a server sent a redirection response that did not include a Location header

const TInt | KErrHttpUnknownParseState = KErrHttpResponseFailureBase - 3
an error occured in parsing which left the parser in a unknown state

const TInt | KErrHttpReqBuildErrorBase = KHttpErrorBase - 130
const TInt | KErrHttpRequestHasBody = KErrHttpReqBuildErrorBase
A body is provided with a method that doesn't allow bodys to be transmitted.

const TInt | KErrHttpRequestBodyMissing = KErrHttpReqBuildErrorBase - 1
A body is missing from a method that requires it.

const TInt | KErrHttpTraceReqWithoutMaxForwardHeader = KErrHttpReqBuildErrorBase - 2
should contain The Max-Forward header

const TInt | KErrHttpPostReqBodyWithoutSizeOnHTTP10 = KErrHttpReqBuildErrorBase - 3
body must NOT be sent chunked if using HTTP/1.0

const TInt | KErrHttpInvalidHeaderInRequest = KErrHttpReqBuildErrorBase - 4
request contained a response header or a entity header but no body

const TInt | KErrHttpMissingHeaderBase = KHttpErrorBase - 160
const TInt | KErrHttpEntityHeaderMissingContentType = KErrHttpMissingHeaderBase
A body was provided in the request but no Content-Type header was set.

const TInt | KErrHttpGeneralHeaderMissingHost = KErrHttpMissingHeaderBase - 1
The request URI was relative, but no Host header was set to indicate a server to connect to.

const TInt | KErrHttpProtocolHandlerBase = KHttpErrorBase - 170
const TInt | KErrHttpCantResetRequestBody = KErrHttpProtocolHandlerBase
const TInt | KErrHttpProtTransactionNotInitialised = KErrHttpProtocolHandlerBase -1

Detailed Description

@public

Warning:
: This file contains Rose Model ID comments - please do not delete

Definition in file httperr.h.

Variable Documentation

const TInt KErrHttpCantResetRequestBody = KErrHttpProtocolHandlerBase

Definition at line 222 of file httperr.h.

const TInt KErrHttpDecodeAccept = KHttpHeaderDecodeErrorBase

Definition at line 185 of file httperr.h.

const TInt KErrHttpDecodeBasicAuth = KHttpHeaderDecodeErrorBase - 7

error decoding a Basic WWWAuthenticate challenge

Definition at line 192 of file httperr.h.

const TInt KErrHttpDecodeConnection = KHttpHeaderDecodeErrorBase - 1

error decoding the Connection field

Definition at line 186 of file httperr.h.

const TInt KErrHttpDecodeContentLength = KHttpHeaderDecodeErrorBase - 2

error decoding the Content-Length field

Definition at line 187 of file httperr.h.

const TInt KErrHttpDecodeContentType = KHttpHeaderDecodeErrorBase - 3

error decoding the Content-Type field

Definition at line 188 of file httperr.h.

const TInt KErrHttpDecodeCookie = KHttpHeaderDecodeErrorBase - 9

error decoding a Set-Cookie field

Definition at line 194 of file httperr.h.

const TInt KErrHttpDecodeDigestAuth = KHttpHeaderDecodeErrorBase - 8

error decoding a Digest WWWAuthenticate challenge

Definition at line 193 of file httperr.h.

const TInt KErrHttpDecodeMalformedDate = KHttpValueDecodeErrorBase

general formatting error for date values

Definition at line 173 of file httperr.h.

const TInt KErrHttpDecodeMalformedDay = KHttpValueDecodeErrorBase - 3

malformed number of day in month

Definition at line 176 of file httperr.h.

const TInt KErrHttpDecodeMalformedInteger = KHttpValueDecodeErrorBase - 6

malformed integer value

Definition at line 179 of file httperr.h.

const TInt KErrHttpDecodeMalformedMonth = KHttpValueDecodeErrorBase - 2

malformed short month name

Definition at line 175 of file httperr.h.

const TInt KErrHttpDecodeMalformedQuotedStr = KHttpValueDecodeErrorBase - 7

malformed quoted string

Definition at line 180 of file httperr.h.

const TInt KErrHttpDecodeMalformedWeekDay = KHttpValueDecodeErrorBase - 5

malformed long day name

Definition at line 178 of file httperr.h.

const TInt KErrHttpDecodeMalformedWkDay = KHttpValueDecodeErrorBase - 4

malformed short day name

Definition at line 177 of file httperr.h.

const TInt KErrHttpDecodeMalformedYear = KHttpValueDecodeErrorBase - 1

malformed year

Definition at line 174 of file httperr.h.

const TInt KErrHttpDecodeTransferEncoding = KHttpHeaderDecodeErrorBase - 4

error decoding the Transfer-Encoding field

Definition at line 189 of file httperr.h.

const TInt KErrHttpDecodeUnknownAuthScheme = KHttpHeaderDecodeErrorBase - 6

the WWWAuthenticate field contained an unrecognised authentication scheme

Definition at line 191 of file httperr.h.

const TInt KErrHttpDecodeWWWAuthenticate = KHttpHeaderDecodeErrorBase - 5

error decoding the WWWAuthenticate field

Definition at line 190 of file httperr.h.

const TInt KErrHttpEncodeAccept = KHttpHeaderEncodeErrorBase - 1

error encoding the Accept field

Definition at line 147 of file httperr.h.

const TInt KErrHttpEncodeAcceptCharset = KHttpHeaderEncodeErrorBase - 2

error encoding the Accept-Charset field

Definition at line 148 of file httperr.h.

const TInt KErrHttpEncodeAuthorization = KHttpHeaderEncodeErrorBase - 4

error encoding the Authorization field

Definition at line 150 of file httperr.h.

const TInt KErrHttpEncodeBasicAuth = KHttpHeaderEncodeErrorBase - 5

error encoding Basic credentials

Definition at line 151 of file httperr.h.

const TInt KErrHttpEncodeCacheControl = KHttpHeaderEncodeErrorBase - 16

error encoding the Cache-Control field

Definition at line 162 of file httperr.h.

const TInt KErrHttpEncodeConnection = KHttpHeaderEncodeErrorBase - 7

error encoding the Connection field

Definition at line 153 of file httperr.h.

const TInt KErrHttpEncodeContentLength = KHttpHeaderEncodeErrorBase - 8

error encoding the Content-Length field

Definition at line 154 of file httperr.h.

const TInt KErrHttpEncodeContentType = KHttpHeaderEncodeErrorBase - 9

error encoding the Content-Type field

Definition at line 155 of file httperr.h.

const TInt KErrHttpEncodeCookie = KHttpHeaderEncodeErrorBase - 15

error encoding the Cookie field

Definition at line 161 of file httperr.h.

const TInt KErrHttpEncodeCookie2 = KHttpHeaderEncodeErrorBase - 22

error encoding the Cookie2 field

Definition at line 168 of file httperr.h.

const TInt KErrHttpEncodeDate = KHttpHeaderEncodeErrorBase - 14

error encoding the Date field

Definition at line 160 of file httperr.h.

const TInt KErrHttpEncodeDefault = KHttpHeaderEncodeErrorBase

error making a default encoding of unrecognised headers

Definition at line 146 of file httperr.h.

const TInt KErrHttpEncodeDigestAuth = KHttpHeaderEncodeErrorBase - 6

error encoding Digest credentials

Definition at line 152 of file httperr.h.

const TInt KErrHttpEncodeHost = KHttpHeaderEncodeErrorBase - 10

error encoding the Host field

Definition at line 156 of file httperr.h.

const TInt KErrHttpEncodeHostPort = KHttpHeaderEncodeErrorBase - 11

error encoding the Host field's port parameter

Definition at line 157 of file httperr.h.

const TInt KErrHttpEncodeIfMatch = KHttpHeaderEncodeErrorBase - 18

error encoding the if match field

Definition at line 164 of file httperr.h.

const TInt KErrHttpEncodeIfModifiedSince = KHttpHeaderEncodeErrorBase - 20

error encoding the if modified since field

Definition at line 166 of file httperr.h.

const TInt KErrHttpEncodeIfNoneMatch = KHttpHeaderEncodeErrorBase - 19

error encoding the if none match field

Definition at line 165 of file httperr.h.

const TInt KErrHttpEncodeIfUnmodifiedSince = KHttpHeaderEncodeErrorBase - 21

error encoding the if unmodified since field

Definition at line 167 of file httperr.h.

const TInt KErrHttpEncodePragma = KHttpHeaderEncodeErrorBase - 17

error encoding the Pragma field

Definition at line 163 of file httperr.h.

const TInt KErrHttpEncodeQValue = KHttpHeaderEncodeErrorBase - 3

error encoding a q-value parameter

Definition at line 149 of file httperr.h.

const TInt KErrHttpEncodeTransferEncoding = KHttpHeaderEncodeErrorBase - 12

error encoding the Transfer-Encoding field

Definition at line 158 of file httperr.h.

const TInt KErrHttpEncodeUserAgent = KHttpHeaderEncodeErrorBase - 13

error encoding the User-Agent field

Definition at line 159 of file httperr.h.

const TInt KErrHttpEntityHeaderMissingContentType = KErrHttpMissingHeaderBase

A body was provided in the request but no Content-Type header was set.

Definition at line 216 of file httperr.h.

const TInt KErrHttpGeneralHeaderMissingHost = KErrHttpMissingHeaderBase - 1

The request URI was relative, but no Host header was set to indicate a server to connect to.

Definition at line 217 of file httperr.h.

const TInt KErrHttpInvalidHeaderInRequest = KErrHttpReqBuildErrorBase - 4

request contained a response header or a entity header but no body

Definition at line 211 of file httperr.h.

const TInt KErrHttpMissingHeaderBase = KHttpErrorBase - 160

Definition at line 214 of file httperr.h.

const TInt KErrHttpPostReqBodyWithoutSizeOnHTTP10 = KErrHttpReqBuildErrorBase - 3

body must NOT be sent chunked if using HTTP/1.0

Definition at line 210 of file httperr.h.

const TInt KErrHttpProtocolHandlerBase = KHttpErrorBase - 170

Definition at line 220 of file httperr.h.

const TInt KErrHttpProtTransactionNotInitialised = KErrHttpProtocolHandlerBase -1

Definition at line 223 of file httperr.h.

const TInt KErrHttpRedirectExceededLimit = KErrHttpResponseFailureBase

a uri redirected too many times, possibly indicating a circular redirection

Definition at line 199 of file httperr.h.

const TInt KErrHttpRedirectNoLocationField = KErrHttpResponseFailureBase - 2

a server sent a redirection response that did not include a Location header

Definition at line 201 of file httperr.h.

const TInt KErrHttpRedirectUseProxy = KErrHttpResponseFailureBase - 1

a server responded that the uri must be fetched via a proxy

Definition at line 200 of file httperr.h.

const TInt KErrHttpReqBuildErrorBase = KHttpErrorBase - 130

Definition at line 205 of file httperr.h.

const TInt KErrHttpRequestBodyMissing = KErrHttpReqBuildErrorBase - 1

A body is missing from a method that requires it.

Definition at line 208 of file httperr.h.

const TInt KErrHttpRequestHasBody = KErrHttpReqBuildErrorBase

A body is provided with a method that doesn't allow bodys to be transmitted.

Definition at line 207 of file httperr.h.

const TInt KErrHttpResponseFailureBase = KHttpErrorBase - 100

Definition at line 197 of file httperr.h.

const TInt KErrHttpTraceReqWithoutMaxForwardHeader = KErrHttpReqBuildErrorBase - 2

should contain The Max-Forward header

Definition at line 209 of file httperr.h.

const TInt KErrHttpUnknownParseState = KErrHttpResponseFailureBase - 3

an error occured in parsing which left the parser in a unknown state

Definition at line 202 of file httperr.h.

const TInt KHttpErrorBase = -7200

Definition at line 137 of file httperr.h.

const TInt KHttpHeaderDecodeErrorBase = KHttpErrorBase - 70

Definition at line 183 of file httperr.h.

const TInt KHttpHeaderEncodeErrorBase = KHttpErrorBase

Codec encoding errors for HTTP headers.

Definition at line 144 of file httperr.h.

const TInt KHttpValueDecodeErrorBase = KHttpErrorBase - 60

Definition at line 171 of file httperr.h.


httperr.h Source File

httperr.h

Go to the documentation of this file.
00001 // httperr.h
00002 //
00003 // Copyright (C) 2001 Symbian Ltd
00004
00011 #ifndef __HTTPERR_H__
00012 #define __HTTPERR_H__
00013
00014 // System includes
00015 #include <e32std.h>
00016
00024 //##ModelId=3C4C18750141
00025 class HTTPStatus
00026     {
00027 public:
00028     enum
00029         {
00031         EContinue                       = 100,
00032         ESwitchingProtocols             = 101,
00034         EOk                             = 200,
00035         ECreated                        = 201,
00036         EAccepted                       = 202,
00037         ENonAuthoritativeInfo           = 203,
00038         ENoContent                      = 204,
00039         EResetContent                   = 205,
00040         EPartialContent                 = 206,
00042         EMultipleChoices                = 300,
00043         EMovedPermanently               = 301,
00044         EFound                          = 302, // Note, this is deprecated in HTTP/1.1 - 307 will be used instead
00045         ESeeOther                       = 303,
00046         ENotModified                    = 304,
00047         EUseProxy                       = 305,
00048         EUnused                         = 306,
00049         ETemporaryRedirect              = 307,
00051         EBadRequest                     = 400,
00052         EUnauthorized                   = 401,
00053         EPaymentRequired                = 402, // Note, this is reserved in HTTP/1.1
00054         EForbidden                      = 403,
00055         ENotFound                       = 404,
00056         EMethodNotAllowed               = 405,
00057         ENotAcceptable                  = 406,
00058         EProxyAuthenticationRequired    = 407,
00059         ERequestTimeout                 = 408,
00060         EConflict                       = 409,
00061         EGone                           = 410,
00062         ELengthRequired                 = 411,
00063         EPreconditionFailed             = 412,
00064         ERequestEntityTooLarge          = 413,
00065         ERequestURITooLong              = 414,
00066         EUnsupportedMediaType           = 415,
00067         ERequestedRangeNotSatisfiable   = 416,
00068         EExpectationFailed              = 417,
00070         EInternalServerError            = 500,
00071         ENotImplemented                 = 501,
00072         EBadGateway                     = 502,
00073         EServiceUnavailable             = 503,
00074         EGatewayTimeout                 = 504,
00075         EHTTPVersionNotSupported        = 505
00076         };
00077
00079     //##ModelId=3C4C18750162
00080     inline static TBool IsInformational(TInt aStatus);
00082     //##ModelId=3C4C18750160
00083     inline static TBool IsSuccessful(TInt aStatus);
00085     //##ModelId=3C4C18750159
00086     inline static TBool IsRedirection(TInt aStatus);
00088     //##ModelId=3C4C18750157
00089     inline static TBool IsClientError(TInt aStatus);
00091     //##ModelId=3C4C18750155
00092     inline static TBool IsServerError(TInt aStatus);
00093     };
00094
00095 //
00096 // HTTP Panic codes
00097 //
00098
00099 #include <e32base.h>
00100
00101 // HTTPPanic::Panic(HTTPPanic:: )
00102
00103 //##ModelId=3C4C18740352
00104 class HTTPPanic
00105     {
00106 public:
00107     enum THTTPPanic
00108         {
00109         ESessionAlreadyOpen,
00110         EHeaderFieldMissing,
00111         EHeaderParamMissing,
00112         EHeaderInvalidPart,
00113         EHeaderInvalidType,
00114         ETransactionEventOutstanding,
00115         ETransactionUnhandledError,
00116         EAddingFilterWithOutstandingTransactions,
00117         EFilterInvalidPosition,
00118         EHTTPFormDataUnreleased,
00119         EHTTPFormSupplyingData,
00120         EValidationFilterFailure,
00121         EInvalidTxData,
00122         EInvalidRxData,
00123         ENoTransportHandlerSet,
00124         EAuthenticationFilterBadState,
00125         EInvalidFilterHandle
00126         };
00127
00128     //##ModelId=3C4C18740366
00129     static void Panic(THTTPPanic aPanic);
00130     };
00131
00132 // HTTP external errors/leave codes. Add new sub-ranges at the end; do not insert between the sub-ranges that
00133 // are already here.  This is to allow a client to reasonably check for errors between two adjacent range
00134 // base values rather than check for individual codes.
00135
00136 // Base value for the HTTP error code range (-7200 to -7399)
00137 const TInt KHttpErrorBase = -7200;
00138
00139 //
00140 // Text mode HTTP protocol handler
00141 //
00142
00144 const TInt KHttpHeaderEncodeErrorBase = KHttpErrorBase;
00145
00146 const TInt KErrHttpEncodeDefault            = KHttpHeaderEncodeErrorBase;
00147 const TInt KErrHttpEncodeAccept             = KHttpHeaderEncodeErrorBase - 1;
00148 const TInt KErrHttpEncodeAcceptCharset      = KHttpHeaderEncodeErrorBase - 2;
00149 const TInt KErrHttpEncodeQValue             = KHttpHeaderEncodeErrorBase - 3;
00150 const TInt KErrHttpEncodeAuthorization      = KHttpHeaderEncodeErrorBase - 4;
00151 const TInt KErrHttpEncodeBasicAuth          = KHttpHeaderEncodeErrorBase - 5;
00152 const TInt KErrHttpEncodeDigestAuth         = KHttpHeaderEncodeErrorBase - 6;
00153 const TInt KErrHttpEncodeConnection         = KHttpHeaderEncodeErrorBase - 7;
00154 const TInt KErrHttpEncodeContentLength      = KHttpHeaderEncodeErrorBase - 8;
00155 const TInt KErrHttpEncodeContentType        = KHttpHeaderEncodeErrorBase - 9;
00156 const TInt KErrHttpEncodeHost               = KHttpHeaderEncodeErrorBase - 10;
00157 const TInt KErrHttpEncodeHostPort           = KHttpHeaderEncodeErrorBase - 11;
00158 const TInt KErrHttpEncodeTransferEncoding   = KHttpHeaderEncodeErrorBase - 12;
00159 const TInt KErrHttpEncodeUserAgent          = KHttpHeaderEncodeErrorBase - 13;
00160 const TInt KErrHttpEncodeDate               = KHttpHeaderEncodeErrorBase - 14;
00161 const TInt KErrHttpEncodeCookie             = KHttpHeaderEncodeErrorBase - 15;
00162 const TInt KErrHttpEncodeCacheControl       = KHttpHeaderEncodeErrorBase - 16;
00163 const TInt KErrHttpEncodePragma             = KHttpHeaderEncodeErrorBase - 17;
00164 const TInt KErrHttpEncodeIfMatch            = KHttpHeaderEncodeErrorBase - 18;
00165 const TInt KErrHttpEncodeIfNoneMatch        = KHttpHeaderEncodeErrorBase - 19;
00166 const TInt KErrHttpEncodeIfModifiedSince    = KHttpHeaderEncodeErrorBase - 20;
00167 const TInt KErrHttpEncodeIfUnmodifiedSince  = KHttpHeaderEncodeErrorBase - 21;
00168 const TInt KErrHttpEncodeCookie2            = KHttpHeaderEncodeErrorBase - 22;
00169
00170 // Codec decoding errors for values found in HTTP headers
00171 const TInt KHttpValueDecodeErrorBase = KHttpErrorBase - 60;
00172
00173 const TInt KErrHttpDecodeMalformedDate      = KHttpValueDecodeErrorBase;
00174 const TInt KErrHttpDecodeMalformedYear      = KHttpValueDecodeErrorBase - 1;
00175 const TInt KErrHttpDecodeMalformedMonth     = KHttpValueDecodeErrorBase - 2;
00176 const TInt KErrHttpDecodeMalformedDay       = KHttpValueDecodeErrorBase - 3;
00177 const TInt KErrHttpDecodeMalformedWkDay     = KHttpValueDecodeErrorBase - 4;
00178 const TInt KErrHttpDecodeMalformedWeekDay   = KHttpValueDecodeErrorBase - 5;
00179 const TInt KErrHttpDecodeMalformedInteger   = KHttpValueDecodeErrorBase - 6;
00180 const TInt KErrHttpDecodeMalformedQuotedStr = KHttpValueDecodeErrorBase - 7;
00181
00182 // Codec decoding errors for HTTP headers
00183 const TInt KHttpHeaderDecodeErrorBase = KHttpErrorBase - 70;
00184
00185 const TInt KErrHttpDecodeAccept             = KHttpHeaderDecodeErrorBase;
00186 const TInt KErrHttpDecodeConnection         = KHttpHeaderDecodeErrorBase - 1;
00187 const TInt KErrHttpDecodeContentLength      = KHttpHeaderDecodeErrorBase - 2;
00188 const TInt KErrHttpDecodeContentType        = KHttpHeaderDecodeErrorBase - 3;
00189 const TInt KErrHttpDecodeTransferEncoding   = KHttpHeaderDecodeErrorBase - 4;
00190 const TInt KErrHttpDecodeWWWAuthenticate    = KHttpHeaderDecodeErrorBase - 5;
00191 const TInt KErrHttpDecodeUnknownAuthScheme  = KHttpHeaderDecodeErrorBase - 6;
00192 const TInt KErrHttpDecodeBasicAuth          = KHttpHeaderDecodeErrorBase - 7;
00193 const TInt KErrHttpDecodeDigestAuth         = KHttpHeaderDecodeErrorBase - 8;
00194 const TInt KErrHttpDecodeCookie             = KHttpHeaderDecodeErrorBase - 9;
00195
00196 // Response errors. These represent specific failure cases
00197 const TInt KErrHttpResponseFailureBase = KHttpErrorBase - 100;
00198
00199 const TInt KErrHttpRedirectExceededLimit        = KErrHttpResponseFailureBase;
00200 const TInt KErrHttpRedirectUseProxy             = KErrHttpResponseFailureBase - 1;
00201 const TInt KErrHttpRedirectNoLocationField      = KErrHttpResponseFailureBase - 2;
00202 const TInt KErrHttpUnknownParseState            = KErrHttpResponseFailureBase - 3;
00203
00204 // Request building errors: cause the Validation Filter to make a transaction fail and terminate
00205 const TInt KErrHttpReqBuildErrorBase = KHttpErrorBase - 130;
00206
00207 const TInt KErrHttpRequestHasBody                   = KErrHttpReqBuildErrorBase;
00208 const TInt KErrHttpRequestBodyMissing               = KErrHttpReqBuildErrorBase - 1;
00209 const TInt KErrHttpTraceReqWithoutMaxForwardHeader  = KErrHttpReqBuildErrorBase - 2;
00210 const TInt KErrHttpPostReqBodyWithoutSizeOnHTTP10   = KErrHttpReqBuildErrorBase - 3;
00211 const TInt KErrHttpInvalidHeaderInRequest           = KErrHttpReqBuildErrorBase - 4;
00212
00213 // Missing but required header errors
00214 const TInt KErrHttpMissingHeaderBase = KHttpErrorBase - 160;
00215
00216 const TInt KErrHttpEntityHeaderMissingContentType       = KErrHttpMissingHeaderBase;
00217 const TInt KErrHttpGeneralHeaderMissingHost             = KErrHttpMissingHeaderBase - 1;
00218
00219 // Protocol handler errors
00220 const TInt KErrHttpProtocolHandlerBase = KHttpErrorBase - 170;
00221 // The request body needed to be rewound but the client but it doesn't support
00222 const TInt KErrHttpCantResetRequestBody             = KErrHttpProtocolHandlerBase;
00223 const TInt KErrHttpProtTransactionNotInitialised    = KErrHttpProtocolHandlerBase -1;
00224
00225 // end of error codes - maximum error value is -7399 - must not be exceeded!
00226
00227
00228
00229 // Inline methods from HTTPStatus
00230 //
00231 inline TBool HTTPStatus::IsInformational(TInt aStatus)
00232     {
00233     return ((aStatus >= HTTPStatus::EContinue) && (aStatus < HTTPStatus::EOk));
00234     }
00235 inline TBool HTTPStatus::IsSuccessful(TInt aStatus)
00236     {
00237     return ((aStatus >= HTTPStatus::EOk) && (aStatus < HTTPStatus::EMultipleChoices));
00238     }
00239 inline TBool HTTPStatus::IsRedirection(TInt aStatus)
00240     {
00241     return ((aStatus >= HTTPStatus::EMultipleChoices) && (aStatus < HTTPStatus::EBadRequest));
00242     }
00243 inline TBool HTTPStatus::IsClientError(TInt aStatus)
00244     {
00245     return ((aStatus >= HTTPStatus::EBadRequest) && (aStatus < HTTPStatus::EInternalServerError));
00246     }
00247 inline TBool HTTPStatus::IsServerError(TInt aStatus)
00248     {
00249     return (aStatus >= HTTPStatus::EInternalServerError);
00250     }
00251
00252
00253
00254 #endif // __HTTPERR_H__


httpexampleclient.h File Reference

#include <e32test.h>
#include <f32file.h>
#include <http\MHTTPAuthenticationCallback.h>

Include dependency graph for httpexampleclient.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | CHttpClient
The example http client. More...

class | CHttpEventHandler
Handles all events for the active transaction. More...

Variables

const TInt | KMaxContentTypeSize = 64
HTTPEXAMPLECLIENT is a simple text based http client.

Variable Documentation

const TInt KMaxContentTypeSize = 64

HTTPEXAMPLECLIENT is a simple text based http client.

It is intended as an example and introduction to the HTTP Client API's available in The Symbian Platform Release 6.2

Users should have a brief understanding of HTTP and the different types of requests and responses you can get from servers. They should also be familiar with setting up a communications database (cdbv2.dat) with suitable settings for modems/NTRas and ISP's.

Definition at line 26 of file httpexampleclient.h.


httpexampleclient.h Source File

httpexampleclient.h

Go to the documentation of this file.
00001 // HTTPEXAMPLECLIENT.H
00002 //
00003 // Copyright (c) 2001 Symbian Ltd.  All rights reserved.
00004 //
00005
00006
00007
00020 #include <e32test.h>
00021 #include <f32file.h>
00022 #include <http\MHTTPAuthenticationCallback.h>
00023
00024 // Maximum size of buffer to hold content-type data
00025 //
00026 const TInt KMaxContentTypeSize = 64;
00027
00028
00029 //
00030 // Definition of CHttpClient
00031 //
00032 class CHttpEventHandler;
00033 class CHttpExampleUtils;
00034
00035
00044 class CHttpClient : public CBase, public MHTTPDataSupplier,
00045                     public MHTTPAuthenticationCallback
00046     {
00047 public:
00048     virtual ~CHttpClient();
00049     static CHttpClient* NewLC();
00050     static CHttpClient* NewL();
00051     void StartClientL();
00052 // methods inherited from MHTTPDataSupplier
00053     virtual TBool GetNextDataPart(TPtrC8& aDataPart);
00054     virtual void ReleaseData();
00055     virtual TInt OverallDataSize();
00056     virtual TInt Reset();
00057
00058 // methods inherited from MHTTPAuthenticationCallback
00059     virtual TBool GetCredentialsL(const TUriC8& aURI, RString aRealm,
00060                                  RStringF aAuthenticationType,
00061                                  RString& aUsername,
00062                                  RString& aPassword);
00063
00064 protected:
00065     CHttpClient();
00066     void ConstructL();
00067 private:
00068
00069     enum TMenuItems
00070         {
00071         EGet,
00072         EPost,
00073         EHead,
00074         ETrace,
00075         EToggleVerbosity,
00076         EQuit
00077         };
00078
00079     void ResetTimeElapsed();
00080     void DisplayTimeElapsed();
00081     //
00082     void InvokeHttpMethodL(const TDesC8& aUri, RStringF aMethod);
00083     void SetHeaderL(RHTTPHeaders aHeaders, TInt aHdrField, const TDesC8& aHdrValue);
00084     void GetRequestBodyL(RStringF& aMethod);
00085     void GetPostBodyManuallyL();
00086
00087 private:
00088     TTime iLastTimeStamp;
00089     TInt iDataChunkCount;
00090     RHTTPSession iSess;
00091     RHTTPTransaction iTrans;
00092     TBool iHasARequestBody;
00093     RFs iFileServ;
00094     RFile iReqBodyFile;
00095     TFileName iReqBodyFileName;
00096     TParse iParsedFileName;
00097     TBuf<KMaxContentTypeSize> iReqBodyContentType;
00098     CHttpEventHandler* iTransObs;
00099     HBufC8* iReqBodySubmitBuffer;
00100     TPtr8 iReqBodySubmitBufferPtr;
00101     CHTTPFormEncoder* iFormEncoder;     // used for manual post submissions
00102     TBool iManualPost;
00103     CHttpExampleUtils* iUtils;
00104     };
00105
00106
00107
00110 class CHttpEventHandler : public CBase, public MHTTPTransactionCallback
00111     {
00112 public:
00113     virtual ~CHttpEventHandler();
00114     static CHttpEventHandler* NewLC(CHttpExampleUtils& aUtils);
00115     static CHttpEventHandler* NewL(CHttpExampleUtils& aUtils);
00116     void SetVerbose(TBool aVerbose);
00117     TBool Verbose() const;
00118     //
00119     // methods from MHTTPTransactionCallback
00120     //
00121     virtual void MHFRunL(RHTTPTransaction aTransaction, const THTTPEvent& aEvent);
00122     virtual TInt MHFRunError(TInt aError, RHTTPTransaction aTransaction, const THTTPEvent& aEvent);
00123
00124 protected:
00125     CHttpEventHandler(CHttpExampleUtils& aUtils);
00126     void ConstructL();
00127 private:
00128     void DumpRespHeadersL(RHTTPTransaction& aTrans);
00129     void DumpRespBody(RHTTPTransaction& aTrans);
00130     void DumpIt(const TDesC8& aData);
00131     TBool iVerbose;
00132     TBool iSavingResponseBody;
00133     RFs iFileServ;
00134     RFile iRespBodyFile;
00135     TFileName iRespBodyFileName;
00136     TParse iParsedFileName;
00137     MHTTPDataSupplier* iRespBody;
00138     CHttpExampleUtils& iUtils; // not owned
00139     };
00140


httpexampleutils.h File Reference

#include <e32test.h>

Include dependency graph for httpexampleutils.h:

Include dependency graph

Go to the source code of this file.

Compounds

class CHttpExampleUtils
CHttpExampleUtils is a class that provides some user input utilities and holds a RTest used throughout. More...


httpexampleutils.h Source File

httpexampleutils.h

Go to the documentation of this file.
00001 // HTTPEXAMPLEUTILS.H
00002 //
00003 // Copyright (c) 2001 Symbian Ltd.  All rights reserved.
00004 //
00005
00006 #include <e32test.h>
00007
00008
00011 class CHttpExampleUtils : public CBase
00012     {
00013 public:
00014     static void InitCommsL();
00015     static CHttpExampleUtils* NewL(const TDesC& aTestName);
00016     ~CHttpExampleUtils();
00017     void GetAnEntry(const TDesC& ourPrompt, TDes& currentstring);
00018     TInt GetSelection(const TDesC& ourPrompt, const TDesC& validChoices);
00019     void PressAnyKey();
00020     void LogIt(TRefByValue<const TDesC> aFmt, ...);
00021     RTest& Test();
00022 private:
00023     CHttpExampleUtils(const TDesC& aTestName);
00024
00025 private:
00026     RTest iTest;
00027     };


httplogger.h File Reference

@public More...

#include <e32std.h>
#include <flogger.h>

Include dependency graph for httplogger.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class | THttpLogger
@private
Since:
7.0 A utility used in HTTP for logging in debug builds.
 More...

Defines

#define | _LOGGING
#define | __DECLARE_LOG TUint8 iDummyLoggerNotUsed[sizeof(THttpLogger)];
#define | __OPEN_LOG(L)
#define | __OPEN_LOG2(L)
#define | __LOG(C)
#define | __LOG1(C, X)
#define | __LOG2(C, X, Y)
#define | __LOG3(C, X, Y, Z)
#define | __DUMPBIN(D)
#define | __QINFO(aText)

Detailed Description

@public

Warning:
: This file contains Rose Model ID comments - please do not delete

Definition in file httplogger.h.

Define Documentation

#define __DECLARE_LOG TUint8 iDummyLoggerNotUsed[sizeof(THttpLogger)];

Definition at line 86 of file httplogger.h.

#define __DUMPBIN ( D )

Definition at line 93 of file httplogger.h.

#define __LOG ( C )

Definition at line 89 of file httplogger.h.

#define __LOG1 | ( | C,
 |  | X | )

Definition at line 90 of file httplogger.h.

#define __LOG2 | ( | C,
 |  | X,
 |  | Y | )

Definition at line 91 of file httplogger.h.

#define __LOG3 | ( | C,
 |  | X,
 |  | Y,
 |  | Z | )

Definition at line 92 of file httplogger.h.

#define __OPEN_LOG ( L )

Definition at line 87 of file httplogger.h.

#define __OPEN_LOG2 ( L )

Definition at line 88 of file httplogger.h.

#define __QINFO ( aText )

Definition at line 94 of file httplogger.h.

#define _LOGGING

Definition at line 68 of file httplogger.h.


httplogger.h Source File

httplogger.h

Go to the documentation of this file.
00001 // httplogger.h
00002 //
00003 // Copyright (C) 2001 Symbian Ltd
00004
00011 #ifndef __HTTPLOGGER_H__
00012 #define __HTTPLOGGER_H__
00013
00014 // System includes
00015 #include <e32std.h>
00016 #include <flogger.h>
00017
00018
00027 //##ModelId=3C4C4C3E0139
00028 class THttpLogger : public TDesOverflow
00029     {
00030 public: // methods
00031
00033     //##ModelId=3C4C4C3E0180
00034     IMPORT_C virtual ~THttpLogger();
00035
00037     //##ModelId=3C4C4C3E0175
00038     IMPORT_C void CreateFlogger(const TDesC& aFileName, TInt aShowDate, TInt aShowTime);
00039
00040     //##ModelId=3C4C4C3E0162
00041     IMPORT_C void LogIt(TRefByValue<const TDesC> aFmt, ...);
00042
00044     //##ModelId=3C4C4C3E0158
00045     IMPORT_C void WriteComment(const TDesC& aComment);
00046
00048     //##ModelId=3C4C4C3E0150
00049     IMPORT_C void DumpIt(const TDesC8& aData);
00050
00052     //##ModelId=3C4C4C3E015A
00053     IMPORT_C void WriteComment(const TDesC8& aData);
00054
00055 private:    // Methods from TDesOverflow
00056
00057     IMPORT_C virtual void Overflow(TDes& aDes);
00058
00059 private: // attributes
00060
00062     //##ModelId=3C4C4C3E014D
00063     RFileLogger iLogger;
00064     };
00065
00066 // By default, logging will always be switched on.  Later, this may be removed, leaving it to individual
00067 // source files to enable logging where needed.
00068 #define _LOGGING
00069
00070 #if defined (_DEBUG) && defined (_LOGGING)
00071
00072 // HTTP Logging macros
00073 #define __DECLARE_LOG       THttpLogger iLogger;
00074 #define __OPEN_LOG(L)       iLogger.CreateFlogger(_L(L), ETrue, ETrue);
00075 #define __OPEN_LOG2(L)      iLogger.CreateFlogger(L, ETrue, ETrue);
00076 #define __LOG(C)            iLogger.WriteComment(C);
00077 #define __LOG1(C, X)        iLogger.LogIt(C, X);
00078 #define __LOG2(C, X, Y)     iLogger.LogIt(C, X, Y);
00079 #define __LOG3(C, X, Y, Z)  iLogger.LogIt(C, X, Y, Z);
00080 #define __DUMPBIN(D)        iLogger.DumpIt(D);
00081 #define __QINFO(aText)      {User::InfoPrint(aText); User::After(1000000);}
00082
00083 #else if !defined (_DEBUG)
00084
00085 // NULL macros
00086 #define __DECLARE_LOG       TUint8 iDummyLoggerNotUsed[sizeof(THttpLogger)];
00087 #define __OPEN_LOG(L)
00088 #define __OPEN_LOG2(L)
00089 #define __LOG(C)
00090 #define __LOG1(C, X)
00091 #define __LOG2(C, X, Y)
00092 #define __LOG3(C, X, Y, Z)
00093 #define __DUMPBIN(D)
00094 #define __QINFO(aText)
00095 #endif // !_DEBUG
00096
00097 #endif // __HTTPLOGGER_H__


logging.h File Reference

@public More...

#include <e32std.h>
#include <f32file.h>
#include <flogger.h>

Include dependency graph for logging.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Defines

#define | _LOGGING
#define | __DECLARE_LOG TUint8 iDummyLoggerNotUsed[sizeof(RFileLogger)];
#define | __OPENLOG(D, L)
#define | __LOG_TITLE(T)
#define | __CLOSELOG
#define | __LOG(C)
#define | __LOG1(C, X)
#define | __LOG2(C, X, Y)
#define | __LOG3(C, X, Y, Z)
#define | __DUMP(H, M, D)
#define | __QINFO(aText)

Detailed Description

@public

Warning:
: This file contains Rose Model ID comments - please do not delete

Definition in file logging.h.

Define Documentation

#define __CLOSELOG

Definition at line 51 of file logging.h.

#define __DECLARE_LOG TUint8 iDummyLoggerNotUsed[sizeof(RFileLogger)];

Definition at line 48 of file logging.h.

#define __DUMP | ( | H,
 |  | M,
 |  | D | )

Definition at line 56 of file logging.h.

#define __LOG ( C )

Definition at line 52 of file logging.h.

#define __LOG1 | ( | C,
 |  | X | )

Definition at line 53 of file logging.h.

#define __LOG2 | ( | C,
 |  | X,
 |  | Y | )

Definition at line 54 of file logging.h.

#define __LOG3 | ( | C,
 |  | X,
 |  | Y,
 |  | Z | )

Definition at line 55 of file logging.h.

#define __LOG_TITLE ( T )

Definition at line 50 of file logging.h.

#define __OPENLOG | ( | D,
 |  | L | )

Definition at line 49 of file logging.h.

#define __QINFO ( aText )

Definition at line 57 of file logging.h.

#define _LOGGING

Definition at line 21 of file logging.h.


logging.h Source File

logging.h

Go to the documentation of this file.
00001 // logging.h
00002 //
00003 // Copyright (C) 2001 Symbian Ltd
00004
00011 #ifndef __LOGGING_H__
00012 #define __LOGGING_H__
00013
00014 // System includes
00015 #include <e32std.h>
00016 #include <f32file.h>
00017 #include <flogger.h>
00018
00019 // By default, logging will always be switched on.  Later, this may be removed, leaving it to individual
00020 // source files to enable logging where needed.
00021 #define _LOGGING
00022
00023 #if defined (_DEBUG) && defined (_LOGGING)
00024
00025 // HTTP Logging macros
00026 #define __DECLARE_LOG       RFileLogger iLogger;
00027 #define __OPENLOG(D, L)     iLogger.Connect(); \
00028                             TParse p; \
00029                             _LIT(KLogFile, L); \
00030                             p.Set(KLogFile(), NULL, NULL); \
00031                             _LIT(KLogDir, D); \
00032                             iLogger.CreateLog(KLogDir(), p.NameAndExt(), EFileLoggingModeOverwrite); \
00033                             iLogger.SetDateAndTime(ETrue, ETrue);
00034 #define __LOG_TITLE(T)      iLogger.Write(TPtrC8((const TText8 *)(T)));
00035 #define __CLOSELOG          iLogger.Close();
00036 #define __LOG(C)            iLogger.Write(TPtrC8((const TText8 *)(C)));
00037 #define __LOG1(C, X)        iLogger.WriteFormat(TPtrC8((const TText8 *)(C)), X);
00038 #define __LOG2(C, X, Y)     iLogger.WriteFormat(TPtrC8((const TText8 *)(C)), X, Y);
00039 #define __LOG3(C, X, Y, Z)  iLogger.WriteFormat(TPtrC8((const TText8 *)(C)), X, Y, Z);
00040 #define __DUMP(H, M, D)     {_LIT(KHeader, H); \
00041                             _LIT(KMargin, M); \
00042                             iLogger.HexDump((const TText*)(KHeader().Ptr()), (const TText*)(KMargin().Ptr()), D.Ptr(), D.Length());}
00043 #define __QINFO(aText)      {User::InfoPrint(aText); User::After(1000000);}
00044
00045 #else if !defined (_DEBUG)
00046
00047 // NULL macros
00048 #define __DECLARE_LOG       TUint8 iDummyLoggerNotUsed[sizeof(RFileLogger)];
00049 #define __OPENLOG(D, L)
00050 #define __LOG_TITLE(T)
00051 #define __CLOSELOG
00052 #define __LOG(C)
00053 #define __LOG1(C, X)
00054 #define __LOG2(C, X, Y)
00055 #define __LOG3(C, X, Y, Z)
00056 #define __DUMP(H, M, D)
00057 #define __QINFO(aText)
00058 #endif // !_DEBUG
00059
00060 #endif // __LOGGING_H__


MConnectInvokerCallback.h File Reference

#include <e32base.h>

Include dependency graph for MConnectInvokerCallback.h:

Include dependency graph

Go to the source code of this file.

Compounds

class MConnectInvokerCallback
The MConnectInvokerCallback is used to perform an automatic session connect. More...


MConnectInvokerCallback.h Source File

MConnectInvokerCallback.h

Go to the documentation of this file.
00001 // MConnectInvokerCallback.h
00002 //
00003 // Copyright (c) Symbian Ltd 2001
00004 //
00005
00006 #ifndef __MCONNECTINVOKERCALLBACK_H__
00007 #define __MCONNECTINVOKERCALLBACK_H__
00008
00009 #include <e32base.h>
00010
00015 class MConnectInvokerCallback
00016     {
00017 public: // Methods
00018
00024     virtual void HandleConnectInvocationL() =0;
00025
00034     virtual TInt ConnectInvokerCallbackError(TInt aError) =0;
00035
00036     };
00037
00038 #endif  // __MPROXYREDIRECTIONCALLBACK_H__


MConnectionInfoProvider.h File Reference

@public More...

#include <wsp/mwspproxyinfoprovider.h>
#include <wsp/mwspcapabilityprovider.h>
#include <wsp/mwspsessionheadersprovider.h>

Include dependency graph for MConnectionInfoProvider.h:

Include dependency graph

Go to the source code of this file.

Compounds

class MConnectionInfoProvider
@private
Since:
7.0 This interface defines methods to obtain further interfaces that supply connection-related information.
 More...

Detailed Description

@public

Warning:
: This file contains Rose Model ID comments - please do not delete

Definition in file MConnectionInfoProvider.h.


MConnectionInfoProvider.h Source File

MConnectionInfoProvider.h

Go to the documentation of this file.
00001 // MConnectionInfoProvider.h
00002 //
00003 // Copyright (c) Symbian Ltd 2001
00004
00011 #ifndef __MCONNECTIONINFOPROVIDER_H__
00012 #define __MCONNECTIONINFOPROVIDER_H__
00013
00014 // System includes
00015 #include <wsp/mwspproxyinfoprovider.h>
00016 #include <wsp/mwspcapabilityprovider.h>
00017 #include <wsp/mwspsessionheadersprovider.h>
00018
00019
00030 //##ModelId=3C9B094C007D
00031 class MConnectionInfoProvider
00032     {
00033 public: // Methods
00034
00039     //##ModelId=3C9B094C00A6
00040     virtual MWspProxyInfoProvider& ProxyInfoProvider() const = 0;
00041
00046     //##ModelId=3C9B094C00A5
00047     virtual MWspCapabilityProvider& CapabilityProvider() const = 0;
00048
00053     //##ModelId=3C9B094C009B
00054     virtual MWspSessionHeadersProvider& SessionHeadersProvider() const = 0;
00055     };
00056
00057 #endif  // __MCONNECTIONINFOPROVIDER_H__


MConnectionTimerCallback.h File Reference

#include <e32std.h>

Include dependency graph for MConnectionTimerCallback.h:

Include dependency graph

Go to the source code of this file.

Compounds

class MConnectionTimerCallback


MConnectionTimerCallback.h Source File

MConnectionTimerCallback.h

Go to the documentation of this file.
00001 // MConnectionTimerCallback.h
00002 //
00003 // Copyright (c) Symbian Ltd 2001
00004 //
00005
00006 #ifndef __MCONNECTIONTIMERCALLBACK_H__
00007 #define __MCONNECTIONTIMERCALLBACK_H__
00008
00009 #include <e32std.h>
00010
00012
00013 //##ModelId=3C4C419D024F
00014 class MConnectionTimerCallback
00015     {
00016 public: // Methods
00017
00025     //##ModelId=3C4C419D0263
00026     virtual void HandleConnectionTimedOut() =0;
00027
00028     };
00029
00030 #endif  // __MCONNECTIONTIMERCALLBACK_H__
00031


mhttpauthenticationcallback.h File Reference

#include <uri8.h>
#include <stringpool.h>
#include <http/rhttpsession.h>
#include <http/cauthenticationfilterinterface.h>

Include dependency graph for mhttpauthenticationcallback.h:

Include dependency graph

Go to the source code of this file.

Compounds

class MHTTPAuthenticationCallback
@public
Since:
7.0 The mixin that needs to be implemented if authentication is to be supported.
 More...


mhttpauthenticationcallback.h Source File

mhttpauthenticationcallback.h

Go to the documentation of this file.
00001 // MHTTPAuthenticationCallback.h
00002 //
00003 // Copyright (C) 2001 Symbian Ltd.
00004
00011 #ifndef __MHTTPAUTHENTICATIONCALLBACK_H__
00012 #define __MHTTPAUTHENTICATIONCALLBACK_H__
00013
00014 // System includes
00015 #include <uri8.h>
00016 #include <stringpool.h>
00017 #include <http/rhttpsession.h>
00018 #include <http/cauthenticationfilterinterface.h>
00019
00031 //##ModelId=3B1E52A50151
00032 class MHTTPAuthenticationCallback
00033     {
00034  public:
00052     //##ModelId=3B1E52A5015D
00053     virtual TBool GetCredentialsL(const TUriC8& aURI, RString aRealm,
00054                                   RStringF aAuthenticationType,
00055                                   RString& aUsername,
00056                                   RString& aPassword) = 0;
00057
00066     //##ModelId=3B1E52A5015B
00067     inline void InstallAuthenticationL(RHTTPSession aSession);
00068     };
00069
00070 inline void MHTTPAuthenticationCallback::InstallAuthenticationL(RHTTPSession aSession)
00071     {
00072     CAuthenticationFilterInterface::InstallFilterL(aSession, this);
00073     }
00074
00075
00076 #endif //   __MHTTPAUTHENTICATIONCALLBACK_H__


mhttpdatasupplier.h File Reference

#include <e32base.h>

Include dependency graph for mhttpdatasupplier.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class MHTTPDataSupplier
@public
Since:
7.0 A data supplier - This class is used to deliver the response data to the client, and is also used by the client to supply request body data to HTTP in POST transactions.
 More...


mhttpdatasupplier.h Source File

mhttpdatasupplier.h

Go to the documentation of this file.
00001 // MHTTPDataSupplier.h
00002 //
00003 // Copyright (C) 2001 Symbian Ltd.
00004
00011 #ifndef __MHTTPDATASUPPLIER_H__
00012 #define __MHTTPDATASUPPLIER_H__
00013
00014 // System includes
00015 #include <e32base.h>
00016
00064 //##ModelId=3C4C187903E5
00065 class MHTTPDataSupplier
00066     {
00067  public:
00072     //##ModelId=3C4C187A0026
00073      virtual TBool GetNextDataPart(TPtrC8& aDataPart) = 0;
00074
00079     //##ModelId=3C4C187A0025
00080     virtual void ReleaseData() = 0;
00081
00090     //##ModelId=3C4C187A001D
00091     virtual TInt OverallDataSize() = 0;
00092
00101     //##ModelId=3C4C187A001C
00102     virtual TInt Reset() = 0;
00103
00104 private:
00105     // Some reserved methods for future expansion (e.g. better support
00106     // for ZCD)
00107     //##ModelId=3C4C187A001B
00108     inline virtual void MHDS_Reserved1();
00109     //##ModelId=3C4C187A0012
00110     inline virtual void MHDS_Reserved2();
00111     //##ModelId=3C4C187A0011
00112     inline virtual void MHDS_Reserved3();
00113     };
00114
00115 inline void MHTTPDataSupplier::MHDS_Reserved1()
00116     {}
00117
00118 inline void MHTTPDataSupplier::MHDS_Reserved2()
00119     {}
00120
00121 inline void MHTTPDataSupplier::MHDS_Reserved3()
00122     {}
00123
00124 #endif // __MHTTPDATASUPPLIER_H__


mhttpfilter.h File Reference

#include <e32std.h>
#include <http/mhttpfilterbase.h>
#include <http/rhttpsession.h>
#include <http/thttpfilterhandle.h>

Include dependency graph for mhttpfilter.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class MHTTPFilter
@public
Since:
7.0 A HTTP filter
 More...


mhttpfilter.h Source File

mhttpfilter.h

Go to the documentation of this file.
00001 // MHTTPFilter.h
00002 //
00003 // Copyright (C) 2001 Symbian Ltd.
00004
00011 #ifndef __MHTTPFILTER_H__
00012 #define __MHTTPFILTER_H__
00013
00014 // System includes
00015 #include <e32std.h>
00016 #include <http/mhttpfilterbase.h>
00017 #include <http/rhttpsession.h>
00018 #include <http/thttpfilterhandle.h>
00019
00027 //##ModelId=3C4C187D03E1
00028 class MHTTPFilter : public MHTTPFilterBase
00029     {
00030  public:
00037     //##ModelId=3C4C187E0011
00038     IMPORT_C virtual void MHFUnload(RHTTPSession aSession,
00039                                     THTTPFilterHandle aHandle);
00040
00047     //##ModelId=3C4C187E000E
00048     IMPORT_C virtual void MHFLoad(RHTTPSession aSession,
00049                                   THTTPFilterHandle aHandle);
00050  public:
00055     enum TPositions
00056         {
00059         EProtocolHandler    = 0,
00060         // Filters that should be downstream of any status-code related processing
00062         ECache              = 100,
00065         EStatusCodeHandler = 200,
00070         ECookies            = 300,
00073         ETidyUp = 400,
00076         EClientFilters      = 500,
00079         EClient             = 1000
00080         };
00081     };
00082
00083 #endif // __MHTTPFILTER_H__


mhttpfilterbase.h File Reference

#include <e32std.h>

Include dependency graph for mhttpfilterbase.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class MHTTPFilterBase
@public
Since:
7.0 A HTTP Filter.
 More...


mhttpfilterbase.h Source File

mhttpfilterbase.h

Go to the documentation of this file.
00001 // MHTTPFilterBase.h
00002 //
00003 // Copyright (C) 2001 Symbian Ltd.
00004
00011 #ifndef __MHTTPFILTERBASE_H__
00012 #define __MHTTPFILTERBASE_H__
00013
00014 // System includes
00015 #include <e32std.h>
00016
00017 // Forward declarations
00018 class RHTTPTransaction;
00019 class THTTPEvent;
00020 class THTTPSessionEvent;
00021
00031 //##ModelId=3A914DF9034F
00032 class MHTTPFilterBase
00033     {
00034 public:
00043     //##ModelId=3A914DF9035D
00044     IMPORT_C virtual void MHFRunL(RHTTPTransaction aTransaction, const THTTPEvent& aEvent);
00045
00051     //##ModelId=3C4C37D401C1
00052     IMPORT_C virtual void MHFSessionRunL(const THTTPSessionEvent& aEvent);
00053
00063     //##ModelId=3A914DF90359
00064     IMPORT_C virtual TInt MHFRunError(TInt aError, RHTTPTransaction aTransaction, const THTTPEvent& aEvent);
00065
00074     //##ModelId=3C4C37D302C4
00075     IMPORT_C virtual TInt MHFSessionRunError(TInt aError, const THTTPSessionEvent& aEvent);
00076     };
00077
00078
00079 #endif //    __MHTTPFILTERBASE_H__


MHTTPFilterCreationCallback.h File Reference

@public More...

Go to the source code of this file.

Compounds

class MHTTPFilterCreationCallback
@public
Since:
7.0 This class serves as a pure virtual interface required as a session callback to the client when the client requires to configure the filters that are installed.
 More...

Detailed Description

@public

Warning:
: This file contains Rose Model ID comments - please do not delete

Definition in file MHTTPFilterCreationCallback.h.


MHTTPFilterCreationCallback.h Source File

MHTTPFilterCreationCallback.h

Go to the documentation of this file.
00001 // MHTTPFilterCreationCallback.h
00002 //
00003 // Copyright (C) 2001 Symbian Ltd.
00004
00011 #ifndef __MHTTPFILTERCREATIONCALLBACK_H__
00012 #define __MHTTPFILTERCREATIONCALLBACK_H__
00013
00014 // Forward declarations
00015 class TFilterConfigurationIterator;
00016
00028 //##ModelId=3C4C0F450132
00029 class MHTTPFilterCreationCallback
00030     {
00031 public: // Methods
00043     //##ModelId=3C4C0F450150
00044     virtual void ConfigureSessionFiltersL(TFilterConfigurationIterator* aFilterConfigIter) = 0;
00045     };
00046
00047 #endif // __MHTTPFILTERCREATIONCALLBACK_H__


mhttpsessioneventcallback.h File Reference

#include <e32std.h>
#include <http/rhttptransaction.h>
#include <http/thttpevent.h>

Include dependency graph for mhttpsessioneventcallback.h:

Include dependency graph

Go to the source code of this file.

Compounds

class MHTTPSessionEventCallback
@public
Since:
7.0 The per-session callback for receiving session event callbacks.
 More...


mhttpsessioneventcallback.h Source File

mhttpsessioneventcallback.h

Go to the documentation of this file.
00001 // MHTTPSessionEventCallback.h
00002 //
00003 // Copyright (C) 2001 Symbian Ltd.
00004
00011 #ifndef __MHTTPSESSIONEVENTCALLBACK_H__
00012 #define __MHTTPSESSIONEVENTCALLBACK_H__
00013
00014 // System includes
00015 #include <e32std.h>
00016 #include <http/rhttptransaction.h>
00017 #include <http/thttpevent.h>
00018
00026 //##ModelId=3C4C0F460242
00027 class MHTTPSessionEventCallback
00028     {
00029 public: // Methods
00030
00036     //##ModelId=3C4C0F460262
00037     virtual void MHFSessionRunL(const THTTPSessionEvent& aEvent) =0;
00038
00047     //##ModelId=3C4C0F460256
00048     virtual TInt MHFSessionRunError(TInt aError, const THTTPSessionEvent& aEvent) =0;
00049     };
00050
00051
00052 #endif //   __MHTTPSESSIONEVENTCALLBACK_H__


mhttptransactioncallback.h File Reference

#include <e32std.h>
#include <http/rhttptransaction.h>
#include <http/thttpevent.h>

Include dependency graph for mhttptransactioncallback.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class MHTTPTransactionCallback
@public
Since:
7.0 The per-transaction callback for receiving HTTP events.
 More...


mhttptransactioncallback.h Source File

mhttptransactioncallback.h

Go to the documentation of this file.
00001 // MHTTPTransactionCallback.h
00002 //
00003 // Copyright (C) 2001 Symbian Ltd.
00004
00011 #ifndef __MHTTPTRANSACTIONCALLBACK_H__
00012 #define __MHTTPTRANSACTIONCALLBACK_H__
00013
00014 // System includes
00015 #include <e32std.h>
00016 #include <http/rhttptransaction.h>
00017 #include <http/thttpevent.h>
00018
00026 //##ModelId=3C4C1886022B
00027 class MHTTPTransactionCallback
00028     {
00029 public: // Methods
00030
00039     //##ModelId=3C4C1886024C
00040     virtual void MHFRunL(RHTTPTransaction aTransaction, const THTTPEvent& aEvent) =0;
00041
00051     //##ModelId=3C4C1886023F
00052     virtual TInt MHFRunError(TInt aError, RHTTPTransaction aTransaction, const THTTPEvent& aEvent) =0;
00053
00054     };
00055
00056 #endif //   __MHTTPTRANSACTIONCALLBACK_H__


MNwssOomHandler.h File Reference

@public More...

#include <wapcli.h>
#include <wsp/mwspcomethodcallback.h>

Include dependency graph for MNwssOomHandler.h:

Include dependency graph

Go to the source code of this file.

Compounds

class MNwssOomHandler
@private
Since:
7.0 This interface provides callback mechanisms used to abort methods or disconnect a session in in out-of-memory situation in the NWSS WSP Transport Handler.
 More...

Detailed Description

@public

Warning:
: This file contains Rose Model ID comments - please do not delete

Definition in file MNwssOomHandler.h.


MNwssOomHandler.h Source File

MNwssOomHandler.h

Go to the documentation of this file.
00001 // MNwssOomHandler.h
00002 //
00003 // Copyright (c) Symbian Ltd 2002
00004
00010 #ifndef __MNWSSOOMHANDLER_H__
00011 #define __MNWSSOOMHANDLER_H__
00012
00013 // System includes
00014 #include <wapcli.h>
00015 #include <wsp/mwspcomethodcallback.h>
00016
00024 //##ModelId=3C9B095502F7
00025 class MNwssOomHandler
00026     {
00027 public: // Methods
00028
00037     //##ModelId=3C9B09550321
00038     virtual void SendOomMethodAbort(MWspCOMethodCallback& aMethodToAbort, TBool aAbortOnStack) = 0;
00039
00049     //##ModelId=3C9B09550324
00050     virtual void SendOomMethodAbort(RWSPCOTrans::TTransID aTransId, TBool aAbortOnStack) = 0;
00051
00059     //##ModelId=3C9B0955031F
00060     virtual void SendOomDisconnect(TBool aDisconnectOnStack) = 0;
00061     };
00062
00063 #endif  // __MNWSSOOMHANDLER_H__


MNwssSessionEventHandler.h File Reference

@public More...

Go to the source code of this file.

Compounds

class MNwssSessionEventHandler
@private
Since:
7.0 This interface defines methods to handle each type of session event that can be received in the WSP layer of the WAP Stack.
 More...

Detailed Description

@public

Warning:
: This file contains Rose Model ID comments - please do not delete

Definition in file MNwssSessionEventHandler.h.


MNwssSessionEventHandler.h Source File

MNwssSessionEventHandler.h

Go to the documentation of this file.
00001 // MNwssSessionEventHandler.h
00002 //
00003 // Copyright (c) Symbian Ltd 2002
00004
00011 #ifndef __MNWSSSESSIONEVENTHANDLER_H__
00012 #define __MNWSSSESSIONEVENTHANDLER_H__
00013
00014
00022 //##ModelId=3C9B094E00E4
00023 class MNwssSessionEventHandler
00024     {
00025 public: // Methods
00026
00032     //##ModelId=3C9B094E0118
00033     virtual void HandleDisconnectIndL() = 0;
00034
00040     //##ModelId=3C9B094E0117
00041     virtual void HandleSuspendIndL() = 0;
00042
00048     //##ModelId=3C9B094E0116
00049     virtual void HandleResumeCnfL() = 0;
00050
00056     //##ModelId=3C9B094E010D
00057     virtual void HandleConnectCnfL() = 0;
00058
00064     //##ModelId=3C9B094E010C
00065     virtual void HandleRedirectIndL() = 0;
00066
00072     //##ModelId=3C9B094E0102
00073     virtual void HandleExceptionIndL() = 0;
00074     };
00075
00076 #endif  // __MNWSSSESSIONEVENTHANDLER_H__


MNwssTransactionEventHandler.h File Reference

@public More...

#include <wapcli.h>

Include dependency graph for MNwssTransactionEventHandler.h:

Include dependency graph

Go to the source code of this file.

Compounds

class MNwssTransactionEventHandler
@private
Since:
7.0 This interface defines methods to handle each type of transaction event that can be received in the WSP layer of the WAP Stack.
 More...

Detailed Description

@public

Warning:
: This file contains Rose Model ID comments - please do not delete

Definition in file MNwssTransactionEventHandler.h.


MNwssTransactionEventHandler.h Source File

MNwssTransactionEventHandler.h

Go to the documentation of this file.
00001 // MNwssTransactionEventHandler.h
00002 //
00003 // Copyright (c) Symbian Ltd 2002
00004
00011 #ifndef __MNWSSTRANSACTIONEVENTHANDLER_H__
00012 #define __MNWSSTRANSACTIONEVENTHANDLER_H__
00013
00014 // System includes
00015 #include <wapcli.h>
00016
00017
00026 //##ModelId=3C9B094C02EA
00027 class MNwssTransactionEventHandler
00028     {
00029 public: // Methods
00030
00037     //##ModelId=3C9B094C031C
00038     virtual void HandleMethodInvokeCnfL(RWSPCOTrans::TTransID aTransId) = 0;
00039     //##ModelId=3C9B094C0314
00046     virtual void HandleMethodResultIndL(RWSPCOTrans::TTransID aTransId) = 0;
00047     //##ModelId=3C9B094C0312
00054     virtual void HandleAbortIndL(RWSPCOTrans::TTransID aTransId) = 0;
00055     };
00056
00057 #endif  // __MNWSSTRANSACTIONEVENTHANDLER_H__


MNwssWapServer.h File Reference

@public More...

#include <wapcli.h>

Include dependency graph for MNwssWapServer.h:

Include dependency graph

Go to the source code of this file.

Compounds

class MNwssWapServer
@private
Since:
7.0 This interface provides access to the WAP Stack Server via a handle owned by the interface implementor.
 More...

Detailed Description

@public

Warning:
: This file contains Rose Model ID comments - please do not delete

Definition in file MNwssWapServer.h.


MNwssWapServer.h Source File

MNwssWapServer.h

Go to the documentation of this file.
00001 // MNwssWapServer.h
00002 //
00003 // Copyright (c) Symbian Ltd 2002
00004
00010 #ifndef __MNWSSWAPSERVER_H__
00011 #define __MNWSSWAPSERVER_H__
00012
00013 // System includes
00014 #include <wapcli.h>
00015
00023 //##ModelId=3C9B09470333
00024 class MNwssWapServer
00025     {
00026 public: // Methods
00027
00033     //##ModelId=3C9B09470347
00034     virtual RWAPServ& WapStack() = 0;
00035     };
00036
00037 #endif  // __MNWSSWAPSERVER_H__


MRxDataObserver.h File Reference

@public More...

#include <e32std.h>

Include dependency graph for MRxDataObserver.h:

Include dependency graph

Go to the source code of this file.

Compounds

class MRxDataObserver
@public
Since:
7.0 An interface to be implemented by classes that wish to receive status information from an implementation of the CRxData class.
 More...

Detailed Description

@public

Warning:
: This file contains Rose Model ID comments - please do not delete

Definition in file MRxDataObserver.h.


MRxDataObserver.h Source File

MRxDataObserver.h

Go to the documentation of this file.
00001 // MRxDataObserver.h
00002 //
00003 // Copyright (C) 2001 Symbian Ltd.
00004
00011 #ifndef __MRXDATAOBSERVER_H__
00012 #define __MRXDATAOBSERVER_H__
00013
00014 // System includes
00015 #include <e32std.h>
00016
00017 // Forward declarations
00018 class CRxData;
00019
00028 //##ModelId=3A914E570296
00029 class MRxDataObserver
00030     {
00031 public:
00039     //##ModelId=3B1E6B5800E5
00040     virtual void SetStatusL(CRxData& aRxData, TInt aStatus) =0;
00041
00042 private: // methods
00043
00048     //##ModelId=3C4C37CE035D
00049     inline virtual void MRDO_Reserved1();
00050
00055     //##ModelId=3C4C37CE0349
00056     inline virtual void MRDO_Reserved2();
00057     };
00058
00059
00060 inline void MRxDataObserver::MRDO_Reserved1()
00061     {}
00062 inline void MRxDataObserver::MRDO_Reserved2()
00063     {}
00064
00065 #endif // __MRXDATAOBSERVER_H__


MSessionPropertiesProvider.h File Reference

Go to the source code of this file.

Compounds

class | MSessionPropertiesProvider
MSessionPropertiesProvider is the interface used by CTcpClientFactory to get/set COMMs Preferences as session properties, used for multi-homing. More...

Enumerations

enum | TSecureDialogPref { EPrompt, EDoNotPrompt }
Security dialog preference. More...

Enumeration Type Documentation

enum TSecureDialogPref

Security dialog preference.

When an untrusted certificate is received, this preference determines whether a dialog has to be displayed allowing the user the option of continuing anyway.

Enumeration values:
EPrompt
EDoNotPrompt

Definition at line 17 of file MSessionPropertiesProvider.h.


MSessionPropertiesProvider.h Source File

MSessionPropertiesProvider.h

Go to the documentation of this file.
00001 // MSessionPropertiesProvider.h
00002 //
00003 // Copyright (c) 2001 Symbian Ltd.  All rights reserved.
00004 //
00005
00006
00007 #ifndef __MSESSIONPROPERTIESPROVIDER_H__
00008 #define __MSESSIONPROPERTIESPROVIDER_H__
00009
00010
00017 enum TSecureDialogPref
00018             {
00019             EPrompt,
00020             EDoNotPrompt
00021             };
00022
00023
00030 class MSessionPropertiesProvider
00031     {
00032     public:
00033
00039         virtual TBool GetCommsPrefs(TInt& aSocketServHandle, TInt& aConnectionPtr) = 0;
00040
00045         virtual void SetCommsPrefs(TInt aSocketServHandle, TInt aConnectionPtr) = 0;
00046
00050         virtual TSecureDialogPref GetSecureDialogPref() const = 0;
00051
00052     };
00053
00054 #endif // __MSESSIONPROPERTIESPROVIDER_H__


MTcpSocketObserver.h File Reference

Go to the source code of this file.

Compounds

class MHttpSocketObserver
MHttpSocketObserver is the interface used by the socket read and write active objects to call back to the transport handler when a read or write has completed. More...


MTcpSocketObserver.h Source File

MTcpSocketObserver.h

Go to the documentation of this file.
00001 // MTcpSocketObserver.h
00002 //
00003 // Copyright (c) 2001 Symbian Ltd.  All rights reserved.
00004 //
00005
00006
00007 #ifndef __MTCPSOCKETOBSERVER_H__
00008 #define __MTCPSOCKETOBSERVER_H__
00009
00013 //##ModelId=3C4C405F02C0
00014 class MHttpSocketObserver
00015     {
00016 public:
00019     //##ModelId=3C4C405F02DF
00020     virtual void WriteCompletedL(TInt aErrorCode) = 0;
00021
00024     //##ModelId=3C4C405F02D4
00025     virtual void ReadCompletedL(TInt aErrorCode) = 0;
00026     };
00027
00028 #endif // __MTCPSOCKETOBSERVER_H__


MTextModeTransportHandler.h File Reference

Go to the source code of this file.

Compounds

class MTextModeTransportHandler
MTextModeTransportHandler is the interface used by the transport framework textmode http protocol handler. More...


MTextModeTransportHandler.h Source File

MTextModeTransportHandler.h

Go to the documentation of this file.
00001 // MTextModeTransportHandler.h
00002 //
00003 // Copyright (c) 2001 Symbian Ltd.  All rights reserved.
00004 //
00005
00006
00007 #ifndef     __MTEXTMODETRANSPORTHANDLER_H__
00008 #define     __MTEXTMODETRANSPORTHANDLER_H__
00009
00010 class CTxData;
00011 class MTransportHndObs;
00012 class CHttpTcpServerLocation;
00013 class TCertInfo;
00014
00020 class MTextModeTransportHandler
00021     {
00022 public:
00025     enum TServerConnectionStatus
00026         {
00027         ENotConnected,
00028         EConnectedAndAvailable,
00029         EConnectedNotAvailable
00030         };
00031
00033     virtual void Close() =0;
00034
00037     virtual TServerConnectionStatus Status() const = 0;
00038
00039
00043     virtual const CHttpTcpServerLocation& ServerLocation() const =0;
00044
00047     virtual void SubmitL(CHttpTcpServerLocation* aServerLocation, CTxData& aData, MTransportHndObs& aObs)=0;
00048
00049
00052     virtual void CancelSubmission(CTxData& aDataToCancel) =0;
00053
00056     virtual void AckData() =0;
00057
00060     virtual void NotifyRequestDataAvailable() =0;
00061
00067     virtual TInt ServerCert(TCertInfo& aServerCert) = 0;
00068     };
00069
00070
00071 #endif //   __MTEXTMODETRANSPORTHANDLER_H__


mtransporthndobs.h File Reference

#include <e32std.h>

Include dependency graph for mtransporthndobs.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class | MTransportHndObs
An interface to be implemented by classes that wish to observe a transport handler. More...

Typedefs

typedef TUint8 | THttpRxDataStat

Enumerations

enum | THttpTransportState { EReplyComplete = 0, ESocketClosed = 1 }
Status messages sent by the transport handler. More...

enum | THttpRxDataFlags { EFoundEndOfReply = 1, EFoundConnectionClose = 2 }
Status flags returned by the transport handlers observer when it processes received data. More...

Typedef Documentation

typedef TUint8 THttpRxDataStat

Definition at line 11 of file mtransporthndobs.h.

Enumeration Type Documentation

enum THttpRxDataFlags

Status flags returned by the transport handlers observer when it processes received data.

Enumeration values:
EFoundEndOfReply | This flag is set when the observer recognises the HTTP server's end of response.
EFoundConnectionClose | This flag is set if the Connection: close header is recognised.

Definition at line 39 of file mtransporthndobs.h.

enum THttpTransportState

Status messages sent by the transport handler.

Enumeration values:
EReplyComplete | Sent when the HTTP response has been completely received.
ESocketClosed | Sent if the socket is prematurely closed.

Definition at line 16 of file mtransporthndobs.h.


mtransporthndobs.h Source File

mtransporthndobs.h

Go to the documentation of this file.
00001 // MTransportHndObs.h
00002 //
00003 // Copyright (c) 2001 Symbian Ltd.  All rights reserved.
00004 //
00005
00006 #ifndef __MTRANSPORTHNDOBS_H__
00007 #define __MTRANSPORTHNDOBS_H__
00008
00009 #include <e32std.h>
00010
00011 typedef TUint8 THttpRxDataStat;
00012 class CTxData;
00013
00014
00016 enum THttpTransportState
00017     {
00019     EReplyComplete = 0,
00021     ESocketClosed  = 1,
00022
00023 #ifdef _DEBUG
00024     ERunErrorFired          = 999,
00025     ERunLFired              = 1000,
00026     ERunLDisconnectedState  = 1001,
00027     ERunLStartingProtState  = 1002,
00028     ERunLAwaitingDNSState   = 1003,
00029     ERunLReadyToConnectState= 1004,
00030     ERunLConnectedState     = 1005,
00031     ERunLRequestingState    = 1006,
00032     ERunLPendingReplyState  = 1007,
00033     ERunLReplyingState      = 1008,
00034     ERunLIdleState          = 1009
00035 #endif
00036     };
00037
00039 enum THttpRxDataFlags
00040     {
00042     EFoundEndOfReply = 1,
00044     EFoundConnectionClose = 2
00045     };
00046
00048 //##ModelId=3A914E48014C
00049 class MTransportHndObs
00050     {
00051 public: // methods to be implemented in sub-classes
00052
00054     //##ModelId=3B1E6E370150
00055     virtual void SetStatusL(CTxData& aTrans, TInt aStatus) =0;
00056
00060     //##ModelId=3B1E6E36014F
00061     virtual THttpRxDataStat DataL(CTxData& aTrans, const TDesC8& aData) =0;
00062
00064     //##ModelId=3B1E6E350157
00065     virtual void HandleError(CTxData& aTrans, TInt aStatus) =0;
00066
00069     //##ModelId=3C4C405F023E
00070     virtual TInt CheckConnectResponseL(TDesC8& aBuffer) = 0;
00071     };
00072
00073
00074 #endif // __MTRANSPORTHNDOBS_H__


MWspAliasAddresses.h File Reference

#include <e32base.h>
#include <wsp/wsptypes.h>

Include dependency graph for MWspAliasAddresses.h:

Include dependency graph

Go to the source code of this file.

Compounds

class MWspAliasAddresses


MWspAliasAddresses.h Source File

MWspAliasAddresses.h

Go to the documentation of this file.
00001 // MWspAliasAddress.h
00002 //
00003 // Copyright (C) 2001 Symbian Ltd
00004
00011 #ifndef __MWSPALIASADDRESS_H__
00012 #define __MWSPALIASADDRESS_H__
00013
00014 // System includes
00015 #include <e32base.h>
00016 #include <wsp/wsptypes.h>
00017
00018 // Types used for arguments in this file (e.g. TWspBearer) are from the Wap namespace
00019 using namespace Wap;
00020
00039 class MWspAliasAddresses
00040     {
00041 public: // Methods
00042
00053     virtual TInt Start() const =0;
00054
00075     virtual TInt GetNext(TWspBearer& aBearer, TUint16& aPort, TPtrC8& aAddress) const =0;
00076
00084     virtual void Reset() =0;
00085
00101     virtual void AddAddressL(TWspBearer aBearer, TUint16 aPort, const TDesC8& aAddress) =0;
00102
00103     };
00104
00105 #endif  // __MWSPALIASADDRESS_H__


MWspCapabilityProvider.h File Reference

@public More...

#include <e32base.h>

Include dependency graph for MWspCapabilityProvider.h:

Include dependency graph

Go to the source code of this file.

Compounds

class MWspCapabilityProvider
@public
Since:
7.0 The MWspCapabilityProvider API supplies the capabilities proposed by the Client using the MWspCapabilityViewer API.
 More...

Detailed Description

@public

Warning:
: This file contains Rose Model ID comments - please do not delete

Definition in file MWspCapabilityProvider.h.


MWspCapabilityProvider.h Source File

MWspCapabilityProvider.h

Go to the documentation of this file.
00001 // MWspCapabilityProvider.h
00002 //
00003 // Copyright (C) 2001 Symbian Ltd
00004
00011 #ifndef __MWSPCAPABILITYPROVIDER_H__
00012 #define __MWSPCAPABILITYPROVIDER_H__
00013
00014 // System includes
00015 #include <e32base.h>
00016
00017 // Forward declarations
00018 class MWspCapabilityViewer;
00019 class MWspCapabilitySetter;
00020
00030 class MWspCapabilityProvider
00031     {
00032 public: // Methods
00033
00041     virtual const MWspCapabilityViewer& ClientCapabilities() const =0;
00042
00052     virtual MWspCapabilitySetter& ServerCapabilities() const =0;
00053     };
00054
00055 #endif  // __MWSPCAPABILITYPROVIDER_H__


MWspCapabilitySetter.h File Reference

@public More...

#include <e32base.h>
#include <wsp/wsptypes.h>

Include dependency graph for MWspCapabilitySetter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class MWspCapabilitySetter
@public
Since:
7.0 The MWspCapabilitySetter API provides an interface to set the values for a set of capabilities as defined by the WSP Specification, July 2001.
 More...

Detailed Description

@public

Warning:
: This file contains Rose Model ID comments - please do not delete

Definition in file MWspCapabilitySetter.h.


MWspCapabilitySetter.h Source File

MWspCapabilitySetter.h

Go to the documentation of this file.
00001 // MWspCapabilitySetter.h
00002 //
00003 // Copyright (C) 2001 Symbian Ltd
00004
00011 #ifndef __MWSPCAPABILITYSETTER_H__
00012 #define __MWSPCAPABILITYSETTER_H__
00013
00014 // System includes
00015 #include <e32base.h>
00016 #include <wsp/wsptypes.h>
00017
00018 // Types used for arguments in this file (e.g. TWspBearer) are from the Wap namespace
00019 using namespace Wap;
00020
00029 class MWspCapabilitySetter
00030     {
00031 public: // Methods
00032
00045     virtual void Reset(TWspCapability aCapability = EAllCapabilities) =0;
00046
00065     virtual void AddAliasAddressL(TWspBearer aBearer, TUint16 aPort, const TDesC8& aAddress) =0;
00066
00083     virtual void AddExtendedMethodL(TUint8 aPDUType, const TDesC8& aMethodName) =0;
00084
00095     virtual void AddHeaderCodePageL(TUint8 aPageCode, const TDesC8& aPageName) =0;
00096
00106     virtual void SetMethodMOR(TUint8 aMOR) =0;
00107
00117     virtual void SetPushMOR(TUint8 aMOR) =0;
00118
00134     virtual void SetProtocolOptions(TUint8 aProtocolOptions) =0;
00135
00146     virtual void SetClientSDUSize(TUint32 aSize) =0;
00147
00158     virtual void SetServerSDUSize(TUint32 aSize) =0;
00159
00171     virtual void SetClientMessageSize(TUint32 aSize) =0;
00172
00184     virtual void SetServerMessageSize(TUint32 aSize) =0;
00185
00206     virtual void AddUnknownCapabilityL(const TDesC8& aIdentifier, const TDesC8& aValue) =0;
00207
00208     };
00209
00210 #endif  // __MWSPCAPABILITYSETTER_H__


MWspCapabilityViewer.h File Reference

@public More...

#include <e32base.h>

Include dependency graph for MWspCapabilityViewer.h:

Include dependency graph

Go to the source code of this file.

Compounds

class MWspCapabilityViewer
@public
Since:
7.0 The MWspCapabiltyViewer API provides an interface to view a set of capabilities as defined by the WSP Specification, July 2001.
 More...

Detailed Description

@public

Warning:
: This file contains Rose Model ID comments - please do not delete

Definition in file MWspCapabilityViewer.h.


MWspCapabilityViewer.h Source File

MWspCapabilityViewer.h

Go to the documentation of this file.
00001 // MWspCapabilityViewer.h
00002 //
00003 // Copyright (C) 2001 Symbian Ltd
00004
00011 #ifndef __MWSPCAPABILITYVIEWER_H__
00012 #define __MWSPCAPABILITYVIEWER_H__
00013
00014 // System includes
00015 #include <e32base.h>
00016
00017 // Forward declarations
00018 class MWspAliasAddresses;
00019 class MWspExtendedMethods;
00020 class MWspHeaderCodePages;
00021 class MWspUnknownCapabilities;
00022
00031 class MWspCapabilityViewer
00032     {
00033 public: // Methods
00034
00045     virtual const MWspAliasAddresses& GetAliasAddresses() const =0;
00046
00054     virtual const MWspExtendedMethods& GetExtendedMethods() const =0;
00055
00062     virtual const MWspHeaderCodePages& GetHeaderCodePages() const =0;
00063
00071     virtual TUint8 GetMethodMOR() const =0;
00072
00080     virtual TUint8 GetPushMOR() const =0;
00081
00098     virtual TUint8 GetProtocolOptions() const =0;
00099
00109     virtual TUint32 GetClientSDUSize() const =0;
00110
00120     virtual TUint32 GetServerSDUSize() const =0;
00121
00132     virtual TUint32 GetClientMessageSize() const =0;
00133
00144     virtual TUint32 GetServerMessageSize() const =0;
00145
00161     virtual const MWspUnknownCapabilities& GetUnknownCapabilities() const =0;
00162
00163     };
00164
00165 #endif  // __MWSPCAPABILITYVIEWER_H__


MWspCLMethodCallback.h File Reference

@public More...

#include <e32base.h>

Include dependency graph for MWspCLMethodCallback.h:

Include dependency graph

Go to the source code of this file.

Compounds

class MWspCLMethodCallback
@public
Since:
7.0 The MWspCLMethodInvoker and MWspCLMethodCallback form the API that provides the WSP Connectionless Session Service Method Invocation facility, as described in the WSP Specification, July 2001.
 More...

Detailed Description

@public

Warning:
: This file contains Rose Model ID comments - please do not delete

Definition in file MWspCLMethodCallback.h.


MWspCLMethodCallback.h Source File

MWspCLMethodCallback.h

Go to the documentation of this file.
00001 // MWspCLMethodCallback.h
00002 //
00003 // Copyright (C) 2001 Symbian Ltd
00004
00011 #ifndef __MWSPCLMETHODCALLBACK_H__
00012 #define __MWSPCLMETHODCALLBACK_H__
00013
00014 // System includes
00015 #include <e32base.h>
00016
00017 // Forward declarations
00018 class MWspCLMethodInvoker;
00019
00038 class MWspCLMethodCallback
00039     {
00040 public: // Methods
00041
00060     virtual void UnitMethodResultInd(
00061                                     TInt            aStatus,
00062                                     const TDesC8&   aResponseHeaders,
00063                                     const TDesC8&   aResponseBody
00064                                     ) =0;
00065
00066     };
00067
00068 #endif  // __MWSPCLMETHODCALLBACK_H__


MWspCLMethodInvoker.h File Reference

@public More...

#include <e32base.h>

Include dependency graph for MWspCLMethodInvoker.h:

Include dependency graph

Go to the source code of this file.

Compounds

class MWspCLMethodInvoker
@public
Since:
7.0 The MWspCLMethodInvoker and MWspCLMethodCallback form the API that provides the WSP Connectionless Session Service Method Invocation facility, as described in the WSP Specification, July 2001.
 More...

Detailed Description

@public

Warning:
: This file contains Rose Model ID comments - please do not delete

Definition in file MWspCLMethodInvoker.h.


MWspCLMethodInvoker.h Source File

MWspCLMethodInvoker.h

Go to the documentation of this file.
00001 // MWspCLMethodInvoker.h
00002 //
00003 // Copyright (C) 2001 Symbian Ltd
00004
00011 #ifndef __MWSPCLMETHODINVOKER_H__
00012 #define __MWSPCLMETHODINVOKER_H__
00013
00014 // System includes
00015 #include <e32base.h>
00016
00017 // Forward declarations
00018 class MWspCLMethodCallback;
00019
00038 class MWspCLMethodInvoker
00039     {
00040 public: // Method
00041
00065     virtual void UnitMethodInvoke(
00066                                  MWspCLMethodCallback&  aMethodCallback,
00067                                  RStringF               aMethod,
00068                                  const TUriC8&          aRequestUri,
00069                                  const TDesC8&          aRequestHeader,
00070                                  const TDesC8&          aRequestBody
00071                                  ) =0;
00072
00088     virtual void CancelMethodInvoke(MWspCLMethodCallback& aMethodCallback) =0;
00089
00090     };
00091
00092 #endif  // __MWSPCLMETHODINVOKER_H__


MWspCLPushCallback.h File Reference

@public More...

#include <e32base.h>

Include dependency graph for MWspCLPushCallback.h:

Include dependency graph

Go to the source code of this file.

Compounds

class MWspCLPushCallback
@public
Since:
7.0 The MWspCLPushInvoker and MWspCLPushCallback form the API that provides the WSP Connectionless Session Service Push facility, as in the WSP Specification, July 2001.
 More...

Detailed Description

@public

Warning:
: This file contains Rose Model ID comments - please do not delete

Definition in file MWspCLPushCallback.h.


MWspCLPushCallback.h Source File

MWspCLPushCallback.h

Go to the documentation of this file.
00001 // MWspCLPushCallback.h
00002 //
00003 // Copyright (C) 2001 Symbian Ltd
00004
00011 #ifndef __MWSPCLPUSHCALLBACK_H__
00012 #define __MWSPCLPUSHCALLBACK_H__
00013
00014 // System includes
00015 #include <e32base.h>
00016
00017 // Forward declarations
00018 class MWspCLPushInvoker;
00019
00036 class MWspCLPushCallback
00037     {
00038 public: // Methods
00039
00057     virtual void UnitPushInd(
00058                             const TDesC8&   aPushHeader,
00059                             const TDesC8&   aPushBody
00060                             ) =0;
00061
00062     };
00063
00064 #endif  // __MWSPCLPUSHCALLBACK_H__
00065


MWspCLPushInvoker.h File Reference

@public More...

#include <e32base.h>

Include dependency graph for MWspCLPushInvoker.h:

Include dependency graph

Go to the source code of this file.

Compounds

class MWspCLPushInvoker
@public
Since:
7.0 The MWspCLPushInvoker and MWspCLPushCallback form the API that provides the WSP Connectionless Session Service Push facility, as in the WSP Specification, July 2001.
 More...

Detailed Description

@public

Warning:
: This file contains Rose Model ID comments - please do not delete

Definition in file MWspCLPushInvoker.h.


MWspCLPushInvoker.h Source File

MWspCLPushInvoker.h

Go to the documentation of this file.
00001 // MWspCLPushInvoker.h
00002 //
00003 // Copyright (C) 2001 Symbian Ltd
00004
00011 #ifndef __MWSPCLPUSHINVOKER_H__
00012 #define __MWSPCLPUSHINVOKER_H__
00013
00014 // System includes
00015 #include <e32base.h>
00016
00017 // Forward declarations
00018 class MWspCLPushCallback;
00019
00036 class MWspCLPushInvoker
00037     {
00038 public: // Methods
00039
00056     virtual void InitPushReceive(MWspCLPushCallback& aPushCallback) =0;
00057
00073     virtual void CancelPushReceive(MWspCLPushCallback& aPushCallback) =0;
00074
00075     };
00076
00077 #endif  // __MWSPCLPUSHINVOKER_H__
00078


MWspCOMethodCallback.h File Reference

@public More...

#include <e32std.h>
#include <wsp/wsptypes.h>

Include dependency graph for MWspCOMethodCallback.h:

Include dependency graph

Go to the source code of this file.

Compounds

class MWspCOMethodCallback
@public
Since:
7.0 The MWspCOMethodInvoker and MWspCOMethodCallback form the API that provides the WSP Connection-Orientated Session Service Method Invocation facility, as described in the WSP Specification, July 2001.
 More...

Detailed Description

@public

Warning:
: This file contains Rose Model ID comments - please do not delete

Definition in file MWspCOMethodCallback.h.


MWspCOMethodCallback.h Source File

MWspCOMethodCallback.h

Go to the documentation of this file.
00001 // MWspCOMethodCallback.h
00002 //
00003 // Copyright (C) 2001 Symbian Ltd
00004
00011 #ifndef __MWSPCOMETHODCALLBACK_H__
00012 #define __MWSPCOMETHODCALLBACK_H__
00013
00014 // System includes
00015 #include <e32std.h>
00016 #include <wsp/wsptypes.h>
00017
00018 // Forward class declarations
00019 class MWspCOMethodInvoker;
00020 class MHTTPDataSupplier;
00021
00022 // Types used for arguments in this file (e.g. TWspBearer) are from the Wap namespace
00023 using namespace Wap;
00024
00067 class MWspCOMethodCallback
00068     {
00069 public: // Methods
00070
00087     virtual void MethodInvokeCnf() =0;
00088
00104     virtual void MethodInvokeDataCnf() =0;
00105
00116     virtual void MethodAbortInd(TWspReason aReason) =0;
00117
00152     virtual void MethodResultInd(
00153                                 TInt                    aStatus,
00154                                 const TDesC8&           aResponseHeaders,
00155                                 MHTTPDataSupplier&      aResponseBody,
00156                                 TBool                   aMoreData
00157                                 ) =0;
00158
00191     virtual void MethodResultDataInd(const TDesC8& aTrailerHeaders, TBool aMoreData) =0;
00192
00193     };
00194
00195 #endif  // __MWSPCOMETHODCALLBACK_H__


MWspCOMethodInvoker.h File Reference

@public More...

#include <e32std.h>
#include <stringpool.h>

Include dependency graph for MWspCOMethodInvoker.h:

Include dependency graph

Go to the source code of this file.

Compounds

class MWspCOMethodInvoker
@public
Since:
7.0 The MWspCOMethodInvoker and MWspCOMethodCallback form the API that provides the WSP Connection-Orientated Session Service Method Invocation facility, as described in the WSP Specification, July 2001.
 More...

Detailed Description

@public

Warning:
: This file contains Rose Model ID comments - please do not delete

Definition in file MWspCOMethodInvoker.h.


MWspCOMethodInvoker.h Source File

MWspCOMethodInvoker.h

Go to the documentation of this file.
00001 // MWspCOMethodInvoker.h
00002 //
00003 // Copyright © 2002 Symbian Ltd. All rights reserved.
00004
00011 #ifndef __MWSPCOMETHODINVOKER_H__
00012 #define __MWSPCOMETHODINVOKER_H__
00013
00014 // System includes
00015 #include <e32std.h>
00016 #include <stringpool.h>
00017
00018 // Forward declarations
00019 class MWspCOMethodCallback;
00020 class MHTTPDataSupplier;
00021 class TUriC8;
00022
00065 class MWspCOMethodInvoker
00066     {
00067 public: // Methods
00068
00109     virtual void MethodInvokeReq(
00110                                 MWspCOMethodCallback&   aMethodCallback,
00111                                 RStringF                aMethod,
00112                                 const TUriC8&           aRequestUri,
00113                                 const TDesC8&           aRequestHeaders,
00114                                 const TDesC8&           aRequestBody,
00115                                 TBool                   aMoreData
00116                                 ) =0;
00117
00156     virtual void MethodInvokeDataReq(
00157                                     MWspCOMethodCallback&   aMethodCallback,
00158                                     const TDesC8&           aRequestBody,
00159                                     const TDesC8&           aTrailerHeaders,
00160                                     TBool                   aMoreData
00161                                     ) =0;
00162
00177     virtual void MethodAbortReq(MWspCOMethodCallback& aMethodCallback) =0;
00178
00199     virtual void MethodResultRes(
00200                                 MWspCOMethodCallback&   aMethodCallback,
00201                                 const TDesC8&               aAckHeaders
00202                                 ) =0;
00203
00224     virtual void MethodResultDataRes(
00225                                     MWspCOMethodCallback&   aMethodCallback,
00226                                     const TDesC8&           aAckHeaders
00227                                     ) =0;
00228
00229     };
00230
00231 #endif // __MWSPCOMETHODINVOKER_H__
00232


MWspCOMethodObserver.h File Reference

#include <e32std.h>
#include <http/framework/mrxdataobserver.h>

Include dependency graph for MWspCOMethodObserver.h:

Include dependency graph

Go to the source code of this file.

Compounds

class MWspCOMethodObserver


MWspCOMethodObserver.h Source File

MWspCOMethodObserver.h

Go to the documentation of this file.
00001 // MWspCOMethodObserver.h
00002 //
00003 // Copyright (c) Symbian Ltd 2001
00004 //
00005
00006 #ifndef __MWSPCOMETHODOBSERVER_H__
00007 #define __MWSPCOMETHODOBSERVER_H__
00008
00009 // System includes
00010 #include <e32std.h>
00011 #include <http/framework/mrxdataobserver.h>
00012
00013 // Forward declarations
00014 class CWspCOTransaction;
00015
00017
00018 //##ModelId=3C4C41AE01BD
00019 class MWspCOMethodObserver : public MRxDataObserver
00020     {
00021 public: // Methods
00022
00029     //##ModelId=3C4C41AE01D2
00030     virtual void HandleMethodAbort(CWspCOTransaction& aTransaction) =0;
00031
00036     virtual void NotifyPendingCompletingMethod() =0;
00037
00042     virtual void NotifyMethodComplete() =0;
00043
00044     };
00045
00046 #endif  // __MWSPCOMETHODOBSERVER_H__


MWspCOPushCallback.h File Reference

@public More...

#include <e32base.h>

Include dependency graph for MWspCOPushCallback.h:

Include dependency graph

Go to the source code of this file.

Compounds

class MWspCOPushCallback
@public
Since:
7.0 The MWspCOPushInvoker and MWspCOPushCallback form the API that proides the WSP Connection-Orientated Session Servise Push and Confirmed Push facilities, as decribed in the WSP Specification, July 2001.
 More...

Detailed Description

@public

Warning:
: This file contains Rose Model ID comments - please do not delete

Definition in file MWspCOPushCallback.h.


MWspCOPushCallback.h Source File

MWspCOPushCallback.h

Go to the documentation of this file.
00001 // MWspCOPushCallback.h
00002 //
00003 // Copyright (C) 2001 Symbian Ltd
00004
00011 #ifndef __MWSPCOPUSHCALLBACK_H__
00012 #define __MWSPCOPUSHCALLBACK_H__
00013
00014 // System includes
00015 #include <e32base.h>
00016
00017 // Forward declarations
00018 class MHTTPDataSupplier;
00019
00057 class MWspCOPushCallback
00058     {
00059 public: // Methods
00060
00077     virtual void PushInd(
00078                         const TDesC8&   aPushHeader,
00079                         const TDesC8&   aPushBody
00080                         ) =0;
00081
00097     virtual void ConfirmedPushInd(
00098                                  const TDesC8&  aPushHeader,
00099                                  const TDesC8&  aPushBody
00100                                  ) =0;
00101
00113     virtual void PushAbortInd(TWspReason aReason) =0;
00114
00115     };
00116
00117 #endif  // __MWSPCOPUSHCALLBACK_H__


MWspCOPushInvoker.h File Reference

@public More...

#include <e32std.h>
#include <wsp/wsptypes.h>

Include dependency graph for MWspCOPushInvoker.h:

Include dependency graph

Go to the source code of this file.

Compounds

class MWspCOPushInvoker
@public
Since:
7.0 The MWspCOPushInvoker and MWspCOPushCallback form the API that provides the WSP Connection-Orientated Session Servise Push and Confirmed Push facilities, as decribed in the WSP Specification, July 2001.
 More...

Detailed Description

@public

Warning:
: This file contains Rose Model ID comments - please do not delete

Definition in file MWspCOPushInvoker.h.


MWspCOPushInvoker.h Source File

MWspCOPushInvoker.h

Go to the documentation of this file.
00001 // MWspCOPushInvoker.h
00002 //
00003 // Copyright (C) 2001 Symbian Ltd
00004
00011 #ifndef __MWSPCOPUSHINVOKER_H__
00012 #define __MWSPCOPUSHINVOKER_H__
00013
00014 // System includes
00015 #include <e32std.h>
00016 #include <wsp/wsptypes.h>
00017
00018 // Forward declarations
00019 class MWspCOPushCallback;
00020
00059 class MWspCOPushInvoker
00060     {
00061 public: // Methods
00062
00079     virtual void PushListen(MWspCOPushCallback& aPushCallback) =0;
00080
00094     virtual void CancelPushListen(MWspCOPushCallback& aPushCallback) =0;
00095
00115     virtual void PushAbortReq(
00116                              MWspCOPushCallback&    aPushCallback,
00117                              TWspReason             aReason
00118                              ) =0;
00119
00139     virtual void ConfirmedPushRes(
00140                                  MWspCOPushCallback&    aPushCallback,
00141                                  const TDesC8&          aAckHeaders
00142                                  ) =0;
00143
00144     };
00145
00146 #endif  // __MWSPCOPUSHINVOKER_H__


MWspCORxDataCallback.h File Reference

#include <e32std.h>

Include dependency graph for MWspCORxDataCallback.h:

Include dependency graph

Go to the source code of this file.

Compounds

class MWspCORxDataCallback


MWspCORxDataCallback.h Source File

MWspCORxDataCallback.h

Go to the documentation of this file.
00001 // MWspCORxDataCallback.h
00002 //
00003 // Copyright (c) Symbian Ltd 2001
00004 //
00005
00006 #ifndef __MWSPCORXDATACALLBACK_H__
00007 #define __MWSPCORXDATACALLBACK_H__
00008
00009 #include <e32std.h>
00010
00011 //##ModelId=3C4C41B40021
00012 class MWspCORxDataCallback
00013     {
00014 public: // Methods
00015
00020     //##ModelId=3C4C41B40037
00021     virtual void AbortResponse() =0;
00022
00028     virtual void SendResponsePrimitive() =0;
00029
00030     };
00031
00032 #endif  // __MWSPCORXDATACALLBACK_H__


MWspCOSessionCallback.h File Reference

@public More...

#include <e32std.h>
#include <wsp/wsptypes.h>

Include dependency graph for MWspCOSessionCallback.h:

Include dependency graph

Go to the source code of this file.

Compounds

class MWspCOSessionCallback
@public
Since:
7.0 The MWspCOSessionInvoker and MWspCOSessionCallback form the API that provides the WSP Connection-Orientated Session Service Session Management, Session Resume and Exception Handling facilities, as described by the WSP Specification, July 2001.
 More...

Detailed Description

@public

Warning:
: This file contains Rose Model ID comments - please do not delete

Definition in file MWspCOSessionCallback.h.


MWspCOSessionCallback.h Source File

MWspCOSessionCallback.h

Go to the documentation of this file.
00001 // MWspCOSessionCallback.h
00002 //
00003 // Copyright (C) 2001 Symbian Ltd
00004
00011 #ifndef __MWSPCOSESSIONCALLBACK_H__
00012 #define __MWSPCOSESSIONCALLBACK_H__
00013
00014 // System includes
00015 #include <e32std.h>
00016 #include <wsp/wsptypes.h>
00017
00018 // Types used for arguments in this file (e.g. TWspBearer) are from the Wap namespace
00019 using namespace Wap;
00020
00044 class MWspCOSessionCallback
00045     {
00046 public: // Methods
00047
00059     virtual void ConnectCnf() =0;
00060
00074     virtual void ResumeCnf() =0;
00075
00105     virtual void DisconnectInd(
00106                               TWspReason                aReason,
00107                               TBool                     aRedirectSecurity,
00108                               TWspRedirectedAddress&    aRedirectAddress,
00109                               const TDesC8&             aErrorHeader,
00110                               const TDesC8&             aErrorBody
00111                               ) =0;
00112
00128     virtual void SuspendInd(TWspReason aReason) =0;
00129
00142     virtual void ExceptionInd(const TDesC8& aExceptionData) =0;
00143
00144     };
00145
00146
00147 #endif  // __MWSPCOSESSIONCALLBACK_H__


MWspCOSessionInvoker.h File Reference

@public More...

#include <e32std.h>
#include <wsp/wsptypes.h>

Include dependency graph for MWspCOSessionInvoker.h:

Include dependency graph

Go to the source code of this file.

Compounds

class MWspCOSessionInvoker
@public
Since:
7.0 The MWspCOSessionInvoker and MWspCOSessionCallback form the API that provides the WSP Connection-Orientated Session Service Session Management, Session Resume and Exception Handling facilities, as described by the WSP Specification, July 2001.
 More...

Detailed Description

@public

Warning:
: This file contains Rose Model ID comments - please do not delete

Definition in file MWspCOSessionInvoker.h.


MWspCOSessionInvoker.h Source File

MWspCOSessionInvoker.h

Go to the documentation of this file.
00001 // MWspCOSessionInvoker.h
00002 //
00003 // Copyright (C) 2001 Symbian Ltd
00004
00011 #ifndef __MWSPCOSESSIONINVOKER_H__
00012 #define __MWSPCOSESSIONINVOKER_H__
00013
00014 // System includes
00015 #include <e32std.h>
00016 #include <wsp/wsptypes.h>
00017
00018 // Types used for arguments in this file (e.g. TWspBearer) are from the Wap namespace
00019 using namespace Wap;
00020
00044 class MWspCOSessionInvoker
00045     {
00046 public: // Methods
00047
00059     virtual void ConnectReq() =0;
00060
00078     virtual void DisconnectReq(TWspReason aReason) =0;
00079
00099     virtual void SuspendReq() =0;
00100
00117     virtual void ResumeReq() =0;
00118
00119     };
00120
00121 #endif  // __MWSPCOSESSIONINVOKER_H__


MWspCOTxDataCallback.h File Reference

#include <e32std.h>

Include dependency graph for MWspCOTxDataCallback.h:

Include dependency graph

Go to the source code of this file.

Compounds

class MWspCOTxDataCallback


MWspCOTxDataCallback.h Source File

MWspCOTxDataCallback.h

Go to the documentation of this file.
00001 // MWspCOTxDataCallback.h
00002 //
00003 // Copyright (c) Symbian Ltd 2002
00004 //
00005
00006 #ifndef __MWSPCOTXDATACALLBACK_H__
00007 #define __MWSPCOTXDATACALLBACK_H__
00008
00009 #include <e32std.h>
00010
00011 //##ModelId=3C4C419A0151
00012 class MWspCOTxDataCallback
00013     {
00014 public: // Methods
00015
00021     virtual void SendInvokePrimitive() =0;
00022
00027     virtual void AbortInvoke() =0;
00028
00029     };
00030
00031 #endif  // __MWSPCOTXDATACALLBACK_H__


MWspExtendedMethods.h File Reference

@public More...

#include <e32base.h>
#include <wsp/wsptypes.h>

Include dependency graph for MWspExtendedMethods.h:

Include dependency graph

Go to the source code of this file.

Compounds

class MWspExtendedMethods
@public
Since:
7.0 The MWspExtendedMethods API provides an interface to a set of extended methods as defined by the WSP Specification, July 2001.
 More...

Detailed Description

@public

Warning:
: This file contains Rose Model ID comments - please do not delete

Definition in file MWspExtendedMethods.h.


MWspExtendedMethods.h Source File

MWspExtendedMethods.h

Go to the documentation of this file.
00001 // MWspExtendedMethods.h
00002 //
00003 // Copyright (C) 2001 Symbian Ltd
00004
00011 #ifndef __MWSPEXTENDEDMETHODS_H__
00012 #define __MWSPEXTENDEDMETHODS_H__
00013
00014 // System includes
00015 #include <e32base.h>
00016 #include <wsp/wsptypes.h>
00017
00037 class MWspExtendedMethods
00038     {
00039 public:
00040
00051     virtual TInt Start() const =0;
00052
00070     virtual TInt GetNext(TUint8& aPDUType, TPtrC8& aMethodName) const =0;
00071
00079     virtual void Reset() =0;
00080
00095     virtual void AddExtendedMethodL(TUint8 aPDUType, const TDesC8& aMethodName) =0;
00096
00097     };
00098
00099 #endif  // __MWSPEXTENDEDMETHODS_H__


MWspHeaderCodePages.h File Reference

@public More...

#include <e32base.h>
#include <wsp/wsptypes.h>

Include dependency graph for MWspHeaderCodePages.h:

Include dependency graph

Go to the source code of this file.

Compounds

class MWspHeaderCodePages
@public
Since:
7.0 The MWspHeaderCodePages API provides an interface to a set of header code pages as defined by the WSP Specification, July 2001.
 More...

Detailed Description

@public

Warning:
: This file contains Rose Model ID comments - please do not delete

Definition in file MWspHeaderCodePages.h.


MWspHeaderCodePages.h Source File

MWspHeaderCodePages.h

Go to the documentation of this file.
00001 // MWspHeaderCodePages.h
00002 //
00003 // Copyright (C) 2001 Symbian Ltd
00004
00011 #ifndef __MWSPHEADERCODEPAGES_H__
00012 #define __MWSPHEADERCODEPAGES_H__
00013
00014 // System includes
00015 #include <e32base.h>
00016 #include <wsp/wsptypes.h>
00017
00035 class MWspHeaderCodePages
00036     {
00037 public: // Methods
00038
00050     virtual TInt Start() const =0;
00051
00067     virtual TInt GetNext(TUint8& aPageCode, TPtrC8& aPageName) const =0;
00068
00077     virtual void Reset() =0;
00078
00090     virtual void AddHeaderCodePageL(TUint8 aPageCode, const TDesC8& aPageName) =0;
00091
00092     };
00093
00094 #endif  // __MWSPHEADERCODEPAGES_H__


MWspPrimitiveSenderCallback.h File Reference

#include <e32std.h>
#include <wsp/wsptypes.h>

Include dependency graph for MWspPrimitiveSenderCallback.h:

Include dependency graph

Go to the source code of this file.

Compounds

class MWspPrimitiveSenderCallback
The MWspPrimitiveSenderCallback is used to perform an automatic session connect. More...


MWspPrimitiveSenderCallback.h Source File

MWspPrimitiveSenderCallback.h

Go to the documentation of this file.
00001 // MWspPrimitiveSenderCallback.h
00002 //
00003 // Copyright (c) Symbian Ltd 2001
00004 //
00005
00006 #ifndef __MWSPPRIMITIVESENDERCALLBACK_H__
00007 #define __MWSPPRIMITIVESENDERCALLBACK_H__
00008
00009 #include <e32std.h>
00010 #include <wsp/wsptypes.h>
00011
00012 // Types used for arguments in this file (e.g. TWspBearer) are from the Wap namespace
00013 using namespace Wap;
00014
00018 //##ModelId=3C4C419D0213
00019 class MWspPrimitiveSenderCallback
00020     {
00021 public: // Methods
00022
00028     //##ModelId=3C4C419D0229
00029     virtual void SendPrimitiveL(TWspPrimitive aPrimitive) =0;
00030
00040     //##ModelId=3C4C419D0227
00041     virtual TInt WspPrimitiveSenderCallbackError(TInt aError) =0;
00042
00043     };
00044
00045 #endif  // __MWSPPRIMITIVESENDERCALLBACK_H__


MWspProxyInfoProvider.h File Reference

@public More...

#include <e32base.h>
#include <wsp/wsptypes.h>

Include dependency graph for MWspProxyInfoProvider.h:

Include dependency graph

Go to the source code of this file.

Compounds

class MWspProxyInfoProvider
@public
Since:
7.0 The MWspProxyInfoProvider API provides an interface to the bearer connection information that has been specified by the Client.
 More...

Detailed Description

@public

Warning:
: This file contains Rose Model ID comments - please do not delete

Definition in file MWspProxyInfoProvider.h.


MWspProxyInfoProvider.h Source File

MWspProxyInfoProvider.h

Go to the documentation of this file.
00001 // MWspProxyInfoProvider.h
00002 //
00003 // Copyright (c) 2001 Symbian Ltd.  All rights reserved.
00004
00011 #ifndef __MWSPPROXYINFOPROVIDER_H__
00012 #define __MWSPPROXYINFOPROVIDER_H__
00013
00014 // System includes
00015 #include <e32base.h>
00016 #include <wsp/wsptypes.h>
00017
00018 // Types used for arguments in this file (e.g. TWspBearer) are from the Wap namespace
00019 using namespace Wap;
00020
00029 class MWspProxyInfoProvider
00030     {
00031 public: // Methods
00032
00042     virtual const TDesC8& ProxyAddress() const =0;
00043
00054     virtual TUint16 RemotePort() const =0;
00055
00064     virtual TUint16 LocalPort() const =0;
00065
00072     virtual TWspBearer Bearer() const =0;
00073
00081     virtual const TDesC8& ServiceCentreNumber() const =0;
00082
00089     virtual TWspSession WspSessionService() const =0;
00090
00097     virtual TBool SecureConnection() const =0;
00098     };
00099
00100 #endif //   __MWSPPROXYINFOPROVIDER_H__


MWspSessionHeadersProvider.h File Reference

@public More...

#include <e32base.h>

Include dependency graph for MWspSessionHeadersProvider.h:

Include dependency graph

Go to the source code of this file.

Compounds

class MWspSessionHeadersProvider
@public
Since:
7.0 The MWspSessionHeadersProvider API provides an interface for accessing and setting the Client and Server session headers, respectively.
 More...

Detailed Description

@public

Warning:
: This file contains Rose Model ID comments - please do not delete

Definition in file MWspSessionHeadersProvider.h.


MWspSessionHeadersProvider.h Source File

MWspSessionHeadersProvider.h

Go to the documentation of this file.
00001 // MWspSessionHeadersProvider.h
00002 //
00003 // Copyright (c) 2001 Symbian Ltd.  All rights reserved.
00004
00011 #ifndef __MWSPSESSIONHEADERSPROVIDER_H__
00012 #define __MWSPSESSIONHEADERSPROVIDER_H__
00013
00014 // System includes
00015 #include <e32base.h>
00016
00028 class MWspSessionHeadersProvider
00029     {
00030 public: // Methods
00031
00038     virtual const TDesC8& ClientHeaders() const =0;
00039
00051     virtual void SetServerHeadersL(const TDesC8& aBuffer) =0;
00052     };
00053
00054 #endif //   __MWSPSESSIONHEADERSPROVIDER_H__


MWspUnknownCapabilities.h File Reference

@public More...

#include <e32base.h>
#include <wsp/wsptypes.h>

Include dependency graph for MWspUnknownCapabilities.h:

Include dependency graph

Go to the source code of this file.

Compounds

class MWspUnknownCapabilities
@public
Since:
7.0 The MWspUnknownCapabilities API provides an interface to a set of unknown capabilities as defined by the WSP Specification, July 2001.
 More...

Detailed Description

@public

Warning:
: This file contains Rose Model ID comments - please do not delete

Definition in file MWspUnknownCapabilities.h.


MWspUnknownCapabilities.h Source File

MWspUnknownCapabilities.h

Go to the documentation of this file.
00001 // MWspUnknownCapabilities.h
00002 //
00003 // Copyright (C) 2001 Symbian Ltd
00004
00011 #ifndef __MWSPUNKNOWNCAPABILITIES_H__
00012 #define __MWSPUNKNOWNCAPABILITIES_H__
00013
00014 // System includes
00015 #include <e32base.h>
00016 #include <wsp/wsptypes.h>
00017
00038 class MWspUnknownCapabilities
00039     {
00040 public: // Methods
00041
00053     virtual TInt Start() const =0;
00054
00071     virtual TInt GetNext(TPtrC8& aIdentifier, TPtrC8& aValue) const =0;
00072
00081     virtual void Reset() =0;
00082
00095     virtual void AddUnknownCapabilityL(const TDesC8& aIdentifier, const TDesC8& aValue) =0;
00096
00097     };
00098
00099 #endif  // __MWSPUNKNOWNCAPABILITIES_H__


redirect.h File Reference

#include <http/mhttpfilter.h>
#include <http/rhttpsession.h>
#include <http/cecomfilter.h>

Include dependency graph for redirect.h:

Include dependency graph

Go to the source code of this file.

Compounds

class CRedirectFilter


redirect.h Source File

redirect.h

Go to the documentation of this file.
00001 // Redirect.h
00002 //
00003 // Copyright (c) Symbian Ltd 2001
00004
00005 #ifndef __REDIRECT_H__
00006 #define __REDIRECT_H__
00007
00008 #include <http/mhttpfilter.h>
00009 #include <http/rhttpsession.h>
00010 #include <http/cecomfilter.h>
00011
00012
00013 //##ModelId=3B1E52A00353
00014 class CRedirectFilter : public CEComFilter, public MHTTPFilter
00015     {
00016  public:
00017     static CEComFilter* InstallFilterL(TAny* aSession);
00018
00019     //##ModelId=3B1E52A0039D
00020     ~CRedirectFilter();
00021
00022 public: // Methods from MHTTPFilterBase
00023
00025     //##ModelId=3B1E52A0039A
00026     virtual void MHFRunL(RHTTPTransaction aTransaction, const THTTPEvent& aEvent);
00027
00029     virtual void MHFSessionRunL(const THTTPSessionEvent& aEvent);
00030
00032     //##ModelId=3B1E52A00391
00033     virtual TInt MHFRunError(TInt aError, RHTTPTransaction aTransaction,
00034                              const THTTPEvent& aEvent);
00035
00037     virtual TInt MHFSessionRunError(TInt aError, const THTTPSessionEvent& aEvent);
00038
00039 public: // Methods from MHTTPFilter
00040
00042     //##ModelId=3B1E52A00389
00043     virtual void MHFUnload(RHTTPSession aSession, THTTPFilterHandle aHandle);
00044
00046     //##ModelId=3B1E52A00386
00047     virtual void MHFLoad(RHTTPSession aSession, THTTPFilterHandle aHandle);
00048
00049  private:
00050
00051     //##ModelId=3B1E52A00385
00052     CRedirectFilter(RHTTPSession aSession);
00054     //##ModelId=3B1E52A0037F
00055     void ConstructL(RHTTPSession aSession);
00056
00058     //##ModelId=3B1E52A0037D
00059     void HandleRedirectL(RHTTPTransaction aTransaction,THTTPEvent::TTransactionWarning aWarningEvent);
00060
00061     // Handle a 305 Use Proxy response
00062     //##ModelId=3B1E52A0037B
00063     void HandleUseProxyL(RHTTPTransaction aTransaction);
00064
00065     // Sets the uri of aRequest to aUri.  If aUri is relative then complete it
00066     // using the host information from the request uri.
00067     // Note: according to the http spec a redirect should not use a relative uri
00068     // but that does not stop some sites from doing it.
00069     void SetRedirectUriL(RHTTPRequest aRequest, const TUriParser8& aUri) const;
00070
00071  private:
00073     //##ModelId=3B1E52A00373
00074     TInt iLoadCount;
00075     //##ModelId=3BA6003B0264
00076     RStringPool iStringPool;
00077
00078     //##ModelId=3BA6003B0250
00079     RHTTPSession iSession;
00080     };
00081
00082 #endif //__REDIRECT_H_


RHeaderField.h File Reference

@public More...

#include <e32base.h>
#include <http/thttphdrval.h>
#include <http/rhttppropertyset.h>
#include <http/rhttpheaders.h>

Include dependency graph for RHeaderField.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | RHeaderField
@public
Since:
7.0 An proxy object for a single field in an HTTP header.
 More...

Variables

const TInt | KDefaultRawChunkSize = 32

Detailed Description

@public

Warning:
: This file contains Rose Model ID comments - please do not delete

Definition in file RHeaderField.h.

Variable Documentation

const TInt KDefaultRawChunkSize = 32

Definition at line 26 of file RHeaderField.h.


RHeaderField.h Source File

RHeaderField.h

Go to the documentation of this file.
00001 // RHeaderField.h
00002 //
00003 // Copyright (C) 2001 Symbian Ltd.
00004
00011 #ifndef __RHEADERFIELD_H__
00012 #define __RHEADERFIELD_H__
00013
00014 // System includes
00015 #include <e32base.h>
00016 #include <http/thttphdrval.h>
00017 #include <http/rhttppropertyset.h>
00018 #include <http/rhttpheaders.h>
00019
00020 // Forward declarations
00021 class CHeaderField;
00022 class THeaderFieldPartIter;
00023
00024 // The default chunk size for Raw data should be set to the average length of a header field when encoded in
00025 // plaintext
00026 const TInt KDefaultRawChunkSize= 32;
00027
00037 //##ModelId=3B1E52A50396
00038 class RHeaderField
00039     {
00040 public: // methods
00041
00048     //##ModelId=3BA6004002BC
00049     RHeaderField(CHeaderField& aHeaderField);
00050
00056     IMPORT_C
00057     //##ModelId=3B1E52A503C0
00058     RStringF Name() const;
00059
00067     IMPORT_C
00068     //##ModelId=3B1E52A503BF
00069     THeaderFieldPartIter PartsL();
00070
00085     IMPORT_C
00086     //##ModelId=3B1E52A503B9
00087     void RawDataL(TPtrC8& aRawData);
00088
00094     IMPORT_C
00095     //##ModelId=3BA6004002B2
00096     RHTTPHeaders Collection();
00097
00108     IMPORT_C
00109     //##ModelId=3B1E52A503B6
00110     void SetPartL(CHeaderFieldPart* aPart, TInt aIndex);
00111
00125     IMPORT_C
00126     //##ModelId=3B1E52A503B4
00127     void BeginRawDataL(TInt aChunkSize = KDefaultRawChunkSize);
00128
00140     IMPORT_C
00141     //##ModelId=3B1E52A503AB
00142     void WriteRawDataL(const TDesC8& aData);
00143
00155     IMPORT_C
00156     //##ModelId=3B1E52A503AD
00157     void WriteRawDataL(TChar aData);
00158
00167     IMPORT_C
00168     //##ModelId=3B1E52A503AA
00169     void CommitRawData();
00170
00171 private: // attributes
00172
00175     //##ModelId=3B1E52A503A2
00176     CHeaderField& iHeaderField;
00177 };
00178
00179 inline RHeaderField::RHeaderField(CHeaderField& aHeaderField)
00180     : iHeaderField(aHeaderField)
00181     {
00182     }
00183
00184 #endif // __CHEADERFIELD_H__


rhttpconnectioninfo.h File Reference

#include <e32std.h>
#include <stringpool.h>
#include <http/rhttppropertyset.h>

Include dependency graph for rhttpconnectioninfo.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class RHTTPConnectionInfo
@public
Since:
7.0 The RHTTPConnectionInfo is used for setting/getting values used for setting up a connection over a protocol.
 More...


rhttpconnectioninfo.h Source File

rhttpconnectioninfo.h

Go to the documentation of this file.
00001 // RHTTPConnectionInfo.h
00002 //
00003 // Copyright (C) 2001 Symbian Ltd.
00004
00011 #ifndef __RHTTPCONNECTIONINFO_H__
00012 #define __RHTTPCONNECTIONINFO_H__
00013
00014 // System includes
00015 #include <e32std.h>
00016 #include <stringpool.h>
00017 #include <http/rhttppropertyset.h>
00018
00052 //##ModelId=3C4C187A01CA
00053 class RHTTPConnectionInfo : public RHTTPPropertySet
00054     {
00055     };
00056
00057 #endif // __RHTTPCONNECTIONINFO_H__


rhttpfiltercollection.h File Reference

#include <e32std.h>
#include <http/thttpevent.h>
#include <stringpool.h>

Include dependency graph for rhttpfiltercollection.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class RHTTPFilterCollection
@public
Since:
7.0 A Handle on the filter collection in a session.
 More...


rhttpfiltercollection.h Source File

rhttpfiltercollection.h

Go to the documentation of this file.
00001 // RHTTPFilterCollection.h
00002 //
00003 // Copyright (C) 2001 Symbian Ltd.
00004
00011 #ifndef __RHTTPFILTERCOLLECTION_H__
00012 #define __RHTTPFILTERCOLLECTION_H__
00013
00014 // System includes
00015 #include <e32std.h>
00016 #include <http/thttpevent.h>
00017 #include <stringpool.h>
00018
00019 // Forward declarations
00020 class RHTTPSession;
00021 class MHTTPFilter;
00022 class THTTPFilterIterator;
00023
00036 //##ModelId=3C4C187C02B3
00037 class RHTTPFilterCollection
00038     {
00039  public:
00040     //##ModelId=3C4C187C02F9
00041     inline RHTTPFilterCollection();
00061     //##ModelId=3C4C187C02E5
00062     IMPORT_C void AddFilterL(MHTTPFilter& aFilter, THTTPEvent aEvent,
00063                              RStringF aHeader, TInt aStatusCode,
00064                              TInt aPosition, RStringF aName);
00065
00066
00080     //##ModelId=3C4C187C02F1
00081     IMPORT_C void AddFilterL(MHTTPFilter& aFilter, THTTPEvent aEvent,
00082                              TInt aPosition, RStringF aName);
00083
00088     //##ModelId=3C4C187C02DF
00089     IMPORT_C TBool CanChangeFilters() const;
00090
00092     //##ModelId=3C4C187C02DD
00093     IMPORT_C void RemoveFilter(RStringF aFilter);
00099     //##ModelId=3C4C187C02DB
00100     IMPORT_C THTTPFilterIterator Query(RStringF aName = RStringF());
00101
00102     //##ModelId=3C4C187C02D1
00103     inline RHTTPSession Session() const;
00104
00105  private:
00106     friend class CHTTPSession;
00107     friend class RHTTPSession;
00108
00109     //##ModelId=3C4C187C02C9
00110     CHTTPSession* iImplementation;
00111     };
00112
00113
00114 inline RHTTPFilterCollection::RHTTPFilterCollection()
00115         : iImplementation(NULL)
00116     {
00117     }
00118
00119 #endif //   __RHTTPFILTERCOLLECTION_H__


rhttpheaders.h File Reference

#include <http/thttphdrfielditer.h>
#include <http/thttphdrval.h>

Include dependency graph for rhttpheaders.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class RHTTPHeaders
@public
Since:
7.0 The collection of headers (or more correctly, header fields) associated with a message.
 More...


rhttpheaders.h Source File

rhttpheaders.h

Go to the documentation of this file.
00001 // RHTTPHeaders.h
00002 //
00003 // Copyright (C) 2001 Symbian Ltd.
00004
00011 #ifndef __RHTTPHEADERS_H__
00012 #define __RHTTPHEADERS_H__
00013
00014 // System includes
00015 #include <http/thttphdrfielditer.h>
00016 #include <http/thttphdrval.h>
00017
00033 //##ModelId=3C4C1880001A
00034 class RHTTPHeaders
00035     {
00036  public:
00039     //##ModelId=3C4C18800088
00040     inline RHTTPHeaders();
00041
00053     //##ModelId=3C4C18800081
00054     IMPORT_C TInt FieldPartsL(RStringF aFieldName) const;
00055
00065     //##ModelId=3C4C18800079
00066     IMPORT_C TInt GetField(RStringF aFieldName,
00067                                   TInt aPartIdx, THTTPHdrVal& aHeaderValue) const;
00068
00080     //##ModelId=3C4C18800076
00081     IMPORT_C TInt GetRawField(RStringF aFieldName,
00082                                TPtrC8& aRawFieldData) const;
00083
00095     //##ModelId=3C4C1880006C
00096     IMPORT_C TInt GetParam(RStringF aFieldName,
00097                                   RStringF aParamName,
00098                                   THTTPHdrVal& aReturn,
00099                                   TInt aPartIdx = 0) const;
00100
00106     //##ModelId=3C4C1880006B
00107     IMPORT_C THTTPHdrFieldIter Fields() const;
00109
00121     //##ModelId=3C4C18800060
00122     IMPORT_C void SetFieldL(RStringF aFieldName, THTTPHdrVal aFieldValue);
00123
00132     //##ModelId=3C4C18800063
00133     IMPORT_C void SetFieldL(RStringF aFieldName, THTTPHdrVal aFieldValue,
00134                             RStringF aParamName, THTTPHdrVal aParamValue);
00135
00143     //##ModelId=3C4C18800058
00144     IMPORT_C void SetParamL(RStringF aFieldName, RStringF aParamName, THTTPHdrVal aParamValue, TInt aPartIdx);
00145
00159     //##ModelId=3C4C1880004F
00160     IMPORT_C void SetRawFieldL(RStringF aFieldName,
00161                                const TDesC8& aRawFieldData,
00162                                const TDesC8& aFieldSeparator);
00163
00170     //##ModelId=3C4C1880004D
00171     IMPORT_C TInt RemoveField(RStringF aFieldName);
00172
00179     //##ModelId=3C4C18800043
00180     IMPORT_C TInt RemoveFieldPart(RStringF aFieldName, TInt aIndex);
00181
00184     //##ModelId=3C4C18800042
00185     IMPORT_C void RemoveAllFields();
00186
00188
00189
00190 private:
00191     friend class CHeaders;
00192     //##ModelId=3C4C1880003A
00193     CHeaders* iImplementation;
00194     };
00195
00196
00197 inline RHTTPHeaders::RHTTPHeaders()
00198         : iImplementation(NULL)
00199     {
00200     }
00201
00202
00203 #endif  // __RHTTPHEADERS_H__


rhttpmessage.h File Reference

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class RHTTPMessage
@public
Since:
7.0 An abstract HTTP message.
 More...


rhttpmessage.h Source File

rhttpmessage.h

Go to the documentation of this file.
00001 // RHTTPMessage.h
00002 //
00003 // Copyright (C) 2001 Symbian Ltd.
00004
00011 #ifndef __RHTTPMESSAGE_H__
00012 #define __RHTTPMESSAGE_H__
00013
00014 // Forward declarations
00015 class RHTTPHeaders;
00016 class MHTTPDataSupplier;
00017 class CMessage;
00018
00028 //##ModelId=3A375D1F0377
00029 class RHTTPMessage
00030     {
00031  public:
00033     //##ModelId=3A375DD60140
00034     inline RHTTPMessage();
00035
00037     //##ModelId=3A375DDE0368
00038     IMPORT_C RHTTPHeaders GetHeaderCollection();
00039
00044     //##ModelId=3A375DE0019E
00045     IMPORT_C void SetBody(MHTTPDataSupplier& aBody);
00046
00048     //##ModelId=3B1E66FF004E
00049     IMPORT_C void RemoveBody();
00050
00054     //##ModelId=3A914DFF01E5
00055     IMPORT_C TBool HasBody() const;
00056
00067     //##ModelId=3A375DE40190
00068     IMPORT_C MHTTPDataSupplier* Body() const;
00069
00070  protected:
00071     //##ModelId=3A914DFF01C7
00072     CMessage* iImplementation;
00073 };
00074
00075
00076 inline RHTTPMessage::RHTTPMessage()
00077         : iImplementation(NULL)
00078     {
00079     };
00080
00081
00082 #endif // __RHTTPMESSAGE_H__


rhttppropertyset.h File Reference

#include <http/thttphdrval.h>

Include dependency graph for rhttppropertyset.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class RHTTPPropertySet
@public
Since:
7.0 A set of named THTTPHdrVal objects.
 More...


rhttppropertyset.h Source File

rhttppropertyset.h

Go to the documentation of this file.
00001 // RHTTPPropertySet.h
00002 //
00003 // Copyright (C) 2001 Symbian Ltd.
00004
00011 #ifndef __RHTTPPROPERTYSET_H__
00012 #define __RHTTPPROPERTYSET_H__
00013
00014 // System includes
00015 #include <http/thttphdrval.h>
00016
00017 // Forward declarations
00018 class CHeaderFieldPart;
00019
00028 //##ModelId=3C4C188201EA
00029 class RHTTPPropertySet
00030     {
00031  public:
00035     //##ModelId=3A63217800E0
00036     IMPORT_C RHTTPPropertySet();
00037
00043     //##ModelId=3C4C1882021F
00044     IMPORT_C TBool Property(RStringF aPropertyName, THTTPHdrVal& aVal) const;
00045
00051     //##ModelId=3C4C1882021C
00052     IMPORT_C void SetPropertyL(RStringF aPropertyName, THTTPHdrVal aValue);
00053
00057     //##ModelId=3C4C18820213
00058     IMPORT_C void RemoveProperty(RStringF aPropertyName);
00059
00062     //##ModelId=3C4C18820212
00063     IMPORT_C void RemoveAllProperties();
00064
00065  protected:
00066     //##ModelId=3C4C18820208
00067     CHeaderFieldPart* iImplementation;
00068
00069     friend class CHeaderFieldPart;
00070     friend class CHTTPSession;
00071     };
00072
00073
00074
00075 #endif //   __RHTTPPROPERTYSET_H__


rhttprequest.h File Reference

#include <uri8.h>
#include <stringpool.h>
#include <http/rhttpmessage.h>

Include dependency graph for rhttprequest.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class RHTTPRequest
@public
Since:
7.0 An HTTP Request.
 More...


rhttprequest.h Source File

rhttprequest.h

Go to the documentation of this file.
00001 // RHTTPRequest.h
00002 //
00003 // Copyright (C) 2001 Symbian Ltd.
00004
00011 #ifndef __RHTTPREQUEST_H__
00012 #define __RHTTPREQUEST_H__
00013
00014 // System includes
00015 #include <uri8.h>
00016 #include <stringpool.h>
00017 #include <http/rhttpmessage.h>
00018
00028 //##ModelId=3C4C186E0191
00029 class RHTTPRequest : public RHTTPMessage
00030     {
00031  public:
00036
00037     //##ModelId=3C4C186E01B3
00038     IMPORT_C RStringF Method() const;
00040     //##ModelId=3C4C186E01B2
00041     IMPORT_C const TUriC8& URI() const;
00043
00050
00051     //##ModelId=3C4C186E01B0
00052     IMPORT_C void  SetMethod(RStringF aMethod);
00054     //##ModelId=3C4C186E01A6
00055     IMPORT_C void SetURIL(const TUriC8& aURI);
00057
00058     friend class CRequest;
00059     };
00060
00061
00062 #endif //   __RHTTPREQUEST_H__


rhttpresponse.h File Reference

#include <e32std.h>
#include <http/rhttpmessage.h>
#include <stringpool.h>

Include dependency graph for rhttpresponse.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class RHTTPResponse
@public
Since:
7.0 An HTTP Response.
 More...


rhttpresponse.h Source File

rhttpresponse.h

Go to the documentation of this file.
00001 // RHTTPResponse.h
00002 //
00003 // Copyright (C) 2001 Symbian Ltd.
00004
00011 #ifndef __RHTTPRESPONSE_H__
00012 #define __RHTTPRESPONSE_H__
00013
00014 // System includes
00015 #include <e32std.h>
00016 #include <http/rhttpmessage.h>
00017 #include <stringpool.h>
00018
00027 //##ModelId=3A375D1203B5
00028 class RHTTPResponse : public RHTTPMessage
00029     {
00030 public:
00036     //##ModelId=3A914DF801B3
00037     IMPORT_C TInt StatusCode() const;
00040     //##ModelId=3A914DF80195
00041     IMPORT_C RStringF StatusText() const;
00043     //##ModelId=3A914DF80163
00044     IMPORT_C TVersion Version() const;
00046
00055     //##ModelId=3A3765310382
00056     IMPORT_C void SetStatusCode(TInt aStatus);
00058     //##ModelId=3A914DF8019F
00059     IMPORT_C void SetStatusText(RStringF aStatusString);
00061     //##ModelId=3A914DF8016D
00062     IMPORT_C void SetVersion(TVersion aVersion);
00064
00065     friend class CResponse;
00066     };
00067
00068
00069
00070 #endif // __RHTTPRESPONSE_H__


rhttpsession.h File Reference

#include <e32std.h>
#include <uri8.h>
#include <http/rhttpconnectioninfo.h>
#include <http/rhttpfiltercollection.h>
#include <http/rhttptransaction.h>

Include dependency graph for rhttpsession.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class | RHTTPSession
@public
Since:
7.0 A session handle.
 More...

Variables

const TInt | KAnyStatusCode = -1

Variable Documentation

const TInt KAnyStatusCode = -1

Definition at line 28 of file rhttpsession.h.


rhttpsession.h Source File

rhttpsession.h

Go to the documentation of this file.
00001 // RHTTPSession.h
00002 //
00003 // Copyright (C) 2001 Symbian Ltd.
00004
00011 #ifndef __RHTTPSESSION_H__
00012 #define __RHTTPSESSION_H__
00013
00014 // System includes
00015 #include <e32std.h>
00016 #include <uri8.h>
00017 #include <http/rhttpconnectioninfo.h>
00018 #include <http/rhttpfiltercollection.h>
00019 #include <http/rhttptransaction.h>
00020
00021 // Forward declarations
00022 class MHTTPTransactionCallback;
00023 class CHTTPSession;
00024 class MHTTPSessionEventCallback;
00025 class MHTTPFilterCreationCallback;
00026 class TCertInfo;
00027
00028 const TInt KAnyStatusCode = -1;
00029
00048 //##ModelId=3C4C187B0280
00049 class RHTTPSession
00050     {
00051  public:
00055     //##ModelId=3C4C187B02EF
00056     inline RHTTPSession();
00057
00061     //##ModelId=3C4C187B02EA
00062     IMPORT_C void SetSessionEventCallback(MHTTPSessionEventCallback* aSessionEventCallback);
00063
00067     //##ModelId=3C4C187B02E6
00068     IMPORT_C void SendSessionEventL(THTTPSessionEvent aStatus, THTTPSessionEvent::TDirection aDirection,
00069                              THTTPFilterHandle aStart = THTTPFilterHandle::EClient);
00070
00073     IMPORT_C void FailSessionEvent(THTTPFilterHandle aStart = THTTPFilterHandle::EClient);
00074
00075     //##ModelId=3A49F701013F
00081     //##ModelId=3C4C187B02DA
00082     IMPORT_C void OpenL();
00083
00090     //##ModelId=3C4C187B02DB
00091     IMPORT_C void OpenL(const TDesC8& aProtocol);
00092
00104     //##ModelId=3C4C187B02DD
00105     IMPORT_C void OpenL(const TDesC8& aProtocol, MHTTPFilterCreationCallback* aSessionCallback);
00106
00116     //##ModelId=3C4C187B02D4
00117     IMPORT_C static void ListAvailableProtocolsL(RPointerArray<HBufC8>& aProtocolArray);
00118
00127     //##ModelId=3C4C187B02D0
00128     IMPORT_C RHTTPTransaction OpenTransactionL(const TUriC8& aURI,
00129                                       MHTTPTransactionCallback& aCallback,
00130                                       RStringF aMethod = RStringF());
00131
00135     //##ModelId=3C4C187B02C8
00136     IMPORT_C void Close();
00137
00138
00139     //##ModelId=3C4C187B02C7
00140     IMPORT_C  static const TStringTable& GetTable();
00141
00145     //##ModelId=3C4C187B02C6
00146     IMPORT_C RStringPool StringPool() const;
00147
00153     //##ModelId=3C4C187B02BE
00154     IMPORT_C RHTTPConnectionInfo ConnectionInfo() const;
00155
00159     //##ModelId=3C4C187B02BD
00160     inline RHTTPFilterCollection FilterCollection() const;
00161
00162
00167     //##ModelId=3C4C187B02BC
00168     IMPORT_C RHTTPHeaders RequestSessionHeadersL();
00169
00170
00174     //##ModelId=3C4C187B02B6
00175     IMPORT_C RHTTPHeaders ResponseSessionHeadersL();
00176
00180     //##ModelId=3C4C187B02B4
00181     TBool operator==(RHTTPSession aTrans) const;
00186     //##ModelId=3C4C187B02B2
00187     TBool operator!=(RHTTPSession aTrans) const;
00188
00197     //##ModelId=3C4C187B02AA
00198     IMPORT_C TInt ServerCert(TCertInfo& aServerCert);
00199
00202     //##ModelId=3C4C187B02A9
00203     IMPORT_C void ConnectL();
00204
00207     //##ModelId=3C4C187B02A8
00208     IMPORT_C void DisconnectL();
00209
00210 private:
00211     friend class RHTTPFilterCollection;
00212     friend class CHTTPSession;
00213
00214     //##ModelId=3C4C187B0296
00215     CHTTPSession* iImplementation;
00216 };
00217
00218 inline RHTTPSession::RHTTPSession()
00219         : iImplementation(0)
00220     {
00221     }
00222
00223
00224 inline RHTTPFilterCollection RHTTPSession::FilterCollection() const
00225     {
00226     RHTTPFilterCollection c;
00227     c.iImplementation = iImplementation;
00228     return c;
00229     }
00230
00231 inline TBool RHTTPSession::operator==(RHTTPSession aTrans) const
00232     {
00233     return (iImplementation == aTrans.iImplementation);
00234     };
00235 inline TBool RHTTPSession::operator!=(RHTTPSession aTrans) const
00236     {
00237     return !(*this == aTrans);
00238     };
00239
00240
00241
00242 inline RHTTPSession RHTTPFilterCollection::Session() const
00243     {
00244     RHTTPSession s;
00245     s.iImplementation = iImplementation;
00246     return s;
00247     }
00248
00249
00250
00251
00252 #endif // __RHTTPSESSION_H__


RHTTPTransaction.h File Reference

@public More...

#include <http/thttpevent.h>
#include <http/rhttpresponse.h>
#include <http/rhttprequest.h>
#include <http/rhttptransactionpropertyset.h>
#include <http/thttpfilterhandle.h>

Include dependency graph for RHTTPTransaction.h:

Include dependency graph

Go to the source code of this file.

Compounds

class RHTTPTransaction
@public
Since:
7.0 A HTTP Transaction.
 More...

Detailed Description

@public

Warning:
: This file contains Rose Model ID comments - please do not delete

Definition in file RHTTPTransaction.h.


RHTTPTransaction.h Source File

RHTTPTransaction.h

Go to the documentation of this file.
00001 // RHTTPTransaction.h
00002 //
00003 // Copyright (C) 2001 Symbian Ltd.
00004
00011 #ifndef __RHTTPTRANSACTION_H__
00012 #define __RHTTPTRANSACTION_H__
00013
00014 // System includes
00015 #include <http/thttpevent.h>
00016 #include <http/rhttpresponse.h>
00017 #include <http/rhttprequest.h>
00018 #include <http/rhttptransactionpropertyset.h>
00019 #include <http/thttpfilterhandle.h>
00020
00021 // Forward declarations
00022 class CHTTPTransaction;
00023 class MHTTPTransactionCallback;
00024 class TCertInfo;
00025
00037 //##ModelId=3C4C18860091
00038 class RHTTPTransaction
00039     {
00040  public:
00042     //##ModelId=3C4C188600F5
00043     inline RHTTPTransaction();
00044
00050     //##ModelId=3C4C188600ED
00051     IMPORT_C void SubmitL(THTTPFilterHandle aStart =
00052                           THTTPFilterHandle::EClient);
00053
00060     //##ModelId=3C4C188600EB
00061     IMPORT_C void NotifyNewRequestBodyPartL(THTTPFilterHandle aStart =
00062                                              THTTPFilterHandle::EClient);
00063
00071     //##ModelId=3C4C188600E2
00072     IMPORT_C void SendEventL(THTTPEvent aStatus,
00073                              THTTPEvent::TDirection aDirection,
00074                              THTTPFilterHandle aStart);
00075
00080 //##ModelId=3C4C188600E1
00081     IMPORT_C RHTTPResponse Response() const;
00082
00084     //##ModelId=3C4C188600DA
00085     IMPORT_C RHTTPRequest Request() const;
00086
00088     //##ModelId=3C4C188600D9
00089     IMPORT_C RHTTPSession Session() const;
00090
00095     //##ModelId=3C4C188600D8
00096     IMPORT_C RHTTPTransactionPropertySet PropertySet() const;
00097
00103     //##ModelId=3C4C188600CF
00104     IMPORT_C void Cancel(THTTPFilterHandle aStart =
00105                          THTTPFilterHandle::EClient);
00106
00111     //##ModelId=3C4C188600CE
00112     IMPORT_C void Close();
00113
00121     //##ModelId=3C4C188600C7
00122     IMPORT_C void Fail(THTTPFilterHandle aStart =
00123                        THTTPFilterHandle::ECurrentFilter);
00124
00128     //##ModelId=3C4C188600C5
00129     TBool operator==(RHTTPTransaction aTrans) const;
00133     //##ModelId=3C4C188600C3
00134     TBool operator!=(RHTTPTransaction aTrans) const;
00141     //##ModelId=3C4C188600BB
00142     IMPORT_C TInt Id() const;
00143
00152     //##ModelId=3C4C188600B9
00153     IMPORT_C TInt ServerCert(TCertInfo& aServerCert);
00154
00155 private:
00156     friend class RHTTPSession;
00157     friend class CTransaction;
00158
00159  private:
00160     //##ModelId=3C4C188600A7
00161     CTransaction* iImplementation;
00162     };
00163
00164 inline TBool RHTTPTransaction::operator==(RHTTPTransaction aTrans) const
00165     {
00166     return (iImplementation == aTrans.iImplementation);
00167     };
00168 inline TBool RHTTPTransaction::operator!=(RHTTPTransaction aTrans) const
00169     {
00170     return !(*this == aTrans);
00171     };
00172
00173 inline RHTTPTransaction::RHTTPTransaction()
00174         : iImplementation(NULL)
00175     {
00176     }
00177
00178
00179 #endif // __RHTTPTRANSACTION_H__


rhttptransactionpropertyset.h File Reference

#include <http/rhttppropertyset.h>

Include dependency graph for rhttptransactionpropertyset.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class RHTTPTransactionPropertySet
@public
Since:
7.0 The set of properties of a transaction.
 More...


rhttptransactionpropertyset.h Source File

rhttptransactionpropertyset.h

Go to the documentation of this file.
00001 // RHTTPTransactionPropertySet.h
00002 //
00003 // Copyright (C) 2001 Symbian Ltd.
00004
00011 #ifndef __RHTTPTRANSACTIONPROPERTYSET_H__
00012 #define __RHTTPTRANSACTIONPROPERTYSET_H__
00013
00014 // System includes
00015 #include <http/rhttppropertyset.h>
00016
00027 //##ModelId=3B1E670402C2
00028 class RHTTPTransactionPropertySet : public RHTTPPropertySet
00029     {
00030     };
00031
00032 #endif //   __RHTTPTRANSACTIONPROPERTYSET_H__


TClientFilter.h File Reference

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class TClientFilter


TClientFilter.h Source File

TClientFilter.h

Go to the documentation of this file.
00001 // Copyright (c) Symbian Ltd 2001
00002
00003 #ifndef __TCLIENTFILTER_H__
00004 #define __TCLIENTFILTER_H__
00005
00006 // A filter whose job is to pass events to the client while appearing
00007 // as an ordinary filter to the transaction.
00008 //##ModelId=3C4C187D032D
00009 class TClientFilter : public MHTTPFilter
00010     {
00011 public: // Methods from MHTTPFilterBase
00012
00014     //##ModelId=3C4C187D0378
00015     virtual void MHFRunL(RHTTPTransaction aTransaction, const THTTPEvent& aEvent);
00016
00018     //##ModelId=3C4C187D0376
00019     virtual void MHFSessionRunL(const THTTPSessionEvent& aEvent);
00020
00022     //##ModelId=3C4C187D036C
00023     virtual TInt MHFRunError(TInt aError, RHTTPTransaction aTransaction,
00024                              const THTTPEvent& aEvent);
00025
00027     //##ModelId=3C4C187D0369
00028     virtual TInt MHFSessionRunError(TInt aError, const THTTPSessionEvent& aEvent);
00029
00030 public: // Methods from MHTTPFilter
00031
00036     //##ModelId=3C4C187D0362
00037     virtual void MHFUnload(RHTTPSession aSession, THTTPFilterHandle aHandle);
00038
00043     //##ModelId=3C4C187D035F
00044     virtual void MHFLoad(RHTTPSession aSession, THTTPFilterHandle aHandle);
00045
00046 public: // Methods
00047
00048     //##ModelId=3C4C187D0355
00049     inline void SetSessionEventCallback(MHTTPSessionEventCallback* aSessionEventCallback);
00050
00051 private:    // Attributes
00052
00053     //##ModelId=3C4C187D034E
00054     MHTTPSessionEventCallback* iSessionEventCallback;
00055
00056     };
00057
00058
00059 inline void TClientFilter::SetSessionEventCallback(MHTTPSessionEventCallback* aSessionEventCallback)
00060     {
00061     iSessionEventCallback = aSessionEventCallback;
00062     }
00063
00064 #endif // __TCLIENTFILTER_H__


TestOom.h File Reference

@public More...

#include <e32std.h>

Include dependency graph for TestOom.h:

Include dependency graph

Go to the source code of this file.

Defines

#define | __TESTOOM(_r, _x) _r = _x
#define | __TESTOOMD(_r, _x) TInt _r = _x
#define | __DEBUGTESTLEAVE

Detailed Description

@public

Definition in file TestOom.h.

Define Documentation

#define __DEBUGTESTLEAVE

Definition at line 32 of file TestOom.h.

#define __TESTOOM | ( | _r,
 |  | _x | ) | _r = _x

Definition at line 30 of file TestOom.h.

#define __TESTOOMD | ( | _r,
 |  | _x | ) | TInt _r = _x

Definition at line 31 of file TestOom.h.


TestOom.h Source File

TestOom.h

Go to the documentation of this file.
00001 // TestOom.h
00002 //
00003 // Copyright (C) 2002 Symbian Ltd.
00004
00010 #ifndef __TESTOOM_H__
00011 #define __TESTOOM_H__
00012
00013 // System includes
00014 #include <e32std.h>
00015
00016
00017 // Testing macro, used as a wrapper to calls made to the WAP Stack.
00018 // The macro simulates allocation failures in the WAP Stack, and returns
00019 // KErrNoMemory in OOM situations when used in a heap-failure testing environment.
00020 // Also define the test-leave macro, which should be place before calls to leaving functions
00021 // in order to simulate the control paths followed should their leaves occur.
00022 #if defined (_DEBUG) && defined(__UNIT_TESTING__)
00023
00024 #define __TESTOOM(_r, _x) _r = KErrNone;{HBufC* _a=HBufC::New(4);delete _a;if (_a==NULL)_r=KErrNoMemory;else _r=_x;}
00025 #define __TESTOOMD(_r, _x) TInt _r = KErrNone;{HBufC* _a=HBufC::New(4);delete _a;if (_a==NULL)_r=KErrNoMemory;else _r=_x;}
00026 #define __DEBUGTESTLEAVE {HBufC* _a=HBufC::NewL(4);delete _a;}
00027
00028 #else
00029
00030 #define __TESTOOM(_r, _x) _r = _x
00031 #define __TESTOOMD(_r, _x) TInt _r = _x
00032 #define __DEBUGTESTLEAVE
00033
00034 #endif
00035
00036
00037 #endif // __TESTOOM_H__


TEventRegistration.h File Reference

#include "http/thttpevent.h"

Include dependency graph for TEventRegistration.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class TEventRegistration
An event's registration in the filter queue. More...


TEventRegistration.h Source File

TEventRegistration.h

Go to the documentation of this file.
00001 // TEventRegistration.h
00002 //
00003 // Copyright (c) Symbian Ltd 2001
00004
00005 #ifndef __TEVENTREGISTRATION_H__
00006 #define __TEVENTREGISTRATION_H__
00007
00008 #include "http/thttpevent.h"
00009
00011 //##ModelId=3C4C1885025C
00012 class TEventRegistration
00013     {
00014  public:
00015     //##ModelId=3C4C18850298
00016     inline TEventRegistration(THTTPEvent aEvent, TInt aDirection,
00017                               TInt aStartFilter);
00018     //##ModelId=3C4C188502A4
00019     inline TEventRegistration();
00020
00022     //##ModelId=3C4C18850290
00023     THTTPEvent iEvent;
00025     //##ModelId=3C4C18850286
00026     TInt iDirection;
00028     //##ModelId=3C4C1885027C
00029     TInt iStartFilter;
00030     };
00031
00032 inline TEventRegistration::TEventRegistration(THTTPEvent aEvent,
00033                                               TInt aDirection,
00034                                               TInt aStartFilter)
00035         : iEvent(aEvent), iDirection(aDirection), iStartFilter(aStartFilter)
00036     {
00037     };
00038
00039 inline TEventRegistration::TEventRegistration()
00040     {
00041     };
00042
00043 #endif


textmodestd.h File Reference

#include <e32std.h>

Include dependency graph for textmodestd.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Enumerations

enum THTTPTextModeProtPanic {
EInvalidHeaderValueType, EFullUrlRequired, EUriMissingAuthority, EInvalidHeaderForHTTP10,
EProtTransNotSet, ETextModeRxDataInvalidState, KRespPsNoLF, KRespPsHttpNotAtZero,
KRespPsHttpNoVersionSep, KRespPsHttpNoStatCodeSep, KRespPsHttpNoHeaderSep, KRespPsHttpInvalidHexChar,
ERespInvalid, EBadRequestComposerBuffer, ETextModeTransportHandlerNotSet, ETextModeTransportHandlerInvalidState,
EConnectionPropertyNotSet
}

Functions

_LIT8 (KCrLf,"\r\n")
_LIT8 (KColonSpace,":")
_LIT8 (KSpace,"")
_LIT8 (KFieldSeparator,"\n")
GLREF_C void Panic (THTTPTextModeProtPanic aPanic)

Enumeration Type Documentation

enum THTTPTextModeProtPanic

Enumeration values:
EInvalidHeaderValueType
EFullUrlRequired
EUriMissingAuthority
EInvalidHeaderForHTTP10
EProtTransNotSet
ETextModeRxDataInvalidState
KRespPsNoLF
KRespPsHttpNotAtZero
KRespPsHttpNoVersionSep
KRespPsHttpNoStatCodeSep
KRespPsHttpNoHeaderSep
KRespPsHttpInvalidHexChar
ERespInvalid
EBadRequestComposerBuffer
ETextModeTransportHandlerNotSet
ETextModeTransportHandlerInvalidState
EConnectionPropertyNotSet

Definition at line 19 of file textmodestd.h.

Function Documentation

_LIT8 | ( | KFieldSeparator | ,
 |  | "\n" |
 | ) |

_LIT8 | ( | KSpace | ,
 |  | "" |
 | ) |

_LIT8 | ( | KColonSpace | ,
 |  | ":" |
 | ) |

_LIT8 | ( | KCrLf | ,
 |  | "\r\n" |
 | ) |

GLREF_C void Panic ( THTTPTextModeProtPanic aPanic )


textmodestd.h Source File

textmodestd.h

Go to the documentation of this file.
00001 // textmodestd.h
00002 //
00003 // Copyright (C) 2001 Symbian Ltd
00004 //
00005
00006 // Standard constants included across the textmode module
00007
00008
00009 #ifndef     __TEXTMODESTD_H__
00010 #define     __TEXTMODESTD_H__
00011
00012 #include <e32std.h>
00013
00014 _LIT8(KCrLf, "\r\n");
00015 _LIT8(KColonSpace, ": ");
00016 _LIT8(KSpace, " ");
00017 _LIT8(KFieldSeparator, "\n");
00018
00019 enum THTTPTextModeProtPanic
00020     {
00021     EInvalidHeaderValueType,
00022     EFullUrlRequired,
00023     EUriMissingAuthority,
00024     EInvalidHeaderForHTTP10,
00025     EProtTransNotSet,
00026     ETextModeRxDataInvalidState,
00027     KRespPsNoLF,
00028     KRespPsHttpNotAtZero,
00029     KRespPsHttpNoVersionSep,
00030     KRespPsHttpNoStatCodeSep,
00031     KRespPsHttpNoHeaderSep,
00032     KRespPsHttpInvalidHexChar,
00033     ERespInvalid,
00034     EBadRequestComposerBuffer,
00035     ETextModeTransportHandlerNotSet,
00036     ETextModeTransportHandlerInvalidState,
00037     EConnectionPropertyNotSet
00038     };
00039
00040 GLREF_C void Panic(THTTPTextModeProtPanic aPanic);
00041
00042 #endif //  __TEXTMODESTD_H__


TFilterConfigurationIter.h File Reference

@public More...

#include <e32std.h>
#include <http/tfilterinformation.h>

Include dependency graph for TFilterConfigurationIter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class TFilterConfigurationIterator
@public @dependancies CHTTPSession, CEComFilter
Since:
7.0 This class can only be created and destroyed by the session.
 More...

Detailed Description

@public

Warning:
: This file contains Rose Model ID comments - please do not delete

Definition in file TFilterConfigurationIter.h.


TFilterConfigurationIter.h Source File

TFilterConfigurationIter.h

Go to the documentation of this file.
00001 // TFilterConfigurationIter.h
00002 //
00003 // Copyright (C) 2001 Symbian Ltd
00004
00011 #ifndef __TFILTERCONFIGURATIONITER_H__
00012 #define __TFILTERCONFIGURATIONITER_H__
00013
00014 // System includes
00015 #include <e32std.h>
00016
00017 // User includes
00018 #include <http/tfilterinformation.h>
00019
00020 // Forward declarations
00021 class CHTTPSession;
00022 class TSessionFilterInfo;
00023 class CFilterConfigurationIterator_UnitTestContext;
00024
00039 //##ModelId=3C4C0F45009C
00040 class TFilterConfigurationIterator
00041     {
00042 public: // Methods
00055     //##ModelId=3C4C0F45010C
00056     IMPORT_C TInt First();
00057
00068     //##ModelId=3C4C0F45010B
00069     IMPORT_C TInt Next();
00070
00080     //##ModelId=3C4C0F45010A
00081     IMPORT_C TBool AtStart();
00082
00092     //##ModelId=3C4C0F450101
00093     IMPORT_C TBool AtEnd();
00094
00109     //##ModelId=3C4C0F4500F8
00110     IMPORT_C TInt FindByDataType(const TDesC8& aDataType);
00111
00130     //##ModelId=3C4C0F4500F7
00131     IMPORT_C const TFilterInformation CurrentFilterInformation() const;
00132
00146     //##ModelId=3C4C0F4500F6
00147     IMPORT_C TInt InstallCurrentFilter() const;
00148
00159     //##ModelId=3C4C0F4500EF
00160     IMPORT_C TInt UninstallCurrentFilter() const;
00161
00162 private: // Methods
00163     // Friend class
00164     friend class CHTTPSession;
00165
00166     // Friend class for testing purposes
00167     friend class CFilterConfigurationIterator_UnitTestContext;
00168
00169     // Standard default constructor, this is private as it is designed so that only
00170     // the CHTTPSession object that create it.
00171     //##ModelId=3C4C0F4500ED
00172     TFilterConfigurationIterator(CHTTPSession* aSession);
00173
00174     // Standard destructor, this is private as it is designed so that only the
00175     // CHTTPSession object can delete it.
00176     //##ModelId=3C4C0F4500EC
00177     ~TFilterConfigurationIterator();
00178
00179 private: // Attributes
00180     // Pointer to the session implementation. This is not owned.
00181     //##ModelId=3C4C0F4500DA
00182     CHTTPSession* iSession;
00183
00184     // Pointer array containing all the information for all the filter plugins
00185     // discovered by ECom. The list is stored and owned by the session. This is
00186     // not owned.
00187     //##ModelId=3C4C0F4500D0
00188     RPointerArray<TSessionFilterInfo>& iFilterInfoList;
00189
00190     // Value conatining the index of the current filter in the list
00191     //##ModelId=3C4C0F4500C6
00192     TInt iCurrentFilterIndex;
00193
00194     // Value containing the number filters in the list
00195     //##ModelId=3C4C0F4500BC
00196     TInt iFilterCount;
00197     };
00198
00199 #endif // __TFILTERCONFIGURATIONITER_H__


TFilterInformation.h File Reference

@public More...

Go to the source code of this file.

Compounds

struct TFilterInformation
@public
Since:
7.0 This structure is used by the TFilterConfigurationIterator to hold the information of the current filter.
 More...

Detailed Description

@public

Warning:
: This file contains Rose Model ID comments - please do not delete

Definition in file TFilterInformation.h.


TFilterInformation.h Source File

TFilterInformation.h

Go to the documentation of this file.
00001 // TFilterInformation.h
00002 //
00003 // Copyright (C) 2001 Symbian Ltd
00004
00011 #ifndef __TFILTERINFORMATION_H__
00012 #define __TFILTERINFORMATION_H__
00013
00024 //##ModelId=3C4C37DF0343
00025 struct TFilterInformation
00026     {
00027 public:
00033     enum TFilterCategory
00034         {
00035         EImplicitFilter,
00036         EExplicitFilter
00037         };
00038
00040     //##ModelId=3C4C37DF03A7
00041     const TDesC& iDisplayName;
00042
00044     //##ModelId=3C4C37DF039D
00045     const TDesC8& iDataType;
00046
00048     //##ModelId=3C4C37DF038B
00049     TInt iVersion;
00050
00052     //##ModelId=3C4C37DF0381
00053     TUid iFilterUid;
00054
00056     //##ModelId=3C4C37DF0375
00057     TFilterCategory iFilterCategory;
00058
00060     //##ModelId=3C4C37DF036B
00061     TBool iInstallStatus;
00062
00076     //##ModelId=3C4C37DF03B1
00077     inline TFilterInformation(const TDesC& aDisplayName, const TDesC8& aDataType,
00078                        TInt aVersion, TUid aFilterUid,
00079                        TFilterCategory aFilterCategory, TBool aInstallStatus);
00080     };
00081
00082 // Inline constructor, initialises data members
00083 inline TFilterInformation::TFilterInformation(const TDesC& aDisplayName, const TDesC8& aDataType,
00084                                               TInt aVersion, TUid aFilterUid,
00085                                               TFilterCategory aFilterCategory, TBool aInstallStatus)
00086     :iDisplayName(aDisplayName),
00087     iDataType(aDataType),
00088     iVersion(aVersion),
00089     iFilterUid(aFilterUid),
00090     iFilterCategory(aFilterCategory),
00091     iInstallStatus(aInstallStatus)
00092     {
00093     }
00094
00095 #endif // __TFILTERINFORMATION_H__


TFilterRegistration.h File Reference

#include "http.h"

Include dependency graph for TFilterRegistration.h:

Include dependency graph

Go to the source code of this file.

Compounds

class TFilterRegistration
A registration of a filter in the filter queue. More...


TFilterRegistration.h Source File

TFilterRegistration.h

Go to the documentation of this file.
00001 // TFilterRegistration.h
00002 //
00003 // Copyright (c) Symbian Ltd 2001
00004
00005 #ifndef __TFILTERREGISTRATION_H__
00006 #define __TFILTERREGISTRATION_H__
00007
00008 #include "http.h"
00009
00011 //##ModelId=3A914DF60029
00012 class TFilterRegistration
00013     {
00014  public:
00016     //##ModelId=3A914DF60098
00017     TFilterRegistration();
00019     //##ModelId=3A914DF60099
00020     inline TFilterRegistration(MHTTPFilter& aFilter, THTTPEvent aEvent,
00021                         RStringToken aHeader, TInt aStatusCode,
00022                         TInt aPosition, RStringToken aName, TInt aHandle);
00024     //##ModelId=3A914DF6008E
00025     TBool operator==(TFilterRegistration& aThat);
00027     //##ModelId=3A914DF60084
00028     TBool operator!=(TFilterRegistration& aThat);
00029
00030  public:
00032     //##ModelId=3A914DF6007C
00033     TInt                iPosition; // This MUST be first!
00035     //##ModelId=3A914DF60070
00036     MHTTPFilter*        iFilter;
00038     //##ModelId=3A914DF6005D
00039     THTTPEvent          iEvent;
00041     //##ModelId=3A914DF60053
00042     RStringToken    iHeader;
00044     //##ModelId=3A914DF60049
00045     TInt                iStatus;
00047     //##ModelId=3A914DF6003F
00048     RStringToken    iName;
00050     //##ModelId=3A914DF60035
00051     TInt                iHandle;
00052     };
00053
00054 inline TFilterRegistration::TFilterRegistration()
00055         : iEvent(THTTPEvent::EAny)
00056     {
00057     }
00058
00059 inline TFilterRegistration::TFilterRegistration(MHTTPFilter& aFilter,
00060                                                 THTTPEvent aEvent,
00061                                                 RStringToken aHeader,
00062                                                 TInt aStatusCode,
00063                                                 TInt aPosition,
00064                                                 RStringToken aName,
00065                                                 TInt aHandle)
00066         :iPosition(aPosition), iFilter(&aFilter), iEvent(aEvent),
00067     iHeader(aHeader), iStatus(aStatusCode) , iName(aName), iHandle(aHandle)
00068     {
00069     }
00070
00071 #endif


thttpevent.h File Reference

#include <e32std.h>
#include "http/THTTPEvent.inl"

Include dependency graph for thttpevent.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class | THTTPEvent
@public
Since:
7.0 A HTTP status message.
 More...

class | THTTPSessionEvent
@public
Since:
7.0 A HTTP session status message.
 More...

Variables

const TUint | KHTTPUid = 0x1000A441
The HTTP UID.

const TUint | KHTTPMatchAnyEventUid = 0x1000A44C
Wildcard Matching UID.

const TInt | KTransactionEventBaseStatus = 0
The base status code for transaction events.

const TInt | KTransactionWarningBaseStatus = 10000
The base status code for transaction warning events.

const TInt | KSessionEventBaseStatus = 100000
The base status code for session events.

const TInt | KSessionWarningBaseStatus = 110000
The base status code for session warning events.

Variable Documentation

const TUint KHTTPMatchAnyEventUid = 0x1000A44C

Wildcard Matching UID.

When specified as part of an event then the UID event part of the match will be ignored.

Definition at line 24 of file thttpevent.h.

const TUint KHTTPUid = 0x1000A441

The HTTP UID.

This UID is used for all events defined here.

Definition at line 19 of file thttpevent.h.

const TInt KSessionEventBaseStatus = 100000

The base status code for session events.

Any number above this is a session event.

Definition at line 38 of file thttpevent.h.

const TInt KSessionWarningBaseStatus = 110000

The base status code for session warning events.

Definition at line 42 of file thttpevent.h.

const TInt KTransactionEventBaseStatus = 0

The base status code for transaction events.

Any number above this but below KSessionEventBaseStatus is a transaction event.

Definition at line 29 of file thttpevent.h.

const TInt KTransactionWarningBaseStatus = 10000

The base status code for transaction warning events.

Definition at line 33 of file thttpevent.h.


thttpevent.h Source File

thttpevent.h

Go to the documentation of this file.
00001 // THTTPEvent.h
00002 //
00003 // Copyright (C) 2001 Symbian Ltd.
00004
00011 #ifndef __THTTPEVENT_H__
00012 #define __THTTPEVENT_H__
00013
00014 // System includes
00015 #include <e32std.h>
00016
00019 const TUint KHTTPUid                = 0x1000A441;
00020
00024 const TUint KHTTPMatchAnyEventUid   =  0x1000A44C;
00025
00029 const TInt KTransactionEventBaseStatus      = 0;
00030
00033 const TInt KTransactionWarningBaseStatus    = 10000;
00034
00038 const TInt KSessionEventBaseStatus          = 100000;
00039
00042 const TInt KSessionWarningBaseStatus        = 110000;
00043
00054 //##ModelId=3C4C18740294
00055 class THTTPEvent
00056     {
00057 public:
00058
00065     enum TStandardEvent
00066         {
00070         EAll                    = KRequestPending + 1,
00074         EAnyTransactionEvent    = KRequestPending,
00078         EAnySessionEvent        = KSessionEventBaseStatus
00079         };
00080
00089     enum TTransactionEvent
00090         {
00093         ESubmit                     = KTransactionEventBaseStatus,
00096         ECancel                     = KTransactionEventBaseStatus + 1,
00100         ENotifyNewRequestBodyPart   = KTransactionEventBaseStatus + 2,
00103         EClosed                     = KTransactionEventBaseStatus + 3,
00106         EGotResponseHeaders         = KTransactionEventBaseStatus + 4,
00110         EGotResponseBodyData        = KTransactionEventBaseStatus + 5,
00113         EResponseComplete           = KTransactionEventBaseStatus + 6,
00116         EGotResponseTrailerHeaders  = KTransactionEventBaseStatus + 7,
00119         ESucceeded                  = KTransactionEventBaseStatus + 8,
00129         EFailed                     = KTransactionEventBaseStatus + 9,
00135         EUnrecoverableError         = KTransactionEventBaseStatus + 10,
00140         ETooMuchRequestData         = KTransactionEventBaseStatus + 11
00141         };
00142
00149     enum TDirection
00150         {
00153         EOutgoing,
00156         EIncoming
00157         };
00158
00164     enum TTransactionWarning
00165         {
00173         ERedirectedPermanently          = KTransactionWarningBaseStatus,
00177         ERedirectedTemporarily          = KTransactionWarningBaseStatus + 1,
00181         EMoreDataReceivedThanExpected   = KTransactionWarningBaseStatus + 2
00182         };
00183
00184 public: // Methods
00185
00190     //##ModelId=3C4C187402FB
00191     inline THTTPEvent(TInt aStatus, TUint aUID = KHTTPUid);
00192
00196     //##ModelId=3C4C18740304
00197     inline THTTPEvent(TStandardEvent aStatus = EAnyTransactionEvent);
00198
00202     //##ModelId=3C4C1874030C
00203     inline THTTPEvent(TTransactionEvent aStatus);
00204
00208     //##ModelId=3C4C187402EF
00209     inline THTTPEvent& operator=(TStandardEvent aStatus);
00210
00214     //##ModelId=3C4C187402F1
00215     inline THTTPEvent& operator=(TTransactionEvent aStatus);
00216
00218     //##ModelId=3C4C187402DA
00219     inline TBool operator==(THTTPEvent aThat) const;
00220
00222     //##ModelId=3C4C187402BD
00223     inline TBool operator!=(THTTPEvent aThat) const;
00224
00226     //##ModelId=3C4C187402DC
00227     inline TBool operator==(TStandardEvent aStatus) const;
00228
00230     //##ModelId=3C4C187402C7
00231     inline TBool operator!=(TStandardEvent aStatus) const;
00232
00234     //##ModelId=3C4C187402E4
00235     inline TBool operator==(TTransactionEvent aStatus) const;
00236
00238     //##ModelId=3C4C187402D0
00239     inline TBool operator!=(TTransactionEvent aStatus) const;
00240
00242     //##ModelId=3C4C187402BC
00243     inline TBool IsSessionEvent() const;
00244
00245 public: // Attributes
00246
00249     //##ModelId=3C4C187402B4
00250     TInt iStatus;
00251
00254     //##ModelId=3C4C187402AA
00255     TUint iUID;
00256
00257 protected: // Attributes
00260     TBool iIsSessionEventFlag;
00261
00262     };
00263
00273 class THTTPSessionEvent : public THTTPEvent
00274     {
00275 public: // Enumerations
00281     enum TSessionEvent
00282         {
00285         EConnect                            = KSessionEventBaseStatus,
00288         EDisconnect                         = KSessionEventBaseStatus + 1,
00293         EConnectedOK                        = KSessionEventBaseStatus + 2,
00298         EConnectedWithReducedCapabilities   = KSessionEventBaseStatus + 3,
00303         EDisconnected                       = KSessionEventBaseStatus + 4,
00307         EAuthenticatedOK                    = KSessionEventBaseStatus + 5,
00310         EAuthenticationFailure              = KSessionEventBaseStatus + 6,
00313         EConnectionTimedOut                 = KSessionEventBaseStatus + 7
00314         };
00315
00316     enum TSessionWarning
00317         {
00323         ENotConnected                       = KSessionWarningBaseStatus,
00328         EExceptionInfo                      = KSessionWarningBaseStatus + 1,
00335         ERedirected                         = KSessionWarningBaseStatus + 2,
00339         EAlreadyConnecting                  = KSessionWarningBaseStatus + 3,
00343         EAlreadyConnected                   = KSessionWarningBaseStatus + 4,
00347         EAlreadyDisconnecting               = KSessionWarningBaseStatus + 5,
00351         EAlreadyDisconnected                = KSessionWarningBaseStatus + 6
00352         };
00353
00354 public:
00359     inline THTTPSessionEvent(TInt aStatus, TUint aUID = KHTTPUid);
00360
00364     inline THTTPSessionEvent(TStandardEvent aStatus = EAnySessionEvent);
00365
00369     inline THTTPSessionEvent(TSessionEvent aStatus);
00370
00374     //##ModelId=3C4C187402F9
00375     inline THTTPSessionEvent& operator=(TSessionEvent aStatus);
00376
00378     //##ModelId=3C4C187402E6
00379     inline TBool operator==(TSessionEvent aStatus) const;
00380
00382     //##ModelId=3C4C187402D2
00383     inline TBool operator!=(TSessionEvent aStatus) const;
00384     };
00385
00386 #include "http/THTTPEvent.inl"
00387
00388 #endif // __THTTPEVENT_H__


thttpfilterhandle.h File Reference

#include <e32std.h>

Include dependency graph for thttpfilterhandle.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class THTTPFilterHandle
@public
Since:
7.0 A Filter registration handle.
 More...


thttpfilterhandle.h Source File

thttpfilterhandle.h

Go to the documentation of this file.
00001 // THTTPFilterHandle.h
00002 //
00003 // Copyright (C) 2001 Symbian Ltd.
00004
00011 #ifndef __THTTPFILTERHANDLE_H__
00012 #define __THTTPFILTERHANDLE_H__
00013
00014 // System includes
00015 #include <e32std.h>
00016
00028 //##ModelId=3A914DF50317
00029 class THTTPFilterHandle
00030     {
00031  public:
00032     /* Note. These are negative as values for particular filters use
00033        positive values.*/
00037     enum TStandardValues
00038         {
00039         EUndefined = 0,
00040         EClient = -1,
00041         EProtocolHandler = -2,
00042
00043         ECurrentFilter = -3
00044         };
00045  public:
00046     //##ModelId=3A914DF50336
00047     inline THTTPFilterHandle(TStandardValues aVal = EUndefined);
00048     //##ModelId=3A914DF5032D
00049     inline TBool operator==(THTTPFilterHandle aThat) const;
00050     //##ModelId=3A914DF5032B
00051     inline TBool operator!=(THTTPFilterHandle aThat) const;
00052  private:
00053     //##ModelId=3A914DF50323
00054     TInt iValue;
00055     friend class RHTTPSession;
00056     friend class RHTTPFilterCollection;
00057     friend class CHTTPSession;
00058     friend class CTransaction;
00059     };
00060
00061 inline THTTPFilterHandle::THTTPFilterHandle(TStandardValues aVal)
00062         : iValue(aVal)
00063     {
00064     }
00065
00066 inline TBool THTTPFilterHandle::operator==(THTTPFilterHandle aThat) const
00067     {
00068     return iValue == aThat.iValue;
00069     }
00070
00071 inline TBool THTTPFilterHandle::operator!=(THTTPFilterHandle aThat) const
00072     {
00073     return !(*this == aThat);
00074     }
00075
00076
00077 #endif // __THTTPFILTERHANDLE_H__


thttpfilteriterator.h File Reference

#include <e32std.h>
#include <stringpool.h>
#include <http/thttpfilterregistration.h>

Include dependency graph for thttpfilteriterator.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class THTTPFilterIterator
@public
Since:
7.0 An iterator for RHTTPFilterCollection.
 More...


thttpfilteriterator.h Source File

thttpfilteriterator.h

Go to the documentation of this file.
00001 // THTTPFilterIterator.h
00002 //
00003 // Copyright (C) 2001 Symbian Ltd.
00004
00011 #ifndef __THTTPFILTERITERATOR_H__
00012 #define __THTTPFILTERITERATOR_H__
00013
00014 // System includes
00015 #include <e32std.h>
00016 #include <stringpool.h>
00017 #include <http/thttpfilterregistration.h>
00018
00019 // Forward declarations
00020 class CHTTPSession;
00021
00033 //##ModelId=3C4C187A0152
00034 class THTTPFilterIterator
00035     {
00036  public:
00040     //##ModelId=3C4C187A01A2
00041     inline THTTPFilterIterator();
00042
00044     //##ModelId=3C4C187A019A
00045     inline void First();
00046
00048     //##ModelId=3C4C187A0199
00049     IMPORT_C TBool AtEnd() const;
00050
00052     //##ModelId=3C4C187A0198
00053     IMPORT_C THTTPFilterIterator& operator++();
00054
00056     //##ModelId=3C4C187A0190
00057     IMPORT_C const THTTPFilterRegistration& operator()() const;
00058
00060     //##ModelId=3C4C187A018F
00061     inline const THTTPFilterRegistration& operator*() const;
00062
00064     //##ModelId=3C4C187A018E
00065     inline const THTTPFilterRegistration& operator->() const;
00066
00067  private:
00068     friend class RHTTPFilterCollection;
00069
00070     //##ModelId=3C4C187A017C
00071     CHTTPSession* iImplementation;
00072
00073     //##ModelId=3C4C187A0172
00074     TInt iPos;
00075
00076     //##ModelId=3C4C187A0168
00077     RStringTokenF iName;
00078     };
00079
00080
00081 inline THTTPFilterIterator::THTTPFilterIterator()
00082         : iImplementation(NULL), iPos(0)
00083     {
00084     }
00085
00086 inline void THTTPFilterIterator::First()
00087     {
00088     iPos = -1;
00089     operator++();
00090     }
00091
00092 inline const THTTPFilterRegistration& THTTPFilterIterator::operator*() const
00093     {
00094     return operator()();
00095     }
00096
00097 inline const THTTPFilterRegistration& THTTPFilterIterator::operator->() const
00098     {
00099     return operator()();
00100     }
00101
00102
00103
00104 #endif //   __THTTPFILTERITERATOR_H__


thttpfilterregistration.h File Reference

#include <e32std.h>
#include <stringpool.h>
#include <http/thttpevent.h>

Include dependency graph for thttpfilterregistration.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class THTTPFilterRegistration
@public
Since:
7.0 A registration of a filter in the filter queue
 More...


thttpfilterregistration.h Source File

thttpfilterregistration.h

Go to the documentation of this file.
00001 // THTTPFilterRegistration.h
00002 //
00003 // Copyright (C) 2001 Symbian Ltd.
00004
00011 #ifndef __THTTPFILTERREGISTRATION_H__
00012 #define __THTTPFILTERREGISTRATION_H__
00013
00014 // System includes
00015 #include <e32std.h>
00016 #include <stringpool.h>
00017 #include <http/thttpevent.h>
00018
00019 // Forward declarations
00020 class MHTTPFilter;
00021
00029 //##ModelId=3C4C187D0188
00030 class THTTPFilterRegistration
00031     {
00032  public:
00034     //##ModelId=3C4C187D020B
00035     THTTPFilterRegistration();
00037     //##ModelId=3C4C187D0214
00038     THTTPFilterRegistration(MHTTPFilter& aFilter, THTTPEvent aEvent,
00039                         RStringTokenF aHeader, TInt aStatusCode,
00040                         TInt aPosition, RStringTokenF aName, TInt aHandle);
00042     //##ModelId=3C4C187D0201
00043     TBool operator==(THTTPFilterRegistration& aThat);
00045     //##ModelId=3C4C187D01F9
00046     TBool operator!=(THTTPFilterRegistration& aThat);
00047
00048  public:
00050     //##ModelId=3C4C187D01F6
00051     TInt                iPosition; // This MUST be first!
00053     //##ModelId=3C4C187D01E4
00054     MHTTPFilter*        iFilter;
00056     //##ModelId=3C4C187D01D8
00057     THTTPEvent          iEvent;
00059     //##ModelId=3C4C187D01C6
00060     RStringTokenF   iHeader;
00062     //##ModelId=3C4C187D01BC
00063     TInt                iStatus;
00065     //##ModelId=3C4C187D01B2
00066     RStringTokenF    iName;
00068     //##ModelId=3C4C187D01A8
00069     TInt                iHandle;
00070     };
00071
00072 inline THTTPFilterRegistration::THTTPFilterRegistration()
00073         : iEvent(THTTPEvent::EAll)
00074     {
00075     }
00076
00077 inline THTTPFilterRegistration::THTTPFilterRegistration(MHTTPFilter& aFilter,
00078                                                         THTTPEvent aEvent,
00079                                                         RStringTokenF aHeader,
00080                                                         TInt aStatusCode,
00081                                                         TInt aPosition,
00082                                                         RStringTokenF aName,
00083                                                         TInt aHandle)
00084         :iPosition(aPosition), iFilter(&aFilter), iEvent(aEvent),
00085     iHeader(aHeader), iStatus(aStatusCode) , iName(aName), iHandle(aHandle)
00086     {
00087     }
00088
00089
00090
00091 #endif // __THTTPFILTERREGISTRATION_H__


thttphdrfielditer.h File Reference

#include <e32std.h>
#include <stringpool.h>

Include dependency graph for thttphdrfielditer.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class THTTPHdrFieldIter
@public
Since:
7.0 Iterator class to iterate the fields within a RHTTPHeaders.
 More...


thttphdrfielditer.h Source File

thttphdrfielditer.h

Go to the documentation of this file.
00001 // THTTPHdrFieldIter.h
00002 //
00003 // Copyright (C) 2001 Symbian Ltd.
00004
00011 #ifndef __THTTPHDRFIELDITER_H__
00012 #define __THTTPHDRFIELDITER_H__
00013
00014 // System includes
00015 #include <e32std.h>
00016 #include <stringpool.h>
00017
00018 // Forward declarations
00019 class CHeaders;
00020
00028 //##ModelId=3A914DFD005C
00029 class THTTPHdrFieldIter
00030     {
00031 public:
00035     //##ModelId=3A914DFD0087
00036     THTTPHdrFieldIter(const CHeaders* aHeaders);
00039     //##ModelId=3A914DFD0086
00040     IMPORT_C ~THTTPHdrFieldIter();
00041
00044     //##ModelId=3A914DFD0085
00045     IMPORT_C void First();
00046
00052     //##ModelId=3A914DFD0084
00053     IMPORT_C TBool AtEnd() const;
00054
00059     //##ModelId=3A914DFD007E
00060     IMPORT_C void operator++();
00061
00067     //##ModelId=3A914DFD007D
00068     IMPORT_C RStringTokenF operator()();
00069
00070 private:
00071
00074     //##ModelId=3BA613240002
00075     void CheckInvalidation();
00076
00079     //##ModelId=3A914DFD007A
00080     const CHeaders* iHeaders;
00084     //##ModelId=3A914DFD0072
00085     TInt iPosIdx;
00086     };
00087
00088 inline THTTPHdrFieldIter::THTTPHdrFieldIter(const CHeaders* aHeaders)
00089     : iHeaders(aHeaders)
00090     {
00091     First();
00092     }
00093
00094
00095 #endif // __THTTPHDRFIELDITER_H__


thttphdrval.h File Reference

#include <e32std.h>
#include <stringpool.h>

Include dependency graph for thttphdrval.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class | THTTPHdrVal
@public
Since:
7.0 A representation of a value found in an HTTP header field.
 More...

class | TQConv


thttphdrval.h Source File

thttphdrval.h

Go to the documentation of this file.
00001 // THTTPHdrVal.h
00002 //
00003 // Copyright (C) 2001 Symbian Ltd.
00004
00011 #ifndef __THTTPHDRVAL_H__
00012 #define __THTTPHDRVAL_H__
00013
00014 // System includes
00015 #include <e32std.h>
00016 #include <stringpool.h>
00017
00034 //##ModelId=3C4C187E027A
00035 class THTTPHdrVal
00036     {
00037 public:
00041     typedef enum {
00042     KTIntVal = 0x00,
00043     KStrVal  = 0x01,
00044     KDateVal = 0x02,
00045     KStrFVal = 0x03,
00046     KNoType =  0x04
00047     } THTTPValType;
00048
00049 public: // classes
00050
00051     // A converter for 'q' parameter values; apparently real numbers in the HTTP RFC but here passed as fixed point
00052 //##ModelId=3B1E66F2024E
00053     class TQConv
00054         {
00055     public:
00057     //##ModelId=3B1E66F20282
00058         TQConv(TReal aQ);
00059
00061     //##ModelId=3B1E66F2028C
00062         TQConv(TInt aQ);
00063
00065     //##ModelId=3B1E66F20281
00066         operator TInt() const;
00067
00069     //##ModelId=3B1E66F20280
00070         operator TReal() const;
00071     private:
00073     //##ModelId=3B1E66F2027A
00074         TReal iQ;
00076     //##ModelId=3B1E66F2026E
00077         TInt iFQ;
00078         };
00079
00080 public:
00085     IMPORT_C THTTPHdrVal();
00086
00090     IMPORT_C THTTPHdrVal(TInt aIntVal);
00091
00095     IMPORT_C THTTPHdrVal(RStringF aStrVal);
00099     IMPORT_C THTTPHdrVal(RString aStrVal);
00100
00104     IMPORT_C THTTPHdrVal(TDateTime aDateVal);
00105
00110     //##ModelId=3C4C187E02F3
00111     IMPORT_C THTTPHdrVal Copy() const;
00112
00116     //##ModelId=3C4C187E02F2
00117     IMPORT_C THTTPValType Type() const;
00118
00124     //##ModelId=3C4C187E02EA
00125     IMPORT_C TInt Int() const;
00126
00132     //##ModelId=3C4C187E02E9
00133     inline operator TInt() const;
00134
00140     //##ModelId=3C4C187E02E8
00141     IMPORT_C RStringF StrF() const;
00142     //##ModelId=3C4C187E02E0
00143     IMPORT_C RString Str() const;
00144
00150     //##ModelId=3C4C187E02DF
00151     inline operator RStringF() const;
00157     //##ModelId=3C4C187E02DE
00158     inline operator RString() const;
00159
00165     //##ModelId=3C4C187E02D6
00166     IMPORT_C TDateTime DateTime() const;
00167
00173     //##ModelId=3C4C187E02D5
00174     inline operator TDateTime() const;
00175
00180     //##ModelId=3C4C187E02CC
00181     IMPORT_C void SetInt(TInt aIntVal);
00182
00187     //##ModelId=3C4C187E02CA
00188     IMPORT_C void SetStrF(RStringF aStrVal);
00192     //##ModelId=3C4C187E02C2
00193     IMPORT_C void SetStr(RString aStrVal);
00194
00198     //##ModelId=3C4C187E02C0
00199     IMPORT_C void SetDateTime(TDateTime aDateVal);
00200
00203     //##ModelId=3C4C187E02B8
00204     IMPORT_C TBool operator==(THTTPHdrVal aVal) const;
00205
00208     //##ModelId=3C4C187E02B6
00209     IMPORT_C TBool operator!=(THTTPHdrVal aVal) const;
00210
00211 private:
00216     //##ModelId=3C4C187E02AC
00217     THTTPValType iType;
00218
00220     //##ModelId=3C4C187E02A4
00221     TInt iVal;
00222     //##ModelId=3C4C187E029A
00223     TInt iMoreSpace;
00224     };
00225
00226 inline THTTPHdrVal::TQConv::TQConv(TReal aQ)
00227     : iQ(aQ), iFQ((TInt)(iQ*1000))
00228     {
00229     }
00230
00231 inline THTTPHdrVal::TQConv::TQConv(TInt aFQ)
00232     : iQ((TReal)(aFQ/1000.)), iFQ(aFQ)
00233     {
00234     }
00235
00236 inline THTTPHdrVal::TQConv::operator TInt() const
00237     {
00238     return iFQ;
00239     }
00240
00241 inline THTTPHdrVal::TQConv::operator TReal() const
00242     {
00243     return iQ;
00244     }
00245
00246 inline THTTPHdrVal::operator TInt() const
00247     {
00248     return Int();
00249     }
00250
00251 inline THTTPHdrVal::operator RStringF() const
00252     {
00253     return StrF();
00254     }
00255
00256 inline THTTPHdrVal::operator RString() const
00257     {
00258     return Str();
00259     }
00260
00261 inline THTTPHdrVal::operator TDateTime() const
00262     {
00263     return DateTime();
00264     }
00265
00266
00267
00268 #endif // __THTTPHDRVAL_H__


TNwssWspTrHndPanic.h File Reference

@public More...

#include <e32std.h>
#include "TNwssWspTrHndPanic.inl"

Include dependency graph for TNwssWspTrHndPanic.h:

Include dependency graph

Go to the source code of this file.

Compounds

class TNwssWspTrHndPanic
@private
Since:
7.0 This class provides a trivial panic utility used throughout the WSP Transport Handler.
 More...

Functions

_LIT (KStubPanicType,"NWSSWSPTH")

Detailed Description

@public

Warning:
: This file contains Rose Model ID comments - please do not delete

Definition in file TNwssWspTrHndPanic.h.

Function Documentation

_LIT | ( | KStubPanicType | ,
 |  | "NWSSWSPTH" |
 | ) |


TNwssWspTrHndPanic.h Source File

TNwssWspTrHndPanic.h

Go to the documentation of this file.
00001 // TNwssWspTrHndPanic.h
00002 //
00003 // Copyright (C) 2002 Symbian Ltd
00004
00010 #ifndef __TNWSSWSPTRHNDPANIC_H__
00011 #define __TNWSSWSPTRHNDPANIC_H__
00012
00013 // System includes
00014 #include <e32std.h>
00015
00016 // Constants used in this file
00017 _LIT(KStubPanicType, "NWSSWSPTH");
00018
00019
00026 //##ModelId=3C4C46CE0250
00027 class TNwssWspTrHndPanic
00028     {
00029 public: // type definitions
00030
00033     typedef enum
00034         {
00035         EServiceNotSupported = 1,
00036         ETransLUTOverflow = 2,
00037         EUnknownMethod = 3,
00038         EURIOverflow = 4,
00039         EWrongSessionType = 5,
00040         EWrongBearerType = 6,
00041         ECOPushNotSupported = 7,
00042         EConnectionLessNotSupported = 8,
00043         EUnknownWspEvent = 9,
00044         EEventOnUnknownTransaction = 10,
00045         EInvalidTransactionInLUT = 11,
00046         EFailedToGetSessionData = 12,
00047         EFailedToGetTransactionData = 13,
00048         EInternalCapCodecError = 14,
00049         ECapabilityOverrun = 15,
00050         EFailedToAcknowledgeTrans = 16,
00051         EFailedToReleaseTrans = 17,
00052         ELargeDataTransferNotSupported = 18,
00053         EFailedToAbortTrans = 19,
00054         ETransLUTLeakage = 20,
00055         EConnectedUponDestruction = 21,
00056         EFailedToOpenWspSession = 22,
00057         // panics that derive from specific NWSS wap stack error codes
00058         EBearerError         = 23,
00059         EPortAlreadyBound    = 24,
00060         ECannotOpenPort      = 25,
00061         ETooManyConnections  = 26,
00062         EBadConnection       = 27,
00063         EBufferTooSmall      = 28,
00064         EInvalidSession      = 29,
00065         EInvalidTransaction  = 30,
00066         EParameterError      = 31,
00067         ESessionNotConnected = 32,
00068         ENotSupported        = 33,
00069         EInvalidState        = 34,
00070         ESessionClosed       = 35,
00071         EMRUExceeded         = 36,
00072         EInvalidBufferSize   = 37,
00073         EDataNotAvailable    = 38,
00074         EErrorTimeout        = 39,
00075         //
00076         EMORExceeded         = 40,
00077         EDeferedMethodFailed = 41,
00078         //
00079         EInsufficientCryptoStrength = 42,
00080         //
00081         EUnknownPanic = 999
00082         } TNwssWspTrHndPanicCode;
00083
00084 public: // methods
00085
00091     //##ModelId=3C4C46CE0264
00092     inline static void Panic(TNwssWspTrHndPanicCode aPanic);
00093
00094     };
00095
00096
00097 // Include inline method definitions
00098 #include "TNwssWspTrHndPanic.inl"
00099
00100 #endif // __TNWSSWSPTRHNDPANIC_H__


TProxyInfo.h File Reference

#include <e32base.h>
#include <stringpool.h>
#include <wsp/wsptypes.h>
#include "TProxyInfo.inl"

Include dependency graph for TProxyInfo.h:

Include dependency graph

Go to the source code of this file.

Compounds

class TProxyInfo
The TProxyInfo type contains the information that defines a connection to a proxy that is capable of establishing a WSP session. More...


TProxyInfo.h Source File

TProxyInfo.h

Go to the documentation of this file.
00001 // TProxyInfo.h
00002 //
00003 // Copyright (C) 2001 Symbian Ltd
00004 //
00005
00006 #ifndef __TPROXYINFO_H__
00007 #define __TPROXYINFO_H__
00008
00009 #include <e32base.h>
00010 #include <stringpool.h>
00011 #include <wsp/wsptypes.h>
00012
00013 // Types used for arguments in this file (e.g. TWspBearer) are from the Wap namespace
00014 using namespace Wap;
00015
00021 //##ModelId=3C4C419F02FC
00022 class TProxyInfo
00023     {
00024 public: // Methods
00025
00031     //##ModelId=3C4C419F0374
00032     TBool operator==(const TProxyInfo& aProxyInfo) const;
00033
00040     //##ModelId=3C4C419F036A
00041     inline TBool operator!=(const TProxyInfo& aProxyInfo) const;
00042
00049     //##ModelId=3C4C419F0360
00050     inline void Close();
00051
00052 public: // Attributes
00053
00057     //##ModelId=3C4C419F0358
00058     RStringF            iProxyAddress;
00059
00062     //##ModelId=3C4C419F034E
00063     TWspBearer          iBearer;
00064
00067     //##ModelId=3C4C419F0344
00068     TUint16             iLocalPort;
00069
00072     //##ModelId=3C4C419F033A
00073     TUint16             iRemotePort;
00074
00078     //##ModelId=3C4C419F0326
00079     RStringF            iServiceCentreNumber;
00080
00083     //##ModelId=3C4C419F031C
00084     TWspSession         iSessionType;
00085
00088     //##ModelId=3C4C419F0312
00089     TBool               iSecureConnection;
00090
00091     };
00092
00093 #include "TProxyInfo.inl"
00094
00095 #endif  // __TPROXYINFO_H__


TTextHeaderUtils.h File Reference

@public More...

Go to the source code of this file.

Compounds

class TTextHeaderUtils
Utility class providing some text processing utilities useful when dealing with HTTP headers. More...

Detailed Description

@public

Warning:
: This file contains Rose Model ID comments please do not delete

Definition in file TTextHeaderUtils.h.


TTextHeaderUtils.h Source File

TTextHeaderUtils.h

Go to the documentation of this file.
00001 //
00002 // TTextHeaderUtils.h
00003 // Copyright (c) Symbian Ltd 2001
00004 //
00012 #ifndef __TTEXTHEADERUTILS_H__
00013 #define __TTEXTHEADERUTILS_H__
00014
00028 //##ModelId=3BA6132C0022
00029 class TTextHeaderUtils
00030     {
00031 public:
00035     //##ModelId=3BA6132C0060
00036     IMPORT_C static void TrimWsLeft(TPtrC8& aData);
00037
00041     //##ModelId=3BA6132C005E
00042     IMPORT_C static void TrimWsRight(TPtrC8& aData);
00043
00046     //##ModelId=3BA6132C005B
00047     IMPORT_C static void TrimWsBothEnds(TPtrC8& aData);
00048
00053     //##ModelId=3BA6132C0050
00054     IMPORT_C static TInt ExtractNextTokenFromList(TPtrC8& aBuffer, TPtrC8& aToken, TChar aSeperator);
00055
00060     //##ModelId=3BA6132C0057
00061     IMPORT_C static TInt ExtractNextTokenFromList(TPtrC8& aBuffer, TPtrC8& aToken, const TDesC8& aSeperator);
00062
00068     //##ModelId=3BA6132C004C
00069     IMPORT_C static TInt ExtractIntegerValueL(TPtrC8& aBuffer, TInt& aIntVal, TBool aAllowNonWsTerminator);
00070
00074     //##ModelId=3BA6132C0039
00075     IMPORT_C static TInt ExtractQuotedStringL(TPtrC8& aBuffer, TPtrC8& aQuStrVal);
00076
00077     };
00078
00079 #endif //__TTEXTHEADERUTILS_H__


ValidationFilter.h File Reference

#include <e32std.h>
#include <e32base.h>
#include <http/mhttpfilter.h>
#include <http/rhttpsession.h>
#include "httplogger.h"
#include <http/cecomfilter.h>

Include dependency graph for ValidationFilter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class CValidationFilter
The validation filter checks requests and responses to ensure that they are valid. More...


ValidationFilter.h Source File

ValidationFilter.h

Go to the documentation of this file.
00001 //  ValidationFilter.h
00002 //
00003 // Copyright (c) Symbian Ltd. 2001
00004
00005
00006 #ifndef     __VALIDATIONFILTER_H__
00007 #define     __VALIDATIONFILTER_H__
00008
00009 #include <e32std.h>
00010 #include <e32base.h>
00011 #include <http/mhttpfilter.h>
00012 #include <http/rhttpsession.h>
00013 #include "httplogger.h"
00014 #include <http/cecomfilter.h>
00015
00016
00021 //##ModelId=3B1E52AC018D
00022 class CValidationFilter : public CEComFilter, public MHTTPFilter
00023     {
00024 public:
00025     static CEComFilter* InstallFilterL(TAny* aSession);
00026     //##ModelId=3B1E52AC0239
00027     ~CValidationFilter();
00028
00029 public: // Methods from MHTTPFilterBase
00030
00032     //##ModelId=3B1E52AC022F
00033     virtual void MHFRunL(RHTTPTransaction aTransaction, const THTTPEvent& aEvent);
00034
00036     virtual void MHFSessionRunL(const THTTPSessionEvent& aEvent);
00037
00039     //##ModelId=3BA600490296
00040     virtual TInt MHFRunError(TInt aError, RHTTPTransaction aTransaction,
00041                              const THTTPEvent& aEvent);
00042
00044     virtual TInt MHFSessionRunError(TInt aError, const THTTPSessionEvent& aEvent);
00045
00046 public: // Methods from MHTTPFilter
00047
00049     //##ModelId=3B1E52AC0225
00050     virtual void MHFUnload(RHTTPSession aSession, THTTPFilterHandle aHandle);
00051
00053     virtual void MHFLoad(RHTTPSession aSession, THTTPFilterHandle aHandle);
00054
00055 private:
00056     // Constructor
00057     //##ModelId=3B1E52AC0224
00058      CValidationFilter();
00059     // For 2 phase construction. Also installs the filter.
00060     //##ModelId=3B1E52AC0219
00061     void ConstructL(RHTTPSession aSession);
00062
00063     //##ModelId=3B1E52AC020F
00064     void ValidateRequestMethodL(RHTTPTransaction aTransaction);
00065
00066     //##ModelId=3B1E52AC01FB
00067     TBool ValidateRequestHeadersL(RHTTPTransaction aTransaction);
00068
00069     //##ModelId=3B1E52AC01E7
00070     void ValidateRequestGetL(RHTTPTransaction aTransaction);
00071     //##ModelId=3B1E52AC01DE
00072     void ValidateRequestPostL(RHTTPTransaction aTransaction);
00073     //##ModelId=3B1E52AC01D5
00074     void ValidateRequestPutL(RHTTPTransaction aTransaction);
00075     //##ModelId=3B1E52AC01D3
00076     void ValidateRequestTraceL(RHTTPTransaction aTransaction);
00077     //##ModelId=3B1E52AC01C9
00078     void ValidateRequestHeadL(RHTTPTransaction aTransaction);
00079
00080     void ValidateRequestOptionsL(RHTTPTransaction aTransaction);
00081
00082     //##ModelId=3B1E52AC0205
00086     //##ModelId=3BA60049020A
00087     TBool ValidateResponseStatusCode(RHTTPTransaction aTransaction);
00088
00092     //##ModelId=3BA6004901CE
00093     TBool RequestFailIfContainsBodyL(RHTTPTransaction aTransaction);
00094
00099     //##ModelId=3BA600490174
00100     void FailAndCancelL(RHTTPTransaction aTransaction, THTTPEvent aStatus);
00101
00102
00103 private:
00104     //##ModelId=3B1E52AC01C1
00105     TBool iTransactionFailed;
00106
00107     //##ModelId=3B1E52AC01A3
00108     RHTTPMessage iCurrentMessage;   // it's a small object
00109     //##ModelId=3B1E52AC019B
00110     RStringPool iStringPool;
00111     // HTTP logger handle, debug only.
00112     __DECLARE_LOG
00113     };
00114
00115
00116 #endif //   __VALIDATIONFILTER_H__


wsp.h File Reference

@public More...

#include <wsp/CWspTransportHandler.h>
#include <wsp/MWspCapabilityProvider.h>
#include <wsp/MWspCapabilitySetter.h>
#include <wsp/MWspCapabilityViewer.h>
#include <wsp/MWspCLMethodCallback.h>
#include <wsp/MWspCLMethodInvoker.h>
#include <wsp/MWspCLPushCallback.h>
#include <wsp/MWspCLPushInvoker.h>
#include <wsp/MWspCOPushCallback.h>
#include <wsp/MWspCOPushInvoker.h>
#include <wsp/MWspCOSessionCallback.h>
#include <wsp/MWspCOSessionInvoker.h>
#include <wsp/MWspCOMethodCallback.h>
#include <wsp/MWspCOMethodInvoker.h>
#include <wsp/WspTypes.h>

Include dependency graph for wsp.h:

Include dependency graph

Go to the source code of this file.

Detailed Description

@public

Warning:
: This file contains Rose Model ID comments - please do not delete

Definition in file wsp.h.


wsp.h Source File

wsp.h

Go to the documentation of this file.
00001 // wsp.h
00002 //
00003 // Copyright (C) 2001 Symbian Ltd
00004
00011 #ifndef __WSP_H__
00012 #define __WSP_H__
00013
00014 // System includes
00015 #include <wsp/CWspTransportHandler.h>
00016 #include <wsp/MWspCapabilityProvider.h>
00017 #include <wsp/MWspCapabilitySetter.h>
00018 #include <wsp/MWspCapabilityViewer.h>
00019 #include <wsp/MWspCLMethodCallback.h>
00020 #include <wsp/MWspCLMethodInvoker.h>
00021 #include <wsp/MWspCLPushCallback.h>
00022 #include <wsp/MWspCLPushInvoker.h>
00023 #include <wsp/MWspCOPushCallback.h>
00024 #include <wsp/MWspCOPushInvoker.h>
00025 #include <wsp/MWspCOSessionCallback.h>
00026 #include <wsp/MWspCOSessionInvoker.h>
00027 #include <wsp/MWspCOMethodCallback.h>
00028 #include <wsp/MWspCOMethodInvoker.h>
00029 #include <wsp/WspTypes.h>
00030
00031 #endif // __WSP_H__
00032
00033


WspError.h File Reference

#include <e32std.h>
#include <httperr.h>

Include dependency graph for WspError.h:

Include dependency graph

Go to the source code of this file.

Enumerations

enum TWspError {
KWspErrServiceNumberNotDefined = KWspErrorBase, KWspErrAccessPointNotSetUp = KWspErrorBase - 1, KWspErrBadRedirectedAddressData = KWspErrorBase - 2, KWspErrBearerNotSupported = KWspErrorBase - 3,
KWspErrRequestTooBig = KWspErrorBase - 4, KWspErrStreamedRequestDataNotSupported = KWspErrorBase - 5, KWspErrUnsupportedSendPrimitive = KWspErrorBase - 6, KWspErrSessionClosingOrSuspending = KWspErrorBase - 7,
KWspErrExpectingBodyData = KWspErrorBase - 8, KWspErrTrailerHeadersNotExpected = KWspErrorBase - 9, KWspErrMissingHeader = KWspErrorBase - 10, KWspErrSMSBearerNotInCommsDB = KWspErrorBase - 11,
KWspErrCouldNotCreateTransportHandler = KWspErrorBase - 12, KWspErrRequiredServicesNotSupported = KWspErrorBase - 13, KWtlsErrConfigurationFailed = KWspErrorBase - 14, KWtlsErrPhase1HandshakeFailed = KWspErrorBase - 15,
KWtlsErrPhase2HandshakeFailed = KWspErrorBase - 16, KWtlsErrInvalidServerCert = KWspErrorBase - 17, KWtlsErrUntrustedServerCert = KWspErrorBase - 18, KWtlsErrNegotiatedConfigRejected = KWspErrorBase - 19
}

Variables

const TInt KWspErrorBase = KHttpErrorBase - 180

Enumeration Type Documentation

enum TWspError

Todo:
docing
Enumeration values:
KWspErrServiceNumberNotDefined
KWspErrAccessPointNotSetUp
KWspErrBadRedirectedAddressData
KWspErrBearerNotSupported
KWspErrRequestTooBig
KWspErrStreamedRequestDataNotSupported
KWspErrUnsupportedSendPrimitive
KWspErrSessionClosingOrSuspending
KWspErrExpectingBodyData
KWspErrTrailerHeadersNotExpected
KWspErrMissingHeader
KWspErrSMSBearerNotInCommsDB
KWspErrCouldNotCreateTransportHandler
KWspErrRequiredServicesNotSupported
KWtlsErrConfigurationFailed
KWtlsErrPhase1HandshakeFailed
KWtlsErrPhase2HandshakeFailed
KWtlsErrInvalidServerCert
KWtlsErrUntrustedServerCert
KWtlsErrNegotiatedConfigRejected

Definition at line 18 of file WspError.h.

Variable Documentation

const TInt KWspErrorBase = KHttpErrorBase - 180

Definition at line 14 of file WspError.h.


WspError.h Source File

WspError.h

Go to the documentation of this file.
00001 // WspError.h
00002 //
00003 // Copyright (C) 2001 Symbian Ltd
00004 //
00005
00006 #ifndef __WSPERROR_H__
00007 #define __WSPERROR_H__
00008
00009 // System includes
00010 #include <e32std.h>
00011 #include <httperr.h>
00012
00013 // Constants used in this file
00014 const TInt KWspErrorBase = KHttpErrorBase - 180;
00015
00017
00018 enum TWspError
00019     {
00020     KWspErrServiceNumberNotDefined          = KWspErrorBase,
00021     KWspErrAccessPointNotSetUp              = KWspErrorBase - 1,
00022     KWspErrBadRedirectedAddressData         = KWspErrorBase - 2,
00023     KWspErrBearerNotSupported               = KWspErrorBase - 3,
00024     KWspErrRequestTooBig                    = KWspErrorBase - 4,
00025     KWspErrStreamedRequestDataNotSupported  = KWspErrorBase - 5,
00026     KWspErrUnsupportedSendPrimitive         = KWspErrorBase - 6,
00027     KWspErrSessionClosingOrSuspending       = KWspErrorBase - 7,
00028     KWspErrExpectingBodyData                = KWspErrorBase - 8,
00029     KWspErrTrailerHeadersNotExpected        = KWspErrorBase - 9,
00030     KWspErrMissingHeader                    = KWspErrorBase - 10,
00031     KWspErrSMSBearerNotInCommsDB            = KWspErrorBase - 11,
00032     KWspErrCouldNotCreateTransportHandler   = KWspErrorBase - 12,
00033     KWspErrRequiredServicesNotSupported     = KWspErrorBase - 13,
00034     KWtlsErrConfigurationFailed             = KWspErrorBase - 14,
00035     KWtlsErrPhase1HandshakeFailed           = KWspErrorBase - 15,
00036     KWtlsErrPhase2HandshakeFailed           = KWspErrorBase - 16,
00037     KWtlsErrInvalidServerCert               = KWspErrorBase - 17,
00038     KWtlsErrUntrustedServerCert             = KWspErrorBase - 18,
00039     KWtlsErrNegotiatedConfigRejected        = KWspErrorBase - 19
00040     };
00041
00042 #endif //  __WSPERROR_H__


WspPanic.h File Reference

#include <e32std.h>

Include dependency graph for WspPanic.h:

Include dependency graph

Go to the source code of this file.

Enumerations

enum TWspPanic {
KWspPanicDisconnectNotDone = 1, KWspPanicBadClientMessageSize = 2, KWspPanicBadServerMessageSize = 3, KWspPanicBadMethodMOR = 4,
KWspPanicBadConenctionTimeout = 5, KWspPanicMethodsStillOutstanding = 6, KWspPanicTransportHandlerAlreadyExists = 7, KWspPanicTransportHandlerDoesNotExist = 8,
KWspPanicNotExpectingMoreResponseData = 9, KWspPanicRxDataObjectNotReset = 10, KWspPanicResponseDataNotReleased = 11, KWspPanicNoResponseDataReceived = 12,
KWspPanicMethodAlreadyActive = 13, KWspPanicLDTNotSuppoted = 14, KWspPanicNotExpectingMoreRequestData = 15, KWspPanicBadMethodState = 16,
KWspPanicTxDataObjectNotReset = 17, KWspPanicNoRequestDataReceived = 18, KWspPanicBadMethodType = 19, KWspPanicBadProxyAddressProperty = 20,
KWspPanicBadServiceNumberProperty = 21, KWspPanicBadWspSessionTypeProperty = 22, KWspPanicBadBearerProperty = 23, KWspPanicBadSecurityProperty = 24,
KWspPanicBadPortProperty = 25, KWspPanicCommDBContainsBadData = 26, KWspPanicBadTrailerHeader = 27, KWspPanicNoTrailerHeaders = 28,
KWspPanicBadBearerType = 29, KWspPanicSessionNotInValidState = 30, KWspPanicIllegalSessionState = 31, KWspPanicNoMoreMessageSpace = 32,
KWspPanicTxDataInInvalidState = 33
}

Functions

_LIT (KWspPanicCategory,"WSP-CO-PH")
GLREF_C void Panic (TWspPanic aPanic)

Enumeration Type Documentation

enum TWspPanic

Enumeration values:
KWspPanicDisconnectNotDone
KWspPanicBadClientMessageSize
KWspPanicBadServerMessageSize
KWspPanicBadMethodMOR
KWspPanicBadConenctionTimeout
KWspPanicMethodsStillOutstanding
KWspPanicTransportHandlerAlreadyExists
KWspPanicTransportHandlerDoesNotExist
KWspPanicNotExpectingMoreResponseData
KWspPanicRxDataObjectNotReset
KWspPanicResponseDataNotReleased
KWspPanicNoResponseDataReceived
KWspPanicMethodAlreadyActive
KWspPanicLDTNotSuppoted
KWspPanicNotExpectingMoreRequestData
KWspPanicBadMethodState
KWspPanicTxDataObjectNotReset
KWspPanicNoRequestDataReceived
KWspPanicBadMethodType
KWspPanicBadProxyAddressProperty
KWspPanicBadServiceNumberProperty
KWspPanicBadWspSessionTypeProperty
KWspPanicBadBearerProperty
KWspPanicBadSecurityProperty
KWspPanicBadPortProperty
KWspPanicCommDBContainsBadData
KWspPanicBadTrailerHeader
KWspPanicNoTrailerHeaders
KWspPanicBadBearerType
KWspPanicSessionNotInValidState
KWspPanicIllegalSessionState
KWspPanicNoMoreMessageSpace
KWspPanicTxDataInInvalidState

Definition at line 14 of file WspPanic.h.

Function Documentation

_LIT | ( | KWspPanicCategory | ,
 |  | "WSP-CO-PH" |
 | ) |

Todo:
docing

GLREF_C void Panic ( TWspPanic aPanic )

Referenced by CTextModeTxData::TextModeTransportHandler(), and CTextModeRxData::TextModeTransportHandler().


WspPanic.h Source File

WspPanic.h

Go to the documentation of this file.
00001 // WspPanic.h
00002 //
00003 // Copyright (C) 2001 Symbian Ltd
00004 //
00005
00006 #ifndef __WSPPANIC_H__
00007 #define __WSPPANIC_H__
00008
00009 #include <e32std.h>
00010
00012
00013 _LIT(KWspPanicCategory, "WSP-CO-PH");
00014 enum TWspPanic
00015     {
00016     KWspPanicDisconnectNotDone                  = 1,
00017     KWspPanicBadClientMessageSize               = 2,
00018     KWspPanicBadServerMessageSize               = 3,
00019     KWspPanicBadMethodMOR                       = 4,
00020     KWspPanicBadConenctionTimeout               = 5,
00021
00022     KWspPanicMethodsStillOutstanding            = 6,
00023     KWspPanicTransportHandlerAlreadyExists      = 7,
00024     KWspPanicTransportHandlerDoesNotExist       = 8,
00025     KWspPanicNotExpectingMoreResponseData       = 9,
00026     KWspPanicRxDataObjectNotReset               = 10,
00027
00028     KWspPanicResponseDataNotReleased            = 11,
00029     KWspPanicNoResponseDataReceived             = 12,
00030     KWspPanicMethodAlreadyActive                = 13,
00031     KWspPanicLDTNotSuppoted                     = 14,
00032     KWspPanicNotExpectingMoreRequestData        = 15,
00033
00034     KWspPanicBadMethodState                     = 16,
00035     KWspPanicTxDataObjectNotReset               = 17,
00036     KWspPanicNoRequestDataReceived              = 18,
00037     KWspPanicBadMethodType                      = 19,
00038     KWspPanicBadProxyAddressProperty            = 20,
00039
00040     KWspPanicBadServiceNumberProperty           = 21,
00041     KWspPanicBadWspSessionTypeProperty          = 22,
00042     KWspPanicBadBearerProperty                  = 23,
00043     KWspPanicBadSecurityProperty                = 24,
00044     KWspPanicBadPortProperty                    = 25,
00045
00046     KWspPanicCommDBContainsBadData              = 26,
00047     KWspPanicBadTrailerHeader                   = 27,
00048     KWspPanicNoTrailerHeaders                   = 28,
00049     KWspPanicBadBearerType                      = 29,
00050     KWspPanicSessionNotInValidState             = 30,
00051
00052     KWspPanicIllegalSessionState                = 31,
00053     KWspPanicNoMoreMessageSpace                 = 32,
00054     KWspPanicTxDataInInvalidState               = 33
00055     };
00056
00057 GLREF_C void Panic(TWspPanic aPanic);
00058
00059 #endif //  __WSPPANIC_H__


WspTypes.h File Reference

@public More...

#include <e32base.h>
#include <stringpool.h>

Include dependency graph for WspTypes.h:

Include dependency graph

Go to the source code of this file.

Namespaces

namespace | Wap

Compounds

class | TWspRedirectedAddress
class | TWtlsCipherSuite
The class TWtlsCipherSuite encapsulates a WTLS cipher suite as defined in the WAP WTLS Specification, July 2001 This is a pair made up of a Bulk Encryption Algorithm and a Mac Algorithm. More...

class | TWtlsKeyExchangeSuite
The class TWtlsKeyExchangeSuite contain the definitions of WTLS Key Exchange Suites as defined in the WAP WTLS Specification, July 2001. More...

Variables

const TInt | KMaxProxyAddrLen = 40
The TWspRedirectedAddress type represents an alternate address to which Clients must use to establish a session with the same service that was initially contacted.

const TInt | KWtlsMaxKeyIdLength = 512
Maximum length of a key ID for WTLS.

Detailed Description

@public

Warning:
: This file contains Rose Model ID comments - please do not delete

Definition in file WspTypes.h.

Variable Documentation

const TInt KMaxProxyAddrLen = 40

The TWspRedirectedAddress type represents an alternate address to which Clients must use to establish a session with the same service that was initially contacted.

If the bearer or port fields have been excluded, then the orginal bearer and port should be used to contact the new server. The WSP Specification, July 2001, defines an Address Type (8.2.2.3) upon which this class is based.

Definition at line 366 of file WspTypes.h.

const TInt KWtlsMaxKeyIdLength = 512

Maximum length of a key ID for WTLS.

Definition at line 401 of file WspTypes.h.


WspTypes.h Source File

WspTypes.h

Go to the documentation of this file.
00001 // WspTypes.h
00002 //
00003 // Copyright (C) 2001 Symbian Ltd
00004
00011 #ifndef __WSPTYPES_H__
00012 #define __WSPTYPES_H__
00013
00014 // System includes
00015 #include <e32base.h>
00016 #include <stringpool.h>
00017
00023 namespace Wap
00024 {
00025
00029 enum TWspPrimitive
00030     {
00033     ESConnect           = 0,
00036     ESDisconnect,
00039     ESSuspend,
00042     ESResume,
00045     ESException,
00048     ESMethodInvoke,
00051     ESMethodInvokeData,
00054     ESMethodResult,
00057     ESMethodResultData,
00060     ESMethodAbort,
00063     ESPush,
00066     ESConfirmedPush,
00069     ESPushAbort
00070     };
00071
00078 enum TWspProtocolOptions
00079     {
00086     ELargeDataTransfer          = 0x08,
00092     EAcknowledgementHeaders     = 0x10,
00097     ESessionResumeFacility      = 0x20,
00102     EPushFacility               = 0x40,
00107     EConfirmedPushFacility      = 0x80
00108     };
00109
00113 enum TWspSessionState
00114     {
00117     ENull           = 0,
00120     EConnecting,
00123     EConnected,
00126     ESuspending,
00129     ESuspended,
00132     EClosing,
00135     EResuming
00136     };
00137
00141 enum TWspMethodState
00142     {
00145     ENullMethod         =0,
00148     ERequesting,
00151     EWaiting,
00154     EWaiting2,
00157     ECompleting,
00160     EAborting
00161     };
00162
00165 enum TWspBearer
00166     {
00169     EAny        = 0,
00172     EIP,
00175     ESMS7,
00178     ESMS,
00181     EWAPSMS7,
00184     EWAPSMS
00185     };
00186
00190 enum TWspSession
00191     {
00194     EWspConnectionOriented          = 0,
00197     EWspConnectionLess
00198     };
00199
00204 enum TWspReason
00205     {
00209     EProtoErr           = 0xE0,
00212     EDisconnect         = 0xE1,
00215     ESuspend            = 0xE2,
00218     EResume             = 0xE3,
00221     ECongestion         = 0xE4,
00224     EConnectErr         = 0xE5,
00227     EMRUExceeded        = 0xE6,
00231     EMORExceeded        = 0xE7,
00234     EPeerReq            = 0xE8,
00237     ENetErr             = 0xE9,
00240     EUserReq            = 0xEA,
00243     EUserRfs            = 0xEB,
00246     EUserPnd            = 0xEC,
00249     EUserDcr            = 0xED,
00252     EUserDcu            = 0xEE,
00258     ETemporaryRedirectedProxy   =0,
00266     EPermanentRedirectedProxy,
00274     EChangedProxyInSuspendedSession,
00279     EWtlsConfigurationFailed,
00283     EWtlsPhase1HandshakeFailed,
00287     EWtlsPhase2HandshakeFailed,
00291     EWtlsInvalidServerCert,
00297     EWtlsUntrustedServerCert,
00302     EWtlsNegotiatedConfigRejected,
00305     EOutOfMemory,
00309     ESessionStateFailure
00310     };
00311
00315 enum TWspCapability
00316     {
00319     EAliasAddresses             = 0,
00322     EExtendedMethods,
00325     EHeaderCodePages,
00328     EMethodMOR,
00331     EPushMOR,
00334     EProtocolOptions,
00337     EClientSDUSize,
00340     EServerSDUSize,
00343     EClientMessageSize,
00346     EServerMessageSize,
00349     EUnknownCapabilities,
00352     EAllCapabilities
00353     };
00354
00355 } // end of namespace Wap
00356
00357
00365 // Size this large enough for a full IPv6 address
00366 const TInt KMaxProxyAddrLen = 40;
00367
00368 //##ModelId=3C4C41B20079
00369 class TWspRedirectedAddress
00370     {
00371 public: // Attributes
00372
00375     //##ModelId=3C4C41B200DD
00376     TBool       iHasPort;
00377
00380     //##ModelId=3C4C41B200CB
00381     TBool       iHasBearer;
00382
00385     //##ModelId=3C4C41B200C1
00386     TBuf8<KMaxProxyAddrLen> iProxyAddress;
00387
00390     //##ModelId=3C4C41B200B5
00391     TUint16     iPort;
00392
00395     //##ModelId=3C4C41B200A3
00396     Wap::TWspBearer iBearer;
00397     };
00398
00401 const TInt KWtlsMaxKeyIdLength = 512;
00402
00407 class TWtlsKeyExchangeSuite
00408     {
00409 public:
00410     enum TKeyExchangeSuite
00411         {
00412         ENULL                   =0,
00413         ESHARED_SECRET          =1,
00414         EDH_anon                =2,
00415         EDH_anon_512            =3,
00416         EDH_anon_768            =4,
00417         ERSA_anon               =5,
00418         ERSA_anon_512           =6,
00419         ERSA_anon_768           =7,
00420         ERSA                    =8,
00421         ERSA_512                =9,
00422         ERSA_768                =10,
00423         EECDH_anon              =11,
00424         EECDH_anon_113          =12,
00425         EECDH_anon_131          =13,
00426         EECDH_ECDSA             =14,
00427         EECDH_anon_uncomp       =15,
00428         EECDH_anon_uncomp_113   =16,
00429         EECDH_anon_uncomp_131   =17,
00430         EECDH_ECDSA_uncomp      =18
00431         };
00432     enum TKeyIdType
00433         {
00434         EIdNull         = 0,
00435         EText           = 1,
00436         EBinary         = 2,
00437         EKeyHashSha     = 254,
00438         EX509Name       = 255
00439         };
00440
00441 public:
00442     TWtlsKeyExchangeSuite(TKeyExchangeSuite aKeyExchangeSuite, TKeyIdType aKeyIdType, const TBuf8<KWtlsMaxKeyIdLength>& aKeyId);
00443
00444 public:
00445     TKeyExchangeSuite iKeyExchangeSuite;
00446     TKeyIdType iKeyIdType;
00447     TBuf8<KWtlsMaxKeyIdLength> iKeyId;
00448     };
00449
00450
00455 class TWtlsCipherSuite
00456     {
00457 public:
00458
00459     enum TBulkEncryptionAlgorithm
00460         {
00461         ENULL           =0,
00462         ERC5_CBC_40     =1,
00463         ERC5_CBC_56     =2,
00464         ERC5_CBC        =3,
00465         EDES_CBC_40     =4,
00466         EDES_CBC        =5,
00467         E3DES_CBC_EDE   =6,
00468         EIDEA_CBC_40    =7,
00469         EIDEA_CBC_56    =8,
00470         EIDEA_CBC       =9,
00471         ERC5_CBC_64     =10,
00472         EIDEA_CBC_64    =11
00473         };
00474
00475     enum TMacAlgorithm
00476         {
00477         ESHA_0          =0,
00478         ESHA_40         =1,
00479         ESHA_80         =2,
00480         ESHA            =3,
00481 //      N/A (removed)   =4,
00482         EMD5_40         =5,
00483         EMD5_80         =6,
00484         EMD5            =7,
00485         };
00486
00487     TWtlsCipherSuite(TBulkEncryptionAlgorithm aBulkEncryptionAlgorithm, TMacAlgorithm aMacAlgorithm);
00488
00489 public:
00490     TBulkEncryptionAlgorithm iBulkEncryptionAlgorithm;
00491     TMacAlgorithm iMacAlgorithm;
00492     };
00493
00494 inline TWtlsCipherSuite::TWtlsCipherSuite(TBulkEncryptionAlgorithm aBulkEncryptionAlgorithm, TMacAlgorithm aMacAlgorithm)
00495     : iBulkEncryptionAlgorithm(aBulkEncryptionAlgorithm), iMacAlgorithm(aMacAlgorithm)
00496     {
00497     }
00498
00499 inline TWtlsKeyExchangeSuite::TWtlsKeyExchangeSuite(TKeyExchangeSuite aKeyExchangeSuite, TKeyIdType aKeyIdType, const TBuf8<KWtlsMaxKeyIdLength>& aKeyId)
00500     : iKeyExchangeSuite(aKeyExchangeSuite), iKeyIdType(aKeyIdType), iKeyId(aKeyId)
00501     {
00502     }
00503
00504
00505 #endif  // __WSPTYPES_H__


Annotated Index

HTTP Transport Framework Internal Documentation Compound List

Here are the classes, structs, unions and interfaces with brief descriptions:
CAliasAddress | Alias Address capability as defined by the WSP Specification, July 2001
MHTTPAuthenticationCallback @public
Since:
7.0 The mixin that needs to be implemented if authentication is to be supported
CAuthenticationFilter
CAuthenticationFilter::TCredentials | Container for holding an internal storage of credentials
CAuthenticationFilterInterface @public
Since:
7.0 @dependencies CBase, REComSession, RHTTPSession @lib euser.lib ecom.lib The ECOM interface definition for an HTTP authentication filter
CAuthenticationFilterInterface::TAuthenticationParams
TClientFilter
MComposerObserver
MConnectInvokerCallback | The MConnectInvokerCallback is used to perform an automatic session connect
RHTTPConnectionInfo @public
Since:
7.0 The RHTTPConnectionInfo is used for setting/getting values used for setting up a connection over a protocol
MConnectionInfoProvider @private
Since:
7.0 This interface defines methods to obtain further interfaces that supply connection-related information
CConnectionTimer | The class CConnectionTimer is used by the Wsp Protocol Handler to ensure that a WSP session establishment times-out
MConnectionTimerCallback
MHTTPDataSupplier @public
Since:
7.0 A data supplier - This class is used to deliver the response data to the client, and is also used by the client to supply request body data to HTTP in POST transactions
TDummyTransactionCallback
CEComFilter @public
Since:
7.0 This class serves as the base class for ECom filter plugins
THTTPEvent @public
Since:
7.0 A HTTP status message
TEventRegistration | An event's registration in the filter queue
CExtendedMethod | Extended Method capability as defined by the WSP Specification, July 2001
TFCoreFiltersPanic
MHTTPFilter @public
Since:
7.0 A HTTP filter
MHTTPFilterBase @public
Since:
7.0 A HTTP Filter
RHTTPFilterCollection @public
Since:
7.0 A Handle on the filter collection in a session
TFilterConfigurationIterator @public @dependancies CHTTPSession, CEComFilter
Since:
7.0 This class can only be created and destroyed by the session
MHTTPFilterCreationCallback @public
Since:
7.0 This class serves as a pure virtual interface required as a session callback to the client when the client requires to configure the filters that are installed
THTTPFilterHandle @public
Since:
7.0 A Filter registration handle
TFilterInformation @public
Since:
7.0 This structure is used by the TFilterConfigurationIterator to hold the information of the current filter
THTTPFilterIterator @public
Since:
7.0 An iterator for RHTTPFilterCollection
TFilterRegistration | A registration of a filter in the filter queue
THTTPFilterRegistration @public
Since:
7.0 A registration of a filter in the filter queue
CHTTPFormEncoder @public
Since:
7.0 A data supplier class that is used to build up data that is to be encoded to application/x-www-form-urlencoded
THTTPHdrFieldIter @public
Since:
7.0 Iterator class to iterate the fields within a RHTTPHeaders
THTTPHdrVal @public
Since:
7.0 A representation of a value found in an HTTP header field
THTTPHdrVal::TQConv
CHeaderCodec @public
Since:
7.0 An abstract HTTP header codec
CHeaderCodePage | Header Code Page capability as defined by the WSP Specification, July 2001
CHeaderField | Generalised internal representation of a single HTTP header field
RHeaderField @public
Since:
7.0 An proxy object for a single field in an HTTP header
CHeaderFieldParam | Generalised representation of a single HTTP header parameter
THeaderFieldParamIter | Iterator class to iterate the parameters contained within a header part
CHeaderFieldPart | Generalised representation of a single HTTP header value part
THeaderFieldPartIter | Iterator class to iterate the parts contained within a header field
CHeaderReader @public
Since:
7.0 An abstract HTTP header decoder
RHTTPHeaders @public
Since:
7.0 The collection of headers (or more correctly, header fields) associated with a message
CHeaders | Internal implementation of the RHTTPHeaders interface, which is documented in <http.h>
CHeaders::THeaderFieldNamePair | Structure which contains the headerfield and the associated name
CHeaderWriter @public
Since:
7.0 An abstract HTTP header encoder
CHttpClient | The example http client
CHttpConnector
CHttpEventHandler | Handles all events for the active transaction
CHttpExampleUtils | CHttpExampleUtils is a class that provides some user input utilities and holds a RTest used throughout
THttpLogger @private
Since:
7.0 A utility used in HTTP for logging in debug builds
HTTPPanic
CHttpSocket | CHttpSocket is an abstraction of a socket
MHttpSocketObserver | MHttpSocketObserver is the interface used by the socket read and write active objects to call back to the transport handler when a read or write has completed
HTTPStatus @public
Since:
7.0 The complete set of HTTP Status codes, as defined in RFC2616
CHttpTcpClient | The TCP client class is a dedicated client end-point for TCP comms with one particular HTTP origin server or proxy server
CHttpTcpReader | Reads data from a CHttpSocket informing its observer when the read is completed
CHttpTcpServerLocation
CHttpTcpWriter | Writes data to a CHttpSocket informing its observer when the write is completed
CHTTPManager | A singleton manager for HTTP Client
RHTTPMessage @public
Since:
7.0 An abstract HTTP message
CMessage | Abstract base class for implementation of HTTP requests and responses
CNwssConnectGuard
Since:
7.0 This class encapsulates the functionality to ensure that the Wsp CO Session states tables are honoured by the NWSS WAP Stack
MNwssOomHandler @private
Since:
7.0 This interface provides callback mechanisms used to abort methods or disconnect a session in in out-of-memory situation in the NWSS WSP Transport Handler
MNwssSessionEventHandler @private
Since:
7.0 This interface defines methods to handle each type of session event that can be received in the WSP layer of the WAP Stack
MNwssTransactionEventHandler @private
Since:
7.0 This interface defines methods to handle each type of transaction event that can be received in the WSP layer of the WAP Stack
CNwssTransLookUpTable @private
Since:
7.0 This class implements a simple, pre-allocated look-up table that is used in the WSP Transport Handler to associate the transaction-related items stored in instances of the embedded class CNwssTransLUTEntry
CNwssTransLookUpTable::CNwssTransLUTEntry @private
Since:
7.0 This class implements a single entry in the transaction look-up table
MNwssWapServer @private
Since:
7.0 This interface provides access to the WAP Stack Server via a handle owned by the interface implementor
CNwssWspCOEventDispatcher @private
Since:
7.0 This class acts as a hub for the receipt of Connection-Oriented WSP session and transaction events
CNwssWspCOSession @public
Since:
7.0 This class encapsulates a Connection-Oriented WSP session by specialising CNwssWspSession
CNwssWspCOSession::TDelayedDisconnectPckg
CNwssWspCOSession::TDelayedMethodAbortPckg
CNwssWspSession @public
Since:
7.0 This abstract class encapsulates a WSP session as implemented by the NWSS WAP Stack
CNwssWspSessionEventFilter
CNwssWspTransactionEventFilter
CNwssWspTransportHandler @public
Since:
7.0 This class provides a concrete implementation of the CWspTransportHandler interface, specifically for the NWSS Rainbow 2.1 WAP Stack, which is used on the Hurricane release of Symbian OS
CNwssWspTrHndDataSupplier @private
Since:
7.0 This class acts as a data supplier for WSP response bodies
TNwssWspTrHndPanic @private
Since:
7.0 This class provides a trivial panic utility used throughout the WSP Transport Handler
RHTTPPropertySet @public
Since:
7.0 A set of named THTTPHdrVal objects
CProtocolHandler @public
Since:
7.0 An abstract protocol handler
CProtTransaction @public
Since:
7.0 A representation of a transaction used by protocol handlers
TProxyInfo | The TProxyInfo type contains the information that defines a connection to a proxy that is capable of establishing a WSP session
CRedirectFilter
RHTTPRequest @public
Since:
7.0 An HTTP Request
CRequest | An HTTP Request
TRequestComposer | This class is a simple HTTP request composer
TRequestComposer::TChunkEncoder | Private Embedded class is used for internal chunking data, it formats the data using a state variable and a small buffer, a cached body
RHTTPResponse @public
Since:
7.0 An HTTP Response
CResponse | An HTTP Response
TResponseParser | This class is an HTTP response parser
CRxData @public
Since:
7.0 An abstract base class for the decoding of response data received by a protocol handler
MRxDataObserver @public
Since:
7.0 An interface to be implemented by classes that wish to receive status information from an implementation of the CRxData class
MSecurityPolicy @public
Since:
7.0 The Security Policy Interface
CSecurityPolicy @public
Since:
7.0 The Security Policy Plug-in API
CHTTPSession Implementation class for the session
See also:
RHTTPSession
RHTTPSession @public
Since:
7.0 A session handle
THTTPSessionEvent @public
Since:
7.0 A HTTP session status message
MHTTPSessionEventCallback @public
Since:
7.0 The per-session callback for receiving session event callbacks
TSessionFilterInfo | Struct for containing a session's filter information
MSessionPropertiesProvider | MSessionPropertiesProvider is the interface used by CTcpClientFactory to get/set COMMs Preferences as session properties, used for multi-homing
CSubmissionDetails
CTCPClientFactory | CTCPClientFactory is responsible for creating Transport Handlers (TH) sharing the same RSocketServ session and RConnection sub-session
TTextHeaderUtils | Utility class providing some text processing utilities useful when dealing with HTTP headers
CTextModeDefaultCodec | A default codec that will be instantiated as a delegate codec to handle any unrecognised header field by copying directly between raw data or string header field values
CTextModeDefHdrReader | A default header reader that just copies received raw data directly into single part string header fields
CTextModeDefHdrWriter | A default header writer that just copies single part string header fields directly into raw data
CTextModeHeaderCodec | An HTTP header codec specialized for the plain-text encoding of HTTP headers used by origin servers
CTextModeHeaderReader | CHTTPHeaderReader is used by its owning codec to do conversion of header data from the plain-text raw representation to the generic format (of parts and parameters)
CTextModeHeadersFilter | Acts as a filter above the HTTP Protocol Handler
CTextModeHeaderWriter | CTextModeHeaderWriter is used by its owning codec to do conversion of header data from the generic format (of parts and parameters) to the plain-text representation
CTextModeHttpProt | Specialisation of CProtocolHandler for plain-text HTTP - i.e
CTextModeProtTransaction
CTextModeRxData | A representation of over-the-air received data for Text-Mode HTTP
MTextModeTransportHandler | MTextModeTransportHandler is the interface used by the transport framework textmode http protocol handler
CTextModeTxData | A representation of over-the-air transmitted data for Text-Mode HTTP
RHTTPTransaction @public
Since:
7.0 A HTTP Transaction
CTransaction Implementation class for the transaction
See also:
RHTTPTransaction
MHTTPTransactionCallback @public
Since:
7.0 The per-transaction callback for receiving HTTP events
RHTTPTransactionPropertySet @public
Since:
7.0 The set of properties of a transaction
MTransportHndObs | An interface to be implemented by classes that wish to observe a transport handler
CTxData @public
Since:
7.0 An abstract base class for the encoding of request data to be transmitted by a protocol handler
CUnknownCapability | Unknown capability as defined by the WSP Specification, July 2001
CValidationFilter | The validation filter checks requests and responses to ensure that they are valid
MWspAliasAddress @public
Since:
7.0 The MWspAliasAddresses API provides an interface to a set of alias addresses as defined by the WSP Specification, July 2001
MWspAliasAddresses
CWspAliasAddresses | Set of Alias Address capabilities
CWspCapabilityInfo | Implements the MWspCapabilityViewer and MWspCapabilitySetter APIs
MWspCapabilityProvider @public
Since:
7.0 The MWspCapabilityProvider API supplies the capabilities proposed by the Client using the MWspCapabilityViewer API
MWspCapabilitySetter @public
Since:
7.0 The MWspCapabilitySetter API provides an interface to set the values for a set of capabilities as defined by the WSP Specification, July 2001
MWspCapabilityViewer @public
Since:
7.0 The MWspCapabiltyViewer API provides an interface to view a set of capabilities as defined by the WSP Specification, July 2001
MWspCLMethodCallback @public
Since:
7.0 The MWspCLMethodInvoker and MWspCLMethodCallback form the API that provides the WSP Connectionless Session Service Method Invocation facility, as described in the WSP Specification, July 2001
MWspCLMethodInvoker @public
Since:
7.0 The MWspCLMethodInvoker and MWspCLMethodCallback form the API that provides the WSP Connectionless Session Service Method Invocation facility, as described in the WSP Specification, July 2001
MWspCLPushCallback @public
Since:
7.0 The MWspCLPushInvoker and MWspCLPushCallback form the API that provides the WSP Connectionless Session Service Push facility, as in the WSP Specification, July 2001
MWspCLPushInvoker @public
Since:
7.0 The MWspCLPushInvoker and MWspCLPushCallback form the API that provides the WSP Connectionless Session Service Push facility, as in the WSP Specification, July 2001
MWspCOMethodCallback @public
Since:
7.0 The MWspCOMethodInvoker and MWspCOMethodCallback form the API that provides the WSP Connection-Orientated Session Service Method Invocation facility, as described in the WSP Specification, July 2001
MWspCOMethodInvoker @public
Since:
7.0 The MWspCOMethodInvoker and MWspCOMethodCallback form the API that provides the WSP Connection-Orientated Session Service Method Invocation facility, as described in the WSP Specification, July 2001
MWspCOMethodObserver
CWspCOProtocolHandler
MWspCOPushCallback @public
Since:
7.0 The MWspCOPushInvoker and MWspCOPushCallback form the API that proides the WSP Connection-Orientated Session Servise Push and Confirmed Push facilities, as decribed in the WSP Specification, July 2001
MWspCOPushInvoker @public
Since:
7.0 The MWspCOPushInvoker and MWspCOPushCallback form the API that provides the WSP Connection-Orientated Session Servise Push and Confirmed Push facilities, as decribed in the WSP Specification, July 2001
CWspCORxData
MWspCORxDataCallback
MWspCOSessionCallback @public
Since:
7.0 The MWspCOSessionInvoker and MWspCOSessionCallback form the API that provides the WSP Connection-Orientated Session Service Session Management, Session Resume and Exception Handling facilities, as described by the WSP Specification, July 2001
MWspCOSessionInvoker @public
Since:
7.0 The MWspCOSessionInvoker and MWspCOSessionCallback form the API that provides the WSP Connection-Orientated Session Service Session Management, Session Resume and Exception Handling facilities, as described by the WSP Specification, July 2001
CWspCOTransaction
CWspCOTxData
MWspCOTxDataCallback
CWspDefaultHdrReader @dependancies CHeaderCodec, CHeaderReader, CHeaderFieldPart, RStringPool, RStringF
Since:
7.0 This class is the by the WSP header codec to provide the decoding functionality required by WSP to decode header fields from a raw binary format to a useful parsed format
CWspDefaultHdrWriter @public @dependancies CHeaderWriter, CWspHeaderCodec, RStringPool, RHeaderField
Since:
7.0 This class provides the encoding functionality for headers that are supported by the WSP Header Codec
CWspDefaultHeaderCodec @dependancies CHeaderCodec, RStringPool, RStringF
Since:
7.0 This class is the default WSP Header Codec that is used if no codec can encode/ decode a particular header
CWspExtendedMethods | Set of Extended Methods capabilities
MWspExtendedMethods @public
Since:
7.0 The MWspExtendedMethods API provides an interface to a set of extended methods as defined by the WSP Specification, July 2001
CWspHeaderCodec @dependancies CHeaderCodec, RStringPool, RStringF
Since:
7.0 This class is the WSP specific header codec that is required to encode and decode WSP headers between a usable form and the form required for transport
MWspHeaderCodePages @public
Since:
7.0 The MWspHeaderCodePages API provides an interface to a set of header code pages as defined by the WSP Specification, July 2001
CWspHeaderCodePages | Set of Extended Methods capabilities
CWspHeaderReader @dependancies CHeaderCodec, CHeaderReader, CHeaderFieldPart, RStringPool, RStringF
Since:
7.0 This class is the by the WSP header codec to provide the decoding functionality required by WSP to decode header fields from a raw binary format to a useful parsed format
CWspHeaderUtils
CWspHeaderWriter @public @dependancies CHeaderWriter, CWspHeaderCodec, RStringPool, RHeaderField
Since:
7.0 This class provides the encoding functionality for encoding all of the supported headers
CWspPrimitiveSender
MWspPrimitiveSenderCallback | The MWspPrimitiveSenderCallback is used to perform an automatic session connect
CWspProxyInfoProvider | Implements the MWspProxyInfoProvider API
MWspProxyInfoProvider @public
Since:
7.0 The MWspProxyInfoProvider API provides an interface to the bearer connection information that has been specified by the Client
TWspRedirectedAddress
MWspSessionHeadersProvider @public
Since:
7.0 The MWspSessionHeadersProvider API provides an interface for accessing and setting the Client and Server session headers, respectively
CWspTransportHandler @public
Since:
7.0 The WSP Transport Handler API
CWspTransportHandler::SInstantiationParams | A structure containing the instantiation parameters to NewL, passed across via ECOM to the sub-class NewL
MWspUnknownCapabilities @public
Since:
7.0 The MWspUnknownCapabilities API provides an interface to a set of unknown capabilities as defined by the WSP Specification, July 2001
CWspUnknownCapabilities | Set of Extended Methods capabilities
TWtlsCipherSuite | The class TWtlsCipherSuite encapsulates a WTLS cipher suite as defined in the WAP WTLS Specification, July 2001 This is a pair made up of a Bulk Encryption Algorithm and a Mac Algorithm
TWtlsKeyExchangeSuite | The class TWtlsKeyExchangeSuite contain the definitions of WTLS Key Exchange Suites as defined in the WAP WTLS Specification, July 2001


CAliasAddress Class Reference

The CAliasAddress class represents the Alias Address capability as defined by the WSP Specification, July 2001. More...

#include <CAliasAddress.h>

List of all members.

Public Methods

~CAliasAddress ()
Standard destructor.

TWspBearer | GetBearer () const
Returns the bearer type.

TUint16 | GetPort () const
Returns the port number.

const TDesC8 & | GetAddress () const

Static Public Methods

CAliasAddress * | NewL (TWspBearer aBearer, TUint16 aPort, const TDesC8 &aAddress)
Static factory constructor.

Private Methods

CAliasAddress (TWspBearer aBearer, TUint16 aPort)
First phase constuctor.

void | ConstructL (const TDesC8 &aAddress)
Second phase constructor.

Private Attributes

TWspBearer | iBearer
The bearer type.

TUint16 | iPort
The port number.

HBufC8 * | iAddress
A buffer containing the address.

Detailed Description

The CAliasAddress class represents the Alias Address capability as defined by the WSP Specification, July 2001.

Definition at line 19 of file CAliasAddress.h.

Constructor & Destructor Documentation

CAliasAddress::~CAliasAddress ( )

Standard destructor.

Since:
7.0

CAliasAddress::CAliasAddress | ( | TWspBearer | aBearer,
 |  | TUint16 | aPort
 | ) | [private]

First phase constuctor.

Since:
7.0
Parameters:
aBearer | The bearer type.
aPort | The port number.

Member Function Documentation

CAliasAddress::ConstructL ( const TDesC8 & aAddress ) [private]

Second phase constructor.

Does any necessary allocations.

Since:
7.0
Parameters:
aAddress A reference to a buffer with the address.

const TDesC8& CAliasAddress::GetAddress ( ) [inline]

CAliasAddress::GetBearer ( ) const [inline]

Returns the bearer type.

Since:
7.0
Returns:
The bearer type.

CAliasAddress::GetPort ( ) const [inline]

Returns the port number.

If the port number is zero, then the port number is invalid.

Since:
7.0
Returns:
The port number. A port number of value zero is invalid.

CAliasAddress::NewL | ( | TWspBearer | aBearer,
 |  | TUint16 | aPort,
 |  | const TDesC8 & | aAddress
 | ) | [static]

Static factory constructor.

Since:
7.0
Exceptions:
This function will leave if the object cannot be constructed.
Parameters:
aBearer | The bearer type.
aPort | The port number.
aAddress | A reference to a buffer with the address.

Member Data Documentation

HBufC8* CAliasAddress::iAddress [private]

A buffer containing the address.

Definition at line 100 of file CAliasAddress.h.

TWspBearer CAliasAddress::iBearer [private]

The bearer type.

Definition at line 90 of file CAliasAddress.h.

TUint16 CAliasAddress::iPort [private]

The port number.

Definition at line 95 of file CAliasAddress.h.

The documentation for this class was generated from the following file:
  • CAliasAddress.h


Member List

CAliasAddress Member List

This is the complete list of members for CAliasAddress, including all inherited members.
CAliasAddress(TWspBearer aBearer, TUint16 aPort) | CAliasAddress | [private]
ConstructL(const TDesC8 &aAddress) | CAliasAddress | [private]
GetAddress() const | CAliasAddress | [inline]
GetBearer() const | CAliasAddress | [inline]
GetPort() const | CAliasAddress | [inline]
iAddress | CAliasAddress | [private]
iBearer | CAliasAddress | [private]
iPort | CAliasAddress | [private]
NewL(TWspBearer aBearer, TUint16 aPort, const TDesC8 &aAddress) | CAliasAddress | [static]
~CAliasAddress() | CAliasAddress |


MHTTPAuthenticationCallback Class Reference

@public
Since:
7.0 The mixin that needs to be implemented if authentication is to be supported.
More...

#include <mhttpauthenticationcallback.h>

Inheritance diagram for MHTTPAuthenticationCallback:

[legend]
List of all members.

Public Methods

virtual TBool | GetCredentialsL (const TUriC8 &aURI, RString aRealm, RStringF aAuthenticationType, RString &aUsername, RString &aPassword)=0
Gets some credentials.

void | InstallAuthenticationL (RHTTPSession aSession)
Installs the callback into the session.

Detailed Description

@public
Since:
7.0 The mixin that needs to be implemented if authentication is to be supported.

This supplies the username and password when they are needed for authentication. To use, subclass off this class and implement GetCredentialsL. To install the class into a session, call InstallAuthenticationL.

Definition at line 32 of file mhttpauthenticationcallback.h.

Member Function Documentation

virtual TBool MHTTPAuthenticationCallback::GetCredentialsL | ( | const TUriC8 & | aURI,
 |  | RString | aRealm,
 |  | RStringF | aAuthenticationType,
 |  | RString & | aUsername,
 |  | RString & | aPassword
 | ) | [pure virtual]

Gets some credentials.

Note that the first 3 parameters are informational and many clients may not have a use for them. Clients may want to display some or all of these parameters to the user, so that the user knows who they are giving their credentials to, and how securely they will be transmitted.

Parameters:
aURI | The URI being requested
aRealm | The realm being requested
aAuthenticationType | The type of authentication (basic or digest)
aUsername | The username is returned in this parameter. The caller will close the returned string.
aPassword | The password is returned in this parameter The caller will close the returned string.
Returns:
True if credentials have been obtained.
Exceptions:
Anything . If this function leaves the transaction will be failed.

Implemented in CHttpClient.

void MHTTPAuthenticationCallback::InstallAuthenticationL ( RHTTPSession aSession ) [inline]

Installs the callback into the session.

Typicaly called from the implementation class's ConstructL().

Precondition:
The session is opened, but no transactions have been created on it
Postcondition:
The session supports authentication, and uses this API to get its credentials.
Parameters:
aSession the session to install the filter into.
Exceptions:
KErrNoMemory There was not enough memory.

Definition at line 70 of file mhttpauthenticationcallback.h.

References CAuthenticationFilterInterface::InstallFilterL().

The documentation for this class was generated from the following file:
  • mhttpauthenticationcallback.h


Member List

MHTTPAuthenticationCallback Member List

This is the complete list of members for MHTTPAuthenticationCallback, including all inherited members.
GetCredentialsL(const TUriC8 &aURI, RString aRealm, RStringF aAuthenticationType, RString &aUsername, RString &aPassword)=0 | MHTTPAuthenticationCallback | [pure virtual]
InstallAuthenticationL(RHTTPSession aSession) | MHTTPAuthenticationCallback | [inline]


CAuthenticationFilter Class Reference

#include <Authentication.h>

Inheritance diagram for CAuthenticationFilter:

[legend]
Collaboration diagram for CAuthenticationFilter:

[legend]
List of all members.

Public Methods

~CAuthenticationFilter ()
Destructor.

virtual void | MHFRunL (RHTTPTransaction aTransaction, const THTTPEvent &aEvent)
See also:
MHTTPFilterBase::MHFRunL

virtual void | MHFSessionRunL (const THTTPSessionEvent &aEvent)
See also:
MHTTPFilterBase::MHFSessionRunL

virtual TInt | MHFRunError (TInt aError, RHTTPTransaction aTransaction, const THTTPEvent &aEvent)
See also:
MHTTPFilterBase::MHFRunError

virtual TInt | MHFSessionRunError (TInt aError, const THTTPSessionEvent &aEvent)
See also:
MHTTPFilterBase::MHFSessionRunError

virtual void | MHFUnload (RHTTPSession aSession, THTTPFilterHandle aHandle)
See also:
MHTTPFilter::MHFUnload

virtual void | MHFLoad (RHTTPSession aSession, THTTPFilterHandle aHandle)
See also:
MHTTPFilter::MHFLoad

Static Public Methods

CAuthenticationFilterInterface * | InstallFilterL (TAny *aAuthenticationParams)

Private Methods

CAuthenticationFilter (MHTTPAuthenticationCallback *aCallback)
Constructor.

void | ConstructL (RHTTPSession aSession)
For 2 phase construction. Also installs the filter.

void | SubmitL (RHTTPTransaction aTransaction)
Function to handle Submit events.

void | HandleTransactionL (RHTTPTransaction aTransaction)
Provides a central point for all Tranaction handling.

TInt | FindCredentials (const RString &aRealm, TInt aAuthType, const TUriC8 &aURI) const
Search list for matching credentials.

TInt | FindCredentialsForURI (const TUriC8 &aURI) const
TInt | FindHeaderPartToUseL (RHTTPTransaction aTransaction) const
Finds the header part with the stringest authentication that we support.

void | EncodeBasicAuthL (const RString &aUsername, const RString &aPW, RHTTPTransaction &aTransaction)
Set Basic Auth.

void | EncodeDigestAuthL (const RString &aUsername, const RString &aPW, RHTTPTransaction &aTransaction, TInt headerPart, const THTTPHdrVal &aRequestUri)
Set Digest Auth.

Digest helper functions
See RFC2617 for details of what these mean

TInt | HA1L (const RString &aUsername, const RString &aPW, const RString &aRealm, TDes8 &aResult)
Calculate H(A1). See section 3.2.2.2.

TInt | HA2L (const RStringF &aMethod, const RString &aRequestUri, TDes8 &aResult)
Calculate H(A2). See section 3.2.2.3.

void | Hash (const TDesC8 &aMessage, TDes8 &aHash)
Calculate a hash and in the form of a 32 character hex result.

void | GenerateCNonce (TDes8 &aNonce)
TBool | FindAuth (const TDesC8 &aQop) const

Private Attributes

MHTTPAuthenticationCallback * iCallback
callback for getting username/pw from external source

RArray< TCredentials > | iCredentials
internal list of valid credentials

RStringPool | iStringPool
local copy

TInt | iLoadCount
A reference count to make sure we delete at the right time.

TInt | iNextID
The next free credential ID.

CMD5 * | iMD5Calculator
The digest calculator.

TInt64 | iSeed
A seed for random numbers, used for client nonces.

Constructor & Destructor Documentation

CAuthenticationFilter::~CAuthenticationFilter ( )

Destructor.

CAuthenticationFilter::CAuthenticationFilter ( MHTTPAuthenticationCallback * aCallback ) [private]

Constructor.

Member Function Documentation

void CAuthenticationFilter::ConstructL ( RHTTPSession aSession ) [private]

For 2 phase construction. Also installs the filter.

void CAuthenticationFilter::EncodeBasicAuthL | ( | const RString & | aUsername,
 |  | const RString & | aPW,
 |  | RHTTPTransaction & | aTransaction
 | ) | [private]

Set Basic Auth.

void CAuthenticationFilter::EncodeDigestAuthL | ( | const RString & | aUsername,
 |  | const RString & | aPW,
 |  | RHTTPTransaction & | aTransaction,
 |  | TInt | headerPart,
 |  | const THTTPHdrVal & | aRequestUri
 | ) | [private]

Set Digest Auth.

TBool CAuthenticationFilter::FindAuth ( const TDesC8 & aQop ) const [private]

TInt CAuthenticationFilter::FindCredentials | ( | const RString & | aRealm,
 |  | TInt | aAuthType,
 |  | const TUriC8 & | aURI
 | ) | const [private]

Search list for matching credentials.

TInt CAuthenticationFilter::FindCredentialsForURI ( const TUriC8 & aURI ) const [private]

TInt CAuthenticationFilter::FindHeaderPartToUseL ( RHTTPTransaction aTransaction ) const [private]

Finds the header part with the stringest authentication that we support.

void CAuthenticationFilter::GenerateCNonce ( TDes8 & aNonce ) [private]

TInt CAuthenticationFilter::HA1L | ( | const RString & | aUsername,
 |  | const RString & | aPW,
 |  | const RString & | aRealm,
 |  | TDes8 & | aResult
 | ) | [private]

Calculate H(A1). See section 3.2.2.2.

TInt CAuthenticationFilter::HA2L | ( | const RStringF & | aMethod,
 |  | const RString & | aRequestUri,
 |  | TDes8 & | aResult
 | ) | [private]

Calculate H(A2). See section 3.2.2.3.

void CAuthenticationFilter::HandleTransactionL ( RHTTPTransaction aTransaction ) [private]

Provides a central point for all Tranaction handling.

void CAuthenticationFilter::Hash | ( | const TDesC8 & | aMessage,
 |  | TDes8 & | aHash
 | ) | [private]

Calculate a hash and in the form of a 32 character hex result.

CAuthenticationFilterInterface* CAuthenticationFilter::InstallFilterL ( TAny * aAuthenticationParams ) [static]

virtual void CAuthenticationFilter::MHFLoad | ( | RHTTPSession | aSession,
 |  | THTTPFilterHandle | aHandle
 | ) | [virtual]

See also:
MHTTPFilter::MHFLoad

Reimplemented from MHTTPFilter.

virtual TInt CAuthenticationFilter::MHFRunError | ( | TInt | aError,
 |  | RHTTPTransaction | aTransaction,
 |  | const THTTPEvent & | aEvent
 | ) | [virtual]

See also:
MHTTPFilterBase::MHFRunError

Reimplemented from MHTTPFilterBase.

virtual void CAuthenticationFilter::MHFRunL | ( | RHTTPTransaction | aTransaction,
 |  | const THTTPEvent & | aEvent
 | ) | [virtual]

See also:
MHTTPFilterBase::MHFRunL

Reimplemented from MHTTPFilterBase.

virtual TInt CAuthenticationFilter::MHFSessionRunError | ( | TInt | aError,
 |  | const THTTPSessionEvent & | aEvent
 | ) | [virtual]

See also:
MHTTPFilterBase::MHFSessionRunError

Reimplemented from MHTTPFilterBase.

virtual void CAuthenticationFilter::MHFSessionRunL ( const THTTPSessionEvent & aEvent ) [virtual]

See also:
MHTTPFilterBase::MHFSessionRunL

Reimplemented from MHTTPFilterBase.

virtual void CAuthenticationFilter::MHFUnload | ( | RHTTPSession | aSession,
 |  | THTTPFilterHandle | aHandle
 | ) | [virtual]

See also:
MHTTPFilter::MHFUnload

Reimplemented from MHTTPFilter.

void CAuthenticationFilter::SubmitL ( RHTTPTransaction aTransaction ) [private]

Function to handle Submit events.

We need to remove any username and password from the URI.

Member Data Documentation

MHTTPAuthenticationCallback* CAuthenticationFilter::iCallback [private]

callback for getting username/pw from external source

Definition at line 139 of file Authentication.h.

RArray<TCredentials> CAuthenticationFilter::iCredentials [private]

internal list of valid credentials

Definition at line 142 of file Authentication.h.

TInt CAuthenticationFilter::iLoadCount [private]

A reference count to make sure we delete at the right time.

Definition at line 149 of file Authentication.h.

CMD5* CAuthenticationFilter::iMD5Calculator [private]

The digest calculator.

Definition at line 157 of file Authentication.h.

TInt CAuthenticationFilter::iNextID [private]

The next free credential ID.

Definition at line 153 of file Authentication.h.

TInt64 CAuthenticationFilter::iSeed [private]

A seed for random numbers, used for client nonces.

Definition at line 161 of file Authentication.h.

RStringPool CAuthenticationFilter::iStringPool [private]

local copy

Definition at line 145 of file Authentication.h.

The documentation for this class was generated from the following file:
  • Authentication.h


Member List

CAuthenticationFilter Member List

This is the complete list of members for CAuthenticationFilter, including all inherited members.
CAuthenticationFilter(MHTTPAuthenticationCallback *aCallback) | CAuthenticationFilter | [private]
ConstructL(RHTTPSession aSession) | CAuthenticationFilter | [private]
ECache enum value | MHTTPFilter |
EClient enum value | MHTTPFilter |
EClientFilters enum value | MHTTPFilter |
ECookies enum value | MHTTPFilter |
EncodeBasicAuthL(const RString &aUsername, const RString &aPW, RHTTPTransaction &aTransaction) | CAuthenticationFilter | [private]
EncodeDigestAuthL(const RString &aUsername, const RString &aPW, RHTTPTransaction &aTransaction, TInt headerPart, const THTTPHdrVal &aRequestUri) | CAuthenticationFilter | [private]
EProtocolHandler enum value | MHTTPFilter |
EStatusCodeHandler enum value | MHTTPFilter |
ETidyUp enum value | MHTTPFilter |
FindAuth(const TDesC8 &aQop) const | CAuthenticationFilter | [private]
FindCredentials(const RString &aRealm, TInt aAuthType, const TUriC8 &aURI) const | CAuthenticationFilter | [private]
FindCredentialsForURI(const TUriC8 &aURI) const | CAuthenticationFilter | [private]
FindHeaderPartToUseL(RHTTPTransaction aTransaction) const | CAuthenticationFilter | [private]
GenerateCNonce(TDes8 &aNonce) | CAuthenticationFilter | [private]
HA1L(const RString &aUsername, const RString &aPW, const RString &aRealm, TDes8 &aResult) | CAuthenticationFilter | [private]
HA2L(const RStringF &aMethod, const RString &aRequestUri, TDes8 &aResult) | CAuthenticationFilter | [private]
HandleTransactionL(RHTTPTransaction aTransaction) | CAuthenticationFilter | [private]
Hash(const TDesC8 &aMessage, TDes8 &aHash) | CAuthenticationFilter | [private]
iCallback | CAuthenticationFilter | [private]
iCredentials | CAuthenticationFilter | [private]
iLoadCount | CAuthenticationFilter | [private]
iMD5Calculator | CAuthenticationFilter | [private]
iNextID | CAuthenticationFilter | [private]
InstallFilterL(TAny *aAuthenticationParams) | CAuthenticationFilter | [static]
CAuthenticationFilterInterface::InstallFilterL(RHTTPSession &aSession, MHTTPAuthenticationCallback *aCallback) | CAuthenticationFilterInterface | [inline, static]
iSeed | CAuthenticationFilter | [private]
iStringPool | CAuthenticationFilter | [private]
MHFLoad(RHTTPSession aSession, THTTPFilterHandle aHandle) | CAuthenticationFilter | [virtual]
MHFRunError(TInt aError, RHTTPTransaction aTransaction, const THTTPEvent &aEvent) | CAuthenticationFilter | [virtual]
MHFRunL(RHTTPTransaction aTransaction, const THTTPEvent &aEvent) | CAuthenticationFilter | [virtual]
MHFSessionRunError(TInt aError, const THTTPSessionEvent &aEvent) | CAuthenticationFilter | [virtual]
MHFSessionRunL(const THTTPSessionEvent &aEvent) | CAuthenticationFilter | [virtual]
MHFUnload(RHTTPSession aSession, THTTPFilterHandle aHandle) | CAuthenticationFilter | [virtual]
SubmitL(RHTTPTransaction aTransaction) | CAuthenticationFilter | [private]
TPositions enum name | MHTTPFilter |
~CAuthenticationFilter() | CAuthenticationFilter |
~CAuthenticationFilterInterface() | CAuthenticationFilterInterface | [inline]


CAuthenticationFilter::TCredentials Class Reference

Container for holding an internal storage of credentials. More...

List of all members.

Public Attributes

RStringToken | iRealm
Realm used - there may be multiple for each host.

RStringToken | iUser
username

RStringToken | iPassword
password

RStringTokenF | iURI
uri

TInt | iAuthType
basic or digest or ??

TInt | iID
to associate credentials with transactions

Detailed Description

Container for holding an internal storage of credentials.

Definition at line 126 of file Authentication.h.

Member Data Documentation

TInt CAuthenticationFilter::TCredentials::iAuthType

basic or digest or ??

Definition at line 133 of file Authentication.h.

TInt CAuthenticationFilter::TCredentials::iID

to associate credentials with transactions

Definition at line 134 of file Authentication.h.

RStringToken CAuthenticationFilter::TCredentials::iPassword

password

Definition at line 131 of file Authentication.h.

RStringToken CAuthenticationFilter::TCredentials::iRealm

Realm used - there may be multiple for each host.

Definition at line 129 of file Authentication.h.

RStringTokenF CAuthenticationFilter::TCredentials::iURI

uri

Definition at line 132 of file Authentication.h.

RStringToken CAuthenticationFilter::TCredentials::iUser

username

Definition at line 130 of file Authentication.h.

The documentation for this class was generated from the following file:
  • Authentication.h


Member List

CAuthenticationFilter::TCredentials Member List

This is the complete list of members for CAuthenticationFilter::TCredentials, including all inherited members.
iAuthType | CAuthenticationFilter::TCredentials
iID | CAuthenticationFilter::TCredentials
iPassword | CAuthenticationFilter::TCredentials
iRealm | CAuthenticationFilter::TCredentials
iURI | CAuthenticationFilter::TCredentials
iUser | CAuthenticationFilter::TCredentials


CAuthenticationFilterInterface Class Reference

@public
Since:
7.0 @dependencies CBase, REComSession, RHTTPSession @lib euser.lib ecom.lib The ECOM interface definition for an HTTP authentication filter.
More...

#include <CAuthenticationFilterInterface.h>

Inheritance diagram for CAuthenticationFilterInterface:

[legend]
List of all members.

Public Methods

~CAuthenticationFilterInterface ()
Intended Usage: Virtual destructor
Since:
7.0.

Static Public Methods

void | InstallFilterL (RHTTPSession &aSession, MHTTPAuthenticationCallback *aCallback)
Intended Usage: This method is used to install the authentication filter to the filter queue.

Private Attributes

TUid | iEcomDtorID
The ECom destructor key identifier.

Detailed Description

@public
Since:
7.0 @dependencies CBase, REComSession, RHTTPSession @lib euser.lib ecom.lib The ECOM interface definition for an HTTP authentication filter.

Implementations of an authentication filter must inherit this class.

Definition at line 32 of file CAuthenticationFilterInterface.h.

Constructor & Destructor Documentation

CAuthenticationFilterInterface::~CAuthenticationFilterInterface ( ) [inline]

Intended Usage: Virtual destructor

Since:
7.0.

Precondition:
The object identified by the destructor key in iEcomDtorID exists
Postcondition:
The object is destroyed

Definition at line 81 of file CAuthenticationFilterInterface.h.

References iEcomDtorID.

Member Function Documentation

void CAuthenticationFilterInterface::InstallFilterL | ( | RHTTPSession & | aSession,
 |  | MHTTPAuthenticationCallback * | aCallback
 | ) | [inline, static]

Intended Usage: This method is used to install the authentication filter to the filter queue.

The returned pointer is not owned as the filters must be self-destroying when they are unloaded.

Since:
7.0
Parameters:
aSession | A handle to the transport session
aCallback | A pointer to the object implementing the callback function
Returns:
Pointer to the newly installed plugin
Precondition:
The session had already been setup
Postcondition:
The filter(s) have been installed

Definition at line 72 of file CAuthenticationFilterInterface.h.

References CAuthenticationFilterInterface::TAuthenticationParams::iCallback, iEcomDtorID, and CAuthenticationFilterInterface::TAuthenticationParams::iSession.

Referenced by MHTTPAuthenticationCallback::InstallAuthenticationL().

Member Data Documentation

TUid CAuthenticationFilterInterface::iEcomDtorID [private]

The ECom destructor key identifier.

Definition at line 67 of file CAuthenticationFilterInterface.h.

Referenced by InstallFilterL(), and ~CAuthenticationFilterInterface().

The documentation for this class was generated from the following file:
  • CAuthenticationFilterInterface.h


Member List

CAuthenticationFilterInterface Member List

This is the complete list of members for CAuthenticationFilterInterface, including all inherited members.
iEcomDtorID | CAuthenticationFilterInterface | [private]
InstallFilterL(RHTTPSession &aSession, MHTTPAuthenticationCallback *aCallback) | CAuthenticationFilterInterface | [inline, static]
~CAuthenticationFilterInterface() | CAuthenticationFilterInterface | [inline]


CAuthenticationFilterInterface::TAuthenticationParams Struct Reference

#include <CAuthenticationFilterInterface.h>

Collaboration diagram for CAuthenticationFilterInterface::TAuthenticationParams:

[legend]
List of all members.

Public Attributes

RHTTPSession * iSession
MHTTPAuthenticationCallback * iCallback

Member Data Documentation

MHTTPAuthenticationCallback* CAuthenticationFilterInterface::TAuthenticationParams::iCallback

Definition at line 62 of file CAuthenticationFilterInterface.h.

Referenced by CAuthenticationFilterInterface::InstallFilterL().

RHTTPSession* CAuthenticationFilterInterface::TAuthenticationParams::iSession

Definition at line 61 of file CAuthenticationFilterInterface.h.

Referenced by CAuthenticationFilterInterface::InstallFilterL().

The documentation for this struct was generated from the following file:
  • CAuthenticationFilterInterface.h


Member List

CAuthenticationFilterInterface::TAuthenticationParams Member List

This is the complete list of members for CAuthenticationFilterInterface::TAuthenticationParams, including all inherited members.
iCallback | CAuthenticationFilterInterface::TAuthenticationParams
iSession | CAuthenticationFilterInterface::TAuthenticationParams


TClientFilter Class Reference

#include <TClientFilter.h>

Inheritance diagram for TClientFilter:

[legend]
Collaboration diagram for TClientFilter:

[legend]
List of all members.

Public Methods

virtual void | MHFRunL (RHTTPTransaction aTransaction, const THTTPEvent &aEvent)
See also:
MHTTPFilterBase::MHFRunL

virtual void | MHFSessionRunL (const THTTPSessionEvent &aEvent)
See also:
MHTTPFilterBase::MHFSessionRunL

virtual TInt | MHFRunError (TInt aError, RHTTPTransaction aTransaction, const THTTPEvent &aEvent)
See also:
MHTTPFilterBase::MHFRunError

virtual TInt | MHFSessionRunError (TInt aError, const THTTPSessionEvent &aEvent)
See also:
MHTTPFilterBase::MHFSessionRunError

virtual void | MHFUnload (RHTTPSession aSession, THTTPFilterHandle aHandle)
virtual void | MHFLoad (RHTTPSession aSession, THTTPFilterHandle aHandle)
void | SetSessionEventCallback (MHTTPSessionEventCallback *aSessionEventCallback)

Private Attributes

MHTTPSessionEventCallback * iSessionEventCallback

Member Function Documentation

TClientFilter::MHFLoad | ( | RHTTPSession | aSession,
 |  | THTTPFilterHandle | aHandle
 | ) | [virtual]

See also:
MHTTFilter

Reimplemented from MHTTPFilter.

virtual TInt TClientFilter::MHFRunError | ( | TInt | aError,
 |  | RHTTPTransaction | aTransaction,
 |  | const THTTPEvent & | aEvent
 | ) | [virtual]

See also:
MHTTPFilterBase::MHFRunError

Reimplemented from MHTTPFilterBase.

virtual void TClientFilter::MHFRunL | ( | RHTTPTransaction | aTransaction,
 |  | const THTTPEvent & | aEvent
 | ) | [virtual]

See also:
MHTTPFilterBase::MHFRunL

Reimplemented from MHTTPFilterBase.

virtual TInt TClientFilter::MHFSessionRunError | ( | TInt | aError,
 |  | const THTTPSessionEvent & | aEvent
 | ) | [virtual]

See also:
MHTTPFilterBase::MHFSessionRunError

Reimplemented from MHTTPFilterBase.

virtual void TClientFilter::MHFSessionRunL ( const THTTPSessionEvent & aEvent ) [virtual]

See also:
MHTTPFilterBase::MHFSessionRunL

Reimplemented from MHTTPFilterBase.

TClientFilter::MHFUnload | ( | RHTTPSession | aSession,
 |  | THTTPFilterHandle | aHandle
 | ) | [virtual]

See also:
MHTTFilter

Reimplemented from MHTTPFilter.

void TClientFilter::SetSessionEventCallback ( MHTTPSessionEventCallback * aSessionEventCallback ) [inline]

Definition at line 59 of file TClientFilter.h.

References iSessionEventCallback.

Member Data Documentation

MHTTPSessionEventCallback* TClientFilter::iSessionEventCallback [private]

Definition at line 54 of file TClientFilter.h.

Referenced by SetSessionEventCallback().

The documentation for this class was generated from the following file:
  • TClientFilter.h


Member List

TClientFilter Member List

This is the complete list of members for TClientFilter, including all inherited members.
ECache enum value | MHTTPFilter |
EClient enum value | MHTTPFilter |
EClientFilters enum value | MHTTPFilter |
ECookies enum value | MHTTPFilter |
EProtocolHandler enum value | MHTTPFilter |
EStatusCodeHandler enum value | MHTTPFilter |
ETidyUp enum value | MHTTPFilter |
iSessionEventCallback | TClientFilter | [private]
MHFLoad(RHTTPSession aSession, THTTPFilterHandle aHandle) | TClientFilter | [virtual]
MHFRunError(TInt aError, RHTTPTransaction aTransaction, const THTTPEvent &aEvent) | TClientFilter | [virtual]
MHFRunL(RHTTPTransaction aTransaction, const THTTPEvent &aEvent) | TClientFilter | [virtual]
MHFSessionRunError(TInt aError, const THTTPSessionEvent &aEvent) | TClientFilter | [virtual]
MHFSessionRunL(const THTTPSessionEvent &aEvent) | TClientFilter | [virtual]
MHFUnload(RHTTPSession aSession, THTTPFilterHandle aHandle) | TClientFilter | [virtual]
SetSessionEventCallback(MHTTPSessionEventCallback *aSessionEventCallback) | TClientFilter | [inline]
TPositions enum name | MHTTPFilter |


MComposerObserver Class Reference

#include <CTextModeTxData.h>

Inheritance diagram for MComposerObserver:

[legend]
List of all members.

Public Methods

virtual void ReAllocBufferL (TInt aRequiredLength, TPtr8 &aBuffer)=0
Requests that the composer observer reallocate the buffer containing the composed HTTP message.

Member Function Documentation

MComposerObserver::ReAllocBufferL | ( | TInt | aRequiredLength,
 |  | TPtr8 & | aBuffer
 | ) | [pure virtual]

Requests that the composer observer reallocate the buffer containing the composed HTTP message.

Since:
7.0
Parameters:
aRequiredLength | The required length of the buffer. Should be greater than the current length or there will be a panic.
aBuffer | An output buffer containig the reallocated buffer pointer.

Implemented in CTextModeTxData.

The documentation for this class was generated from the following file:
  • CTextModeTxData.h


Member List

MComposerObserver Member List

This is the complete list of members for MComposerObserver, including all inherited members.
ReAllocBufferL(TInt aRequiredLength, TPtr8 &aBuffer)=0 MComposerObserver [pure virtual]


MConnectInvokerCallback Class Reference

The MConnectInvokerCallback is used to perform an automatic session connect. More...

#include <MConnectInvokerCallback.h>

List of all members.

Public Methods

virtual void | HandleConnectInvocationL ()=0
Intended Usage :
Since:
7.0.

virtual TInt | ConnectInvokerCallbackError (TInt aError)=0
Intended Usage : Error handling function for when RunL() leaves.

Detailed Description

The MConnectInvokerCallback is used to perform an automatic session connect.

An active object uses this callback to get the protocol handler to initiate the session connect.

Definition at line 15 of file MConnectInvokerCallback.h.

Member Function Documentation

MConnectInvokerCallback::ConnectInvokerCallbackError ( TInt aError ) [pure virtual]

Intended Usage : Error handling function for when RunL() leaves.

Since:
7.0
Parameters:
aError The error with which RunL() left.
Returns:
An error code. If the input error value could be handled, then KErrNone is returned, otherwise the input error code is returned.

MConnectInvokerCallback::HandleConnectInvocationL ( ) [pure virtual]

Intended Usage :

Since:
7.0.

Postcondition:
A session connect has been initiated with the new proxy.

The documentation for this class was generated from the following file:
  • MConnectInvokerCallback.h


Member List

MConnectInvokerCallback Member List

This is the complete list of members for MConnectInvokerCallback, including all inherited members.
ConnectInvokerCallbackError(TInt aError)=0 | MConnectInvokerCallback | [pure virtual]
HandleConnectInvocationL()=0 | MConnectInvokerCallback | [pure virtual]


RHTTPConnectionInfo Class Reference

@public
Since:
7.0 The RHTTPConnectionInfo is used for setting/getting values used for setting up a connection over a protocol.
More...

#include <rhttpconnectioninfo.h>

Inheritance diagram for RHTTPConnectionInfo:

[legend]
Collaboration diagram for RHTTPConnectionInfo:

[legend]
List of all members.

Detailed Description

@public
Since:
7.0 The RHTTPConnectionInfo is used for setting/getting values used for setting up a connection over a protocol.

All methods are inherited directly from RHTTPPropertySet.

To lookup/change any of the following properties, use RHTTPPropertySet::Property(...) and RHTTPPropertySet::SetPropertyL(...)

To remove properties, use RHTTPPropertySet::RemoveProperty(...) for a named property, or RHTTPPropertySet::RemoveAllProperties() for all.

The following values are currently defined. Note that new values could be added by individual filters. In general, properties should be defined before the first transction is created; filters are not obliged to check with the connection info if the values have changed after this point.

HTTP::EProxyUsage (default HTTP::EDoNotUseProxy) (HTTP::EDoNotUseProxy | HTTP::EUseProxy)

HTTP::EProxyAddress (default empty)

HTTP::EMaxNumTransportHandlers (default 4)

HTTP::EMaxNumTransPerTranspHndlr (default 5)

HTTP::EHTTPVersion (default HTTP::EHttp11) (HTTP::EHttp11 | HTTP::EHttp10)

HTTP::EProtocol (default, and currently only defined value is HTTP::EHTTP)

Definition at line 53 of file rhttpconnectioninfo.h.

The documentation for this class was generated from the following file:
  • rhttpconnectioninfo.h


Member List

RHTTPConnectionInfo Member List

This is the complete list of members for RHTTPConnectionInfo, including all inherited members.
CHeaderFieldPart class | RHTTPPropertySet | [friend]
CHTTPSession class | RHTTPPropertySet | [friend]
iImplementation | RHTTPPropertySet | [protected]
Property(RStringF aPropertyName, THTTPHdrVal &aVal) const | RHTTPPropertySet |
RemoveAllProperties() | RHTTPPropertySet |
RemoveProperty(RStringF aPropertyName) | RHTTPPropertySet |
RHTTPPropertySet() | RHTTPPropertySet |
SetPropertyL(RStringF aPropertyName, THTTPHdrVal aValue) | RHTTPPropertySet |


MConnectionInfoProvider Class Reference

@private
Since:
7.0 This interface defines methods to obtain further interfaces that supply connection-related information.
More...

#include <MConnectionInfoProvider.h>

Inheritance diagram for MConnectionInfoProvider:

[legend]
List of all members.

Public Methods

virtual MWspProxyInfoProvider & | ProxyInfoProvider () const=0
Intended Usage: Obtain the client's provider of proxy information
Since:
7.0.

virtual MWspCapabilityProvider & | CapabilityProvider () const=0
Intended Usage: Obtain the client's provider of capabilities information
Since:
7.0.

virtual MWspSessionHeadersProvider & | SessionHeadersProvider () const=0
Intended Usage: Obtain the client's provider of sesion headers
Since:
7.0.

Detailed Description

@private
Since:
7.0 This interface defines methods to obtain further interfaces that supply connection-related information.

This information comes in three varieties: the WAP Proxy which is to be connected to; the Client's requested capabilities and the Server's negotiated capabilities; the Client's session request header, and the Server's session response header.

Definition at line 31 of file MConnectionInfoProvider.h.

Member Function Documentation

MWspCapabilityProvider & MConnectionInfoProvider::CapabilityProvider ( ) const [pure virtual]

Intended Usage: Obtain the client's provider of capabilities information

Since:
7.0.

Implemented in CNwssWspTransportHandler.

MWspProxyInfoProvider & MConnectionInfoProvider::ProxyInfoProvider ( ) const [pure virtual]

Intended Usage: Obtain the client's provider of proxy information

Since:
7.0.

Implemented in CNwssWspTransportHandler.

MWspSessionHeadersProvider & MConnectionInfoProvider::SessionHeadersProvider ( ) const [pure virtual]

Intended Usage: Obtain the client's provider of sesion headers

Since:
7.0.

Implemented in CNwssWspTransportHandler.

The documentation for this class was generated from the following file:
  • MConnectionInfoProvider.h


Member List

MConnectionInfoProvider Member List

This is the complete list of members for MConnectionInfoProvider, including all inherited members.
CapabilityProvider() const=0 | MConnectionInfoProvider | [pure virtual]
ProxyInfoProvider() const=0 | MConnectionInfoProvider | [pure virtual]
SessionHeadersProvider() const=0 | MConnectionInfoProvider | [pure virtual]


CConnectionTimer Class Reference

The class CConnectionTimer is used by the Wsp Protocol Handler to ensure that a WSP session establishment times-out. More...

#include <CConnectionTimer.h>

Collaboration diagram for CConnectionTimer:

[legend]
List of all members.

Public Methods

~CConnectionTimer ()
Intended Usage : Standard destructor.

void | Start (TInt aDelayTime)
Intended Usage : Starts the timer.

Static Public Methods

CConnectionTimer * | NewL (MConnectionTimerCallback &aCallback)
Intended Usage : Static factory constructor.

Private Methods

virtual void | RunL ()
Intended Usage : Called by active schedule when the timer is complete.

virtual TInt | RunError (TInt aError)
Intended Usage : Error handling function for when RunL() leaves.

CConnectionTimer (MConnectionTimerCallback &aCallback)
Intended Usage : First phase constructor.

void | ConstructL ()

Private Attributes

MConnectionTimerCallback & iCallback
A reference to the callback object.

Detailed Description

The class CConnectionTimer is used by the Wsp Protocol Handler to ensure that a WSP session establishment times-out.

Definition at line 17 of file CConnectionTimer.h.

Constructor & Destructor Documentation

CConnectionTimer::~CConnectionTimer ( )

Intended Usage : Standard destructor.

Since:
7.0

CConnectionTimer::CConnectionTimer ( MConnectionTimerCallback & aCallback ) [private]

Intended Usage : First phase constructor.

Since:
7.0
Parameters:
aCallback A reference to the callback object that handles the timer complete event.

Member Function Documentation

void CConnectionTimer::ConstructL ( ) [private]

CConnectionTimer::NewL ( MConnectionTimerCallback & aCallback ) [static]

Intended Usage : Static factory constructor.

Since:
7.0
Parameters:
aCallback A reference to the callback object that handles the timer complete event.
Returns:
A pointer to a fully initialised object.

CConnectionTimer::RunError ( TInt aError ) [private, virtual]

Intended Usage : Error handling function for when RunL() leaves.

Defers action to callback object.

Since:
7.0
Parameters:
aError The error with which RunL() left.
Returns:
An error code. If the input error value could be handled, then KErrNone is returned, otherwise the input error code is returned. This will cause a panic.

CConnectionTimer::RunL ( ) [private, virtual]

Intended Usage : Called by active schedule when the timer is complete.

Since:
7.0
Todo:
add leaves
Precondition:
The timer has completed.
Postcondition:
The connection time-out has been handled.

CConnectionTimer::Start ( TInt aDelayTime )

Intended Usage : Starts the timer.

Since:
7.0
Parameters:
aDelayTime The time delay, in microseconds, by when the timer should complete.
Postcondition:
The object is active.

Member Data Documentation

MConnectionTimerCallback& CConnectionTimer::iCallback [private]

A reference to the callback object.

Definition at line 97 of file CConnectionTimer.h.

The documentation for this class was generated from the following file:
  • CConnectionTimer.h


Member List

CConnectionTimer Member List

This is the complete list of members for CConnectionTimer, including all inherited members.
CConnectionTimer(MConnectionTimerCallback &aCallback) | CConnectionTimer | [private]
ConstructL() | CConnectionTimer | [private]
iCallback | CConnectionTimer | [private]
NewL(MConnectionTimerCallback &aCallback) | CConnectionTimer | [static]
RunError(TInt aError) | CConnectionTimer | [private, virtual]
RunL() | CConnectionTimer | [private, virtual]
Start(TInt aDelayTime) | CConnectionTimer |
~CConnectionTimer() | CConnectionTimer |


MConnectionTimerCallback Class Reference

#include <MConnectionTimerCallback.h>

Inheritance diagram for MConnectionTimerCallback:

[legend]
List of all members.

Public Methods

virtual void HandleConnectionTimedOut ()=0
Intended Usage : A connection timer calls this function on the callback object to indicate that the connection time has lapsed.

Detailed Description

Todo:
docing

Definition at line 14 of file MConnectionTimerCallback.h.

Member Function Documentation

MConnectionTimerCallback::HandleConnectionTimedOut ( ) [pure virtual]

Intended Usage : A connection timer calls this function on the callback object to indicate that the connection time has lapsed.

Since:
7.0
Precondition:
The connection time has lapsed.
Postcondition:
The connection request has been cancelled.

Implemented in CWspCOProtocolHandler.

The documentation for this class was generated from the following file:
  • MConnectionTimerCallback.h


Member List

MConnectionTimerCallback Member List

This is the complete list of members for MConnectionTimerCallback, including all inherited members.
HandleConnectionTimedOut()=0 MConnectionTimerCallback [pure virtual]


MHTTPDataSupplier Class Reference

@public
Since:
7.0 A data supplier - This class is used to deliver the response data to the client, and is also used by the client to supply request body data to HTTP in POST transactions.
More...

#include <mhttpdatasupplier.h>

Inheritance diagram for MHTTPDataSupplier:

[legend]
List of all members.

Public Methods

virtual TBool | GetNextDataPart (TPtrC8 &aDataPart)=0
Obtain a data part from the supplier.

virtual void | ReleaseData ()=0
Release the current data part being held at the data supplier.

virtual TInt | OverallDataSize ()=0
Obtain the overall size of the data being supplied, if known to the supplier.

virtual TInt | Reset ()=0
Reset the data supplier.

Private Methods

virtual void | MHDS_Reserved1 ()
virtual void | MHDS_Reserved2 ()
virtual void | MHDS_Reserved3 ()

Detailed Description

@public
Since:
7.0 A data supplier - This class is used to deliver the response data to the client, and is also used by the client to supply request body data to HTTP in POST transactions.

Data is supplied in a number of parts. When a part is available it can be retreived with GetNextDataPart. The returned descriptor will remain valid until ReleaseData is called.

To use this class to supply POST data, you have a number of options. If the post data needs to be URL Form encoded, you should use CHTTPFormEncoder, which will do the encoding and interface to the MHTTPDataSupplier for you. If you have all the data available, return its length in OverallDataSize, and pass back all the data from GetNextDataPart, returning ETrue to indicate that this is the last part.

If you don't want to form all the data at once, but know how much you'll eventualy have, return the total length from OverallDataSize. When GetNextDataPart is first called, return the first part. If GetNextDataPart is called again before ReleaseData, you should still return the first part. Only when ReleaseData is called should you move to the second part. If you don't know the total size of the data, the procedure is the same but you should return KErrNotFound from OverallDataSize.

When the next part is available, clients should call RHTTPTransaction::NotifyNewRequestBodyPartL to inform HTTP that the new data is available. They can do this from ReleaseData if more data is instantly available, or in some applications they may need to call it some time later when the next part has been assembled.

Filter writers should note that the MHTTPDataSupplier interface is designed to be used by 1 client, as 1 component needs to know when to call ReleaseData(). However, filters can be written to transform the data in some way. For instance, a filter could be written to automaticaly handle a particular content encoding. When this filter first receives a GotResponseBodyData, it should take a copy of the response's body and replace the body with a MHTTPDataSupplier supplied by the filter. The filter should then receive the data from HTTP via the saved data supplier and give it to the client via its own data supplier.

Definition at line 65 of file mhttpdatasupplier.h.

Member Function Documentation

virtual TBool MHTTPDataSupplier::GetNextDataPart ( TPtrC8 & aDataPart ) [pure virtual]

Obtain a data part from the supplier.

The data is guaranteed to survive until a call is made to ReleaseData().

Parameters:
aDataPart - the data part
Returns:
ETrue if this is the last part. EFalse otherwise

Implemented in CHTTPFormEncoder, CTextModeRxData, CTextModeTxData, CWspCORxData, CWspCOTxData, CNwssWspTrHndDataSupplier, and CHttpClient.

void MHTTPDataSupplier::MHDS_Reserved1 ( ) [inline, private, virtual]

Definition at line 115 of file mhttpdatasupplier.h.

void MHTTPDataSupplier::MHDS_Reserved2 ( ) [inline, private, virtual]

Definition at line 118 of file mhttpdatasupplier.h.

void MHTTPDataSupplier::MHDS_Reserved3 ( ) [inline, private, virtual]

Definition at line 121 of file mhttpdatasupplier.h.

virtual TInt MHTTPDataSupplier::OverallDataSize ( ) [pure virtual]

Obtain the overall size of the data being supplied, if known to the supplier.

Where a body of data is supplied in several parts this size will be the sum of all the part sizes. If the size is not known, KErrNotFound is returned; in this case the client must use the return code of GetNextDataPart to find out when the data is complete.

Returns:
A size in bytes, or KErrNotFound if the size is not known.

Implemented in CHTTPFormEncoder, CTextModeRxData, CTextModeTxData, CWspCORxData, CWspCOTxData, CNwssWspTrHndDataSupplier, and CHttpClient.

virtual void MHTTPDataSupplier::ReleaseData ( ) [pure virtual]

Release the current data part being held at the data supplier.

This call indicates to the supplier that the part is no longer needed, and another one can be supplied, if appropriate.

Implemented in CHTTPFormEncoder, CTextModeRxData, CTextModeTxData, CWspCORxData, CWspCOTxData, CNwssWspTrHndDataSupplier, and CHttpClient.

virtual TInt MHTTPDataSupplier::Reset ( ) [pure virtual]

Reset the data supplier.

This indicates to the data supplier that it should return to the first part of the data. This could be used in a situation where the data consumer has encountered an error and needs the data to be supplied afresh. Even if the last part has been supplied (i.e. GetNextDataPart has returned ETrue), the data supplier should reset to the first part.

If the supplier cannot reset it should return an error code; otherwise it should return KErrNone, where the reset will be assumed to have succeeded

Implemented in CHTTPFormEncoder, CTextModeRxData, CTextModeTxData, CWspCORxData, CWspCOTxData, CNwssWspTrHndDataSupplier, and CHttpClient.

The documentation for this class was generated from the following file:
  • mhttpdatasupplier.h


Member List

MHTTPDataSupplier Member List

This is the complete list of members for MHTTPDataSupplier, including all inherited members.
GetNextDataPart(TPtrC8 &aDataPart)=0 | MHTTPDataSupplier | [pure virtual]
MHDS_Reserved1() | MHTTPDataSupplier | [inline, private, virtual]
MHDS_Reserved2() | MHTTPDataSupplier | [inline, private, virtual]
MHDS_Reserved3() | MHTTPDataSupplier | [inline, private, virtual]
OverallDataSize()=0 | MHTTPDataSupplier | [pure virtual]
ReleaseData()=0 | MHTTPDataSupplier | [pure virtual]
Reset()=0 | MHTTPDataSupplier | [pure virtual]


TDummyTransactionCallback Class Reference

#include <CHTTPSession.h>

Inheritance diagram for TDummyTransactionCallback:

[legend]
Collaboration diagram for TDummyTransactionCallback:

[legend]
List of all members.

Public Methods

virtual void | MHFRunL (RHTTPTransaction aTransaction, const THTTPEvent &aEvent)
virtual TInt | MHFRunError (TInt aError, RHTTPTransaction aTransaction, const THTTPEvent &aEvent)

Member Function Documentation

TDummyTransactionCallback::MHFRunError | ( | TInt | aError,
 |  | RHTTPTransaction | aTransaction,
 |  | const THTTPEvent & | aEvent
 | ) | [virtual]

See also:
MHTTPFilterBase

Implements MHTTPTransactionCallback.

TDummyTransactionCallback::MHFRunL | ( | RHTTPTransaction | aTransaction,
 |  | const THTTPEvent & | aEvent
 | ) | [virtual]

See also:
MHTTPFilterBase

Implements MHTTPTransactionCallback.

The documentation for this class was generated from the following file:
  • CHTTPSession.h


Member List

TDummyTransactionCallback Member List

This is the complete list of members for TDummyTransactionCallback, including all inherited members.
MHFRunError(TInt aError, RHTTPTransaction aTransaction, const THTTPEvent &aEvent) | TDummyTransactionCallback | [virtual]
MHFRunL(RHTTPTransaction aTransaction, const THTTPEvent &aEvent) | TDummyTransactionCallback | [virtual]


CEComFilter Class Reference

@public
Since:
7.0 This class serves as the base class for ECom filter plugins.
More...

#include <CEComFilter.h>

Inheritance diagram for CEComFilter:

[legend]
List of all members.

Public Methods

~CEComFilter ()
Intended Usage: Virtual destructor
Since:
7.0.

Static Public Methods

CEComFilter * | InstallFilterL (RHTTPSession aSession, const TUid aEComFilterUid)
Intended Usage: This method is used to install filters to the filter queue.

CEComFilter * | InstallFilterL (RHTTPSession aSession, const TDesC8 &aEComFilterDataType)
Intended Usage: This method is used to install filters to the filter queue.

Private Attributes

TUid | iEcomDtorID
The ECom destructor key identifier.

Detailed Description

@public
Since:
7.0 This class serves as the base class for ECom filter plugins.

It provides minimal functionality to simply install and destroy filters specified by their UID or data type. The RHTTPSession passed in is passed onto the filter as a TAny* pointer and therefore must be casted back to an RHTTPSession pointer by the filter.

Definition at line 33 of file CEComFilter.h.

Constructor & Destructor Documentation

CEComFilter::~CEComFilter ( ) [inline]

Intended Usage: Virtual destructor

Since:
7.0.

Precondition:
The object identified by the destructor key in iEcomDtorID exists
Postcondition:
The object is destroyed

Definition at line 103 of file CEComFilter.h.

References iEcomDtorID.

Member Function Documentation

CEComFilter * CEComFilter::InstallFilterL | ( | RHTTPSession | aSession,
 |  | const TDesC8 & | aEComFilterDataType
 | ) | [inline, static]

Intended Usage: This method is used to install filters to the filter queue.

The implementation UID of the filter plugin is passed to identify the plugin that is required. The returned pointer is not owned as the filters must be self-destroying when they are unloaded.

Since:
7.0
Parameters:
aSession | A handle to the transport session
aEComFilterDataType | A descriptor containing the datatype of the filter to load
Returns:
Pointer to the newly installed plugin
Precondition:
The session had already been setup
Postcondition:
The filter(s) have been installed

Definition at line 92 of file CEComFilter.h.

References iEcomDtorID, and KUidFilterPluginInterface.

CEComFilter * CEComFilter::InstallFilterL | ( | RHTTPSession | aSession,
 |  | const TUid | aEComFilterUid
 | ) | [inline, static]

Intended Usage: This method is used to install filters to the filter queue.

The implementation UID of the filter plugin is passed to identify the plugin that is required. The returned pointer is not owned as the filters must be self-destroying when they are unloaded.

Since:
7.0
Parameters:
aSession | A handle to the transport session
aEComFilterUid | The implementation UID of the plugin
Returns:
Pointer to the newly installed plugin
Precondition:
The session had already been setup
Postcondition:
The filter(s) have been installed

Definition at line 86 of file CEComFilter.h.

References iEcomDtorID.

Member Data Documentation

TUid CEComFilter::iEcomDtorID [private]

The ECom destructor key identifier.

Definition at line 81 of file CEComFilter.h.

Referenced by InstallFilterL(), and ~CEComFilter().

The documentation for this class was generated from the following file:
  • CEComFilter.h


Member List

CEComFilter Member List

This is the complete list of members for CEComFilter, including all inherited members.
iEcomDtorID | CEComFilter | [private]
InstallFilterL(RHTTPSession aSession, const TUid aEComFilterUid) | CEComFilter | [inline, static]
InstallFilterL(RHTTPSession aSession, const TDesC8 &aEComFilterDataType) | CEComFilter | [inline, static]
~CEComFilter() | CEComFilter | [inline]


THTTPEvent Class Reference

@public
Since:
7.0 A HTTP status message.
More...

#include <thttpevent.h>

Inheritance diagram for THTTPEvent:

[legend]
List of all members.

Public Types

enum | TStandardEvent { EAll = KRequestPending + 1, EAnyTransactionEvent = KRequestPending, EAnySessionEvent = KSessionEventBaseStatus }
The TStandardEvent type is used to specify a family of event types. More...

enum TTransactionEvent {
ESubmit = KTransactionEventBaseStatus, ECancel = KTransactionEventBaseStatus + 1, ENotifyNewRequestBodyPart = KTransactionEventBaseStatus + 2, EClosed = KTransactionEventBaseStatus + 3,
EGotResponseHeaders = KTransactionEventBaseStatus + 4, EGotResponseBodyData = KTransactionEventBaseStatus + 5, EResponseComplete = KTransactionEventBaseStatus + 6, EGotResponseTrailerHeaders = KTransactionEventBaseStatus + 7,
ESucceeded = KTransactionEventBaseStatus + 8, EFailed = KTransactionEventBaseStatus + 9, EUnrecoverableError = KTransactionEventBaseStatus + 10, ETooMuchRequestData = KTransactionEventBaseStatus + 11
}
The TTransactionEvents type defines the events that correspond to transactions. More...

enum | TDirection { EOutgoing, EIncoming }
The TDirection type defines the direction of an event. More...

enum | TTransactionWarning { ERedirectedPermanently = KTransactionWarningBaseStatus, ERedirectedTemporarily = KTransactionWarningBaseStatus + 1, EMoreDataReceivedThanExpected = KTransactionWarningBaseStatus + 2 }
The TTransactionWarning type indicates that something in a transaction may be incorrect but the transaction may continue. More...

Public Methods

THTTPEvent (TInt aStatus, TUint aUID=KHTTPUid)
Constructor.

THTTPEvent (TStandardEvent aStatus=EAnyTransactionEvent)
Constructor (using a standard event and the HTTP UID).

THTTPEvent (TTransactionEvent aStatus)
Constructor (using a transaction event and the HTTP UID).

THTTPEvent & | operator= (TStandardEvent aStatus)
Assigns a standard event code to an event object.

THTTPEvent & | operator= (TTransactionEvent aStatus)
Assigns a transaction event code to an event object.

TBool | operator== (THTTPEvent aThat) const
Equality operator.

TBool | operator!= (THTTPEvent aThat) const
Inequality operator.

TBool | operator== (TStandardEvent aStatus) const
Equality operator (compares with a standard event).

TBool | operator!= (TStandardEvent aStatus) const
Inequality operator (compares with a standard event).

TBool | operator== (TTransactionEvent aStatus) const
Equality operator (compares with a transaction event).

TBool | operator!= (TTransactionEvent aStatus) const
Inequality operator (compares with a transaction event).

TBool | IsSessionEvent () const
Returns True if the event is a session event.

Public Attributes

TInt | iStatus
The status value.

TUint | iUID
The UID.

Protected Attributes

TBool | iIsSessionEventFlag
Flag to indicate whether the event is a session event.

Detailed Description

@public
Since:
7.0 A HTTP status message.

Status messages consist of a UID and a status code within that UID. Extension dlls that needs to create new status messages should use their own UID and create status codes within that UID.

Definition at line 55 of file thttpevent.h.

Member Enumeration Documentation

enum THTTPEvent::TDirection

The TDirection type defines the direction of an event.

An outgoing event originates from the client or from filters. The clients do not send these explicitly since the API methods of RHTTPTransaction or RHTTPSession do it on their behalf. Incoming events originate from the protocol handler or from filters, and clients should handle these.

Enumeration values:
EOutgoing An event originating with the client (e.g.

start transaction).

EIncoming An event originating with the server (e.g.

something received).

Definition at line 149 of file thttpevent.h.

enum THTTPEvent::TStandardEvent

The TStandardEvent type is used to specify a family of event types.

Any negative event number is used to convey error codes. All events are incoming (originate with the origin server) unless otherwise indicated. Outgoing messages will not be seen by the MHTTPTransactionCallback's MHFRunL.

Enumeration values:
EAll | Used when registering filter to indicate the filter is instrested in ALL events, both transaction and session events.
EAnyTransactionEvent | Used when registering filters to indicate the filter is interested in any transaction event, from any direction.
EAnySessionEvent | Used when registering filters to indicate the filter is interested in any session event.

Definition at line 65 of file thttpevent.h.

enum THTTPEvent::TTransactionEvent

The TTransactionEvents type defines the events that correspond to transactions.

Outgoing events originate from the client or from filters. The clients do not send these explicitly since the API methods of RHTTPTransaction do it on their behalf. Incoming events originate from the protocol handler or from filters, and clients should handle these. The ESucceeded and EFailed events are mutually exclusive, but one will always be sent to the client as the final event for a transaction.

Enumeration values:
ESubmit The transaction is being submitted.

An outgoing event.

ECancel The transaction is being cancelled.

An outgoing event.

ENotifyNewRequestBodyPart A new part of request body data is available for transmission.

An outgoing event

EClosed The transaction is being closed.

An outgoing event.

EGotResponseHeaders All the response headers have been received.

An incoming event.

EGotResponseBodyData Some (more) body data has been received (in the HTTP response).

An incoming event.

EResponseComplete The transaction's response is complete.

An incoming event.

EGotResponseTrailerHeaders Some trailer headers have been received.

An incoming event.

ESucceeded The transaction has succeeded.

An incoming event.

EFailed The transaction has failed.

This is a 'catch-all' for communicating failures, and more details of the failure should have been notified in previous messages or status codes. If the client could process these then it is possible that it should not consider the transaction a failure. For instance a browser that displays the body of 404 responses to the user would not consider a 404 response to be a failure, as it would display it just like a 200 response even though a 404 will be flagged as a 'failure'. An incoming event.

EUnrecoverableError Generated from RHTTPTransaction::Fail().

A filter has failed in a way that prevents it from using the normal event mechanism to inform the client of the error. This probably means it's run out of memory. An incoming event.

ETooMuchRequestData An event that indicates that there is too much request data to be sent.

The transaction will subsequently be cancelled. An incoming event.

Definition at line 89 of file thttpevent.h.

enum THTTPEvent::TTransactionWarning

The TTransactionWarning type indicates that something in a transaction may be incorrect but the transaction may continue.

It may also indicate that something (e.g. a filter) may have performed an action that has changed the transaction and that the client should be informed of this.

Enumeration values:
ERedirectedPermanently An event indicating that the transaction has been redirected and the original origin server indicated that it was a permanent redirection.

The URI for the transaction is now the redirected location. A permanent redirection may require further client behavior if the request came from a stored URI. This is to avoid further redirections on subsequent requests for this resource.

ERedirectedTemporarily | An event indicating that the transaction has been redirected and the original server indicated that it was a temporary redirection.
EMoreDataReceivedThanExpected | An event generated by the Protocol Handler when it receives a Content- Length value that does not match the actual length of the body data.

Definition at line 164 of file thttpevent.h.

Constructor & Destructor Documentation

THTTPEvent::THTTPEvent | ( | TInt | aStatus,
 |  | TUint | aUID = KHTTPUid
 | ) | [inline]

Constructor.

Parameters:
aStatus | The status value.
aUid | The UID.

THTTPEvent::THTTPEvent ( TStandardEvent aStatus = EAnyTransactionEvent ) [inline]

Constructor (using a standard event and the HTTP UID).

Parameters:
aStatus The standard event to use.

THTTPEvent::THTTPEvent ( TTransactionEvent aStatus ) [inline]

Constructor (using a transaction event and the HTTP UID).

Parameters:
aStatus The transaction event to use.

Member Function Documentation

TBool THTTPEvent::IsSessionEvent ( ) [inline]

Returns True if the event is a session event.

TBool THTTPEvent::operator!= ( TTransactionEvent aStatus ) const [inline]

Inequality operator (compares with a transaction event).

TBool THTTPEvent::operator!= ( TStandardEvent aStatus ) const [inline]

Inequality operator (compares with a standard event).

TBool THTTPEvent::operator!= ( THTTPEvent aThat ) const [inline]

Inequality operator.

THTTPEvent& THTTPEvent::operator= ( TTransactionEvent aStatus ) [inline]

Assigns a transaction event code to an event object.

Parameters:
aStatus The transaction event.

THTTPEvent& THTTPEvent::operator= ( TStandardEvent aStatus ) [inline]

Assigns a standard event code to an event object.

Parameters:
aStatus The standard event.

TBool THTTPEvent::operator== ( TTransactionEvent aStatus ) const [inline]

Equality operator (compares with a transaction event).

TBool THTTPEvent::operator== ( TStandardEvent aStatus ) const [inline]

Equality operator (compares with a standard event).

TBool THTTPEvent::operator== ( THTTPEvent aThat ) const [inline]

Equality operator.

Member Data Documentation

TBool THTTPEvent::iIsSessionEventFlag [protected]

Flag to indicate whether the event is a session event.

Definition at line 260 of file thttpevent.h.

TInt THTTPEvent::iStatus

The status value.

Definition at line 250 of file thttpevent.h.

TUint THTTPEvent::iUID

The UID.

Definition at line 255 of file thttpevent.h.

The documentation for this class was generated from the following file:
  • thttpevent.h


Member List

THTTPEvent Member List

This is the complete list of members for THTTPEvent, including all inherited members.
EAll enum value | THTTPEvent |
EAnySessionEvent enum value | THTTPEvent |
EAnyTransactionEvent enum value | THTTPEvent |
ECancel enum value | THTTPEvent |
EClosed enum value | THTTPEvent |
EFailed enum value | THTTPEvent |
EGotResponseBodyData enum value | THTTPEvent |
EGotResponseHeaders enum value | THTTPEvent |
EGotResponseTrailerHeaders enum value | THTTPEvent |
EIncoming enum value | THTTPEvent |
EMoreDataReceivedThanExpected enum value | THTTPEvent |
ENotifyNewRequestBodyPart enum value | THTTPEvent |
EOutgoing enum value | THTTPEvent |
ERedirectedPermanently enum value | THTTPEvent |
ERedirectedTemporarily enum value | THTTPEvent |
EResponseComplete enum value | THTTPEvent |
ESubmit enum value | THTTPEvent |
ESucceeded enum value | THTTPEvent |
ETooMuchRequestData enum value | THTTPEvent |
EUnrecoverableError enum value | THTTPEvent |
iIsSessionEventFlag | THTTPEvent | [protected]
IsSessionEvent() const | THTTPEvent | [inline]
iStatus | THTTPEvent |
iUID | THTTPEvent |
operator!=(THTTPEvent aThat) const | THTTPEvent | [inline]
operator!=(TStandardEvent aStatus) const | THTTPEvent | [inline]
operator!=(TTransactionEvent aStatus) const | THTTPEvent | [inline]
operator=(TStandardEvent aStatus) | THTTPEvent | [inline]
operator=(TTransactionEvent aStatus) | THTTPEvent | [inline]
operator==(THTTPEvent aThat) const | THTTPEvent | [inline]
operator==(TStandardEvent aStatus) const | THTTPEvent | [inline]
operator==(TTransactionEvent aStatus) const | THTTPEvent | [inline]
TDirection enum name | THTTPEvent |
THTTPEvent(TInt aStatus, TUint aUID=KHTTPUid) | THTTPEvent | [inline]
THTTPEvent(TStandardEvent aStatus=EAnyTransactionEvent) | THTTPEvent | [inline]
THTTPEvent(TTransactionEvent aStatus) | THTTPEvent | [inline]
TStandardEvent enum name | THTTPEvent |
TTransactionEvent enum name | THTTPEvent |
TTransactionWarning enum name | THTTPEvent |


TEventRegistration Class Reference

An event's registration in the filter queue. More...

#include <TEventRegistration.h>

Collaboration diagram for TEventRegistration:

[legend]
List of all members.

Public Methods

TEventRegistration (THTTPEvent aEvent, TInt aDirection, TInt aStartFilter)
TEventRegistration ()

Public Attributes

THTTPEvent iEvent
The event.

TInt | iDirection
The direction it's going in.

TInt | iStartFilter
The filter it starts at.

Detailed Description

An event's registration in the filter queue.

Definition at line 12 of file TEventRegistration.h.

Constructor & Destructor Documentation

TEventRegistration::TEventRegistration | ( | THTTPEvent | aEvent,
 |  | TInt | aDirection,
 |  | TInt | aStartFilter
 | ) | [inline]

Definition at line 32 of file TEventRegistration.h.

TEventRegistration::TEventRegistration ( ) [inline]

Definition at line 39 of file TEventRegistration.h.

Member Data Documentation

TInt TEventRegistration::iDirection

The direction it's going in.

Definition at line 26 of file TEventRegistration.h.

THTTPEvent TEventRegistration::iEvent

The event.

Definition at line 23 of file TEventRegistration.h.

TInt TEventRegistration::iStartFilter

The filter it starts at.

Definition at line 29 of file TEventRegistration.h.

The documentation for this class was generated from the following file:
  • TEventRegistration.h


Member List

TEventRegistration Member List

This is the complete list of members for TEventRegistration, including all inherited members.
iDirection | TEventRegistration |
iEvent | TEventRegistration |
iStartFilter | TEventRegistration |
TEventRegistration(THTTPEvent aEvent, TInt aDirection, TInt aStartFilter) | TEventRegistration | [inline]
TEventRegistration() | TEventRegistration | [inline]


CExtendedMethod Class Reference

The CExtendedMethod class represents the Extended Method capability as defined by the WSP Specification, July 2001. More...

#include <CExtendedMethod.h>

List of all members.

Public Methods

~CExtendedMethod ()
Standard destrcutor.

TUint8 | GetPDUType () const
Returns the PDU type for this method.

const TDesC8 & | GetMethodName () const
Returns the method name.

Static Public Methods

CExtendedMethod * | NewL (TUint8 aPDUType, const TDesC8 &aMethodName)
Static factory constructor.

Private Methods

CExtendedMethod (TUint8 aPDUType)
First phase constuctor.

void | ConstructL (const TDesC8 &aMethodName)
Second phase constructor.

Private Attributes

TUint8 | iType
The PDU type assigned to the method specified by iMethodName.

HBufC8 * | iName
A buffer containing the method name.

Detailed Description

The CExtendedMethod class represents the Extended Method capability as defined by the WSP Specification, July 2001.

Definition at line 15 of file CExtendedMethod.h.

Constructor & Destructor Documentation

CExtendedMethod::~CExtendedMethod ( )

Standard destrcutor.

Since:
7.0

CExtendedMethod::CExtendedMethod ( TUint8 aPDUType ) [private]

First phase constuctor.

Since:
7.0
Parameters:
aPDUType The PDU type assigned to the method name.

Member Function Documentation

CExtendedMethod::ConstructL ( const TDesC8 & aMethodName ) [private]

Second phase constructor.

Does any necessary allocations.

Since:
7.0
Parameters:
aMethodName A reference to a buffer with the method name.

CExtendedMethod::GetMethodName ( ) const [inline]

Returns the method name.

Since:
7.0
Returns:
A const reference to the buffer containg the method name.

CExtendedMethod::GetPDUType ( ) const [inline]

Returns the PDU type for this method.

Since:
7.0
Returns:
A byte containing the PDU type assigned to the method name.

CExtendedMethod::NewL | ( | TUint8 | aPDUType,
 |  | const TDesC8 & | aMethodName
 | ) | [static]

Static factory constructor.

Since:
7.0
Exceptions:
This function will leave if the object cannot be constructed.
Parameters:
aPDUType | The PDU type assigned to the method name.
aMethodName | A reference to a buffer with the method name.

Member Data Documentation

HBufC8* CExtendedMethod::iName [private]

A buffer containing the method name.

Definition at line 80 of file CExtendedMethod.h.

TUint8 CExtendedMethod::iType [private]

The PDU type assigned to the method specified by iMethodName.

Definition at line 75 of file CExtendedMethod.h.

The documentation for this class was generated from the following file:
  • CExtendedMethod.h


Member List

CExtendedMethod Member List

This is the complete list of members for CExtendedMethod, including all inherited members.
CExtendedMethod(TUint8 aPDUType) | CExtendedMethod | [private]
ConstructL(const TDesC8 &aMethodName) | CExtendedMethod | [private]
GetMethodName() const | CExtendedMethod | [inline]
GetPDUType() const | CExtendedMethod | [inline]
iName | CExtendedMethod | [private]
iType | CExtendedMethod | [private]
NewL(TUint8 aPDUType, const TDesC8 &aMethodName) | CExtendedMethod | [static]
~CExtendedMethod() | CExtendedMethod |


TFCoreFiltersPanic Class Reference

#include <corefilterspanic.h>

List of all members.

Public Types

enum | TPanic { EInvalidRedirectCountProperty, EInvalidMaxRedirectProperty, EValidationFilterFailure, EAuthenticationFilterBadState }

Static Public Methods

void | Panic (TInt aPanicCode)

Member Enumeration Documentation

enum TFCoreFiltersPanic::TPanic

Enumeration values:
EInvalidRedirectCountProperty
EInvalidMaxRedirectProperty
EValidationFilterFailure
EAuthenticationFilterBadState

Definition at line 14 of file corefilterspanic.h.

Member Function Documentation

void TFCoreFiltersPanic::Panic ( TInt aPanicCode ) [static]

The documentation for this class was generated from the following file:
  • corefilterspanic.h


Member List

TFCoreFiltersPanic Member List

This is the complete list of members for TFCoreFiltersPanic, including all inherited members.
EAuthenticationFilterBadState enum value | TFCoreFiltersPanic |
EInvalidMaxRedirectProperty enum value | TFCoreFiltersPanic |
EInvalidRedirectCountProperty enum value | TFCoreFiltersPanic |
EValidationFilterFailure enum value | TFCoreFiltersPanic |
Panic(TInt aPanicCode) | TFCoreFiltersPanic | [static]
TPanic enum name | TFCoreFiltersPanic |


MHTTPFilter Class Reference

@public
Since:
7.0 A HTTP filter
More...

#include <mhttpfilter.h>

Inheritance diagram for MHTTPFilter:

[legend]
Collaboration diagram for MHTTPFilter:

[legend]
List of all members.

Public Types

enum TPositions {
EProtocolHandler = 0, ECache = 100, EStatusCodeHandler = 200, ECookies = 300,
ETidyUp = 400, EClientFilters = 500, EClient = 1000
}
Default filter positions. More...

Public Methods

virtual IMPORT_C void | MHFUnload (RHTTPSession aSession, THTTPFilterHandle aHandle)
Called when the filter is being removed from a session's filter queue.

virtual IMPORT_C void | MHFLoad (RHTTPSession aSession, THTTPFilterHandle aHandle)
Called when the filter is being added to the session's filter queue.

Detailed Description

@public
Since:
7.0 A HTTP filter

Definition at line 28 of file mhttpfilter.h.

Member Enumeration Documentation

enum MHTTPFilter::TPositions

Default filter positions.

Enumeration values:
EProtocolHandler | The Protocol Handler :- At the base of the filter chain and nearest to the transport layer.
ECache | Filters to handle caching behaviours.
EStatusCodeHandler Filters to handle particular status codes.

e.g.Redirection and authentication.

ECookies | The cookie filter, and other filters that don't need to be concerned with resubmitting of transactions due to things like redirection.
ETidyUp | The validation filter and any other final tidy up or initial preprocessing of transactions.
EClientFilters | Client filters that assume all standard behaviour is already there.
EClient | The client :- At the head of the filter chain : No position above this must be used.

Definition at line 55 of file mhttpfilter.h.

Member Function Documentation

virtual IMPORT_C void MHTTPFilter::MHFLoad | ( | RHTTPSession | aSession,
 |  | THTTPFilterHandle | aHandle
 | ) | [virtual]

Called when the filter is being added to the session's filter queue.

Parameters:
aSession | The session it's being added to.
aHandle | The filter handle. Complex filters may need to keep track of this, for instance if generating events in response to external stimuli

Reimplemented in TClientFilter, CProtocolHandler, CAuthenticationFilter, CRedirectFilter, CValidationFilter, and CTextModeHeadersFilter.

virtual IMPORT_C void MHTTPFilter::MHFUnload | ( | RHTTPSession | aSession,
 |  | THTTPFilterHandle | aHandle
 | ) | [virtual]

Called when the filter is being removed from a session's filter queue.

Parameters:
aSession | The session it's being removed from
aHandle | The filter handle. Complex filters may need to refer to this to keep track of which particular registration is being unloaded.

Reimplemented in TClientFilter, CProtocolHandler, CAuthenticationFilter, CRedirectFilter, CValidationFilter, and CTextModeHeadersFilter.

The documentation for this class was generated from the following file:
  • mhttpfilter.h


Member List

MHTTPFilter Member List

This is the complete list of members for MHTTPFilter, including all inherited members.
ECache enum value | MHTTPFilter |
EClient enum value | MHTTPFilter |
EClientFilters enum value | MHTTPFilter |
ECookies enum value | MHTTPFilter |
EProtocolHandler enum value | MHTTPFilter |
EStatusCodeHandler enum value | MHTTPFilter |
ETidyUp enum value | MHTTPFilter |
MHFLoad(RHTTPSession aSession, THTTPFilterHandle aHandle) | MHTTPFilter | [virtual]
MHFRunError(TInt aError, RHTTPTransaction aTransaction, const THTTPEvent &aEvent) | MHTTPFilterBase | [virtual]
MHFRunL(RHTTPTransaction aTransaction, const THTTPEvent &aEvent) | MHTTPFilterBase | [virtual]
MHFSessionRunError(TInt aError, const THTTPSessionEvent &aEvent) | MHTTPFilterBase | [virtual]
MHFSessionRunL(const THTTPSessionEvent &aEvent) | MHTTPFilterBase | [virtual]
MHFUnload(RHTTPSession aSession, THTTPFilterHandle aHandle) | MHTTPFilter | [virtual]
TPositions enum name | MHTTPFilter |


MHTTPFilterBase Class Reference

@public
Since:
7.0 A HTTP Filter.
More...

#include <mhttpfilterbase.h>

Inheritance diagram for MHTTPFilterBase:

[legend]
List of all members.

Public Methods

virtual IMPORT_C void | MHFRunL (RHTTPTransaction aTransaction, const THTTPEvent &aEvent)
Called when the filter's registration conditions are satisfied for events that occur on a transaction.

virtual IMPORT_C void | MHFSessionRunL (const THTTPSessionEvent &aEvent)
Called when the filters registration conditions are satisfied for events that occur on the session.

virtual IMPORT_C TInt | MHFRunError (TInt aError, RHTTPTransaction aTransaction, const THTTPEvent &aEvent)
Called when RunL leaves from a transaction event.

virtual IMPORT_C TInt | MHFSessionRunError (TInt aError, const THTTPSessionEvent &aEvent)
Called when MHFRunL leaves from a session event.

Detailed Description

@public
Since:
7.0 A HTTP Filter.

This is the base class for normal filters (MHTTPFilter) which adds an unload function, and MHTTPTransactionCallback, which doesn't add an unload function.

Definition at line 32 of file mhttpfilterbase.h.

Member Function Documentation

virtual IMPORT_C TInt MHTTPFilterBase::MHFRunError | ( | TInt | aError,
 |  | RHTTPTransaction | aTransaction,
 |  | const THTTPEvent & | aEvent
 | ) | [virtual]

Called when RunL leaves from a transaction event.

This works in the same way as CActve::RunError; return KErrNone if you have handled the error. If you don't completely handle the error, a panic will occur.

Parameters:
aError | The leave code that RunL left with.
aTransaction | The transaction that was being processed.
aEvent | The Event that was being processed.
Returns:
KErrNone if the error has been cancelled or the code of the continuing error otherwise.

Reimplemented in TClientFilter, CProtocolHandler, CAuthenticationFilter, CRedirectFilter, CValidationFilter, and CTextModeHeadersFilter.

virtual IMPORT_C void MHTTPFilterBase::MHFRunL | ( | RHTTPTransaction | aTransaction,
 |  | const THTTPEvent & | aEvent
 | ) | [virtual]

Called when the filter's registration conditions are satisfied for events that occur on a transaction.

Note that this function is not allowed to leave if called with certain events.

See also:
THTTPEvent
Parameters:
aTransaction | The transaction that the event has occurred on.
aEvent | The event that has occurred.
Exceptions:
Any Leaves must be handled by the appropriate MHFRunError.

Reimplemented in TClientFilter, CProtocolHandler, CAuthenticationFilter, CRedirectFilter, CValidationFilter, and CTextModeHeadersFilter.

virtual IMPORT_C TInt MHTTPFilterBase::MHFSessionRunError | ( | TInt | aError,
 |  | const THTTPSessionEvent & | aEvent
 | ) | [virtual]

Called when MHFRunL leaves from a session event.

This works in the same way as CActve::RunError If you don't completely handle the error, a panic will occur.

Parameters:
aError | The leave code that RunL left with.
aEvent | The Event that was being processed.
Returns:
KErrNone if the error has been cancelled or the code of the continuing error otherwise.

Reimplemented in TClientFilter, CProtocolHandler, CAuthenticationFilter, CRedirectFilter, CValidationFilter, CTextModeHeadersFilter, and CWspCOProtocolHandler.

virtual IMPORT_C void MHTTPFilterBase::MHFSessionRunL ( const THTTPSessionEvent & aEvent ) [virtual]

Called when the filters registration conditions are satisfied for events that occur on the session.

@ param aEvent The session event that has occured. @ exception Any leaves must be handled by the appropriate MHFRunError.

Reimplemented in TClientFilter, CProtocolHandler, CAuthenticationFilter, CRedirectFilter, CValidationFilter, CTextModeHeadersFilter, and CWspCOProtocolHandler.

The documentation for this class was generated from the following file:
  • mhttpfilterbase.h


Member List

MHTTPFilterBase Member List

This is the complete list of members for MHTTPFilterBase, including all inherited members.
MHFRunError(TInt aError, RHTTPTransaction aTransaction, const THTTPEvent &aEvent) | MHTTPFilterBase | [virtual]
MHFRunL(RHTTPTransaction aTransaction, const THTTPEvent &aEvent) | MHTTPFilterBase | [virtual]
MHFSessionRunError(TInt aError, const THTTPSessionEvent &aEvent) | MHTTPFilterBase | [virtual]
MHFSessionRunL(const THTTPSessionEvent &aEvent) | MHTTPFilterBase | [virtual]


RHTTPFilterCollection Class Reference

@public
Since:
7.0 A Handle on the filter collection in a session.
More...

#include <rhttpfiltercollection.h>

Collaboration diagram for RHTTPFilterCollection:

[legend]
List of all members.

Public Methods

RHTTPFilterCollection ()
IMPORT_C void | AddFilterL (MHTTPFilter &aFilter, THTTPEvent aEvent, RStringF aHeader, TInt aStatusCode, TInt aPosition, RStringF aName)
Adds a filter to the session's filter queue.

IMPORT_C void | AddFilterL (MHTTPFilter &aFilter, THTTPEvent aEvent, TInt aPosition, RStringF aName)
Adds a filter to the session's filter queue.

IMPORT_C TBool | CanChangeFilters () const
Returns ETrue if filters can currently be added or removed.

IMPORT_C void | RemoveFilter (RStringF aFilter)
Removes all filter registrations of the specified name.

IMPORT_C THTTPFilterIterator | Query (RStringF aName=RStringF())
Returns an iterator to look at all filter registrations of a particular name.

RHTTPSession | Session () const

Private Attributes

CHTTPSession * iImplementation

Friends

class | CHTTPSession
class | RHTTPSession

Detailed Description

@public
Since:
7.0 A Handle on the filter collection in a session.

It provides facilities for adding and deleting filters and for querying what filters are installed.

See also:
RHTTPSession::FilterCollection , MHTTPFilter::TPositions

Definition at line 37 of file rhttpfiltercollection.h.

Constructor & Destructor Documentation

RHTTPFilterCollection::RHTTPFilterCollection ( ) [inline]

Definition at line 114 of file rhttpfiltercollection.h.

Member Function Documentation

IMPORT_C void RHTTPFilterCollection::AddFilterL | ( | MHTTPFilter & | aFilter,
 |  | THTTPEvent | aEvent,
 |  | TInt | aPosition,
 |  | RStringF | aName
 | ) |

Adds a filter to the session's filter queue.

Intended Usage: This variant takes no status code or header. It is intended for filters that are only interested in events. For example session events.

Precondition:
The session is open and no transactions have been created yet
Parameters:
aFilter | The filter to add
aEvent | The event that triggers this filter (or all)
aPosition | The position of the filter in the queue. Standard values are documented in the documentation for the supplied filters, and are based on the standard defines in MHTTPFilter::TPositions
aName | the name of the Filter to add
Exceptions:
KErrNoMemory There was not enough memory.
See also:
See MHTTPFilter::TPositions

IMPORT_C void RHTTPFilterCollection::AddFilterL | ( | MHTTPFilter & | aFilter,
 |  | THTTPEvent | aEvent,
 |  | RStringF | aHeader,
 |  | TInt | aStatusCode,
 |  | TInt | aPosition,
 |  | RStringF | aName
 | ) |

Adds a filter to the session's filter queue.

Note: This function only adds filters; it doesn't replace or otherwise affect any pre-existing filters.

Precondition:
The session is open and no transactions have been created yet.
Parameters:
aFilter | The filter to add
aEvent | The event that triggers this filter (or all)
aHeader | The header whose presence triggers this filter (or KNullDesC for any)
aStatusCode | The status code that triggers this filter (or -1 for all)
aPosition | The position of the filter in the queue. Standard values are documented in the documentation for the supplied filters, and are based on the standard defines in MHTTPFilter::TPositions
aName | the name of the Filter to add
Exceptions:
KErrNoMemory There was not enough memory.
See also:
See MHTTPFilter::TPositions

IMPORT_C TBool RHTTPFilterCollection::CanChangeFilters ( )

Returns ETrue if filters can currently be added or removed.

Filters can only be added/removed if there are no transactions in existence on the session.

IMPORT_C THTTPFilterIterator RHTTPFilterCollection::Query ( RStringF aName = RStringF() )

Returns an iterator to look at all filter registrations of a particular name.

By default it will find all filters.

Parameters:
aName The name of the filter to find. (All filters will be found if the default parameter is used)

IMPORT_C void RHTTPFilterCollection::RemoveFilter ( RStringF aFilter )

Removes all filter registrations of the specified name.

RHTTPSession RHTTPFilterCollection::Session ( ) [inline]

Definition at line 242 of file rhttpsession.h.

References iImplementation, and RHTTPSession::iImplementation.

Friends And Related Function Documentation

friend class CHTTPSession [friend]

Definition at line 106 of file rhttpfiltercollection.h.

friend class RHTTPSession [friend]

Definition at line 107 of file rhttpfiltercollection.h.

Member Data Documentation

CHTTPSession* RHTTPFilterCollection::iImplementation [private]

Definition at line 110 of file rhttpfiltercollection.h.

Referenced by RHTTPSession::FilterCollection(), and Session().

The documentation for this class was generated from the following files:
  • rhttpfiltercollection.h
  • rhttpsession.h


Member List

RHTTPFilterCollection Member List

This is the complete list of members for RHTTPFilterCollection, including all inherited members.
AddFilterL(MHTTPFilter &aFilter, THTTPEvent aEvent, RStringF aHeader, TInt aStatusCode, TInt aPosition, RStringF aName) | RHTTPFilterCollection |
AddFilterL(MHTTPFilter &aFilter, THTTPEvent aEvent, TInt aPosition, RStringF aName) | RHTTPFilterCollection |
CanChangeFilters() const | RHTTPFilterCollection |
CHTTPSession class | RHTTPFilterCollection | [friend]
iImplementation | RHTTPFilterCollection | [private]
Query(RStringF aName=RStringF()) | RHTTPFilterCollection |
RemoveFilter(RStringF aFilter) | RHTTPFilterCollection |
RHTTPFilterCollection() | RHTTPFilterCollection | [inline]
RHTTPSession class | RHTTPFilterCollection | [friend]
Session() const | RHTTPFilterCollection | [inline]


TFilterConfigurationIterator Class Reference

@public @dependancies CHTTPSession, CEComFilter
Since:
7.0 This class can only be created and destroyed by the session.
More...

#include <TFilterConfigurationIter.h>

Collaboration diagram for TFilterConfigurationIterator:

[legend]
List of all members.

Public Methods

IMPORT_C TInt | First ()
Intended Usage: This method sets the current filter to the first filter in the list.

IMPORT_C TInt | Next ()
Intended Usage: This method sets the current filter to the next filter in the list.

IMPORT_C TBool | AtStart ()
Intended Usage: This method indicates whether the current filter is the first filter in the list.

IMPORT_C TBool | AtEnd ()
Intended Usage: This method indicates whether the current filter is the last filter in the list.

IMPORT_C TInt | FindByDataType (const TDesC8 &aDataType)
Intended Usage: This method find the first filter in the list that has a matching data type that is passed in.

IMPORT_C const TFilterInformation | CurrentFilterInformation () const
Intended Usage: This method will return the information of the current filter.

IMPORT_C TInt | InstallCurrentFilter () const
Intended Usage: This method will install the current filter.

IMPORT_C TInt | UninstallCurrentFilter () const
Intended Usage: This method will uninstall the current filter.

Private Methods

TFilterConfigurationIterator (CHTTPSession *aSession)
~TFilterConfigurationIterator ()

Private Attributes

CHTTPSession * iSession
RPointerArray< TSessionFilterInfo > & | iFilterInfoList
TInt | iCurrentFilterIndex
TInt | iFilterCount

Friends

class | CHTTPSession
class | CFilterConfigurationIterator_UnitTestContext

Detailed Description

@public @dependancies CHTTPSession, CEComFilter
Since:
7.0 This class can only be created and destroyed by the session.

It is supplied to the client, if the client wishes to configure the filter that are installed or install filters that must be installed explicitly. The API of the class allows the client to navigate, install, uninstall and query the filter list. The filters visible in this list are only the implicit and explicit filters declared as plugins. This iterator MUST be initialised using the First() method and the return error code checked before any other operations are called.

Definition at line 40 of file TFilterConfigurationIter.h.

Constructor & Destructor Documentation

TFilterConfigurationIterator::TFilterConfigurationIterator ( CHTTPSession * aSession ) [private]

TFilterConfigurationIterator::~TFilterConfigurationIterator ( ) [private]

Member Function Documentation

TFilterConfigurationIterator::AtEnd ( )

Intended Usage: This method indicates whether the current filter is the last filter in the list.

This method will panic if the iterator has not been initialised using the First() method.

Since:
7.0
Returns:
ETrue if the current filter is the last in the list
Precondition:
The iterator has been initialised using the First() method

TFilterConfigurationIterator::AtStart ( )

Intended Usage: This method indicates whether the current filter is the first filter in the list.

This method will panic if the iterator has not been initialised using the First() method.

Since:
7.0
Returns:
ETrue if the current filter is the first in the list
Precondition:
The iterator has been initialised using the First() method

TFilterConfigurationIterator::CurrentFilterInformation ( ) const

Intended Usage: This method will return the information of the current filter.

The information is provided in a TFilterInformation structure containing the following information: 1) Display name 2) Data type 3) Version 4) UID 5) Category 6) Install status This method will panic if the iterator has not been initialised using the First() method

Since:
7.0
Returns:
A struct containing the current filter information
Precondition:
The iterator has been initialised using the First() method
See also:
TFilterInformation

TFilterConfigurationIterator::FindByDataType ( const TDesC8 & aDataType )

Intended Usage: This method find the first filter in the list that has a matching data type that is passed in.

The method will set the current filter to the filter that matches the data type or if not found the current filter will not change. This method will always begin its search from the beginning of the list.

Since:
7.0
Parameters:
aDataType An 8-bit descriptor containing the data type to match the filter plug-in with
Returns:
KErrNone is the filter plug-in is found, KErrNotFound if not found
Precondition:
Object is constructed
Postcondition:
The current filter is set to the filter that matches the data type

TFilterConfigurationIterator::First ( )

Intended Usage: This method sets the current filter to the first filter in the list.

This method must be used initially to set the current filter and the returned error code must be noted prior to using any of the methods that query or modify the current filter.

Since:
7.0
Returns:
KErrNone if the first filter is found, KErrNotFound if the filter can't be found or no filters exist
Precondition:
Object is constructed
Postcondition:
Current filter is set to the first filter in the list

TFilterConfigurationIterator::InstallCurrentFilter ( ) const

Intended Usage: This method will install the current filter.

This method will panic if a current filter is not set.

Since:
7.0
Returns:
KErrNone if the filter installed, KErrAlreadyExists if the filter has already been installed, KErrNotFound if the filter cannot be found, KErrNotConnected if the ECom plug-in architecture is not connected, KErrNoMemory is the filter is not installed due to low memory, or any other system-wide error codes.
Precondition:
A current filter has been set and is not already installed
Postcondition:
The filter is installed

TFilterConfigurationIterator::Next ( )

Intended Usage: This method sets the current filter to the next filter in the list.

Since:
7.0
Returns:
KErrNone if the next filter is found, KErrNotFound if the filter can't be found, or no filters exist, or the current filter is at the end of the list.
Precondition:
Object is constructed
Postcondition:
Current filter is set to the next filter in the list

TFilterConfigurationIterator::UninstallCurrentFilter ( ) const

Intended Usage: This method will uninstall the current filter.

This method will panic if a current filter is not set.

Since:
7.0
Returns:
KErrNone is the filter uninstalled correctly, KErrNotFound if the filter has not already been installed
Precondition:
A current filter has been set and has already been installed
Postcondition:
The filter is uninstalled

Friends And Related Function Documentation

friend class CFilterConfigurationIterator_UnitTestContext [friend]

Definition at line 167 of file TFilterConfigurationIter.h.

friend class CHTTPSession [friend]

Definition at line 164 of file TFilterConfigurationIter.h.

Member Data Documentation

TInt TFilterConfigurationIterator::iCurrentFilterIndex [private]

Definition at line 192 of file TFilterConfigurationIter.h.

TInt TFilterConfigurationIterator::iFilterCount [private]

Definition at line 196 of file TFilterConfigurationIter.h.

RPointerArray<TSessionFilterInfo>& TFilterConfigurationIterator::iFilterInfoList [private]

Definition at line 188 of file TFilterConfigurationIter.h.

CHTTPSession* TFilterConfigurationIterator::iSession [private]

Definition at line 182 of file TFilterConfigurationIter.h.

The documentation for this class was generated from the following file:
  • TFilterConfigurationIter.h


Member List

TFilterConfigurationIterator Member List

This is the complete list of members for TFilterConfigurationIterator, including all inherited members.
AtEnd() | TFilterConfigurationIterator |
AtStart() | TFilterConfigurationIterator |
CFilterConfigurationIterator_UnitTestContext class | TFilterConfigurationIterator | [friend]
CHTTPSession class | TFilterConfigurationIterator | [friend]
CurrentFilterInformation() const | TFilterConfigurationIterator |
FindByDataType(const TDesC8 &aDataType) | TFilterConfigurationIterator |
First() | TFilterConfigurationIterator |
iCurrentFilterIndex | TFilterConfigurationIterator | [private]
iFilterCount | TFilterConfigurationIterator | [private]
iFilterInfoList | TFilterConfigurationIterator | [private]
InstallCurrentFilter() const | TFilterConfigurationIterator |
iSession | TFilterConfigurationIterator | [private]
Next() | TFilterConfigurationIterator |
TFilterConfigurationIterator(CHTTPSession *aSession) | TFilterConfigurationIterator | [private]
UninstallCurrentFilter() const | TFilterConfigurationIterator |
~TFilterConfigurationIterator() | TFilterConfigurationIterator | [private]


MHTTPFilterCreationCallback Class Reference

@public
Since:
7.0 This class serves as a pure virtual interface required as a session callback to the client when the client requires to configure the filters that are installed.
More...

#include <MHTTPFilterCreationCallback.h>

List of all members.

Public Methods

virtual void ConfigureSessionFiltersL (TFilterConfigurationIterator *aFilterConfigIter)=0
Intended Usage: Pure virtual that is called by the session when the session construction is complete.

Detailed Description

@public
Since:
7.0 This class serves as a pure virtual interface required as a session callback to the client when the client requires to configure the filters that are installed.

The session calls the method in the interface when the construction of the session is complete. The callback passes an object of CFilterConfigurationIterator that allows the client to configure the filters that are installed.

Definition at line 29 of file MHTTPFilterCreationCallback.h.

Member Function Documentation

MHTTPFilterCreationCallback::ConfigureSessionFiltersL ( TFilterConfigurationIterator * aFilterConfigIter ) [pure virtual]

Intended Usage: Pure virtual that is called by the session when the session construction is complete.

This passes a CFilterConfigurationIterator back to the client which allows the client to install or install selected filters.

Since:
7.0
Parameters:
aFilterConfigIter Pointer to the filter configuration iterator. Ownership of CFilterConfigurationIterator remains with the session and is not transfered
Precondition:
The session has been constructed
Postcondition:
The filters that are installed are have been configured by the client

The documentation for this class was generated from the following file:
  • MHTTPFilterCreationCallback.h


Member List

MHTTPFilterCreationCallback Member List

This is the complete list of members for MHTTPFilterCreationCallback, including all inherited members.
ConfigureSessionFiltersL(TFilterConfigurationIterator *aFilterConfigIter)=0 MHTTPFilterCreationCallback [pure virtual]


THTTPFilterHandle Class Reference

@public
Since:
7.0 A Filter registration handle.
More...

#include <thttpfilterhandle.h>

List of all members.

Public Types

enum | TStandardValues { EUndefined = 0, EClient = -1, EProtocolHandler = -2, ECurrentFilter = -3 }
Alisases for the client, and the filters you're most likely to want to refer to. More...

Public Methods

THTTPFilterHandle (TStandardValues aVal=EUndefined)
TBool | operator== (THTTPFilterHandle aThat) const
TBool | operator!= (THTTPFilterHandle aThat) const

Private Attributes

TInt | iValue

Friends

class | RHTTPSession
class | RHTTPFilterCollection
class | CHTTPSession
class | CTransaction

Detailed Description

@public
Since:
7.0 A Filter registration handle.

This identifies a particular filter registration, and is passed to the filter in MHFLoad. It is used to identify filters for deletion and for locating the start point for sending events. It is an opaque class; all you need to be able to do with it is to compare them for equality.

Definition at line 29 of file thttpfilterhandle.h.

Member Enumeration Documentation

enum THTTPFilterHandle::TStandardValues

Alisases for the client, and the filters you're most likely to want to refer to.

Enumeration values:
EUndefined | Undefined default value.
EClient | Placeholder for the client.
EProtocolHandler Constant value for the protocol handler.

When sending an event from a MHFRunL, indicates the current filter.

ECurrentFilter

Definition at line 37 of file thttpfilterhandle.h.

Constructor & Destructor Documentation

THTTPFilterHandle::THTTPFilterHandle ( TStandardValues aVal = EUndefined ) [inline]

Definition at line 61 of file thttpfilterhandle.h.

Member Function Documentation

TBool THTTPFilterHandle::operator!= ( THTTPFilterHandle aThat ) const [inline]

Definition at line 71 of file thttpfilterhandle.h.

TBool THTTPFilterHandle::operator== ( THTTPFilterHandle aThat ) const [inline]

Definition at line 66 of file thttpfilterhandle.h.

References iValue.

Friends And Related Function Documentation

friend class CHTTPSession [friend]

Definition at line 57 of file thttpfilterhandle.h.

friend class CTransaction [friend]

Definition at line 58 of file thttpfilterhandle.h.

friend class RHTTPFilterCollection [friend]

Definition at line 56 of file thttpfilterhandle.h.

friend class RHTTPSession [friend]

Definition at line 55 of file thttpfilterhandle.h.

Member Data Documentation

TInt THTTPFilterHandle::iValue [private]

Definition at line 54 of file thttpfilterhandle.h.

Referenced by operator==().

The documentation for this class was generated from the following file:
  • thttpfilterhandle.h


Member List

THTTPFilterHandle Member List

This is the complete list of members for THTTPFilterHandle, including all inherited members.
CHTTPSession class | THTTPFilterHandle | [friend]
CTransaction class | THTTPFilterHandle | [friend]
EClient enum value | THTTPFilterHandle |
ECurrentFilter enum value | THTTPFilterHandle |
EProtocolHandler enum value | THTTPFilterHandle |
EUndefined enum value | THTTPFilterHandle |
iValue | THTTPFilterHandle | [private]
operator!=(THTTPFilterHandle aThat) const | THTTPFilterHandle | [inline]
operator==(THTTPFilterHandle aThat) const | THTTPFilterHandle | [inline]
RHTTPFilterCollection class | THTTPFilterHandle | [friend]
RHTTPSession class | THTTPFilterHandle | [friend]
THTTPFilterHandle(TStandardValues aVal=EUndefined) | THTTPFilterHandle | [inline]
TStandardValues enum name | THTTPFilterHandle |


TFilterInformation Struct Reference

@public
Since:
7.0 This structure is used by the TFilterConfigurationIterator to hold the information of the current filter.
More...

#include <TFilterInformation.h>

List of all members.

Public Types

enum | TFilterCategory { EImplicitFilter, EExplicitFilter }
Public enum defining the filter categories available to the client. More...

Public Methods

TFilterInformation (const TDesC &aDisplayName, const TDesC8 &aDataType, TInt aVersion, TUid aFilterUid, TFilterCategory aFilterCategory, TBool aInstallStatus)
Default constructor that simply initialises the data members.

Public Attributes

const TDesC & | iDisplayName
Contains a constant reference to the descriptor containing the filter's display name.

const TDesC8 & | iDataType
Contains a constant reference to the descriptor containing the filter's data type.

TInt | iVersion
The filter's version number.

TUid | iFilterUid
The filter's plugin UID.

TFilterCategory iFilterCategory
The filter's category.

TBool | iInstallStatus
The install status of the filter.

Detailed Description

@public
Since:
7.0 This structure is used by the TFilterConfigurationIterator to hold the information of the current filter.

This structure simply contains public members containing the following information, the display name, data type, version, UID, category and install status.

See also:
TFilterConfigurationIterator

Definition at line 25 of file TFilterInformation.h.

Member Enumeration Documentation

enum TFilterInformation::TFilterCategory

Public enum defining the filter categories available to the client.

Since:
7.0 @cat Enumerations
Enumeration values:
EImplicitFilter
EExplicitFilter

Definition at line 33 of file TFilterInformation.h.

Constructor & Destructor Documentation

TFilterInformation::TFilterInformation | ( | const TDesC & | aDisplayName,
 |  | const TDesC8 & | aDataType,
 |  | TInt | aVersion,
 |  | TUid | aFilterUid,
 |  | TFilterCategory | aFilterCategory,
 |  | TBool | aInstallStatus
 | ) | [inline]

Default constructor that simply initialises the data members.

Since:
7.0
Parameters:
aDisplayName | Reference to descriptor containing the display name
aDataType | Reference to descriptor containing the data type
aVersion | Integer of the version number
aFilterUid | The UID of the filter plugin
aFilterCategory | The category of the filter
aInstallStatus | The install status of the filter plugin. Contains ETrue if installed or EFalse otherwise.
Precondition:
None
Postcondition:
Object is fully constructed and initialised

Definition at line 83 of file TFilterInformation.h.

Member Data Documentation

const TDesC8& TFilterInformation::iDataType

Contains a constant reference to the descriptor containing the filter's data type.

Definition at line 45 of file TFilterInformation.h.

const TDesC& TFilterInformation::iDisplayName

Contains a constant reference to the descriptor containing the filter's display name.

Definition at line 41 of file TFilterInformation.h.

TFilterCategory TFilterInformation::iFilterCategory

The filter's category.

Definition at line 57 of file TFilterInformation.h.

TUid TFilterInformation::iFilterUid

The filter's plugin UID.

Definition at line 53 of file TFilterInformation.h.

TBool TFilterInformation::iInstallStatus

The install status of the filter.

Contains ETrue if installed, otherwise EFalse

Definition at line 61 of file TFilterInformation.h.

TInt TFilterInformation::iVersion

The filter's version number.

Definition at line 49 of file TFilterInformation.h.

The documentation for this struct was generated from the following file:
  • TFilterInformation.h


Member List

TFilterInformation Member List

This is the complete list of members for TFilterInformation, including all inherited members.
EExplicitFilter enum value | TFilterInformation |
EImplicitFilter enum value | TFilterInformation |
iDataType | TFilterInformation |
iDisplayName | TFilterInformation |
iFilterCategory | TFilterInformation |
iFilterUid | TFilterInformation |
iInstallStatus | TFilterInformation |
iVersion | TFilterInformation |
TFilterCategory enum name | TFilterInformation |
TFilterInformation(const TDesC &aDisplayName, const TDesC8 &aDataType, TInt aVersion, TUid aFilterUid, TFilterCategory aFilterCategory, TBool aInstallStatus) | TFilterInformation | [inline]


THTTPFilterIterator Class Reference

@public
Since:
7.0 An iterator for RHTTPFilterCollection.
More...

#include <thttpfilteriterator.h>

Collaboration diagram for THTTPFilterIterator:

[legend]
List of all members.

Public Methods

THTTPFilterIterator ()
Non-initialised constructor.

void | First ()
Moves the iterator to the first member of the collection.

IMPORT_C TBool | AtEnd () const
Returns ETrue if the iterator is at the end of the collection.

IMPORT_C THTTPFilterIterator & | operator++ ()
Moves on to the next item in the collection.

IMPORT_C const THTTPFilterRegistration & | operator() () const
Returns the filter that the iterator is pointing at.

const THTTPFilterRegistration & | operator * () const
Returns the filter that the iterator is pointing at.

const THTTPFilterRegistration & | operator-> () const
Returns the filter that the iterator is pointing at.

Private Attributes

CHTTPSession * iImplementation
TInt | iPos
RStringTokenF | iName

Friends

class | RHTTPFilterCollection

Detailed Description

@public
Since:
7.0 An iterator for RHTTPFilterCollection.

The iterator can iterate over a subset of the filters in the collection, depending on how it was created. See RHTTPFilterCollection::Query for more details. In the documentation here, 'the collection' always refers to the filters that this iterator can see.

Definition at line 34 of file thttpfilteriterator.h.

Constructor & Destructor Documentation

THTTPFilterIterator::THTTPFilterIterator ( ) [inline]

Non-initialised constructor.

Note, to get an initialised one that actualy points to a filter collection, use RHTTPFilterCollection::Query

Definition at line 81 of file thttpfilteriterator.h.

Member Function Documentation

IMPORT_C TBool THTTPFilterIterator::AtEnd ( )

Returns ETrue if the iterator is at the end of the collection.

void THTTPFilterIterator::First ( ) [inline]

Moves the iterator to the first member of the collection.

Definition at line 86 of file thttpfilteriterator.h.

References iPos, and operator++().

const THTTPFilterRegistration & THTTPFilterIterator::operator * ( ) [inline]

Returns the filter that the iterator is pointing at.

Definition at line 92 of file thttpfilteriterator.h.

References operator()().

IMPORT_C const THTTPFilterRegistration& THTTPFilterIterator::operator() ( )

Returns the filter that the iterator is pointing at.

Referenced by operator *(), and operator->().

IMPORT_C THTTPFilterIterator& THTTPFilterIterator::operator++ ( )

Moves on to the next item in the collection.

Referenced by First().

const THTTPFilterRegistration & THTTPFilterIterator::operator-> ( ) [inline]

Returns the filter that the iterator is pointing at.

Definition at line 97 of file thttpfilteriterator.h.

References operator()().

Friends And Related Function Documentation

friend class RHTTPFilterCollection [friend]

Definition at line 68 of file thttpfilteriterator.h.

Member Data Documentation

CHTTPSession* THTTPFilterIterator::iImplementation [private]

Definition at line 71 of file thttpfilteriterator.h.

RStringTokenF THTTPFilterIterator::iName [private]

Definition at line 77 of file thttpfilteriterator.h.

TInt THTTPFilterIterator::iPos [private]

Definition at line 74 of file thttpfilteriterator.h.

Referenced by First().

The documentation for this class was generated from the following file:
  • thttpfilteriterator.h


Member List

THTTPFilterIterator Member List

This is the complete list of members for THTTPFilterIterator, including all inherited members.
AtEnd() const | THTTPFilterIterator |
First() | THTTPFilterIterator | [inline]
iImplementation | THTTPFilterIterator | [private]
iName | THTTPFilterIterator | [private]
iPos | THTTPFilterIterator | [private]
operator *() const | THTTPFilterIterator | [inline]
operator()() const | THTTPFilterIterator |
operator++() | THTTPFilterIterator |
operator->() const | THTTPFilterIterator | [inline]
RHTTPFilterCollection class | THTTPFilterIterator | [friend]
THTTPFilterIterator() | THTTPFilterIterator | [inline]


TFilterRegistration Class Reference

A registration of a filter in the filter queue. More...

#include <TFilterRegistration.h>

Collaboration diagram for TFilterRegistration:

[legend]
List of all members.

Public Methods

TFilterRegistration ()
Default constructor.

TFilterRegistration (MHTTPFilter &aFilter, THTTPEvent aEvent, RStringToken aHeader, TInt aStatusCode, TInt aPosition, RStringToken aName, TInt aHandle)
Constructor.

TBool | operator== (TFilterRegistration &aThat)
Equality operator.

TBool | operator!= (TFilterRegistration &aThat)
Inequality operator.

Public Attributes

TInt | iPosition
The priority.

MHTTPFilter * iFilter
The filter.

THTTPEvent iEvent
The event it's interested in (or any).

RStringToken | iHeader
The header it's interested in (or any).

TInt | iStatus
The status it's interested in (or any).

RStringToken | iName
The name of the filter.

TInt | iHandle
The handle of the filter.

Detailed Description

A registration of a filter in the filter queue.

Definition at line 12 of file TFilterRegistration.h.

Constructor & Destructor Documentation

TFilterRegistration::TFilterRegistration ( ) [inline]

Default constructor.

Definition at line 54 of file TFilterRegistration.h.

References Wap::EAny.

TFilterRegistration::TFilterRegistration | ( | MHTTPFilter & | aFilter,
 |  | THTTPEvent | aEvent,
 |  | RStringToken | aHeader,
 |  | TInt | aStatusCode,
 |  | TInt | aPosition,
 |  | RStringToken | aName,
 |  | TInt | aHandle
 | ) | [inline]

Constructor.

Definition at line 59 of file TFilterRegistration.h.

Member Function Documentation

TBool TFilterRegistration::operator!= ( TFilterRegistration & aThat )

Inequality operator.

TBool TFilterRegistration::operator== ( TFilterRegistration & aThat )

Equality operator.

Member Data Documentation

THTTPEvent TFilterRegistration::iEvent

The event it's interested in (or any).

Definition at line 39 of file TFilterRegistration.h.

MHTTPFilter* TFilterRegistration::iFilter

The filter.

Definition at line 36 of file TFilterRegistration.h.

TInt TFilterRegistration::iHandle

The handle of the filter.

Definition at line 51 of file TFilterRegistration.h.

RStringToken TFilterRegistration::iHeader

The header it's interested in (or any).

Definition at line 42 of file TFilterRegistration.h.

RStringToken TFilterRegistration::iName

The name of the filter.

Definition at line 48 of file TFilterRegistration.h.

TInt TFilterRegistration::iPosition

The priority.

Definition at line 33 of file TFilterRegistration.h.

TInt TFilterRegistration::iStatus

The status it's interested in (or any).

Definition at line 45 of file TFilterRegistration.h.

The documentation for this class was generated from the following file:
  • TFilterRegistration.h


Member List

TFilterRegistration Member List

This is the complete list of members for TFilterRegistration, including all inherited members.
iEvent | TFilterRegistration |
iFilter | TFilterRegistration |
iHandle | TFilterRegistration |
iHeader | TFilterRegistration |
iName | TFilterRegistration |
iPosition | TFilterRegistration |
iStatus | TFilterRegistration |
operator!=(TFilterRegistration &aThat) | TFilterRegistration |
operator==(TFilterRegistration &aThat) | TFilterRegistration |
TFilterRegistration() | TFilterRegistration | [inline]
TFilterRegistration(MHTTPFilter &aFilter, THTTPEvent aEvent, RStringToken aHeader, TInt aStatusCode, TInt aPosition, RStringToken aName, TInt aHandle) | TFilterRegistration | [inline]


THTTPFilterRegistration Class Reference

@public
Since:
7.0 A registration of a filter in the filter queue
More...

#include <thttpfilterregistration.h>

Collaboration diagram for THTTPFilterRegistration:

[legend]
List of all members.

Public Methods

THTTPFilterRegistration ()
Default constructor.

THTTPFilterRegistration (MHTTPFilter &aFilter, THTTPEvent aEvent, RStringTokenF aHeader, TInt aStatusCode, TInt aPosition, RStringTokenF aName, TInt aHandle)
Constructor.

TBool | operator== (THTTPFilterRegistration &aThat)
Equality operator.

TBool | operator!= (THTTPFilterRegistration &aThat)
Inequality operator.

Public Attributes

TInt | iPosition
The position.

MHTTPFilter * iFilter
The filter.

THTTPEvent iEvent
The event it's interested in (or any).

RStringTokenF | iHeader
The header it's interested in (or any).

TInt | iStatus
The status it's interested in (or any).

RStringTokenF | iName
The name of the filter.

TInt | iHandle
The handle of the filter.

Detailed Description

@public
Since:
7.0 A registration of a filter in the filter queue

Definition at line 30 of file thttpfilterregistration.h.

Constructor & Destructor Documentation

THTTPFilterRegistration::THTTPFilterRegistration ( ) [inline]

Default constructor.

Definition at line 72 of file thttpfilterregistration.h.

THTTPFilterRegistration::THTTPFilterRegistration | ( | MHTTPFilter & | aFilter,
 |  | THTTPEvent | aEvent,
 |  | RStringTokenF | aHeader,
 |  | TInt | aStatusCode,
 |  | TInt | aPosition,
 |  | RStringTokenF | aName,
 |  | TInt | aHandle
 | ) | [inline]

Constructor.

Definition at line 77 of file thttpfilterregistration.h.

Member Function Documentation

TBool THTTPFilterRegistration::operator!= ( THTTPFilterRegistration & aThat )

Inequality operator.

TBool THTTPFilterRegistration::operator== ( THTTPFilterRegistration & aThat )

Equality operator.

Member Data Documentation

THTTPEvent THTTPFilterRegistration::iEvent

The event it's interested in (or any).

Definition at line 57 of file thttpfilterregistration.h.

MHTTPFilter* THTTPFilterRegistration::iFilter

The filter.

Definition at line 54 of file thttpfilterregistration.h.

TInt THTTPFilterRegistration::iHandle

The handle of the filter.

Definition at line 69 of file thttpfilterregistration.h.

RStringTokenF THTTPFilterRegistration::iHeader

The header it's interested in (or any).

Definition at line 60 of file thttpfilterregistration.h.

RStringTokenF THTTPFilterRegistration::iName

The name of the filter.

Definition at line 66 of file thttpfilterregistration.h.

TInt THTTPFilterRegistration::iPosition

The position.

Definition at line 51 of file thttpfilterregistration.h.

TInt THTTPFilterRegistration::iStatus

The status it's interested in (or any).

Definition at line 63 of file thttpfilterregistration.h.

The documentation for this class was generated from the following file:
  • thttpfilterregistration.h


Member List

THTTPFilterRegistration Member List

This is the complete list of members for THTTPFilterRegistration, including all inherited members.
iEvent | THTTPFilterRegistration |
iFilter | THTTPFilterRegistration |
iHandle | THTTPFilterRegistration |
iHeader | THTTPFilterRegistration |
iName | THTTPFilterRegistration |
iPosition | THTTPFilterRegistration |
iStatus | THTTPFilterRegistration |
operator!=(THTTPFilterRegistration &aThat) | THTTPFilterRegistration |
operator==(THTTPFilterRegistration &aThat) | THTTPFilterRegistration |
THTTPFilterRegistration() | THTTPFilterRegistration | [inline]
THTTPFilterRegistration(MHTTPFilter &aFilter, THTTPEvent aEvent, RStringTokenF aHeader, TInt aStatusCode, TInt aPosition, RStringTokenF aName, TInt aHandle) | THTTPFilterRegistration | [inline]


CHTTPFormEncoder Class Reference

@public
Since:
7.0 A data supplier class that is used to build up data that is to be encoded to application/x-www-form-urlencoded.
More...

#include <chttpformencoder.h>

Inheritance diagram for CHTTPFormEncoder:

[legend]
Collaboration diagram for CHTTPFormEncoder:

[legend]
List of all members.

Public Methods

IMPORT_C | ~CHTTPFormEncoder ()
virtual TBool | GetNextDataPart (TPtrC8 &aDataPart)
Obtain a data part from the supplier.

virtual void | ReleaseData ()
Release the current data part being held at the data supplier.

virtual TInt | OverallDataSize ()
Obtain the overall size of the data being supplied, if known to the supplier.

virtual TInt | Reset ()
Reset the data supplier.

IMPORT_C void | AddFieldL (const TDesC8 &aFieldName, const TDesC8 &aFieldValue)
Adds a field to the data.

Static Public Methods

IMPORT_C CHTTPFormEncoder * | NewL ()

Private Types

enum | THTTPFormEncoderState { EAllowAppendData, ESuppliedSize, ESupplyingData, EDataReleased }

Private Methods

CHTTPFormEncoder ()
void | ConstructL ()
TBool | IsAlphaNumeric (TUint8 aChar)
void | AppendSpecialChar (TUint8 aChar)
void | AppendData (const TDesC8 &aData)

Private Attributes

THTTPFormEncoderState iState
HBufC8 * | iData

Detailed Description

@public
Since:
7.0 A data supplier class that is used to build up data that is to be encoded to application/x-www-form-urlencoded.

A client will create an instance of this class and add name/value pairs. They then use this as the data supplier for the body of an http request that is a forms submission.

The name and value must both be supplied in the correct character encoding that you want to send to the server. This then gets url encoded.

Definition at line 31 of file chttpformencoder.h.

Member Enumeration Documentation

enum CHTTPFormEncoder::THTTPFormEncoderState [private]

Enumeration values:
EAllowAppendData
ESuppliedSize
ESupplyingData
EDataReleased

Definition at line 76 of file chttpformencoder.h.

Constructor & Destructor Documentation

IMPORT_C CHTTPFormEncoder::~CHTTPFormEncoder ( )

CHTTPFormEncoder::CHTTPFormEncoder ( ) [private]

Member Function Documentation

IMPORT_C void CHTTPFormEncoder::AddFieldL | ( | const TDesC8 & | aFieldName,
 |  | const TDesC8 & | aFieldValue
 | ) |

Adds a field to the data.

A field consists a name and value pair

Parameters:
aFieldName | A name. This must not be empty
aFieldValue | A value. This may be an empty descriptor
Exceptions:
KErrNoMemory | There was not enough memory
KErrArgument | aFieldName was empty @panic Will panic if called after the first data has been supplied or OverallDataSize has been called

void CHTTPFormEncoder::AppendData ( const TDesC8 & aData ) [private]

void CHTTPFormEncoder::AppendSpecialChar ( TUint8 aChar ) [private]

void CHTTPFormEncoder::ConstructL ( ) [private]

virtual TBool CHTTPFormEncoder::GetNextDataPart ( TPtrC8 & aDataPart ) [virtual]

Obtain a data part from the supplier.

The data is guaranteed to survive until a call is made to ReleaseData().

Parameters:
aDataPart - the data part
Returns:
ETrue if this is the last part. EFalse otherwise

Implements MHTTPDataSupplier.

TBool CHTTPFormEncoder::IsAlphaNumeric ( TUint8 aChar ) [private]

IMPORT_C CHTTPFormEncoder* CHTTPFormEncoder::NewL ( ) [static]

virtual TInt CHTTPFormEncoder::OverallDataSize ( ) [virtual]

Obtain the overall size of the data being supplied, if known to the supplier.

Where a body of data is supplied in several parts this size will be the sum of all the part sizes. If the size is not known, KErrNotFound is returned; in this case the client must use the return code of GetNextDataPart to find out when the data is complete.

Returns:
A size in bytes, or KErrNotFound if the size is not known.

Implements MHTTPDataSupplier.

virtual void CHTTPFormEncoder::ReleaseData ( ) [virtual]

Release the current data part being held at the data supplier.

This call indicates to the supplier that the part is no longer needed, and another one can be supplied, if appropriate.

Implements MHTTPDataSupplier.

virtual TInt CHTTPFormEncoder::Reset ( ) [virtual]

Reset the data supplier.

This indicates to the data supplier that it should return to the first part of the data. This could be used in a situation where the data consumer has encountered an error and needs the data to be supplied afresh. Even if the last part has been supplied (i.e. GetNextDataPart has returned ETrue), the data supplier should reset to the first part.

If the supplier cannot reset it should return an error code; otherwise it should return KErrNone, where the reset will be assumed to have succeeded

Implements MHTTPDataSupplier.

Member Data Documentation

HBufC8* CHTTPFormEncoder::iData [private]

Definition at line 87 of file chttpformencoder.h.

THTTPFormEncoderState CHTTPFormEncoder::iState [private]

Definition at line 85 of file chttpformencoder.h.

The documentation for this class was generated from the following file:
  • chttpformencoder.h


Member List

CHTTPFormEncoder Member List

This is the complete list of members for CHTTPFormEncoder, including all inherited members.
AddFieldL(const TDesC8 &aFieldName, const TDesC8 &aFieldValue) | CHTTPFormEncoder |
AppendData(const TDesC8 &aData) | CHTTPFormEncoder | [private]
AppendSpecialChar(TUint8 aChar) | CHTTPFormEncoder | [private]
CHTTPFormEncoder() | CHTTPFormEncoder | [private]
ConstructL() | CHTTPFormEncoder | [private]
EAllowAppendData enum value | CHTTPFormEncoder | [private]
EDataReleased enum value | CHTTPFormEncoder | [private]
ESuppliedSize enum value | CHTTPFormEncoder | [private]
ESupplyingData enum value | CHTTPFormEncoder | [private]
GetNextDataPart(TPtrC8 &aDataPart) | CHTTPFormEncoder | [virtual]
iData | CHTTPFormEncoder | [private]
IsAlphaNumeric(TUint8 aChar) | CHTTPFormEncoder | [private]
iState | CHTTPFormEncoder | [private]
NewL() | CHTTPFormEncoder | [static]
OverallDataSize() | CHTTPFormEncoder | [virtual]
ReleaseData() | CHTTPFormEncoder | [virtual]
Reset() | CHTTPFormEncoder | [virtual]
THTTPFormEncoderState enum name | CHTTPFormEncoder | [private]
~CHTTPFormEncoder() | CHTTPFormEncoder |


THTTPHdrFieldIter Class Reference

@public
Since:
7.0 Iterator class to iterate the fields within a RHTTPHeaders.
More...

#include <thttphdrfielditer.h>

Collaboration diagram for THTTPHdrFieldIter:

[legend]
List of all members.

Public Methods

THTTPHdrFieldIter (const CHeaders *aHeaders)
Construct an iterator for the fields of the supplied header collection.

IMPORT_C | ~THTTPHdrFieldIter ()
Class destructor.

IMPORT_C void | First ()
Reset iterator to point at the first field in the header collection.

IMPORT_C TBool | AtEnd () const
Check if the iterator is at the end of the collection.

IMPORT_C void | operator++ ()
Advance the iterator to the next field.

IMPORT_C RStringTokenF | operator() ()
Obtain the name of the header field currently pointed at by the iterator.

Private Methods

void | CheckInvalidation ()
Check the iterator state for invalidity following deletions in the collection.

Private Attributes

const CHeaders * | iHeaders
The headers whose fields we are iterating.

TInt | iPosIdx
The index of the field in the header that is currently pointed at by the iterator.

Detailed Description

@public
Since:
7.0 Iterator class to iterate the fields within a RHTTPHeaders.

Definition at line 29 of file thttphdrfielditer.h.

Constructor & Destructor Documentation

THTTPHdrFieldIter::THTTPHdrFieldIter ( const CHeaders * aHeaders ) [inline]

Construct an iterator for the fields of the supplied header collection.

Parameters:
aHeaders The header collection whose fields we want to iterate

Definition at line 88 of file thttphdrfielditer.h.

References First().

IMPORT_C THTTPHdrFieldIter::~THTTPHdrFieldIter ( )

Class destructor.

Member Function Documentation

IMPORT_C TBool THTTPHdrFieldIter::AtEnd ( )

Check if the iterator is at the end of the collection.

If so, further calls to operator() will return NULL.

Returns:
True if the iterator has reached the end of the header fields

void THTTPHdrFieldIter::CheckInvalidation ( ) [private]

Check the iterator state for invalidity following deletions in the collection.

IMPORT_C void THTTPHdrFieldIter::First ( )

Reset iterator to point at the first field in the header collection.

Referenced by THTTPHdrFieldIter().

IMPORT_C RStringTokenF THTTPHdrFieldIter::operator() ( )

Obtain the name of the header field currently pointed at by the iterator.

Returns:
The field name; or <empty string> if the iterator has gone off the end of the header collection

IMPORT_C void THTTPHdrFieldIter::operator++ ( )

Advance the iterator to the next field.

Returns:
True if the iterator still points at a valid part after advancing.

Member Data Documentation

const CHeaders* THTTPHdrFieldIter::iHeaders [private]

The headers whose fields we are iterating.

Definition at line 80 of file thttphdrfielditer.h.

TInt THTTPHdrFieldIter::iPosIdx [private]

The index of the field in the header that is currently pointed at by the iterator.

Definition at line 85 of file thttphdrfielditer.h.

The documentation for this class was generated from the following file:
  • thttphdrfielditer.h


Member List

THTTPHdrFieldIter Member List

This is the complete list of members for THTTPHdrFieldIter, including all inherited members.
AtEnd() const | THTTPHdrFieldIter |
CheckInvalidation() | THTTPHdrFieldIter | [private]
First() | THTTPHdrFieldIter |
iHeaders | THTTPHdrFieldIter | [private]
iPosIdx | THTTPHdrFieldIter | [private]
operator()() | THTTPHdrFieldIter |
operator++() | THTTPHdrFieldIter |
THTTPHdrFieldIter(const CHeaders *aHeaders) | THTTPHdrFieldIter | [inline]
~THTTPHdrFieldIter() | THTTPHdrFieldIter |


THTTPHdrVal Class Reference

@public
Since:
7.0 A representation of a value found in an HTTP header field.
More...

#include <thttphdrval.h>

List of all members.

Public Types

enum THTTPValType {
KTIntVal = 0x00, KStrVal = 0x01, KDateVal = 0x02, KStrFVal = 0x03,
KNoType = 0x04
}

Public Methods

IMPORT_C | THTTPHdrVal ()
Default constructor Used when constructing an empty header value that is to be filled in by a call to a function.

IMPORT_C | THTTPHdrVal (TInt aIntVal)
Constructor for an integer field value.

IMPORT_C | THTTPHdrVal (RStringF aStrVal)
Constructor for an string value.

IMPORT_C | THTTPHdrVal (RString aStrVal)
Constructor for an string value.

IMPORT_C | THTTPHdrVal (TDateTime aDateVal)
Constructor for an date/time value.

IMPORT_C THTTPHdrVal | Copy () const
Obtain a copy of this header value.

IMPORT_C THTTPValType | Type () const
Determine the type of this header field value.

IMPORT_C TInt | Int () const
Obtain the (integer) value held within Panics if the value is of the wring type.

operator TInt () const
Cast operator to obtain the HTTP value as an integer.

IMPORT_C RStringF | StrF () const
Obtain the (string) value held within Panics if the value is of the wring type.

IMPORT_C RString | Str () const
operator RStringF () const
Cast operator to obtain the HTTP value as a string.

operator RString () const
Cast operator to obtain the HTTP value as a string.

IMPORT_C TDateTime | DateTime () const
Obtain the (date/time) value held within.

operator TDateTime () const
Cast operator to obtain the HTTP value as an date/time.

IMPORT_C void | SetInt (TInt aIntVal)
Set the header value to be the supplied integer.

IMPORT_C void | SetStrF (RStringF aStrVal)
Set the header value to be the supplied string.

IMPORT_C void | SetStr (RString aStrVal)
Set the header value to be the supplied string.

IMPORT_C void | SetDateTime (TDateTime aDateVal)
Set the header value to be the supplied date/time.

IMPORT_C TBool | operator== (THTTPHdrVal aVal) const
Comparison operator.

IMPORT_C TBool | operator!= (THTTPHdrVal aVal) const
Comparison operator.

Private Attributes

THTTPValType iType
@private The current type

TInt | iVal
The value.

TInt | iMoreSpace

Detailed Description

@public
Since:
7.0 A representation of a value found in an HTTP header field.

Three fundamental types are used in HTTP - integers, strings (which may be free text, 'enumeration values', URIs, etc. or date/times.

The class allows any of the three values to be held and the current value (as well as its type) to be determined.

THTTPHdrVal instances are used to assign values to header fields, their parts and their associated parameters.

See also:
RHTTPHeaders

Definition at line 35 of file thttphdrval.h.

Member Enumeration Documentation

enum THTTPHdrVal::THTTPValType

Enumeration values:
KTIntVal | the value is an integer
KStrVal | the value is a case-sensitive string
KDateVal | the value is a date/time
KStrFVal | the value is a case-insensitive string
KNoType | no value has yet been set

Definition at line 41 of file thttphdrval.h.

Constructor & Destructor Documentation

IMPORT_C THTTPHdrVal::THTTPHdrVal ( )

Default constructor Used when constructing an empty header value that is to be filled in by a call to a function.

e.g. RHTTPHeaders::GetField

IMPORT_C THTTPHdrVal::THTTPHdrVal ( TInt aIntVal )

Constructor for an integer field value.

Parameters:
aIntVal The integer value

IMPORT_C THTTPHdrVal::THTTPHdrVal ( RStringF aStrVal )

Constructor for an string value.

Parameters:
aStrVal The string value

IMPORT_C THTTPHdrVal::THTTPHdrVal ( RString aStrVal )

Constructor for an string value.

Parameters:
aStrVal The string value

IMPORT_C THTTPHdrVal::THTTPHdrVal ( TDateTime aDateVal )

Constructor for an date/time value.

Parameters:
aDateVal The date/time value

Member Function Documentation

IMPORT_C THTTPHdrVal THTTPHdrVal::Copy ( )

Obtain a copy of this header value.

This is critical when the header contains a string, since a new string reference must be created

Returns:
The copied header value

IMPORT_C TDateTime THTTPHdrVal::DateTime ( )

Obtain the (date/time) value held within.

Panics if the value is of the wrong type

Precondition:
Requires that the object was previously set to hold a TDateTime
Returns:
An date/time value

Referenced by operator TDateTime().

IMPORT_C TInt THTTPHdrVal::Int ( )

Obtain the (integer) value held within Panics if the value is of the wring type.

Precondition:
Requires that the object was previously set to hold a TInt
Returns:
An integer value

Referenced by operator TInt().

THTTPHdrVal::operator RString ( ) [inline]

Cast operator to obtain the HTTP value as a string.

Note this doesn't convert from a different form to string! Panics if the value is of the wring type

Precondition:
Requires that the object was previously set to hold a string

Definition at line 256 of file thttphdrval.h.

References Str().

THTTPHdrVal::operator RStringF ( ) [inline]

Cast operator to obtain the HTTP value as a string.

Note this doesn't convert from a different form to string! Panics if the value is of the wring type

Precondition:
Requires that the object was previously set to hold a string

Definition at line 251 of file thttphdrval.h.

References StrF().

THTTPHdrVal::operator TDateTime ( ) [inline]

Cast operator to obtain the HTTP value as an date/time.

Note this doesn't convert from a different form to date! Panics if the value is of the wring type

Precondition:
Requires that the object was previously set to hold a TDateTime

Definition at line 261 of file thttphdrval.h.

References DateTime().

THTTPHdrVal::operator TInt ( ) [inline]

Cast operator to obtain the HTTP value as an integer.

Note this doesn't convert from a different form to integer! Panics if the value is of the wrong type

Precondition:
Requires that the object was previously set to hold a TInt

Definition at line 246 of file thttphdrval.h.

References Int().

IMPORT_C TBool THTTPHdrVal::operator!= ( THTTPHdrVal aVal ) const

Comparison operator.

Does a comparison based on the current type.

Parameters:
aVal The string to compare.

IMPORT_C TBool THTTPHdrVal::operator== ( THTTPHdrVal aVal ) const

Comparison operator.

Does a comparison based on the current type.

Parameters:
aVal The header value to compare.

IMPORT_C void THTTPHdrVal::SetDateTime ( TDateTime aDateVal )

Set the header value to be the supplied date/time.

Any previous value, or its type, are lost.

Parameters:
aDateVal The date/time value

IMPORT_C void THTTPHdrVal::SetInt ( TInt aIntVal )

Set the header value to be the supplied integer.

Warning:
Any previous value, or its type, are lost.
Parameters:
aIntVal The integer value

IMPORT_C void THTTPHdrVal::SetStr ( RString aStrVal )

Set the header value to be the supplied string.

Any previous value, or its type, are lost.

Parameters:
aStrVal The string value

IMPORT_C void THTTPHdrVal::SetStrF ( RStringF aStrVal )

Set the header value to be the supplied string.

Warning:
Any previous value, or its type, are lost.
Parameters:
aStrVal The string value

IMPORT_C RString THTTPHdrVal::Str ( )

Referenced by operator RString().

IMPORT_C RStringF THTTPHdrVal::StrF ( )

Obtain the (string) value held within Panics if the value is of the wring type.

Precondition:
Requires that the object was previously set to hold a string
Returns:
A string

Referenced by operator RStringF().

IMPORT_C THTTPValType THTTPHdrVal::Type ( )

Determine the type of this header field value.

Returns:
A THTTPValType enumeration describing the value's type

Member Data Documentation

TInt THTTPHdrVal::iMoreSpace [private]

Definition at line 223 of file thttphdrval.h.

THTTPValType THTTPHdrVal::iType [private]

@private The current type

Definition at line 217 of file thttphdrval.h.

TInt THTTPHdrVal::iVal [private]

The value.

Definition at line 221 of file thttphdrval.h.

The documentation for this class was generated from the following file:
  • thttphdrval.h


Member List

THTTPHdrVal Member List

This is the complete list of members for THTTPHdrVal, including all inherited members.
Copy() const | THTTPHdrVal |
DateTime() const | THTTPHdrVal |
iMoreSpace | THTTPHdrVal | [private]
Int() const | THTTPHdrVal |
iType | THTTPHdrVal | [private]
iVal | THTTPHdrVal | [private]
KDateVal enum value | THTTPHdrVal |
KNoType enum value | THTTPHdrVal |
KStrFVal enum value | THTTPHdrVal |
KStrVal enum value | THTTPHdrVal |
KTIntVal enum value | THTTPHdrVal |
operator RString() const | THTTPHdrVal | [inline]
operator RStringF() const | THTTPHdrVal | [inline]
operator TDateTime() const | THTTPHdrVal | [inline]
operator TInt() const | THTTPHdrVal | [inline]
operator!=(THTTPHdrVal aVal) const | THTTPHdrVal |
operator==(THTTPHdrVal aVal) const | THTTPHdrVal |
SetDateTime(TDateTime aDateVal) | THTTPHdrVal |
SetInt(TInt aIntVal) | THTTPHdrVal |
SetStr(RString aStrVal) | THTTPHdrVal |
SetStrF(RStringF aStrVal) | THTTPHdrVal |
Str() const | THTTPHdrVal |
StrF() const | THTTPHdrVal |
THTTPHdrVal() | THTTPHdrVal |
THTTPHdrVal(TInt aIntVal) | THTTPHdrVal |
THTTPHdrVal(RStringF aStrVal) | THTTPHdrVal |
THTTPHdrVal(RString aStrVal) | THTTPHdrVal |
THTTPHdrVal(TDateTime aDateVal) | THTTPHdrVal |
THTTPValType enum name | THTTPHdrVal |
Type() const | THTTPHdrVal |


THTTPHdrVal::TQConv Class Reference

#include <thttphdrval.h>

List of all members.

Public Methods

TQConv (TReal aQ)
Construct from a real number representation of 'q'.

TQConv (TInt aQ)
Construct from a fixed-point representation of 'q'.

operator TInt () const
Integer cast operator to get the fixed-point representation.

operator TReal () const
TReal cast operator to get the real number representation.

Private Attributes

TReal | iQ
The real number q-value.

TInt | iFQ
The integer fixed-point q-value representation.

Constructor & Destructor Documentation

THTTPHdrVal::TQConv::TQConv ( TReal aQ ) [inline]

Construct from a real number representation of 'q'.

Definition at line 226 of file thttphdrval.h.

THTTPHdrVal::TQConv::TQConv ( TInt aQ ) [inline]

Construct from a fixed-point representation of 'q'.

Definition at line 231 of file thttphdrval.h.

Member Function Documentation

THTTPHdrVal::TQConv::operator TInt ( ) [inline]

Integer cast operator to get the fixed-point representation.

Definition at line 236 of file thttphdrval.h.

References iFQ.

THTTPHdrVal::TQConv::operator TReal ( ) [inline]

TReal cast operator to get the real number representation.

Definition at line 241 of file thttphdrval.h.

References iQ.

Member Data Documentation

TInt THTTPHdrVal::TQConv::iFQ [private]

The integer fixed-point q-value representation.

Definition at line 77 of file thttphdrval.h.

Referenced by operator TInt().

TReal THTTPHdrVal::TQConv::iQ [private]

The real number q-value.

Definition at line 74 of file thttphdrval.h.

Referenced by operator TReal().

The documentation for this class was generated from the following file:
  • thttphdrval.h


Member List

THTTPHdrVal::TQConv Member List

This is the complete list of members for THTTPHdrVal::TQConv, including all inherited members.
iFQ | THTTPHdrVal::TQConv | [private]
iQ | THTTPHdrVal::TQConv | [private]
operator TInt() const | THTTPHdrVal::TQConv | [inline]
operator TReal() const | THTTPHdrVal::TQConv | [inline]
TQConv(TReal aQ) | THTTPHdrVal::TQConv | [inline]
TQConv(TInt aQ) | THTTPHdrVal::TQConv | [inline]


CHeaderCodec Class Reference

@public
Since:
7.0 An abstract HTTP header codec.
More...

#include <cheadercodec.h>

Inheritance diagram for CHeaderCodec:

[legend]
Collaboration diagram for CHeaderCodec:

[legend]
List of all members.

Public Methods

virtual IMPORT_C | ~CHeaderCodec ()
Intended Usage: Destructor - cleans up and releases resources to the system.

IMPORT_C void | EncodeHeaderL (RHeaderField &aHeader) const
Intended Usage: Decode the supplied header field.

IMPORT_C void | DecodeHeaderL (RHeaderField &aHeader) const
virtual TBool | CanEncode (RStringF aHeaderField) const=0
Intended Usage: Concrete header codec classes must implement this method to indicate to the framework whether their concrete CHeaderWriter is capable of encoding the named header field.

virtual TBool | CanDecode (RStringF aHeaderField) const=0
Intended Usage: Concrete header codec classes must implement this method to indicate to the framework whether their concrete CHeaderReader is capable of decoding the named header field.

virtual CHeaderCodec * | FindDelegateCodecL (RStringF aHeaderField) const=0
Intended Usage: Concrete header codecs must be implement this method if they wish to delegate the encoding/decoding of particular header fields to a different codec.

Protected Methods

IMPORT_C | CHeaderCodec ()
Intended Usage: Default constructor.

IMPORT_C void | ConstructL ()
Intended Usage: Second phase construction in which any necessary allocation is done
Since:
7.0 @leaves Standard Symbian OS error codes.

Protected Attributes

CHeaderWriter * iWriter
The owned header writer object that does actual encoding of header fields.

CHeaderReader * iReader
The owned header reader object that does actual decoding of header fields.

Private Methods

virtual void | Reserved1 ()
Intended Usage: Reserve a slot in the v-table to preserve future BC
Since:
7.0.

virtual void | Reserved2 ()
Intended Usage: Reserve a slot in the v-table to preserve future BC
Since:
7.0.

Private Attributes

CHeaderCodec * | iDelegateCodec
The most recently-obtained delegate codec.

Detailed Description

@public
Since:
7.0 An abstract HTTP header codec.

Each instance of a concrete subclass of CHeaderCodec is associated with, and owned by, a specific CProtocolHandler. It provides on-demand encoding/decoding of HTTP header data, between the generic format used by clients/filters to formulate requests and interpret responses, and the raw format used by the transport handlers (and origin servers/gateways/etc.)

The CHeaderCodec has an associated instance of a sub-class of each of CHeaderReader and CHeaderWriter. It delegates the actual encoding and decoding function to these instances.

Header codecs provide a mechanism for extensibility whereby if one codec can't decode (or encode) a given header, it locates a codec that can, and then delegates the task to that codec instead.

Definition at line 43 of file cheadercodec.h.

Constructor & Destructor Documentation

CHeaderCodec::~CHeaderCodec ( ) [virtual]

Intended Usage: Destructor - cleans up and releases resources to the system.

Since:
7.0

CHeaderCodec::CHeaderCodec ( ) [protected]

Intended Usage: Default constructor.

Since:
7.0

Member Function Documentation

CHeaderCodec::CanDecode ( RStringF aHeaderField ) const [pure virtual]

Intended Usage: Concrete header codec classes must implement this method to indicate to the framework whether their concrete CHeaderReader is capable of decoding the named header field.

Since:
7.0
Parameters:
aHeader (in) A proxy for the header field to be encoded
Returns:
A flag indicating ETrue if the field can be decoded.

Implemented in CTextModeHeaderCodec, CTextModeDefaultCodec, CWspHeaderCodec, and CWspDefaultHeaderCodec.

CHeaderCodec::CanEncode ( RStringF aHeaderField ) const [pure virtual]

Intended Usage: Concrete header codec classes must implement this method to indicate to the framework whether their concrete CHeaderWriter is capable of encoding the named header field.

Since:
7.0
Parameters:
aHeader (in) A proxy for the header field to be encoded
Returns:
A flag indicating ETrue if the field can be encoded.

Implemented in CTextModeHeaderCodec, CTextModeDefaultCodec, CWspHeaderCodec, and CWspDefaultHeaderCodec.

CHeaderCodec::ConstructL ( ) [protected]

Intended Usage: Second phase construction in which any necessary allocation is done

Since:
7.0 @leaves Standard Symbian OS error codes.

e.g. KErrNoMemory.

Reimplemented in CTextModeHeaderCodec, CTextModeDefaultCodec, CWspHeaderCodec, and CWspDefaultHeaderCodec.

IMPORT_C void CHeaderCodec::DecodeHeaderL ( RHeaderField & aHeader ) const

CHeaderCodec::EncodeHeaderL ( RHeaderField & aHeader ) const

Intended Usage: Decode the supplied header field.

This method uses the associated concrete CHeaderWriter object to do a conversion of the field into raw form from the generic internal representation.

Since:
7.0
Parameters:
aHeader (in) A proxy for the header field to be encoded @leaves Standard Symbian OS error codes. e.g. KErrNoMemory; additional error codes that occur during the encode are defined in <httperr.h>

CHeaderCodec::FindDelegateCodecL ( RStringF aHeaderField ) const [pure virtual]

Intended Usage: Concrete header codecs must be implement this method if they wish to delegate the encoding/decoding of particular header fields to a different codec.

This would be done if the codec doesn't have the ability itself to do the encode/decode but can locate an alternative that does.

The caller takes ownership of the returned codec.

Since:
7.0
Parameters:
aHeader (in) A proxy for the header field to be encoded
Returns:
A pointer to the new CHeaderCodec, or NULL if one couldn't be found. @leaves Standard Symbian OS error codes. e.g. KErrNoMemory.

Implemented in CTextModeHeaderCodec, CTextModeDefaultCodec, CWspHeaderCodec, and CWspDefaultHeaderCodec.

void CHeaderCodec::Reserved1 ( ) [inline, private, virtual]

Intended Usage: Reserve a slot in the v-table to preserve future BC

Since:
7.0.

Definition at line 322 of file cheadercodec.h.

void CHeaderCodec::Reserved2 ( ) [inline, private, virtual]

Intended Usage: Reserve a slot in the v-table to preserve future BC

Since:
7.0.

Definition at line 324 of file cheadercodec.h.

Member Data Documentation

CHeaderCodec* CHeaderCodec::iDelegateCodec [private]

The most recently-obtained delegate codec.

Definition at line 173 of file cheadercodec.h.

CHeaderReader* CHeaderCodec::iReader [protected]

The owned header reader object that does actual decoding of header fields.

Definition at line 150 of file cheadercodec.h.

CHeaderWriter* CHeaderCodec::iWriter [protected]

The owned header writer object that does actual encoding of header fields.

Definition at line 145 of file cheadercodec.h.

The documentation for this class was generated from the following file:
  • cheadercodec.h


Member List

CHeaderCodec Member List

This is the complete list of members for CHeaderCodec, including all inherited members.
CanDecode(RStringF aHeaderField) const=0 | CHeaderCodec | [pure virtual]
CanEncode(RStringF aHeaderField) const=0 | CHeaderCodec | [pure virtual]
CHeaderCodec() | CHeaderCodec | [protected]
ConstructL() | CHeaderCodec | [protected]
DecodeHeaderL(RHeaderField &aHeader) const | CHeaderCodec |
EncodeHeaderL(RHeaderField &aHeader) const | CHeaderCodec |
FindDelegateCodecL(RStringF aHeaderField) const=0 | CHeaderCodec | [pure virtual]
iDelegateCodec | CHeaderCodec | [private]
iReader | CHeaderCodec | [protected]
iWriter | CHeaderCodec | [protected]
Reserved1() | CHeaderCodec | [inline, private, virtual]
Reserved2() | CHeaderCodec | [inline, private, virtual]
~CHeaderCodec() | CHeaderCodec | [virtual]


CHeaderCodePage Class Reference

The CHeaderCodePage class represents the Header Code Page capability as defined by the WSP Specification, July 2001. More...

#include <CHeaderCodePage.h>

List of all members.

Public Methods

~CHeaderCodePage ()
Standard destructor
Since:
7.0.

TUint8 | GetPageCode () const
Returns the page code assigned to the header code page.

const TDesC8 & | GetPageName () const
Returns the header code page name.

Static Public Methods

CHeaderCodePage * | NewL (TUint8 aPageCode, const TDesC8 &aPageName)
Static factory constructor.

Private Methods

CHeaderCodePage (TUint8 aPageCode)
First phase constructor
Since:
7.0.

void | ConstructL (const TDesC8 &aPageName)
Second phase constructor.

Private Attributes

TUint8 | iCode
The page code assigned to the header code page specified by iName.

HBufC8 * | iName
A buffer containing the header code page name.

Detailed Description

The CHeaderCodePage class represents the Header Code Page capability as defined by the WSP Specification, July 2001.

Definition at line 15 of file CHeaderCodePage.h.

Constructor & Destructor Documentation

CHeaderCodePage::~CHeaderCodePage ( )

Standard destructor

Since:
7.0.

CHeaderCodePage::CHeaderCodePage ( TUint8 aPageCode ) [private]

First phase constructor

Since:
7.0.

Parameters:
aPageCode The page code assigned to the header code page.

Member Function Documentation

CHeaderCodePage::ConstructL ( const TDesC8 & aPageName ) [private]

Second phase constructor.

Does any necessary allocations

Since:
7.0
a aPageName A reference to a buffer containing the header
code page name.

CHeaderCodePage::GetPageCode ( ) const [inline]

Returns the page code assigned to the header code page.

Since:
7.0
Returns:
The page code assigned to the header code page.

CHeaderCodePage::GetPageName ( ) const [inline]

Returns the header code page name.

Since:
7.0
Returns:
A const reference to a buffer containing the header code page name.

CHeaderCodePage::NewL | ( | TUint8 | aPageCode,
 |  | const TDesC8 & | aPageName
 | ) | [static]

Static factory constructor.

Since:
7.0
Parameters:
aPageCode The page code assigned to the header code page.
a aPageName A reference to a buffer containing the header
code page name.

Member Data Documentation

TUint8 CHeaderCodePage::iCode [private]

The page code assigned to the header code page specified by iName.

Definition at line 76 of file CHeaderCodePage.h.

HBufC8* CHeaderCodePage::iName [private]

A buffer containing the header code page name.

Definition at line 81 of file CHeaderCodePage.h.

The documentation for this class was generated from the following file:
  • CHeaderCodePage.h


Member List

CHeaderCodePage Member List

This is the complete list of members for CHeaderCodePage, including all inherited members.
CHeaderCodePage(TUint8 aPageCode) | CHeaderCodePage | [private]
ConstructL(const TDesC8 &aPageName) | CHeaderCodePage | [private]
GetPageCode() const | CHeaderCodePage | [inline]
GetPageName() const | CHeaderCodePage | [inline]
iCode | CHeaderCodePage | [private]
iName | CHeaderCodePage | [private]
NewL(TUint8 aPageCode, const TDesC8 &aPageName) | CHeaderCodePage | [static]
~CHeaderCodePage() | CHeaderCodePage |


CHeaderField Class Reference

Generalised internal representation of a single HTTP header field. More...

#include <CHeaderField.h>

Collaboration diagram for CHeaderField:

[legend]
List of all members.

Public Methods

RStringF | Name () const
Obtain the name of the header field, e.g.

THeaderFieldPartIter PartsL ()
Access the header value parts via an iterator.

IMPORT_C void | RawDataL (TPtrC8 &aRawData)
Get the Raw header representation.

void | SetPartL (CHeaderFieldPart *aPart, TInt aIndex)
Set a part in the header.

void | BeginRawDataL (TInt aChunkSize=KHttpDefaultRawChunkSize)
Start setting Raw data in the header.

void | WriteRawDataL (const TDesC8 &aData)
Add more Raw data, supplied as a descriptor.

void | WriteRawDataL (TChar aData)
Add more Raw data, supplied as a single character.

void | CommitRawData ()
Commit the Raw data.

TInt | NumPartsL ()
Obtain the number of parts in this header.

virtual | ~CHeaderField ()
Class destructor.

CHeaderFieldPart * | PartL (TInt aIndex)
Access the header value parts by index.

void | AddPartL (CHeaderFieldPart *aPart)
Add a part to the header.

void | InsertPartL (CHeaderFieldPart *aPart, TInt aIndex)
Insert a part into the header.

TInt | RemovePartL (CHeaderFieldPart *aPart)
Remove the specified part from the header.

TInt | RemovePartL (TInt aIndex)
Remove the indexed part from the header.

Static Public Methods

CHeaderField * | NewL (RStringF aHeaderFieldName, CHeaders &aOwner)
Create a new header field that has no value yet.

CHeaderField * | NewL (RStringF aHeaderFieldName, CHeaders &aOwner, THTTPHdrVal aVal)
Create a new header field with a single part, whose HTTP value is specified.

CHeaderField * | NewL (RStringF aHeaderFieldName, CHeaders &aOwner, const TDesC8 &aRawData)
Create a new header field from the supplied Raw data using the specified transaction codec.

Private Types

enum | TDataState { ENoDataSupplied = 0x00, EDataInRawForm = 0x01, EDataParsedOK = 0x02, EDataParseError = 0x03 }
Enumeration of the states in which this header's value data can exist. More...

Private Methods

void | ConvertToRawFormatL ()
Create an Raw encoding of the header's field name and value.

void | ConvertToParsedFormatL ()
Create the part objects that represent the header field's value, by parsing the Raw data received by HTTP.

CHeaderField (RStringF aHeaderFieldName, CHeaders &aOwner)
Standard constructor.

void | ConstructL (const TDesC8 &aRawData)
Phase Two construction.

void | ClearParsedData ()
Empty and destroy contents of the 'parts' array.

void | ClearRawData ()
Empty and destroy any Raw data held.

Private Attributes

RStringF | iName
Name of this header (a reference into the string table).

TDataState iDataParseState
Has this header been parsed yet? did it parse correctly?

CHeaders * iOwner
Headers collection that owns this field.

HBufC8 * | iRawData
Header data - in Raw format.

RPointerArray< CHeaderFieldPart > | iParts
Header data - in parsed format.

const CHeaderCodec & | iCodec
Codec used to convert this header.

TInt | iRawChunkSize
Size of data chunk used when allocating and extending the Raw data buffer.

Friends

class | THeaderFieldPartIter
class | RHeaderField

Detailed Description

Generalised internal representation of a single HTTP header field.

The field's value may be contained as raw data as received by HTTP, or in a object-oriented parsed form, which is accessible to the client via the class API.

Each field has a type and a (potentially complex) value. The type must be chosen at construction time, and remains the same during the header's lifetime.

Simple headers are represented using a single 'part'. Several factory methods are provided for each type the part can take; e.g.

    Max-Forwards: 3                         -- a single integer value
    Location: http://ayg.com/               -- a single string token value
    Expires: Mon, 15 Jan 2001 10:30:25 GMT  -- a single date/time value

More complex headers are possible (see the RFC2116 for many more examples) which are built up from several parts; e.g.

    Accept: text/wml, application/vnd.wap.wmlc  -- a header with two string token parts
    Allow: GET, POST, HEAD                      -- a header with three string token parts

Multiple parts are supported by the CHeaderFieldPart class.

Furthermore, some headers allow parameters to be supplied in the form of attribute-value pairs. These may be present on any part of the header, according to the syntax defined in the RFC; e.g.

    Accept-Charset: utf-8; q=0.8, us-ascii; q=0.2
    Cache-Control: maxage=6000

Parameters are supported by the CHeaderFieldParam class.

The classes CHeaderField, CHeaderFieldPart and CHeaderFieldParam are internal header representations and will only be manipulated by protocol handlers and filters. Only the RHTTPHeaders and THTTPHdrVal classes are intended for use by the Client.

See also:
RHTTPHeaders , THTTPHdrVal , CHeaderFieldPart , CHeaderFieldParam

Definition at line 83 of file CHeaderField.h.

Member Enumeration Documentation

enum CHeaderField::TDataState [private]

Enumeration of the states in which this header's value data can exist.

Enumeration values:
ENoDataSupplied | the header object is not populated with data after construction
EDataInRawForm the data is in it's raw form, i.e

not accessible by part

EDataParsedOK the data is in it's client representation, i.e

parsed into parts.

EDataParseError | the data could not be parsed so remains in Raw form

Definition at line 297 of file CHeaderField.h.

Constructor & Destructor Documentation

virtual CHeaderField::~CHeaderField ( ) [virtual]

Class destructor.

CHeaderField::CHeaderField | ( | RStringF | aHeaderFieldName,
 |  | CHeaders & | aOwner
 | ) | [private]

Standard constructor.

Used when client constructs headers.

Parameters:
aHeaderFieldName | A string table reference to the header field's name.
aOwner | The header fields collection that this field belongs to
Returns:
The constructed instance of CHeaderField

Member Function Documentation

void CHeaderField::AddPartL ( CHeaderFieldPart * aPart )

Add a part to the header.

It is appended after any existing parts. Simple headers have just one part; they could be constructed using the 'single part' NewL() methods.

Parameters:
aPart The part to be added. The header takes ownership of the new part. @leave KErrNoMemory - insufficient free memory to create an instance of the class, or any classes needed to create subclasses for parsing @leave KErrNotSupported - if decoding for this header field can't be made

void CHeaderField::BeginRawDataL ( TInt aChunkSize = KHttpDefaultRawChunkSize )

Start setting Raw data in the header.

Leaves if initial Raw buffer allocation fails. The optional parameter specifies the size to be used for Raw data chunk allocation. Note this is for use only by the header codec. @leave KErrNoMemory - insufficient free memory buffer allocation

void CHeaderField::ClearParsedData ( ) [private]

Empty and destroy contents of the 'parts' array.

void CHeaderField::ClearRawData ( ) [private]

Empty and destroy any Raw data held.

void CHeaderField::CommitRawData ( )

Commit the Raw data.

The parsed header parts and parameters are removed. Note this is for use only by the header codec.

void CHeaderField::ConstructL ( const TDesC8 & aRawData ) [private]

Phase Two construction.

This variant copies-to-keep the supplied Raw data buffer.

Parameters:
aRawData An 8-bit buffer containing raw header data received by HTTP.

void CHeaderField::ConvertToParsedFormatL ( ) [private]

Create the part objects that represent the header field's value, by parsing the Raw data received by HTTP.

The Raw data is removed after conversion completes successfully. @leave An error code obtained from the Codec when it attempts to convert the data.

void CHeaderField::ConvertToRawFormatL ( ) [private]

Create an Raw encoding of the header's field name and value.

This is done using the Codec, which must be supplied prior to this call. The part data is removed after conversion to the Raw format. @leave An error code obtained from the Codec when it attempts to convert the data.

void CHeaderField::InsertPartL | ( | CHeaderFieldPart * | aPart,
 |  | TInt | aIndex
 | ) |

Insert a part into the header.

It is inserted at the specified index - i.e. to insert a new part at the start of the header, aIndex should be set to 0.

Parameters:
aPart | The part to be inserted. The header takes ownership of the new part.
aIndex | The index at which the part is to be inserted. @leave KErrNoMemory - insufficient free memory to create an instance of the class, or any classes needed to create subclasses for parsing @leave KErrNotSupported - if decoding for this header field can't be made

RStringF CHeaderField::Name ( )

Obtain the name of the header field, e.g.

Accept

Returns:
The header field name as a string token

CHeaderField* CHeaderField::NewL | ( | RStringF | aHeaderFieldName,
 |  | CHeaders & | aOwner,
 |  | const TDesC8 & | aRawData
 | ) | [static]

Create a new header field from the supplied Raw data using the specified transaction codec.

Parameters:
aHeaderFieldName | The header field type.
aOwner | The header fields collection that this field belongs to
aRawData | The raw data buffer, as a descriptor @leave KErrNoMemory - insufficient free memory to create an instance of the class, or any classes needed to create subclasses for parsing @leave KErrNotSupported - if decoding for this header field can't be made

CHeaderField* CHeaderField::NewL | ( | RStringF | aHeaderFieldName,
 |  | CHeaders & | aOwner,
 |  | THTTPHdrVal | aVal
 | ) | [static]

Create a new header field with a single part, whose HTTP value is specified.

Parameters:
aHeaderFieldName | The header field type.
aOwner | The header fields collection that this field belongs to
aVal | The header field value. A copy is taken when storing. @leave KErrNoMemory - insufficient free memory to create an instance of the class, or any classes needed to create subclasses for parsing @leave KErrNotSupported - if decoding for this header field can't be made

CHeaderField* CHeaderField::NewL | ( | RStringF | aHeaderFieldName,
 |  | CHeaders & | aOwner
 | ) | [static]

Create a new header field that has no value yet.

Parameters:
aHeaderFieldName | The header field type.
aOwner | The header fields collection that this field belongs to @leave KErrNoMemory - insufficient free memory to create an instance of the class.

TInt CHeaderField::NumPartsL ( )

Obtain the number of parts in this header.

Returns:
The number, as an integer @leave KErrNoMemory - insufficient free memory for object creation when decoding parts @leave KErrNotSupported - if decoding when counting parts fails

CHeaderFieldPart* CHeaderField::PartL ( TInt aIndex )

Access the header value parts by index.

Parameters:
aIndex The index of the desired part. 0 references the first one.
Returns:
The indexed part, or NULL if the index was invalid. @leave KErrNoMemory - insufficient free memory for object creation when decoding parts @leave KErrNotSupported - if decoding when counting parts fails

THeaderFieldPartIter CHeaderField::PartsL ( )

Access the header value parts via an iterator.

Returns:
An iterator constructed to point at the first part @leave KErrNoMemory - insufficient free memory for object creation when decoding parts @leave KErrNotSupported - if decoding when counting parts fails

IMPORT_C void CHeaderField::RawDataL ( TPtrC8 & aRawData )

Get the Raw header representation.

This will flip the internal state of the header, if it's not already in Raw form. Requires a Codec to be set.

Parameters:
The 8-bit data buffer representing the header in Raw form @leave KErrNoMemory - insufficient free memory for object creation when decoding parts @leave KErrNotSupported - if decoding when counting parts fails

TInt CHeaderField::RemovePartL ( TInt aIndex )

Remove the indexed part from the header.

Parameters:
aIndex An index to the part to be removed. The header deletes the removed part.
Returns:
An error code; KErrNone if the removal succeeds or KErrNotFound if it didn't. @leave KErrNoMemory - insufficient free memory to create an instance of the class, or any classes needed to create subclasses for parsing @leave KErrNotSupported - if decoding for this header field can't be made

TInt CHeaderField::RemovePartL ( CHeaderFieldPart * aPart )

Remove the specified part from the header.

Parameters:
aPart The part to be removed. The header deletes the removed part.
Returns:
An error code; KErrNone if the removal succeeds or KErrNotFound if it didn't. @leave KErrNoMemory - insufficient free memory to create an instance of the class, or any classes needed to create subclasses for parsing @leave KErrNotSupported - if decoding for this header field can't be made

void CHeaderField::SetPartL | ( | CHeaderFieldPart * | aPart,
 |  | TInt | aIndex
 | ) |

Set a part in the header.

It replaces any existing parts at the specified index. Note this is for use only by the header codec, when converting Raw data into parsed header parts from parsed Raw data.

Parameters:
aPart | The part to be added. The header takes ownership of the new part.
aIndex | The index of the part you are replacing @leave If fails to append this part to internal list.

void CHeaderField::WriteRawDataL ( TChar aData )

Add more Raw data, supplied as a single character.

The buffer is extended as necessary. Leaves if buffer allocation fails. Note this is for use only by the header codec. @leave KErrNoMemory - insufficient free memory buffer allocation

void CHeaderField::WriteRawDataL ( const TDesC8 & aData )

Add more Raw data, supplied as a descriptor.

The buffer is extended as necessary. Leaves if buffer allocation fails. Note this is for use only by the header codec. @leave KErrNoMemory - insufficient free memory buffer allocation

Friends And Related Function Documentation

friend class RHeaderField [friend]

Definition at line 86 of file CHeaderField.h.

friend class THeaderFieldPartIter [friend]

Definition at line 85 of file CHeaderField.h.

Member Data Documentation

const CHeaderCodec& CHeaderField::iCodec [private]

Codec used to convert this header.

Definition at line 337 of file CHeaderField.h.

TDataState CHeaderField::iDataParseState [private]

Has this header been parsed yet? did it parse correctly?

Definition at line 315 of file CHeaderField.h.

RStringF CHeaderField::iName [private]

Name of this header (a reference into the string table).

Definition at line 310 of file CHeaderField.h.

CHeaders* CHeaderField::iOwner [private]

Headers collection that owns this field.

Definition at line 320 of file CHeaderField.h.

RPointerArray<CHeaderFieldPart> CHeaderField::iParts [private]

Header data - in parsed format.

Todo:
Is it worth this being a union?

Definition at line 332 of file CHeaderField.h.

TInt CHeaderField::iRawChunkSize [private]

Size of data chunk used when allocating and extending the Raw data buffer.

Definition at line 342 of file CHeaderField.h.

HBufC8* CHeaderField::iRawData [private]

Header data - in Raw format.

Todo:
Is it worth this being a union?

Definition at line 326 of file CHeaderField.h.

The documentation for this class was generated from the following file:
  • CHeaderField.h


Member List

CHeaderField Member List

This is the complete list of members for CHeaderField, including all inherited members.
AddPartL(CHeaderFieldPart *aPart) | CHeaderField |
BeginRawDataL(TInt aChunkSize=KHttpDefaultRawChunkSize) | CHeaderField |
CHeaderField(RStringF aHeaderFieldName, CHeaders &aOwner) | CHeaderField | [private]
ClearParsedData() | CHeaderField | [private]
ClearRawData() | CHeaderField | [private]
CommitRawData() | CHeaderField |
ConstructL(const TDesC8 &aRawData) | CHeaderField | [private]
ConvertToParsedFormatL() | CHeaderField | [private]
ConvertToRawFormatL() | CHeaderField | [private]
EDataInRawForm enum value | CHeaderField | [private]
EDataParsedOK enum value | CHeaderField | [private]
EDataParseError enum value | CHeaderField | [private]
ENoDataSupplied enum value | CHeaderField | [private]
iCodec | CHeaderField | [private]
iDataParseState | CHeaderField | [private]
iName | CHeaderField | [private]
InsertPartL(CHeaderFieldPart *aPart, TInt aIndex) | CHeaderField |
iOwner | CHeaderField | [private]
iParts | CHeaderField | [private]
iRawChunkSize | CHeaderField | [private]
iRawData | CHeaderField | [private]
Name() const | CHeaderField |
NewL(RStringF aHeaderFieldName, CHeaders &aOwner) | CHeaderField | [static]
NewL(RStringF aHeaderFieldName, CHeaders &aOwner, THTTPHdrVal aVal) | CHeaderField | [static]
NewL(RStringF aHeaderFieldName, CHeaders &aOwner, const TDesC8 &aRawData) | CHeaderField | [static]
NumPartsL() | CHeaderField |
PartL(TInt aIndex) | CHeaderField |
PartsL() | CHeaderField |
RawDataL(TPtrC8 &aRawData) | CHeaderField |
RemovePartL(CHeaderFieldPart *aPart) | CHeaderField |
RemovePartL(TInt aIndex) | CHeaderField |
RHeaderField class | CHeaderField | [friend]
SetPartL(CHeaderFieldPart *aPart, TInt aIndex) | CHeaderField |
TDataState enum name | CHeaderField | [private]
THeaderFieldPartIter class | CHeaderField | [friend]
WriteRawDataL(const TDesC8 &aData) | CHeaderField |
WriteRawDataL(TChar aData) | CHeaderField |
~CHeaderField() | CHeaderField | [virtual]


RHeaderField Class Reference

@public
Since:
7.0 An proxy object for a single field in an HTTP header.
More...

#include <RHeaderField.h>

Collaboration diagram for RHeaderField:

[legend]
List of all members.

Public Methods

RHeaderField (CHeaderField &aHeaderField)
Intended Usage: Normal constructor.

IMPORT_C RStringF | Name () const
IMPORT_C THeaderFieldPartIter | PartsL ()
Intended Usage: Access the header value parts via an iterator
Since:
7.0.

IMPORT_C void | RawDataL (TPtrC8 &aRawData)
Intended Usage: Get the header field's raw data representation.

IMPORT_C RHTTPHeaders | Collection ()
Intended Usage: Set a part in the header.

IMPORT_C void | SetPartL (CHeaderFieldPart *aPart, TInt aIndex)
IMPORT_C void | BeginRawDataL (TInt aChunkSize=KDefaultRawChunkSize)
Intended Usage: When the header codec starts converting parsed header data into the raw form, it must first call this method to indicate that the raw data is being generated.

IMPORT_C void | WriteRawDataL (const TDesC8 &aData)
Intended Usage: Add more Raw data, supplied as a single character.

IMPORT_C void | WriteRawDataL (TChar aData)
IMPORT_C void | CommitRawData ()
Intended Usage: Commits the Raw data.

Private Attributes

CHeaderField & iHeaderField
The internal representation of this header field.

Detailed Description

@public
Since:
7.0 An proxy object for a single field in an HTTP header.

The class is used by implementations of CHeaderCodec in order to manipulate the header at the part and parameter level, or to obtain raw data, during a header encode/decode operation.

Definition at line 38 of file RHeaderField.h.

Constructor & Destructor Documentation

RHeaderField::RHeaderField ( CHeaderField & aHeaderField ) [inline]

Intended Usage: Normal constructor.

Creates a header field proxy based on the internal representation.

Since:
7.0
Parameters:
aHeaderField (in) The internal representation of a header field

Definition at line 179 of file RHeaderField.h.

Member Function Documentation

RHeaderField::BeginRawDataL ( TInt aChunkSize = KDefaultRawChunkSize )

Intended Usage: When the header codec starts converting parsed header data into the raw form, it must first call this method to indicate that the raw data is being generated.

Memory allocations are done in chunks set at the specified size. Note this method is for use only by the header codec.

Since:
7.0
Parameters:
aChunkSize (in) (optional) The size to be used for raw data chunk allocation.
Precondition:
The header field is in the 'parsed' state
Postcondition:
The header field is still in the 'parsed' state @leaves Standard Symbian OS error codes. e.g. KErrNoMemory.

RHeaderField::Collection ( )

Intended Usage: Set a part in the header.

Returns:
The header collection handle.

RHeaderField::CommitRawData ( )

Intended Usage: Commits the Raw data.

The parsed header parts and parameters are removed, leaving the field in a the raw data form. Note this method is for use only by the header codec.

Since:
7.0
Precondition:
The header field is in the 'parsed' state
Postcondition:
The header field is in the 'raw' state

IMPORT_C RStringF RHeaderField::Name ( )

RHeaderField::PartsL ( )

Intended Usage: Access the header value parts via an iterator

Since:
7.0.

Returns:
An iterator constructed to point at the first part @leave KErrNoMemory - insufficient free memory for object creation when decoding parts @leave KErrNotSupported - if decoding when counting parts fails

RHeaderField::RawDataL ( TPtrC8 & aRawData )

Intended Usage: Get the header field's raw data representation.

This will flip the internal state of the header, if it's not already in Raw form. Requires a Codec to be set.

Since:
7.0
Parameters:
aRawData (inout) An 8-bit pointer descriptor that is set during the call to point at the data buffer representing the header in its raw form.
Postcondition:
The header field is in either its 'raw' state (following a successful conversion) or in a 'corrupt' state if decoding failed. @leave KErrNoMemory - insufficient free memory for object creation when decoding parts @leave KErrNotSupported - if decoding when counting parts fails @leave Various error codes from <httperr.h> indicating a decode failure

IMPORT_C void RHeaderField::SetPartL | ( | CHeaderFieldPart * | aPart,
 |  | TInt | aIndex
 | ) |

IMPORT_C void RHeaderField::WriteRawDataL ( TChar aData )

RHeaderField::WriteRawDataL ( const TDesC8 & aData )

Intended Usage: Add more Raw data, supplied as a single character.

The data is appended to the existing contents of the field's internal raw data buffer, which is extended as necessary. Note this method is for use only by the header codec.

Since:
7.0
Parameters:
aData (in) The data to append to the buffer.
Precondition:
The header field is in the 'parsed' state
Postcondition:
The header field is still in the 'parsed' state @leaves Standard Symbian OS error codes. e.g. KErrNoMemory.

Member Data Documentation

CHeaderField& RHeaderField::iHeaderField [private]

The internal representation of this header field.

Definition at line 176 of file RHeaderField.h.

The documentation for this class was generated from the following file:
  • RHeaderField.h


Member List

RHeaderField Member List

This is the complete list of members for RHeaderField, including all inherited members.
BeginRawDataL(TInt aChunkSize=KDefaultRawChunkSize) | RHeaderField |
Collection() | RHeaderField |
CommitRawData() | RHeaderField |
iHeaderField | RHeaderField | [private]
Name() const | RHeaderField |
PartsL() | RHeaderField |
RawDataL(TPtrC8 &aRawData) | RHeaderField |
RHeaderField(CHeaderField &aHeaderField) | RHeaderField | [inline]
SetPartL(CHeaderFieldPart *aPart, TInt aIndex) | RHeaderField |
WriteRawDataL(const TDesC8 &aData) | RHeaderField |
WriteRawDataL(TChar aData) | RHeaderField |


CHeaderFieldParam Class Reference

Generalised representation of a single HTTP header parameter. More...

#include <CHeaderField.h>

Collaboration diagram for CHeaderFieldParam:

[legend]
List of all members.

Public Methods

virtual | ~CHeaderFieldParam ()
Class destructor.

IMPORT_C RStringF | Name () const
Obtain the name of the parameter, e.g.

IMPORT_C THTTPHdrVal | Value () const
Obtain the value of the parameter.

void | SetValue (THTTPHdrVal aVal)
Change the value held in this field parameter.

Static Public Methods

IMPORT_C CHeaderFieldParam * | NewL (RStringF aParamName, THTTPHdrVal aVal)
Create a new header parameter that has a descriptor value.

Private Methods

CHeaderFieldParam (RStringF aName, THTTPHdrVal aVal)
Default constructor.

Private Attributes

RStringF | iName
A string table reference for the name of this parameter.

THTTPHdrVal iValue
The value of this part of the header field.

Detailed Description

Generalised representation of a single HTTP header parameter.

The parameter has a name and takes a value using one of the three types supported in CHeaderFieldPart.

Special case:

  • an unnamed parameter with an assigned value
Examples of the use for this special case are:

    Cache-Control: max-stale [=delta-seconds]
    Expect: expectation1=value1; expectation2=value2
    Content-Range: bytes 0-1023/4096

Cache-Control's max-stale directive can take an optional value; hence the client should create a one-part header where the part is an enumeration value 'max-stale', and assign to that part an un-named parameter for the delta-seconds value if it is desired.

Expect's sets of expectation expressions should each be added by the client as a separate part, each of which is given an unnamed parameter that takes the expectation value.

Content-Range should have one part added containing the enumeration 'bytes'. Three parameters should be defined for that part: 'first', 'last' and 'total' which take the values in the byte-range. This is, of course, application-specific and similar guidelines might be adopted by the parser to represent other headers.

Definition at line 500 of file CHeaderField.h.

Constructor & Destructor Documentation

virtual CHeaderFieldParam::~CHeaderFieldParam ( ) [virtual]

Class destructor.

CHeaderFieldParam::CHeaderFieldParam | ( | RStringF | aName,
 |  | THTTPHdrVal | aVal
 | ) | [private]

Default constructor.

Member Function Documentation

IMPORT_C RStringF CHeaderFieldParam::Name ( )

Obtain the name of the parameter, e.g.

q

Returns:
String table reference to the name

IMPORT_C CHeaderFieldParam* CHeaderFieldParam::NewL | ( | RStringF | aParamName,
 |  | THTTPHdrVal | aVal
 | ) | [static]

Create a new header parameter that has a descriptor value.

Parameters:
aParamName | The name of the parameter, as a string table reference. Can be an empty string.
aVal | The HTTP value of the parameter. A copy is taken when storing.
Returns:
The constructed instance of CHeaderFieldParam

void CHeaderFieldParam::SetValue ( THTTPHdrVal aVal )

Change the value held in this field parameter.

Parameters:
The HTTP value

IMPORT_C THTTPHdrVal CHeaderFieldParam::Value ( )

Obtain the value of the parameter.

The caller must call Copy() on the returned THTTPHdrVal if it is going to be stored. This is needed in order to correctly maintain string references.

Returns:
The parameter's HTTP value

Member Data Documentation

RStringF CHeaderFieldParam::iName [private]

A string table reference for the name of this parameter.

Definition at line 558 of file CHeaderField.h.

THTTPHdrVal CHeaderFieldParam::iValue [private]

The value of this part of the header field.

Definition at line 562 of file CHeaderField.h.

The documentation for this class was generated from the following file:
  • CHeaderField.h


Member List

CHeaderFieldParam Member List

This is the complete list of members for CHeaderFieldParam, including all inherited members.
CHeaderFieldParam(RStringF aName, THTTPHdrVal aVal) | CHeaderFieldParam | [private]
iName | CHeaderFieldParam | [private]
iValue | CHeaderFieldParam | [private]
Name() const | CHeaderFieldParam |
NewL(RStringF aParamName, THTTPHdrVal aVal) | CHeaderFieldParam | [static]
SetValue(THTTPHdrVal aVal) | CHeaderFieldParam |
Value() const | CHeaderFieldParam |
~CHeaderFieldParam() | CHeaderFieldParam | [virtual]


THeaderFieldParamIter Class Reference

Iterator class to iterate the parameters contained within a header part. More...

#include <CHeaderField.h>

Collaboration diagram for THeaderFieldParamIter:

[legend]
List of all members.

Public Methods

THeaderFieldParamIter (const CHeaderFieldPart *aHeaderPart)
Construct an iterator for the parameterss of the supplied header part.

IMPORT_C | ~THeaderFieldParamIter ()
Class destructor.

IMPORT_C void | First ()
Reset iterator to point at the first part of the header.

IMPORT_C TBool | AtEnd ()
Check if the iterator is at the end of the list.

IMPORT_C void | operator++ ()
Advance the iterator.

IMPORT_C const CHeaderFieldParam * | operator() ()
Obtain the header parameter currently pointed at by the iterator.

Private Methods

void | CheckInvalidation ()
Check the iterator state for invalidity following deletions in the list.

Private Attributes

const CHeaderFieldPart * | iHeaderPart
The header part whose parameters we are iterating.

TInt | iPosIdx
The index of the parameter in the header part that is currently pointed at by the iterator.

Detailed Description

Iterator class to iterate the parameters contained within a header part.

Requires friendship with CHeaderFieldPart and as such is tightly bound to that class.

Definition at line 627 of file CHeaderField.h.

Constructor & Destructor Documentation

THeaderFieldParamIter::THeaderFieldParamIter ( const CHeaderFieldPart * aHeaderPart )

Construct an iterator for the parameterss of the supplied header part.

Parameters:
aHeaderPart The header part whose parameters we want to iterate

IMPORT_C THeaderFieldParamIter::~THeaderFieldParamIter ( )

Class destructor.

Member Function Documentation

IMPORT_C TBool THeaderFieldParamIter::AtEnd ( )

Check if the iterator is at the end of the list.

If so, further calls to operator() will return NULL.

void THeaderFieldParamIter::CheckInvalidation ( ) [private]

Check the iterator state for invalidity following deletions in the list.

IMPORT_C void THeaderFieldParamIter::First ( )

Reset iterator to point at the first part of the header.

IMPORT_C const CHeaderFieldParam* THeaderFieldParamIter::operator() ( )

Obtain the header parameter currently pointed at by the iterator.

Returns:
The header parameter; NULL if the iterator has gone off the end of the list

IMPORT_C void THeaderFieldParamIter::operator++ ( )

Advance the iterator.

Returns:
True if the iterator still points at a valid parameter after advancing.

Member Data Documentation

const CHeaderFieldPart* THeaderFieldParamIter::iHeaderPart [private]

The header part whose parameters we are iterating.

Definition at line 676 of file CHeaderField.h.

TInt THeaderFieldParamIter::iPosIdx [private]

The index of the parameter in the header part that is currently pointed at by the iterator.

Definition at line 680 of file CHeaderField.h.

The documentation for this class was generated from the following file:
  • CHeaderField.h


Member List

THeaderFieldParamIter Member List

This is the complete list of members for THeaderFieldParamIter, including all inherited members.
AtEnd() | THeaderFieldParamIter |
CheckInvalidation() | THeaderFieldParamIter | [private]
First() | THeaderFieldParamIter |
iHeaderPart | THeaderFieldParamIter | [private]
iPosIdx | THeaderFieldParamIter | [private]
operator()() | THeaderFieldParamIter |
operator++() | THeaderFieldParamIter |
THeaderFieldParamIter(const CHeaderFieldPart *aHeaderPart) | THeaderFieldParamIter |
~THeaderFieldParamIter() | THeaderFieldParamIter |


CHeaderFieldPart Class Reference

Generalised representation of a single HTTP header value part. More...

#include <CHeaderField.h>

Collaboration diagram for CHeaderFieldPart:

[legend]
List of all members.

Public Methods

virtual | ~CHeaderFieldPart ()
Class destructor.

void | SetPropertySet (RHTTPPropertySet &aPropertySet)
IMPORT_C THTTPHdrVal | Value () const
Obtain the value held in this field part.

IMPORT_C TInt | NumParameters () const
Obtain the number of parameters in this header.

IMPORT_C THeaderFieldParamIter | Parameters () const
Access the parameters in this header part via an iterator.

CHeaderFieldParam * | Parameter (TInt aIndex) const
Access the header parameters by index.

CHeaderFieldParam * | Parameter (RStringF aParamName) const
Access the header parameters by parameter name.

void | SetValue (THTTPHdrVal aVal)
Change the value held in this field part.

IMPORT_C void | AddParamL (CHeaderFieldParam *aParam)
Add a parameter to the header part.

TInt | RemoveParam (CHeaderFieldParam *aParam)
Remove the specified parameter from the header part.

Static Public Methods

IMPORT_C CHeaderFieldPart * | NewL (THTTPHdrVal aVal)
Create a new part, for the supplied HTTP value.

void | ClosePropertySet (RHTTPPropertySet &aPropertySet)

Private Methods

CHeaderFieldPart (THTTPHdrVal aVal)
Default constructor.

Private Attributes

THTTPHdrVal iValue
The value of this part of the header field.

RPointerArray< CHeaderFieldParam > | iParams
Parameters for this part.

Friends

class | THeaderFieldParamIter

Detailed Description

Generalised representation of a single HTTP header value part.

The part takes a value of one of the following three types:

  • integer, signed (i.e. can be -ve or +ve)
  • string token, which can represent free text (i.e. text with no special meaning; ETags; MD5 hashes; MIME types, etc.), enumerations (words with special meanings such as 'private', 'close', ') or URLs
  • Date/Time
In addition the part may have one or more parameters. These take the form of attribute-value pairs. They are implemented by the CHeaderFieldParam class.

Definition at line 360 of file CHeaderField.h.

Constructor & Destructor Documentation

virtual CHeaderFieldPart::~CHeaderFieldPart ( ) [virtual]

Class destructor.

CHeaderFieldPart::CHeaderFieldPart ( THTTPHdrVal aVal ) [private]

Default constructor.

Member Function Documentation

IMPORT_C void CHeaderFieldPart::AddParamL ( CHeaderFieldParam * aParam )

Add a parameter to the header part.

It is appended after any existing parameters.

Parameters:
aParam The parameter to be added. The header takes ownership of the new parameter.

void CHeaderFieldPart::ClosePropertySet ( RHTTPPropertySet & aPropertySet ) [inline, static]

Definition at line 688 of file CHeaderField.h.

References RHTTPPropertySet::iImplementation.

IMPORT_C CHeaderFieldPart* CHeaderFieldPart::NewL ( THTTPHdrVal aVal ) [static]

Create a new part, for the supplied HTTP value.

Parameters:
aVal The HTTP value for this part of the header field. A copy is taken when storing.
Returns:
The constructed instance of CHeaderFieldPart.

IMPORT_C TInt CHeaderFieldPart::NumParameters ( )

Obtain the number of parameters in this header.

Returns:
The number, as an integer

CHeaderFieldParam* CHeaderFieldPart::Parameter ( RStringF aParamName ) const

Access the header parameters by parameter name.

Parameters:
aParamName The name of the desired part.
Returns:
The named parameter, or NULL if it doesn't exist.

CHeaderFieldParam* CHeaderFieldPart::Parameter ( TInt aIndex ) const

Access the header parameters by index.

Parameters:
aIndex The index of the desired parameter. 0 references the first one.
Returns:
The indexed parameter, or NULL if the index was invalid.

IMPORT_C THeaderFieldParamIter CHeaderFieldPart::Parameters ( )

Access the parameters in this header part via an iterator.

Returns:
An iterator constructed to point at the first parameter

TInt CHeaderFieldPart::RemoveParam ( CHeaderFieldParam * aParam )

Remove the specified parameter from the header part.

Parameters:
aParam The parameter to be removed. The header deletes the removed parameter.
Returns:
An error code; KErrNone if the removal succeeds or KErrNotFound if it didn't.

void CHeaderFieldPart::SetPropertySet ( RHTTPPropertySet & aPropertySet ) [inline]

Definition at line 683 of file CHeaderField.h.

References RHTTPPropertySet::iImplementation.

void CHeaderFieldPart::SetValue ( THTTPHdrVal aVal )

Change the value held in this field part.

Parameters:
The HTTP value. It is copied in order to store it.

IMPORT_C THTTPHdrVal CHeaderFieldPart::Value ( )

Obtain the value held in this field part.

The caller must call Copy() on the returned THTTPHdrVal if it is going to be stored. This is needed in order to correctly maintain string references.

Returns:
The field part's HTTP value

Friends And Related Function Documentation

friend class THeaderFieldParamIter [friend]

Definition at line 362 of file CHeaderField.h.

Member Data Documentation

RPointerArray<CHeaderFieldParam> CHeaderFieldPart::iParams [private]

Parameters for this part.

Definition at line 466 of file CHeaderField.h.

THTTPHdrVal CHeaderFieldPart::iValue [private]

The value of this part of the header field.

Definition at line 462 of file CHeaderField.h.

The documentation for this class was generated from the following file:
  • CHeaderField.h


Member List

CHeaderFieldPart Member List

This is the complete list of members for CHeaderFieldPart, including all inherited members.
AddParamL(CHeaderFieldParam *aParam) | CHeaderFieldPart |
CHeaderFieldPart(THTTPHdrVal aVal) | CHeaderFieldPart | [private]
ClosePropertySet(RHTTPPropertySet &aPropertySet) | CHeaderFieldPart | [inline, static]
iParams | CHeaderFieldPart | [private]
iValue | CHeaderFieldPart | [private]
NewL(THTTPHdrVal aVal) | CHeaderFieldPart | [static]
NumParameters() const | CHeaderFieldPart |
Parameter(TInt aIndex) const | CHeaderFieldPart |
Parameter(RStringF aParamName) const | CHeaderFieldPart |
Parameters() const | CHeaderFieldPart |
RemoveParam(CHeaderFieldParam *aParam) | CHeaderFieldPart |
SetPropertySet(RHTTPPropertySet &aPropertySet) | CHeaderFieldPart | [inline]
SetValue(THTTPHdrVal aVal) | CHeaderFieldPart |
THeaderFieldParamIter class | CHeaderFieldPart | [friend]
Value() const | CHeaderFieldPart |
~CHeaderFieldPart() | CHeaderFieldPart | [virtual]


THeaderFieldPartIter Class Reference

Iterator class to iterate the parts contained within a header field. More...

#include <CHeaderField.h>

Collaboration diagram for THeaderFieldPartIter:

[legend]
List of all members.

Public Methods

THeaderFieldPartIter (const CHeaderField *aHeader)
Construct an iterator for the parts of the supplied header.

IMPORT_C void | First ()
Reset iterator to point at the first part of the header.

IMPORT_C TBool | AtEnd ()
Check if the iterator is at the end of the list.

IMPORT_C void | operator++ ()
Advance the iterator.

IMPORT_C const CHeaderFieldPart * | operator() ()
Obtain the header part currently pointed at by the iterator.

Private Methods

void | CheckInvalidation ()
Check the iterator state for invalidity following deletions in the list.

Private Attributes

const CHeaderField * | iHeader
The header whose parts we are iterating.

TInt | iPosIdx
The index of the part in the header that is currently pointed at by the iterator.

Detailed Description

Iterator class to iterate the parts contained within a header field.

Requires friendship with CHeaderField and as such is tightly bound to that class.

Definition at line 569 of file CHeaderField.h.

Constructor & Destructor Documentation

THeaderFieldPartIter::THeaderFieldPartIter ( const CHeaderField * aHeader )

Construct an iterator for the parts of the supplied header.

Parameters:
aHeader The header whose parts we want to iterate

Member Function Documentation

IMPORT_C TBool THeaderFieldPartIter::AtEnd ( )

Check if the iterator is at the end of the list.

If so, further calls to operator() will return NULL.

Returns:
True if the iterator has hit the end of the parts list

void THeaderFieldPartIter::CheckInvalidation ( ) [private]

Check the iterator state for invalidity following deletions in the list.

IMPORT_C void THeaderFieldPartIter::First ( )

Reset iterator to point at the first part of the header.

IMPORT_C const CHeaderFieldPart* THeaderFieldPartIter::operator() ( )

Obtain the header part currently pointed at by the iterator.

Returns:
The header part; NULL if the iterator has gone off the end of the list

IMPORT_C void THeaderFieldPartIter::operator++ ( )

Advance the iterator.

Member Data Documentation

const CHeaderField* THeaderFieldPartIter::iHeader [private]

The header whose parts we are iterating.

Definition at line 615 of file CHeaderField.h.

TInt THeaderFieldPartIter::iPosIdx [private]

The index of the part in the header that is currently pointed at by the iterator.

Definition at line 620 of file CHeaderField.h.

The documentation for this class was generated from the following file:
  • CHeaderField.h


Member List

THeaderFieldPartIter Member List

This is the complete list of members for THeaderFieldPartIter, including all inherited members.
AtEnd() | THeaderFieldPartIter |
CheckInvalidation() | THeaderFieldPartIter | [private]
First() | THeaderFieldPartIter |
iHeader | THeaderFieldPartIter | [private]
iPosIdx | THeaderFieldPartIter | [private]
operator()() | THeaderFieldPartIter |
operator++() | THeaderFieldPartIter |
THeaderFieldPartIter(const CHeaderField *aHeader) | THeaderFieldPartIter |


CHeaderReader Class Reference

@public
Since:
7.0 An abstract HTTP header decoder.
More...

#include <cheadercodec.h>

Inheritance diagram for CHeaderReader:

[legend]
List of all members.

Public Methods

virtual IMPORT_C | ~CHeaderReader ()
Intended Usage: Destructor - cleans up and release resources to the system.

virtual void | DecodeHeaderL (RHeaderField &aHeader)=0

Protected Methods

IMPORT_C | CHeaderReader ()
Intended Usage: Default constructor.

IMPORT_C void | ConstructL ()
Intended Usage: Second phase construction in which any necessary allocation is done
Since:
7.0 @leaves Standard Symbian OS error codes.

Private Methods

virtual void | Reserved1 ()
Intended Usage: Reserve a slot in the v-table to preserve future BC
Since:
7.0.

virtual void | Reserved2 ()
Intended Usage: Reserve a slot in the v-table to preserve future BC
Since:
7.0.

Detailed Description

@public
Since:
7.0 An abstract HTTP header decoder.

CHeaderReader provides an interface used by its owning codec to do conversion of header data from the raw representation used for a particular protocol/transport to the generic internal header representation. Specific sub-classes of CHeaderWriter are associated with specific protocol handlers.

Definition at line 261 of file cheadercodec.h.

Constructor & Destructor Documentation

CHeaderReader::~CHeaderReader ( ) [virtual]

Intended Usage: Destructor - cleans up and release resources to the system.

Since:
7.0

CHeaderReader::CHeaderReader ( ) [protected]

Intended Usage: Default constructor.

Since:
7.0

Member Function Documentation

CHeaderReader::ConstructL ( ) [protected]

Intended Usage: Second phase construction in which any necessary allocation is done

Since:
7.0 @leaves Standard Symbian OS error codes.

e.g. KErrNoMemory.

virtual void CHeaderReader::DecodeHeaderL ( RHeaderField & aHeader ) [pure virtual]

Implemented in CTextModeHeaderReader, CTextModeDefHdrReader, CWspHeaderReader, and CWspDefaultHdrReader.

void CHeaderReader::Reserved1 ( ) [inline, private, virtual]

Intended Usage: Reserve a slot in the v-table to preserve future BC

Since:
7.0.

Definition at line 330 of file cheadercodec.h.

void CHeaderReader::Reserved2 ( ) [inline, private, virtual]

Intended Usage: Reserve a slot in the v-table to preserve future BC

Since:
7.0.

Definition at line 332 of file cheadercodec.h.

The documentation for this class was generated from the following file:
  • cheadercodec.h


Member List

CHeaderReader Member List

This is the complete list of members for CHeaderReader, including all inherited members.
CHeaderReader() | CHeaderReader | [protected]
ConstructL() | CHeaderReader | [protected]
DecodeHeaderL(RHeaderField &aHeader)=0 | CHeaderReader | [pure virtual]
Reserved1() | CHeaderReader | [inline, private, virtual]
Reserved2() | CHeaderReader | [inline, private, virtual]
~CHeaderReader() | CHeaderReader | [virtual]


RHTTPHeaders Class Reference

@public
Since:
7.0 The collection of headers (or more correctly, header fields) associated with a message.
More...

#include <rhttpheaders.h>

Collaboration diagram for RHTTPHeaders:

[legend]
List of all members.

Public Methods

RHTTPHeaders ()
Default constructor.

Getter methods
Methods for reading data.

IMPORT_C TInt | FieldPartsL (RStringF aFieldName) const
Obtain the number of parts in the named header field's value, Simple headers are created with a single part following one call to SetFieldL.

IMPORT_C TInt | GetField (RStringF aFieldName, TInt aPartIdx, THTTPHdrVal &aHeaderValue) const
Obtain the named header field's value.

IMPORT_C TInt | GetRawField (RStringF aFieldName, TPtrC8 &aRawFieldData) const
Obtain an Raw representation of the named header field's value.

IMPORT_C TInt | GetParam (RStringF aFieldName, RStringF aParamName, THTTPHdrVal &aReturn, TInt aPartIdx=0) const
Obtain the value of a named parameter, associated with the named header field.

IMPORT_C THTTPHdrFieldIter | Fields () const
Access the fields within this header collection, via an iterator.

Setter Methods
Methods for writing data.

IMPORT_C void | SetFieldL (RStringF aFieldName, THTTPHdrVal aFieldValue)
Set a named field in the header.

IMPORT_C void | SetFieldL (RStringF aFieldName, THTTPHdrVal aFieldValue, RStringF aParamName, THTTPHdrVal aParamValue)
Set a named field in the header, and associate with it the supplied parameter.

IMPORT_C void | SetParamL (RStringF aFieldName, RStringF aParamName, THTTPHdrVal aParamValue, TInt aPartIdx)
Set a parameter in an existing header.

IMPORT_C void | SetRawFieldL (RStringF aFieldName, const TDesC8 &aRawFieldData, const TDesC8 &aFieldSeparator)
Set a named field in the header to contain the supplied Raw header data.

IMPORT_C TInt | RemoveField (RStringF aFieldName)
Remove, entirely, the named header field from the header collection.

IMPORT_C TInt | RemoveFieldPart (RStringF aFieldName, TInt aIndex)
Remove a single part of a header field.

IMPORT_C void | RemoveAllFields ()
Remove all the fields of this header collection.

Private Attributes

CHeaders * iImplementation

Friends

class | CHeaders

Detailed Description

@public
Since:
7.0 The collection of headers (or more correctly, header fields) associated with a message.

Header (fields) can be created, read and modified. They may be composed of several parts (by repeated invocations of API methods, see below) and may be assigned one or more parameters. Individual field parts and parameters take values described using THTTPHdrVal.

See also:
RHTTPMessage , THTTPHdrVal

Definition at line 34 of file rhttpheaders.h.

Constructor & Destructor Documentation

RHTTPHeaders::RHTTPHeaders ( ) [inline]

Default constructor.

Definition at line 197 of file rhttpheaders.h.

Member Function Documentation

IMPORT_C TInt RHTTPHeaders::FieldPartsL ( RStringF aFieldName ) const

Obtain the number of parts in the named header field's value, Simple headers are created with a single part following one call to SetFieldL.

Subsequent calls to SetFieldL create additional parts if the field exists already.

Exceptions:
KErrNoMemory
Parameters:
aFieldName The header name
Returns:
The number of parts, or zero if the field does not exist.

IMPORT_C THTTPHdrFieldIter RHTTPHeaders::Fields ( )

Access the fields within this header collection, via an iterator.

Each application of the iterator returns the name of the next field type. This may then be accessed via RHTTPHeaders methods.

Returns:
The iterator.

IMPORT_C TInt RHTTPHeaders::GetField | ( | RStringF | aFieldName,
 |  | TInt | aPartIdx,
 |  | THTTPHdrVal & | aHeaderValue
 | ) | const

Obtain the named header field's value.

The index of a part within the field must be specified. Parts are indexed from 0 and fields with only one part return the entire field for index 0

Parameters:
aFieldName | The header name
aPartIdx | The index of the part
aHeaderValue | The header field value
Returns:
An error condition. Returns KErrNotFound if there is not a field with the specifed field name

IMPORT_C TInt RHTTPHeaders::GetParam | ( | RStringF | aFieldName,
 |  | RStringF | aParamName,
 |  | THTTPHdrVal & | aReturn,
 |  | TInt | aPartIdx = 0
 | ) | const

Obtain the value of a named parameter, associated with the named header field.

An optional index to a part within the header field may be supplied, if not it is assumed that it is the first part.

Parameters:
aFieldName | The header name
aParamName | The parameter name
aReturn | The returned value. Note that this must be Copy()d by the caller, if it wants to keep the value.
aPartIdx | The optional index of the part
Returns:
An error condition. Returns KErrNotFound if there is not a field with the specifed field name

IMPORT_C TInt RHTTPHeaders::GetRawField | ( | RStringF | aFieldName,
 |  | TPtrC8 & | aRawFieldData
 | ) | const

Obtain an Raw representation of the named header field's value.

Note that general client use of this method is strongly discouraged since it exposes the Raw representation of particular headers. However it may be needed for some cases where received headers could not be decoded by HTTP. It will normally be used internally when preparing header data to be transmitted with a request.

Parameters:
aFieldName | The field name, e.g, 'Content-Type'
aRawFieldData | The field's data content, in an appropriate Raw form
Returns:
An error condition. Returns KErrNotFound if there is not a field with the specifed field name

IMPORT_C void RHTTPHeaders::RemoveAllFields ( )

Remove all the fields of this header collection.

IMPORT_C TInt RHTTPHeaders::RemoveField ( RStringF aFieldName )

Remove, entirely, the named header field from the header collection.

All its parts and associated parameters (where they exist) are also removed.

Parameters:
aFieldName The field name.
Returns:
KErrNone if the removal is successful; KErrNotFound if the field didn't exist within the headers.

IMPORT_C TInt RHTTPHeaders::RemoveFieldPart | ( | RStringF | aFieldName,
 |  | TInt | aIndex
 | ) |

Remove a single part of a header field.

Just the part and any associated paramters are removed. If this results in no parts being present in the header then it will also be removed

Parameters:
aFieldName The header name
a aIndex The particular part of the field to be removed
Returns:
KErrNone if the removal is sucessful; KErrNotFound if the header didn't exist. No exception is raised if the particular value is not found as part of that header

IMPORT_C void RHTTPHeaders::SetFieldL | ( | RStringF | aFieldName,
 |  | THTTPHdrVal | aFieldValue,
 |  | RStringF | aParamName,
 |  | THTTPHdrVal | aParamValue
 | ) |

Set a named field in the header, and associate with it the supplied parameter.

If the field doesn't already exist it will be created along with a parameter; if it does exist, then a new part will be created along with the parameter.

Parameters:
aFieldName | The field name, e.g. 'Accept'
aFieldValue | The field value. e.g. 'text/plain'
aParamName | The parameter name, e.g. 'q'
aParamValue | The parameter value, e.g. '0.3'

IMPORT_C void RHTTPHeaders::SetFieldL | ( | RStringF | aFieldName,
 |  | THTTPHdrVal | aFieldValue
 | ) |

Set a named field in the header.

On the first instance that this API method is used for a given field name, the first will be created. On subsequent calls, the same field will be extended to have several parts, with a new part created to hold the supplied value.

Parameters:
aFieldName | The field name, e.g, 'Content-Type'
aFieldValue | The field value, e.g. 'text/html'

IMPORT_C void RHTTPHeaders::SetParamL | ( | RStringF | aFieldName,
 |  | RStringF | aParamName,
 |  | THTTPHdrVal | aParamValue,
 |  | TInt | aPartIdx
 | ) |

Set a parameter in an existing header.

Parameters:
aFieldName | The field name, e.g. 'Accept'
aPartIdx | The part of the header to add the parameter to
aParamName | The parameter name, e.g. 'q'
aParamValue | The parameter value, e.g. '0.3' @leave KErrNotFoud if the field, or the part within the field doesn't exist

IMPORT_C void RHTTPHeaders::SetRawFieldL | ( | RStringF | aFieldName,
 |  | const TDesC8 & | aRawFieldData,
 |  | const TDesC8 & | aFieldSeparator
 | ) |

Set a named field in the header to contain the supplied Raw header data.

If the header already exists then a LF and the new data will be added to the existing data. This is used to indicate that there are multiple instances of this header

Note that general client use of this method is strongly discouraged since it exposes the raw representation of particular headers. However it may be needed for some cases where headers to be transmitted have no encoding known to HTTP. It will normally be used internally when receiving data from a service provider.

Parameters:
aFieldName | The field name, e.g, 'Content-Type'
aRawFieldData | The field's data content, in a raw form
aFieldSeparator | The header field separator

Friends And Related Function Documentation

friend class CHeaders [friend]

Definition at line 191 of file rhttpheaders.h.

Member Data Documentation

CHeaders* RHTTPHeaders::iImplementation [private]

Definition at line 193 of file rhttpheaders.h.

The documentation for this class was generated from the following file:
  • rhttpheaders.h


Member List

RHTTPHeaders Member List

This is the complete list of members for RHTTPHeaders, including all inherited members.
CHeaders class | RHTTPHeaders | [friend]
FieldPartsL(RStringF aFieldName) const | RHTTPHeaders |
Fields() const | RHTTPHeaders |
GetField(RStringF aFieldName, TInt aPartIdx, THTTPHdrVal &aHeaderValue) const | RHTTPHeaders |
GetParam(RStringF aFieldName, RStringF aParamName, THTTPHdrVal &aReturn, TInt aPartIdx=0) const | RHTTPHeaders |
GetRawField(RStringF aFieldName, TPtrC8 &aRawFieldData) const | RHTTPHeaders |
iImplementation | RHTTPHeaders | [private]
RemoveAllFields() | RHTTPHeaders |
RemoveField(RStringF aFieldName) | RHTTPHeaders |
RemoveFieldPart(RStringF aFieldName, TInt aIndex) | RHTTPHeaders |
RHTTPHeaders() | RHTTPHeaders | [inline]
SetFieldL(RStringF aFieldName, THTTPHdrVal aFieldValue) | RHTTPHeaders |
SetFieldL(RStringF aFieldName, THTTPHdrVal aFieldValue, RStringF aParamName, THTTPHdrVal aParamValue) | RHTTPHeaders |
SetParamL(RStringF aFieldName, RStringF aParamName, THTTPHdrVal aParamValue, TInt aPartIdx) | RHTTPHeaders |
SetRawFieldL(RStringF aFieldName, const TDesC8 &aRawFieldData, const TDesC8 &aFieldSeparator) | RHTTPHeaders |


CHeaders Class Reference

The CHeaders class provides the internal implementation of the RHTTPHeaders interface, which is documented in <http.h>. More...

#include <CHeaders.h>

Collaboration diagram for CHeaders:

[legend]
List of all members.

Public Methods

~CHeaders ()
Destructor. Cleans up and releases resources to the system.

RHTTPHeaders Handle ()
void | SetFieldL (RStringF aFieldName, THTTPHdrVal aFieldValue)
Create or append a field part for the named field and assigned value.

void | SetFieldL (RStringF aFieldName, THTTPHdrVal aFieldValue, RStringF aParamName, THTTPHdrVal aParamValue)
Create or append a field part with parameter, for the specified field, parameter and associated values.

void | SetParamL (RStringF aFieldName, RStringF aParamName, THTTPHdrVal aParamValue, TInt aPartIdx)
Create a parameter in an exisitng part.

void | SetRawFieldL (RStringF aFieldName, const TDesC8 &aOtaFieldData, const TDesC8 &aFieldSeparator)
Set a named field in the header to contain the supplied OTA data.

TInt | RemoveField (RStringF aFieldName)
Remove, entirely, the named header field from the header collection.

TInt | RemoveFieldPartL (RStringF aFieldName, TInt aIndex)
Remove the particular part of a field.

void | RemoveAllFields ()
Remove all the fields in this header collection.

TInt | FieldPartsL (RStringF aFieldName) const
Obtain the number of parts in the named header field's value, Simple headers are created with a single part following one call to SetFieldL.

TInt | GetField (RStringF aFieldName, TInt aPartIdx, THTTPHdrVal &aHeaderValue) const
Obtain the named header field's value.

TInt | GetRawField (RStringF aFieldName, TPtrC8 &aRawFieldData) const
Obtain an Over-The-Air representation of the named header field's value.

THTTPHdrVal | GetParam (RStringF aFieldName, RStringF aParamName, THTTPHdrVal &aValue, TInt aPartIdx) const
Obtain the value of a named parameter, associated with the named header field.

THTTPHdrFieldIter | Fields () const
Access the header fields via an iterator.

CHeaderCodec & | Codec () const
Access the codec used to convert header fields between OTA and parsed format.

Static Public Methods

CHeaders * | NewL (CHeaderCodec &aCodec)
Factory construction, given a particular codec. Ownership of the codec remains with the caller.

Private Methods

CHeaders (CHeaderCodec &aCodec)
Constructor; stores the supplied codec pointer.

TInt | LocateFieldName (RStringF aHeaderName) const
Utility to look up a given header name from the iFieldNames array and return its index.

CHeaderField & | CreateOrLookupFieldL (RStringF aHeaderName)
Looks up the given header name and returns the corresponding field if it exists; if not, a new field is created and returned.

CHeaderFieldPart * | GetFieldPartL (RStringF aFieldName, TInt aPartIdx) const
Obtains the indexed part of the named field.

CHeaderFieldParam * | GetFieldParameter (RStringF aFieldName, RStringF aParamName, TInt aPartIdx) const
Obtains the index parameter of the named field's indexed part.

void | DoInsertInNameOrderL (CHeaderField *aHeader, RStringF aHeaderName)
Inserts a header in the order of the name.

void | PurgeFields ()
Deletes all fields.

Private Attributes

RArray< THeaderFieldNamePair > | iFields
An array of field name pairs. Each field contains several values that is associated with a name of a field.

CHeaderCodec & iCodec
The transaction codec associated with this header collection.

Friends

class | THTTPHdrFieldIter

Detailed Description

The CHeaders class provides the internal implementation of the RHTTPHeaders interface, which is documented in <http.h>.

Briefly, this interface provides a unified point at which all header data can be read and written for a given request or response. The CHeaders object is related to an instance of a specific CHTTPTransactionCodec subclass, which is used to provide on-demand decoding and encoding of indivual header fields.

See also:
RHTTPHeaders

Definition at line 28 of file CHeaders.h.

Constructor & Destructor Documentation

CHeaders::~CHeaders ( )

Destructor. Cleans up and releases resources to the system.

CHeaders::CHeaders ( CHeaderCodec & aCodec ) [inline, private]

Constructor; stores the supplied codec pointer.

Definition at line 163 of file CHeaders.h.

Member Function Documentation

CHeaderCodec & CHeaders::Codec ( ) [inline]

Access the codec used to convert header fields between OTA and parsed format.

Definition at line 168 of file CHeaders.h.

References iCodec.

CHeaderField& CHeaders::CreateOrLookupFieldL ( RStringF aHeaderName ) [private]

Looks up the given header name and returns the corresponding field if it exists; if not, a new field is created and returned.

void CHeaders::DoInsertInNameOrderL | ( | CHeaderField * | aHeader,
 |  | RStringF | aHeaderName
 | ) | [private]

Inserts a header in the order of the name.

TInt CHeaders::FieldPartsL ( RStringF aFieldName ) const

Obtain the number of parts in the named header field's value, Simple headers are created with a single part following one call to SetFieldL.

Subsequent calls to SetFieldL create additional parts with the field exists already

THTTPHdrFieldIter CHeaders::Fields ( )

Access the header fields via an iterator.

TInt CHeaders::GetField | ( | RStringF | aFieldName,
 |  | TInt | aPartIdx,
 |  | THTTPHdrVal & | aHeaderValue
 | ) | const

Obtain the named header field's value.

Optionally, the index of a part within the field may be specified. Parts are indexed from zero

CHeaderFieldParam* CHeaders::GetFieldParameter | ( | RStringF | aFieldName,
 |  | RStringF | aParamName,
 |  | TInt | aPartIdx
 | ) | const [private]

Obtains the index parameter of the named field's indexed part.

CHeaderFieldPart* CHeaders::GetFieldPartL | ( | RStringF | aFieldName,
 |  | TInt | aPartIdx
 | ) | const [private]

Obtains the indexed part of the named field.

THTTPHdrVal CHeaders::GetParam | ( | RStringF | aFieldName,
 |  | RStringF | aParamName,
 |  | THTTPHdrVal & | aValue,
 |  | TInt | aPartIdx
 | ) | const

Obtain the value of a named parameter, associated with the named header field.

An optional index to a part within the header field may be supplied, if not it is assumed that it is the first part

TInt CHeaders::GetRawField | ( | RStringF | aFieldName,
 |  | TPtrC8 & | aRawFieldData
 | ) | const

Obtain an Over-The-Air representation of the named header field's value.

RHTTPHeaders CHeaders::Handle ( )

TInt CHeaders::LocateFieldName ( RStringF aHeaderName ) const [private]

Utility to look up a given header name from the iFieldNames array and return its index.

CHeaders* CHeaders::NewL ( CHeaderCodec & aCodec ) [static]

Factory construction, given a particular codec. Ownership of the codec remains with the caller.

void CHeaders::PurgeFields ( ) [private]

Deletes all fields.

void CHeaders::RemoveAllFields ( )

Remove all the fields in this header collection.

TInt CHeaders::RemoveField ( RStringF aFieldName )

Remove, entirely, the named header field from the header collection.

All its parts and associated parameters (where they exist) are also removed

TInt CHeaders::RemoveFieldPartL | ( | RStringF | aFieldName,
 |  | TInt | aIndex
 | ) |

Remove the particular part of a field.

All its parameters ,where they exist, are removed. If this is the only part then the header is also removed

void CHeaders::SetFieldL | ( | RStringF | aFieldName,
 |  | THTTPHdrVal | aFieldValue,
 |  | RStringF | aParamName,
 |  | THTTPHdrVal | aParamValue
 | ) |

Create or append a field part with parameter, for the specified field, parameter and associated values.

void CHeaders::SetFieldL | ( | RStringF | aFieldName,
 |  | THTTPHdrVal | aFieldValue
 | ) |

Create or append a field part for the named field and assigned value.

void CHeaders::SetParamL | ( | RStringF | aFieldName,
 |  | RStringF | aParamName,
 |  | THTTPHdrVal | aParamValue,
 |  | TInt | aPartIdx
 | ) |

Create a parameter in an exisitng part.

void CHeaders::SetRawFieldL | ( | RStringF | aFieldName,
 |  | const TDesC8 & | aOtaFieldData,
 |  | const TDesC8 & | aFieldSeparator
 | ) |

Set a named field in the header to contain the supplied OTA data.

Any existing header field of this name will be lost.

Friends And Related Function Documentation

friend class THTTPHdrFieldIter [friend]

Definition at line 30 of file CHeaders.h.

Member Data Documentation

CHeaderCodec& CHeaders::iCodec [private]

The transaction codec associated with this header collection.

Definition at line 159 of file CHeaders.h.

Referenced by Codec().

RArray<THeaderFieldNamePair> CHeaders::iFields [private]

An array of field name pairs. Each field contains several values that is associated with a name of a field.

Definition at line 155 of file CHeaders.h.

The documentation for this class was generated from the following file:
  • CHeaders.h


Member List

CHeaders Member List

This is the complete list of members for CHeaders, including all inherited members.
CHeaders(CHeaderCodec &aCodec) | CHeaders | [inline, private]
Codec() const | CHeaders | [inline]
CreateOrLookupFieldL(RStringF aHeaderName) | CHeaders | [private]
DoInsertInNameOrderL(CHeaderField *aHeader, RStringF aHeaderName) | CHeaders | [private]
FieldPartsL(RStringF aFieldName) const | CHeaders |
Fields() const | CHeaders |
GetField(RStringF aFieldName, TInt aPartIdx, THTTPHdrVal &aHeaderValue) const | CHeaders |
GetFieldParameter(RStringF aFieldName, RStringF aParamName, TInt aPartIdx) const | CHeaders | [private]
GetFieldPartL(RStringF aFieldName, TInt aPartIdx) const | CHeaders | [private]
GetParam(RStringF aFieldName, RStringF aParamName, THTTPHdrVal &aValue, TInt aPartIdx) const | CHeaders |
GetRawField(RStringF aFieldName, TPtrC8 &aRawFieldData) const | CHeaders |
Handle() | CHeaders |
iCodec | CHeaders | [private]
iFields | CHeaders | [private]
LocateFieldName(RStringF aHeaderName) const | CHeaders | [private]
NewL(CHeaderCodec &aCodec) | CHeaders | [static]
PurgeFields() | CHeaders | [private]
RemoveAllFields() | CHeaders |
RemoveField(RStringF aFieldName) | CHeaders |
RemoveFieldPartL(RStringF aFieldName, TInt aIndex) | CHeaders |
SetFieldL(RStringF aFieldName, THTTPHdrVal aFieldValue) | CHeaders |
SetFieldL(RStringF aFieldName, THTTPHdrVal aFieldValue, RStringF aParamName, THTTPHdrVal aParamValue) | CHeaders |
SetParamL(RStringF aFieldName, RStringF aParamName, THTTPHdrVal aParamValue, TInt aPartIdx) | CHeaders |
SetRawFieldL(RStringF aFieldName, const TDesC8 &aOtaFieldData, const TDesC8 &aFieldSeparator) | CHeaders |
THTTPHdrFieldIter class | CHeaders | [friend]
~CHeaders() | CHeaders |


CHeaders::THeaderFieldNamePair Class Reference

Structure which contains the headerfield and the associated name. More...

Collaboration diagram for CHeaders::THeaderFieldNamePair:

[legend]
List of all members.

Static Public Methods

TInt | CompareFieldNames (const THeaderFieldNamePair &aField1, const THeaderFieldNamePair &aFieldName2)

Public Attributes

RStringF | iFieldName
CHeaderField * iField

Detailed Description

Structure which contains the headerfield and the associated name.

Definition at line 112 of file CHeaders.h.

Member Function Documentation

TInt CHeaders::THeaderFieldNamePair::CompareFieldNames | ( | const THeaderFieldNamePair & | aField1,
 |  | const THeaderFieldNamePair & | aFieldName2
 | ) | [static]

Member Data Documentation

CHeaderField* CHeaders::THeaderFieldNamePair::iField

Definition at line 118 of file CHeaders.h.

RStringF CHeaders::THeaderFieldNamePair::iFieldName

Definition at line 117 of file CHeaders.h.

The documentation for this class was generated from the following file:
  • CHeaders.h


Member List

CHeaders::THeaderFieldNamePair Member List

This is the complete list of members for CHeaders::THeaderFieldNamePair, including all inherited members.
CompareFieldNames(const THeaderFieldNamePair &aField1, const THeaderFieldNamePair &aFieldName2) | CHeaders::THeaderFieldNamePair | [static]
iField | CHeaders::THeaderFieldNamePair |
iFieldName | CHeaders::THeaderFieldNamePair |


CHeaderWriter Class Reference

@public
Since:
7.0 An abstract HTTP header encoder.
More...

#include <cheadercodec.h>

Inheritance diagram for CHeaderWriter:

[legend]
List of all members.

Public Methods

virtual IMPORT_C | ~CHeaderWriter ()
Intended Usage: Destructor - cleans up and release resources to the system.

virtual void | EncodeHeaderL (RHeaderField &aHeader)=0

Protected Methods

IMPORT_C | CHeaderWriter ()
Intended Usage: Default constructor.

IMPORT_C void | ConstructL ()
Intended Usage: Second phase construction in which any necessary allocation is done
Since:
7.0 @leaves Standard Symbian OS error codes.

Private Methods

virtual void | Reserved1 ()
Intended Usage: Reserve a slot in the v-table to preserve future BC
Since:
7.0.

virtual void | Reserved2 ()
Intended Usage: Reserve a slot in the v-table to preserve future BC
Since:
7.0.

Detailed Description

@public
Since:
7.0 An abstract HTTP header encoder.

CHeaderWriter provides an interface used by its owning codec to do conversion of header data from the generic internal header representation to the raw representation used for a particular protocol/transport. Specific sub-classes of CHeaderWriter are associated with specific protocol handlers.

Definition at line 188 of file cheadercodec.h.

Constructor & Destructor Documentation

CHeaderWriter::~CHeaderWriter ( ) [virtual]

Intended Usage: Destructor - cleans up and release resources to the system.

Since:
7.0

CHeaderWriter::CHeaderWriter ( ) [protected]

Intended Usage: Default constructor.

Since:
7.0

Member Function Documentation

CHeaderWriter::ConstructL ( ) [protected]

Intended Usage: Second phase construction in which any necessary allocation is done

Since:
7.0 @leaves Standard Symbian OS error codes.

e.g. KErrNoMemory.

virtual void CHeaderWriter::EncodeHeaderL ( RHeaderField & aHeader ) [pure virtual]

Implemented in CTextModeHeaderWriter, CTextModeDefHdrWriter, CWspHeaderWriter, and CWspDefaultHdrWriter.

void CHeaderWriter::Reserved1 ( ) [inline, private, virtual]

Intended Usage: Reserve a slot in the v-table to preserve future BC

Since:
7.0.

Definition at line 326 of file cheadercodec.h.

void CHeaderWriter::Reserved2 ( ) [inline, private, virtual]

Intended Usage: Reserve a slot in the v-table to preserve future BC

Since:
7.0.

Definition at line 328 of file cheadercodec.h.

The documentation for this class was generated from the following file:
  • cheadercodec.h


Member List

CHeaderWriter Member List

This is the complete list of members for CHeaderWriter, including all inherited members.
CHeaderWriter() | CHeaderWriter | [protected]
ConstructL() | CHeaderWriter | [protected]
EncodeHeaderL(RHeaderField &aHeader)=0 | CHeaderWriter | [pure virtual]
Reserved1() | CHeaderWriter | [inline, private, virtual]
Reserved2() | CHeaderWriter | [inline, private, virtual]
~CHeaderWriter() | CHeaderWriter | [virtual]


CHttpClient Class Reference

The example http client. More...

#include <httpexampleclient.h>

Inheritance diagram for CHttpClient:

[legend]
Collaboration diagram for CHttpClient:

[legend]
List of all members.

Public Methods

virtual | ~CHttpClient ()
void | StartClientL ()
virtual TBool | GetNextDataPart (TPtrC8 &aDataPart)
Obtain a data part from the supplier.

virtual void | ReleaseData ()
Release the current data part being held at the data supplier.

virtual TInt | OverallDataSize ()
Obtain the overall size of the data being supplied, if known to the supplier.

virtual TInt | Reset ()
Reset the data supplier.

virtual TBool | GetCredentialsL (const TUriC8 &aURI, RString aRealm, RStringF aAuthenticationType, RString &aUsername, RString &aPassword)
Gets some credentials.

Static Public Methods

CHttpClient * | NewLC ()
CHttpClient * | NewL ()

Protected Methods

CHttpClient ()
void | ConstructL ()

Private Types

enum TMenuItems {
EGet, EPost, EHead, ETrace,
EToggleVerbosity, EQuit
}

Private Methods

void | ResetTimeElapsed ()
void | DisplayTimeElapsed ()
void | InvokeHttpMethodL (const TDesC8 &aUri, RStringF aMethod)
void | SetHeaderL (RHTTPHeaders aHeaders, TInt aHdrField, const TDesC8 &aHdrValue)
void | GetRequestBodyL (RStringF &aMethod)
void | GetPostBodyManuallyL ()

Private Attributes

TTime | iLastTimeStamp
TInt | iDataChunkCount
RHTTPSession iSess
RHTTPTransaction iTrans
TBool | iHasARequestBody
RFs | iFileServ
RFile | iReqBodyFile
TFileName | iReqBodyFileName
TParse | iParsedFileName
TBuf< KMaxContentTypeSize > | iReqBodyContentType
CHttpEventHandler * iTransObs
HBufC8 * | iReqBodySubmitBuffer
TPtr8 | iReqBodySubmitBufferPtr
CHTTPFormEncoder * iFormEncoder
TBool | iManualPost
CHttpExampleUtils * iUtils

Detailed Description

The example http client.

Intended as a simple example of an http client. It is a simple text console app that allows basic http methods to be tested. It allows data for the post method to be supplied via a file or built up dynamically. It also allows responses to be saved to a file

It is derived from MHTTPAuthenticationCallback to allow access to servers that require a user to submit a username and password to access protected sections of that server.

Definition at line 44 of file httpexampleclient.h.

Member Enumeration Documentation

enum CHttpClient::TMenuItems [private]

Enumeration values:
EGet
EPost
EHead
ETrace
EToggleVerbosity
EQuit

Definition at line 69 of file httpexampleclient.h.

Constructor & Destructor Documentation

virtual CHttpClient::~CHttpClient ( ) [virtual]

CHttpClient::CHttpClient ( ) [protected]

Member Function Documentation

void CHttpClient::ConstructL ( ) [protected]

void CHttpClient::DisplayTimeElapsed ( ) [private]

virtual TBool CHttpClient::GetCredentialsL | ( | const TUriC8 & | aURI,
 |  | RString | aRealm,
 |  | RStringF | aAuthenticationType,
 |  | RString & | aUsername,
 |  | RString & | aPassword
 | ) | [virtual]

Gets some credentials.

Note that the first 3 parameters are informational and many clients may not have a use for them. Clients may want to display some or all of these parameters to the user, so that the user knows who they are giving their credentials to, and how securely they will be transmitted.

Parameters:
aURI | The URI being requested
aRealm | The realm being requested
aAuthenticationType | The type of authentication (basic or digest)
aUsername | The username is returned in this parameter. The caller will close the returned string.
aPassword | The password is returned in this parameter The caller will close the returned string.
Returns:
True if credentials have been obtained.
Exceptions:
Anything . If this function leaves the transaction will be failed.

Implements MHTTPAuthenticationCallback.

virtual TBool CHttpClient::GetNextDataPart ( TPtrC8 & aDataPart ) [virtual]

Obtain a data part from the supplier.

The data is guaranteed to survive until a call is made to ReleaseData().

Parameters:
aDataPart - the data part
Returns:
ETrue if this is the last part. EFalse otherwise

Implements MHTTPDataSupplier.

void CHttpClient::GetPostBodyManuallyL ( ) [private]

void CHttpClient::GetRequestBodyL ( RStringF & aMethod ) [private]

void CHttpClient::InvokeHttpMethodL | ( | const TDesC8 & | aUri,
 |  | RStringF | aMethod
 | ) | [private]

CHttpClient* CHttpClient::NewL ( ) [static]

CHttpClient* CHttpClient::NewLC ( ) [static]

virtual TInt CHttpClient::OverallDataSize ( ) [virtual]

Obtain the overall size of the data being supplied, if known to the supplier.

Where a body of data is supplied in several parts this size will be the sum of all the part sizes. If the size is not known, KErrNotFound is returned; in this case the client must use the return code of GetNextDataPart to find out when the data is complete.

Returns:
A size in bytes, or KErrNotFound if the size is not known.

Implements MHTTPDataSupplier.

virtual void CHttpClient::ReleaseData ( ) [virtual]

Release the current data part being held at the data supplier.

This call indicates to the supplier that the part is no longer needed, and another one can be supplied, if appropriate.

Implements MHTTPDataSupplier.

virtual TInt CHttpClient::Reset ( ) [virtual]

Reset the data supplier.

This indicates to the data supplier that it should return to the first part of the data. This could be used in a situation where the data consumer has encountered an error and needs the data to be supplied afresh. Even if the last part has been supplied (i.e. GetNextDataPart has returned ETrue), the data supplier should reset to the first part.

If the supplier cannot reset it should return an error code; otherwise it should return KErrNone, where the reset will be assumed to have succeeded

Implements MHTTPDataSupplier.

void CHttpClient::ResetTimeElapsed ( ) [private]

void CHttpClient::SetHeaderL | ( | RHTTPHeaders | aHeaders,
 |  | TInt | aHdrField,
 |  | const TDesC8 & | aHdrValue
 | ) | [private]

void CHttpClient::StartClientL ( )

Member Data Documentation

TInt CHttpClient::iDataChunkCount [private]

Definition at line 89 of file httpexampleclient.h.

RFs CHttpClient::iFileServ [private]

Definition at line 93 of file httpexampleclient.h.

CHTTPFormEncoder* CHttpClient::iFormEncoder [private]

Definition at line 101 of file httpexampleclient.h.

TBool CHttpClient::iHasARequestBody [private]

Definition at line 92 of file httpexampleclient.h.

TTime CHttpClient::iLastTimeStamp [private]

Definition at line 88 of file httpexampleclient.h.

TBool CHttpClient::iManualPost [private]

Definition at line 102 of file httpexampleclient.h.

TParse CHttpClient::iParsedFileName [private]

Definition at line 96 of file httpexampleclient.h.

TBuf<KMaxContentTypeSize> CHttpClient::iReqBodyContentType [private]

Definition at line 97 of file httpexampleclient.h.

RFile CHttpClient::iReqBodyFile [private]

Definition at line 94 of file httpexampleclient.h.

TFileName CHttpClient::iReqBodyFileName [private]

Definition at line 95 of file httpexampleclient.h.

HBufC8* CHttpClient::iReqBodySubmitBuffer [private]

Definition at line 99 of file httpexampleclient.h.

TPtr8 CHttpClient::iReqBodySubmitBufferPtr [private]

Definition at line 100 of file httpexampleclient.h.

RHTTPSession CHttpClient::iSess [private]

Definition at line 90 of file httpexampleclient.h.

RHTTPTransaction CHttpClient::iTrans [private]

Definition at line 91 of file httpexampleclient.h.

CHttpEventHandler* CHttpClient::iTransObs [private]

Definition at line 98 of file httpexampleclient.h.

CHttpExampleUtils* CHttpClient::iUtils [private]

Definition at line 103 of file httpexampleclient.h.

The documentation for this class was generated from the following file:
  • httpexampleclient.h


Member List

CHttpClient Member List

This is the complete list of members for CHttpClient, including all inherited members.
CHttpClient() | CHttpClient | [protected]
ConstructL() | CHttpClient | [protected]
DisplayTimeElapsed() | CHttpClient | [private]
EGet enum value | CHttpClient | [private]
EHead enum value | CHttpClient | [private]
EPost enum value | CHttpClient | [private]
EQuit enum value | CHttpClient | [private]
EToggleVerbosity enum value | CHttpClient | [private]
ETrace enum value | CHttpClient | [private]
GetCredentialsL(const TUriC8 &aURI, RString aRealm, RStringF aAuthenticationType, RString &aUsername, RString &aPassword) | CHttpClient | [virtual]
GetNextDataPart(TPtrC8 &aDataPart) | CHttpClient | [virtual]
GetPostBodyManuallyL() | CHttpClient | [private]
GetRequestBodyL(RStringF &aMethod) | CHttpClient | [private]
iDataChunkCount | CHttpClient | [private]
iFileServ | CHttpClient | [private]
iFormEncoder | CHttpClient | [private]
iHasARequestBody | CHttpClient | [private]
iLastTimeStamp | CHttpClient | [private]
iManualPost | CHttpClient | [private]
InstallAuthenticationL(RHTTPSession aSession) | MHTTPAuthenticationCallback | [inline]
InvokeHttpMethodL(const TDesC8 &aUri, RStringF aMethod) | CHttpClient | [private]
iParsedFileName | CHttpClient | [private]
iReqBodyContentType | CHttpClient | [private]
iReqBodyFile | CHttpClient | [private]
iReqBodyFileName | CHttpClient | [private]
iReqBodySubmitBuffer | CHttpClient | [private]
iReqBodySubmitBufferPtr | CHttpClient | [private]
iSess | CHttpClient | [private]
iTrans | CHttpClient | [private]
iTransObs | CHttpClient | [private]
iUtils | CHttpClient | [private]
NewL() | CHttpClient | [static]
NewLC() | CHttpClient | [static]
OverallDataSize() | CHttpClient | [virtual]
ReleaseData() | CHttpClient | [virtual]
Reset() | CHttpClient | [virtual]
ResetTimeElapsed() | CHttpClient | [private]
SetHeaderL(RHTTPHeaders aHeaders, TInt aHdrField, const TDesC8 &aHdrValue) | CHttpClient | [private]
StartClientL() | CHttpClient |
TMenuItems enum name | CHttpClient | [private]
~CHttpClient() | CHttpClient | [virtual]


CHttpConnector Class Reference

#include <CHttpConnector.h>

Collaboration diagram for CHttpConnector:

[legend]
List of all members.

Public Methods

virtual | ~CHttpConnector ()
Destructor - cleans up and releases resources to the system.

void | ConnectL (TInetAddr aRemoteAddr, TRequestStatus *aTcpTHStatus)
TInt | GetProxyCONNECTStatus () const
void | TranferDataBufferOwnership (HBufC8 *&aNewOwner)

Static Public Methods

CHttpConnector * | NewL (CHttpSocket &aSocket, CHttpTcpServerLocation &aLocation, MTransportHndObs &aObserver)
Factory construction - creates a new CHttpConnector.

Protected Methods

virtual void | RunL ()
Do some processing when a previous asynch request made by this object has completed.

virtual TInt | RunError (TInt aError)
Do any cleanup required should RunL leave.

virtual void | DoCancel ()
Cancel outstanding asynchronous requests that this object has made.

Private Types

enum TConnectState {
EPendingSocketConnect, ESocketConnected, ETunneling, EPendingTunnel,
ETunnelCreated, ESecureEstablished
}

Private Methods

CHttpConnector (CHttpSocket &aSocket, CHttpTcpServerLocation &aLocation, MTransportHndObs &aObserver)
Normal constructor, setting the active object to the supplied priority.

void | ConstructL ()
Second phase construction; does any required allocation.

void | CompleteSelf ()
TBool | IsHostIPAddress (const TDesC8 &aUri) const

Private Attributes

CHttpSocket & iSocket
The socket to do our transmitting on.

CHttpTcpServerLocation & iLocation
Information about the destination of the connection.

TRequestStatus * | iTcpTHStatus
Status word of the TH so that we can complete it when we finish CONNECTing.

TConnectState iConnectState
Our internal state.

TInetAddr | iRemoteAddr
The address of the proxy to connect to - reqd by the socket.

HBufC8 * | iSendBuffer
The buffer containing the data to transmit over the socket.

TSockXfrLength | iNumBytesRcvd
The number of bytes recieved in an asychronous socket read.

HBufC8 * | iRecvBuffer
The buffer in which received data is written by the socket server.

TPtr8 | iRecvBufferPtr
A writable descriptor pointing at our receive buffer.

MTransportHndObs & iObserver
Allows the CONNECT response to be checked using the facilities of the protocol handler.

TInt | iProxyCONNECTStatus

Member Enumeration Documentation

enum CHttpConnector::TConnectState [private]

Enumeration values:
EPendingSocketConnect
ESocketConnected
ETunneling
EPendingTunnel
ETunnelCreated
ESecureEstablished

Definition at line 54 of file CHttpConnector.h.

Constructor & Destructor Documentation

virtual CHttpConnector::~CHttpConnector ( ) [virtual]

Destructor - cleans up and releases resources to the system.

CHttpConnector::CHttpConnector | ( | CHttpSocket & | aSocket,
 |  | CHttpTcpServerLocation & | aLocation,
 |  | MTransportHndObs & | aObserver
 | ) | [private]

Normal constructor, setting the active object to the supplied priority.

Member Function Documentation

void CHttpConnector::CompleteSelf ( ) [private]

void CHttpConnector::ConnectL | ( | TInetAddr | aRemoteAddr,
 |  | TRequestStatus * | aTcpTHStatus
 | ) |

void CHttpConnector::ConstructL ( ) [private]

Second phase construction; does any required allocation.

virtual void CHttpConnector::DoCancel ( ) [protected, virtual]

Cancel outstanding asynchronous requests that this object has made.

TInt CHttpConnector::GetProxyCONNECTStatus ( )

TBool CHttpConnector::IsHostIPAddress ( const TDesC8 & aUri ) const [private]

CHttpConnector* CHttpConnector::NewL | ( | CHttpSocket & | aSocket,
 |  | CHttpTcpServerLocation & | aLocation,
 |  | MTransportHndObs & | aObserver
 | ) | [static]

Factory construction - creates a new CHttpConnector.

virtual TInt CHttpConnector::RunError ( TInt aError ) [protected, virtual]

Do any cleanup required should RunL leave.

virtual void CHttpConnector::RunL ( ) [protected, virtual]

Do some processing when a previous asynch request made by this object has completed.

void CHttpConnector::TranferDataBufferOwnership ( HBufC8 *& aNewOwner )

Member Data Documentation

TConnectState CHttpConnector::iConnectState [private]

Our internal state.

Definition at line 92 of file CHttpConnector.h.

CHttpTcpServerLocation& CHttpConnector::iLocation [private]

Information about the destination of the connection.

Definition at line 84 of file CHttpConnector.h.

TSockXfrLength CHttpConnector::iNumBytesRcvd [private]

The number of bytes recieved in an asychronous socket read.

This is directly written into by the socket server

Definition at line 105 of file CHttpConnector.h.

MTransportHndObs& CHttpConnector::iObserver [private]

Allows the CONNECT response to be checked using the facilities of the protocol handler.

Definition at line 118 of file CHttpConnector.h.

TInt CHttpConnector::iProxyCONNECTStatus [private]

Definition at line 121 of file CHttpConnector.h.

HBufC8* CHttpConnector::iRecvBuffer [private]

The buffer in which received data is written by the socket server.

Definition at line 109 of file CHttpConnector.h.

TPtr8 CHttpConnector::iRecvBufferPtr [private]

A writable descriptor pointing at our receive buffer.

Definition at line 113 of file CHttpConnector.h.

TInetAddr CHttpConnector::iRemoteAddr [private]

The address of the proxy to connect to - reqd by the socket.

Definition at line 96 of file CHttpConnector.h.

HBufC8* CHttpConnector::iSendBuffer [private]

The buffer containing the data to transmit over the socket.

Definition at line 100 of file CHttpConnector.h.

CHttpSocket& CHttpConnector::iSocket [private]

The socket to do our transmitting on.

Definition at line 80 of file CHttpConnector.h.

TRequestStatus* CHttpConnector::iTcpTHStatus [private]

Status word of the TH so that we can complete it when we finish CONNECTing.

Definition at line 88 of file CHttpConnector.h.

The documentation for this class was generated from the following file:
  • CHttpConnector.h


Member List

CHttpConnector Member List

This is the complete list of members for CHttpConnector, including all inherited members.
CHttpConnector(CHttpSocket &aSocket, CHttpTcpServerLocation &aLocation, MTransportHndObs &aObserver) | CHttpConnector | [private]
CompleteSelf() | CHttpConnector | [private]
ConnectL(TInetAddr aRemoteAddr, TRequestStatus *aTcpTHStatus) | CHttpConnector |
ConstructL() | CHttpConnector | [private]
DoCancel() | CHttpConnector | [protected, virtual]
EPendingSocketConnect enum value | CHttpConnector | [private]
EPendingTunnel enum value | CHttpConnector | [private]
ESecureEstablished enum value | CHttpConnector | [private]
ESocketConnected enum value | CHttpConnector | [private]
ETunnelCreated enum value | CHttpConnector | [private]
ETunneling enum value | CHttpConnector | [private]
GetProxyCONNECTStatus() const | CHttpConnector |
iConnectState | CHttpConnector | [private]
iLocation | CHttpConnector | [private]
iNumBytesRcvd | CHttpConnector | [private]
iObserver | CHttpConnector | [private]
iProxyCONNECTStatus | CHttpConnector | [private]
iRecvBuffer | CHttpConnector | [private]
iRecvBufferPtr | CHttpConnector | [private]
iRemoteAddr | CHttpConnector | [private]
iSendBuffer | CHttpConnector | [private]
IsHostIPAddress(const TDesC8 &aUri) const | CHttpConnector | [private]
iSocket | CHttpConnector | [private]
iTcpTHStatus | CHttpConnector | [private]
NewL(CHttpSocket &aSocket, CHttpTcpServerLocation &aLocation, MTransportHndObs &aObserver) | CHttpConnector | [static]
RunError(TInt aError) | CHttpConnector | [protected, virtual]
RunL() | CHttpConnector | [protected, virtual]
TConnectState enum name | CHttpConnector | [private]
TranferDataBufferOwnership(HBufC8 *&aNewOwner) | CHttpConnector |
~CHttpConnector() | CHttpConnector | [virtual]


CHttpEventHandler Class Reference

Handles all events for the active transaction. More...

#include <httpexampleclient.h>

Inheritance diagram for CHttpEventHandler:

[legend]
Collaboration diagram for CHttpEventHandler:

[legend]
List of all members.

Public Methods

virtual | ~CHttpEventHandler ()
void | SetVerbose (TBool aVerbose)
TBool | Verbose () const
virtual void | MHFRunL (RHTTPTransaction aTransaction, const THTTPEvent &aEvent)
Called when the filter's registration conditions are satisfied for events that occur on a transaction.

virtual TInt | MHFRunError (TInt aError, RHTTPTransaction aTransaction, const THTTPEvent &aEvent)
Called when RunL leaves from a transaction event.

Static Public Methods

CHttpEventHandler * | NewLC (CHttpExampleUtils &aUtils)
CHttpEventHandler * | NewL (CHttpExampleUtils &aUtils)

Protected Methods

CHttpEventHandler (CHttpExampleUtils &aUtils)
void | ConstructL ()

Private Methods

void | DumpRespHeadersL (RHTTPTransaction &aTrans)
void | DumpRespBody (RHTTPTransaction &aTrans)
void | DumpIt (const TDesC8 &aData)

Private Attributes

TBool | iVerbose
TBool | iSavingResponseBody
RFs | iFileServ
RFile | iRespBodyFile
TFileName | iRespBodyFileName
TParse | iParsedFileName
MHTTPDataSupplier * iRespBody
CHttpExampleUtils & iUtils

Detailed Description

Handles all events for the active transaction.

Just displays and logs events that occur.

Definition at line 110 of file httpexampleclient.h.

Constructor & Destructor Documentation

virtual CHttpEventHandler::~CHttpEventHandler ( ) [virtual]

CHttpEventHandler::CHttpEventHandler ( CHttpExampleUtils & aUtils ) [protected]

Member Function Documentation

void CHttpEventHandler::ConstructL ( ) [protected]

void CHttpEventHandler::DumpIt ( const TDesC8 & aData ) [private]

void CHttpEventHandler::DumpRespBody ( RHTTPTransaction & aTrans ) [private]

void CHttpEventHandler::DumpRespHeadersL ( RHTTPTransaction & aTrans ) [private]

virtual TInt CHttpEventHandler::MHFRunError | ( | TInt | aError,
 |  | RHTTPTransaction | aTransaction,
 |  | const THTTPEvent & | aEvent
 | ) | [virtual]

Called when RunL leaves from a transaction event.

This works in the same way as CActve::RunError; return KErrNone if you have handled the error. If you don't completely handle the error, a panic will occur.

Parameters:
aError | The leave code that RunL left with.
aTransaction | The transaction that was being processed.
aEvent | The Event that was being processed.
Returns:
KErrNone if the error has been cancelled or the code of the continuing error otherwise.

Implements MHTTPTransactionCallback.

virtual void CHttpEventHandler::MHFRunL | ( | RHTTPTransaction | aTransaction,
 |  | const THTTPEvent & | aEvent
 | ) | [virtual]

Called when the filter's registration conditions are satisfied for events that occur on a transaction.

Note that this function is not allowed to leave if called with certain events.

See also:
THTTPEvent
Parameters:
aTransaction | The transaction that the event has occurred on.
aEvent | The event that has occurred.
Exceptions:
Any Leaves must be handled by the appropriate MHFRunError.

Implements MHTTPTransactionCallback.

CHttpEventHandler* CHttpEventHandler::NewL ( CHttpExampleUtils & aUtils ) [static]

CHttpEventHandler* CHttpEventHandler::NewLC ( CHttpExampleUtils & aUtils ) [static]

void CHttpEventHandler::SetVerbose ( TBool aVerbose )

TBool CHttpEventHandler::Verbose ( )

Member Data Documentation

RFs CHttpEventHandler::iFileServ [private]

Definition at line 133 of file httpexampleclient.h.

TParse CHttpEventHandler::iParsedFileName [private]

Definition at line 136 of file httpexampleclient.h.

MHTTPDataSupplier* CHttpEventHandler::iRespBody [private]

Definition at line 137 of file httpexampleclient.h.

RFile CHttpEventHandler::iRespBodyFile [private]

Definition at line 134 of file httpexampleclient.h.

TFileName CHttpEventHandler::iRespBodyFileName [private]

Definition at line 135 of file httpexampleclient.h.

TBool CHttpEventHandler::iSavingResponseBody [private]

Definition at line 132 of file httpexampleclient.h.

CHttpExampleUtils& CHttpEventHandler::iUtils [private]

Definition at line 138 of file httpexampleclient.h.

TBool CHttpEventHandler::iVerbose [private]

Definition at line 131 of file httpexampleclient.h.

The documentation for this class was generated from the following file:
  • httpexampleclient.h


Member List

CHttpEventHandler Member List

This is the complete list of members for CHttpEventHandler, including all inherited members.
CHttpEventHandler(CHttpExampleUtils &aUtils) | CHttpEventHandler | [protected]
ConstructL() | CHttpEventHandler | [protected]
DumpIt(const TDesC8 &aData) | CHttpEventHandler | [private]
DumpRespBody(RHTTPTransaction &aTrans) | CHttpEventHandler | [private]
DumpRespHeadersL(RHTTPTransaction &aTrans) | CHttpEventHandler | [private]
iFileServ | CHttpEventHandler | [private]
iParsedFileName | CHttpEventHandler | [private]
iRespBody | CHttpEventHandler | [private]
iRespBodyFile | CHttpEventHandler | [private]
iRespBodyFileName | CHttpEventHandler | [private]
iSavingResponseBody | CHttpEventHandler | [private]
iUtils | CHttpEventHandler | [private]
iVerbose | CHttpEventHandler | [private]
MHFRunError(TInt aError, RHTTPTransaction aTransaction, const THTTPEvent &aEvent) | CHttpEventHandler | [virtual]
MHFRunL(RHTTPTransaction aTransaction, const THTTPEvent &aEvent) | CHttpEventHandler | [virtual]
NewL(CHttpExampleUtils &aUtils) | CHttpEventHandler | [static]
NewLC(CHttpExampleUtils &aUtils) | CHttpEventHandler | [static]
SetVerbose(TBool aVerbose) | CHttpEventHandler |
Verbose() const | CHttpEventHandler |
~CHttpEventHandler() | CHttpEventHandler | [virtual]


CHttpExampleUtils Class Reference

CHttpExampleUtils is a class that provides some user input utilities and holds a RTest used throughout. More...

#include <httpexampleutils.h>

List of all members.

Public Methods

~CHttpExampleUtils ()
void | GetAnEntry (const TDesC &ourPrompt, TDes &currentstring)
TInt | GetSelection (const TDesC &ourPrompt, const TDesC &validChoices)
void | PressAnyKey ()
void | LogIt (TRefByValue< const TDesC > aFmt,...)
RTest & | Test ()

Static Public Methods

void | InitCommsL ()
CHttpExampleUtils * | NewL (const TDesC &aTestName)

Private Methods

CHttpExampleUtils (const TDesC &aTestName)

Private Attributes

RTest | iTest

Detailed Description

CHttpExampleUtils is a class that provides some user input utilities and holds a RTest used throughout.

Definition at line 11 of file httpexampleutils.h.

Constructor & Destructor Documentation

CHttpExampleUtils::~CHttpExampleUtils ( )

CHttpExampleUtils::CHttpExampleUtils ( const TDesC & aTestName ) [private]

Member Function Documentation

void CHttpExampleUtils::GetAnEntry | ( | const TDesC & | ourPrompt,
 |  | TDes & | currentstring
 | ) |

TInt CHttpExampleUtils::GetSelection | ( | const TDesC & | ourPrompt,
 |  | const TDesC & | validChoices
 | ) |

void CHttpExampleUtils::InitCommsL ( ) [static]

void CHttpExampleUtils::LogIt | ( | TRefByValue< const TDesC > | aFmt,
 |  | ... |
 | ) |

CHttpExampleUtils* CHttpExampleUtils::NewL ( const TDesC & aTestName ) [static]

void CHttpExampleUtils::PressAnyKey ( )

RTest& CHttpExampleUtils::Test ( )

Member Data Documentation

RTest CHttpExampleUtils::iTest [private]

Definition at line 26 of file httpexampleutils.h.

The documentation for this class was generated from the following file:
  • httpexampleutils.h


Member List

CHttpExampleUtils Member List

This is the complete list of members for CHttpExampleUtils, including all inherited members.
CHttpExampleUtils(const TDesC &aTestName) | CHttpExampleUtils | [private]
GetAnEntry(const TDesC &ourPrompt, TDes &currentstring) | CHttpExampleUtils |
GetSelection(const TDesC &ourPrompt, const TDesC &validChoices) | CHttpExampleUtils |
InitCommsL() | CHttpExampleUtils | [static]
iTest | CHttpExampleUtils | [private]
LogIt(TRefByValue< const TDesC > aFmt,...) | CHttpExampleUtils |
NewL(const TDesC &aTestName) | CHttpExampleUtils | [static]
PressAnyKey() | CHttpExampleUtils |
Test() | CHttpExampleUtils |
~CHttpExampleUtils() | CHttpExampleUtils |


THttpLogger Class Reference

@private
Since:
7.0 A utility used in HTTP for logging in debug builds.
More...

#include <httplogger.h>

List of all members.

Public Methods

virtual IMPORT_C | ~THttpLogger ()
Destructor - closes the log.

IMPORT_C void | CreateFlogger (const TDesC &aFileName, TInt aShowDate, TInt aShowTime)
Create log file in directory KLogsdir\KWapLogsDirName - Note: ingore Drive and Path of aFilename.

IMPORT_C void | LogIt (TRefByValue< const TDesC > aFmt,...)
IMPORT_C void | WriteComment (const TDesC &aComment)
Writes aComment to test log file, logging file and test harness.

IMPORT_C void | DumpIt (const TDesC8 &aData)
Do a formatted dump of binary data.

IMPORT_C void | WriteComment (const TDesC8 &aData)
Do a write of the supplied 8 bit data.

Private Methods

virtual IMPORT_C void | Overflow (TDes &aDes)

Private Attributes

RFileLogger | iLogger
Logger handle.

Detailed Description

@private
Since:
7.0 A utility used in HTTP for logging in debug builds.

Log files are placed in the directory EPOCROOT%/epoc32/wins/c/logs/http

Definition at line 28 of file httplogger.h.

Constructor & Destructor Documentation

virtual IMPORT_C THttpLogger::~THttpLogger ( ) [virtual]

Destructor - closes the log.

Member Function Documentation

IMPORT_C void THttpLogger::CreateFlogger | ( | const TDesC & | aFileName,
 |  | TInt | aShowDate,
 |  | TInt | aShowTime
 | ) |

Create log file in directory KLogsdir\KWapLogsDirName - Note: ingore Drive and Path of aFilename.

IMPORT_C void THttpLogger::DumpIt ( const TDesC8 & aData )

Do a formatted dump of binary data.

IMPORT_C void THttpLogger::LogIt | ( | TRefByValue< const TDesC > | aFmt,
 |  | ... |
 | ) |

virtual IMPORT_C void THttpLogger::Overflow ( TDes & aDes ) [private, virtual]

IMPORT_C void THttpLogger::WriteComment ( const TDesC8 & aData )

Do a write of the supplied 8 bit data.

IMPORT_C void THttpLogger::WriteComment ( const TDesC & aComment )

Writes aComment to test log file, logging file and test harness.

Member Data Documentation

RFileLogger THttpLogger::iLogger [private]

Logger handle.

Definition at line 63 of file httplogger.h.

The documentation for this class was generated from the following file:
  • httplogger.h


Member List

THttpLogger Member List

This is the complete list of members for THttpLogger, including all inherited members.
CreateFlogger(const TDesC &aFileName, TInt aShowDate, TInt aShowTime) | THttpLogger |
DumpIt(const TDesC8 &aData) | THttpLogger |
iLogger | THttpLogger | [private]
LogIt(TRefByValue< const TDesC > aFmt,...) | THttpLogger |
Overflow(TDes &aDes) | THttpLogger | [private, virtual]
WriteComment(const TDesC &aComment) | THttpLogger |
WriteComment(const TDesC8 &aData) | THttpLogger |
~THttpLogger() | THttpLogger | [virtual]


HTTPPanic Class Reference

#include <httperr.h>

List of all members.

Public Types

enum THTTPPanic {
ESessionAlreadyOpen, EHeaderFieldMissing, EHeaderParamMissing, EHeaderInvalidPart,
EHeaderInvalidType, ETransactionEventOutstanding, ETransactionUnhandledError, EAddingFilterWithOutstandingTransactions,
EFilterInvalidPosition, EHTTPFormDataUnreleased, EHTTPFormSupplyingData, EValidationFilterFailure,
EInvalidTxData, EInvalidRxData, ENoTransportHandlerSet, EAuthenticationFilterBadState,
EInvalidFilterHandle
}

Static Public Methods

void Panic (THTTPPanic aPanic)

Member Enumeration Documentation

enum HTTPPanic::THTTPPanic

Enumeration values:
ESessionAlreadyOpen
EHeaderFieldMissing
EHeaderParamMissing
EHeaderInvalidPart
EHeaderInvalidType
ETransactionEventOutstanding
ETransactionUnhandledError
EAddingFilterWithOutstandingTransactions
EFilterInvalidPosition
EHTTPFormDataUnreleased
EHTTPFormSupplyingData
EValidationFilterFailure
EInvalidTxData
EInvalidRxData
ENoTransportHandlerSet
EAuthenticationFilterBadState
EInvalidFilterHandle

Definition at line 107 of file httperr.h.

Member Function Documentation

void HTTPPanic::Panic ( THTTPPanic aPanic ) [static]

The documentation for this class was generated from the following file:
  • httperr.h


Member List

HTTPPanic Member List

This is the complete list of members for HTTPPanic, including all inherited members.
EAddingFilterWithOutstandingTransactions enum value | HTTPPanic |
EAuthenticationFilterBadState enum value | HTTPPanic |
EFilterInvalidPosition enum value | HTTPPanic |
EHeaderFieldMissing enum value | HTTPPanic |
EHeaderInvalidPart enum value | HTTPPanic |
EHeaderInvalidType enum value | HTTPPanic |
EHeaderParamMissing enum value | HTTPPanic |
EHTTPFormDataUnreleased enum value | HTTPPanic |
EHTTPFormSupplyingData enum value | HTTPPanic |
EInvalidFilterHandle enum value | HTTPPanic |
EInvalidRxData enum value | HTTPPanic |
EInvalidTxData enum value | HTTPPanic |
ENoTransportHandlerSet enum value | HTTPPanic |
ESessionAlreadyOpen enum value | HTTPPanic |
ETransactionEventOutstanding enum value | HTTPPanic |
ETransactionUnhandledError enum value | HTTPPanic |
EValidationFilterFailure enum value | HTTPPanic |
Panic(THTTPPanic aPanic) | HTTPPanic | [static]
THTTPPanic enum name | HTTPPanic |


CHttpSocket Class Reference

CHttpSocket is an abstraction of a socket. More...

#include <chttpsocket.h>

Collaboration diagram for CHttpSocket:

[legend]
List of all members.

Public Methods

~CHttpSocket ()
TBool | IsOpen ()
TInt | Open (RSocketServ &aServer, TUint addrFamily, TUint sockType, TUint protocol, RConnection &aConnection)
void | Close ()
void | SetRemoteClose ()
void | Connect (TSockAddr &anAddr, TRequestStatus &aStatus)
void | CancelConnect ()
void | Write (const TDesC8 &aDesc, TRequestStatus &aStatus)
void | CancelWrite ()
void | RecvOneOrMore (TDes8 &aDesc, TUint flags, TRequestStatus &aStatus, TSockXfrLength &aLen)
void | Recv (TDes8 &aDesc, TUint flags, TRequestStatus &aStatus, TSockXfrLength &aLen)
void | Read (TDes8 &aDesc, TRequestStatus &aStatus)
void | CancelRecv ()
TBool | IsDisconnected ()
TBool | IsSecure () const
void | GoSecureL (TRequestStatus &aStatus, const TDesC8 &aDomainName)
TInt | ServerCert (TCertInfo &aServerCert)
Get the Server Certificate for this socket session.

void | GetCertInfoL (const CX509Certificate &aSource, TCertInfo &aDest)
void | GetDNInfo (const CX500DistinguishedName &aSource, TDNInfo &aDest)

Static Public Methods

CHttpSocket * | NewL (MSecurityPolicy *aSecurityPolicy, TSecureDialogPref aPref)

Private Methods

CHttpSocket (MSecurityPolicy *aSecurityPolicy, TSecureDialogPref aPref)

Private Attributes

CSecureSocket * | iTlsSocket
RSocket | iSocket
TBool | iIsSocketOpen
MSecurityPolicy * iSecurityPolicy
TSecureDialogPref iSecureDialogPref

Detailed Description

CHttpSocket is an abstraction of a socket.

It acts as a common interface to either an RSocket or CSecureSocket depending on the type and progress of a connection.

Definition at line 27 of file chttpsocket.h.

Constructor & Destructor Documentation

CHttpSocket::~CHttpSocket ( )

CHttpSocket::CHttpSocket | ( | MSecurityPolicy * | aSecurityPolicy,
 |  | TSecureDialogPref | aPref
 | ) | [private]

Member Function Documentation

void CHttpSocket::CancelConnect ( )

void CHttpSocket::CancelRecv ( )

void CHttpSocket::CancelWrite ( )

void CHttpSocket::Close ( )

void CHttpSocket::Connect | ( | TSockAddr & | anAddr,
 |  | TRequestStatus & | aStatus
 | ) |

void CHttpSocket::GetCertInfoL | ( | const CX509Certificate & | aSource,
 |  | TCertInfo & | aDest
 | ) |

void CHttpSocket::GetDNInfo | ( | const CX500DistinguishedName & | aSource,
 |  | TDNInfo & | aDest
 | ) |

void CHttpSocket::GoSecureL | ( | TRequestStatus & | aStatus,
 |  | const TDesC8 & | aDomainName
 | ) |

TBool CHttpSocket::IsDisconnected ( )

TBool CHttpSocket::IsOpen ( ) [inline]

Definition at line 100 of file chttpsocket.h.

References iIsSocketOpen.

TBool CHttpSocket::IsSecure ( )

CHttpSocket* CHttpSocket::NewL | ( | MSecurityPolicy * | aSecurityPolicy,
 |  | TSecureDialogPref | aPref
 | ) | [static]

TInt CHttpSocket::Open | ( | RSocketServ & | aServer,
 |  | TUint | addrFamily,
 |  | TUint | sockType,
 |  | TUint | protocol,
 |  | RConnection & | aConnection
 | ) |

void CHttpSocket::Read | ( | TDes8 & | aDesc,
 |  | TRequestStatus & | aStatus
 | ) |

void CHttpSocket::Recv | ( | TDes8 & | aDesc,
 |  | TUint | flags,
 |  | TRequestStatus & | aStatus,
 |  | TSockXfrLength & | aLen
 | ) |

void CHttpSocket::RecvOneOrMore | ( | TDes8 & | aDesc,
 |  | TUint | flags,
 |  | TRequestStatus & | aStatus,
 |  | TSockXfrLength & | aLen
 | ) |

TInt CHttpSocket::ServerCert ( TCertInfo & aServerCert )

Get the Server Certificate for this socket session.

Parameters:
aServerCert A TCertInfo which will be filled with the certificate information
Returns:
An error code. KErrNone if aServerCert has been completed, otherwise one of the system wide error codes

void CHttpSocket::SetRemoteClose ( ) [inline]

Definition at line 105 of file chttpsocket.h.

References iIsSocketOpen, and iTlsSocket.

void CHttpSocket::Write | ( | const TDesC8 & | aDesc,
 |  | TRequestStatus & | aStatus
 | ) |

Member Data Documentation

TBool CHttpSocket::iIsSocketOpen [private]

Definition at line 91 of file chttpsocket.h.

Referenced by IsOpen(), and SetRemoteClose().

TSecureDialogPref CHttpSocket::iSecureDialogPref [private]

Definition at line 97 of file chttpsocket.h.

MSecurityPolicy* CHttpSocket::iSecurityPolicy [private]

Definition at line 94 of file chttpsocket.h.

RSocket CHttpSocket::iSocket [private]

Definition at line 89 of file chttpsocket.h.

CSecureSocket* CHttpSocket::iTlsSocket [private]

Definition at line 86 of file chttpsocket.h.

Referenced by SetRemoteClose().

The documentation for this class was generated from the following file:
  • chttpsocket.h


Member List

CHttpSocket Member List

This is the complete list of members for CHttpSocket, including all inherited members.
CancelConnect() | CHttpSocket |
CancelRecv() | CHttpSocket |
CancelWrite() | CHttpSocket |
CHttpSocket(MSecurityPolicy *aSecurityPolicy, TSecureDialogPref aPref) | CHttpSocket | [private]
Close() | CHttpSocket |
Connect(TSockAddr &anAddr, TRequestStatus &aStatus) | CHttpSocket |
GetCertInfoL(const CX509Certificate &aSource, TCertInfo &aDest) | CHttpSocket |
GetDNInfo(const CX500DistinguishedName &aSource, TDNInfo &aDest) | CHttpSocket |
GoSecureL(TRequestStatus &aStatus, const TDesC8 &aDomainName) | CHttpSocket |
iIsSocketOpen | CHttpSocket | [private]
IsDisconnected() | CHttpSocket |
iSecureDialogPref | CHttpSocket | [private]
iSecurityPolicy | CHttpSocket | [private]
iSocket | CHttpSocket | [private]
IsOpen() | CHttpSocket | [inline]
IsSecure() const | CHttpSocket |
iTlsSocket | CHttpSocket | [private]
NewL(MSecurityPolicy *aSecurityPolicy, TSecureDialogPref aPref) | CHttpSocket | [static]
Open(RSocketServ &aServer, TUint addrFamily, TUint sockType, TUint protocol, RConnection &aConnection) | CHttpSocket |
Read(TDes8 &aDesc, TRequestStatus &aStatus) | CHttpSocket |
Recv(TDes8 &aDesc, TUint flags, TRequestStatus &aStatus, TSockXfrLength &aLen) | CHttpSocket |
RecvOneOrMore(TDes8 &aDesc, TUint flags, TRequestStatus &aStatus, TSockXfrLength &aLen) | CHttpSocket |
ServerCert(TCertInfo &aServerCert) | CHttpSocket |
SetRemoteClose() | CHttpSocket | [inline]
Write(const TDesC8 &aDesc, TRequestStatus &aStatus) | CHttpSocket |
~CHttpSocket() | CHttpSocket |


MHttpSocketObserver Class Reference

MHttpSocketObserver is the interface used by the socket read and write active objects to call back to the transport handler when a read or write has completed. More...

#include <MTcpSocketObserver.h>

Inheritance diagram for MHttpSocketObserver:

[legend]
List of all members.

Public Methods

virtual void | WriteCompletedL (TInt aErrorCode)=0
Signal back to the observer that a socket write has completed.

virtual void | ReadCompletedL (TInt aErrorCode)=0
Signal back to the observer that a socket read has completed.

Detailed Description

MHttpSocketObserver is the interface used by the socket read and write active objects to call back to the transport handler when a read or write has completed.

Definition at line 14 of file MTcpSocketObserver.h.

Member Function Documentation

virtual void MHttpSocketObserver::ReadCompletedL ( TInt aErrorCode ) [pure virtual]

Signal back to the observer that a socket read has completed.

Implemented in CHttpTcpClient.

virtual void MHttpSocketObserver::WriteCompletedL ( TInt aErrorCode ) [pure virtual]

Signal back to the observer that a socket write has completed.

Implemented in CHttpTcpClient.

The documentation for this class was generated from the following file:
  • MTcpSocketObserver.h


Member List

MHttpSocketObserver Member List

This is the complete list of members for MHttpSocketObserver, including all inherited members.
ReadCompletedL(TInt aErrorCode)=0 | MHttpSocketObserver | [pure virtual]
WriteCompletedL(TInt aErrorCode)=0 | MHttpSocketObserver | [pure virtual]


HTTPStatus Class Reference

@public
Since:
7.0 The complete set of HTTP Status codes, as defined in RFC2616.
More...

#include <httperr.h>

List of all members.

Public Types

enum {
EContinue = 100, ESwitchingProtocols = 101, EOk = 200, ECreated = 201,
EAccepted = 202, ENonAuthoritativeInfo = 203, ENoContent = 204, EResetContent = 205,
EPartialContent = 206, EMultipleChoices = 300, EMovedPermanently = 301, EFound = 302,
ESeeOther = 303, ENotModified = 304, EUseProxy = 305, EUnused = 306,
ETemporaryRedirect = 307, EBadRequest = 400, EUnauthorized = 401, EPaymentRequired = 402,
EForbidden = 403, ENotFound = 404, EMethodNotAllowed = 405, ENotAcceptable = 406,
EProxyAuthenticationRequired = 407, ERequestTimeout = 408, EConflict = 409, EGone = 410,
ELengthRequired = 411, EPreconditionFailed = 412, ERequestEntityTooLarge = 413, ERequestURITooLong = 414,
EUnsupportedMediaType = 415, ERequestedRangeNotSatisfiable = 416, EExpectationFailed = 417, EInternalServerError = 500,
ENotImplemented = 501, EBadGateway = 502, EServiceUnavailable = 503, EGatewayTimeout = 504,
EHTTPVersionNotSupported = 505
}

Static Public Methods

TBool | IsInformational (TInt aStatus)
Is the supplied status code in the 1xx Informational range?

TBool | IsSuccessful (TInt aStatus)
Is the supplied status code in the 2xx Successful range?

TBool | IsRedirection (TInt aStatus)
Is the supplied status code in the 3xx Redirection range?

TBool | IsClientError (TInt aStatus)
Is the supplied status code in the 4xx Client Error range?

TBool | IsServerError (TInt aStatus)
Is the supplied status code in the 5xx Server Error range?

Detailed Description

@public
Since:
7.0 The complete set of HTTP Status codes, as defined in RFC2616.

Definition at line 25 of file httperr.h.

Member Enumeration Documentation

anonymous enum

Enumeration values:
EContinue | 'Informational' range of codes 1xx
ESwitchingProtocols
EOk | 'Successful' range of codes 2xx
ECreated
EAccepted
ENonAuthoritativeInfo
ENoContent
EResetContent
EPartialContent
EMultipleChoices | 'Redirection' range of codes 3xx
EMovedPermanently
EFound
ESeeOther
ENotModified
EUseProxy
EUnused
ETemporaryRedirect
EBadRequest | 'Client Error' range of codes 4xx
EUnauthorized
EPaymentRequired
EForbidden
ENotFound
EMethodNotAllowed
ENotAcceptable
EProxyAuthenticationRequired
ERequestTimeout
EConflict
EGone
ELengthRequired
EPreconditionFailed
ERequestEntityTooLarge
ERequestURITooLong
EUnsupportedMediaType
ERequestedRangeNotSatisfiable
EExpectationFailed
EInternalServerError | 'Server Error' range of codes 5xx
ENotImplemented
EBadGateway
EServiceUnavailable
EGatewayTimeout
EHTTPVersionNotSupported

Definition at line 28 of file httperr.h.

Member Function Documentation

TBool HTTPStatus::IsClientError ( TInt aStatus ) [inline, static]

Is the supplied status code in the 4xx Client Error range?

Definition at line 243 of file httperr.h.

References EBadRequest, and EInternalServerError.

TBool HTTPStatus::IsInformational ( TInt aStatus ) [inline, static]

Is the supplied status code in the 1xx Informational range?

Definition at line 231 of file httperr.h.

References EContinue, and EOk.

TBool HTTPStatus::IsRedirection ( TInt aStatus ) [inline, static]

Is the supplied status code in the 3xx Redirection range?

Definition at line 239 of file httperr.h.

References EBadRequest, and EMultipleChoices.

TBool HTTPStatus::IsServerError ( TInt aStatus ) [inline, static]

Is the supplied status code in the 5xx Server Error range?

Definition at line 247 of file httperr.h.

References EInternalServerError.

TBool HTTPStatus::IsSuccessful ( TInt aStatus ) [inline, static]

Is the supplied status code in the 2xx Successful range?

Definition at line 235 of file httperr.h.

References EMultipleChoices, and EOk.

The documentation for this class was generated from the following file:
  • httperr.h


Member List

HTTPStatus Member List

This is the complete list of members for HTTPStatus, including all inherited members.
EAccepted enum value | HTTPStatus |
EBadGateway enum value | HTTPStatus |
EBadRequest enum value | HTTPStatus |
EConflict enum value | HTTPStatus |
EContinue enum value | HTTPStatus |
ECreated enum value | HTTPStatus |
EExpectationFailed enum value | HTTPStatus |
EForbidden enum value | HTTPStatus |
EFound enum value | HTTPStatus |
EGatewayTimeout enum value | HTTPStatus |
EGone enum value | HTTPStatus |
EHTTPVersionNotSupported enum value | HTTPStatus |
EInternalServerError enum value | HTTPStatus |
ELengthRequired enum value | HTTPStatus |
EMethodNotAllowed enum value | HTTPStatus |
EMovedPermanently enum value | HTTPStatus |
EMultipleChoices enum value | HTTPStatus |
ENoContent enum value | HTTPStatus |
ENonAuthoritativeInfo enum value | HTTPStatus |
ENotAcceptable enum value | HTTPStatus |
ENotFound enum value | HTTPStatus |
ENotImplemented enum value | HTTPStatus |
ENotModified enum value | HTTPStatus |
EOk enum value | HTTPStatus |
EPartialContent enum value | HTTPStatus |
EPaymentRequired enum value | HTTPStatus |
EPreconditionFailed enum value | HTTPStatus |
EProxyAuthenticationRequired enum value | HTTPStatus |
ERequestedRangeNotSatisfiable enum value | HTTPStatus |
ERequestEntityTooLarge enum value | HTTPStatus |
ERequestTimeout enum value | HTTPStatus |
ERequestURITooLong enum value | HTTPStatus |
EResetContent enum value | HTTPStatus |
ESeeOther enum value | HTTPStatus |
EServiceUnavailable enum value | HTTPStatus |
ESwitchingProtocols enum value | HTTPStatus |
ETemporaryRedirect enum value | HTTPStatus |
EUnauthorized enum value | HTTPStatus |
EUnsupportedMediaType enum value | HTTPStatus |
EUnused enum value | HTTPStatus |
EUseProxy enum value | HTTPStatus |
IsClientError(TInt aStatus) | HTTPStatus | [inline, static]
IsInformational(TInt aStatus) | HTTPStatus | [inline, static]
IsRedirection(TInt aStatus) | HTTPStatus | [inline, static]
IsServerError(TInt aStatus) | HTTPStatus | [inline, static]
IsSuccessful(TInt aStatus) | HTTPStatus | [inline, static]


CHttpTcpClient Class Reference

The TCP client class is a dedicated client end-point for TCP comms with one particular HTTP origin server or proxy server. More...

#include <CHttpTcpCli.h>

Inheritance diagram for CHttpTcpClient:

[legend]
Collaboration diagram for CHttpTcpClient:

[legend]
List of all members.

Public Methods

virtual void | Close ()
Close is called when the protocol handler has finished with the text mode transport handler.

virtual TServerConnectionStatus | Status () const
Status returns an indication which can be used to decide if more submissions should be made using this instantiation of a MTextModeTransportHandler.

virtual const CHttpTcpServerLocation & | ServerLocation () const
Returns the location that the protocol is currently or was last connected to.

virtual | ~CHttpTcpClient ()
Destructor - cleans up and releases resources to the system.

virtual void | SubmitL (CHttpTcpServerLocation *aServerLocation, CTxData &aData, MTransportHndObs &aObs)
Allows the caller to submit a new transaction by supplying an over-the-air representation of the HTTP request.

virtual void | CancelSubmission (CTxData &aDataToCancel)
Cancel a prior submission of transmission data.

virtual void | AckData ()
Acknowledge the receipt of response data, to allow the TCP Client to continue fetching further data from the origin/proxy server.

virtual void | NotifyRequestDataAvailable ()
Provide notification that new request data is available for transmission.

virtual TInt | ServerCert (TCertInfo &aServerCert)
Get the Server Certificate from the socket.

Static Public Methods

CHttpTcpClient * | NewL (MSecurityPolicy *aSecurityPolicy, MSessionPropertiesProvider &aSessionPropertiesProvider, RSocketServ &aSocketServ, RConnection &aConnection)
Factory construction - creates a new TCP client.

Protected Methods

virtual void | RunL ()
Do some processing when a previous asynch request made by this object has completed.

virtual TInt | RunError (TInt aError)
Do any cleanup required should RunL leave.

virtual void | DoCancel ()
Cancel outstanding asynchronous requests that this object has made.

Private Types

enum THttpState {
EDisconnected, EReadyForDNS, EAwaitingDNS, EReadyToConnect,
EMadeCONNECT, EDoSecureHandshake, EConnected, EPendingRequest,
ERequesting, EPendingReply, EReplying, EPendingAck,
EIdleListening, EIdle
}
The state machine for the TCP Client is based on the states enumerated in THttpState. More...

Private Methods

CHttpTcpClient (TInt aPriority, MSecurityPolicy *aSecurityPolicy, RSocketServ &aSocketServ, RConnection &aConnection)
Normal constructor, setting the active object to the supplied priority.

void | ConstructL (MSessionPropertiesProvider &aSessionPropertiesProvider)
Second phase construction; does any required allocation.

void | LeaveOnRequestErrL ()
Leaves if this active object's most recent request completed with an error condition.

void | CompleteSelf ()
Advance the state machine advances without making an asychronous request, by completing 'self'.

void | DetermineNextState ()
Determine the next action when completing processing following EOF in EReplying state or after an error has occured.

void | ReadCompletedL (TInt aErrorCode)
Signal back to the observer that a socket read has completed.

void | WriteCompletedL (TInt aErrorCode)
Signal back to the observer that a socket write has completed.

void | SubmitDataToObserverL ()

Static Private Methods

void | Panic (TTcpCliPanicCode aPanic)

Private Attributes

CSubmissionDetails * iActiveSubmission
The submission we are currently dealing with.

TBool | iTxLastChunk
Flag set to record that there are no further chunks of transmission data to send.

THttpState iTransmissionState
Our present state.

RSocketServ & | iSockSrvHnd
Handle to the system's socket server.

RConnection & | iConnHnd
CHttpSocket * iSocket
Wrapper for a socket.

RHostResolver | iDnsHnd
Handle to the system's DNS resolver.

TBool | iDnsHndOpen
Flag indicating that host resolver handle is open.

TNameEntry | iHostAddrDnsEntry
Representation of the host address as a DNS entry.

TInetAddr | iRemoteAddr
Representation of the remote server's address (be it the origin server or a proxy) following DNS resolution.

TSockXfrLength | iNumBytesRcvd
The number of bytes recieved in an asychronous socket read.

HBufC8 * | iRecvBuffer
The buffer in which received data is written by the socket server.

TPtr8 | iRecvBufferPtr
A writable descriptor pointing at our receive buffer.

TPtrC8 | iSendBuffer
A non-writable descriptor pointing at the transmission buffer (which is owned by our caller).

CHttpTcpServerLocation * iLastServerLocation
CHttpTcpReader * iSocketReader
CHttpTcpWriter * iSocketWriter
CHttpConnector * iHttpConnector
__DECLARE_LOG MSecurityPolicy * | iSecurityPolicy
HTTP logger handle, debug only.

Detailed Description

The TCP client class is a dedicated client end-point for TCP comms with one particular HTTP origin server or proxy server.

It owns a single socket connection which will be reused for each transaction made with that server. The socket may remain connected for several transactions if the TCP Client is constructed as 'persistent'.Otherwise it will be closed at the end of a transaction and reopened for the next.

Transmission data is streamed in using the CTxData class. Received data is streamed out via the MTransportHndObs observer interface. Each 'chunk' streamed out must be acknowledged by the observer before the TCP client can continue to extract more data from the server.

This class also takes care of socket server connection and DNS lookups for the server you are connecting to

The TCP Client class can queue CTxData objects to serialise requests to the same server over a persistent connection. Should pipelining support be required this class would be the right place to implement it.

See also:
CTxData , MTransportHndObs

Definition at line 64 of file CHttpTcpCli.h.

Member Enumeration Documentation

enum CHttpTcpClient::THttpState [private]

The state machine for the TCP Client is based on the states enumerated in THttpState.

Enumeration values:
EDisconnected | the initial state following construction in which there is no connection
EReadyForDNS | the state in which a DNS lookup on the host address
EAwaitingDNS | the state following a request to do a DNS lookup on the host address
EReadyToConnect | the state in which the socket connection is made to the host address
EMadeCONNECT | the state in which the CONNECT has been made via a proxy to a secure host
EDoSecureHandshake | the state in which a secure handshake is made with the origin server, if secure
EConnected | the state following a successful connection, in which the first HTTP request chunk is submitted
EPendingRequest | the state in which the TCP client waits for the data supplier to generate further request body data,
ERequesting | the state in which subsequent chunks of the HTTP request are submitted,
EPendingReply | the state in which attempts are made to read the HTTP response from the socket
EReplying | the state where response reads have completed and data is sent to the TCP client observer
EPendingAck | the state after sending response data where we await acknowledgment before continuing
EIdleListening | an idle state where a response has completed but the socket connection has been left open
EIdle | an idle state where a response has completed and the socket connection was closed

Definition at line 132 of file CHttpTcpCli.h.

Constructor & Destructor Documentation

virtual CHttpTcpClient::~CHttpTcpClient ( ) [virtual]

Destructor - cleans up and releases resources to the system.

CHttpTcpClient::CHttpTcpClient | ( | TInt | aPriority,
 |  | MSecurityPolicy * | aSecurityPolicy,
 |  | RSocketServ & | aSocketServ,
 |  | RConnection & | aConnection
 | ) | [private]

Normal constructor, setting the active object to the supplied priority.

Member Function Documentation

virtual void CHttpTcpClient::AckData ( ) [virtual]

Acknowledge the receipt of response data, to allow the TCP Client to continue fetching further data from the origin/proxy server.

Implements MTextModeTransportHandler.

virtual void CHttpTcpClient::CancelSubmission ( CTxData & aDataToCancel ) [virtual]

Cancel a prior submission of transmission data.

It will be removed from the internal queue. If it is currently active the transmission will be cancelled and the next queued transmission started.

Implements MTextModeTransportHandler.

virtual void CHttpTcpClient::Close ( ) [virtual]

Close is called when the protocol handler has finished with the text mode transport handler.

Implements MTextModeTransportHandler.

void CHttpTcpClient::CompleteSelf ( ) [private]

Advance the state machine advances without making an asychronous request, by completing 'self'.

void CHttpTcpClient::ConstructL ( MSessionPropertiesProvider & aSessionPropertiesProvider ) [private]

Second phase construction; does any required allocation.

void CHttpTcpClient::DetermineNextState ( ) [private]

Determine the next action when completing processing following EOF in EReplying state or after an error has occured.

virtual void CHttpTcpClient::DoCancel ( ) [protected, virtual]

Cancel outstanding asynchronous requests that this object has made.

void CHttpTcpClient::LeaveOnRequestErrL ( ) [private]

Leaves if this active object's most recent request completed with an error condition.

CHttpTcpClient* CHttpTcpClient::NewL | ( | MSecurityPolicy * | aSecurityPolicy,
 |  | MSessionPropertiesProvider & | aSessionPropertiesProvider,
 |  | RSocketServ & | aSocketServ,
 |  | RConnection & | aConnection
 | ) | [static]

Factory construction - creates a new TCP client.

virtual void CHttpTcpClient::NotifyRequestDataAvailable ( ) [virtual]

Provide notification that new request data is available for transmission.

Used to unblock the protocol in which request data is transmitted.

Implements MTextModeTransportHandler.

void CHttpTcpClient::Panic ( TTcpCliPanicCode aPanic ) [static, private]

void CHttpTcpClient::ReadCompletedL ( TInt aErrorCode ) [private, virtual]

Signal back to the observer that a socket read has completed.

Implements MHttpSocketObserver.

virtual TInt CHttpTcpClient::RunError ( TInt aError ) [protected, virtual]

Do any cleanup required should RunL leave.

virtual void CHttpTcpClient::RunL ( ) [protected, virtual]

Do some processing when a previous asynch request made by this object has completed.

virtual TInt CHttpTcpClient::ServerCert ( TCertInfo & aServerCert ) [virtual]

Get the Server Certificate from the socket.

Parameters:
aServerCert A TCertInfo which will be filled with the certificate information
Returns:
An error code. KErrNone if aServerCert has been completed, otherwise one of the system wide error codes

Implements MTextModeTransportHandler.

virtual const CHttpTcpServerLocation& CHttpTcpClient::ServerLocation ( ) [virtual]

Returns the location that the protocol is currently or was last connected to.

@panic If called when not status is ENotConnected

Implements MTextModeTransportHandler.

virtual TServerConnectionStatus CHttpTcpClient::Status ( ) [virtual]

Status returns an indication which can be used to decide if more submissions should be made using this instantiation of a MTextModeTransportHandler.

Implements MTextModeTransportHandler.

void CHttpTcpClient::SubmitDataToObserverL ( ) [private]

virtual void CHttpTcpClient::SubmitL | ( | CHttpTcpServerLocation * | aServerLocation,
 |  | CTxData & | aData,
 |  | MTransportHndObs & | aObs
 | ) | [virtual]

Allows the caller to submit a new transaction by supplying an over-the-air representation of the HTTP request.

The client supplies the host address and port, and also an observer which is invoked when response data is received or to send status messages. The flag indicates whether a persistent connection should be maintained (to be used only in HTTP/1.1 mode).

Implements MTextModeTransportHandler.

void CHttpTcpClient::WriteCompletedL ( TInt aErrorCode ) [private, virtual]

Signal back to the observer that a socket write has completed.

Implements MHttpSocketObserver.

Member Data Documentation

CSubmissionDetails* CHttpTcpClient::iActiveSubmission [private]

The submission we are currently dealing with.

Definition at line 188 of file CHttpTcpCli.h.

RConnection& CHttpTcpClient::iConnHnd [private]

Definition at line 203 of file CHttpTcpCli.h.

RHostResolver CHttpTcpClient::iDnsHnd [private]

Handle to the system's DNS resolver.

Definition at line 211 of file CHttpTcpCli.h.

TBool CHttpTcpClient::iDnsHndOpen [private]

Flag indicating that host resolver handle is open.

Definition at line 215 of file CHttpTcpCli.h.

TNameEntry CHttpTcpClient::iHostAddrDnsEntry [private]

Representation of the host address as a DNS entry.

Definition at line 219 of file CHttpTcpCli.h.

CHttpConnector* CHttpTcpClient::iHttpConnector [private]

Definition at line 254 of file CHttpTcpCli.h.

CHttpTcpServerLocation* CHttpTcpClient::iLastServerLocation [private]

Definition at line 247 of file CHttpTcpCli.h.

TSockXfrLength CHttpTcpClient::iNumBytesRcvd [private]

The number of bytes recieved in an asychronous socket read.

This is directly written into by the socket server

Definition at line 228 of file CHttpTcpCli.h.

HBufC8* CHttpTcpClient::iRecvBuffer [private]

The buffer in which received data is written by the socket server.

This buffer should be used throughout the HTTP Client in order to avoid copying; hence the need for acknowledgment

Definition at line 233 of file CHttpTcpCli.h.

TPtr8 CHttpTcpClient::iRecvBufferPtr [private]

A writable descriptor pointing at our receive buffer.

Definition at line 237 of file CHttpTcpCli.h.

TInetAddr CHttpTcpClient::iRemoteAddr [private]

Representation of the remote server's address (be it the origin server or a proxy) following DNS resolution.

Definition at line 223 of file CHttpTcpCli.h.

__DECLARE_LOG MSecurityPolicy* CHttpTcpClient::iSecurityPolicy [private]

HTTP logger handle, debug only.

Definition at line 260 of file CHttpTcpCli.h.

TPtrC8 CHttpTcpClient::iSendBuffer [private]

A non-writable descriptor pointing at the transmission buffer (which is owned by our caller).

Definition at line 241 of file CHttpTcpCli.h.

CHttpSocket* CHttpTcpClient::iSocket [private]

Wrapper for a socket.

Definition at line 207 of file CHttpTcpCli.h.

CHttpTcpReader* CHttpTcpClient::iSocketReader [private]

Definition at line 250 of file CHttpTcpCli.h.

CHttpTcpWriter* CHttpTcpClient::iSocketWriter [private]

Definition at line 252 of file CHttpTcpCli.h.

RSocketServ& CHttpTcpClient::iSockSrvHnd [private]

Handle to the system's socket server.

Definition at line 200 of file CHttpTcpCli.h.

THttpState CHttpTcpClient::iTransmissionState [private]

Our present state.

Definition at line 196 of file CHttpTcpCli.h.

TBool CHttpTcpClient::iTxLastChunk [private]

Flag set to record that there are no further chunks of transmission data to send.

Definition at line 192 of file CHttpTcpCli.h.

The documentation for this class was generated from the following file:
  • CHttpTcpCli.h


Member List

CHttpTcpClient Member List

This is the complete list of members for CHttpTcpClient, including all inherited members.
AckData() | CHttpTcpClient | [virtual]
CancelSubmission(CTxData &aDataToCancel) | CHttpTcpClient | [virtual]
CHttpTcpClient(TInt aPriority, MSecurityPolicy *aSecurityPolicy, RSocketServ &aSocketServ, RConnection &aConnection) | CHttpTcpClient | [private]
Close() | CHttpTcpClient | [virtual]
CompleteSelf() | CHttpTcpClient | [private]
ConstructL(MSessionPropertiesProvider &aSessionPropertiesProvider) | CHttpTcpClient | [private]
DetermineNextState() | CHttpTcpClient | [private]
DoCancel() | CHttpTcpClient | [protected, virtual]
EAwaitingDNS enum value | CHttpTcpClient | [private]
EConnected enum value | CHttpTcpClient | [private]
EConnectedAndAvailable enum value | MTextModeTransportHandler |
EConnectedNotAvailable enum value | MTextModeTransportHandler |
EDisconnected enum value | CHttpTcpClient | [private]
EDoSecureHandshake enum value | CHttpTcpClient | [private]
EIdle enum value | CHttpTcpClient | [private]
EIdleListening enum value | CHttpTcpClient | [private]
EMadeCONNECT enum value | CHttpTcpClient | [private]
ENotConnected enum value | MTextModeTransportHandler |
EPendingAck enum value | CHttpTcpClient | [private]
EPendingReply enum value | CHttpTcpClient | [private]
EPendingRequest enum value | CHttpTcpClient | [private]
EReadyForDNS enum value | CHttpTcpClient | [private]
EReadyToConnect enum value | CHttpTcpClient | [private]
EReplying enum value | CHttpTcpClient | [private]
ERequesting enum value | CHttpTcpClient | [private]
iActiveSubmission | CHttpTcpClient | [private]
iConnHnd | CHttpTcpClient | [private]
iDnsHnd | CHttpTcpClient | [private]
iDnsHndOpen | CHttpTcpClient | [private]
iHostAddrDnsEntry | CHttpTcpClient | [private]
iHttpConnector | CHttpTcpClient | [private]
iLastServerLocation | CHttpTcpClient | [private]
iNumBytesRcvd | CHttpTcpClient | [private]
iRecvBuffer | CHttpTcpClient | [private]
iRecvBufferPtr | CHttpTcpClient | [private]
iRemoteAddr | CHttpTcpClient | [private]
iSecurityPolicy | CHttpTcpClient | [private]
iSendBuffer | CHttpTcpClient | [private]
iSocket | CHttpTcpClient | [private]
iSocketReader | CHttpTcpClient | [private]
iSocketWriter | CHttpTcpClient | [private]
iSockSrvHnd | CHttpTcpClient | [private]
iTransmissionState | CHttpTcpClient | [private]
iTxLastChunk | CHttpTcpClient | [private]
LeaveOnRequestErrL() | CHttpTcpClient | [private]
NewL(MSecurityPolicy *aSecurityPolicy, MSessionPropertiesProvider &aSessionPropertiesProvider, RSocketServ &aSocketServ, RConnection &aConnection) | CHttpTcpClient | [static]
NotifyRequestDataAvailable() | CHttpTcpClient | [virtual]
Panic(TTcpCliPanicCode aPanic) | CHttpTcpClient | [private, static]
ReadCompletedL(TInt aErrorCode) | CHttpTcpClient | [private, virtual]
RunError(TInt aError) | CHttpTcpClient | [protected, virtual]
RunL() | CHttpTcpClient | [protected, virtual]
ServerCert(TCertInfo &aServerCert) | CHttpTcpClient | [virtual]
ServerLocation() const | CHttpTcpClient | [virtual]
Status() const | CHttpTcpClient | [virtual]
SubmitDataToObserverL() | CHttpTcpClient | [private]
SubmitL(CHttpTcpServerLocation *aServerLocation, CTxData &aData, MTransportHndObs &aObs) | CHttpTcpClient | [virtual]
THttpState enum name | CHttpTcpClient | [private]
TServerConnectionStatus enum name | MTextModeTransportHandler |
WriteCompletedL(TInt aErrorCode) | CHttpTcpClient | [private, virtual]
~CHttpTcpClient() | CHttpTcpClient | [virtual]


CHttpTcpReader Class Reference

Reads data from a CHttpSocket informing its observer when the read is completed. More...

#include <CHttpTcpReader.h>

Collaboration diagram for CHttpTcpReader:

[legend]
List of all members.

Public Methods

virtual | ~CHttpTcpReader ()
Destructor - cleans up and releases resources to the system.

void | RecvOneOrMore (TDes8 &aRecvBuffer, TSockXfrLength &aLen)

Static Public Methods

CHttpTcpReader * | NewL (CHttpSocket &aSocket, MHttpSocketObserver &aObserver)
Factory construction - creates a new TCP writer.

Protected Methods

virtual void | RunL ()
Do some processing when a previous asynch request made by this object has completed.

virtual TInt | RunError (TInt aError)
Do any cleanup required should RunL leave.

virtual void | DoCancel ()
Cancel outstanding asynchronous requests that this object has made.

Private Methods

CHttpTcpReader (CHttpSocket &aSocket, MHttpSocketObserver &aObserver)
Normal constructor which sets the active object priority to EPriorityStandard.

Private Attributes

CHttpSocket & iSocket
The socket which the data is to be read from.

MHttpSocketObserver & iObserver
The observer to be informed when the read is complete.

Detailed Description

Reads data from a CHttpSocket informing its observer when the read is completed.

Definition at line 17 of file CHttpTcpReader.h.

Constructor & Destructor Documentation

virtual CHttpTcpReader::~CHttpTcpReader ( ) [virtual]

Destructor - cleans up and releases resources to the system.

CHttpTcpReader::CHttpTcpReader | ( | CHttpSocket & | aSocket,
 |  | MHttpSocketObserver & | aObserver
 | ) | [private]

Normal constructor which sets the active object priority to EPriorityStandard.

Member Function Documentation

virtual void CHttpTcpReader::DoCancel ( ) [protected, virtual]

Cancel outstanding asynchronous requests that this object has made.

CHttpTcpReader* CHttpTcpReader::NewL | ( | CHttpSocket & | aSocket,
 |  | MHttpSocketObserver & | aObserver
 | ) | [static]

Factory construction - creates a new TCP writer.

void CHttpTcpReader::RecvOneOrMore | ( | TDes8 & | aRecvBuffer,
 |  | TSockXfrLength & | aLen
 | ) |

virtual TInt CHttpTcpReader::RunError ( TInt aError ) [protected, virtual]

Do any cleanup required should RunL leave.

virtual void CHttpTcpReader::RunL ( ) [protected, virtual]

Do some processing when a previous asynch request made by this object has completed.

Member Data Documentation

MHttpSocketObserver& CHttpTcpReader::iObserver [private]

The observer to be informed when the read is complete.

Definition at line 55 of file CHttpTcpReader.h.

CHttpSocket& CHttpTcpReader::iSocket [private]

The socket which the data is to be read from.

Definition at line 52 of file CHttpTcpReader.h.

The documentation for this class was generated from the following file:
  • CHttpTcpReader.h


Member List

CHttpTcpReader Member List

This is the complete list of members for CHttpTcpReader, including all inherited members.
CHttpTcpReader(CHttpSocket &aSocket, MHttpSocketObserver &aObserver) | CHttpTcpReader | [private]
DoCancel() | CHttpTcpReader | [protected, virtual]
iObserver | CHttpTcpReader | [private]
iSocket | CHttpTcpReader | [private]
NewL(CHttpSocket &aSocket, MHttpSocketObserver &aObserver) | CHttpTcpReader | [static]
RecvOneOrMore(TDes8 &aRecvBuffer, TSockXfrLength &aLen) | CHttpTcpReader |
RunError(TInt aError) | CHttpTcpReader | [protected, virtual]
RunL() | CHttpTcpReader | [protected, virtual]
~CHttpTcpReader() | CHttpTcpReader | [virtual]


CHttpTcpServerLocation Class Reference

#include <chttptcpserverlocation.h>

List of all members.

Public Methods

IMPORT_C | ~CHttpTcpServerLocation ()
IMPORT_C TBool | LocationMatches (const CHttpTcpServerLocation &aLocation) const
const TDesC & | HostAddress () const
const TDesC8 & | HostAddress8 () const
TUint | HostPort () const
TBool | IsPersistentConnection () const
void | SetPersistentConnection (TBool aIsPersistentConnection)
TBool | IsSecure () const
void | SetSecure (TBool aIsSecure)
TBool | UsesProxy () const
void | SetProxy (HBufC8 *aProxy, TUint aProxyPort)
const TDesC8 & | ProxiedHost () const
const TUint | ProxiedPort () const

Static Public Methods

IMPORT_C CHttpTcpServerLocation * | NewL (const TDesC &aHostAddress, TUint aHostPort)
Creates a new server location class.

Private Methods

void | ConstructL (const TDesC &aHostAddress)
CHttpTcpServerLocation (TUint aHostPort)

Private Attributes

HBufC * | iHostAddress
HBufC8 * | iHostAddress8
TUint | iHostPort
TBool | iPersistentConn
TBool | iIsSecure
HBufC8 * | iProxiedHost
TUint | iProxiedPort

Constructor & Destructor Documentation

IMPORT_C CHttpTcpServerLocation::~CHttpTcpServerLocation ( )

CHttpTcpServerLocation::CHttpTcpServerLocation ( TUint aHostPort ) [private]

Member Function Documentation

void CHttpTcpServerLocation::ConstructL ( const TDesC & aHostAddress ) [private]

const TDesC & CHttpTcpServerLocation::HostAddress ( ) [inline]

Definition at line 71 of file chttptcpserverlocation.h.

References iHostAddress.

const TDesC8 & CHttpTcpServerLocation::HostAddress8 ( ) [inline]

Definition at line 76 of file chttptcpserverlocation.h.

References iHostAddress8.

TUint CHttpTcpServerLocation::HostPort ( ) [inline]

Definition at line 81 of file chttptcpserverlocation.h.

References iHostPort.

TBool CHttpTcpServerLocation::IsPersistentConnection ( ) [inline]

Definition at line 86 of file chttptcpserverlocation.h.

References iPersistentConn.

TBool CHttpTcpServerLocation::IsSecure ( ) [inline]

Definition at line 96 of file chttptcpserverlocation.h.

References iIsSecure.

IMPORT_C TBool CHttpTcpServerLocation::LocationMatches ( const CHttpTcpServerLocation & aLocation ) const

IMPORT_C CHttpTcpServerLocation* CHttpTcpServerLocation::NewL | ( | const TDesC & | aHostAddress,
 |  | TUint | aHostPort
 | ) | [static]

Creates a new server location class.

This uniquely identfies a server and the type of connection that is being made to the server

Parameters:

const TDesC8 & CHttpTcpServerLocation::ProxiedHost ( ) [inline]

Definition at line 118 of file chttptcpserverlocation.h.

References iProxiedHost.

const TUint CHttpTcpServerLocation::ProxiedPort ( ) [inline]

Definition at line 124 of file chttptcpserverlocation.h.

References iProxiedHost, and iProxiedPort.

void CHttpTcpServerLocation::SetPersistentConnection ( TBool aIsPersistentConnection ) [inline]

Definition at line 91 of file chttptcpserverlocation.h.

References iPersistentConn.

void CHttpTcpServerLocation::SetProxy | ( | HBufC8 * | aProxy,
 |  | TUint | aProxyPort
 | ) | [inline]

Definition at line 111 of file chttptcpserverlocation.h.

References iProxiedHost, and iProxiedPort.

void CHttpTcpServerLocation::SetSecure ( TBool aIsSecure ) [inline]

Definition at line 101 of file chttptcpserverlocation.h.

References iIsSecure.

TBool CHttpTcpServerLocation::UsesProxy ( ) [inline]

Definition at line 106 of file chttptcpserverlocation.h.

References iProxiedHost.

Member Data Documentation

HBufC* CHttpTcpServerLocation::iHostAddress [private]

Definition at line 57 of file chttptcpserverlocation.h.

Referenced by HostAddress().

HBufC8* CHttpTcpServerLocation::iHostAddress8 [private]

Definition at line 58 of file chttptcpserverlocation.h.

Referenced by HostAddress8().

TUint CHttpTcpServerLocation::iHostPort [private]

Definition at line 60 of file chttptcpserverlocation.h.

Referenced by HostPort().

TBool CHttpTcpServerLocation::iIsSecure [private]

Definition at line 64 of file chttptcpserverlocation.h.

Referenced by IsSecure(), and SetSecure().

TBool CHttpTcpServerLocation::iPersistentConn [private]

Definition at line 62 of file chttptcpserverlocation.h.

Referenced by IsPersistentConnection(), and SetPersistentConnection().

HBufC8* CHttpTcpServerLocation::iProxiedHost [private]

Definition at line 66 of file chttptcpserverlocation.h.

Referenced by ProxiedHost(), ProxiedPort(), SetProxy(), and UsesProxy().

TUint CHttpTcpServerLocation::iProxiedPort [private]

Definition at line 67 of file chttptcpserverlocation.h.

Referenced by ProxiedPort(), and SetProxy().

The documentation for this class was generated from the following file:
  • chttptcpserverlocation.h


Member List

CHttpTcpServerLocation Member List

This is the complete list of members for CHttpTcpServerLocation, including all inherited members.
CHttpTcpServerLocation(TUint aHostPort) | CHttpTcpServerLocation | [private]
ConstructL(const TDesC &aHostAddress) | CHttpTcpServerLocation | [private]
HostAddress() const | CHttpTcpServerLocation | [inline]
HostAddress8() const | CHttpTcpServerLocation | [inline]
HostPort() const | CHttpTcpServerLocation | [inline]
iHostAddress | CHttpTcpServerLocation | [private]
iHostAddress8 | CHttpTcpServerLocation | [private]
iHostPort | CHttpTcpServerLocation | [private]
iIsSecure | CHttpTcpServerLocation | [private]
iPersistentConn | CHttpTcpServerLocation | [private]
iProxiedHost | CHttpTcpServerLocation | [private]
iProxiedPort | CHttpTcpServerLocation | [private]
IsPersistentConnection() const | CHttpTcpServerLocation | [inline]
IsSecure() const | CHttpTcpServerLocation | [inline]
LocationMatches(const CHttpTcpServerLocation &aLocation) const | CHttpTcpServerLocation |
NewL(const TDesC &aHostAddress, TUint aHostPort) | CHttpTcpServerLocation | [static]
ProxiedHost() const | CHttpTcpServerLocation | [inline]
ProxiedPort() const | CHttpTcpServerLocation | [inline]
SetPersistentConnection(TBool aIsPersistentConnection) | CHttpTcpServerLocation | [inline]
SetProxy(HBufC8 *aProxy, TUint aProxyPort) | CHttpTcpServerLocation | [inline]
SetSecure(TBool aIsSecure) | CHttpTcpServerLocation | [inline]
UsesProxy() const | CHttpTcpServerLocation | [inline]
~CHttpTcpServerLocation() | CHttpTcpServerLocation |


CHttpTcpWriter Class Reference

Writes data to a CHttpSocket informing its observer when the write is completed. More...

#include <CHttpTcpWriter.h>

Collaboration diagram for CHttpTcpWriter:

[legend]
List of all members.

Public Methods

virtual | ~CHttpTcpWriter ()
Destructor - cleans up and releases resources to the system.

void | Write (TDesC8 &aBuffer)

Static Public Methods

CHttpTcpWriter * | NewL (CHttpSocket &aSocket, MHttpSocketObserver &aObserver)
Factory construction - creates a new TCP writer.

Protected Methods

virtual void | RunL ()
Do some processing when a previous asynch request made by this object has completed.

virtual TInt | RunError (TInt aError)
Do any cleanup required should RunL leave.

virtual void | DoCancel ()
Cancel outstanding asynchronous requests that this object has made.

Private Methods

CHttpTcpWriter (CHttpSocket &aSocket, MHttpSocketObserver &aObserver)
Normal constructor which sets the active object priority to EPriorityStandard.

Private Attributes

CHttpSocket & iSocket
The socket which the data is to be written to.

MHttpSocketObserver & iObserver
The observer to be informed when the write is complete.

Detailed Description

Writes data to a CHttpSocket informing its observer when the write is completed.

Definition at line 17 of file CHttpTcpWriter.h.

Constructor & Destructor Documentation

virtual CHttpTcpWriter::~CHttpTcpWriter ( ) [virtual]

Destructor - cleans up and releases resources to the system.

CHttpTcpWriter::CHttpTcpWriter | ( | CHttpSocket & | aSocket,
 |  | MHttpSocketObserver & | aObserver
 | ) | [private]

Normal constructor which sets the active object priority to EPriorityStandard.

Member Function Documentation

virtual void CHttpTcpWriter::DoCancel ( ) [protected, virtual]

Cancel outstanding asynchronous requests that this object has made.

CHttpTcpWriter* CHttpTcpWriter::NewL | ( | CHttpSocket & | aSocket,
 |  | MHttpSocketObserver & | aObserver
 | ) | [static]

Factory construction - creates a new TCP writer.

virtual TInt CHttpTcpWriter::RunError ( TInt aError ) [protected, virtual]

Do any cleanup required should RunL leave.

virtual void CHttpTcpWriter::RunL ( ) [protected, virtual]

Do some processing when a previous asynch request made by this object has completed.

void CHttpTcpWriter::Write ( TDesC8 & aBuffer )

Member Data Documentation

MHttpSocketObserver& CHttpTcpWriter::iObserver [private]

The observer to be informed when the write is complete.

Definition at line 55 of file CHttpTcpWriter.h.

CHttpSocket& CHttpTcpWriter::iSocket [private]

The socket which the data is to be written to.

Definition at line 52 of file CHttpTcpWriter.h.

The documentation for this class was generated from the following file:
  • CHttpTcpWriter.h


Member List

CHttpTcpWriter Member List

This is the complete list of members for CHttpTcpWriter, including all inherited members.
CHttpTcpWriter(CHttpSocket &aSocket, MHttpSocketObserver &aObserver) | CHttpTcpWriter | [private]
DoCancel() | CHttpTcpWriter | [protected, virtual]
iObserver | CHttpTcpWriter | [private]
iSocket | CHttpTcpWriter | [private]
NewL(CHttpSocket &aSocket, MHttpSocketObserver &aObserver) | CHttpTcpWriter | [static]
RunError(TInt aError) | CHttpTcpWriter | [protected, virtual]
RunL() | CHttpTcpWriter | [protected, virtual]
Write(TDesC8 &aBuffer) | CHttpTcpWriter |
~CHttpTcpWriter() | CHttpTcpWriter | [virtual]


CHTTPManager Class Reference

A singleton manager for HTTP Client. More...

#include <CHTTPManager.h>

List of all members.

Public Methods

void | Release ()
Decrements the reference count, and deletes if it is 0.

RStringPool & | StringPool ()
Returns the string pool.

const RStringPool & | StringPool () const
Returns the string pool.

Static Public Methods

CHTTPManager * | CreateOrFindL ()
Creates the object, or returns a pointer to the existing singleton.

Private Methods

CHTTPManager ()
Constructor.

void | ConstructL ()
2 phase construction

~CHTTPManager ()
Destructor.

Private Attributes

RStringPool | iPool
The string pool.

TUint | iUseCount
The reference count.

Detailed Description

A singleton manager for HTTP Client.

The purpose of this class is to ensure that only a single instance of a string pool is used throughout HTTP - necessary to ensure that string comparisons in requests and responses succeed. The singleton pattern is achieved by caching a pointer to the manager object in DLL's Thread-Local Storage.

Definition at line 20 of file CHTTPManager.h.

Constructor & Destructor Documentation

CHTTPManager::CHTTPManager ( ) [private]

Constructor.

CHTTPManager::~CHTTPManager ( ) [private]

Destructor.

Member Function Documentation

void CHTTPManager::ConstructL ( ) [private]

2 phase construction

CHTTPManager* CHTTPManager::CreateOrFindL ( ) [static]

Creates the object, or returns a pointer to the existing singleton.

Note that the manager has a reference count; calls to this must be matched with a call to Release()

void CHTTPManager::Release ( )

Decrements the reference count, and deletes if it is 0.

(opposite of CreateOrFindL())

const RStringPool& CHTTPManager::StringPool ( )

Returns the string pool.

RStringPool& CHTTPManager::StringPool ( )

Returns the string pool.

Member Data Documentation

RStringPool CHTTPManager::iPool [private]

The string pool.

Definition at line 69 of file CHTTPManager.h.

TUint CHTTPManager::iUseCount [private]

The reference count.

Definition at line 74 of file CHTTPManager.h.

The documentation for this class was generated from the following file:
  • CHTTPManager.h


Member List

CHTTPManager Member List

This is the complete list of members for CHTTPManager, including all inherited members.
CHTTPManager() | CHTTPManager | [private]
ConstructL() | CHTTPManager | [private]
CreateOrFindL() | CHTTPManager | [static]
iPool | CHTTPManager | [private]
iUseCount | CHTTPManager | [private]
Release() | CHTTPManager |
StringPool() | CHTTPManager |
StringPool() const | CHTTPManager |
~CHTTPManager() | CHTTPManager | [private]


RHTTPMessage Class Reference

@public
Since:
7.0 An abstract HTTP message.
More...

#include <rhttpmessage.h>

Inheritance diagram for RHTTPMessage:

[legend]
Collaboration diagram for RHTTPMessage:

[legend]
List of all members.

Public Methods

RHTTPMessage ()
Default (uninitialised) constructor.

IMPORT_C RHTTPHeaders | GetHeaderCollection ()
Returns the header collection for the message.

IMPORT_C void | SetBody (MHTTPDataSupplier &aBody)
Sets the messages body, replacing any existing body.

IMPORT_C void | RemoveBody ()
Removes the body.

IMPORT_C TBool | HasBody () const
Determine whether this message has any associated body data.

IMPORT_C MHTTPDataSupplier * | Body () const
Gets the body.

Protected Attributes

CMessage * iImplementation

Detailed Description

@public
Since:
7.0 An abstract HTTP message.

In RFC2616, an HTTP message is defined as having a header and an optional body. This class is specialised for HTTP requests and responses.

Definition at line 29 of file rhttpmessage.h.

Constructor & Destructor Documentation

RHTTPMessage::RHTTPMessage ( ) [inline]

Default (uninitialised) constructor.

Definition at line 76 of file rhttpmessage.h.

Member Function Documentation

IMPORT_C MHTTPDataSupplier* RHTTPMessage::Body ( )

Gets the body.

The body is supplied as a MHTTPDataSupplier, which can be used to return the current data chunk, and to acknowledge when that chunk has been consumed by the client.

Note that the client can assume the body object will remain unchanged from when it receives the first data until the end of the transaction.

Returns:
A data supplier that provides access to a body data chunk. NULL if the body has not been set, or has been removed

IMPORT_C RHTTPHeaders RHTTPMessage::GetHeaderCollection ( )

Returns the header collection for the message.

IMPORT_C TBool RHTTPMessage::HasBody ( )

Determine whether this message has any associated body data.

Returns:
ETrue if there is some body data, EFalse if not.

IMPORT_C void RHTTPMessage::RemoveBody ( )

Removes the body.

IMPORT_C void RHTTPMessage::SetBody ( MHTTPDataSupplier & aBody )

Sets the messages body, replacing any existing body.

The body is supplied as a MHTTPDataSupplier, which will then return the data in 1 or more chunks on request.

Parameters:
aBody The data supplier that will supply the body.

Member Data Documentation

CMessage* RHTTPMessage::iImplementation [protected]

Definition at line 72 of file rhttpmessage.h.

The documentation for this class was generated from the following file:
  • rhttpmessage.h


Member List

RHTTPMessage Member List

This is the complete list of members for RHTTPMessage, including all inherited members.
Body() const | RHTTPMessage |
GetHeaderCollection() | RHTTPMessage |
HasBody() const | RHTTPMessage |
iImplementation | RHTTPMessage | [protected]
RemoveBody() | RHTTPMessage |
RHTTPMessage() | RHTTPMessage | [inline]
SetBody(MHTTPDataSupplier &aBody) | RHTTPMessage |


CMessage Class Reference

Abstract base class for implementation of HTTP requests and responses. More...

#include <CMessage.h>

Inheritance diagram for CMessage:

[legend]
Collaboration diagram for CMessage:

[legend]
List of all members.

Public Methods

~CMessage ()=0
Destructor.

void | AddBody (MHTTPDataSupplier *aBody)
Specify the body data supplier for this HTTP message.

TBool | HasBody () const
Determine whether this HTTP message has a body or not.

MHTTPDataSupplier * | Body () const
Obtain this HTTP message's body data supplier.

RHTTPHeaders | Headers () const
Obtain the message headers.

Protected Methods

void | ConstructL (CTransaction *aTransaction)
Does base class 2 phase construction.

Private Attributes

CHeaders * iHeaders
The header fields.

CTransaction * iTransaction
The associated transaction.

MHTTPDataSupplier * iDataSupplier
The body.

Friends

class | RHTTPMessage
class | RHTTPRequest
class | RHTTPResponse

Detailed Description

Abstract base class for implementation of HTTP requests and responses.

Definition at line 18 of file CMessage.h.

Constructor & Destructor Documentation

CMessage::~CMessage ( ) [pure virtual]

Destructor.

(NB Although this method has an implementation - this class must be abstract)

Member Function Documentation

void CMessage::AddBody ( MHTTPDataSupplier * aBody ) [inline]

Specify the body data supplier for this HTTP message.

See also:
RHTTPMessage::AddBody

MHTTPDataSupplier* CMessage::Body ( ) [inline]

Obtain this HTTP message's body data supplier.

See also:
RHTTPMessage::GetBody

void CMessage::ConstructL ( CTransaction * aTransaction ) [inline, protected]

Does base class 2 phase construction.

TBool CMessage::HasBody ( ) [inline]

Determine whether this HTTP message has a body or not.

See also:
RHTTPMessage::HasBody

RHTTPHeaders CMessage::Headers ( ) [inline]

Obtain the message headers.

Friends And Related Function Documentation

friend class RHTTPMessage [friend]

Definition at line 74 of file CMessage.h.

friend class RHTTPRequest [friend]

Definition at line 75 of file CMessage.h.

friend class RHTTPResponse [friend]

Definition at line 76 of file CMessage.h.

Member Data Documentation

MHTTPDataSupplier* CMessage::iDataSupplier [private]

The body.

Definition at line 72 of file CMessage.h.

CHeaders* CMessage::iHeaders [private]

The header fields.

Definition at line 62 of file CMessage.h.

CTransaction* CMessage::iTransaction [private]

The associated transaction.

Definition at line 67 of file CMessage.h.

The documentation for this class was generated from the following file:
  • CMessage.h


Member List

CMessage Member List

This is the complete list of members for CMessage, including all inherited members.
AddBody(MHTTPDataSupplier *aBody) | CMessage | [inline]
Body() const | CMessage | [inline]
ConstructL(CTransaction *aTransaction) | CMessage | [inline, protected]
HasBody() const | CMessage | [inline]
Headers() const | CMessage | [inline]
iDataSupplier | CMessage | [private]
iHeaders | CMessage | [private]
iTransaction | CMessage | [private]
RHTTPMessage class | CMessage | [friend]
RHTTPRequest class | CMessage | [friend]
RHTTPResponse class | CMessage | [friend]
~CMessage()=0 | CMessage | [pure virtual]


CNwssConnectGuard Class Reference

Since:
7.0 This class encapsulates the functionality to ensure that the Wsp CO Session states tables are honoured by the NWSS WAP Stack.
More...

#include <CNwssConnectGuard.h>

Collaboration diagram for CNwssConnectGuard:

[legend]
List of all members.

Public Methods

~CNwssConnectGuard ()
Standard destructor.

void | SendDisconnectInd (Wap::TWspReason aReason)
void | SendMethodInvokeReq ()
Sends the S-MethodInvoke.req primitive.

void | SendMethodAbortInd ()
Sends the T-MethodAbort.ind primitive to the Wsp CO Method callback.

void | ReceivedMethodInvokeReqL (MWspCOMethodCallback &aMethodCallback, RStringF aMethod, const TUriC8 &aRequestUri, const TDesC8 &aRequestHeaders, const TDesC8 &aRequestBody)
Stores the method invocation information.

Static Public Methods

CNwssConnectGuard * | NewL (MWspCOMethodInvoker &aMethodInvoker, MWspCOSessionCallback &aSessionCallback)
Static factory c'tor.

Private Methods

virtual void | RunL ()
virtual void | DoCancel ()
CNwssConnectGuard (MWspCOMethodInvoker &aMethodInvoker, MWspCOSessionCallback &aSessionCallback)
Constuctor.

void | ResetMethodInfo ()
Resets the method info.

void | CompleteSelf ()
Completes the request.

Private Attributes

MWspCOMethodInvoker & iMethodInvoker
A reference to the Wsp CO method invoker object.

MWspCOSessionCallback & iSessionCallback
A reference to the Wsp CO session callback.

MWspCOMethodCallback * iMethodCallback
A reference to the Wsp CO method callback object for this method.

RStringF | iMethod
The method type.

CUri8 * | iRequestUri
The request Uri.

HBufC8 * | iRequestHeaders
The request header data.

HBufC8 * | iRequestBody
The request body data.

TBool | iSendDisconnect
A flag indicating that an S-Disconnect.ind be sent.

Wap::TWspReason iDisconnectReason
A parameter that indicates the reason for the S-Disconnect.ind.

Detailed Description

Since:
7.0 This class encapsulates the functionality to ensure that the Wsp CO Session states tables are honoured by the NWSS WAP Stack.

Specifically, during WTLS connection, there is a gap from when the S-Connect.req is received from the protocol handler to when the RWSPCOConn receives that primitive. During this time the protocol handler thinks that the Wsp CO Session state is Connecting and will method invocation and allow the S-Disconnect.req primitive to be sent.

If a T-MethodInvoke.req is received by the transport handler, this class will store the information and send the primitive once it is told that the S-Connect.req has been sent to the WAP Stack.

Also, if the S-Disconnect.req is received by the transport handler, it can use this class to send the T-MethodAbort.ind (if necessary) and the S-Disconnect.ind.

Similarly, if the transport handler receives T-MethodAbort.req.

Definition at line 44 of file CNwssConnectGuard.h.

Constructor & Destructor Documentation

CNwssConnectGuard::~CNwssConnectGuard ( )

Standard destructor.

Since:
7.0

CNwssConnectGuard::CNwssConnectGuard | ( | MWspCOMethodInvoker & | aMethodInvoker,
 |  | MWspCOSessionCallback & | aSessionCallback
 | ) | [private]

Constuctor.

Since:
7.0
Parameters:
aMethodInvoker | A reference to the Wsp CO method invoker.
aSessionCallback | A reference to the Wsp CO session callback.

Member Function Documentation

CNwssConnectGuard::CompleteSelf ( ) [private]

Completes the request.

Since:
7.0

virtual void CNwssConnectGuard::DoCancel ( ) [private, virtual]

CNwssConnectGuard::NewL | ( | MWspCOMethodInvoker & | aMethodInvoker,
 |  | MWspCOSessionCallback & | aSessionCallback
 | ) | [static]

Static factory c'tor.

Since:
7.0
Parameters:
aMethodInvoker | A reference to the Wsp CO method invoker.
aSessionCallback | A reference to the Wsp CO session callback.

CNwssConnectGuard::ReceivedMethodInvokeReqL | ( | MWspCOMethodCallback & | aMethodCallback,
 |  | RStringF | aMethod,
 |  | const TUriC8 & | aRequestUri,
 |  | const TDesC8 & | aRequestHeaders,
 |  | const TDesC8 & | aRequestBody
 | ) |

Stores the method invocation information.

Warning:
Will panic with EMORExceeded if there already is method info stored.
Parameters:
aMethodCallback | A reference to the Wsp CO method callback object for this method.
aMethod | The method type.
aRequestUri | A reference to the request Uri.
aRequestHeaders | A reference to a buffer with the request header data.
aRequestBody | A reference to a buffer with the request

CNwssConnectGuard::ResetMethodInfo ( ) [private]

Resets the method info.

Releases resources.

Since:
7.0

virtual void CNwssConnectGuard::RunL ( ) [private, virtual]

void CNwssConnectGuard::SendDisconnectInd ( Wap::TWspReason aReason )

CNwssConnectGuard::SendMethodAbortInd ( )

Sends the T-MethodAbort.ind primitive to the Wsp CO Method callback.

Since:
7.0

CNwssConnectGuard::SendMethodInvokeReq ( )

Sends the S-MethodInvoke.req primitive.

Since:
7.0

Member Data Documentation

Wap::TWspReason CNwssConnectGuard::iDisconnectReason [private]

A parameter that indicates the reason for the S-Disconnect.ind.

Definition at line 187 of file CNwssConnectGuard.h.

RStringF CNwssConnectGuard::iMethod [private]

The method type.

Definition at line 162 of file CNwssConnectGuard.h.

MWspCOMethodCallback* CNwssConnectGuard::iMethodCallback [private]

A reference to the Wsp CO method callback object for this method.

Definition at line 157 of file CNwssConnectGuard.h.

MWspCOMethodInvoker& CNwssConnectGuard::iMethodInvoker [private]

A reference to the Wsp CO method invoker object.

Definition at line 147 of file CNwssConnectGuard.h.

HBufC8* CNwssConnectGuard::iRequestBody [private]

The request body data.

Definition at line 177 of file CNwssConnectGuard.h.

HBufC8* CNwssConnectGuard::iRequestHeaders [private]

The request header data.

Definition at line 172 of file CNwssConnectGuard.h.

CUri8* CNwssConnectGuard::iRequestUri [private]

The request Uri.

Definition at line 167 of file CNwssConnectGuard.h.

TBool CNwssConnectGuard::iSendDisconnect [private]

A flag indicating that an S-Disconnect.ind be sent.

Definition at line 182 of file CNwssConnectGuard.h.

MWspCOSessionCallback& CNwssConnectGuard::iSessionCallback [private]

A reference to the Wsp CO session callback.

Definition at line 152 of file CNwssConnectGuard.h.

The documentation for this class was generated from the following file:
  • CNwssConnectGuard.h


Member List

CNwssConnectGuard Member List

This is the complete list of members for CNwssConnectGuard, including all inherited members.
CNwssConnectGuard(MWspCOMethodInvoker &aMethodInvoker, MWspCOSessionCallback &aSessionCallback) | CNwssConnectGuard | [private]
CompleteSelf() | CNwssConnectGuard | [private]
DoCancel() | CNwssConnectGuard | [private, virtual]
iDisconnectReason | CNwssConnectGuard | [private]
iMethod | CNwssConnectGuard | [private]
iMethodCallback | CNwssConnectGuard | [private]
iMethodInvoker | CNwssConnectGuard | [private]
iRequestBody | CNwssConnectGuard | [private]
iRequestHeaders | CNwssConnectGuard | [private]
iRequestUri | CNwssConnectGuard | [private]
iSendDisconnect | CNwssConnectGuard | [private]
iSessionCallback | CNwssConnectGuard | [private]
NewL(MWspCOMethodInvoker &aMethodInvoker, MWspCOSessionCallback &aSessionCallback) | CNwssConnectGuard | [static]
ReceivedMethodInvokeReqL(MWspCOMethodCallback &aMethodCallback, RStringF aMethod, const TUriC8 &aRequestUri, const TDesC8 &aRequestHeaders, const TDesC8 &aRequestBody) | CNwssConnectGuard |
ResetMethodInfo() | CNwssConnectGuard | [private]
RunL() | CNwssConnectGuard | [private, virtual]
SendDisconnectInd(Wap::TWspReason aReason) | CNwssConnectGuard |
SendMethodAbortInd() | CNwssConnectGuard |
SendMethodInvokeReq() | CNwssConnectGuard |
~CNwssConnectGuard() | CNwssConnectGuard |


MNwssOomHandler Class Reference

@private
Since:
7.0 This interface provides callback mechanisms used to abort methods or disconnect a session in in out-of-memory situation in the NWSS WSP Transport Handler.
More...

#include <MNwssOomHandler.h>

Inheritance diagram for MNwssOomHandler:

[legend]
List of all members.

Public Methods

virtual void | SendOomMethodAbort (MWspCOMethodCallback &aMethodToAbort, TBool aAbortOnStack)=0
virtual void | SendOomMethodAbort (RWSPCOTrans::TTransID aTransId, TBool aAbortOnStack)=0
virtual void | SendOomDisconnect (TBool aDisconnectOnStack)=0

Detailed Description

@private
Since:
7.0 This interface provides callback mechanisms used to abort methods or disconnect a session in in out-of-memory situation in the NWSS WSP Transport Handler.

Definition at line 25 of file MNwssOomHandler.h.

Member Function Documentation

virtual void MNwssOomHandler::SendOomDisconnect ( TBool aDisconnectOnStack ) [pure virtual]

Implemented in CNwssWspCOSession.

virtual void MNwssOomHandler::SendOomMethodAbort | ( | RWSPCOTrans::TTransID | aTransId,
 |  | TBool | aAbortOnStack
 | ) | [pure virtual]

Implemented in CNwssWspCOSession.

virtual void MNwssOomHandler::SendOomMethodAbort | ( | MWspCOMethodCallback & | aMethodToAbort,
 |  | TBool | aAbortOnStack
 | ) | [pure virtual]

Implemented in CNwssWspCOSession.

The documentation for this class was generated from the following file:
  • MNwssOomHandler.h


Member List

MNwssOomHandler Member List

This is the complete list of members for MNwssOomHandler, including all inherited members.
SendOomDisconnect(TBool aDisconnectOnStack)=0 | MNwssOomHandler | [pure virtual]
SendOomMethodAbort(MWspCOMethodCallback &aMethodToAbort, TBool aAbortOnStack)=0 | MNwssOomHandler | [pure virtual]
SendOomMethodAbort(RWSPCOTrans::TTransID aTransId, TBool aAbortOnStack)=0 | MNwssOomHandler | [pure virtual]


MNwssSessionEventHandler Class Reference

@private
Since:
7.0 This interface defines methods to handle each type of session event that can be received in the WSP layer of the WAP Stack.
More...

#include <MNwssSessionEventHandler.h>

Inheritance diagram for MNwssSessionEventHandler:

[legend]
List of all members.

Public Methods

virtual void | HandleDisconnectIndL ()=0
Intended Usage: Handle the S-Disconnect.ind PDU received from the WAP Stack.

virtual void | HandleSuspendIndL ()=0
Intended Usage: Handle the S-Suspend.ind PDU received from the WAP Stack.

virtual void | HandleResumeCnfL ()=0
Intended Usage: Handle the S-Resume.cnf PDU received from the WAP Stack.

virtual void | HandleConnectCnfL ()=0
Intended Usage: Handle the S-Connect.cnf PDU received from the WAP Stack.

virtual void | HandleRedirectIndL ()=0
Intended Usage: Handle the S-Redirect.ind PDU received from the WAP Stack.

virtual void | HandleExceptionIndL ()=0
Intended Usage: Handle the E-Exception.ind PDU received from the WAP Stack.

Detailed Description

@private
Since:
7.0 This interface defines methods to handle each type of session event that can be received in the WSP layer of the WAP Stack.

Definition at line 23 of file MNwssSessionEventHandler.h.

Member Function Documentation

void MNwssSessionEventHandler::HandleConnectCnfL ( ) [pure virtual]

Intended Usage: Handle the S-Connect.cnf PDU received from the WAP Stack.

Since:
7.0 @leave System wide errors, e.g. KErrNoMemory

Implemented in CNwssWspCOSession, and CNwssWspSessionEventFilter.

void MNwssSessionEventHandler::HandleDisconnectIndL ( ) [pure virtual]

Intended Usage: Handle the S-Disconnect.ind PDU received from the WAP Stack.

Since:
7.0 @leave System wide errors, e.g. KErrNoMemory

Implemented in CNwssWspCOSession, and CNwssWspSessionEventFilter.

void MNwssSessionEventHandler::HandleExceptionIndL ( ) [pure virtual]

Intended Usage: Handle the E-Exception.ind PDU received from the WAP Stack.

Since:
7.0 @leave System wide errors, e.g. KErrNoMemory

Implemented in CNwssWspCOSession, and CNwssWspSessionEventFilter.

void MNwssSessionEventHandler::HandleRedirectIndL ( ) [pure virtual]

Intended Usage: Handle the S-Redirect.ind PDU received from the WAP Stack.

Since:
7.0 @leave System wide errors, e.g. KErrNoMemory

Implemented in CNwssWspCOSession, and CNwssWspSessionEventFilter.

void MNwssSessionEventHandler::HandleResumeCnfL ( ) [pure virtual]

Intended Usage: Handle the S-Resume.cnf PDU received from the WAP Stack.

Since:
7.0 @leave System wide errors, e.g. KErrNoMemory

Implemented in CNwssWspCOSession, and CNwssWspSessionEventFilter.

void MNwssSessionEventHandler::HandleSuspendIndL ( ) [pure virtual]

Intended Usage: Handle the S-Suspend.ind PDU received from the WAP Stack.

Since:
7.0 @leave System wide errors, e.g. KErrNoMemory

Implemented in CNwssWspCOSession, and CNwssWspSessionEventFilter.

The documentation for this class was generated from the following file:
  • MNwssSessionEventHandler.h


Member List

MNwssSessionEventHandler Member List

This is the complete list of members for MNwssSessionEventHandler, including all inherited members.
HandleConnectCnfL()=0 | MNwssSessionEventHandler | [pure virtual]
HandleDisconnectIndL()=0 | MNwssSessionEventHandler | [pure virtual]
HandleExceptionIndL()=0 | MNwssSessionEventHandler | [pure virtual]
HandleRedirectIndL()=0 | MNwssSessionEventHandler | [pure virtual]
HandleResumeCnfL()=0 | MNwssSessionEventHandler | [pure virtual]
HandleSuspendIndL()=0 | MNwssSessionEventHandler | [pure virtual]


MNwssTransactionEventHandler Class Reference

@private
Since:
7.0 This interface defines methods to handle each type of transaction event that can be received in the WSP layer of the WAP Stack.
More...

#include <MNwssTransactionEventHandler.h>

Inheritance diagram for MNwssTransactionEventHandler:

[legend]
List of all members.

Public Methods

virtual void | HandleMethodInvokeCnfL (RWSPCOTrans::TTransID aTransId)=0
virtual void | HandleMethodResultIndL (RWSPCOTrans::TTransID aTransId)=0
virtual void | HandleAbortIndL (RWSPCOTrans::TTransID aTransId)=0

Detailed Description

@private
Since:
7.0 This interface defines methods to handle each type of transaction event that can be received in the WSP layer of the WAP Stack.

To handle an event, the corresponding transaction ID is supplied.

Definition at line 27 of file MNwssTransactionEventHandler.h.

Member Function Documentation

virtual void MNwssTransactionEventHandler::HandleAbortIndL ( RWSPCOTrans::TTransID aTransId ) [pure virtual]

Implemented in CNwssWspCOSession, and CNwssWspTransactionEventFilter.

virtual void MNwssTransactionEventHandler::HandleMethodInvokeCnfL ( RWSPCOTrans::TTransID aTransId ) [pure virtual]

Implemented in CNwssWspCOSession, and CNwssWspTransactionEventFilter.

virtual void MNwssTransactionEventHandler::HandleMethodResultIndL ( RWSPCOTrans::TTransID aTransId ) [pure virtual]

Implemented in CNwssWspCOSession, and CNwssWspTransactionEventFilter.

The documentation for this class was generated from the following file:
  • MNwssTransactionEventHandler.h


Member List

MNwssTransactionEventHandler Member List

This is the complete list of members for MNwssTransactionEventHandler, including all inherited members.
HandleAbortIndL(RWSPCOTrans::TTransID aTransId)=0 | MNwssTransactionEventHandler | [pure virtual]
HandleMethodInvokeCnfL(RWSPCOTrans::TTransID aTransId)=0 | MNwssTransactionEventHandler | [pure virtual]
HandleMethodResultIndL(RWSPCOTrans::TTransID aTransId)=0 | MNwssTransactionEventHandler | [pure virtual]


CNwssTransLookUpTable Class Reference

@private
Since:
7.0 This class implements a simple, pre-allocated look-up table that is used in the WSP Transport Handler to associate the transaction-related items stored in instances of the embedded class CNwssTransLUTEntry.
More...

#include <CNwssTransLookUpTable.h>

List of all members.

Public Methods

virtual | ~CNwssTransLookUpTable ()
Intended Usage: Destructor.

CNwssTransLUTEntry & NewEntry ()
Intended Usage: Returns the next available LUT entry at the top of the table.

CNwssTransLUTEntry & | LookUpByTransId (RWSPCOTrans::TTransID aTransId, TBool &aFound)
Intended Usage: Locate a look-up table entry that matches the supplied transaction ID.

CNwssTransLUTEntry & | LookUpByCallback (MWspCOMethodCallback &aCallback, TBool &aFound)
Intended Usage: Locate a look-up table entry that matches the supplied client method callback.

void | RemoveEntry (MWspCOMethodCallback &aCallback)
Intended Usage: Removes the entry corresponding to aCallback from the table.

void | ResizeTableL (TInt aNewSize)
Intended Usage: Resizes the look-up table.

TBool | IsEmpty () const
Intended Usage: Indicates whether there are any 'live' entries in the lookup table,
Since:
7.0.

CNwssTransLUTEntry & | Head (TBool &aFound)
Intended Usage: Returns the first entry in the lookup table.

Static Public Methods

CNwssTransLookUpTable * | NewL (TInt aTableSize)
Intended Usage: Factory construction.

Private Methods

CNwssTransLookUpTable ()
Intended Usage: Normal constructor.

void | ConstructL (TInt aTableSize)
Intended Usage: Second phase construction.

CNwssTransLUTEntry * | LookUp (MWspCOMethodCallback &aCallback, TInt &aIndex)

Private Attributes

TInt | iNumActiveLUTEntries
The number of active entries in the look-up table.

RPointerArray< CNwssTransLUTEntry > | iEntries
The pre-allocated look-up table.

Detailed Description

@private
Since:
7.0 This class implements a simple, pre-allocated look-up table that is used in the WSP Transport Handler to associate the transaction-related items stored in instances of the embedded class CNwssTransLUTEntry.

Definition at line 35 of file CNwssTransLookUpTable.h.

Constructor & Destructor Documentation

CNwssTransLookUpTable::~CNwssTransLookUpTable ( ) [virtual]

Intended Usage: Destructor.

Since:
7.0

CNwssTransLookUpTable::CNwssTransLookUpTable ( ) [private]

Intended Usage: Normal constructor.

Since:
7.0

Member Function Documentation

void CNwssTransLookUpTable::ConstructL ( TInt aTableSize ) [private]

Intended Usage: Second phase construction.

Pre-allocates table entries upto the specified table size.

Since:
7.0
Parameters:
aTableSize (in) The required initial table size. @leaves System error codes, e.g. KErrNoMemory.

CNwssTransLUTEntry & CNwssTransLookUpTable::Head ( TBool & aFound )

Intended Usage: Returns the first entry in the lookup table.

Parameters:
aFound (out) A flag indicating if the entry was found.
Returns:
A reference to the located entry. Note, if aFound is EFalse the reference should be discard, as it will be garbage.

TBool CNwssTransLookUpTable::IsEmpty ( ) const

Intended Usage: Indicates whether there are any 'live' entries in the lookup table,

Since:
7.0.

CNwssTransLUTEntry* CNwssTransLookUpTable::LookUp | ( | MWspCOMethodCallback & | aCallback,
 |  | TInt & | aIndex
 | ) | [private]

CNwssTransLUTEntry & CNwssTransLookUpTable::LookUpByCallback | ( | MWspCOMethodCallback & | aCallback,
 |  | TBool & | aFound
 | ) |

Intended Usage: Locate a look-up table entry that matches the supplied client method callback.

It is a requirement on the client that it uses unique MWspCOMethodCallback objects for each transaction. Hence there is an assumption that the look-up table user does not allow entries with duplicate callback's to be entered in the table.

Since:
7.0
Parameters:
aCallback | (in) The client transaction callback.
aFound | (out) A flag indicating if the entry was found.
Returns:
A reference to the located entry. Note, if aFound is EFalse the reference should be discard, as it will be garbage.

CNwssTransLUTEntry & CNwssTransLookUpTable::LookUpByTransId | ( | RWSPCOTrans::TTransID | aTransId,
 |  | TBool & | aFound
 | ) |

Intended Usage: Locate a look-up table entry that matches the supplied transaction ID.

It is assumed that the look-up table user does not allow duplicates to be entered in the table.

Since:
7.0
Parameters:
aTransId | (in) The WAP Stack transaction ID.
aFound | (out) A flag indicating if the entry was found.
Returns:
A reference to the located entry. Note, if aFound is EFalse the reference should be discard, as it will be garbage.

CNwssTransLUTEntry & CNwssTransLookUpTable::NewEntry ( )

Intended Usage: Returns the next available LUT entry at the top of the table.

Since:
7.0
Returns:
A reference to the entry.

CNwssTransLookUpTable * CNwssTransLookUpTable::NewL ( TInt aTableSize ) [static]

Intended Usage: Factory construction.

Pre-allocates a table of the specified size.

Since:
7.0
Parameters:
aTableSize (in) The initial size of the look-up table.
Returns:
The newly constructed instance. @leaves System error codes, e.g. KErrNoMemory.

CNwssTransLookUpTable::RemoveEntry ( MWspCOMethodCallback & aCallback )

Intended Usage: Removes the entry corresponding to aCallback from the table.

Note that since the table is pre-allocated, the actual entry is just recycled by moving it to the top of the table, adjusting the high- water mark (if necessary) to point at it.

Since:
7.0
Parameters:
aCallback (in) A callback, uniquely identifying the table entry to remove.

CNwssTransLookUpTable::ResizeTableL ( TInt aNewSize )

Intended Usage: Resizes the look-up table.

If aNewSize exceeds the current size, then entries are added. If it is less than the current size, then surplus entries are deleted.

Since:
7.0
Parameters:
aNewSize (in) The new table size @leave System error codes, e.g. KErrNoMemory if the table can't be enlarged.

Member Data Documentation

RPointerArray<CNwssTransLUTEntry> CNwssTransLookUpTable::iEntries [private]

The pre-allocated look-up table.

It is ready populated with entry structures.

Definition at line 246 of file CNwssTransLookUpTable.h.

TInt CNwssTransLookUpTable::iNumActiveLUTEntries [private]

The number of active entries in the look-up table.

iEntries[iNumActiveLUTEntries] will return the next free entry.

Definition at line 240 of file CNwssTransLookUpTable.h.

The documentation for this class was generated from the following file:
  • CNwssTransLookUpTable.h


Member List

CNwssTransLookUpTable Member List

This is the complete list of members for CNwssTransLookUpTable, including all inherited members.
CNwssTransLookUpTable() | CNwssTransLookUpTable | [private]
ConstructL(TInt aTableSize) | CNwssTransLookUpTable | [private]
Head(TBool &aFound) | CNwssTransLookUpTable |
iEntries | CNwssTransLookUpTable | [private]
iNumActiveLUTEntries | CNwssTransLookUpTable | [private]
IsEmpty() const | CNwssTransLookUpTable |
LookUp(MWspCOMethodCallback &aCallback, TInt &aIndex) | CNwssTransLookUpTable | [private]
LookUpByCallback(MWspCOMethodCallback &aCallback, TBool &aFound) | CNwssTransLookUpTable |
LookUpByTransId(RWSPCOTrans::TTransID aTransId, TBool &aFound) | CNwssTransLookUpTable |
NewEntry() | CNwssTransLookUpTable |
NewL(TInt aTableSize) | CNwssTransLookUpTable | [static]
RemoveEntry(MWspCOMethodCallback &aCallback) | CNwssTransLookUpTable |
ResizeTableL(TInt aNewSize) | CNwssTransLookUpTable |
~CNwssTransLookUpTable() | CNwssTransLookUpTable | [virtual]


CNwssTransLookUpTable::CNwssTransLUTEntry Class Reference

@private
Since:
7.0 This class implements a single entry in the transaction look-up table.
More...

#include <CNwssTransLookUpTable.h>

Collaboration diagram for CNwssTransLookUpTable::CNwssTransLUTEntry:

[legend]
List of all members.

Public Methods

virtual | ~CNwssTransLUTEntry ()
Intended Usage: Destructor.

Static Public Methods

CNwssTransLUTEntry * | NewL ()
Intended Usage: Factory construction.

Public Attributes

MWspCOMethodCallback * iCallback
Client callback pointer for the transaction.

RWSPCOTrans | iStackTrans
WAP Stack transaction handle.

RWSPCOTrans::TTransID | iStackTransID
WAP Stack transaction ID.

CNwssWspTrHndDataSupplier * iResponseBodyHandler
Response body data handler.

TBool | iAborted
A flag to indicate whether this transaction has been aborted by the client, but is in the EDone state.

Private Methods

CNwssTransLUTEntry ()
Intended Usage: Default constructor.

Detailed Description

@private
Since:
7.0 This class implements a single entry in the transaction look-up table.

It is an association of the following five items : NWSS Wap Stack transaction handler (RWSPCOTrans) NWSS Wap Stack transaction ID (RWSPCOTrans::TTransID) - for convenience Client transaction callback (MWspCOMethodCallback) Client's request body data supplier (MHTTPDataSupplier) WSP Transport Handler response body handler (CNwssWspTrHndDataSupplier)

Definition at line 52 of file CNwssTransLookUpTable.h.

Constructor & Destructor Documentation

CNwssTransLookUpTable::CNwssTransLUTEntry::~CNwssTransLUTEntry ( ) [virtual]

Intended Usage: Destructor.

Since:
7.0

CNwssTransLookUpTable::CNwssTransLUTEntry::CNwssTransLUTEntry ( ) [private]

Intended Usage: Default constructor.

Since:
7.0

Member Function Documentation

static CNwssTransLUTEntry * CNwssTransLookUpTable::CNwssTransLUTEntry::NewL ( ) [static]

Intended Usage: Factory construction.

Since:
7.0

Member Data Documentation

TBool CNwssTransLookUpTable::CNwssTransLUTEntry::iAborted

A flag to indicate whether this transaction has been aborted by the client, but is in the EDone state.

Definition at line 103 of file CNwssTransLookUpTable.h.

MWspCOMethodCallback* CNwssTransLookUpTable::CNwssTransLUTEntry::iCallback

Client callback pointer for the transaction.

This uniquely identifies the transaction.

Definition at line 83 of file CNwssTransLookUpTable.h.

CNwssWspTrHndDataSupplier* CNwssTransLookUpTable::CNwssTransLUTEntry::iResponseBodyHandler

Response body data handler.

Definition at line 98 of file CNwssTransLookUpTable.h.

RWSPCOTrans CNwssTransLookUpTable::CNwssTransLUTEntry::iStackTrans

WAP Stack transaction handle.

Definition at line 88 of file CNwssTransLookUpTable.h.

RWSPCOTrans::TTransID CNwssTransLookUpTable::CNwssTransLUTEntry::iStackTransID

WAP Stack transaction ID.

Definition at line 93 of file CNwssTransLookUpTable.h.

The documentation for this class was generated from the following file:
  • CNwssTransLookUpTable.h


Member List

CNwssTransLookUpTable::CNwssTransLUTEntry Member List

This is the complete list of members for CNwssTransLookUpTable::CNwssTransLUTEntry, including all inherited members.
CNwssTransLUTEntry() | CNwssTransLookUpTable::CNwssTransLUTEntry | [private]
iAborted | CNwssTransLookUpTable::CNwssTransLUTEntry |
iCallback | CNwssTransLookUpTable::CNwssTransLUTEntry |
iResponseBodyHandler | CNwssTransLookUpTable::CNwssTransLUTEntry |
iStackTrans | CNwssTransLookUpTable::CNwssTransLUTEntry |
iStackTransID | CNwssTransLookUpTable::CNwssTransLUTEntry |
NewL() | CNwssTransLookUpTable::CNwssTransLUTEntry | [static]
~CNwssTransLUTEntry() | CNwssTransLookUpTable::CNwssTransLUTEntry | [virtual]


MNwssWapServer Class Reference

@private
Since:
7.0 This interface provides access to the WAP Stack Server via a handle owned by the interface implementor.
More...

#include <MNwssWapServer.h>

Inheritance diagram for MNwssWapServer:

[legend]
List of all members.

Public Methods

virtual RWAPServ & WapStack ()=0
Intended Usage: Obtain access to the WAP Stack Server via the returned handle.

Detailed Description

@private
Since:
7.0 This interface provides access to the WAP Stack Server via a handle owned by the interface implementor.

It is used to narrow the API on the implementor for particular clients.

Definition at line 24 of file MNwssWapServer.h.

Member Function Documentation

RWAPServ & MNwssWapServer::WapStack ( ) [pure virtual]

Intended Usage: Obtain access to the WAP Stack Server via the returned handle.

Since:
7.0
Returns:
Reference to a WAP Stack Server session handle. This must NOT be closed by the caller.

Implemented in CNwssWspTransportHandler.

The documentation for this class was generated from the following file:
  • MNwssWapServer.h


Member List

MNwssWapServer Member List

This is the complete list of members for MNwssWapServer, including all inherited members.
WapStack()=0 MNwssWapServer [pure virtual]


CNwssWspCOEventDispatcher Class Reference

@private
Since:
7.0 This class acts as a hub for the receipt of Connection-Oriented WSP session and transaction events.
More...

#include <CNwssWspCOEventDispatcher.h>

Collaboration diagram for CNwssWspCOEventDispatcher:

[legend]
List of all members.

Public Methods

virtual | ~CNwssWspCOEventDispatcher ()
Intended Usage: Destructor.

void | Start ()
Intended Usage: Start waiting for stack events.

Static Public Methods

CNwssWspCOEventDispatcher * | NewL (RWSPCOConn &aWspSession, MNwssSessionEventHandler &aSessEventHnd, MNwssTransactionEventHandler &aTransEventHnd, MNwssOomHandler &aOutOfMemoryHnd)

Private Methods

virtual void | RunL ()
Intended Usage: Called when the active object fires, ie.

virtual TInt | RunError (TInt aError)
Intended Usage: Called if RunL leaves, to allow the AO to handle the error before the scheduler does
Since:
7.0.

virtual void | DoCancel ()
Intended Usage: Cancellation protocol for the active object.

CNwssWspCOEventDispatcher (RWSPCOConn &aWspSession, MNwssSessionEventHandler &aSessEventHnd, MNwssTransactionEventHandler &aTransEventHnd, MNwssOomHandler &aOutOfMemoryHnd)

Private Attributes

RWSPCOConn & | iWspSession
The WSP Session handle.

MNwssSessionEventHandler & iSessEventHnd
Handler for session events received at the dispatcher.

MNwssTransactionEventHandler & iTransEventHnd
Handler for transaction events received at the dispatcher.

MNwssOomHandler & iOutOfMemoryHnd
Handler for out-of-memory situations.

RWSPCOConn::TEvent | iWspEvent
The event that has occured.

RWSPCOTrans | iTransaction
The transaction handle on which transaction events occur.

RWSPCOTrans::TTransID | iTrId
The ID of the last transaction on which an event was received.

Detailed Description

@private
Since:
7.0 This class acts as a hub for the receipt of Connection-Oriented WSP session and transaction events.

It is an Active Object, and each time the method Start() is called, it requests an event from the NWSS WAP Stack. Upon completion of the request, the incoming event is examined, and its type (session or transaction) is determined. A call-back method appropriate to the event type is called on either the MNwssTransactionEventHandler or MNwssSessionEventHandler interfaces that 'observes' the object. In the case of transaction events, the NWSS WAP Stack's transaction handle (a RWSPCOTrans object) is passed through along with the event.

Definition at line 40 of file CNwssWspCOEventDispatcher.h.

Constructor & Destructor Documentation

CNwssWspCOEventDispatcher::~CNwssWspCOEventDispatcher ( ) [virtual]

Intended Usage: Destructor.

Since:
7.0

CNwssWspCOEventDispatcher::CNwssWspCOEventDispatcher | ( | RWSPCOConn & | aWspSession,
 |  | MNwssSessionEventHandler & | aSessEventHnd,
 |  | MNwssTransactionEventHandler & | aTransEventHnd,
 |  | MNwssOomHandler & | aOutOfMemoryHnd
 | ) | [private]

Member Function Documentation

void CNwssWspCOEventDispatcher::DoCancel ( ) [private, virtual]

Intended Usage: Cancellation protocol for the active object.

It cancels the request GetNextEvent() request it keeps outstanding with the WAP Stack.

Since:
7.0

CNwssWspCOEventDispatcher* CNwssWspCOEventDispatcher::NewL | ( | RWSPCOConn & | aWspSession,
 |  | MNwssSessionEventHandler & | aSessEventHnd,
 |  | MNwssTransactionEventHandler & | aTransEventHnd,
 |  | MNwssOomHandler & | aOutOfMemoryHnd
 | ) | [static]

TInt CNwssWspCOEventDispatcher::RunError ( TInt aError ) [private, virtual]

Intended Usage: Called if RunL leaves, to allow the AO to handle the error before the scheduler does

Since:
7.0.

Parameters:
aError (in) The error code to be handled, which RunL() left with
Returns:
A final error code, should aError not have been handled, which the active scheduler handles.

void CNwssWspCOEventDispatcher::RunL ( ) [private, virtual]

Intended Usage: Called when the active object fires, ie.

its asynchronous request has completed

Since:
7.0 @leaves System error codes, e.g. KErrNoMemory and internal error codes generated for WTLS handshake failures, see <wsperror.h>

void CNwssWspCOEventDispatcher::Start ( )

Intended Usage: Start waiting for stack events.

The dispatcher goes active, and will repeatedly request events from the WAP Stack, until it is subsequently cancelled.

Since:
7.0

Member Data Documentation

MNwssOomHandler& CNwssWspCOEventDispatcher::iOutOfMemoryHnd [private]

Handler for out-of-memory situations.

Definition at line 156 of file CNwssWspCOEventDispatcher.h.

MNwssSessionEventHandler& CNwssWspCOEventDispatcher::iSessEventHnd [private]

Handler for session events received at the dispatcher.

Definition at line 146 of file CNwssWspCOEventDispatcher.h.

RWSPCOTrans CNwssWspCOEventDispatcher::iTransaction [private]

The transaction handle on which transaction events occur.

Definition at line 166 of file CNwssWspCOEventDispatcher.h.

MNwssTransactionEventHandler& CNwssWspCOEventDispatcher::iTransEventHnd [private]

Handler for transaction events received at the dispatcher.

Definition at line 151 of file CNwssWspCOEventDispatcher.h.

RWSPCOTrans::TTransID CNwssWspCOEventDispatcher::iTrId [private]

The ID of the last transaction on which an event was received.

Definition at line 171 of file CNwssWspCOEventDispatcher.h.

RWSPCOConn::TEvent CNwssWspCOEventDispatcher::iWspEvent [private]

The event that has occured.

Definition at line 161 of file CNwssWspCOEventDispatcher.h.

RWSPCOConn& CNwssWspCOEventDispatcher::iWspSession [private]

The WSP Session handle.

This is not owned, opened or closed in this class.

Definition at line 141 of file CNwssWspCOEventDispatcher.h.

The documentation for this class was generated from the following file:
  • CNwssWspCOEventDispatcher.h


Member List

CNwssWspCOEventDispatcher Member List

This is the complete list of members for CNwssWspCOEventDispatcher, including all inherited members.
CNwssWspCOEventDispatcher(RWSPCOConn &aWspSession, MNwssSessionEventHandler &aSessEventHnd, MNwssTransactionEventHandler &aTransEventHnd, MNwssOomHandler &aOutOfMemoryHnd) | CNwssWspCOEventDispatcher | [private]
DoCancel() | CNwssWspCOEventDispatcher | [private, virtual]
iOutOfMemoryHnd | CNwssWspCOEventDispatcher | [private]
iSessEventHnd | CNwssWspCOEventDispatcher | [private]
iTransaction | CNwssWspCOEventDispatcher | [private]
iTransEventHnd | CNwssWspCOEventDispatcher | [private]
iTrId | CNwssWspCOEventDispatcher | [private]
iWspEvent | CNwssWspCOEventDispatcher | [private]
iWspSession | CNwssWspCOEventDispatcher | [private]
NewL(RWSPCOConn &aWspSession, MNwssSessionEventHandler &aSessEventHnd, MNwssTransactionEventHandler &aTransEventHnd, MNwssOomHandler &aOutOfMemoryHnd) | CNwssWspCOEventDispatcher | [static]
RunError(TInt aError) | CNwssWspCOEventDispatcher | [private, virtual]
RunL() | CNwssWspCOEventDispatcher | [private, virtual]
Start() | CNwssWspCOEventDispatcher |
~CNwssWspCOEventDispatcher() | CNwssWspCOEventDispatcher | [virtual]


CNwssWspCOSession Class Reference

@public
Since:
7.0 This class encapsulates a Connection-Oriented WSP session by specialising CNwssWspSession.
More...

#include <CNwssWspCOSession.h>

Inheritance diagram for CNwssWspCOSession:

[legend]
Collaboration diagram for CNwssWspCOSession:

[legend]
List of all members.

Public Methods

virtual | ~CNwssWspCOSession ()
Intended Usage: Destructor.

Static Public Methods

CNwssWspCOSession * | NewL (RStringPool &aStringPool, MNwssWapServer &aWapStackProvider, MConnectionInfoProvider &aConnInfoProvider, MSecurityPolicy &aSecurityPolicy, MWspCOSessionCallback &aSessionCB)
Intended Usage: Factory construction of the CNwssWspCOSession class.

Private Types

enum TAbortReason {
EUnknown = -1, EWapStackTimeout = 8, EProtoErr = 0xe0, EDisconnect = 0xe1,
ESuspend = 0xe2, EResume = 0xe3, ECongestion = 0xe4, EConnectErr = 0xe5,
EMRUExceeded = 0xe6, EMORExceeded = 0xe7, EPeerReq = 0xe8, ENetErr = 0xe9,
EUserReq = 0xea
}
An enumeration of the reasons for aborting a transaction. More...

Private Methods

virtual TInt | OpenWspSession (const TDesC8 &aRemoteHost, RWAPConn::TPort aRemotePort, RWAPConn::TPort aLocalPort, TBearer aBearer, TBool aSecureConn)
Intended Usage: Hook provided to the parent class allowing it to cause a Connection-Oriented WSP session to the specified proxy to be opened.

virtual TInt | CloseWspSession ()
Intended Usage: Hook provided to the parent class allowing it to cause an opened Connection-Oriented WSP session to be closed.

virtual void | CompleteProxyConnectionL ()
Intended Usage: Hook provided to the parent class allowing it to perform any required actions to complete a connection to the WAP Proxy after the WSP session has been opened, and optionally a WTLS handshake performed.

virtual RWTLS | WtlsHnd ()
Intended Usage: Hook provided to the parent class allowing it to obtain the WTLS handle from the current opened Connection-Oriented WSP session.

virtual void | DoRunError (TInt aError)
Intended Usage: Allows this class to to perform specific actions in response to the parent class' RunError().

virtual TBool | SubDoCancel ()
Intended Usage: Called from DoCancel ofthe parent class' RunError() in the EReady state.

virtual void | ConnectReq ()
This represents the S-Connect.req primitive.

virtual void | DisconnectReq (TWspReason aReason)
This represents the S-Disconnect.req primitive.

virtual void | SuspendReq ()
This represents the S-Suspend.req primitive.

virtual void | ResumeReq ()
This represents the S-Resume.req primitive.

virtual void | MethodInvokeReq (MWspCOMethodCallback &aTransactionCallback, RStringF aMethod, const TUriC8 &aRequestUri, const TDesC8 &aRequestHeaders, const TDesC8 &aRequestBody, TBool aMoreData)
This represents the S-MethodInvoke.req primitive.

virtual void | MethodInvokeDataReq (MWspCOMethodCallback &aTransactionCallback, const TDesC8 &aRequestBody, const TDesC8 &aTrailerHeaders, TBool aMoreData)
This represents the S-MethodInvokeData.req primitive.

virtual void | MethodAbortReq (MWspCOMethodCallback &aTransactionCallback)
This represents the S-MethodAbort.req primitive.

virtual void | MethodResultRes (MWspCOMethodCallback &aTransactionCallback, const TDesC8 &aAckHeaders)
This represents the S-MethodResult.res primitive.

virtual void | MethodResultDataRes (MWspCOMethodCallback &aTransactionCallback, const TDesC8 &aAckHeaders)
This represents the S-MethodResultData.res primitive.

virtual void | HandleDisconnectIndL ()
This represents the S-Disconnect.ind primitive.

virtual void | HandleSuspendIndL ()
This represents the S-Suspend.ind primitive.

virtual void | HandleResumeCnfL ()
This represents the S-Resume.cnf primitive.

virtual void | HandleConnectCnfL ()
This represents the S-Connect.cnf primitive.

virtual void | HandleRedirectIndL ()
This represents the S-Disconnect.ind (redirect) primitive.

virtual void | HandleExceptionIndL ()
This represents the E-Exception.ind primitive.

virtual void | HandleMethodInvokeCnfL (RWSPCOTrans::TTransID aTransId)
This represents the T-MethodInvoke.cnf primitive.

virtual void | HandleMethodResultIndL (RWSPCOTrans::TTransID aTransId)
This represents the T-MethodResult.ind primitive.

virtual void | HandleAbortIndL (RWSPCOTrans::TTransID aTransId)
This represents the T-MethodAbort.ind primitive.

void | ScheduleDelayedOomMethodAbort (MWspCOMethodCallback &aMethodToAbort, TBool aAbortOnStack)
void | ScheduleDelayedOomDisconnect (TBool aDisconnectOnStack)
virtual void | SendOomMethodAbort (MWspCOMethodCallback &aMethodToAbort, TBool aAbortOnStack)
virtual void | SendOomMethodAbort (RWSPCOTrans::TTransID aTransId, TBool aAbortOnStack)
virtual void | SendOomDisconnect (TBool aDisconnectOnStack)
CNwssWspCOSession (RStringPool &aStringPool, MNwssWapServer &aWapStackProvider, MConnectionInfoProvider &aConnInfoProvider, MSecurityPolicy &aSecurityPolicy, MWspCOSessionCallback &aSessionCB)
void | ConstructL ()
Intended Usage: Second phase of construction.

void | PrepareClientCapabilities ()
Intended Usage: Helper to ConnectReq, configures a capability codec to reflect the capabilities proposed by the client.

void | SetNegotiatedCapabilitiesL ()
Intended Usage: Helper to HandleConnectCnf, uses the capability codec to return the capabilities negotiated with the proxy.

TInt | GetSessionData (TDes8 &aBuffer, RWSPCOConn::TSessionDataType aType)
Intended Usage: Helper in the extraction of WSP session data from the NWSS WAP stack.

HBufC8 * | GetAllSessionDataLC (RWSPCOConn::TSessionDataType aType)
Intended Usage: Helper in the extraction of WSP session data from the NWSS WAP stack.

TInt | GetTransactionData (RWSPCOTrans aTransaction, TDes8 &aBuffer, RWSPCOTrans::TDataType aType)
Intended Usage: Helper in the extraction of WSP transaction data from the NWSS WAP stack.

HBufC8 * | GetAllTransactionDataLC (RWSPCOTrans aTransaction, RWSPCOTrans::TDataType aType)
void | ExtractRedirectedProxyInfoL (const TDesC8 &aRedirectedAddresses)
Intended Usage: Utility to convert a buffer received as the 'redirect addresses' after an S-Disconnect.ind (Redirect) event, into the structure used in the adaptation API to represent a redirect address.

void | DoSendDisconnectInd (Wap::TWspReason aReason, TBool aRedirectSecurity, TWspRedirectedAddress &aRedirectAddress, const TDesC8 &aErrorHeader, const TDesC8 &aErrorBody)

Static Private Methods

TInt | DelayedSendOomMethodAbort (TAny *aPtr)
TInt | DelayedSendOomDisconnect (TAny *aPtr)

Private Attributes

RWSPCOConn | iWspCOSession
Connection-oriented WAP Stack session.

CNwssTransLookUpTable * iCOTransTable
The transaction look-up table.

MWspCOSessionCallback & iSessionCB
The client's callback for session events.

CNwssWspCOEventDispatcher * iEventDispatcher
A hub to receive events from the WAP stack.

CCapCodec * | iCapabilityCodec
A codec for client and server capabilities.

HBufC * | iUriBuffer
A scratch buffer used for URLs, which must be converted from 8-bit to Unicode when submitting transactions to the WAP stack.

HBufC8 * | iSessDataBuffer
A scratch buffer used for retrieving session data.

TUint8 | iMethodMOR
The negotiated Method Maximum Outstanding Requests (MOR) value.

TBool | iUseAckHdrs
The negotiated 'Use Acknowledgement Headers' protocol option.

TWspRedirectedAddress iRedirectAddr
A parsed redirect address.

TBool | iInConnectLimbo
A flag indicating that S-Connect.req has been sent by the client but has yet to be sent to the WAP Stack.

CNwssConnectGuard * iConnectGuard
Object that handles the connect limbo state.

CNwssWspTransactionEventFilter * iTransEventFilter
Object used to filter transaction events from the NWSS stack and to ensure that T-MethodAbort.ind events are sent for transactions in EDone state.

CNwssWspSessionEventFilter * iSessionEventFilter
Object used to filter session events from the NWSS stack to ensure WSP spec compliance.

CAsyncCallBack * | iOOMCallBack
Object used to get an asynchronous, one-off callback, in order to break the callstack from the client when OOM forces us to abort their T-MethodInvoke.req.

TDelayedMethodAbortPckg iAbortPckg
Structure that holds some info needed by the TCallback method that sends a deferred T-MethodAbort.ind in OOM situations experienced during a T-MethodInvoke.req.

TDelayedDisconnectPckg iDisconnectPckg
Structure that holds some info needed by the TCallback method that sends a deferred S-Disconnect.ind in OOM situations experienced during a S-Disconnect.req.

Detailed Description

@public
Since:
7.0 This class encapsulates a Connection-Oriented WSP session by specialising CNwssWspSession.

It is responsible for making the majority of the calls on the underlying NWSS WAP protocol stack. It has five main areas of functionality: 1. Opening, and connecting, the handle for a WSP CO session using the proxy information supplied by the client (OpenWspSession() and CompleteProxyConnectionL()) 2. Converting the requested client capabilities from the M-class interfaces supplied by the client into a CCapCodec object, as used by the NWSS WAP stack (PrepareClientCapabilities()) 3. Doing the reverse for negotiated capabilities that are received from the WAP Proxy before passing back to the client (SetNegotiatedCapabilitiesL()). 4. Implementing the MWspCOSessionInvoker and MWspCOMethodInvoker interfaces, and translating each of the primitives exposed by these interfaces into calls on the underlying NWSS WAP Stack. 5. Implementing the MNwssSessionEventHandler and MNwssTransactionEventHandler interfaces, in order that events received from the underlying WAP Stack (by the class CNwssWspCOEventDispatcher) may be converted into the primitives exposed by the client's callback interfaces MWspCOSessionCallback and MWspCOMethodCallback.

Definition at line 63 of file CNwssWspCOSession.h.

Member Enumeration Documentation

enum CNwssWspCOSession::TAbortReason [private]

An enumeration of the reasons for aborting a transaction.

Not all might might have meaning for both CO and CL WSP sessions. Note that this type should be in <wapcli.h> but was omitted there for some reason.

Enumeration values:
EUnknown
EWapStackTimeout
EProtoErr
EDisconnect
ESuspend
EResume
ECongestion
EConnectErr
EMRUExceeded
EMORExceeded
EPeerReq
ENetErr
EUserReq

Definition at line 528 of file CNwssWspCOSession.h.

Constructor & Destructor Documentation

CNwssWspCOSession::~CNwssWspCOSession ( ) [virtual]

Intended Usage: Destructor.

Since:
7.0

CNwssWspCOSession::CNwssWspCOSession | ( | RStringPool & | aStringPool,
 |  | MNwssWapServer & | aWapStackProvider,
 |  | MConnectionInfoProvider & | aConnInfoProvider,
 |  | MSecurityPolicy & | aSecurityPolicy,
 |  | MWspCOSessionCallback & | aSessionCB
 | ) | [private]

Member Function Documentation

TInt CNwssWspCOSession::CloseWspSession ( ) [private, virtual]

Intended Usage: Hook provided to the parent class allowing it to cause an opened Connection-Oriented WSP session to be closed.

Since:
7.0
Returns:
A system error code originating from the NWSS WAP Stack.

Implements CNwssWspSession.

void CNwssWspCOSession::CompleteProxyConnectionL ( ) [private, virtual]

Intended Usage: Hook provided to the parent class allowing it to perform any required actions to complete a connection to the WAP Proxy after the WSP session has been opened, and optionally a WTLS handshake performed.

For connection-oriented WSP, this implies the use of RWSPCOConn::Connect() to send the S-Connect.cnf primitive to the proxy. This initiates the connection, with an exchange of capability information and session headers.

Since:
7.0 @leaves A system error code originating from the NWSS WAP Stack.

Implements CNwssWspSession.

virtual void CNwssWspCOSession::ConnectReq ( ) [private, virtual]

This represents the S-Connect.req primitive.

See also:
MWspCOSessionInvoker

Implements MWspCOSessionInvoker.

void CNwssWspCOSession::ConstructL ( ) [private]

Intended Usage: Second phase of construction.

Allocations may be made here.

Since:
7.0 @leaves System error codes, e.g. KErrNoMemory.

TInt CNwssWspCOSession::DelayedSendOomDisconnect ( TAny * aPtr ) [static, private]

TInt CNwssWspCOSession::DelayedSendOomMethodAbort ( TAny * aPtr ) [static, private]

virtual void CNwssWspCOSession::DisconnectReq ( TWspReason aReason ) [private, virtual]

This represents the S-Disconnect.req primitive.

See also:
MWspCOSessionInvoker

Implements MWspCOSessionInvoker.

void CNwssWspCOSession::DoRunError ( TInt aError ) [private, virtual]

Intended Usage: Allows this class to to perform specific actions in response to the parent class' RunError().

This is called in the EReady state. This handles situations where CompleteProxyConnectionL() has left. In practice, this handles errors arising from the use of RWSPCOConn::Connect().

Since:
7.0
Parameters:
aError (in) The error code to be handled, with which CompleteProxyConnectionL() left.

Implements CNwssWspSession.

void CNwssWspCOSession::DoSendDisconnectInd | ( | Wap::TWspReason | aReason,
 |  | TBool | aRedirectSecurity,
 |  | TWspRedirectedAddress & | aRedirectAddress,
 |  | const TDesC8 & | aErrorHeader,
 |  | const TDesC8 & | aErrorBody
 | ) | [private]

void CNwssWspCOSession::ExtractRedirectedProxyInfoL ( const TDesC8 & aRedirectedAddresses ) [private]

Intended Usage: Utility to convert a buffer received as the 'redirect addresses' after an S-Disconnect.ind (Redirect) event, into the structure used in the adaptation API to represent a redirect address.

The address is written into the structure iRedirectAddr.

Since:
7.0
Parameters:
aRedirectedAddresses (in) The raw WSP-encoded address data @leave System error codes, e.g. KErrNoMemory

HBufC8 * CNwssWspCOSession::GetAllSessionDataLC ( RWSPCOConn::TSessionDataType aType ) [private]

Intended Usage: Helper in the extraction of WSP session data from the NWSS WAP stack.

This method retrieves all data of a named type, allocating a heap descriptor large enough to hold it all. Should be used for data of unknown size.

Since:
7.0
Parameters:
aType (in) The type of the session data to be extracted
Returns:
A heap-allocated 8-bit buffer to contain the session data. This buffer is left on the clean-up stack. @leave System error codes, e.g. KErrNoMemory

HBufC8* CNwssWspCOSession::GetAllTransactionDataLC | ( | RWSPCOTrans | aTransaction,
 |  | RWSPCOTrans::TDataType | aType
 | ) | [private]

void CNwssWspCOSession::GetSessionData | ( | TDes8 & | aBuffer,
 |  | RWSPCOConn::TSessionDataType | aType
 | ) | [private]

Intended Usage: Helper in the extraction of WSP session data from the NWSS WAP stack.

Should be used when the data size is known in advance and may be passed as a buffer like TPckgBuf<TUint> for example.

Warning:
It will Panic the client if there is more data available than the buffer can hold!
Since:
7.0
Parameters:
aBuffer | (in) The client's pre-allocated buffer
aType | (in) The type of the session data to be extracted
Returns:
A WAP stack error code

TInt CNwssWspCOSession::GetTransactionData | ( | RWSPCOTrans | aTransaction,
 |  | TDes8 & | aBuffer,
 |  | RWSPCOTrans::TDataType | aType
 | ) | [private]

Intended Usage: Helper in the extraction of WSP transaction data from the NWSS WAP stack.

Should be used when the data size is known in advance and may be passed as a buffer like TPckgBuf<TUint> for example.

Warning:
It will Panic the client if there is more data available than the buffer can hold!
Since:
7.0
Parameters:
aTransaction | (in) The stack transaction handle
aBuffer | (in) The client's pre-allocated buffer
aType | (in) The type of the transaction data to be extracted
Returns:
A WAP stack error code

virtual void CNwssWspCOSession::HandleAbortIndL ( RWSPCOTrans::TTransID aTransId ) [private, virtual]

This represents the T-MethodAbort.ind primitive.

See also:
MNwssTransactionEventHandler

Implements MNwssTransactionEventHandler.

virtual void CNwssWspCOSession::HandleConnectCnfL ( ) [private, virtual]

This represents the S-Connect.cnf primitive.

See also:
MNwssSessionEventHandler

Implements MNwssSessionEventHandler.

virtual void CNwssWspCOSession::HandleDisconnectIndL ( ) [private, virtual]

This represents the S-Disconnect.ind primitive.

See also:
MNwssSessionEventHandler

Implements MNwssSessionEventHandler.

virtual void CNwssWspCOSession::HandleExceptionIndL ( ) [private, virtual]

This represents the E-Exception.ind primitive.

See also:
MNwssSessionEventHandler

Implements MNwssSessionEventHandler.

virtual void CNwssWspCOSession::HandleMethodInvokeCnfL ( RWSPCOTrans::TTransID aTransId ) [private, virtual]

This represents the T-MethodInvoke.cnf primitive.

See also:
MNwssTransactionEventHandler

Implements MNwssTransactionEventHandler.

virtual void CNwssWspCOSession::HandleMethodResultIndL ( RWSPCOTrans::TTransID aTransId ) [private, virtual]

This represents the T-MethodResult.ind primitive.

See also:
MNwssTransactionEventHandler

Implements MNwssTransactionEventHandler.

virtual void CNwssWspCOSession::HandleRedirectIndL ( ) [private, virtual]

This represents the S-Disconnect.ind (redirect) primitive.

See also:
MNwssSessionEventHandler

Implements MNwssSessionEventHandler.

virtual void CNwssWspCOSession::HandleResumeCnfL ( ) [private, virtual]

This represents the S-Resume.cnf primitive.

See also:
MNwssSessionEventHandler

Implements MNwssSessionEventHandler.

virtual void CNwssWspCOSession::HandleSuspendIndL ( ) [private, virtual]

This represents the S-Suspend.ind primitive.

See also:
MNwssSessionEventHandler

Implements MNwssSessionEventHandler.

virtual void CNwssWspCOSession::MethodAbortReq ( MWspCOMethodCallback & aTransactionCallback ) [private, virtual]

This represents the S-MethodAbort.req primitive.

See also:
MWspCOSessionInvoker

Implements MWspCOMethodInvoker.

virtual void CNwssWspCOSession::MethodInvokeDataReq | ( | MWspCOMethodCallback & | aTransactionCallback,
 |  | const TDesC8 & | aRequestBody,
 |  | const TDesC8 & | aTrailerHeaders,
 |  | TBool | aMoreData
 | ) | [private, virtual]

This represents the S-MethodInvokeData.req primitive.

See also:
MWspCOSessionInvoker

Implements MWspCOMethodInvoker.

virtual void CNwssWspCOSession::MethodInvokeReq | ( | MWspCOMethodCallback & | aTransactionCallback,
 |  | RStringF | aMethod,
 |  | const TUriC8 & | aRequestUri,
 |  | const TDesC8 & | aRequestHeaders,
 |  | const TDesC8 & | aRequestBody,
 |  | TBool | aMoreData
 | ) | [private, virtual]

This represents the S-MethodInvoke.req primitive.

See also:
MWspCOSessionInvoker

Implements MWspCOMethodInvoker.

virtual void CNwssWspCOSession::MethodResultDataRes | ( | MWspCOMethodCallback & | aTransactionCallback,
 |  | const TDesC8 & | aAckHeaders
 | ) | [private, virtual]

This represents the S-MethodResultData.res primitive.

See also:
MWspCOSessionInvoker

Implements MWspCOMethodInvoker.

virtual void CNwssWspCOSession::MethodResultRes | ( | MWspCOMethodCallback & | aTransactionCallback,
 |  | const TDesC8 & | aAckHeaders
 | ) | [private, virtual]

This represents the S-MethodResult.res primitive.

See also:
MWspCOSessionInvoker

Implements MWspCOMethodInvoker.

static CNwssWspCOSession * CNwssWspCOSession::NewL | ( | RStringPool & | aStringPool,
 |  | MNwssWapServer & | aWapStackProvider,
 |  | MConnectionInfoProvider & | aConnInfoProvider,
 |  | MSecurityPolicy & | aSecurityPolicy,
 |  | MWspCOSessionCallback & | aSessionCB
 | ) | [static]

Intended Usage: Factory construction of the CNwssWspCOSession class.

Since:
7.0
Parameters:
aStringPool | (in) The client's string pool.
aWapStackProvider | (in) An owner of a WAP stack server session.
aConnInfoProvider | (in) A collection of client interfaces that provide connection-related information
aSecurityPolicy | (in) A security policy provider.
aSessionCB | (in) The client's callback for receiving WSP session events
Returns:
The newly constructed CNwssWspCOSession instance. @leaves System error codes, e.g. KErrNoMemory.

TInt CNwssWspCOSession::OpenWspSession | ( | const TDesC8 & | aRemoteHost,
 |  | RWAPConn::TPort | aRemotePort,
 |  | RWAPConn::TPort | aLocalPort,
 |  | TBearer | aBearer,
 |  | TBool | aSecureConn
 | ) | [private, virtual]

Intended Usage: Hook provided to the parent class allowing it to cause a Connection-Oriented WSP session to the specified proxy to be opened.

Since:
7.0
Parameters:
aRemoteHost | (in) The bearer-dependent address of the proxy.
aRemotePort | (in) The proxy port to which a connection is made.
aLocalPort | (in) (optional) The local port to which proxy replies are sent. A value of zero means 'don't care'.
aBearer | (in) The bearer on which the connection is made.
aSecureConn | (in) Flag indicating whether WTLS is to be used.
Returns:
A system error code originating from the NWSS WAP Stack.

Implements CNwssWspSession.

void CNwssWspCOSession::PrepareClientCapabilities ( ) [private]

Intended Usage: Helper to ConnectReq, configures a capability codec to reflect the capabilities proposed by the client.

Since:
7.0

virtual void CNwssWspCOSession::ResumeReq ( ) [private, virtual]

This represents the S-Resume.req primitive.

See also:
MWspCOSessionInvoker

Implements MWspCOSessionInvoker.

void CNwssWspCOSession::ScheduleDelayedOomDisconnect ( TBool aDisconnectOnStack ) [private]

void CNwssWspCOSession::ScheduleDelayedOomMethodAbort | ( | MWspCOMethodCallback & | aMethodToAbort,
 |  | TBool | aAbortOnStack
 | ) | [private]

virtual void CNwssWspCOSession::SendOomDisconnect ( TBool aDisconnectOnStack ) [private, virtual]

Implements MNwssOomHandler.

virtual void CNwssWspCOSession::SendOomMethodAbort | ( | RWSPCOTrans::TTransID | aTransId,
 |  | TBool | aAbortOnStack
 | ) | [private, virtual]

Implements MNwssOomHandler.

virtual void CNwssWspCOSession::SendOomMethodAbort | ( | MWspCOMethodCallback & | aMethodToAbort,
 |  | TBool | aAbortOnStack
 | ) | [private, virtual]

Implements MNwssOomHandler.

void CNwssWspCOSession::SetNegotiatedCapabilitiesL ( ) [private]

Intended Usage: Helper to HandleConnectCnf, uses the capability codec to return the capabilities negotiated with the proxy.

Since:
7.0 @leaves System error codes, e.g. KErrNoMemory.

TBool CNwssWspCOSession::SubDoCancel ( ) [private, virtual]

Intended Usage: Called from DoCancel ofthe parent class' RunError() in the EReady state.

This class cancels outstanding asynchronous requests it makes from the Event Dispatcher.

Since:
7.0
Returns:
Flag indicating whether, following cancellation, this class must return to the EDisconnected state.

Implements CNwssWspSession.

virtual void CNwssWspCOSession::SuspendReq ( ) [private, virtual]

This represents the S-Suspend.req primitive.

See also:
MWspCOSessionInvoker

Implements MWspCOSessionInvoker.

RWTLS CNwssWspCOSession::WtlsHnd ( ) [private, virtual]

Intended Usage: Hook provided to the parent class allowing it to obtain the WTLS handle from the current opened Connection-Oriented WSP session.

Since:
7.0
Returns:
A handle for the WTLS layer of the WAP protocol stack.

Implements CNwssWspSession.

Member Data Documentation

TDelayedMethodAbortPckg CNwssWspCOSession::iAbortPckg [private]

Structure that holds some info needed by the TCallback method that sends a deferred T-MethodAbort.ind in OOM situations experienced during a T-MethodInvoke.req.

Definition at line 632 of file CNwssWspCOSession.h.

CCapCodec* CNwssWspCOSession::iCapabilityCodec [private]

A codec for client and server capabilities.

Definition at line 571 of file CNwssWspCOSession.h.

CNwssConnectGuard* CNwssWspCOSession::iConnectGuard [private]

Object that handles the connect limbo state.

Definition at line 608 of file CNwssWspCOSession.h.

CNwssTransLookUpTable* CNwssWspCOSession::iCOTransTable [private]

The transaction look-up table.

Definition at line 556 of file CNwssWspCOSession.h.

TDelayedDisconnectPckg CNwssWspCOSession::iDisconnectPckg [private]

Structure that holds some info needed by the TCallback method that sends a deferred S-Disconnect.ind in OOM situations experienced during a S-Disconnect.req.

Definition at line 638 of file CNwssWspCOSession.h.

CNwssWspCOEventDispatcher* CNwssWspCOSession::iEventDispatcher [private]

A hub to receive events from the WAP stack.

Definition at line 566 of file CNwssWspCOSession.h.

TBool CNwssWspCOSession::iInConnectLimbo [private]

A flag indicating that S-Connect.req has been sent by the client but has yet to be sent to the WAP Stack.

Definition at line 603 of file CNwssWspCOSession.h.

TUint8 CNwssWspCOSession::iMethodMOR [private]

The negotiated Method Maximum Outstanding Requests (MOR) value.

Definition at line 587 of file CNwssWspCOSession.h.

CAsyncCallBack* CNwssWspCOSession::iOOMCallBack [private]

Object used to get an asynchronous, one-off callback, in order to break the callstack from the client when OOM forces us to abort their T-MethodInvoke.req.

Definition at line 626 of file CNwssWspCOSession.h.

TWspRedirectedAddress CNwssWspCOSession::iRedirectAddr [private]

A parsed redirect address.

Definition at line 597 of file CNwssWspCOSession.h.

HBufC8* CNwssWspCOSession::iSessDataBuffer [private]

A scratch buffer used for retrieving session data.

Definition at line 582 of file CNwssWspCOSession.h.

MWspCOSessionCallback& CNwssWspCOSession::iSessionCB [private]

The client's callback for session events.

Definition at line 561 of file CNwssWspCOSession.h.

CNwssWspSessionEventFilter* CNwssWspCOSession::iSessionEventFilter [private]

Object used to filter session events from the NWSS stack to ensure WSP spec compliance.

Definition at line 620 of file CNwssWspCOSession.h.

CNwssWspTransactionEventFilter* CNwssWspCOSession::iTransEventFilter [private]

Object used to filter transaction events from the NWSS stack and to ensure that T-MethodAbort.ind events are sent for transactions in EDone state.

Definition at line 614 of file CNwssWspCOSession.h.

HBufC* CNwssWspCOSession::iUriBuffer [private]

A scratch buffer used for URLs, which must be converted from 8-bit to Unicode when submitting transactions to the WAP stack.

Definition at line 577 of file CNwssWspCOSession.h.

TBool CNwssWspCOSession::iUseAckHdrs [private]

The negotiated 'Use Acknowledgement Headers' protocol option.

Definition at line 592 of file CNwssWspCOSession.h.

RWSPCOConn CNwssWspCOSession::iWspCOSession [private]

Connection-oriented WAP Stack session.

Definition at line 551 of file CNwssWspCOSession.h.

The documentation for this class was generated from the following file:
  • CNwssWspCOSession.h


Member List

CNwssWspCOSession Member List

This is the complete list of members for CNwssWspCOSession, including all inherited members.
BaseConstructL() | CNwssWspSession | [protected]
CloseWspSession() | CNwssWspCOSession | [private, virtual]
CNwssWspCOSession(RStringPool &aStringPool, MNwssWapServer &aWapStackProvider, MConnectionInfoProvider &aConnInfoProvider, MSecurityPolicy &aSecurityPolicy, MWspCOSessionCallback &aSessionCB) | CNwssWspCOSession | [private]
CNwssWspSession(RStringPool &aStringPool, MNwssWapServer &aWapStackProvider, MConnectionInfoProvider &aConnInfoProvider, MSecurityPolicy &aSecurityPolicy) | CNwssWspSession | [protected]
CompleteProxyConnectionL() | CNwssWspCOSession | [private, virtual]
ConnectReq() | CNwssWspCOSession | [private, virtual]
ConstructL() | CNwssWspCOSession | [private]
DelayedSendOomDisconnect(TAny *aPtr) | CNwssWspCOSession | [private, static]
DelayedSendOomMethodAbort(TAny *aPtr) | CNwssWspCOSession | [private, static]
DisconnectReq(TWspReason aReason) | CNwssWspCOSession | [private, virtual]
DoRunError(TInt aError) | CNwssWspCOSession | [private, virtual]
DoSendDisconnectInd(Wap::TWspReason aReason, TBool aRedirectSecurity, TWspRedirectedAddress &aRedirectAddress, const TDesC8 &aErrorHeader, const TDesC8 &aErrorBody) | CNwssWspCOSession | [private]
ECheckingNegotiated enum value | CNwssWspSession |
ECheckingServerCert enum value | CNwssWspSession |
ECongestion enum value | CNwssWspCOSession | [private]
EConnectErr enum value | CNwssWspCOSession | [private]
EDisconnect enum value | CNwssWspCOSession | [private]
EDisconnected enum value | CNwssWspSession |
EDoingWtlsPhase1 enum value | CNwssWspSession |
EDoingWtlsPhase2 enum value | CNwssWspSession |
EMORExceeded enum value | CNwssWspCOSession | [private]
EMRUExceeded enum value | CNwssWspCOSession | [private]
ENetErr enum value | CNwssWspCOSession | [private]
EPeerReq enum value | CNwssWspCOSession | [private]
EProtoErr enum value | CNwssWspCOSession | [private]
EReady enum value | CNwssWspSession |
EResume enum value | CNwssWspCOSession | [private]
ESessionOpen enum value | CNwssWspSession |
ESuspend enum value | CNwssWspCOSession | [private]
EUnknown enum value | CNwssWspCOSession | [private]
EUserReq enum value | CNwssWspCOSession | [private]
EWapStackTimeout enum value | CNwssWspCOSession | [private]
ExtractRedirectedProxyInfoL(const TDesC8 &aRedirectedAddresses) | CNwssWspCOSession | [private]
GetAllSessionDataLC(RWSPCOConn::TSessionDataType aType) | CNwssWspCOSession | [private]
GetAllTransactionDataLC(RWSPCOTrans aTransaction, RWSPCOTrans::TDataType aType) | CNwssWspCOSession | [private]
GetSessionData(TDes8 &aBuffer, RWSPCOConn::TSessionDataType aType) | CNwssWspCOSession | [private]
GetTransactionData(RWSPCOTrans aTransaction, TDes8 &aBuffer, RWSPCOTrans::TDataType aType) | CNwssWspCOSession | [private]
HandleAbortIndL(RWSPCOTrans::TTransID aTransId) | CNwssWspCOSession | [private, virtual]
HandleConnectCnfL() | CNwssWspCOSession | [private, virtual]
HandleDisconnectIndL() | CNwssWspCOSession | [private, virtual]
HandleExceptionIndL() | CNwssWspCOSession | [private, virtual]
HandleMethodInvokeCnfL(RWSPCOTrans::TTransID aTransId) | CNwssWspCOSession | [private, virtual]
HandleMethodResultIndL(RWSPCOTrans::TTransID aTransId) | CNwssWspCOSession | [private, virtual]
HandleRedirectIndL() | CNwssWspCOSession | [private, virtual]
HandleResumeCnfL() | CNwssWspCOSession | [private, virtual]
HandleSuspendIndL() | CNwssWspCOSession | [private, virtual]
iAbortPckg | CNwssWspCOSession | [private]
iCapabilityCodec | CNwssWspCOSession | [private]
iConnectGuard | CNwssWspCOSession | [private]
iConnInfoProvider | CNwssWspSession | [protected]
iCOTransTable | CNwssWspCOSession | [private]
iDisconnectPckg | CNwssWspCOSession | [private]
iEventDispatcher | CNwssWspCOSession | [private]
iInConnectLimbo | CNwssWspCOSession | [private]
iMethodMOR | CNwssWspCOSession | [private]
InitiateProxyConnection() | CNwssWspSession | [protected]
iOOMCallBack | CNwssWspCOSession | [private]
iRedirectAddr | CNwssWspCOSession | [private]
iSessDataBuffer | CNwssWspCOSession | [private]
iSessionCB | CNwssWspCOSession | [private]
iSessionEventFilter | CNwssWspCOSession | [private]
iStringPool | CNwssWspSession | [protected]
iTransEventFilter | CNwssWspCOSession | [private]
iUriBuffer | CNwssWspCOSession | [private]
iUseAckHdrs | CNwssWspCOSession | [private]
iWapStackProvider | CNwssWspSession | [protected]
iWspCOSession | CNwssWspCOSession | [private]
MapToPanic(TInt aErrorCode) const | CNwssWspSession | [protected]
MethodAbortReq(MWspCOMethodCallback &aTransactionCallback) | CNwssWspCOSession | [private, virtual]
MethodInvokeDataReq(MWspCOMethodCallback &aTransactionCallback, const TDesC8 &aRequestBody, const TDesC8 &aTrailerHeaders, TBool aMoreData) | CNwssWspCOSession | [private, virtual]
MethodInvokeReq(MWspCOMethodCallback &aTransactionCallback, RStringF aMethod, const TUriC8 &aRequestUri, const TDesC8 &aRequestHeaders, const TDesC8 &aRequestBody, TBool aMoreData) | CNwssWspCOSession | [private, virtual]
MethodResultDataRes(MWspCOMethodCallback &aTransactionCallback, const TDesC8 &aAckHeaders) | CNwssWspCOSession | [private, virtual]
MethodResultRes(MWspCOMethodCallback &aTransactionCallback, const TDesC8 &aAckHeaders) | CNwssWspCOSession | [private, virtual]
NewL(RStringPool &aStringPool, MNwssWapServer &aWapStackProvider, MConnectionInfoProvider &aConnInfoProvider, MSecurityPolicy &aSecurityPolicy, MWspCOSessionCallback &aSessionCB) | CNwssWspCOSession | [static]
OpenWspSession(const TDesC8 &aRemoteHost, RWAPConn::TPort aRemotePort, RWAPConn::TPort aLocalPort, TBearer aBearer, TBool aSecureConn) | CNwssWspCOSession | [private, virtual]
PrepareClientCapabilities() | CNwssWspCOSession | [private]
ResumeReq() | CNwssWspCOSession | [private, virtual]
ScheduleDelayedOomDisconnect(TBool aDisconnectOnStack) | CNwssWspCOSession | [private]
ScheduleDelayedOomMethodAbort(MWspCOMethodCallback &aMethodToAbort, TBool aAbortOnStack) | CNwssWspCOSession | [private]
SendOomDisconnect(TBool aDisconnectOnStack) | CNwssWspCOSession | [private, virtual]
SendOomMethodAbort(MWspCOMethodCallback &aMethodToAbort, TBool aAbortOnStack) | CNwssWspCOSession | [private, virtual]
SendOomMethodAbort(RWSPCOTrans::TTransID aTransId, TBool aAbortOnStack) | CNwssWspCOSession | [private, virtual]
ServerCert(TCertInfo &aCertInfo) | CNwssWspSession |
SessionDisconnectedCallback() | CNwssWspSession | [protected]
SetNegotiatedCapabilitiesL() | CNwssWspCOSession | [private]
State() const | CNwssWspSession | [protected]
SubDoCancel() | CNwssWspCOSession | [private, virtual]
SuspendReq() | CNwssWspCOSession | [private, virtual]
TAbortReason enum name | CNwssWspCOSession | [private]
TState enum name | CNwssWspSession |
WtlsHnd() | CNwssWspCOSession | [private, virtual]
~CNwssWspCOSession() | CNwssWspCOSession | [virtual]
~CNwssWspSession() | CNwssWspSession | [virtual]


CNwssWspCOSession::TDelayedDisconnectPckg Struct Reference

Collaboration diagram for CNwssWspCOSession::TDelayedDisconnectPckg:

[legend]
List of all members.

Public Attributes

CNwssWspCOSession * iSession
TBool iDisconnectOnStack

Member Data Documentation

TBool CNwssWspCOSession::TDelayedDisconnectPckg::iDisconnectOnStack

Definition at line 346 of file CNwssWspCOSession.h.

CNwssWspCOSession* CNwssWspCOSession::TDelayedDisconnectPckg::iSession

Definition at line 345 of file CNwssWspCOSession.h.

The documentation for this struct was generated from the following file:
  • CNwssWspCOSession.h


Member List

CNwssWspCOSession::TDelayedDisconnectPckg Member List

This is the complete list of members for CNwssWspCOSession::TDelayedDisconnectPckg, including all inherited members.
iDisconnectOnStack | CNwssWspCOSession::TDelayedDisconnectPckg
iSession | CNwssWspCOSession::TDelayedDisconnectPckg


CNwssWspCOSession::TDelayedMethodAbortPckg Struct Reference

Collaboration diagram for CNwssWspCOSession::TDelayedMethodAbortPckg:

[legend]
List of all members.

Public Attributes

CNwssWspCOSession * iSession
MWspCOMethodCallback * iCallback
TBool iAbortOnStack

Member Data Documentation

TBool CNwssWspCOSession::TDelayedMethodAbortPckg::iAbortOnStack

Definition at line 334 of file CNwssWspCOSession.h.

MWspCOMethodCallback* CNwssWspCOSession::TDelayedMethodAbortPckg::iCallback

Definition at line 333 of file CNwssWspCOSession.h.

CNwssWspCOSession* CNwssWspCOSession::TDelayedMethodAbortPckg::iSession

Definition at line 332 of file CNwssWspCOSession.h.

The documentation for this struct was generated from the following file:
  • CNwssWspCOSession.h


Member List

CNwssWspCOSession::TDelayedMethodAbortPckg Member List

This is the complete list of members for CNwssWspCOSession::TDelayedMethodAbortPckg, including all inherited members.
iAbortOnStack | CNwssWspCOSession::TDelayedMethodAbortPckg
iCallback | CNwssWspCOSession::TDelayedMethodAbortPckg
iSession | CNwssWspCOSession::TDelayedMethodAbortPckg


CNwssWspSession Class Reference

@public
Since:
7.0 This abstract class encapsulates a WSP session as implemented by the NWSS WAP Stack.
More...

#include <CNwssWspSession.h>

Inheritance diagram for CNwssWspSession:

[legend]
Collaboration diagram for CNwssWspSession:

[legend]
List of all members.

Public Types

enum TState {
EDisconnected, ESessionOpen, EDoingWtlsPhase1, ECheckingServerCert,
EDoingWtlsPhase2, ECheckingNegotiated, EReady
}
An enumeration of the states the CNwssWspSession class can be in. More...

Public Methods

virtual | ~CNwssWspSession ()
Intended Usage: Destructor.

TInt | ServerCert (TCertInfo &aCertInfo)
Get the Server Certificate for this session.

Protected Methods

CNwssWspSession (RStringPool &aStringPool, MNwssWapServer &aWapStackProvider, MConnectionInfoProvider &aConnInfoProvider, MSecurityPolicy &aSecurityPolicy)
Intended Usage: Normal constructor.

void | BaseConstructL ()
Intended Usage: Second phase construction.

void | InitiateProxyConnection ()
Intended Usage: Used by sub-classes to initiate a new connection to a WAP proxy, the various steps of which are performed in an asynchronous state machine in this class.

TState | State () const
TInt | SessionDisconnectedCallback ()
Intended Usage: Callback for use by sub-classes, to indicate when the session with a WAP proxy has been disconnected.

void | MapToPanic (TInt aErrorCode) const
Intended Usage: Map NWSS stack error codes to local panic codes.

Protected Attributes

__DECLARE_LOG RStringPool & | iStringPool
The client's string pool - not opened or closed here.

MNwssWapServer & iWapStackProvider
The WAP Stack provider.

MConnectionInfoProvider & iConnInfoProvider
The client connection information provider.

Private Methods

virtual void | RunL ()
Intended Usage: Called when the active object fires, ie.

virtual TInt | RunError (TInt aError)
Intended Usage: Called if RunL leaves, to allow the AO to handle the error before the scheduler does
Since:
7.0.

virtual void | DoCancel ()
Intended Usage: Cancellation protocol for the active object.

virtual TInt | OpenWspSession (const TDesC8 &aRemoteHost, RWAPConn::TPort aRemotePort, RWAPConn::TPort aLocalPort, TBearer aBearer, TBool aSecureConn)=0
Intended Usage: Hook that allows the class to cause a particular type of WSP session to the specified proxy to be opened.

virtual TInt | CloseWspSession ()=0
Intended Usage: Hook that allows the class to cause an opened WSP session to be closed.

virtual void | CompleteProxyConnectionL ()=0
Intended Usage: Hook that allows the class to perform any required actions to complete a connection to the WAP Proxy after the WSP session has been opened, and optionally a WTLS handshake performed.

virtual RWTLS | WtlsHnd ()=0
Intended Usage: Obtains the WTLS handle from the current opened WSP session.

virtual void | DoRunError (TInt aError)=0
Intended Usage: Allows sub-classes to perform specific actions in response to this class' RunError().

virtual TBool | SubDoCancel ()=0
Intended Usage: Allows sub-classes to perform specific actions in response to this class' DoCancel().

TBool | OpenWapProxyL ()
Intended Usage: Open the WSP session to the proxy identified by the client's Proxy Info Provider.

void | DoWTLSConnectionPreHandshakeL ()
Intended Usage: Pre-handshake phase of WTLS negotiations with the WAP Stack.

void | DoWTLSConnectionPhaseOne (TBool aTwoPhaseHandshake)
Intended Usage: First phase of WTLS negotiations with the WAP Stack - the first of two phases for authentication, but the one and only phase for anonymous.

void | CancelWTLSConnectionPhaseOne ()
Intended Usage: Cancellation of phase 1 of the secure handshake, if eg.

void | ValidateUntrustedServerCertL ()
Intended Usage: Mid phase of WTLS negotiations - used only for authenticating connections - obtains the WAP Gateway certificate information and asks the security policy to determine if it the server can be trusted.

void | GetServerCertL ()
Intended Usage: Gets the server certificate from the wap stack and converts it to a TCertInfo which is stored in iServerCert.

void | CancelValidateUntrustedServerCert ()
Intended Usage: Cancel the validation of an untrusted server cert.

void | DoWTLSConnectionPhaseTwo ()
Intended Usage: Second phase of WTLS negotiations with the WAP Stack (used for authenticating connections only).

void | CancelWTLSConnectionPhaseTwo ()
Intended Usage: Cancellation of phase 2 of the secure handshake, if eg.

void | DoWTLSConnectionPostHandshakeL ()
Intended Usage: Post-security handshake finalisation of WTLS via the WAP Stack.

TBool | AnonymousAuthenticationAllowed ()
Intended Usage: Short-cut for call to the security policy plug-in, which checks a named property to see if anonymous authentication is allowed or not.

void | CompleteSelf ()
Intended Usage: Active object self completion.

Private Attributes

TState iState
State of the WSP session.

MSecurityPolicy & iSecurityPolicy
Security policy provider.

TBool | iHandshakeWasAnonymous
Flag that records if the secure handshake resulted in anonymous key exchange suites being agreed with the WAP proxy.

TCertInfo | iServerCert
Storage for the WAP proxy's server certificate, in the form used by the security policy plugin.

TBool | iServerCertValid
Flag indicating that the variable iServerCert contains a valid server certificate.

Detailed Description

@public
Since:
7.0 This abstract class encapsulates a WSP session as implemented by the NWSS WAP Stack.

It must be specialised to provide Connection-Oriented or Connectionless WSP services. It is an Active Object class, and uses an active state machine to drive a WTLS handshake through four phases. For non-secure WSP sessions, the handshake is skipped, and two phases are used to complete a WSP connection.

Definition at line 41 of file CNwssWspSession.h.

Member Enumeration Documentation

enum CNwssWspSession::TState

An enumeration of the states the CNwssWspSession class can be in.

When in the EReady state, further processing is done in the derived session class.

Enumeration values:
EDisconnected | the initial state following construction in which there is no WSP session open or connected
ESessionOpen | the state in which a WSP session has been opened (either CO or CL)
EDoingWtlsPhase1 | the state during a phase 1 WTLS handshake
ECheckingServerCert | the state during presentation of an untrusted WTLS certificate
EDoingWtlsPhase2 | the state during a phase 2 WTLS handshake
ECheckingNegotiated | the state in which the negotiated security settings are checked with the security policy following a successful handshake
EReady | the state in which the WSP session is processing events (either CO or CL)

Definition at line 53 of file CNwssWspSession.h.

Constructor & Destructor Documentation

CNwssWspSession::~CNwssWspSession ( ) [virtual]

Intended Usage: Destructor.

Since:
7.0

CNwssWspSession::CNwssWspSession | ( | RStringPool & | aStringPool,
 |  | MNwssWapServer & | aWapStackProvider,
 |  | MConnectionInfoProvider & | aConnInfoProvider,
 |  | MSecurityPolicy & | aSecurityPolicy
 | ) | [protected]

Intended Usage: Normal constructor.

Creates an instance of the session, keeping references to the supplied providers from the client.

Since:
7.0
Parameters:
aStringPool | (in) The client's string pool.
aWapStackProvider | (in) An owner of a WAP stack server session.
aConnInfoProvider | (in) A collection of client interfaces that provide connection-related information
aSecurityPolicy | (in) A security policy provider.

Member Function Documentation

TBool CNwssWspSession::AnonymousAuthenticationAllowed ( ) [private]

Intended Usage: Short-cut for call to the security policy plug-in, which checks a named property to see if anonymous authentication is allowed or not.

Returns:
Flag indicating whether, the policy allows anonymous handshakes.
Since:
7.0

void CNwssWspSession::BaseConstructL ( ) [protected]

Intended Usage: Second phase construction.

Does initial allocations required for this class.

Since:
7.0 @leaves System error codes, e.g. KErrNoMemory

void CNwssWspSession::CancelValidateUntrustedServerCert ( ) [private]

Intended Usage: Cancel the validation of an untrusted server cert.

Since:
7.0

void CNwssWspSession::CancelWTLSConnectionPhaseOne ( ) [private]

Intended Usage: Cancellation of phase 1 of the secure handshake, if eg.

ciphers are not available or a certificate was not obtained, or the entire connection has been cancelled.

Since:
7.0

void CNwssWspSession::CancelWTLSConnectionPhaseTwo ( ) [private]

Intended Usage: Cancellation of phase 2 of the secure handshake, if eg.

ciphers are not available or a certificate was not obtained, or the entire connection has been cancelled.

Since:
7.0

TInt CNwssWspSession::CloseWspSession ( ) [private, pure virtual]

Intended Usage: Hook that allows the class to cause an opened WSP session to be closed.

Must be implemented in sub-classes which deal with either CO or CL WSP.

Since:
7.0
Returns:
A system error code originating from the NWSS WAP Stack.

Implemented in CNwssWspCOSession.

void CNwssWspSession::CompleteProxyConnectionL ( ) [private, pure virtual]

Intended Usage: Hook that allows the class to perform any required actions to complete a connection to the WAP Proxy after the WSP session has been opened, and optionally a WTLS handshake performed.

Must be implemented in sub-classes which deal with either CO or CL WSP.

Since:
7.0 @leaves A system error code originating from the NWSS WAP Stack.

Implemented in CNwssWspCOSession.

void CNwssWspSession::CompleteSelf ( ) [private]

Intended Usage: Active object self completion.

Since:
7.0

void CNwssWspSession::DoCancel ( ) [private, virtual]

Intended Usage: Cancellation protocol for the active object.

It cancels any outstanding requests it has made, according to its state.

Since:
7.0

void CNwssWspSession::DoRunError ( TInt aError ) [private, pure virtual]

Intended Usage: Allows sub-classes to perform specific actions in response to this class' RunError().

This is called in the EReady state, where processing in the RunL is performed in the sub-class. In practice, this will handle situations where CompleteProxyConnectionL() has left.

Since:
7.0
Parameters:
aError (in) The error code to be handled, which RunL() left with

Implemented in CNwssWspCOSession.

void CNwssWspSession::DoWTLSConnectionPhaseOne ( TBool aTwoPhaseHandshake ) [private]

Intended Usage: First phase of WTLS negotiations with the WAP Stack - the first of two phases for authentication, but the one and only phase for anonymous.

Since:
7.0

void CNwssWspSession::DoWTLSConnectionPhaseTwo ( ) [private]

Intended Usage: Second phase of WTLS negotiations with the WAP Stack (used for authenticating connections only).

Since:
7.0

void CNwssWspSession::DoWTLSConnectionPostHandshakeL ( ) [private]

Intended Usage: Post-security handshake finalisation of WTLS via the WAP Stack.

Since:
7.0 @leaves System error codes, e.g. KErrNoMemory and internal error codes generated for WTLS handshake failures, see <wsperror.h>

void CNwssWspSession::DoWTLSConnectionPreHandshakeL ( ) [private]

Intended Usage: Pre-handshake phase of WTLS negotiations with the WAP Stack.

The WTLS settings are configured according to the security policy plug-in.

Since:
7.0 @leaves System error codes, e.g. KErrNoMemory

void CNwssWspSession::GetServerCertL ( ) [private]

Intended Usage: Gets the server certificate from the wap stack and converts it to a TCertInfo which is stored in iServerCert.

Since:
7.0 @leaves System error codes, e.g. KErrNoMemory and internal error codes generated for WTLS handshake failures, see <wsperror.h>

void CNwssWspSession::InitiateProxyConnection ( ) [protected]

Intended Usage: Used by sub-classes to initiate a new connection to a WAP proxy, the various steps of which are performed in an asynchronous state machine in this class.

Since:
7.0

void CNwssWspSession::MapToPanic ( TInt aErrorCode ) const [protected]

Intended Usage: Map NWSS stack error codes to local panic codes.

Panics the client using the mapped panic code.

Since:
7.0

TBool CNwssWspSession::OpenWapProxyL ( ) [private]

Intended Usage: Open the WSP session to the proxy identified by the client's Proxy Info Provider.

Since:
7.0 @leave System-wide error codes, e.g. KErrNoMemory
Returns:
Flag indicating whether WTLS is to be used or not.

TInt CNwssWspSession::OpenWspSession | ( | const TDesC8 & | aRemoteHost,
 |  | RWAPConn::TPort | aRemotePort,
 |  | RWAPConn::TPort | aLocalPort,
 |  | TBearer | aBearer,
 |  | TBool | aSecureConn
 | ) | [private, pure virtual]

Intended Usage: Hook that allows the class to cause a particular type of WSP session to the specified proxy to be opened.

Must be implemented in sub-classes which deal with either CO or CL WSP.

Since:
7.0
Parameters:
aRemoteHost | (in) The bearer-dependent address of the proxy.
aRemotePort | (in) The proxy port to which a connection is made.
aLocalPort | (in) (optional) The local port to which proxy replies are sent. A value of zero means 'don't care'.
aBearer | (in) The bearer on which the connection is made.
aSecureConn | (in) Flag indicating whether WTLS is to be used.
Returns:
A system error code originating from the NWSS WAP Stack.

Implemented in CNwssWspCOSession.

TInt CNwssWspSession::RunError ( TInt aError ) [private, virtual]

Intended Usage: Called if RunL leaves, to allow the AO to handle the error before the scheduler does

Since:
7.0.

Parameters:
aError (in) The error code to be handled, which RunL() left with
Returns:
A final error code, should aError not have been handled, which the active scheduler handles.

void CNwssWspSession::RunL ( ) [private, virtual]

Intended Usage: Called when the active object fires, ie.

its asynchronous request has completed

Since:
7.0 @leaves System error codes, e.g. KErrNoMemory and internal error codes generated for WTLS handshake failures, see <wsperror.h>

TInt CNwssWspSession::ServerCert ( TCertInfo & aCertInfo )

Get the Server Certificate for this session.

Parameters:
aServerCert A TCertInfo which will be filled with the certificate information
Returns:
An error code. KErrNone if aServerCert has been completed, otherwise one of the system wide error codes

void CNwssWspSession::SessionDisconnectedCallback ( ) [protected]

Intended Usage: Callback for use by sub-classes, to indicate when the session with a WAP proxy has been disconnected.

Causes the WSP session to be closed.

Since:
7.0
Returns:
A system error code.

TState CNwssWspSession::State ( ) [protected]

TBool CNwssWspSession::SubDoCancel ( ) [private, pure virtual]

Intended Usage: Allows sub-classes to perform specific actions in response to this class' DoCancel().

This is called in the EReady state.

Since:
7.0
Returns:
Flag indicating whether, following cancellation, this class must return to the EDisconnected state.

Implemented in CNwssWspCOSession.

void CNwssWspSession::ValidateUntrustedServerCertL ( ) [private]

Intended Usage: Mid phase of WTLS negotiations - used only for authenticating connections - obtains the WAP Gateway certificate information and asks the security policy to determine if it the server can be trusted.

Since:
7.0 @leaves System error codes, e.g. KErrNoMemory and internal error codes generated for WTLS handshake failures, see <wsperror.h>

RWTLS CNwssWspSession::WtlsHnd ( ) [private, pure virtual]

Intended Usage: Obtains the WTLS handle from the current opened WSP session.

Must be implemented in sub-classes which deal with either CO or CL WSP.

Since:
7.0
Returns:
A handle for the WTLS layer of the WAP protocol stack.

Implemented in CNwssWspCOSession.

Member Data Documentation

MConnectionInfoProvider& CNwssWspSession::iConnInfoProvider [protected]

The client connection information provider.

Definition at line 431 of file CNwssWspSession.h.

TBool CNwssWspSession::iHandshakeWasAnonymous [private]

Flag that records if the secure handshake resulted in anonymous key exchange suites being agreed with the WAP proxy.

Definition at line 449 of file CNwssWspSession.h.

MSecurityPolicy& CNwssWspSession::iSecurityPolicy [private]

Security policy provider.

Definition at line 443 of file CNwssWspSession.h.

TCertInfo CNwssWspSession::iServerCert [private]

Storage for the WAP proxy's server certificate, in the form used by the security policy plugin.

Definition at line 455 of file CNwssWspSession.h.

TBool CNwssWspSession::iServerCertValid [private]

Flag indicating that the variable iServerCert contains a valid server certificate.

Definition at line 459 of file CNwssWspSession.h.

TState CNwssWspSession::iState [private]

State of the WSP session.

Definition at line 438 of file CNwssWspSession.h.

__DECLARE_LOG RStringPool& CNwssWspSession::iStringPool [protected]

The client's string pool - not opened or closed here.

Definition at line 421 of file CNwssWspSession.h.

MNwssWapServer& CNwssWspSession::iWapStackProvider [protected]

The WAP Stack provider.

Definition at line 426 of file CNwssWspSession.h.

The documentation for this class was generated from the following file:
  • CNwssWspSession.h


Member List

CNwssWspSession Member List

This is the complete list of members for CNwssWspSession, including all inherited members.
AnonymousAuthenticationAllowed() | CNwssWspSession | [private]
BaseConstructL() | CNwssWspSession | [protected]
CancelValidateUntrustedServerCert() | CNwssWspSession | [private]
CancelWTLSConnectionPhaseOne() | CNwssWspSession | [private]
CancelWTLSConnectionPhaseTwo() | CNwssWspSession | [private]
CloseWspSession()=0 | CNwssWspSession | [private, pure virtual]
CNwssWspSession(RStringPool &aStringPool, MNwssWapServer &aWapStackProvider, MConnectionInfoProvider &aConnInfoProvider, MSecurityPolicy &aSecurityPolicy) | CNwssWspSession | [protected]
CompleteProxyConnectionL()=0 | CNwssWspSession | [private, pure virtual]
CompleteSelf() | CNwssWspSession | [private]
DoCancel() | CNwssWspSession | [private, virtual]
DoRunError(TInt aError)=0 | CNwssWspSession | [private, pure virtual]
DoWTLSConnectionPhaseOne(TBool aTwoPhaseHandshake) | CNwssWspSession | [private]
DoWTLSConnectionPhaseTwo() | CNwssWspSession | [private]
DoWTLSConnectionPostHandshakeL() | CNwssWspSession | [private]
DoWTLSConnectionPreHandshakeL() | CNwssWspSession | [private]
ECheckingNegotiated enum value | CNwssWspSession |
ECheckingServerCert enum value | CNwssWspSession |
EDisconnected enum value | CNwssWspSession |
EDoingWtlsPhase1 enum value | CNwssWspSession |
EDoingWtlsPhase2 enum value | CNwssWspSession |
EReady enum value | CNwssWspSession |
ESessionOpen enum value | CNwssWspSession |
GetServerCertL() | CNwssWspSession | [private]
iConnInfoProvider | CNwssWspSession | [protected]
iHandshakeWasAnonymous | CNwssWspSession | [private]
InitiateProxyConnection() | CNwssWspSession | [protected]
iSecurityPolicy | CNwssWspSession | [private]
iServerCert | CNwssWspSession | [private]
iServerCertValid | CNwssWspSession | [private]
iState | CNwssWspSession | [private]
iStringPool | CNwssWspSession | [protected]
iWapStackProvider | CNwssWspSession | [protected]
MapToPanic(TInt aErrorCode) const | CNwssWspSession | [protected]
OpenWapProxyL() | CNwssWspSession | [private]
OpenWspSession(const TDesC8 &aRemoteHost, RWAPConn::TPort aRemotePort, RWAPConn::TPort aLocalPort, TBearer aBearer, TBool aSecureConn)=0 | CNwssWspSession | [private, pure virtual]
RunError(TInt aError) | CNwssWspSession | [private, virtual]
RunL() | CNwssWspSession | [private, virtual]
ServerCert(TCertInfo &aCertInfo) | CNwssWspSession |
SessionDisconnectedCallback() | CNwssWspSession | [protected]
State() const | CNwssWspSession | [protected]
SubDoCancel()=0 | CNwssWspSession | [private, pure virtual]
TState enum name | CNwssWspSession |
ValidateUntrustedServerCertL() | CNwssWspSession | [private]
WtlsHnd()=0 | CNwssWspSession | [private, pure virtual]
~CNwssWspSession() | CNwssWspSession | [virtual]


CNwssWspSessionEventFilter Class Reference

#include <CNwssWspSessionEventFilter.h>

Inheritance diagram for CNwssWspSessionEventFilter:

[legend]
Collaboration diagram for CNwssWspSessionEventFilter:

[legend]
List of all members.

Public Methods

virtual | ~CNwssWspSessionEventFilter ()
Intended Usage: Destructor.

Static Public Methods

CNwssWspSessionEventFilter * | NewL (CNwssTransLookUpTable &aTransTable, MNwssSessionEventHandler &aSessionEventHandler, MNwssTransactionEventHandler &aTransEventHandler)
Static factory c'tor.

Private Methods

virtual void | HandleDisconnectIndL ()
virtual void | HandleSuspendIndL ()
virtual void | HandleResumeCnfL ()
virtual void | HandleConnectCnfL ()
virtual void | HandleRedirectIndL ()
virtual void | HandleExceptionIndL ()
virtual void | RunL ()
Intended Usage: Called when the active object fires, ie.

virtual TInt | RunError (TInt aError)
Intended Usage: Called if RunL leaves, to allow the AO to handle the error before the scheduler does
Since:
7.0.

virtual void | DoCancel ()
Intended Usage: Cancellation protocol for the active object.

CNwssWspSessionEventFilter (CNwssTransLookUpTable &aTransTable, MNwssSessionEventHandler &aSessionEventHandler, MNwssTransactionEventHandler &aTransEventHandler)
C'tor.

void | CompleteSelf ()
Sets this object active and then completes the request.

Private Attributes

CNwssTransLookUpTable & iTransTable
A reference to the transaction look up table.

MNwssSessionEventHandler & iSessionEventHandler
A reference to the actual session event handler.

MNwssTransactionEventHandler & iTransEventHandler
A reference to the actual transaction event handler/.

Constructor & Destructor Documentation

CNwssWspSessionEventFilter::~CNwssWspSessionEventFilter ( ) [virtual]

Intended Usage: Destructor.

Since:
7.0

CNwssWspSessionEventFilter::CNwssWspSessionEventFilter | ( | CNwssTransLookUpTable & | aTransTable,
 |  | MNwssSessionEventHandler & | aSessionEventHandler,
 |  | MNwssTransactionEventHandler & | aTransEventHandler
 | ) | [private]

C'tor.

Since:
7.0

Member Function Documentation

CNwssWspSessionEventFilter::CompleteSelf ( ) [private]

Sets this object active and then completes the request.

Since:
7.0

void CNwssWspSessionEventFilter::DoCancel ( ) [private, virtual]

Intended Usage: Cancellation protocol for the active object.

It cancels the request GetNextEvent() request it keeps outstanding with the WAP Stack.

Since:
7.0

void CNwssWspSessionEventFilter::HandleConnectCnfL ( ) [private, virtual]

See also:
MNwssSessionEventHandler

Implements MNwssSessionEventHandler.

void CNwssWspSessionEventFilter::HandleDisconnectIndL ( ) [private, virtual]

See also:
MNwssSessionEventHandler

Implements MNwssSessionEventHandler.

void CNwssWspSessionEventFilter::HandleExceptionIndL ( ) [private, virtual]

See also:
MNwssSessionEventHandler

Implements MNwssSessionEventHandler.

void CNwssWspSessionEventFilter::HandleRedirectIndL ( ) [private, virtual]

See also:
MNwssSessionEventHandler

Implements MNwssSessionEventHandler.

void CNwssWspSessionEventFilter::HandleResumeCnfL ( ) [private, virtual]

See also:
MNwssSessionEventHandler

Implements MNwssSessionEventHandler.

void CNwssWspSessionEventFilter::HandleSuspendIndL ( ) [private, virtual]

See also:
MNwssSessionEventHandler

Implements MNwssSessionEventHandler.

CNwssWspSessionEventFilter * CNwssWspSessionEventFilter::NewL | ( | CNwssTransLookUpTable & | aTransTable,
 |  | MNwssSessionEventHandler & | aSessionEventHandler,
 |  | MNwssTransactionEventHandler & | aTransEventHandler
 | ) | [static]

Static factory c'tor.

Since:
7.0
Parameters:
aTransLUT | A reference to the transaction lookup table.
aSessionEventHandler | A reference to the actual session event handler.
aTransEventHandler | A reference to the actual transaction event handler.

TInt CNwssWspSessionEventFilter::RunError ( TInt aError ) [private, virtual]

Intended Usage: Called if RunL leaves, to allow the AO to handle the error before the scheduler does

Since:
7.0.

Parameters:
aError (in) The error code to be handled, which RunL() left with
Returns:
A final error code, should aError not have been handled, which the active scheduler handles.

void CNwssWspSessionEventFilter::RunL ( ) [private, virtual]

Intended Usage: Called when the active object fires, ie.

its asynchronous request has completed

Since:
7.0 @leaves System error codes, e.g. KErrNoMemory and internal error codes generated for WTLS handshake failures, see <wsperror.h>

Member Data Documentation

MNwssSessionEventHandler& CNwssWspSessionEventFilter::iSessionEventHandler [private]

A reference to the actual session event handler.

Definition at line 145 of file CNwssWspSessionEventFilter.h.

MNwssTransactionEventHandler& CNwssWspSessionEventFilter::iTransEventHandler [private]

A reference to the actual transaction event handler/.

Definition at line 150 of file CNwssWspSessionEventFilter.h.

CNwssTransLookUpTable& CNwssWspSessionEventFilter::iTransTable [private]

A reference to the transaction look up table.

Definition at line 140 of file CNwssWspSessionEventFilter.h.

The documentation for this class was generated from the following file:
  • CNwssWspSessionEventFilter.h


Member List

CNwssWspSessionEventFilter Member List

This is the complete list of members for CNwssWspSessionEventFilter, including all inherited members.
CNwssWspSessionEventFilter(CNwssTransLookUpTable &aTransTable, MNwssSessionEventHandler &aSessionEventHandler, MNwssTransactionEventHandler &aTransEventHandler) | CNwssWspSessionEventFilter | [private]
CompleteSelf() | CNwssWspSessionEventFilter | [private]
DoCancel() | CNwssWspSessionEventFilter | [private, virtual]
HandleConnectCnfL() | CNwssWspSessionEventFilter | [private, virtual]
HandleDisconnectIndL() | CNwssWspSessionEventFilter | [private, virtual]
HandleExceptionIndL() | CNwssWspSessionEventFilter | [private, virtual]
HandleRedirectIndL() | CNwssWspSessionEventFilter | [private, virtual]
HandleResumeCnfL() | CNwssWspSessionEventFilter | [private, virtual]
HandleSuspendIndL() | CNwssWspSessionEventFilter | [private, virtual]
iSessionEventHandler | CNwssWspSessionEventFilter | [private]
iTransEventHandler | CNwssWspSessionEventFilter | [private]
iTransTable | CNwssWspSessionEventFilter | [private]
NewL(CNwssTransLookUpTable &aTransTable, MNwssSessionEventHandler &aSessionEventHandler, MNwssTransactionEventHandler &aTransEventHandler) | CNwssWspSessionEventFilter | [static]
RunError(TInt aError) | CNwssWspSessionEventFilter | [private, virtual]
RunL() | CNwssWspSessionEventFilter | [private, virtual]
~CNwssWspSessionEventFilter() | CNwssWspSessionEventFilter | [virtual]


CNwssWspTransactionEventFilter Class Reference

#include <CNwssWspTransactionEventFilter.h>

Inheritance diagram for CNwssWspTransactionEventFilter:

[legend]
Collaboration diagram for CNwssWspTransactionEventFilter:

[legend]
List of all members.

Public Methods

virtual | ~CNwssWspTransactionEventFilter ()
Intended Usage: Destructor.

void | SendMethodAbortIndEvent (RWSPCOTrans::TTransID aTransId)
Signals that a T-MethodAbort.ind needs to be sent.

void | SessionDisconnectRequested ()
Indicates that client has sent the S-Disconnect.req primitive.

void | SessionDisconnected ()
Indicates that the server has sent the S-Disconnect.ind primitive.

void | ResizeTableL (TInt aNewSize)
Intended Usage: Resizes the transaction Id table.

Static Public Methods

CNwssWspTransactionEventFilter * | NewL (CNwssTransLookUpTable &aTransTable, MNwssTransactionEventHandler &aTransEventHandler, TInt aTableSize)
Static factory c'tor.

Private Methods

virtual void | HandleMethodInvokeCnfL (RWSPCOTrans::TTransID aTransId)
This represents the T-MethodInvoke.cnf primitive.

virtual void | HandleMethodResultIndL (RWSPCOTrans::TTransID aTransId)
This represents the T-MethodResult.ind primitive.

virtual void | HandleAbortIndL (RWSPCOTrans::TTransID aTransId)
This represents the T-MethodAbort.ind primitive.

virtual void | RunL ()
Intended Usage: Called when the active object fires, ie.

virtual TInt | RunError (TInt aError)
Intended Usage: Called if RunL leaves, to allow the AO to handle the error before the scheduler does
Since:
7.0.

virtual void | DoCancel ()
Intended Usage: Cancellation protocol for the active object.

CNwssWspTransactionEventFilter (CNwssTransLookUpTable &aTransTable, MNwssTransactionEventHandler &aTransEventHandler)
C'tor.

void | ConstructL (TInt aTableSize)
Second phase c'tor.

void | CompleteSelf ()
Sets this object active and then completes the request.

Private Attributes

CNwssTransLookUpTable & iTransTable
A reference to the transaction look up table.

MNwssTransactionEventHandler & iTransEventHandler
A reference to the actual transaction event handler.

TInt | iHighWaterMark
The index to the next available slot in the table.

RArray< RWSPCOTrans::TTransID > | iEntries
An array of entries for the transaction IDs of aborted methods;.

TBool | iSessionClosing
A flag indicating whether the session is in the Closing state.

Constructor & Destructor Documentation

CNwssWspTransactionEventFilter::~CNwssWspTransactionEventFilter ( ) [virtual]

Intended Usage: Destructor.

Since:
7.0

CNwssWspTransactionEventFilter::CNwssWspTransactionEventFilter | ( | CNwssTransLookUpTable & | aTransTable,
 |  | MNwssTransactionEventHandler & | aTransEventHandler
 | ) | [private]

C'tor.

Since:
7.0

Member Function Documentation

CNwssWspTransactionEventFilter::CompleteSelf ( ) [private]

Sets this object active and then completes the request.

Since:
7.0

void CNwssWspTransactionEventFilter::ConstructL ( TInt aTableSize ) [private]

Second phase c'tor.

Since:
7.0

void CNwssWspTransactionEventFilter::DoCancel ( ) [private, virtual]

Intended Usage: Cancellation protocol for the active object.

It cancels the request GetNextEvent() request it keeps outstanding with the WAP Stack.

Since:
7.0

virtual void CNwssWspTransactionEventFilter::HandleAbortIndL ( RWSPCOTrans::TTransID aTransId ) [private, virtual]

This represents the T-MethodAbort.ind primitive.

See also:
MNwssTransactionEventHandler

Implements MNwssTransactionEventHandler.

virtual void CNwssWspTransactionEventFilter::HandleMethodInvokeCnfL ( RWSPCOTrans::TTransID aTransId ) [private, virtual]

This represents the T-MethodInvoke.cnf primitive.

See also:
MNwssTransactionEventHandler

Implements MNwssTransactionEventHandler.

virtual void CNwssWspTransactionEventFilter::HandleMethodResultIndL ( RWSPCOTrans::TTransID aTransId ) [private, virtual]

This represents the T-MethodResult.ind primitive.

See also:
MNwssTransactionEventHandler

Implements MNwssTransactionEventHandler.

CNwssWspTransactionEventFilter * CNwssWspTransactionEventFilter::NewL | ( | CNwssTransLookUpTable & | aTransTable,
 |  | MNwssTransactionEventHandler & | aTransEventHandler,
 |  | TInt | aTableSize
 | ) | [static]

Static factory c'tor.

Since:
7.0
Parameters:
aTransLUT | A reference to the transaction look up table.
aTransEventHandler | A reference to the actual transaction event handler.

CNwssWspTransactionEventFilter::ResizeTableL ( TInt aNewSize )

Intended Usage: Resizes the transaction Id table.

If aNewSize exceeds the current size, then entries are added. If it is less than the current size, then surplus entries are deleted.

Since:
7.0
Parameters:
aNewSize (in) The new table size @leave System error codes, e.g. KErrNoMemory if the table can't be enlarged.

TInt CNwssWspTransactionEventFilter::RunError ( TInt aError ) [private, virtual]

Intended Usage: Called if RunL leaves, to allow the AO to handle the error before the scheduler does

Since:
7.0.

Parameters:
aError (in) The error code to be handled, which RunL() left with
Returns:
A final error code, should aError not have been handled, which the active scheduler handles.

void CNwssWspTransactionEventFilter::RunL ( ) [private, virtual]

Intended Usage: Called when the active object fires, ie.

its asynchronous request has completed

Since:
7.0 @leaves System error codes, e.g. KErrNoMemory and internal error codes generated for WTLS handshake failures, see <wsperror.h>

void CNwssWspTransactionEventFilter::SendMethodAbortIndEvent ( RWSPCOTrans::TTransID aTransId )

Signals that a T-MethodAbort.ind needs to be sent.

The aborted method aTransaction is marked as being aborted in the transaction look up table.

Since:
7.0
Parameters:
aTransId The ID for the transaction object that has been aborted.

void CNwssWspTransactionEventFilter::SessionDisconnected ( )

Indicates that the server has sent the S-Disconnect.ind primitive.

Since:
7.0

void CNwssWspTransactionEventFilter::SessionDisconnectRequested ( )

Indicates that client has sent the S-Disconnect.req primitive.

Need to ignore all transaction events bar T-MethodAbort.ind.

Since:
7.0

Member Data Documentation

RArray<RWSPCOTrans::TTransID> CNwssWspTransactionEventFilter::iEntries [private]

An array of entries for the transaction IDs of aborted methods;.

Definition at line 174 of file CNwssWspTransactionEventFilter.h.

TInt CNwssWspTransactionEventFilter::iHighWaterMark [private]

The index to the next available slot in the table.

Definition at line 169 of file CNwssWspTransactionEventFilter.h.

TBool CNwssWspTransactionEventFilter::iSessionClosing [private]

A flag indicating whether the session is in the Closing state.

Definition at line 179 of file CNwssWspTransactionEventFilter.h.

MNwssTransactionEventHandler& CNwssWspTransactionEventFilter::iTransEventHandler [private]

A reference to the actual transaction event handler.

Definition at line 164 of file CNwssWspTransactionEventFilter.h.

CNwssTransLookUpTable& CNwssWspTransactionEventFilter::iTransTable [private]

A reference to the transaction look up table.

Definition at line 159 of file CNwssWspTransactionEventFilter.h.

The documentation for this class was generated from the following file:
  • CNwssWspTransactionEventFilter.h


Member List

CNwssWspTransactionEventFilter Member List

This is the complete list of members for CNwssWspTransactionEventFilter, including all inherited members.
CNwssWspTransactionEventFilter(CNwssTransLookUpTable &aTransTable, MNwssTransactionEventHandler &aTransEventHandler) | CNwssWspTransactionEventFilter | [private]
CompleteSelf() | CNwssWspTransactionEventFilter | [private]
ConstructL(TInt aTableSize) | CNwssWspTransactionEventFilter | [private]
DoCancel() | CNwssWspTransactionEventFilter | [private, virtual]
HandleAbortIndL(RWSPCOTrans::TTransID aTransId) | CNwssWspTransactionEventFilter | [private, virtual]
HandleMethodInvokeCnfL(RWSPCOTrans::TTransID aTransId) | CNwssWspTransactionEventFilter | [private, virtual]
HandleMethodResultIndL(RWSPCOTrans::TTransID aTransId) | CNwssWspTransactionEventFilter | [private, virtual]
iEntries | CNwssWspTransactionEventFilter | [private]
iHighWaterMark | CNwssWspTransactionEventFilter | [private]
iSessionClosing | CNwssWspTransactionEventFilter | [private]
iTransEventHandler | CNwssWspTransactionEventFilter | [private]
iTransTable | CNwssWspTransactionEventFilter | [private]
NewL(CNwssTransLookUpTable &aTransTable, MNwssTransactionEventHandler &aTransEventHandler, TInt aTableSize) | CNwssWspTransactionEventFilter | [static]
ResizeTableL(TInt aNewSize) | CNwssWspTransactionEventFilter |
RunError(TInt aError) | CNwssWspTransactionEventFilter | [private, virtual]
RunL() | CNwssWspTransactionEventFilter | [private, virtual]
SendMethodAbortIndEvent(RWSPCOTrans::TTransID aTransId) | CNwssWspTransactionEventFilter |
SessionDisconnected() | CNwssWspTransactionEventFilter |
SessionDisconnectRequested() | CNwssWspTransactionEventFilter |
~CNwssWspTransactionEventFilter() | CNwssWspTransactionEventFilter | [virtual]


CNwssWspTransportHandler Class Reference

@public
Since:
7.0 This class provides a concrete implementation of the CWspTransportHandler interface, specifically for the NWSS Rainbow 2.1 WAP Stack, which is used on the Hurricane release of Symbian OS.
More...

#include <CNwssWspTransportHandler.h>

Inheritance diagram for CNwssWspTransportHandler:

[legend]
Collaboration diagram for CNwssWspTransportHandler:

[legend]
List of all members.

Public Methods

virtual | ~CNwssWspTransportHandler ()
Intended Usage: Destructor.

virtual CWspTransportHandler::TWspSupportedServices | SupportedServices () const
Intended Usage: Query the services supported by this instantiation of the WSP transport handler plug-in.

virtual MWspCOSessionInvoker & | COSessionInvoker ()
Intended Usage: Obtain the connection-oriented session invocation API.

virtual MWspCOMethodInvoker & | COTransactionInvoker ()
Intended Usage: Obtain the connection-oriented method invocation API.

virtual MWspCOPushInvoker & | COPushInvoker ()
Intended Usage: Obtain the connection-oriented push invocation API.

virtual MWspCLMethodInvoker & | CLMethodInvoker ()
Intended Usage: Obtain the connectionless method invocation API.

virtual MWspCLPushInvoker & | CLPushInvoker ()
Intended Usage: Obtain the connectionless push invocation API.

virtual TInt | ServerCert (TCertInfo &aCertInfo) const
Get the Server Certificate for the current session.

Static Public Methods

CNwssWspTransportHandler * | NewL (TAny *aInstantiationParams)
Intended Usage: Factory construction of the transport handler.

Private Methods

virtual RWAPServ & | WapStack ()
Intended Usage: Obtain a handle for the WAP Stack server.

virtual MWspProxyInfoProvider & | ProxyInfoProvider () const
Intended Usage: Obtain the client's provider of proxy information.

virtual MWspCapabilityProvider & | CapabilityProvider () const
Intended Usage: Obtain the client's provider of capability information.

virtual MWspSessionHeadersProvider & | SessionHeadersProvider () const
Intended Usage: Obtain the client's provider of session headers.

virtual void | ValidateUntrustedServerCert (TCertInfo &aServerCert, TRequestStatus &aStatus) const
virtual void | CancelValidateUntrustedServerCert ()
Intended Usage: Cancel a previous request to ask the client to accept or reject an untrusted WTLS server certificate.

virtual const RArray< TWtlsCipherSuite > & | GetWtlsCipherSuites ()
Intended Usage: Obtain an array of WTLS cipher suites.

virtual const TDesC8 & | GetTlsCipherSuites ()
Intended Usage: Obtain a list of TLS cipher suites.

virtual const RArray< TWtlsKeyExchangeSuite > & | GetWtlsKeyExchangeSuites ()
Intended Usage: Obtain the WTLS key exchange suites.

virtual TInt | GetNamedPolicyProperty (RStringF aPropertyName, RString &aPropertyValue)
Intended Usage: Obtain arbitrary, named security policy properties, in a generic 'stringified' form.

virtual void | Reserved1 ()
Intended Usage: Reserve a slot in the v-table to preserve future BC
Since:
7.0.

virtual void | Reserved2 ()
Intended Usage: Reserve a slot in the v-table to preserve future BC
Since:
7.0.

CNwssWspTransportHandler (TAny *aInstantiationParams)
Intended Usage: Second phase construction.

void | ConstructL ()

Private Attributes

RWAPServ | iWapStackHnd
Session with the WAP Stack server.

CNwssWspCOSession * iWspCOSession
Adapter for Connection-Oriented WSP sessions.

RArray< TWtlsCipherSuite > | iDefSecPolCipherSuites
Default security policy values for WTLS cipher suites.

RArray< TWtlsKeyExchangeSuite > | iDefSecPolKeyExchSuite
Default security policy values for WTLS key exchange suites.

Detailed Description

@public
Since:
7.0 This class provides a concrete implementation of the CWspTransportHandler interface, specifically for the NWSS Rainbow 2.1 WAP Stack, which is used on the Hurricane release of Symbian OS.

The present implementation supports only the Connection-Oriented Session and Method services. In the future, Connectionless and Push may be added.

There is no real behaviour in this class. It acts mainly as a container for the objects that provide the various services. Also, it implements a set of additional Mix-in interfaces, which provide internal services to other classes in the transport handler.

By implementing MSecurityPolicy, it can supply default policy values when the WTLS handshake takes place, if a security policy plug-in is not provided by the client.

The class owns the main WAP protocol stack server handle, RWAPServ. It provides access to this for other classes in the transport handler by implementing the narrow interface MNwssWapServer. It provides access to the client's Capability Info, Session Headers and Proxy Info services by implementing the MConnectionInfoProvider interface and offering it to other classes in the transport handler.

Definition at line 53 of file CNwssWspTransportHandler.h.

Constructor & Destructor Documentation

CNwssWspTransportHandler::~CNwssWspTransportHandler ( ) [virtual]

Intended Usage: Destructor.

Since:
7.0

CNwssWspTransportHandler::CNwssWspTransportHandler ( TAny * aInstantiationParams ) [private]

Intended Usage: Second phase construction.

The bundled instantiation params are passed to the parent class constructor. Ownership of the parameters is _not_ passed across.

Since:
7.0
Parameters:
aInstantiationParams (in) The set of instantiation parameters.

Member Function Documentation

void CNwssWspTransportHandler::CancelValidateUntrustedServerCert ( ) [private, virtual]

Intended Usage: Cancel a previous request to ask the client to accept or reject an untrusted WTLS server certificate.

Since:
7.0

Implements MSecurityPolicy.

MWspCapabilityProvider & CNwssWspTransportHandler::CapabilityProvider ( ) const [private, virtual]

Intended Usage: Obtain the client's provider of capability information.

Since:
7.0
Returns:
The interface supplied by the client through which capability information is obtained.

Implements MConnectionInfoProvider.

MWspCLMethodInvoker & CNwssWspTransportHandler::CLMethodInvoker ( ) [virtual]

Intended Usage: Obtain the connectionless method invocation API.

Since:
7.0
Returns:
The interface to be used by a client to make invocations on the connectionless transaction service.
See also:
MWspCLMethodInvoker

Implements CWspTransportHandler.

MWspCLPushInvoker & CNwssWspTransportHandler::CLPushInvoker ( ) [virtual]

Intended Usage: Obtain the connectionless push invocation API.

Since:
7.0
Returns:
The interface to be used by a client to make invocations on the connectionless push service.
See also:
MWspCLPushInvoker

Implements CWspTransportHandler.

void CNwssWspTransportHandler::ConstructL ( ) [private]

MWspCOPushInvoker & CNwssWspTransportHandler::COPushInvoker ( ) [virtual]

Intended Usage: Obtain the connection-oriented push invocation API.

Since:
7.0
Returns:
The interface to be used by a client to make invocations on the connection-oriented push service.
See also:
MWspCOPushInvoker

Implements CWspTransportHandler.

MWspCOSessionInvoker & CNwssWspTransportHandler::COSessionInvoker ( ) [virtual]

Intended Usage: Obtain the connection-oriented session invocation API.

Since:
7.0
Returns:
The interface to be used by a client to make invocations on the connection-oriented session service.
See also:
MWspCOSessionInvoker

Implements CWspTransportHandler.

MWspCOMethodInvoker & CNwssWspTransportHandler::COTransactionInvoker ( ) [virtual]

Intended Usage: Obtain the connection-oriented method invocation API.

Since:
7.0
Returns:
The interface to be used by a client to make invocations on the connection-oriented transaction service.
See also:
MWspCOMethodInvoker

Implements CWspTransportHandler.

TInt CNwssWspTransportHandler::GetNamedPolicyProperty | ( | RStringF | aPropertyName,
 |  | RString & | aPropertyValue
 | ) | [private, virtual]

Intended Usage: Obtain arbitrary, named security policy properties, in a generic 'stringified' form.

Since:
7.0
Parameters:
aPropertyName | (in) The policy property name.
aPropertyValue | (out) The property value. Parsing of the value is left to the caller. The caller must close the RString.
Returns:
An error code: KErrNone if the property exists or KErrNotFound if it doesn't.

Implements MSecurityPolicy.

const TDesC8 & CNwssWspTransportHandler::GetTlsCipherSuites ( ) [private, virtual]

Intended Usage: Obtain a list of TLS cipher suites.

Not applicable to WTLS clients.

Since:
7.0
Returns:
An descriptor containing a list of the TLS cipher suites. Each cipher suite is a 2 byte pair

Implements MSecurityPolicy.

const RArray< TWtlsCipherSuite > & CNwssWspTransportHandler::GetWtlsCipherSuites ( ) [private, virtual]

Intended Usage: Obtain an array of WTLS cipher suites.

Not applicable to TLS clients.

Since:
7.0
Returns:
An array of cipher suites, consisting of paired bulk encryption algorithms and MAC algorithms. The array must be ordered with strongest cipher suites at the start.

Implements MSecurityPolicy.

const RArray< TWtlsKeyExchangeSuite > & CNwssWspTransportHandler::GetWtlsKeyExchangeSuites ( ) [private, virtual]

Intended Usage: Obtain the WTLS key exchange suites.

Not applicable to TLS clients.

Since:
7.0
Returns:
An array of the WTLS key exchange suites. The array must be ordered with authenticating key exchange suites at the start followed by anonymous key exchange suites if desired. Within each group of keys longer keys should precede shorter ones.

Implements MSecurityPolicy.

CNwssWspTransportHandler * CNwssWspTransportHandler::NewL ( TAny * aInstantiationParams ) [static]

Intended Usage: Factory construction of the transport handler.

Since:
7.0
Parameters:
aInstantiationParams (in) Points to a structure containing the parameters sent to the parent class constructor.
Returns:
The newly-created transport handler object. @leaves KErrNoMemory.

MWspProxyInfoProvider & CNwssWspTransportHandler::ProxyInfoProvider ( ) const [private, virtual]

Intended Usage: Obtain the client's provider of proxy information.

Since:
7.0
Returns:
The interface supplied by the client through which proxy information is obtained.

Implements MConnectionInfoProvider.

CNwssWspTransportHandler::Reserved1 ( ) [private, virtual]

Intended Usage: Reserve a slot in the v-table to preserve future BC

Since:
7.0.

Implements MSecurityPolicy.

CNwssWspTransportHandler::Reserved2 ( ) [private, virtual]

Intended Usage: Reserve a slot in the v-table to preserve future BC

Since:
7.0.

Implements MSecurityPolicy.

virtual TInt CNwssWspTransportHandler::ServerCert ( TCertInfo & aCertInfo ) const [virtual]

Get the Server Certificate for the current session.

Parameters:
aServerCert A TCertInfo which will be filled with the certificate information
Returns:
An error code. KErrNone if aServerCert has been completed, otherwise one of the system wide error codes

Implements CWspTransportHandler.

MWspSessionHeadersProvider & CNwssWspTransportHandler::SessionHeadersProvider ( ) const [private, virtual]

Intended Usage: Obtain the client's provider of session headers.

Since:
7.0
Returns:
The interface supplied by the client through which client session headers are obtained, and to which server (i.e. proxy) session headers are returned.

Implements MConnectionInfoProvider.

CWspTransportHandler::TWspSupportedServices CNwssWspTransportHandler::SupportedServices ( ) const [virtual]

Intended Usage: Query the services supported by this instantiation of the WSP transport handler plug-in.

Since:
7.0
Returns:
A bit-field set of flags indicating the service supported.
See also:
CWspTransportHandler

Implements CWspTransportHandler.

virtual void CNwssWspTransportHandler::ValidateUntrustedServerCert | ( | TCertInfo & | aServerCert,
 |  | TRequestStatus & | aStatus
 | ) | const [private, virtual]

Implements MSecurityPolicy.

RWAPServ & CNwssWspTransportHandler::WapStack ( ) [private, virtual]

Intended Usage: Obtain a handle for the WAP Stack server.

Since:
7.0
Returns:
The WAP Stack server session handle.

Implements MNwssWapServer.

Member Data Documentation

RArray<TWtlsCipherSuite> CNwssWspTransportHandler::iDefSecPolCipherSuites [private]

Default security policy values for WTLS cipher suites.

Definition at line 305 of file CNwssWspTransportHandler.h.

RArray<TWtlsKeyExchangeSuite> CNwssWspTransportHandler::iDefSecPolKeyExchSuite [private]

Default security policy values for WTLS key exchange suites.

Definition at line 310 of file CNwssWspTransportHandler.h.

RWAPServ CNwssWspTransportHandler::iWapStackHnd [private]

Session with the WAP Stack server.

Definition at line 295 of file CNwssWspTransportHandler.h.

CNwssWspCOSession* CNwssWspTransportHandler::iWspCOSession [private]

Adapter for Connection-Oriented WSP sessions.

Definition at line 300 of file CNwssWspTransportHandler.h.

The documentation for this class was generated from the following file:
  • CNwssWspTransportHandler.h


Member List

CNwssWspTransportHandler Member List

This is the complete list of members for CNwssWspTransportHandler, including all inherited members.
CancelValidateUntrustedServerCert() | CNwssWspTransportHandler | [private, virtual]
CapabilityProvider() const | CNwssWspTransportHandler | [private, virtual]
CLMethodInvoker() | CNwssWspTransportHandler | [virtual]
CLPushInvoker() | CNwssWspTransportHandler | [virtual]
CNwssWspTransportHandler(TAny *aInstantiationParams) | CNwssWspTransportHandler | [private]
ConstructL() | CNwssWspTransportHandler | [private]
COPushInvoker() | CNwssWspTransportHandler | [virtual]
COSessionInvoker() | CNwssWspTransportHandler | [virtual]
COTransactionInvoker() | CNwssWspTransportHandler | [virtual]
CWspTransportHandler(RStringPool aStringPool, MSecurityPolicy *aSecurityPolicy, MWspCOSessionCallback &aSessionCB, MWspProxyInfoProvider &aProxyInfoProv, MWspCapabilityProvider &aCapProv, MWspSessionHeadersProvider &aSessHdrProv) | CWspTransportHandler | [inline, protected]
ECLPushService enum value | CWspTransportHandler |
ECLSessionService enum value | CWspTransportHandler |
ECOMethodInvocationService enum value | CWspTransportHandler |
ECOPushService enum value | CWspTransportHandler |
ECOSessionService enum value | CWspTransportHandler |
GetNamedPolicyProperty(RStringF aPropertyName, RString &aPropertyValue) | CNwssWspTransportHandler | [private, virtual]
GetTlsCipherSuites() | CNwssWspTransportHandler | [private, virtual]
GetWtlsCipherSuites() | CNwssWspTransportHandler | [private, virtual]
GetWtlsKeyExchangeSuites() | CNwssWspTransportHandler | [private, virtual]
iCapProv | CWspTransportHandler | [protected]
iDefSecPolCipherSuites | CNwssWspTransportHandler | [private]
iDefSecPolKeyExchSuite | CNwssWspTransportHandler | [private]
iProxyInfoProv | CWspTransportHandler | [protected]
iSecurityPolicy | CWspTransportHandler | [protected]
iSessHdrProv | CWspTransportHandler | [protected]
iSessionCB | CWspTransportHandler | [protected]
iStringPool | CWspTransportHandler | [protected]
iWapStackHnd | CNwssWspTransportHandler | [private]
iWspCOSession | CNwssWspTransportHandler | [private]
NewL(TAny *aInstantiationParams) | CNwssWspTransportHandler | [static]
CWspTransportHandler::NewL(RStringPool aStringPool, MSecurityPolicy *aSecurityPolicy, MWspCOSessionCallback &aSessionCB, MWspProxyInfoProvider &aProxyInfoProv, MWspCapabilityProvider &aCapProv, MWspSessionHeadersProvider &aSessHdrProv) | CWspTransportHandler | [inline, static]
ProxyInfoProvider() const | CNwssWspTransportHandler | [private, virtual]
Reserved1() | CNwssWspTransportHandler | [private, virtual]
Reserved2() | CNwssWspTransportHandler | [private, virtual]
ServerCert(TCertInfo &aCertInfo) const | CNwssWspTransportHandler | [virtual]
SessionHeadersProvider() const | CNwssWspTransportHandler | [private, virtual]
SupportedServices() const | CNwssWspTransportHandler | [virtual]
TWspService enum name | CWspTransportHandler |
TWspSupportedServices typedef | CWspTransportHandler |
ValidateUntrustedServerCert(TCertInfo &aServerCert, TRequestStatus &aStatus) const | CNwssWspTransportHandler | [private, virtual]
WapStack() | CNwssWspTransportHandler | [private, virtual]
~CNwssWspTransportHandler() | CNwssWspTransportHandler | [virtual]
~CWspTransportHandler() | CWspTransportHandler | [inline, virtual]


CNwssWspTrHndDataSupplier Class Reference

@private
Since:
7.0 This class acts as a data supplier for WSP response bodies.
More...

#include <CNwssWspTrHndDataSupplier.h>

Inheritance diagram for CNwssWspTrHndDataSupplier:

[legend]
Collaboration diagram for CNwssWspTrHndDataSupplier:

[legend]
List of all members.

Public Methods

virtual | ~CNwssWspTrHndDataSupplier ()
Intended Usage: Destructor.

Static Public Methods

CNwssWspTrHndDataSupplier * | NewL (RWSPCOTrans &aStackTrans, MNwssOomHandler &aOomHandler)
Intended Usage: Factory construction.

Private Methods

virtual TBool | GetNextDataPart (TPtrC8 &aDataPart)
Intended Usage: Obtain a data part from the supplier.

virtual void | ReleaseData ()
Intended Usage: Release the current data part being held at the data supplier.

virtual TInt | OverallDataSize ()
Intended Usage: Obtain the overall size of the data being supplied, if known to the supplier.

virtual TInt | Reset ()
Intended Usage: Reset the data supplier.

CNwssWspTrHndDataSupplier (RWSPCOTrans &aStackTrans, MNwssOomHandler &aOomHandler)
Intended Usage: Normal constructor.

void | ConstructL ()
Intended Usage: Second phase construction, allocates the buffer to be used by the data supplier.

TInt | ExtractBodyData ()
Intended Usage: Extracts the response body data from the transaction.

Private Attributes

__DECLARE_LOG RWSPCOTrans & | iStackTrans
The WAP stack transaction from which response data is being extracted.

MNwssOomHandler & iOomHandler
The handler provided for use in out-of-memory situations.

RWSPCOTrans::TTransID | iStackTransId
The transaction ID for iStackTrans.

TBuf8< KNwssResponseDataBufferSize > | iBuffer
A buffer used to hold the data received from the WAP proxy.

TInt | iOverallDataSize
The overall size of the response.

TInt | iRemainingBytes
The number of bytes remaining to be extracted from the body response in the WAP stack.

Detailed Description

@private
Since:
7.0 This class acts as a data supplier for WSP response bodies.

It is created when the T-MethodResult.ind PDU is received, and is passed to the client to allow them to extract the result data from the WAP Stack.

Definition at line 38 of file CNwssWspTrHndDataSupplier.h.

Constructor & Destructor Documentation

CNwssWspTrHndDataSupplier::~CNwssWspTrHndDataSupplier ( ) [virtual]

Intended Usage: Destructor.

Since:
7.0

CNwssWspTrHndDataSupplier::CNwssWspTrHndDataSupplier | ( | RWSPCOTrans & | aStackTrans,
 |  | MNwssOomHandler & | aOomHandler
 | ) | [private]

Intended Usage: Normal constructor.

Since:
7.0
Parameters:
aStackTrans | (in) The WAP Stack transaction from which the response data is to be extracted.
aOomHandler | (in) A handler used in OOM situations that occur when invocations on the WAP stack fail with KErrNoMemory.

Member Function Documentation

void CNwssWspTrHndDataSupplier::ConstructL ( ) [private]

Intended Usage: Second phase construction, allocates the buffer to be used by the data supplier.

Since:
7.0

TInt CNwssWspTrHndDataSupplier::ExtractBodyData ( ) [private]

Intended Usage: Extracts the response body data from the transaction.

Since:
7.0
Returns:
An error code from the WAP stack.

TBool CNwssWspTrHndDataSupplier::GetNextDataPart ( TPtrC8 & aDataPart ) [private, virtual]

Intended Usage: Obtain a data part from the supplier.

The data is guaranteed to survive until a call is made to ReleaseData().

Since:
7.0
Parameters:
aDataPart (in) the data part
Returns:
ETrue if this is the last part. EFalse otherwise

Implements MHTTPDataSupplier.

static CNwssWspTrHndDataSupplier * CNwssWspTrHndDataSupplier::NewL | ( | RWSPCOTrans & | aStackTrans,
 |  | MNwssOomHandler & | aOomHandler
 | ) | [static]

Intended Usage: Factory construction.

Creates a new data supplier, associated with the supplied WAP stack transaction handle.

Since:
7.0
Parameters:
aStackTrans | (in) The WAP Stack transaction from which the response data is to be extracted.
aOomHandler | (in) A handler used in OOM situations that occur when invocations on the WAP stack fail with KErrNoMemory. @leave System wide errors, e.g. KErrNoMemory.

TInt CNwssWspTrHndDataSupplier::OverallDataSize ( ) [private, virtual]

Intended Usage: Obtain the overall size of the data being supplied, if known to the supplier.

Where a body of data is supplied in several parts this size will be the sum of all the part sizes. If the size is not known, KErrNotFound is returned; in this case the client must use the return code of GetNextDataPart to find out when the data is complete.

Since:
7.0
Returns:
A size in bytes, or KErrNotFound if the size is not known.

Implements MHTTPDataSupplier.

void CNwssWspTrHndDataSupplier::ReleaseData ( ) [private, virtual]

Intended Usage: Release the current data part being held at the data supplier.

This call indicates to the supplier that the part is no longer needed, and another one can be supplied, if appropriate.

Since:
7.0

Implements MHTTPDataSupplier.

TInt CNwssWspTrHndDataSupplier::Reset ( ) [private, virtual]

Intended Usage: Reset the data supplier.

This indicates to the data supplier that it should return to the first part of the data. This could be used in a situation where the data consumer has encountered an error and needs the data to be supplied afresh. Even if the last part has been supplied (i.e. GetNextDataPart has returned ETrue), the data supplier should reset to the first part.

If the supplier cannot reset it should return an error code; otherwise it should return KErrNone, where the reset will be assumed to have succeeded

Since:
7.0
Returns:
KErrNone, if reset is supported and was sucessfull; or KErrNotSupported otherwise.

Implements MHTTPDataSupplier.

Member Data Documentation

TBuf8<KNwssResponseDataBufferSize> CNwssWspTrHndDataSupplier::iBuffer [private]

A buffer used to hold the data received from the WAP proxy.

Definition at line 164 of file CNwssWspTrHndDataSupplier.h.

MNwssOomHandler& CNwssWspTrHndDataSupplier::iOomHandler [private]

The handler provided for use in out-of-memory situations.

Definition at line 154 of file CNwssWspTrHndDataSupplier.h.

TInt CNwssWspTrHndDataSupplier::iOverallDataSize [private]

The overall size of the response.

Definition at line 169 of file CNwssWspTrHndDataSupplier.h.

TInt CNwssWspTrHndDataSupplier::iRemainingBytes [private]

The number of bytes remaining to be extracted from the body response in the WAP stack.

Definition at line 175 of file CNwssWspTrHndDataSupplier.h.

__DECLARE_LOG RWSPCOTrans& CNwssWspTrHndDataSupplier::iStackTrans [private]

The WAP stack transaction from which response data is being extracted.

Definition at line 149 of file CNwssWspTrHndDataSupplier.h.

RWSPCOTrans::TTransID CNwssWspTrHndDataSupplier::iStackTransId [private]

The transaction ID for iStackTrans.

Definition at line 159 of file CNwssWspTrHndDataSupplier.h.

The documentation for this class was generated from the following file:
  • CNwssWspTrHndDataSupplier.h


Member List

CNwssWspTrHndDataSupplier Member List

This is the complete list of members for CNwssWspTrHndDataSupplier, including all inherited members.
CNwssWspTrHndDataSupplier(RWSPCOTrans &aStackTrans, MNwssOomHandler &aOomHandler) | CNwssWspTrHndDataSupplier | [private]
ConstructL() | CNwssWspTrHndDataSupplier | [private]
ExtractBodyData() | CNwssWspTrHndDataSupplier | [private]
GetNextDataPart(TPtrC8 &aDataPart) | CNwssWspTrHndDataSupplier | [private, virtual]
iBuffer | CNwssWspTrHndDataSupplier | [private]
iOomHandler | CNwssWspTrHndDataSupplier | [private]
iOverallDataSize | CNwssWspTrHndDataSupplier | [private]
iRemainingBytes | CNwssWspTrHndDataSupplier | [private]
iStackTrans | CNwssWspTrHndDataSupplier | [private]
iStackTransId | CNwssWspTrHndDataSupplier | [private]
NewL(RWSPCOTrans &aStackTrans, MNwssOomHandler &aOomHandler) | CNwssWspTrHndDataSupplier | [static]
OverallDataSize() | CNwssWspTrHndDataSupplier | [private, virtual]
ReleaseData() | CNwssWspTrHndDataSupplier | [private, virtual]
Reset() | CNwssWspTrHndDataSupplier | [private, virtual]
~CNwssWspTrHndDataSupplier() | CNwssWspTrHndDataSupplier | [virtual]


TNwssWspTrHndPanic Class Reference

@private
Since:
7.0 This class provides a trivial panic utility used throughout the WSP Transport Handler.
More...

#include <TNwssWspTrHndPanic.h>

List of all members.

Public Types

enum TNwssWspTrHndPanicCode {
EServiceNotSupported = 1, ETransLUTOverflow = 2, EUnknownMethod = 3, EURIOverflow = 4,
EWrongSessionType = 5, EWrongBearerType = 6, ECOPushNotSupported = 7, EConnectionLessNotSupported = 8,
EUnknownWspEvent = 9, EEventOnUnknownTransaction = 10, EInvalidTransactionInLUT = 11, EFailedToGetSessionData = 12,
EFailedToGetTransactionData = 13, EInternalCapCodecError = 14, ECapabilityOverrun = 15, EFailedToAcknowledgeTrans = 16,
EFailedToReleaseTrans = 17, ELargeDataTransferNotSupported = 18, EFailedToAbortTrans = 19, ETransLUTLeakage = 20,
EConnectedUponDestruction = 21, EFailedToOpenWspSession = 22, EBearerError = 23, EPortAlreadyBound = 24,
ECannotOpenPort = 25, ETooManyConnections = 26, EBadConnection = 27, EBufferTooSmall = 28,
EInvalidSession = 29, EInvalidTransaction = 30, EParameterError = 31, ESessionNotConnected = 32,
ENotSupported = 33, EInvalidState = 34, ESessionClosed = 35, EMRUExceeded = 36,
EInvalidBufferSize = 37, EDataNotAvailable = 38, EErrorTimeout = 39, EMORExceeded = 40,
EDeferedMethodFailed = 41, EInsufficientCryptoStrength = 42, EUnknownPanic = 999
}
Panic codes for the WSP TH, NWSS stack binding. More...

Static Public Methods

void Panic (TNwssWspTrHndPanicCode aPanic)
Intended Usage: Panic the stub.

Detailed Description

@private
Since:
7.0 This class provides a trivial panic utility used throughout the WSP Transport Handler.

Definition at line 27 of file TNwssWspTrHndPanic.h.

Member Enumeration Documentation

enum TNwssWspTrHndPanic::TNwssWspTrHndPanicCode

Panic codes for the WSP TH, NWSS stack binding.

Enumeration values:
EServiceNotSupported
ETransLUTOverflow
EUnknownMethod
EURIOverflow
EWrongSessionType
EWrongBearerType
ECOPushNotSupported
EConnectionLessNotSupported
EUnknownWspEvent
EEventOnUnknownTransaction
EInvalidTransactionInLUT
EFailedToGetSessionData
EFailedToGetTransactionData
EInternalCapCodecError
ECapabilityOverrun
EFailedToAcknowledgeTrans
EFailedToReleaseTrans
ELargeDataTransferNotSupported
EFailedToAbortTrans
ETransLUTLeakage
EConnectedUponDestruction
EFailedToOpenWspSession
EBearerError
EPortAlreadyBound
ECannotOpenPort
ETooManyConnections
EBadConnection
EBufferTooSmall
EInvalidSession
EInvalidTransaction
EParameterError
ESessionNotConnected
ENotSupported
EInvalidState
ESessionClosed
EMRUExceeded
EInvalidBufferSize
EDataNotAvailable
EErrorTimeout
EMORExceeded
EDeferedMethodFailed
EInsufficientCryptoStrength
EUnknownPanic

Definition at line 33 of file TNwssWspTrHndPanic.h.

Member Function Documentation

static void TNwssWspTrHndPanic::Panic ( TNwssWspTrHndPanicCode aPanic ) [inline, static]

Intended Usage: Panic the stub.

Uses the specified panic code.

Since:
7.0
Parameters:
aPanic (in) The code with which the client is panicked.

The documentation for this class was generated from the following file:
  • TNwssWspTrHndPanic.h


Member List

TNwssWspTrHndPanic Member List

This is the complete list of members for TNwssWspTrHndPanic, including all inherited members.
EBadConnection enum value | TNwssWspTrHndPanic |
EBearerError enum value | TNwssWspTrHndPanic |
EBufferTooSmall enum value | TNwssWspTrHndPanic |
ECannotOpenPort enum value | TNwssWspTrHndPanic |
ECapabilityOverrun enum value | TNwssWspTrHndPanic |
EConnectedUponDestruction enum value | TNwssWspTrHndPanic |
EConnectionLessNotSupported enum value | TNwssWspTrHndPanic |
ECOPushNotSupported enum value | TNwssWspTrHndPanic |
EDataNotAvailable enum value | TNwssWspTrHndPanic |
EDeferedMethodFailed enum value | TNwssWspTrHndPanic |
EErrorTimeout enum value | TNwssWspTrHndPanic |
EEventOnUnknownTransaction enum value | TNwssWspTrHndPanic |
EFailedToAbortTrans enum value | TNwssWspTrHndPanic |
EFailedToAcknowledgeTrans enum value | TNwssWspTrHndPanic |
EFailedToGetSessionData enum value | TNwssWspTrHndPanic |
EFailedToGetTransactionData enum value | TNwssWspTrHndPanic |
EFailedToOpenWspSession enum value | TNwssWspTrHndPanic |
EFailedToReleaseTrans enum value | TNwssWspTrHndPanic |
EInsufficientCryptoStrength enum value | TNwssWspTrHndPanic |
EInternalCapCodecError enum value | TNwssWspTrHndPanic |
EInvalidBufferSize enum value | TNwssWspTrHndPanic |
EInvalidSession enum value | TNwssWspTrHndPanic |
EInvalidState enum value | TNwssWspTrHndPanic |
EInvalidTransaction enum value | TNwssWspTrHndPanic |
EInvalidTransactionInLUT enum value | TNwssWspTrHndPanic |
ELargeDataTransferNotSupported enum value | TNwssWspTrHndPanic |
EMORExceeded enum value | TNwssWspTrHndPanic |
EMRUExceeded enum value | TNwssWspTrHndPanic |
ENotSupported enum value | TNwssWspTrHndPanic |
EParameterError enum value | TNwssWspTrHndPanic |
EPortAlreadyBound enum value | TNwssWspTrHndPanic |
EServiceNotSupported enum value | TNwssWspTrHndPanic |
ESessionClosed enum value | TNwssWspTrHndPanic |
ESessionNotConnected enum value | TNwssWspTrHndPanic |
ETooManyConnections enum value | TNwssWspTrHndPanic |
ETransLUTLeakage enum value | TNwssWspTrHndPanic |
ETransLUTOverflow enum value | TNwssWspTrHndPanic |
EUnknownMethod enum value | TNwssWspTrHndPanic |
EUnknownPanic enum value | TNwssWspTrHndPanic |
EUnknownWspEvent enum value | TNwssWspTrHndPanic |
EURIOverflow enum value | TNwssWspTrHndPanic |
EWrongBearerType enum value | TNwssWspTrHndPanic |
EWrongSessionType enum value | TNwssWspTrHndPanic |
Panic(TNwssWspTrHndPanicCode aPanic) | TNwssWspTrHndPanic | [inline, static]
TNwssWspTrHndPanicCode enum name | TNwssWspTrHndPanic |


RHTTPPropertySet Class Reference

@public
Since:
7.0 A set of named THTTPHdrVal objects.
More...

#include <rhttppropertyset.h>

Inheritance diagram for RHTTPPropertySet:

[legend]
Collaboration diagram for RHTTPPropertySet:

[legend]
List of all members.

Public Methods

IMPORT_C | RHTTPPropertySet ()
Default (uninitialised) constructor.

IMPORT_C TBool | Property (RStringF aPropertyName, THTTPHdrVal &aVal) const
Returns a property.

IMPORT_C void | SetPropertyL (RStringF aPropertyName, THTTPHdrVal aValue)
Sets or creates a property.

IMPORT_C void | RemoveProperty (RStringF aPropertyName)
Removes a named property.

IMPORT_C void | RemoveAllProperties ()
Removes all properties.

Protected Attributes

CHeaderFieldPart * iImplementation

Friends

class | CHeaderFieldPart
class | CHTTPSession

Detailed Description

@public
Since:
7.0 A set of named THTTPHdrVal objects.

Used for storing arbitrary collections of information.

Definition at line 29 of file rhttppropertyset.h.

Constructor & Destructor Documentation

IMPORT_C RHTTPPropertySet::RHTTPPropertySet ( )

Default (uninitialised) constructor.

An object constructed in this way means 'use text-mode HTTP with default settings'

Member Function Documentation

IMPORT_C TBool RHTTPPropertySet::Property | ( | RStringF | aPropertyName,
 |  | THTTPHdrVal & | aVal
 | ) | const

Returns a property.

Parameters:
aPropertyName | The name of the property.
aVal | The returned value of the property (if defined)
Returns:
ETrue if the property exists

IMPORT_C void RHTTPPropertySet::RemoveAllProperties ( )

Removes all properties.

IMPORT_C void RHTTPPropertySet::RemoveProperty ( RStringF aPropertyName )

Removes a named property.

Parameters:
aPropertyName The name of the property

IMPORT_C void RHTTPPropertySet::SetPropertyL | ( | RStringF | aPropertyName,
 |  | THTTPHdrVal | aValue
 | ) |

Sets or creates a property.

Parameters:
aPropertyName | The name of the property
aValue | The new value of the property
Exceptions:
KErrNoMemory There was not enough memory.

Friends And Related Function Documentation

friend class CHeaderFieldPart [friend]

Definition at line 69 of file rhttppropertyset.h.

friend class CHTTPSession [friend]

Definition at line 70 of file rhttppropertyset.h.

Member Data Documentation

CHeaderFieldPart* RHTTPPropertySet::iImplementation [protected]

Definition at line 67 of file rhttppropertyset.h.

Referenced by CHeaderFieldPart::ClosePropertySet(), and CHeaderFieldPart::SetPropertySet().

The documentation for this class was generated from the following file:
  • rhttppropertyset.h


Member List

RHTTPPropertySet Member List

This is the complete list of members for RHTTPPropertySet, including all inherited members.
CHeaderFieldPart class | RHTTPPropertySet | [friend]
CHTTPSession class | RHTTPPropertySet | [friend]
iImplementation | RHTTPPropertySet | [protected]
Property(RStringF aPropertyName, THTTPHdrVal &aVal) const | RHTTPPropertySet |
RemoveAllProperties() | RHTTPPropertySet |
RemoveProperty(RStringF aPropertyName) | RHTTPPropertySet |
RHTTPPropertySet() | RHTTPPropertySet |
SetPropertyL(RStringF aPropertyName, THTTPHdrVal aValue) | RHTTPPropertySet |


CProtocolHandler Class Reference

@public
Since:
7.0 An abstract protocol handler.
More...

#include <cprotocolhandler.h>

Inheritance diagram for CProtocolHandler:

[legend]
Collaboration diagram for CProtocolHandler:

[legend]
List of all members.

Public Methods

virtual IMPORT_C | ~CProtocolHandler ()
Intended Usage: Class destructor.

IMPORT_C CHeaderCodec * | Codec () const
Intended Usage: Obtain the protocol handler's header codec.

virtual TInt | SessionServerCert (TCertInfo &aServerCert)=0
Get the Server Certificate for the current session.

virtual TInt | TransactionServerCert (TCertInfo &aServerCert, RHTTPTransaction aTransaction)=0
Get the Server Certificate for the specified transaction.

virtual IMPORT_C void | MHFRunL (RHTTPTransaction aTransaction, const THTTPEvent &aEvent)
Since:
7.0 @leaves Standard Symbian OS error codes.

virtual IMPORT_C void | MHFSessionRunL (const THTTPSessionEvent &aEvent)
Since:
7.0 @leaves Standard Symbian OS error codes.

virtual IMPORT_C TInt | MHFRunError (TInt aError, RHTTPTransaction aTransaction, const THTTPEvent &aEvent)
Since:
7.0

virtual IMPORT_C TInt | MHFSessionRunError (TInt aError, const THTTPSessionEvent &aEvent)
Since:
7.0

virtual IMPORT_C void | MHFUnload (RHTTPSession aSession, THTTPFilterHandle aHandle)
Since:
7.0

virtual IMPORT_C void | MHFLoad (RHTTPSession aSession, THTTPFilterHandle aHandle)
Since:
7.0

Static Public Methods

CProtocolHandler * | NewL (const TDesC8 &aProtocol, RHTTPSession aSession)
Intended Usage: Standard factory constructor.

Protected Methods

IMPORT_C void | TransactionCompletedL (RHTTPTransaction aTrans, THTTPEvent aEventStatus)
Intended usage: Callback method for concrete protocol handler sub-classes to inform the base protocol handler that a transaction has completed.

IMPORT_C TInt | NumActiveTransactions () const
Intended usage: Obtain the number of currently active transactions
Since:
7.0.

IMPORT_C void | TransactionFailed (RHTTPTransaction aTrans)
Intended usage: Callback method for concrete protocol handler sub-classes to inform the base protocol handler that a transaction has failed utterly.

IMPORT_C void | CompleteSelf ()
Intended usage: Creates the specific type of codec required for a specific type of protocol handler.

IMPORT_C TInt | FindTransaction (RHTTPTransaction aTransaction, const CProtTransaction *&aProtTransaction) const
virtual IMPORT_C void | RunL ()
Intended Usage: Do some processing when a previous asynchronous request made by this object has completed.

virtual IMPORT_C TInt | RunError (TInt aError)
Intended Usage: Do any cleanup required should RunL leave
Since:
7.0.

virtual IMPORT_C void | DoCancel ()
Intended Usage: Cancel outstanding asynchronous requests that this object has made
Since:
7.0.

IMPORT_C | CProtocolHandler (RHTTPSession aSession)
Intended Usage: Constructs a protocol handler associated with the supplied HTTP client session.

IMPORT_C void | ConstructL (RHTTPSession aSession)
Intended Usage: Second phase construction in which any necessary allocation is done
Since:
7.0 @leaves Standard Symbian OS error codes.

Protected Attributes

RHTTPSession iSession
The session to which this protocol handler is dedicated.

CHeaderCodec * iCodec
The codec used for this protocol handler (to be specialised in subclasses).

__DECLARE_LOG CSecurityPolicy * | iSecurityPolicy
An interface providing the security policy.

Private Methods

virtual void | CreateCodecL ()=0
virtual CProtTransaction * | CreateProtTransactionL (RHTTPTransaction aTransaction)=0
Intended Usage: Creates a representation of a client transaction to be used in the protocol handler.

virtual TBool | ServiceL (CProtTransaction &aTrans)=0
Intended Usage: Attempt to service the transaction.

virtual void | ClosedTransactionHook (CProtTransaction *aTrans)=0
Intended Usage: Called when the RHTTPTransaction object corresponding to aTrans has been closed by the client.

virtual void | CancelTransactionHook (CProtTransaction &aTransaction)=0
Intended Usage: Called when the RHTTPTransaction object corresponding to aTrans has been cancelled by the client or an intermediate filter.

virtual void | NotifyNewRequestBodyPart (CProtTransaction &aTransaction)=0
Intended Usage: Called to notify the concrete protocol handler that new request body data is available for transmission.

void | SubmitTransactionL (RHTTPTransaction aTransaction)
Intended Usage: Called after a client RHTTPTransaction::SubmitL(), this method enqueues the supplied client transaction.

void | HandleCancelTransaction (RHTTPTransaction aTrans)
Intended Usage: Sets the state of the CProtTransaction object for this transaction to ECancelled, and resets the object.

void | HandleClosedTransaction (RHTTPTransaction aTrans)
Intended Usage: Removes the CProtTransaction object for the transaction from the queue of CProtTransaction objects.

TInt | FindTransaction (RHTTPTransaction aTransaction) const
Intended Usage: Searches the array of CProtTransaction objects to if the aTransaction object is wrapped by one of them.

virtual void | Reserved1 ()
Intended Usage: Reserve a slot in the v-table to preserve future BC
Since:
7.0.

virtual void | Reserved2 ()
Intended Usage: Reserve a slot in the v-table to preserve future BC
Since:
7.0.

Private Attributes

RPointerArray< CProtTransaction > | iTransactions
A list of transactions.

RHTTPTransaction iCurrentTransaction
The transaction which is currently being serviced - used in RunError so we know which transaction caused RunL to leave.

TUid | iDtor_ID_Key
The destructor key UID indentification required by ECom.

Detailed Description

@public
Since:
7.0 An abstract protocol handler.

Protocol handlers are required to act as the bridge between abstract representations of sessions, transactions and headers (the client side of the HTTP architecture) and specific comms transports (the network side of the architecture).

Each instance of a concrete subclass of CProtocolHandler is associated with a specific client session, and hence with a particular choice of proxy type, and by implication, transport type. It is designed to appear like a filter in order to be placed at the end of a session's filter queue. This allows it to receive transaction-related events in the same way that any other filter (or indeed, the client) does. An active object, it may implement a queuing system for submitted transactions, according to the chosen internal service model.

In order to divide the abstract functionality associated with handling the HTTP protocol handler from the specifics needed for a particular choice of transport, this class defines a number of pure virtual methods which allow it to defer transport-specific choices or mechamisms. These are mainly concerned with the service model (ie. allocation of transactions to objects that can handle them), the codec model (ie. on-demand encoding/decoding of HTTP header data) and general housekeeping (eg. instantiation and cleanup of objects at particular points in a transaction lifecycle).

Definition at line 62 of file cprotocolhandler.h.

Constructor & Destructor Documentation

CProtocolHandler::~CProtocolHandler ( ) [virtual]

Intended Usage: Class destructor.

Since:
7.0

CProtocolHandler::CProtocolHandler ( RHTTPSession aSession ) [protected]

Intended Usage: Constructs a protocol handler associated with the supplied HTTP client session.

Since:
7.0
Parameters:
aSession (in) The session on which the new protocol handler will be installed.

Member Function Documentation

CProtocolHandler::CancelTransactionHook ( CProtTransaction & aTrans ) [private, pure virtual]

Intended Usage: Called when the RHTTPTransaction object corresponding to aTrans has been cancelled by the client or an intermediate filter.

This allows the concrete protocol handler to do any cleanup and to perform the necessary actions for cancellation on its transport layer.

This must be implemented by a concrete protocol handler sub-class.

Since:
7.0
Parameters:
aTrans (in) A reference to the transaction being cancelled.

Implemented in CTextModeHttpProt, and CWspCOProtocolHandler.

CProtocolHandler::ClosedTransactionHook ( CProtTransaction * aTrans ) [private, pure virtual]

Intended Usage: Called when the RHTTPTransaction object corresponding to aTrans has been closed by the client.

This allows the concrete protocol handler to do any cleanup required for this particular transaction.

Ownership of the CProtTransaction object is transferred back to the concrete protocol handler, which then has deletion responsibility for it. By the time this function has been called, the base protocol handler will have dequeued the transaction.

The client's RHTTPTransaction will be closed when this function returns, so it is not possible to send events to the client during the function's execution.

This must be implemented by a concrete protocol handler sub-class.

Since:
7.0
Parameters:
aTrans (in) A pointer to the transaction about to be closed.

Implemented in CTextModeHttpProt, and CWspCOProtocolHandler.

CProtocolHandler::Codec ( ) const

Intended Usage: Obtain the protocol handler's header codec.

Since:
7.0
Returns:
The header codec owned by this protocol handler, or NULL if one has not yet been created.
See also:
CHeaderCodec

CProtocolHandler::CompleteSelf ( ) [protected]

Intended usage: Creates the specific type of codec required for a specific type of protocol handler.

Since:
7.0

CProtocolHandler::ConstructL ( RHTTPSession aSession ) [protected]

Intended Usage: Second phase construction in which any necessary allocation is done

Since:
7.0 @leaves Standard Symbian OS error codes.

e.g. KErrNoMemory.

Parameters:
RHTTPSession aSession.

Reimplemented in CTextModeHttpProt.

virtual void CProtocolHandler::CreateCodecL ( ) [private, pure virtual]

Implemented in CTextModeHttpProt, and CWspCOProtocolHandler.

CProtocolHandler::CreateProtTransactionL ( RHTTPTransaction aTransaction ) [private, pure virtual]

Intended Usage: Creates a representation of a client transaction to be used in the protocol handler.

Since the protocol handler deals with the low- level data for a transaction as sent over a particular transport, an appropriate CProtTransaction-derived class is used that owns a CRxData and a CTxData to handle the low-level data.

This must be implemented by a concrete protocol handler sub-class.

Since:
7.0 @leave Leave code KErrNoMemory if there was not enough memory to create the object.
Parameters:
aTransaction The RHTTPTransaction object associated with this CProtTransaction object.
Returns:
A pointer to a created CProtTransaction-derived class. @leaves Standard Symbian OS error codes. e.g. KErrNoMemory.
See also:
CRxData , CTxData

Implemented in CTextModeHttpProt, and CWspCOProtocolHandler.

CProtocolHandler::DoCancel ( ) [protected, virtual]

Intended Usage: Cancel outstanding asynchronous requests that this object has made

Since:
7.0.

CProtocolHandler::FindTransaction ( RHTTPTransaction aTransaction ) const [private]

Intended Usage: Searches the array of CProtTransaction objects to if the aTransaction object is wrapped by one of them.

Since:
7.0
Parameters:
aTransaction The transaction to search for.
Returns:
If a CProtTransaction object is found, a positive value is returned that is the index to that object in the array. If no object is found, KErrNotFound is returned.

IMPORT_C TInt CProtocolHandler::FindTransaction | ( | RHTTPTransaction | aTransaction,
 |  | const CProtTransaction *& | aProtTransaction
 | ) | const [protected]

CProtocolHandler::HandleCancelTransaction ( RHTTPTransaction aTrans ) [private]

Intended Usage: Sets the state of the CProtTransaction object for this transaction to ECancelled, and resets the object.

This object can be reused if the transaction is resubmitted.

Since:
7.0
Parameters:
RHTTPTransaction aTrans
Precondition:
A CProtTransaction object exists for this transaction.
Postcondition:
The state of the CProtTransaction object is set to ECancelled and it has been reset.

CProtocolHandler::HandleClosedTransaction ( RHTTPTransaction aTrans ) [private]

Intended Usage: Removes the CProtTransaction object for the transaction from the queue of CProtTransaction objects.

Since:
7.0
Parameters:
RHTTPTransaction aTrans
Precondition:
A CProtTransaction object exists for this transaction.
Postcondition:
The CProtTransaction object has been removed from the queue.

CProtocolHandler::MHFLoad | ( | RHTTPSession | aSession,
 |  | THTTPFilterHandle | aHandle
 | ) | [virtual]

Since:
7.0

See also:
MHTTFilter

Reimplemented from MHTTPFilter.

CProtocolHandler::MHFRunError | ( | TInt | aError,
 |  | RHTTPTransaction | aTransaction,
 |  | const THTTPEvent & | aEvent
 | ) | [virtual]

Since:
7.0

See also:
MHTTPFilterBase

Reimplemented from MHTTPFilterBase.

CProtocolHandler::MHFRunL | ( | RHTTPTransaction | aTransaction,
 |  | const THTTPEvent & | aEvent
 | ) | [virtual]

Since:
7.0 @leaves Standard Symbian OS error codes.

e.g. KErrNoMemory.

See also:
MHTTPFilterBase

Reimplemented from MHTTPFilterBase.

CProtocolHandler::MHFSessionRunError | ( | TInt | aError,
 |  | const THTTPSessionEvent & | aEvent
 | ) | [virtual]

Since:
7.0

See also:
MHTTPFilterBase

Reimplemented from MHTTPFilterBase.

Reimplemented in CWspCOProtocolHandler.

CProtocolHandler::MHFSessionRunL ( const THTTPSessionEvent & aEvent ) [virtual]

Since:
7.0 @leaves Standard Symbian OS error codes.

e.g. KErrNoMemory.

See also:
MHTTPFilterBase

Reimplemented from MHTTPFilterBase.

Reimplemented in CWspCOProtocolHandler.

CProtocolHandler::MHFUnload | ( | RHTTPSession | aSession,
 |  | THTTPFilterHandle | aHandle
 | ) | [virtual]

Since:
7.0

See also:
MHTTFilter

Reimplemented from MHTTPFilter.

CProtocolHandler::NewL | ( | const TDesC8 & | aProtocol,
 |  | RHTTPSession | aSession
 | ) | [static]

Intended Usage: Standard factory constructor.

This is the ECOM interface class from which concrete protocol handlers are derived. The method queries ECOM for the protocol handler plugin that matches the protocol description passed in.

Since:
7.0
Parameters:
aProtocol | (in) The name of the protocol required.
aSession | (in) The HTTP session on which this protocol handler will be installed. @leaves Standard Symbian OS error codes. e.g. KErrNoMemory.

CProtocolHandler::NotifyNewRequestBodyPart ( CProtTransaction & aTransaction ) [private, pure virtual]

Intended Usage: Called to notify the concrete protocol handler that new request body data is available for transmission.

This must be implemented by a concrete protocol handler sub-class.

Since:
7.0
Parameters:
aTrans (in) A reference to the transaction whose request body has new data available.

Implemented in CTextModeHttpProt, and CWspCOProtocolHandler.

CProtocolHandler::NumActiveTransactions ( ) const [protected]

Intended usage: Obtain the number of currently active transactions

Since:
7.0.

Returns:
The number of currently active transactions

void CProtocolHandler::Reserved1 ( ) [inline, private, virtual]

Intended Usage: Reserve a slot in the v-table to preserve future BC

Since:
7.0.

Definition at line 481 of file cprotocolhandler.h.

void CProtocolHandler::Reserved2 ( ) [inline, private, virtual]

Intended Usage: Reserve a slot in the v-table to preserve future BC

Since:
7.0.

Definition at line 483 of file cprotocolhandler.h.

CProtocolHandler::RunError ( TInt aError ) [protected, virtual]

Intended Usage: Do any cleanup required should RunL leave

Since:
7.0.

Parameters:
aError (in) The error code that RunL left with
Returns:
A final error code - KErrNone if the error was handled by this method.

CProtocolHandler::RunL ( ) [protected, virtual]

Intended Usage: Do some processing when a previous asynchronous request made by this object has completed.

Since:
7.0 @leaves Standard Symbian OS error codes. e.g. KErrNoMemory.

CProtocolHandler::ServiceL ( CProtTransaction & aTrans ) [private, pure virtual]

Intended Usage: Attempt to service the transaction.

This implies that the concrete protocol handler will allocate some transport resources to the transaction - which could fail if the protocol handler has hit an internal limit of resources or bandwidth.

This must be implemented by a concrete protocol handler sub-class.

Since:
7.0
Parameters:
aTrans The pending protocol transaction object which is to be serviced.
Returns:
A flag that indicates if the transaction can be serviced immediately. @leaves Standard Symbian OS error codes. e.g. KErrNoMemory.

Implemented in CTextModeHttpProt, and CWspCOProtocolHandler.

virtual TInt CProtocolHandler::SessionServerCert ( TCertInfo & aServerCert ) [pure virtual]

Get the Server Certificate for the current session.

Parameters:
aServerCert A TCertInfo which will be filled with the certificate information
Returns:
An error code. KErrNone if aServerCert has been completed, otherwise one of the system wide error codes

Implemented in CTextModeHttpProt, and CWspCOProtocolHandler.

CProtocolHandler::SubmitTransactionL ( RHTTPTransaction aTransaction ) [private]

Intended Usage: Called after a client RHTTPTransaction::SubmitL(), this method enqueues the supplied client transaction.

It checks to see if there already exists a CProtTransaction for this transaction. If there is and its state is ECancelled, then the associated request data is reset and the state changed to EPending. A CompleteSelf() is issued. In the case of an existing CProtTransaction that has not been cancelled, the submit event is ignored. If no CProtTransaction object existed, then one is created for the transaction and a CompleteSelf() is issued.

Since:
7.0 @leave KErrHttpCantResetRequestBody if the request body data cannot be reset. KErrNoMemory if a new CProtTransaction cannot be created or added to the transaction queue.
Parameters:
aTransaction The submitted transaction.
Precondition:
None
Postcondition:
If there is a new pending CProtTransaction object the protocol handler will have been self-completed (i.e. the RunL will be called).

CProtocolHandler::TransactionCompletedL | ( | RHTTPTransaction | aTrans,
 |  | THTTPEvent | aEventStatus
 | ) | [protected]

Intended usage: Callback method for concrete protocol handler sub-classes to inform the base protocol handler that a transaction has completed.

The concrete protocol handler must call this method in order to supply a completion event that will be sent to the client. In addition, the method allows the base protocol handler to do some queue management.

Since:
7.0
Parameters:
aTrans | (in) the completed transaction
aEventStatus | (in) an event to be sent back to the client along the filter queue @leaves Standard Symbian OS error codes. e.g. KErrNoMemory.

CProtocolHandler::TransactionFailed ( RHTTPTransaction aTrans ) [protected]

Intended usage: Callback method for concrete protocol handler sub-classes to inform the base protocol handler that a transaction has failed utterly.

(i.e. the sub-class used aTrans.Fail().) The base protocol handler sets the transaction state to be cancelled.

Since:
7.0
Parameters:
aTrans (in) the completed transaction

virtual TInt CProtocolHandler::TransactionServerCert | ( | TCertInfo & | aServerCert,
 |  | RHTTPTransaction | aTransaction
 | ) | [pure virtual]

Get the Server Certificate for the specified transaction.

Parameters:
aServerCert | A TCertInfo which will be filled with the certificate information
aTransaction | The transaction for which the certificate is requested
Returns:
An error code. KErrNone if aServerCert has been completed, otherwise one of the system wide error codes

Implemented in CTextModeHttpProt, and CWspCOProtocolHandler.

Member Data Documentation

CHeaderCodec* CProtocolHandler::iCodec [protected]

The codec used for this protocol handler (to be specialised in subclasses).

Definition at line 374 of file cprotocolhandler.h.

RHTTPTransaction CProtocolHandler::iCurrentTransaction [private]

The transaction which is currently being serviced - used in RunError so we know which transaction caused RunL to leave.

Definition at line 471 of file cprotocolhandler.h.

TUid CProtocolHandler::iDtor_ID_Key [private]

The destructor key UID indentification required by ECom.

Definition at line 476 of file cprotocolhandler.h.

__DECLARE_LOG CSecurityPolicy* CProtocolHandler::iSecurityPolicy [protected]

An interface providing the security policy.

This may be NULL if there is no security policy plugin

Definition at line 382 of file cprotocolhandler.h.

RHTTPSession CProtocolHandler::iSession [protected]

The session to which this protocol handler is dedicated.

Definition at line 369 of file cprotocolhandler.h.

RPointerArray<CProtTransaction> CProtocolHandler::iTransactions [private]

A list of transactions.

Each transaction has a list state, e.g. pending, active, etc.

Definition at line 465 of file cprotocolhandler.h.

The documentation for this class was generated from the following file:
  • cprotocolhandler.h


Member List

CProtocolHandler Member List

This is the complete list of members for CProtocolHandler, including all inherited members.
CancelTransactionHook(CProtTransaction &aTransaction)=0 | CProtocolHandler | [private, pure virtual]
ClosedTransactionHook(CProtTransaction *aTrans)=0 | CProtocolHandler | [private, pure virtual]
Codec() const | CProtocolHandler |
CompleteSelf() | CProtocolHandler | [protected]
ConstructL(RHTTPSession aSession) | CProtocolHandler | [protected]
CProtocolHandler(RHTTPSession aSession) | CProtocolHandler | [protected]
CreateCodecL()=0 | CProtocolHandler | [private, pure virtual]
CreateProtTransactionL(RHTTPTransaction aTransaction)=0 | CProtocolHandler | [private, pure virtual]
DoCancel() | CProtocolHandler | [protected, virtual]
ECache enum value | MHTTPFilter |
EClient enum value | MHTTPFilter |
EClientFilters enum value | MHTTPFilter |
ECookies enum value | MHTTPFilter |
EProtocolHandler enum value | MHTTPFilter |
EStatusCodeHandler enum value | MHTTPFilter |
ETidyUp enum value | MHTTPFilter |
FindTransaction(RHTTPTransaction aTransaction, const CProtTransaction *&aProtTransaction) const | CProtocolHandler | [protected]
FindTransaction(RHTTPTransaction aTransaction) const | CProtocolHandler | [private]
HandleCancelTransaction(RHTTPTransaction aTrans) | CProtocolHandler | [private]
HandleClosedTransaction(RHTTPTransaction aTrans) | CProtocolHandler | [private]
iCodec | CProtocolHandler | [protected]
iCurrentTransaction | CProtocolHandler | [private]
iDtor_ID_Key | CProtocolHandler | [private]
iSecurityPolicy | CProtocolHandler | [protected]
iSession | CProtocolHandler | [protected]
iTransactions | CProtocolHandler | [private]
MHFLoad(RHTTPSession aSession, THTTPFilterHandle aHandle) | CProtocolHandler | [virtual]
MHFRunError(TInt aError, RHTTPTransaction aTransaction, const THTTPEvent &aEvent) | CProtocolHandler | [virtual]
MHFRunL(RHTTPTransaction aTransaction, const THTTPEvent &aEvent) | CProtocolHandler | [virtual]
MHFSessionRunError(TInt aError, const THTTPSessionEvent &aEvent) | CProtocolHandler | [virtual]
MHFSessionRunL(const THTTPSessionEvent &aEvent) | CProtocolHandler | [virtual]
MHFUnload(RHTTPSession aSession, THTTPFilterHandle aHandle) | CProtocolHandler | [virtual]
NewL(const TDesC8 &aProtocol, RHTTPSession aSession) | CProtocolHandler | [static]
NotifyNewRequestBodyPart(CProtTransaction &aTransaction)=0 | CProtocolHandler | [private, pure virtual]
NumActiveTransactions() const | CProtocolHandler | [protected]
Reserved1() | CProtocolHandler | [inline, private, virtual]
Reserved2() | CProtocolHandler | [inline, private, virtual]
RunError(TInt aError) | CProtocolHandler | [protected, virtual]
RunL() | CProtocolHandler | [protected, virtual]
ServiceL(CProtTransaction &aTrans)=0 | CProtocolHandler | [private, pure virtual]
SessionServerCert(TCertInfo &aServerCert)=0 | CProtocolHandler | [pure virtual]
SubmitTransactionL(RHTTPTransaction aTransaction) | CProtocolHandler | [private]
TPositions enum name | MHTTPFilter |
TransactionCompletedL(RHTTPTransaction aTrans, THTTPEvent aEventStatus) | CProtocolHandler | [protected]
TransactionFailed(RHTTPTransaction aTrans) | CProtocolHandler | [protected]
TransactionServerCert(TCertInfo &aServerCert, RHTTPTransaction aTransaction)=0 | CProtocolHandler | [pure virtual]
~CProtocolHandler() | CProtocolHandler | [virtual]


CProtTransaction Class Reference

@public
Since:
7.0 A representation of a transaction used by protocol handlers.
More...

#include <CProtTransaction.h>

Inheritance diagram for CProtTransaction:

[legend]
Collaboration diagram for CProtTransaction:

[legend]
List of all members.

Public Types

enum | TTransactionState { EPending = 0, EActive, ECancelled, ECompleted }
The TTransactionState type defines the states of a transaction. More...

Public Methods

virtual IMPORT_C | ~CProtTransaction ()
Intended Usage: Destructor - cleans up and releases resources to the system
Since:
7.0.

TTransactionState | TransactionState () const
Intended Usage: Provides the state of the transaction, e.g.

void | SetTransactionState (TTransactionState aState)
Intended Usage: Sets the state of the transaction.

IMPORT_C void | ResetRxData ()
Intended Usage: Resets the Rx data object.

IMPORT_C void | ResetTxData ()
Intended Usage: Resets the Tx data object.

IMPORT_C RHTTPTransaction | Transaction () const
Intended Usage: Obtain the API-level transaction to which this object corresponds to.

IMPORT_C CTxData & | TxData () const
Intended Usage: Obtain the Transmit Data portion of the transaction.

IMPORT_C CRxData & | RxData () const
Intended Usage: Obtain the Receive Data portion of the transaction.

virtual void | CreateTxDataL ()=0
Intended Usage: Creates the appropriate CTxData object.

virtual void | CreateRxDataL (MRxDataObserver &aObserver)=0
Intended Usage: Creates the appropriate CRxData object.

Protected Methods

CProtTransaction ()
Intended Usage: Default constructor
Since:
7.0.

IMPORT_C | CProtTransaction (RHTTPTransaction aTrans)
Intended Usage: Normal constructor, of a CProtTransaction that corresponds to the supplied client transaction handle.

Protected Attributes

RHTTPTransaction iTrans
The client transaction.

CTxData * iTxData
The transmission data.

CRxData * iRxData
The received data.

TTransactionState iTransactionState
Transaction state indicator.

Private Methods

virtual void | Reserved1 ()
Intended Usage: Reserve a slot in the v-table to preserve future BC
Since:
7.0.

virtual void | Reserved2 ()
Intended Usage: Reserve a slot in the v-table to preserve future BC
Since:
7.0.

Detailed Description

@public
Since:
7.0 A representation of a transaction used by protocol handlers.

This class is lower-level than the RHTTPTransaction class, since it owns objects that represent the request and response data as transmitted and received over a transport medium.

Definition at line 34 of file CProtTransaction.h.

Member Enumeration Documentation

enum CProtTransaction::TTransactionState

The TTransactionState type defines the states of a transaction.

Enumeration values:
EPending | Specifies that the transaction is pending servicing.
EActive | Specifies that the transaction is being serviced - active.
ECancelled | Specifies that the transaction has been cancelled.
ECompleted | Specifies that the transaction has completed.

Definition at line 40 of file CProtTransaction.h.

Constructor & Destructor Documentation

CProtTransaction::~CProtTransaction ( ) [virtual]

Intended Usage: Destructor - cleans up and releases resources to the system

Since:
7.0.

CProtTransaction::CProtTransaction ( ) [protected]

Intended Usage: Default constructor

Since:
7.0.

CProtTransaction::CProtTransaction ( RHTTPTransaction aTrans ) [protected]

Intended Usage: Normal constructor, of a CProtTransaction that corresponds to the supplied client transaction handle.

Since:
7.0
Parameters:
aTrans (in) The client transaction handle.

Member Function Documentation

CProtTransaction::CreateRxDataL ( MRxDataObserver & aObserver ) [pure virtual]

Intended Usage: Creates the appropriate CRxData object.

Since:
7.0 @leave KErrNoMemory if there is not enough memory available to create the object.
Parameters:
aObserver A reference to the observer for the Rx data object.

Implemented in CTextModeProtTransaction, and CWspCOTransaction.

CProtTransaction::CreateTxDataL ( ) [pure virtual]

Intended Usage: Creates the appropriate CTxData object.

Since:
7.0 @leave KErrNoMemory if there is not enough memory available to create the object.

Implemented in CTextModeProtTransaction, and CWspCOTransaction.

void CProtTransaction::Reserved1 ( ) [inline, private, virtual]

Intended Usage: Reserve a slot in the v-table to preserve future BC

Since:
7.0.

Definition at line 207 of file CProtTransaction.h.

void CProtTransaction::Reserved2 ( ) [inline, private, virtual]

Intended Usage: Reserve a slot in the v-table to preserve future BC

Since:
7.0.

Definition at line 209 of file CProtTransaction.h.

CProtTransaction::ResetRxData ( )

Intended Usage: Resets the Rx data object.

The Rx data object must be created again to be used.

Since:
7.0
Postcondition:
The Rx data objects has been reset.

CProtTransaction::ResetTxData ( )

Intended Usage: Resets the Tx data object.

The Tx data object must be created again to be used.

Since:
7.0
Postcondition:
The Tx data objects has been reset.

CProtTransaction::RxData ( ) const

Intended Usage: Obtain the Receive Data portion of the transaction.

Since:
7.0
Returns:
A reference to the Rx data object of the transaction.

CProtTransaction::SetTransactionState ( TTransactionState aState )

Intended Usage: Sets the state of the transaction.

Since:
7.0
Parameters:
aState The state that the transaction is in.
Postcondition:
The state of the transaction has been updated.

CProtTransaction::Transaction ( ) const

Intended Usage: Obtain the API-level transaction to which this object corresponds to.

Since:
7.0
Returns:
The API-level transaction that this object corresponds to.

CProtTransaction::TransactionState ( ) const

Intended Usage: Provides the state of the transaction, e.g.

pending, active, etc.

Since:
7.0
Returns:
A enum specifying the state of the transaction.

CProtTransaction::TxData ( ) const

Intended Usage: Obtain the Transmit Data portion of the transaction.

Since:
7.0
Returns:
A reference to the Tx data object of the transaction.

Member Data Documentation

CRxData* CProtTransaction::iRxData [protected]

The received data.

Definition at line 182 of file CProtTransaction.h.

RHTTPTransaction CProtTransaction::iTrans [protected]

The client transaction.

Definition at line 172 of file CProtTransaction.h.

TTransactionState CProtTransaction::iTransactionState [protected]

Transaction state indicator.

Definition at line 187 of file CProtTransaction.h.

CTxData* CProtTransaction::iTxData [protected]

The transmission data.

Definition at line 177 of file CProtTransaction.h.

The documentation for this class was generated from the following file:
  • CProtTransaction.h


Member List

CProtTransaction Member List

This is the complete list of members for CProtTransaction, including all inherited members.
CProtTransaction() | CProtTransaction | [protected]
CProtTransaction(RHTTPTransaction aTrans) | CProtTransaction | [protected]
CreateRxDataL(MRxDataObserver &aObserver)=0 | CProtTransaction | [pure virtual]
CreateTxDataL()=0 | CProtTransaction | [pure virtual]
EActive enum value | CProtTransaction |
ECancelled enum value | CProtTransaction |
ECompleted enum value | CProtTransaction |
EPending enum value | CProtTransaction |
iRxData | CProtTransaction | [protected]
iTrans | CProtTransaction | [protected]
iTransactionState | CProtTransaction | [protected]
iTxData | CProtTransaction | [protected]
Reserved1() | CProtTransaction | [inline, private, virtual]
Reserved2() | CProtTransaction | [inline, private, virtual]
ResetRxData() | CProtTransaction |
ResetTxData() | CProtTransaction |
RxData() const | CProtTransaction |
SetTransactionState(TTransactionState aState) | CProtTransaction |
Transaction() const | CProtTransaction |
TransactionState() const | CProtTransaction |
TTransactionState enum name | CProtTransaction |
TxData() const | CProtTransaction |
~CProtTransaction() | CProtTransaction | [virtual]


TProxyInfo Class Reference

The TProxyInfo type contains the information that defines a connection to a proxy that is capable of establishing a WSP session. More...

#include <TProxyInfo.h>

List of all members.

Public Methods

TBool | operator== (const TProxyInfo &aProxyInfo) const
Intended Usage : Equality operator.

TBool | operator!= (const TProxyInfo &aProxyInfo) const
Intended Usage : Inequality operator.

void | Close ()
Intended Usage : Cleans up the resource usage in this class.

Public Attributes

RStringF | iProxyAddress
The proxy address.

TWspBearer | iBearer
The bearer type.

TUint16 | iLocalPort
The local port number (only for IP bearer).

TUint16 | iRemotePort
The remote port number (only for IP bearer).

RStringF | iServiceCentreNumber
The service number for the proxy (only for SMS bearer).

TWspSession | iSessionType
The Wsp Session Service type.

TBool | iSecureConnection
A flag indicating whether the WSP session should be secured.

Detailed Description

The TProxyInfo type contains the information that defines a connection to a proxy that is capable of establishing a WSP session.

As a T-class the destructor does no cleanup. A Close() function has been supplied to do the cleanup - i.e. it closes the RStringF data members.

Definition at line 22 of file TProxyInfo.h.

Member Function Documentation

TProxyInfo::Close ( ) [inline]

Intended Usage : Cleans up the resource usage in this class.

Closes the RStringFs for the proxy address and the service number.

Since:
7.0
Postcondition:
The string members have been closed.

TProxyInfo::operator!= ( const TProxyInfo & aProxyInfo ) const [inline]

Intended Usage : Inequality operator.

Since:
7.0
Returns:
A boolean value of ETrue if aProxyInfo does not match this object.

TProxyInfo::operator== ( const TProxyInfo & aProxyInfo ) const

Intended Usage : Equality operator.

Since:
7.0
Returns:
A boolean value of ETrue if aProxyInfo matches this object.

Member Data Documentation

TWspBearer TProxyInfo::iBearer

The bearer type.

Definition at line 63 of file TProxyInfo.h.

TUint16 TProxyInfo::iLocalPort

The local port number (only for IP bearer).

Definition at line 68 of file TProxyInfo.h.

RStringF TProxyInfo::iProxyAddress

The proxy address.

This class is not responsible for the cleanup of this string.

Definition at line 58 of file TProxyInfo.h.

TUint16 TProxyInfo::iRemotePort

The remote port number (only for IP bearer).

Definition at line 73 of file TProxyInfo.h.

TBool TProxyInfo::iSecureConnection

A flag indicating whether the WSP session should be secured.

Definition at line 89 of file TProxyInfo.h.

RStringF TProxyInfo::iServiceCentreNumber

The service number for the proxy (only for SMS bearer).

This class is not responsible for the cleanup of this string.

Definition at line 79 of file TProxyInfo.h.

TWspSession TProxyInfo::iSessionType

The Wsp Session Service type.

Definition at line 84 of file TProxyInfo.h.

The documentation for this class was generated from the following file:
  • TProxyInfo.h


Member List

TProxyInfo Member List

This is the complete list of members for TProxyInfo, including all inherited members.
Close() | TProxyInfo | [inline]
iBearer | TProxyInfo |
iLocalPort | TProxyInfo |
iProxyAddress | TProxyInfo |
iRemotePort | TProxyInfo |
iSecureConnection | TProxyInfo |
iServiceCentreNumber | TProxyInfo |
iSessionType | TProxyInfo |
operator!=(const TProxyInfo &aProxyInfo) const | TProxyInfo | [inline]
operator==(const TProxyInfo &aProxyInfo) const | TProxyInfo |


CRedirectFilter Class Reference

#include <redirect.h>

Inheritance diagram for CRedirectFilter:

[legend]
Collaboration diagram for CRedirectFilter:

[legend]
List of all members.

Public Methods

~CRedirectFilter ()
virtual void | MHFRunL (RHTTPTransaction aTransaction, const THTTPEvent &aEvent)
See also:
MHTTPFilterBase::MHFRunL

virtual void | MHFSessionRunL (const THTTPSessionEvent &aEvent)
See also:
MHTTPFilterBase::MHFSessionRunL

virtual TInt | MHFRunError (TInt aError, RHTTPTransaction aTransaction, const THTTPEvent &aEvent)
See also:
MHTTPFilterBase::MHFRunError

virtual TInt | MHFSessionRunError (TInt aError, const THTTPSessionEvent &aEvent)
See also:
MHTTPFilterBase::MHFSessionRunError

virtual void | MHFUnload (RHTTPSession aSession, THTTPFilterHandle aHandle)
See also:
MHTTPFilter::MHFUnload

virtual void | MHFLoad (RHTTPSession aSession, THTTPFilterHandle aHandle)
See also:
MHTTPFilter::MHFLoad

Static Public Methods

CEComFilter * | InstallFilterL (TAny *aSession)

Private Methods

CRedirectFilter (RHTTPSession aSession)
void | ConstructL (RHTTPSession aSession)
ContructL also Installs the filter.

void | HandleRedirectL (RHTTPTransaction aTransaction, THTTPEvent::TTransactionWarning aWarningEvent)
Function to handle the receipt of 301 Moved Permanently, 302 Found, 307 Moved Temporarily or 303 See Other.

void | HandleUseProxyL (RHTTPTransaction aTransaction)
void | SetRedirectUriL (RHTTPRequest aRequest, const TUriParser8 &aUri) const

Private Attributes

TInt | iLoadCount
A count to make sure we delete at the right time.

RStringPool | iStringPool
RHTTPSession iSession

Constructor & Destructor Documentation

CRedirectFilter::~CRedirectFilter ( )

CRedirectFilter::CRedirectFilter ( RHTTPSession aSession ) [private]

Member Function Documentation

void CRedirectFilter::ConstructL ( RHTTPSession aSession ) [private]

ContructL also Installs the filter.

void CRedirectFilter::HandleRedirectL | ( | RHTTPTransaction | aTransaction,
 |  | THTTPEvent::TTransactionWarning | aWarningEvent
 | ) | [private]

Function to handle the receipt of 301 Moved Permanently, 302 Found, 307 Moved Temporarily or 303 See Other.

void CRedirectFilter::HandleUseProxyL ( RHTTPTransaction aTransaction ) [private]

CEComFilter* CRedirectFilter::InstallFilterL ( TAny * aSession ) [static]

virtual void CRedirectFilter::MHFLoad | ( | RHTTPSession | aSession,
 |  | THTTPFilterHandle | aHandle
 | ) | [virtual]

See also:
MHTTPFilter::MHFLoad

Reimplemented from MHTTPFilter.

virtual TInt CRedirectFilter::MHFRunError | ( | TInt | aError,
 |  | RHTTPTransaction | aTransaction,
 |  | const THTTPEvent & | aEvent
 | ) | [virtual]

See also:
MHTTPFilterBase::MHFRunError

Reimplemented from MHTTPFilterBase.

virtual void CRedirectFilter::MHFRunL | ( | RHTTPTransaction | aTransaction,
 |  | const THTTPEvent & | aEvent
 | ) | [virtual]

See also:
MHTTPFilterBase::MHFRunL

Reimplemented from MHTTPFilterBase.

virtual TInt CRedirectFilter::MHFSessionRunError | ( | TInt | aError,
 |  | const THTTPSessionEvent & | aEvent
 | ) | [virtual]

See also:
MHTTPFilterBase::MHFSessionRunError

Reimplemented from MHTTPFilterBase.

virtual void CRedirectFilter::MHFSessionRunL ( const THTTPSessionEvent & aEvent ) [virtual]

See also:
MHTTPFilterBase::MHFSessionRunL

Reimplemented from MHTTPFilterBase.

virtual void CRedirectFilter::MHFUnload | ( | RHTTPSession | aSession,
 |  | THTTPFilterHandle | aHandle
 | ) | [virtual]

See also:
MHTTPFilter::MHFUnload

Reimplemented from MHTTPFilter.

void CRedirectFilter::SetRedirectUriL | ( | RHTTPRequest | aRequest,
 |  | const TUriParser8 & | aUri
 | ) | const [private]

Member Data Documentation

TInt CRedirectFilter::iLoadCount [private]

A count to make sure we delete at the right time.

Definition at line 74 of file redirect.h.

RHTTPSession CRedirectFilter::iSession [private]

Definition at line 79 of file redirect.h.

RStringPool CRedirectFilter::iStringPool [private]

Definition at line 76 of file redirect.h.

The documentation for this class was generated from the following file:
  • redirect.h


Member List

CRedirectFilter Member List

This is the complete list of members for CRedirectFilter, including all inherited members.
ConstructL(RHTTPSession aSession) | CRedirectFilter | [private]
CRedirectFilter(RHTTPSession aSession) | CRedirectFilter | [private]
ECache enum value | MHTTPFilter |
EClient enum value | MHTTPFilter |
EClientFilters enum value | MHTTPFilter |
ECookies enum value | MHTTPFilter |
EProtocolHandler enum value | MHTTPFilter |
EStatusCodeHandler enum value | MHTTPFilter |
ETidyUp enum value | MHTTPFilter |
HandleRedirectL(RHTTPTransaction aTransaction, THTTPEvent::TTransactionWarning aWarningEvent) | CRedirectFilter | [private]
HandleUseProxyL(RHTTPTransaction aTransaction) | CRedirectFilter | [private]
iLoadCount | CRedirectFilter | [private]
InstallFilterL(TAny *aSession) | CRedirectFilter | [static]
CEComFilter::InstallFilterL(RHTTPSession aSession, const TUid aEComFilterUid) | CEComFilter | [inline, static]
CEComFilter::InstallFilterL(RHTTPSession aSession, const TDesC8 &aEComFilterDataType) | CEComFilter | [inline, static]
iSession | CRedirectFilter | [private]
iStringPool | CRedirectFilter | [private]
MHFLoad(RHTTPSession aSession, THTTPFilterHandle aHandle) | CRedirectFilter | [virtual]
MHFRunError(TInt aError, RHTTPTransaction aTransaction, const THTTPEvent &aEvent) | CRedirectFilter | [virtual]
MHFRunL(RHTTPTransaction aTransaction, const THTTPEvent &aEvent) | CRedirectFilter | [virtual]
MHFSessionRunError(TInt aError, const THTTPSessionEvent &aEvent) | CRedirectFilter | [virtual]
MHFSessionRunL(const THTTPSessionEvent &aEvent) | CRedirectFilter | [virtual]
MHFUnload(RHTTPSession aSession, THTTPFilterHandle aHandle) | CRedirectFilter | [virtual]
SetRedirectUriL(RHTTPRequest aRequest, const TUriParser8 &aUri) const | CRedirectFilter | [private]
TPositions enum name | MHTTPFilter |
~CEComFilter() | CEComFilter | [inline]
~CRedirectFilter() | CRedirectFilter |


RHTTPRequest Class Reference

@public
Since:
7.0 An HTTP Request.
More...

#include <rhttprequest.h>

Inheritance diagram for RHTTPRequest:

[legend]
Collaboration diagram for RHTTPRequest:

[legend]
List of all members.

Public Methods

Get Methods
Methods for reading information from the response.

IMPORT_C RStringF | Method () const
Gets the method name.

IMPORT_C const TUriC8 & | URI () const
Gets the URI.

Set Methods
Methods for setting information.

These methods will not be of use to the client; they are intended for the use of advanced filters

IMPORT_C void | SetMethod (RStringF aMethod)
Sets the method name.

IMPORT_C void | SetURIL (const TUriC8 &aURI)
Sets the URI.

Friends

class | CRequest

Detailed Description

@public
Since:
7.0 An HTTP Request.

This class extends the abstract HTTP Message to add an HTTP method to be invoked on the resource at the remote HTTP server, and the URL that identifies that resource.

Definition at line 29 of file rhttprequest.h.

Member Function Documentation

IMPORT_C RStringF RHTTPRequest::Method ( )

Gets the method name.

IMPORT_C void RHTTPRequest::SetMethod ( RStringF aMethod )

Sets the method name.

IMPORT_C void RHTTPRequest::SetURIL ( const TUriC8 & aURI )

Sets the URI.

IMPORT_C const TUriC8& RHTTPRequest::URI ( )

Gets the URI.

Friends And Related Function Documentation

friend class CRequest [friend]

Definition at line 58 of file rhttprequest.h.

The documentation for this class was generated from the following file:
  • rhttprequest.h


Member List

RHTTPRequest Member List

This is the complete list of members for RHTTPRequest, including all inherited members.
Body() const | RHTTPMessage |
CRequest class | RHTTPRequest | [friend]
GetHeaderCollection() | RHTTPMessage |
HasBody() const | RHTTPMessage |
iImplementation | RHTTPMessage | [protected]
Method() const | RHTTPRequest |
RemoveBody() | RHTTPMessage |
RHTTPMessage() | RHTTPMessage | [inline]
SetBody(MHTTPDataSupplier &aBody) | RHTTPMessage |
SetMethod(RStringF aMethod) | RHTTPRequest |
SetURIL(const TUriC8 &aURI) | RHTTPRequest |
URI() const | RHTTPRequest |


CRequest Class Reference

An HTTP Request. More...

#include <CRequest.h>

Inheritance diagram for CRequest:

[legend]
Collaboration diagram for CRequest:

[legend]
List of all members.

Public Methods

~CRequest ()
Destructor.

const RStringF & | Method () const
Returns the method.

RStringF & | Method ()
Returns the method (as a reference so you can set it).

CUri8 *& | URI ()
Returns the URI (as a reference so you can set it).

RHTTPRequest Handle ()
Obtain a handle for this request that can be used by the client.

Static Public Methods

CRequest * | NewL (RStringF aMethod, const TUriC8 &aURI, CTransaction *aTransaction)
Constructs a request.

Private Methods

CRequest ()
Constructor.

void | ConstructL (RStringF aMethod, const TUriC8 &aURI, CTransaction *aTransaction)
Does 2 phase construction.

Private Attributes

CUri8 * | iURI
The URI.

RStringF | iMethod
The method.

Detailed Description

An HTTP Request.

Provides the real implementation of a request, as proxied in the public API by RHTTPRequest.

See also:
RHTTPRequest

Definition at line 16 of file CRequest.h.

Constructor & Destructor Documentation

CRequest::~CRequest ( )

Destructor.

CRequest::CRequest ( ) [private]

Constructor.

Member Function Documentation

void CRequest::ConstructL | ( | RStringF | aMethod,
 |  | const TUriC8 & | aURI,
 |  | CTransaction * | aTransaction
 | ) | [private]

Does 2 phase construction.

RHTTPRequest CRequest::Handle ( ) [inline]

Obtain a handle for this request that can be used by the client.

RStringF& CRequest::Method ( )

Returns the method (as a reference so you can set it).

const RStringF& CRequest::Method ( )

Returns the method.

CRequest* CRequest::NewL | ( | RStringF | aMethod,
 |  | const TUriC8 & | aURI,
 |  | CTransaction * | aTransaction
 | ) | [static]

Constructs a request.

CUri8*& CRequest::URI ( )

Returns the URI (as a reference so you can set it).

Member Data Documentation

RStringF CRequest::iMethod [private]

The method.

Definition at line 73 of file CRequest.h.

CUri8* CRequest::iURI [private]

The URI.

Definition at line 68 of file CRequest.h.

The documentation for this class was generated from the following file:
  • CRequest.h


Member List

CRequest Member List

This is the complete list of members for CRequest, including all inherited members.
AddBody(MHTTPDataSupplier *aBody) | CMessage | [inline]
Body() const | CMessage | [inline]
ConstructL(RStringF aMethod, const TUriC8 &aURI, CTransaction *aTransaction) | CRequest | [private]
CMessage::ConstructL(CTransaction *aTransaction) | CMessage | [inline, protected]
CRequest() | CRequest | [private]
Handle() | CRequest | [inline]
HasBody() const | CMessage | [inline]
Headers() const | CMessage | [inline]
iMethod | CRequest | [private]
iURI | CRequest | [private]
Method() const | CRequest |
Method() | CRequest |
NewL(RStringF aMethod, const TUriC8 &aURI, CTransaction *aTransaction) | CRequest | [static]
URI() | CRequest |
~CMessage()=0 | CMessage | [pure virtual]
~CRequest() | CRequest |


TRequestComposer Class Reference

This class is a simple HTTP request composer. More...

#include <CTextModeTxData.h>

Collaboration diagram for TRequestComposer:

[legend]
List of all members.

Public Methods

TRequestComposer ()
Default constructor.

TRequestComposer (TPtr8 aWorkingBuffer, MComposerObserver &aObserver, RHTTPRequest aRequest, RStringPool aStrPool)
Normal constructor - constructs a composer for the specified HTTP request.

TBool | ComposeMoreDataL (TPtrC8 &aChunkData, TBool &aMustReleaseDataSupplier)
Do some more composing, using the HTTP request previously set.

void | SetWorkingBuffer (TPtr8 aWorkingBuffer, MComposerObserver &aObserver)
Set the working buffer to be used whilst composing OTA requests.

void | SetRequest (RHTTPRequest aRequest)
Set the HTTP request being composed into raw request data.

void | SetStringPool (RStringPool aStrPool)
Set the HTTP string pool.

void | SetConnectionInfo (RHTTPConnectionInfo aConnectionInfo)
Parameters:
aConnectionInfo Input ConnectionInfo forinternal usage

void | SetURI (RString aURI)
Sets the URI to appear on the request line.

void | Reset ()
Reset the composer, start a fresh request from scratch.

TBool | IsTimeToTerminateChunkEncoding () const

Private Methods

void | ComposeReqHeadersL ()
Composes Request Headers in HTTP text encoding format.

void | FormatRequestLineBeginningL ()
void | AppendDataL (const TDesC8 &aHeader, const TDesC8 &aTailingPattern)
TBool | IsChunkEncoding ()

Private Attributes

RStringPool | iStrPool
Handle to the HTTP string pool.

RHTTPConnectionInfo iConnectionInfo
TPtr8 | iWorkingBuffer
The working buffer in which an raw representation of the request is composed (the actual buffer is owned elsewhere).

MComposerObserver * iObserver
RHTTPRequest iRequest
The request being composed.

RString | iURI
The URI that should appear in the request line.

TBool | iSentLastChunk
Flag that indicates if we've already sent the final chunk for transmission.

TInt | iChunksSent
How many chunks we've churned out so far.

TBool | iChunkEncode
TChunkEncoder iChunkEncoder

Detailed Description

This class is a simple HTTP request composer.

It is initialised with a handle to an HTTP request which it processes into successive chunks for transmission. If the request contains a body (e.g. for POST) whose length isn't known up- front then this class produces suitable headers and chunks for the 'chunked' transfer encoding.

Definition at line 46 of file CTextModeTxData.h.

Constructor & Destructor Documentation

TRequestComposer::TRequestComposer ( )

Default constructor.

TRequestComposer::TRequestComposer | ( | TPtr8 | aWorkingBuffer,
 |  | MComposerObserver & | aObserver,
 |  | RHTTPRequest | aRequest,
 |  | RStringPool | aStrPool
 | ) |

Normal constructor - constructs a composer for the specified HTTP request.

that will store raw request data in the supplied working buffer. Body data is obtained via the request.

Parameters:
aWorkingBuffer | The buffer owned by the caller that will be formatted
aObserver | The observer owning the working buffer.
aRequest | Input The Raw Request
aStrPool | Input string pool for internal usage

Member Function Documentation

void TRequestComposer::AppendDataL | ( | const TDesC8 & | aHeader,
 |  | const TDesC8 & | aTailingPattern
 | ) | [private]

TBool TRequestComposer::ComposeMoreDataL | ( | TPtrC8 & | aChunkData,
 |  | TBool & | aMustReleaseDataSupplier
 | ) |

Do some more composing, using the HTTP request previously set.

Points the buffer passed in at the composed raw data that's ready to transmit so far.

Parameters:
aChunkData | Output composed chunk of data returned.
aMustReleaseDataSupplier | Output indicator to the owner whether to release or not
Returns:
EFalse if last chunk, ETrue if more data to chunk up

void TRequestComposer::ComposeReqHeadersL ( ) [private]

Composes Request Headers in HTTP text encoding format.

void TRequestComposer::FormatRequestLineBeginningL ( ) [private]

TBool TRequestComposer::IsChunkEncoding ( ) [private]

TBool TRequestComposer::IsTimeToTerminateChunkEncoding ( ) [inline]

Definition at line 386 of file CTextModeTxData.h.

References iChunkEncode, iChunkEncoder, and TRequestComposer::TChunkEncoder::IsLastChunk().

void TRequestComposer::Reset ( )

Reset the composer, start a fresh request from scratch.

void TRequestComposer::SetConnectionInfo ( RHTTPConnectionInfo aConnectionInfo ) [inline]

Parameters:
aConnectionInfo Input ConnectionInfo forinternal usage

Definition at line 376 of file CTextModeTxData.h.

References iConnectionInfo.

void TRequestComposer::SetRequest ( RHTTPRequest aRequest ) [inline]

Set the HTTP request being composed into raw request data.

Parameters:
aRequest Input The Raw Request

Definition at line 366 of file CTextModeTxData.h.

References iRequest.

void TRequestComposer::SetStringPool ( RStringPool aStrPool ) [inline]

Set the HTTP string pool.

Parameters:
aStrPool Input string pool for internal usage

Definition at line 371 of file CTextModeTxData.h.

References iStrPool.

void TRequestComposer::SetURI ( RString aURI ) [inline]

Sets the URI to appear on the request line.

Definition at line 381 of file CTextModeTxData.h.

References iURI.

void TRequestComposer::SetWorkingBuffer | ( | TPtr8 | aWorkingBuffer,
 |  | MComposerObserver & | aObserver
 | ) | [inline]

Set the working buffer to be used whilst composing OTA requests.

Parameters:
aWorkingBuffer | The buffer owned by the caller that will be formatted
aObserver | The observer owning the working buffer.

Definition at line 360 of file CTextModeTxData.h.

References iObserver, and iWorkingBuffer.

Member Data Documentation

TBool TRequestComposer::iChunkEncode [private]

Definition at line 223 of file CTextModeTxData.h.

Referenced by IsTimeToTerminateChunkEncoding().

TChunkEncoder TRequestComposer::iChunkEncoder [private]

Definition at line 227 of file CTextModeTxData.h.

Referenced by IsTimeToTerminateChunkEncoding().

TInt TRequestComposer::iChunksSent [private]

How many chunks we've churned out so far.

Definition at line 219 of file CTextModeTxData.h.

RHTTPConnectionInfo TRequestComposer::iConnectionInfo [private]

Definition at line 196 of file CTextModeTxData.h.

Referenced by SetConnectionInfo().

MComposerObserver* TRequestComposer::iObserver [private]

Definition at line 203 of file CTextModeTxData.h.

Referenced by SetWorkingBuffer().

RHTTPRequest TRequestComposer::iRequest [private]

The request being composed.

Definition at line 207 of file CTextModeTxData.h.

Referenced by SetRequest().

TBool TRequestComposer::iSentLastChunk [private]

Flag that indicates if we've already sent the final chunk for transmission.

Definition at line 215 of file CTextModeTxData.h.

RStringPool TRequestComposer::iStrPool [private]

Handle to the HTTP string pool.

Definition at line 193 of file CTextModeTxData.h.

Referenced by SetStringPool().

RString TRequestComposer::iURI [private]

The URI that should appear in the request line.

Definition at line 211 of file CTextModeTxData.h.

Referenced by SetURI().

TPtr8 TRequestComposer::iWorkingBuffer [private]

The working buffer in which an raw representation of the request is composed (the actual buffer is owned elsewhere).

Definition at line 201 of file CTextModeTxData.h.

Referenced by SetWorkingBuffer().

The documentation for this class was generated from the following file:
  • CTextModeTxData.h


Member List

TRequestComposer Member List

This is the complete list of members for TRequestComposer, including all inherited members.
AppendDataL(const TDesC8 &aHeader, const TDesC8 &aTailingPattern) | TRequestComposer | [private]
ComposeMoreDataL(TPtrC8 &aChunkData, TBool &aMustReleaseDataSupplier) | TRequestComposer |
ComposeReqHeadersL() | TRequestComposer | [private]
FormatRequestLineBeginningL() | TRequestComposer | [private]
iChunkEncode | TRequestComposer | [private]
iChunkEncoder | TRequestComposer | [private]
iChunksSent | TRequestComposer | [private]
iConnectionInfo | TRequestComposer | [private]
iObserver | TRequestComposer | [private]
iRequest | TRequestComposer | [private]
IsChunkEncoding() | TRequestComposer | [private]
iSentLastChunk | TRequestComposer | [private]
IsTimeToTerminateChunkEncoding() const | TRequestComposer | [inline]
iStrPool | TRequestComposer | [private]
iURI | TRequestComposer | [private]
iWorkingBuffer | TRequestComposer | [private]
Reset() | TRequestComposer |
SetConnectionInfo(RHTTPConnectionInfo aConnectionInfo) | TRequestComposer | [inline]
SetRequest(RHTTPRequest aRequest) | TRequestComposer | [inline]
SetStringPool(RStringPool aStrPool) | TRequestComposer | [inline]
SetURI(RString aURI) | TRequestComposer | [inline]
SetWorkingBuffer(TPtr8 aWorkingBuffer, MComposerObserver &aObserver) | TRequestComposer | [inline]
TRequestComposer() | TRequestComposer |
TRequestComposer(TPtr8 aWorkingBuffer, MComposerObserver &aObserver, RHTTPRequest aRequest, RStringPool aStrPool) | TRequestComposer |


TRequestComposer::TChunkEncoder Class Reference

Private Embedded class is used for internal chunking data, it formats the data using a state variable and a small buffer, a cached body. More...

List of all members.

Public Methods

TChunkEncoder ()
Default Constructor.

void | Reset ()
Reset the encoder to start state.

void | EncodeDataL (MHTTPDataSupplier &aBodySupplier, TPtrC8 &aChunkData, TBool &aMustReleaseDataSupplier, TBool &aSentLast)
Given a supplier, it formats the chunks into aChunkData.

TBool | IsLastChunk () const

Private Types

enum | TChunkState { ESendNumBytesFirst, ESendNumBytes, ESendBody, ESendLast }
States for sending chunked data. More...

Private Attributes

TBool | iLastChunkToEncode
TPtrC8 | iChunkBodyHolder
Chunking takes two passes, size then body. This will hold a pointer to body while size is being sent.

TChunkState iChunkState
State variable when sending chunked data.

TBuf8< KChunkHeaderSize > | iScratchBuf
Internal Scratch Buffer for sending control data to caller (chunksize, termination).

Detailed Description

Private Embedded class is used for internal chunking data, it formats the data using a state variable and a small buffer, a cached body.

A body split into N chunks will be sent like: "<BodyChunk1Size>\r
" "<BodyChunk1>" "\r
<BodyChunk...Size>\r
" "<BodyChunk...>" "\r
<BodyChunkNSize>\r
" "<BodyChunkN>" "\r\n0\r
"

BodyChunks buffer will come from the Data supplier, and sent as is. All formatted size and terminations will be sent a internal fix sized scratch buffer.

Definition at line 67 of file CTextModeTxData.h.

Member Enumeration Documentation

enum TRequestComposer::TChunkEncoder::TChunkState [private]

States for sending chunked data.

Enumeration values:
ESendNumBytesFirst Send the first chunk "<BodyChunkSize>\r
".
ESendNumBytes Send the number of bytyes in the body "\r
<BodyChunkSize>\r
".
ESendBody Send the body "BodyChunk".
ESendLast Send the termination "0\r
".

Definition at line 92 of file CTextModeTxData.h.

Constructor & Destructor Documentation

TRequestComposer::TChunkEncoder::TChunkEncoder ( )

Default Constructor.

Member Function Documentation

void TRequestComposer::TChunkEncoder::EncodeDataL | ( | MHTTPDataSupplier & | aBodySupplier,
 |  | TPtrC8 & | aChunkData,
 |  | TBool & | aMustReleaseDataSupplier,
 |  | TBool & | aSentLast
 | ) |

Given a supplier, it formats the chunks into aChunkData.

Parameters:
aBodySupplier | Input the supplier of data
aChunkData | Out param buffer that receives the chunk of data
aMustReleaseDataSupplier | Out param set if this is a releasable buffer (ie, does it come from the supplier)
aSentLast | Out param set indicating that this is the terminator

TBool TRequestComposer::TChunkEncoder::IsLastChunk ( ) [inline]

Definition at line 355 of file CTextModeTxData.h.

References iLastChunkToEncode.

Referenced by TRequestComposer::IsTimeToTerminateChunkEncoding().

void TRequestComposer::TChunkEncoder::Reset ( )

Reset the encoder to start state.

Member Data Documentation

TPtrC8 TRequestComposer::TChunkEncoder::iChunkBodyHolder [private]

Chunking takes two passes, size then body. This will hold a pointer to body while size is being sent.

Definition at line 104 of file CTextModeTxData.h.

TChunkState TRequestComposer::TChunkEncoder::iChunkState [private]

State variable when sending chunked data.

Definition at line 107 of file CTextModeTxData.h.

TBool TRequestComposer::TChunkEncoder::iLastChunkToEncode [private]

Definition at line 101 of file CTextModeTxData.h.

Referenced by IsLastChunk().

TBuf8<KChunkHeaderSize> TRequestComposer::TChunkEncoder::iScratchBuf [private]

Internal Scratch Buffer for sending control data to caller (chunksize, termination).

Definition at line 110 of file CTextModeTxData.h.

The documentation for this class was generated from the following file:
  • CTextModeTxData.h


Member List

TRequestComposer::TChunkEncoder Member List

This is the complete list of members for TRequestComposer::TChunkEncoder, including all inherited members.
EncodeDataL(MHTTPDataSupplier &aBodySupplier, TPtrC8 &aChunkData, TBool &aMustReleaseDataSupplier, TBool &aSentLast) | TRequestComposer::TChunkEncoder |
ESendBody enum value | TRequestComposer::TChunkEncoder | [private]
ESendLast enum value | TRequestComposer::TChunkEncoder | [private]
ESendNumBytes enum value | TRequestComposer::TChunkEncoder | [private]
ESendNumBytesFirst enum value | TRequestComposer::TChunkEncoder | [private]
iChunkBodyHolder | TRequestComposer::TChunkEncoder | [private]
iChunkState | TRequestComposer::TChunkEncoder | [private]
iLastChunkToEncode | TRequestComposer::TChunkEncoder | [private]
iScratchBuf | TRequestComposer::TChunkEncoder | [private]
IsLastChunk() const | TRequestComposer::TChunkEncoder | [inline]
Reset() | TRequestComposer::TChunkEncoder |
TChunkEncoder() | TRequestComposer::TChunkEncoder |
TChunkState enum name | TRequestComposer::TChunkEncoder | [private]


RHTTPResponse Class Reference

@public
Since:
7.0 An HTTP Response.
More...

#include <rhttpresponse.h>

Inheritance diagram for RHTTPResponse:

[legend]
Collaboration diagram for RHTTPResponse:

[legend]
List of all members.

Public Methods

Get Methods
Methods for reading information from the response.

IMPORT_C TInt | StatusCode () const
Returns the status code.

IMPORT_C RStringF | StatusText () const
Returns the status text, that is the text after the number on the first line of the response.

IMPORT_C TVersion | Version () const
Returns the version of HTTP used by the server.

Set Methods
Methods for setting information.

These methods will not be of use to the client; they are intended for the use of advanced filters

IMPORT_C void | SetStatusCode (TInt aStatus)
Sets the status code.

IMPORT_C void | SetStatusText (RStringF aStatusString)
Sets the status string.

IMPORT_C void | SetVersion (TVersion aVersion)
Sets the HTTP version.

Friends

class | CResponse

Detailed Description

@public
Since:
7.0 An HTTP Response.

This class extends the abstract HTTP Message to add an HTTP version, a status code and status text.

Definition at line 28 of file rhttpresponse.h.

Member Function Documentation

IMPORT_C void RHTTPResponse::SetStatusCode ( TInt aStatus )

Sets the status code.

IMPORT_C void RHTTPResponse::SetStatusText ( RStringF aStatusString )

Sets the status string.

IMPORT_C void RHTTPResponse::SetVersion ( TVersion aVersion )

Sets the HTTP version.

IMPORT_C TInt RHTTPResponse::StatusCode ( )

Returns the status code.

IMPORT_C RStringF RHTTPResponse::StatusText ( )

Returns the status text, that is the text after the number on the first line of the response.

IMPORT_C TVersion RHTTPResponse::Version ( )

Returns the version of HTTP used by the server.

Friends And Related Function Documentation

friend class CResponse [friend]

Definition at line 65 of file rhttpresponse.h.

The documentation for this class was generated from the following file:
  • rhttpresponse.h


Member List

RHTTPResponse Member List

This is the complete list of members for RHTTPResponse, including all inherited members.
Body() const | RHTTPMessage |
CResponse class | RHTTPResponse | [friend]
GetHeaderCollection() | RHTTPMessage |
HasBody() const | RHTTPMessage |
iImplementation | RHTTPMessage | [protected]
RemoveBody() | RHTTPMessage |
RHTTPMessage() | RHTTPMessage | [inline]
SetBody(MHTTPDataSupplier &aBody) | RHTTPMessage |
SetStatusCode(TInt aStatus) | RHTTPResponse |
SetStatusText(RStringF aStatusString) | RHTTPResponse |
SetVersion(TVersion aVersion) | RHTTPResponse |
StatusCode() const | RHTTPResponse |
StatusText() const | RHTTPResponse |
Version() const | RHTTPResponse |


CResponse Class Reference

An HTTP Response. More...

#include <CResponse.h>

Inheritance diagram for CResponse:

[legend]
Collaboration diagram for CResponse:

[legend]
List of all members.

Public Methods

~CResponse ()
Destructor.

TInt & | Status ()
Returns the status (returned as a reference; use this call to set it).

const TInt & | Status () const
Returns the status.

RStringF & | StatusString ()
Returns the status string (returned as a reference, which you can set).

const RStringF & | StatusString () const
Returns the status string.

TVersion & | Version ()
Returns the HTTP version (returned as a reference, which you can set).

const TVersion & | Version () const
Returns the HTTP version.

RHTTPResponse Handle ()
Obtain a handle for this response that can be used by the client.

Static Public Methods

CResponse * | NewL (CTransaction *aTransaction)
Constructs a response.

Private Methods

CResponse ()
Constructor.

Private Attributes

TInt | iStatus
The HTTP status code obtained from the HTTP server's response.

RStringF | iStatusString
The HTTP status description string obtained from the HTTP server's response.

TVersion | iVersion
The HTTP version number (major/minor) obtained from the HTTP server's response.

Detailed Description

An HTTP Response.

Provides the real implementation of a response, as proxied in the public API by RHTTPResponse.

See also:
RHTTPResponse

Definition at line 16 of file CResponse.h.

Constructor & Destructor Documentation

CResponse::~CResponse ( )

Destructor.

CResponse::CResponse ( ) [private]

Constructor.

Member Function Documentation

RHTTPResponse CResponse::Handle ( ) [inline]

Obtain a handle for this response that can be used by the client.

CResponse* CResponse::NewL ( CTransaction * aTransaction ) [inline, static]

Constructs a response.

const TInt& CResponse::Status ( ) [inline]

Returns the status.

TInt& CResponse::Status ( ) [inline]

Returns the status (returned as a reference; use this call to set it).

const RStringF& CResponse::StatusString ( ) [inline]

Returns the status string.

RStringF& CResponse::StatusString ( ) [inline]

Returns the status string (returned as a reference, which you can set).

const TVersion& CResponse::Version ( ) [inline]

Returns the HTTP version.

TVersion& CResponse::Version ( ) [inline]

Returns the HTTP version (returned as a reference, which you can set).

Member Data Documentation

TInt CResponse::iStatus [private]

The HTTP status code obtained from the HTTP server's response.

Definition at line 75 of file CResponse.h.

RStringF CResponse::iStatusString [private]

The HTTP status description string obtained from the HTTP server's response.

Definition at line 80 of file CResponse.h.

TVersion CResponse::iVersion [private]

The HTTP version number (major/minor) obtained from the HTTP server's response.

Definition at line 85 of file CResponse.h.

The documentation for this class was generated from the following file:
  • CResponse.h


Member List

CResponse Member List

This is the complete list of members for CResponse, including all inherited members.
AddBody(MHTTPDataSupplier *aBody) | CMessage | [inline]
Body() const | CMessage | [inline]
ConstructL(CTransaction *aTransaction) | CMessage | [inline, protected]
CResponse() | CResponse | [private]
Handle() | CResponse | [inline]
HasBody() const | CMessage | [inline]
Headers() const | CMessage | [inline]
iStatus | CResponse | [private]
iStatusString | CResponse | [private]
iVersion | CResponse | [private]
NewL(CTransaction *aTransaction) | CResponse | [inline, static]
Status() | CResponse | [inline]
Status() const | CResponse | [inline]
StatusString() | CResponse | [inline]
StatusString() const | CResponse | [inline]
Version() | CResponse | [inline]
Version() const | CResponse | [inline]
~CMessage()=0 | CMessage | [pure virtual]
~CResponse() | CResponse |


TResponseParser Class Reference

This class is an HTTP response parser. More...

#include <CTextModeRxData.h>

List of all members.

Public Types

enum | TSuperState { EUndefSuper, ERespBuffPopulated, ERespBuffEmpty, ERespBuffCarryOver }
'Outermost' states of the response parser More...

enum TState {
EUndefined, EParsingStatusLine, EParsingHeaders, EReadingNormalBody,
EReadingChunkedBody, EParsingPostChunkedEntityHeaders
}
enum | TSubState { EUndefSub, EParsingChunkHeader, EReadingChunkBodyData }

Public Methods

TResponseParser ()
Default constructor.

TResponseParser (TPtr8 aLineBuffer)
Normal constructor - construct a parser for the data in the supplied response buffer.

TInt | ParseMoreData ()
Do some more parsing, from the response buffer passed in.

void | SetRespBuffer (const TDesC8 &aRespBuffer)
Set the parser's response buffer to point at the specified chunk of data.

void | SetLineBuffer (const TPtr8 &aLineBuffer)
Set the parser's line buffer to point at the specified chunk of data.

const TDesC8 & | CurrentLine () const
The current line being parsed.

void | Reset (TBool aDoResetResponseBuffer=ETrue)
Reset the parser, in order to start a fresh response from scratch.

TInt | GetLineBufferOverrunSize () const
Get the size by which the line buffer needs to be extended for ExtractALineL() to succeed.

TInt | StatusLine (TInt &aMajVers, TInt &aMinVers, TPtrC8 &aStatDesc) const
Return the HTTP status, version number and textual description.

void | Header (TPtrC8 &aFieldName, TPtrC8 &aFieldVal) const
Return the most recently-parsed header field name and value.

void | Body (TPtrC8 &aBodyData)
Return some body data.

Private Methods

TInt | TryParseMoreDataL ()
Attempt some more parsing, from the response buffer passed in.

TInt | ExtractALineL ()
Extract a response line.

TInt | ExtractBody ()
Extract some body data.

TInt | ExtractBodyChunk ()
Extract some body data, used when chunked encoding is detected.

TInt | ParseLine ()
Analyse current line.

TInt | ParseStatusLine ()
Parse the current line assuming it is a status line.

TInt | ParseHeaders ()
Parse the current line assuming it is a header line.

TInt | ParseChunkHeader ()
Parse the current line assuming it is a chunk header line.

void | TryAppendLineBufferL (const TDesC8 &aAppendData)
Attempt to append to the line buffer - this will leave if the buffer is too short.

void | TrySetLineBufferL (const TDesC8 &aSetData)
Attempt to set the line buffer - this will leave if the buffer is too short.

Private Attributes

TPtrC8 | iRespBuffer
The current response buffer being parsed.

TPtr8 | iLineBuffer
The line currently being analysed.

TSuperState iSuperState
The state machine's 'super'-state.

TState iMainState
The state machine's 'main'-state.

TSubState iSubState
The state machine's 'sub'-state.

TInt | iStatCode
The HTTP status code, found on the status line.

TInt | iMajorVersion
The HTTP major version, found on the status line.

TInt | iMinorVersion
The HTTP minor version, found on the status line.

TPtrC8 | iStatDesc
The HTTP status description, found on the status line.

TPtrC8 | iFieldName
The most recently-read header field's name.

TPtrC8 | iFieldValue
The most recently-read header field's value.

TPtrC8 | iBodyData
The most recently-read body data.

TBool | iIsChunked
Flag indicating that the body being read is chunked.

TInt | iChunkSize
The chunk size as read from the chunk header.

TInt | iChunkBytesReadSoFar
Number of bytes read from the current body chunk so far (in case it is broken into more than one response buffer).

TInt | iLineBufferOverrunSize
Number of bytes by which the line buffer is too short to handle the current line in the response buffer.

TBool | iPreviousLineFitExactly
Flag that indicates whether the previous line extracted had taken exactly the remains of the response buffer.

Friends

class | TTResponseParser_StateAccessor
Declare Test Bed friend - requires access to private members for testing purposes.

Detailed Description

This class is an HTTP response parser.

It is fed by successive buffers of received data, and extracts data line-by-line. For each whole line it extracts it attempts to recognise the purpose of the line (ie. status-line, header field, body data, etc.). It doesn't do anything further with the data other than return status codes that allow the owning class to take appropriate action.

Definition at line 45 of file CTextModeRxData.h.

Member Enumeration Documentation

enum TResponseParser::TState

Enumeration values:
EUndefined | not defined; the main state upon construction
EParsingStatusLine | currently expecting to find a status line
EParsingHeaders | currently expecting to find a header field
EReadingNormalBody | currently reading a 'normal' (ie. non-chunked) body
EReadingChunkedBody | currently reading a chunked body
EParsingPostChunkedEntityHeaders | currently reading entity headers that follow a chunked body

Definition at line 60 of file CTextModeRxData.h.

enum TResponseParser::TSubState

Enumeration values:
EUndefSub | not defined; the sub-state upon construction
EParsingChunkHeader | currently expecting to find a chunk header
EReadingChunkBodyData | currently reading actual body chunk data

Definition at line 70 of file CTextModeRxData.h.

enum TResponseParser::TSuperState

'Outermost' states of the response parser

Enumeration values:
EUndefSuper | not defined; the super state upon construction
ERespBuffPopulated | the parser's response buffer contains data
ERespBuffEmpty | the parser's response buffer is empty
ERespBuffCarryOver | the parser has some data left in its response buffer but not enough to extract a whole line

Definition at line 52 of file CTextModeRxData.h.

Constructor & Destructor Documentation

TResponseParser::TResponseParser ( )

Default constructor.

TResponseParser::TResponseParser ( TPtr8 aLineBuffer )

Normal constructor - construct a parser for the data in the supplied response buffer.

The supplied line buffer is working space used during parsing.

Member Function Documentation

void TResponseParser::Body ( TPtrC8 & aBodyData )

Return some body data.

Valid only when the most recent call to ParseMoreData() has returned a status code indicating that body data has been identified

const TDesC8& TResponseParser::CurrentLine ( )

The current line being parsed.

TInt TResponseParser::ExtractALineL ( ) [private]

Extract a response line.

Reads from the previous buffer position to the next end-of-line. returns error code if no complete line can be extracted from the response buffer. Leaves if the line buffer is not large enough to hold the extracted line.

TInt TResponseParser::ExtractBody ( ) [private]

Extract some body data.

TInt TResponseParser::ExtractBodyChunk ( ) [private]

Extract some body data, used when chunked encoding is detected.

TInt TResponseParser::GetLineBufferOverrunSize ( )

Get the size by which the line buffer needs to be extended for ExtractALineL() to succeed.

void TResponseParser::Header | ( | TPtrC8 & | aFieldName,
 |  | TPtrC8 & | aFieldVal
 | ) | const

Return the most recently-parsed header field name and value.

Valid only when the most recent call to ParseMoreData() has returned a status code indicating that a header field has been identified

TInt TResponseParser::ParseChunkHeader ( ) [private]

Parse the current line assuming it is a chunk header line.

TInt TResponseParser::ParseHeaders ( ) [private]

Parse the current line assuming it is a header line.

TInt TResponseParser::ParseLine ( ) [private]

Analyse current line.

Given the current state, attempt to work out what the current line is (or should be) return error codes according to whether the data is good or not

TInt TResponseParser::ParseMoreData ( )

Do some more parsing, from the response buffer passed in.

Returns a completion or status code.

TInt TResponseParser::ParseStatusLine ( ) [private]

Parse the current line assuming it is a status line.

void TResponseParser::Reset ( TBool aDoResetResponseBuffer = ETrue )

Reset the parser, in order to start a fresh response from scratch.

void TResponseParser::SetLineBuffer ( const TPtr8 & aLineBuffer )

Set the parser's line buffer to point at the specified chunk of data.

void TResponseParser::SetRespBuffer ( const TDesC8 & aRespBuffer )

Set the parser's response buffer to point at the specified chunk of data.

TInt TResponseParser::StatusLine | ( | TInt & | aMajVers,
 |  | TInt & | aMinVers,
 |  | TPtrC8 & | aStatDesc
 | ) | const

Return the HTTP status, version number and textual description.

Valid only when after a call to ParseMoreData() has returned a status code indicating that a status-line has been identified

void TResponseParser::TryAppendLineBufferL ( const TDesC8 & aAppendData ) [private]

Attempt to append to the line buffer - this will leave if the buffer is too short.

TInt TResponseParser::TryParseMoreDataL ( ) [private]

Attempt some more parsing, from the response buffer passed in.

Returns a completion or status code. Leaves if the line buffer requires reallocation

void TResponseParser::TrySetLineBufferL ( const TDesC8 & aSetData ) [private]

Attempt to set the line buffer - this will leave if the buffer is too short.

Friends And Related Function Documentation

friend class TTResponseParser_StateAccessor [friend]

Declare Test Bed friend - requires access to private members for testing purposes.

Definition at line 48 of file CTextModeRxData.h.

Member Data Documentation

TPtrC8 TResponseParser::iBodyData [private]

The most recently-read body data.

Definition at line 228 of file CTextModeRxData.h.

TInt TResponseParser::iChunkBytesReadSoFar [private]

Number of bytes read from the current body chunk so far (in case it is broken into more than one response buffer).

Definition at line 241 of file CTextModeRxData.h.

TInt TResponseParser::iChunkSize [private]

The chunk size as read from the chunk header.

Definition at line 236 of file CTextModeRxData.h.

TPtrC8 TResponseParser::iFieldName [private]

The most recently-read header field's name.

Definition at line 220 of file CTextModeRxData.h.

TPtrC8 TResponseParser::iFieldValue [private]

The most recently-read header field's value.

Definition at line 224 of file CTextModeRxData.h.

TBool TResponseParser::iIsChunked [private]

Flag indicating that the body being read is chunked.

Definition at line 232 of file CTextModeRxData.h.

TPtr8 TResponseParser::iLineBuffer [private]

The line currently being analysed.

Definition at line 188 of file CTextModeRxData.h.

TInt TResponseParser::iLineBufferOverrunSize [private]

Number of bytes by which the line buffer is too short to handle the current line in the response buffer.

Definition at line 245 of file CTextModeRxData.h.

TState TResponseParser::iMainState [private]

The state machine's 'main'-state.

Definition at line 196 of file CTextModeRxData.h.

TInt TResponseParser::iMajorVersion [private]

The HTTP major version, found on the status line.

Definition at line 208 of file CTextModeRxData.h.

TInt TResponseParser::iMinorVersion [private]

The HTTP minor version, found on the status line.

Definition at line 212 of file CTextModeRxData.h.

TBool TResponseParser::iPreviousLineFitExactly [private]

Flag that indicates whether the previous line extracted had taken exactly the remains of the response buffer.

Definition at line 250 of file CTextModeRxData.h.

TPtrC8 TResponseParser::iRespBuffer [private]

The current response buffer being parsed.

Definition at line 184 of file CTextModeRxData.h.

TInt TResponseParser::iStatCode [private]

The HTTP status code, found on the status line.

Definition at line 204 of file CTextModeRxData.h.

TPtrC8 TResponseParser::iStatDesc [private]

The HTTP status description, found on the status line.

Definition at line 216 of file CTextModeRxData.h.

TSubState TResponseParser::iSubState [private]

The state machine's 'sub'-state.

Definition at line 200 of file CTextModeRxData.h.

TSuperState TResponseParser::iSuperState [private]

The state machine's 'super'-state.

Definition at line 192 of file CTextModeRxData.h.

The documentation for this class was generated from the following file:
  • CTextModeRxData.h


Member List

TResponseParser Member List

This is the complete list of members for TResponseParser, including all inherited members.
Body(TPtrC8 &aBodyData) | TResponseParser |
CurrentLine() const | TResponseParser |
EParsingChunkHeader enum value | TResponseParser |
EParsingHeaders enum value | TResponseParser |
EParsingPostChunkedEntityHeaders enum value | TResponseParser |
EParsingStatusLine enum value | TResponseParser |
EReadingChunkBodyData enum value | TResponseParser |
EReadingChunkedBody enum value | TResponseParser |
EReadingNormalBody enum value | TResponseParser |
ERespBuffCarryOver enum value | TResponseParser |
ERespBuffEmpty enum value | TResponseParser |
ERespBuffPopulated enum value | TResponseParser |
EUndefined enum value | TResponseParser |
EUndefSub enum value | TResponseParser |
EUndefSuper enum value | TResponseParser |
ExtractALineL() | TResponseParser | [private]
ExtractBody() | TResponseParser | [private]
ExtractBodyChunk() | TResponseParser | [private]
GetLineBufferOverrunSize() const | TResponseParser |
Header(TPtrC8 &aFieldName, TPtrC8 &aFieldVal) const | TResponseParser |
iBodyData | TResponseParser | [private]
iChunkBytesReadSoFar | TResponseParser | [private]
iChunkSize | TResponseParser | [private]
iFieldName | TResponseParser | [private]
iFieldValue | TResponseParser | [private]
iIsChunked | TResponseParser | [private]
iLineBuffer | TResponseParser | [private]
iLineBufferOverrunSize | TResponseParser | [private]
iMainState | TResponseParser | [private]
iMajorVersion | TResponseParser | [private]
iMinorVersion | TResponseParser | [private]
iPreviousLineFitExactly | TResponseParser | [private]
iRespBuffer | TResponseParser | [private]
iStatCode | TResponseParser | [private]
iStatDesc | TResponseParser | [private]
iSubState | TResponseParser | [private]
iSuperState | TResponseParser | [private]
ParseChunkHeader() | TResponseParser | [private]
ParseHeaders() | TResponseParser | [private]
ParseLine() | TResponseParser | [private]
ParseMoreData() | TResponseParser |
ParseStatusLine() | TResponseParser | [private]
Reset(TBool aDoResetResponseBuffer=ETrue) | TResponseParser |
SetLineBuffer(const TPtr8 &aLineBuffer) | TResponseParser |
SetRespBuffer(const TDesC8 &aRespBuffer) | TResponseParser |
StatusLine(TInt &aMajVers, TInt &aMinVers, TPtrC8 &aStatDesc) const | TResponseParser |
TResponseParser() | TResponseParser |
TResponseParser(TPtr8 aLineBuffer) | TResponseParser |
TryAppendLineBufferL(const TDesC8 &aAppendData) | TResponseParser | [private]
TryParseMoreDataL() | TResponseParser | [private]
TrySetLineBufferL(const TDesC8 &aSetData) | TResponseParser | [private]
TState enum name | TResponseParser |
TSubState enum name | TResponseParser |
TSuperState enum name | TResponseParser |
TTResponseParser_StateAccessor class | TResponseParser | [friend]


CRxData Class Reference

@public
Since:
7.0 An abstract base class for the decoding of response data received by a protocol handler.
More...

#include <crxdata.h>

Inheritance diagram for CRxData:

[legend]
Collaboration diagram for CRxData:

[legend]
List of all members.

Public Methods

virtual IMPORT_C | ~CRxData ()
Intended Usage: Destructor - cleans up and releases resources to the system
Since:
7.0.

IMPORT_C CProtTransaction & | ProtTrans ()
Intended Usage: Obtain the protocol transaction whose request part is represented as encoded data by this object.

virtual void | ResetRxData ()=0
Intended Usage: Resets the received data object to its initial state following construction.

Protected Methods

IMPORT_C | CRxData ()
Intended Usage: Default constructor - creates an Rx data object not associated with any protocol transaction.

IMPORT_C | CRxData (CProtTransaction &aProtTrans, MRxDataObserver &aObserver)
Intended Usage: Normal constructor, of a CRxData that corresponds to the supplied protocol transaction, and which sends status updates to the supplied observer interface,
Since:
7.0.

IMPORT_C void | ConstructL ()
Intended Usage: Second phase construction, default
Since:
7.0.

Protected Attributes

CProtTransaction * iProtTrans
The protocol transaction for which this object represents the encoded received data.

MRxDataObserver * iObserver
This object's observer, to whom we forward status information.

Private Methods

virtual void | Reserved1 ()
Intended Usage: Reserve a slot in the v-table to preserve future BC
Since:
7.0.

virtual void | Reserved2 ()
Intended Usage: Reserve a slot in the v-table to preserve future BC
Since:
7.0.

Detailed Description

@public
Since:
7.0 An abstract base class for the decoding of response data received by a protocol handler.

Definition at line 32 of file crxdata.h.

Constructor & Destructor Documentation

CRxData::~CRxData ( ) [virtual]

Intended Usage: Destructor - cleans up and releases resources to the system

Since:
7.0.

CRxData::CRxData ( ) [protected]

Intended Usage: Default constructor - creates an Rx data object not associated with any protocol transaction.

Since:
7.0

CRxData::CRxData | ( | CProtTransaction & | aProtTrans,
 |  | MRxDataObserver & | aObserver
 | ) | [protected]

Intended Usage: Normal constructor, of a CRxData that corresponds to the supplied protocol transaction, and which sends status updates to the supplied observer interface,

Since:
7.0.

Parameters:
aProtTransaction | (in) The transaction for which this object represents the transmitted data.
aObserver | (in) The object's observer.

Member Function Documentation

CRxData::ConstructL ( ) [protected]

Intended Usage: Second phase construction, default

Since:
7.0.

Reimplemented in CTextModeRxData.

CProtTransaction & CRxData::ProtTrans ( )

Intended Usage: Obtain the protocol transaction whose request part is represented as encoded data by this object.

Since:
7.0
Returns:
The protocol transaction object

void CRxData::Reserved1 ( ) [inline, private, virtual]

Intended Usage: Reserve a slot in the v-table to preserve future BC

Since:
7.0.

Definition at line 126 of file crxdata.h.

void CRxData::Reserved2 ( ) [inline, private, virtual]

Intended Usage: Reserve a slot in the v-table to preserve future BC

Since:
7.0.

Definition at line 128 of file crxdata.h.

void CRxData::ResetRxData ( ) [pure virtual]

Intended Usage: Resets the received data object to its initial state following construction.

This method must be implemented for specific sub- classes of received data.

Postcondition:
The object is reset.
Since:
7.0

Implemented in CTextModeRxData, and CWspCORxData.

Member Data Documentation

MRxDataObserver* CRxData::iObserver [protected]

This object's observer, to whom we forward status information.

Definition at line 106 of file crxdata.h.

CProtTransaction* CRxData::iProtTrans [protected]

The protocol transaction for which this object represents the encoded received data.

Definition at line 101 of file crxdata.h.

The documentation for this class was generated from the following file:
  • crxdata.h


Member List

CRxData Member List

This is the complete list of members for CRxData, including all inherited members.
ConstructL() | CRxData | [protected]
CRxData() | CRxData | [protected]
CRxData(CProtTransaction &aProtTrans, MRxDataObserver &aObserver) | CRxData | [protected]
GetNextDataPart(TPtrC8 &aDataPart)=0 | MHTTPDataSupplier | [pure virtual]
iObserver | CRxData | [protected]
iProtTrans | CRxData | [protected]
OverallDataSize()=0 | MHTTPDataSupplier | [pure virtual]
ProtTrans() | CRxData |
ReleaseData()=0 | MHTTPDataSupplier | [pure virtual]
Reserved1() | CRxData | [inline, private, virtual]
Reserved2() | CRxData | [inline, private, virtual]
Reset()=0 | MHTTPDataSupplier | [pure virtual]
ResetRxData()=0 | CRxData | [pure virtual]
~CRxData() | CRxData | [virtual]


MRxDataObserver Class Reference

@public
Since:
7.0 An interface to be implemented by classes that wish to receive status information from an implementation of the CRxData class.
More...

#include <MRxDataObserver.h>

Inheritance diagram for MRxDataObserver:

[legend]
List of all members.

Public Methods

virtual void | SetStatusL (CRxData &aRxData, TInt aStatus)=0
Intended Usage: Receive a status message from the object that processes received data in a protocol handler.

Private Methods

virtual void | MRDO_Reserved1 ()
virtual void | MRDO_Reserved2 ()

Detailed Description

@public
Since:
7.0 An interface to be implemented by classes that wish to receive status information from an implementation of the CRxData class.

Definition at line 29 of file MRxDataObserver.h.

Member Function Documentation

void MRxDataObserver::MRDO_Reserved1 ( ) [inline, private, virtual]

Definition at line 60 of file MRxDataObserver.h.

void MRxDataObserver::MRDO_Reserved2 ( ) [inline, private, virtual]

Definition at line 62 of file MRxDataObserver.h.

void MRxDataObserver::SetStatusL | ( | CRxData & | aRxData,
 |  | TInt | aStatus
 | ) | [pure virtual]

Intended Usage: Receive a status message from the object that processes received data in a protocol handler.

Since:
7.0
Parameters:
aRxData | The object which is processing the data.
aStatus | The status (or error) code.

Implemented in CTextModeHttpProt, and CWspCOProtocolHandler.

The documentation for this class was generated from the following file:
  • MRxDataObserver.h


Member List

MRxDataObserver Member List

This is the complete list of members for MRxDataObserver, including all inherited members.
MRDO_Reserved1() | MRxDataObserver | [inline, private, virtual]
MRDO_Reserved2() | MRxDataObserver | [inline, private, virtual]
SetStatusL(CRxData &aRxData, TInt aStatus)=0 | MRxDataObserver | [pure virtual]


MSecurityPolicy Class Reference

@public
Since:
7.0 The Security Policy Interface.
More...

#include <csecuritypolicy.h>

Inheritance diagram for MSecurityPolicy:

[legend]
List of all members.

Public Methods

virtual void | ValidateUntrustedServerCert (TCertInfo &aServerCert, TRequestStatus &aStatus) const=0
virtual void | CancelValidateUntrustedServerCert ()=0
Intended Usage: Cancel a previous request to ask the client to accept or reject an untrusted WTLS server certificate.

virtual const RArray< TWtlsCipherSuite > & | GetWtlsCipherSuites ()=0
Intended Usage: Obtain an array of WTLS cipher suites.

virtual const TDesC8 & | GetTlsCipherSuites ()=0
Intended Usage: Obtain a list of TLS cipher suites.

virtual const RArray< TWtlsKeyExchangeSuite > & | GetWtlsKeyExchangeSuites ()=0
Intended Usage: Obtain the WTLS key exchange suites.

virtual TInt | GetNamedPolicyProperty (RStringF aPropertyName, RString &aPropertyValue)=0
Intended Usage: Obtain arbitrary, named security policy properties, in a generic 'stringified' form.

Protected Methods

virtual void | Reserved1 ()=0
Intended Usage: Reserve a slot in the v-table to preserve future BC
Since:
7.0.

virtual void | Reserved2 ()=0
Intended Usage: Reserve a slot in the v-table to preserve future BC
Since:
7.0.

Detailed Description

@public
Since:
7.0 The Security Policy Interface.

This interface class must be the base class of a security policy plug-in.

Definition at line 30 of file csecuritypolicy.h.

Member Function Documentation

void MSecurityPolicy::CancelValidateUntrustedServerCert ( ) [pure virtual]

Intended Usage: Cancel a previous request to ask the client to accept or reject an untrusted WTLS server certificate.

Since:
7.0

Implemented in CNwssWspTransportHandler.

TInt MSecurityPolicy::GetNamedPolicyProperty | ( | RStringF | aPropertyName,
 |  | RString & | aPropertyValue
 | ) | [pure virtual]

Intended Usage: Obtain arbitrary, named security policy properties, in a generic 'stringified' form.

Since:
7.0
Parameters:
aPropertyName | (in) The policy property name.
aPropertyValue | (out) The property value. Parsing of the value is left to the caller. The caller must close the RString.
Returns:
An error code: KErrNone if the property exists or KErrNotFound if it doesn't.

Implemented in CNwssWspTransportHandler.

const TDesC8 & MSecurityPolicy::GetTlsCipherSuites ( ) [pure virtual]

Intended Usage: Obtain a list of TLS cipher suites.

Not applicable to WTLS clients.

Since:
7.0
Returns:
An descriptor containing a list of the TLS cipher suites. Each cipher suite is a 2 byte pair

Implemented in CNwssWspTransportHandler.

const RArray< TWtlsCipherSuite > & MSecurityPolicy::GetWtlsCipherSuites ( ) [pure virtual]

Intended Usage: Obtain an array of WTLS cipher suites.

Not applicable to TLS clients.

Since:
7.0
Returns:
An array of cipher suites, consisting of paired bulk encryption algorithms and MAC algorithms. The array must be ordered with strongest cipher suites at the start.

Implemented in CNwssWspTransportHandler.

const RArray< TWtlsKeyExchangeSuite > & MSecurityPolicy::GetWtlsKeyExchangeSuites ( ) [pure virtual]

Intended Usage: Obtain the WTLS key exchange suites.

Not applicable to TLS clients.

Since:
7.0
Returns:
An array of the WTLS key exchange suites. The array must be ordered with authenticating key exchange suites at the start followed by anonymous key exchange suites if desired. Within each group of keys longer keys should precede shorter ones.

Implemented in CNwssWspTransportHandler.

MSecurityPolicy::Reserved1 ( ) [protected, pure virtual]

Intended Usage: Reserve a slot in the v-table to preserve future BC

Since:
7.0.

Implemented in CSecurityPolicy, and CNwssWspTransportHandler.

MSecurityPolicy::Reserved2 ( ) [protected, pure virtual]

Intended Usage: Reserve a slot in the v-table to preserve future BC

Since:
7.0.

Implemented in CSecurityPolicy, and CNwssWspTransportHandler.

virtual void MSecurityPolicy::ValidateUntrustedServerCert | ( | TCertInfo & | aServerCert,
 |  | TRequestStatus & | aStatus
 | ) | const [pure virtual]

Implemented in CNwssWspTransportHandler.

The documentation for this class was generated from the following file:
  • csecuritypolicy.h


Member List

MSecurityPolicy Member List

This is the complete list of members for MSecurityPolicy, including all inherited members.
CancelValidateUntrustedServerCert()=0 | MSecurityPolicy | [pure virtual]
GetNamedPolicyProperty(RStringF aPropertyName, RString &aPropertyValue)=0 | MSecurityPolicy | [pure virtual]
GetTlsCipherSuites()=0 | MSecurityPolicy | [pure virtual]
GetWtlsCipherSuites()=0 | MSecurityPolicy | [pure virtual]
GetWtlsKeyExchangeSuites()=0 | MSecurityPolicy | [pure virtual]
Reserved1()=0 | MSecurityPolicy | [protected, pure virtual]
Reserved2()=0 | MSecurityPolicy | [protected, pure virtual]
ValidateUntrustedServerCert(TCertInfo &aServerCert, TRequestStatus &aStatus) const=0 | MSecurityPolicy | [pure virtual]


CSecurityPolicy Class Reference

@public
Since:
7.0 The Security Policy Plug-in API.
More...

#include <csecuritypolicy.h>

Inheritance diagram for CSecurityPolicy:

[legend]
Collaboration diagram for CSecurityPolicy:

[legend]
List of all members.

Public Methods

virtual | ~CSecurityPolicy ()
Intended Usage: Class destructor.

Static Public Methods

CSecurityPolicy * | NewL (RStringPool aStringPool)
Intended Usage: Factory construction - instantiates the plug-in.

Protected Methods

CSecurityPolicy (RStringPool aStrPool)
Intended Usage: Normal constructor.

virtual void | Reserved1 ()
Intended Usage: Reserve a slot in the v-table to preserve future BC
Since:
7.0.

virtual void | Reserved2 ()
Intended Usage: Reserve a slot in the v-table to preserve future BC
Since:
7.0.

Protected Attributes

RStringPool | iStrPool
The stringpool reference.

Private Attributes

TUid | iDtor_ID_Key
D'tor Key identification required for ECOM.

Detailed Description

@public
Since:
7.0 The Security Policy Plug-in API.

This ECOM interface class must be implemented by each instance of a security policy plug-in.

Definition at line 124 of file csecuritypolicy.h.

Constructor & Destructor Documentation

CSecurityPolicy::~CSecurityPolicy ( ) [inline, virtual]

Intended Usage: Class destructor.

Since:
7.0

CSecurityPolicy::CSecurityPolicy ( RStringPool aStrPool ) [inline, protected]

Intended Usage: Normal constructor.

Creates an instance of the plug-in base.

Since:
7.0
Parameters:
aStringPool (in) An open string pool reference that can be used by the plugin.
Returns:
The constructed plug-in base.

Member Function Documentation

CSecurityPolicy::NewL ( RStringPool aStringPool ) [inline, static]

Intended Usage: Factory construction - instantiates the plug-in.

Since:
7.0
Parameters:
aStringPool (in) An open string pool reference that can be used by the plugin.
Returns:
The constructed plug-in.

CSecurityPolicy::Reserved1 ( ) [inline, protected, virtual]

Intended Usage: Reserve a slot in the v-table to preserve future BC

Since:
7.0.

Implements MSecurityPolicy.

CSecurityPolicy::Reserved2 ( ) [inline, protected, virtual]

Intended Usage: Reserve a slot in the v-table to preserve future BC

Since:
7.0.

Implements MSecurityPolicy.

Member Data Documentation

TUid CSecurityPolicy::iDtor_ID_Key [private]

D'tor Key identification required for ECOM.

For internal use only.

Definition at line 184 of file csecuritypolicy.h.

RStringPool CSecurityPolicy::iStrPool [protected]

The stringpool reference.

Definition at line 176 of file csecuritypolicy.h.

The documentation for this class was generated from the following file:
  • csecuritypolicy.h


Member List

CSecurityPolicy Member List

This is the complete list of members for CSecurityPolicy, including all inherited members.
CancelValidateUntrustedServerCert()=0 | MSecurityPolicy | [pure virtual]
CSecurityPolicy(RStringPool aStrPool) | CSecurityPolicy | [inline, protected]
GetNamedPolicyProperty(RStringF aPropertyName, RString &aPropertyValue)=0 | MSecurityPolicy | [pure virtual]
GetTlsCipherSuites()=0 | MSecurityPolicy | [pure virtual]
GetWtlsCipherSuites()=0 | MSecurityPolicy | [pure virtual]
GetWtlsKeyExchangeSuites()=0 | MSecurityPolicy | [pure virtual]
iDtor_ID_Key | CSecurityPolicy | [private]
iStrPool | CSecurityPolicy | [protected]
NewL(RStringPool aStringPool) | CSecurityPolicy | [inline, static]
Reserved1() | CSecurityPolicy | [inline, protected, virtual]
Reserved2() | CSecurityPolicy | [inline, protected, virtual]
ValidateUntrustedServerCert(TCertInfo &aServerCert, TRequestStatus &aStatus) const=0 | MSecurityPolicy | [pure virtual]
~CSecurityPolicy() | CSecurityPolicy | [inline, virtual]


CHTTPSession Class Reference

Implementation class for the session
See also:
RHTTPSession.
More...

#include <CHTTPSession.h>

Collaboration diagram for CHTTPSession:

[legend]
List of all members.

Public Methods

~CHTTPSession ()
Destructor.

CHTTPManager & Manager ()
Returns the manager. Does not transfer ownership.

const CHTTPManager & | Manager () const
Returns the manager. Does not transfer ownership.

RArray< THTTPFilterRegistration > & | FilterQueue ()
Returns the filter queue.

const RArray< THTTPFilterRegistration > & | FilterQueue () const
Returns the filter queue.

TInt | NextFilterHandle ()
Returns the next free filter handle.

TInt | NextTransactionID ()
Returns the next transaction ID.

void | AddTransactionL (CTransaction *aTransaction)
Adds a transaction to the session.

void | RemoveTransaction (CTransaction *aTransaction)
Removes a transaction from the session.

CHeaderCodec * | Codec () const
Returns the codec.

RHTTPConnectionInfo | ConnectionInfo () const
Returns the proxy/connection details.

RHTTPSession Handle ()
RHTTPHeaders RequestSessionHeadersL ()
Returns the request session headers.

RHTTPHeaders ResponseSessionHeadersL ()
Returns the response session headers.

void | CreateProtocolHandlerL ()
Creates the Protocol handler if necessary, called in transaction creation to allow delayed creation.

TBool | CanAddFilters () const
TFilterConfigurationIterator * | FilterConfigIterator () const
Returns the filter configuration iterator if one exists, otherwise will return NULL.

void | SetSessionEventCallback (MHTTPSessionEventCallback *aSessionEventCallback)
Sets the session event callback.

void | SendSessionEventL (THTTPSessionEvent aStatus, THTTPSessionEvent::TDirection aDirection, THTTPFilterHandle aStart=THTTPFilterHandle::EClient)
Send a session event.

void | FailSessionEvent (THTTPFilterHandle aStart=THTTPFilterHandle::EClient)
Fail the session event.

TInt | SessionServerCert (TCertInfo &aServerCert)
Get the Server Certificate for this session.

TInt | TransactionServerCert (TCertInfo &aServerCert, RHTTPTransaction aTransaction)
Get the Server Certificate for the specified transaction.

Blocking code
When 1 transaction runs, the session is blocked using the Block function.

It is unblocked at the end with the Unblock function.

If a transaction has run, it must block, and must inform the session of this by calling TransactionHasBlocked

If at least 1 transaction has blocked then when Unblock is called on the session, CTransaction::Unblock will be called on all the transactions. Any transaction that had blocked must then unblock and other transactions must do nothing.

The purpose of this implementation is to be as simple as possible, especialy in terms of storage, but to minimise the ammount of extra code that gets executed in the normal case (when no transactions fire while the session is blocked). This is why the session does not remember which transactions have blocked (which would add complex storage requirements) but it does remember if any have (meaning that all transactions don't need to be unblocked in the normal case)

TBool | IsBlocking () const
Returns ETrue if any transaction that fires should block.

void | TransactionHasBlocked ()
Used to inform the session that a transaction has blocked.

void | Block ()
Called by transaction to indicate that session should now block.

void | Unblock ()
Called by transaction to indicate that other transactions should stop blocking (and if transaction have blocked, they should be awakened).

Static Public Methods

CHTTPSession * | NewL ()
Constructs a session with default parameters.

CHTTPSession * | NewL (const TDesC8 &aProtocol)
Constructs a session with the specifed protocol.

CHTTPSession * | NewL (const TDesC8 &aProtocol, MHTTPFilterCreationCallback *aSessionCallback)
Constructs a session that allows filter configuration.

void | ListAvailableProtocolsL (RPointerArray< HBufC8 > &aProtocolArray)
This methods lists all of the available protocols on the device.

Private Types

enum | TBlockingStates { ENormal = 0, EShouldBlock, EHasBlocked }

Private Methods

CHTTPSession ()
Constructor.

void | ConstructL (const TDesC8 &aProtocol, MHTTPFilterCreationCallback *aSessionCallback)
2-phase construction

void | InitializeFiltersL (const TDesC8 &aProtocol)
Method to construct and build filter lists and install the mandatory and implicits filters.

void | CreateProtocolHandlerL (const TDesC8 &aProtocol)
Creates the Protocol handler if necessary, called in transaction creation to allow delayed creation.

Static Private Methods

void | CleanListImplementationArray (TAny *aArray)
Method used to cleanup the ECom implementation array for TCleanupItem.

Private Attributes

CHeaderFieldPart * iConnectionInfo
The proxy/connection details.

CHTTPManager * iManager
The manager (singleton).

RArray< THTTPFilterRegistration > | iFilterQueue
The filter queue.

RArray< CTransaction * > | iTransactions
A list of all the open transactions.

CProtocolHandler * iProtocolHandler
The protocol handler.

TInt | iNextFilterHandle
The next free filter handle.

TInt | iTransCount
The transaction counter, used to derive next transaction ID. Only ever incremented.

TBlockingStates iBlockingState
TClientFilter iClientFilter
CHeaders * iRequestSessionHeaders
CHeaders * iResponseSessionHeaders
CTransaction * iSessionEventTransaction
TDummyTransactionCallback iDummyTransactionCallback
RImplInfoPtrArray | iEComFilterInfoArray
RPointerArray< TSessionFilterInfo > | iFilterInfoList
TFilterConfigurationIterator * iFilterConfigIter

Friends

class | TFilterConfigurationIterator

Detailed Description

Implementation class for the session
See also:
RHTTPSession.

Definition at line 69 of file CHTTPSession.h.

Member Enumeration Documentation

enum CHTTPSession::TBlockingStates [private]

Enumeration values:
ENormal
EShouldBlock
EHasBlocked

Definition at line 245 of file CHTTPSession.h.

Constructor & Destructor Documentation

CHTTPSession::~CHTTPSession ( )

Destructor.

CHTTPSession::CHTTPSession ( ) [private]

Constructor.

Member Function Documentation

void CHTTPSession::AddTransactionL ( CTransaction * aTransaction )

Adds a transaction to the session.

void CHTTPSession::Block ( ) [inline]

Called by transaction to indicate that session should now block.

TBool CHTTPSession::CanAddFilters ( ) [inline]

void CHTTPSession::CleanListImplementationArray ( TAny * aArray ) [static, private]

Method used to cleanup the ECom implementation array for TCleanupItem.

CHeaderCodec* CHTTPSession::Codec ( )

Returns the codec.

RHTTPConnectionInfo CHTTPSession::ConnectionInfo ( )

Returns the proxy/connection details.

void CHTTPSession::ConstructL | ( | const TDesC8 & | aProtocol,
 |  | MHTTPFilterCreationCallback * | aSessionCallback
 | ) | [private]

2-phase construction

void CHTTPSession::CreateProtocolHandlerL ( const TDesC8 & aProtocol ) [private]

Creates the Protocol handler if necessary, called in transaction creation to allow delayed creation.

void CHTTPSession::CreateProtocolHandlerL ( )

Creates the Protocol handler if necessary, called in transaction creation to allow delayed creation.

void CHTTPSession::FailSessionEvent ( THTTPFilterHandle aStart = THTTPFilterHandle::EClient )

Fail the session event.

TFilterConfigurationIterator* CHTTPSession::FilterConfigIterator ( )

Returns the filter configuration iterator if one exists, otherwise will return NULL.

const RArray<THTTPFilterRegistration>& CHTTPSession::FilterQueue ( )

Returns the filter queue.

RArray<THTTPFilterRegistration>& CHTTPSession::FilterQueue ( )

Returns the filter queue.

RHTTPSession CHTTPSession::Handle ( ) [inline]

void CHTTPSession::InitializeFiltersL ( const TDesC8 & aProtocol ) [private]

Method to construct and build filter lists and install the mandatory and implicits filters.

TBool CHTTPSession::IsBlocking ( ) [inline]

Returns ETrue if any transaction that fires should block.

void CHTTPSession::ListAvailableProtocolsL ( RPointerArray< HBufC8 > & aProtocolArray ) [static]

This methods lists all of the available protocols on the device.

These are identified by using the list of protocol handler plugins discovered by ECom and appending the data type descriptors to the array. Any existing data in the array is deleted.

const CHTTPManager& CHTTPSession::Manager ( )

Returns the manager. Does not transfer ownership.

CHTTPManager& CHTTPSession::Manager ( )

Returns the manager. Does not transfer ownership.

CHTTPSession* CHTTPSession::NewL | ( | const TDesC8 & | aProtocol,
 |  | MHTTPFilterCreationCallback * | aSessionCallback
 | ) | [static]

Constructs a session that allows filter configuration.

This requires the callback interface of MHTTPFilterCreationCallback that is called during construction, so the client can determine the filters that are installed.

CHTTPSession* CHTTPSession::NewL ( const TDesC8 & aProtocol ) [static]

Constructs a session with the specifed protocol.

CHTTPSession* CHTTPSession::NewL ( ) [static]

Constructs a session with default parameters.

TInt CHTTPSession::NextFilterHandle ( )

Returns the next free filter handle.

TInt CHTTPSession::NextTransactionID ( )

Returns the next transaction ID.

void CHTTPSession::RemoveTransaction ( CTransaction * aTransaction )

Removes a transaction from the session.

RHTTPHeaders CHTTPSession::RequestSessionHeadersL ( )

Returns the request session headers.

This will create the protocol handler if it doesn't already exist @leave Leaves if protocol handler doesn't exist and fails to be created

RHTTPHeaders CHTTPSession::ResponseSessionHeadersL ( )

Returns the response session headers.

This will create the protocol handler if it doesn't already exist @leave Leaves if protocol handler doesn't exist and fails to be created

void CHTTPSession::SendSessionEventL | ( | THTTPSessionEvent | aStatus,
 |  | THTTPSessionEvent::TDirection | aDirection,
 |  | THTTPFilterHandle | aStart = THTTPFilterHandle::EClient
 | ) |

Send a session event.

TInt CHTTPSession::SessionServerCert ( TCertInfo & aServerCert )

Get the Server Certificate for this session.

Parameters:
aServerCert A TCertInfo which will be filled with the certificate information
Returns:
An error code. KErrNone if aServerCert has been completed, otherwise one of the system wide error codes

void CHTTPSession::SetSessionEventCallback ( MHTTPSessionEventCallback * aSessionEventCallback )

Sets the session event callback.

void CHTTPSession::TransactionHasBlocked ( ) [inline]

Used to inform the session that a transaction has blocked.

TInt CHTTPSession::TransactionServerCert | ( | TCertInfo & | aServerCert,
 |  | RHTTPTransaction | aTransaction
 | ) |

Get the Server Certificate for the specified transaction.

Parameters:
aServerCert | A TCertInfo which will be filled with the certificate information
aTransaction | The transaction for which the certificate is requested
Returns:
An error code. KErrNone if aServerCert has been completed, otherwise one of the system wide error codes

void CHTTPSession::Unblock ( )

Called by transaction to indicate that other transactions should stop blocking (and if transaction have blocked, they should be awakened).

Friends And Related Function Documentation

friend class TFilterConfigurationIterator [friend]

Definition at line 243 of file CHTTPSession.h.

Member Data Documentation

TBlockingStates CHTTPSession::iBlockingState [private]

Definition at line 275 of file CHTTPSession.h.

TClientFilter CHTTPSession::iClientFilter [private]

Definition at line 279 of file CHTTPSession.h.

CHeaderFieldPart* CHTTPSession::iConnectionInfo [private]

The proxy/connection details.

Definition at line 254 of file CHTTPSession.h.

TDummyTransactionCallback CHTTPSession::iDummyTransactionCallback [private]

Definition at line 295 of file CHTTPSession.h.

RImplInfoPtrArray CHTTPSession::iEComFilterInfoArray [private]

Definition at line 299 of file CHTTPSession.h.

TFilterConfigurationIterator* CHTTPSession::iFilterConfigIter [private]

Definition at line 308 of file CHTTPSession.h.

RPointerArray<TSessionFilterInfo> CHTTPSession::iFilterInfoList [private]

Definition at line 303 of file CHTTPSession.h.

RArray<THTTPFilterRegistration> CHTTPSession::iFilterQueue [private]

The filter queue.

Definition at line 260 of file CHTTPSession.h.

CHTTPManager* CHTTPSession::iManager [private]

The manager (singleton).

Definition at line 257 of file CHTTPSession.h.

TInt CHTTPSession::iNextFilterHandle [private]

The next free filter handle.

Definition at line 269 of file CHTTPSession.h.

CProtocolHandler* CHTTPSession::iProtocolHandler [private]

The protocol handler.

Definition at line 266 of file CHTTPSession.h.

CHeaders* CHTTPSession::iRequestSessionHeaders [private]

Definition at line 283 of file CHTTPSession.h.

CHeaders* CHTTPSession::iResponseSessionHeaders [private]

Definition at line 287 of file CHTTPSession.h.

CTransaction* CHTTPSession::iSessionEventTransaction [private]

Definition at line 291 of file CHTTPSession.h.

RArray<CTransaction*> CHTTPSession::iTransactions [private]

A list of all the open transactions.

Definition at line 263 of file CHTTPSession.h.

TInt CHTTPSession::iTransCount [private]

The transaction counter, used to derive next transaction ID. Only ever incremented.

Definition at line 272 of file CHTTPSession.h.

The documentation for this class was generated from the following file:
  • CHTTPSession.h


Member List

CHTTPSession Member List

This is the complete list of members for CHTTPSession, including all inherited members.
AddTransactionL(CTransaction *aTransaction) | CHTTPSession |
Block() | CHTTPSession | [inline]
CanAddFilters() const | CHTTPSession | [inline]
CHTTPSession() | CHTTPSession | [private]
CleanListImplementationArray(TAny *aArray) | CHTTPSession | [private, static]
Codec() const | CHTTPSession |
ConnectionInfo() const | CHTTPSession |
ConstructL(const TDesC8 &aProtocol, MHTTPFilterCreationCallback *aSessionCallback) | CHTTPSession | [private]
CreateProtocolHandlerL() | CHTTPSession |
CreateProtocolHandlerL(const TDesC8 &aProtocol) | CHTTPSession | [private]
EHasBlocked enum value | CHTTPSession | [private]
ENormal enum value | CHTTPSession | [private]
EShouldBlock enum value | CHTTPSession | [private]
FailSessionEvent(THTTPFilterHandle aStart=THTTPFilterHandle::EClient) | CHTTPSession |
FilterConfigIterator() const | CHTTPSession |
FilterQueue() | CHTTPSession |
FilterQueue() const | CHTTPSession |
Handle() | CHTTPSession | [inline]
iBlockingState | CHTTPSession | [private]
iClientFilter | CHTTPSession | [private]
iConnectionInfo | CHTTPSession | [private]
iDummyTransactionCallback | CHTTPSession | [private]
iEComFilterInfoArray | CHTTPSession | [private]
iFilterConfigIter | CHTTPSession | [private]
iFilterInfoList | CHTTPSession | [private]
iFilterQueue | CHTTPSession | [private]
iManager | CHTTPSession | [private]
iNextFilterHandle | CHTTPSession | [private]
InitializeFiltersL(const TDesC8 &aProtocol) | CHTTPSession | [private]
iProtocolHandler | CHTTPSession | [private]
iRequestSessionHeaders | CHTTPSession | [private]
iResponseSessionHeaders | CHTTPSession | [private]
IsBlocking() const | CHTTPSession | [inline]
iSessionEventTransaction | CHTTPSession | [private]
iTransactions | CHTTPSession | [private]
iTransCount | CHTTPSession | [private]
ListAvailableProtocolsL(RPointerArray< HBufC8 > &aProtocolArray) | CHTTPSession | [static]
Manager() | CHTTPSession |
Manager() const | CHTTPSession |
NewL() | CHTTPSession | [static]
NewL(const TDesC8 &aProtocol) | CHTTPSession | [static]
NewL(const TDesC8 &aProtocol, MHTTPFilterCreationCallback *aSessionCallback) | CHTTPSession | [static]
NextFilterHandle() | CHTTPSession |
NextTransactionID() | CHTTPSession |
RemoveTransaction(CTransaction *aTransaction) | CHTTPSession |
RequestSessionHeadersL() | CHTTPSession |
ResponseSessionHeadersL() | CHTTPSession |
SendSessionEventL(THTTPSessionEvent aStatus, THTTPSessionEvent::TDirection aDirection, THTTPFilterHandle aStart=THTTPFilterHandle::EClient) | CHTTPSession |
SessionServerCert(TCertInfo &aServerCert) | CHTTPSession |
SetSessionEventCallback(MHTTPSessionEventCallback *aSessionEventCallback) | CHTTPSession |
TBlockingStates enum name | CHTTPSession | [private]
TFilterConfigurationIterator class | CHTTPSession | [friend]
TransactionHasBlocked() | CHTTPSession | [inline]
TransactionServerCert(TCertInfo &aServerCert, RHTTPTransaction aTransaction) | CHTTPSession |
Unblock() | CHTTPSession |
~CHTTPSession() | CHTTPSession |


RHTTPSession Class Reference

@public
Since:
7.0 A session handle.
More...

#include <rhttpsession.h>

Collaboration diagram for RHTTPSession:

[legend]
List of all members.

Public Methods

RHTTPSession ()
Constructor.

IMPORT_C void | SetSessionEventCallback (MHTTPSessionEventCallback *aSessionEventCallback)
Sets the session event callback.

IMPORT_C void | SendSessionEventL (THTTPSessionEvent aStatus, THTTPSessionEvent::TDirection aDirection, THTTPFilterHandle aStart=THTTPFilterHandle::EClient)
Send an session event.

IMPORT_C void | FailSessionEvent (THTTPFilterHandle aStart=THTTPFilterHandle::EClient)
Fail the session event.

IMPORT_C void | OpenL ()
Opens the session using the default protocol HTTP/TCP.

IMPORT_C void | OpenL (const TDesC8 &aProtocol)
Opens the session using the protocol indicated by the parameter passed in.

IMPORT_C void | OpenL (const TDesC8 &aProtocol, MHTTPFilterCreationCallback *aSessionCallback)
Opens the session using the protocol indicated by the parameter passed in.

IMPORT_C RHTTPTransaction | OpenTransactionL (const TUriC8 &aURI, MHTTPTransactionCallback &aCallback, RStringF aMethod=RStringF())
Creates a transaction.

IMPORT_C void | Close ()
Closes the session.

IMPORT_C RStringPool | StringPool () const
Accessor for the HTTP string pool.

IMPORT_C RHTTPConnectionInfo | ConnectionInfo () const
Accessor for the connection info for this session, and which is used for all transactions in the session.

RHTTPFilterCollection | FilterCollection () const
Accessor for the filter collection.

IMPORT_C RHTTPHeaders | RequestSessionHeadersL ()
Accessor for the session headers.

IMPORT_C RHTTPHeaders | ResponseSessionHeadersL ()
Accessor for the response session headers.

TBool | operator== (RHTTPSession aTrans) const
Equality operator.

TBool | operator!= (RHTTPSession aTrans) const
Inequality operator.

IMPORT_C TInt | ServerCert (TCertInfo &aServerCert)
Obtain the server certificate information for this session.

IMPORT_C void | ConnectL ()
Connect this WSP session.

IMPORT_C void | DisconnectL ()
Disconnect this WSP session.

Static Public Methods

IMPORT_C void | ListAvailableProtocolsL (RPointerArray< HBufC8 > &aProtocolArray)
This is a static methods that lists all the available protocols by adding the prorocol descriptors to the descriptor array passed in.

IMPORT_C const TStringTable & | GetTable ()

Private Attributes

CHTTPSession * iImplementation

Friends

class | RHTTPFilterCollection
class | CHTTPSession

Detailed Description

@public
Since:
7.0 A session handle.

A session is a set of HTTP transactions using the same connection settings (e.g. proxy) and the same set of filters. Multi-homing support provided by HTTP framework enables clients to specify Connection preferences through the session property EHttpSocketConnection.

Note that RHTTPSession (and consequently the whole of HTTP) depends on the active scheduler; a scheduler must be installed when the session is opened and it must be running if a transaction is actually to do anything.

See also:
RHTTPTransaction

Definition at line 49 of file rhttpsession.h.

Constructor & Destructor Documentation

RHTTPSession::RHTTPSession ( ) [inline]

Constructor.

Postcondition:
The session is closed. (It must be opened with OpenL)
See also:
OpenL

Definition at line 218 of file rhttpsession.h.

Member Function Documentation

IMPORT_C void RHTTPSession::Close ( )

Closes the session.

All transactions will be stopped and closed

Postcondition:
The session and all open transactions in it are closed.

IMPORT_C RHTTPConnectionInfo RHTTPSession::ConnectionInfo ( )

Accessor for the connection info for this session, and which is used for all transactions in the session.

Note that by and large, the connection info should be set up before the first transaction is created.

Returns:
A handle to the connection inf.

IMPORT_C void RHTTPSession::ConnectL ( )

Connect this WSP session.

This function does nothing when called for text-mode.

IMPORT_C void RHTTPSession::DisconnectL ( )

Disconnect this WSP session.

This function does nothing when called for text-mode.

IMPORT_C void RHTTPSession::FailSessionEvent ( THTTPFilterHandle aStart = THTTPFilterHandle::EClient )

Fail the session event.

RHTTPFilterCollection RHTTPSession::FilterCollection ( ) [inline]

Accessor for the filter collection.

Note that the filter collection can't be edited after the first transaction has been created.

Definition at line 224 of file rhttpsession.h.

References iImplementation, and RHTTPFilterCollection::iImplementation.

IMPORT_C const TStringTable& RHTTPSession::GetTable ( ) [static]

IMPORT_C void RHTTPSession::ListAvailableProtocolsL ( RPointerArray< HBufC8 > & aProtocolArray ) [static]

This is a static methods that lists all the available protocols by adding the prorocol descriptors to the descriptor array passed in.

Any existing data in the descriptor array passed in is deleted. This function leaves if the descriptor array can not be updated with the appropriate array code.

Parameters:
aProtocolArray A pointer array to heap based descriptors. The data in this array will be deleted and filled with descriptors containing the available protocols
See also:
OpenL

IMPORT_C void RHTTPSession::OpenL | ( | const TDesC8 & | aProtocol,
 |  | MHTTPFilterCreationCallback * | aSessionCallback
 | ) |

Opens the session using the protocol indicated by the parameter passed in.

This method should be used if configuring the installed filters is required. Once construction if the session is complete the callback method passed in is called passing in a TFilterConfigurationIterator to allow the filters that are installed to be configured. This function leaves with an apropriate code if the open failed.

Parameters:
aProtocol | The protocol required
aSessionCallback | The pointer to the object providing the call back method
Precondition:
The session is closed. An active scheduler is installed.
Postcondition:
The session is open.

IMPORT_C void RHTTPSession::OpenL ( const TDesC8 & aProtocol )

Opens the session using the protocol indicated by the parameter passed in.

This function leaves with an apropriate code if the open failed.

Parameters:
aProtocol The protocol required
Precondition:
The session is closed. An active scheduler is installed.
Postcondition:
The session is open.

IMPORT_C void RHTTPSession::OpenL ( )

Opens the session using the default protocol HTTP/TCP.

This function leaves with an apropriate code if the open failed.

Precondition:
The session is closed. An active scheduler is installed.
Postcondition:
The session is open.

IMPORT_C RHTTPTransaction RHTTPSession::OpenTransactionL | ( | const TUriC8 & | aURI,
 |  | MHTTPTransactionCallback & | aCallback,
 |  | RStringF | aMethod = RStringF()
 | ) |

Creates a transaction.

Precondition:
The session is open
Parameters:
aURI | The URI that the request will be sent to.
aCallback | A callback for all status events relating to this transaction.
aMethod | The HTTP method to use (default: GET)
Exceptions:
KErrNoMemory There was not enough memory.

TBool RHTTPSession::operator!= ( RHTTPSession aTrans ) const [inline]

Inequality operator.

Parameters:
aTrans The session to compare this one to.

Definition at line 235 of file rhttpsession.h.

TBool RHTTPSession::operator== ( RHTTPSession aTrans ) const [inline]

Equality operator.

Parameters:
aTrans The session to compare this one to.

Definition at line 231 of file rhttpsession.h.

References iImplementation.

IMPORT_C RHTTPHeaders RHTTPSession::RequestSessionHeadersL ( )

Accessor for the session headers.

These are headers that will get added to each request They only become part of the transaction headers when a transaction is submitted and they will not replace headers that already exist in the transaction request

IMPORT_C RHTTPHeaders RHTTPSession::ResponseSessionHeadersL ( )

Accessor for the response session headers.

These are headers that will get added to each response if the corresponding header doesn't already exist

IMPORT_C void RHTTPSession::SendSessionEventL | ( | THTTPSessionEvent | aStatus,
 |  | THTTPSessionEvent::TDirection | aDirection,
 |  | THTTPFilterHandle | aStart = THTTPFilterHandle::EClient
 | ) |

Send an session event.

Parameters:
aEvent. The session event to sent.

IMPORT_C TInt RHTTPSession::ServerCert ( TCertInfo & aServerCert )

Obtain the server certificate information for this session.

This function should only be used for WSP, for text-mode use RHttpTransaction::ServerCert.

See also:
RHttpTransaction::ServerCert
Parameters:
aServerCert A client supplied object into which the certificate information will be placed.
Returns:
KErrNone if certificate has been completed, KErrNotSupported if this function is called for text-mode.

IMPORT_C void RHTTPSession::SetSessionEventCallback ( MHTTPSessionEventCallback * aSessionEventCallback )

Sets the session event callback.

Until it is set all incoming session events are consumed

IMPORT_C RStringPool RHTTPSession::StringPool ( )

Accessor for the HTTP string pool.

Returns:
A handle for the string pool used in HTTP.

Friends And Related Function Documentation

friend class CHTTPSession [friend]

Definition at line 212 of file rhttpsession.h.

friend class RHTTPFilterCollection [friend]

Definition at line 211 of file rhttpsession.h.

Member Data Documentation

CHTTPSession* RHTTPSession::iImplementation [private]

Definition at line 215 of file rhttpsession.h.

Referenced by FilterCollection(), operator==(), and RHTTPFilterCollection::Session().

The documentation for this class was generated from the following file:
  • rhttpsession.h


Member List

RHTTPSession Member List

This is the complete list of members for RHTTPSession, including all inherited members.
CHTTPSession class | RHTTPSession | [friend]
Close() | RHTTPSession |
ConnectionInfo() const | RHTTPSession |
ConnectL() | RHTTPSession |
DisconnectL() | RHTTPSession |
FailSessionEvent(THTTPFilterHandle aStart=THTTPFilterHandle::EClient) | RHTTPSession |
FilterCollection() const | RHTTPSession | [inline]
GetTable() | RHTTPSession | [static]
iImplementation | RHTTPSession | [private]
ListAvailableProtocolsL(RPointerArray< HBufC8 > &aProtocolArray) | RHTTPSession | [static]
OpenL() | RHTTPSession |
OpenL(const TDesC8 &aProtocol) | RHTTPSession |
OpenL(const TDesC8 &aProtocol, MHTTPFilterCreationCallback *aSessionCallback) | RHTTPSession |
OpenTransactionL(const TUriC8 &aURI, MHTTPTransactionCallback &aCallback, RStringF aMethod=RStringF()) | RHTTPSession |
operator!=(RHTTPSession aTrans) const | RHTTPSession | [inline]
operator==(RHTTPSession aTrans) const | RHTTPSession | [inline]
RequestSessionHeadersL() | RHTTPSession |
ResponseSessionHeadersL() | RHTTPSession |
RHTTPFilterCollection class | RHTTPSession | [friend]
RHTTPSession() | RHTTPSession | [inline]
SendSessionEventL(THTTPSessionEvent aStatus, THTTPSessionEvent::TDirection aDirection, THTTPFilterHandle aStart=THTTPFilterHandle::EClient) | RHTTPSession |
ServerCert(TCertInfo &aServerCert) | RHTTPSession |
SetSessionEventCallback(MHTTPSessionEventCallback *aSessionEventCallback) | RHTTPSession |
StringPool() const | RHTTPSession |


THTTPSessionEvent Class Reference

@public
Since:
7.0 A HTTP session status message.
More...

#include <thttpevent.h>

Inheritance diagram for THTTPSessionEvent:

[legend]
Collaboration diagram for THTTPSessionEvent:

[legend]
List of all members.

Public Types

enum TSessionEvent {
EConnect = KSessionEventBaseStatus, EDisconnect = KSessionEventBaseStatus + 1, EConnectedOK = KSessionEventBaseStatus + 2, EConnectedWithReducedCapabilities = KSessionEventBaseStatus + 3,
EDisconnected = KSessionEventBaseStatus + 4, EAuthenticatedOK = KSessionEventBaseStatus + 5, EAuthenticationFailure = KSessionEventBaseStatus + 6, EConnectionTimedOut = KSessionEventBaseStatus + 7
}
The TSessionEvents type defines the evenst that correspond to the of a session entity. More...

enum TSessionWarning {
ENotConnected = KSessionWarningBaseStatus, EExceptionInfo = KSessionWarningBaseStatus + 1, ERedirected = KSessionWarningBaseStatus + 2, EAlreadyConnecting = KSessionWarningBaseStatus + 3,
EAlreadyConnected = KSessionWarningBaseStatus + 4, EAlreadyDisconnecting = KSessionWarningBaseStatus + 5, EAlreadyDisconnected = KSessionWarningBaseStatus + 6
}

Public Methods

THTTPSessionEvent (TInt aStatus, TUint aUID=KHTTPUid)
Constructor.

THTTPSessionEvent (TStandardEvent aStatus=EAnySessionEvent)
Constructor (using a standard event and the HTTP UID).

THTTPSessionEvent (TSessionEvent aStatus)
Constructor (using a session event and the HTTP UID).

THTTPSessionEvent & | operator= (TSessionEvent aStatus)
Assigns a session event code to an event object.

TBool | operator== (TSessionEvent aStatus) const
Equality operator (compares with a session event).

TBool | operator!= (TSessionEvent aStatus) const
Inequality operator (compares with a session event).

Detailed Description

@public
Since:
7.0 A HTTP session status message.

Status messages consist of a UID and a status code within that UID. Extension dlls that needs to create new status messages should use their own UID and create status codes within that UID.

Definition at line 273 of file thttpevent.h.

Member Enumeration Documentation

enum THTTPSessionEvent::TSessionEvent

The TSessionEvents type defines the evenst that correspond to the of a session entity.

Outgoing events originate from the client or from filters. Incoming events originate from the protocol handler or from filters, and clients should handle these.

Enumeration values:
EConnect A session connection should be initiated.

An outgoing event.

EDisconnect The session should be disconnected.

An outgoing event.

EConnectedOK The session has been successfully connected.

None of the client requested capabilities were denied or reduced by the proxy. An incoming event.

EConnectedWithReducedCapabilities The session has been connected, but with one or more of the client requested capabilities denied or reduced by the proxy.

An incoming event.

EDisconnected The session has been disconnected.

This either confirms an earlier EDisconnect event or indicates a forced disconnection by the proxy. An incoming event.

EAuthenticatedOK | The authentication handshake succeeded with the automatic validation of the (proxy) server certificate.
EAuthenticationFailure | The authentication handshake failed.
EConnectionTimedOut | The connection attempt to the proxy timed out.

Definition at line 281 of file thttpevent.h.

enum THTTPSessionEvent::TSessionWarning

Enumeration values:
ENotConnected The client has requested a transaction event that requires a session to be connected or the connection to be initiated, but neither is currently true.

The transaction event will be left pending until the session is connected. An incoming event.

EExceptionInfo The proxy has sent some information that is not related to a transaction and has no effect on the state of the session.

The information from the proxy is in the EProxyExceptionInfo property.

ERedirected The client connection request was (permanently) redirected to a new WAP proxy address.

The client should check the EWspProxyAddress property for the new address. The client's access-point database can then be updated with this address. No notification is given of a temporary redirection.

EAlreadyConnecting | The client has requested a session event that is not valid whilst the WSP session is trying to establish a connection.
EAlreadyConnected | The client has requested a session event that is not valid whilst the WSP session is in the Connected state.
EAlreadyDisconnecting | The client has requested a session event that is not valid whilst the WSP session is trying to close the connection.
EAlreadyDisconnected | The client has requested a session event that is not valid whilst the WSP session is in the Null (or disconnected) state.

Definition at line 316 of file thttpevent.h.

Constructor & Destructor Documentation

THTTPSessionEvent::THTTPSessionEvent | ( | TInt | aStatus,
 |  | TUint | aUID = KHTTPUid
 | ) | [inline]

Constructor.

Parameters:
aStatus | The status value.
aUid | The UID.

THTTPSessionEvent::THTTPSessionEvent ( TStandardEvent aStatus = EAnySessionEvent ) [inline]

Constructor (using a standard event and the HTTP UID).

Parameters:
aStatus The standard event to use.

THTTPSessionEvent::THTTPSessionEvent ( TSessionEvent aStatus ) [inline]

Constructor (using a session event and the HTTP UID).

Parameters:
aStatus The session event to use.

Member Function Documentation

TBool THTTPSessionEvent::operator!= ( TSessionEvent aStatus ) const [inline]

Inequality operator (compares with a session event).

THTTPSessionEvent& THTTPSessionEvent::operator= ( TSessionEvent aStatus ) [inline]

Assigns a session event code to an event object.

Parameters:
aStatus The session event.

TBool THTTPSessionEvent::operator== ( TSessionEvent aStatus ) const [inline]

Equality operator (compares with a session event).

The documentation for this class was generated from the following file:
  • thttpevent.h


Member List

THTTPSessionEvent Member List

This is the complete list of members for THTTPSessionEvent, including all inherited members.
EAll enum value | THTTPEvent |
EAlreadyConnected enum value | THTTPSessionEvent |
EAlreadyConnecting enum value | THTTPSessionEvent |
EAlreadyDisconnected enum value | THTTPSessionEvent |
EAlreadyDisconnecting enum value | THTTPSessionEvent |
EAnySessionEvent enum value | THTTPEvent |
EAnyTransactionEvent enum value | THTTPEvent |
EAuthenticatedOK enum value | THTTPSessionEvent |
EAuthenticationFailure enum value | THTTPSessionEvent |
ECancel enum value | THTTPEvent |
EClosed enum value | THTTPEvent |
EConnect enum value | THTTPSessionEvent |
EConnectedOK enum value | THTTPSessionEvent |
EConnectedWithReducedCapabilities enum value | THTTPSessionEvent |
EConnectionTimedOut enum value | THTTPSessionEvent |
EDisconnect enum value | THTTPSessionEvent |
EDisconnected enum value | THTTPSessionEvent |
EExceptionInfo enum value | THTTPSessionEvent |
EFailed enum value | THTTPEvent |
EGotResponseBodyData enum value | THTTPEvent |
EGotResponseHeaders enum value | THTTPEvent |
EGotResponseTrailerHeaders enum value | THTTPEvent |
EIncoming enum value | THTTPEvent |
EMoreDataReceivedThanExpected enum value | THTTPEvent |
ENotConnected enum value | THTTPSessionEvent |
ENotifyNewRequestBodyPart enum value | THTTPEvent |
EOutgoing enum value | THTTPEvent |
ERedirected enum value | THTTPSessionEvent |
ERedirectedPermanently enum value | THTTPEvent |
ERedirectedTemporarily enum value | THTTPEvent |
EResponseComplete enum value | THTTPEvent |
ESubmit enum value | THTTPEvent |
ESucceeded enum value | THTTPEvent |
ETooMuchRequestData enum value | THTTPEvent |
EUnrecoverableError enum value | THTTPEvent |
iIsSessionEventFlag | THTTPEvent | [protected]
IsSessionEvent() const | THTTPEvent | [inline]
iStatus | THTTPEvent |
iUID | THTTPEvent |
operator!=(TSessionEvent aStatus) const | THTTPSessionEvent | [inline]
THTTPEvent::operator!=(THTTPEvent aThat) const | THTTPEvent | [inline]
THTTPEvent::operator!=(TStandardEvent aStatus) const | THTTPEvent | [inline]
THTTPEvent::operator!=(TTransactionEvent aStatus) const | THTTPEvent | [inline]
operator=(TSessionEvent aStatus) | THTTPSessionEvent | [inline]
THTTPEvent::operator=(TStandardEvent aStatus) | THTTPEvent | [inline]
THTTPEvent::operator=(TTransactionEvent aStatus) | THTTPEvent | [inline]
operator==(TSessionEvent aStatus) const | THTTPSessionEvent | [inline]
THTTPEvent::operator==(THTTPEvent aThat) const | THTTPEvent | [inline]
THTTPEvent::operator==(TStandardEvent aStatus) const | THTTPEvent | [inline]
THTTPEvent::operator==(TTransactionEvent aStatus) const | THTTPEvent | [inline]
TDirection enum name | THTTPEvent |
THTTPEvent(TInt aStatus, TUint aUID=KHTTPUid) | THTTPEvent | [inline]
THTTPEvent(TStandardEvent aStatus=EAnyTransactionEvent) | THTTPEvent | [inline]
THTTPEvent(TTransactionEvent aStatus) | THTTPEvent | [inline]
THTTPSessionEvent(TInt aStatus, TUint aUID=KHTTPUid) | THTTPSessionEvent | [inline]
THTTPSessionEvent(TStandardEvent aStatus=EAnySessionEvent) | THTTPSessionEvent | [inline]
THTTPSessionEvent(TSessionEvent aStatus) | THTTPSessionEvent | [inline]
TSessionEvent enum name | THTTPSessionEvent |
TSessionWarning enum name | THTTPSessionEvent |
TStandardEvent enum name | THTTPEvent |
TTransactionEvent enum name | THTTPEvent |
TTransactionWarning enum name | THTTPEvent |


MHTTPSessionEventCallback Class Reference

@public
Since:
7.0 The per-session callback for receiving session event callbacks.
More...

#include <mhttpsessioneventcallback.h>

List of all members.

Public Methods

virtual void | MHFSessionRunL (const THTTPSessionEvent &aEvent)=0
Called when the filters registration conditions are satisfied for events that occur on the session.

virtual TInt | MHFSessionRunError (TInt aError, const THTTPSessionEvent &aEvent)=0
Called when MHFRunL leaves from a session event.

Detailed Description

@public
Since:
7.0 The per-session callback for receiving session event callbacks.

Definition at line 27 of file mhttpsessioneventcallback.h.

Member Function Documentation

virtual TInt MHTTPSessionEventCallback::MHFSessionRunError | ( | TInt | aError,
 |  | const THTTPSessionEvent & | aEvent
 | ) | [pure virtual]

Called when MHFRunL leaves from a session event.

This works in the same way as CActve::RunError If you don't completely handle the error, a panic will occur.

Parameters:
aError | The leave code that RunL left with.
aEvent | The Event that was being processed.
Returns:
KErrNone if the error has been cancelled or the code of the continuing error otherwise.

virtual void MHTTPSessionEventCallback::MHFSessionRunL ( const THTTPSessionEvent & aEvent ) [pure virtual]

Called when the filters registration conditions are satisfied for events that occur on the session.

@ param aEvent The session event that has occured. @ exception Any leaves must be handled by the appropriate MHFRunError.

The documentation for this class was generated from the following file:
  • mhttpsessioneventcallback.h


Member List

MHTTPSessionEventCallback Member List

This is the complete list of members for MHTTPSessionEventCallback, including all inherited members.
MHFSessionRunError(TInt aError, const THTTPSessionEvent &aEvent)=0 | MHTTPSessionEventCallback | [pure virtual]
MHFSessionRunL(const THTTPSessionEvent &aEvent)=0 | MHTTPSessionEventCallback | [pure virtual]


TSessionFilterInfo Class Reference

Struct for containing a session's filter information. More...

#include <CHTTPSession.h>

Collaboration diagram for TSessionFilterInfo:

[legend]
List of all members.

Public Types

enum | TFilterCategory { EMandatory, EImplicit, EExplicit }
Enum defining the filter category. More...

Public Attributes

CImplementationInformation * | iFilterInfo
TFilterCategory iCategory
CEComFilter * iFilterPlugin

Detailed Description

Struct for containing a session's filter information.

Definition at line 48 of file CHTTPSession.h.

Member Enumeration Documentation

enum TSessionFilterInfo::TFilterCategory

Enum defining the filter category.

Enumeration values:
EMandatory
EImplicit
EExplicit

Definition at line 52 of file CHTTPSession.h.

Member Data Documentation

TFilterCategory TSessionFilterInfo::iCategory

Definition at line 62 of file CHTTPSession.h.

CImplementationInformation* TSessionFilterInfo::iFilterInfo

Definition at line 60 of file CHTTPSession.h.

CEComFilter* TSessionFilterInfo::iFilterPlugin

Definition at line 64 of file CHTTPSession.h.

The documentation for this class was generated from the following file:
  • CHTTPSession.h


Member List

TSessionFilterInfo Member List

This is the complete list of members for TSessionFilterInfo, including all inherited members.
EExplicit enum value | TSessionFilterInfo
EImplicit enum value | TSessionFilterInfo
EMandatory enum value | TSessionFilterInfo
iCategory | TSessionFilterInfo
iFilterInfo | TSessionFilterInfo
iFilterPlugin | TSessionFilterInfo
TFilterCategory enum name | TSessionFilterInfo


MSessionPropertiesProvider Class Reference

MSessionPropertiesProvider is the interface used by CTcpClientFactory to get/set COMMs Preferences as session properties, used for multi-homing. More...

#include <MSessionPropertiesProvider.h>

Inheritance diagram for MSessionPropertiesProvider:

[legend]
List of all members.

Public Methods

virtual TBool | GetCommsPrefs (TInt &aSocketServHandle, TInt &aConnectionPtr)=0
Get COMMs preferences from session properties.

virtual void | SetCommsPrefs (TInt aSocketServHandle, TInt aConnectionPtr)=0
Set COMMs preferences as session properties.

virtual TSecureDialogPref | GetSecureDialogPref () const=0
Get Security dialog preference from Session properties.

Detailed Description

MSessionPropertiesProvider is the interface used by CTcpClientFactory to get/set COMMs Preferences as session properties, used for multi-homing.

CHttpSocket uses this interface to get the Security Dialog preference, for secure connections.

Definition at line 30 of file MSessionPropertiesProvider.h.

Member Function Documentation

virtual TBool MSessionPropertiesProvider::GetCommsPrefs | ( | TInt & | aSocketServHandle,
 |  | TInt & | aConnectionPtr
 | ) | [pure virtual]

Get COMMs preferences from session properties.

Parameters:
aSocketServHandle | Output parameter which holds the RSocketServ session handle.
aConnectionRef | Output parameter which holds a reference to the RConnection sub-session.
Returns:
ETure if both the session properties have values, else EFalse

Implemented in CTextModeHttpProt.

virtual TSecureDialogPref MSessionPropertiesProvider::GetSecureDialogPref ( ) [pure virtual]

Get Security dialog preference from Session properties.

Returns:
clients preference if set, else returns EPrompt as default

Implemented in CTextModeHttpProt.

virtual void MSessionPropertiesProvider::SetCommsPrefs | ( | TInt | aSocketServHandle,
 |  | TInt | aConnectionPtr
 | ) | [pure virtual]

Set COMMs preferences as session properties.

Parameters:
aSocketServHandle | Input parameter
aConnectionRef | Input parameter

Implemented in CTextModeHttpProt.

The documentation for this class was generated from the following file:
  • MSessionPropertiesProvider.h


Member List

MSessionPropertiesProvider Member List

This is the complete list of members for MSessionPropertiesProvider, including all inherited members.
GetCommsPrefs(TInt &aSocketServHandle, TInt &aConnectionPtr)=0 | MSessionPropertiesProvider | [pure virtual]
GetSecureDialogPref() const=0 | MSessionPropertiesProvider | [pure virtual]
SetCommsPrefs(TInt aSocketServHandle, TInt aConnectionPtr)=0 | MSessionPropertiesProvider | [pure virtual]


CSubmissionDetails Class Reference

#include <CHttpTcpCli.h>

Collaboration diagram for CSubmissionDetails:

[legend]
List of all members.

Public Methods

CHttpTcpServerLocation * TakeOwnershipOfServerLocation ()
~CSubmissionDetails ()
CTxData & | SubmissionData () const
MTransportHndObs & | Observer () const
CHttpTcpServerLocation & | ServerLocation () const

Static Public Methods

CSubmissionDetails * | NewL (CHttpTcpServerLocation *aServerLocation, CTxData &aSubmitData, MTransportHndObs &aObserver)

Private Methods

CSubmissionDetails (CHttpTcpServerLocation *aServerLocation, CTxData &aSubmitData, MTransportHndObs &aObserver)

Private Attributes

CHttpTcpServerLocation * iServerLocation
CTxData & iSubmitData
MTransportHndObs & iObserver

Constructor & Destructor Documentation

CSubmissionDetails::~CSubmissionDetails ( )

CSubmissionDetails::CSubmissionDetails | ( | CHttpTcpServerLocation * | aServerLocation,
 |  | CTxData & | aSubmitData,
 |  | MTransportHndObs & | aObserver
 | ) | [private]

Member Function Documentation

CSubmissionDetails* CSubmissionDetails::NewL | ( | CHttpTcpServerLocation * | aServerLocation,
 |  | CTxData & | aSubmitData,
 |  | MTransportHndObs & | aObserver
 | ) | [static]

MTransportHndObs & CSubmissionDetails::Observer ( ) [inline]

Definition at line 307 of file CHttpTcpCli.h.

References iObserver.

CHttpTcpServerLocation & CSubmissionDetails::ServerLocation ( ) [inline]

Definition at line 297 of file CHttpTcpCli.h.

References iServerLocation.

CTxData & CSubmissionDetails::SubmissionData ( ) [inline]

Definition at line 302 of file CHttpTcpCli.h.

References iSubmitData.

CHttpTcpServerLocation* CSubmissionDetails::TakeOwnershipOfServerLocation ( )

Member Data Documentation

MTransportHndObs& CSubmissionDetails::iObserver [private]

Definition at line 294 of file CHttpTcpCli.h.

Referenced by Observer().

CHttpTcpServerLocation* CSubmissionDetails::iServerLocation [private]

Definition at line 290 of file CHttpTcpCli.h.

Referenced by ServerLocation().

CTxData& CSubmissionDetails::iSubmitData [private]

Definition at line 292 of file CHttpTcpCli.h.

Referenced by SubmissionData().

The documentation for this class was generated from the following file:
  • CHttpTcpCli.h


Member List

CSubmissionDetails Member List

This is the complete list of members for CSubmissionDetails, including all inherited members.
CSubmissionDetails(CHttpTcpServerLocation *aServerLocation, CTxData &aSubmitData, MTransportHndObs &aObserver) | CSubmissionDetails | [private]
iObserver | CSubmissionDetails | [private]
iServerLocation | CSubmissionDetails | [private]
iSubmitData | CSubmissionDetails | [private]
NewL(CHttpTcpServerLocation *aServerLocation, CTxData &aSubmitData, MTransportHndObs &aObserver) | CSubmissionDetails | [static]
Observer() const | CSubmissionDetails | [inline]
ServerLocation() const | CSubmissionDetails | [inline]
SubmissionData() const | CSubmissionDetails | [inline]
TakeOwnershipOfServerLocation() | CSubmissionDetails |
~CSubmissionDetails() | CSubmissionDetails |


CTCPClientFactory Class Reference

CTCPClientFactory is responsible for creating Transport Handlers (TH) sharing the same RSocketServ session and RConnection sub-session. More...

#include <CTcpClientFactory.h>

Collaboration diagram for CTCPClientFactory:

[legend]
List of all members.

Public Methods

~CTCPClientFactory ()
IMPORT_C MTextModeTransportHandler * | NewTransportHandlerL (MSecurityPolicy *aSecurityPolicy)
Called from the Protocol Handler to create THs.

Static Public Methods

IMPORT_C CTCPClientFactory * | NewL (MSessionPropertiesProvider &aSessionPropertiesProvider)
Called by Protocol Handler to create CTCPClientFactory.

Private Methods

CTCPClientFactory (MSessionPropertiesProvider &aSessionPropertiesProvider)
Normal Constructor, stores the supplied MCommsPrefsProvider reference.

void | ConstructL ()
Second phase constructor; does initialization of RSocketServ and RConnection sub-sessions.

Private Attributes

RSocketServ | iSocketServer
Socket server session shared by THs.

RConnection * | iConnection
Connection settings shared by THs.

TBool | iOwnsCommsSession
flag used by the destructor to check whether the factory owns the RSocketServ & RConnection sessions

MSessionPropertiesProvider & iSessionPropertiesProvider
Interface used for call-back.

Detailed Description

CTCPClientFactory is responsible for creating Transport Handlers (TH) sharing the same RSocketServ session and RConnection sub-session.

If the client wishes to specify its own Connection preferences, it creates an RSocketServ and RConnection and sets these as session properties. The Factory uses MSessionPropertiesProvider interface callback implemented by the protocol handler to fetch these session properties. If these properties are not set by the client, the factory creates and owns them. In this case, RConnection will be created with default preferences.

Definition at line 27 of file CTcpClientFactory.h.

Constructor & Destructor Documentation

CTCPClientFactory::~CTCPClientFactory ( )

CTCPClientFactory::CTCPClientFactory ( MSessionPropertiesProvider & aSessionPropertiesProvider ) [private]

Normal Constructor, stores the supplied MCommsPrefsProvider reference.

Member Function Documentation

void CTCPClientFactory::ConstructL ( ) [private]

Second phase constructor; does initialization of RSocketServ and RConnection sub-sessions.

IMPORT_C CTCPClientFactory* CTCPClientFactory::NewL ( MSessionPropertiesProvider & aSessionPropertiesProvider ) [static]

Called by Protocol Handler to create CTCPClientFactory.

IMPORT_C MTextModeTransportHandler* CTCPClientFactory::NewTransportHandlerL ( MSecurityPolicy * aSecurityPolicy )

Called from the Protocol Handler to create THs.

Member Data Documentation

RConnection* CTCPClientFactory::iConnection [private]

Connection settings shared by THs.

Definition at line 55 of file CTcpClientFactory.h.

TBool CTCPClientFactory::iOwnsCommsSession [private]

flag used by the destructor to check whether the factory owns the RSocketServ & RConnection sessions

Definition at line 58 of file CTcpClientFactory.h.

MSessionPropertiesProvider& CTCPClientFactory::iSessionPropertiesProvider [private]

Interface used for call-back.

Definition at line 61 of file CTcpClientFactory.h.

RSocketServ CTCPClientFactory::iSocketServer [private]

Socket server session shared by THs.

Definition at line 52 of file CTcpClientFactory.h.

The documentation for this class was generated from the following file:
  • CTcpClientFactory.h


Member List

CTCPClientFactory Member List

This is the complete list of members for CTCPClientFactory, including all inherited members.
ConstructL() | CTCPClientFactory | [private]
CTCPClientFactory(MSessionPropertiesProvider &aSessionPropertiesProvider) | CTCPClientFactory | [private]
iConnection | CTCPClientFactory | [private]
iOwnsCommsSession | CTCPClientFactory | [private]
iSessionPropertiesProvider | CTCPClientFactory | [private]
iSocketServer | CTCPClientFactory | [private]
NewL(MSessionPropertiesProvider &aSessionPropertiesProvider) | CTCPClientFactory | [static]
NewTransportHandlerL(MSecurityPolicy *aSecurityPolicy) | CTCPClientFactory |
~CTCPClientFactory() | CTCPClientFactory |


TTextHeaderUtils Class Reference

Utility class providing some text processing utilities useful when dealing with HTTP headers. More...

#include <TTextHeaderUtils.h>

List of all members.

Static Public Methods

IMPORT_C void | TrimWsLeft (TPtrC8 &aData)
Modify the supplied descriptor so that any (spaces or horizontal tabs) found at the left of the string is trimmed away.

IMPORT_C void | TrimWsRight (TPtrC8 &aData)
Modify the supplied descriptor so that any (spaces or horizontal tabs) found at the right of the string is trimmed away.

IMPORT_C void | TrimWsBothEnds (TPtrC8 &aData)
Trims at both the left and the right sides of the string (but not within it).

IMPORT_C TInt | ExtractNextTokenFromList (TPtrC8 &aBuffer, TPtrC8 &aToken, TChar aSeperator)
Extract a token from the head of the supplied buffer, which is assumed to be a token-list.

IMPORT_C TInt | ExtractNextTokenFromList (TPtrC8 &aBuffer, TPtrC8 &aToken, const TDesC8 &aSeperator)
Extract a token from the head of the supplied buffer.

IMPORT_C TInt | ExtractIntegerValueL (TPtrC8 &aBuffer, TInt &aIntVal, TBool aAllowNonWsTerminator)
Extract an integer from the head of the supplied buffer.

IMPORT_C TInt | ExtractQuotedStringL (TPtrC8 &aBuffer, TPtrC8 &aQuStrVal)
Extract a quoted string value from the head of the supplied buffer.

Detailed Description

Utility class providing some text processing utilities useful when dealing with HTTP headers.

This includes:

White-space trimming

Delimited list parsing

Date parsing

Integer parsing

Definition at line 29 of file TTextHeaderUtils.h.

Member Function Documentation

IMPORT_C TInt TTextHeaderUtils::ExtractIntegerValueL | ( | TPtrC8 & | aBuffer,
 |  | TInt & | aIntVal,
 |  | TBool | aAllowNonWsTerminator
 | ) | [static]

Extract an integer from the head of the supplied buffer.

Any WS surrounding the integer is stripped out. The supplied flag indicates if anything other than WS (or EOL) is allowed to mark the end of the integer. Returns the number of characters consumed from the buffer, which contracts accordingly.

IMPORT_C TInt TTextHeaderUtils::ExtractNextTokenFromList | ( | TPtrC8 & | aBuffer,
 |  | TPtrC8 & | aToken,
 |  | const TDesC8 & | aSeperator
 | ) | [static]

Extract a token from the head of the supplied buffer.

The buffer is assumed to be a list of tokens separated by ANY of the characters in the separator descriptor.

IMPORT_C TInt TTextHeaderUtils::ExtractNextTokenFromList | ( | TPtrC8 & | aBuffer,
 |  | TPtrC8 & | aToken,
 |  | TChar | aSeperator
 | ) | [static]

Extract a token from the head of the supplied buffer, which is assumed to be a token-list.

Any WS surrounding the token is stripped out. Returns the number of characters consumed from the buffer, which contracts accordingly.

IMPORT_C TInt TTextHeaderUtils::ExtractQuotedStringL | ( | TPtrC8 & | aBuffer,
 |  | TPtrC8 & | aQuStrVal
 | ) | [static]

Extract a quoted string value from the head of the supplied buffer.

Anything outside the quotes is discarded; the quotes themselves are not returned.

IMPORT_C void TTextHeaderUtils::TrimWsBothEnds ( TPtrC8 & aData ) [static]

Trims at both the left and the right sides of the string (but not within it).

IMPORT_C void TTextHeaderUtils::TrimWsLeft ( TPtrC8 & aData ) [static]

Modify the supplied descriptor so that any (spaces or horizontal tabs) found at the left of the string is trimmed away.

IMPORT_C void TTextHeaderUtils::TrimWsRight ( TPtrC8 & aData ) [static]

Modify the supplied descriptor so that any (spaces or horizontal tabs) found at the right of the string is trimmed away.

The documentation for this class was generated from the following file:
  • TTextHeaderUtils.h


Member List

TTextHeaderUtils Member List

This is the complete list of members for TTextHeaderUtils, including all inherited members.
ExtractIntegerValueL(TPtrC8 &aBuffer, TInt &aIntVal, TBool aAllowNonWsTerminator) | TTextHeaderUtils | [static]
ExtractNextTokenFromList(TPtrC8 &aBuffer, TPtrC8 &aToken, TChar aSeperator) | TTextHeaderUtils | [static]
ExtractNextTokenFromList(TPtrC8 &aBuffer, TPtrC8 &aToken, const TDesC8 &aSeperator) | TTextHeaderUtils | [static]
ExtractQuotedStringL(TPtrC8 &aBuffer, TPtrC8 &aQuStrVal) | TTextHeaderUtils | [static]
TrimWsBothEnds(TPtrC8 &aData) | TTextHeaderUtils | [static]
TrimWsLeft(TPtrC8 &aData) | TTextHeaderUtils | [static]
TrimWsRight(TPtrC8 &aData) | TTextHeaderUtils | [static]


CTextModeDefaultCodec Class Reference

A default codec that will be instantiated as a delegate codec to handle any unrecognised header field by copying directly between raw data or string header field values. More...

#include <CTextModeHeaderCodec.h>

Inheritance diagram for CTextModeDefaultCodec:

[legend]
Collaboration diagram for CTextModeDefaultCodec:

[legend]
List of all members.

Public Methods

virtual | ~CTextModeDefaultCodec ()
Destructor - cleans up and releases resources to the system.

virtual TBool | CanEncode (RStringF aHeaderField) const
Can this codec encode the specified header field? Always returns true because it will handle anything by design!

virtual TBool | CanDecode (RStringF aHeaderField) const
Can this codec decode the specified header field? Always returns true because it will handle anything by design!

virtual CHeaderCodec * | FindDelegateCodecL (RStringF aHeaderField) const
Find a delegate codec...

Static Public Methods

CTextModeDefaultCodec * | NewL (RStringPool aStrPool)
Factory construction - creates a new CTextModeHeaderCodec.

Protected Methods

CTextModeDefaultCodec (RStringPool aStrPool)
Constructor - stores a copy of the string pool handle..

void | ConstructL ()
Second phase construction.

Private Methods

CTextModeDefaultCodec ()
Default constructor - not needed.

Private Attributes

RStringPool | iStrPool
A handle to the HTTP string pool.

Detailed Description

A default codec that will be instantiated as a delegate codec to handle any unrecognised header field by copying directly between raw data or string header field values.

Definition at line 395 of file CTextModeHeaderCodec.h.

Constructor & Destructor Documentation

virtual CTextModeDefaultCodec::~CTextModeDefaultCodec ( ) [virtual]

Destructor - cleans up and releases resources to the system.

CTextModeDefaultCodec::CTextModeDefaultCodec ( RStringPool aStrPool ) [protected]

Constructor - stores a copy of the string pool handle..

CTextModeDefaultCodec::CTextModeDefaultCodec ( ) [private]

Default constructor - not needed.

Member Function Documentation

virtual TBool CTextModeDefaultCodec::CanDecode ( RStringF aHeaderField ) const [virtual]

Can this codec decode the specified header field? Always returns true because it will handle anything by design!

Implements CHeaderCodec.

virtual TBool CTextModeDefaultCodec::CanEncode ( RStringF aHeaderField ) const [virtual]

Can this codec encode the specified header field? Always returns true because it will handle anything by design!

Implements CHeaderCodec.

void CTextModeDefaultCodec::ConstructL ( ) [protected]

Second phase construction.

Does any allocation needed.

Reimplemented from CHeaderCodec.

virtual CHeaderCodec* CTextModeDefaultCodec::FindDelegateCodecL ( RStringF aHeaderField ) const [virtual]

Find a delegate codec...

always returns NULL, since this codec handles anything by design.

Implements CHeaderCodec.

CTextModeDefaultCodec* CTextModeDefaultCodec::NewL ( RStringPool aStrPool ) [static]

Factory construction - creates a new CTextModeHeaderCodec.

A string pool handle is supplied for convenience.

Member Data Documentation

RStringPool CTextModeDefaultCodec::iStrPool [private]

A handle to the HTTP string pool.

Definition at line 452 of file CTextModeHeaderCodec.h.

The documentation for this class was generated from the following file:
  • CTextModeHeaderCodec.h


Member List

CTextModeDefaultCodec Member List

This is the complete list of members for CTextModeDefaultCodec, including all inherited members.
CanDecode(RStringF aHeaderField) const | CTextModeDefaultCodec | [virtual]
CanEncode(RStringF aHeaderField) const | CTextModeDefaultCodec | [virtual]
CHeaderCodec() | CHeaderCodec | [protected]
ConstructL() | CTextModeDefaultCodec | [protected]
CTextModeDefaultCodec(RStringPool aStrPool) | CTextModeDefaultCodec | [protected]
CTextModeDefaultCodec() | CTextModeDefaultCodec | [private]
DecodeHeaderL(RHeaderField &aHeader) const | CHeaderCodec |
EncodeHeaderL(RHeaderField &aHeader) const | CHeaderCodec |
FindDelegateCodecL(RStringF aHeaderField) const | CTextModeDefaultCodec | [virtual]
iReader | CHeaderCodec | [protected]
iStrPool | CTextModeDefaultCodec | [private]
iWriter | CHeaderCodec | [protected]
NewL(RStringPool aStrPool) | CTextModeDefaultCodec | [static]
~CHeaderCodec() | CHeaderCodec | [virtual]
~CTextModeDefaultCodec() | CTextModeDefaultCodec | [virtual]


CTextModeDefHdrReader Class Reference

A default header reader that just copies received raw data directly into single part string header fields. More...

#include <CTextModeHeaderCodec.h>

Inheritance diagram for CTextModeDefHdrReader:

[legend]
Collaboration diagram for CTextModeDefHdrReader:

[legend]
List of all members.

Public Methods

virtual | ~CTextModeDefHdrReader ()
Destructor - cleans up and release resources to the system.

virtual void | DecodeHeaderL (RHeaderField &aHeader)
Provides default behaviour for fields which are unknown and thus fall through to this codec.

Static Public Methods

CTextModeDefHdrReader * | NewL (RStringPool aStrPool)
Factory construction - creates a new CTextModeDefHdrWriter.

CTextModeDefHdrReader * | NewLC (RStringPool aStrPool)
Factory construction - creates a new CTextModeDefHdrWriter, leaving the new instance on the cleanup stack.

Protected Methods

CTextModeDefHdrReader (RStringPool aStrPool)
Constructor - stores a copy of the string pool handle.

Private Attributes

RStringPool | iStrPool
The HTTP String Pool.

RStringF | iFieldName
Holder for the field name being read.

Detailed Description

A default header reader that just copies received raw data directly into single part string header fields.

NB would this be better placed in the Codec base class, by making EncodeL and DecodeL non-pure virtual? Could therefore eliminate these three 'default' classes.

Definition at line 510 of file CTextModeHeaderCodec.h.

Constructor & Destructor Documentation

virtual CTextModeDefHdrReader::~CTextModeDefHdrReader ( ) [virtual]

Destructor - cleans up and release resources to the system.

CTextModeDefHdrReader::CTextModeDefHdrReader ( RStringPool aStrPool ) [protected]

Constructor - stores a copy of the string pool handle.

Member Function Documentation

virtual void CTextModeDefHdrReader::DecodeHeaderL ( RHeaderField & aHeader ) [virtual]

Provides default behaviour for fields which are unknown and thus fall through to this codec.

It does a default conversion that consists of copying the raw data into the header fields first part, as a string.

Implements CHeaderReader.

CTextModeDefHdrReader* CTextModeDefHdrReader::NewL ( RStringPool aStrPool ) [static]

Factory construction - creates a new CTextModeDefHdrWriter.

A string pool handle is supplied for convenience

CTextModeDefHdrReader* CTextModeDefHdrReader::NewLC ( RStringPool aStrPool ) [static]

Factory construction - creates a new CTextModeDefHdrWriter, leaving the new instance on the cleanup stack.

A string pool handle is supplied for convenience

Member Data Documentation

RStringF CTextModeDefHdrReader::iFieldName [private]

Holder for the field name being read.

Definition at line 555 of file CTextModeHeaderCodec.h.

RStringPool CTextModeDefHdrReader::iStrPool [private]

The HTTP String Pool.

Definition at line 550 of file CTextModeHeaderCodec.h.

The documentation for this class was generated from the following file:
  • CTextModeHeaderCodec.h


Member List

CTextModeDefHdrReader Member List

This is the complete list of members for CTextModeDefHdrReader, including all inherited members.
CHeaderReader() | CHeaderReader | [protected]
ConstructL() | CHeaderReader | [protected]
CTextModeDefHdrReader(RStringPool aStrPool) | CTextModeDefHdrReader | [protected]
DecodeHeaderL(RHeaderField &aHeader) | CTextModeDefHdrReader | [virtual]
iFieldName | CTextModeDefHdrReader | [private]
iStrPool | CTextModeDefHdrReader | [private]
NewL(RStringPool aStrPool) | CTextModeDefHdrReader | [static]
NewLC(RStringPool aStrPool) | CTextModeDefHdrReader | [static]
~CHeaderReader() | CHeaderReader | [virtual]
~CTextModeDefHdrReader() | CTextModeDefHdrReader | [virtual]


CTextModeDefHdrWriter Class Reference

A default header writer that just copies single part string header fields directly into raw data. More...

#include <CTextModeHeaderCodec.h>

Inheritance diagram for CTextModeDefHdrWriter:

[legend]
Collaboration diagram for CTextModeDefHdrWriter:

[legend]
List of all members.

Public Methods

virtual | ~CTextModeDefHdrWriter ()
Destructor - cleans up and release resources to the system.

virtual void | EncodeHeaderL (RHeaderField &aHeader)
Provides default behavior for fields which are unknown and thus fall through to this codec.

Static Public Methods

CTextModeDefHdrWriter * | NewL (RStringPool aStrPool)
Factory construction - creates a new CTextModeDefHdrWriter.

CTextModeDefHdrWriter * | NewLC (RStringPool aStrPool)
Factory construction - creates a new CTextModeDefHdrWriter, leaving the new instance on the cleanup stack.

Protected Methods

CTextModeDefHdrWriter (RStringPool aStrPool)
Constructor - stores a copy of the string pool handle.

Private Attributes

RStringPool | iStrPool
The HTTP String Pool.

Detailed Description

A default header writer that just copies single part string header fields directly into raw data.

NB would this be better placed in the Codec base class, by making EncodeL and DecodeL non-pure virtual? Could therefore eliminate these three 'default' classes.

Definition at line 460 of file CTextModeHeaderCodec.h.

Constructor & Destructor Documentation

virtual CTextModeDefHdrWriter::~CTextModeDefHdrWriter ( ) [virtual]

Destructor - cleans up and release resources to the system.

CTextModeDefHdrWriter::CTextModeDefHdrWriter ( RStringPool aStrPool ) [protected]

Constructor - stores a copy of the string pool handle.

Member Function Documentation

virtual void CTextModeDefHdrWriter::EncodeHeaderL ( RHeaderField & aHeader ) [virtual]

Provides default behavior for fields which are unknown and thus fall through to this codec.

It does a default conversion that consists of copying the first header part (required to be a string value?) into the raw data.

Implements CHeaderWriter.

CTextModeDefHdrWriter* CTextModeDefHdrWriter::NewL ( RStringPool aStrPool ) [static]

Factory construction - creates a new CTextModeDefHdrWriter.

A string pool handle is supplied for convenience

CTextModeDefHdrWriter* CTextModeDefHdrWriter::NewLC ( RStringPool aStrPool ) [static]

Factory construction - creates a new CTextModeDefHdrWriter, leaving the new instance on the cleanup stack.

A string pool handle is supplied for convenience

Member Data Documentation

RStringPool CTextModeDefHdrWriter::iStrPool [private]

The HTTP String Pool.

Definition at line 501 of file CTextModeHeaderCodec.h.

The documentation for this class was generated from the following file:
  • CTextModeHeaderCodec.h


Member List

CTextModeDefHdrWriter Member List

This is the complete list of members for CTextModeDefHdrWriter, including all inherited members.
CHeaderWriter() | CHeaderWriter | [protected]
ConstructL() | CHeaderWriter | [protected]
CTextModeDefHdrWriter(RStringPool aStrPool) | CTextModeDefHdrWriter | [protected]
EncodeHeaderL(RHeaderField &aHeader) | CTextModeDefHdrWriter | [virtual]
iStrPool | CTextModeDefHdrWriter | [private]
NewL(RStringPool aStrPool) | CTextModeDefHdrWriter | [static]
NewLC(RStringPool aStrPool) | CTextModeDefHdrWriter | [static]
~CHeaderWriter() | CHeaderWriter | [virtual]
~CTextModeDefHdrWriter() | CTextModeDefHdrWriter | [virtual]


CTextModeHeaderCodec Class Reference

An HTTP header codec specialized for the plain-text encoding of HTTP headers used by origin servers. More...

#include <CTextModeHeaderCodec.h>

Inheritance diagram for CTextModeHeaderCodec:

[legend]
Collaboration diagram for CTextModeHeaderCodec:

[legend]
List of all members.

Public Methods

virtual | ~CTextModeHeaderCodec ()
Destructor - cleans up and releases resources to the system.

virtual TBool | CanEncode (RStringF aHeaderField) const
Can this codec encode the specified header field?

virtual TBool | CanDecode (RStringF aHeaderField) const
Can this codec decode the specified header field?

virtual CHeaderCodec * | FindDelegateCodecL (RStringF aHeaderField) const
Locate an alternative codec that can handle the specified header field, in the event that this one can't.

Static Public Methods

CTextModeHeaderCodec * | NewL (RStringPool aStrPool)
Factory construction - creates a new CTextModeHeaderCodec.

Protected Methods

CTextModeHeaderCodec (RStringPool aStrPool)
Constructor - stores a copy of the string pool handle.

void | ConstructL ()
Second phase construction.

Private Methods

CTextModeHeaderCodec ()
Default constructor - not needed.

Private Attributes

RStringPool | iStrPool
A handle to the HTTP string pool.

Detailed Description

An HTTP header codec specialized for the plain-text encoding of HTTP headers used by origin servers.

Each instance of the text-mode header codec is associated with a Text-Mode HTTP Protocol Handler. It provides on-demand encoding/decoding of HTTP header data, between the generic format used by clients/filters and plain-text format defined in RFC2616.

The CTextModeHeaderCodec has an associated instance of each of CTextModeHeaderWriter and CTextModeHeaderReader. It delegates the actual encoding and decoding to them.

The text mode codec by default provides extensibility by choosing the CTextModeDefaultCodec for headers it can't handle.

See also:
CTextModeHttpProt , CTextModeHeaderReader , CTextModeHeaderWriter , CTextModeDefaultCodec

Definition at line 35 of file CTextModeHeaderCodec.h.

Constructor & Destructor Documentation

virtual CTextModeHeaderCodec::~CTextModeHeaderCodec ( ) [virtual]

Destructor - cleans up and releases resources to the system.

CTextModeHeaderCodec::CTextModeHeaderCodec ( RStringPool aStrPool ) [protected]

Constructor - stores a copy of the string pool handle.

CTextModeHeaderCodec::CTextModeHeaderCodec ( ) [private]

Default constructor - not needed.

Member Function Documentation

virtual TBool CTextModeHeaderCodec::CanDecode ( RStringF aHeaderField ) const [virtual]

Can this codec decode the specified header field?

Implements CHeaderCodec.

virtual TBool CTextModeHeaderCodec::CanEncode ( RStringF aHeaderField ) const [virtual]

Can this codec encode the specified header field?

Implements CHeaderCodec.

void CTextModeHeaderCodec::ConstructL ( ) [protected]

Second phase construction.

Does any allocation needed.

Reimplemented from CHeaderCodec.

virtual CHeaderCodec* CTextModeHeaderCodec::FindDelegateCodecL ( RStringF aHeaderField ) const [virtual]

Locate an alternative codec that can handle the specified header field, in the event that this one can't.

Implements CHeaderCodec.

CTextModeHeaderCodec* CTextModeHeaderCodec::NewL ( RStringPool aStrPool ) [static]

Factory construction - creates a new CTextModeHeaderCodec.

A string pool handle is supplied for convenience.

Member Data Documentation

RStringPool CTextModeHeaderCodec::iStrPool [private]

A handle to the HTTP string pool.

Definition at line 90 of file CTextModeHeaderCodec.h.

The documentation for this class was generated from the following file:
  • CTextModeHeaderCodec.h


Member List

CTextModeHeaderCodec Member List

This is the complete list of members for CTextModeHeaderCodec, including all inherited members.
CanDecode(RStringF aHeaderField) const | CTextModeHeaderCodec | [virtual]
CanEncode(RStringF aHeaderField) const | CTextModeHeaderCodec | [virtual]
CHeaderCodec() | CHeaderCodec | [protected]
ConstructL() | CTextModeHeaderCodec | [protected]
CTextModeHeaderCodec(RStringPool aStrPool) | CTextModeHeaderCodec | [protected]
CTextModeHeaderCodec() | CTextModeHeaderCodec | [private]
DecodeHeaderL(RHeaderField &aHeader) const | CHeaderCodec |
EncodeHeaderL(RHeaderField &aHeader) const | CHeaderCodec |
FindDelegateCodecL(RStringF aHeaderField) const | CTextModeHeaderCodec | [virtual]
iReader | CHeaderCodec | [protected]
iStrPool | CTextModeHeaderCodec | [private]
iWriter | CHeaderCodec | [protected]
NewL(RStringPool aStrPool) | CTextModeHeaderCodec | [static]
~CHeaderCodec() | CHeaderCodec | [virtual]
~CTextModeHeaderCodec() | CTextModeHeaderCodec | [virtual]


CTextModeHeaderReader Class Reference

CHTTPHeaderReader is used by its owning codec to do conversion of header data from the plain-text raw representation to the generic format (of parts and parameters). More...

#include <CTextModeHeaderCodec.h>

Inheritance diagram for CTextModeHeaderReader:

[legend]
Collaboration diagram for CTextModeHeaderReader:

[legend]
List of all members.

Public Methods

virtual | ~CTextModeHeaderReader ()
Destructor - cleans up and release resources to the system.

virtual void | DecodeHeaderL (RHeaderField &aHeader)
Converts the supplied header field to the generic format from the plain-text raw format.

Static Public Methods

CTextModeHeaderReader * | NewL (RStringPool aStrPool)
Factory construction - creates a new CTextModeHeaderReader.

CTextModeHeaderReader * | NewLC (RStringPool aStrPool)
Factory construction - creates a new CTextModeHeaderReader, leaving the new instance on the cleanup stack.

Protected Methods

CTextModeHeaderReader (RStringPool aStrPool)
Constructor.

Private Methods

void | DoCacheControlL (RHeaderField &aHeader) const
Convert the Cache-Control header field from raw to generic form.

void | DoConnectionL (RHeaderField &aHeader) const
Convert the Connection header field from raw to generic form.

void | DoContentTypeL (RHeaderField &aHeader) const
Convert the Content-Type header field from raw to generic form.

void | DoDateL (RHeaderField &aHeader) const
Convert the Date header field from raw to generic form.

void | DoTransferEncodingL (RHeaderField &aHeader) const
Convert the Transfer-Encoding header field from raw to generic form.

void | DoWWWAuthenticateL (RHeaderField &aHeader) const
Convert the WWW-Authenticate header field from raw to generic form.

void | DecodeSetCookieL (RHeaderField &aHeader) const
Convert the Set-Cookie header field from raw to generic form.

void | DecodeOneCookieL (RHeaderField &aHeader, const TDesC8 &aCookieData, TInt aCookieNumber) const
void | SetCookieNameAndValueL (CHeaderFieldPart &aCookie, const TDesC8 &aNameValue) const
void | SetCookieParamL (CHeaderFieldPart &aCookie, const TDesC8 &aCookieParam) const
void | DecodeCacheControlL (RHeaderField &aHeader) const
void | DecodeAgeL (RHeaderField &aHeader) const
void | DecodeETagL (RHeaderField &aHeader) const
void | DecodeGenericL (RHeaderField &aHeader, const TDesC8 &aSeparator) const
Splits generic type headers into strings based on position of the seprarator char, given as list of separators.

void | DecodeGenericNumberL (RHeaderField &aHeader) const
Decodes a generic numerical header.

CHeaderFieldPart * | SetNewIntegerPartL (RHeaderField &aHeader, TInt aPartIndex, TInt aValue) const
Set in the specified header field a new part containing the supplied integer data.

CHeaderFieldPart * | SetNewDatePartL (RHeaderField &aHeader, TInt aPartIndex, TDateTime &date) const
Set in the specified header field a new part containing the supplied date/time.

CHeaderFieldPart * | SetNewFStringPartL (RHeaderField &aHeader, TInt aPartIndex, TPtrC8 aValue) const
Set in the specified header field a new part containing the supplied string data.

CHeaderFieldPart * | SetNewStringPartL (RHeaderField &aHeader, TInt aPartIndex, TPtrC8 aValue) const
CHeaderFieldPart * | SetNewPartL (RHeaderField &aHeader, TInt aPartIndex, THTTPHdrVal &aValue) const
Helper method for SetNewIntegerPartL(), SetNewDatePartL() and SetNewFStringPartL(), based on a supplied general HTTP header value.

CHeaderFieldParam * | SetNewFStringParamL (CHeaderFieldPart &aHeaderPart, TPtrC8 aParamName, TPtrC8 aParamValue) const
Set in the specified header field part a new parameter with the supplied name and string value.

CHeaderFieldParam * | SetNewStringParamL (CHeaderFieldPart &aHeaderPart, TPtrC8 aParamName, TPtrC8 aParamValue) const

Private Attributes

RStringPool | iStrPool
Handle to the HTTP String pool.

RStringF | iFieldName
Holder for the field name being read.

Detailed Description

CHTTPHeaderReader is used by its owning codec to do conversion of header data from the plain-text raw representation to the generic format (of parts and parameters).

Definition at line 242 of file CTextModeHeaderCodec.h.

Constructor & Destructor Documentation

virtual CTextModeHeaderReader::~CTextModeHeaderReader ( ) [virtual]

Destructor - cleans up and release resources to the system.

CTextModeHeaderReader::CTextModeHeaderReader ( RStringPool aStrPool ) [protected]

Constructor.

Copies the supplied string pool handle.

Member Function Documentation

void CTextModeHeaderReader::DecodeAgeL ( RHeaderField & aHeader ) const [private]

void CTextModeHeaderReader::DecodeCacheControlL ( RHeaderField & aHeader ) const [private]

void CTextModeHeaderReader::DecodeETagL ( RHeaderField & aHeader ) const [private]

void CTextModeHeaderReader::DecodeGenericL | ( | RHeaderField & | aHeader,
 |  | const TDesC8 & | aSeparator
 | ) | const [private]

Splits generic type headers into strings based on position of the seprarator char, given as list of separators.

void CTextModeHeaderReader::DecodeGenericNumberL ( RHeaderField & aHeader ) const [private]

Decodes a generic numerical header.

That is a header with one part that is a number

virtual void CTextModeHeaderReader::DecodeHeaderL ( RHeaderField & aHeader ) [virtual]

Converts the supplied header field to the generic format from the plain-text raw format.

The header parts and parameters comprising the generic format are stored in the header field itself.

Implements CHeaderReader.

void CTextModeHeaderReader::DecodeOneCookieL | ( | RHeaderField & | aHeader,
 |  | const TDesC8 & | aCookieData,
 |  | TInt | aCookieNumber
 | ) | const [private]

void CTextModeHeaderReader::DecodeSetCookieL ( RHeaderField & aHeader ) const [private]

Convert the Set-Cookie header field from raw to generic form.

void CTextModeHeaderReader::DoCacheControlL ( RHeaderField & aHeader ) const [private]

Convert the Cache-Control header field from raw to generic form.

void CTextModeHeaderReader::DoConnectionL ( RHeaderField & aHeader ) const [private]

Convert the Connection header field from raw to generic form.

void CTextModeHeaderReader::DoContentTypeL ( RHeaderField & aHeader ) const [private]

Convert the Content-Type header field from raw to generic form.

void CTextModeHeaderReader::DoDateL ( RHeaderField & aHeader ) const [private]

Convert the Date header field from raw to generic form.

void CTextModeHeaderReader::DoTransferEncodingL ( RHeaderField & aHeader ) const [private]

Convert the Transfer-Encoding header field from raw to generic form.

void CTextModeHeaderReader::DoWWWAuthenticateL ( RHeaderField & aHeader ) const [private]

Convert the WWW-Authenticate header field from raw to generic form.

CTextModeHeaderReader* CTextModeHeaderReader::NewL ( RStringPool aStrPool ) [static]

Factory construction - creates a new CTextModeHeaderReader.

A string pool handle is supplied for convenience

CTextModeHeaderReader* CTextModeHeaderReader::NewLC ( RStringPool aStrPool ) [static]

Factory construction - creates a new CTextModeHeaderReader, leaving the new instance on the cleanup stack.

A string pool handle is supplied for convenience

void CTextModeHeaderReader::SetCookieNameAndValueL | ( | CHeaderFieldPart & | aCookie,
 |  | const TDesC8 & | aNameValue
 | ) | const [private]

void CTextModeHeaderReader::SetCookieParamL | ( | CHeaderFieldPart & | aCookie,
 |  | const TDesC8 & | aCookieParam
 | ) | const [private]

CHeaderFieldPart* CTextModeHeaderReader::SetNewDatePartL | ( | RHeaderField & | aHeader,
 |  | TInt | aPartIndex,
 |  | TDateTime & | date
 | ) | const [private]

Set in the specified header field a new part containing the supplied date/time.

This will override any raw data or any existing part at the stated index, Returns the new part that is created.

CHeaderFieldParam* CTextModeHeaderReader::SetNewFStringParamL | ( | CHeaderFieldPart & | aHeaderPart,
 |  | TPtrC8 | aParamName,
 |  | TPtrC8 | aParamValue
 | ) | const [private]

Set in the specified header field part a new parameter with the supplied name and string value.

Returns the new parameter created.

CHeaderFieldPart* CTextModeHeaderReader::SetNewFStringPartL | ( | RHeaderField & | aHeader,
 |  | TInt | aPartIndex,
 |  | TPtrC8 | aValue
 | ) | const [private]

Set in the specified header field a new part containing the supplied string data.

This will override any raw data or any existing part at the stated index, Returns the new part that is created.

CHeaderFieldPart* CTextModeHeaderReader::SetNewIntegerPartL | ( | RHeaderField & | aHeader,
 |  | TInt | aPartIndex,
 |  | TInt | aValue
 | ) | const [private]

Set in the specified header field a new part containing the supplied integer data.

This will override any raw data or any existing part at the stated index. Returns the new part that is created.

CHeaderFieldPart* CTextModeHeaderReader::SetNewPartL | ( | RHeaderField & | aHeader,
 |  | TInt | aPartIndex,
 |  | THTTPHdrVal & | aValue
 | ) | const [private]

Helper method for SetNewIntegerPartL(), SetNewDatePartL() and SetNewFStringPartL(), based on a supplied general HTTP header value.

Returns the new part that is created.

CHeaderFieldParam* CTextModeHeaderReader::SetNewStringParamL | ( | CHeaderFieldPart & | aHeaderPart,
 |  | TPtrC8 | aParamName,
 |  | TPtrC8 | aParamValue
 | ) | const [private]

CHeaderFieldPart* CTextModeHeaderReader::SetNewStringPartL | ( | RHeaderField & | aHeader,
 |  | TInt | aPartIndex,
 |  | TPtrC8 | aValue
 | ) | const [private]

Member Data Documentation

RStringF CTextModeHeaderReader::iFieldName [private]

Holder for the field name being read.

Definition at line 384 of file CTextModeHeaderCodec.h.

RStringPool CTextModeHeaderReader::iStrPool [private]

Handle to the HTTP String pool.

Definition at line 379 of file CTextModeHeaderCodec.h.

The documentation for this class was generated from the following file:
  • CTextModeHeaderCodec.h


Member List

CTextModeHeaderReader Member List

This is the complete list of members for CTextModeHeaderReader, including all inherited members.
CHeaderReader() | CHeaderReader | [protected]
ConstructL() | CHeaderReader | [protected]
CTextModeHeaderReader(RStringPool aStrPool) | CTextModeHeaderReader | [protected]
DecodeAgeL(RHeaderField &aHeader) const | CTextModeHeaderReader | [private]
DecodeCacheControlL(RHeaderField &aHeader) const | CTextModeHeaderReader | [private]
DecodeETagL(RHeaderField &aHeader) const | CTextModeHeaderReader | [private]
DecodeGenericL(RHeaderField &aHeader, const TDesC8 &aSeparator) const | CTextModeHeaderReader | [private]
DecodeGenericNumberL(RHeaderField &aHeader) const | CTextModeHeaderReader | [private]
DecodeHeaderL(RHeaderField &aHeader) | CTextModeHeaderReader | [virtual]
DecodeOneCookieL(RHeaderField &aHeader, const TDesC8 &aCookieData, TInt aCookieNumber) const | CTextModeHeaderReader | [private]
DecodeSetCookieL(RHeaderField &aHeader) const | CTextModeHeaderReader | [private]
DoCacheControlL(RHeaderField &aHeader) const | CTextModeHeaderReader | [private]
DoConnectionL(RHeaderField &aHeader) const | CTextModeHeaderReader | [private]
DoContentTypeL(RHeaderField &aHeader) const | CTextModeHeaderReader | [private]
DoDateL(RHeaderField &aHeader) const | CTextModeHeaderReader | [private]
DoTransferEncodingL(RHeaderField &aHeader) const | CTextModeHeaderReader | [private]
DoWWWAuthenticateL(RHeaderField &aHeader) const | CTextModeHeaderReader | [private]
iFieldName | CTextModeHeaderReader | [private]
iStrPool | CTextModeHeaderReader | [private]
NewL(RStringPool aStrPool) | CTextModeHeaderReader | [static]
NewLC(RStringPool aStrPool) | CTextModeHeaderReader | [static]
SetCookieNameAndValueL(CHeaderFieldPart &aCookie, const TDesC8 &aNameValue) const | CTextModeHeaderReader | [private]
SetCookieParamL(CHeaderFieldPart &aCookie, const TDesC8 &aCookieParam) const | CTextModeHeaderReader | [private]
SetNewDatePartL(RHeaderField &aHeader, TInt aPartIndex, TDateTime &date) const | CTextModeHeaderReader | [private]
SetNewFStringParamL(CHeaderFieldPart &aHeaderPart, TPtrC8 aParamName, TPtrC8 aParamValue) const | CTextModeHeaderReader | [private]
SetNewFStringPartL(RHeaderField &aHeader, TInt aPartIndex, TPtrC8 aValue) const | CTextModeHeaderReader | [private]
SetNewIntegerPartL(RHeaderField &aHeader, TInt aPartIndex, TInt aValue) const | CTextModeHeaderReader | [private]
SetNewPartL(RHeaderField &aHeader, TInt aPartIndex, THTTPHdrVal &aValue) const | CTextModeHeaderReader | [private]
SetNewStringParamL(CHeaderFieldPart &aHeaderPart, TPtrC8 aParamName, TPtrC8 aParamValue) const | CTextModeHeaderReader | [private]
SetNewStringPartL(RHeaderField &aHeader, TInt aPartIndex, TPtrC8 aValue) const | CTextModeHeaderReader | [private]
~CHeaderReader() | CHeaderReader | [virtual]
~CTextModeHeaderReader() | CTextModeHeaderReader | [virtual]


CTextModeHeadersFilter Class Reference

Acts as a filter above the HTTP Protocol Handler. More...

#include <ctextmodeheadersfilter.h>

Inheritance diagram for CTextModeHeadersFilter:

[legend]
Collaboration diagram for CTextModeHeadersFilter:

[legend]
List of all members.

Public Methods

~CTextModeHeadersFilter ()
From MHTTPFilter
virtual void | MHFRunL (RHTTPTransaction aTransaction, const THTTPEvent &aEvent)
virtual void | MHFSessionRunL (const THTTPSessionEvent &aEvent)
See also:
MHTTPFilterBase::MHFSessionRunL

virtual TInt | MHFRunError (TInt aError, RHTTPTransaction aTransaction, const THTTPEvent &aEvent)
See also:
MHTTPFilterBase::MHFRunError

virtual TInt | MHFSessionRunError (TInt aError, const THTTPSessionEvent &aEvent)
See also:
MHTTPFilterBase::MHFSessionRunError

virtual void | MHFUnload (RHTTPSession aSession, THTTPFilterHandle aHandle)
See also:
MHTTPFilter::MHFUnload

virtual void | MHFLoad (RHTTPSession aSession, THTTPFilterHandle aHandle)
See also:
MHTTPFilter::MHFLoad

Static Public Methods

CTextModeHeadersFilter * | NewL (RHTTPSession aSession)

Private Methods

CTextModeHeadersFilter ()
void | ConstructL (RHTTPSession aSession)
void | AlterRequestHeadersL (RHTTPTransaction aTransaction)
void | AlterResponseHeadersL (RHTTPTransaction aTransaction)
void | EnsureContentTypePresentL (RHTTPTransaction aTransaction)
void | EnsurePathExistsL (RHTTPTransaction aTransaction)
void | EnsureContentLengthL (RHTTPTransaction aTransaction)
void | EnsureNoEndToEndHeadersInConnectionHeaderL (RHTTPTransaction aTransaction)
TBool | IsHopByHopHeader (RStringF aHeaderName)
void | AddExpect100ContinueL (RHTTPTransaction aTransaction)
void | AddSessionHeadersL (RHTTPHeaders aTransactionHeaders, RHTTPHeaders aSessionHeaders)

Private Attributes

TInt | iLoadCount
A count to make sure we delete at the right time.

RStringPool | iStringPool
RHTTPSession iSession

Detailed Description

Acts as a filter above the HTTP Protocol Handler.

This filter alters request and responses where necessary to ensure complaince with various sections of RFC 2616

Definition at line 21 of file ctextmodeheadersfilter.h.

Constructor & Destructor Documentation

CTextModeHeadersFilter::~CTextModeHeadersFilter ( )

CTextModeHeadersFilter::CTextModeHeadersFilter ( ) [private]

Member Function Documentation

void CTextModeHeadersFilter::AddExpect100ContinueL ( RHTTPTransaction aTransaction ) [private]

void CTextModeHeadersFilter::AddSessionHeadersL | ( | RHTTPHeaders | aTransactionHeaders,
 |  | RHTTPHeaders | aSessionHeaders
 | ) | [private]

void CTextModeHeadersFilter::AlterRequestHeadersL ( RHTTPTransaction aTransaction ) [private]

void CTextModeHeadersFilter::AlterResponseHeadersL ( RHTTPTransaction aTransaction ) [private]

void CTextModeHeadersFilter::ConstructL ( RHTTPSession aSession ) [private]

Referenced by NewL().

void CTextModeHeadersFilter::EnsureContentLengthL ( RHTTPTransaction aTransaction ) [private]

void CTextModeHeadersFilter::EnsureContentTypePresentL ( RHTTPTransaction aTransaction ) [private]

void CTextModeHeadersFilter::EnsureNoEndToEndHeadersInConnectionHeaderL ( RHTTPTransaction aTransaction ) [private]

void CTextModeHeadersFilter::EnsurePathExistsL ( RHTTPTransaction aTransaction ) [private]

TBool CTextModeHeadersFilter::IsHopByHopHeader ( RStringF aHeaderName ) [private]

virtual void CTextModeHeadersFilter::MHFLoad | ( | RHTTPSession | aSession,
 |  | THTTPFilterHandle | aHandle
 | ) | [virtual]

See also:
MHTTPFilter::MHFLoad

Reimplemented from MHTTPFilter.

virtual TInt CTextModeHeadersFilter::MHFRunError | ( | TInt | aError,
 |  | RHTTPTransaction | aTransaction,
 |  | const THTTPEvent & | aEvent
 | ) | [virtual]

See also:
MHTTPFilterBase::MHFRunError

Reimplemented from MHTTPFilterBase.

virtual void CTextModeHeadersFilter::MHFRunL | ( | RHTTPTransaction | aTransaction,
 |  | const THTTPEvent & | aEvent
 | ) | [virtual]

See also:
MHTTPFilterBase::MHFRunL

Reimplemented from MHTTPFilterBase.

virtual TInt CTextModeHeadersFilter::MHFSessionRunError | ( | TInt | aError,
 |  | const THTTPSessionEvent & | aEvent
 | ) | [virtual]

See also:
MHTTPFilterBase::MHFSessionRunError

Reimplemented from MHTTPFilterBase.

virtual void CTextModeHeadersFilter::MHFSessionRunL ( const THTTPSessionEvent & aEvent ) [virtual]

See also:
MHTTPFilterBase::MHFSessionRunL

Reimplemented from MHTTPFilterBase.

virtual void CTextModeHeadersFilter::MHFUnload | ( | RHTTPSession | aSession,
 |  | THTTPFilterHandle | aHandle
 | ) | [virtual]

See also:
MHTTPFilter::MHFUnload

Reimplemented from MHTTPFilter.

CTextModeHeadersFilter * CTextModeHeadersFilter::NewL ( RHTTPSession aSession ) [inline, static]

Definition at line 108 of file ctextmodeheadersfilter.h.

References ConstructL().

Member Data Documentation

TInt CTextModeHeadersFilter::iLoadCount [private]

A count to make sure we delete at the right time.

Definition at line 100 of file ctextmodeheadersfilter.h.

RHTTPSession CTextModeHeadersFilter::iSession [private]

Definition at line 104 of file ctextmodeheadersfilter.h.

RStringPool CTextModeHeadersFilter::iStringPool [private]

Definition at line 102 of file ctextmodeheadersfilter.h.

The documentation for this class was generated from the following file:
  • ctextmodeheadersfilter.h


Member List

CTextModeHeadersFilter Member List

This is the complete list of members for CTextModeHeadersFilter, including all inherited members.
AddExpect100ContinueL(RHTTPTransaction aTransaction) | CTextModeHeadersFilter | [private]
AddSessionHeadersL(RHTTPHeaders aTransactionHeaders, RHTTPHeaders aSessionHeaders) | CTextModeHeadersFilter | [private]
AlterRequestHeadersL(RHTTPTransaction aTransaction) | CTextModeHeadersFilter | [private]
AlterResponseHeadersL(RHTTPTransaction aTransaction) | CTextModeHeadersFilter | [private]
ConstructL(RHTTPSession aSession) | CTextModeHeadersFilter | [private]
CTextModeHeadersFilter() | CTextModeHeadersFilter | [private]
ECache enum value | MHTTPFilter |
EClient enum value | MHTTPFilter |
EClientFilters enum value | MHTTPFilter |
ECookies enum value | MHTTPFilter |
EnsureContentLengthL(RHTTPTransaction aTransaction) | CTextModeHeadersFilter | [private]
EnsureContentTypePresentL(RHTTPTransaction aTransaction) | CTextModeHeadersFilter | [private]
EnsureNoEndToEndHeadersInConnectionHeaderL(RHTTPTransaction aTransaction) | CTextModeHeadersFilter | [private]
EnsurePathExistsL(RHTTPTransaction aTransaction) | CTextModeHeadersFilter | [private]
EProtocolHandler enum value | MHTTPFilter |
EStatusCodeHandler enum value | MHTTPFilter |
ETidyUp enum value | MHTTPFilter |
iLoadCount | CTextModeHeadersFilter | [private]
iSession | CTextModeHeadersFilter | [private]
IsHopByHopHeader(RStringF aHeaderName) | CTextModeHeadersFilter | [private]
iStringPool | CTextModeHeadersFilter | [private]
MHFLoad(RHTTPSession aSession, THTTPFilterHandle aHandle) | CTextModeHeadersFilter | [virtual]
MHFRunError(TInt aError, RHTTPTransaction aTransaction, const THTTPEvent &aEvent) | CTextModeHeadersFilter | [virtual]
MHFRunL(RHTTPTransaction aTransaction, const THTTPEvent &aEvent) | CTextModeHeadersFilter | [virtual]
MHFSessionRunError(TInt aError, const THTTPSessionEvent &aEvent) | CTextModeHeadersFilter | [virtual]
MHFSessionRunL(const THTTPSessionEvent &aEvent) | CTextModeHeadersFilter | [virtual]
MHFUnload(RHTTPSession aSession, THTTPFilterHandle aHandle) | CTextModeHeadersFilter | [virtual]
NewL(RHTTPSession aSession) | CTextModeHeadersFilter | [inline, static]
TPositions enum name | MHTTPFilter |
~CTextModeHeadersFilter() | CTextModeHeadersFilter |


CTextModeHeaderWriter Class Reference

CTextModeHeaderWriter is used by its owning codec to do conversion of header data from the generic format (of parts and parameters) to the plain-text representation. More...

#include <CTextModeHeaderCodec.h>

Inheritance diagram for CTextModeHeaderWriter:

[legend]
Collaboration diagram for CTextModeHeaderWriter:

[legend]
List of all members.

Public Methods

virtual | ~CTextModeHeaderWriter ()
Destructor - cleans up and release resources to the system.

virtual void | EncodeHeaderL (RHeaderField &aHeader)
Converts the supplied header field from its generic format to the plain-text raw format.

Static Public Methods

CTextModeHeaderWriter * | NewL (RStringPool aStrPool)
Factory construction - creates a new CTextModeHeaderWriter.

CTextModeHeaderWriter * | NewLC (RStringPool aStrPool)
Factory construction - creates a new CTextModeHeaderWriter, leaving the new instance on the cleanup stack.

Protected Methods

CTextModeHeaderWriter (RStringPool aStrPool)
Constructor.

Private Methods

void | DoAcceptL (RHeaderField &aHeader) const
Convert the Accept header field from generic to raw form.

void | DoAcceptCharsetL (RHeaderField &aHeader) const
Convert the Accept-Charset header field from generic to raw form.

void | DoAuthorizationL (RHeaderField &aHeader) const
Convert the Authorization header field from generic to raw form.

void | DoConnectionL (RHeaderField &aHeader) const
Convert the Connection header field from generic to raw form.

void | DoContentLengthL (RHeaderField &aHeader) const
Convert the Content-Length header field from generic to raw form.

void | DoContentTypeL (RHeaderField &aHeader) const
Convert the Content-Type header field from generic to raw form.

void | DoDateL (RHeaderField &aHeader) const
Convert the Date header field from generic to raw form.

void | EncodeCookieL (RHeaderField &aHeader) const
void | EncodeOneCookieL (RHeaderField &aHeader, const CHeaderFieldPart &aCookieFieldPart, TBool aIsNetscapeStyleCookie) const
void | EncodeOneCookieAttributeL (RHeaderField &aHeader, const CHeaderFieldParam &aAttribute) const
void | EncodeCacheControlL (RHeaderField &aHeader) const
void | EncodePragmaL (RHeaderField &aHeader) const
void | DoHostL (RHeaderField &aHeader) const
Convert the Host header field from generic to raw form.

void | DoTransferEncodingL (RHeaderField &aHeader) const
Convert the Transfer-Encoding header field from generic to raw form.

void | DoUserAgentL (RHeaderField &aHeader) const
Convert the User-Agent header field from generic to raw form.

void | DoGeneralAcceptHeaderL (RHeaderField &aHeader, RStringF aFieldType, TInt aErrorCode) const
Helper to DoAcceptL(), DoAcceptCharsetL(), DoAcceptLanguageL() and DoAcceptEncodingL() for comma-separated lists incorporating q-values.

void | DoTokenCsvListHeaderL (RHeaderField &aHeader, TInt aErrorCode) const
Helper to DoConnectionL(), DoContentEncodingL(), DoTransferEncodingL(), etc., which take comma-separated token lists.

void | DoTokenListHeaderL (RHeaderField &aHeader, const TDesC8 &aSep, TInt aErrorCode) const
Helper to DoUserAgentL(), etc., which take token lists with arbitrary separators.

const CHeaderFieldPart * | WriteRawStrFPartL (RHeaderField &aHeader, THeaderFieldPartIter &aIter, TInt aErrorCode) const
void | EncodeGenericDateL (RHeaderField &aHeader, TInt aErrorCodeToUseOnFailure) const
void | EncodeGenericNumberHeaderL (RHeaderField &aHeader, TInt aErrorCodeToUseOnFailure) const

Private Attributes

RStringPool | iStrPool
A handle to the HTTP string pool.

Detailed Description

CTextModeHeaderWriter is used by its owning codec to do conversion of header data from the generic format (of parts and parameters) to the plain-text representation.

Definition at line 98 of file CTextModeHeaderCodec.h.

Constructor & Destructor Documentation

virtual CTextModeHeaderWriter::~CTextModeHeaderWriter ( ) [virtual]

Destructor - cleans up and release resources to the system.

CTextModeHeaderWriter::CTextModeHeaderWriter ( RStringPool aStrPool ) [protected]

Constructor.

Copies the supplied string pool handle.

Member Function Documentation

void CTextModeHeaderWriter::DoAcceptCharsetL ( RHeaderField & aHeader ) const [private]

Convert the Accept-Charset header field from generic to raw form.

void CTextModeHeaderWriter::DoAcceptL ( RHeaderField & aHeader ) const [private]

Convert the Accept header field from generic to raw form.

void CTextModeHeaderWriter::DoAuthorizationL ( RHeaderField & aHeader ) const [private]

Convert the Authorization header field from generic to raw form.

void CTextModeHeaderWriter::DoConnectionL ( RHeaderField & aHeader ) const [private]

Convert the Connection header field from generic to raw form.

void CTextModeHeaderWriter::DoContentLengthL ( RHeaderField & aHeader ) const [private]

Convert the Content-Length header field from generic to raw form.

void CTextModeHeaderWriter::DoContentTypeL ( RHeaderField & aHeader ) const [private]

Convert the Content-Type header field from generic to raw form.

void CTextModeHeaderWriter::DoDateL ( RHeaderField & aHeader ) const [private]

Convert the Date header field from generic to raw form.

void CTextModeHeaderWriter::DoGeneralAcceptHeaderL | ( | RHeaderField & | aHeader,
 |  | RStringF | aFieldType,
 |  | TInt | aErrorCode
 | ) | const [private]

Helper to DoAcceptL(), DoAcceptCharsetL(), DoAcceptLanguageL() and DoAcceptEncodingL() for comma-separated lists incorporating q-values.

Parameters:
aHeader | The header field being encoded
aFieldType | A string reference to the field type being encoded
aErrorCode | An error value to use when encoding fails

void CTextModeHeaderWriter::DoHostL ( RHeaderField & aHeader ) const [private]

Convert the Host header field from generic to raw form.

void CTextModeHeaderWriter::DoTokenCsvListHeaderL | ( | RHeaderField & | aHeader,
 |  | TInt | aErrorCode
 | ) | const [private]

Helper to DoConnectionL(), DoContentEncodingL(), DoTransferEncodingL(), etc., which take comma-separated token lists.

Parameters:
aHeader | The header field being encoded
aErrorCode | An error value to use when encoding fails

void CTextModeHeaderWriter::DoTokenListHeaderL | ( | RHeaderField & | aHeader,
 |  | const TDesC8 & | aSep,
 |  | TInt | aErrorCode
 | ) | const [private]

Helper to DoUserAgentL(), etc., which take token lists with arbitrary separators.

Parameters:
aHeader | The header field being encoded
aFieldType | A string reference to the field type being encoded
aErrorCode | An error value to use when encoding fails

void CTextModeHeaderWriter::DoTransferEncodingL ( RHeaderField & aHeader ) const [private]

Convert the Transfer-Encoding header field from generic to raw form.

void CTextModeHeaderWriter::DoUserAgentL ( RHeaderField & aHeader ) const [private]

Convert the User-Agent header field from generic to raw form.

void CTextModeHeaderWriter::EncodeCacheControlL ( RHeaderField & aHeader ) const [private]

void CTextModeHeaderWriter::EncodeCookieL ( RHeaderField & aHeader ) const [private]

void CTextModeHeaderWriter::EncodeGenericDateL | ( | RHeaderField & | aHeader,
 |  | TInt | aErrorCodeToUseOnFailure
 | ) | const [private]

void CTextModeHeaderWriter::EncodeGenericNumberHeaderL | ( | RHeaderField & | aHeader,
 |  | TInt | aErrorCodeToUseOnFailure
 | ) | const [private]

virtual void CTextModeHeaderWriter::EncodeHeaderL ( RHeaderField & aHeader ) [virtual]

Converts the supplied header field from its generic format to the plain-text raw format.

The raw data is stored in the header field itself.

Implements CHeaderWriter.

void CTextModeHeaderWriter::EncodeOneCookieAttributeL | ( | RHeaderField & | aHeader,
 |  | const CHeaderFieldParam & | aAttribute
 | ) | const [private]

void CTextModeHeaderWriter::EncodeOneCookieL | ( | RHeaderField & | aHeader,
 |  | const CHeaderFieldPart & | aCookieFieldPart,
 |  | TBool | aIsNetscapeStyleCookie
 | ) | const [private]

void CTextModeHeaderWriter::EncodePragmaL ( RHeaderField & aHeader ) const [private]

CTextModeHeaderWriter* CTextModeHeaderWriter::NewL ( RStringPool aStrPool ) [static]

Factory construction - creates a new CTextModeHeaderWriter.

A string pool handle is supplied for convenience

CTextModeHeaderWriter* CTextModeHeaderWriter::NewLC ( RStringPool aStrPool ) [static]

Factory construction - creates a new CTextModeHeaderWriter, leaving the new instance on the cleanup stack.

A string pool handle is supplied for convenience

const CHeaderFieldPart* CTextModeHeaderWriter::WriteRawStrFPartL | ( | RHeaderField & | aHeader,
 |  | THeaderFieldPartIter & | aIter,
 |  | TInt | aErrorCode
 | ) | const [private]

Member Data Documentation

RStringPool CTextModeHeaderWriter::iStrPool [private]

A handle to the HTTP string pool.

Definition at line 235 of file CTextModeHeaderCodec.h.

The documentation for this class was generated from the following file:
  • CTextModeHeaderCodec.h


Member List

CTextModeHeaderWriter Member List

This is the complete list of members for CTextModeHeaderWriter, including all inherited members.
CHeaderWriter() | CHeaderWriter | [protected]
ConstructL() | CHeaderWriter | [protected]
CTextModeHeaderWriter(RStringPool aStrPool) | CTextModeHeaderWriter | [protected]
DoAcceptCharsetL(RHeaderField &aHeader) const | CTextModeHeaderWriter | [private]
DoAcceptL(RHeaderField &aHeader) const | CTextModeHeaderWriter | [private]
DoAuthorizationL(RHeaderField &aHeader) const | CTextModeHeaderWriter | [private]
DoConnectionL(RHeaderField &aHeader) const | CTextModeHeaderWriter | [private]
DoContentLengthL(RHeaderField &aHeader) const | CTextModeHeaderWriter | [private]
DoContentTypeL(RHeaderField &aHeader) const | CTextModeHeaderWriter | [private]
DoDateL(RHeaderField &aHeader) const | CTextModeHeaderWriter | [private]
DoGeneralAcceptHeaderL(RHeaderField &aHeader, RStringF aFieldType, TInt aErrorCode) const | CTextModeHeaderWriter | [private]
DoHostL(RHeaderField &aHeader) const | CTextModeHeaderWriter | [private]
DoTokenCsvListHeaderL(RHeaderField &aHeader, TInt aErrorCode) const | CTextModeHeaderWriter | [private]
DoTokenListHeaderL(RHeaderField &aHeader, const TDesC8 &aSep, TInt aErrorCode) const | CTextModeHeaderWriter | [private]
DoTransferEncodingL(RHeaderField &aHeader) const | CTextModeHeaderWriter | [private]
DoUserAgentL(RHeaderField &aHeader) const | CTextModeHeaderWriter | [private]
EncodeCacheControlL(RHeaderField &aHeader) const | CTextModeHeaderWriter | [private]
EncodeCookieL(RHeaderField &aHeader) const | CTextModeHeaderWriter | [private]
EncodeGenericDateL(RHeaderField &aHeader, TInt aErrorCodeToUseOnFailure) const | CTextModeHeaderWriter | [private]
EncodeGenericNumberHeaderL(RHeaderField &aHeader, TInt aErrorCodeToUseOnFailure) const | CTextModeHeaderWriter | [private]
EncodeHeaderL(RHeaderField &aHeader) | CTextModeHeaderWriter | [virtual]
EncodeOneCookieAttributeL(RHeaderField &aHeader, const CHeaderFieldParam &aAttribute) const | CTextModeHeaderWriter | [private]
EncodeOneCookieL(RHeaderField &aHeader, const CHeaderFieldPart &aCookieFieldPart, TBool aIsNetscapeStyleCookie) const | CTextModeHeaderWriter | [private]
EncodePragmaL(RHeaderField &aHeader) const | CTextModeHeaderWriter | [private]
iStrPool | CTextModeHeaderWriter | [private]
NewL(RStringPool aStrPool) | CTextModeHeaderWriter | [static]
NewLC(RStringPool aStrPool) | CTextModeHeaderWriter | [static]
WriteRawStrFPartL(RHeaderField &aHeader, THeaderFieldPartIter &aIter, TInt aErrorCode) const | CTextModeHeaderWriter | [private]
~CHeaderWriter() | CHeaderWriter | [virtual]
~CTextModeHeaderWriter() | CTextModeHeaderWriter | [virtual]


CTextModeHttpProt Class Reference

The CTextModeHttpProt class is a specialisation of CProtocolHandler for plain-text HTTP - i.e. More...

#include <CTextModeHttpProt.h>

Inheritance diagram for CTextModeHttpProt:

[legend]
Collaboration diagram for CTextModeHttpProt:

[legend]
List of all members.

Public Methods

virtual | ~CTextModeHttpProt ()
Destructor. Cleans up and releases resources to the system.

virtual void | SetStatusL (CRxData &aRxData, TInt aStatus)
Supply a status message to the protocol handler from the specified OTA response data holder.

Static Public Methods

CTextModeHttpProt * | NewL (TAny *aSession)
Factory creation.

Private Methods

virtual void | CreateCodecL ()
@private

virtual CProtTransaction * | CreateProtTransactionL (RHTTPTransaction aTransaction)
virtual TBool | ServiceL (CProtTransaction &aTrans)
virtual void | ClosedTransactionHook (CProtTransaction *aTrans)
virtual void | CancelTransactionHook (CProtTransaction &aTransaction)
virtual void | NotifyNewRequestBodyPart (CProtTransaction &aTransaction)
void | SetupProxyInformation ()
TInt | SessionServerCert (TCertInfo &aServerCert)
Get the Server Certificate for the current session.

TInt | TransactionServerCert (TCertInfo &aServerCert, RHTTPTransaction aTransaction)
Get the Server Certificate for the specified transaction.

virtual TBool | GetCommsPrefs (TInt &aSocketServHandle, TInt &aConnectionPtr)
virtual void | SetCommsPrefs (TInt aSocketServHandle, TInt aConnectionPtr)
virtual TSecureDialogPref | GetSecureDialogPref () const
Get Security dialog preference from Session properties.

CTextModeHttpProt (RHTTPSession aSession)
Constructor; stores the supplied session handle.

void | ConstructL (RHTTPSession aSession)
Second-phase construction. Does any required allocation.

TBool | PrepareRequestForTransL (RHTTPTransaction aTrans, RStringF &aAddress, RStringF &aHost, TInt &aPort, TInt &aHostPort, TBool &aIsSecure)
Add general HTTP headers needed for the management of the HTTP protocol level in use by the session.

void | PrepareUriForTransL (RHTTPTransaction aTrans, RStringF &aAddress, RStringF &aHost, TInt &aPort, TInt &aHostPort, TBool aIsHttp10, TBool &aIsSecure)
Prepare the url for the transaction, stripping connection and host headers for HTTP/1.0.

TBool | SelectTransportHandlerL (MTextModeTransportHandler *&aTransportHandler, CHttpTcpServerLocation &aServerLocation)
Selects a transport handler.

TBool | LookUpProtTrans (RHTTPTransaction aTrans, CTextModeProtTransaction *&aProtTrans) const
Locate the Protocol Transaction corresponding to the supplied client transaction.

TInt | MaxNumTransportHandlers () const
Return the maximum allowed number of transport handlers - obtained from session properties if present; or defaulted if not.

TInt | MaxNumTransPerTranspHndlr () const
Return the maximum allowed number of transactions per transport handler - obtained from session properties if present; or defaulted if not.

TBool | IsHostIPAddress (const TDesC8 &aUri) const

Private Attributes

RArray< MTextModeTransportHandler * > | iTransportHnds
The set of transport handlers.

TBool | iSessionUsesWebProxy
Flag indicating whether the session to which this protocol handler belongs has been opened with Connection Information indicating a Web Proxy.

TBool | iUseNamedProxy
Flag indicating whether the Web Proxy for this session was named (if not the CommDB default is used).

RStringF | iProxyAddress
The named proxy to be used, in the instance that both iSessionUsesWebProxy and iUseNamedProxy are set to ETrue.

TInt | iMaxNumTransportHandlers
The maximum number of transport handlers in the protocol handler's session.

TInt | iMaxNumTransPerTranspHndlr
The maximum number of transactions that can be queued for any one transport handler.

CTextModeHeadersFilter * iHeadersFilter
TBool | iFirstTransaction
CTCPClientFactory * iTCPClientFactory

Detailed Description

The CTextModeHttpProt class is a specialisation of CProtocolHandler for plain-text HTTP - i.e.

that spoken by HTTP servers and proxies when interacting directly with them. It provides the bridge between the text-mode HTTP world and the EPOC generic representation of headers and bodies, requests and responses.

Asociated with a single HTTP session, the text mode protocol handler owns a text-mode transaction codec which is used to encode/decode plaintext headers. It owns a set of transport handlers which represent actual connections to origin servers or proxies.

Transactions submitted by the client are queued first in the protocol handler, then allocated to a transport handler when one is able to service the transaction. The servicing mechanism is currently on a one-at-a-time basis only. However in the future it is envisaged that an algorithm to share out a set of transport handlers will be implemented. This will involve load balancing on a limited number of socket connections - possible pipelining, possible fanout of multiple connections to the same server.

When transactions are complete (in the sense that their response half has been entirely received) the Text-Mode protocol handler marks them as completed. Their data isn't deleted until the transaction is closed. This allows the client to take time over retrieving the body data if it so desires.

The text-mode protocol handler is an observer for OTA received data holders, in order for it to receive status messages about the progress of response receipt and parsing.

The text-mode protocol handler is a Session Properties Provider. Functions to get/set specific session properties and hence provides support for multi-homing.

Definition at line 67 of file CTextModeHttpProt.h.

Constructor & Destructor Documentation

virtual CTextModeHttpProt::~CTextModeHttpProt ( ) [virtual]

Destructor. Cleans up and releases resources to the system.

CTextModeHttpProt::CTextModeHttpProt ( RHTTPSession aSession ) [private]

Constructor; stores the supplied session handle.

Member Function Documentation

CTextModeHttpProt::CancelTransactionHook ( CProtTransaction & aTrans ) [private, virtual]

See also:
CProtocolHandler

Implements CProtocolHandler.

CTextModeHttpProt::ClosedTransactionHook ( CProtTransaction * aTrans ) [private, virtual]

See also:
CProtocolHandler

Implements CProtocolHandler.

void CTextModeHttpProt::ConstructL ( RHTTPSession aSession ) [private]

Second-phase construction. Does any required allocation.

Reimplemented from CProtocolHandler.

CTextModeHttpProt::CreateCodecL ( ) [private, virtual]

@private

See also:
CProtocolHandler

Implements CProtocolHandler.

CTextModeHttpProt::CreateProtTransactionL ( RHTTPTransaction aTransaction ) [private, virtual]

See also:
CProtocolHandler

Implements CProtocolHandler.

CTextModeHttpProt::GetCommsPrefs | ( | TInt & | aSocketServHandle,
 |  | TInt & | aConnectionRef
 | ) | [private, virtual]

See also:
MSessionPropertiesProvider

Implements MSessionPropertiesProvider.

virtual TSecureDialogPref CTextModeHttpProt::GetSecureDialogPref ( ) [private, virtual]

Get Security dialog preference from Session properties.

Returns:
clients preference if set, else returns EPrompt as default

Implements MSessionPropertiesProvider.

TBool CTextModeHttpProt::IsHostIPAddress ( const TDesC8 & aUri ) const [private]

TBool CTextModeHttpProt::LookUpProtTrans | ( | RHTTPTransaction | aTrans,
 |  | CTextModeProtTransaction *& | aProtTrans
 | ) | const [private]

Locate the Protocol Transaction corresponding to the supplied client transaction.

Returns ETrue if this succeeded or EFalse if no corresponding Protocol Transaction could be found - eg. if the client transaction had not been submitted.

TInt CTextModeHttpProt::MaxNumTransPerTranspHndlr ( ) [private]

Return the maximum allowed number of transactions per transport handler - obtained from session properties if present; or defaulted if not.

TInt CTextModeHttpProt::MaxNumTransportHandlers ( ) [private]

Return the maximum allowed number of transport handlers - obtained from session properties if present; or defaulted if not.

CTextModeHttpProt* CTextModeHttpProt::NewL ( TAny * aSession ) [static]

Factory creation.

Makes a new text-mode protocol handler to be associated with the supplied session.

CTextModeHttpProt::NotifyNewRequestBodyPart ( CProtTransaction & aTransaction ) [private, virtual]

See also:
CProtocolHandler

Implements CProtocolHandler.

TBool CTextModeHttpProt::PrepareRequestForTransL | ( | RHTTPTransaction | aTrans,
 |  | RStringF & | aAddress,
 |  | RStringF & | aHost,
 |  | TInt & | aPort,
 |  | TInt & | aHostPort,
 |  | TBool & | aIsSecure
 | ) | [private]

Add general HTTP headers needed for the management of the HTTP protocol level in use by the session.

Returns:
TBool, ETrue if the transaction is a 1.1 persistant one

void CTextModeHttpProt::PrepareUriForTransL | ( | RHTTPTransaction | aTrans,
 |  | RStringF & | aAddress,
 |  | RStringF & | aHost,
 |  | TInt & | aPort,
 |  | TInt & | aHostPort,
 |  | TBool | aIsHttp10,
 |  | TBool & | aIsSecure
 | ) | [private]

Prepare the url for the transaction, stripping connection and host headers for HTTP/1.0.

TBool CTextModeHttpProt::SelectTransportHandlerL | ( | MTextModeTransportHandler *& | aTransportHandler,
 |  | CHttpTcpServerLocation & | aServerLocation
 | ) | [private]

Selects a transport handler.

Parameters:
aTransportHandler | The transport handler to use if one is found
aServerLocation | The location which the transport handler is going to be connected to
Returns:
TBool. ETrue if a transport handler has been found, EFalse if not

CTextModeHttpProt::ServiceL ( CProtTransaction & aTrans ) [private, virtual]

See also:
CProtocolHandler

Implements CProtocolHandler.

TInt CTextModeHttpProt::SessionServerCert ( TCertInfo & aServerCert ) [private, virtual]

Get the Server Certificate for the current session.

This function returns KErrNotSupported because for text-mode there is no concept of a session certificate.

Parameters:
aServerCert A TCertInfo which will be filled with the certificate information
Returns:
KErrNotSupported

Implements CProtocolHandler.

CTextModeHttpProt::SetCommsPrefs | ( | TInt | aSocketServHandle,
 |  | TInt | aConnectionRef
 | ) | [private, virtual]

See also:
MSessionPropertiesProvider

Implements MSessionPropertiesProvider.

virtual void CTextModeHttpProt::SetStatusL | ( | CRxData & | aRxData,
 |  | TInt | aStatus
 | ) | [virtual]

Supply a status message to the protocol handler from the specified OTA response data holder.

Implements MRxDataObserver.

void CTextModeHttpProt::SetupProxyInformation ( ) [private]

TInt CTextModeHttpProt::TransactionServerCert | ( | TCertInfo & | aServerCert,
 |  | RHTTPTransaction | aTransaction
 | ) | [private, virtual]

Get the Server Certificate for the specified transaction.

Parameters:
aServerCert | A TCertInfo which will be filled with the certificate information
aTransaction | The transaction for which the certificate is requested.
Returns:
An error code. KErrNone if aServerCert has been completed, otherwise one of the system wide error codes

Implements CProtocolHandler.

Member Data Documentation

TBool CTextModeHttpProt::iFirstTransaction [private]

Definition at line 266 of file CTextModeHttpProt.h.

CTextModeHeadersFilter* CTextModeHttpProt::iHeadersFilter [private]

Definition at line 263 of file CTextModeHttpProt.h.

TInt CTextModeHttpProt::iMaxNumTransPerTranspHndlr [private]

The maximum number of transactions that can be queued for any one transport handler.

This is obtained from session info if available; otherwise it is defaulted.

Definition at line 257 of file CTextModeHttpProt.h.

TInt CTextModeHttpProt::iMaxNumTransportHandlers [private]

The maximum number of transport handlers in the protocol handler's session.

This is obtained from session info if available; otherwise it is defaulted.

Definition at line 252 of file CTextModeHttpProt.h.

RStringF CTextModeHttpProt::iProxyAddress [private]

The named proxy to be used, in the instance that both iSessionUsesWebProxy and iUseNamedProxy are set to ETrue.

Definition at line 247 of file CTextModeHttpProt.h.

TBool CTextModeHttpProt::iSessionUsesWebProxy [private]

Flag indicating whether the session to which this protocol handler belongs has been opened with Connection Information indicating a Web Proxy.

Definition at line 237 of file CTextModeHttpProt.h.

CTCPClientFactory* CTextModeHttpProt::iTCPClientFactory [private]

Definition at line 269 of file CTextModeHttpProt.h.

RArray<MTextModeTransportHandler*> CTextModeHttpProt::iTransportHnds [private]

The set of transport handlers.

Definition at line 232 of file CTextModeHttpProt.h.

TBool CTextModeHttpProt::iUseNamedProxy [private]

Flag indicating whether the Web Proxy for this session was named (if not the CommDB default is used).

Irrelevant if iSessionUsesWebProxy is EFalse

Definition at line 242 of file CTextModeHttpProt.h.

The documentation for this class was generated from the following file:
  • CTextModeHttpProt.h


Member List

CTextModeHttpProt Member List

This is the complete list of members for CTextModeHttpProt, including all inherited members.
CancelTransactionHook(CProtTransaction &aTransaction) | CTextModeHttpProt | [private, virtual]
ClosedTransactionHook(CProtTransaction *aTrans) | CTextModeHttpProt | [private, virtual]
Codec() const | CProtocolHandler |
CompleteSelf() | CProtocolHandler | [protected]
ConstructL(RHTTPSession aSession) | CTextModeHttpProt | [private]
CProtocolHandler(RHTTPSession aSession) | CProtocolHandler | [protected]
CreateCodecL() | CTextModeHttpProt | [private, virtual]
CreateProtTransactionL(RHTTPTransaction aTransaction) | CTextModeHttpProt | [private, virtual]
CTextModeHttpProt(RHTTPSession aSession) | CTextModeHttpProt | [private]
DoCancel() | CProtocolHandler | [protected, virtual]
ECache enum value | MHTTPFilter |
EClient enum value | MHTTPFilter |
EClientFilters enum value | MHTTPFilter |
ECookies enum value | MHTTPFilter |
EProtocolHandler enum value | MHTTPFilter |
EStatusCodeHandler enum value | MHTTPFilter |
ETidyUp enum value | MHTTPFilter |
FindTransaction(RHTTPTransaction aTransaction, const CProtTransaction *&aProtTransaction) const | CProtocolHandler | [protected]
GetCommsPrefs(TInt &aSocketServHandle, TInt &aConnectionPtr) | CTextModeHttpProt | [private, virtual]
GetSecureDialogPref() const | CTextModeHttpProt | [private, virtual]
iCodec | CProtocolHandler | [protected]
iFirstTransaction | CTextModeHttpProt | [private]
iHeadersFilter | CTextModeHttpProt | [private]
iMaxNumTransPerTranspHndlr | CTextModeHttpProt | [private]
iMaxNumTransportHandlers | CTextModeHttpProt | [private]
iProxyAddress | CTextModeHttpProt | [private]
iSecurityPolicy | CProtocolHandler | [protected]
iSession | CProtocolHandler | [protected]
iSessionUsesWebProxy | CTextModeHttpProt | [private]
IsHostIPAddress(const TDesC8 &aUri) const | CTextModeHttpProt | [private]
iTCPClientFactory | CTextModeHttpProt | [private]
iTransportHnds | CTextModeHttpProt | [private]
iUseNamedProxy | CTextModeHttpProt | [private]
LookUpProtTrans(RHTTPTransaction aTrans, CTextModeProtTransaction *&aProtTrans) const | CTextModeHttpProt | [private]
MaxNumTransPerTranspHndlr() const | CTextModeHttpProt | [private]
MaxNumTransportHandlers() const | CTextModeHttpProt | [private]
MHFLoad(RHTTPSession aSession, THTTPFilterHandle aHandle) | CProtocolHandler | [virtual]
MHFRunError(TInt aError, RHTTPTransaction aTransaction, const THTTPEvent &aEvent) | CProtocolHandler | [virtual]
MHFRunL(RHTTPTransaction aTransaction, const THTTPEvent &aEvent) | CProtocolHandler | [virtual]
MHFSessionRunError(TInt aError, const THTTPSessionEvent &aEvent) | CProtocolHandler | [virtual]
MHFSessionRunL(const THTTPSessionEvent &aEvent) | CProtocolHandler | [virtual]
MHFUnload(RHTTPSession aSession, THTTPFilterHandle aHandle) | CProtocolHandler | [virtual]
NewL(TAny *aSession) | CTextModeHttpProt | [static]
CProtocolHandler::NewL(const TDesC8 &aProtocol, RHTTPSession aSession) | CProtocolHandler | [static]
NotifyNewRequestBodyPart(CProtTransaction &aTransaction) | CTextModeHttpProt | [private, virtual]
NumActiveTransactions() const | CProtocolHandler | [protected]
PrepareRequestForTransL(RHTTPTransaction aTrans, RStringF &aAddress, RStringF &aHost, TInt &aPort, TInt &aHostPort, TBool &aIsSecure) | CTextModeHttpProt | [private]
PrepareUriForTransL(RHTTPTransaction aTrans, RStringF &aAddress, RStringF &aHost, TInt &aPort, TInt &aHostPort, TBool aIsHttp10, TBool &aIsSecure) | CTextModeHttpProt | [private]
RunError(TInt aError) | CProtocolHandler | [protected, virtual]
RunL() | CProtocolHandler | [protected, virtual]
SelectTransportHandlerL(MTextModeTransportHandler *&aTransportHandler, CHttpTcpServerLocation &aServerLocation) | CTextModeHttpProt | [private]
ServiceL(CProtTransaction &aTrans) | CTextModeHttpProt | [private, virtual]
SessionServerCert(TCertInfo &aServerCert) | CTextModeHttpProt | [private, virtual]
SetCommsPrefs(TInt aSocketServHandle, TInt aConnectionPtr) | CTextModeHttpProt | [private, virtual]
SetStatusL(CRxData &aRxData, TInt aStatus) | CTextModeHttpProt | [virtual]
SetupProxyInformation() | CTextModeHttpProt | [private]
TPositions enum name | MHTTPFilter |
TransactionCompletedL(RHTTPTransaction aTrans, THTTPEvent aEventStatus) | CProtocolHandler | [protected]
TransactionFailed(RHTTPTransaction aTrans) | CProtocolHandler | [protected]
TransactionServerCert(TCertInfo &aServerCert, RHTTPTransaction aTransaction) | CTextModeHttpProt | [private, virtual]
~CProtocolHandler() | CProtocolHandler | [virtual]
~CTextModeHttpProt() | CTextModeHttpProt | [virtual]


CTextModeProtTransaction Class Reference

#include <ctextmodeprottransaction.h>

Inheritance diagram for CTextModeProtTransaction:

[legend]
Collaboration diagram for CTextModeProtTransaction:

[legend]
List of all members.

Public Methods

~CTextModeProtTransaction ()
MTextModeTransportHandler & | TextModeTransportHandler () const
void | SetTextModeTransportHandler (MTextModeTransportHandler &aTextModeTransportHandler)

Static Public Methods

CTextModeProtTransaction * | NewL (RHTTPTransaction aTransaction)

Private Methods

virtual void | CreateTxDataL ()
virtual void | CreateRxDataL (MRxDataObserver &aObserver)
CTextModeProtTransaction (RHTTPTransaction aTransaction)

Private Attributes

MTextModeTransportHandler * iTextModeTransportHandler

Constructor & Destructor Documentation

CTextModeProtTransaction::~CTextModeProtTransaction ( )

CTextModeProtTransaction::CTextModeProtTransaction ( RHTTPTransaction aTransaction ) [private]

Member Function Documentation

CTextModeProtTransaction::CreateRxDataL ( MRxDataObserver & aObserver ) [private, virtual]

See also:
CProtTransaction

Implements CProtTransaction.

CTextModeProtTransaction::CreateTxDataL ( ) [private, virtual]

See also:
CProtTransaction

Implements CProtTransaction.

CTextModeProtTransaction* CTextModeProtTransaction::NewL ( RHTTPTransaction aTransaction ) [static]

void CTextModeProtTransaction::SetTextModeTransportHandler ( MTextModeTransportHandler & aTextModeTransportHandler )

MTextModeTransportHandler& CTextModeProtTransaction::TextModeTransportHandler ( )

Member Data Documentation

MTextModeTransportHandler* CTextModeProtTransaction::iTextModeTransportHandler [private]

Definition at line 58 of file ctextmodeprottransaction.h.

The documentation for this class was generated from the following file:
  • ctextmodeprottransaction.h


Member List

CTextModeProtTransaction Member List

This is the complete list of members for CTextModeProtTransaction, including all inherited members.
CProtTransaction() | CProtTransaction | [protected]
CProtTransaction(RHTTPTransaction aTrans) | CProtTransaction | [protected]
CreateRxDataL(MRxDataObserver &aObserver) | CTextModeProtTransaction | [private, virtual]
CreateTxDataL() | CTextModeProtTransaction | [private, virtual]
CTextModeProtTransaction(RHTTPTransaction aTransaction) | CTextModeProtTransaction | [private]
EActive enum value | CProtTransaction |
ECancelled enum value | CProtTransaction |
ECompleted enum value | CProtTransaction |
EPending enum value | CProtTransaction |
iRxData | CProtTransaction | [protected]
iTextModeTransportHandler | CTextModeProtTransaction | [private]
iTrans | CProtTransaction | [protected]
iTransactionState | CProtTransaction | [protected]
iTxData | CProtTransaction | [protected]
NewL(RHTTPTransaction aTransaction) | CTextModeProtTransaction | [static]
ResetRxData() | CProtTransaction |
ResetTxData() | CProtTransaction |
RxData() const | CProtTransaction |
SetTextModeTransportHandler(MTextModeTransportHandler &aTextModeTransportHandler) | CTextModeProtTransaction |
SetTransactionState(TTransactionState aState) | CProtTransaction |
TextModeTransportHandler() const | CTextModeProtTransaction |
Transaction() const | CProtTransaction |
TransactionState() const | CProtTransaction |
TTransactionState enum name | CProtTransaction |
TxData() const | CProtTransaction |
~CProtTransaction() | CProtTransaction | [virtual]
~CTextModeProtTransaction() | CTextModeProtTransaction |


CTextModeRxData Class Reference

A representation of over-the-air received data for Text-Mode HTTP. More...

#include <CTextModeRxData.h>

Inheritance diagram for CTextModeRxData:

[legend]
Collaboration diagram for CTextModeRxData:

[legend]
List of all members.

Public Methods

virtual | ~CTextModeRxData ()
Destructor; releases back to the system resources used by this object.

void | ResetRxData ()
Reset the encoded data iterator to the first 'chunk' for transmission.

virtual void | SetStatusL (CTxData &aTrans, TInt aStatus)
Callback from TCP transport handler to send a status message.

virtual THttpRxDataStat | DataL (CTxData &aTrans, const TDesC8 &aData)
Callback from TCP transport handler when data is received.

virtual void | HandleError (CTxData &aTrans, TInt aError)
Handle an error from the transport handler.

virtual TInt | CheckConnectResponseL (TDesC8 &aBuffer)
Provide simple checking of the CONNECT response.

virtual TBool | GetNextDataPart (TPtrC8 &aDataChunk)
Obtain a part of data from the supplier. This is guaranteed to survive until a call is made to ReleaseData().

virtual void | ReleaseData ()
Release the current data chunk being held at the data supplier.

virtual TInt | OverallDataSize ()
Obtain the overall size of the data being supplied, if known to the supplier.

virtual TInt | Reset ()
Reset the data supplier.

Static Public Methods

CTextModeRxData * | NewL (CProtTransaction &aProtTrans, MTextModeTransportHandler &aTransportHnd, MRxDataObserver &aObserver)
Factory construction for this class.

Private Types

enum | EBlankLineCount { EFirstBlankLine = 1, ESecondBlankLine = 2 }

Private Methods

CTextModeRxData ()
Default constructor - creates an object not associated with any transaction.

CTextModeRxData (CProtTransaction &aProtTrans, MTextModeTransportHandler &aTransportHnd, MRxDataObserver &aObserver)
Normal constructor for an OTA received data object corresponding to the supplied transaction, TCP handler and observer.

void | ConstructL ()
Second phase construction in which any construct-time allocation is done.

void | HandleStatusLineL (CTxData &aTrans)
Handles 100 continues in status line and sets status otherwise.

void | DoFoundHeaderFieldL (CTxData &aTrans, THttpRxDataStat &aDataFlags)
void | DoFoundHeaderFieldContinuationL (CTxData &aTrans)
void | DoFoundBodyL (CTxData &aTrans)
void | DoFoundLineSeparatorL (CTxData &aTrans)
MTextModeTransportHandler & TextModeTransportHandler ()

Private Attributes

TBool | iGotAllHeaders
Flag indicating when our response parser believes it has reached the end of the response header section.

TBool | iReplyComplete
Flag indicating that the ReplyComplete status code has been received from the Transport Handler.

TResponseParser iParse
The parser used to segment the received OTA response data.

HBufC8 * | iLineBuffer
A buffer used to store the next line of the response.

RArray< TPtrC8 > | iFoundBodyParts
An array of identified body parts that are being sent to the client.

TInt | iOverallDataSize
The overall data size of the response raw body data, if known or KErrNotFound (== -1) if not known.

TInt | iBodyDataSizeSoFar
The amount of body data received so far.

TInt | iEmptyLineCount
The number of empty lines recognised in the response (which mark the end of header blocks).

TBool | iHaveReadContentLengthHeader
flag indicating that the content-length has been read from the header

RStringF | iLastHeaderName
a string indicating the last response header added to the transaction.

TBool | iConsumingResponse
flag indicating that the we are consuming a response;

MTextModeTransportHandler * iTextModeTransportHandler
TBool | iFoundConnectionClose
flag indicating that Connection:Close header has been received

Detailed Description

A representation of over-the-air received data for Text-Mode HTTP.

This object handles data received from an origin server/proxy and, using its TResponseParser, identifies each section in the response, including lines broken across chunk boundaries. It creates OTA header representations in the RHTTPResponse header collection.

Definition at line 263 of file CTextModeRxData.h.

Member Enumeration Documentation

enum CTextModeRxData::EBlankLineCount [private]

Enumeration values:
EFirstBlankLine
ESecondBlankLine

Definition at line 329 of file CTextModeRxData.h.

Constructor & Destructor Documentation

virtual CTextModeRxData::~CTextModeRxData ( ) [virtual]

Destructor; releases back to the system resources used by this object.

CTextModeRxData::CTextModeRxData ( ) [private]

Default constructor - creates an object not associated with any transaction.

CTextModeRxData::CTextModeRxData | ( | CProtTransaction & | aProtTrans,
 |  | MTextModeTransportHandler & | aTransportHnd,
 |  | MRxDataObserver & | aObserver
 | ) | [private]

Normal constructor for an OTA received data object corresponding to the supplied transaction, TCP handler and observer.

Member Function Documentation

virtual TInt CTextModeRxData::CheckConnectResponseL ( TDesC8 & aBuffer ) [virtual]

Provide simple checking of the CONNECT response.

Used by the transport handler to look for a 200 OK response.

Returns:
The status code of the response
Parameters:
aBuffer Descriptor containing the response
Exceptions:
KErrNoMemory if a buffer for parsing could not be created

Implements MTransportHndObs.

void CTextModeRxData::ConstructL ( ) [private]

Second phase construction in which any construct-time allocation is done.

Reimplemented from CRxData.

virtual THttpRxDataStat CTextModeRxData::DataL | ( | CTxData & | aTrans,
 |  | const TDesC8 & | aData
 | ) | [virtual]

Callback from TCP transport handler when data is received.

Returns a set of flag indicating whether particular conditions were recognised based on the data content.

Implements MTransportHndObs.

void CTextModeRxData::DoFoundBodyL ( CTxData & aTrans ) [private]

void CTextModeRxData::DoFoundHeaderFieldContinuationL ( CTxData & aTrans ) [private]

void CTextModeRxData::DoFoundHeaderFieldL | ( | CTxData & | aTrans,
 |  | THttpRxDataStat & | aDataFlags
 | ) | [private]

void CTextModeRxData::DoFoundLineSeparatorL ( CTxData & aTrans ) [private]

virtual TBool CTextModeRxData::GetNextDataPart ( TPtrC8 & aDataChunk ) [virtual]

Obtain a part of data from the supplier. This is guaranteed to survive until a call is made to ReleaseData().

Implements MHTTPDataSupplier.

virtual void CTextModeRxData::HandleError | ( | CTxData & | aTrans,
 |  | TInt | aError
 | ) | [virtual]

Handle an error from the transport handler.

Implements MTransportHndObs.

void CTextModeRxData::HandleStatusLineL ( CTxData & aTrans ) [private]

Handles 100 continues in status line and sets status otherwise.

CTextModeRxData* CTextModeRxData::NewL | ( | CProtTransaction & | aProtTrans,
 |  | MTextModeTransportHandler & | aTransportHnd,
 |  | MRxDataObserver & | aObserver
 | ) | [static]

Factory construction for this class.

Build a new OTA received data holder to be associated with the specified transaction and TCP handler; and to be linked to the supplied observer

virtual TInt CTextModeRxData::OverallDataSize ( ) [virtual]

Obtain the overall size of the data being supplied, if known to the supplier.

Where a body of data is supplied in several chunks this size will be the sum of all the chunk sizes.

Implements MHTTPDataSupplier.

virtual void CTextModeRxData::ReleaseData ( ) [virtual]

Release the current data chunk being held at the data supplier.

This call indicates to the supplier that the chunk is no longer needed, and another one can be supplied, if appropriate.

Implements MHTTPDataSupplier.

virtual TInt CTextModeRxData::Reset ( ) [virtual]

Reset the data supplier.

This indicates to the data supplier that it should return to the first part of the data.

Implements MHTTPDataSupplier.

void CTextModeRxData::ResetRxData ( ) [virtual]

Reset the encoded data iterator to the first 'chunk' for transmission.

Implements CRxData.

virtual void CTextModeRxData::SetStatusL | ( | CTxData & | aTrans,
 |  | TInt | aStatus
 | ) | [virtual]

Callback from TCP transport handler to send a status message.

Implements MTransportHndObs.

MTextModeTransportHandler & CTextModeRxData::TextModeTransportHandler ( ) [inline, private]

Definition at line 422 of file CTextModeRxData.h.

References ETextModeTransportHandlerNotSet, iTextModeTransportHandler, and Panic().

Member Data Documentation

TInt CTextModeRxData::iBodyDataSizeSoFar [private]

The amount of body data received so far.

Definition at line 395 of file CTextModeRxData.h.

TBool CTextModeRxData::iConsumingResponse [private]

flag indicating that the we are consuming a response;

Definition at line 412 of file CTextModeRxData.h.

TInt CTextModeRxData::iEmptyLineCount [private]

The number of empty lines recognised in the response (which mark the end of header blocks).

Definition at line 399 of file CTextModeRxData.h.

RArray<TPtrC8> CTextModeRxData::iFoundBodyParts [private]

An array of identified body parts that are being sent to the client.

Definition at line 387 of file CTextModeRxData.h.

TBool CTextModeRxData::iFoundConnectionClose [private]

flag indicating that Connection:Close header has been received

Definition at line 418 of file CTextModeRxData.h.

TBool CTextModeRxData::iGotAllHeaders [private]

Flag indicating when our response parser believes it has reached the end of the response header section.

Definition at line 368 of file CTextModeRxData.h.

TBool CTextModeRxData::iHaveReadContentLengthHeader [private]

flag indicating that the content-length has been read from the header

Definition at line 403 of file CTextModeRxData.h.

RStringF CTextModeRxData::iLastHeaderName [private]

a string indicating the last response header added to the transaction.

Used to decide what header a header continuation line should be added to*

Definition at line 408 of file CTextModeRxData.h.

HBufC8* CTextModeRxData::iLineBuffer [private]

A buffer used to store the next line of the response.

This must be copied since the OTA chunks recieved from the TCP Client might contain partial lines at the start and end.

Definition at line 383 of file CTextModeRxData.h.

TInt CTextModeRxData::iOverallDataSize [private]

The overall data size of the response raw body data, if known or KErrNotFound (== -1) if not known.

Definition at line 391 of file CTextModeRxData.h.

TResponseParser CTextModeRxData::iParse [private]

The parser used to segment the received OTA response data.

Note that it doesn't form internal representations of the data (that is done by the Transaction Codec classes); rather it 'slices and dices' the response in order to store the OTA form of headers, to identify status codes and to understand the chunked transfer-encoding

Definition at line 378 of file CTextModeRxData.h.

TBool CTextModeRxData::iReplyComplete [private]

Flag indicating that the ReplyComplete status code has been received from the Transport Handler.

Definition at line 372 of file CTextModeRxData.h.

MTextModeTransportHandler* CTextModeRxData::iTextModeTransportHandler [private]

Definition at line 415 of file CTextModeRxData.h.

Referenced by TextModeTransportHandler().

The documentation for this class was generated from the following file:
  • CTextModeRxData.h


Member List

CTextModeRxData Member List

This is the complete list of members for CTextModeRxData, including all inherited members.
CheckConnectResponseL(TDesC8 &aBuffer) | CTextModeRxData | [virtual]
ConstructL() | CTextModeRxData | [private]
CRxData() | CRxData | [protected]
CRxData(CProtTransaction &aProtTrans, MRxDataObserver &aObserver) | CRxData | [protected]
CTextModeRxData() | CTextModeRxData | [private]
CTextModeRxData(CProtTransaction &aProtTrans, MTextModeTransportHandler &aTransportHnd, MRxDataObserver &aObserver) | CTextModeRxData | [private]
DataL(CTxData &aTrans, const TDesC8 &aData) | CTextModeRxData | [virtual]
DoFoundBodyL(CTxData &aTrans) | CTextModeRxData | [private]
DoFoundHeaderFieldContinuationL(CTxData &aTrans) | CTextModeRxData | [private]
DoFoundHeaderFieldL(CTxData &aTrans, THttpRxDataStat &aDataFlags) | CTextModeRxData | [private]
DoFoundLineSeparatorL(CTxData &aTrans) | CTextModeRxData | [private]
EBlankLineCount enum name | CTextModeRxData | [private]
EFirstBlankLine enum value | CTextModeRxData | [private]
ESecondBlankLine enum value | CTextModeRxData | [private]
GetNextDataPart(TPtrC8 &aDataChunk) | CTextModeRxData | [virtual]
HandleError(CTxData &aTrans, TInt aError) | CTextModeRxData | [virtual]
HandleStatusLineL(CTxData &aTrans) | CTextModeRxData | [private]
iBodyDataSizeSoFar | CTextModeRxData | [private]
iConsumingResponse | CTextModeRxData | [private]
iEmptyLineCount | CTextModeRxData | [private]
iFoundBodyParts | CTextModeRxData | [private]
iFoundConnectionClose | CTextModeRxData | [private]
iGotAllHeaders | CTextModeRxData | [private]
iHaveReadContentLengthHeader | CTextModeRxData | [private]
iLastHeaderName | CTextModeRxData | [private]
iLineBuffer | CTextModeRxData | [private]
iObserver | CRxData | [protected]
iOverallDataSize | CTextModeRxData | [private]
iParse | CTextModeRxData | [private]
iProtTrans | CRxData | [protected]
iReplyComplete | CTextModeRxData | [private]
iTextModeTransportHandler | CTextModeRxData | [private]
NewL(CProtTransaction &aProtTrans, MTextModeTransportHandler &aTransportHnd, MRxDataObserver &aObserver) | CTextModeRxData | [static]
OverallDataSize() | CTextModeRxData | [virtual]
ProtTrans() | CRxData |
ReleaseData() | CTextModeRxData | [virtual]
Reset() | CTextModeRxData | [virtual]
ResetRxData() | CTextModeRxData | [virtual]
SetStatusL(CTxData &aTrans, TInt aStatus) | CTextModeRxData | [virtual]
TextModeTransportHandler() | CTextModeRxData | [inline, private]
~CRxData() | CRxData | [virtual]
~CTextModeRxData() | CTextModeRxData | [virtual]


MTextModeTransportHandler Class Reference

MTextModeTransportHandler is the interface used by the transport framework textmode http protocol handler. More...

#include <MTextModeTransportHandler.h>

Inheritance diagram for MTextModeTransportHandler:

[legend]
List of all members.

Public Types

enum | TServerConnectionStatus { ENotConnected, EConnectedAndAvailable, EConnectedNotAvailable }
Status enum indicates what state the transport handler is in. More...

Public Methods

virtual void | Close ()=0
Close is called when the protocol handler has finished with the text mode transport handler.

virtual TServerConnectionStatus | Status () const=0
Status returns an indication which can be used to decide if more submissions should be made using this instantiation of a MTextModeTransportHandler.

virtual const CHttpTcpServerLocation & | ServerLocation () const=0
Returns the location that the protocol is currently or was last connected to.

virtual void | SubmitL (CHttpTcpServerLocation *aServerLocation, CTxData &aData, MTransportHndObs &aObs)=0
Submit a new transaction by supplying a CTextModeProtocolTransaction.

virtual void | CancelSubmission (CTxData &aDataToCancel)=0
Cancel a prior submission of transmission data.

virtual void | AckData ()=0
Acknowledge the receipt of response data, to allow the TCP Client to continue fetching further data from the origin/proxy server.

virtual void | NotifyRequestDataAvailable ()=0
Provide notification that new request data is available for transmission.

virtual TInt | ServerCert (TCertInfo &aServerCert)=0
Get the Server Certificate for the current session.

Detailed Description

MTextModeTransportHandler is the interface used by the transport framework textmode http protocol handler.

It hides the real transport specific details from the protocol handler

Definition at line 20 of file MTextModeTransportHandler.h.

Member Enumeration Documentation

enum MTextModeTransportHandler::TServerConnectionStatus

Status enum indicates what state the transport handler is in.

This information can be used to decide if a particular instance can be used

Enumeration values:
ENotConnected
EConnectedAndAvailable
EConnectedNotAvailable

Definition at line 25 of file MTextModeTransportHandler.h.

Member Function Documentation

virtual void MTextModeTransportHandler::AckData ( ) [pure virtual]

Acknowledge the receipt of response data, to allow the TCP Client to continue fetching further data from the origin/proxy server.

Implemented in CHttpTcpClient.

virtual void MTextModeTransportHandler::CancelSubmission ( CTxData & aDataToCancel ) [pure virtual]

Cancel a prior submission of transmission data.

If it is currently active the protocol will be cancelled

Implemented in CHttpTcpClient.

virtual void MTextModeTransportHandler::Close ( ) [pure virtual]

Close is called when the protocol handler has finished with the text mode transport handler.

Implemented in CHttpTcpClient.

virtual void MTextModeTransportHandler::NotifyRequestDataAvailable ( ) [pure virtual]

Provide notification that new request data is available for transmission.

Used to unblock the protocol in which request data is transmitted.

Implemented in CHttpTcpClient.

virtual TInt MTextModeTransportHandler::ServerCert ( TCertInfo & aServerCert ) [pure virtual]

Get the Server Certificate for the current session.

Parameters:
aServerCert A TCertInfo which will be filled with the certificate information
Returns:
An error code. KErrNone if aServerCert has been completed, otherwise one of the system wide error codes

Implemented in CHttpTcpClient.

virtual const CHttpTcpServerLocation& MTextModeTransportHandler::ServerLocation ( ) [pure virtual]

Returns the location that the protocol is currently or was last connected to.

@panic If called when not status is ENotConnected

Implemented in CHttpTcpClient.

virtual TServerConnectionStatus MTextModeTransportHandler::Status ( ) [pure virtual]

Status returns an indication which can be used to decide if more submissions should be made using this instantiation of a MTextModeTransportHandler.

Implemented in CHttpTcpClient.

virtual void MTextModeTransportHandler::SubmitL | ( | CHttpTcpServerLocation * | aServerLocation,
 |  | CTxData & | aData,
 |  | MTransportHndObs & | aObs
 | ) | [pure virtual]

Submit a new transaction by supplying a CTextModeProtocolTransaction.

This is queried to find out things such as persistence

Implemented in CHttpTcpClient.

The documentation for this class was generated from the following file:
  • MTextModeTransportHandler.h


Member List

MTextModeTransportHandler Member List

This is the complete list of members for MTextModeTransportHandler, including all inherited members.
AckData()=0 | MTextModeTransportHandler | [pure virtual]
CancelSubmission(CTxData &aDataToCancel)=0 | MTextModeTransportHandler | [pure virtual]
Close()=0 | MTextModeTransportHandler | [pure virtual]
EConnectedAndAvailable enum value | MTextModeTransportHandler |
EConnectedNotAvailable enum value | MTextModeTransportHandler |
ENotConnected enum value | MTextModeTransportHandler |
NotifyRequestDataAvailable()=0 | MTextModeTransportHandler | [pure virtual]
ServerCert(TCertInfo &aServerCert)=0 | MTextModeTransportHandler | [pure virtual]
ServerLocation() const=0 | MTextModeTransportHandler | [pure virtual]
Status() const=0 | MTextModeTransportHandler | [pure virtual]
SubmitL(CHttpTcpServerLocation *aServerLocation, CTxData &aData, MTransportHndObs &aObs)=0 | MTextModeTransportHandler | [pure virtual]
TServerConnectionStatus enum name | MTextModeTransportHandler |


CTextModeTxData Class Reference

A representation of over-the-air transmitted data for Text-Mode HTTP. More...

#include <CTextModeTxData.h>

Inheritance diagram for CTextModeTxData:

[legend]
Collaboration diagram for CTextModeTxData:

[legend]
List of all members.

Public Methods

virtual | ~CTextModeTxData ()
Destructor - cleans up and releases resources to the system.

void | NotifyNewRequestBodyPart ()
virtual TBool | GetNextDataPart (TPtrC8 &aDataPart)
virtual void | ReleaseData ()
virtual TInt | OverallDataSize ()
virtual TInt | Reset ()

Static Public Methods

CTextModeTxData * | NewL (CProtTransaction &aTrans, MTextModeTransportHandler &aTransportHnd)
Factory construction, creates an OTA transmit data holder based on the supplied transaction.

CTextModeTxData * | NewL (const TDesC8 &aEncodedData)
Factory construction, creates an OTA transmit data holder based on some ready-encoded data.

Private Methods

virtual void | ReAllocBufferL (TInt aRequiredLength, TPtr8 &aBuffer)
void | PrepareMessageL ()
Prepare the transmitted message as an HTTP request, ie. a request line followed by headers from the transaction.

CTextModeTxData ()
Default constructor.

CTextModeTxData (CProtTransaction &aTrans, MTextModeTransportHandler &aTextModeTransportHnd)
Normal constructor - construct using the specified transaction.

void | ConstructL ()
Second phase construction, default.

void | ConstructL (const TDesC8 &aEncodedData)
Second phase construction, copies the supplied ready-encoded data.

MTextModeTransportHandler & TextModeTransportHandler ()

Private Attributes

TRequestComposer iComposer
The composer of over-the-air encoded HTTP request data.

TBool | iTransSet
Flag that records whether the object was constructed using a transaction or with encoded data.

HBufC8 * | iEncodedData
A buffer to contain the encoded transmission data.

TBool | iLastChunk
Record of whether our data supplier (obtained via iTrans's request) has already given us the last chunk of body data.

TInt | iChunksSent
Number of chunks sent by this class due to calls to GetNextChunkL().

TBool | iMustReleaseDataSupplier
Record of whether the client's request body data supplier must be released when ReleaseChunk() is called.

MTextModeTransportHandler * iTextModeTransportHandler

Detailed Description

A representation of over-the-air transmitted data for Text-Mode HTTP.

This object handles data to be sent to an origin server/proxy and, using its TRequestComposer, constructs the request in chunks for transmission. This includes, for POST, using the 'chunked' transfer encoding if the body length isn't known up-front. It gets the required OTA header representations from the RHTTPRequest's header collection and encoding them.

Definition at line 241 of file CTextModeTxData.h.

Constructor & Destructor Documentation

virtual CTextModeTxData::~CTextModeTxData ( ) [virtual]

Destructor - cleans up and releases resources to the system.

CTextModeTxData::CTextModeTxData ( ) [private]

Default constructor.

CTextModeTxData::CTextModeTxData | ( | CProtTransaction & | aTrans,
 |  | MTextModeTransportHandler & | aTextModeTransportHnd
 | ) | [private]

Normal constructor - construct using the specified transaction.

Member Function Documentation

void CTextModeTxData::ConstructL ( const TDesC8 & aEncodedData ) [private]

Second phase construction, copies the supplied ready-encoded data.

void CTextModeTxData::ConstructL ( ) [private]

Second phase construction, default.

Reimplemented from CTxData.

CTextModeTxData::GetNextDataPart ( TPtrC8 & aDataPart ) [virtual]

See also:
MHTTPDataSupplier

Implements MHTTPDataSupplier.

CTextModeTxData* CTextModeTxData::NewL ( const TDesC8 & aEncodedData ) [static]

Factory construction, creates an OTA transmit data holder based on some ready-encoded data.

Note that this is not used in real usage but is supplied for testing purposes.

CTextModeTxData* CTextModeTxData::NewL | ( | CProtTransaction & | aTrans,
 |  | MTextModeTransportHandler & | aTransportHnd
 | ) | [static]

Factory construction, creates an OTA transmit data holder based on the supplied transaction.

void CTextModeTxData::NotifyNewRequestBodyPart ( )

CTextModeTxData::OverallDataSize ( ) [virtual]

See also:
MHTTPDataSupplier

Implements MHTTPDataSupplier.

void CTextModeTxData::PrepareMessageL ( ) [private]

Prepare the transmitted message as an HTTP request, ie. a request line followed by headers from the transaction.

CTextModeTxData::ReAllocBufferL | ( | TInt | aRequiredLength,
 |  | TPtr8 & | aBuffer
 | ) | [private, virtual]

See also:
MComposerObserver

Implements MComposerObserver.

CTextModeTxData::ReleaseData ( ) [virtual]

See also:
MHTTPDataSupplier

Implements MHTTPDataSupplier.

CTextModeTxData::Reset ( ) [virtual]

See also:
MHTTPDataSupplier

Implements MHTTPDataSupplier.

MTextModeTransportHandler & CTextModeTxData::TextModeTransportHandler ( ) [inline, private]

Definition at line 392 of file CTextModeTxData.h.

References ETextModeTransportHandlerNotSet, iTextModeTransportHandler, and Panic().

Member Data Documentation

TInt CTextModeTxData::iChunksSent [private]

Number of chunks sent by this class due to calls to GetNextChunkL().

Definition at line 342 of file CTextModeTxData.h.

TRequestComposer CTextModeTxData::iComposer [private]

The composer of over-the-air encoded HTTP request data.

Definition at line 325 of file CTextModeTxData.h.

HBufC8* CTextModeTxData::iEncodedData [private]

A buffer to contain the encoded transmission data.

Definition at line 333 of file CTextModeTxData.h.

TBool CTextModeTxData::iLastChunk [private]

Record of whether our data supplier (obtained via iTrans's request) has already given us the last chunk of body data.

Definition at line 338 of file CTextModeTxData.h.

TBool CTextModeTxData::iMustReleaseDataSupplier [private]

Record of whether the client's request body data supplier must be released when ReleaseChunk() is called.

Definition at line 346 of file CTextModeTxData.h.

MTextModeTransportHandler* CTextModeTxData::iTextModeTransportHandler [private]

Definition at line 349 of file CTextModeTxData.h.

Referenced by TextModeTransportHandler().

TBool CTextModeTxData::iTransSet [private]

Flag that records whether the object was constructed using a transaction or with encoded data.

Definition at line 329 of file CTextModeTxData.h.

The documentation for this class was generated from the following file:
  • CTextModeTxData.h


Member List

CTextModeTxData Member List

This is the complete list of members for CTextModeTxData, including all inherited members.
ConstructL() | CTextModeTxData | [private]
ConstructL(const TDesC8 &aEncodedData) | CTextModeTxData | [private]
CTextModeTxData() | CTextModeTxData | [private]
CTextModeTxData(CProtTransaction &aTrans, MTextModeTransportHandler &aTextModeTransportHnd) | CTextModeTxData | [private]
CTxData() | CTxData | [protected]
CTxData(CProtTransaction &aProtTransaction) | CTxData | [protected]
GetNextDataPart(TPtrC8 &aDataPart) | CTextModeTxData | [virtual]
iChunksSent | CTextModeTxData | [private]
iComposer | CTextModeTxData | [private]
iEncodedData | CTextModeTxData | [private]
iLastChunk | CTextModeTxData | [private]
iMustReleaseDataSupplier | CTextModeTxData | [private]
iProtTrans | CTxData | [protected]
iTextModeTransportHandler | CTextModeTxData | [private]
iTransSet | CTextModeTxData | [private]
NewL(CProtTransaction &aTrans, MTextModeTransportHandler &aTransportHnd) | CTextModeTxData | [static]
NewL(const TDesC8 &aEncodedData) | CTextModeTxData | [static]
NotifyNewRequestBodyPart() | CTextModeTxData |
OverallDataSize() | CTextModeTxData | [virtual]
PrepareMessageL() | CTextModeTxData | [private]
ProtTrans() | CTxData |
ReAllocBufferL(TInt aRequiredLength, TPtr8 &aBuffer) | CTextModeTxData | [private, virtual]
ReleaseData() | CTextModeTxData | [virtual]
Reset() | CTextModeTxData | [virtual]
TextModeTransportHandler() | CTextModeTxData | [inline, private]
~CTextModeTxData() | CTextModeTxData | [virtual]
~CTxData() | CTxData | [virtual]


RHTTPTransaction Class Reference

@public
Since:
7.0 A HTTP Transaction.
More...

#include <RHTTPTransaction.h>

Collaboration diagram for RHTTPTransaction:

[legend]
List of all members.

Public Methods

RHTTPTransaction ()
Default (uninitialised) constructor.

IMPORT_C void | SubmitL (THTTPFilterHandle aStart=THTTPFilterHandle::EClient)
Submits a transaction.

IMPORT_C void | NotifyNewRequestBodyPartL (THTTPFilterHandle aStart=THTTPFilterHandle::EClient)
Notify HTTP of the availability of more request body data, when submitting body data in several parts.

IMPORT_C void | SendEventL (THTTPEvent aStatus, THTTPEvent::TDirection aDirection, THTTPFilterHandle aStart)
Sends a status message to all relevant filters.

IMPORT_C RHTTPResponse | Response () const
Gets the response.

IMPORT_C RHTTPRequest | Request () const
Gets the request.

IMPORT_C RHTTPSession | Session () const
Returns the session associated with the transaction.

IMPORT_C RHTTPTransactionPropertySet | PropertySet () const
Returns the transaction's property set.

IMPORT_C void | Cancel (THTTPFilterHandle aStart=THTTPFilterHandle::EClient)
Cancels the transaction.

IMPORT_C void | Close ()
Closes the transaction and frees all owned resources.

IMPORT_C void | Fail (THTTPFilterHandle aStart=THTTPFilterHandle::ECurrentFilter)
This function should be called by filters when they have failed due to running out of memory.

TBool | operator== (RHTTPTransaction aTrans) const
Equality operator to check if this transaction is the same as that one.

TBool | operator!= (RHTTPTransaction aTrans) const
Inequality operator.

IMPORT_C TInt | Id () const
Obtain this transaction's ID, which is unique within its session.

IMPORT_C TInt | ServerCert (TCertInfo &aServerCert)
Obtain the server certificate information for this transaction.

Private Attributes

CTransaction * iImplementation

Friends

class | RHTTPSession
class | CTransaction

Detailed Description

@public
Since:
7.0 A HTTP Transaction.

This encapsulates 1 HTTP request and response. A Transaction is associated with a session, and must be created using the session's CreateTransactionL method.

See also:
RHTTPSession , RHTTPSession::CreateTransactionL

Definition at line 38 of file RHTTPTransaction.h.

Constructor & Destructor Documentation

RHTTPTransaction::RHTTPTransaction ( ) [inline]

Default (uninitialised) constructor.

Definition at line 173 of file RHTTPTransaction.h.

Member Function Documentation

IMPORT_C void RHTTPTransaction::Cancel ( THTTPFilterHandle aStart = THTTPFilterHandle::EClient )

Cancels the transaction.

Parameters:
aStart The entity that is initiating the cancel (defaults to the client). See THTTPFilterHandle for the values this can take.

IMPORT_C void RHTTPTransaction::Close ( )

Closes the transaction and frees all owned resources.

Transactions must be opened using RHTTPSession::OpenTransactionL. It is also closed when you close the session.

IMPORT_C void RHTTPTransaction::Fail ( THTTPFilterHandle aStart = THTTPFilterHandle::ECurrentFilter )

This function should be called by filters when they have failed due to running out of memory.

It cancels the transaction and sends the synchronous events EUnrecoverableError and EFailed to the client to inform it of the failure. For instance in a filter that attempts to send an event to the client from a MHFRunError to inform the client of a failure, if the call to SendEventL leaves, Fail() may be used to 'give up'.

IMPORT_C TInt RHTTPTransaction::Id ( )

Obtain this transaction's ID, which is unique within its session.

This is mostly used for producing a slightly-meaningful way of identifying transactions in logging code.

Returns:
The transaction ID.

IMPORT_C void RHTTPTransaction::NotifyNewRequestBodyPartL ( THTTPFilterHandle aStart = THTTPFilterHandle::EClient )

Notify HTTP of the availability of more request body data, when submitting body data in several parts.

Parameters:
aStart The filter supplying the new data. This will almost always be the client (default value)
Exceptions:
KErrNoMemory There was not enough memory.

TBool RHTTPTransaction::operator!= ( RHTTPTransaction aTrans ) const [inline]

Inequality operator.

Parameters:
aTrans The transaction to compare this one to.

Definition at line 168 of file RHTTPTransaction.h.

TBool RHTTPTransaction::operator== ( RHTTPTransaction aTrans ) const [inline]

Equality operator to check if this transaction is the same as that one.

Parameters:
aTrans The transaction to compare this one to.

Definition at line 164 of file RHTTPTransaction.h.

References iImplementation.

IMPORT_C RHTTPTransactionPropertySet RHTTPTransaction::PropertySet ( )

Returns the transaction's property set.

This is used by filters to store transaction-specific information, and by clients to specify things like reload or no cache behaviour.

IMPORT_C RHTTPRequest RHTTPTransaction::Request ( )

Gets the request.

IMPORT_C RHTTPResponse RHTTPTransaction::Response ( )

Gets the response.

Note that the returned response may not be valid if it hasn't been created yet.

See also:
RHTTPMessage::IsValid()

IMPORT_C void RHTTPTransaction::SendEventL | ( | THTTPEvent | aStatus,
 |  | THTTPEvent::TDirection | aDirection,
 |  | THTTPFilterHandle | aStart
 | ) |

Sends a status message to all relevant filters.

This function is predominantly used by filters, rather than by the client.

Parameters:
aStatus | The status message to send.
aDirection | The direction down the filter queue that this event will be propogated.
Exceptions:
KErrNoMemory There was not enough memory.

IMPORT_C TInt RHTTPTransaction::ServerCert ( TCertInfo & aServerCert )

Obtain the server certificate information for this transaction.

This function should only be used for text-mode, for WSP use RHttpSession::ServerCert.

See also:
RHttpSession::ServerCert
Parameters:
aServerCert A client supplied object into which the certificate information will be placed.
Returns:
KErrNone if certificate has been completed, KErrNotSupported if this function is called for WSP.

IMPORT_C RHTTPSession RHTTPTransaction::Session ( )

Returns the session associated with the transaction.

IMPORT_C void RHTTPTransaction::SubmitL ( THTTPFilterHandle aStart = THTTPFilterHandle::EClient )

Submits a transaction.

Once all the headers and other details have been set up, this call actualy causes the request to be made.

Exceptions:
KErrNoMemory There was not enough memory.

Friends And Related Function Documentation

friend class CTransaction [friend]

Definition at line 157 of file RHTTPTransaction.h.

friend class RHTTPSession [friend]

Definition at line 156 of file RHTTPTransaction.h.

Member Data Documentation

CTransaction* RHTTPTransaction::iImplementation [private]

Definition at line 161 of file RHTTPTransaction.h.

Referenced by operator==().

The documentation for this class was generated from the following file:
  • RHTTPTransaction.h


Member List

RHTTPTransaction Member List

This is the complete list of members for RHTTPTransaction, including all inherited members.
Cancel(THTTPFilterHandle aStart=THTTPFilterHandle::EClient) | RHTTPTransaction |
Close() | RHTTPTransaction |
CTransaction class | RHTTPTransaction | [friend]
Fail(THTTPFilterHandle aStart=THTTPFilterHandle::ECurrentFilter) | RHTTPTransaction |
Id() const | RHTTPTransaction |
iImplementation | RHTTPTransaction | [private]
NotifyNewRequestBodyPartL(THTTPFilterHandle aStart=THTTPFilterHandle::EClient) | RHTTPTransaction |
operator!=(RHTTPTransaction aTrans) const | RHTTPTransaction | [inline]
operator==(RHTTPTransaction aTrans) const | RHTTPTransaction | [inline]
PropertySet() const | RHTTPTransaction |
Request() const | RHTTPTransaction |
Response() const | RHTTPTransaction |
RHTTPSession class | RHTTPTransaction | [friend]
RHTTPTransaction() | RHTTPTransaction | [inline]
SendEventL(THTTPEvent aStatus, THTTPEvent::TDirection aDirection, THTTPFilterHandle aStart) | RHTTPTransaction |
ServerCert(TCertInfo &aServerCert) | RHTTPTransaction |
Session() const | RHTTPTransaction |
SubmitL(THTTPFilterHandle aStart=THTTPFilterHandle::EClient) | RHTTPTransaction |


CTransaction Class Reference

Implementation class for the transaction
See also:
RHTTPTransaction.
More...

#include <CTransaction.h>

Collaboration diagram for CTransaction:

[legend]
List of all members.

Public Methods

void | SendEventL (THTTPEvent &aEvent, TInt aDirection, THTTPFilterHandle aStart)
See also:
RHTTPTransaction::SendEventL

void | SynchronousSendEvent (THTTPEvent aEvent, TInt aDirection, THTTPFilterHandle aStart)
Sends an event syncronously.

RHTTPSession | Session () const
Returns the transaction's session.

CHeaderCodec & | Codec () const
Returns the transaction's codec.

CRequest & | Request () const
Returns the request object.

CResponse & | Response () const
Returns the response object.

TInt | Id () const
Returns the transactions ID.

RHTTPTransactionPropertySet | PropertySet () const
Returns the transaction's property set.

void | CancelTransaction (THTTPFilterHandle aStart)
Cancels the transaction.

void | Close ()
'Closes the transaction'.

void | Fail (THTTPFilterHandle aStart)
Fails the transaction.

MHTTPTransactionCallback & | Callback () const
Returns the callback for this transaction.

void | Unblock ()
If the transaction has previously blocked, set itself active and continue running.

RHTTPTransaction Handle ()
Returns a RHTTPTransaction for this CTransaction.

TBool | SyncMode () const
TInt | ServerCert (TCertInfo &aServerCert)
Get the Server Certificate for this transaction.

Static Public Methods

CTransaction * | NewL (MHTTPTransactionCallback &aCallback, const TUriC8 &aURI, CHTTPSession &aSession, RStringF aMethod)
Constructs a transaction.

CTransaction * | Implementation (RHTTPTransaction aHandle)
Extracts the implementation from a RHTTPTransaction.

Private Types

enum TTransactionStates {
EPassive = 0, EFilter, EInFilter, EExiting,
EBlocked, ECancelled
}
States the transaction can be in. More...

Private Methods

virtual void | RunL ()
Active object RunL; executes 1 filter.

virtual void | DoCancel ()
From CActive. Does nothing.

virtual TInt | RunError (TInt aError)
From CActive. Offers the error to the current filter.

CTransaction (MHTTPTransactionCallback &aCallback, CHTTPSession &aSession)
Constructor.

void | ConstructL (const TUriC8 &aURI, RStringF aMethod)
2 phase construcion

TInt | AddEvent (THTTPEvent &aEvent, TInt aDirection, THTTPFilterHandle aStart)
Adds an event to the queue (but doesn't start it).

TTransactionStates FindFilterForThisEvent ()
Finds the next filter for the current event.

TTransactionStates FindNextFilter ()
Finds the next filter (possibly in another event).

void | Activate (TTransactionStates aStatus)
Sets the AO active and enters the specified state.

TBool | RunOneFilterL ()
Runs the filter that's waiting to run.

void | NextFilter ()
Moves on to the next filter.

const TEventRegistration & | CurrentEvent () const
TBool | EventAvailable () const
TInt | AppendEvent (TEventRegistration &aEvent)
void | RemoveEvent ()

Private Attributes

CRequest * iRequest
The request.

CResponse * iResponse
The response.

CHTTPTransactionCodec * | iCodec
The codec.

MHTTPTransactionCallback & iCallback
The client.

CHTTPSession & iSession
The session.

TInt | iId
The transaction's ID, unique within the session.

TInt | iCurrentFilter
The filter currently running.

THTTPEvent iASyncEvent
It will keep a copy of the event as it is before leave caused by a syncronous event occours This will be used to handle RunErrorL() with the right parameters.

TInt | iCurrentASyncFilter
It will keep a copy of the the iNextFilter variable before a leave caused by a syncronous event occours This will be used to handle RunErrorL() with the right parameters.

TInt | iNextFilter
The next filter to be run.

TBool | iProcessingSyncEvent
True when processing sync events.

RArray< TEventRegistration > | iEventQueue
The event queue.

TEventRegistration iCurrentSyncEvent
A slot for async events.

RHTTPTransactionPropertySet iPropertySet

Detailed Description

Implementation class for the transaction
See also:
RHTTPTransaction.

Definition at line 19 of file CTransaction.h.

Member Enumeration Documentation

enum CTransaction::TTransactionStates [private]

States the transaction can be in.

Enumeration values:
EPassive | No events are occuring.
EFilter | There is a 'next filter' to run.
EInFilter | In filter code.
EExiting | The transaction has been closed from within a filter's MHFRunL (detectable as the state is either EInFilter or ECancelled at the time of the close) and so is 'zombified' until the filter returns from its MHFRunL, at which point the transaction will delete itself.
EBlocked The transaction's RunL has fired from within an active scheduler started from within a filter on another transaction.

This transaction must be rescheduled once the other transaction has finished.

ECancelled | The transaction has been cancelled from within a filter.

Definition at line 129 of file CTransaction.h.

Constructor & Destructor Documentation

CTransaction::CTransaction | ( | MHTTPTransactionCallback & | aCallback,
 |  | CHTTPSession & | aSession
 | ) | [private]

Constructor.

Member Function Documentation

void CTransaction::Activate ( TTransactionStates aStatus ) [private]

Sets the AO active and enters the specified state.

TInt CTransaction::AddEvent | ( | THTTPEvent & | aEvent,
 |  | TInt | aDirection,
 |  | THTTPFilterHandle | aStart
 | ) | [private]

Adds an event to the queue (but doesn't start it).

TInt CTransaction::AppendEvent ( TEventRegistration & aEvent ) [private]

MHTTPTransactionCallback& CTransaction::Callback ( ) [inline]

Returns the callback for this transaction.

void CTransaction::CancelTransaction ( THTTPFilterHandle aStart )

Cancels the transaction.

This removes all outstanding events and sends a cancel event outward.

void CTransaction::Close ( )

'Closes the transaction'.

This is essentialy the way other objects destroy the transaction. They don't directly call the destructor in order to cope with filters closing the transaction, in which situation the transaction will zombify itself, deleting itself when the stack is unwound.

CHeaderCodec& CTransaction::Codec ( )

Returns the transaction's codec.

void CTransaction::ConstructL | ( | const TUriC8 & | aURI,
 |  | RStringF | aMethod
 | ) | [private]

2 phase construcion

const TEventRegistration& CTransaction::CurrentEvent ( ) [private]

virtual void CTransaction::DoCancel ( ) [private, virtual]

From CActive. Does nothing.

TBool CTransaction::EventAvailable ( ) [private]

void CTransaction::Fail ( THTTPFilterHandle aStart ) [inline]

Fails the transaction.

That is to say, cancel the transaction and send the synchronous events 'EUnrecoverableError' and 'EFailed'. It implements the RHTTPTransaction::Fail function.

TTransactionStates CTransaction::FindFilterForThisEvent ( ) [private]

Finds the next filter for the current event.

Returns:
EFilter if a filter was found, EPassive otherwise

TTransactionStates CTransaction::FindNextFilter ( ) [private]

Finds the next filter (possibly in another event).

Returns:
The new state

RHTTPTransaction CTransaction::Handle ( ) [inline]

Returns a RHTTPTransaction for this CTransaction.

TInt CTransaction::Id ( ) [inline]

Returns the transactions ID.

CTransaction* CTransaction::Implementation ( RHTTPTransaction aHandle ) [inline, static]

Extracts the implementation from a RHTTPTransaction.

CTransaction* CTransaction::NewL | ( | MHTTPTransactionCallback & | aCallback,
 |  | const TUriC8 & | aURI,
 |  | CHTTPSession & | aSession,
 |  | RStringF | aMethod
 | ) | [static]

Constructs a transaction.

void CTransaction::NextFilter ( ) [private]

Moves on to the next filter.

RHTTPTransactionPropertySet CTransaction::PropertySet ( ) [inline]

Returns the transaction's property set.

void CTransaction::RemoveEvent ( ) [private]

CRequest& CTransaction::Request ( ) [inline]

Returns the request object.

CResponse& CTransaction::Response ( ) [inline]

Returns the response object.

virtual TInt CTransaction::RunError ( TInt aError ) [private, virtual]

From CActive. Offers the error to the current filter.

virtual void CTransaction::RunL ( ) [private, virtual]

Active object RunL; executes 1 filter.

TBool CTransaction::RunOneFilterL ( ) [private]

Runs the filter that's waiting to run.

void CTransaction::SendEventL | ( | THTTPEvent & | aEvent,
 |  | TInt | aDirection,
 |  | THTTPFilterHandle | aStart
 | ) |

See also:
RHTTPTransaction::SendEventL

TInt CTransaction::ServerCert ( TCertInfo & aServerCert )

Get the Server Certificate for this transaction.

Parameters:
aServerCert A TCertInfo which will be filled with the certificate information
Returns:
An error code. KErrNone if aServerCert has been completed, otherwise one of the system wide error codes

RHTTPSession CTransaction::Session ( )

Returns the transaction's session.

void CTransaction::SynchronousSendEvent | ( | THTTPEvent | aEvent,
 |  | TInt | aDirection,
 |  | THTTPFilterHandle | aStart
 | ) |

Sends an event syncronously.

Only callable when there are no outstanding events.

See also:
SendEventL __ASSERT_DEBUG will panic if there are outstanding events.

TBool CTransaction::SyncMode ( ) [inline]

void CTransaction::Unblock ( ) [inline]

If the transaction has previously blocked, set itself active and continue running.

Member Data Documentation

THTTPEvent CTransaction::iASyncEvent [private]

It will keep a copy of the event as it is before leave caused by a syncronous event occours This will be used to handle RunErrorL() with the right parameters.

Definition at line 226 of file CTransaction.h.

MHTTPTransactionCallback& CTransaction::iCallback [private]

The client.

Definition at line 212 of file CTransaction.h.

CHTTPTransactionCodec* CTransaction::iCodec [private]

The codec.

Definition at line 209 of file CTransaction.h.

TInt CTransaction::iCurrentASyncFilter [private]

It will keep a copy of the the iNextFilter variable before a leave caused by a syncronous event occours This will be used to handle RunErrorL() with the right parameters.

Definition at line 231 of file CTransaction.h.

TInt CTransaction::iCurrentFilter [private]

The filter currently running.

Definition at line 221 of file CTransaction.h.

TEventRegistration CTransaction::iCurrentSyncEvent [private]

A slot for async events.

Definition at line 246 of file CTransaction.h.

RArray<TEventRegistration> CTransaction::iEventQueue [private]

The event queue.

Definition at line 242 of file CTransaction.h.

TInt CTransaction::iId [private]

The transaction's ID, unique within the session.

Definition at line 218 of file CTransaction.h.

TInt CTransaction::iNextFilter [private]

The next filter to be run.

Definition at line 235 of file CTransaction.h.

TBool CTransaction::iProcessingSyncEvent [private]

True when processing sync events.

Definition at line 239 of file CTransaction.h.

RHTTPTransactionPropertySet CTransaction::iPropertySet [private]

Definition at line 249 of file CTransaction.h.

CRequest* CTransaction::iRequest [private]

The request.

Definition at line 203 of file CTransaction.h.

CResponse* CTransaction::iResponse [private]

The response.

Definition at line 206 of file CTransaction.h.

CHTTPSession& CTransaction::iSession [private]

The session.

Definition at line 215 of file CTransaction.h.

The documentation for this class was generated from the following file:
  • CTransaction.h


Member List

CTransaction Member List

This is the complete list of members for CTransaction, including all inherited members.
Activate(TTransactionStates aStatus) | CTransaction | [private]
AddEvent(THTTPEvent &aEvent, TInt aDirection, THTTPFilterHandle aStart) | CTransaction | [private]
AppendEvent(TEventRegistration &aEvent) | CTransaction | [private]
Callback() const | CTransaction | [inline]
CancelTransaction(THTTPFilterHandle aStart) | CTransaction |
Close() | CTransaction |
Codec() const | CTransaction |
ConstructL(const TUriC8 &aURI, RStringF aMethod) | CTransaction | [private]
CTransaction(MHTTPTransactionCallback &aCallback, CHTTPSession &aSession) | CTransaction | [private]
CurrentEvent() const | CTransaction | [private]
DoCancel() | CTransaction | [private, virtual]
EBlocked enum value | CTransaction | [private]
ECancelled enum value | CTransaction | [private]
EExiting enum value | CTransaction | [private]
EFilter enum value | CTransaction | [private]
EInFilter enum value | CTransaction | [private]
EPassive enum value | CTransaction | [private]
EventAvailable() const | CTransaction | [private]
Fail(THTTPFilterHandle aStart) | CTransaction | [inline]
FindFilterForThisEvent() | CTransaction | [private]
FindNextFilter() | CTransaction | [private]
Handle() | CTransaction | [inline]
iASyncEvent | CTransaction | [private]
iCallback | CTransaction | [private]
iCodec | CTransaction | [private]
iCurrentASyncFilter | CTransaction | [private]
iCurrentFilter | CTransaction | [private]
iCurrentSyncEvent | CTransaction | [private]
Id() const | CTransaction | [inline]
iEventQueue | CTransaction | [private]
iId | CTransaction | [private]
Implementation(RHTTPTransaction aHandle) | CTransaction | [inline, static]
iNextFilter | CTransaction | [private]
iProcessingSyncEvent | CTransaction | [private]
iPropertySet | CTransaction | [private]
iRequest | CTransaction | [private]
iResponse | CTransaction | [private]
iSession | CTransaction | [private]
NewL(MHTTPTransactionCallback &aCallback, const TUriC8 &aURI, CHTTPSession &aSession, RStringF aMethod) | CTransaction | [static]
NextFilter() | CTransaction | [private]
PropertySet() const | CTransaction | [inline]
RemoveEvent() | CTransaction | [private]
Request() const | CTransaction | [inline]
Response() const | CTransaction | [inline]
RunError(TInt aError) | CTransaction | [private, virtual]
RunL() | CTransaction | [private, virtual]
RunOneFilterL() | CTransaction | [private]
SendEventL(THTTPEvent &aEvent, TInt aDirection, THTTPFilterHandle aStart) | CTransaction |
ServerCert(TCertInfo &aServerCert) | CTransaction |
Session() const | CTransaction |
SynchronousSendEvent(THTTPEvent aEvent, TInt aDirection, THTTPFilterHandle aStart) | CTransaction |
SyncMode() const | CTransaction | [inline]
TTransactionStates enum name | CTransaction | [private]
Unblock() | CTransaction | [inline]


MHTTPTransactionCallback Class Reference

@public
Since:
7.0 The per-transaction callback for receiving HTTP events.
More...

#include <mhttptransactioncallback.h>

Inheritance diagram for MHTTPTransactionCallback:

[legend]
List of all members.

Public Methods

virtual void | MHFRunL (RHTTPTransaction aTransaction, const THTTPEvent &aEvent)=0
Called when the filter's registration conditions are satisfied for events that occur on a transaction.

virtual TInt | MHFRunError (TInt aError, RHTTPTransaction aTransaction, const THTTPEvent &aEvent)=0
Called when RunL leaves from a transaction event.

Detailed Description

@public
Since:
7.0 The per-transaction callback for receiving HTTP events.

Definition at line 27 of file mhttptransactioncallback.h.

Member Function Documentation

virtual TInt MHTTPTransactionCallback::MHFRunError | ( | TInt | aError,
 |  | RHTTPTransaction | aTransaction,
 |  | const THTTPEvent & | aEvent
 | ) | [pure virtual]

Called when RunL leaves from a transaction event.

This works in the same way as CActve::RunError; return KErrNone if you have handled the error. If you don't completely handle the error, a panic will occur.

Parameters:
aError | The leave code that RunL left with.
aTransaction | The transaction that was being processed.
aEvent | The Event that was being processed.
Returns:
KErrNone if the error has been cancelled or the code of the continuing error otherwise.

Implemented in TDummyTransactionCallback, and CHttpEventHandler.

virtual void MHTTPTransactionCallback::MHFRunL | ( | RHTTPTransaction | aTransaction,
 |  | const THTTPEvent & | aEvent
 | ) | [pure virtual]

Called when the filter's registration conditions are satisfied for events that occur on a transaction.

Note that this function is not allowed to leave if called with certain events.

See also:
THTTPEvent
Parameters:
aTransaction | The transaction that the event has occurred on.
aEvent | The event that has occurred.
Exceptions:
Any Leaves must be handled by the appropriate MHFRunError.

Implemented in TDummyTransactionCallback, and CHttpEventHandler.

The documentation for this class was generated from the following file:
  • mhttptransactioncallback.h


Member List

MHTTPTransactionCallback Member List

This is the complete list of members for MHTTPTransactionCallback, including all inherited members.
MHFRunError(TInt aError, RHTTPTransaction aTransaction, const THTTPEvent &aEvent)=0 | MHTTPTransactionCallback | [pure virtual]
MHFRunL(RHTTPTransaction aTransaction, const THTTPEvent &aEvent)=0 | MHTTPTransactionCallback | [pure virtual]


RHTTPTransactionPropertySet Class Reference

@public
Since:
7.0 The set of properties of a transaction.
More...

#include <rhttptransactionpropertyset.h>

Inheritance diagram for RHTTPTransactionPropertySet:

[legend]
Collaboration diagram for RHTTPTransactionPropertySet:

[legend]
List of all members.

Detailed Description

@public
Since:
7.0 The set of properties of a transaction.

This is used by filters to store per-transaction information, and is also used by the client to specify transaction properties (such as no caching, reload and so on)

Definition at line 28 of file rhttptransactionpropertyset.h.

The documentation for this class was generated from the following file:
  • rhttptransactionpropertyset.h


Member List

RHTTPTransactionPropertySet Member List

This is the complete list of members for RHTTPTransactionPropertySet, including all inherited members.
CHeaderFieldPart class | RHTTPPropertySet | [friend]
CHTTPSession class | RHTTPPropertySet | [friend]
iImplementation | RHTTPPropertySet | [protected]
Property(RStringF aPropertyName, THTTPHdrVal &aVal) const | RHTTPPropertySet |
RemoveAllProperties() | RHTTPPropertySet |
RemoveProperty(RStringF aPropertyName) | RHTTPPropertySet |
RHTTPPropertySet() | RHTTPPropertySet |
SetPropertyL(RStringF aPropertyName, THTTPHdrVal aValue) | RHTTPPropertySet |


MTransportHndObs Class Reference

An interface to be implemented by classes that wish to observe a transport handler. More...

#include <mtransporthndobs.h>

Inheritance diagram for MTransportHndObs:

[legend]
List of all members.

Public Methods

virtual void | SetStatusL (CTxData &aTrans, TInt aStatus)=0
Receive a status message from the transport handler for a particular transaction.

virtual THttpRxDataStat | DataL (CTxData &aTrans, const TDesC8 &aData)=0
Receive response data from the origin server or proxy The method returns a set of flags indicating a variety of conditions that the observer might recognise in the response.

virtual void | HandleError (CTxData &aTrans, TInt aStatus)=0
Receive an error from the the transport handler for a particular transaction.

virtual TInt | CheckConnectResponseL (TDesC8 &aBuffer)=0
Provides very simple validation of the contents of aBuffer to extract the status code.

Detailed Description

An interface to be implemented by classes that wish to observe a transport handler.

Definition at line 49 of file mtransporthndobs.h.

Member Function Documentation

virtual TInt MTransportHndObs::CheckConnectResponseL ( TDesC8 & aBuffer ) [pure virtual]

Provides very simple validation of the contents of aBuffer to extract the status code.

Implemented in CTextModeRxData.

virtual THttpRxDataStat MTransportHndObs::DataL | ( | CTxData & | aTrans,
 |  | const TDesC8 & | aData
 | ) | [pure virtual]

Receive response data from the origin server or proxy The method returns a set of flags indicating a variety of conditions that the observer might recognise in the response.

Implemented in CTextModeRxData.

virtual void MTransportHndObs::HandleError | ( | CTxData & | aTrans,
 |  | TInt | aStatus
 | ) | [pure virtual]

Receive an error from the the transport handler for a particular transaction.

Implemented in CTextModeRxData.

virtual void MTransportHndObs::SetStatusL | ( | CTxData & | aTrans,
 |  | TInt | aStatus
 | ) | [pure virtual]

Receive a status message from the transport handler for a particular transaction.

Implemented in CTextModeRxData.

The documentation for this class was generated from the following file:
  • mtransporthndobs.h


Member List

MTransportHndObs Member List

This is the complete list of members for MTransportHndObs, including all inherited members.
CheckConnectResponseL(TDesC8 &aBuffer)=0 | MTransportHndObs | [pure virtual]
DataL(CTxData &aTrans, const TDesC8 &aData)=0 | MTransportHndObs | [pure virtual]
HandleError(CTxData &aTrans, TInt aStatus)=0 | MTransportHndObs | [pure virtual]
SetStatusL(CTxData &aTrans, TInt aStatus)=0 | MTransportHndObs | [pure virtual]


CTxData Class Reference

@public
Since:
7.0 An abstract base class for the encoding of request data to be transmitted by a protocol handler.
More...

#include <ctxdata.h>

Inheritance diagram for CTxData:

[legend]
Collaboration diagram for CTxData:

[legend]
List of all members.

Public Methods

virtual IMPORT_C | ~CTxData ()
Intended Usage: Destructor - cleans up and releases resources to the system
Since:
7.0.

IMPORT_C CProtTransaction & | ProtTrans ()
Intended Usage: Obtain the protocol transaction whose request part is represented as encoded data by this object.

Protected Methods

IMPORT_C | CTxData ()
Intended Usage: Default constructor - creates a Tx data object not associated with any protocol transaction.

IMPORT_C | CTxData (CProtTransaction &aProtTransaction)
Intended Usage: Normal constructor, of a CTxData that corresponds to the supplied protocol transaction.

IMPORT_C void | ConstructL ()
Intended Usage: Second phase construction, default
Since:
7.0.

Protected Attributes

CProtTransaction * iProtTrans
The HTTP transaction from whose request this OTA transmission data is built.

Private Methods

virtual void | Reserved1 ()
Intended Usage: Reserve a slot in the v-table to preserve future BC
Since:
7.0.

virtual void | Reserved2 ()
Intended Usage: Reserve a slot in the v-table to preserve future BC
Since:
7.0.

Detailed Description

@public
Since:
7.0 An abstract base class for the encoding of request data to be transmitted by a protocol handler.

Definition at line 29 of file ctxdata.h.

Constructor & Destructor Documentation

CTxData::~CTxData ( ) [virtual]

Intended Usage: Destructor - cleans up and releases resources to the system

Since:
7.0.

CTxData::CTxData ( ) [protected]

Intended Usage: Default constructor - creates a Tx data object not associated with any protocol transaction.

Since:
7.0

CTxData::CTxData ( CProtTransaction & aProtTransaction ) [protected]

Intended Usage: Normal constructor, of a CTxData that corresponds to the supplied protocol transaction.

Since:
7.0
Parameters:
aProtTransaction (in) The transaction for which this object represents the transmitted data.

Member Function Documentation

CTxData::ConstructL ( ) [protected]

Intended Usage: Second phase construction, default

Since:
7.0.

Reimplemented in CTextModeTxData.

CProtTransaction & CTxData::ProtTrans ( )

Intended Usage: Obtain the protocol transaction whose request part is represented as encoded data by this object.

Since:
7.0
Returns:
The protocol transaction object

void CTxData::Reserved1 ( ) [inline, private, virtual]

Intended Usage: Reserve a slot in the v-table to preserve future BC

Since:
7.0.

Definition at line 105 of file ctxdata.h.

void CTxData::Reserved2 ( ) [inline, private, virtual]

Intended Usage: Reserve a slot in the v-table to preserve future BC

Since:
7.0.

Definition at line 107 of file ctxdata.h.

Member Data Documentation

CProtTransaction* CTxData::iProtTrans [protected]

The HTTP transaction from whose request this OTA transmission data is built.

Note that the transaction is not owned by this object.

Definition at line 85 of file ctxdata.h.

The documentation for this class was generated from the following file:
  • ctxdata.h


Member List

CTxData Member List

This is the complete list of members for CTxData, including all inherited members.
ConstructL() | CTxData | [protected]
CTxData() | CTxData | [protected]
CTxData(CProtTransaction &aProtTransaction) | CTxData | [protected]
GetNextDataPart(TPtrC8 &aDataPart)=0 | MHTTPDataSupplier | [pure virtual]
iProtTrans | CTxData | [protected]
OverallDataSize()=0 | MHTTPDataSupplier | [pure virtual]
ProtTrans() | CTxData |
ReleaseData()=0 | MHTTPDataSupplier | [pure virtual]
Reserved1() | CTxData | [inline, private, virtual]
Reserved2() | CTxData | [inline, private, virtual]
Reset()=0 | MHTTPDataSupplier | [pure virtual]
~CTxData() | CTxData | [virtual]


CUnknownCapability Class Reference

The CUnknownCapability class represents the Unknown capability as defined by the WSP Specification, July 2001. More...

#include <CUnknownCapability.h>

List of all members.

Public Methods

~CUnknownCapability ()
Standard destructor
Since:
7.0.

const TDesC8 & | GetIdentifier () const
Returns the identifier for the capability.

const TDesC8 & | GetValue () const
Returns the parameter value for the capability.

Static Public Methods

CUnknownCapability * | NewL (const TDesC8 &aIdentifier, const TDesC8 &aValue)
Static factory constructor.

Private Methods

CUnknownCapability ()
First phase constructor
Since:
7.0.

void | ConstructL (const TDesC8 &aIdentifier, const TDesC8 &aValue)
Second phase constructor.

Private Attributes

HBufC8 * | iIdentifier
A buffer containing the pidentifier for the capability.

HBufC8 * | iValue
A buffer containing the parameter value for the capability.

Detailed Description

The CUnknownCapability class represents the Unknown capability as defined by the WSP Specification, July 2001.

Definition at line 15 of file CUnknownCapability.h.

Constructor & Destructor Documentation

CUnknownCapability::~CUnknownCapability ( )

Standard destructor

Since:
7.0.

CUnknownCapability::CUnknownCapability ( ) [private]

First phase constructor

Since:
7.0.

Member Function Documentation

CUnknownCapability::ConstructL | ( | const TDesC8 & | aIdentifier,
 |  | const TDesC8 & | aValue
 | ) | [private]

Second phase constructor.

Does any necessary allocations

Since:
7.0
Parameters:
aIdentifier A reference to a buffer containing the identifier for the capability.
a aValue A reference to a buffer containing the parameter
value for the capability

CUnknownCapability::GetIdentifier ( ) const [inline]

Returns the identifier for the capability.

Since:
7.0
Returns:
A const reference to a buffer containing the identifier for the capability.

CUnknownCapability::GetValue ( ) const [inline]

Returns the parameter value for the capability.

Since:
7.0
Returns:
A const reference to a buffer containing the parameter value for the capability.

CUnknownCapability::NewL | ( | const TDesC8 & | aIdentifier,
 |  | const TDesC8 & | aValue
 | ) | [static]

Static factory constructor.

Since:
7.0
Parameters:
aIdentifier A reference to a buffer containing the identifier for the capability.
a aValue A reference to a buffer containing the parameter
value for the capability

Member Data Documentation

HBufC8* CUnknownCapability::iIdentifier [private]

A buffer containing the pidentifier for the capability.

Definition at line 80 of file CUnknownCapability.h.

HBufC8* CUnknownCapability::iValue [private]

A buffer containing the parameter value for the capability.

Definition at line 85 of file CUnknownCapability.h.

The documentation for this class was generated from the following file:
  • CUnknownCapability.h


Member List

CUnknownCapability Member List

This is the complete list of members for CUnknownCapability, including all inherited members.
ConstructL(const TDesC8 &aIdentifier, const TDesC8 &aValue) | CUnknownCapability | [private]
CUnknownCapability() | CUnknownCapability | [private]
GetIdentifier() const | CUnknownCapability | [inline]
GetValue() const | CUnknownCapability | [inline]
iIdentifier | CUnknownCapability | [private]
iValue | CUnknownCapability | [private]
NewL(const TDesC8 &aIdentifier, const TDesC8 &aValue) | CUnknownCapability | [static]
~CUnknownCapability() | CUnknownCapability |


CValidationFilter Class Reference

The validation filter checks requests and responses to ensure that they are valid. More...

#include <ValidationFilter.h>

Inheritance diagram for CValidationFilter:

[legend]
Collaboration diagram for CValidationFilter:

[legend]
List of all members.

Public Methods

~CValidationFilter ()
virtual void | MHFRunL (RHTTPTransaction aTransaction, const THTTPEvent &aEvent)
See also:
MHTTPFilterBase::MHFRunL

virtual void | MHFSessionRunL (const THTTPSessionEvent &aEvent)
See also:
MHTTPFilterBase::MHFSessionRunL

virtual TInt | MHFRunError (TInt aError, RHTTPTransaction aTransaction, const THTTPEvent &aEvent)
See also:
MHTTPFilterBase::MHFRunError

virtual TInt | MHFSessionRunError (TInt aError, const THTTPSessionEvent &aEvent)
See also:
MHTTPFilterBase::MHFSessionRunError

virtual void | MHFUnload (RHTTPSession aSession, THTTPFilterHandle aHandle)
See also:
MHTTPFilter::MHFUnload

virtual void | MHFLoad (RHTTPSession aSession, THTTPFilterHandle aHandle)
See also:
MHTTPFilter::MHFLoad

Static Public Methods

CEComFilter * | InstallFilterL (TAny *aSession)

Private Methods

CValidationFilter ()
void | ConstructL (RHTTPSession aSession)
void | ValidateRequestMethodL (RHTTPTransaction aTransaction)
TBool | ValidateRequestHeadersL (RHTTPTransaction aTransaction)
void | ValidateRequestGetL (RHTTPTransaction aTransaction)
void | ValidateRequestPostL (RHTTPTransaction aTransaction)
void | ValidateRequestPutL (RHTTPTransaction aTransaction)
void | ValidateRequestTraceL (RHTTPTransaction aTransaction)
void | ValidateRequestHeadL (RHTTPTransaction aTransaction)
void | ValidateRequestOptionsL (RHTTPTransaction aTransaction)
TBool | ValidateResponseStatusCode (RHTTPTransaction aTransaction)
Validate status codes.

TBool | RequestFailIfContainsBodyL (RHTTPTransaction aTransaction)
Fails a request if it contains a body.

void | FailAndCancelL (RHTTPTransaction aTransaction, THTTPEvent aStatus)
Fails and cancels a transaction.

Private Attributes

TBool | iTransactionFailed
RHTTPMessage iCurrentMessage
RStringPool | iStringPool

Detailed Description

The validation filter checks requests and responses to ensure that they are valid.

It also adds either a succeded or failed event. Most clients will only be intrested in this simplified reporting of success. Any error codes are still sent to the client.

Definition at line 22 of file ValidationFilter.h.

Constructor & Destructor Documentation

CValidationFilter::~CValidationFilter ( )

CValidationFilter::CValidationFilter ( ) [private]

Member Function Documentation

void CValidationFilter::ConstructL ( RHTTPSession aSession ) [private]

void CValidationFilter::FailAndCancelL | ( | RHTTPTransaction | aTransaction,
 |  | THTTPEvent | aStatus
 | ) | [private]

Fails and cancels a transaction.

Parameters:
aTransaction | The transaction to cancel
aStatus | The status or error that caused the transaction to fail

CEComFilter* CValidationFilter::InstallFilterL ( TAny * aSession ) [static]

virtual void CValidationFilter::MHFLoad | ( | RHTTPSession | aSession,
 |  | THTTPFilterHandle | aHandle
 | ) | [virtual]

See also:
MHTTPFilter::MHFLoad

Reimplemented from MHTTPFilter.

virtual TInt CValidationFilter::MHFRunError | ( | TInt | aError,
 |  | RHTTPTransaction | aTransaction,
 |  | const THTTPEvent & | aEvent
 | ) | [virtual]

See also:
MHTTPFilterBase::MHFRunError

Reimplemented from MHTTPFilterBase.

virtual void CValidationFilter::MHFRunL | ( | RHTTPTransaction | aTransaction,
 |  | const THTTPEvent & | aEvent
 | ) | [virtual]

See also:
MHTTPFilterBase::MHFRunL

Reimplemented from MHTTPFilterBase.

virtual TInt CValidationFilter::MHFSessionRunError | ( | TInt | aError,
 |  | const THTTPSessionEvent & | aEvent
 | ) | [virtual]

See also:
MHTTPFilterBase::MHFSessionRunError

Reimplemented from MHTTPFilterBase.

virtual void CValidationFilter::MHFSessionRunL ( const THTTPSessionEvent & aEvent ) [virtual]

See also:
MHTTPFilterBase::MHFSessionRunL

Reimplemented from MHTTPFilterBase.

virtual void CValidationFilter::MHFUnload | ( | RHTTPSession | aSession,
 |  | THTTPFilterHandle | aHandle
 | ) | [virtual]

See also:
MHTTPFilter::MHFUnload

Reimplemented from MHTTPFilter.

TBool CValidationFilter::RequestFailIfContainsBodyL ( RHTTPTransaction aTransaction ) [private]

Fails a request if it contains a body.

Returns:
returns ETrue if the request did contain a body

void CValidationFilter::ValidateRequestGetL ( RHTTPTransaction aTransaction ) [private]

TBool CValidationFilter::ValidateRequestHeadersL ( RHTTPTransaction aTransaction ) [private]

void CValidationFilter::ValidateRequestHeadL ( RHTTPTransaction aTransaction ) [private]

void CValidationFilter::ValidateRequestMethodL ( RHTTPTransaction aTransaction ) [private]

void CValidationFilter::ValidateRequestOptionsL ( RHTTPTransaction aTransaction ) [private]

void CValidationFilter::ValidateRequestPostL ( RHTTPTransaction aTransaction ) [private]

void CValidationFilter::ValidateRequestPutL ( RHTTPTransaction aTransaction ) [private]

void CValidationFilter::ValidateRequestTraceL ( RHTTPTransaction aTransaction ) [private]

TBool CValidationFilter::ValidateResponseStatusCode ( RHTTPTransaction aTransaction ) [private]

Validate status codes.

Anything from 400->599 is an error or warning

Returns:
ETrue if the status code indicates a problem with the transaction

Member Data Documentation

RHTTPMessage CValidationFilter::iCurrentMessage [private]

Definition at line 108 of file ValidationFilter.h.

RStringPool CValidationFilter::iStringPool [private]

Definition at line 110 of file ValidationFilter.h.

TBool CValidationFilter::iTransactionFailed [private]

Definition at line 105 of file ValidationFilter.h.

The documentation for this class was generated from the following file:
  • ValidationFilter.h


Member List

CValidationFilter Member List

This is the complete list of members for CValidationFilter, including all inherited members.
ConstructL(RHTTPSession aSession) | CValidationFilter | [private]
CValidationFilter() | CValidationFilter | [private]
ECache enum value | MHTTPFilter |
EClient enum value | MHTTPFilter |
EClientFilters enum value | MHTTPFilter |
ECookies enum value | MHTTPFilter |
EProtocolHandler enum value | MHTTPFilter |
EStatusCodeHandler enum value | MHTTPFilter |
ETidyUp enum value | MHTTPFilter |
FailAndCancelL(RHTTPTransaction aTransaction, THTTPEvent aStatus) | CValidationFilter | [private]
iCurrentMessage | CValidationFilter | [private]
InstallFilterL(TAny *aSession) | CValidationFilter | [static]
CEComFilter::InstallFilterL(RHTTPSession aSession, const TUid aEComFilterUid) | CEComFilter | [inline, static]
CEComFilter::InstallFilterL(RHTTPSession aSession, const TDesC8 &aEComFilterDataType) | CEComFilter | [inline, static]
iStringPool | CValidationFilter | [private]
iTransactionFailed | CValidationFilter | [private]
MHFLoad(RHTTPSession aSession, THTTPFilterHandle aHandle) | CValidationFilter | [virtual]
MHFRunError(TInt aError, RHTTPTransaction aTransaction, const THTTPEvent &aEvent) | CValidationFilter | [virtual]
MHFRunL(RHTTPTransaction aTransaction, const THTTPEvent &aEvent) | CValidationFilter | [virtual]
MHFSessionRunError(TInt aError, const THTTPSessionEvent &aEvent) | CValidationFilter | [virtual]
MHFSessionRunL(const THTTPSessionEvent &aEvent) | CValidationFilter | [virtual]
MHFUnload(RHTTPSession aSession, THTTPFilterHandle aHandle) | CValidationFilter | [virtual]
RequestFailIfContainsBodyL(RHTTPTransaction aTransaction) | CValidationFilter | [private]
TPositions enum name | MHTTPFilter |
ValidateRequestGetL(RHTTPTransaction aTransaction) | CValidationFilter | [private]
ValidateRequestHeadersL(RHTTPTransaction aTransaction) | CValidationFilter | [private]
ValidateRequestHeadL(RHTTPTransaction aTransaction) | CValidationFilter | [private]
ValidateRequestMethodL(RHTTPTransaction aTransaction) | CValidationFilter | [private]
ValidateRequestOptionsL(RHTTPTransaction aTransaction) | CValidationFilter | [private]
ValidateRequestPostL(RHTTPTransaction aTransaction) | CValidationFilter | [private]
ValidateRequestPutL(RHTTPTransaction aTransaction) | CValidationFilter | [private]
ValidateRequestTraceL(RHTTPTransaction aTransaction) | CValidationFilter | [private]
ValidateResponseStatusCode(RHTTPTransaction aTransaction) | CValidationFilter | [private]
~CEComFilter() | CEComFilter | [inline]
~CValidationFilter() | CValidationFilter |


MWspAliasAddress Class Reference

@public
Since:
7.0 The MWspAliasAddresses API provides an interface to a set of alias addresses as defined by the WSP Specification, July 2001.
More...

#include <MWspAliasAddresses.h>

Detailed Description

@public
Since:
7.0 The MWspAliasAddresses API provides an interface to a set of alias addresses as defined by the WSP Specification, July 2001.

This is an informational capability that indicates alternate addresses that can be used to access the same entity instance in this current session. The addresses are listed in preferential order, with the most preferred at the start.

The interface allows the set of addresses to be accessed one by one. The read function provides the caller with a copy of the alias address information. The set of alias addresses can be reset to the default value of the capability (as defined by the WSP Specification), which is an empty set. An alias address can be added to the set - the preferred addresses should be added first.

The documentation for this class was generated from the following file:
  • MWspAliasAddresses.h


MWspAliasAddresses Class Reference

#include <MWspAliasAddresses.h>

Inheritance diagram for MWspAliasAddresses:

[legend]
List of all members.

Public Methods

virtual TInt | Start () const=0
Intended Usage : Ensures that the first alias address in the set is available for reading.

virtual TInt | GetNext (TWspBearer &aBearer, TUint16 &aPort, TPtrC8 &aAddress) const=0
Intended Usage : Gets the next alias address in the set.

virtual void | Reset ()=0
Intended Usage : Resets the capability to the default.

virtual void | AddAddressL (TWspBearer aBearer, TUint16 aPort, const TDesC8 &aAddress)=0
Intended Usage : Adds an alias address to the set.

Member Function Documentation

MWspAliasAddresses::AddAddressL | ( | TWspBearer | aBearer,
 |  | TUint16 | aPort,
 |  | const TDesC8 & | aAddress
 | ) | [pure virtual]

Intended Usage : Adds an alias address to the set.

The addresses should be added in preferential order, with the most preferred at the start.

Since:
7.0 @leave Leave code KErrNoMemory if the address cannot be added to the set.
Parameters:
aBearer | The type of bearer network which this address should be used with.
aPort | The destination port number. A value of zero indicates that no port number has been specified.
aAddress | A buffer with the bearer address to be used. The format of the address is bearer dependent.
Postcondition:
If no error has occurred then the alias address has been added.

Implemented in CWspAliasAddresses.

MWspAliasAddresses::GetNext | ( | TWspBearer & | aBearer,
 |  | TUint16 & | aPort,
 |  | TPtrC8 & | aAddress
 | ) | const [pure virtual]

Intended Usage : Gets the next alias address in the set.

If there are no addresses left then KErrNotFound error code is returned. The addresses are listed in preferential order, with the most preferred at the start.

Since:
7.0
Parameters:
aBearer | An output parameter reference for the type of bearer network which this address should be used with.
aPort | An output parameter reference for the destination port number. A value of zero indicates that no port number has been specified.
aAddress | An output parameter reference for a buffer with the bearer address to be used. The format of the address is bearer dependent.
Returns:
An error code. If there are no alias addresses left, then the value returned is KErrNotFound. If there are alias addresses left then the value KErrNone is returned.
Postcondition:
The next alias address in the set is available for reading.

Implemented in CWspAliasAddresses.

MWspAliasAddresses::Reset ( ) [pure virtual]

Intended Usage : Resets the capability to the default.

The default is defined in the WSP Specification, July 2001, as being an empty set of addresses.

Since:
7.0
Postcondition:
The set of alias addresses is empty.

Implemented in CWspAliasAddresses.

MWspAliasAddresses::Start ( ) const [pure virtual]

Intended Usage : Ensures that the first alias address in the set is available for reading.

Since:
7.0
Returns:
An error code. If there are no alias addresses, then the value returned is KErrNotFound. If there are alias addresses then the value KErrNone is returned.
Postcondition:
The subsequent call to GetNext() is applied to the first alias address in the set.

Implemented in CWspAliasAddresses.

The documentation for this class was generated from the following file:
  • MWspAliasAddresses.h


Member List

MWspAliasAddresses Member List

This is the complete list of members for MWspAliasAddresses, including all inherited members.
AddAddressL(TWspBearer aBearer, TUint16 aPort, const TDesC8 &aAddress)=0 | MWspAliasAddresses | [pure virtual]
GetNext(TWspBearer &aBearer, TUint16 &aPort, TPtrC8 &aAddress) const=0 | MWspAliasAddresses | [pure virtual]
Reset()=0 | MWspAliasAddresses | [pure virtual]
Start() const=0 | MWspAliasAddresses | [pure virtual]


CWspAliasAddresses Class Reference

The CWspAliasAddresses class represents a set of Alias Address capabilities. More...

#include <CWspAliasAddresses.h>

Inheritance diagram for CWspAliasAddresses:

[legend]
Collaboration diagram for CWspAliasAddresses:

[legend]
List of all members.

Public Methods

~CWspAliasAddresses ()
Standard destructor.

virtual TInt | Start () const
virtual TInt | GetNext (TWspBearer &aBearer, TUint16 &aPort, TPtrC8 &aAddress) const
virtual void | Reset ()
virtual void | AddAddressL (TWspBearer aBearer, TUint16 aPort, const TDesC8 &aAddress)

Static Public Methods

CWspAliasAddresses * | NewL ()
Static factory constructor.

Private Methods

CWspAliasAddresses ()
First phase constructor.

Private Attributes

RPointerArray< CAliasAddress > | iAddresses
An array of alias addresses.

TInt | iIndex
An index with the current position in the array.

Detailed Description

The CWspAliasAddresses class represents a set of Alias Address capabilities.

It implements the MWspAliasAddresses interface.

See also:
MWspAliasAddresses

Definition at line 19 of file CWspAliasAddresses.h.

Constructor & Destructor Documentation

CWspAliasAddresses::~CWspAliasAddresses ( )

Standard destructor.

Since:
7.0

CWspAliasAddresses::CWspAliasAddresses ( ) [private]

First phase constructor.

Since:
7.0

Member Function Documentation

CWspAliasAddresses::AddAddressL | ( | TWspBearer | aBearer,
 |  | TUint16 | aPort,
 |  | const TDesC8 & | aAddress
 | ) | [virtual]

See also:
MWspAliasAddresses

Implements MWspAliasAddresses.

CWspAliasAddresses::GetNext | ( | TWspBearer & | aBearer,
 |  | TUint16 & | aPort,
 |  | TPtrC8 & | aAddress
 | ) | const [virtual]

See also:
MWspAliasAddresses

Implements MWspAliasAddresses.

CWspAliasAddresses::NewL ( ) [static]

Static factory constructor.

Since:
7.0

CWspAliasAddresses::Reset ( ) [virtual]

See also:
MWspAliasAddresses

Implements MWspAliasAddresses.

CWspAliasAddresses::Start ( ) const [virtual]

See also:
MWspAliasAddresses

Implements MWspAliasAddresses.

Member Data Documentation

RPointerArray<CAliasAddress> CWspAliasAddresses::iAddresses [private]

An array of alias addresses.

Definition at line 77 of file CWspAliasAddresses.h.

TInt CWspAliasAddresses::iIndex [private]

An index with the current position in the array.

Is mutable to maintain logical const-ness.

Definition at line 83 of file CWspAliasAddresses.h.

The documentation for this class was generated from the following file:
  • CWspAliasAddresses.h


Member List

CWspAliasAddresses Member List

This is the complete list of members for CWspAliasAddresses, including all inherited members.
AddAddressL(TWspBearer aBearer, TUint16 aPort, const TDesC8 &aAddress) | CWspAliasAddresses | [virtual]
CWspAliasAddresses() | CWspAliasAddresses | [private]
GetNext(TWspBearer &aBearer, TUint16 &aPort, TPtrC8 &aAddress) const | CWspAliasAddresses | [virtual]
iAddresses | CWspAliasAddresses | [private]
iIndex | CWspAliasAddresses | [private]
NewL() | CWspAliasAddresses | [static]
Reset() | CWspAliasAddresses | [virtual]
Start() const | CWspAliasAddresses | [virtual]
~CWspAliasAddresses() | CWspAliasAddresses |


CWspCapabilityInfo Class Reference

The CWspCapabilityInfo class implements the MWspCapabilityViewer and MWspCapabilitySetter APIs. More...

#include <CWspCapabilityInfo.h>

Inheritance diagram for CWspCapabilityInfo:

[legend]
Collaboration diagram for CWspCapabilityInfo:

[legend]
List of all members.

Public Methods

~CWspCapabilityInfo ()
Intended Usage : Destructor.

virtual const MWspAliasAddresses & | GetAliasAddresses () const
virtual const MWspExtendedMethods & | GetExtendedMethods () const
virtual const MWspHeaderCodePages & | GetHeaderCodePages () const
virtual TUint8 | GetMethodMOR () const
virtual TUint8 | GetPushMOR () const
virtual TUint8 | GetProtocolOptions () const
virtual TUint32 | GetClientSDUSize () const
virtual TUint32 | GetServerSDUSize () const
virtual TUint32 | GetClientMessageSize () const
virtual TUint32 | GetServerMessageSize () const
virtual const MWspUnknownCapabilities & | GetUnknownCapabilities () const
virtual void | Reset (TWspCapability aCapability=EAllCapabilities)
virtual void | AddAliasAddressL (TWspBearer aBearer, TUint16 aPort, const TDesC8 &aAddress)
virtual void | AddExtendedMethodL (TUint8 aPDUType, const TDesC8 &aMethodName)
virtual void | AddHeaderCodePageL (TUint8 aPageCode, const TDesC8 &aPageName)
virtual void | SetMethodMOR (TUint8 aMOR)

Static Public Methods

CWspCapabilityInfo * | NewL ()
Intended Usage : Static factory function.

Detailed Description

The CWspCapabilityInfo class implements the MWspCapabilityViewer and MWspCapabilitySetter APIs.

See also:
MWspCapabilityViewer , MWspCapabilitySetter

Definition at line 27 of file CWspCapabilityInfo.h.

Constructor & Destructor Documentation

CWspCapabilityInfo::~CWspCapabilityInfo ( )

Intended Usage : Destructor.

Since:
7.0

Member Function Documentation

CWspCapabilityInfo::AddAliasAddressL | ( | TWspBearer | aBearer,
 |  | TUint16 | aPort,
 |  | const TDesC8 & | aAddress
 | ) | [virtual]

See also:
MWspCapabilitySetter

Implements MWspCapabilitySetter.

CWspCapabilityInfo::AddExtendedMethodL | ( | TUint8 | aPDUType,
 |  | const TDesC8 & | aMethodName
 | ) | [virtual]

See also:
MWspCapabilitySetter

Implements MWspCapabilitySetter.

CWspCapabilityInfo::AddHeaderCodePageL | ( | TUint8 | aPageCode,
 |  | const TDesC8 & | aPageName
 | ) | [virtual]

See also:
MWspCapabilitySetter

Implements MWspCapabilitySetter.

CWspCapabilityInfo::GetAliasAddresses ( ) const [virtual]

See also:
MWspCapabilityViewer

Implements MWspCapabilityViewer.

CWspCapabilityInfo::GetClientMessageSize ( ) const [virtual]

See also:
MWspCapabilityViewer

Implements MWspCapabilityViewer.

CWspCapabilityInfo::GetClientSDUSize ( ) const [virtual]

See also:
MWspCapabilityViewer

Implements MWspCapabilityViewer.

CWspCapabilityInfo::GetExtendedMethods ( ) const [virtual]

See also:
MWspCapabilityViewer

Implements MWspCapabilityViewer.

CWspCapabilityInfo::GetHeaderCodePages ( ) const [virtual]

See also:
MWspCapabilityViewer

Implements MWspCapabilityViewer.

CWspCapabilityInfo::GetMethodMOR ( ) const [virtual]

See also:
MWspCapabilityViewer

Implements MWspCapabilityViewer.

CWspCapabilityInfo::GetProtocolOptions ( ) const [virtual]

See also:
MWspCapabilityViewer

Implements MWspCapabilityViewer.

CWspCapabilityInfo::GetPushMOR ( ) const [virtual]

See also:
MWspCapabilityViewer

Implements MWspCapabilityViewer.

CWspCapabilityInfo::GetServerMessageSize ( ) const [virtual]

See also:
MWspCapabilityViewer

Implements MWspCapabilityViewer.

CWspCapabilityInfo::GetServerSDUSize ( ) const [virtual]

See also:
MWspCapabilityViewer

Implements MWspCapabilityViewer.

CWspCapabilityInfo::GetUnknownCapabilities ( ) const [virtual]

See also:
MWspCapabilityViewer

Implements MWspCapabilityViewer.

CWspCapabilityInfo::NewL ( ) [static]

Intended Usage : Static factory function.

Since:
7.0
Exceptions:
This function will leave if the object fails to be created.
Returns:
A pointer to created CWspCapabilityInfo object.

CWspCapabilityInfo::Reset ( TWspCapability aCapability = EAllCapabilities ) [virtual]

See also:
MWspCapabilitySetter

Implements MWspCapabilitySetter.

CWspCapabilityInfo::SetMethodMOR ( TUint8 aMOR ) [virtual]

See also:
MWspCapabilitySetter

Implements MWspCapabilitySetter.

The documentation for this class was generated from the following file:
  • CWspCapabilityInfo.h


Member List

CWspCapabilityInfo Member List

This is the complete list of members for CWspCapabilityInfo, including all inherited members.
AddAliasAddressL(TWspBearer aBearer, TUint16 aPort, const TDesC8 &aAddress) | CWspCapabilityInfo | [virtual]
AddExtendedMethodL(TUint8 aPDUType, const TDesC8 &aMethodName) | CWspCapabilityInfo | [virtual]
AddHeaderCodePageL(TUint8 aPageCode, const TDesC8 &aPageName) | CWspCapabilityInfo | [virtual]
AddUnknownCapabilityL(const TDesC8 &aIdentifier, const TDesC8 &aValue)=0 | MWspCapabilitySetter | [pure virtual]
GetAliasAddresses() const | CWspCapabilityInfo | [virtual]
GetClientMessageSize() const | CWspCapabilityInfo | [virtual]
GetClientSDUSize() const | CWspCapabilityInfo | [virtual]
GetExtendedMethods() const | CWspCapabilityInfo | [virtual]
GetHeaderCodePages() const | CWspCapabilityInfo | [virtual]
GetMethodMOR() const | CWspCapabilityInfo | [virtual]
GetProtocolOptions() const | CWspCapabilityInfo | [virtual]
GetPushMOR() const | CWspCapabilityInfo | [virtual]
GetServerMessageSize() const | CWspCapabilityInfo | [virtual]
GetServerSDUSize() const | CWspCapabilityInfo | [virtual]
GetUnknownCapabilities() const | CWspCapabilityInfo | [virtual]
NewL() | CWspCapabilityInfo | [static]
Reset(TWspCapability aCapability=EAllCapabilities) | CWspCapabilityInfo | [virtual]
SetClientMessageSize(TUint32 aSize)=0 | MWspCapabilitySetter | [pure virtual]
SetClientSDUSize(TUint32 aSize)=0 | MWspCapabilitySetter | [pure virtual]
SetMethodMOR(TUint8 aMOR) | CWspCapabilityInfo | [virtual]
SetProtocolOptions(TUint8 aProtocolOptions)=0 | MWspCapabilitySetter | [pure virtual]
SetPushMOR(TUint8 aMOR)=0 | MWspCapabilitySetter | [pure virtual]
SetServerMessageSize(TUint32 aSize)=0 | MWspCapabilitySetter | [pure virtual]
SetServerSDUSize(TUint32 aSize)=0 | MWspCapabilitySetter | [pure virtual]
~CWspCapabilityInfo() | CWspCapabilityInfo |


MWspCapabilityProvider Class Reference

@public
Since:
7.0 The MWspCapabilityProvider API supplies the capabilities proposed by the Client using the MWspCapabilityViewer API.
More...

#include <MWspCapabilityProvider.h>

Inheritance diagram for MWspCapabilityProvider:

[legend]
List of all members.

Public Methods

virtual const MWspCapabilityViewer & | ClientCapabilities () const=0
Intended Usage : Provides the proposed Client capabilities.

virtual MWspCapabilitySetter & | ServerCapabilities () const=0
Intended Usage : Provides the call-back interface for the negotiated capabilities from the Server.

Detailed Description

@public
Since:
7.0 The MWspCapabilityProvider API supplies the capabilities proposed by the Client using the MWspCapabilityViewer API.

The negotiated capabilities from the Server can be given to the Client using the MWspCapabilitySetter API.

Definition at line 30 of file MWspCapabilityProvider.h.

Member Function Documentation

MWspCapabilityProvider::ClientCapabilities ( ) const [pure virtual]

Intended Usage : Provides the proposed Client capabilities.

Since:
7.0
Returns:
A reference to a MWspCapabilityViewer object that contains the Client's proposed capabilities.

Implemented in CWspCOProtocolHandler.

MWspCapabilityProvider::ServerCapabilities ( ) const [pure virtual]

Intended Usage : Provides the call-back interface for the negotiated capabilities from the Server.

Since:
7.0
Returns:
A reference to a MWspCapabilitySetter object through which the negotiated capabilities from the Server are passed to the Client.

Implemented in CWspCOProtocolHandler.

The documentation for this class was generated from the following file:
  • MWspCapabilityProvider.h


Member List

MWspCapabilityProvider Member List

This is the complete list of members for MWspCapabilityProvider, including all inherited members.
ClientCapabilities() const=0 | MWspCapabilityProvider | [pure virtual]
ServerCapabilities() const=0 | MWspCapabilityProvider | [pure virtual]


MWspCapabilitySetter Class Reference

@public
Since:
7.0 The MWspCapabilitySetter API provides an interface to set the values for a set of capabilities as defined by the WSP Specification, July 2001.
More...

#include <MWspCapabilitySetter.h>

Inheritance diagram for MWspCapabilitySetter:

[legend]
List of all members.

Public Methods

virtual void | Reset (TWspCapability aCapability=EAllCapabilities)=0
Intended Usage : Resets the capability specified by the aCapability.

virtual void | AddAliasAddressL (TWspBearer aBearer, TUint16 aPort, const TDesC8 &aAddress)=0
Intended Usage : Adds an alias address to the set.

virtual void | AddExtendedMethodL (TUint8 aPDUType, const TDesC8 &aMethodName)=0
Intended Usage : Adds an extended method to the set.

virtual void | AddHeaderCodePageL (TUint8 aPageCode, const TDesC8 &aPageName)=0
Intended Usage : Adds an extension header code page to the set.

virtual void | SetMethodMOR (TUint8 aMOR)=0
Intended Usage : Set the Method MOR.

virtual void | SetPushMOR (TUint8 aMOR)=0
Intended Usage : Set the Push MOR.

virtual void | SetProtocolOptions (TUint8 aProtocolOptions)=0
Intended Usage : Set the protocol options.

virtual void | SetClientSDUSize (TUint32 aSize)=0
Intended Usage : Set the Client SDU size.

virtual void | SetServerSDUSize (TUint32 aSize)=0
Intended Usage : Set the Server SDU size.

virtual void | SetClientMessageSize (TUint32 aSize)=0
Intended Usage : Set the Client Message size.

virtual void | SetServerMessageSize (TUint32 aSize)=0
Intended Usage : Set the Server Message size.

virtual void | AddUnknownCapabilityL (const TDesC8 &aIdentifier, const TDesC8 &aValue)=0
Intended Usage : Adds an unknown capability to the set.

Detailed Description

@public
Since:
7.0 The MWspCapabilitySetter API provides an interface to set the values for a set of capabilities as defined by the WSP Specification, July 2001.

Definition at line 29 of file MWspCapabilitySetter.h.

Member Function Documentation

MWspCapabilitySetter::AddAliasAddressL | ( | TWspBearer | aBearer,
 |  | TUint16 | aPort,
 |  | const TDesC8 & | aAddress
 | ) | [pure virtual]

Intended Usage : Adds an alias address to the set.

This capability indicates alternate addresses that can be used to access the same entity instance in this current session. The addresses are listed in preferential order, with the most preferred at the start.

Since:
7.0 @leave Leave code KErrNoMemory if the capability cannot be added to the set.
Parameters:
aBearer | The type of bearer network which this address should be used with.
aPort | The destination port number. A value of zero indicates that no port number has been specified.
aAddress | A buffer with the bearer address to be used. The format of the address is bearer dependent.
Postcondition:
The alias address has been added to the set.

Implemented in CWspCapabilityInfo.

MWspCapabilitySetter::AddExtendedMethodL | ( | TUint8 | aPDUType,
 |  | const TDesC8 & | aMethodName
 | ) | [pure virtual]

Intended Usage : Adds an extended method to the set.

This capability gives a set of methods, beyond those defined in HTTP/1.1.

Since:
7.0 @leave Leave code KErrNoMemory if the capability cannot be added to the set.
Parameters:
aPDUType | A byte indicating the type of the PDU. The WSP Specification, July 2001, specifies that the range 0x50-0x5F is for methods that use a Get PDU format, and the range 0x70-7F is for methods that use a Post PDU format.
aMethodName | A buffer with the name of the method.
Postcondition:
The extended method has been added to the set.

Implemented in CWspCapabilityInfo.

MWspCapabilitySetter::AddHeaderCodePageL | ( | TUint8 | aPageCode,
 |  | const TDesC8 & | aPageName
 | ) | [pure virtual]

Intended Usage : Adds an extension header code page to the set.

Since:
7.0 @leave Leave code KErrNoMemory if the capability cannot be added to the set.
Parameters:
aPageCode | A byte with the extension code page number.
aPageName | A buffer with the name of the header code page.
Postcondition:
The Header Code Page has been added to the set.

Implemented in CWspCapabilityInfo.

MWspCapabilitySetter::AddUnknownCapabilityL | ( | const TDesC8 & | aIdentifier,
 |  | const TDesC8 & | aValue
 | ) | [pure virtual]

Intended Usage : Adds an unknown capability to the set.

This is a capability not defined by the WSP Specification, July 2001. The Identifier is encoded in the same way as the header field name - it uses the BNF rule for Field-Name, as shown in 8.4.2.6. Well-known capabilities have their identifier encoded using a short-integer, and unknown capabilities encode their identifier using a Null- terminated string. Any extra capabilities must be defined in such a way that an empty parameter value is illegal. This allows the unknown capability to be rejected.

Since:
7.0 @leave Leave code KErrNoMemory if the capability cannot be added to the set.
Parameters:
aIdentifier | A buffer with the identifier for the unknown capability.
aValue | A buffer with the parameters for the capability.
Postcondition:
The unknown capability has been added to the set.

MWspCapabilitySetter::Reset ( TWspCapability aCapability = EAllCapabilities ) [pure virtual]

Intended Usage : Resets the capability specified by the aCapability.

The value to which the capability is reset is the default value defined in the WSP Specification, July 2001. In the case of set capabilities (e.g. Alias Address), the default is to have none.

Since:
7.0
Parameters:
aCapability A enum specifying which capability to reset. The default value is EAllCapabilities.
Postcondition:
The specified capability is reset to its default value.

Implemented in CWspCapabilityInfo.

MWspCapabilitySetter::SetClientMessageSize ( TUint32 aSize ) [pure virtual]

Intended Usage : Set the Client Message size.

The Client Message size is the size of the largest message that may be sent to the Client during the session. A message may consist of multiple SDUs. A value of zero indicates that there is no limit to the Message size.

Since:
7.0
Parameters:
aSize The message size, in bytes, as a 32-bit positive number.
Postcondition:
The Client Message size has been set to the given value.

MWspCapabilitySetter::SetClientSDUSize ( TUint32 aSize ) [pure virtual]

Intended Usage : Set the Client SDU size.

The Client SDU size is the size of the largest service data unit that may be sent to the Client during the session. A value of zero indicates that there is no limit to the SDU size.

Since:
7.0
Parameters:
aSize The SDU size, in bytes, as a 32-bit positive number.
Postcondition:
The Client SDU size has been set to the given value.

MWspCapabilitySetter::SetMethodMOR ( TUint8 aMOR ) [pure virtual]

Intended Usage : Set the Method MOR.

The Method MOR defines the number of active/outstanding method invocations at one time during the session.

Since:
7.0
Parameters:
aMOR The Method MOR as an 8-bit positive number.
Postcondition:
The Method MOR has been set to the given value.

Implemented in CWspCapabilityInfo.

MWspCapabilitySetter::SetProtocolOptions ( TUint8 aProtocolOptions ) [pure virtual]

Intended Usage : Set the protocol options.

The Protocol Options capability defines the optional service facilities and features for the session. The presence of an element indicates that the use of the specified facility or feature is enabled. The features and facilities described in the WSP Specification, July 2001, are specified by flags in a single byte. Additional flags will be specified in subsequent bytes, but this is not supported currently.

Since:
7.0 @leave Leave code KErrNoMemory if the capability cannot be set.
Parameters:
aProtocolOptions A byte containing the Protocol Options.
Postcondition:
The Protocol Options have been set to the given value.

MWspCapabilitySetter::SetPushMOR ( TUint8 aMOR ) [pure virtual]

Intended Usage : Set the Push MOR.

The Push MOR defines the number of active/outstanding push invocations at one time during the session.

Since:
7.0
Parameters:
aMOR The Push MOR as an 8-bit positive number.
Postcondition:
The Push MOR has been set to the given value.

MWspCapabilitySetter::SetServerMessageSize ( TUint32 aSize ) [pure virtual]

Intended Usage : Set the Server Message size.

The Server Message size is the size of the largest message that may be sent to the Server during the session. A message may consist of multiple SDUs. A value of zero indicates that there is no limit to the Message size.

Since:
7.0
Parameters:
aSize The message size, in bytes, as a 32-bit positive number.
Postcondition:
The Server Message size has been set to the given value.

MWspCapabilitySetter::SetServerSDUSize ( TUint32 aSize ) [pure virtual]

Intended Usage : Set the Server SDU size.

The Server SDU size is the size of the largest service data unit that may be sent to the Server during the session. A value of zero indicates that there is no limit to the SDU size.

Since:
7.0
Parameters:
aSize The SDU size, in bytes, as a 32-bit positive number.
Postcondition:
The Server SDU size has been set to the given value.

The documentation for this class was generated from the following file:
  • MWspCapabilitySetter.h


Member List

MWspCapabilitySetter Member List

This is the complete list of members for MWspCapabilitySetter, including all inherited members.
AddAliasAddressL(TWspBearer aBearer, TUint16 aPort, const TDesC8 &aAddress)=0 | MWspCapabilitySetter | [pure virtual]
AddExtendedMethodL(TUint8 aPDUType, const TDesC8 &aMethodName)=0 | MWspCapabilitySetter | [pure virtual]
AddHeaderCodePageL(TUint8 aPageCode, const TDesC8 &aPageName)=0 | MWspCapabilitySetter | [pure virtual]
AddUnknownCapabilityL(const TDesC8 &aIdentifier, const TDesC8 &aValue)=0 | MWspCapabilitySetter | [pure virtual]
Reset(TWspCapability aCapability=EAllCapabilities)=0 | MWspCapabilitySetter | [pure virtual]
SetClientMessageSize(TUint32 aSize)=0 | MWspCapabilitySetter | [pure virtual]
SetClientSDUSize(TUint32 aSize)=0 | MWspCapabilitySetter | [pure virtual]
SetMethodMOR(TUint8 aMOR)=0 | MWspCapabilitySetter | [pure virtual]
SetProtocolOptions(TUint8 aProtocolOptions)=0 | MWspCapabilitySetter | [pure virtual]
SetPushMOR(TUint8 aMOR)=0 | MWspCapabilitySetter | [pure virtual]
SetServerMessageSize(TUint32 aSize)=0 | MWspCapabilitySetter | [pure virtual]
SetServerSDUSize(TUint32 aSize)=0 | MWspCapabilitySetter | [pure virtual]


MWspCapabilityViewer Class Reference

@public
Since:
7.0 The MWspCapabiltyViewer API provides an interface to view a set of capabilities as defined by the WSP Specification, July 2001.
More...

#include <MWspCapabilityViewer.h>

Inheritance diagram for MWspCapabilityViewer:

[legend]
List of all members.

Public Methods

virtual const MWspAliasAddresses & | GetAliasAddresses () const=0
Intended Usage : The set of Alias Addresses.

virtual const MWspExtendedMethods & | GetExtendedMethods () const=0
Intended Usage : The set of extended methods.

virtual const MWspHeaderCodePages & | GetHeaderCodePages () const=0
Intended Usage : The set of extension header code pages.

virtual TUint8 | GetMethodMOR () const=0
Intended Usage : The Method MOR defines the number of active/outstanding method invocations at one time during the session.

virtual TUint8 | GetPushMOR () const=0
Intended Usage : The Push MOR defines the number of active/outstanding push invocations at one time during the session.

virtual TUint8 | GetProtocolOptions () const=0
Intended Usage : The Protocol Options capability defines the optional service facilities and features for the session.

virtual TUint32 | GetClientSDUSize () const=0
Intended Usage : The Client SDU size is the size of the largest service data unit that may be sent to the Client during the session.

virtual TUint32 | GetServerSDUSize () const=0
Intended Usage : The Server SDU size is the size of the largest service data unit that may be sent to the Server during the session.

virtual TUint32 | GetClientMessageSize () const=0
Intended Usage : The Client Message size is the size of the largest message that may be sent to the Client during the session.

virtual TUint32 | GetServerMessageSize () const=0
Intended Usage : The Server Message size is the size of the largest message that may be sent to the Server during the session.

virtual const MWspUnknownCapabilities & | GetUnknownCapabilities () const=0
Intended Usage : A set of capabilities not defined by the WSP Specification, July 2001.

Detailed Description

@public
Since:
7.0 The MWspCapabiltyViewer API provides an interface to view a set of capabilities as defined by the WSP Specification, July 2001.

Definition at line 31 of file MWspCapabilityViewer.h.

Member Function Documentation

MWspCapabilityViewer::GetAliasAddresses ( ) const [pure virtual]

Intended Usage : The set of Alias Addresses.

This capability indicates alternate addresses that can be used to access the same entity instance in this current session. The addresses are listed in preferential order, with the most preferred at the start.

Since:
7.0
Returns:
A const reference to a MWspAliasAddresses object.

Implemented in CWspCapabilityInfo.

MWspCapabilityViewer::GetClientMessageSize ( ) const [pure virtual]

Intended Usage : The Client Message size is the size of the largest message that may be sent to the Client during the session.

A message may consist of multiple SDUs. A value of zero indicates that there is no limit to the Message size.

Since:
7.0
Returns:
The Message size, in bytes, as an unsigned 32-bit number.

Implemented in CWspCapabilityInfo.

MWspCapabilityViewer::GetClientSDUSize ( ) const [pure virtual]

Intended Usage : The Client SDU size is the size of the largest service data unit that may be sent to the Client during the session.

A value of zero indicates that there is no limit to the SDU size.

Since:
7.0
Returns:
The SDU size, in bytes, as an unsigned 32-bit number.

Implemented in CWspCapabilityInfo.

MWspCapabilityViewer::GetExtendedMethods ( ) const [pure virtual]

Intended Usage : The set of extended methods.

This capability gives a set of methods, beyond those defined in HTTP/1.1.

Since:
7.0
Returns:
A const reference to a MWspExtendedMethods object.

Implemented in CWspCapabilityInfo.

MWspCapabilityViewer::GetHeaderCodePages ( ) const [pure virtual]

Intended Usage : The set of extension header code pages.

Since:
7.0
Returns:
A const reference to a MWspHeaderCodePages object.

Implemented in CWspCapabilityInfo.

MWspCapabilityViewer::GetMethodMOR ( ) const [pure virtual]

Intended Usage : The Method MOR defines the number of active/outstanding method invocations at one time during the session.

Since:
7.0
Returns:
The Method MOR size as an unsigned 8-bit number.

Implemented in CWspCapabilityInfo.

MWspCapabilityViewer::GetProtocolOptions ( ) const [pure virtual]

Intended Usage : The Protocol Options capability defines the optional service facilities and features for the session.

The presence of an element indicates that the use of the specified facility or feature is enabled. The features and facilities described in the WSP Specification, July 2001, are specified by flags in a single byte. Additional flags will be specified in subsequent bytes, but this is not supported currently.

Since:
7.0
Returns:
The Protocol Options encoded within a byte. Options.

Implemented in CWspCapabilityInfo.

MWspCapabilityViewer::GetPushMOR ( ) const [pure virtual]

Intended Usage : The Push MOR defines the number of active/outstanding push invocations at one time during the session.

Since:
7.0
Returns:
The Push MOR size as an unsigned 8-bit number.

Implemented in CWspCapabilityInfo.

MWspCapabilityViewer::GetServerMessageSize ( ) const [pure virtual]

Intended Usage : The Server Message size is the size of the largest message that may be sent to the Server during the session.

A message may consist of multiple SDUs. A value of zero indicates that there is no limit to the Message size.

Since:
7.0
Returns:
The Message size, in bytes, as an unsigned 32-bit number.

Implemented in CWspCapabilityInfo.

MWspCapabilityViewer::GetServerSDUSize ( ) const [pure virtual]

Intended Usage : The Server SDU size is the size of the largest service data unit that may be sent to the Server during the session.

A value of zero indicates that there is no limit to the SDU size.

Since:
7.0
Returns:
The SDU size, in bytes, as an unsigned 32-bit number.

Implemented in CWspCapabilityInfo.

MWspCapabilityViewer::GetUnknownCapabilities ( ) const [pure virtual]

Intended Usage : A set of capabilities not defined by the WSP Specification, July 2001.

The Identifier is encoded in the same way as the header field name - it uses the BNF rule for Field-Name, as shown in 8.4.2.6. Well-known capabilities have their identifier encoded using a short- integer, and unknown capabilities encode their identifier using a Null-terminated string. Any extra capabilities must be defined in such a way that an empty parameter value is illegal. This allows the unknown capability to be rejected.

Since:
7.0
Returns:
A const reference to a MWspUknownCapabilities object.

Implemented in CWspCapabilityInfo.

The documentation for this class was generated from the following file:
  • MWspCapabilityViewer.h


Member List

MWspCapabilityViewer Member List

This is the complete list of members for MWspCapabilityViewer, including all inherited members.
GetAliasAddresses() const=0 | MWspCapabilityViewer | [pure virtual]
GetClientMessageSize() const=0 | MWspCapabilityViewer | [pure virtual]
GetClientSDUSize() const=0 | MWspCapabilityViewer | [pure virtual]
GetExtendedMethods() const=0 | MWspCapabilityViewer | [pure virtual]
GetHeaderCodePages() const=0 | MWspCapabilityViewer | [pure virtual]
GetMethodMOR() const=0 | MWspCapabilityViewer | [pure virtual]
GetProtocolOptions() const=0 | MWspCapabilityViewer | [pure virtual]
GetPushMOR() const=0 | MWspCapabilityViewer | [pure virtual]
GetServerMessageSize() const=0 | MWspCapabilityViewer | [pure virtual]
GetServerSDUSize() const=0 | MWspCapabilityViewer | [pure virtual]
GetUnknownCapabilities() const=0 | MWspCapabilityViewer | [pure virtual]


MWspCLMethodCallback Class Reference

@public
Since:
7.0 The MWspCLMethodInvoker and MWspCLMethodCallback form the API that provides the WSP Connectionless Session Service Method Invocation facility, as described in the WSP Specification, July 2001.
More...

#include <MWspCLMethodCallback.h>

List of all members.

Public Methods

virtual void UnitMethodResultInd (TInt aStatus, const TDesC8 &aResponseHeaders, const TDesC8 &aResponseBody)=0
Intended Usage : This represents the S-Unit-MethodResult.ind primitive.

Detailed Description

@public
Since:
7.0 The MWspCLMethodInvoker and MWspCLMethodCallback form the API that provides the WSP Connectionless Session Service Method Invocation facility, as described in the WSP Specification, July 2001.

The MWspCLMethodInvoker interface is supplied by the Provider entity. The MWspCLMethodCallback interface is supplied by the Client entity. The Provider implements the communications necessary to send the primitives issued by the Client to the Server, and from the Server to the Client.

The Client object that encapsulates a method transaction implements the call-back API MWspCLMethodCallback. Internally, the Provider should associate each of these objects with a WSP Transaction Id in order to distinguish between method transactions.

Definition at line 38 of file MWspCLMethodCallback.h.

Member Function Documentation

MWspCLMethodCallback::UnitMethodResultInd | ( | TInt | aStatus,
 |  | const TDesC8 & | aResponseHeaders,
 |  | const TDesC8 & | aResponseBody
 | ) | [pure virtual]

Intended Usage : This represents the S-Unit-MethodResult.ind primitive.

The Provider issues this when it receives a method response from the Server.

Since:
7.0
Parameters:
aStatus | A status code whose value is given by the Status types defined in the WSP Specification, July 2001 .
aResponseHeaders | A buffer with the encoded request header.
aResponseBody | A buffer with the data associated with the request. Only used if the method aMethod supports an entity body.
Precondition:
There is a MWspCLMethodCallback object associated with the Transaction Id in the S-Unit-MethodResult.ind primitive.
Postcondition:
The MWspCLMethodCallback object associated with the Transaction Id in the S-Unit-MethodResult.ind primitive is no longer valid.

The documentation for this class was generated from the following file:
  • MWspCLMethodCallback.h


Member List

MWspCLMethodCallback Member List

This is the complete list of members for MWspCLMethodCallback, including all inherited members.
UnitMethodResultInd(TInt aStatus, const TDesC8 &aResponseHeaders, const TDesC8 &aResponseBody)=0 MWspCLMethodCallback [pure virtual]


MWspCLMethodInvoker Class Reference

@public
Since:
7.0 The MWspCLMethodInvoker and MWspCLMethodCallback form the API that provides the WSP Connectionless Session Service Method Invocation facility, as described in the WSP Specification, July 2001.
More...

#include <MWspCLMethodInvoker.h>

List of all members.

Public Methods

virtual void | UnitMethodInvoke (MWspCLMethodCallback &aMethodCallback, RStringF aMethod, const TUriC8 &aRequestUri, const TDesC8 &aRequestHeader, const TDesC8 &aRequestBody)=0
Intended Usage : This represents the S-Unit-MethodInvoke primitive.

virtual void | CancelMethodInvoke (MWspCLMethodCallback &aMethodCallback)=0
Intended Usage : The Client wishes to cancel the method.

Detailed Description

@public
Since:
7.0 The MWspCLMethodInvoker and MWspCLMethodCallback form the API that provides the WSP Connectionless Session Service Method Invocation facility, as described in the WSP Specification, July 2001.

The MWspCLMethodInvoker interface is supplied by the Provider entity. The MWspCLMethodCallback interface is supplied by the Client entity. The Provider implements the communications necessary to send the primitives issued by the Client to the Server, and from the Server to the Client.

The Client object that encapsulates a method transaction implements the call-back API MWspCLMethodCallback. Internally, the Provider should associate each of these objects with a WSP Transaction Id in order to distinguish between method transactions.

Definition at line 38 of file MWspCLMethodInvoker.h.

Member Function Documentation

MWspCLMethodInvoker::CancelMethodInvoke ( MWspCLMethodCallback & aMethodCallback ) [pure virtual]

Intended Usage : The Client wishes to cancel the method.

The call-back object pointed to by aMethodCallback is no longer valid. The Provider ignores any method responses associated with aMethodCallback.

Since:
7.0
Parameters:
aMethodCallback A refernce to an instance of the call-back API MWspCLMethodCallback.It uniquely identifies this method transaction for the lifetime of the transaction.
Precondition:
There exists a Transaction Id associated with aMethodCallback.
Postcondition:
Any received S-Unit-MethodResult primitive with a Transaction Id associated with aMethodCallback is ignored.

MWspCLMethodInvoker::UnitMethodInvoke | ( | MWspCLMethodCallback & | aMethodCallback,
 |  | RStringF | aMethod,
 |  | const TUriC8 & | aRequestUri,
 |  | const TDesC8 & | aRequestHeaders,
 |  | const TDesC8 & | aRequestBody
 | ) | [pure virtual]

Intended Usage : This represents the S-Unit-MethodInvoke primitive.

The Provider initiates a non-confirmed method with the Server. The Client expects the S-Unit-MethodResult primitive to be issued from the Provider.

Since:
7.0
Parameters:
aMethodCallback | A refernce to an instance of the call-back API MWspCLMethodCallback.It uniquely identifies this method transaction for the lifetime of the transaction.
aMethod | An RStringF object that describes the HTTP method for this transaction.
aRequestUri | A URI object that specifies the resource to which this operation applies.
aRequestHeaders | A buffer with the encoded request header.
aRequestBody | A buffer with the data associated with the request. Only used if the method aMethod supports an entity body.
Precondition:
The underlying layers are prepared for communication.
Postcondition:
The Provider is waiting for a S-Unit-MethodResult primitive from the Server.

The documentation for this class was generated from the following file:
  • MWspCLMethodInvoker.h


Member List

MWspCLMethodInvoker Member List

This is the complete list of members for MWspCLMethodInvoker, including all inherited members.
CancelMethodInvoke(MWspCLMethodCallback &aMethodCallback)=0 | MWspCLMethodInvoker | [pure virtual]
UnitMethodInvoke(MWspCLMethodCallback &aMethodCallback, RStringF aMethod, const TUriC8 &aRequestUri, const TDesC8 &aRequestHeader, const TDesC8 &aRequestBody)=0 | MWspCLMethodInvoker | [pure virtual]


MWspCLPushCallback Class Reference

@public
Since:
7.0 The MWspCLPushInvoker and MWspCLPushCallback form the API that provides the WSP Connectionless Session Service Push facility, as in the WSP Specification, July 2001.
More...

#include <MWspCLPushCallback.h>

List of all members.

Public Methods

virtual void UnitPushInd (const TDesC8 &aPushHeader, const TDesC8 &aPushBody)=0
Intended Usage : This represents the S-Unit-Push.ind primitive.

Detailed Description

@public
Since:
7.0 The MWspCLPushInvoker and MWspCLPushCallback form the API that provides the WSP Connectionless Session Service Push facility, as in the WSP Specification, July 2001.

The MWspCLMethodInvoker interface is supplied by the Provider entity. The MWspCLMethodCallback interface is supplied by the Client entity. The Provider implements the communications necessary to send the primitives issued by the Client to the Server, and from the Server to the Client.

The Client object that encapsulates a push transaction implements the call-back API MWspCLPushCallback. Internally, the Provider should associate each of these objects with a WSP Push Id in order to distinguish between push transactions.

Definition at line 36 of file MWspCLPushCallback.h.

Member Function Documentation

MWspCLPushCallback::UnitPushInd | ( | const TDesC8 & | aPushHeader,
 |  | const TDesC8 & | aPushBody
 | ) | [pure virtual]

Intended Usage : This represents the S-Unit-Push.ind primitive.

The Provider issues this when it receives Push information. The Client supplies a new listening Push transaction object, via the MWspCLPushInvoker API, to maintain the correct number of these objects in the Provider.

Since:
7.0
Parameters:
aPushHeader | A buffer that contains the byte-encoded headers for the Push information.
aPushBody | A buffer that contains the body of the Push information.
Precondition:
There is a listening Push transaction object available in the Provider.
Postcondition:
The number of available Push transaction objects available in the Provider is reduced by one.

The documentation for this class was generated from the following file:
  • MWspCLPushCallback.h


Member List

MWspCLPushCallback Member List

This is the complete list of members for MWspCLPushCallback, including all inherited members.
UnitPushInd(const TDesC8 &aPushHeader, const TDesC8 &aPushBody)=0 MWspCLPushCallback [pure virtual]


MWspCLPushInvoker Class Reference

@public
Since:
7.0 The MWspCLPushInvoker and MWspCLPushCallback form the API that provides the WSP Connectionless Session Service Push facility, as in the WSP Specification, July 2001.
More...

#include <MWspCLPushInvoker.h>

List of all members.

Public Methods

virtual void | InitPushReceive (MWspCLPushCallback &aPushCallback)=0
Intended Usage : Supplies the Provider with a Push transaction object.

virtual void | CancelPushReceive (MWspCLPushCallback &aPushCallback)=0
Intended Usage : Removes the listening Push transaction.

Detailed Description

@public
Since:
7.0 The MWspCLPushInvoker and MWspCLPushCallback form the API that provides the WSP Connectionless Session Service Push facility, as in the WSP Specification, July 2001.

The MWspCLMethodInvoker interface is supplied by the Provider entity. The MWspCLMethodCallback interface is supplied by the Client entity. The Provider implements the communications necessary to send the primitives issued by the Client to the Server, and from the Server to the Client.

The Client object that encapsulates a push transaction implements the call-back API MWspCLPushCallback. Internally, the Provider should associate each of these objects with a WSP Push Id in order to distinguish between push transactions.

Definition at line 36 of file MWspCLPushInvoker.h.

Member Function Documentation

MWspCLPushInvoker::CancelPushReceive ( MWspCLPushCallback & aPushCallback ) [pure virtual]

Intended Usage : Removes the listening Push transaction.

The Client no longer wishes to receive Push information via the specified MWspCLPushCallback object.

Since:
7.0
Parameters:
aPushCallback A reference to an instance of the call-back API MWspCLPushCallback.It uniquely identifies this method transaction for the lifetime of the transaction.
Precondition:
The Push transaction object is exists.
Postcondition:
The aPushCallback object is no longer valid. The number of listening Push transaction objects in the Provider is reduced by one.

MWspCLPushInvoker::InitPushReceive ( MWspCLPushCallback & aPushCallback ) [pure virtual]

Intended Usage : Supplies the Provider with a Push transaction object.

Also, informs the Provider that the Client is ready to receive Push information. The Provider uses this call- back object to pass Push information to the Client.

Since:
7.0
Parameters:
aPushCallback A reference to an instance of the call-back API MWspCLPushCallback.It uniquely identifies this method transaction for the lifetime of the transaction.
Precondition:
The underlying layers are prepared for communication.
Postcondition:
The Provider is waiting for a S-Unit-Push primitive from the Server. Increases the number of listening Push transactions by one.

The documentation for this class was generated from the following file:
  • MWspCLPushInvoker.h


Member List

MWspCLPushInvoker Member List

This is the complete list of members for MWspCLPushInvoker, including all inherited members.
CancelPushReceive(MWspCLPushCallback &aPushCallback)=0 | MWspCLPushInvoker | [pure virtual]
InitPushReceive(MWspCLPushCallback &aPushCallback)=0 | MWspCLPushInvoker | [pure virtual]


MWspCOMethodCallback Class Reference

@public
Since:
7.0 The MWspCOMethodInvoker and MWspCOMethodCallback form the API that provides the WSP Connection-Orientated Session Service Method Invocation facility, as described in the WSP Specification, July 2001.
More...

#include <MWspCOMethodCallback.h>

Inheritance diagram for MWspCOMethodCallback:

[legend]
List of all members.

Public Methods

virtual void | MethodInvokeCnf ()=0
Intended Usage : This represents the S-MethodInvoke.cnf primitive.

virtual void | MethodInvokeDataCnf ()=0
Intended Usage : This represents the S-MethodInvokeData.cnf primitive.

virtual void | MethodAbortInd (TWspReason aReason)=0
Intended Usage : This represents the S-MethodAbort.ind primitive.

virtual void | MethodResultInd (TInt aStatus, const TDesC8 &aResponseHeaders, MHTTPDataSupplier &aResponseBody, TBool aMoreData)=0
Intended Usage : This represents the S-MethodResult.ind primitive.

virtual void | MethodResultDataInd (const TDesC8 &aTrailerHeaders, TBool aMoreData)=0
Intended Usage : This represents the S-MethodResultData.ind primitive.

Detailed Description

@public
Since:
7.0 The MWspCOMethodInvoker and MWspCOMethodCallback form the API that provides the WSP Connection-Orientated Session Service Method Invocation facility, as described in the WSP Specification, July 2001.

The MWspCOMethodInvoker interface is supplied by the Provider entity. The MWspCOMethodCallback interface is supplied by the Client entity. The Provider implements the communications necessary to send the primitives issued by the Client to the Server, and from the Server to the Client.

A method transaction can only be invoked under the following circumstances; 1) The WSP session is in either the Connecting, Connected or Resuming state. 2) The number of of outstanding method transactions has not reached the negotiated Method MOR. Both these circumstances must be statisfied before a method may be invoked.

Further, during the capability negotiations, the Protocol Option for Large Data Transfer may be refused (WSP Specification 8.3.2.3). If this is the case, then the use of the S-MethodInvokeData (by the Client) and S-MethodResultData (by the Server) is forbidden.

The effect of not supporting LDT is that POST data may not be streamed and must not overflow the negotiated Server SDU size. The amount of allowed data in the S-MethodInvoke.req is dependent on the size of the destination URI and the method headers. A method transaction that exceeds the Server SDU size is aborted by the Client and is not invoked on the Provider.

Another case in which the Client may abort a method transaction is when the negotiated Server Message size has been exceeded. This also applies when LDT is supported in the WSP session. The Client aborts the method invocation on the Provider as well.

The object that encapsulates the concept of a method transaction implements the call-back API MWspCOMethodCallback. The Provider associates each of these objects with a Transaction Id used to distinguish between method transactions during a WSP session.

Definition at line 67 of file MWspCOMethodCallback.h.

Member Function Documentation

MWspCOMethodCallback::MethodAbortInd ( TWspReason aReason ) [pure virtual]

Intended Usage : This represents the S-MethodAbort.ind primitive.

This is issued when the method transaction has been aborted.

Since:
7.0
Parameters:
aReason A parameter that indicates the cause of the abort. The value maps to the Reason type defined in the WSP Specification, July 2001.
Precondition:
The WSP method transaction is not in the Null state.
Postcondition:
The WSP method transaction is in the Null state.

Implemented in CWspCOTransaction.

MWspCOMethodCallback::MethodInvokeCnf ( ) [pure virtual]

Intended Usage : This represents the S-MethodInvoke.cnf primitive.

The Provider issues this primitive when it has received the response to the method request invocation from the Server (S-MethodInvoke.res). If the negotiated Server Message size has been exceeded by the S-MethodInvoke.ind primitive, then the Provider aborts the method transaction.

Since:
7.0
Precondition:
The WSP method transaction is in the Requesting state.
Postcondition:
If there are subsequent S-MethodInvokeData.req primitives to be issued for this method request, then the WSP method transaction remains in the Requesting state. If the entire request has been sent to the Server, then the WSP method transaction is in the Waiting state.

Implemented in CWspCOTransaction.

MWspCOMethodCallback::MethodInvokeDataCnf ( ) [pure virtual]

Intended Usage : This represents the S-MethodInvokeData.cnf primitive.

The Provider issues this primitive when it has received the response to the method request invocation from the Server (S-MethodInvokeData.res).If the negotiated Server Message size has been exceeded, then the Provider aborts the method transaction.

Since:
7.0
Precondition:
The WSP method transaction is in the Requesting state.
Postcondition:
If there are subsequent S-MethodInvokeData.req primitives to be issued for this method request, then the WSP method transaction remains in the Requesting state. If the entire request has been sent to the Server, then the WSP method transaction is in the Waiting state.

Implemented in CWspCOTransaction.

MWspCOMethodCallback::MethodResultDataInd | ( | const TDesC8 & | aTrailerHeaders,
 |  | TBool | aMoreData
 | ) | [pure virtual]

Intended Usage : This represents the S-MethodResultData.ind primitive.

The Provider sends more data associated with a previous S-MethodResult.ind primitive.

The remaining body data is obtained using the data supplier object aResponseBody provided to the Client as a parameter of the previous call to MethodResultInd().

The aMoreData flag indicates whether there are subsequent S-MethodResultData primitives to follow.

If there are trailer headers these are provided by the input parameter aTrailerHeaders. This is only valid if this is the last S-MethodResultData primitive.

The Server expects the S-MethodResultData.res primitive to be sent from the Client.

Since:
7.0
Parameters:
aTrailerHeaders | A reference to a buffer with the encoded trailer headers. This must be empty unless this is the last S-MethodResultData primitive.
aMoreDate | A flag indicating that there are subsequent S-MethodResultData primitives to follow for this transaction.
Precondition:
The WSP method transaction is in the Waiting2 state.
Postcondition:
If subsequent S-MethodResultData primitives are expected, then the WSP method transaction is in the Waiting2 state. If all the response information has been received, then the WSP method transaction is in the Completing state.

Implemented in CWspCOTransaction.

MWspCOMethodCallback::MethodResultInd | ( | TInt | aStatus,
 |  | const TDesC8 & | aResponseHeaders,
 |  | MHTTPDataSupplier & | aResponseBody,
 |  | TBool | aMoreData
 | ) | [pure virtual]

Intended Usage : This represents the S-MethodResult.ind primitive.

The Provider issues this primitive when it has received the response for this method transaction from the Server.

The aMoreData flag indicates whether there are subsequent S-MethodResultData primitives to follow. This is only possible if LDT is supported.

If there are subsequent S-MethodResultData primitives for this transaction, then the data supplier object aResponseBody is used to obtain the body data in all the subsequent S-MethodResultData primitives.

The Server expects the S-MethodResult.res primitive to be sent from the Client.

Since:
7.0
Parameters:
aStatus | A status code whose value is given by the Status types defined in the WSP Specification, July 2001 .
aResponseHeaders | A reference to buffer that provides the encoded response headers.
aResponseBody | A reference to a data supplier object that provides the data associated with the response.
aMoreDate | A flag indicating that there are subsequent S-MethodResultData primitives to follow for this transaction.
Precondition:
The WSP method transaction is in the Waiting state.
Postcondition:
If subsequent S-MethodResultData primitives are expected, then the WSP method transaction is in the Waiting2 state. If all the response information has been received, then the WSP method transaction is in the Completing state.

Implemented in CWspCOTransaction.

The documentation for this class was generated from the following file:
  • MWspCOMethodCallback.h


Member List

MWspCOMethodCallback Member List

This is the complete list of members for MWspCOMethodCallback, including all inherited members.
MethodAbortInd(TWspReason aReason)=0 | MWspCOMethodCallback | [pure virtual]
MethodInvokeCnf()=0 | MWspCOMethodCallback | [pure virtual]
MethodInvokeDataCnf()=0 | MWspCOMethodCallback | [pure virtual]
MethodResultDataInd(const TDesC8 &aTrailerHeaders, TBool aMoreData)=0 | MWspCOMethodCallback | [pure virtual]
MethodResultInd(TInt aStatus, const TDesC8 &aResponseHeaders, MHTTPDataSupplier &aResponseBody, TBool aMoreData)=0 | MWspCOMethodCallback | [pure virtual]


MWspCOMethodInvoker Class Reference

@public
Since:
7.0 The MWspCOMethodInvoker and MWspCOMethodCallback form the API that provides the WSP Connection-Orientated Session Service Method Invocation facility, as described in the WSP Specification, July 2001.
More...

#include <MWspCOMethodInvoker.h>

Inheritance diagram for MWspCOMethodInvoker:

[legend]
List of all members.

Public Methods

virtual void | MethodInvokeReq (MWspCOMethodCallback &aMethodCallback, RStringF aMethod, const TUriC8 &aRequestUri, const TDesC8 &aRequestHeaders, const TDesC8 &aRequestBody, TBool aMoreData)=0
Intended Usage : This represents the S-MethodInvoke.req primitive.

virtual void | MethodInvokeDataReq (MWspCOMethodCallback &aMethodCallback, const TDesC8 &aRequestBody, const TDesC8 &aTrailerHeaders, TBool aMoreData)=0
Intended Usage : This represents the S-MethodInvokeData.req primitive.

virtual void | MethodAbortReq (MWspCOMethodCallback &aMethodCallback)=0
Intended Usage : This represents the S-MethodAbort.req primitive.

virtual void | MethodResultRes (MWspCOMethodCallback &aMethodCallback, const TDesC8 &aAckHeaders)=0
Intended Usage : This represents the S-MethodResult.res primitive.

virtual void | MethodResultDataRes (MWspCOMethodCallback &aMethodCallback, const TDesC8 &aAckHeaders)=0
Intended Usage : This represents the S-MethodResultData.res primitive.

Detailed Description

@public
Since:
7.0 The MWspCOMethodInvoker and MWspCOMethodCallback form the API that provides the WSP Connection-Orientated Session Service Method Invocation facility, as described in the WSP Specification, July 2001.

The MWspCOMethodInvoker interface is supplied by the Provider entity. The MWspCOMethodCallback interface is supplied by the Client entity. The Provider implements the communications necessary to send the primitives issued by the Client to the Server, and from the Server to the Client.

A method transaction can only be invoked under the following circumstances; 1) The WSP session is in either the Connecting, Connected or Resuming state. 2) The number of of outstanding method transactions has not reached the negotiated Method MOR. Both these circumstances must be statisfied before a method may be invoked.

Further, during the capability negotiations, the Protocol Option for Large Data Transfer may be refused (WSP Specification 8.3.2.3). If this is the case, then the use of the S-MethodInvokeData (by the Client) and S-MethodResultData (by the Server) is forbidden.

The effect of not supporting LDT is that POST data may not be streamed and must not overflow the negotiated Server SDU size. The amount of allowed data in the S-MethodInvoke.req is dependent on the size of the destination URI and the method headers. A method transaction that exceeds the Server SDU size is aborted by the Client and is not invoked on the Provider.

Another case in which the Client may abort a method transaction is when the negotiated Server Message size has been exceeded. This also applies when LDT is supported in the WSP session. The Client aborts the method invocation on the Provider as well.

The object that encapsulates the concept of a method transaction implements the call-back API MWspCOMethodCallback. The Provider associates each of these objects with a Transaction Id used to distinguish between method transactions during a WSP session.

Definition at line 65 of file MWspCOMethodInvoker.h.

Member Function Documentation

MWspCOMethodInvoker::MethodAbortReq ( MWspCOMethodCallback & aMethodCallback ) [pure virtual]

Intended Usage : This represents the S-MethodAbort.req primitive.

The Provider aborts the method transaction specified by aMethodCallback. The Client expects the S-MethdoInvoke.ind primitive to indicate that the transaction is aborted.

Since:
7.0
Parameters:
aMethodCallback A reference to an instance of the call-back API MWspCOMethodCallback. It uniquely identifies this method transaction for the lifetime of the transaction.
Precondition:
The WSP method transaction is in any state other than the Null or Aborting state.
Postcondition:
The WSP method transaction is in the Aborting state.

Implemented in CNwssWspCOSession.

MWspCOMethodInvoker::MethodInvokeDataReq | ( | MWspCOMethodCallback & | aMethodCallback,
 |  | const TDesC8 & | aRequestBody,
 |  | const TDesC8 & | aTrailerHeaders,
 |  | TBool | aMoreData
 | ) | [pure virtual]

Intended Usage : This represents the S-MethodInvokeData.req primitive.

The Provider sends more data associated with a previous S-MethodInvoke.req primitive. The Transport Handler uses the transaction callback to identify which previous S-MethodInvoke.req corresponds correctly.

The aMoreData flag indicates whether there are subsequent S-MethodInvokeData primitives for this transaction. The data for entity body will not excced the SDU.

If there are trailer headers these are provided by the input parameter aTrailerHeaders. This is only valid if this is the last S-MethodInvokeData primitive.

The expected callback primitives that may follow are S-MethodInvokeData.cnf or S-MethodAbort.ind. The method is aborted if the negotiated Server Message size is exceeded.

Since:
7.0
Parameters:
aMethodCallback | A reference to an instance of the call-back API MWspCOMethodCallback. It uniquely identifies this method transaction for the lifetime of the transaction.
aRequestBody | A reference to a buffer containing the data associated with the request.
aTrailerHeaders | A reference to a buffer with the encoded trailer headers. This must be empty unless this is the last S-MethodInvokeData primitive.
aMoreData | A boolean flag indicating whether there are subsequent S-MethodInvokeData primitives for this transaction.
Precondition:
The WSP method transaction is in the Requesting state.
Postcondition:
The WSP method transaction remains in the Requesting state. Neither the Server SDU size nor the Server Message size have been exceeded.

Implemented in CNwssWspCOSession.

MWspCOMethodInvoker::MethodInvokeReq | ( | MWspCOMethodCallback & | aMethodCallback,
 |  | RStringF | aMethod,
 |  | const TUriC8 & | aRequestUri,
 |  | const TDesC8 & | aRequestHeaders,
 |  | const TDesC8 & | aRequestBody,
 |  | TBool | aMoreData
 | ) | [pure virtual]

Intended Usage : This represents the S-MethodInvoke.req primitive.

The Provider initiates a method request, associating the parameter aMethodCallback with a Transaction Id for this request. This Id is unique for the lifetime of the transaction.

The expected primitives to be received are S-MethodInvoke.cnf or S-MethodAbort.ind. The method is aborted if the Server Message size is exceeded.

The aMoreData flag indicates whether there are subsequent S-MethodInvokeData primitives for this transaction. The data for entity body will not excced the SDU.

Since:
7.0
Parameters:
aMethodCallback | A reference to an instance of the call- back API MWspCOMethodCallback. It uniquely identifies this method transaction for the lifetime of the transaction.
aMethod | An RStringF object that describes the HTTP method for this transaction.
aRequestUri | A URI object that specifies the resource to which this operation applies.
aRequestHeaders | A reference to a buffer with the encoded request headers.
aRequestBody | A reference to a buffer containing the data associated with the request. Only used if the method aMethod supports an entity body.
aMoreData | A boolean flag indicating whether there are subsequent S-MethodInvokeData primitives for this transaction.
Precondition:
The WSP session is in the Connecting, Connected or Resuming state. The method MOR has not been reached. The WSP method transaction is in Null state.
Postcondition:
The WSP method transaction is in Requesting state. Neither the Server SDU size nor the Server Message size have been exceeded.

Implemented in CNwssWspCOSession.

MWspCOMethodInvoker::MethodResultDataRes | ( | MWspCOMethodCallback & | aMethodCallback,
 |  | const TDesC8 & | aAckHeaders
 | ) | [pure virtual]

Intended Usage : This represents the S-MethodResultData.res primitive.

The sending of acknowledgement headers is a negotiated capability. If the Server has not agreed to this capability, then the parameter aAckHeaders is ignored.

Since:
7.0
Parameters:
aMethodCallback | A reference to an instance of the call-back API MWspCOMethodCallback. It uniquely identifies this method transaction for the lifetime of the transaction.
aAckHeaders | A buffer that contains the optional set of headers containing some information to return to the Server. This may be empty.
Precondition:
The WSP method transaction is in the Waiting2 or Completing state.
Postcondition:
If the WSP method transaction was in the Waiting2 state, it remains in that state. If the WSP method transaction was in the Completing state, it moves into the Null state amd the method transaction is complete.

Implemented in CNwssWspCOSession.

MWspCOMethodInvoker::MethodResultRes | ( | MWspCOMethodCallback & | aMethodCallback,
 |  | const TDesC8 & | aAckHeaders
 | ) | [pure virtual]

Intended Usage : This represents the S-MethodResult.res primitive.

The sending of acknowledgement headers is a negotiated capability. If the Server has not agreed to this capability, then the parameter aAckHeaders is ignored.

Since:
7.0
Parameters:
aMethodCallback | A reference to an instance of the call-back API MWspCOMethodCallback. It uniquely identifies this method transaction for the lifetime of the transaction.
aAckHeaders | A buffer that contains the optional set of headers containing some information to return to the Server. This may be empty.
Precondition:
The WSP method transaction is in the Waiting2 or Completing state.
Postcondition:
If the WSP method transaction was in the Waiting2 state, it remains in that state. If the WSP method transaction was in the Completing state, it moves into the Null state and the method transaction is complete.

Implemented in CNwssWspCOSession.

The documentation for this class was generated from the following file:
  • MWspCOMethodInvoker.h


Member List

MWspCOMethodInvoker Member List

This is the complete list of members for MWspCOMethodInvoker, including all inherited members.
MethodAbortReq(MWspCOMethodCallback &aMethodCallback)=0 | MWspCOMethodInvoker | [pure virtual]
MethodInvokeDataReq(MWspCOMethodCallback &aMethodCallback, const TDesC8 &aRequestBody, const TDesC8 &aTrailerHeaders, TBool aMoreData)=0 | MWspCOMethodInvoker | [pure virtual]
MethodInvokeReq(MWspCOMethodCallback &aMethodCallback, RStringF aMethod, const TUriC8 &aRequestUri, const TDesC8 &aRequestHeaders, const TDesC8 &aRequestBody, TBool aMoreData)=0 | MWspCOMethodInvoker | [pure virtual]
MethodResultDataRes(MWspCOMethodCallback &aMethodCallback, const TDesC8 &aAckHeaders)=0 | MWspCOMethodInvoker | [pure virtual]
MethodResultRes(MWspCOMethodCallback &aMethodCallback, const TDesC8 &aAckHeaders)=0 | MWspCOMethodInvoker | [pure virtual]


MWspCOMethodObserver Class Reference

#include <MWspCOMethodObserver.h>

Inheritance diagram for MWspCOMethodObserver:

[legend]
Collaboration diagram for MWspCOMethodObserver:

[legend]
List of all members.

Public Methods

virtual void | HandleMethodAbort (CWspCOTransaction &aTransaction)=0
Since:
7.0

virtual void | NotifyPendingCompletingMethod ()=0
Since:
7.0

virtual void | NotifyMethodComplete ()=0
Since:
7.0

Detailed Description

Todo:
docing

Definition at line 19 of file MWspCOMethodObserver.h.

Member Function Documentation

MWspCOMethodObserver::HandleMethodAbort ( CWspCOTransaction & aTransaction ) [pure virtual]

Since:
7.0

Parameters:
aTransaction A reference to the aborted method transaction.
Postcondition:
The aborted method transaction has been dealt with.

Implemented in CWspCOProtocolHandler.

MWspCOMethodObserver::NotifyMethodComplete ( ) [pure virtual]

Since:
7.0

Implemented in CWspCOProtocolHandler.

MWspCOMethodObserver::NotifyPendingCompletingMethod ( ) [pure virtual]

Since:
7.0

Implemented in CWspCOProtocolHandler.

The documentation for this class was generated from the following file:
  • MWspCOMethodObserver.h


Member List

MWspCOMethodObserver Member List

This is the complete list of members for MWspCOMethodObserver, including all inherited members.
HandleMethodAbort(CWspCOTransaction &aTransaction)=0 | MWspCOMethodObserver | [pure virtual]
NotifyMethodComplete()=0 | MWspCOMethodObserver | [pure virtual]
NotifyPendingCompletingMethod()=0 | MWspCOMethodObserver | [pure virtual]
SetStatusL(CRxData &aRxData, TInt aStatus)=0 | MRxDataObserver | [pure virtual]


CWspCOProtocolHandler Class Reference

#include <CWspCOProtocolHandler.h>

Inheritance diagram for CWspCOProtocolHandler:

[legend]
Collaboration diagram for CWspCOProtocolHandler:

[legend]
List of all members.

Public Methods

~CWspCOProtocolHandler ()
Intended Usage : Standard destructor.

Static Public Methods

CWspCOProtocolHandler * | NewL (TAny *aSession)
Intended Usage : Static factory constructor.

Private Methods

virtual void | CreateCodecL ()
virtual CProtTransaction * | CreateProtTransactionL (RHTTPTransaction aTransaction)
Intended Usage: Creates a representation of a client transaction to be used in the protocol handler.

virtual TBool | ServiceL (CProtTransaction &aTrans)
virtual void | ClosedTransactionHook (CProtTransaction *aTrans)
virtual void | CancelTransactionHook (CProtTransaction &aTransaction)
virtual void | NotifyNewRequestBodyPart (CProtTransaction &aTransaction)
TInt | SessionServerCert (TCertInfo &aServerCert)
Get the Server Certificate for the current session.

TInt | TransactionServerCert (TCertInfo &aServerCert, RHTTPTransaction aTransaction)
Get the Server Certificate for the specified transaction.

virtual void | MHFSessionRunL (const THTTPSessionEvent &aEvent)
virtual TInt | MHFSessionRunError (TInt aError, const THTTPSessionEvent &aEvent)
virtual void | ConnectCnf ()
virtual void | ResumeCnf ()
virtual void | DisconnectInd (TWspReason aReason, TBool aRedirectSecurity, TWspRedirectedAddress &aRedirectAddress, const TDesC8 &aErrorHeader, const TDesC8 &aErrorBody)
virtual void | SuspendInd (TWspReason aReason)
virtual void | ExceptionInd (const TDesC8 &aExceptionData)
virtual const MWspCapabilityViewer & | ClientCapabilities () const
virtual MWspCapabilitySetter & | ServerCapabilities () const
virtual const TDesC8 & | ClientHeaders () const
virtual void | SetServerHeadersL (const TDesC8 &aBuffer)
virtual void | HandleConnectionTimedOut ()
virtual void | SendPrimitiveL (TWspPrimitive aPrimitive)
virtual TInt | WspPrimitiveSenderCallbackError (TInt aError)
virtual void | HandleMethodAbort (CWspCOTransaction &aTransaction)
virtual void | NotifyPendingCompletingMethod ()
virtual void | NotifyMethodComplete ()
virtual void | SetStatusL (CRxData &aRecv, TInt aStatus)
CWspCOProtocolHandler (RHTTPSession aSession)
Since:
7.0

void | ConstructL ()
Since:
7.0

void | SessionConnectL ()
Intended Usage : Initiates a session connection.

void | SessionResumeL ()
Intended Usage : Initiates a session resume.

void | SessionDisconnect (TWspReason aReason)
Intended Usage : The session should be disconnected.

void | SessionSuspend ()
Intended Usage : The session should be suspended.

void | DoSessionConnectedL ()
Intended Usage : Processes the session connected event.

void | DoSessionConnected ()
Intended Usage : Processes the session connected event, this is a non-leaving method of DoSessionConnectedL()
Since:
7.0.

void | SendSessionEvent (THTTPSessionEvent aEvent)
void | CreateWspTransportHandlerL ()
Intended Usage :
Since:
7.0.

void | UpdateClientSessionHeadersL ()
Intended Usage : Updates the client session headers that is supplied to the transport handler
Since:
7.0 @leave Leaves with KErrNoMemory if the header buffer cannot be created.

void | CheckClientCapabilities ()
Intended Usage : Checks the properties in the HTTP session for any client proposed capablities and a specified connection time-out value.

TBool | UpdateNegotiatedCapabilitiesL ()
Intended Usage : Checks the client-requested capabilities against the corresponding negotiated capabilities to see if they have been reduced or denied.

void | HandleConnectRequestL ()
Handles the receipt of a EConnect session event.

void | HandleDisconnectRequest ()
Handles the receipt of a EDisconnect session event.

void | CheckWaitingMethod ()
Checks to see if a method is waiting.

TBool | SupportSuspendResume () const
Intended Usage : Indicates if the Suspend Resume facility is supported by the WSP session.

TBool | CanResume () const
Intended Usage : Indicates whether the WSP session can be resumed.

TBool | CanSuspend () const
Intended Usage : Indicates whether the WSP session can be suspended.

void | ResetAll ()
Intended Usage : Resets the state of the protocol handler to that upon initial construction, without changing the transport handler.

Private Attributes

CWspTransportHandler * iTransportHandler
A pointer to the Wsp Transport Handler.

MWspCOSessionInvoker * iSessionInvoker
A pointer to the CO Session Invoker object.

CWspCapabilityInfo * iNegotiatedCapInfo
An object that holds the negotiated capabilties for the current Wsp session.

CWspCapabilityInfo * iClientCapInfo
An object that holds the proposed client capabilities.

CWspProxyInfoProvider * iProxyInfoProvider
A pointer to the proxy info provider.

TWspSessionState | iSessionState
The state of the WSP session.

TInt | iTimedOutValue
The connection timed-out value in microseconds.

CConnectionTimer * iConnectionTimer
A pointer to the connection timed-out timer.

CWspPrimitiveSender * iPrimitiveSender
An active object that is used to invoke the sending of certain WSP primitives.

HBufC8 * | iClientSessionHeaders
A buffer holding the encoded client session headers.

TBool | iConnectTimedOut
A flag indicating that a session connect or resume has timed-out.

TBool | iWaitingMethod
A flag indicating that there is a method transaction waiting to be serviced.

CWspHeaderUtils * iHdrUtils
A pointer to the WSP header utils.

TInt | iPendingCompletingMethods
The number of methods in Completing state waiting to send the final .res primitive.

TBool | iDisconnectRequested
A flag indicating that the client has requested a disconnect.

Detailed Description

Todo:
docing

Definition at line 34 of file CWspCOProtocolHandler.h.

Constructor & Destructor Documentation

CWspCOProtocolHandler::~CWspCOProtocolHandler ( )

Intended Usage : Standard destructor.

Since:
7.0

CWspCOProtocolHandler::CWspCOProtocolHandler ( RHTTPSession aSession ) [private]

Since:
7.0

Parameters:
aSession The HTTP session.

Member Function Documentation

CWspCOProtocolHandler::CancelTransactionHook ( CProtTransaction & aTrans ) [private, virtual]

See also:
CProtocolHandler

Implements CProtocolHandler.

CWspCOProtocolHandler::CanResume ( ) const [private]

Intended Usage : Indicates whether the WSP session can be resumed.

The Suspend Resume facility must be supported and the WSP session must in the Connected, Suspending or Suspended state.

Since:
7.0
Returns:
A boolean value of ETrue if the WSP session can be resumed.

CWspCOProtocolHandler::CanSuspend ( ) const [private]

Intended Usage : Indicates whether the WSP session can be suspended.

The Suspend Resume facility must be supported and the WSP session must in the Connected or Resuming state.

Since:
7.0
Returns:
A boolean value of ETrue if the WSP session can be suspended.

CWspCOProtocolHandler::CheckClientCapabilities ( ) [private]

Intended Usage : Checks the properties in the HTTP session for any client proposed capablities and a specified connection time-out value.

Since:
7.0
Postcondition:
The client proposed capabilities and the connection time-out value have been updated.

CWspCOProtocolHandler::CheckWaitingMethod ( ) [private]

Checks to see if a method is waiting.

If so it sets the base class active so that the next pending transaction gets serviced.

Since:
7.0

CWspCOProtocolHandler::ClientCapabilities ( ) const [private, virtual]

See also:
MWspCapabilityProvider

Implements MWspCapabilityProvider.

CWspCOProtocolHandler::ClientHeaders ( ) const [private, virtual]

See also:
MWspSessionHeadersProvider

Implements MWspSessionHeadersProvider.

CWspCOProtocolHandler::ClosedTransactionHook ( CProtTransaction * aTrans ) [private, virtual]

See also:
CProtocolHandler

Implements CProtocolHandler.

CWspCOProtocolHandler::ConnectCnf ( ) [private, virtual]

See also:
MWspCOSessionCallback

Implements MWspCOSessionCallback.

CWspCOProtocolHandler::ConstructL ( ) [private]

Since:
7.0

Todo:
leaves
Precondition:
First phase construction has been done.
Postcondition:
The object is fully initialised.

CWspCOProtocolHandler::CreateCodecL ( ) [private, virtual]

See also:
CProtocolHandler

Implements CProtocolHandler.

virtual CProtTransaction* CWspCOProtocolHandler::CreateProtTransactionL ( RHTTPTransaction aTransaction ) [private, virtual]

Intended Usage: Creates a representation of a client transaction to be used in the protocol handler.

Since the protocol handler deals with the low- level data for a transaction as sent over a particular transport, an appropriate CProtTransaction-derived class is used that owns a CRxData and a CTxData to handle the low-level data.

This must be implemented by a concrete protocol handler sub-class.

Since:
7.0 @leave Leave code KErrNoMemory if there was not enough memory to create the object.
Parameters:
aTransaction The RHTTPTransaction object associated with this CProtTransaction object.
Returns:
A pointer to a created CProtTransaction-derived class. @leaves Standard Symbian OS error codes. e.g. KErrNoMemory.
See also:
CRxData , CTxData

Implements CProtocolHandler.

CWspCOProtocolHandler::CreateWspTransportHandlerL ( ) [private]

Intended Usage :

Since:
7.0.

Todo:
docing @leave Leaves with KErrNotFound if the WSP transport handler cannot be found. Leaves with KErrNotSupported if the loaded WSP transport handler does not support Connection-Orientated Session Management facility and Method Invocation facility.
Postcondition:
The

CWspCOProtocolHandler::DisconnectInd | ( | TWspReason | aReason,
 |  | TBool | aRedirectSecurity,
 |  | TWspRedirectedAddress & | aRedirectAddress,
 |  | const TDesC8 & | aErrorHeaders,
 |  | const TDesC8 & | aErrorBody
 | ) | [private, virtual]

See also:
MWspCOSessionCallback

Implements MWspCOSessionCallback.

CWspCOProtocolHandler::DoSessionConnected ( ) [private]

Intended Usage : Processes the session connected event, this is a non-leaving method of DoSessionConnectedL()

Since:
7.0.

Precondition:
Postcondition:

CWspCOProtocolHandler::DoSessionConnectedL ( ) [private]

Intended Usage : Processes the session connected event.

Since:
7.0
Precondition:
Postcondition:

CWspCOProtocolHandler::ExceptionInd ( const TDesC8 & aExceptionData ) [private, virtual]

See also:
MWspCOSessionCallback

Implements MWspCOSessionCallback.

CWspCOProtocolHandler::HandleConnectionTimedOut ( ) [private, virtual]

See also:
MConnectionTimerCallback

Implements MConnectionTimerCallback.

CWspCOProtocolHandler::HandleConnectRequestL ( ) [private]

Handles the receipt of a EConnect session event.

Will inform the client if the WSP session is not in the appropriate state to receive this event.

Since:
7.0
Exceptions:
This function will leave if the session connect/resume fails.

CWspCOProtocolHandler::HandleDisconnectRequest ( ) [private]

Handles the receipt of a EDisconnect session event.

Will inform the client if the WSP session is not in the appropriate state to receive this event.

Since:
7.0

CWspCOProtocolHandler::HandleMethodAbort ( CWspCOTransaction & aTransaction ) [private, virtual]

See also:
MWspCOMethodObserver

Implements MWspCOMethodObserver.

CWspCOProtocolHandler::MHFSessionRunError | ( | TInt | aError,
 |  | const THTTPSessionEvent & | aEvent
 | ) | [private, virtual]

See also:
MHTTPFilterBase

Reimplemented from CProtocolHandler.

CWspCOProtocolHandler::MHFSessionRunL ( const THTTPSessionEvent & aEvent ) [private, virtual]

See also:
MHTTPFilterBase

Reimplemented from CProtocolHandler.

CWspCOProtocolHandler::NewL ( TAny * aSession ) [static]

Intended Usage : Static factory constructor.

Since:
7.0 @leave Leaves with KErrNoMemory if there was not enough memory to create the object.
Parameters:
aSession A pointer to an RHTTPSession object.
Returns:
A pointer to newly created object.

CWspCOProtocolHandler::NotifyMethodComplete ( ) [private, virtual]

See also:
MWspCOMethodObserver

Implements MWspCOMethodObserver.

CWspCOProtocolHandler::NotifyNewRequestBodyPart ( CProtTransaction & aTransaction ) [private, virtual]

See also:
CProtocolHandler

Implements CProtocolHandler.

CWspCOProtocolHandler::NotifyPendingCompletingMethod ( ) [private, virtual]

See also:
MWspCOMethodObserver

Implements MWspCOMethodObserver.

CWspCOProtocolHandler::ResetAll ( ) [private]

Intended Usage : Resets the state of the protocol handler to that upon initial construction, without changing the transport handler.

This is NOT a published mechanism!

Since:
7.0

CWspCOProtocolHandler::ResumeCnf ( ) [private, virtual]

See also:
MWspCOSessionCallback

Implements MWspCOSessionCallback.

CWspCOProtocolHandler::SendPrimitiveL ( TWspPrimitive aPrimitive ) [private, virtual]

See also:
MWspPrimitiveSenderCallback

Implements MWspPrimitiveSenderCallback.

void CWspCOProtocolHandler::SendSessionEvent ( THTTPSessionEvent aEvent ) [private]

CWspCOProtocolHandler::ServerCapabilities ( ) const [private, virtual]

See also:
MWspCapabilityProvider

Implements MWspCapabilityProvider.

CWspCOProtocolHandler::ServiceL ( CProtTransaction & aTrans ) [private, virtual]

See also:
CProtocolHandler

Implements CProtocolHandler.

CWspCOProtocolHandler::SessionConnectL ( ) [private]

Intended Usage : Initiates a session connection.

Since:
7.0
Warning:
This function will panic with KWspPanicSessionNotInValidState if the WSP session cannot be connected.
Todo:
leaves
Precondition:
The WSP session is in the Null state.
Postcondition:
The WSP session is in the Connecting state. The connection timer has been started.

CWspCOProtocolHandler::SessionDisconnect ( TWspReason aReason ) [private]

Intended Usage : The session should be disconnected.

Since:
7.0
Warning:
This function will panic with KWspPanicSessionNotInValidState if the WSP session cannot be disconnected.
Todo:
leaves
Precondition:
The WSP session is in the Connecting, Connected, Suspending, Suspended, or Resuming state.
Postcondition:
The WSP session is in the Closing state. The connection timer has been cancelled.

CWspCOProtocolHandler::SessionResumeL ( ) [private]

Intended Usage : Initiates a session resume.

Since:
7.0
Warning:
This function will panic with KWspPanicSessionNotInValidState if the WSP session cannot be resumed.
Todo:
leaves
Precondition:
The WSP session is in the Connected, Suspending or Suspended state. The Suspend Resume facility is supported in this WSP session.
Postcondition:
The WSP session is in the Resuming state. The connection timer has been started.

TInt CWspCOProtocolHandler::SessionServerCert ( TCertInfo & aServerCert ) [private, virtual]

Get the Server Certificate for the current session.

Parameters:
aServerCert A TCertInfo which will be filled with the certificate information
Returns:
An error code. KErrNone if aServerCert has been completed, otherwise one of the system wide error codes

Implements CProtocolHandler.

CWspCOProtocolHandler::SessionSuspend ( ) [private]

Intended Usage : The session should be suspended.

Since:
7.0
Warning:
This function will panic with KWspPanicSessionNotInValidState if the WSP session cannot be suspended.
Todo:
leaves
Precondition:
The WSP session is in the Connected or Resuming state. The Suspend Resume facility is supported in this WSP session.
Postcondition:
The WSP session is in the Closing state. The connection timer has been cancelled.

CWspCOProtocolHandler::SetServerHeadersL ( const TDesC8 & aBuffer ) [private, virtual]

See also:
MWspSessionHeadersProvider

Implements MWspSessionHeadersProvider.

CWspCOProtocolHandler::SetStatusL | ( | CRxData & | aRecv,
 |  | TInt | aStatus
 | ) | [private, virtual]

See also:
MRxDataObserver

Implements MRxDataObserver.

CWspCOProtocolHandler::SupportSuspendResume ( ) const [private]

Intended Usage : Indicates if the Suspend Resume facility is supported by the WSP session.

Since:
7.0
Returns:
A boolean value of ETrue if the WSP session can support the Suspend Resume facility.

CWspCOProtocolHandler::SuspendInd ( TWspReason aReason ) [private, virtual]

See also:
MWspCOSessionCallback

Implements MWspCOSessionCallback.

TInt CWspCOProtocolHandler::TransactionServerCert | ( | TCertInfo & | aServerCert,
 |  | RHTTPTransaction | aTransaction
 | ) | [private, virtual]

Get the Server Certificate for the specified transaction.

This function returns KErrNotSupported because for WSP the certificate applies to the whole session.

Parameters:
aServerCert | A TCertInfo which will be filled with the certificate information
aTransaction | The transaction for which the certificate info is requested
Returns:
KErrNotSupported

Implements CProtocolHandler.

CWspCOProtocolHandler::UpdateClientSessionHeadersL ( ) [private]

Intended Usage : Updates the client session headers that is supplied to the transport handler

Since:
7.0 @leave Leaves with KErrNoMemory if the header buffer cannot be created.

Postcondition:
The client session headers buffer is upto date.

CWspCOProtocolHandler::UpdateNegotiatedCapabilitiesL ( ) [private]

Intended Usage : Checks the client-requested capabilities against the corresponding negotiated capabilities to see if they have been reduced or denied.

Since:
7.0
Todo:
leaves
Returns:
A boolean value of ETrue if one or more of the client- requested capabilities have been reduced or denied.
Precondition:
The negotiated capabilities have been passed up from the transport handler. The S-Connect.cnf primitive has been received.
Postcondition:
If any of the client-requested capabilities have been reduced or rejected, the session property representing that capabililty is set the appropriate negotiated value.

CWspCOProtocolHandler::WspPrimitiveSenderCallbackError ( TInt aError ) [private, virtual]

See also:
MWspPrimitiveSenderCallback

Implements MWspPrimitiveSenderCallback.

Member Data Documentation

CWspCapabilityInfo* CWspCOProtocolHandler::iClientCapInfo [private]

An object that holds the proposed client capabilities.

Definition at line 485 of file CWspCOProtocolHandler.h.

HBufC8* CWspCOProtocolHandler::iClientSessionHeaders [private]

A buffer holding the encoded client session headers.

Definition at line 518 of file CWspCOProtocolHandler.h.

CConnectionTimer* CWspCOProtocolHandler::iConnectionTimer [private]

A pointer to the connection timed-out timer.

Definition at line 507 of file CWspCOProtocolHandler.h.

TBool CWspCOProtocolHandler::iConnectTimedOut [private]

A flag indicating that a session connect or resume has timed-out.

Definition at line 523 of file CWspCOProtocolHandler.h.

TBool CWspCOProtocolHandler::iDisconnectRequested [private]

A flag indicating that the client has requested a disconnect.

Definition at line 543 of file CWspCOProtocolHandler.h.

CWspHeaderUtils* CWspCOProtocolHandler::iHdrUtils [private]

A pointer to the WSP header utils.

Definition at line 534 of file CWspCOProtocolHandler.h.

CWspCapabilityInfo* CWspCOProtocolHandler::iNegotiatedCapInfo [private]

An object that holds the negotiated capabilties for the current Wsp session.

Definition at line 480 of file CWspCOProtocolHandler.h.

TInt CWspCOProtocolHandler::iPendingCompletingMethods [private]

The number of methods in Completing state waiting to send the final .res primitive.

Definition at line 539 of file CWspCOProtocolHandler.h.

CWspPrimitiveSender* CWspCOProtocolHandler::iPrimitiveSender [private]

An active object that is used to invoke the sending of certain WSP primitives.

Definition at line 513 of file CWspCOProtocolHandler.h.

CWspProxyInfoProvider* CWspCOProtocolHandler::iProxyInfoProvider [private]

A pointer to the proxy info provider.

Definition at line 490 of file CWspCOProtocolHandler.h.

MWspCOSessionInvoker* CWspCOProtocolHandler::iSessionInvoker [private]

A pointer to the CO Session Invoker object.

Owned by the transport handler.

Definition at line 474 of file CWspCOProtocolHandler.h.

TWspSessionState CWspCOProtocolHandler::iSessionState [private]

The state of the WSP session.

Definition at line 495 of file CWspCOProtocolHandler.h.

TInt CWspCOProtocolHandler::iTimedOutValue [private]

The connection timed-out value in microseconds.

The protocol handler will abort a session connect after this time if a connection has not been established.

Definition at line 502 of file CWspCOProtocolHandler.h.

CWspTransportHandler* CWspCOProtocolHandler::iTransportHandler [private]

A pointer to the Wsp Transport Handler.

Definition at line 468 of file CWspCOProtocolHandler.h.

TBool CWspCOProtocolHandler::iWaitingMethod [private]

A flag indicating that there is a method transaction waiting to be serviced.

Definition at line 529 of file CWspCOProtocolHandler.h.

The documentation for this class was generated from the following file:
  • CWspCOProtocolHandler.h


Member List

CWspCOProtocolHandler Member List

This is the complete list of members for CWspCOProtocolHandler, including all inherited members.
CancelTransactionHook(CProtTransaction &aTransaction) | CWspCOProtocolHandler | [private, virtual]
CanResume() const | CWspCOProtocolHandler | [private]
CanSuspend() const | CWspCOProtocolHandler | [private]
CheckClientCapabilities() | CWspCOProtocolHandler | [private]
CheckWaitingMethod() | CWspCOProtocolHandler | [private]
ClientCapabilities() const | CWspCOProtocolHandler | [private, virtual]
ClientHeaders() const | CWspCOProtocolHandler | [private, virtual]
ClosedTransactionHook(CProtTransaction *aTrans) | CWspCOProtocolHandler | [private, virtual]
Codec() const | CProtocolHandler |
CompleteSelf() | CProtocolHandler | [protected]
ConnectCnf() | CWspCOProtocolHandler | [private, virtual]
ConstructL() | CWspCOProtocolHandler | [private]
CProtocolHandler::ConstructL(RHTTPSession aSession) | CProtocolHandler | [protected]
CProtocolHandler(RHTTPSession aSession) | CProtocolHandler | [protected]
CreateCodecL() | CWspCOProtocolHandler | [private, virtual]
CreateProtTransactionL(RHTTPTransaction aTransaction) | CWspCOProtocolHandler | [private, virtual]
CreateWspTransportHandlerL() | CWspCOProtocolHandler | [private]
CWspCOProtocolHandler(RHTTPSession aSession) | CWspCOProtocolHandler | [private]
DisconnectInd(TWspReason aReason, TBool aRedirectSecurity, TWspRedirectedAddress &aRedirectAddress, const TDesC8 &aErrorHeader, const TDesC8 &aErrorBody) | CWspCOProtocolHandler | [private, virtual]
DoCancel() | CProtocolHandler | [protected, virtual]
DoSessionConnected() | CWspCOProtocolHandler | [private]
DoSessionConnectedL() | CWspCOProtocolHandler | [private]
ECache enum value | MHTTPFilter |
EClient enum value | MHTTPFilter |
EClientFilters enum value | MHTTPFilter |
ECookies enum value | MHTTPFilter |
EProtocolHandler enum value | MHTTPFilter |
EStatusCodeHandler enum value | MHTTPFilter |
ETidyUp enum value | MHTTPFilter |
ExceptionInd(const TDesC8 &aExceptionData) | CWspCOProtocolHandler | [private, virtual]
FindTransaction(RHTTPTransaction aTransaction, const CProtTransaction *&aProtTransaction) const | CProtocolHandler | [protected]
HandleConnectionTimedOut() | CWspCOProtocolHandler | [private, virtual]
HandleConnectRequestL() | CWspCOProtocolHandler | [private]
HandleDisconnectRequest() | CWspCOProtocolHandler | [private]
HandleMethodAbort(CWspCOTransaction &aTransaction) | CWspCOProtocolHandler | [private, virtual]
iClientCapInfo | CWspCOProtocolHandler | [private]
iClientSessionHeaders | CWspCOProtocolHandler | [private]
iCodec | CProtocolHandler | [protected]
iConnectionTimer | CWspCOProtocolHandler | [private]
iConnectTimedOut | CWspCOProtocolHandler | [private]
iDisconnectRequested | CWspCOProtocolHandler | [private]
iHdrUtils | CWspCOProtocolHandler | [private]
iNegotiatedCapInfo | CWspCOProtocolHandler | [private]
iPendingCompletingMethods | CWspCOProtocolHandler | [private]
iPrimitiveSender | CWspCOProtocolHandler | [private]
iProxyInfoProvider | CWspCOProtocolHandler | [private]
iSecurityPolicy | CProtocolHandler | [protected]
iSession | CProtocolHandler | [protected]
iSessionInvoker | CWspCOProtocolHandler | [private]
iSessionState | CWspCOProtocolHandler | [private]
iTimedOutValue | CWspCOProtocolHandler | [private]
iTransportHandler | CWspCOProtocolHandler | [private]
iWaitingMethod | CWspCOProtocolHandler | [private]
MHFLoad(RHTTPSession aSession, THTTPFilterHandle aHandle) | CProtocolHandler | [virtual]
MHFRunError(TInt aError, RHTTPTransaction aTransaction, const THTTPEvent &aEvent) | CProtocolHandler | [virtual]
MHFRunL(RHTTPTransaction aTransaction, const THTTPEvent &aEvent) | CProtocolHandler | [virtual]
MHFSessionRunError(TInt aError, const THTTPSessionEvent &aEvent) | CWspCOProtocolHandler | [private, virtual]
MHFSessionRunL(const THTTPSessionEvent &aEvent) | CWspCOProtocolHandler | [private, virtual]
MHFUnload(RHTTPSession aSession, THTTPFilterHandle aHandle) | CProtocolHandler | [virtual]
NewL(TAny *aSession) | CWspCOProtocolHandler | [static]
CProtocolHandler::NewL(const TDesC8 &aProtocol, RHTTPSession aSession) | CProtocolHandler | [static]
NotifyMethodComplete() | CWspCOProtocolHandler | [private, virtual]
NotifyNewRequestBodyPart(CProtTransaction &aTransaction) | CWspCOProtocolHandler | [private, virtual]
NotifyPendingCompletingMethod() | CWspCOProtocolHandler | [private, virtual]
NumActiveTransactions() const | CProtocolHandler | [protected]
ResetAll() | CWspCOProtocolHandler | [private]
ResumeCnf() | CWspCOProtocolHandler | [private, virtual]
RunError(TInt aError) | CProtocolHandler | [protected, virtual]
RunL() | CProtocolHandler | [protected, virtual]
SendPrimitiveL(TWspPrimitive aPrimitive) | CWspCOProtocolHandler | [private, virtual]
SendSessionEvent(THTTPSessionEvent aEvent) | CWspCOProtocolHandler | [private]
ServerCapabilities() const | CWspCOProtocolHandler | [private, virtual]
ServiceL(CProtTransaction &aTrans) | CWspCOProtocolHandler | [private, virtual]
SessionConnectL() | CWspCOProtocolHandler | [private]
SessionDisconnect(TWspReason aReason) | CWspCOProtocolHandler | [private]
SessionResumeL() | CWspCOProtocolHandler | [private]
SessionServerCert(TCertInfo &aServerCert) | CWspCOProtocolHandler | [private, virtual]
SessionSuspend() | CWspCOProtocolHandler | [private]
SetServerHeadersL(const TDesC8 &aBuffer) | CWspCOProtocolHandler | [private, virtual]
SetStatusL(CRxData &aRecv, TInt aStatus) | CWspCOProtocolHandler | [private, virtual]
SupportSuspendResume() const | CWspCOProtocolHandler | [private]
SuspendInd(TWspReason aReason) | CWspCOProtocolHandler | [private, virtual]
TPositions enum name | MHTTPFilter |
TransactionCompletedL(RHTTPTransaction aTrans, THTTPEvent aEventStatus) | CProtocolHandler | [protected]
TransactionFailed(RHTTPTransaction aTrans) | CProtocolHandler | [protected]
TransactionServerCert(TCertInfo &aServerCert, RHTTPTransaction aTransaction) | CWspCOProtocolHandler | [private, virtual]
UpdateClientSessionHeadersL() | CWspCOProtocolHandler | [private]
UpdateNegotiatedCapabilitiesL() | CWspCOProtocolHandler | [private]
WspPrimitiveSenderCallbackError(TInt aError) | CWspCOProtocolHandler | [private, virtual]
~CProtocolHandler() | CProtocolHandler | [virtual]
~CWspCOProtocolHandler() | CWspCOProtocolHandler |


MWspCOPushCallback Class Reference

@public
Since:
7.0 The MWspCOPushInvoker and MWspCOPushCallback form the API that proides the WSP Connection-Orientated Session Servise Push and Confirmed Push facilities, as decribed in the WSP Specification, July 2001.
More...

#include <MWspCOPushCallback.h>

List of all members.

Public Methods

virtual void | PushInd (const TDesC8 &aPushHeader, const TDesC8 &aPushBody)=0
Intended Usage : This represents the S-Push.ind primitive.

virtual void | ConfirmedPushInd (const TDesC8 &aPushHeader, const TDesC8 &aPushBody)=0
Intended Usage : This represents the S-ConfirmedPush.ind primitive.

virtual void | PushAbortInd (TWspReason aReason)=0
Intended Usage : This represents the S-PushAbort.ind primitive.

Detailed Description

@public
Since:
7.0 The MWspCOPushInvoker and MWspCOPushCallback form the API that proides the WSP Connection-Orientated Session Servise Push and Confirmed Push facilities, as decribed in the WSP Specification, July 2001.

The MWspCOPsuhInvoker interface is supplied by the Provider entity. The MWspCOPsuhCallback interface is supplied by the Client entity. The Provider implements the communications necessary to send the primitives issued by the Client to the Server, and from the Server to the Client.

The use of the Push and Confirmed Push facilities during the lifetime of the WSP Session is dependent on these being successfully negotiated capabilities for that session.

The Push MOR is also negotiated with the Server, and defines the number of outstanding confirmed push invocations that can be active at one time.

The object that implements the call-back API MWspCOPushCallback encapsulates the concept of a Push transaction. The Provider associates each of these objects with a Push Id used to distinguish between push transactions during a WSP session.

The sending of Push information is initiated by the Server, but for this information to be passed onto the Client, the Provider must be informed that the Client is ready to receive Push transactions. This is achieved by supplying the Provider with Push transaction objects that are prepared to receive Push information - listening Push transaction objects.

In the case of the Confirmed Push facility, the number of these objects that the Client supplies to the Provider is decided by the negotiated Push MOR. If the Push facility has been successfully negotiated, the Client must supply a further Push transaction object.

Definition at line 57 of file MWspCOPushCallback.h.

Member Function Documentation

MWspCOPushCallback::ConfirmedPushInd | ( | const TDesC8 & | aPushHeader,
 |  | const TDesC8 & | aPushBody
 | ) | [pure virtual]

Intended Usage : This represents the S-ConfirmedPush.ind primitive.

The Provider issues this when it receives Confirmed Push information. The Provider expects either the S-ConfirmedPush.res or the S-PushAbort.req primitives to be issued from the Client.

Since:
7.0
Parameters:
aPushHeader | A buffer that contains the byte-encoded headers for the Push information.
aPushBody | A buffer that contains the body of the Push information.
Precondition:
The WSP push transaction is in the Null state.
Postcondition:
The WSP push transaction is in the Receiving state.

MWspCOPushCallback::PushAbortInd ( TWspReason aReason ) [pure virtual]

Intended Usage : This represents the S-PushAbort.ind primitive.

This is issued when Confirmed Push information has been rejected.

Since:
7.0
Parameters:
aReason A parameter that indicates the cause of the abort. The value maps to the Reason type defined in the WSP Specification, July 2001.
Precondition:
The WSP push transaction is in the Receiving or Aborting state.
Postcondition:
The WSP push transaction is in the Null state.

MWspCOPushCallback::PushInd | ( | const TDesC8 & | aPushHeader,
 |  | const TDesC8 & | aPushBody
 | ) | [pure virtual]

Intended Usage : This represents the S-Push.ind primitive.

The Provider issues this when it receives unconfirmed Push information. The Client supplies a new listening Push transaction object, via the MWspCOPushInvoker API, to maintain the correct number of these objects in the Provider.

Since:
7.0
Parameters:
aPushHeader | A buffer that contains the byte-encoded headers for the Push information.
aPushBody | A buffer that contains the body of the Push information.
Precondition:
There is a listening Push transaction object.
Postcondition:
The number of listening Push transaction objects are reduced by one.

The documentation for this class was generated from the following file:
  • MWspCOPushCallback.h


Member List

MWspCOPushCallback Member List

This is the complete list of members for MWspCOPushCallback, including all inherited members.
ConfirmedPushInd(const TDesC8 &aPushHeader, const TDesC8 &aPushBody)=0 | MWspCOPushCallback | [pure virtual]
PushAbortInd(TWspReason aReason)=0 | MWspCOPushCallback | [pure virtual]
PushInd(const TDesC8 &aPushHeader, const TDesC8 &aPushBody)=0 | MWspCOPushCallback | [pure virtual]


MWspCOPushInvoker Class Reference

@public
Since:
7.0 The MWspCOPushInvoker and MWspCOPushCallback form the API that provides the WSP Connection-Orientated Session Servise Push and Confirmed Push facilities, as decribed in the WSP Specification, July 2001.
More...

#include <MWspCOPushInvoker.h>

List of all members.

Public Methods

virtual void | PushListen (MWspCOPushCallback &aPushCallback)=0
Intended Usage : Provides a Push transaction to the Provider.

virtual void | CancelPushListen (MWspCOPushCallback &aPushCallback)=0
Intended Usage : Removes a listening Push transaction.

virtual void | PushAbortReq (MWspCOPushCallback &aPushCallback, TWspReason aReason)=0
Intended Usage : This represents the S-PushAbort.req primitive.

virtual void | ConfirmedPushRes (MWspCOPushCallback &aPushCallback, const TDesC8 &aAckHeaders)=0
Intended Usage : This represents the S-ConfirmedPush.res primitive.

Detailed Description

@public
Since:
7.0 The MWspCOPushInvoker and MWspCOPushCallback form the API that provides the WSP Connection-Orientated Session Servise Push and Confirmed Push facilities, as decribed in the WSP Specification, July 2001.

The MWspCOPsuhInvoker interface is supplied by the Provider entity. The MWspCOPsuhCallback interface is supplied by the Client entity. The Provider implements the communications necessary to send the primitives issued by the Client to the Server, and from the Server to the Client.

The use of the Push and Confirmed Push facilities during the lifetime of the WSP Session is dependent on these being successfully negotiated capabilities for that session.

The Push MOR is also negotiated with the Server, and defines the number of outstanding confirmed push invocations that can be active at one time.

The object that implements the call-back API MWspCOPushCallback encapsulates the concept of a Push transaction. The Provider associates each of these objects with a Push Id used to distinguish between push transactions during a WSP session.

The sending of Push information is initiated by the Server, but for this information to be passed onto the Client, the Provider must be informed that the Client is ready to receive Push transactions. This is achieved by supplying the Provider with Push transaction objects that are prepared to receive Push information - listening Push transaction objects.

In the case of the Confirmed Push facility, the exact number of these objects that the Client supplies to the Provider is determined by the negotiated Push MOR.

Furthermore, if the Push facility has been successfully negotiated, the Client must supply one additional Push transaction object.

Definition at line 59 of file MWspCOPushInvoker.h.

Member Function Documentation

MWspCOPushInvoker::CancelPushListen ( MWspCOPushCallback & aPushCallback ) [pure virtual]

Intended Usage : Removes a listening Push transaction.

The Client no longer wishes to receive Push information via the specified Push transaction call-back object.

Since:
7.0
Parameters:
aPushCallback A reference to an instance of the call-back API MWspCOPushCallback.It uniquely identifies this method transaction for the lifetime of the transaction.
Precondition:
The Push transaction object exists.
Postcondition:
Reduces the number of listening Push transactions by one.

MWspCOPushInvoker::ConfirmedPushRes | ( | MWspCOPushCallback & | aPushCallback,
 |  | const TDesC8 & | aAckHeaders
 | ) | [pure virtual]

Intended Usage : This represents the S-ConfirmedPush.res primitive.

The Protocol Handler issues this primitive to acknowledge the receipt of Confirmed Push information. The call-back pointer is no longer valid after this call.

Since:
7.0
Parameters:
aPushCallback | A reference to an instance of the call-back API MWspCOPushCallback.It uniquely identifies this method transaction for the lifetime of the transaction. This is no longer valid once this call returns.
aAckHeaders | A buffer that contains the optional set of headers containing some information to return to the Server.
Precondition:
The WSP push transaction is in the Receiving state.
Postcondition:
The WSP push transaction is in the Null state. The call-back object aPushCallback is no longer valid.

MWspCOPushInvoker::PushAbortReq | ( | MWspCOPushCallback & | aPushCallback,
 |  | TWspReason | aReason
 | ) | [pure virtual]

Intended Usage : This represents the S-PushAbort.req primitive.

The Client issues this when it has received Confirmed Push information that it wishes to reject.The Client expects the S-PushAbort.ind to be issued by the Provider.

Since:
7.0
Parameters:
aPushCallback | A reference to an instance of the call-back API MWspCOPushCallback.It uniquely identifies this method transaction for the lifetime of the transaction.
aReason | A parameter that indicates the cause of the abort.The value maps to the Reason type defined in the July 2001 WSP Specification.
Precondition:
The call-back reference aPushCallback represents a Confirmed Push transaction. The WSP push transaction is in the Receiving state.
Postcondition:
The WSP push tranasaction is in the Aborting state.

MWspCOPushInvoker::PushListen ( MWspCOPushCallback & aPushCallback ) [pure virtual]

Intended Usage : Provides a Push transaction to the Provider.

Also, informs the Provider that the Client can receive Push information. The Provider uses this call-back object to pass Push and Confirmed Push transactions to the Client.

Since:
7.0
Parameters:
aPushCallback A reference to an instance of the call-back API MWspCOPushCallback.It uniquely identifies this method transaction for the lifetime of the transaction.
Precondition:
The WSP session is in the Connecting, Connected or Resuming state. Either the Push facility, Confirmed Push facility or both have been successfully negotiated with the Server.
Postcondition:
Increases the number of listening Push transactions by one.

The documentation for this class was generated from the following file:
  • MWspCOPushInvoker.h


Member List

MWspCOPushInvoker Member List

This is the complete list of members for MWspCOPushInvoker, including all inherited members.
CancelPushListen(MWspCOPushCallback &aPushCallback)=0 | MWspCOPushInvoker | [pure virtual]
ConfirmedPushRes(MWspCOPushCallback &aPushCallback, const TDesC8 &aAckHeaders)=0 | MWspCOPushInvoker | [pure virtual]
PushAbortReq(MWspCOPushCallback &aPushCallback, TWspReason aReason)=0 | MWspCOPushInvoker | [pure virtual]
PushListen(MWspCOPushCallback &aPushCallback)=0 | MWspCOPushInvoker | [pure virtual]


CWspCORxData Class Reference

#include <CWspCORxData.h>

Inheritance diagram for CWspCORxData:

[legend]
Collaboration diagram for CWspCORxData:

[legend]
List of all members.

Public Methods

~CWspCORxData ()
Intended Usage : Standard destructor.

void | SetResponseDataL (const TDesC8 &aResponseHeaders, MHTTPDataSupplier &aResponseBody, TBool aMoreResponseData)
void | UpdateResponseDataL (const TDesC8 &aTrailerHeaders, TBool aMoreResponseData)
Intended Usage : Fetches any extra body data from the stored data supplier.

Static Public Methods

CWspCORxData * | NewL (CProtTransaction &aTrasaction, MRxDataObserver &aObserver, MWspCORxDataCallback &aMethodCallback)
Intended Usage : Static factory constructor.

Private Methods

virtual void | ResetRxData ()
virtual TBool | GetNextDataPart (TPtrC8 &aDataPart)
virtual void | ReleaseData ()
virtual TInt | OverallDataSize ()
virtual TInt | Reset ()
CWspCORxData (CProtTransaction &aTransaction, MRxDataObserver &aObserver, MWspCORxDataCallback &aMethodCallback)
Intended Usage : First phase constructor.

void | SetHeaderDataL (const TDesC8 &aResponseHeaders)
Intended Usage :
Since:
7.0 @leave.

void | SetBodyDataL (MHTTPDataSupplier &aResponseBody)
Intended Usage :
Since:
7.0 @leave.

void | UpdateHeaderDataL (const TDesC8 &aTrailerHeaders)
Intended Usage :
Since:
7.0 @leave.

void | UpdateBodyDataL ()
Intended Usage :
Since:
7.0 @leave.

void | ResponseCompleteL ()
Informs the observer that the response is complete.

Private Attributes

MWspCORxDataCallback & iMethodCallback
A reference to the method callback object.

MHTTPDataSupplier * iBodyDataSupplier
A pointer to the data supplier for the body data - not owned.

TBool | iMoreData
A flag that indicates whether subsequent S-MethodResultData primitives are expected for the response.

TBool | iLastChunk
A flag to indicate whether there are more data chunks to be obtained from the data supplier object for the current SDU.

TBool | iGotBodyData
A flag that indicates whether there is a current response body data part.

TPtrC8 | iBodyData
A descriptor pointer to a buffer containing the current reponse body data part.

TInt | iOverallDataSize
The overall size of the body data.

TBool | iHasTrailer
A flag that indicates the there are trailer headers.

Constructor & Destructor Documentation

CWspCORxData::~CWspCORxData ( )

Intended Usage : Standard destructor.

Since:
7.0

CWspCORxData::CWspCORxData | ( | CProtTransaction & | aTransaction,
 |  | MRxDataObserver & | aObserver,
 |  | MWspCORxDataCallback & | aMethodCallback
 | ) | [private]

Intended Usage : First phase constructor.

Since:
7.0
Parameters:
aTransaction | The protocol transaction object associated with the Rx data object.
aObserver | A reference to the Rx data observer object.
aMethodCallback | A reference to the callback object.

Member Function Documentation

CWspCORxData::GetNextDataPart ( TPtrC8 & aDataPart ) [private, virtual]

See also:
MHTTPDataSupplier

Implements MHTTPDataSupplier.

CWspCORxData::NewL | ( | CProtTransaction & | aProtTrans,
 |  | MRxDataObserver & | aObserver,
 |  | MWspCORxDataCallback & | aMethodCallback
 | ) | [static]

Intended Usage : Static factory constructor.

Since:
7.0 @leave Leaves with KErrNoMemory if there was not enough memory to create the object.
Parameters:
aTransaction | The protocol transaction object associated with the Rx data object.
aObserver | A reference to the Rx data observer object.
aMethodCallback | A reference to the callback object.
Returns:
A pointer to newly created object.

CWspCORxData::OverallDataSize ( ) [private, virtual]

See also:
MHTTPDataSupplier

Implements MHTTPDataSupplier.

CWspCORxData::ReleaseData ( ) [private, virtual]

See also:
MHTTPDataSupplier

Implements MHTTPDataSupplier.

CWspCORxData::Reset ( ) [private, virtual]

See also:
MHTTPDataSupplier

Implements MHTTPDataSupplier.

void CWspCORxData::ResetRxData ( ) [private, virtual]

See also:
CRxData

Implements CRxData.

CWspCORxData::ResponseCompleteL ( ) [private]

Informs the observer that the response is complete.

Also, if there are trailer headers, the client is sent the EGotResponseTrailerHeaders event.

Since:
7.0
Precondition:
All the response data has been received and sent to the client.
Postcondition:
The observer has been told that the response is complete. If trailer headers have been received, the client is sent the EGotResponseTrailerHeaders event.

CWspCORxData::SetBodyDataL ( MHTTPDataSupplier & aResponseBody ) [private]

Intended Usage :

Since:
7.0 @leave.

Parameters:
aResponseBody A reference to the data supplier object for the body data.
Precondition:
A S-MethodResult primitive has been received. The EGotResponseHeaders event has been sent.
Postcondition:
The body data supplier is stored.

CWspCORxData::SetHeaderDataL ( const TDesC8 & aResponseHeaders ) [private]

Intended Usage :

Since:
7.0 @leave.

Parameters:
aResponseHeaders A reference a buffer with the header data.
Precondition:
A S-MethodResult primitive has been received.
Postcondition:
The trailer header data has been segmented into the individual header fields and set in the response object.

void CWspCORxData::SetResponseDataL | ( | const TDesC8 & | aResponseHeaders,
 |  | MHTTPDataSupplier & | aResponseBody,
 |  | TBool | aMoreResponseData
 | ) |

CWspCORxData::UpdateBodyDataL ( ) [private]

Intended Usage :

Since:
7.0 @leave.

Precondition:
A S-MethodResultData primitive has been received.
Postcondition:
Any extra body data is appended to the buffer.

CWspCORxData::UpdateHeaderDataL ( const TDesC8 & aTrailerHeaders ) [private]

Intended Usage :

Since:
7.0 @leave.

Parameters:
aTrailerHeaders A reference to a buffer with the encoded trailer headers. This must be empty unless this is the last S-MethodResultData primitive.
Precondition:
A S-MethodResultData primitive has been received.
Postcondition:
Any extra header data is segmented into the individual header fields and added to the response object's headers.

CWspCORxData::UpdateResponseDataL | ( | const TDesC8 & | aTrailerHeaders,
 |  | TBool | aMoreResponseData
 | ) |

Intended Usage : Fetches any extra body data from the stored data supplier.

Trailer header data is only allowed if this is the last S-MethodResultData primitive.

If this is the last primitive and there is some header data, this is segmented into the individual header fields and added to the response object's headers. The raw field value is not decoded. This is left for when the field value is required.

The client is sent the EGotResponseTrailerHeaders event.

If there is any extra body data and the client has already released the previous batch of body data, then the EGotResponseBodyData event is sent.

The more data flag that indicates if there is more data to be received for this transaction in subsequent S-MethodResultData primitives to follow.

Since:
7.0 @leave The function will leave with KWspErrNotExpectingTrailers if there is trailer header data but more S-MethodResulData primitives are expected. Also, it will leave if it fails to update the body data.
Parameters:
aTrailerHeaders | A reference to a buffer with the encoded trailer headers. This must be empty unless this is the last S-MethodResultData primitive.
aMoreResponseData | A flag indicating that there is more data to be received for this transaction in subsequent S-MethodResultData primitives to follow. .
Precondition:
A S-MethodResultData primitive has been received.
Postcondition:
Any trailer header data is segmented into the individual header fields and added to the response object's headers. The client is notified of more body data if there is any and the previous batch of data has been released.

Member Data Documentation

TPtrC8 CWspCORxData::iBodyData [private]

A descriptor pointer to a buffer containing the current reponse body data part.

Definition at line 272 of file CWspCORxData.h.

MHTTPDataSupplier* CWspCORxData::iBodyDataSupplier [private]

A pointer to the data supplier for the body data - not owned.

Definition at line 250 of file CWspCORxData.h.

TBool CWspCORxData::iGotBodyData [private]

A flag that indicates whether there is a current response body data part.

Definition at line 266 of file CWspCORxData.h.

TBool CWspCORxData::iHasTrailer [private]

A flag that indicates the there are trailer headers.

Definition at line 283 of file CWspCORxData.h.

TBool CWspCORxData::iLastChunk [private]

A flag to indicate whether there are more data chunks to be obtained from the data supplier object for the current SDU.

Definition at line 261 of file CWspCORxData.h.

MWspCORxDataCallback& CWspCORxData::iMethodCallback [private]

A reference to the method callback object.

Definition at line 245 of file CWspCORxData.h.

TBool CWspCORxData::iMoreData [private]

A flag that indicates whether subsequent S-MethodResultData primitives are expected for the response.

Definition at line 256 of file CWspCORxData.h.

TInt CWspCORxData::iOverallDataSize [private]

The overall size of the body data.

If this is not known, e.g. the response is divided over several primitives, then this is set to KErrNotFound.

Definition at line 279 of file CWspCORxData.h.

The documentation for this class was generated from the following file:
  • CWspCORxData.h


Member List

CWspCORxData Member List

This is the complete list of members for CWspCORxData, including all inherited members.
ConstructL() | CRxData | [protected]
CRxData() | CRxData | [protected]
CRxData(CProtTransaction &aProtTrans, MRxDataObserver &aObserver) | CRxData | [protected]
CWspCORxData(CProtTransaction &aTransaction, MRxDataObserver &aObserver, MWspCORxDataCallback &aMethodCallback) | CWspCORxData | [private]
GetNextDataPart(TPtrC8 &aDataPart) | CWspCORxData | [private, virtual]
iBodyData | CWspCORxData | [private]
iBodyDataSupplier | CWspCORxData | [private]
iGotBodyData | CWspCORxData | [private]
iHasTrailer | CWspCORxData | [private]
iLastChunk | CWspCORxData | [private]
iMethodCallback | CWspCORxData | [private]
iMoreData | CWspCORxData | [private]
iObserver | CRxData | [protected]
iOverallDataSize | CWspCORxData | [private]
iProtTrans | CRxData | [protected]
NewL(CProtTransaction &aTrasaction, MRxDataObserver &aObserver, MWspCORxDataCallback &aMethodCallback) | CWspCORxData | [static]
OverallDataSize() | CWspCORxData | [private, virtual]
ProtTrans() | CRxData |
ReleaseData() | CWspCORxData | [private, virtual]
Reset() | CWspCORxData | [private, virtual]
ResetRxData() | CWspCORxData | [private, virtual]
ResponseCompleteL() | CWspCORxData | [private]
SetBodyDataL(MHTTPDataSupplier &aResponseBody) | CWspCORxData | [private]
SetHeaderDataL(const TDesC8 &aResponseHeaders) | CWspCORxData | [private]
SetResponseDataL(const TDesC8 &aResponseHeaders, MHTTPDataSupplier &aResponseBody, TBool aMoreResponseData) | CWspCORxData |
UpdateBodyDataL() | CWspCORxData | [private]
UpdateHeaderDataL(const TDesC8 &aTrailerHeaders) | CWspCORxData | [private]
UpdateResponseDataL(const TDesC8 &aTrailerHeaders, TBool aMoreResponseData) | CWspCORxData |
~CRxData() | CRxData | [virtual]
~CWspCORxData() | CWspCORxData |


MWspCORxDataCallback Class Reference

#include <MWspCORxDataCallback.h>

Inheritance diagram for MWspCORxDataCallback:

[legend]
List of all members.

Public Methods

virtual void | AbortResponse ()=0
Informs the Rx Data object observer that the method should be aborted.

virtual void | SendResponsePrimitive ()=0
Informs the Tx Data object observer that it should send the response to the S-MethodResult or S-MethodResultData primitive.

Member Function Documentation

MWspCORxDataCallback::AbortResponse ( ) [pure virtual]

Informs the Rx Data object observer that the method should be aborted.

Since:
7.0

Implemented in CWspCOTransaction.

MWspCORxDataCallback::SendResponsePrimitive ( ) [pure virtual]

Informs the Tx Data object observer that it should send the response to the S-MethodResult or S-MethodResultData primitive.

Since:
7.0

Implemented in CWspCOTransaction.

The documentation for this class was generated from the following file:
  • MWspCORxDataCallback.h


Member List

MWspCORxDataCallback Member List

This is the complete list of members for MWspCORxDataCallback, including all inherited members.
AbortResponse()=0 | MWspCORxDataCallback | [pure virtual]
SendResponsePrimitive()=0 | MWspCORxDataCallback | [pure virtual]


MWspCOSessionCallback Class Reference

@public
Since:
7.0 The MWspCOSessionInvoker and MWspCOSessionCallback form the API that provides the WSP Connection-Orientated Session Service Session Management, Session Resume and Exception Handling facilities, as described by the WSP Specification, July 2001.
More...

#include <MWspCOSessionCallback.h>

Inheritance diagram for MWspCOSessionCallback:

[legend]
List of all members.

Public Methods

virtual void | ConnectCnf ()=0
Intended Usage : This represents the S-Connect.cnf primitive.

virtual void | ResumeCnf ()=0
Intended Usage : This represents the S-Resume.cnf primitive.

virtual void | DisconnectInd (TWspReason aReason, TBool aRedirectSecurity, TWspRedirectedAddress &aRedirectAddress, const TDesC8 &aErrorHeader, const TDesC8 &aErrorBody)=0
Intended Usage : This represents the S-Disconnect.ind primitive.

virtual void | SuspendInd (TWspReason aReason)=0
Intended Usage : This represents the S-Suspend.ind primitive.

virtual void | ExceptionInd (const TDesC8 &aExceptionData)=0
Intended Usage : This represents the S-Exception.ind primitive.

Detailed Description

@public
Since:
7.0 The MWspCOSessionInvoker and MWspCOSessionCallback form the API that provides the WSP Connection-Orientated Session Service Session Management, Session Resume and Exception Handling facilities, as described by the WSP Specification, July 2001.

The MWspCOSessionInvoker interface is supplied by the Provider entity. The MWspCOSessionCallback interface is supplied by the Client entity. The Provider implements the communications necessary to send the primitives issued by the Client to the Server, and from the Server to the Client.

The APIs that provide connection information, session headers and capabilities are supplied to the Provider from the Client during configuration. The Provider uses these APIs to return any Server session headers and the negotiated capabilities from the Server

The use of the Session Resume facility during the lifetime of a WSP session is dependent on this being a successfully negotiated capability for that session.

Definition at line 44 of file MWspCOSessionCallback.h.

Member Function Documentation

MWspCOSessionCallback::ConnectCnf ( ) [pure virtual]

Intended Usage : This represents the S-Connect.cnf primitive.

The Provider issues this primitive when a WSP session has been successfully established. Any Session Headers sent by the Server are passed to the Client.

Since:
7.0
Precondition:
The WSP session is in the Connecting state.
Postcondition:
The WSP session is established with the Server. The WSP session is in the Connected state.

Implemented in CWspCOProtocolHandler.

MWspCOSessionCallback::DisconnectInd | ( | TWspReason | aReason,
 |  | TBool | aRedirectSecurity,
 |  | TWspRedirectedAddress & | aRedirectAddress,
 |  | const TDesC8 & | aErrorHeaders,
 |  | const TDesC8 & | aErrorBody
 | ) | [pure virtual]

Intended Usage : This represents the S-Disconnect.ind primitive.

The Provider issues this primitive when the WSP session has been disconnected. Any incomplete method or push transactions have been aborted. If the aReasonCode indicates that the redirection is temporary, then the original address should be used in future connection attempts. If the redirection is permanent, then the Client should use the new address in all future connection attempts.

Since:
7.0
Parameters:
aReason | A parameter that indicates the cause of the disconnection. The value maps to the Reason type defined in the WSP Specification, July 2001.
aRedirectSecurity | A flag to indicate that the current secure session may be reused with the redirected server address.
aRedirectAddress | An object containing an alternative address that must be used to establish a WSP session with the same service.
aErrorHeaders | Together with aErrorBody, this provides some meaningful information as to why the session was disconnected.
aErrorBody | See explanation of aErrorHeader.
Precondition:
The WSP session is in any state other than Null.
Postcondition:
The WSP session is in the Null state.

Implemented in CWspCOProtocolHandler.

MWspCOSessionCallback::ExceptionInd ( const TDesC8 & aExceptionData ) [pure virtual]

Intended Usage : This represents the S-Exception.ind primitive.

The Provider issues this when it receives an event from the Server that is not related to a transaction nor changes the state of the WSP session.

Since:
7.0
Parameters:
aExceptionData A buffer containing the information sent by the Server.
Precondition:
The WSP session is not in the Null or Suspended state.
Postcondition:
Unspecified

Implemented in CWspCOProtocolHandler.

MWspCOSessionCallback::ResumeCnf ( ) [pure virtual]

Intended Usage : This represents the S-Resume.cnf primitive.

The Provider issues this primitive when a WSP session has been successfully resumed. This primitive can only be issued if the Session Resume facility has been successfully negotiated. Any Session Headers sent by the Server are passed to the Client.

Since:
7.0
Precondition:
The Session Resume facitlity has been successfully negotiated for this WSP session. The WSP session is in the Resuming state.
Postcondition:
The WSP session is in the Connected state.

Implemented in CWspCOProtocolHandler.

MWspCOSessionCallback::SuspendInd ( TWspReason aReason ) [pure virtual]

Intended Usage : This represents the S-Suspend.ind primitive.

The Provider issues this primitive when a WSP session has been suspended. This primitive is only issued if the Session Resume facility has been successfully negotiated.

Since:
7.0
Parameters:
aReason A parameter that indicates the cause of the suspension. The value maps to the Reason type defined in the WSP Specification, July 2001.
Precondition:
The Session Resume facitlity has been successfully negotiated for this WSP session. The WSP session is in either the Connected, Suspending or Resuming state.
Postcondition:
The WSP session is in the Suspended state.

Implemented in CWspCOProtocolHandler.

The documentation for this class was generated from the following file:
  • MWspCOSessionCallback.h


Member List

MWspCOSessionCallback Member List

This is the complete list of members for MWspCOSessionCallback, including all inherited members.
ConnectCnf()=0 | MWspCOSessionCallback | [pure virtual]
DisconnectInd(TWspReason aReason, TBool aRedirectSecurity, TWspRedirectedAddress &aRedirectAddress, const TDesC8 &aErrorHeader, const TDesC8 &aErrorBody)=0 | MWspCOSessionCallback | [pure virtual]
ExceptionInd(const TDesC8 &aExceptionData)=0 | MWspCOSessionCallback | [pure virtual]
ResumeCnf()=0 | MWspCOSessionCallback | [pure virtual]
SuspendInd(TWspReason aReason)=0 | MWspCOSessionCallback | [pure virtual]


MWspCOSessionInvoker Class Reference

@public
Since:
7.0 The MWspCOSessionInvoker and MWspCOSessionCallback form the API that provides the WSP Connection-Orientated Session Service Session Management, Session Resume and Exception Handling facilities, as described by the WSP Specification, July 2001.
More...

#include <MWspCOSessionInvoker.h>

Inheritance diagram for MWspCOSessionInvoker:

[legend]
List of all members.

Public Methods

virtual void | ConnectReq ()=0
Intended Usage : This represents the S-Connect.req primitive.

virtual void | DisconnectReq (TWspReason aReason)=0
Intended Usage : This represents the S-Disconnect.req primitive.The Client requests that the WSP session be disconnected.

virtual void | SuspendReq ()=0
Intended Usage : This represents the S-Suspend.req primitive.

virtual void | ResumeReq ()=0
Intended Usage : This represents the S-Resume.req primitive.

Detailed Description

@public
Since:
7.0 The MWspCOSessionInvoker and MWspCOSessionCallback form the API that provides the WSP Connection-Orientated Session Service Session Management, Session Resume and Exception Handling facilities, as described by the WSP Specification, July 2001.

The MWspCOSessionInvoker interface is supplied by the Provider entity. The MWspCOSessionCallback interface is supplied by the Client entity. The Provider implements the communications necessary to send the primitives issued by the Client to the Server, and from the Server to the Client.

The APIs that provide connection information, session headers and capabilities are supplied to the Provider from the Client during configuration. The Provider uses these APIs to return any Server session headers and the negotiated capabilities from the Server

The use of the Session Resume facility during the lifetime of a WSP session is dependent on this being a successfully negotiated capability for that session.

Definition at line 44 of file MWspCOSessionInvoker.h.

Member Function Documentation

MWspCOSessionInvoker::ConnectReq ( ) [pure virtual]

Intended Usage : This represents the S-Connect.req primitive.

The Provider initiates WSP session establishment with the Server. The expected primitives to be issued from the Provider are S-Connect.cnf or S-Disconnect.ind.

Since:
7.0
Precondition:
The WSP Session is in the Null state.
Postcondition:
The Provider has initiated a connection with the Server (a WAP Gateway). The WSP Session is in the Connecting state.

Implemented in CNwssWspCOSession.

MWspCOSessionInvoker::DisconnectReq ( TWspReason aReasonCode ) [pure virtual]

Intended Usage : This represents the S-Disconnect.req primitive.The Client requests that the WSP session be disconnected.

The session is not disconnected until the Provider has given the indication for this primitive, S-Disconnect.ind. Before the disconnect indication, the Provider must have aborted any outstanding method and push transactions. The Client will not issue any further primitives.

Since:
7.0
Parameters:
aReasonCode A parameter that indicates the reason for the disconnection. The value maps to the 'WSP Reason' type defined in the WSP Specification, July 2001.
Precondition:
The WSP session is in any state other than Null or Closing.
Postcondition:
The Provider is disconnecting the session. The WSP session is in the Closing state.

Implemented in CNwssWspCOSession.

MWspCOSessionInvoker::ResumeReq ( ) [pure virtual]

Intended Usage : This represents the S-Resume.req primitive.

The Client requests that the WSP session be resumed. This function can only called if the Session Resume facility has been successfully negotiated for this WSP session.If the session is in the Connected state, this primitive can be used to update the Session Headers used in the WSP session.

Since:
7.0
Precondition:
The Session Resume facitlity has been successfully negotiated for this WSP session. The WSP session is in either the Connected, Suspending or Suspended state.
Postcondition:
The Provider has requested that the Server resume the WSP session. The WSP session is in the Resuming state.

Implemented in CNwssWspCOSession.

MWspCOSessionInvoker::SuspendReq ( ) [pure virtual]

Intended Usage : This represents the S-Suspend.req primitive.

The Client requests that the WSP session be suspended. This function can only called if the Session Resume facility has been successfully negotiated for this WSP session. The session is not suspended until the Provider has given the indication to this primitive, S-Suspend.ind. Before the suspend indication, the Provider must have aborted any outstanding method and push transactions. The Client will only issue the S-Resume.req and S-Disconnect.req primitives.

Since:
7.0
Precondition:
The Session Resume facitlity has been successfully negotiated for this WSP session. The WSP session is either in the Connected or Resuming state.
Postcondition:
The Provider has requested that the server suspend the WSP session. The WSP session is in the Suspending state.

Implemented in CNwssWspCOSession.

The documentation for this class was generated from the following file:
  • MWspCOSessionInvoker.h


Member List

MWspCOSessionInvoker Member List

This is the complete list of members for MWspCOSessionInvoker, including all inherited members.
ConnectReq()=0 | MWspCOSessionInvoker | [pure virtual]
DisconnectReq(TWspReason aReason)=0 | MWspCOSessionInvoker | [pure virtual]
ResumeReq()=0 | MWspCOSessionInvoker | [pure virtual]
SuspendReq()=0 | MWspCOSessionInvoker | [pure virtual]


CWspCOTransaction Class Reference

#include <CWspCOTransaction.h>

Inheritance diagram for CWspCOTransaction:

[legend]
Collaboration diagram for CWspCOTransaction:

[legend]
List of all members.

Public Methods

~CWspCOTransaction ()
Intended Usage : Standard destructor.

void | InitRequestL ()
Since:
7.0

void | NotifyMoreRequestData ()
Since:
7.0

void | AbortRequest ()
Since:
7.0

void | Suicide ()
Intended Usage : The client has closed the RHTTPTransaction that this object wraps.

CWspHeaderUtils & | GetWspHeaderUtils () const
Intended Usage : This method provides access to the WSP header utilities.

Static Public Methods

CWspCOTransaction * | NewL (RHTTPTransaction aTransaction, MWspCOMethodInvoker &aMethodInvoker, MWspCapabilityViewer &aNegotiatedCapInfo, MWspCOMethodObserver &aObserver, CWspHeaderUtils &aHdrUtils)

Private Methods

virtual void | CreateTxDataL ()
virtual void | CreateRxDataL (MRxDataObserver &aObserver)
virtual void | MethodInvokeCnf ()
virtual void | MethodInvokeDataCnf ()
virtual void | MethodAbortInd (TWspReason aReason)
Intended Usage : This represents the S-MethodAbort.ind primitive.

virtual void | MethodResultInd (TInt aStatus, const TDesC8 &aResponseHeaders, MHTTPDataSupplier &aResponseBody, TBool aMoreData)
virtual void | MethodResultDataInd (const TDesC8 &aTrailerHeaders, TBool aMoreData)
virtual void | SendPrimitiveL (TWspPrimitive aPrimitive)
virtual TInt | WspPrimitiveSenderCallbackError (TInt aError)
virtual void | AbortResponse ()
virtual void | SendResponsePrimitive ()
virtual void | SendInvokePrimitive ()
Informs the Tx Data object observer that it should send a S-MethodInvoke or S-MethodInvokeData primitive.

virtual void | AbortInvoke ()
Informs the Tx Data object observer that the method should be aborted.

CWspCOTransaction (RHTTPTransaction aTransaction, MWspCOMethodInvoker &aMethodInvoker, MWspCapabilityViewer &aNegotiatedCapInfo, MWspCOMethodObserver &aObserver, CWspHeaderUtils &aHdrUtils)
void | ConstructL ()
Intended Usage : Second phase constructor.

void | MethodInvoke ()
Intended Usage : Invokes the method.

void | MethodInvokeData ()
Intended Usage :
Since:
7.0.

void | MethodAbort ()
Intended Usage :
Since:
7.0.

void | MethodResultRes ()
Intended Usage :
Since:
7.0.

void | MethodResultDataRes ()
Intended Usage :
Since:
7.0.

void | ProcessResponseDataL (const TDesC8 &aResponseHeaders, MHTTPDataSupplier &aResponseBody, TBool aMoreData)
Since:
7.0

void | PostResProcessing ()
Does the necessary processing given that either a S-MethodResult.res or a S-MethodResultData.res primitive has just been sent.

void | ResetFlags ()
Intended Usage : Resets all the flags in the object.

Private Attributes

__DECLARE_LOG MWspCOMethodInvoker & | iMethodInvoker
A reference to the CO Transaction Invoker object.

MWspCapabilityViewer & iNegotiatedCapInfo
An object that holds the negotiated capabilties for the current Wsp session.

MWspCOMethodObserver & iObserver
A reference to the method observer.

CWspHeaderUtils & iHdrUtils
A reference to the WSP header utilities.

TWspMethodState | iMethodState
The state of the WSP method transaction.

TBool | iMoreRequestData
A flag to indicate whether there is more data to send in subsequent S-MethodInvokeData primitives.

TBool | iSentMethodResultRes
A flag to incidcate whether the S-MethodResult.res primitive has been sent.

TBool | iClientMethodAbort
A flag to indicate whether the client aborted the method.

TBool | iFinalResPending
A flag that inducates whether the final S-MethodResult.res or S-MethodResultData.res primitive is waiting to be sent.

TBool | iSuicide
A flag to indicate that the client has closed the transaction and that once the S-MethodAbort.ind primitive is received, the object must self- destruct.

CWspPrimitiveSender * iPrimitiveSender
An active object that is used to invoke the sending of certain WSP primitives.

Detailed Description

Todo:
docing

Definition at line 34 of file CWspCOTransaction.h.

Constructor & Destructor Documentation

CWspCOTransaction::~CWspCOTransaction ( )

Intended Usage : Standard destructor.

Since:
7.0

CWspCOTransaction::CWspCOTransaction | ( | RHTTPTransaction | aTransaction,
 |  | MWspCOMethodInvoker & | aMethodInvoker,
 |  | MWspCapabilityViewer & | aNegotiatedCapInfo,
 |  | MWspCOMethodObserver & | aObserver,
 |  | CWspHeaderUtils & | aHdrUtils
 | ) | [private]

Member Function Documentation

CWspCOTransaction::AbortInvoke ( ) [private, virtual]

Informs the Tx Data object observer that the method should be aborted.

See also:
7.0

Implements MWspCOTxDataCallback.

CWspCOTransaction::AbortRequest ( )

Since:
7.0

CWspCOTransaction::AbortResponse ( ) [private, virtual]

See also:
MWspCORxDataCallback

Implements MWspCORxDataCallback.

CWspCOTransaction::ConstructL ( ) [private]

Intended Usage : Second phase constructor.

Does any necessary allocations.

Since:
7.0
Precondition:
First phase construction has been done.
Postcondition:
The object is fully initialised.

CWspCOTransaction::CreateRxDataL ( MRxDataObserver & aObserver ) [private, virtual]

See also:
CProtTransaction

Implements CProtTransaction.

CWspCOTransaction::CreateTxDataL ( ) [private, virtual]

See also:
CProtTransaction

Implements CProtTransaction.

CWspCOTransaction::GetWspHeaderUtils ( ) const

Intended Usage : This method provides access to the WSP header utilities.

Since:
7.0
Returns:
A reference to the WSP header utilities

CWspCOTransaction::InitRequestL ( )

Since:
7.0

CWspCOTransaction::MethodAbort ( ) [private]

Intended Usage :

Since:
7.0.

Todo:
finish docing
Precondition:
The WSP method transaction is not in the Null or Aborting state.
Postcondition:
The S-MethodAbort.req primitive has been sent and the WSP method transaction is in the Aborting state.

virtual void CWspCOTransaction::MethodAbortInd ( TWspReason aReason ) [private, virtual]

Intended Usage : This represents the S-MethodAbort.ind primitive.

This is issued when the method transaction has been aborted.

Since:
7.0
Parameters:
aReason A parameter that indicates the cause of the abort. The value maps to the Reason type defined in the WSP Specification, July 2001.
Precondition:
The WSP method transaction is not in the Null state.
Postcondition:
The WSP method transaction is in the Null state.

Implements MWspCOMethodCallback.

CWspCOTransaction::MethodInvoke ( ) [private]

Intended Usage : Invokes the method.

Sends the S-MethodInvoke.req primitive. Ensures that the Server SDU size and the Server message size are observed. Will leave if either of these session capabilities are exceeded.

Since:
7.0
Precondition:
The WSP method transaction is in the Null state.
Postcondition:
The S-MethodInvoke.req primitive has been sent and the WSP method transaction is in the Requesting state.

CWspCOTransaction::MethodInvokeCnf ( ) [private, virtual]

See also:
MWspCOMethodCallback

Implements MWspCOMethodCallback.

CWspCOTransaction::MethodInvokeData ( ) [private]

Intended Usage :

Since:
7.0.

Todo:
finish docing
Precondition:
The WSP method transaction is in the Requesting state.
Postcondition:
The S-MethodInvokeData.req primitive has been sent and the WSP method transaction remains in the Requesting state.

CWspCOTransaction::MethodInvokeDataCnf ( ) [private, virtual]

See also:
MWspCOMethodCallback

Implements MWspCOMethodCallback.

CWspCOTransaction::MethodResultDataInd | ( | const TDesC8 & | aTrailerHeaders,
 |  | TBool | aMoreData
 | ) | [private, virtual]

See also:
MWspCOMethodCallback

Implements MWspCOMethodCallback.

CWspCOTransaction::MethodResultDataRes ( ) [private]

Intended Usage :

Since:
7.0.

Postcondition:
The WSP method transaction is in the Waiting2 or Completing state.
Precondition:
The WSP method transaction remains in the Waiting2 state if the request response is not complete and there are subsequent S-MethodResultData primitives to be received. If the request response is complete, then the WSP method transaction is in the Null state.

CWspCOTransaction::MethodResultInd | ( | TInt | aStatus,
 |  | const TDesC8 & | aResponseHeaders,
 |  | MHTTPDataSupplier & | aResponseBody,
 |  | TBool | aMoreData
 | ) | [private, virtual]

See also:
MWspCOMethodCallback

Implements MWspCOMethodCallback.

CWspCOTransaction::MethodResultRes ( ) [private]

Intended Usage :

Since:
7.0.

Postcondition:
The WSP method transaction is in the Waiting or Completing state.
Precondition:
The WSP method transaction is in the Waiting2 state if the request response is not complete and there are subsequent S-MethodResultData primitives to be received. If the request response is complete, then the WSP method transaction is in the Null state.

CWspCOTransaction* CWspCOTransaction::NewL | ( | RHTTPTransaction | aTransaction,
 |  | MWspCOMethodInvoker & | aMethodInvoker,
 |  | MWspCapabilityViewer & | aNegotiatedCapInfo,
 |  | MWspCOMethodObserver & | aObserver,
 |  | CWspHeaderUtils & | aHdrUtils
 | ) | [static]

CWspCOTransaction::NotifyMoreRequestData ( )

Since:
7.0

void CWspCOTransaction::PostResProcessing ( ) [private]

Does the necessary processing given that either a S-MethodResult.res or a S-MethodResultData.res primitive has just been sent.

If the method state is Completing, then the method moves into the Null state, and if the self- destruction has been flagged, the object deletes itself. If the method is not in the Completing state, then it is in the Waiting2 state, and it does not change state.

Since:
7.0
Precondition:
The method is in either the Completing or the Waiting2 state.
Postcondition:
The method is in either in the Null state or has remained in the Waiting2 state.

CWspCOTransaction::ProcessResponseDataL | ( | const TDesC8 & | aResponseHeaders,
 |  | MHTTPDataSupplier & | aResponseBody,
 |  | TBool | aMoreData
 | ) | [private]

Since:
7.0

Parameters:
aResponseHeaders | A reference to a buffer that provides the encoded response headers.
aResponseBody | A reference to a data supplier object that provides the data associated with the response.
aMoreData | A flag to indicate whether subsequent S-MethodResultData primitives are to be received for this transaction.

CWspCOTransaction::ResetFlags ( ) [private]

Intended Usage : Resets all the flags in the object.

Since:
7.0
Postcondition:
All flags are set to EFalse.

CWspCOTransaction::SendInvokePrimitive ( ) [private, virtual]

Informs the Tx Data object observer that it should send a S-MethodInvoke or S-MethodInvokeData primitive.

Since:
7.0

Implements MWspCOTxDataCallback.

CWspCOTransaction::SendPrimitiveL ( TWspPrimitive aPrimitive ) [private, virtual]

See also:
MWspPrimitiveSenderCallback

Implements MWspPrimitiveSenderCallback.

CWspCOTransaction::SendResponsePrimitive ( ) [private, virtual]

See also:
MWspCORxDataCallback

Implements MWspCORxDataCallback.

CWspCOTransaction::Suicide ( )

Intended Usage : The client has closed the RHTTPTransaction that this object wraps.

The protocol base base class has also transferred ownership of this object to the sub-class, the WSP protocol handler. This function ensures cleanup of this object. If the WSP method transaction was in the Null state, then the object deletes itself. If the WSP method transaction is in the Aborting state, then the object will delete itself once it receives the S-MethodAbort.ind primitive.

Since:
7.0
Todo:
finish docing
Precondition:
The client has closed the RHTTPTransaction that this object wraps.
Postcondition:
If the WSP method transaction was in the Null state, then the object has deleted itself. If the WSP method transaction is in the Aborting state, then the object will delete itself once it receives the S-MethodAbort.ind primitive.

CWspCOTransaction::WspPrimitiveSenderCallbackError ( TInt aError ) [private, virtual]

See also:
MWspPrimitiveSenderCallback

Implements MWspPrimitiveSenderCallback.

Member Data Documentation

TBool CWspCOTransaction::iClientMethodAbort [private]

A flag to indicate whether the client aborted the method.

Definition at line 388 of file CWspCOTransaction.h.

TBool CWspCOTransaction::iFinalResPending [private]

A flag that inducates whether the final S-MethodResult.res or S-MethodResultData.res primitive is waiting to be sent.

Definition at line 393 of file CWspCOTransaction.h.

CWspHeaderUtils& CWspCOTransaction::iHdrUtils [private]

A reference to the WSP header utilities.

Definition at line 368 of file CWspCOTransaction.h.

__DECLARE_LOG MWspCOMethodInvoker& CWspCOTransaction::iMethodInvoker [private]

A reference to the CO Transaction Invoker object.

Owned by the transport handler.

Definition at line 352 of file CWspCOTransaction.h.

TWspMethodState CWspCOTransaction::iMethodState [private]

The state of the WSP method transaction.

Definition at line 373 of file CWspCOTransaction.h.

TBool CWspCOTransaction::iMoreRequestData [private]

A flag to indicate whether there is more data to send in subsequent S-MethodInvokeData primitives.

Definition at line 379 of file CWspCOTransaction.h.

MWspCapabilityViewer& CWspCOTransaction::iNegotiatedCapInfo [private]

An object that holds the negotiated capabilties for the current Wsp session.

Definition at line 358 of file CWspCOTransaction.h.

MWspCOMethodObserver& CWspCOTransaction::iObserver [private]

A reference to the method observer.

Definition at line 363 of file CWspCOTransaction.h.

CWspPrimitiveSender* CWspCOTransaction::iPrimitiveSender [private]

An active object that is used to invoke the sending of certain WSP primitives.

Definition at line 406 of file CWspCOTransaction.h.

TBool CWspCOTransaction::iSentMethodResultRes [private]

A flag to incidcate whether the S-MethodResult.res primitive has been sent.

Definition at line 383 of file CWspCOTransaction.h.

TBool CWspCOTransaction::iSuicide [private]

A flag to indicate that the client has closed the transaction and that once the S-MethodAbort.ind primitive is received, the object must self- destruct.

Definition at line 400 of file CWspCOTransaction.h.

The documentation for this class was generated from the following file:
  • CWspCOTransaction.h


Member List

CWspCOTransaction Member List

This is the complete list of members for CWspCOTransaction, including all inherited members.
AbortInvoke() | CWspCOTransaction | [private, virtual]
AbortRequest() | CWspCOTransaction |
AbortResponse() | CWspCOTransaction | [private, virtual]
ConstructL() | CWspCOTransaction | [private]
CProtTransaction() | CProtTransaction | [protected]
CProtTransaction(RHTTPTransaction aTrans) | CProtTransaction | [protected]
CreateRxDataL(MRxDataObserver &aObserver) | CWspCOTransaction | [private, virtual]
CreateTxDataL() | CWspCOTransaction | [private, virtual]
CWspCOTransaction(RHTTPTransaction aTransaction, MWspCOMethodInvoker &aMethodInvoker, MWspCapabilityViewer &aNegotiatedCapInfo, MWspCOMethodObserver &aObserver, CWspHeaderUtils &aHdrUtils) | CWspCOTransaction | [private]
EActive enum value | CProtTransaction |
ECancelled enum value | CProtTransaction |
ECompleted enum value | CProtTransaction |
EPending enum value | CProtTransaction |
GetWspHeaderUtils() const | CWspCOTransaction |
iClientMethodAbort | CWspCOTransaction | [private]
iFinalResPending | CWspCOTransaction | [private]
iHdrUtils | CWspCOTransaction | [private]
iMethodInvoker | CWspCOTransaction | [private]
iMethodState | CWspCOTransaction | [private]
iMoreRequestData | CWspCOTransaction | [private]
iNegotiatedCapInfo | CWspCOTransaction | [private]
InitRequestL() | CWspCOTransaction |
iObserver | CWspCOTransaction | [private]
iPrimitiveSender | CWspCOTransaction | [private]
iRxData | CProtTransaction | [protected]
iSentMethodResultRes | CWspCOTransaction | [private]
iSuicide | CWspCOTransaction | [private]
iTrans | CProtTransaction | [protected]
iTransactionState | CProtTransaction | [protected]
iTxData | CProtTransaction | [protected]
MethodAbort() | CWspCOTransaction | [private]
MethodAbortInd(TWspReason aReason) | CWspCOTransaction | [private, virtual]
MethodInvoke() | CWspCOTransaction | [private]
MethodInvokeCnf() | CWspCOTransaction | [private, virtual]
MethodInvokeData() | CWspCOTransaction | [private]
MethodInvokeDataCnf() | CWspCOTransaction | [private, virtual]
MethodResultDataInd(const TDesC8 &aTrailerHeaders, TBool aMoreData) | CWspCOTransaction | [private, virtual]
MethodResultDataRes() | CWspCOTransaction | [private]
MethodResultInd(TInt aStatus, const TDesC8 &aResponseHeaders, MHTTPDataSupplier &aResponseBody, TBool aMoreData) | CWspCOTransaction | [private, virtual]
MethodResultRes() | CWspCOTransaction | [private]
NewL(RHTTPTransaction aTransaction, MWspCOMethodInvoker &aMethodInvoker, MWspCapabilityViewer &aNegotiatedCapInfo, MWspCOMethodObserver &aObserver, CWspHeaderUtils &aHdrUtils) | CWspCOTransaction | [static]
NotifyMoreRequestData() | CWspCOTransaction |
PostResProcessing() | CWspCOTransaction | [private]
ProcessResponseDataL(const TDesC8 &aResponseHeaders, MHTTPDataSupplier &aResponseBody, TBool aMoreData) | CWspCOTransaction | [private]
ResetFlags() | CWspCOTransaction | [private]
ResetRxData() | CProtTransaction |
ResetTxData() | CProtTransaction |
RxData() const | CProtTransaction |
SendInvokePrimitive() | CWspCOTransaction | [private, virtual]
SendPrimitiveL(TWspPrimitive aPrimitive) | CWspCOTransaction | [private, virtual]
SendResponsePrimitive() | CWspCOTransaction | [private, virtual]
SetTransactionState(TTransactionState aState) | CProtTransaction |
Suicide() | CWspCOTransaction |
Transaction() const | CProtTransaction |
TransactionState() const | CProtTransaction |
TTransactionState enum name | CProtTransaction |
TxData() const | CProtTransaction |
WspPrimitiveSenderCallbackError(TInt aError) | CWspCOTransaction | [private, virtual]
~CProtTransaction() | CProtTransaction | [virtual]
~CWspCOTransaction() | CWspCOTransaction |


CWspCOTxData Class Reference

#include <CWspCOTxData.h>

Inheritance diagram for CWspCOTxData:

[legend]
Collaboration diagram for CWspCOTxData:

[legend]
List of all members.

Public Methods

~CWspCOTxData ()
Intended Usage : Standard destructor.

const TDesC8 & | RequestHeadersData ()
Intended Usage : Provides a buffer with the request headers.

MHTTPDataSupplier & RequestBodyData ()
Intended Usage : Provides the data supplier object for the request body data.

void | SetRequestDataL ()
Intended Usage :
Since:
7.0.

void | ReceivedCnf ()
The cnf for the current invoke primitive has been received.

void | NotifyMoreRequestData ()
Intended Usage : The client has got more request data.

Static Public Methods

CWspCOTxData * | NewL (CProtTransaction &aTransaction, MWspCOTxDataCallback &aObserver, MWspCapabilityViewer &aNegotiatedCapInfo)
Intended Usage : Static factory constructor.

Private Types

enum TRequestState {
EIdle = 0, EDone, EGotMoreData, EWaitForMoreData,
EAbortMethod
}
The TRequestState type represents the states of the request data object. More...

Private Methods

virtual TBool | GetNextDataPart (TPtrC8 &aDataPart)
virtual void | ReleaseData ()
virtual TInt | OverallDataSize ()
virtual TInt | Reset ()
CWspCOTxData (CProtTransaction &aTransaction, MWspCOTxDataCallback &aObserver, MWspCapabilityViewer &aNegotiatedCapInfo)
Intended Usage : First phase constructor.

void | SetSessionPropertyL (TInt aProperty, THTTPHdrVal aFieldValue)
Intended Usage :
Since:
7.0.

void | SetHeaderDataL (RHTTPRequest aRequest)
Intended Usage :
Since:
7.0.

void | EncodeHeadersL (RHTTPHeaders aHeaders)
Intended Usage :
Since:
7.0.

void | SetBodyDataL (MHTTPDataSupplier &aRequestBody)
Intended Usage :
Since:
7.0.

void | UpdateBodyData ()
Intended Usage :
Since:
7.0.

TInt | CalculateUIntVarLength (TUint32 aUint)
Intended Usage : A utility function to calculate how many bytes are required to represent a number in UIntVar format, as defined by the WSP Specification, July 2001.

void | UpdateState ()
Since:
7.0

void | CheckTrailer ()
Since:
7.0

void | DecideObserverAction ()
Since:
7.0

void | Cleanup ()
Since:
7.0

Private Attributes

TRequestState iState
The state of the request data.

MWspCOTxDataCallback & iObserver
A reference to Tx data callback object.

MWspCapabilityViewer & iNegotiatedCapInfo
A reference to the negotiated capability viewer.

MHTTPDataSupplier * iBodyDataSupplier
A pointer to the request body data supplier.

HBufC8 * | iHeaderData
A buffer with the encoded request header data.

HBufC8 * | iTrailerData
A buffer with the encoded request trailer header data.

HBufC8 * | iBodyData
A buffer with the current request data.

TBool | iHasTrailer
A flag indicating that there are trailer header data.

TBool | iRequestComplete
A flag that indicates whether all the request data has been received from the client.

TBool | iGotBodyData
A flag that indicates whether there is a current request body data part.

TPtrC8 | iDataPart
A descriptor pointer to a buffer containing the current request body data part.

TInt | iOverallDataSize
The overall size of the body data.

TUint32 | iRemainingSDUSpace
The remaining server SDU space for the current primitive.

TUint32 | iRemainingMessageSpace
The remaining server message space.

TBool | iSupportLDT
A flag to indicate whether LDT is supported.

TUint32 | iTrailerInfoLength
The length of the trailer header info.

TBool | iLimitedMessageSize
A flag to indicate wether the Server Message is limited.

Detailed Description

Todo:
docing

Definition at line 21 of file CWspCOTxData.h.

Member Enumeration Documentation

enum CWspCOTxData::TRequestState [private]

The TRequestState type represents the states of the request data object.

Enumeration values:
EIdle
EDone
EGotMoreData
EWaitForMoreData
EAbortMethod

Definition at line 245 of file CWspCOTxData.h.

Constructor & Destructor Documentation

CWspCOTxData::~CWspCOTxData ( )

Intended Usage : Standard destructor.

Since:
7.0

CWspCOTxData::CWspCOTxData | ( | CProtTransaction & | aTransaction,
 |  | MWspCOTxDataCallback & | aObserver,
 |  | MWspCapabilityViewer & | aNegotiatedCapInfo
 | ) | [private]

Intended Usage : First phase constructor.

Since:
7.0
Parameters:
aTransaction | The protocol transaction object associated with the Tx data object.
aObserver | A reference to the Tx observer.
aNegotiatedCapInfo | A reference to the negotiated capability viewer object.

Member Function Documentation

CWspCOTxData::CalculateUIntVarLength ( TUint32 aUint ) [private]

Intended Usage : A utility function to calculate how many bytes are required to represent a number in UIntVar format, as defined by the WSP Specification, July 2001.

Since:
7.0
Parameters:
aUint The unsigned positive number for which to calculate the length of its UIntVar representation.
Returns:
The number of bytes required to represent the input integer as a UIntVar.

CWspCOTxData::CheckTrailer ( ) [private]

Since:
7.0

CWspCOTxData::Cleanup ( ) [private]

Since:
7.0

CWspCOTxData::DecideObserverAction ( ) [private]

Since:
7.0

CWspCOTxData::EncodeHeadersL ( RHTTPHeaders aHeaders ) [private]

Intended Usage :

Since:
7.0.

Todo:
finish docing
Parameters:
aHeaders The headers object
Precondition:
Postcondition:

CWspCOTxData::GetNextDataPart ( TPtrC8 & aDataPart ) [private, virtual]

See also:
MHTTPDataSupplier

Implements MHTTPDataSupplier.

CWspCOTxData::NewL | ( | CProtTransaction & | aTransaction,
 |  | MWspCOTxDataCallback & | aObserver,
 |  | MWspCapabilityViewer & | aNegotiatedCapInfo
 | ) | [static]

Intended Usage : Static factory constructor.

Since:
7.0 @leave Leaves with KErrNoMemory if there was not enough memory to create the object.
Parameters:
aTransaction | The protocol transaction object associated with the Tx data object.
aObserver | A reference to the Tx data observer
aNegotiatedCapInfo | A reference to the negotiated capability viewer object.
Returns:
A pointer to newly created object.

CWspCOTxData::NotifyMoreRequestData ( )

Intended Usage : The client has got more request data.

Since:
7.0
Postcondition:
The fact that the client has nore request data has been flagged.

CWspCOTxData::OverallDataSize ( ) [private, virtual]

See also:
MHTTPDataSupplier

Implements MHTTPDataSupplier.

CWspCOTxData::ReceivedCnf ( )

The cnf for the current invoke primitive has been received.

If there is more data to send, then the observer is asked to send an S-MethodInvokeData primitive. If there is no more data to send and the request is not complete then wait for the client to send more data.

Since:
7.0
Precondition:
The state is either EDone or EGotMoreData.
Postcondition:
The has changed to EIdle if the originally EDone. This indicates that the request is complete. If the state was EGotMoreData then the state is EDone if the remaining data can be sent in the next SDU, EGotMoreData if the remaining data cannot be all sent in the next SDU, or EWaitForData if the request is not complete and remaining data does not fill the next SDU.

CWspCOTxData::ReleaseData ( ) [private, virtual]

See also:
MHTTPDataSupplier

Implements MHTTPDataSupplier.

CWspCOTxData::RequestBodyData ( )

Intended Usage : Provides the data supplier object for the request body data.

This data supplier supplies the more data flag via the return from GetNextDataPart().

Since:
7.0
Returns:
A reference to a MHTTPDataSupplier object that provides the request body.

CWspCOTxData::RequestHeadersData ( )

Intended Usage : Provides a buffer with the request headers.

Since:
7.0
Returns:
A const reference to a buffer that contains the request headers.

CWspCOTxData::Reset ( ) [private, virtual]

See also:
MHTTPDataSupplier

Implements MHTTPDataSupplier.

CWspCOTxData::SetBodyDataL ( MHTTPDataSupplier & aRequestBody ) [private]

Intended Usage :

Since:
7.0.

Todo:
finish docing
Parameters:
aRequestBody The data supplier for the request body data.
Precondition:
Postcondition:

CWspCOTxData::SetHeaderDataL ( RHTTPRequest aRequest ) [private]

Intended Usage :

Since:
7.0.

Todo:
finish docing
Parameters:
aRequest The request object.
Precondition:
Postcondition:

CWspCOTxData::SetRequestDataL ( )

Intended Usage :

Since:
7.0.

Todo:
finish docing

CWspCOTxData::SetSessionPropertyL | ( | TInt | aProperty,
 |  | THTTPHdrVal | aFieldValue
 | ) | [private]

Intended Usage :

Since:
7.0.

Todo:
docing
Parameters:
aProperty | An integer specifying the property to be set.
aFieldValue | The value the property is to be set to.
Postcondition:
The property has been set to the specified value/

CWspCOTxData::UpdateBodyData ( ) [private]

Intended Usage :

Since:
7.0.

Todo:
finish docing
Precondition:
Postcondition:

CWspCOTxData::UpdateState ( ) [private]

Since:
7.0

Member Data Documentation

HBufC8* CWspCOTxData::iBodyData [private]

A buffer with the current request data.

Definition at line 297 of file CWspCOTxData.h.

MHTTPDataSupplier* CWspCOTxData::iBodyDataSupplier [private]

A pointer to the request body data supplier.

Not owned.

Definition at line 283 of file CWspCOTxData.h.

TPtrC8 CWspCOTxData::iDataPart [private]

A descriptor pointer to a buffer containing the current request body data part.

Definition at line 319 of file CWspCOTxData.h.

TBool CWspCOTxData::iGotBodyData [private]

A flag that indicates whether there is a current request body data part.

Definition at line 313 of file CWspCOTxData.h.

TBool CWspCOTxData::iHasTrailer [private]

A flag indicating that there are trailer header data.

Definition at line 302 of file CWspCOTxData.h.

HBufC8* CWspCOTxData::iHeaderData [private]

A buffer with the encoded request header data.

Definition at line 288 of file CWspCOTxData.h.

TBool CWspCOTxData::iLimitedMessageSize [private]

A flag to indicate wether the Server Message is limited.

Definition at line 349 of file CWspCOTxData.h.

MWspCapabilityViewer& CWspCOTxData::iNegotiatedCapInfo [private]

A reference to the negotiated capability viewer.

Definition at line 278 of file CWspCOTxData.h.

MWspCOTxDataCallback& CWspCOTxData::iObserver [private]

A reference to Tx data callback object.

Definition at line 273 of file CWspCOTxData.h.

TInt CWspCOTxData::iOverallDataSize [private]

The overall size of the body data.

If this is not known, e.g. the resquest is divided over several primitives, then this is set to KErrNotFound.

Definition at line 326 of file CWspCOTxData.h.

TUint32 CWspCOTxData::iRemainingMessageSpace [private]

The remaining server message space.

Definition at line 336 of file CWspCOTxData.h.

TUint32 CWspCOTxData::iRemainingSDUSpace [private]

The remaining server SDU space for the current primitive.

Definition at line 331 of file CWspCOTxData.h.

TBool CWspCOTxData::iRequestComplete [private]

A flag that indicates whether all the request data has been received from the client.

Definition at line 308 of file CWspCOTxData.h.

TRequestState CWspCOTxData::iState [private]

The state of the request data.

Definition at line 268 of file CWspCOTxData.h.

TBool CWspCOTxData::iSupportLDT [private]

A flag to indicate whether LDT is supported.

Definition at line 341 of file CWspCOTxData.h.

HBufC8* CWspCOTxData::iTrailerData [private]

A buffer with the encoded request trailer header data.

Definition at line 293 of file CWspCOTxData.h.

TUint32 CWspCOTxData::iTrailerInfoLength [private]

The length of the trailer header info.

Definition at line 345 of file CWspCOTxData.h.

The documentation for this class was generated from the following file:
  • CWspCOTxData.h


Member List

CWspCOTxData Member List

This is the complete list of members for CWspCOTxData, including all inherited members.
CalculateUIntVarLength(TUint32 aUint) | CWspCOTxData | [private]
CheckTrailer() | CWspCOTxData | [private]
Cleanup() | CWspCOTxData | [private]
ConstructL() | CTxData | [protected]
CTxData() | CTxData | [protected]
CTxData(CProtTransaction &aProtTransaction) | CTxData | [protected]
CWspCOTxData(CProtTransaction &aTransaction, MWspCOTxDataCallback &aObserver, MWspCapabilityViewer &aNegotiatedCapInfo) | CWspCOTxData | [private]
DecideObserverAction() | CWspCOTxData | [private]
EAbortMethod enum value | CWspCOTxData | [private]
EDone enum value | CWspCOTxData | [private]
EGotMoreData enum value | CWspCOTxData | [private]
EIdle enum value | CWspCOTxData | [private]
EncodeHeadersL(RHTTPHeaders aHeaders) | CWspCOTxData | [private]
EWaitForMoreData enum value | CWspCOTxData | [private]
GetNextDataPart(TPtrC8 &aDataPart) | CWspCOTxData | [private, virtual]
iBodyData | CWspCOTxData | [private]
iBodyDataSupplier | CWspCOTxData | [private]
iDataPart | CWspCOTxData | [private]
iGotBodyData | CWspCOTxData | [private]
iHasTrailer | CWspCOTxData | [private]
iHeaderData | CWspCOTxData | [private]
iLimitedMessageSize | CWspCOTxData | [private]
iNegotiatedCapInfo | CWspCOTxData | [private]
iObserver | CWspCOTxData | [private]
iOverallDataSize | CWspCOTxData | [private]
iProtTrans | CTxData | [protected]
iRemainingMessageSpace | CWspCOTxData | [private]
iRemainingSDUSpace | CWspCOTxData | [private]
iRequestComplete | CWspCOTxData | [private]
iState | CWspCOTxData | [private]
iSupportLDT | CWspCOTxData | [private]
iTrailerData | CWspCOTxData | [private]
iTrailerInfoLength | CWspCOTxData | [private]
NewL(CProtTransaction &aTransaction, MWspCOTxDataCallback &aObserver, MWspCapabilityViewer &aNegotiatedCapInfo) | CWspCOTxData | [static]
NotifyMoreRequestData() | CWspCOTxData |
OverallDataSize() | CWspCOTxData | [private, virtual]
ProtTrans() | CTxData |
ReceivedCnf() | CWspCOTxData |
ReleaseData() | CWspCOTxData | [private, virtual]
RequestBodyData() | CWspCOTxData |
RequestHeadersData() | CWspCOTxData |
Reset() | CWspCOTxData | [private, virtual]
SetBodyDataL(MHTTPDataSupplier &aRequestBody) | CWspCOTxData | [private]
SetHeaderDataL(RHTTPRequest aRequest) | CWspCOTxData | [private]
SetRequestDataL() | CWspCOTxData |
SetSessionPropertyL(TInt aProperty, THTTPHdrVal aFieldValue) | CWspCOTxData | [private]
TRequestState enum name | CWspCOTxData | [private]
UpdateBodyData() | CWspCOTxData | [private]
UpdateState() | CWspCOTxData | [private]
~CTxData() | CTxData | [virtual]
~CWspCOTxData() | CWspCOTxData |


MWspCOTxDataCallback Class Reference

#include <MWspCOTxDataCallback.h>

Inheritance diagram for MWspCOTxDataCallback:

[legend]
List of all members.

Public Methods

virtual void | SendInvokePrimitive ()=0
Informs the Tx Data object observer that it should send a S-MethodInvoke or S-MethodInvokeData primitive.

virtual void | AbortInvoke ()=0
Informs the Tx Data object observer that the method should be aborted.

Member Function Documentation

MWspCOTxDataCallback::AbortInvoke ( ) [pure virtual]

Informs the Tx Data object observer that the method should be aborted.

See also:
7.0

Implemented in CWspCOTransaction.

MWspCOTxDataCallback::SendInvokePrimitive ( ) [pure virtual]

Informs the Tx Data object observer that it should send a S-MethodInvoke or S-MethodInvokeData primitive.

Since:
7.0

Implemented in CWspCOTransaction.

The documentation for this class was generated from the following file:
  • MWspCOTxDataCallback.h


Member List

MWspCOTxDataCallback Member List

This is the complete list of members for MWspCOTxDataCallback, including all inherited members.
AbortInvoke()=0 | MWspCOTxDataCallback | [pure virtual]
SendInvokePrimitive()=0 | MWspCOTxDataCallback | [pure virtual]


CWspDefaultHdrReader Class Reference

@dependancies CHeaderCodec, CHeaderReader, CHeaderFieldPart, RStringPool, RStringF
Since:
7.0 This class is the by the WSP header codec to provide the decoding functionality required by WSP to decode header fields from a raw binary format to a useful parsed format.
More...

#include <CWspHeaderReader.h>

Inheritance diagram for CWspDefaultHdrReader:

[legend]
Collaboration diagram for CWspDefaultHdrReader:

[legend]
List of all members.

Public Methods

virtual | ~CWspDefaultHdrReader ()
Intended Usage: Standard virtual destructor.

virtual void | DecodeHeaderL (RHeaderField &aHeader)
Intended Usage: This method is used by the codec to decode any header field that is passed in.

Static Public Methods

CWspDefaultHdrReader * | NewL (RStringPool aStrPool)
Intended Usage: Standard factory 2 phase construction.

CWspDefaultHdrReader * | NewLC (RStringPool aStrPool)
Intended Usage: Standard factory 2 phase construction leaving a handle on the cleanup stack.

Protected Methods

CWspDefaultHdrReader (RStringPool aStrPool)
Intended Usage: Standard default constructor.

Private Attributes

RStringPool | iStrPool
Handle to an opened string pool.

Detailed Description

@dependancies CHeaderCodec, CHeaderReader, CHeaderFieldPart, RStringPool, RStringF
Since:
7.0 This class is the by the WSP header codec to provide the decoding functionality required by WSP to decode header fields from a raw binary format to a useful parsed format.

For internal use only.

This decoder is the default decoder for headers that have no specific decoding pattern and expects text-string format data as defined WSP specifications avaialable from www.wapforum.org.

Definition at line 405 of file CWspHeaderReader.h.

Constructor & Destructor Documentation

CWspDefaultHdrReader::~CWspDefaultHdrReader ( ) [virtual]

Intended Usage: Standard virtual destructor.

Since:
7.0
Precondition:
Object is constructed
Postcondition:
Object is destroyed @cat Construction and Destruction

CWspDefaultHdrReader::CWspDefaultHdrReader ( RStringPool aStrPool ) [protected]

Intended Usage: Standard default constructor.

Error Condition: Low memory conditions

Since:
7.0
Parameters:
aStrPool A handle to an opened string pool
Precondition:
None
Postcondition:
Object is constructed @cat Construction and Destruction

Member Function Documentation

CWspDefaultHdrReader::DecodeHeaderL ( RHeaderField & aHeader ) [virtual]

Intended Usage: This method is used by the codec to decode any header field that is passed in.

Assumes the header field value is a text-string. Error Condition: Low memory conditions or invalid or corrupt data

Since:
7.0
Parameters:
aHeader A reference to the header field to decode
Precondition:
The header field is its raw format state
Postcondition:
The header field is decoded and in its parsed state
Exceptions:
KErrNoMemory KErrNotSupported if the header field is not supported KErrCorrupt if the data is invalid or corrupt

Implements CHeaderReader.

CWspDefaultHdrReader * CWspDefaultHdrReader::NewL ( RStringPool aStr ) [static]

Intended Usage: Standard factory 2 phase construction.

Error Condition: Low memory conditions

Since:
7.0
Parameters:
aStrPool A handle to an opened string pool
Returns:
A pointer to the newly created object
Precondition:
None
Postcondition:
Object is fully constructed
Exceptions:
KErrNoMemory @cat Construction and Destruction

CWspDefaultHdrReader * CWspDefaultHdrReader::NewLC ( RStringPool aStr ) [static]

Intended Usage: Standard factory 2 phase construction leaving a handle on the cleanup stack.

Error Condition: Low memory conditions

Since:
7.0
Parameters:
aStrPool A handle to an opened string pool
Returns:
A pointer to the newly created object
Precondition:
None
Postcondition:
Object is fully constructed with a handle on the cleanup stack
Exceptions:
KErrNoMemory @cat Construction and Destruction

Member Data Documentation

RStringPool CWspDefaultHdrReader::iStrPool [private]

Handle to an opened string pool.

Definition at line 481 of file CWspHeaderReader.h.

The documentation for this class was generated from the following file:
  • CWspHeaderReader.h


Member List

CWspDefaultHdrReader Member List

This is the complete list of members for CWspDefaultHdrReader, including all inherited members.
CHeaderReader() | CHeaderReader | [protected]
ConstructL() | CHeaderReader | [protected]
CWspDefaultHdrReader(RStringPool aStrPool) | CWspDefaultHdrReader | [protected]
DecodeHeaderL(RHeaderField &aHeader) | CWspDefaultHdrReader | [virtual]
iStrPool | CWspDefaultHdrReader | [private]
NewL(RStringPool aStrPool) | CWspDefaultHdrReader | [static]
NewLC(RStringPool aStrPool) | CWspDefaultHdrReader | [static]
~CHeaderReader() | CHeaderReader | [virtual]
~CWspDefaultHdrReader() | CWspDefaultHdrReader | [virtual]


CWspDefaultHdrWriter Class Reference

@public @dependancies CHeaderWriter, CWspHeaderCodec, RStringPool, RHeaderField
Since:
7.0 This class provides the encoding functionality for headers that are supported by the WSP Header Codec.
More...

#include <CWspHeaderWriter.h>

Inheritance diagram for CWspDefaultHdrWriter:

[legend]
Collaboration diagram for CWspDefaultHdrWriter:

[legend]
List of all members.

Public Methods

virtual | ~CWspDefaultHdrWriter ()
Intended Usage: Standard virtual destructor
Since:
7.0.

virtual void | EncodeHeaderL (RHeaderField &aHeader)
Intended Usage: This method will encode the header field that is passed in into its raw form.

Static Public Methods

CWspDefaultHdrWriter * | NewL (RStringPool aStrPool)
Intended Usage: Standard factory 2 phase construction Error Condition: Low memory conditions
Since:
7.0.

CWspDefaultHdrWriter * | NewLC (RStringPool aStrPool)
Intended Usage: Standard factory 2 phase construction leaving a handle on the cleanup stack.

Protected Methods

CWspDefaultHdrWriter (RStringPool aStrPool)
Intended Usage: Standard default constructor.

Private Attributes

RStringPool | iStrPool

Detailed Description

@public @dependancies CHeaderWriter, CWspHeaderCodec, RStringPool, RHeaderField
Since:
7.0 This class provides the encoding functionality for headers that are supported by the WSP Header Codec.

This encoder provides default functionality and encodes the header field as a text-string as defined in the WSP specifications at www.wapforum.org.

Definition at line 388 of file CWspHeaderWriter.h.

Constructor & Destructor Documentation

CWspDefaultHdrWriter::~CWspDefaultHdrWriter ( ) [virtual]

Intended Usage: Standard virtual destructor

Since:
7.0.

Precondition:
Fully constructed object
Postcondition:
Object is destroyed @cat Construction and Destruction

CWspDefaultHdrWriter::CWspDefaultHdrWriter ( RStringPool aStrPool ) [protected]

Intended Usage: Standard default constructor.

Since:
7.0
Parameters:
aStrPool Handle to an opened string pool with the WSP string table already opened
Precondition:
None
Postcondition:
Object is constructed

Member Function Documentation

CWspDefaultHdrWriter::EncodeHeaderL ( RHeaderField & aHeader ) [virtual]

Intended Usage: This method will encode the header field that is passed in into its raw form.

Error Condition: Invalid or corrupt data formats and out of memeory conditions

Since:
7.0
Parameters:
aHeader The header field to encode
Precondition:
The header field is in its parsed state
Postcondition:
The header field is in its raw format state
Exceptions:
KErrNotSupported If the header field is not supported KErrNoMemory Out of memory conditions KErrCorrupt If the data is invalid or is corrupt

Implements CHeaderWriter.

CWspDefaultHdrWriter * CWspDefaultHdrWriter::NewL ( RStringPool aStrPool ) [static]

Intended Usage: Standard factory 2 phase construction Error Condition: Low memory conditions

Since:
7.0.

Parameters:
aStrPool Handle to an opened string pool with the WSP string table already opened
Returns:
A pointer to the newly constructed class
Precondition:
None
Postcondition:
Object is constructed @cat Construction and Destruction

CWspDefaultHdrWriter * CWspDefaultHdrWriter::NewLC ( RStringPool aStrPool ) [static]

Intended Usage: Standard factory 2 phase construction leaving a handle on the cleanup stack.

Error Condition: Low memory conditions

Since:
7.0
Parameters:
aStrPool Handle to an opened string pool with the WSP string table already opened
Returns:
A pointer to the newly constructed class
Precondition:
None
Postcondition:
Object is constructed with a handle on the cleanup stack @cat Construction and Destruction

Member Data Documentation

RStringPool CWspDefaultHdrWriter::iStrPool [private]

Definition at line 457 of file CWspHeaderWriter.h.

The documentation for this class was generated from the following file:
  • CWspHeaderWriter.h


Member List

CWspDefaultHdrWriter Member List

This is the complete list of members for CWspDefaultHdrWriter, including all inherited members.
CHeaderWriter() | CHeaderWriter | [protected]
ConstructL() | CHeaderWriter | [protected]
CWspDefaultHdrWriter(RStringPool aStrPool) | CWspDefaultHdrWriter | [protected]
EncodeHeaderL(RHeaderField &aHeader) | CWspDefaultHdrWriter | [virtual]
iStrPool | CWspDefaultHdrWriter | [private]
NewL(RStringPool aStrPool) | CWspDefaultHdrWriter | [static]
NewLC(RStringPool aStrPool) | CWspDefaultHdrWriter | [static]
~CHeaderWriter() | CHeaderWriter | [virtual]
~CWspDefaultHdrWriter() | CWspDefaultHdrWriter | [virtual]


CWspDefaultHeaderCodec Class Reference

@dependancies CHeaderCodec, RStringPool, RStringF
Since:
7.0 This class is the default WSP Header Codec that is used if no codec can encode/ decode a particular header.
More...

#include <CWspHeaderCodec.h>

Inheritance diagram for CWspDefaultHeaderCodec:

[legend]
Collaboration diagram for CWspDefaultHeaderCodec:

[legend]
List of all members.

Public Methods

virtual | ~CWspDefaultHeaderCodec ()
Intended Usage: Standard virtual destructor
Since:
7.0.

virtual TBool | CanEncode (RStringF aHeaderField) const
Intended Usage: This method returns whether the header field passed in can be encoded or not.

virtual TBool | CanDecode (RStringF aHeaderField) const
Intended Usage: This method returns whether the header field passed in can be decoded or not.

virtual CHeaderCodec * | FindDelegateCodecL (RStringF aHeaderField) const
Intended Usage: Find a delegate codec...

Static Public Methods

CWspDefaultHeaderCodec * | NewL (RStringPool aStrPool)
Intended Usage: Standard factory 2 phase construction.

Protected Methods

CWspDefaultHeaderCodec (RStringPool aStrPool)
Intended Usage: Standard constructor
Since:
7.0.

void | ConstructL ()
Intended Usage: Standard 2nd phase construction.

Private Methods

CWspDefaultHeaderCodec ()
Intended Usage: Standard default private constructor
Since:
7.0.

Private Attributes

RStringPool | iStrPool
Handle to an opened string pool.

Detailed Description

@dependancies CHeaderCodec, RStringPool, RStringF
Since:
7.0 This class is the default WSP Header Codec that is used if no codec can encode/ decode a particular header.

For internal use only.

This codec will encode/decode headers with the default behaviour of treating the data as a text-string as defined in the WSP specifications at www.wapforum.org.

Definition at line 210 of file CWspHeaderCodec.h.

Constructor & Destructor Documentation

CWspDefaultHeaderCodec::~CWspDefaultHeaderCodec ( ) [virtual]

Intended Usage: Standard virtual destructor

Since:
7.0.

Postcondition:
Object has been fully destroyed @cat Construction and Destruction

CWspDefaultHeaderCodec::CWspDefaultHeaderCodec ( RStringPool aStrPool ) [protected]

Intended Usage: Standard constructor

Since:
7.0.

Parameters:
aStrPool A handle to an opened string pool with the string table that contains the header field names already open
Precondition:
None
Postcondition:
Object is constructed @cat Construction and Destruction

CWspDefaultHeaderCodec::CWspDefaultHeaderCodec ( ) [private]

Intended Usage: Standard default private constructor

Since:
7.0.

Precondition:
None
Postcondition:
Object is constructed @cat Construction and Destruction

Member Function Documentation

CWspDefaultHeaderCodec::CanDecode ( RStringF aHeaderField ) const [virtual]

Intended Usage: This method returns whether the header field passed in can be decoded or not.

Always returns true because it will handle anything by design!

Since:
7.0
Parameters:
aHeaderField The header field to enquire about
Returns:
ETrue if the header can be decoded otherwise EFalse. In this case ETrue is always returned

Implements CHeaderCodec.

CWspDefaultHeaderCodec::CanEncode ( RStringF aHeaderField ) const [virtual]

Intended Usage: This method returns whether the header field passed in can be encoded or not.

Always returns true because it will handle anything by design!

Since:
7.0
Parameters:
aHeaderField The header field to enquire about
Returns:
ETrue if the header can be encoded otherwise EFalse. In this case ETrue is always returned

Implements CHeaderCodec.

CWspDefaultHeaderCodec::ConstructL ( ) [protected]

Intended Usage: Standard 2nd phase construction.

Exceptions:
KErrNoMemory
Since:
7.0
Precondition:
Object is constructed
Postcondition:
Object is initialized and all the required string tables have been opened in the string pool @cat Construction and Destruction

Reimplemented from CHeaderCodec.

CWspDefaultHeaderCodec::FindDelegateCodecL ( RStringF aHeaderField ) const [virtual]

Intended Usage: Find a delegate codec...

always returns NULL, since this codec handles anything by design.

Since:
7.0
Parameters:
aHeaderField The header field name string
Returns:
A pointer to the newly created codec if one is found, otherwise NULL is returned if a codec cannot be found. The caller takes ownership of the returned codec. In this case NULL is always returned

Implements CHeaderCodec.

CWspDefaultHeaderCodec::NewL ( RStringPool aStrPool ) [static]

Intended Usage: Standard factory 2 phase construction.

Exceptions:
KErrNoMemory
Since:
7.0
Parameters:
aStrPool A handle to an open string pool with the string table that contains the header field names already open
Returns:
A pointer to the newly created object
Precondition:
None
Postcondition:
Fully constructed and initialized object @cat Construction and Destruction

Member Data Documentation

RStringPool CWspDefaultHeaderCodec::iStrPool [private]

Handle to an opened string pool.

Definition at line 315 of file CWspHeaderCodec.h.

The documentation for this class was generated from the following file:
  • CWspHeaderCodec.h


Member List

CWspDefaultHeaderCodec Member List

This is the complete list of members for CWspDefaultHeaderCodec, including all inherited members.
CanDecode(RStringF aHeaderField) const | CWspDefaultHeaderCodec | [virtual]
CanEncode(RStringF aHeaderField) const | CWspDefaultHeaderCodec | [virtual]
CHeaderCodec() | CHeaderCodec | [protected]
ConstructL() | CWspDefaultHeaderCodec | [protected]
CWspDefaultHeaderCodec(RStringPool aStrPool) | CWspDefaultHeaderCodec | [protected]
CWspDefaultHeaderCodec() | CWspDefaultHeaderCodec | [private]
DecodeHeaderL(RHeaderField &aHeader) const | CHeaderCodec |
EncodeHeaderL(RHeaderField &aHeader) const | CHeaderCodec |
FindDelegateCodecL(RStringF aHeaderField) const | CWspDefaultHeaderCodec | [virtual]
iReader | CHeaderCodec | [protected]
iStrPool | CWspDefaultHeaderCodec | [private]
iWriter | CHeaderCodec | [protected]
NewL(RStringPool aStrPool) | CWspDefaultHeaderCodec | [static]
~CHeaderCodec() | CHeaderCodec | [virtual]
~CWspDefaultHeaderCodec() | CWspDefaultHeaderCodec | [virtual]


CWspExtendedMethods Class Reference

The CWspExtendedMethods class represents a set of Extended Methods capabilities. More...

#include <CWspExtendedMethods.h>

Inheritance diagram for CWspExtendedMethods:

[legend]
Collaboration diagram for CWspExtendedMethods:

[legend]
List of all members.

Public Methods

~CWspExtendedMethods ()
Standard destructor.

virtual TInt | Start () const
virtual TInt | GetNext (TUint8 &aPDUType, TPtrC8 &aMethodName) const
virtual void | Reset ()
virtual void | AddExtendedMethodL (TUint8 aPDUType, const TDesC8 &aMethodName)

Static Public Methods

CWspExtendedMethods * | NewL ()
Static factory constructor.

Private Methods

CWspExtendedMethods ()
First phase constructor.

Private Attributes

RPointerArray< CExtendedMethod > | iMethods
An array of extended methods.

TInt | iIndex
An index with the current position in the array.

Detailed Description

The CWspExtendedMethods class represents a set of Extended Methods capabilities.

It implements the MWspExtendedMethods interface.

See also:
MWspExtendedMethods

Definition at line 19 of file CWspExtendedMethods.h.

Constructor & Destructor Documentation

CWspExtendedMethods::~CWspExtendedMethods ( )

Standard destructor.

Since:
7.0

CWspExtendedMethods::CWspExtendedMethods ( ) [private]

First phase constructor.

Since:
7.0

Member Function Documentation

CWspExtendedMethods::AddExtendedMethodL | ( | TUint8 | aPDUType,
 |  | const TDesC8 & | aMethodName
 | ) | [virtual]

See also:
MWspExtendedMethods

Implements MWspExtendedMethods.

CWspExtendedMethods::GetNext | ( | TUint8 & | aPDUType,
 |  | TPtrC8 & | aMethodName
 | ) | const [virtual]

See also:
MWspExtendedMethods

Implements MWspExtendedMethods.

CWspExtendedMethods::NewL ( ) [static]

Static factory constructor.

Since:
7.0

CWspExtendedMethods::Reset ( ) [virtual]

See also:
MWspExtendedMethods

Implements MWspExtendedMethods.

CWspExtendedMethods::Start ( ) const [virtual]

See also:
MWspExtendedMethods

Implements MWspExtendedMethods.

Member Data Documentation

TInt CWspExtendedMethods::iIndex [private]

An index with the current position in the array.

Is mutable to maintain logical const-ness.

Definition at line 83 of file CWspExtendedMethods.h.

RPointerArray<CExtendedMethod> CWspExtendedMethods::iMethods [private]

An array of extended methods.

Definition at line 77 of file CWspExtendedMethods.h.

The documentation for this class was generated from the following file:
  • CWspExtendedMethods.h


Member List

CWspExtendedMethods Member List

This is the complete list of members for CWspExtendedMethods, including all inherited members.
AddExtendedMethodL(TUint8 aPDUType, const TDesC8 &aMethodName) | CWspExtendedMethods | [virtual]
CWspExtendedMethods() | CWspExtendedMethods | [private]
GetNext(TUint8 &aPDUType, TPtrC8 &aMethodName) const | CWspExtendedMethods | [virtual]
iIndex | CWspExtendedMethods | [private]
iMethods | CWspExtendedMethods | [private]
NewL() | CWspExtendedMethods | [static]
Reset() | CWspExtendedMethods | [virtual]
Start() const | CWspExtendedMethods | [virtual]
~CWspExtendedMethods() | CWspExtendedMethods |


MWspExtendedMethods Class Reference

@public
Since:
7.0 The MWspExtendedMethods API provides an interface to a set of extended methods as defined by the WSP Specification, July 2001.
More...

#include <MWspExtendedMethods.h>

Inheritance diagram for MWspExtendedMethods:

[legend]
List of all members.

Public Methods

virtual TInt | Start () const=0
Intended Usage : Ensures that the first extended method in the set is available for reading.

virtual TInt | GetNext (TUint8 &aPDUType, TPtrC8 &aMethodName) const=0
Intended Usage : Gets the next extended method in the set.

virtual void | Reset ()=0
Intended Usage : Resets the capability to the default.

virtual void | AddExtendedMethodL (TUint8 aPDUType, const TDesC8 &aMethodName)=0
Intended Usage : Adds an extended method to the set.

Detailed Description

@public
Since:
7.0 The MWspExtendedMethods API provides an interface to a set of extended methods as defined by the WSP Specification, July 2001.

This capability gives a set of methods, beyond those defined in HTTP/1.1 to be used in the WSP Session. Each method has a PDU type, which is assigned by the Client, and a PDU name. The WSP Specification, July 2001, specifies for the PDU type that the range 0x50-0x5F indicates a method that use a Get PDU format, and the range 0x70-7F indicates a method that use a Post PDU format.

The interface allows the set of methods to be accessed one by one. The read function provides the caller with a copy of the extend method information. The set can be reset to the default value of the capability (as defined by the WSP Specification), which is an empty set. An extended method can be added to the set, the preferred addresses should be added first.

Definition at line 37 of file MWspExtendedMethods.h.

Member Function Documentation

MWspExtendedMethods::AddExtendedMethodL | ( | TUint8 | aPDUType,
 |  | const TDesC8 & | aMethodName
 | ) | [pure virtual]

Intended Usage : Adds an extended method to the set.

Since:
7.0 @leave Leave code KErrNoMemory if the method cannot be added to the set.
Parameters:
aPDUType | A byte indicating the type of the PDU. The WSP Specification, July 2001, specifies that the range 0x50-0x5F is for methods that use a Get PDU format, and the range 0x70-7F is for methods that use a Post PDU format.
aMethodName | A buffer with the name of the method.
Postcondition:
If no error has occurred then the extended method has been added.

Implemented in CWspExtendedMethods.

MWspExtendedMethods::GetNext | ( | TUint8 & | aPDUType,
 |  | TPtrC8 & | aMethodName
 | ) | const [pure virtual]

Intended Usage : Gets the next extended method in the set.

If there are no methods left then KErrNotFound error code is returned.

Since:
7.0
Parameters:
aPDUType | An output parameter reference for a byte indicating the type of the PDU. The WSP Specification, July 2001, specifies that the range 0x50-0x5F is for methods that use a Get PDU format, and the range 0x70-7F is for methods that use a Post PDU format.
aMethodName | An output reference for a buffer with the name of the method.
Returns:
An error code. If there are no extended methods left, then the value returned is KErrNotFound. If there are extended methods left then the value KErrNone is returned.
Postcondition:
The next extended method in the set is available for reading.

Implemented in CWspExtendedMethods.

MWspExtendedMethods::Reset ( ) [pure virtual]

Intended Usage : Resets the capability to the default.

The default is defined in the WSP Specification, July 2001, as being an empty set of extended methods.

Since:
7.0
Postcondition:
The set of extended methods is empty.

Implemented in CWspExtendedMethods.

MWspExtendedMethods::Start ( ) const [pure virtual]

Intended Usage : Ensures that the first extended method in the set is available for reading.

Since:
7.0
Returns:
An error code. If there are no extended methods, then the value returned is KErrNotFound. If there are extended methods then the value KErrNone is returned.
Postcondition:
The subsequent call to GetNext() is applied to the first extended method in the set.

Implemented in CWspExtendedMethods.

The documentation for this class was generated from the following file:
  • MWspExtendedMethods.h


Member List

MWspExtendedMethods Member List

This is the complete list of members for MWspExtendedMethods, including all inherited members.
AddExtendedMethodL(TUint8 aPDUType, const TDesC8 &aMethodName)=0 | MWspExtendedMethods | [pure virtual]
GetNext(TUint8 &aPDUType, TPtrC8 &aMethodName) const=0 | MWspExtendedMethods | [pure virtual]
Reset()=0 | MWspExtendedMethods | [pure virtual]
Start() const=0 | MWspExtendedMethods | [pure virtual]


CWspHeaderCodec Class Reference

@dependancies CHeaderCodec, RStringPool, RStringF
Since:
7.0 This class is the WSP specific header codec that is required to encode and decode WSP headers between a usable form and the form required for transport.
More...

#include <CWspHeaderCodec.h>

Inheritance diagram for CWspHeaderCodec:

[legend]
Collaboration diagram for CWspHeaderCodec:

[legend]
List of all members.

Public Types

enum | TWspVersion { EVersion1_1, EVersion1_2, EVersion1_3, EVersion1_4 }
Enumeration defining the different WSP encoding versions that are supported
Since:
7.0 @cat Enumerations.
 More...

Public Methods

virtual | ~CWspHeaderCodec ()
Intended Usage: Standard virtual destructor
Since:
7.0.

virtual TBool | CanEncode (RStringF aHeaderField) const
Intended Usage: This method returns whether the header field passed in can be encoded or not.

virtual TBool | CanDecode (RStringF aHeaderField) const
Intended Usage: This method returns whether the header field passed in can be decoded or not.

virtual CHeaderCodec * | FindDelegateCodecL (RStringF aHeaderField) const
Intended Usage: This method should be used to find an alternative codec for the header field name if this codec cannot handle the header field.

TWspVersion | GetWspVersion () const
Intended Usage: This method gets the current encoding version that is being used.

void | SetWspVersion (TWspVersion aWspVersion)
Intended Usage: This method sets the encoding version to use.

TInt | EncodeFieldName (RStringF aFieldName) const
Intended Usage: This method encodes a header field name to its correct encoded token value.

Static Public Methods

CWspHeaderCodec * | NewL (RStringPool aStrPool, const TStringTable &aStrTable)
Intended Usage: Standard factory 2 phase construction.

Protected Methods

CWspHeaderCodec (RStringPool aStrPool, const TStringTable &aStrTable)
Intended Usage: Standard constructor
Since:
7.0.

void | ConstructL ()
Intended Usage: Standard 2nd phase construction.

Private Methods

CWspHeaderCodec ()
Intended Usage: Standard default private constructor
Since:
7.0.

Private Attributes

RStringPool | iStrPool
Handle to an opened string pool with the header field names table open.

const TStringTable & | iStrTable
The string table that contains the header field names.

TWspVersion iWspVersion
The current encoding version that is to be used, defaults to 1.2.

Detailed Description

@dependancies CHeaderCodec, RStringPool, RStringF
Since:
7.0 This class is the WSP specific header codec that is required to encode and decode WSP headers between a usable form and the form required for transport.

For internal use only.

The codec derives from CHeaderCodec interface and provided the WSP specific encoding and decoding of header fields following the specifications stated in the WSP specs available from http://www.wapforum.org and the RFC2616.

Definition at line 28 of file CWspHeaderCodec.h.

Member Enumeration Documentation

enum CWspHeaderCodec::TWspVersion

Enumeration defining the different WSP encoding versions that are supported

Since:
7.0 @cat Enumerations.

Enumeration values:
EVersion1_1
EVersion1_2
EVersion1_3
EVersion1_4

Definition at line 36 of file CWspHeaderCodec.h.

Constructor & Destructor Documentation

CWspHeaderCodec::~CWspHeaderCodec ( ) [virtual]

Intended Usage: Standard virtual destructor

Since:
7.0.

Postcondition:
Object has been fully destroyed @cat Construction and Destruction

CWspHeaderCodec::CWspHeaderCodec | ( | RStringPool | aStrPool,
 |  | const TStringTable & | aStrTable
 | ) | [protected]

Intended Usage: Standard constructor

Since:
7.0.

Parameters:
aStrPool | A handle to an opened string pool with the string table that contains the header field names already open
aStrTable | The string table that contains the header field names
Precondition:
None
Postcondition:
Object is constructed @cat Construction and Destruction

CWspHeaderCodec::CWspHeaderCodec ( ) [private]

Intended Usage: Standard default private constructor

Since:
7.0.

Precondition:
None
Postcondition:
Object is constructed @cat Construction and Destruction

Member Function Documentation

CWspHeaderCodec::CanDecode ( RStringF aHeaderField ) const [virtual]

Intended Usage: This method returns whether the header field passed in can be decoded or not.

Since:
7.0
Parameters:
aHeaderField The header field to enquire about
Returns:
ETrue if the header can be decoded otherwise EFalse

Implements CHeaderCodec.

CWspHeaderCodec::CanEncode ( RStringF aHeaderField ) const [virtual]

Intended Usage: This method returns whether the header field passed in can be encoded or not.

Since:
7.0
Parameters:
aHeaderField The header field to enquire about
Returns:
ETrue if the header can be encoded otherwise EFalse

Implements CHeaderCodec.

CWspHeaderCodec::ConstructL ( ) [protected]

Intended Usage: Standard 2nd phase construction.

Exceptions:
KErrNoMemory
Since:
7.0
Precondition:
Object is constructed
Postcondition:
Object is initialized and all the required string tables have been opened in the string pool @cat Construction and Destruction

Reimplemented from CHeaderCodec.

CWspHeaderCodec::EncodeFieldName ( RStringF aFieldName ) const

Intended Usage: This method encodes a header field name to its correct encoded token value.

For WSP the returned value must be then be encoded to a short integer by flipping the first bit to a 1, this is NOT done in this method.

Since:
7.0
Parameters:
aFieldName The header field name string
Returns:
The encoded token value of the header field name. KErrNotFound if no encoding value could be found for the header field name

CWspHeaderCodec::FindDelegateCodecL ( RStringF aHeaderField ) const [virtual]

Intended Usage: This method should be used to find an alternative codec for the header field name if this codec cannot handle the header field.

The caller takes ownership of the returned codec.

Since:
7.0
Parameters:
aHeaderField The header field name string
Returns:
A pointer to the newly created codec if one is found, otherwise NULL is returned if a codec cannot be found. The caller takes ownership of the returned codec.

Implements CHeaderCodec.

CWspHeaderCodec::GetWspVersion ( ) const

Intended Usage: This method gets the current encoding version that is being used.

Since:
7.0
Returns:
The encoding version enumeration

CWspHeaderCodec::NewL | ( | RStringPool | aStrPool,
 |  | const TStringTable & | aStrTable
 | ) | [static]

Intended Usage: Standard factory 2 phase construction.

Exceptions:
KErrNoMemory
Since:
7.0
Parameters:
aStrPool | A handle to an open string pool with the string table that contains the header field names already open
aStrTable | The string table that contains the header field names
Returns:
A pointer to the newly created object
Precondition:
None
Postcondition:
Fully constructed and initialized object @cat Construction and Destruction

CWspHeaderCodec::SetWspVersion ( TWspVersion aWspVersion )

Intended Usage: This method sets the encoding version to use.

The encoding version defaults to 1.2 if this method is not called.

Since:
7.0
Parameters:
aWspVersion The encoding version enumeration
Postcondition:
The encoding version is set to the version passed in

Member Data Documentation

RStringPool CWspHeaderCodec::iStrPool [private]

Handle to an opened string pool with the header field names table open.

Definition at line 189 of file CWspHeaderCodec.h.

const TStringTable& CWspHeaderCodec::iStrTable [private]

The string table that contains the header field names.

Definition at line 193 of file CWspHeaderCodec.h.

TWspVersion CWspHeaderCodec::iWspVersion [private]

The current encoding version that is to be used, defaults to 1.2.

Definition at line 197 of file CWspHeaderCodec.h.

The documentation for this class was generated from the following file:
  • CWspHeaderCodec.h


Member List

CWspHeaderCodec Member List

This is the complete list of members for CWspHeaderCodec, including all inherited members.
CanDecode(RStringF aHeaderField) const | CWspHeaderCodec | [virtual]
CanEncode(RStringF aHeaderField) const | CWspHeaderCodec | [virtual]
CHeaderCodec() | CHeaderCodec | [protected]
ConstructL() | CWspHeaderCodec | [protected]
CWspHeaderCodec(RStringPool aStrPool, const TStringTable &aStrTable) | CWspHeaderCodec | [protected]
CWspHeaderCodec() | CWspHeaderCodec | [private]
DecodeHeaderL(RHeaderField &aHeader) const | CHeaderCodec |
EncodeFieldName(RStringF aFieldName) const | CWspHeaderCodec |
EncodeHeaderL(RHeaderField &aHeader) const | CHeaderCodec |
EVersion1_1 enum value | CWspHeaderCodec |
EVersion1_2 enum value | CWspHeaderCodec |
EVersion1_3 enum value | CWspHeaderCodec |
EVersion1_4 enum value | CWspHeaderCodec |
FindDelegateCodecL(RStringF aHeaderField) const | CWspHeaderCodec | [virtual]
GetWspVersion() const | CWspHeaderCodec |
iReader | CHeaderCodec | [protected]
iStrPool | CWspHeaderCodec | [private]
iStrTable | CWspHeaderCodec | [private]
iWriter | CHeaderCodec | [protected]
iWspVersion | CWspHeaderCodec | [private]
NewL(RStringPool aStrPool, const TStringTable &aStrTable) | CWspHeaderCodec | [static]
SetWspVersion(TWspVersion aWspVersion) | CWspHeaderCodec |
TWspVersion enum name | CWspHeaderCodec |
~CHeaderCodec() | CHeaderCodec | [virtual]
~CWspHeaderCodec() | CWspHeaderCodec | [virtual]


MWspHeaderCodePages Class Reference

@public
Since:
7.0 The MWspHeaderCodePages API provides an interface to a set of header code pages as defined by the WSP Specification, July 2001.
More...

#include <MWspHeaderCodePages.h>

Inheritance diagram for MWspHeaderCodePages:

[legend]
List of all members.

Public Methods

virtual TInt | Start () const=0
Intended Usage : Ensures that the first header code page in the set is available for reading.

virtual TInt | GetNext (TUint8 &aPageCode, TPtrC8 &aPageName) const=0
Intended Usage : Gets the next header code page in the set.

virtual void | Reset ()=0
Intended Usage : Resets the capability to the default.

virtual void | AddHeaderCodePageL (TUint8 aPageCode, const TDesC8 &aPageName)=0
Intended Usage : Adds a header code page to the set.

Detailed Description

@public
Since:
7.0 The MWspHeaderCodePages API provides an interface to a set of header code pages as defined by the WSP Specification, July 2001.

This capability associates a page number with a page name. The Server can negotiate the use of header code page proposed by the Client by including the page codes (without the page name) in the return negotiation.

The interface allows the set of header code pages to be accessed one by one. The read function provides the caller with a copy of the header code page information. The set can be reset to the default value of the capability (as defined by the WSP Specification), which is an empty set. A header code page can be added to the set.

Definition at line 35 of file MWspHeaderCodePages.h.

Member Function Documentation

MWspHeaderCodePages::AddHeaderCodePageL | ( | TUint8 | aPageCode,
 |  | const TDesC8 & | aPageName
 | ) | [pure virtual]

Intended Usage : Adds a header code page to the set.

Since:
7.0 @leave Leave code KErrNoMemory if the code page cannot be added to the set.
Parameters:
aPageCode | A byte with the extension code page number.
aPageName | A buffer with the name of the header code page.
Postcondition:
If no error has occured then the header code page has been added.

Implemented in CWspHeaderCodePages.

MWspHeaderCodePages::GetNext | ( | TUint8 & | aPageCode,
 |  | TPtrC8 & | aPageName
 | ) | const [pure virtual]

Intended Usage : Gets the next header code page in the set.

If there are no code pages left then KErrNotFound error code is returned.

Since:
7.0
Parameters:
aPageCode | A output parameter reference for a byte with the extension code page number.
aPageName | A output parameter reference for a buffer with the name of the header code page.
Returns:
An error code. If there are no header code pages left, then the value returned is KErrNotFound. If there are header code pages left then the value KErrNone is returned.
Postcondition:
The next header code page in the set is available for reading.

Implemented in CWspHeaderCodePages.

MWspHeaderCodePages::Reset ( ) [pure virtual]

Intended Usage : Resets the capability to the default.

The default is defined in the WSP Specification, July 2001, as being an empty set of code pages.

Since:
7.0
Postcondition:
The set of header code pages is empty.

Implemented in CWspHeaderCodePages.

MWspHeaderCodePages::Start ( ) const [pure virtual]

Intended Usage : Ensures that the first header code page in the set is available for reading.

Since:
7.0
Returns:
An error code. If there are no header code pages, then the value returned is KErrNotFound. If there are header code pages then the value KErrNone is returned.
Postcondition:
The subsequent call to GetNext() is applied to the first header code page in the set.

Implemented in CWspHeaderCodePages.

The documentation for this class was generated from the following file:
  • MWspHeaderCodePages.h


Member List

MWspHeaderCodePages Member List

This is the complete list of members for MWspHeaderCodePages, including all inherited members.
AddHeaderCodePageL(TUint8 aPageCode, const TDesC8 &aPageName)=0 | MWspHeaderCodePages | [pure virtual]
GetNext(TUint8 &aPageCode, TPtrC8 &aPageName) const=0 | MWspHeaderCodePages | [pure virtual]
Reset()=0 | MWspHeaderCodePages | [pure virtual]
Start() const=0 | MWspHeaderCodePages | [pure virtual]


CWspHeaderCodePages Class Reference

The CWspHeaderCodePages class represents a set of Extended Methods capabilities. More...

#include <CWspHeaderCodePages.h>

Inheritance diagram for CWspHeaderCodePages:

[legend]
Collaboration diagram for CWspHeaderCodePages:

[legend]
List of all members.

Public Methods

~CWspHeaderCodePages ()
Standard destructor.

virtual TInt | Start () const
virtual TInt | GetNext (TUint8 &aPageCode, TPtrC8 &aPageName) const
virtual void | Reset ()
virtual void | AddHeaderCodePageL (TUint8 aPageCode, const TDesC8 &aPageName)

Static Public Methods

CWspHeaderCodePages * | NewL ()
Static factory constructor.

Private Methods

CWspHeaderCodePages ()
First phase constructor.

Private Attributes

RPointerArray< CHeaderCodePage > | iCodePages
An array of header code pages.

TInt | iIndex
An index with the current position in the array.

Detailed Description

The CWspHeaderCodePages class represents a set of Extended Methods capabilities.

It implements the MWspHeaderCodePages interface.

See also:
MWspHeaderCodePages

Definition at line 19 of file CWspHeaderCodePages.h.

Constructor & Destructor Documentation

CWspHeaderCodePages::~CWspHeaderCodePages ( )

Standard destructor.

Since:
7.0

CWspHeaderCodePages::CWspHeaderCodePages ( ) [private]

First phase constructor.

Since:
7.0

Member Function Documentation

CWspHeaderCodePages::AddHeaderCodePageL | ( | TUint8 | aPageCode,
 |  | const TDesC8 & | aPageName
 | ) | [virtual]

See also:
MWspHeaderCodePages

Implements MWspHeaderCodePages.

CWspHeaderCodePages::GetNext | ( | TUint8 & | aPageCode,
 |  | TPtrC8 & | aPageName
 | ) | const [virtual]

See also:
MWspHeaderCodePages

Implements MWspHeaderCodePages.

CWspHeaderCodePages::NewL ( ) [static]

Static factory constructor.

Since:
7.0

CWspHeaderCodePages::Reset ( ) [virtual]

See also:
MWspHeaderCodePages

Implements MWspHeaderCodePages.

CWspHeaderCodePages::Start ( ) const [virtual]

See also:
MWspHeaderCodePages

Implements MWspHeaderCodePages.

Member Data Documentation

RPointerArray<CHeaderCodePage> CWspHeaderCodePages::iCodePages [private]

An array of header code pages.

Definition at line 77 of file CWspHeaderCodePages.h.

TInt CWspHeaderCodePages::iIndex [private]

An index with the current position in the array.

Is mutable to maintain logical const-ness.

Definition at line 83 of file CWspHeaderCodePages.h.

The documentation for this class was generated from the following file:
  • CWspHeaderCodePages.h


Member List

CWspHeaderCodePages Member List

This is the complete list of members for CWspHeaderCodePages, including all inherited members.
AddHeaderCodePageL(TUint8 aPageCode, const TDesC8 &aPageName) | CWspHeaderCodePages | [virtual]
CWspHeaderCodePages() | CWspHeaderCodePages | [private]
GetNext(TUint8 &aPageCode, TPtrC8 &aPageName) const | CWspHeaderCodePages | [virtual]
iCodePages | CWspHeaderCodePages | [private]
iIndex | CWspHeaderCodePages | [private]
NewL() | CWspHeaderCodePages | [static]
Reset() | CWspHeaderCodePages | [virtual]
Start() const | CWspHeaderCodePages | [virtual]
~CWspHeaderCodePages() | CWspHeaderCodePages |


CWspHeaderReader Class Reference

@dependancies CHeaderCodec, CHeaderReader, CHeaderFieldPart, RStringPool, RStringF
Since:
7.0 This class is the by the WSP header codec to provide the decoding functionality required by WSP to decode header fields from a raw binary format to a useful parsed format.
More...

#include <CWspHeaderReader.h>

Inheritance diagram for CWspHeaderReader:

[legend]
Collaboration diagram for CWspHeaderReader:

[legend]
List of all members.

Public Methods

virtual | ~CWspHeaderReader ()
Intended Usage: Standard virtual destructor.

virtual void | DecodeHeaderL (RHeaderField &aHeader)
Intended Usage: This method is used by the codec to decode any supported header field that passed in.

Static Public Methods

CWspHeaderReader * | NewL (RStringPool aStrPool, const TStringTable &aStrTable, CWspHeaderCodec &aCodec)
Intended Usage: Standard factory 2 phase construction.

CWspHeaderReader * | NewLC (RStringPool aStrPool, const TStringTable &aStrTable, CWspHeaderCodec &aCodec)
Intended Usage: Standard factory 2 phase construction leaving a handle on the cleanup stack.

Protected Methods

CWspHeaderReader (RStringPool aStrPool, const TStringTable &aStrTable, CWspHeaderCodec &aCodec)
Intended Usage: Standard default constructor.

Private Methods

void | DecodeContentTypeL (RHeaderField &aHeader) const
Decodes the Content-type header field.

void | DecodeDateL (RHeaderField &aHeader) const
Decodes the Date header field.

void | DecodeLastModifiedL (RHeaderField &aHeader) const
Decodes the Last-modified header field.

void | DecodePragmaL (RHeaderField &aHeader) const
Decodes the Pragma header field.

void | DecodeVaryL (RHeaderField &aHeader) const
Decodes the Vary header field.

void | DecodeWWWAuthenticateL (RHeaderField &aHeader) const
Decodes the WWW-Authenticate header field.

void | DecodeSetCookieL (RHeaderField &aHeader) const
Decodes the Set-Cookie header field.

void | DecodeContentLocationL (RHeaderField &aHeader) const
Decodes the Content-location header field.

void | DecodeLocationL (RHeaderField &aHeader) const
Decodes the Location header field.

void | DecodeEncodingVersionL (RHeaderField &aHeader) const
Decodes the Encoding-version header field.

void | DecodeAcceptRangesL (RHeaderField &aHeader) const
Decodes the Accept-ranges header field.

void | DecodeContentEncodingL (RHeaderField &aHeader) const
Decodes the Content-encoding header field.

void | DecodeContentLanguageL (RHeaderField &aHeader) const
Decodes the Content-language header field.

void | DecodeContentMD5L (RHeaderField &aHeader) const
Decodes the Content-MD5 header field.

void | DecodeProxyAuthenticateL (RHeaderField &aHeader) const
Decodes the Proxy-authenticate header field.

void | DecodeServerL (RHeaderField &aHeader) const
Decodes the Server header field.

void | DecodeRetryAfterL (RHeaderField &aHeader) const
Decodes the Retry-after header field.

void | DecodeViaL (RHeaderField &aHeader) const
Decodes the Via header field.

void | DecodeTrailerL (RHeaderField &aHeader) const
Decodes the Trailer header field.

void | DecodeContentRangeL (RHeaderField &aHeader) const
Decodes the Content-range header field.

void | DecodeXWapApplicationIdL (RHeaderField &aHeader) const
Decodes the X-Wap-Application-Id header field.

void | DecodeXWapInitiatorURIL (RHeaderField &aHeader) const
Decodes the X-Wap-Initiator-URI header field.

void | DecodePushFlagL (RHeaderField &aHeader) const
Decodes the Push-flag header field.

void | DecodeAllowL (RHeaderField &aHeader) const
Decodes the Allow header field.

void | DecodeUpgradeL (RHeaderField &aHeader) const
Decodes the Upgrade header field.

void | DecodeWarningL (RHeaderField &aHeader) const
Decodes the Warning header field.

void | DecodeGenericWarnCodeL (RHeaderField &aHeader, TWspPrimitiveDecoder &aDecoder) const
Decodes the warn codes.

TBool | CheckForNullStringL (TPtrC8 &aRawData, TInt &aBytesRead, TWspPrimitiveDecoder &aDecoder) const
Checks for NULL strings, ie strings with no but data with a NULL terminator.

void | DecodeGenericVersionL (RHeaderField &aHeader, TWspPrimitiveDecoder &aDecoder, TInt aIndex) const
Decodes version values.

void | CheckLengthL (TPtrC8 &aRawData, TInt aMinLength) const
Check the length of data is greater than a required minimum.

TBool | CheckNullDesPartL (RHeaderField &aHeader, TPtrC8 &aRawData, TInt aPartIndex) const
Check for a NULL data part and adds a NULL descriptor part to the parsed data.

TInt | AddNewDecoderStringPartL (RHeaderField &aHeader, TWspPrimitiveDecoder &aDecoder, TInt aIndex=0) const
Adds a new string part to the parsed data.

void | DecodeGenericIntegerValueL (RHeaderField &aHeader) const
Decodes generic integer values.

void | DecodeGenericNewStringValueL (RHeaderField &aHeader) const
Decodes generic new string values.

void | DecodeGenericDateValueL (RHeaderField &aHeader) const
Decodes generic data values.

void | DecodeGenericFieldNameL (RHeaderField &aHeader) const
Decodes generic field names.

TInt | DecodeGenericSingleParameterL (TPtrC8 &aRawParam, CHeaderFieldPart &aHeaderFieldPart) const
Decodes generic string parameter types.

void | DecodeWellKnownParamTokenL (TWspPrimitiveDecoder &aDecoder, TInt &aBytesRead, TPtrC8 &aRawParamBlock, CHeaderFieldPart &aHeaderFieldPart) const
Decodes well known parameter tokens.

void | DecodeUntypedParamL (TWspPrimitiveDecoder &aDecoder, TInt &aBytesRead, TPtrC8 &aRawParamBlock, CHeaderFieldPart &aHeaderFieldPart) const
Decodes untyped parameter types.

TInt | DecodeGenericParamTokenL (TWspPrimitiveDecoder &aDecoder, const TStringTable &aStrTable, THTTPHdrVal &aParamValue, RStringF &aParamDesValue) const
Decodes generic parameter tokens.

void | GetCharacterSetFromValueL (TInt aValue, RStringF &aCharSetStr) const
Decodes character-sets.

void | DecodeGenericChallengeL (RHeaderField &aHeader) const
Decodes generic challenge data.

CHeaderFieldPart & | SetNewPartL (RHeaderField &aHeader, TInt aPartIndex, THTTPHdrVal &aPartVal) const
Sets a new part.

CHeaderFieldPart & | SetNewIntegerPartL (RHeaderField &aHeader, TInt aPartIndex, TInt aValue) const
Sets a new integer part.

CHeaderFieldPart & | SetNewFStringPartL (RHeaderField &aHeader, TInt aPartIndex, TPtrC8 aValue) const
Sets a new case insensitive string part.

CHeaderFieldPart & | SetNewStringPartL (RHeaderField &aHeader, TInt aPartIndex, TPtrC8 aValue) const
Sets a new case sensitive string part.

CHeaderFieldPart & | SetFStringPartL (RHeaderField &aHeader, TInt aPartIndex, RStringF aStrVal) const
Sets an existing case insensitive string part.

CHeaderFieldPart & | SetNewDatePartL (RHeaderField &aHeader, TInt aPartIndex, TDateTime &aValue) const
Sets a new date value part.

CHeaderFieldParam & | SetNewParamL (CHeaderFieldPart &aHeaderPart, TPtrC8 aParamName, THTTPHdrVal aParamValue) const
Adds a new param to the supplied part.

Private Attributes

RStringPool | iStrPool
Handle to an opened string pool with the WSP header field names table opened.

const TStringTable & | iStrTable
Reference to the WSP header field names table.

CWspHeaderCodec & iCodec
Reference to the parent owning codec.

Detailed Description

@dependancies CHeaderCodec, CHeaderReader, CHeaderFieldPart, RStringPool, RStringF
Since:
7.0 This class is the by the WSP header codec to provide the decoding functionality required by WSP to decode header fields from a raw binary format to a useful parsed format.

For internal use only.

The decoding is done as stated in the WSP specifications avaialable from www.wapforum.org.

Definition at line 33 of file CWspHeaderReader.h.

Constructor & Destructor Documentation

CWspHeaderReader::~CWspHeaderReader ( ) [virtual]

Intended Usage: Standard virtual destructor.

Since:
7.0
Precondition:
Object is constructed
Postcondition:
Object is destroyed @cat Construction and Destruction

CWspHeaderReader::CWspHeaderReader | ( | RStringPool | aStrPool,
 |  | const TStringTable & | aStrTable,
 |  | CWspHeaderCodec & | aCodec
 | ) | [protected]

Intended Usage: Standard default constructor.

Error Condition: Low memory conditions

Since:
7.0
Parameters:
aStrPool | A handle to an opened string pool with the WSP table opened
aStrTable | The WSP table that contains the header field names
aCodec | A reference to the parent owning codec
Precondition:
None
Postcondition:
Object is constructed @cat Construction and Destruction

Member Function Documentation

TInt CWspHeaderReader::AddNewDecoderStringPartL | ( | RHeaderField & | aHeader,
 |  | TWspPrimitiveDecoder & | aDecoder,
 |  | TInt | aIndex = 0
 | ) | const [private]

Adds a new string part to the parsed data.

TBool CWspHeaderReader::CheckForNullStringL | ( | TPtrC8 & | aRawData,
 |  | TInt & | aBytesRead,
 |  | TWspPrimitiveDecoder & | aDecoder
 | ) | const [private]

Checks for NULL strings, ie strings with no but data with a NULL terminator.

void CWspHeaderReader::CheckLengthL | ( | TPtrC8 & | aRawData,
 |  | TInt | aMinLength
 | ) | const [inline, private]

Check the length of data is greater than a required minimum.

Definition at line 389 of file CWspHeaderReader.h.

TBool CWspHeaderReader::CheckNullDesPartL | ( | RHeaderField & | aHeader,
 |  | TPtrC8 & | aRawData,
 |  | TInt | aPartIndex
 | ) | const [private]

Check for a NULL data part and adds a NULL descriptor part to the parsed data.

void CWspHeaderReader::DecodeAcceptRangesL ( RHeaderField & aHeader ) const [private]

Decodes the Accept-ranges header field.

void CWspHeaderReader::DecodeAllowL ( RHeaderField & aHeader ) const [private]

Decodes the Allow header field.

void CWspHeaderReader::DecodeContentEncodingL ( RHeaderField & aHeader ) const [private]

Decodes the Content-encoding header field.

void CWspHeaderReader::DecodeContentLanguageL ( RHeaderField & aHeader ) const [private]

Decodes the Content-language header field.

void CWspHeaderReader::DecodeContentLocationL ( RHeaderField & aHeader ) const [private]

Decodes the Content-location header field.

void CWspHeaderReader::DecodeContentMD5L ( RHeaderField & aHeader ) const [private]

Decodes the Content-MD5 header field.

void CWspHeaderReader::DecodeContentRangeL ( RHeaderField & aHeader ) const [private]

Decodes the Content-range header field.

void CWspHeaderReader::DecodeContentTypeL ( RHeaderField & aHeader ) const [private]

Decodes the Content-type header field.

void CWspHeaderReader::DecodeDateL ( RHeaderField & aHeader ) const [private]

Decodes the Date header field.

void CWspHeaderReader::DecodeEncodingVersionL ( RHeaderField & aHeader ) const [private]

Decodes the Encoding-version header field.

void CWspHeaderReader::DecodeGenericChallengeL ( RHeaderField & aHeader ) const [private]

Decodes generic challenge data.

void CWspHeaderReader::DecodeGenericDateValueL ( RHeaderField & aHeader ) const [private]

Decodes generic data values.

void CWspHeaderReader::DecodeGenericFieldNameL ( RHeaderField & aHeader ) const [private]

Decodes generic field names.

void CWspHeaderReader::DecodeGenericIntegerValueL ( RHeaderField & aHeader ) const [private]

Decodes generic integer values.

void CWspHeaderReader::DecodeGenericNewStringValueL ( RHeaderField & aHeader ) const [private]

Decodes generic new string values.

TInt CWspHeaderReader::DecodeGenericParamTokenL | ( | TWspPrimitiveDecoder & | aDecoder,
 |  | const TStringTable & | aStrTable,
 |  | THTTPHdrVal & | aParamValue,
 |  | RStringF & | aParamDesValue
 | ) | const [private]

Decodes generic parameter tokens.

TInt CWspHeaderReader::DecodeGenericSingleParameterL | ( | TPtrC8 & | aRawParam,
 |  | CHeaderFieldPart & | aHeaderFieldPart
 | ) | const [private]

Decodes generic string parameter types.

void CWspHeaderReader::DecodeGenericVersionL | ( | RHeaderField & | aHeader,
 |  | TWspPrimitiveDecoder & | aDecoder,
 |  | TInt | aIndex
 | ) | const [private]

Decodes version values.

void CWspHeaderReader::DecodeGenericWarnCodeL | ( | RHeaderField & | aHeader,
 |  | TWspPrimitiveDecoder & | aDecoder
 | ) | const [private]

Decodes the warn codes.

CWspHeaderReader::DecodeHeaderL ( RHeaderField & aHeader ) [virtual]

Intended Usage: This method is used by the codec to decode any supported header field that passed in.

Error Condition: Low memory conditions or invalid or corrupt data

Since:
7.0
Parameters:
aHeader A reference to the header field to decode
Precondition:
The header field is its raw format state
Postcondition:
The header field is decoded and in its parsed state
Exceptions:
KErrNoMemory KErrNotSupported if the header field is not supported KErrCorrupt if the data is invalid or corrupt

Implements CHeaderReader.

void CWspHeaderReader::DecodeLastModifiedL ( RHeaderField & aHeader ) const [private]

Decodes the Last-modified header field.

void CWspHeaderReader::DecodeLocationL ( RHeaderField & aHeader ) const [private]

Decodes the Location header field.

void CWspHeaderReader::DecodePragmaL ( RHeaderField & aHeader ) const [private]

Decodes the Pragma header field.

void CWspHeaderReader::DecodeProxyAuthenticateL ( RHeaderField & aHeader ) const [private]

Decodes the Proxy-authenticate header field.

void CWspHeaderReader::DecodePushFlagL ( RHeaderField & aHeader ) const [private]

Decodes the Push-flag header field.

void CWspHeaderReader::DecodeRetryAfterL ( RHeaderField & aHeader ) const [private]

Decodes the Retry-after header field.

void CWspHeaderReader::DecodeServerL ( RHeaderField & aHeader ) const [private]

Decodes the Server header field.

void CWspHeaderReader::DecodeSetCookieL ( RHeaderField & aHeader ) const [private]

Decodes the Set-Cookie header field.

void CWspHeaderReader::DecodeTrailerL ( RHeaderField & aHeader ) const [private]

Decodes the Trailer header field.

void CWspHeaderReader::DecodeUntypedParamL | ( | TWspPrimitiveDecoder & | aDecoder,
 |  | TInt & | aBytesRead,
 |  | TPtrC8 & | aRawParamBlock,
 |  | CHeaderFieldPart & | aHeaderFieldPart
 | ) | const [private]

Decodes untyped parameter types.

void CWspHeaderReader::DecodeUpgradeL ( RHeaderField & aHeader ) const [private]

Decodes the Upgrade header field.

void CWspHeaderReader::DecodeVaryL ( RHeaderField & aHeader ) const [private]

Decodes the Vary header field.

void CWspHeaderReader::DecodeViaL ( RHeaderField & aHeader ) const [private]

Decodes the Via header field.

void CWspHeaderReader::DecodeWarningL ( RHeaderField & aHeader ) const [private]

Decodes the Warning header field.

void CWspHeaderReader::DecodeWellKnownParamTokenL | ( | TWspPrimitiveDecoder & | aDecoder,
 |  | TInt & | aBytesRead,
 |  | TPtrC8 & | aRawParamBlock,
 |  | CHeaderFieldPart & | aHeaderFieldPart
 | ) | const [private]

Decodes well known parameter tokens.

void CWspHeaderReader::DecodeWWWAuthenticateL ( RHeaderField & aHeader ) const [private]

Decodes the WWW-Authenticate header field.

void CWspHeaderReader::DecodeXWapApplicationIdL ( RHeaderField & aHeader ) const [private]

Decodes the X-Wap-Application-Id header field.

void CWspHeaderReader::DecodeXWapInitiatorURIL ( RHeaderField & aHeader ) const [private]

Decodes the X-Wap-Initiator-URI header field.

void CWspHeaderReader::GetCharacterSetFromValueL | ( | TInt | aValue,
 |  | RStringF & | aCharSetStr
 | ) | const [private]

Decodes character-sets.

CWspHeaderReader * CWspHeaderReader::NewL | ( | RStringPool | aStrPool,
 |  | const TStringTable & | aStrTable,
 |  | CWspHeaderCodec & | aCodec
 | ) | [static]

Intended Usage: Standard factory 2 phase construction.

Error Condition: Low memory conditions

Since:
7.0
Parameters:
aStrPool | A handle to an opened string pool with the WSP table opened
aStrTable | The WSP table that contains the header field names
aCodec | A reference to the parent owning codec
Returns:
A pointer to the newly created object
Precondition:
None
Postcondition:
Object is fully constructed
Exceptions:
KErrNoMemory @cat Construction and Destruction

CWspHeaderReader * CWspHeaderReader::NewLC | ( | RStringPool | aStrPool,
 |  | const TStringTable & | aStrTable,
 |  | CWspHeaderCodec & | aCodec
 | ) | [static]

Intended Usage: Standard factory 2 phase construction leaving a handle on the cleanup stack.

Error Condition: Low memory conditions

Since:
7.0
Parameters:
aStrPool | A handle to an opened string pool with the WSP table opened
aStrTable | The WSP table that contains the header field names
aCodec | A reference to the parent owning codec
Returns:
A pointer to the newly created object
Precondition:
None
Postcondition:
Object is fully constructed with a handle on the cleanup stack
Exceptions:
KErrNoMemory @cat Construction and Destruction

CHeaderFieldPart& CWspHeaderReader::SetFStringPartL | ( | RHeaderField & | aHeader,
 |  | TInt | aPartIndex,
 |  | RStringF | aStrVal
 | ) | const [private]

Sets an existing case insensitive string part.

CHeaderFieldPart& CWspHeaderReader::SetNewDatePartL | ( | RHeaderField & | aHeader,
 |  | TInt | aPartIndex,
 |  | TDateTime & | aValue
 | ) | const [private]

Sets a new date value part.

CHeaderFieldPart& CWspHeaderReader::SetNewFStringPartL | ( | RHeaderField & | aHeader,
 |  | TInt | aPartIndex,
 |  | TPtrC8 | aValue
 | ) | const [private]

Sets a new case insensitive string part.

CHeaderFieldPart& CWspHeaderReader::SetNewIntegerPartL | ( | RHeaderField & | aHeader,
 |  | TInt | aPartIndex,
 |  | TInt | aValue
 | ) | const [private]

Sets a new integer part.

CHeaderFieldParam& CWspHeaderReader::SetNewParamL | ( | CHeaderFieldPart & | aHeaderPart,
 |  | TPtrC8 | aParamName,
 |  | THTTPHdrVal | aParamValue
 | ) | const [private]

Adds a new param to the supplied part.

CHeaderFieldPart& CWspHeaderReader::SetNewPartL | ( | RHeaderField & | aHeader,
 |  | TInt | aPartIndex,
 |  | THTTPHdrVal & | aPartVal
 | ) | const [private]

Sets a new part.

CHeaderFieldPart& CWspHeaderReader::SetNewStringPartL | ( | RHeaderField & | aHeader,
 |  | TInt | aPartIndex,
 |  | TPtrC8 | aValue
 | ) | const [private]

Sets a new case sensitive string part.

Member Data Documentation

CWspHeaderCodec& CWspHeaderReader::iCodec [private]

Reference to the parent owning codec.

Definition at line 386 of file CWspHeaderReader.h.

RStringPool CWspHeaderReader::iStrPool [private]

Handle to an opened string pool with the WSP header field names table opened.

Definition at line 376 of file CWspHeaderReader.h.

const TStringTable& CWspHeaderReader::iStrTable [private]

Reference to the WSP header field names table.

Definition at line 381 of file CWspHeaderReader.h.

The documentation for this class was generated from the following file:
  • CWspHeaderReader.h


Member List

CWspHeaderReader Member List

This is the complete list of members for CWspHeaderReader, including all inherited members.
AddNewDecoderStringPartL(RHeaderField &aHeader, TWspPrimitiveDecoder &aDecoder, TInt aIndex=0) const | CWspHeaderReader | [private]
CHeaderReader() | CHeaderReader | [protected]
CheckForNullStringL(TPtrC8 &aRawData, TInt &aBytesRead, TWspPrimitiveDecoder &aDecoder) const | CWspHeaderReader | [private]
CheckLengthL(TPtrC8 &aRawData, TInt aMinLength) const | CWspHeaderReader | [inline, private]
CheckNullDesPartL(RHeaderField &aHeader, TPtrC8 &aRawData, TInt aPartIndex) const | CWspHeaderReader | [private]
ConstructL() | CHeaderReader | [protected]
CWspHeaderReader(RStringPool aStrPool, const TStringTable &aStrTable, CWspHeaderCodec &aCodec) | CWspHeaderReader | [protected]
DecodeAcceptRangesL(RHeaderField &aHeader) const | CWspHeaderReader | [private]
DecodeAllowL(RHeaderField &aHeader) const | CWspHeaderReader | [private]
DecodeContentEncodingL(RHeaderField &aHeader) const | CWspHeaderReader | [private]
DecodeContentLanguageL(RHeaderField &aHeader) const | CWspHeaderReader | [private]
DecodeContentLocationL(RHeaderField &aHeader) const | CWspHeaderReader | [private]
DecodeContentMD5L(RHeaderField &aHeader) const | CWspHeaderReader | [private]
DecodeContentRangeL(RHeaderField &aHeader) const | CWspHeaderReader | [private]
DecodeContentTypeL(RHeaderField &aHeader) const | CWspHeaderReader | [private]
DecodeDateL(RHeaderField &aHeader) const | CWspHeaderReader | [private]
DecodeEncodingVersionL(RHeaderField &aHeader) const | CWspHeaderReader | [private]
DecodeGenericChallengeL(RHeaderField &aHeader) const | CWspHeaderReader | [private]
DecodeGenericDateValueL(RHeaderField &aHeader) const | CWspHeaderReader | [private]
DecodeGenericFieldNameL(RHeaderField &aHeader) const | CWspHeaderReader | [private]
DecodeGenericIntegerValueL(RHeaderField &aHeader) const | CWspHeaderReader | [private]
DecodeGenericNewStringValueL(RHeaderField &aHeader) const | CWspHeaderReader | [private]
DecodeGenericParamTokenL(TWspPrimitiveDecoder &aDecoder, const TStringTable &aStrTable, THTTPHdrVal &aParamValue, RStringF &aParamDesValue) const | CWspHeaderReader | [private]
DecodeGenericSingleParameterL(TPtrC8 &aRawParam, CHeaderFieldPart &aHeaderFieldPart) const | CWspHeaderReader | [private]
DecodeGenericVersionL(RHeaderField &aHeader, TWspPrimitiveDecoder &aDecoder, TInt aIndex) const | CWspHeaderReader | [private]
DecodeGenericWarnCodeL(RHeaderField &aHeader, TWspPrimitiveDecoder &aDecoder) const | CWspHeaderReader | [private]
DecodeHeaderL(RHeaderField &aHeader) | CWspHeaderReader | [virtual]
DecodeLastModifiedL(RHeaderField &aHeader) const | CWspHeaderReader | [private]
DecodeLocationL(RHeaderField &aHeader) const | CWspHeaderReader | [private]
DecodePragmaL(RHeaderField &aHeader) const | CWspHeaderReader | [private]
DecodeProxyAuthenticateL(RHeaderField &aHeader) const | CWspHeaderReader | [private]
DecodePushFlagL(RHeaderField &aHeader) const | CWspHeaderReader | [private]
DecodeRetryAfterL(RHeaderField &aHeader) const | CWspHeaderReader | [private]
DecodeServerL(RHeaderField &aHeader) const | CWspHeaderReader | [private]
DecodeSetCookieL(RHeaderField &aHeader) const | CWspHeaderReader | [private]
DecodeTrailerL(RHeaderField &aHeader) const | CWspHeaderReader | [private]
DecodeUntypedParamL(TWspPrimitiveDecoder &aDecoder, TInt &aBytesRead, TPtrC8 &aRawParamBlock, CHeaderFieldPart &aHeaderFieldPart) const | CWspHeaderReader | [private]
DecodeUpgradeL(RHeaderField &aHeader) const | CWspHeaderReader | [private]
DecodeVaryL(RHeaderField &aHeader) const | CWspHeaderReader | [private]
DecodeViaL(RHeaderField &aHeader) const | CWspHeaderReader | [private]
DecodeWarningL(RHeaderField &aHeader) const | CWspHeaderReader | [private]
DecodeWellKnownParamTokenL(TWspPrimitiveDecoder &aDecoder, TInt &aBytesRead, TPtrC8 &aRawParamBlock, CHeaderFieldPart &aHeaderFieldPart) const | CWspHeaderReader | [private]
DecodeWWWAuthenticateL(RHeaderField &aHeader) const | CWspHeaderReader | [private]
DecodeXWapApplicationIdL(RHeaderField &aHeader) const | CWspHeaderReader | [private]
DecodeXWapInitiatorURIL(RHeaderField &aHeader) const | CWspHeaderReader | [private]
GetCharacterSetFromValueL(TInt aValue, RStringF &aCharSetStr) const | CWspHeaderReader | [private]
iCodec | CWspHeaderReader | [private]
iStrPool | CWspHeaderReader | [private]
iStrTable | CWspHeaderReader | [private]
NewL(RStringPool aStrPool, const TStringTable &aStrTable, CWspHeaderCodec &aCodec) | CWspHeaderReader | [static]
NewLC(RStringPool aStrPool, const TStringTable &aStrTable, CWspHeaderCodec &aCodec) | CWspHeaderReader | [static]
SetFStringPartL(RHeaderField &aHeader, TInt aPartIndex, RStringF aStrVal) const | CWspHeaderReader | [private]
SetNewDatePartL(RHeaderField &aHeader, TInt aPartIndex, TDateTime &aValue) const | CWspHeaderReader | [private]
SetNewFStringPartL(RHeaderField &aHeader, TInt aPartIndex, TPtrC8 aValue) const | CWspHeaderReader | [private]
SetNewIntegerPartL(RHeaderField &aHeader, TInt aPartIndex, TInt aValue) const | CWspHeaderReader | [private]
SetNewParamL(CHeaderFieldPart &aHeaderPart, TPtrC8 aParamName, THTTPHdrVal aParamValue) const | CWspHeaderReader | [private]
SetNewPartL(RHeaderField &aHeader, TInt aPartIndex, THTTPHdrVal &aPartVal) const | CWspHeaderReader | [private]
SetNewStringPartL(RHeaderField &aHeader, TInt aPartIndex, TPtrC8 aValue) const | CWspHeaderReader | [private]
~CHeaderReader() | CHeaderReader | [virtual]
~CWspHeaderReader() | CWspHeaderReader | [virtual]


CWspHeaderUtils Class Reference

#include <CWspHeaderUtils.h>

Collaboration diagram for CWspHeaderUtils:

[legend]
List of all members.

Public Methods

~CWspHeaderUtils ()
HBufC8 * | EncodeHeadersL (RStringPool aStringPool, RHTTPHeaders aHeaders)
HBufC8 * | EncodeNoTrailerHeadersL (RStringPool aStringPool, RHTTPHeaders aHeaders, HBufC8 *&iTrailerData)
void | DecodeReplyHeadersL (RStringPool aStringPool, const TDesC8 &aEncodedData, RHTTPHeaders &aHeaders)
void | DecodeHeadersL (RStringPool aStringPool, const TDesC8 &aEncodedData, RHTTPHeaders &aHeaders)

Static Public Methods

CWspHeaderUtils * | NewL (CWspHeaderCodec &aCodec)

Private Methods

CWspHeaderUtils (CWspHeaderCodec &aCodec)
TBool | EncodeContentTypeL (RStringPool aStringPool, RHTTPHeaders aHeaders, HBufC8 *&aBuf)
void | EncodeHeaderFieldL (RHTTPHeaders aHeaders, RStringF aHeaderField, HBufC8 *&aBuf)
TBool | IsTrailerHeader (RArray< RStringF > aTrailerHeaders, RStringF aHeaderField)

Private Attributes

CWspHeaderCodec & iCodec

Detailed Description

Todo:
docing

Definition at line 18 of file CWspHeaderUtils.h.

Constructor & Destructor Documentation

CWspHeaderUtils::~CWspHeaderUtils ( )

CWspHeaderUtils::CWspHeaderUtils ( CWspHeaderCodec & aCodec ) [private]

Member Function Documentation

void CWspHeaderUtils::DecodeHeadersL | ( | RStringPool | aStringPool,
 |  | const TDesC8 & | aEncodedData,
 |  | RHTTPHeaders & | aHeaders
 | ) |

void CWspHeaderUtils::DecodeReplyHeadersL | ( | RStringPool | aStringPool,
 |  | const TDesC8 & | aEncodedData,
 |  | RHTTPHeaders & | aHeaders
 | ) |

TBool CWspHeaderUtils::EncodeContentTypeL | ( | RStringPool | aStringPool,
 |  | RHTTPHeaders | aHeaders,
 |  | HBufC8 *& | aBuf
 | ) | [private]

void CWspHeaderUtils::EncodeHeaderFieldL | ( | RHTTPHeaders | aHeaders,
 |  | RStringF | aHeaderField,
 |  | HBufC8 *& | aBuf
 | ) | [private]

HBufC8* CWspHeaderUtils::EncodeHeadersL | ( | RStringPool | aStringPool,
 |  | RHTTPHeaders | aHeaders
 | ) |

HBufC8* CWspHeaderUtils::EncodeNoTrailerHeadersL | ( | RStringPool | aStringPool,
 |  | RHTTPHeaders | aHeaders,
 |  | HBufC8 *& | iTrailerData
 | ) |

TBool CWspHeaderUtils::IsTrailerHeader | ( | RArray< RStringF > | aTrailerHeaders,
 |  | RStringF | aHeaderField
 | ) | [private]

CWspHeaderUtils* CWspHeaderUtils::NewL ( CWspHeaderCodec & aCodec ) [static]

Member Data Documentation

CWspHeaderCodec& CWspHeaderUtils::iCodec [private]

Definition at line 57 of file CWspHeaderUtils.h.

The documentation for this class was generated from the following file:
  • CWspHeaderUtils.h


Member List

CWspHeaderUtils Member List

This is the complete list of members for CWspHeaderUtils, including all inherited members.
CWspHeaderUtils(CWspHeaderCodec &aCodec) | CWspHeaderUtils | [private]
DecodeHeadersL(RStringPool aStringPool, const TDesC8 &aEncodedData, RHTTPHeaders &aHeaders) | CWspHeaderUtils |
DecodeReplyHeadersL(RStringPool aStringPool, const TDesC8 &aEncodedData, RHTTPHeaders &aHeaders) | CWspHeaderUtils |
EncodeContentTypeL(RStringPool aStringPool, RHTTPHeaders aHeaders, HBufC8 *&aBuf) | CWspHeaderUtils | [private]
EncodeHeaderFieldL(RHTTPHeaders aHeaders, RStringF aHeaderField, HBufC8 *&aBuf) | CWspHeaderUtils | [private]
EncodeHeadersL(RStringPool aStringPool, RHTTPHeaders aHeaders) | CWspHeaderUtils |
EncodeNoTrailerHeadersL(RStringPool aStringPool, RHTTPHeaders aHeaders, HBufC8 *&iTrailerData) | CWspHeaderUtils |
iCodec | CWspHeaderUtils | [private]
IsTrailerHeader(RArray< RStringF > aTrailerHeaders, RStringF aHeaderField) | CWspHeaderUtils | [private]
NewL(CWspHeaderCodec &aCodec) | CWspHeaderUtils | [static]
~CWspHeaderUtils() | CWspHeaderUtils |


CWspHeaderWriter Class Reference

@public @dependancies CHeaderWriter, CWspHeaderCodec, RStringPool, RHeaderField
Since:
7.0 This class provides the encoding functionality for encoding all of the supported headers.
More...

#include <CWspHeaderWriter.h>

Inheritance diagram for CWspHeaderWriter:

[legend]
Collaboration diagram for CWspHeaderWriter:

[legend]
List of all members.

Public Methods

virtual | ~CWspHeaderWriter ()
Intended Usage: Standard virtual destructor
Since:
7.0.

virtual void | EncodeHeaderL (RHeaderField &aHeader)
Intended Usage: This method will encode the header field that is passed in into its raw form.

TInt | EncodeFieldName (RStringF aFieldName) const
Intended Usage: This method encodes the field name into its encoded token value.

Static Public Methods

CWspHeaderWriter * | NewL (RStringPool aStrPool, const TStringTable &aStrTable, CWspHeaderCodec &aCodec)
Intended Usage: Standard factory 2 phase construction Error Condition: Low memory conditions
Since:
7.0.

CWspHeaderWriter * | NewLC (RStringPool aStrPool, const TStringTable &aStrTable, CWspHeaderCodec &aCodec)
Intended Usage: Standard factory 2 phase construction leaving a handle on the cleanup stack.

Protected Methods

CWspHeaderWriter (RStringPool aStrPool, const TStringTable &aStrTable, CWspHeaderCodec &aCodec)
Intended Usage: Standard default constructor.

Private Methods

void | EncodeAcceptL (RHeaderField &aHeader) const
Encodes the 'Accept' header.

void | EncodeAcceptCharsetL (RHeaderField &aHeader) const
Encodes the 'Accept-charset' header.

void | EncodeAcceptEncodingL (RHeaderField &aHeader) const
Encodes the 'Accept-encoding' header.

void | EncodeAcceptLanguageL (RHeaderField &aHeader) const
Encodes the 'Accept-language' header.

void | EncodeAllowL (RHeaderField &aHeader) const
Encodes the 'Allow' header.

void | EncodeAuthorizationL (RHeaderField &aHeader) const
Encodes the 'Authorization' header.

void | EncodeContentEncodingL (RHeaderField &aHeader) const
Encodes the 'Content-encoding' header.

void | EncodeContentLanguageL (RHeaderField &aHeader) const
Encodes the 'Content-language' header.

void | EncodeContentLocationL (RHeaderField &aHeader) const
Encodes the 'Content-location' header.

void | EncodeContentMD5L (RHeaderField &aHeader) const
Encodes the 'Content-MD5' header.

void | EncodeContentRangeL (RHeaderField &aHeader) const
Encodes the 'Content-range' header.

void | EncodeContentTypeL (RHeaderField &aHeader) const
Encodes the 'Content-type' header.

void | EncodeCookieL (RHeaderField &aHeader) const
Encodes the 'Cookie' header.

void | EncodeDateL (RHeaderField &aHeader) const
Encodes the 'Date' header.

void | EncodeEncodingVersionL (RHeaderField &aHeader) const
Encodes the 'Encoding-version' header.

void | EncodeExpectL (RHeaderField &aHeader) const
Encodes the 'Expect' header.

void | EncodeFromL (RHeaderField &aHeader) const
Encodes the 'From' header.

void | EncodeLastModifiedL (RHeaderField &aHeader) const
Encodes the 'Last-modified' header.

void | EncodePragmaL (RHeaderField &aHeader) const
Encodes the 'Pragma' header.

void | EncodeRangeL (RHeaderField &aHeader) const
Encodes the 'Range' header.

void | EncodeRefererL (RHeaderField &aHeader) const
Encodes the 'Referer' header.

void | EncodeTEL (RHeaderField &aHeader) const
Encodes the 'TE' header.

void | EncodeTrailerL (RHeaderField &aHeader) const
Encodes the 'Trailer' header.

void | EncodeUpgradeL (RHeaderField &aHeader) const
Encodes the 'Upgrade' header.

void | EncodeUserAgentL (RHeaderField &aHeader) const
Encodes the 'User-agent' header.

void | EncodeViaL (RHeaderField &aHeader) const
Encodes the 'Via' header.

void | EncodeWarningL (RHeaderField &aHeader) const
Encodes the 'Warning' header.

void | EncodeXWapApplicationIdL (RHeaderField &aHeader) const
Encodes the 'X-Wap-Application-Id' header.

void | GenericEncodeDateL (RHeaderField &aHeader) const
Encodes generic headers that have a date value.

void | GenericEncodeTextStringL (RHeaderField &aHeader) const
Encodes generic headers that have a text string value.

void | EncodeParameterL (const CHeaderFieldParam &aHeaderFieldParam, CWspHeaderEncoder &aEncoder) const
Encodes a parameter value.

HBufC8 * | EncodeQValueL (RStringF aQValue) const
Encodes a single 'Q' value.

TUint8 | EncodeVersionValueL (RStringF aVersionValue) const
Encodes a single version value.

TInt | EncodeHeaderNameL (RHeaderField &aHeader) const
Encodes a header name.

TInt | GetCharacterSetValue (RStringF aCharSet) const
Encodes a single character set value.

TInt | CheckTokenText (RStringF aTokenText) const
Checks the passed in string for any invalid characters as specified in RFC2616.

TInt | CheckTextString (RStringF aTextString) const
Checks the passed in string for any invalid characters as specified in RFC2616.

TInt | EncodeContentTypeValue (THTTPHdrVal &aContentType) const
Gets encoding for content-type text value with correct WSP version control.

TInt | EncodeParameterTokenValue (RStringF aParameterName) const

Private Attributes

RStringPool | iStrPool
const TStringTable & | iStrTable
CWspHeaderCodec & iCodec

Detailed Description

@public @dependancies CHeaderWriter, CWspHeaderCodec, RStringPool, RHeaderField
Since:
7.0 This class provides the encoding functionality for encoding all of the supported headers.

The single method EncodeHeaderL() is used passing in the header field and the particular header field is then encoded into its faw format.

Definition at line 31 of file CWspHeaderWriter.h.

Constructor & Destructor Documentation

CWspHeaderWriter::~CWspHeaderWriter ( ) [virtual]

Intended Usage: Standard virtual destructor

Since:
7.0.

Precondition:
Fully constructed object
Postcondition:
Object is destroyed @cat Construction and Destruction

CWspHeaderWriter::CWspHeaderWriter | ( | RStringPool | aStrPool,
 |  | const TStringTable & | aStrTable,
 |  | CWspHeaderCodec & | aCodec
 | ) | [protected]

Intended Usage: Standard default constructor.

Since:
7.0
Parameters:
aStrPool | Handle to an opened string pool with the WSP string table already opened
aStrTable | The WSP string table to use for the header field names
aCodec | The codec that owns this header writer
Precondition:
None
Postcondition:
Object is constructed

Member Function Documentation

TInt CWspHeaderWriter::CheckTextString ( RStringF aTextString ) const [private]

Checks the passed in string for any invalid characters as specified in RFC2616.

TInt CWspHeaderWriter::CheckTokenText ( RStringF aTokenText ) const [private]

Checks the passed in string for any invalid characters as specified in RFC2616.

void CWspHeaderWriter::EncodeAcceptCharsetL ( RHeaderField & aHeader ) const [private]

Encodes the 'Accept-charset' header.

void CWspHeaderWriter::EncodeAcceptEncodingL ( RHeaderField & aHeader ) const [private]

Encodes the 'Accept-encoding' header.

void CWspHeaderWriter::EncodeAcceptL ( RHeaderField & aHeader ) const [private]

Encodes the 'Accept' header.

void CWspHeaderWriter::EncodeAcceptLanguageL ( RHeaderField & aHeader ) const [private]

Encodes the 'Accept-language' header.

void CWspHeaderWriter::EncodeAllowL ( RHeaderField & aHeader ) const [private]

Encodes the 'Allow' header.

void CWspHeaderWriter::EncodeAuthorizationL ( RHeaderField & aHeader ) const [private]

Encodes the 'Authorization' header.

void CWspHeaderWriter::EncodeContentEncodingL ( RHeaderField & aHeader ) const [private]

Encodes the 'Content-encoding' header.

void CWspHeaderWriter::EncodeContentLanguageL ( RHeaderField & aHeader ) const [private]

Encodes the 'Content-language' header.

void CWspHeaderWriter::EncodeContentLocationL ( RHeaderField & aHeader ) const [private]

Encodes the 'Content-location' header.

void CWspHeaderWriter::EncodeContentMD5L ( RHeaderField & aHeader ) const [private]

Encodes the 'Content-MD5' header.

void CWspHeaderWriter::EncodeContentRangeL ( RHeaderField & aHeader ) const [private]

Encodes the 'Content-range' header.

void CWspHeaderWriter::EncodeContentTypeL ( RHeaderField & aHeader ) const [private]

Encodes the 'Content-type' header.

TInt CWspHeaderWriter::EncodeContentTypeValue ( THTTPHdrVal & aContentType ) const [private]

Gets encoding for content-type text value with correct WSP version control.

Returns KErrNotFound if no encoding is available

void CWspHeaderWriter::EncodeCookieL ( RHeaderField & aHeader ) const [private]

Encodes the 'Cookie' header.

void CWspHeaderWriter::EncodeDateL ( RHeaderField & aHeader ) const [private]

Encodes the 'Date' header.

void CWspHeaderWriter::EncodeEncodingVersionL ( RHeaderField & aHeader ) const [private]

Encodes the 'Encoding-version' header.

void CWspHeaderWriter::EncodeExpectL ( RHeaderField & aHeader ) const [private]

Encodes the 'Expect' header.

CWspHeaderWriter::EncodeFieldName ( RStringF aFieldName ) const

Intended Usage: This method encodes the field name into its encoded token value.

For WSP transport the encoded token must be a short integer where the top bit is set to 1. This method will NOT set the top bit to 1.

Since:
7.0
Parameters:
aFieldName The name of the field to encode
Returns:
The encoded token value for the header field name. This value will always be between 0 and 127 inclusive or KErrNotFound if the header name does not have an encoded token value.

void CWspHeaderWriter::EncodeFromL ( RHeaderField & aHeader ) const [private]

Encodes the 'From' header.

CWspHeaderWriter::EncodeHeaderL ( RHeaderField & aHeader ) [virtual]

Intended Usage: This method will encode the header field that is passed in into its raw form.

Error Condition: Invalid or corrupt data formats and out of memeory conditions

Since:
7.0
Parameters:
aHeader The header field to encode
Precondition:
The header field is in its parsed state
Postcondition:
The header field is in its raw format state
Exceptions:
KErrNotSupported If the header field is not supported KErrNoMemory Out of memory conditions KErrCorrupt If the data is invalid or is corrupt

Implements CHeaderWriter.

TInt CWspHeaderWriter::EncodeHeaderNameL ( RHeaderField & aHeader ) const [private]

Encodes a header name.

The method returns an integer value of the length of the header name.

void CWspHeaderWriter::EncodeLastModifiedL ( RHeaderField & aHeader ) const [private]

Encodes the 'Last-modified' header.

void CWspHeaderWriter::EncodeParameterL | ( | const CHeaderFieldParam & | aHeaderFieldParam,
 |  | CWspHeaderEncoder & | aEncoder
 | ) | const [private]

Encodes a parameter value.

The method returns a heap based descriptor containing the encoded buffer. The caller takes ownership of the buffer.

TInt CWspHeaderWriter::EncodeParameterTokenValue ( RStringF aParameterName ) const [private]

void CWspHeaderWriter::EncodePragmaL ( RHeaderField & aHeader ) const [private]

Encodes the 'Pragma' header.

HBufC8* CWspHeaderWriter::EncodeQValueL ( RStringF aQValue ) const [private]

Encodes a single 'Q' value.

The method returns a heap based descriptor containing the encoded buffer. The caller takes ownership of the buffer.

void CWspHeaderWriter::EncodeRangeL ( RHeaderField & aHeader ) const [private]

Encodes the 'Range' header.

void CWspHeaderWriter::EncodeRefererL ( RHeaderField & aHeader ) const [private]

Encodes the 'Referer' header.

void CWspHeaderWriter::EncodeTEL ( RHeaderField & aHeader ) const [private]

Encodes the 'TE' header.

void CWspHeaderWriter::EncodeTrailerL ( RHeaderField & aHeader ) const [private]

Encodes the 'Trailer' header.

void CWspHeaderWriter::EncodeUpgradeL ( RHeaderField & aHeader ) const [private]

Encodes the 'Upgrade' header.

void CWspHeaderWriter::EncodeUserAgentL ( RHeaderField & aHeader ) const [private]

Encodes the 'User-agent' header.

TUint8 CWspHeaderWriter::EncodeVersionValueL ( RStringF aVersionValue ) const [private]

Encodes a single version value.

The method returns the encoded version value of the version passed in as a parameter in a string format. The method will return 0 if the version should be encoded as a text-value.

void CWspHeaderWriter::EncodeViaL ( RHeaderField & aHeader ) const [private]

Encodes the 'Via' header.

void CWspHeaderWriter::EncodeWarningL ( RHeaderField & aHeader ) const [private]

Encodes the 'Warning' header.

void CWspHeaderWriter::EncodeXWapApplicationIdL ( RHeaderField & aHeader ) const [private]

Encodes the 'X-Wap-Application-Id' header.

void CWspHeaderWriter::GenericEncodeDateL ( RHeaderField & aHeader ) const [private]

Encodes generic headers that have a date value.

void CWspHeaderWriter::GenericEncodeTextStringL ( RHeaderField & aHeader ) const [private]

Encodes generic headers that have a text string value.

TInt CWspHeaderWriter::GetCharacterSetValue ( RStringF aCharSet ) const [private]

Encodes a single character set value.

The method returns the encoded charset value of the passed in string.

CWspHeaderWriter * CWspHeaderWriter::NewL | ( | RStringPool | aStrPool,
 |  | const TStringTable & | aStrTable,
 |  | CWspHeaderCodec & | aCodec
 | ) | [static]

Intended Usage: Standard factory 2 phase construction Error Condition: Low memory conditions

Since:
7.0.

Parameters:
aStrPool | Handle to an opened string pool with the WSP string table already opened
aStrTable | The WSP string table to use for the header field names
aCodec | The codec that owns this header writer
Returns:
A pointer to the newly constructed class
Precondition:
None
Postcondition:
Object is constructed @cat Construction and Destruction

CWspHeaderWriter * CWspHeaderWriter::NewLC | ( | RStringPool | aStrPool,
 |  | const TStringTable & | aStrTable,
 |  | CWspHeaderCodec & | aCodec
 | ) | [static]

Intended Usage: Standard factory 2 phase construction leaving a handle on the cleanup stack.

Error Condition: Low memory conditions

Since:
7.0
Parameters:
aStrPool | Handle to an opened string pool with the WSP string table already opened
aStrTable | The WSP string table to use for the header field names
aCodec | The codec that owns this header writer
Returns:
A pointer to the newly constructed class
Precondition:
None
Postcondition:
Object is constructed with a handle on the cleanup stack @cat Construction and Destruction

Member Data Documentation

CWspHeaderCodec& CWspHeaderWriter::iCodec [private]

Definition at line 375 of file CWspHeaderWriter.h.

RStringPool CWspHeaderWriter::iStrPool [private]

Definition at line 369 of file CWspHeaderWriter.h.

const TStringTable& CWspHeaderWriter::iStrTable [private]

Definition at line 372 of file CWspHeaderWriter.h.

The documentation for this class was generated from the following file:
  • CWspHeaderWriter.h


Member List

CWspHeaderWriter Member List

This is the complete list of members for CWspHeaderWriter, including all inherited members.
CHeaderWriter() | CHeaderWriter | [protected]
CheckTextString(RStringF aTextString) const | CWspHeaderWriter | [private]
CheckTokenText(RStringF aTokenText) const | CWspHeaderWriter | [private]
ConstructL() | CHeaderWriter | [protected]
CWspHeaderWriter(RStringPool aStrPool, const TStringTable &aStrTable, CWspHeaderCodec &aCodec) | CWspHeaderWriter | [protected]
EncodeAcceptCharsetL(RHeaderField &aHeader) const | CWspHeaderWriter | [private]
EncodeAcceptEncodingL(RHeaderField &aHeader) const | CWspHeaderWriter | [private]
EncodeAcceptL(RHeaderField &aHeader) const | CWspHeaderWriter | [private]
EncodeAcceptLanguageL(RHeaderField &aHeader) const | CWspHeaderWriter | [private]
EncodeAllowL(RHeaderField &aHeader) const | CWspHeaderWriter | [private]
EncodeAuthorizationL(RHeaderField &aHeader) const | CWspHeaderWriter | [private]
EncodeContentEncodingL(RHeaderField &aHeader) const | CWspHeaderWriter | [private]
EncodeContentLanguageL(RHeaderField &aHeader) const | CWspHeaderWriter | [private]
EncodeContentLocationL(RHeaderField &aHeader) const | CWspHeaderWriter | [private]
EncodeContentMD5L(RHeaderField &aHeader) const | CWspHeaderWriter | [private]
EncodeContentRangeL(RHeaderField &aHeader) const | CWspHeaderWriter | [private]
EncodeContentTypeL(RHeaderField &aHeader) const | CWspHeaderWriter | [private]
EncodeContentTypeValue(THTTPHdrVal &aContentType) const | CWspHeaderWriter | [private]
EncodeCookieL(RHeaderField &aHeader) const | CWspHeaderWriter | [private]
EncodeDateL(RHeaderField &aHeader) const | CWspHeaderWriter | [private]
EncodeEncodingVersionL(RHeaderField &aHeader) const | CWspHeaderWriter | [private]
EncodeExpectL(RHeaderField &aHeader) const | CWspHeaderWriter | [private]
EncodeFieldName(RStringF aFieldName) const | CWspHeaderWriter |
EncodeFromL(RHeaderField &aHeader) const | CWspHeaderWriter | [private]
EncodeHeaderL(RHeaderField &aHeader) | CWspHeaderWriter | [virtual]
EncodeHeaderNameL(RHeaderField &aHeader) const | CWspHeaderWriter | [private]
EncodeLastModifiedL(RHeaderField &aHeader) const | CWspHeaderWriter | [private]
EncodeParameterL(const CHeaderFieldParam &aHeaderFieldParam, CWspHeaderEncoder &aEncoder) const | CWspHeaderWriter | [private]
EncodeParameterTokenValue(RStringF aParameterName) const | CWspHeaderWriter | [private]
EncodePragmaL(RHeaderField &aHeader) const | CWspHeaderWriter | [private]
EncodeQValueL(RStringF aQValue) const | CWspHeaderWriter | [private]
EncodeRangeL(RHeaderField &aHeader) const | CWspHeaderWriter | [private]
EncodeRefererL(RHeaderField &aHeader) const | CWspHeaderWriter | [private]
EncodeTEL(RHeaderField &aHeader) const | CWspHeaderWriter | [private]
EncodeTrailerL(RHeaderField &aHeader) const | CWspHeaderWriter | [private]
EncodeUpgradeL(RHeaderField &aHeader) const | CWspHeaderWriter | [private]
EncodeUserAgentL(RHeaderField &aHeader) const | CWspHeaderWriter | [private]
EncodeVersionValueL(RStringF aVersionValue) const | CWspHeaderWriter | [private]
EncodeViaL(RHeaderField &aHeader) const | CWspHeaderWriter | [private]
EncodeWarningL(RHeaderField &aHeader) const | CWspHeaderWriter | [private]
EncodeXWapApplicationIdL(RHeaderField &aHeader) const | CWspHeaderWriter | [private]
GenericEncodeDateL(RHeaderField &aHeader) const | CWspHeaderWriter | [private]
GenericEncodeTextStringL(RHeaderField &aHeader) const | CWspHeaderWriter | [private]
GetCharacterSetValue(RStringF aCharSet) const | CWspHeaderWriter | [private]
iCodec | CWspHeaderWriter | [private]
iStrPool | CWspHeaderWriter | [private]
iStrTable | CWspHeaderWriter | [private]
NewL(RStringPool aStrPool, const TStringTable &aStrTable, CWspHeaderCodec &aCodec) | CWspHeaderWriter | [static]
NewLC(RStringPool aStrPool, const TStringTable &aStrTable, CWspHeaderCodec &aCodec) | CWspHeaderWriter | [static]
~CHeaderWriter() | CHeaderWriter | [virtual]
~CWspHeaderWriter() | CWspHeaderWriter | [virtual]


CWspPrimitiveSender Class Reference

#include <CWspPrimitiveSender.h>

Collaboration diagram for CWspPrimitiveSender:

[legend]
List of all members.

Public Methods

~CWspPrimitiveSender ()
Intended Usage : Destructor.

void | InitiateSend (TWspPrimitive aPrimitive)
Intended Usage : Sets this object active and completes it self.

Static Public Methods

CWspPrimitiveSender * | NewL (MWspPrimitiveSenderCallback &aCallback)
Intended Usage : Static factory constructor.

Private Methods

virtual void | RunL ()
Intended Usage : Called by active schedule when the request is complete.

virtual TInt | RunError (TInt aError)
Intended Usage : Error handling function for when RunL() leaves.

virtual void | DoCancel ()
Intended Usage : Part of Active Objects framework.

CWspPrimitiveSender (MWspPrimitiveSenderCallback &aCallback)
Intended Usage : First phase constructor.

void | ConstructL ()

Private Attributes

MWspPrimitiveSenderCallback & iCallback
The callback object that will send the WSP primitive.

TWspPrimitive | iPrimitive
The primitive to be sent.

Detailed Description

Todo:
docing

Definition at line 19 of file CWspPrimitiveSender.h.

Constructor & Destructor Documentation

CWspPrimitiveSender::~CWspPrimitiveSender ( )

Intended Usage : Destructor.

Since:
7.0

CWspPrimitiveSender::CWspPrimitiveSender ( MWspPrimitiveSenderCallback & aCallback ) [private]

Intended Usage : First phase constructor.

Since:
7.0
Parameters:
aCallback A reference to the callback object that will send the WSP primitive.

Member Function Documentation

void CWspPrimitiveSender::ConstructL ( ) [private]

CWspPrimitiveSender::DoCancel ( ) [private, virtual]

Intended Usage : Part of Active Objects framework.

For this active object this function does nothing.

Since:
7.0

CWspPrimitiveSender::InitiateSend ( TWspPrimitive aPrimitive )

Intended Usage : Sets this object active and completes it self.

This ensures that the RunL() is entered as soon as possible after this function ends. The RunL() does the session connect.

Since:
7.0
Postcondition:
The embeddded active object has been set active and completed.

CWspPrimitiveSender::NewL ( MWspPrimitiveSenderCallback & aCallback ) [static]

Intended Usage : Static factory constructor.

Since:
7.0
Parameters:
aCallback A reference to the callback object that will send the WSP primitive.
Returns:
A pointer to a fully initialised object.

CWspPrimitiveSender::RunError ( TInt aError ) [private, virtual]

Intended Usage : Error handling function for when RunL() leaves.

Defers action to callback object.

Since:
7.0
Parameters:
aError The error with which RunL() left.
Returns:
An error code. If the input error value could be handled, then KErrNone is returned, otherwise the input error code is returned. This will cause a panic.

CWspPrimitiveSender::RunL ( ) [private, virtual]

Intended Usage : Called by active schedule when the request is complete.

This will invoke the callback object to send the WSP primitive.

Since:
7.0
Todo:
adds leaves
Precondition:
The request has been completed
Postcondition:
The WSP primitive has been sent.

Member Data Documentation

MWspPrimitiveSenderCallback& CWspPrimitiveSender::iCallback [private]

The callback object that will send the WSP primitive.

Definition at line 111 of file CWspPrimitiveSender.h.

TWspPrimitive CWspPrimitiveSender::iPrimitive [private]

The primitive to be sent.

Definition at line 116 of file CWspPrimitiveSender.h.

The documentation for this class was generated from the following file:
  • CWspPrimitiveSender.h


Member List

CWspPrimitiveSender Member List

This is the complete list of members for CWspPrimitiveSender, including all inherited members.
ConstructL() | CWspPrimitiveSender | [private]
CWspPrimitiveSender(MWspPrimitiveSenderCallback &aCallback) | CWspPrimitiveSender | [private]
DoCancel() | CWspPrimitiveSender | [private, virtual]
iCallback | CWspPrimitiveSender | [private]
InitiateSend(TWspPrimitive aPrimitive) | CWspPrimitiveSender |
iPrimitive | CWspPrimitiveSender | [private]
NewL(MWspPrimitiveSenderCallback &aCallback) | CWspPrimitiveSender | [static]
RunError(TInt aError) | CWspPrimitiveSender | [private, virtual]
RunL() | CWspPrimitiveSender | [private, virtual]
~CWspPrimitiveSender() | CWspPrimitiveSender |


MWspPrimitiveSenderCallback Class Reference

The MWspPrimitiveSenderCallback is used to perform an automatic session connect. More...

#include <MWspPrimitiveSenderCallback.h>

Inheritance diagram for MWspPrimitiveSenderCallback:

[legend]
List of all members.

Public Methods

virtual void | SendPrimitiveL (TWspPrimitive aPrimitive)=0
Intended Usage :
Since:
7.0.

virtual TInt | WspPrimitiveSenderCallbackError (TInt aError)=0
Intended Usage : Error handling function for when SendPrimitiveL() leaves.

Detailed Description

The MWspPrimitiveSenderCallback is used to perform an automatic session connect.

An active object uses this callback to send a WSP primitive.

Definition at line 19 of file MWspPrimitiveSenderCallback.h.

Member Function Documentation

MWspPrimitiveSenderCallback::SendPrimitiveL ( TWspPrimitive aPrimitive ) [pure virtual]

Intended Usage :

Since:
7.0.

Postcondition:
The specified primitive has been sent.

Implemented in CWspCOProtocolHandler, and CWspCOTransaction.

MWspPrimitiveSenderCallback::WspPrimitiveSenderCallbackError ( TInt aError ) [pure virtual]

Intended Usage : Error handling function for when SendPrimitiveL() leaves.

Since:
7.0
Parameters:
aError The error with which SendPrimitiveL() left.
Returns:
An error code. If the input error value could be handled, then KErrNone is returned, otherwise the input error code is returned.

Implemented in CWspCOProtocolHandler, and CWspCOTransaction.

The documentation for this class was generated from the following file:
  • MWspPrimitiveSenderCallback.h


Member List

MWspPrimitiveSenderCallback Member List

This is the complete list of members for MWspPrimitiveSenderCallback, including all inherited members.
SendPrimitiveL(TWspPrimitive aPrimitive)=0 | MWspPrimitiveSenderCallback | [pure virtual]
WspPrimitiveSenderCallbackError(TInt aError)=0 | MWspPrimitiveSenderCallback | [pure virtual]


CWspProxyInfoProvider Class Reference

The CWspProxyInfoProvider class implements the MWspProxyInfoProvider API. More...

#include <CWspProxyInfoProvider.h>

Inheritance diagram for CWspProxyInfoProvider:

[legend]
Collaboration diagram for CWspProxyInfoProvider:

[legend]
List of all members.

Public Methods

~CWspProxyInfoProvider ()
Intended Usage : Standard destructor.

void | UpdateProxyInfoL ()
Intended Usage : Updates the proxy info.

void | SetTemporaryRedirectedProxyL (TWspRedirectedAddress &aRedirectAddress)
void | SetPermanentRedirectedProxyL (TWspRedirectedAddress &aRedirectAddress)
TBool | ProxyInfoChangedAndUpdateL ()
Intended Usage : Checks the current proxy info against the proxy info specified by the client either through the HTTP session properties or the Comms Database.

void | UnlockProxyInfo ()
Intended Usage : Ensures that the next call to UpdateProxiInfoL actually does an update.

void | ResetProxyInfo ()

Static Public Methods

CWspProxyInfoProvider * | NewL (RHTTPSession aSession)
Intended Usage : Static factory constructor.

Private Methods

virtual const TDesC8 & | ProxyAddress () const
virtual TUint16 | RemotePort () const
virtual TUint16 | LocalPort () const
virtual TWspBearer | Bearer () const
virtual const TDesC8 & | ServiceCentreNumber () const
virtual TWspSession | WspSessionService () const
virtual TBool | SecureConnection () const
CWspProxyInfoProvider (RHTTPSession aSession)
Intended Usage : First phase constructor.

void | ChangeToRedirectedProxyInfoL (TWspRedirectedAddress &aRedirectAddress)
Intended Usage : Sets the currect proxy info to be that given the redirected address.

TProxyInfo | GetProxyInfoL () const
Intended Usage : Extracts the specified proxy info.

Static Private Methods

TWspSession | ExtractSessionTypeFromSession (RHTTPConnectionInfo aConnInfo, RStringPool aStringPool)
Extracts the WSP session type from the HTTP session properties set.

TWspBearer | ExtractBearerInfoFromSession (RHTTPConnectionInfo aConnInfo, RStringPool aStringPool)
Extracts the bearer type from the HTTP session properties set.

TBool | ExtractSecurityInfoFromSession (RHTTPConnectionInfo aConnInfo, RStringPool aStringPool)
Extracts the security info from the HTTP session properties set.

TUint16 | ExtractPortInfoFromSession (TInt aPortType, RHTTPConnectionInfo aConnInfo, RStringPool aStringPool)
Extracts the specified port number from the HTTP session properties set.

TUint16 | DefaultRemotePort (TBool aSecureConnection, TBool aCOConnection)
Gives the default remote port number given the security status and connection type, as specified by the WAP specs.

void | ReadWapAccessPointInfoL (RStringPool aStringPool, TWspBearer &aBearer, RStringF &aProxyAddress, TBool &aSecureConnection, RStringF &aServiceCentreNumber, TWspSession &aSessionServiceType)
Reads the connection information from the comms database file.

TWspRedirectedAddress | ExtractRedirectedProxyInfoL (RStringPool aStringPool, const TDesC8 &aRedirectedAddresses)
Extracts a redirected address data structure from the given data.

void | ReadServiceCentreNumberL (RStringPool aStringPool, RStringF &aServiceCentreNumber)
Extracts the (SMS) service centre number from the comms database.

Private Attributes

RHTTPSession iSession
The HTTP sessiom in use.

TProxyInfo iProxyInfo
The proxy info.

TBool | iProxyInfoLocked
A flag to indicate that the proxy info has already been updated and should not be changed on the next UpdateProcyInfoL call.

Detailed Description

The CWspProxyInfoProvider class implements the MWspProxyInfoProvider API.

The proxy information that is provided is obtained either from the HTTP session properties or from the Symbian OS Comms Database.

The EWspProxyAddress property must be set in the HTTP session for the proxy info not to be taken from the Comms Database. The other properties (described below) are optional. If these have been not set then the following defaults will bw applied; the session will be unsecured CO over IP.

The following HTTP properties define the proxy info;

1) EWspProxyAddress - a property of type RStringF that contains a bearer independent address.

2) EWspBearer - a property of type RStringF which should have a value of EWspIp for an IP (v4) bearer or a value of EWspSMS for an 8-bit WAP SMS bearer

3) EWspSecurity - a property of type RStringF which should contain the values EWspUseWtls, for a WTLS secured WSP session, or EWspDoNotUseWtls, for a non-secured WSP session.

4) EWspSessionType - a property of type RStringF that can have either the value EWspConnectionOriented for a CO session and a value of EWspConnectionless for a CL session.

For the case of an IP bearer, the following additional properties are required to be defined;

a) EWspLocalPort - a property of type TInt that contains the local port number. Defaulted at 0, which means that the transport handler will allocate an appropriate value.

b) EWspRemotePort - a property of type TInt that contains the remote port number. Default value depends of the security status of the session.

For the case of an SMS bearer, the following additional property is required to be defined;

a) EWspServiceNumber - a property of type RStringF that should contain the service centre number for the SMS bearer.

Definition at line 61 of file CWspProxyInfoProvider.h.

Constructor & Destructor Documentation

CWspProxyInfoProvider::~CWspProxyInfoProvider ( )

Intended Usage : Standard destructor.

Since:
7.0

CWspProxyInfoProvider::CWspProxyInfoProvider ( RHTTPSession aSession ) [private]

Intended Usage : First phase constructor.

Since:
7.0

Member Function Documentation

CWspProxyInfoProvider::Bearer ( ) const [private, virtual]

See also:
MWspProxyInfoProvider

Implements MWspProxyInfoProvider.

CWspProxyInfoProvider::ChangeToRedirectedProxyInfoL ( TWspRedirectedAddress & aRedirectedAddress ) [private]

Intended Usage : Sets the currect proxy info to be that given the redirected address.

Any fields that are not set in the redirected address are kept from the current proxy info.

Since:
7.0
Exceptions:
The function will leave if the redirected address info cannot be extracted from the supplied data.
Parameters:
aRedirectedAddress A structure containing a single parsed alternate address for the redirected proxy.
Postcondition:
The current proxy info contains the redirected proxt info.

CWspProxyInfoProvider::DefaultRemotePort | ( | TBool | aSecureConnection,
 |  | TBool | aCOConnection
 | ) | [static, private]

Gives the default remote port number given the security status and connection type, as specified by the WAP specs.

Since:
7.0
Parameters:
aConnInfo | The session properties for the current HTTP session.
aStringPool | The current string pool.
Returns:
A 16-bit unsigned integer with the default remote port number.

CWspProxyInfoProvider::ExtractBearerInfoFromSession | ( | RHTTPConnectionInfo | aConnInfo,
 |  | RStringPool | aStringPool
 | ) | [static, private]

Extracts the bearer type from the HTTP session properties set.

A default value of EIP is given if the bearer property is not present.

Since:
7.0
Parameters:
aConnInfo | The session properties for the current HTTP session.
aStringPool | The current string pool.
Returns:
The bearer type specified in the properties set.

CWspProxyInfoProvider::ExtractPortInfoFromSession | ( | TInt | aPortType,
 |  | RHTTPConnectionInfo | aConnInfo,
 |  | RStringPool | aStringPool
 | ) | [static, private]

Extracts the specified port number from the HTTP session properties set.

Can be either HTTP::ELocalPort or HTTP::ERemotePort. The default value of zero is given if the specified port property is not present.

Since:
7.0
Parameters:
aPortType | The specified port.
aConnInfo | The session properties for the current HTTP session.
aStringPool | The current string pool.
Returns:
A 16-bit unsigned integer with the port number extracted from the properties set.

CWspProxyInfoProvider::ExtractRedirectedProxyInfoL | ( | RStringPool | aStringPool,
 |  | const TDesC8 & | aRedirectedAddresses
 | ) | [static, private]

Extracts a redirected address data structure from the given data.

The redirected address data structure is defined by the WSP Specification, July 2001. The extracted information is returned in the TWspRedirectedAddress object. If there is more than one address in the data, then only the first redirected address is extracted. The remaining data is ignored.

Since:
7.0
Exceptions:
The function will leave with KWspErrBadRedirectedAddressData if the data is not correctly formed. If an unsupported bearer has been specified then the function will leave with KWspErrBearerNotSupported. The function will also leave if the RStringF for the proxy address fails to open.
Parameters:
aStringPool | The current string pool.
aRedirectedAddresses | A reference to the buffer containing the redirected addresses data.

CWspProxyInfoProvider::ExtractSecurityInfoFromSession | ( | RHTTPConnectionInfo | aConnInfo,
 |  | RStringPool | aStringPool
 | ) | [static, private]

Extracts the security info from the HTTP session properties set.

A default value of EFalse is given if the security info property is not present.

Since:
7.0
Parameters:
aConnInfo | The session properties for the current HTTP session.
aStringPool | The current string pool.
Returns:
A boolean value of ETrue of a security has been specified in the properties set.

CWspProxyInfoProvider::ExtractSessionTypeFromSession | ( | RHTTPConnectionInfo | aConnInfo,
 |  | RStringPool | aStringPool
 | ) | [static, private]

Extracts the WSP session type from the HTTP session properties set.

A default value of EWspConnectionOriented is given if the connection type property is not given.

Since:
7.0
Parameters:
aConnInfo | The session properties for the current HTTP session.
aStringPool | The current string pool.
Returns:
The WSP session type specified in the properties set.

CWspProxyInfoProvider::GetProxyInfoL ( ) const [private]

Intended Usage : Extracts the specified proxy info.

Checks the HTTP session properties for proxy info. If the proxy info has not been completely specified in the properties then the default WAP proxy in the Comms Database is used.

Since:
7.0
Exceptions:
The function will leave with KErrNotSupported if the Connectionless session service has been specified. It will also leave with KWspErrServiceNumberNotDefined if an SMS bearer has been specified and there is no Service Centre number defined. The function will leave if the proxy info cannot be extracted from the Comms DB.
Returns:
A TProxyInfo object that contains the proxy info.

CWspProxyInfoProvider::LocalPort ( ) const [private, virtual]

See also:
MWspProxyInfoProvider

Implements MWspProxyInfoProvider.

CWspProxyInfoProvider::NewL ( RHTTPSession aSession ) [static]

Intended Usage : Static factory constructor.

Since:
7.0
Parameters:
aSession The HTTP session in use.
Returns:
A pointer to a fully initialised object.

CWspProxyInfoProvider::ProxyAddress ( ) const [private, virtual]

See also:
MWspProxyInfoProvider

Implements MWspProxyInfoProvider.

CWspProxyInfoProvider::ProxyInfoChangedAndUpdateL ( )

Intended Usage : Checks the current proxy info against the proxy info specified by the client either through the HTTP session properties or the Comms Database.

Also updates the current proxy info if there has been a change. A flag is set indicating that the proxy info should not be updated on the next call to UpdateProxyInfoL.

Since:
7.0
Exceptions:
The function will leave if the proxy info cannot be obtained from either the Comms DB or from the HTTP session properties.
Returns:
A boolean value of ETrue if the current proxy info defers from the client specified proxy info.
Postcondition:
The proxy info has been updated. The next call to UpdateProxyInfoL will not cause the proxy info to be updated.

CWspProxyInfoProvider::ReadServiceCentreNumberL | ( | RStringPool | aStringPool,
 |  | RStringF & | aServiceCentreNumber
 | ) | [static, private]

Extracts the (SMS) service centre number from the comms database.

Since:
7.0
Parameters:
aStringPool | The current string pool.
aServiceCentreNumber | An output argument for the service centre number.

CWspProxyInfoProvider::ReadWapAccessPointInfoL | ( | RStringPool | aStringPool,
 |  | TWspBearer & | aBearer,
 |  | RStringF & | aProxyAddress,
 |  | TBool & | aSecureConnection,
 |  | RStringF & | aServiceCentreNumber,
 |  | TWspSession & | aSessionServiceType
 | ) | [static, private]

Reads the connection information from the comms database file.

Gives the bearer type, proxy address, security info, service centre number and connection type through the output arguments.

Since:
7.0
Parameters:
aStringPool | The current string pool.
aBearer | An output argument for the bearer type.
aProxyAddress | An output argument for the proxy address.
aSecureConnection | An output argument for the security info.
aServiceCentreNumber | An output argument for the service centre number.
aSessionServiceType | An output argument for the connection type.

CWspProxyInfoProvider::RemotePort ( ) const [private, virtual]

See also:
MWspProxyInfoProvider

Implements MWspProxyInfoProvider.

void CWspProxyInfoProvider::ResetProxyInfo ( )

CWspProxyInfoProvider::SecureConnection ( ) const [private, virtual]

See also:
MWspProxyInfoProvider

Implements MWspProxyInfoProvider.

CWspProxyInfoProvider::ServiceCentreNumber ( ) const [private, virtual]

See also:
MWspProxyInfoProvider

Implements MWspProxyInfoProvider.

void CWspProxyInfoProvider::SetPermanentRedirectedProxyL ( TWspRedirectedAddress & aRedirectAddress )

void CWspProxyInfoProvider::SetTemporaryRedirectedProxyL ( TWspRedirectedAddress & aRedirectAddress )

CWspProxyInfoProvider::UnlockProxyInfo ( )

Intended Usage : Ensures that the next call to UpdateProxiInfoL actually does an update.

Since:
7.0
Postcondition:
The proxy info is unlocked so that the next call to UpdateProxiInfoL actually does an update.

CWspProxyInfoProvider::UpdateProxyInfoL ( )

Intended Usage : Updates the proxy info.

If the client has specified proxy info in the session properties then that is the proxy info that is used. If no proxy info has been defined in the session properties, then the default WAP proxy in the Comms Database is used.

Since:
7.0
Exceptions:
The function will leave if the proxy info cannot be obtained from either the Comms DB or from the HTTP session properties.
Postcondition:
The proxy info has been updated.

CWspProxyInfoProvider::WspSessionService ( ) const [private, virtual]

See also:
MWspProxyInfoProvider

Implements MWspProxyInfoProvider.

Member Data Documentation

TProxyInfo CWspProxyInfoProvider::iProxyInfo [private]

The proxy info.

Definition at line 392 of file CWspProxyInfoProvider.h.

TBool CWspProxyInfoProvider::iProxyInfoLocked [private]

A flag to indicate that the proxy info has already been updated and should not be changed on the next UpdateProcyInfoL call.

Definition at line 398 of file CWspProxyInfoProvider.h.

RHTTPSession CWspProxyInfoProvider::iSession [private]

The HTTP sessiom in use.

This is not owned.

Definition at line 387 of file CWspProxyInfoProvider.h.

The documentation for this class was generated from the following file:
  • CWspProxyInfoProvider.h


Member List

CWspProxyInfoProvider Member List

This is the complete list of members for CWspProxyInfoProvider, including all inherited members.
Bearer() const | CWspProxyInfoProvider | [private, virtual]
ChangeToRedirectedProxyInfoL(TWspRedirectedAddress &aRedirectAddress) | CWspProxyInfoProvider | [private]
CWspProxyInfoProvider(RHTTPSession aSession) | CWspProxyInfoProvider | [private]
DefaultRemotePort(TBool aSecureConnection, TBool aCOConnection) | CWspProxyInfoProvider | [private, static]
ExtractBearerInfoFromSession(RHTTPConnectionInfo aConnInfo, RStringPool aStringPool) | CWspProxyInfoProvider | [private, static]
ExtractPortInfoFromSession(TInt aPortType, RHTTPConnectionInfo aConnInfo, RStringPool aStringPool) | CWspProxyInfoProvider | [private, static]
ExtractRedirectedProxyInfoL(RStringPool aStringPool, const TDesC8 &aRedirectedAddresses) | CWspProxyInfoProvider | [private, static]
ExtractSecurityInfoFromSession(RHTTPConnectionInfo aConnInfo, RStringPool aStringPool) | CWspProxyInfoProvider | [private, static]
ExtractSessionTypeFromSession(RHTTPConnectionInfo aConnInfo, RStringPool aStringPool) | CWspProxyInfoProvider | [private, static]
GetProxyInfoL() const | CWspProxyInfoProvider | [private]
iProxyInfo | CWspProxyInfoProvider | [private]
iProxyInfoLocked | CWspProxyInfoProvider | [private]
iSession | CWspProxyInfoProvider | [private]
LocalPort() const | CWspProxyInfoProvider | [private, virtual]
NewL(RHTTPSession aSession) | CWspProxyInfoProvider | [static]
ProxyAddress() const | CWspProxyInfoProvider | [private, virtual]
ProxyInfoChangedAndUpdateL() | CWspProxyInfoProvider |
ReadServiceCentreNumberL(RStringPool aStringPool, RStringF &aServiceCentreNumber) | CWspProxyInfoProvider | [private, static]
ReadWapAccessPointInfoL(RStringPool aStringPool, TWspBearer &aBearer, RStringF &aProxyAddress, TBool &aSecureConnection, RStringF &aServiceCentreNumber, TWspSession &aSessionServiceType) | CWspProxyInfoProvider | [private, static]
RemotePort() const | CWspProxyInfoProvider | [private, virtual]
ResetProxyInfo() | CWspProxyInfoProvider |
SecureConnection() const | CWspProxyInfoProvider | [private, virtual]
ServiceCentreNumber() const | CWspProxyInfoProvider | [private, virtual]
SetPermanentRedirectedProxyL(TWspRedirectedAddress &aRedirectAddress) | CWspProxyInfoProvider |
SetTemporaryRedirectedProxyL(TWspRedirectedAddress &aRedirectAddress) | CWspProxyInfoProvider |
UnlockProxyInfo() | CWspProxyInfoProvider |
UpdateProxyInfoL() | CWspProxyInfoProvider |
WspSessionService() const | CWspProxyInfoProvider | [private, virtual]
~CWspProxyInfoProvider() | CWspProxyInfoProvider |


MWspProxyInfoProvider Class Reference

@public
Since:
7.0 The MWspProxyInfoProvider API provides an interface to the bearer connection information that has been specified by the Client.
More...

#include <MWspProxyInfoProvider.h>

Inheritance diagram for MWspProxyInfoProvider:

[legend]
List of all members.

Public Methods

virtual const TDesC8 & | ProxyAddress () const=0
Intended Usage : Identifies the peer with which the WSP session is to be established.

virtual TUint16 | RemotePort () const=0
Intended Usage : Identifies the port on the remote peer with which the connection for the WSP session should be made.

virtual TUint16 | LocalPort () const=0
Intended Usage : Identifies the port on the local peer.

virtual TWspBearer | Bearer () const=0
Intended Usage : Identifies the type of bearer network which the Server address should be used with.

virtual const TDesC8 & | ServiceCentreNumber () const=0
Intended Usage : The telephone number for the SMS service centre.

virtual TWspSession | WspSessionService () const=0
Intended Usage : The type WSP Session Service set in the proxy info.

virtual TBool | SecureConnection () const=0
Intended Usage : Identifies the security to be used in the WSP session.

Detailed Description

@public
Since:
7.0 The MWspProxyInfoProvider API provides an interface to the bearer connection information that has been specified by the Client.

Definition at line 29 of file MWspProxyInfoProvider.h.

Member Function Documentation

MWspProxyInfoProvider::Bearer ( ) const [pure virtual]

Intended Usage : Identifies the type of bearer network which the Server address should be used with.

Since:
7.0
Returns:
An enum specifying the type of bearer network.

Implemented in CWspProxyInfoProvider.

MWspProxyInfoProvider::LocalPort ( ) const [pure virtual]

Intended Usage : Identifies the port on the local peer.

A value of zero is invalid and is used to indicate that either a port has not been specified or it is not relevant to the chosen bearer

Since:
7.0
Returns:
A word specifying the local port number

Implemented in CWspProxyInfoProvider.

MWspProxyInfoProvider::ProxyAddress ( ) const [pure virtual]

Intended Usage : Identifies the peer with which the WSP session is to be established.

The format of the this data is dependent on the type of bearer to be used in the connection. In the case of an SMS bearer, the Proxy peer is identified by a telephone number.

Since:
7.0
Returns:
A const reference to a buffer containing the proxy address.

Implemented in CWspProxyInfoProvider.

MWspProxyInfoProvider::RemotePort ( ) const [pure virtual]

Intended Usage : Identifies the port on the remote peer with which the connection for the WSP session should be made.

This is only relevant for certain bearers, e.g. IP bearer. A value of zero is invalid and is used to indicate that either a port has not been specified or it is not relevant to the chosen bearer

Since:
7.0
Returns:
A word specifying the remote port number.

Implemented in CWspProxyInfoProvider.

MWspProxyInfoProvider::SecureConnection ( ) const [pure virtual]

Intended Usage : Identifies the security to be used in the WSP session.

Since:
7.0
Returns:
A flag that indicates whether the WSP session is to be secured with WTLS or not.

Implemented in CWspProxyInfoProvider.

MWspProxyInfoProvider::ServiceCentreNumber ( ) const [pure virtual]

Intended Usage : The telephone number for the SMS service centre.

This is only relavent for an SMS bearer.

Since:
7.0
Returns:
A reference to a buffer containing the telephone number of the service centre.

Implemented in CWspProxyInfoProvider.

MWspProxyInfoProvider::WspSessionService ( ) const [pure virtual]

Intended Usage : The type WSP Session Service set in the proxy info.

This can be either ConnectionOriented or Connectionless.

Since:
7.0
Returns:
An enum specifying the Wsp Session Service type

Implemented in CWspProxyInfoProvider.

The documentation for this class was generated from the following file:
  • MWspProxyInfoProvider.h


Member List

MWspProxyInfoProvider Member List

This is the complete list of members for MWspProxyInfoProvider, including all inherited members.
Bearer() const=0 | MWspProxyInfoProvider | [pure virtual]
LocalPort() const=0 | MWspProxyInfoProvider | [pure virtual]
ProxyAddress() const=0 | MWspProxyInfoProvider | [pure virtual]
RemotePort() const=0 | MWspProxyInfoProvider | [pure virtual]
SecureConnection() const=0 | MWspProxyInfoProvider | [pure virtual]
ServiceCentreNumber() const=0 | MWspProxyInfoProvider | [pure virtual]
WspSessionService() const=0 | MWspProxyInfoProvider | [pure virtual]


TWspRedirectedAddress Class Reference

#include <WspTypes.h>

List of all members.

Public Attributes

TBool | iHasPort
A flag to indicate that the port field is set.

TBool | iHasBearer
A flag to indicate that the bearer field is set.

TBuf8< KMaxProxyAddrLen > | iProxyAddress
The proxy address.

TUint16 | iPort
The port number.

Wap::TWspBearer iBearer
The bearer type.

Member Data Documentation

Wap::TWspBearer TWspRedirectedAddress::iBearer

The bearer type.

Definition at line 396 of file WspTypes.h.

TBool TWspRedirectedAddress::iHasBearer

A flag to indicate that the bearer field is set.

Definition at line 381 of file WspTypes.h.

TBool TWspRedirectedAddress::iHasPort

A flag to indicate that the port field is set.

Definition at line 376 of file WspTypes.h.

TUint16 TWspRedirectedAddress::iPort

The port number.

Definition at line 391 of file WspTypes.h.

TBuf8<KMaxProxyAddrLen> TWspRedirectedAddress::iProxyAddress

The proxy address.

Definition at line 386 of file WspTypes.h.

The documentation for this class was generated from the following file:
  • WspTypes.h


Member List

TWspRedirectedAddress Member List

This is the complete list of members for TWspRedirectedAddress, including all inherited members.
iBearer | TWspRedirectedAddress
iHasBearer | TWspRedirectedAddress
iHasPort | TWspRedirectedAddress
iPort | TWspRedirectedAddress
iProxyAddress | TWspRedirectedAddress


MWspSessionHeadersProvider Class Reference

@public
Since:
7.0 The MWspSessionHeadersProvider API provides an interface for accessing and setting the Client and Server session headers, respectively.
More...

#include <MWspSessionHeadersProvider.h>

Inheritance diagram for MWspSessionHeadersProvider:

[legend]
List of all members.

Public Methods

virtual const TDesC8 & | ClientHeaders () const=0
Intended Usage : Provides the Client session headers as an encoded buffer.

virtual void | SetServerHeadersL (const TDesC8 &aBuffer)=0
Intended Usage : Sets the Server session headers.

Detailed Description

@public
Since:
7.0 The MWspSessionHeadersProvider API provides an interface for accessing and setting the Client and Server session headers, respectively.

The Client session headers can be accessed to send to the Server in the S-Connect.req primitive. Any header information that is returned from the Server in the S-Connect.cnf can be passed to the Client.

Definition at line 28 of file MWspSessionHeadersProvider.h.

Member Function Documentation

MWspSessionHeadersProvider::ClientHeaders ( ) const [pure virtual]

Intended Usage : Provides the Client session headers as an encoded buffer.

Since:
7.0
Returns:
A const reference to a buffer containing the encoded headers.

Implemented in CWspCOProtocolHandler.

MWspSessionHeadersProvider::SetServerHeadersL ( const TDesC8 & aBuffer ) [pure virtual]

Intended Usage : Sets the Server session headers.

Any headers returned from the Server are passed to the Client in their encoded form.

Since:
7.0 @leave Leave code KErrNoMemory if the headers cannot be set.
Parameters:
aBuffer A const reference to a buffer containing the encoded session headers from the Server.
Postcondition:
The Server session headers have been passed to the Client.

Implemented in CWspCOProtocolHandler.

The documentation for this class was generated from the following file:
  • MWspSessionHeadersProvider.h


Member List

MWspSessionHeadersProvider Member List

This is the complete list of members for MWspSessionHeadersProvider, including all inherited members.
ClientHeaders() const=0 | MWspSessionHeadersProvider | [pure virtual]
SetServerHeadersL(const TDesC8 &aBuffer)=0 | MWspSessionHeadersProvider | [pure virtual]


CWspTransportHandler Class Reference

@public
Since:
7.0 The WSP Transport Handler API.
More...

#include <CWspTransportHandler.h>

Inheritance diagram for CWspTransportHandler:

[legend]
Collaboration diagram for CWspTransportHandler:

[legend]
List of all members.

Public Types

typedef TUint8 | TWspSupportedServices
A bit-field type that is set to contain a union of the services supported by the WSP transport handler.

enum TWspService {
ECOSessionService = 0x01, ECOMethodInvocationService = 0x02, ECOPushService = 0x04, ECLSessionService = 0x08,
ECLPushService = 0x10
}
The five different service types that may be supported. More...

Public Methods

virtual | ~CWspTransportHandler ()
Intended Usage: Class destructor.

virtual TWspSupportedServices | SupportedServices () const=0
Intended Usage: Query the services supported by this instantiation of the WSP transport handler plug-in.

virtual TInt | ServerCert (TCertInfo &aCertInfo) const=0
Get the Server Certificate for the current session.

virtual MWspCOSessionInvoker & | COSessionInvoker ()=0
Intended Usage: Obtain the connection-oriented session invocation API.

virtual MWspCOMethodInvoker & | COTransactionInvoker ()=0
Intended Usage: Obtain the connection-oriented transaction invocation API.

virtual MWspCOPushInvoker & | COPushInvoker ()=0
Intended Usage: Obtain the connection-oriented push invocation API.

virtual MWspCLMethodInvoker & | CLMethodInvoker ()=0
Intended Usage: Obtain the connection-less method invocation API.

virtual MWspCLPushInvoker & | CLPushInvoker ()=0
Intended Usage: Obtain the connection-less push invocation API.

Static Public Methods

CWspTransportHandler * | NewL (RStringPool aStringPool, MSecurityPolicy *aSecurityPolicy, MWspCOSessionCallback &aSessionCB, MWspProxyInfoProvider &aProxyInfoProv, MWspCapabilityProvider &aCapProv, MWspSessionHeadersProvider &aSessHdrProv)
Intended Usage: Factory construction - instantiates the transport handler plug-in.

Protected Methods

CWspTransportHandler (RStringPool aStringPool, MSecurityPolicy *aSecurityPolicy, MWspCOSessionCallback &aSessionCB, MWspProxyInfoProvider &aProxyInfoProv, MWspCapabilityProvider &aCapProv, MWspSessionHeadersProvider &aSessHdrProv)

Protected Attributes

RStringPool | iStringPool
Handle for a string pool used by the WSP transport handler.

MSecurityPolicy * iSecurityPolicy
An optional security policy plug-in.

MWspCOSessionCallback & iSessionCB
The client's callback for session events.

MWspProxyInfoProvider & iProxyInfoProv
The client's provider of proxy information.

MWspCapabilityProvider & iCapProv
The client's provider of capabilities information.

MWspSessionHeadersProvider & iSessHdrProv
THe client's provider of session headers.

Private Attributes

TUid | iDtor_ID_Key
D'tor Key identification required for ECOM.

Detailed Description

@public
Since:
7.0 The WSP Transport Handler API.

The WSP TH provides its client with WSP services. It defines a set of interfaces that abstract the behaviour of the top-level of a WAP protocol stack - ie. the WSP layer.

Five distinct services are offered:

MWspCOSessionInvoker a Connection-Oriented Session service.

MWspCOMethodInvoker a Connection-Oriented Transaction service.

MWspCOPushInvoker a Connection-Oriented Push service.

MWspCLMethodInvoker a Connection-Less Session service.

MWspCLPushInvoker a Connection-Less Push service.

The API is specified as an ECOM interface. Specific implementations may offer some or all of the five services.

All implementations must provide default security policy settings via the MSecurityPolicy interface. The defaults shall be used when no security policy plug-in is supplied by the caller of CWspTransportHandler::NewL(). This might occur if the plug-in could not be located on the device,

Definition at line 60 of file CWspTransportHandler.h.

Member Typedef Documentation

typedef TUint8 CWspTransportHandler::TWspSupportedServices

A bit-field type that is set to contain a union of the services supported by the WSP transport handler.

Definition at line 67 of file CWspTransportHandler.h.

Member Enumeration Documentation

enum CWspTransportHandler::TWspService

The five different service types that may be supported.

Enumeration values:
ECOSessionService
ECOMethodInvocationService
ECOPushService
ECLSessionService
ECLPushService

Definition at line 71 of file CWspTransportHandler.h.

Constructor & Destructor Documentation

CWspTransportHandler::~CWspTransportHandler ( ) [inline, virtual]

Intended Usage: Class destructor.

Since:
7.0

CWspTransportHandler::CWspTransportHandler | ( | RStringPool | aStringPool,
 |  | MSecurityPolicy * | aSecurityPolicy,
 |  | MWspCOSessionCallback & | aSessionCB,
 |  | MWspProxyInfoProvider & | aProxyInfoProv,
 |  | MWspCapabilityProvider & | aCapProv,
 |  | MWspSessionHeadersProvider & | aSessHdrProv
 | ) | [inline, protected]

Member Function Documentation

MWspCLMethodInvoker & CWspTransportHandler::CLMethodInvoker ( ) [pure virtual]

Intended Usage: Obtain the connection-less method invocation API.

Since:
7.0
Returns:
The API object that should be used by the client for CL method invocations.
Exceptions:
This method will panic if the service isn't supported by a particular implementation of the API.

Implemented in CNwssWspTransportHandler.

MWspCLPushInvoker & CWspTransportHandler::CLPushInvoker ( ) [pure virtual]

Intended Usage: Obtain the connection-less push invocation API.

Since:
7.0
Returns:
The API object that should be used by the client to signal readiness to receive CL push invocations.
Exceptions:
This method will panic if the service isn't supported by a particular implementation of the API.

Implemented in CNwssWspTransportHandler.

MWspCOPushInvoker & CWspTransportHandler::COPushInvoker ( ) [pure virtual]

Intended Usage: Obtain the connection-oriented push invocation API.

Since:
7.0
Returns:
The API object that should be used by the client to signal readiness to receive CO push invocations.
Exceptions:
This method will panic if the service isn't supported by a particular implementation of the API.

Implemented in CNwssWspTransportHandler.

MWspCOSessionInvoker & CWspTransportHandler::COSessionInvoker ( ) [pure virtual]

Intended Usage: Obtain the connection-oriented session invocation API.

Since:
7.0
Returns:
The API object that should be used by the client for CO session invocations.
Exceptions:
This method will panic if the service isn't supported by a particular implementation of the API.

Implemented in CNwssWspTransportHandler.

MWspCOMethodInvoker & CWspTransportHandler::COTransactionInvoker ( ) [pure virtual]

Intended Usage: Obtain the connection-oriented transaction invocation API.

Since:
7.0
Returns:
The API object that should be used by the client for transaction invocations.
Exceptions:
This method will panic if the service isn't supported by a particular implementation of the API.

Implemented in CNwssWspTransportHandler.

static CWspTransportHandler * CWspTransportHandler::NewL | ( | RStringPool | aStringPool,
 |  | MSecurityPolicy * | aSecurityPolicy,
 |  | MWspCOSessionCallback & | aSessionCB,
 |  | MWspProxyInfoProvider & | aProxyInfoProv,
 |  | MWspCapabilityProvider & | aCapProv,
 |  | MWspSessionHeadersProvider & | aSessHdrProv
 | ) | [inline, static]

Intended Usage: Factory construction - instantiates the transport handler plug-in.

Since:
7.0
Parameters:
aStringPool | (in) An open string pool reference.
aSecurityPolicy | (in) (optional) A security policy provider
aSessionCB | (in) A client callback API for CO session events.
aProxyInfoProv | (in) A client API that provides WAP proxy details
aCapProv | (in) A client API for capability negotatiation.
aSessHdrProv | (in) A client API for exchange of session headers
Returns:
The constructed plug-in.
Exceptions:
KErrNotFound | - if an ECOM implementation of the interface is not present on the device.
It | could also leave with other ECOM error codes.

virtual TInt CWspTransportHandler::ServerCert ( TCertInfo & aCertInfo ) const [pure virtual]

Get the Server Certificate for the current session.

Parameters:
aServerCert A TCertInfo which will be filled with the certificate information
Returns:
An error code. KErrNone if aServerCert has been completed, otherwise one of the system wide error codes

Implemented in CNwssWspTransportHandler.

TWspSupportedServices CWspTransportHandler::SupportedServices ( ) const [pure virtual]

Intended Usage: Query the services supported by this instantiation of the WSP transport handler plug-in.

Since:
7.0
Returns:
A union of flags describing the services supported by the WSP transport handler

Implemented in CNwssWspTransportHandler.

Member Data Documentation

MWspCapabilityProvider& CWspTransportHandler::iCapProv [protected]

The client's provider of capabilities information.

Definition at line 267 of file CWspTransportHandler.h.

TUid CWspTransportHandler::iDtor_ID_Key [private]

D'tor Key identification required for ECOM.

For internal use only.

Definition at line 281 of file CWspTransportHandler.h.

MWspProxyInfoProvider& CWspTransportHandler::iProxyInfoProv [protected]

The client's provider of proxy information.

Definition at line 262 of file CWspTransportHandler.h.

MSecurityPolicy* CWspTransportHandler::iSecurityPolicy [protected]

An optional security policy plug-in.

If a plug-in was not supplied, the value is NULL.

Definition at line 252 of file CWspTransportHandler.h.

MWspSessionHeadersProvider& CWspTransportHandler::iSessHdrProv [protected]

THe client's provider of session headers.

Definition at line 272 of file CWspTransportHandler.h.

MWspCOSessionCallback& CWspTransportHandler::iSessionCB [protected]

The client's callback for session events.

Definition at line 257 of file CWspTransportHandler.h.

RStringPool CWspTransportHandler::iStringPool [protected]

Handle for a string pool used by the WSP transport handler.

This is owned and managed elsewhere.

Definition at line 246 of file CWspTransportHandler.h.

The documentation for this class was generated from the following file:
  • CWspTransportHandler.h


Member List

CWspTransportHandler Member List

This is the complete list of members for CWspTransportHandler, including all inherited members.
CancelValidateUntrustedServerCert()=0 | MSecurityPolicy | [pure virtual]
CLMethodInvoker()=0 | CWspTransportHandler | [pure virtual]
CLPushInvoker()=0 | CWspTransportHandler | [pure virtual]
COPushInvoker()=0 | CWspTransportHandler | [pure virtual]
COSessionInvoker()=0 | CWspTransportHandler | [pure virtual]
COTransactionInvoker()=0 | CWspTransportHandler | [pure virtual]
CWspTransportHandler(RStringPool aStringPool, MSecurityPolicy *aSecurityPolicy, MWspCOSessionCallback &aSessionCB, MWspProxyInfoProvider &aProxyInfoProv, MWspCapabilityProvider &aCapProv, MWspSessionHeadersProvider &aSessHdrProv) | CWspTransportHandler | [inline, protected]
ECLPushService enum value | CWspTransportHandler |
ECLSessionService enum value | CWspTransportHandler |
ECOMethodInvocationService enum value | CWspTransportHandler |
ECOPushService enum value | CWspTransportHandler |
ECOSessionService enum value | CWspTransportHandler |
GetNamedPolicyProperty(RStringF aPropertyName, RString &aPropertyValue)=0 | MSecurityPolicy | [pure virtual]
GetTlsCipherSuites()=0 | MSecurityPolicy | [pure virtual]
GetWtlsCipherSuites()=0 | MSecurityPolicy | [pure virtual]
GetWtlsKeyExchangeSuites()=0 | MSecurityPolicy | [pure virtual]
iCapProv | CWspTransportHandler | [protected]
iDtor_ID_Key | CWspTransportHandler | [private]
iProxyInfoProv | CWspTransportHandler | [protected]
iSecurityPolicy | CWspTransportHandler | [protected]
iSessHdrProv | CWspTransportHandler | [protected]
iSessionCB | CWspTransportHandler | [protected]
iStringPool | CWspTransportHandler | [protected]
NewL(RStringPool aStringPool, MSecurityPolicy *aSecurityPolicy, MWspCOSessionCallback &aSessionCB, MWspProxyInfoProvider &aProxyInfoProv, MWspCapabilityProvider &aCapProv, MWspSessionHeadersProvider &aSessHdrProv) | CWspTransportHandler | [inline, static]
Reserved1()=0 | MSecurityPolicy | [protected, pure virtual]
Reserved2()=0 | MSecurityPolicy | [protected, pure virtual]
ServerCert(TCertInfo &aCertInfo) const=0 | CWspTransportHandler | [pure virtual]
SupportedServices() const=0 | CWspTransportHandler | [pure virtual]
TWspService enum name | CWspTransportHandler |
TWspSupportedServices typedef | CWspTransportHandler |
ValidateUntrustedServerCert(TCertInfo &aServerCert, TRequestStatus &aStatus) const=0 | MSecurityPolicy | [pure virtual]
~CWspTransportHandler() | CWspTransportHandler | [inline, virtual]


CWspTransportHandler::SInstantiationParams Struct Reference

A structure containing the instantiation parameters to NewL, passed across via ECOM to the sub-class NewL. More...

#include <CWspTransportHandler.h>

Collaboration diagram for CWspTransportHandler::SInstantiationParams:

[legend]
List of all members.

Public Attributes

RStringPool * iStringPool
An open string pool reference.

MSecurityPolicy * iSecurityPolicy
The security policy plugin.

MWspCOSessionCallback * iSessionCB
A client callback API for CO session events.

MWspProxyInfoProvider * iProxyInfoProv
A client API that provides WAP proxy details.

MWspCapabilityProvider * iCapProv
A client API for capability negotatiation.

MWspSessionHeadersProvider * iSessHdrProv
A client API for exchange of session headers.

Detailed Description

A structure containing the instantiation parameters to NewL, passed across via ECOM to the sub-class NewL.

Definition at line 200 of file CWspTransportHandler.h.

Member Data Documentation

MWspCapabilityProvider* CWspTransportHandler::SInstantiationParams::iCapProv

A client API for capability negotatiation.

Definition at line 211 of file CWspTransportHandler.h.

MWspProxyInfoProvider* CWspTransportHandler::SInstantiationParams::iProxyInfoProv

A client API that provides WAP proxy details.

Definition at line 209 of file CWspTransportHandler.h.

MSecurityPolicy* CWspTransportHandler::SInstantiationParams::iSecurityPolicy

The security policy plugin.

Definition at line 205 of file CWspTransportHandler.h.

MWspSessionHeadersProvider* CWspTransportHandler::SInstantiationParams::iSessHdrProv

A client API for exchange of session headers.

Definition at line 213 of file CWspTransportHandler.h.

MWspCOSessionCallback* CWspTransportHandler::SInstantiationParams::iSessionCB

A client callback API for CO session events.

Definition at line 207 of file CWspTransportHandler.h.

RStringPool* CWspTransportHandler::SInstantiationParams::iStringPool

An open string pool reference.

Definition at line 203 of file CWspTransportHandler.h.

The documentation for this struct was generated from the following file:
  • CWspTransportHandler.h


Member List

CWspTransportHandler::SInstantiationParams Member List

This is the complete list of members for CWspTransportHandler::SInstantiationParams, including all inherited members.
iCapProv | CWspTransportHandler::SInstantiationParams
iProxyInfoProv | CWspTransportHandler::SInstantiationParams
iSecurityPolicy | CWspTransportHandler::SInstantiationParams
iSessHdrProv | CWspTransportHandler::SInstantiationParams
iSessionCB | CWspTransportHandler::SInstantiationParams
iStringPool | CWspTransportHandler::SInstantiationParams


MWspUnknownCapabilities Class Reference

@public
Since:
7.0 The MWspUnknownCapabilities API provides an interface to a set of unknown capabilities as defined by the WSP Specification, July 2001.
More...

#include <MWspUnknownCapabilities.h>

Inheritance diagram for MWspUnknownCapabilities:

[legend]
List of all members.

Public Methods

virtual TInt | Start () const=0
Intended Usage : Ensures that the first unknown capability in the set is available for reading.

virtual TInt | GetNext (TPtrC8 &aIdentifier, TPtrC8 &aValue) const=0
Intended Usage : Gets the next unknown capability in the set.

virtual void | Reset ()=0
Intended Usage : Resets the capability to the default.

virtual void | AddUnknownCapabilityL (const TDesC8 &aIdentifier, const TDesC8 &aValue)=0
Intended Usage : Adds an unknown capability to the set.

Detailed Description

@public
Since:
7.0 The MWspUnknownCapabilities API provides an interface to a set of unknown capabilities as defined by the WSP Specification, July 2001.

The Identifier is encoded in the same way as the header field name - it uses the BNF rule for Field-Name, as shown in the WSP Specification, Section 8.4.2.6. Well- known capabilities have their identifier encoded using a short-integer, and unknown capabilities encode their identifier using a Null-terminated string. Any extra capabilities must be defined in such a way that an empty parameter value is illegal. This allows the unknown capability to be rejected.

The interface allows the set of unknown capabilities to be accessed one by one. The read function provides the caller with a copy of the capability information. The set can be reset to the default value of the capability (as defined by the WSP Specification), which is an empty set. An unknown capability can be added to the set.

Definition at line 38 of file MWspUnknownCapabilities.h.

Member Function Documentation

MWspUnknownCapabilities::AddUnknownCapabilityL | ( | const TDesC8 & | aIdentifier,
 |  | const TDesC8 & | aValue
 | ) | [pure virtual]

Intended Usage : Adds an unknown capability to the set.

Since:
7.0 @leave Leave code KErrNoMemory if the capability cannot be added to the set.
Parameters:
aIdentifier | A buffer with the identifier for the unknown capability.
aValue | A buffer with the parameters for the capability.
Postcondition:
If no error has occurred then the unknown capability has been added.

Implemented in CWspUnknownCapabilities.

MWspUnknownCapabilities::GetNext | ( | TPtrC8 & | aIdentifier,
 |  | TPtrC8 & | aValue
 | ) | const [pure virtual]

Intended Usage : Gets the next unknown capability in the set.

If there are no unknown capabilities left then KErrNotFound error code is returned.

Since:
7.0
Parameters:
aIdentifier | An output parameter reference for a buffer with the identifier for the unknown capability.
aValue | An output parameter reference for a buffer with the parameters for the capability.
Returns:
An error code. If there are no unknown capabilities left, then the value returned is KErrNotFound. If there are unknown capabilities left then the value KErrNone is returned.
Postcondition:
The next unknown capability in the set is available for reading.

Implemented in CWspUnknownCapabilities.

MWspUnknownCapabilities::Reset ( ) [pure virtual]

Intended Usage : Resets the capability to the default.

The default is defined in the WSP Specification, July 2001, as being an empty set of code pages.

Since:
7.0
Postcondition:
The set of unknown capabilities is empty.

Implemented in CWspUnknownCapabilities.

MWspUnknownCapabilities::Start ( ) const [pure virtual]

Intended Usage : Ensures that the first unknown capability in the set is available for reading.

Since:
7.0
Returns:
An error code. If there are no unknown capabilities, then the value returned is KErrNotFound. If there are unknown capabilities then the value KErrNone is returned.
Postcondition:
The subsequent call to GetNext() is applied to the first unknown capability in the set.

Implemented in CWspUnknownCapabilities.

The documentation for this class was generated from the following file:
  • MWspUnknownCapabilities.h


Member List

MWspUnknownCapabilities Member List

This is the complete list of members for MWspUnknownCapabilities, including all inherited members.
AddUnknownCapabilityL(const TDesC8 &aIdentifier, const TDesC8 &aValue)=0 | MWspUnknownCapabilities | [pure virtual]
GetNext(TPtrC8 &aIdentifier, TPtrC8 &aValue) const=0 | MWspUnknownCapabilities | [pure virtual]
Reset()=0 | MWspUnknownCapabilities | [pure virtual]
Start() const=0 | MWspUnknownCapabilities | [pure virtual]


CWspUnknownCapabilities Class Reference

The CWspUnknownCapabilities class represents a set of Extended Methods capabilities. More...

#include <CWspUnknownCapabilities.h>

Inheritance diagram for CWspUnknownCapabilities:

[legend]
Collaboration diagram for CWspUnknownCapabilities:

[legend]
List of all members.

Public Methods

~CWspUnknownCapabilities ()
Standard destructor.

virtual TInt | Start () const
virtual TInt | GetNext (TPtrC8 &aIdentifier, TPtrC8 &aValue) const
virtual void | Reset ()
virtual void | AddUnknownCapabilityL (const TDesC8 &aIdentifier, const TDesC8 &aValue)

Static Public Methods

CWspUnknownCapabilities * | NewL ()
Static factory constructor.

Private Methods

CWspUnknownCapabilities ()
First phase constructor.

Private Attributes

RPointerArray< CUnknownCapability > | iUnknownCapabilities
An array of unknown capabilities.

TInt | iIndex
An index with the current position in the array.

Detailed Description

The CWspUnknownCapabilities class represents a set of Extended Methods capabilities.

It implements the MWspUnknownCapabilities interface.

See also:
MWspHeaderCoMWspUnknownCapabilitiesdePages

Definition at line 19 of file CWspUnknownCapabilities.h.

Constructor & Destructor Documentation

CWspUnknownCapabilities::~CWspUnknownCapabilities ( )

Standard destructor.

Since:
7.0

CWspUnknownCapabilities::CWspUnknownCapabilities ( ) [private]

First phase constructor.

Since:
7.0

Member Function Documentation

CWspUnknownCapabilities::AddUnknownCapabilityL | ( | const TDesC8 & | aIdentifier,
 |  | const TDesC8 & | aValue
 | ) | [virtual]

See also:
MWspUnknownCapabilities

Implements MWspUnknownCapabilities.

CWspUnknownCapabilities::GetNext | ( | TPtrC8 & | aIdentifier,
 |  | TPtrC8 & | aValue
 | ) | const [virtual]

See also:
MWspUnknownCapabilities

Implements MWspUnknownCapabilities.

CWspUnknownCapabilities::NewL ( ) [static]

Static factory constructor.

Since:
7.0

CWspUnknownCapabilities::Reset ( ) [virtual]

See also:
MWspUnknownCapabilities

Implements MWspUnknownCapabilities.

CWspUnknownCapabilities::Start ( ) const [virtual]

See also:
MWspUnknownCapabilities

Implements MWspUnknownCapabilities.

Member Data Documentation

TInt CWspUnknownCapabilities::iIndex [private]

An index with the current position in the array.

Is mutable to maintain logical const-ness.

Definition at line 83 of file CWspUnknownCapabilities.h.

RPointerArray<CUnknownCapability> CWspUnknownCapabilities::iUnknownCapabilities [private]

An array of unknown capabilities.

Definition at line 77 of file CWspUnknownCapabilities.h.

The documentation for this class was generated from the following file:
  • CWspUnknownCapabilities.h


Member List

CWspUnknownCapabilities Member List

This is the complete list of members for CWspUnknownCapabilities, including all inherited members.
AddUnknownCapabilityL(const TDesC8 &aIdentifier, const TDesC8 &aValue) | CWspUnknownCapabilities | [virtual]
CWspUnknownCapabilities() | CWspUnknownCapabilities | [private]
GetNext(TPtrC8 &aIdentifier, TPtrC8 &aValue) const | CWspUnknownCapabilities | [virtual]
iIndex | CWspUnknownCapabilities | [private]
iUnknownCapabilities | CWspUnknownCapabilities | [private]
NewL() | CWspUnknownCapabilities | [static]
Reset() | CWspUnknownCapabilities | [virtual]
Start() const | CWspUnknownCapabilities | [virtual]
~CWspUnknownCapabilities() | CWspUnknownCapabilities |


TWtlsCipherSuite Class Reference

The class TWtlsCipherSuite encapsulates a WTLS cipher suite as defined in the WAP WTLS Specification, July 2001 This is a pair made up of a Bulk Encryption Algorithm and a Mac Algorithm. More...

#include <WspTypes.h>

List of all members.

Public Types

enum TBulkEncryptionAlgorithm {
ENULL = 0, ERC5_CBC_40 = 1, ERC5_CBC_56 = 2, ERC5_CBC = 3,
EDES_CBC_40 = 4, EDES_CBC = 5, E3DES_CBC_EDE = 6, EIDEA_CBC_40 = 7,
EIDEA_CBC_56 = 8, EIDEA_CBC = 9, ERC5_CBC_64 = 10, EIDEA_CBC_64 = 11
}
enum TMacAlgorithm {
ESHA_0 = 0, ESHA_40 = 1, ESHA_80 = 2, ESHA = 3,
EMD5_40 = 5, EMD5_80 = 6, EMD5 = 7
}

Public Methods

TWtlsCipherSuite (TBulkEncryptionAlgorithm aBulkEncryptionAlgorithm, TMacAlgorithm aMacAlgorithm)

Public Attributes

TBulkEncryptionAlgorithm iBulkEncryptionAlgorithm
TMacAlgorithm iMacAlgorithm

Detailed Description

The class TWtlsCipherSuite encapsulates a WTLS cipher suite as defined in the WAP WTLS Specification, July 2001 This is a pair made up of a Bulk Encryption Algorithm and a Mac Algorithm.

Definition at line 455 of file WspTypes.h.

Member Enumeration Documentation

enum TWtlsCipherSuite::TBulkEncryptionAlgorithm

Enumeration values:
ENULL
ERC5_CBC_40
ERC5_CBC_56
ERC5_CBC
EDES_CBC_40
EDES_CBC
E3DES_CBC_EDE
EIDEA_CBC_40
EIDEA_CBC_56
EIDEA_CBC
ERC5_CBC_64
EIDEA_CBC_64

Definition at line 459 of file WspTypes.h.

enum TWtlsCipherSuite::TMacAlgorithm

Enumeration values:
ESHA_0
ESHA_40
ESHA_80
ESHA
EMD5_40
EMD5_80
EMD5

Definition at line 475 of file WspTypes.h.

Constructor & Destructor Documentation

TWtlsCipherSuite::TWtlsCipherSuite | ( | TBulkEncryptionAlgorithm | aBulkEncryptionAlgorithm,
 |  | TMacAlgorithm | aMacAlgorithm
 | ) | [inline]

Definition at line 494 of file WspTypes.h.

Member Data Documentation

TBulkEncryptionAlgorithm TWtlsCipherSuite::iBulkEncryptionAlgorithm

Definition at line 490 of file WspTypes.h.

TMacAlgorithm TWtlsCipherSuite::iMacAlgorithm

Definition at line 491 of file WspTypes.h.

The documentation for this class was generated from the following file:
  • WspTypes.h


Member List

TWtlsCipherSuite Member List

This is the complete list of members for TWtlsCipherSuite, including all inherited members.
E3DES_CBC_EDE enum value | TWtlsCipherSuite |
EDES_CBC enum value | TWtlsCipherSuite |
EDES_CBC_40 enum value | TWtlsCipherSuite |
EIDEA_CBC enum value | TWtlsCipherSuite |
EIDEA_CBC_40 enum value | TWtlsCipherSuite |
EIDEA_CBC_56 enum value | TWtlsCipherSuite |
EIDEA_CBC_64 enum value | TWtlsCipherSuite |
EMD5 enum value | TWtlsCipherSuite |
EMD5_40 enum value | TWtlsCipherSuite |
EMD5_80 enum value | TWtlsCipherSuite |
ENULL enum value | TWtlsCipherSuite |
ERC5_CBC enum value | TWtlsCipherSuite |
ERC5_CBC_40 enum value | TWtlsCipherSuite |
ERC5_CBC_56 enum value | TWtlsCipherSuite |
ERC5_CBC_64 enum value | TWtlsCipherSuite |
ESHA enum value | TWtlsCipherSuite |
ESHA_0 enum value | TWtlsCipherSuite |
ESHA_40 enum value | TWtlsCipherSuite |
ESHA_80 enum value | TWtlsCipherSuite |
iBulkEncryptionAlgorithm | TWtlsCipherSuite |
iMacAlgorithm | TWtlsCipherSuite |
TBulkEncryptionAlgorithm enum name | TWtlsCipherSuite |
TMacAlgorithm enum name | TWtlsCipherSuite |
TWtlsCipherSuite(TBulkEncryptionAlgorithm aBulkEncryptionAlgorithm, TMacAlgorithm aMacAlgorithm) | TWtlsCipherSuite | [inline]


TWtlsKeyExchangeSuite Class Reference

The class TWtlsKeyExchangeSuite contain the definitions of WTLS Key Exchange Suites as defined in the WAP WTLS Specification, July 2001. More...

#include <WspTypes.h>

List of all members.

Public Types

enum TKeyExchangeSuite {
ENULL = 0, ESHARED_SECRET = 1, EDH_anon = 2, EDH_anon_512 = 3,
EDH_anon_768 = 4, ERSA_anon = 5, ERSA_anon_512 = 6, ERSA_anon_768 = 7,
ERSA = 8, ERSA_512 = 9, ERSA_768 = 10, EECDH_anon = 11,
EECDH_anon_113 = 12, EECDH_anon_131 = 13, EECDH_ECDSA = 14, EECDH_anon_uncomp = 15,
EECDH_anon_uncomp_113 = 16, EECDH_anon_uncomp_131 = 17, EECDH_ECDSA_uncomp = 18
}
enum TKeyIdType {
EIdNull = 0, EText = 1, EBinary = 2, EKeyHashSha = 254,
EX509Name = 255
}

Public Methods

TWtlsKeyExchangeSuite (TKeyExchangeSuite aKeyExchangeSuite, TKeyIdType aKeyIdType, const TBuf8< KWtlsMaxKeyIdLength > &aKeyId)

Public Attributes

TKeyExchangeSuite iKeyExchangeSuite
TKeyIdType iKeyIdType
TBuf8< KWtlsMaxKeyIdLength > iKeyId

Detailed Description

The class TWtlsKeyExchangeSuite contain the definitions of WTLS Key Exchange Suites as defined in the WAP WTLS Specification, July 2001.

Definition at line 407 of file WspTypes.h.

Member Enumeration Documentation

enum TWtlsKeyExchangeSuite::TKeyExchangeSuite

Enumeration values:
ENULL
ESHARED_SECRET
EDH_anon
EDH_anon_512
EDH_anon_768
ERSA_anon
ERSA_anon_512
ERSA_anon_768
ERSA
ERSA_512
ERSA_768
EECDH_anon
EECDH_anon_113
EECDH_anon_131
EECDH_ECDSA
EECDH_anon_uncomp
EECDH_anon_uncomp_113
EECDH_anon_uncomp_131
EECDH_ECDSA_uncomp

Definition at line 410 of file WspTypes.h.

enum TWtlsKeyExchangeSuite::TKeyIdType

Enumeration values:
EIdNull
EText
EBinary
EKeyHashSha
EX509Name

Definition at line 432 of file WspTypes.h.

Constructor & Destructor Documentation

TWtlsKeyExchangeSuite::TWtlsKeyExchangeSuite | ( | TKeyExchangeSuite | aKeyExchangeSuite,
 |  | TKeyIdType | aKeyIdType,
 |  | const TBuf8< KWtlsMaxKeyIdLength > & | aKeyId
 | ) | [inline]

Definition at line 499 of file WspTypes.h.

Member Data Documentation

TKeyExchangeSuite TWtlsKeyExchangeSuite::iKeyExchangeSuite

Definition at line 445 of file WspTypes.h.

TBuf8<KWtlsMaxKeyIdLength> TWtlsKeyExchangeSuite::iKeyId

Definition at line 447 of file WspTypes.h.

TKeyIdType TWtlsKeyExchangeSuite::iKeyIdType

Definition at line 446 of file WspTypes.h.

The documentation for this class was generated from the following file:
  • WspTypes.h


Member List

TWtlsKeyExchangeSuite Member List

This is the complete list of members for TWtlsKeyExchangeSuite, including all inherited members.
EBinary enum value | TWtlsKeyExchangeSuite |
EDH_anon enum value | TWtlsKeyExchangeSuite |
EDH_anon_512 enum value | TWtlsKeyExchangeSuite |
EDH_anon_768 enum value | TWtlsKeyExchangeSuite |
EECDH_anon enum value | TWtlsKeyExchangeSuite |
EECDH_anon_113 enum value | TWtlsKeyExchangeSuite |
EECDH_anon_131 enum value | TWtlsKeyExchangeSuite |
EECDH_anon_uncomp enum value | TWtlsKeyExchangeSuite |
EECDH_anon_uncomp_113 enum value | TWtlsKeyExchangeSuite |
EECDH_anon_uncomp_131 enum value | TWtlsKeyExchangeSuite |
EECDH_ECDSA enum value | TWtlsKeyExchangeSuite |
EECDH_ECDSA_uncomp enum value | TWtlsKeyExchangeSuite |
EIdNull enum value | TWtlsKeyExchangeSuite |
EKeyHashSha enum value | TWtlsKeyExchangeSuite |
ENULL enum value | TWtlsKeyExchangeSuite |
ERSA enum value | TWtlsKeyExchangeSuite |
ERSA_512 enum value | TWtlsKeyExchangeSuite |
ERSA_768 enum value | TWtlsKeyExchangeSuite |
ERSA_anon enum value | TWtlsKeyExchangeSuite |
ERSA_anon_512 enum value | TWtlsKeyExchangeSuite |
ERSA_anon_768 enum value | TWtlsKeyExchangeSuite |
ESHARED_SECRET enum value | TWtlsKeyExchangeSuite |
EText enum value | TWtlsKeyExchangeSuite |
EX509Name enum value | TWtlsKeyExchangeSuite |
iKeyExchangeSuite | TWtlsKeyExchangeSuite |
iKeyId | TWtlsKeyExchangeSuite |
iKeyIdType | TWtlsKeyExchangeSuite |
TKeyExchangeSuite enum name | TWtlsKeyExchangeSuite |
TKeyIdType enum name | TWtlsKeyExchangeSuite |
TWtlsKeyExchangeSuite(TKeyExchangeSuite aKeyExchangeSuite, TKeyIdType aKeyIdType, const TBuf8< KWtlsMaxKeyIdLength > &aKeyId) | TWtlsKeyExchangeSuite | [inline]


Hierarchical Index

HTTP Transport Framework Internal Documentation Class Hierarchy

Go to the graphical class hierarchy

This inheritance list is sorted roughly, but not completely, alphabetically:

  • CAliasAddress
  • MHTTPAuthenticationCallback
    • CHttpClient
  • CAuthenticationFilter::TCredentials
  • CAuthenticationFilterInterface
    • CAuthenticationFilter
  • CAuthenticationFilterInterface::TAuthenticationParams
  • MComposerObserver
    • CTextModeTxData
  • MConnectInvokerCallback
  • MConnectionInfoProvider
    • CNwssWspTransportHandler
  • CConnectionTimer
  • MConnectionTimerCallback
    • CWspCOProtocolHandler
  • MHTTPDataSupplier
    • CHttpClient
    • CHTTPFormEncoder
    • CNwssWspTrHndDataSupplier
    • CRxData
      • CTextModeRxData
      • CWspCORxData
    • CTxData
      • CTextModeTxData
      • CWspCOTxData
  • CEComFilter
    • CRedirectFilter
    • CValidationFilter
  • THTTPEvent
    • THTTPSessionEvent
  • TEventRegistration
  • CExtendedMethod
  • TFCoreFiltersPanic
  • MHTTPFilterBase
    • MHTTPFilter
      • CAuthenticationFilter
      • CProtocolHandler
        • CTextModeHttpProt
        • CWspCOProtocolHandler
      • CRedirectFilter
      • CTextModeHeadersFilter
      • CValidationFilter
      • TClientFilter
  • RHTTPFilterCollection
  • TFilterConfigurationIterator
  • MHTTPFilterCreationCallback
  • THTTPFilterHandle
  • TFilterInformation
  • THTTPFilterIterator
  • TFilterRegistration
  • THTTPFilterRegistration
  • THTTPHdrFieldIter
  • THTTPHdrVal
  • THTTPHdrVal::TQConv
  • CHeaderCodec
    • CTextModeDefaultCodec
    • CTextModeHeaderCodec
    • CWspDefaultHeaderCodec
    • CWspHeaderCodec
  • CHeaderCodePage
  • CHeaderField
  • RHeaderField
  • CHeaderFieldParam
  • THeaderFieldParamIter
  • CHeaderFieldPart
  • THeaderFieldPartIter
  • CHeaderReader
    • CTextModeDefHdrReader
    • CTextModeHeaderReader
    • CWspDefaultHdrReader
    • CWspHeaderReader
  • RHTTPHeaders
  • CHeaders
  • CHeaders::THeaderFieldNamePair
  • CHeaderWriter
    • CTextModeDefHdrWriter
    • CTextModeHeaderWriter
    • CWspDefaultHdrWriter
    • CWspHeaderWriter
  • CHttpConnector
  • CHttpExampleUtils
  • THttpLogger
  • HTTPPanic
  • CHttpSocket
  • MHttpSocketObserver
    • CHttpTcpClient
  • HTTPStatus
  • CHttpTcpReader
  • CHttpTcpServerLocation
  • CHttpTcpWriter
  • CHTTPManager
  • RHTTPMessage
    • RHTTPRequest
    • RHTTPResponse
  • CMessage
    • CRequest
    • CResponse
  • CNwssConnectGuard
  • MNwssOomHandler
    • CNwssWspCOSession
  • MNwssSessionEventHandler
    • CNwssWspCOSession
    • CNwssWspSessionEventFilter
  • MNwssTransactionEventHandler
    • CNwssWspCOSession
    • CNwssWspTransactionEventFilter
  • CNwssTransLookUpTable
  • CNwssTransLookUpTable::CNwssTransLUTEntry
  • MNwssWapServer
    • CNwssWspTransportHandler
  • CNwssWspCOEventDispatcher
  • CNwssWspCOSession::TDelayedDisconnectPckg
  • CNwssWspCOSession::TDelayedMethodAbortPckg
  • CNwssWspSession
    • CNwssWspCOSession
  • TNwssWspTrHndPanic
  • RHTTPPropertySet
    • RHTTPConnectionInfo
    • RHTTPTransactionPropertySet
  • CProtTransaction
    • CTextModeProtTransaction
    • CWspCOTransaction
  • TProxyInfo
  • TRequestComposer
  • TRequestComposer::TChunkEncoder
  • TResponseParser
  • MRxDataObserver
    • CTextModeHttpProt
    • MWspCOMethodObserver
      • CWspCOProtocolHandler
  • MSecurityPolicy
    • CSecurityPolicy
    • CWspTransportHandler
      • CNwssWspTransportHandler
  • CHTTPSession
  • RHTTPSession
  • MHTTPSessionEventCallback
  • TSessionFilterInfo
  • MSessionPropertiesProvider
    • CTextModeHttpProt
  • CSubmissionDetails
  • CTCPClientFactory
  • TTextHeaderUtils
  • MTextModeTransportHandler
    • CHttpTcpClient
  • RHTTPTransaction
  • CTransaction
  • MHTTPTransactionCallback
    • CHttpEventHandler
    • TDummyTransactionCallback
  • MTransportHndObs
    • CTextModeRxData
  • CUnknownCapability
  • MWspAliasAddress
  • MWspAliasAddresses
    • CWspAliasAddresses
  • MWspCapabilityProvider
    • CWspCOProtocolHandler
  • MWspCapabilitySetter
    • CWspCapabilityInfo
  • MWspCapabilityViewer
    • CWspCapabilityInfo
  • MWspCLMethodCallback
  • MWspCLMethodInvoker
  • MWspCLPushCallback
  • MWspCLPushInvoker
  • MWspCOMethodCallback
    • CWspCOTransaction
  • MWspCOMethodInvoker
    • CNwssWspCOSession
  • MWspCOPushCallback
  • MWspCOPushInvoker
  • MWspCORxDataCallback
    • CWspCOTransaction
  • MWspCOSessionCallback
    • CWspCOProtocolHandler
  • MWspCOSessionInvoker
    • CNwssWspCOSession
  • MWspCOTxDataCallback
    • CWspCOTransaction
  • MWspExtendedMethods
    • CWspExtendedMethods
  • MWspHeaderCodePages
    • CWspHeaderCodePages
  • CWspHeaderUtils
  • CWspPrimitiveSender
  • MWspPrimitiveSenderCallback
    • CWspCOProtocolHandler
    • CWspCOTransaction
  • MWspProxyInfoProvider
    • CWspProxyInfoProvider
  • TWspRedirectedAddress
  • MWspSessionHeadersProvider
    • CWspCOProtocolHandler
  • CWspTransportHandler::SInstantiationParams
  • MWspUnknownCapabilities
    • CWspUnknownCapabilities
  • TWtlsCipherSuite
  • TWtlsKeyExchangeSuite


Compound Member Index

HTTP Transport Framework Internal Documentation Compound Members

a | b | c | d | e | f | g | h | i | k | l | m | n | o | p | q | r | s | t | u | v | w | ~

Here is a list of all class members with links to the class documentation for each member:

- a -

  • AbortInvoke() : MWspCOTxDataCallback, CWspCOTransaction
  • AbortRequest() : CWspCOTransaction
  • AbortResponse() : MWspCORxDataCallback, CWspCOTransaction
  • AckData() : CHttpTcpClient, MTextModeTransportHandler
  • Activate() : CTransaction
  • AddAddressL() : CWspAliasAddresses, MWspAliasAddresses
  • AddAliasAddressL() : CWspCapabilityInfo, MWspCapabilitySetter
  • AddBody() : CMessage
  • AddEvent() : CTransaction
  • AddExpect100ContinueL() : CTextModeHeadersFilter
  • AddExtendedMethodL() : CWspExtendedMethods, CWspCapabilityInfo, MWspExtendedMethods, MWspCapabilitySetter
  • AddFieldL() : CHTTPFormEncoder
  • AddFilterL() : RHTTPFilterCollection
  • AddHeaderCodePageL() : CWspHeaderCodePages, CWspCapabilityInfo, MWspHeaderCodePages, MWspCapabilitySetter
  • AddNewDecoderStringPartL() : CWspHeaderReader
  • AddParamL() : CHeaderFieldPart
  • AddPartL() : CHeaderField
  • AddSessionHeadersL() : CTextModeHeadersFilter
  • AddTransactionL() : CHTTPSession
  • AddUnknownCapabilityL() : CWspUnknownCapabilities, MWspUnknownCapabilities, MWspCapabilitySetter
  • AlterRequestHeadersL() : CTextModeHeadersFilter
  • AlterResponseHeadersL() : CTextModeHeadersFilter
  • AnonymousAuthenticationAllowed() : CNwssWspSession
  • AppendData() : CHTTPFormEncoder
  • AppendDataL() : TRequestComposer
  • AppendEvent() : CTransaction
  • AppendSpecialChar() : CHTTPFormEncoder
  • AtEnd() : THTTPHdrFieldIter, THTTPFilterIterator, TFilterConfigurationIterator, THeaderFieldParamIter, THeaderFieldPartIter
  • AtStart() : TFilterConfigurationIterator

- b -

  • BaseConstructL() : CNwssWspSession
  • Bearer() : CWspProxyInfoProvider, MWspProxyInfoProvider
  • BeginRawDataL() : RHeaderField, CHeaderField
  • Block() : CHTTPSession
  • Body() : TResponseParser, RHTTPMessage, CMessage

- c -

  • CalculateUIntVarLength() : CWspCOTxData
  • CAliasAddress() : CAliasAddress
  • Callback() : CTransaction
  • CanAddFilters() : CHTTPSession
  • Cancel() : RHTTPTransaction
  • CancelConnect() : CHttpSocket
  • CancelMethodInvoke() : MWspCLMethodInvoker
  • CancelPushListen() : MWspCOPushInvoker
  • CancelPushReceive() : MWspCLPushInvoker
  • CancelRecv() : CHttpSocket
  • CancelSubmission() : CHttpTcpClient, MTextModeTransportHandler
  • CancelTransaction() : CTransaction
  • CancelTransactionHook() : CWspCOProtocolHandler, CTextModeHttpProt, CProtocolHandler
  • CancelValidateUntrustedServerCert() : CNwssWspTransportHandler, CNwssWspSession, MSecurityPolicy
  • CancelWrite() : CHttpSocket
  • CancelWTLSConnectionPhaseOne() : CNwssWspSession
  • CancelWTLSConnectionPhaseTwo() : CNwssWspSession
  • CanChangeFilters() : RHTTPFilterCollection
  • CanDecode() : CWspDefaultHeaderCodec, CWspHeaderCodec, CTextModeDefaultCodec, CTextModeHeaderCodec, CHeaderCodec
  • CanEncode() : CWspDefaultHeaderCodec, CWspHeaderCodec, CTextModeDefaultCodec, CTextModeHeaderCodec, CHeaderCodec
  • CanResume() : CWspCOProtocolHandler
  • CanSuspend() : CWspCOProtocolHandler
  • CapabilityProvider() : MConnectionInfoProvider, CNwssWspTransportHandler
  • CAuthenticationFilter() : CAuthenticationFilter
  • CConnectionTimer() : CConnectionTimer
  • CExtendedMethod() : CExtendedMethod
  • CFilterConfigurationIterator_UnitTestContext : TFilterConfigurationIterator
  • ChangeToRedirectedProxyInfoL() : CWspProxyInfoProvider
  • CHeaderCodec() : CHeaderCodec
  • CHeaderCodePage() : CHeaderCodePage
  • CHeaderField() : CHeaderField
  • CHeaderFieldParam() : CHeaderFieldParam
  • CHeaderFieldPart : CHeaderFieldPart, RHTTPPropertySet
  • CHeaderReader() : CHeaderReader
  • CHeaders : CHeaders, RHTTPHeaders
  • CHeaderWriter() : CHeaderWriter
  • CheckClientCapabilities() : CWspCOProtocolHandler
  • CheckConnectResponseL() : CTextModeRxData, MTransportHndObs
  • CheckForNullStringL() : CWspHeaderReader
  • CheckInvalidation() : THTTPHdrFieldIter, THeaderFieldParamIter, THeaderFieldPartIter
  • CheckLengthL() : CWspHeaderReader
  • CheckNullDesPartL() : CWspHeaderReader
  • CheckTextString() : CWspHeaderWriter
  • CheckTokenText() : CWspHeaderWriter
  • CheckTrailer() : CWspCOTxData
  • CheckWaitingMethod() : CWspCOProtocolHandler
  • CHttpClient() : CHttpClient
  • CHttpConnector() : CHttpConnector
  • CHttpEventHandler() : CHttpEventHandler
  • CHttpExampleUtils() : CHttpExampleUtils
  • CHTTPFormEncoder() : CHTTPFormEncoder
  • CHTTPManager() : CHTTPManager
  • CHTTPSession : CHTTPSession, THTTPFilterHandle, TFilterConfigurationIterator, RHTTPSession, RHTTPPropertySet, RHTTPFilterCollection
  • CHttpSocket() : CHttpSocket
  • CHttpTcpClient() : CHttpTcpClient
  • CHttpTcpReader() : CHttpTcpReader
  • CHttpTcpServerLocation() : CHttpTcpServerLocation
  • CHttpTcpWriter() : CHttpTcpWriter
  • CleanListImplementationArray() : CHTTPSession
  • Cleanup() : CWspCOTxData
  • ClearParsedData() : CHeaderField
  • ClearRawData() : CHeaderField
  • ClientCapabilities() : CWspCOProtocolHandler, MWspCapabilityProvider
  • ClientHeaders() : CWspCOProtocolHandler, MWspSessionHeadersProvider
  • CLMethodInvoker() : CNwssWspTransportHandler, CWspTransportHandler
  • Close() : TProxyInfo, CHttpTcpClient, CHttpSocket, MTextModeTransportHandler, RHTTPTransaction, RHTTPSession, CTransaction
  • ClosedTransactionHook() : CWspCOProtocolHandler, CTextModeHttpProt, CProtocolHandler
  • ClosePropertySet() : CHeaderFieldPart
  • CloseWspSession() : CNwssWspSession, CNwssWspCOSession
  • CLPushInvoker() : CNwssWspTransportHandler, CWspTransportHandler
  • CNwssConnectGuard() : CNwssConnectGuard
  • CNwssTransLookUpTable() : CNwssTransLookUpTable
  • CNwssTransLUTEntry() : CNwssTransLookUpTable::CNwssTransLUTEntry
  • CNwssWspCOEventDispatcher() : CNwssWspCOEventDispatcher
  • CNwssWspCOSession() : CNwssWspCOSession
  • CNwssWspSession() : CNwssWspSession
  • CNwssWspSessionEventFilter() : CNwssWspSessionEventFilter
  • CNwssWspTransactionEventFilter() : CNwssWspTransactionEventFilter
  • CNwssWspTransportHandler() : CNwssWspTransportHandler
  • CNwssWspTrHndDataSupplier() : CNwssWspTrHndDataSupplier
  • Codec() : CProtocolHandler, CTransaction, CHTTPSession, CHeaders
  • Collection() : RHeaderField
  • CommitRawData() : RHeaderField, CHeaderField
  • CompareFieldNames() : CHeaders::THeaderFieldNamePair
  • CompleteProxyConnectionL() : CNwssWspSession, CNwssWspCOSession
  • CompleteSelf() : CNwssWspTransactionEventFilter, CNwssWspSessionEventFilter, CNwssWspSession, CNwssConnectGuard, CHttpTcpClient, CHttpConnector, CProtocolHandler
  • ComposeMoreDataL() : TRequestComposer
  • ComposeReqHeadersL() : TRequestComposer
  • ConfigureSessionFiltersL() : MHTTPFilterCreationCallback
  • ConfirmedPushInd() : MWspCOPushCallback
  • ConfirmedPushRes() : MWspCOPushInvoker
  • Connect() : CHttpSocket
  • ConnectCnf() : CWspCOProtocolHandler, MWspCOSessionCallback
  • ConnectInvokerCallbackError() : MConnectInvokerCallback
  • ConnectionInfo() : RHTTPSession, CHTTPSession
  • ConnectL() : CHttpConnector, RHTTPSession
  • ConnectReq() : CNwssWspCOSession, MWspCOSessionInvoker
  • ConstructL() : CHttpEventHandler, CHttpClient, CNwssWspTrHndDataSupplier, CNwssWspTransportHandler, CNwssWspTransactionEventFilter, CNwssWspCOSession, CNwssTransLookUpTable, CWspPrimitiveSender, CWspCOTransaction, CWspCOProtocolHandler, CUnknownCapability, CHeaderCodePage, CExtendedMethod, CConnectionTimer, CAliasAddress, CWspDefaultHeaderCodec, CWspHeaderCodec, CTCPClientFactory, CHttpTcpServerLocation, CHttpTcpClient, CHttpConnector, CTextModeTxData, CTextModeRxData, CTextModeHttpProt, CTextModeHeadersFilter, CTextModeDefaultCodec, CTextModeHeaderCodec, CValidationFilter, CRedirectFilter, CAuthenticationFilter, CTxData, CRxData, CProtocolHandler, CHeaderReader, CHeaderWriter, CHeaderCodec, CHTTPFormEncoder, CTransaction, CRequest, CMessage, CHTTPSession, CHTTPManager, CHeaderField
  • ConvertToParsedFormatL() : CHeaderField
  • ConvertToRawFormatL() : CHeaderField
  • COPushInvoker() : CNwssWspTransportHandler, CWspTransportHandler
  • Copy() : THTTPHdrVal
  • COSessionInvoker() : CNwssWspTransportHandler, CWspTransportHandler
  • COTransactionInvoker() : CNwssWspTransportHandler, CWspTransportHandler
  • CProtocolHandler() : CProtocolHandler
  • CProtTransaction() : CProtTransaction
  • CreateCodecL() : CWspCOProtocolHandler, CTextModeHttpProt, CProtocolHandler
  • CreateFlogger() : THttpLogger
  • CreateOrFindL() : CHTTPManager
  • CreateOrLookupFieldL() : CHeaders
  • CreateProtocolHandlerL() : CHTTPSession
  • CreateProtTransactionL() : CWspCOProtocolHandler, CTextModeHttpProt, CProtocolHandler
  • CreateRxDataL() : CWspCOTransaction, CTextModeProtTransaction, CProtTransaction
  • CreateTxDataL() : CWspCOTransaction, CTextModeProtTransaction, CProtTransaction
  • CreateWspTransportHandlerL() : CWspCOProtocolHandler
  • CRedirectFilter() : CRedirectFilter
  • CRequest : CRequest, RHTTPRequest
  • CResponse : CResponse, RHTTPResponse
  • CRxData() : CRxData
  • CSecurityPolicy() : CSecurityPolicy
  • CSubmissionDetails() : CSubmissionDetails
  • CTCPClientFactory() : CTCPClientFactory
  • CTextModeDefaultCodec() : CTextModeDefaultCodec
  • CTextModeDefHdrReader() : CTextModeDefHdrReader
  • CTextModeDefHdrWriter() : CTextModeDefHdrWriter
  • CTextModeHeaderCodec() : CTextModeHeaderCodec
  • CTextModeHeaderReader() : CTextModeHeaderReader
  • CTextModeHeadersFilter() : CTextModeHeadersFilter
  • CTextModeHeaderWriter() : CTextModeHeaderWriter
  • CTextModeHttpProt() : CTextModeHttpProt
  • CTextModeProtTransaction() : CTextModeProtTransaction
  • CTextModeRxData() : CTextModeRxData
  • CTextModeTxData() : CTextModeTxData
  • CTransaction : CTransaction, THTTPFilterHandle, RHTTPTransaction
  • CTxData() : CTxData
  • CUnknownCapability() : CUnknownCapability
  • CurrentEvent() : CTransaction
  • CurrentFilterInformation() : TFilterConfigurationIterator
  • CurrentLine() : TResponseParser
  • CValidationFilter() : CValidationFilter
  • CWspAliasAddresses() : CWspAliasAddresses
  • CWspCOProtocolHandler() : CWspCOProtocolHandler
  • CWspCORxData() : CWspCORxData
  • CWspCOTransaction() : CWspCOTransaction
  • CWspCOTxData() : CWspCOTxData
  • CWspDefaultHdrReader() : CWspDefaultHdrReader
  • CWspDefaultHdrWriter() : CWspDefaultHdrWriter
  • CWspDefaultHeaderCodec() : CWspDefaultHeaderCodec
  • CWspExtendedMethods() : CWspExtendedMethods
  • CWspHeaderCodec() : CWspHeaderCodec
  • CWspHeaderCodePages() : CWspHeaderCodePages
  • CWspHeaderReader() : CWspHeaderReader
  • CWspHeaderUtils() : CWspHeaderUtils
  • CWspHeaderWriter() : CWspHeaderWriter
  • CWspPrimitiveSender() : CWspPrimitiveSender
  • CWspProxyInfoProvider() : CWspProxyInfoProvider
  • CWspTransportHandler() : CWspTransportHandler
  • CWspUnknownCapabilities() : CWspUnknownCapabilities

- d -

  • DataL() : CTextModeRxData, MTransportHndObs
  • DateTime() : THTTPHdrVal
  • DecideObserverAction() : CWspCOTxData
  • DecodeAcceptRangesL() : CWspHeaderReader
  • DecodeAgeL() : CTextModeHeaderReader
  • DecodeAllowL() : CWspHeaderReader
  • DecodeCacheControlL() : CTextModeHeaderReader
  • DecodeContentEncodingL() : CWspHeaderReader
  • DecodeContentLanguageL() : CWspHeaderReader
  • DecodeContentLocationL() : CWspHeaderReader
  • DecodeContentMD5L() : CWspHeaderReader
  • DecodeContentRangeL() : CWspHeaderReader
  • DecodeContentTypeL() : CWspHeaderReader
  • DecodeDateL() : CWspHeaderReader
  • DecodeEncodingVersionL() : CWspHeaderReader
  • DecodeETagL() : CTextModeHeaderReader
  • DecodeGenericChallengeL() : CWspHeaderReader
  • DecodeGenericDateValueL() : CWspHeaderReader
  • DecodeGenericFieldNameL() : CWspHeaderReader
  • DecodeGenericIntegerValueL() : CWspHeaderReader
  • DecodeGenericL() : CTextModeHeaderReader
  • DecodeGenericNewStringValueL() : CWspHeaderReader
  • DecodeGenericNumberL() : CTextModeHeaderReader
  • DecodeGenericParamTokenL() : CWspHeaderReader
  • DecodeGenericSingleParameterL() : CWspHeaderReader
  • DecodeGenericVersionL() : CWspHeaderReader
  • DecodeGenericWarnCodeL() : CWspHeaderReader
  • DecodeHeaderL() : CWspDefaultHdrReader, CWspHeaderReader, CTextModeDefHdrReader, CTextModeHeaderReader, CHeaderReader, CHeaderCodec
  • DecodeHeadersL() : CWspHeaderUtils
  • DecodeLastModifiedL() : CWspHeaderReader
  • DecodeLocationL() : CWspHeaderReader
  • DecodeOneCookieL() : CTextModeHeaderReader
  • DecodePragmaL() : CWspHeaderReader
  • DecodeProxyAuthenticateL() : CWspHeaderReader
  • DecodePushFlagL() : CWspHeaderReader
  • DecodeReplyHeadersL() : CWspHeaderUtils
  • DecodeRetryAfterL() : CWspHeaderReader
  • DecodeServerL() : CWspHeaderReader
  • DecodeSetCookieL() : CWspHeaderReader, CTextModeHeaderReader
  • DecodeTrailerL() : CWspHeaderReader
  • DecodeUntypedParamL() : CWspHeaderReader
  • DecodeUpgradeL() : CWspHeaderReader
  • DecodeVaryL() : CWspHeaderReader
  • DecodeViaL() : CWspHeaderReader
  • DecodeWarningL() : CWspHeaderReader
  • DecodeWellKnownParamTokenL() : CWspHeaderReader
  • DecodeWWWAuthenticateL() : CWspHeaderReader
  • DecodeXWapApplicationIdL() : CWspHeaderReader
  • DecodeXWapInitiatorURIL() : CWspHeaderReader
  • DefaultRemotePort() : CWspProxyInfoProvider
  • DelayedSendOomDisconnect() : CNwssWspCOSession
  • DelayedSendOomMethodAbort() : CNwssWspCOSession
  • DetermineNextState() : CHttpTcpClient
  • DisconnectInd() : CWspCOProtocolHandler, MWspCOSessionCallback
  • DisconnectL() : RHTTPSession
  • DisconnectReq() : CNwssWspCOSession, MWspCOSessionInvoker
  • DisplayTimeElapsed() : CHttpClient
  • DoAcceptCharsetL() : CTextModeHeaderWriter
  • DoAcceptL() : CTextModeHeaderWriter
  • DoAuthorizationL() : CTextModeHeaderWriter
  • DoCacheControlL() : CTextModeHeaderReader
  • DoCancel() : CNwssWspTransactionEventFilter, CNwssWspSessionEventFilter, CNwssWspSession, CNwssWspCOEventDispatcher, CNwssConnectGuard, CWspPrimitiveSender, CHttpTcpWriter, CHttpTcpReader, CHttpTcpClient, CHttpConnector, CProtocolHandler, CTransaction
  • DoConnectionL() : CTextModeHeaderReader, CTextModeHeaderWriter
  • DoContentLengthL() : CTextModeHeaderWriter
  • DoContentTypeL() : CTextModeHeaderReader, CTextModeHeaderWriter
  • DoDateL() : CTextModeHeaderReader, CTextModeHeaderWriter
  • DoFoundBodyL() : CTextModeRxData
  • DoFoundHeaderFieldContinuationL() : CTextModeRxData
  • DoFoundHeaderFieldL() : CTextModeRxData
  • DoFoundLineSeparatorL() : CTextModeRxData
  • DoGeneralAcceptHeaderL() : CTextModeHeaderWriter
  • DoHostL() : CTextModeHeaderWriter
  • DoInsertInNameOrderL() : CHeaders
  • DoRunError() : CNwssWspSession, CNwssWspCOSession
  • DoSendDisconnectInd() : CNwssWspCOSession
  • DoSessionConnected() : CWspCOProtocolHandler
  • DoSessionConnectedL() : CWspCOProtocolHandler
  • DoTokenCsvListHeaderL() : CTextModeHeaderWriter
  • DoTokenListHeaderL() : CTextModeHeaderWriter
  • DoTransferEncodingL() : CTextModeHeaderReader, CTextModeHeaderWriter
  • DoUserAgentL() : CTextModeHeaderWriter
  • DoWTLSConnectionPhaseOne() : CNwssWspSession
  • DoWTLSConnectionPhaseTwo() : CNwssWspSession
  • DoWTLSConnectionPostHandshakeL() : CNwssWspSession
  • DoWTLSConnectionPreHandshakeL() : CNwssWspSession
  • DoWWWAuthenticateL() : CTextModeHeaderReader
  • DumpIt() : CHttpEventHandler, THttpLogger
  • DumpRespBody() : CHttpEventHandler
  • DumpRespHeadersL() : CHttpEventHandler

- e -

  • E3DES_CBC_EDE : TWtlsCipherSuite
  • EAbortMethod : CWspCOTxData
  • EAccepted : HTTPStatus
  • EActive : CProtTransaction
  • EAddingFilterWithOutstandingTransactions : HTTPPanic
  • EAll : THTTPEvent
  • EAllowAppendData : CHTTPFormEncoder
  • EAlreadyConnected : THTTPSessionEvent
  • EAlreadyConnecting : THTTPSessionEvent
  • EAlreadyDisconnected : THTTPSessionEvent
  • EAlreadyDisconnecting : THTTPSessionEvent
  • EAnySessionEvent : THTTPEvent
  • EAnyTransactionEvent : THTTPEvent
  • EAuthenticatedOK : THTTPSessionEvent
  • EAuthenticationFailure : THTTPSessionEvent
  • EAuthenticationFilterBadState : TFCoreFiltersPanic, HTTPPanic
  • EAwaitingDNS : CHttpTcpClient
  • EBadConnection : TNwssWspTrHndPanic
  • EBadGateway : HTTPStatus
  • EBadRequest : HTTPStatus
  • EBearerError : TNwssWspTrHndPanic
  • EBinary : TWtlsKeyExchangeSuite
  • EBlankLineCount : CTextModeRxData
  • EBlocked : CTransaction
  • EBufferTooSmall : TNwssWspTrHndPanic
  • ECache : MHTTPFilter
  • ECancel : THTTPEvent
  • ECancelled : CProtTransaction, CTransaction
  • ECannotOpenPort : TNwssWspTrHndPanic
  • ECapabilityOverrun : TNwssWspTrHndPanic
  • ECheckingNegotiated : CNwssWspSession
  • ECheckingServerCert : CNwssWspSession
  • EClient : THTTPFilterHandle, MHTTPFilter
  • EClientFilters : MHTTPFilter
  • EClosed : THTTPEvent
  • ECLPushService : CWspTransportHandler
  • ECLSessionService : CWspTransportHandler
  • ECOMethodInvocationService : CWspTransportHandler
  • ECompleted : CProtTransaction
  • EConflict : HTTPStatus
  • ECongestion : CNwssWspCOSession
  • EConnect : THTTPSessionEvent
  • EConnected : CHttpTcpClient
  • EConnectedAndAvailable : MTextModeTransportHandler
  • EConnectedNotAvailable : MTextModeTransportHandler
  • EConnectedOK : THTTPSessionEvent
  • EConnectedUponDestruction : TNwssWspTrHndPanic
  • EConnectedWithReducedCapabilities : THTTPSessionEvent
  • EConnectErr : CNwssWspCOSession
  • EConnectionLessNotSupported : TNwssWspTrHndPanic
  • EConnectionTimedOut : THTTPSessionEvent
  • EContinue : HTTPStatus
  • ECookies : MHTTPFilter
  • ECOPushNotSupported : TNwssWspTrHndPanic
  • ECOPushService : CWspTransportHandler
  • ECOSessionService : CWspTransportHandler
  • ECreated : HTTPStatus
  • ECurrentFilter : THTTPFilterHandle
  • EDataInRawForm : CHeaderField
  • EDataNotAvailable : TNwssWspTrHndPanic
  • EDataParsedOK : CHeaderField
  • EDataParseError : CHeaderField
  • EDataReleased : CHTTPFormEncoder
  • EDeferedMethodFailed : TNwssWspTrHndPanic
  • EDES_CBC : TWtlsCipherSuite
  • EDES_CBC_40 : TWtlsCipherSuite
  • EDH_anon : TWtlsKeyExchangeSuite
  • EDH_anon_512 : TWtlsKeyExchangeSuite
  • EDH_anon_768 : TWtlsKeyExchangeSuite
  • EDisconnect : CNwssWspCOSession, THTTPSessionEvent
  • EDisconnected : CNwssWspSession, CHttpTcpClient, THTTPSessionEvent
  • EDoingWtlsPhase1 : CNwssWspSession
  • EDoingWtlsPhase2 : CNwssWspSession
  • EDone : CWspCOTxData
  • EDoSecureHandshake : CHttpTcpClient
  • EECDH_anon : TWtlsKeyExchangeSuite
  • EECDH_anon_113 : TWtlsKeyExchangeSuite
  • EECDH_anon_131 : TWtlsKeyExchangeSuite
  • EECDH_anon_uncomp : TWtlsKeyExchangeSuite
  • EECDH_anon_uncomp_113 : TWtlsKeyExchangeSuite
  • EECDH_anon_uncomp_131 : TWtlsKeyExchangeSuite
  • EECDH_ECDSA : TWtlsKeyExchangeSuite
  • EECDH_ECDSA_uncomp : TWtlsKeyExchangeSuite
  • EErrorTimeout : TNwssWspTrHndPanic
  • EEventOnUnknownTransaction : TNwssWspTrHndPanic
  • EExceptionInfo : THTTPSessionEvent
  • EExiting : CTransaction
  • EExpectationFailed : HTTPStatus
  • EExplicit : TSessionFilterInfo
  • EExplicitFilter : TFilterInformation
  • EFailed : THTTPEvent
  • EFailedToAbortTrans : TNwssWspTrHndPanic
  • EFailedToAcknowledgeTrans : TNwssWspTrHndPanic
  • EFailedToGetSessionData : TNwssWspTrHndPanic
  • EFailedToGetTransactionData : TNwssWspTrHndPanic
  • EFailedToOpenWspSession : TNwssWspTrHndPanic
  • EFailedToReleaseTrans : TNwssWspTrHndPanic
  • EFilter : CTransaction
  • EFilterInvalidPosition : HTTPPanic
  • EFirstBlankLine : CTextModeRxData
  • EForbidden : HTTPStatus
  • EFound : HTTPStatus
  • EGatewayTimeout : HTTPStatus
  • EGet : CHttpClient
  • EGone : HTTPStatus
  • EGotMoreData : CWspCOTxData
  • EGotResponseBodyData : THTTPEvent
  • EGotResponseHeaders : THTTPEvent
  • EGotResponseTrailerHeaders : THTTPEvent
  • EHasBlocked : CHTTPSession
  • EHead : CHttpClient
  • EHeaderFieldMissing : HTTPPanic
  • EHeaderInvalidPart : HTTPPanic
  • EHeaderInvalidType : HTTPPanic
  • EHeaderParamMissing : HTTPPanic
  • EHTTPFormDataUnreleased : HTTPPanic
  • EHTTPFormSupplyingData : HTTPPanic
  • EHTTPVersionNotSupported : HTTPStatus
  • EIDEA_CBC : TWtlsCipherSuite
  • EIDEA_CBC_40 : TWtlsCipherSuite
  • EIDEA_CBC_56 : TWtlsCipherSuite
  • EIDEA_CBC_64 : TWtlsCipherSuite
  • EIdle : CWspCOTxData, CHttpTcpClient
  • EIdleListening : CHttpTcpClient
  • EIdNull : TWtlsKeyExchangeSuite
  • EImplicit : TSessionFilterInfo
  • EImplicitFilter : TFilterInformation
  • EIncoming : THTTPEvent
  • EInFilter : CTransaction
  • EInsufficientCryptoStrength : TNwssWspTrHndPanic
  • EInternalCapCodecError : TNwssWspTrHndPanic
  • EInternalServerError : HTTPStatus
  • EInvalidBufferSize : TNwssWspTrHndPanic
  • EInvalidFilterHandle : HTTPPanic
  • EInvalidMaxRedirectProperty : TFCoreFiltersPanic
  • EInvalidRedirectCountProperty : TFCoreFiltersPanic
  • EInvalidRxData : HTTPPanic
  • EInvalidSession : TNwssWspTrHndPanic
  • EInvalidState : TNwssWspTrHndPanic
  • EInvalidTransaction : TNwssWspTrHndPanic
  • EInvalidTransactionInLUT : TNwssWspTrHndPanic
  • EInvalidTxData : HTTPPanic
  • EKeyHashSha : TWtlsKeyExchangeSuite
  • ELargeDataTransferNotSupported : TNwssWspTrHndPanic
  • ELengthRequired : HTTPStatus
  • EMadeCONNECT : CHttpTcpClient
  • EMandatory : TSessionFilterInfo
  • EMD5 : TWtlsCipherSuite
  • EMD5_40 : TWtlsCipherSuite
  • EMD5_80 : TWtlsCipherSuite
  • EMethodNotAllowed : HTTPStatus
  • EMoreDataReceivedThanExpected : THTTPEvent
  • EMORExceeded : TNwssWspTrHndPanic, CNwssWspCOSession
  • EMovedPermanently : HTTPStatus
  • EMRUExceeded : TNwssWspTrHndPanic, CNwssWspCOSession
  • EMultipleChoices : HTTPStatus
  • EncodeAcceptCharsetL() : CWspHeaderWriter
  • EncodeAcceptEncodingL() : CWspHeaderWriter
  • EncodeAcceptL() : CWspHeaderWriter
  • EncodeAcceptLanguageL() : CWspHeaderWriter
  • EncodeAllowL() : CWspHeaderWriter
  • EncodeAuthorizationL() : CWspHeaderWriter
  • EncodeBasicAuthL() : CAuthenticationFilter
  • EncodeCacheControlL() : CTextModeHeaderWriter
  • EncodeContentEncodingL() : CWspHeaderWriter
  • EncodeContentLanguageL() : CWspHeaderWriter
  • EncodeContentLocationL() : CWspHeaderWriter
  • EncodeContentMD5L() : CWspHeaderWriter
  • EncodeContentRangeL() : CWspHeaderWriter
  • EncodeContentTypeL() : CWspHeaderUtils, CWspHeaderWriter
  • EncodeContentTypeValue() : CWspHeaderWriter
  • EncodeCookieL() : CWspHeaderWriter, CTextModeHeaderWriter
  • EncodeDataL() : TRequestComposer::TChunkEncoder
  • EncodeDateL() : CWspHeaderWriter
  • EncodeDigestAuthL() : CAuthenticationFilter
  • EncodeEncodingVersionL() : CWspHeaderWriter
  • EncodeExpectL() : CWspHeaderWriter
  • EncodeFieldName() : CWspHeaderWriter, CWspHeaderCodec
  • EncodeFromL() : CWspHeaderWriter
  • EncodeGenericDateL() : CTextModeHeaderWriter
  • EncodeGenericNumberHeaderL() : CTextModeHeaderWriter
  • EncodeHeaderFieldL() : CWspHeaderUtils
  • EncodeHeaderL() : CWspDefaultHdrWriter, CWspHeaderWriter, CTextModeDefHdrWriter, CTextModeHeaderWriter, CHeaderWriter, CHeaderCodec
  • EncodeHeaderNameL() : CWspHeaderWriter
  • EncodeHeadersL() : CWspHeaderUtils, CWspCOTxData
  • EncodeLastModifiedL() : CWspHeaderWriter
  • EncodeNoTrailerHeadersL() : CWspHeaderUtils
  • EncodeOneCookieAttributeL() : CTextModeHeaderWriter
  • EncodeOneCookieL() : CTextModeHeaderWriter
  • EncodeParameterL() : CWspHeaderWriter
  • EncodeParameterTokenValue() : CWspHeaderWriter
  • EncodePragmaL() : CWspHeaderWriter, CTextModeHeaderWriter
  • EncodeQValueL() : CWspHeaderWriter
  • EncodeRangeL() : CWspHeaderWriter
  • EncodeRefererL() : CWspHeaderWriter
  • EncodeTEL() : CWspHeaderWriter
  • EncodeTrailerL() : CWspHeaderWriter
  • EncodeUpgradeL() : CWspHeaderWriter
  • EncodeUserAgentL() : CWspHeaderWriter
  • EncodeVersionValueL() : CWspHeaderWriter
  • EncodeViaL() : CWspHeaderWriter
  • EncodeWarningL() : CWspHeaderWriter
  • EncodeXWapApplicationIdL() : CWspHeaderWriter
  • ENetErr : CNwssWspCOSession
  • ENoContent : HTTPStatus
  • ENoDataSupplied : CHeaderField
  • ENonAuthoritativeInfo : HTTPStatus
  • ENormal : CHTTPSession
  • ENotAcceptable : HTTPStatus
  • ENotConnected : MTextModeTransportHandler, THTTPSessionEvent
  • ENotFound : HTTPStatus
  • ENotifyNewRequestBodyPart : THTTPEvent
  • ENotImplemented : HTTPStatus
  • ENotModified : HTTPStatus
  • ENoTransportHandlerSet : HTTPPanic
  • ENotSupported : TNwssWspTrHndPanic
  • EnsureContentLengthL() : CTextModeHeadersFilter
  • EnsureContentTypePresentL() : CTextModeHeadersFilter
  • EnsureNoEndToEndHeadersInConnectionHeaderL() : CTextModeHeadersFilter
  • EnsurePathExistsL() : CTextModeHeadersFilter
  • ENULL : TWtlsCipherSuite, TWtlsKeyExchangeSuite
  • EOk : HTTPStatus
  • EOutgoing : THTTPEvent
  • EParameterError : TNwssWspTrHndPanic
  • EParsingChunkHeader : TResponseParser
  • EParsingHeaders : TResponseParser
  • EParsingPostChunkedEntityHeaders : TResponseParser
  • EParsingStatusLine : TResponseParser
  • EPartialContent : HTTPStatus
  • EPassive : CTransaction
  • EPaymentRequired : HTTPStatus
  • EPeerReq : CNwssWspCOSession
  • EPending : CProtTransaction
  • EPendingAck : CHttpTcpClient
  • EPendingReply : CHttpTcpClient
  • EPendingRequest : CHttpTcpClient
  • EPendingSocketConnect : CHttpConnector
  • EPendingTunnel : CHttpConnector
  • EPortAlreadyBound : TNwssWspTrHndPanic
  • EPost : CHttpClient
  • EPreconditionFailed : HTTPStatus
  • EProtocolHandler : THTTPFilterHandle, MHTTPFilter
  • EProtoErr : CNwssWspCOSession
  • EProxyAuthenticationRequired : HTTPStatus
  • EQuit : CHttpClient
  • ERC5_CBC : TWtlsCipherSuite
  • ERC5_CBC_40 : TWtlsCipherSuite
  • ERC5_CBC_56 : TWtlsCipherSuite
  • ERC5_CBC_64 : TWtlsCipherSuite
  • EReadingChunkBodyData : TResponseParser
  • EReadingChunkedBody : TResponseParser
  • EReadingNormalBody : TResponseParser
  • EReady : CNwssWspSession
  • EReadyForDNS : CHttpTcpClient
  • EReadyToConnect : CHttpTcpClient
  • ERedirected : THTTPSessionEvent
  • ERedirectedPermanently : THTTPEvent
  • ERedirectedTemporarily : THTTPEvent
  • EReplying : CHttpTcpClient
  • ERequestedRangeNotSatisfiable : HTTPStatus
  • ERequestEntityTooLarge : HTTPStatus
  • ERequesting : CHttpTcpClient
  • ERequestTimeout : HTTPStatus
  • ERequestURITooLong : HTTPStatus
  • EResetContent : HTTPStatus
  • ERespBuffCarryOver : TResponseParser
  • ERespBuffEmpty : TResponseParser
  • ERespBuffPopulated : TResponseParser
  • EResponseComplete : THTTPEvent
  • EResume : CNwssWspCOSession
  • ERSA : TWtlsKeyExchangeSuite
  • ERSA_512 : TWtlsKeyExchangeSuite
  • ERSA_768 : TWtlsKeyExchangeSuite
  • ERSA_anon : TWtlsKeyExchangeSuite
  • ERSA_anon_512 : TWtlsKeyExchangeSuite
  • ERSA_anon_768 : TWtlsKeyExchangeSuite
  • ESecondBlankLine : CTextModeRxData
  • ESecureEstablished : CHttpConnector
  • ESeeOther : HTTPStatus
  • ESendBody : TRequestComposer::TChunkEncoder
  • ESendLast : TRequestComposer::TChunkEncoder
  • ESendNumBytes : TRequestComposer::TChunkEncoder
  • ESendNumBytesFirst : TRequestComposer::TChunkEncoder
  • EServiceNotSupported : TNwssWspTrHndPanic
  • EServiceUnavailable : HTTPStatus
  • ESessionAlreadyOpen : HTTPPanic
  • ESessionClosed : TNwssWspTrHndPanic
  • ESessionNotConnected : TNwssWspTrHndPanic
  • ESessionOpen : CNwssWspSession
  • ESHA : TWtlsCipherSuite
  • ESHA_0 : TWtlsCipherSuite
  • ESHA_40 : TWtlsCipherSuite
  • ESHA_80 : TWtlsCipherSuite
  • ESHARED_SECRET : TWtlsKeyExchangeSuite
  • EShouldBlock : CHTTPSession
  • ESocketConnected : CHttpConnector
  • EStatusCodeHandler : MHTTPFilter
  • ESubmit : THTTPEvent
  • ESucceeded : THTTPEvent
  • ESuppliedSize : CHTTPFormEncoder
  • ESupplyingData : CHTTPFormEncoder
  • ESuspend : CNwssWspCOSession
  • ESwitchingProtocols : HTTPStatus
  • ETemporaryRedirect : HTTPStatus
  • EText : TWtlsKeyExchangeSuite
  • ETidyUp : MHTTPFilter
  • EToggleVerbosity : CHttpClient
  • ETooManyConnections : TNwssWspTrHndPanic
  • ETooMuchRequestData : THTTPEvent
  • ETrace : CHttpClient
  • ETransactionEventOutstanding : HTTPPanic
  • ETransactionUnhandledError : HTTPPanic
  • ETransLUTLeakage : TNwssWspTrHndPanic
  • ETransLUTOverflow : TNwssWspTrHndPanic
  • ETunnelCreated : CHttpConnector
  • ETunneling : CHttpConnector
  • EUnauthorized : HTTPStatus
  • EUndefined : TResponseParser, THTTPFilterHandle
  • EUndefSub : TResponseParser
  • EUndefSuper : TResponseParser
  • EUnknown : CNwssWspCOSession
  • EUnknownMethod : TNwssWspTrHndPanic
  • EUnknownPanic : TNwssWspTrHndPanic
  • EUnknownWspEvent : TNwssWspTrHndPanic
  • EUnrecoverableError : THTTPEvent
  • EUnsupportedMediaType : HTTPStatus
  • EUnused : HTTPStatus
  • EURIOverflow : TNwssWspTrHndPanic
  • EUseProxy : HTTPStatus
  • EUserReq : CNwssWspCOSession
  • EValidationFilterFailure : TFCoreFiltersPanic, HTTPPanic
  • EventAvailable() : CTransaction
  • EVersion1_1 : CWspHeaderCodec
  • EVersion1_2 : CWspHeaderCodec
  • EVersion1_3 : CWspHeaderCodec
  • EVersion1_4 : CWspHeaderCodec
  • EWaitForMoreData : CWspCOTxData
  • EWapStackTimeout : CNwssWspCOSession
  • EWrongBearerType : TNwssWspTrHndPanic
  • EWrongSessionType : TNwssWspTrHndPanic
  • EX509Name : TWtlsKeyExchangeSuite
  • ExceptionInd() : CWspCOProtocolHandler, MWspCOSessionCallback
  • ExtractALineL() : TResponseParser
  • ExtractBearerInfoFromSession() : CWspProxyInfoProvider
  • ExtractBody() : TResponseParser
  • ExtractBodyChunk() : TResponseParser
  • ExtractBodyData() : CNwssWspTrHndDataSupplier
  • ExtractIntegerValueL() : TTextHeaderUtils
  • ExtractNextTokenFromList() : TTextHeaderUtils
  • ExtractPortInfoFromSession() : CWspProxyInfoProvider
  • ExtractQuotedStringL() : TTextHeaderUtils
  • ExtractRedirectedProxyInfoL() : CNwssWspCOSession, CWspProxyInfoProvider
  • ExtractSecurityInfoFromSession() : CWspProxyInfoProvider
  • ExtractSessionTypeFromSession() : CWspProxyInfoProvider

- f -

  • Fail() : RHTTPTransaction, CTransaction
  • FailAndCancelL() : CValidationFilter
  • FailSessionEvent() : RHTTPSession, CHTTPSession
  • FieldPartsL() : RHTTPHeaders, CHeaders
  • Fields() : RHTTPHeaders, CHeaders
  • FilterCollection() : RHTTPSession
  • FilterConfigIterator() : CHTTPSession
  • FilterQueue() : CHTTPSession
  • FindAuth() : CAuthenticationFilter
  • FindByDataType() : TFilterConfigurationIterator
  • FindCredentials() : CAuthenticationFilter
  • FindCredentialsForURI() : CAuthenticationFilter
  • FindDelegateCodecL() : CWspDefaultHeaderCodec, CWspHeaderCodec, CTextModeDefaultCodec, CTextModeHeaderCodec, CHeaderCodec
  • FindFilterForThisEvent() : CTransaction
  • FindHeaderPartToUseL() : CAuthenticationFilter
  • FindNextFilter() : CTransaction
  • FindTransaction() : CProtocolHandler
  • First() : THTTPHdrFieldIter, THTTPFilterIterator, TFilterConfigurationIterator, THeaderFieldParamIter, THeaderFieldPartIter
  • FormatRequestLineBeginningL() : TRequestComposer

- g -

  • GenerateCNonce() : CAuthenticationFilter
  • GenericEncodeDateL() : CWspHeaderWriter
  • GenericEncodeTextStringL() : CWspHeaderWriter
  • GetAddress() : CAliasAddress
  • GetAliasAddresses() : CWspCapabilityInfo, MWspCapabilityViewer
  • GetAllSessionDataLC() : CNwssWspCOSession
  • GetAllTransactionDataLC() : CNwssWspCOSession
  • GetAnEntry() : CHttpExampleUtils
  • GetBearer() : CAliasAddress
  • GetCertInfoL() : CHttpSocket
  • GetCharacterSetFromValueL() : CWspHeaderReader
  • GetCharacterSetValue() : CWspHeaderWriter
  • GetClientMessageSize() : CWspCapabilityInfo, MWspCapabilityViewer
  • GetClientSDUSize() : CWspCapabilityInfo, MWspCapabilityViewer
  • GetCommsPrefs() : CTextModeHttpProt, MSessionPropertiesProvider
  • GetCredentialsL() : CHttpClient, MHTTPAuthenticationCallback
  • GetDNInfo() : CHttpSocket
  • GetExtendedMethods() : CWspCapabilityInfo, MWspCapabilityViewer
  • GetField() : RHTTPHeaders, CHeaders
  • GetFieldParameter() : CHeaders
  • GetFieldPartL() : CHeaders
  • GetHeaderCodePages() : CWspCapabilityInfo, MWspCapabilityViewer
  • GetHeaderCollection() : RHTTPMessage
  • GetIdentifier() : CUnknownCapability
  • GetLineBufferOverrunSize() : TResponseParser
  • GetMethodMOR() : CWspCapabilityInfo, MWspCapabilityViewer
  • GetMethodName() : CExtendedMethod
  • GetNamedPolicyProperty() : CNwssWspTransportHandler, MSecurityPolicy
  • GetNext() : CWspUnknownCapabilities, CWspHeaderCodePages, CWspExtendedMethods, CWspAliasAddresses, MWspUnknownCapabilities, MWspHeaderCodePages, MWspExtendedMethods, MWspAliasAddresses
  • GetNextDataPart() : CHttpClient, CNwssWspTrHndDataSupplier, CWspCOTxData, CWspCORxData, CTextModeTxData, CTextModeRxData, MHTTPDataSupplier, CHTTPFormEncoder
  • GetPageCode() : CHeaderCodePage
  • GetPageName() : CHeaderCodePage
  • GetParam() : RHTTPHeaders, CHeaders
  • GetPDUType() : CExtendedMethod
  • GetPort() : CAliasAddress
  • GetPostBodyManuallyL() : CHttpClient
  • GetProtocolOptions() : CWspCapabilityInfo, MWspCapabilityViewer
  • GetProxyCONNECTStatus() : CHttpConnector
  • GetProxyInfoL() : CWspProxyInfoProvider
  • GetPushMOR() : CWspCapabilityInfo, MWspCapabilityViewer
  • GetRawField() : RHTTPHeaders, CHeaders
  • GetRequestBodyL() : CHttpClient
  • GetSecureDialogPref() : CTextModeHttpProt, MSessionPropertiesProvider
  • GetSelection() : CHttpExampleUtils
  • GetServerCertL() : CNwssWspSession
  • GetServerMessageSize() : CWspCapabilityInfo, MWspCapabilityViewer
  • GetServerSDUSize() : CWspCapabilityInfo, MWspCapabilityViewer
  • GetSessionData() : CNwssWspCOSession
  • GetTable() : RHTTPSession
  • GetTlsCipherSuites() : CNwssWspTransportHandler, MSecurityPolicy
  • GetTransactionData() : CNwssWspCOSession
  • GetUnknownCapabilities() : CWspCapabilityInfo, MWspCapabilityViewer
  • GetValue() : CUnknownCapability
  • GetWspHeaderUtils() : CWspCOTransaction
  • GetWspVersion() : CWspHeaderCodec
  • GetWtlsCipherSuites() : CNwssWspTransportHandler, MSecurityPolicy
  • GetWtlsKeyExchangeSuites() : CNwssWspTransportHandler, MSecurityPolicy
  • GoSecureL() : CHttpSocket

- h -

  • HA1L() : CAuthenticationFilter
  • HA2L() : CAuthenticationFilter
  • Handle() : CTransaction, CResponse, CRequest, CHTTPSession, CHeaders
  • HandleAbortIndL() : MNwssTransactionEventHandler, CNwssWspTransactionEventFilter, CNwssWspCOSession
  • HandleCancelTransaction() : CProtocolHandler
  • HandleClosedTransaction() : CProtocolHandler
  • HandleConnectCnfL() : MNwssSessionEventHandler, CNwssWspSessionEventFilter, CNwssWspCOSession
  • HandleConnectInvocationL() : MConnectInvokerCallback
  • HandleConnectionTimedOut() : MConnectionTimerCallback, CWspCOProtocolHandler
  • HandleConnectRequestL() : CWspCOProtocolHandler
  • HandleDisconnectIndL() : MNwssSessionEventHandler, CNwssWspSessionEventFilter, CNwssWspCOSession
  • HandleDisconnectRequest() : CWspCOProtocolHandler
  • HandleError() : CTextModeRxData, MTransportHndObs
  • HandleExceptionIndL() : MNwssSessionEventHandler, CNwssWspSessionEventFilter, CNwssWspCOSession
  • HandleMethodAbort() : MWspCOMethodObserver, CWspCOProtocolHandler
  • HandleMethodInvokeCnfL() : MNwssTransactionEventHandler, CNwssWspTransactionEventFilter, CNwssWspCOSession
  • HandleMethodResultIndL() : MNwssTransactionEventHandler, CNwssWspTransactionEventFilter, CNwssWspCOSession
  • HandleRedirectIndL() : MNwssSessionEventHandler, CNwssWspSessionEventFilter, CNwssWspCOSession
  • HandleRedirectL() : CRedirectFilter
  • HandleResumeCnfL() : MNwssSessionEventHandler, CNwssWspSessionEventFilter, CNwssWspCOSession
  • HandleStatusLineL() : CTextModeRxData
  • HandleSuspendIndL() : MNwssSessionEventHandler, CNwssWspSessionEventFilter, CNwssWspCOSession
  • HandleTransactionL() : CAuthenticationFilter
  • HandleUseProxyL() : CRedirectFilter
  • HasBody() : RHTTPMessage, CMessage
  • Hash() : CAuthenticationFilter
  • Head() : CNwssTransLookUpTable
  • Header() : TResponseParser
  • Headers() : CMessage
  • HostAddress() : CHttpTcpServerLocation
  • HostAddress8() : CHttpTcpServerLocation
  • HostPort() : CHttpTcpServerLocation

- i -

  • iAborted : CNwssTransLookUpTable::CNwssTransLUTEntry
  • iAbortOnStack : CNwssWspCOSession::TDelayedMethodAbortPckg
  • iAbortPckg : CNwssWspCOSession
  • iActiveSubmission : CHttpTcpClient
  • iAddress : CAliasAddress
  • iAddresses : CWspAliasAddresses
  • iASyncEvent : CTransaction
  • iAuthType : CAuthenticationFilter::TCredentials
  • iBearer : TProxyInfo, CAliasAddress, TWspRedirectedAddress
  • iBlockingState : CHTTPSession
  • iBodyData : CWspCOTxData, CWspCORxData, TResponseParser
  • iBodyDataSizeSoFar : CTextModeRxData
  • iBodyDataSupplier : CWspCOTxData, CWspCORxData
  • iBuffer : CNwssWspTrHndDataSupplier
  • iBulkEncryptionAlgorithm : TWtlsCipherSuite
  • iCallback : CNwssWspCOSession::TDelayedMethodAbortPckg, CNwssTransLookUpTable::CNwssTransLUTEntry, CWspPrimitiveSender, CConnectionTimer, CAuthenticationFilter, CAuthenticationFilterInterface::TAuthenticationParams, CTransaction
  • iCapabilityCodec : CNwssWspCOSession
  • iCapProv : CWspTransportHandler, CWspTransportHandler::SInstantiationParams
  • iCategory : TSessionFilterInfo
  • iChunkBodyHolder : TRequestComposer::TChunkEncoder
  • iChunkBytesReadSoFar : TResponseParser
  • iChunkEncode : TRequestComposer
  • iChunkEncoder : TRequestComposer
  • iChunkSize : TResponseParser
  • iChunksSent : CTextModeTxData, TRequestComposer
  • iChunkState : TRequestComposer::TChunkEncoder
  • iClientCapInfo : CWspCOProtocolHandler
  • iClientFilter : CHTTPSession
  • iClientMethodAbort : CWspCOTransaction
  • iClientSessionHeaders : CWspCOProtocolHandler
  • iCode : CHeaderCodePage
  • iCodec : CWspHeaderUtils, CWspHeaderWriter, CWspHeaderReader, CProtocolHandler, CTransaction, CHeaders, CHeaderField
  • iCodePages : CWspHeaderCodePages
  • iComposer : CTextModeTxData
  • iConnectGuard : CNwssWspCOSession
  • iConnection : CTCPClientFactory
  • iConnectionInfo : TRequestComposer, CHTTPSession
  • iConnectionTimer : CWspCOProtocolHandler
  • iConnectState : CHttpConnector
  • iConnectTimedOut : CWspCOProtocolHandler
  • iConnHnd : CHttpTcpClient
  • iConnInfoProvider : CNwssWspSession
  • iConsumingResponse : CTextModeRxData
  • iCOTransTable : CNwssWspCOSession
  • iCredentials : CAuthenticationFilter
  • iCurrentASyncFilter : CTransaction
  • iCurrentFilter : CTransaction
  • iCurrentFilterIndex : TFilterConfigurationIterator
  • iCurrentMessage : CValidationFilter
  • iCurrentSyncEvent : CTransaction
  • iCurrentTransaction : CProtocolHandler
  • Id() : RHTTPTransaction, CTransaction
  • iData : CHTTPFormEncoder
  • iDataChunkCount : CHttpClient
  • iDataParseState : CHeaderField
  • iDataPart : CWspCOTxData
  • iDataSupplier : CMessage
  • iDataType : TFilterInformation
  • iDefSecPolCipherSuites : CNwssWspTransportHandler
  • iDefSecPolKeyExchSuite : CNwssWspTransportHandler
  • iDelegateCodec : CHeaderCodec
  • iDirection : TEventRegistration
  • iDisconnectOnStack : CNwssWspCOSession::TDelayedDisconnectPckg
  • iDisconnectPckg : CNwssWspCOSession
  • iDisconnectReason : CNwssConnectGuard
  • iDisconnectRequested : CWspCOProtocolHandler
  • iDisplayName : TFilterInformation
  • iDnsHnd : CHttpTcpClient
  • iDnsHndOpen : CHttpTcpClient
  • iDtor_ID_Key : CWspTransportHandler, CSecurityPolicy, CProtocolHandler
  • iDummyTransactionCallback : CHTTPSession
  • iEcomDtorID : CEComFilter, CAuthenticationFilterInterface
  • iEComFilterInfoArray : CHTTPSession
  • iEmptyLineCount : CTextModeRxData
  • iEncodedData : CTextModeTxData
  • iEntries : CNwssWspTransactionEventFilter, CNwssTransLookUpTable
  • iEvent : THTTPFilterRegistration, TFilterRegistration, TEventRegistration
  • iEventDispatcher : CNwssWspCOSession
  • iEventQueue : CTransaction
  • iField : CHeaders::THeaderFieldNamePair
  • iFieldName : TResponseParser, CTextModeDefHdrReader, CTextModeHeaderReader, CHeaders::THeaderFieldNamePair
  • iFields : CHeaders
  • iFieldValue : TResponseParser
  • iFileServ : CHttpEventHandler, CHttpClient
  • iFilter : THTTPFilterRegistration, TFilterRegistration
  • iFilterCategory : TFilterInformation
  • iFilterConfigIter : CHTTPSession
  • iFilterCount : TFilterConfigurationIterator
  • iFilterInfo : TSessionFilterInfo
  • iFilterInfoList : TFilterConfigurationIterator, CHTTPSession
  • iFilterPlugin : TSessionFilterInfo
  • iFilterQueue : CHTTPSession
  • iFilterUid : TFilterInformation
  • iFinalResPending : CWspCOTransaction
  • iFirstTransaction : CTextModeHttpProt
  • iFormEncoder : CHttpClient
  • iFoundBodyParts : CTextModeRxData
  • iFoundConnectionClose : CTextModeRxData
  • iFQ : THTTPHdrVal::TQConv
  • iGotAllHeaders : CTextModeRxData
  • iGotBodyData : CWspCOTxData, CWspCORxData
  • iHandle : THTTPFilterRegistration, TFilterRegistration
  • iHandshakeWasAnonymous : CNwssWspSession
  • iHasARequestBody : CHttpClient
  • iHasBearer : TWspRedirectedAddress
  • iHasPort : TWspRedirectedAddress
  • iHasTrailer : CWspCOTxData, CWspCORxData
  • iHaveReadContentLengthHeader : CTextModeRxData
  • iHdrUtils : CWspCOTransaction, CWspCOProtocolHandler
  • iHeader : THTTPFilterRegistration, TFilterRegistration, THeaderFieldPartIter
  • iHeaderData : CWspCOTxData
  • iHeaderField : RHeaderField
  • iHeaderPart : THeaderFieldParamIter
  • iHeaders : THTTPHdrFieldIter, CMessage
  • iHeadersFilter : CTextModeHttpProt
  • iHighWaterMark : CNwssWspTransactionEventFilter
  • iHostAddrDnsEntry : CHttpTcpClient
  • iHostAddress : CHttpTcpServerLocation
  • iHostAddress8 : CHttpTcpServerLocation
  • iHostPort : CHttpTcpServerLocation
  • iHttpConnector : CHttpTcpClient
  • iId : CTransaction
  • iID : CAuthenticationFilter::TCredentials
  • iIdentifier : CUnknownCapability
  • iImplementation : THTTPFilterIterator, RHTTPTransaction, RHTTPSession, RHTTPPropertySet, RHTTPMessage, RHTTPHeaders, RHTTPFilterCollection
  • iInConnectLimbo : CNwssWspCOSession
  • iIndex : CWspUnknownCapabilities, CWspHeaderCodePages, CWspExtendedMethods, CWspAliasAddresses
  • iInstallStatus : TFilterInformation
  • iIsChunked : TResponseParser
  • iIsSecure : CHttpTcpServerLocation
  • iIsSessionEventFlag : THTTPEvent
  • iIsSocketOpen : CHttpSocket
  • iKeyExchangeSuite : TWtlsKeyExchangeSuite
  • iKeyId : TWtlsKeyExchangeSuite
  • iKeyIdType : TWtlsKeyExchangeSuite
  • iLastChunk : CWspCORxData, CTextModeTxData
  • iLastChunkToEncode : TRequestComposer::TChunkEncoder
  • iLastHeaderName : CTextModeRxData
  • iLastServerLocation : CHttpTcpClient
  • iLastTimeStamp : CHttpClient
  • iLimitedMessageSize : CWspCOTxData
  • iLineBuffer : CTextModeRxData, TResponseParser
  • iLineBufferOverrunSize : TResponseParser
  • iLoadCount : CTextModeHeadersFilter, CRedirectFilter, CAuthenticationFilter
  • iLocalPort : TProxyInfo
  • iLocation : CHttpConnector
  • iLogger : THttpLogger
  • iMacAlgorithm : TWtlsCipherSuite
  • iMainState : TResponseParser
  • iMajorVersion : TResponseParser
  • iManager : CHTTPSession
  • iManualPost : CHttpClient
  • iMaxNumTransPerTranspHndlr : CTextModeHttpProt
  • iMaxNumTransportHandlers : CTextModeHttpProt
  • iMD5Calculator : CAuthenticationFilter
  • iMethod : CNwssConnectGuard, CRequest
  • iMethodCallback : CNwssConnectGuard, CWspCORxData
  • iMethodInvoker : CNwssConnectGuard, CWspCOTransaction
  • iMethodMOR : CNwssWspCOSession
  • iMethods : CWspExtendedMethods
  • iMethodState : CWspCOTransaction
  • iMinorVersion : TResponseParser
  • iMoreData : CWspCORxData
  • iMoreRequestData : CWspCOTransaction
  • iMoreSpace : THTTPHdrVal
  • Implementation() : CTransaction
  • iMustReleaseDataSupplier : CTextModeTxData
  • iName : CHeaderCodePage, CExtendedMethod, THTTPFilterRegistration, THTTPFilterIterator, TFilterRegistration, CHeaderFieldParam, CHeaderField
  • iNegotiatedCapInfo : CWspCOTxData, CWspCOTransaction, CWspCOProtocolHandler
  • iNextFilter : CTransaction
  • iNextFilterHandle : CHTTPSession
  • iNextID : CAuthenticationFilter
  • InitCommsL() : CHttpExampleUtils
  • InitializeFiltersL() : CHTTPSession
  • InitiateProxyConnection() : CNwssWspSession
  • InitiateSend() : CWspPrimitiveSender
  • InitPushReceive() : MWspCLPushInvoker
  • InitRequestL() : CWspCOTransaction
  • InsertPartL() : CHeaderField
  • InstallAuthenticationL() : MHTTPAuthenticationCallback
  • InstallCurrentFilter() : TFilterConfigurationIterator
  • InstallFilterL() : CValidationFilter, CRedirectFilter, CAuthenticationFilter, CEComFilter, CAuthenticationFilterInterface
  • Int() : THTTPHdrVal
  • iNumActiveLUTEntries : CNwssTransLookUpTable
  • iNumBytesRcvd : CHttpTcpClient, CHttpConnector
  • InvokeHttpMethodL() : CHttpClient
  • iObserver : CWspCOTxData, CWspCOTransaction, CHttpTcpWriter, CHttpTcpReader, CSubmissionDetails, CHttpConnector, TRequestComposer, CRxData
  • iOOMCallBack : CNwssWspCOSession
  • iOomHandler : CNwssWspTrHndDataSupplier
  • iOutOfMemoryHnd : CNwssWspCOEventDispatcher
  • iOverallDataSize : CNwssWspTrHndDataSupplier, CWspCOTxData, CWspCORxData, CTextModeRxData
  • iOwner : CHeaderField
  • iOwnsCommsSession : CTCPClientFactory
  • iParams : CHeaderFieldPart
  • iParse : CTextModeRxData
  • iParsedFileName : CHttpEventHandler, CHttpClient
  • iParts : CHeaderField
  • iPassword : CAuthenticationFilter::TCredentials
  • iPendingCompletingMethods : CWspCOProtocolHandler
  • iPersistentConn : CHttpTcpServerLocation
  • iPool : CHTTPManager
  • iPort : CAliasAddress, TWspRedirectedAddress
  • iPos : THTTPFilterIterator
  • iPosIdx : THTTPHdrFieldIter, THeaderFieldParamIter, THeaderFieldPartIter
  • iPosition : THTTPFilterRegistration, TFilterRegistration
  • iPreviousLineFitExactly : TResponseParser
  • iPrimitive : CWspPrimitiveSender
  • iPrimitiveSender : CWspCOTransaction, CWspCOProtocolHandler
  • iProcessingSyncEvent : CTransaction
  • iPropertySet : CTransaction
  • iProtocolHandler : CHTTPSession
  • iProtTrans : CTxData, CRxData
  • iProxiedHost : CHttpTcpServerLocation
  • iProxiedPort : CHttpTcpServerLocation
  • iProxyAddress : TProxyInfo, CTextModeHttpProt, TWspRedirectedAddress
  • iProxyCONNECTStatus : CHttpConnector
  • iProxyInfo : CWspProxyInfoProvider
  • iProxyInfoLocked : CWspProxyInfoProvider
  • iProxyInfoProv : CWspTransportHandler, CWspTransportHandler::SInstantiationParams
  • iProxyInfoProvider : CWspCOProtocolHandler
  • iQ : THTTPHdrVal::TQConv
  • iRawChunkSize : CHeaderField
  • iRawData : CHeaderField
  • iReader : CHeaderCodec
  • iRealm : CAuthenticationFilter::TCredentials
  • iRecvBuffer : CHttpTcpClient, CHttpConnector
  • iRecvBufferPtr : CHttpTcpClient, CHttpConnector
  • iRedirectAddr : CNwssWspCOSession
  • iRemainingBytes : CNwssWspTrHndDataSupplier
  • iRemainingMessageSpace : CWspCOTxData
  • iRemainingSDUSpace : CWspCOTxData
  • iRemoteAddr : CHttpTcpClient, CHttpConnector
  • iRemotePort : TProxyInfo
  • iReplyComplete : CTextModeRxData
  • iReqBodyContentType : CHttpClient
  • iReqBodyFile : CHttpClient
  • iReqBodyFileName : CHttpClient
  • iReqBodySubmitBuffer : CHttpClient
  • iReqBodySubmitBufferPtr : CHttpClient
  • iRequest : TRequestComposer, CTransaction
  • iRequestBody : CNwssConnectGuard
  • iRequestComplete : CWspCOTxData
  • iRequestHeaders : CNwssConnectGuard
  • iRequestSessionHeaders : CHTTPSession
  • iRequestUri : CNwssConnectGuard
  • iRespBody : CHttpEventHandler
  • iRespBodyFile : CHttpEventHandler
  • iRespBodyFileName : CHttpEventHandler
  • iRespBuffer : TResponseParser
  • iResponse : CTransaction
  • iResponseBodyHandler : CNwssTransLookUpTable::CNwssTransLUTEntry
  • iResponseSessionHeaders : CHTTPSession
  • iRxData : CProtTransaction
  • IsAlphaNumeric() : CHTTPFormEncoder
  • iSavingResponseBody : CHttpEventHandler
  • IsBlocking() : CHTTPSession
  • IsChunkEncoding() : TRequestComposer
  • IsClientError() : HTTPStatus
  • iScratchBuf : TRequestComposer::TChunkEncoder
  • IsDisconnected() : CHttpSocket
  • iSecureConnection : TProxyInfo
  • iSecureDialogPref : CHttpSocket
  • iSecurityPolicy : CNwssWspSession, CHttpTcpClient, CHttpSocket, CWspTransportHandler, CWspTransportHandler::SInstantiationParams, CProtocolHandler
  • iSeed : CAuthenticationFilter
  • IsEmpty() : CNwssTransLookUpTable
  • iSendBuffer : CHttpTcpClient, CHttpConnector
  • iSendDisconnect : CNwssConnectGuard
  • iSentLastChunk : TRequestComposer
  • iSentMethodResultRes : CWspCOTransaction
  • iServerCert : CNwssWspSession
  • iServerCertValid : CNwssWspSession
  • iServerLocation : CSubmissionDetails
  • iServiceCentreNumber : TProxyInfo
  • iSess : CHttpClient
  • iSessDataBuffer : CNwssWspCOSession
  • iSessEventHnd : CNwssWspCOEventDispatcher
  • iSessHdrProv : CWspTransportHandler, CWspTransportHandler::SInstantiationParams
  • iSession : CNwssWspCOSession::TDelayedDisconnectPckg, CNwssWspCOSession::TDelayedMethodAbortPckg, CWspProxyInfoProvider, CTextModeHeadersFilter, CRedirectFilter, TFilterConfigurationIterator, CAuthenticationFilterInterface::TAuthenticationParams, CProtocolHandler, CTransaction
  • iSessionCallback : CNwssConnectGuard
  • iSessionCB : CNwssWspCOSession, CWspTransportHandler, CWspTransportHandler::SInstantiationParams
  • iSessionClosing : CNwssWspTransactionEventFilter
  • iSessionEventCallback : TClientFilter
  • iSessionEventFilter : CNwssWspCOSession
  • iSessionEventHandler : CNwssWspSessionEventFilter
  • iSessionEventTransaction : CHTTPSession
  • iSessionInvoker : CWspCOProtocolHandler
  • iSessionPropertiesProvider : CTCPClientFactory
  • iSessionState : CWspCOProtocolHandler
  • iSessionType : TProxyInfo
  • iSessionUsesWebProxy : CTextModeHttpProt
  • IsHopByHopHeader() : CTextModeHeadersFilter
  • IsHostIPAddress() : CHttpConnector, CTextModeHttpProt
  • IsInformational() : HTTPStatus
  • IsLastChunk() : TRequestComposer::TChunkEncoder
  • iSocket : CHttpTcpWriter, CHttpTcpReader, CHttpTcpClient, CHttpSocket, CHttpConnector
  • iSocketReader : CHttpTcpClient
  • iSocketServer : CTCPClientFactory
  • iSocketWriter : CHttpTcpClient
  • iSockSrvHnd : CHttpTcpClient
  • IsOpen() : CHttpSocket
  • IsPersistentConnection() : CHttpTcpServerLocation
  • IsRedirection() : HTTPStatus
  • IsSecure() : CHttpTcpServerLocation, CHttpSocket
  • IsServerError() : HTTPStatus
  • IsSessionEvent() : THTTPEvent
  • IsSuccessful() : HTTPStatus
  • iStackTrans : CNwssWspTrHndDataSupplier, CNwssTransLookUpTable::CNwssTransLUTEntry
  • iStackTransId : CNwssWspTrHndDataSupplier
  • iStackTransID : CNwssTransLookUpTable::CNwssTransLUTEntry
  • iStartFilter : TEventRegistration
  • iStatCode : TResponseParser
  • iStatDesc : TResponseParser
  • iState : CNwssWspSession, CWspCOTxData, CHTTPFormEncoder
  • iStatus : THTTPFilterRegistration, THTTPEvent, TFilterRegistration, CResponse
  • iStatusString : CResponse
  • IsTimeToTerminateChunkEncoding() : TRequestComposer
  • IsTrailerHeader() : CWspHeaderUtils
  • iStringPool : CNwssWspSession, CTextModeHeadersFilter, CValidationFilter, CRedirectFilter, CAuthenticationFilter, CWspTransportHandler, CWspTransportHandler::SInstantiationParams
  • iStrPool : CWspDefaultHdrWriter, CWspHeaderWriter, CWspDefaultHdrReader, CWspHeaderReader, CWspDefaultHeaderCodec, CWspHeaderCodec, TRequestComposer, CTextModeDefHdrReader, CTextModeDefHdrWriter, CTextModeDefaultCodec, CTextModeHeaderReader, CTextModeHeaderWriter, CTextModeHeaderCodec, CSecurityPolicy
  • iStrTable : CWspHeaderWriter, CWspHeaderReader, CWspHeaderCodec
  • iSubmitData : CSubmissionDetails
  • iSubState : TResponseParser
  • iSuicide : CWspCOTransaction
  • iSuperState : TResponseParser
  • iSupportLDT : CWspCOTxData
  • iTCPClientFactory : CTextModeHttpProt
  • iTcpTHStatus : CHttpConnector
  • iTest : CHttpExampleUtils
  • iTextModeTransportHandler : CTextModeTxData, CTextModeRxData, CTextModeProtTransaction
  • iTimedOutValue : CWspCOProtocolHandler
  • iTlsSocket : CHttpSocket
  • iTrailerData : CWspCOTxData
  • iTrailerInfoLength : CWspCOTxData
  • iTrans : CHttpClient, CProtTransaction
  • iTransaction : CNwssWspCOEventDispatcher, CMessage
  • iTransactionFailed : CValidationFilter
  • iTransactions : CProtocolHandler, CHTTPSession
  • iTransactionState : CProtTransaction
  • iTransCount : CHTTPSession
  • iTransEventFilter : CNwssWspCOSession
  • iTransEventHandler : CNwssWspTransactionEventFilter, CNwssWspSessionEventFilter
  • iTransEventHnd : CNwssWspCOEventDispatcher
  • iTransmissionState : CHttpTcpClient
  • iTransObs : CHttpClient
  • iTransportHandler : CWspCOProtocolHandler
  • iTransportHnds : CTextModeHttpProt
  • iTransSet : CTextModeTxData
  • iTransTable : CNwssWspTransactionEventFilter, CNwssWspSessionEventFilter
  • iTrId : CNwssWspCOEventDispatcher
  • iTxData : CProtTransaction
  • iTxLastChunk : CHttpTcpClient
  • iType : CExtendedMethod, THTTPHdrVal
  • iUID : THTTPEvent
  • iUnknownCapabilities : CWspUnknownCapabilities
  • iURI : TRequestComposer, CAuthenticationFilter::TCredentials, CRequest
  • iUriBuffer : CNwssWspCOSession
  • iUseAckHdrs : CNwssWspCOSession
  • iUseCount : CHTTPManager
  • iUseNamedProxy : CTextModeHttpProt
  • iUser : CAuthenticationFilter::TCredentials
  • iUtils : CHttpEventHandler, CHttpClient
  • iVal : THTTPHdrVal
  • iValue : CUnknownCapability, THTTPFilterHandle, CHeaderFieldParam, CHeaderFieldPart
  • iVerbose : CHttpEventHandler
  • iVersion : TFilterInformation, CResponse
  • iWaitingMethod : CWspCOProtocolHandler
  • iWapStackHnd : CNwssWspTransportHandler
  • iWapStackProvider : CNwssWspSession
  • iWorkingBuffer : TRequestComposer
  • iWriter : CHeaderCodec
  • iWspCOSession : CNwssWspTransportHandler, CNwssWspCOSession
  • iWspEvent : CNwssWspCOEventDispatcher
  • iWspSession : CNwssWspCOEventDispatcher
  • iWspVersion : CWspHeaderCodec

- k -

  • KDateVal : THTTPHdrVal
  • KNoType : THTTPHdrVal
  • KStrFVal : THTTPHdrVal
  • KStrVal : THTTPHdrVal
  • KTIntVal : THTTPHdrVal

- l -

  • LeaveOnRequestErrL() : CHttpTcpClient
  • ListAvailableProtocolsL() : RHTTPSession, CHTTPSession
  • LocalPort() : CWspProxyInfoProvider, MWspProxyInfoProvider
  • LocateFieldName() : CHeaders
  • LocationMatches() : CHttpTcpServerLocation
  • LogIt() : CHttpExampleUtils, THttpLogger
  • LookUp() : CNwssTransLookUpTable
  • LookUpByCallback() : CNwssTransLookUpTable
  • LookUpByTransId() : CNwssTransLookUpTable
  • LookUpProtTrans() : CTextModeHttpProt

- m -

  • Manager() : CHTTPSession
  • MapToPanic() : CNwssWspSession
  • MaxNumTransPerTranspHndlr() : CTextModeHttpProt
  • MaxNumTransportHandlers() : CTextModeHttpProt
  • Method() : RHTTPRequest, CRequest
  • MethodAbort() : CWspCOTransaction
  • MethodAbortInd() : CWspCOTransaction, MWspCOMethodCallback
  • MethodAbortReq() : CNwssWspCOSession, MWspCOMethodInvoker
  • MethodInvoke() : CWspCOTransaction
  • MethodInvokeCnf() : CWspCOTransaction, MWspCOMethodCallback
  • MethodInvokeData() : CWspCOTransaction
  • MethodInvokeDataCnf() : CWspCOTransaction, MWspCOMethodCallback
  • MethodInvokeDataReq() : CNwssWspCOSession, MWspCOMethodInvoker
  • MethodInvokeReq() : CNwssWspCOSession, MWspCOMethodInvoker
  • MethodResultDataInd() : CWspCOTransaction, MWspCOMethodCallback
  • MethodResultDataRes() : CNwssWspCOSession, CWspCOTransaction, MWspCOMethodInvoker
  • MethodResultInd() : CWspCOTransaction, MWspCOMethodCallback
  • MethodResultRes() : CNwssWspCOSession, CWspCOTransaction, MWspCOMethodInvoker
  • MHDS_Reserved1() : MHTTPDataSupplier
  • MHDS_Reserved2() : MHTTPDataSupplier
  • MHDS_Reserved3() : MHTTPDataSupplier
  • MHFLoad() : CTextModeHeadersFilter, CValidationFilter, CRedirectFilter, CAuthenticationFilter, MHTTPFilter, CProtocolHandler, TClientFilter
  • MHFRunError() : CHttpEventHandler, CTextModeHeadersFilter, CValidationFilter, CRedirectFilter, CAuthenticationFilter, MHTTPTransactionCallback, MHTTPFilterBase, CProtocolHandler, TClientFilter, TDummyTransactionCallback
  • MHFRunL() : CHttpEventHandler, CTextModeHeadersFilter, CValidationFilter, CRedirectFilter, CAuthenticationFilter, MHTTPTransactionCallback, MHTTPFilterBase, CProtocolHandler, TClientFilter, TDummyTransactionCallback
  • MHFSessionRunError() : CWspCOProtocolHandler, CTextModeHeadersFilter, CValidationFilter, CRedirectFilter, CAuthenticationFilter, MHTTPSessionEventCallback, MHTTPFilterBase, CProtocolHandler, TClientFilter
  • MHFSessionRunL() : CWspCOProtocolHandler, CTextModeHeadersFilter, CValidationFilter, CRedirectFilter, CAuthenticationFilter, MHTTPSessionEventCallback, MHTTPFilterBase, CProtocolHandler, TClientFilter
  • MHFUnload() : CTextModeHeadersFilter, CValidationFilter, CRedirectFilter, CAuthenticationFilter, MHTTPFilter, CProtocolHandler, TClientFilter
  • MRDO_Reserved1() : MRxDataObserver
  • MRDO_Reserved2() : MRxDataObserver

- n -

  • Name() : RHeaderField, CHeaderFieldParam, CHeaderField
  • NewEntry() : CNwssTransLookUpTable
  • NewL() : CHttpExampleUtils, CHttpEventHandler, CHttpClient, CNwssWspTrHndDataSupplier, CNwssWspTransportHandler, CNwssWspTransactionEventFilter, CNwssWspSessionEventFilter, CNwssWspCOSession, CNwssWspCOEventDispatcher, CNwssTransLookUpTable, CNwssTransLookUpTable::CNwssTransLUTEntry, CNwssConnectGuard, CWspUnknownCapabilities, CWspProxyInfoProvider, CWspPrimitiveSender, CWspHeaderUtils, CWspHeaderCodePages, CWspExtendedMethods, CWspCOTxData, CWspCOTransaction, CWspCORxData, CWspCOProtocolHandler, CWspCapabilityInfo, CWspAliasAddresses, CUnknownCapability, CHeaderCodePage, CExtendedMethod, CConnectionTimer, CAliasAddress, CWspDefaultHdrWriter, CWspHeaderWriter, CWspDefaultHdrReader, CWspHeaderReader, CWspDefaultHeaderCodec, CWspHeaderCodec, CTCPClientFactory, CHttpTcpWriter, CHttpTcpServerLocation, CHttpTcpReader, CSubmissionDetails, CHttpTcpClient, CHttpSocket, CHttpConnector, CTextModeTxData, CTextModeRxData, CTextModeProtTransaction, CTextModeHttpProt, CTextModeHeadersFilter, CTextModeDefHdrReader, CTextModeDefHdrWriter, CTextModeDefaultCodec, CTextModeHeaderReader, CTextModeHeaderWriter, CTextModeHeaderCodec, CWspTransportHandler, CSecurityPolicy, CProtocolHandler, CHTTPFormEncoder, CTransaction, CResponse, CRequest, CHTTPSession, CHeaders, CHeaderFieldParam, CHeaderFieldPart, CHeaderField
  • NewLC() : CHttpEventHandler, CHttpClient, CWspDefaultHdrWriter, CWspHeaderWriter, CWspDefaultHdrReader, CWspHeaderReader, CTextModeDefHdrReader, CTextModeDefHdrWriter, CTextModeHeaderReader, CTextModeHeaderWriter
  • NewTransportHandlerL() : CTCPClientFactory
  • Next() : TFilterConfigurationIterator
  • NextFilter() : CTransaction
  • NextFilterHandle() : CHTTPSession
  • NextTransactionID() : CHTTPSession
  • NotifyMethodComplete() : MWspCOMethodObserver, CWspCOProtocolHandler
  • NotifyMoreRequestData() : CWspCOTxData, CWspCOTransaction
  • NotifyNewRequestBodyPart() : CWspCOProtocolHandler, CTextModeTxData, CTextModeHttpProt, CProtocolHandler
  • NotifyNewRequestBodyPartL() : RHTTPTransaction
  • NotifyPendingCompletingMethod() : MWspCOMethodObserver, CWspCOProtocolHandler
  • NotifyRequestDataAvailable() : CHttpTcpClient, MTextModeTransportHandler
  • NumActiveTransactions() : CProtocolHandler
  • NumParameters() : CHeaderFieldPart
  • NumPartsL() : CHeaderField

- o -

  • Observer() : CSubmissionDetails
  • Open() : CHttpSocket
  • OpenL() : RHTTPSession
  • OpenTransactionL() : RHTTPSession
  • OpenWapProxyL() : CNwssWspSession
  • OpenWspSession() : CNwssWspSession, CNwssWspCOSession
  • operator *() : THTTPFilterIterator
  • operator RString() : THTTPHdrVal
  • operator RStringF() : THTTPHdrVal
  • operator TDateTime() : THTTPHdrVal
  • operator TInt() : THTTPHdrVal, THTTPHdrVal::TQConv
  • operator TReal() : THTTPHdrVal::TQConv
  • operator!=() : TProxyInfo, THTTPHdrVal, THTTPFilterRegistration, THTTPFilterHandle, THTTPSessionEvent, THTTPEvent, RHTTPTransaction, RHTTPSession, TFilterRegistration
  • operator()() : THTTPHdrFieldIter, THTTPFilterIterator, THeaderFieldParamIter, THeaderFieldPartIter
  • operator++() : THTTPHdrFieldIter, THTTPFilterIterator, THeaderFieldParamIter, THeaderFieldPartIter
  • operator->() : THTTPFilterIterator
  • operator=() : THTTPSessionEvent, THTTPEvent
  • operator==() : TProxyInfo, THTTPHdrVal, THTTPFilterRegistration, THTTPFilterHandle, THTTPSessionEvent, THTTPEvent, RHTTPTransaction, RHTTPSession, TFilterRegistration
  • OverallDataSize() : CHttpClient, CNwssWspTrHndDataSupplier, CWspCOTxData, CWspCORxData, CTextModeTxData, CTextModeRxData, MHTTPDataSupplier, CHTTPFormEncoder
  • Overflow() : THttpLogger

- p -

  • Panic() : TNwssWspTrHndPanic, CHttpTcpClient, TFCoreFiltersPanic, HTTPPanic
  • Parameter() : CHeaderFieldPart
  • Parameters() : CHeaderFieldPart
  • ParseChunkHeader() : TResponseParser
  • ParseHeaders() : TResponseParser
  • ParseLine() : TResponseParser
  • ParseMoreData() : TResponseParser
  • ParseStatusLine() : TResponseParser
  • PartL() : CHeaderField
  • PartsL() : RHeaderField, CHeaderField
  • PostResProcessing() : CWspCOTransaction
  • PrepareClientCapabilities() : CNwssWspCOSession
  • PrepareMessageL() : CTextModeTxData
  • PrepareRequestForTransL() : CTextModeHttpProt
  • PrepareUriForTransL() : CTextModeHttpProt
  • PressAnyKey() : CHttpExampleUtils
  • ProcessResponseDataL() : CWspCOTransaction
  • Property() : RHTTPPropertySet
  • PropertySet() : RHTTPTransaction, CTransaction
  • ProtTrans() : CTxData, CRxData
  • ProxiedHost() : CHttpTcpServerLocation
  • ProxiedPort() : CHttpTcpServerLocation
  • ProxyAddress() : CWspProxyInfoProvider, MWspProxyInfoProvider
  • ProxyInfoChangedAndUpdateL() : CWspProxyInfoProvider
  • ProxyInfoProvider() : MConnectionInfoProvider, CNwssWspTransportHandler
  • PurgeFields() : CHeaders
  • PushAbortInd() : MWspCOPushCallback
  • PushAbortReq() : MWspCOPushInvoker
  • PushInd() : MWspCOPushCallback
  • PushListen() : MWspCOPushInvoker

- q -

  • Query() : RHTTPFilterCollection

- r -

  • RawDataL() : RHeaderField, CHeaderField
  • Read() : CHttpSocket
  • ReadCompletedL() : MHttpSocketObserver, CHttpTcpClient
  • ReadServiceCentreNumberL() : CWspProxyInfoProvider
  • ReadWapAccessPointInfoL() : CWspProxyInfoProvider
  • ReAllocBufferL() : CTextModeTxData, MComposerObserver
  • ReceivedCnf() : CWspCOTxData
  • ReceivedMethodInvokeReqL() : CNwssConnectGuard
  • Recv() : CHttpSocket
  • RecvOneOrMore() : CHttpTcpReader, CHttpSocket
  • Release() : CHTTPManager
  • ReleaseData() : CHttpClient, CNwssWspTrHndDataSupplier, CWspCOTxData, CWspCORxData, CTextModeTxData, CTextModeRxData, MHTTPDataSupplier, CHTTPFormEncoder
  • RemotePort() : CWspProxyInfoProvider, MWspProxyInfoProvider
  • RemoveAllFields() : RHTTPHeaders, CHeaders
  • RemoveAllProperties() : RHTTPPropertySet
  • RemoveBody() : RHTTPMessage
  • RemoveEntry() : CNwssTransLookUpTable
  • RemoveEvent() : CTransaction
  • RemoveField() : RHTTPHeaders, CHeaders
  • RemoveFieldPart() : RHTTPHeaders
  • RemoveFieldPartL() : CHeaders
  • RemoveFilter() : RHTTPFilterCollection
  • RemoveParam() : CHeaderFieldPart
  • RemovePartL() : CHeaderField
  • RemoveProperty() : RHTTPPropertySet
  • RemoveTransaction() : CHTTPSession
  • Request() : RHTTPTransaction, CTransaction
  • RequestBodyData() : CWspCOTxData
  • RequestFailIfContainsBodyL() : CValidationFilter
  • RequestHeadersData() : CWspCOTxData
  • RequestSessionHeadersL() : RHTTPSession, CHTTPSession
  • Reserved1() : CNwssWspTransportHandler, CTxData, CSecurityPolicy, MSecurityPolicy, CRxData, CProtTransaction, CProtocolHandler, CHeaderReader, CHeaderWriter, CHeaderCodec
  • Reserved2() : CNwssWspTransportHandler, CTxData, CSecurityPolicy, MSecurityPolicy, CRxData, CProtTransaction, CProtocolHandler, CHeaderReader, CHeaderWriter, CHeaderCodec
  • Reset() : CHttpClient, CNwssWspTrHndDataSupplier, CWspUnknownCapabilities, CWspHeaderCodePages, CWspExtendedMethods, CWspCOTxData, CWspCORxData, CWspCapabilityInfo, CWspAliasAddresses, CTextModeTxData, TRequestComposer, TRequestComposer::TChunkEncoder, CTextModeRxData, TResponseParser, MWspUnknownCapabilities, MWspHeaderCodePages, MWspExtendedMethods, MWspCapabilitySetter, MWspAliasAddresses, MHTTPDataSupplier, CHTTPFormEncoder
  • ResetAll() : CWspCOProtocolHandler
  • ResetFlags() : CWspCOTransaction
  • ResetMethodInfo() : CNwssConnectGuard
  • ResetProxyInfo() : CWspProxyInfoProvider
  • ResetRxData() : CWspCORxData, CTextModeRxData, CRxData, CProtTransaction
  • ResetTimeElapsed() : CHttpClient
  • ResetTxData() : CProtTransaction
  • ResizeTableL() : CNwssWspTransactionEventFilter, CNwssTransLookUpTable
  • Response() : RHTTPTransaction, CTransaction
  • ResponseCompleteL() : CWspCORxData
  • ResponseSessionHeadersL() : RHTTPSession, CHTTPSession
  • ResumeCnf() : CWspCOProtocolHandler, MWspCOSessionCallback
  • ResumeReq() : CNwssWspCOSession, MWspCOSessionInvoker
  • RHeaderField : RHeaderField, CHeaderField
  • RHTTPFilterCollection : RHTTPFilterCollection, THTTPFilterIterator, THTTPFilterHandle, RHTTPSession
  • RHTTPHeaders() : RHTTPHeaders
  • RHTTPMessage : RHTTPMessage, CMessage
  • RHTTPPropertySet() : RHTTPPropertySet
  • RHTTPRequest : CMessage
  • RHTTPResponse : CMessage
  • RHTTPSession : RHTTPSession, THTTPFilterHandle, RHTTPTransaction, RHTTPFilterCollection
  • RHTTPTransaction() : RHTTPTransaction
  • RunError() : CNwssWspTransactionEventFilter, CNwssWspSessionEventFilter, CNwssWspSession, CNwssWspCOEventDispatcher, CWspPrimitiveSender, CConnectionTimer, CHttpTcpWriter, CHttpTcpReader, CHttpTcpClient, CHttpConnector, CProtocolHandler, CTransaction
  • RunL() : CNwssWspTransactionEventFilter, CNwssWspSessionEventFilter, CNwssWspSession, CNwssWspCOEventDispatcher, CNwssConnectGuard, CWspPrimitiveSender, CConnectionTimer, CHttpTcpWriter, CHttpTcpReader, CHttpTcpClient, CHttpConnector, CProtocolHandler, CTransaction
  • RunOneFilterL() : CTransaction
  • RxData() : CProtTransaction

- s -

  • ScheduleDelayedOomDisconnect() : CNwssWspCOSession
  • ScheduleDelayedOomMethodAbort() : CNwssWspCOSession
  • SecureConnection() : CWspProxyInfoProvider, MWspProxyInfoProvider
  • SelectTransportHandlerL() : CTextModeHttpProt
  • SendDisconnectInd() : CNwssConnectGuard
  • SendEventL() : RHTTPTransaction, CTransaction
  • SendInvokePrimitive() : MWspCOTxDataCallback, CWspCOTransaction
  • SendMethodAbortInd() : CNwssConnectGuard
  • SendMethodAbortIndEvent() : CNwssWspTransactionEventFilter
  • SendMethodInvokeReq() : CNwssConnectGuard
  • SendOomDisconnect() : MNwssOomHandler, CNwssWspCOSession
  • SendOomMethodAbort() : MNwssOomHandler, CNwssWspCOSession
  • SendPrimitiveL() : MWspPrimitiveSenderCallback, CWspCOTransaction, CWspCOProtocolHandler
  • SendResponsePrimitive() : MWspCORxDataCallback, CWspCOTransaction
  • SendSessionEvent() : CWspCOProtocolHandler
  • SendSessionEventL() : RHTTPSession, CHTTPSession
  • ServerCapabilities() : CWspCOProtocolHandler, MWspCapabilityProvider
  • ServerCert() : CNwssWspTransportHandler, CNwssWspSession, CHttpTcpClient, CHttpSocket, MTextModeTransportHandler, CWspTransportHandler, RHTTPTransaction, RHTTPSession, CTransaction
  • ServerLocation() : CSubmissionDetails, CHttpTcpClient, MTextModeTransportHandler
  • ServiceCentreNumber() : CWspProxyInfoProvider, MWspProxyInfoProvider
  • ServiceL() : CWspCOProtocolHandler, CTextModeHttpProt, CProtocolHandler
  • Session() : RHTTPTransaction, RHTTPFilterCollection, CTransaction
  • SessionConnectL() : CWspCOProtocolHandler
  • SessionDisconnect() : CWspCOProtocolHandler
  • SessionDisconnected() : CNwssWspTransactionEventFilter
  • SessionDisconnectedCallback() : CNwssWspSession
  • SessionDisconnectRequested() : CNwssWspTransactionEventFilter
  • SessionHeadersProvider() : MConnectionInfoProvider, CNwssWspTransportHandler
  • SessionResumeL() : CWspCOProtocolHandler
  • SessionServerCert() : CWspCOProtocolHandler, CTextModeHttpProt, CProtocolHandler, CHTTPSession
  • SessionSuspend() : CWspCOProtocolHandler
  • SetBody() : RHTTPMessage
  • SetBodyDataL() : CWspCOTxData, CWspCORxData
  • SetClientMessageSize() : MWspCapabilitySetter
  • SetClientSDUSize() : MWspCapabilitySetter
  • SetCommsPrefs() : CTextModeHttpProt, MSessionPropertiesProvider
  • SetConnectionInfo() : TRequestComposer
  • SetCookieNameAndValueL() : CTextModeHeaderReader
  • SetCookieParamL() : CTextModeHeaderReader
  • SetDateTime() : THTTPHdrVal
  • SetFieldL() : RHTTPHeaders, CHeaders
  • SetFStringPartL() : CWspHeaderReader
  • SetHeaderDataL() : CWspCOTxData, CWspCORxData
  • SetHeaderL() : CHttpClient
  • SetInt() : THTTPHdrVal
  • SetLineBuffer() : TResponseParser
  • SetMethod() : RHTTPRequest
  • SetMethodMOR() : CWspCapabilityInfo, MWspCapabilitySetter
  • SetNegotiatedCapabilitiesL() : CNwssWspCOSession
  • SetNewDatePartL() : CWspHeaderReader, CTextModeHeaderReader
  • SetNewFStringParamL() : CTextModeHeaderReader
  • SetNewFStringPartL() : CWspHeaderReader, CTextModeHeaderReader
  • SetNewIntegerPartL() : CWspHeaderReader, CTextModeHeaderReader
  • SetNewParamL() : CWspHeaderReader
  • SetNewPartL() : CWspHeaderReader, CTextModeHeaderReader
  • SetNewStringParamL() : CTextModeHeaderReader
  • SetNewStringPartL() : CWspHeaderReader, CTextModeHeaderReader
  • SetParamL() : RHTTPHeaders, CHeaders
  • SetPartL() : RHeaderField, CHeaderField
  • SetPermanentRedirectedProxyL() : CWspProxyInfoProvider
  • SetPersistentConnection() : CHttpTcpServerLocation
  • SetPropertyL() : RHTTPPropertySet
  • SetPropertySet() : CHeaderFieldPart
  • SetProtocolOptions() : MWspCapabilitySetter
  • SetProxy() : CHttpTcpServerLocation
  • SetPushMOR() : MWspCapabilitySetter
  • SetRawFieldL() : RHTTPHeaders, CHeaders
  • SetRedirectUriL() : CRedirectFilter
  • SetRemoteClose() : CHttpSocket
  • SetRequest() : TRequestComposer
  • SetRequestDataL() : CWspCOTxData
  • SetRespBuffer() : TResponseParser
  • SetResponseDataL() : CWspCORxData
  • SetSecure() : CHttpTcpServerLocation
  • SetServerHeadersL() : CWspCOProtocolHandler, MWspSessionHeadersProvider
  • SetServerMessageSize() : MWspCapabilitySetter
  • SetServerSDUSize() : MWspCapabilitySetter
  • SetSessionEventCallback() : RHTTPSession, TClientFilter, CHTTPSession
  • SetSessionPropertyL() : CWspCOTxData
  • SetStatusCode() : RHTTPResponse
  • SetStatusL() : CWspCOProtocolHandler, CTextModeRxData, CTextModeHttpProt, MTransportHndObs, MRxDataObserver
  • SetStatusText() : RHTTPResponse
  • SetStr() : THTTPHdrVal
  • SetStrF() : THTTPHdrVal
  • SetStringPool() : TRequestComposer
  • SetTemporaryRedirectedProxyL() : CWspProxyInfoProvider
  • SetTextModeTransportHandler() : CTextModeProtTransaction
  • SetTransactionState() : CProtTransaction
  • SetupProxyInformation() : CTextModeHttpProt
  • SetURI() : TRequestComposer
  • SetURIL() : RHTTPRequest
  • SetValue() : CHeaderFieldParam, CHeaderFieldPart
  • SetVerbose() : CHttpEventHandler
  • SetVersion() : RHTTPResponse
  • SetWorkingBuffer() : TRequestComposer
  • SetWspVersion() : CWspHeaderCodec
  • Start() : CNwssWspCOEventDispatcher, CWspUnknownCapabilities, CWspHeaderCodePages, CWspExtendedMethods, CWspAliasAddresses, CConnectionTimer, MWspUnknownCapabilities, MWspHeaderCodePages, MWspExtendedMethods, MWspAliasAddresses
  • StartClientL() : CHttpClient
  • State() : CNwssWspSession
  • Status() : CHttpTcpClient, MTextModeTransportHandler, CResponse
  • StatusCode() : RHTTPResponse
  • StatusLine() : TResponseParser
  • StatusString() : CResponse
  • StatusText() : RHTTPResponse
  • Str() : THTTPHdrVal
  • StrF() : THTTPHdrVal
  • StringPool() : RHTTPSession, CHTTPManager
  • SubDoCancel() : CNwssWspSession, CNwssWspCOSession
  • SubmissionData() : CSubmissionDetails
  • SubmitDataToObserverL() : CHttpTcpClient
  • SubmitL() : CHttpTcpClient, CAuthenticationFilter, MTextModeTransportHandler, RHTTPTransaction
  • SubmitTransactionL() : CProtocolHandler
  • Suicide() : CWspCOTransaction
  • SupportedServices() : CNwssWspTransportHandler, CWspTransportHandler
  • SupportSuspendResume() : CWspCOProtocolHandler
  • SuspendInd() : CWspCOProtocolHandler, MWspCOSessionCallback
  • SuspendReq() : CNwssWspCOSession, MWspCOSessionInvoker
  • SynchronousSendEvent() : CTransaction
  • SyncMode() : CTransaction

- t -

  • TAbortReason : CNwssWspCOSession
  • TakeOwnershipOfServerLocation() : CSubmissionDetails
  • TBlockingStates : CHTTPSession
  • TBulkEncryptionAlgorithm : TWtlsCipherSuite
  • TChunkEncoder() : TRequestComposer::TChunkEncoder
  • TChunkState : TRequestComposer::TChunkEncoder
  • TConnectState : CHttpConnector
  • TDataState : CHeaderField
  • TDirection : THTTPEvent
  • Test() : CHttpExampleUtils
  • TEventRegistration() : TEventRegistration
  • TextModeTransportHandler() : CTextModeTxData, CTextModeRxData, CTextModeProtTransaction
  • TFilterCategory : TFilterInformation, TSessionFilterInfo
  • TFilterConfigurationIterator : TFilterConfigurationIterator, CHTTPSession
  • TFilterInformation() : TFilterInformation
  • TFilterRegistration() : TFilterRegistration
  • THeaderFieldParamIter : THeaderFieldParamIter, CHeaderFieldPart
  • THeaderFieldPartIter : THeaderFieldPartIter, CHeaderField
  • THTTPEvent() : THTTPEvent
  • THTTPFilterHandle() : THTTPFilterHandle
  • THTTPFilterIterator() : THTTPFilterIterator
  • THTTPFilterRegistration() : THTTPFilterRegistration
  • THTTPFormEncoderState : CHTTPFormEncoder
  • THTTPHdrFieldIter : THTTPHdrFieldIter, CHeaders
  • THTTPHdrVal() : THTTPHdrVal
  • THTTPPanic : HTTPPanic
  • THTTPSessionEvent() : THTTPSessionEvent
  • THttpState : CHttpTcpClient
  • THTTPValType : THTTPHdrVal
  • TKeyExchangeSuite : TWtlsKeyExchangeSuite
  • TKeyIdType : TWtlsKeyExchangeSuite
  • TMacAlgorithm : TWtlsCipherSuite
  • TMenuItems : CHttpClient
  • TNwssWspTrHndPanicCode : TNwssWspTrHndPanic
  • TPanic : TFCoreFiltersPanic
  • TPositions : MHTTPFilter
  • TQConv() : THTTPHdrVal::TQConv
  • TranferDataBufferOwnership() : CHttpConnector
  • Transaction() : CProtTransaction
  • TransactionCompletedL() : CProtocolHandler
  • TransactionFailed() : CProtocolHandler
  • TransactionHasBlocked() : CHTTPSession
  • TransactionServerCert() : CWspCOProtocolHandler, CTextModeHttpProt, CProtocolHandler, CHTTPSession
  • TransactionState() : CProtTransaction
  • TRequestComposer() : TRequestComposer
  • TRequestState : CWspCOTxData
  • TResponseParser() : TResponseParser
  • TrimWsBothEnds() : TTextHeaderUtils
  • TrimWsLeft() : TTextHeaderUtils
  • TrimWsRight() : TTextHeaderUtils
  • TryAppendLineBufferL() : TResponseParser
  • TryParseMoreDataL() : TResponseParser
  • TrySetLineBufferL() : TResponseParser
  • TServerConnectionStatus : MTextModeTransportHandler
  • TSessionEvent : THTTPSessionEvent
  • TSessionWarning : THTTPSessionEvent
  • TStandardEvent : THTTPEvent
  • TStandardValues : THTTPFilterHandle
  • TState : CNwssWspSession, TResponseParser
  • TSubState : TResponseParser
  • TSuperState : TResponseParser
  • TTransactionEvent : THTTPEvent
  • TTransactionState : CProtTransaction
  • TTransactionStates : CTransaction
  • TTransactionWarning : THTTPEvent
  • TTResponseParser_StateAccessor : TResponseParser
  • TWspService : CWspTransportHandler
  • TWspSupportedServices : CWspTransportHandler
  • TWspVersion : CWspHeaderCodec
  • TWtlsCipherSuite() : TWtlsCipherSuite
  • TWtlsKeyExchangeSuite() : TWtlsKeyExchangeSuite
  • TxData() : CProtTransaction
  • Type() : THTTPHdrVal

- u -

  • Unblock() : CTransaction, CHTTPSession
  • UninstallCurrentFilter() : TFilterConfigurationIterator
  • UnitMethodInvoke() : MWspCLMethodInvoker
  • UnitMethodResultInd() : MWspCLMethodCallback
  • UnitPushInd() : MWspCLPushCallback
  • UnlockProxyInfo() : CWspProxyInfoProvider
  • UpdateBodyData() : CWspCOTxData
  • UpdateBodyDataL() : CWspCORxData
  • UpdateClientSessionHeadersL() : CWspCOProtocolHandler
  • UpdateHeaderDataL() : CWspCORxData
  • UpdateNegotiatedCapabilitiesL() : CWspCOProtocolHandler
  • UpdateProxyInfoL() : CWspProxyInfoProvider
  • UpdateResponseDataL() : CWspCORxData
  • UpdateState() : CWspCOTxData
  • URI() : RHTTPRequest, CRequest
  • UsesProxy() : CHttpTcpServerLocation

- v -

  • ValidateRequestGetL() : CValidationFilter
  • ValidateRequestHeadersL() : CValidationFilter
  • ValidateRequestHeadL() : CValidationFilter
  • ValidateRequestMethodL() : CValidationFilter
  • ValidateRequestOptionsL() : CValidationFilter
  • ValidateRequestPostL() : CValidationFilter
  • ValidateRequestPutL() : CValidationFilter
  • ValidateRequestTraceL() : CValidationFilter
  • ValidateResponseStatusCode() : CValidationFilter
  • ValidateUntrustedServerCert() : CNwssWspTransportHandler, MSecurityPolicy
  • ValidateUntrustedServerCertL() : CNwssWspSession
  • Value() : CHeaderFieldParam, CHeaderFieldPart
  • Verbose() : CHttpEventHandler
  • Version() : RHTTPResponse, CResponse

- w -

  • WapStack() : MNwssWapServer, CNwssWspTransportHandler
  • Write() : CHttpTcpWriter, CHttpSocket
  • WriteComment() : THttpLogger
  • WriteCompletedL() : MHttpSocketObserver, CHttpTcpClient
  • WriteRawDataL() : RHeaderField, CHeaderField
  • WriteRawStrFPartL() : CTextModeHeaderWriter
  • WspPrimitiveSenderCallbackError() : MWspPrimitiveSenderCallback, CWspCOTransaction, CWspCOProtocolHandler
  • WspSessionService() : CWspProxyInfoProvider, MWspProxyInfoProvider
  • WtlsHnd() : CNwssWspSession, CNwssWspCOSession

- ~ -

  • ~CAliasAddress() : CAliasAddress
  • ~CAuthenticationFilter() : CAuthenticationFilter
  • ~CAuthenticationFilterInterface() : CAuthenticationFilterInterface
  • ~CConnectionTimer() : CConnectionTimer
  • ~CEComFilter() : CEComFilter
  • ~CExtendedMethod() : CExtendedMethod
  • ~CHeaderCodec() : CHeaderCodec
  • ~CHeaderCodePage() : CHeaderCodePage
  • ~CHeaderField() : CHeaderField
  • ~CHeaderFieldParam() : CHeaderFieldParam
  • ~CHeaderFieldPart() : CHeaderFieldPart
  • ~CHeaderReader() : CHeaderReader
  • ~CHeaders() : CHeaders
  • ~CHeaderWriter() : CHeaderWriter
  • ~CHttpClient() : CHttpClient
  • ~CHttpConnector() : CHttpConnector
  • ~CHttpEventHandler() : CHttpEventHandler
  • ~CHttpExampleUtils() : CHttpExampleUtils
  • ~CHTTPFormEncoder() : CHTTPFormEncoder
  • ~CHTTPManager() : CHTTPManager
  • ~CHTTPSession() : CHTTPSession
  • ~CHttpSocket() : CHttpSocket
  • ~CHttpTcpClient() : CHttpTcpClient
  • ~CHttpTcpReader() : CHttpTcpReader
  • ~CHttpTcpServerLocation() : CHttpTcpServerLocation
  • ~CHttpTcpWriter() : CHttpTcpWriter
  • ~CMessage() : CMessage
  • ~CNwssConnectGuard() : CNwssConnectGuard
  • ~CNwssTransLookUpTable() : CNwssTransLookUpTable
  • ~CNwssTransLUTEntry() : CNwssTransLookUpTable::CNwssTransLUTEntry
  • ~CNwssWspCOEventDispatcher() : CNwssWspCOEventDispatcher
  • ~CNwssWspCOSession() : CNwssWspCOSession
  • ~CNwssWspSession() : CNwssWspSession
  • ~CNwssWspSessionEventFilter() : CNwssWspSessionEventFilter
  • ~CNwssWspTransactionEventFilter() : CNwssWspTransactionEventFilter
  • ~CNwssWspTransportHandler() : CNwssWspTransportHandler
  • ~CNwssWspTrHndDataSupplier() : CNwssWspTrHndDataSupplier
  • ~CProtocolHandler() : CProtocolHandler
  • ~CProtTransaction() : CProtTransaction
  • ~CRedirectFilter() : CRedirectFilter
  • ~CRequest() : CRequest
  • ~CResponse() : CResponse
  • ~CRxData() : CRxData
  • ~CSecurityPolicy() : CSecurityPolicy
  • ~CSubmissionDetails() : CSubmissionDetails
  • ~CTCPClientFactory() : CTCPClientFactory
  • ~CTextModeDefaultCodec() : CTextModeDefaultCodec
  • ~CTextModeDefHdrReader() : CTextModeDefHdrReader
  • ~CTextModeDefHdrWriter() : CTextModeDefHdrWriter
  • ~CTextModeHeaderCodec() : CTextModeHeaderCodec
  • ~CTextModeHeaderReader() : CTextModeHeaderReader
  • ~CTextModeHeadersFilter() : CTextModeHeadersFilter
  • ~CTextModeHeaderWriter() : CTextModeHeaderWriter
  • ~CTextModeHttpProt() : CTextModeHttpProt
  • ~CTextModeProtTransaction() : CTextModeProtTransaction
  • ~CTextModeRxData() : CTextModeRxData
  • ~CTextModeTxData() : CTextModeTxData
  • ~CTxData() : CTxData
  • ~CUnknownCapability() : CUnknownCapability
  • ~CValidationFilter() : CValidationFilter
  • ~CWspAliasAddresses() : CWspAliasAddresses
  • ~CWspCapabilityInfo() : CWspCapabilityInfo
  • ~CWspCOProtocolHandler() : CWspCOProtocolHandler
  • ~CWspCORxData() : CWspCORxData
  • ~CWspCOTransaction() : CWspCOTransaction
  • ~CWspCOTxData() : CWspCOTxData
  • ~CWspDefaultHdrReader() : CWspDefaultHdrReader
  • ~CWspDefaultHdrWriter() : CWspDefaultHdrWriter
  • ~CWspDefaultHeaderCodec() : CWspDefaultHeaderCodec
  • ~CWspExtendedMethods() : CWspExtendedMethods
  • ~CWspHeaderCodec() : CWspHeaderCodec
  • ~CWspHeaderCodePages() : CWspHeaderCodePages
  • ~CWspHeaderReader() : CWspHeaderReader
  • ~CWspHeaderUtils() : CWspHeaderUtils
  • ~CWspHeaderWriter() : CWspHeaderWriter
  • ~CWspPrimitiveSender() : CWspPrimitiveSender
  • ~CWspProxyInfoProvider() : CWspProxyInfoProvider
  • ~CWspTransportHandler() : CWspTransportHandler
  • ~CWspUnknownCapabilities() : CWspUnknownCapabilities
  • ~TFilterConfigurationIterator() : TFilterConfigurationIterator
  • ~THeaderFieldParamIter() : THeaderFieldParamIter
  • ~THTTPHdrFieldIter() : THTTPHdrFieldIter
  • ~THttpLogger() : THttpLogger


Namespace Index

HTTP Transport Framework Internal Documentation Namespace List

Here is a list of all namespaces with brief descriptions:
Wap All type definitions and enumerations used in WSP are in placed in a wider WAP namespace, to avoid name conflicts with other components


Wap Namespace Reference

All type definitions and enumerations used in WSP are in placed in a wider WAP namespace, to avoid name conflicts with other components. More...

Enumerations

enum TWspPrimitive {
ESConnect = 0, ESDisconnect, ESSuspend, ESResume,
ESException, ESMethodInvoke, ESMethodInvokeData, ESMethodResult,
ESMethodResultData, ESMethodAbort, ESPush, ESConfirmedPush,
ESPushAbort
}
The TWspPrimitive type represents the WSP primitives defined in the WSP Specification, July 2001. More...

enum TWspProtocolOptions {
ELargeDataTransfer = 0x08, EAcknowledgementHeaders = 0x10, ESessionResumeFacility = 0x20, EPushFacility = 0x40,
EConfirmedPushFacility = 0x80
}
The TWspProtocolOptions type represents the optional protocol functions defined in the WSP Specification, July 2001. More...

enum TWspSessionState {
ENull = 0, EConnecting, EConnected, ESuspending,
ESuspended, EClosing, EResuming
}
The TWspSessionState type represents the states of a WSP session, as defined by the WSP Specification, July 2001. More...

enum TWspMethodState {
ENullMethod = 0, ERequesting, EWaiting, EWaiting2,
ECompleting, EAborting
}
The TWspMethodState type represents the states of a WSP method transaction, as defined by the WSP Specification, July 2001. More...

enum TWspBearer {
EAny = 0, EIP, ESMS7, ESMS,
EWAPSMS7, EWAPSMS
}
The TWspBearer type defines the set of supported bearers. More...

enum TWspSession { EWspConnectionOriented = 0, EWspConnectionLess }
The TWspSession type defines the 2 types of WSP Session Service; Connection Oriented and Connectionless. More...

enum TWspReason {
EProtoErr = 0xE0, EDisconnect = 0xE1, ESuspend = 0xE2, EResume = 0xE3,
ECongestion = 0xE4, EConnectErr = 0xE5, EMRUExceeded = 0xE6, EMORExceeded = 0xE7,
EPeerReq = 0xE8, ENetErr = 0xE9, EUserReq = 0xEA, EUserRfs = 0xEB,
EUserPnd = 0xEC, EUserDcr = 0xED, EUserDcu = 0xEE, ETemporaryRedirectedProxy = 0,
EPermanentRedirectedProxy, EChangedProxyInSuspendedSession, EWtlsConfigurationFailed, EWtlsPhase1HandshakeFailed,
EWtlsPhase2HandshakeFailed, EWtlsInvalidServerCert, EWtlsUntrustedServerCert, EWtlsNegotiatedConfigRejected,
EOutOfMemory, ESessionStateFailure
}
The TWspReason type is used by to report the cause of a particular indication primitive. More...

enum TWspCapability {
EAliasAddresses = 0, EExtendedMethods, EHeaderCodePages, EMethodMOR,
EPushMOR, EProtocolOptions, EClientSDUSize, EServerSDUSize,
EClientMessageSize, EServerMessageSize, EUnknownCapabilities, EAllCapabilities
}
The enum TWspCapabilty is used to select a capability to reset (if required) before setting the value of the capability. More...

Detailed Description

All type definitions and enumerations used in WSP are in placed in a wider WAP namespace, to avoid name conflicts with other components.

TODO - These will move to a common WAPMSG/WSPTransport file at a later stage, in the wap-stack subsystem, to be shared with the WAP Messaging API.

Enumeration Type Documentation

enum Wap::TWspBearer

The TWspBearer type defines the set of supported bearers.

Enumeration values:
EAny | Specifier for any bearer.
EIP | IP bearer.
ESMS7 | A 7-bit SMS bearer.
ESMS | An 8-bit SMS bearer.
EWAPSMS7 | A 7-bit WAP SMS bearer.
EWAPSMS | An 8-bit WAP SMS bearer.

Definition at line 165 of file WspTypes.h.

enum Wap::TWspCapability

The enum TWspCapabilty is used to select a capability to reset (if required) before setting the value of the capability.

Enumeration values:
EAliasAddresses | Specifies the Alias Addresses capability.
EExtendedMethods | Specifies the Extended Methods capability.
EHeaderCodePages | Specifies the Header Code Pages capability.
EMethodMOR Specifies the Method Maximum Outstanding Requests capability.

Default value is 1.

EPushMOR Specifies the Push Maximum Outstanding Requests capability.

Default value is 1.

EProtocolOptions Specifies the Protocol Options capability.

Default value is 0x00.

EClientSDUSize Specifies the Client SDU size capability.

Default value is 1400 octets.

EServerSDUSize Specifies the Server SDU size capability.

Default value is 1400 octets.

EClientMessageSize Specifies the Client Message size capability.

Default value is 1400 octets.

EServerMessageSize Specifies the Server Message size capability.

Default value is 1400 octets.

EUnknownCapabilities | Specifies the Unknown capabilities.
EAllCapabilities | Specifies all the capabilities.

Definition at line 315 of file WspTypes.h.

enum Wap::TWspMethodState

The TWspMethodState type represents the states of a WSP method transaction, as defined by the WSP Specification, July 2001.

Enumeration values:
ENullMethod
ERequesting
EWaiting
EWaiting2
ECompleting
EAborting

Definition at line 141 of file WspTypes.h.

enum Wap::TWspPrimitive

The TWspPrimitive type represents the WSP primitives defined in the WSP Specification, July 2001.

Enumeration values:
ESConnect
ESDisconnect
ESSuspend
ESResume
ESException
ESMethodInvoke
ESMethodInvokeData
ESMethodResult
ESMethodResultData
ESMethodAbort
ESPush
ESConfirmedPush
ESPushAbort

Definition at line 29 of file WspTypes.h.

enum Wap::TWspProtocolOptions

The TWspProtocolOptions type represents the optional protocol functions defined in the WSP Specification, July 2001.

When the client sends the Protocol Capability to the server, it indicates which functions it will accept from the server. The server returns from the set of functions sent by the client those that it will perform.

Enumeration values:
ELargeDataTransfer The Large Data Transfer feature includes support for multiple SDU's and support for the Data Fragment PDU.

Setting this falg indicates support for sending and receiving large data. If a client only wishes to receive large data, then it should set the Client and Server Message size fields appropriately.

EAcknowledgementHeaders The acknowledgement headers flag specifies that the client wishes to send acknowledgement headers.

If the server cannot process them (indicated by negotiating down the flag) the client should not send the headers as they will be ignored.

ESessionResumeFacility The client enables the Suspend Resume facility when it wishes to suspend and resume the session.

If the server does not support suspend and resume then this flag must be cleared in the negotiated capabilities.

EPushFacility The client uses this flag to indicate that it is able and willing to receive push information.

If the server cannot send pushes then this flag must be cleared in the negotiated capabilities.

EConfirmedPushFacility The client uses this flag to indicate that it is able and willing to receive confirmed push information.

If the server cannot send pushes then this flag must be cleared in the negotiated capabilities.

Definition at line 78 of file WspTypes.h.

enum Wap::TWspReason

The TWspReason type is used by to report the cause of a particular indication primitive.

The WSP Specification, July 2001, specifies a given set that MUST be recognised (6.2.5). Further values may be added.

Enumeration values:
EProtoErr The rules of the protocol were broken and in its current state, the peer could not perform the specified operation.

E.g. the PDU was not allowed.

EDisconnect | The session was disconnected while the operation was still in progress.
ESuspend | The session was suspended while the operation was still in progress.
EResume | The session was resumed while the operation was still in progress.
ECongestion | The request could not be processed due to a lack of resources.
EConnectErr | The connection was prevented due to an error.
EMRUExceeded | The SDU size in a request exceeded the maximum negotiated SDU size.
EMORExceeded | The negotiated value of the maximum outstanding transactions (either for push or method transactions) has been exceeded.
EPeerReq | The operation was aborted by the Provider.
ENetErr | An underlying network error prevented the completion of a request.
EUserReq | The cause of the indication was an action by the Client.
EUserRfs | The client has refesed the Push message, no specific reason, no retries.
EUserPnd | The Push message cannot be delivered to the intended destination.
EUserDcr | The Push message was discarded due to resource shortage.
EUserDcu | The content-type of the Push message cannot be processed.
ETemporaryRedirectedProxy The session connect request has been redirected to a new proxy.

This is a temporary redirection and the original proxy should be used in the future when trying to access this service. This is not defined by the WSP Specification.

EPermanentRedirectedProxy The session connect request has been redirected to a new proxy.

This is a permanent redirection and the new proxy should be used in the future when trying to access this service. The client will be notified of this event and the HTTP session property EWspProxyAddressnew will contain the new proxy's address. The client should update its access point database. This is not defined by the WSP Specification.

EChangedProxyInSuspendedSession The client had disconnected the session, but as Suspend Resume facility was being used, the session was suspended.

The client then changed the proxy and did a connect. The suspended session cannot be resumed, so the the current session must be disconnected (with this reason) and a session connect initiated with the new proxy. This is not defined by the WSP Specification.

EWtlsConfigurationFailed | The client's WSP session was disconnected in the Connecting state because configuration of the underlying WTLS layer failed prior to the phase 1 WTLS handshake.
EWtlsPhase1HandshakeFailed | The client's WSP session was disconnected in the Connecting state because phase 1 of the WTLS handshake failed.
EWtlsPhase2HandshakeFailed | The client's WSP session was disconnected in the Connecting state because phase 2 of the WTLS handshake failed.
EWtlsInvalidServerCert The client's WSP session was disconnected in the Connecting state because the proxy's WTLS certificate was invalid - e.g.

badly formed, or out of date.

EWtlsUntrustedServerCert The client's WSP session was disconnected in the Connecting state because the proxy's WTLS certificate could not be trusted.

This means it was not signed by any root certificate on the device, and the security policy criteria could not determine further whether it could be trusted or not.

EWtlsNegotiatedConfigRejected | The client's WSP session was disconnected in the Connecting state because the negotiated WTLS configuration at completion of the secure handshake was rejected by criteria in the security policy.
EOutOfMemory | The client's transaction or session has failed due to an out-of-memory situation.
ESessionStateFailure | The client's session has entered an inconsistent state, probably due to a failure caused by an out-of-memory situation.

Definition at line 204 of file WspTypes.h.

enum Wap::TWspSession

The TWspSession type defines the 2 types of WSP Session Service; Connection Oriented and Connectionless.

Enumeration values:
EWspConnectionOriented | Specifier for Connection Oriented Session Service.
EWspConnectionLess | Specifier for Connectionless Session Service.

Definition at line 190 of file WspTypes.h.

enum Wap::TWspSessionState

The TWspSessionState type represents the states of a WSP session, as defined by the WSP Specification, July 2001.

Enumeration values:
ENull
EConnecting
EConnected
ESuspending
ESuspended
EClosing
EResuming

Definition at line 113 of file WspTypes.h.


File Member Index

HTTP Transport Framework Internal Documentation File Members

_ | e | k | p | t

Here is a list of all file members with links to the files they belong to:

- _ -

  • __CLOSELOG : logging.h
  • __DEBUGTESTLEAVE : TestOom.h
  • __DECLARE_LOG : logging.h, httplogger.h
  • __DUMP : logging.h
  • __DUMPBIN : httplogger.h
  • __LOG : logging.h, httplogger.h
  • __LOG1 : logging.h, httplogger.h
  • __LOG2 : logging.h, httplogger.h
  • __LOG3 : logging.h, httplogger.h
  • __LOG_TITLE : logging.h
  • __OPEN_LOG : httplogger.h
  • __OPEN_LOG2 : httplogger.h
  • __OPENLOG : logging.h
  • __QINFO : logging.h, httplogger.h
  • __TESTOOM : TestOom.h
  • __TESTOOMD : TestOom.h
  • _LIT() : TNwssWspTrHndPanic.h, WspPanic.h
  • _LIT8() : textmodestd.h
  • _LOGGING : logging.h, httplogger.h

- e -

  • EBadRequestComposerBuffer : textmodestd.h
  • EBadState : CHttpTcpCli.h
  • ECompleteNoError : CTextModeRxData.h
  • EConnectionPropertyNotSet : textmodestd.h
  • EDoNotPrompt : MSessionPropertiesProvider.h
  • EEmptyLine : CTextModeRxData.h
  • EFoundBody : CTextModeRxData.h
  • EFoundChunkHeader : CTextModeRxData.h
  • EFoundConnectionClose : mtransporthndobs.h
  • EFoundEndOfReply : mtransporthndobs.h
  • EFoundHeaderField : CTextModeRxData.h
  • EFoundHeaderFieldContinuation : CTextModeRxData.h
  • EFoundStatusLine : CTextModeRxData.h
  • EFullUrlRequired : textmodestd.h
  • EIncorrectObserver : CHttpTcpCli.h
  • EInvalidHeaderForHTTP10 : textmodestd.h
  • EInvalidHeaderValueType : textmodestd.h
  • ELineBuffOverrun : CTextModeRxData.h
  • ENoData : CTextModeRxData.h
  • ENoSubmissions : CHttpTcpCli.h
  • EParseError : CTextModeRxData.h
  • EPartialData : CTextModeRxData.h
  • EPrompt : MSessionPropertiesProvider.h
  • EProtTransNotSet : textmodestd.h
  • EReadCompletedUnexpectedly : CHttpTcpCli.h
  • EReplyComplete : mtransporthndobs.h
  • ERequestingServerLocationWhenNotConnected : CHttpTcpCli.h
  • ERespInvalid : textmodestd.h
  • ESocketClosed : mtransporthndobs.h
  • ESubmitLWithActiveSubmission : CHttpTcpCli.h
  • ETextModeRxDataInvalidState : textmodestd.h
  • ETextModeTransportHandlerInvalidState : textmodestd.h
  • ETextModeTransportHandlerNotSet : textmodestd.h
  • EUriMissingAuthority : textmodestd.h
  • EWriteCompletedUnexpectedly : CHttpTcpCli.h

- k -

  • KAnyStatusCode : rhttpsession.h
  • KChunkHeaderSize : CTextModeTxData.h
  • KDefaultRawChunkSize : RHeaderField.h
  • KErrHttpCantResetRequestBody : httperr.h
  • KErrHttpDecodeAccept : httperr.h
  • KErrHttpDecodeBasicAuth : httperr.h
  • KErrHttpDecodeConnection : httperr.h
  • KErrHttpDecodeContentLength : httperr.h
  • KErrHttpDecodeContentType : httperr.h
  • KErrHttpDecodeCookie : httperr.h
  • KErrHttpDecodeDigestAuth : httperr.h
  • KErrHttpDecodeMalformedDate : httperr.h
  • KErrHttpDecodeMalformedDay : httperr.h
  • KErrHttpDecodeMalformedInteger : httperr.h
  • KErrHttpDecodeMalformedMonth : httperr.h
  • KErrHttpDecodeMalformedQuotedStr : httperr.h
  • KErrHttpDecodeMalformedWeekDay : httperr.h
  • KErrHttpDecodeMalformedWkDay : httperr.h
  • KErrHttpDecodeMalformedYear : httperr.h
  • KErrHttpDecodeTransferEncoding : httperr.h
  • KErrHttpDecodeUnknownAuthScheme : httperr.h
  • KErrHttpDecodeWWWAuthenticate : httperr.h
  • KErrHttpEncodeAccept : httperr.h
  • KErrHttpEncodeAcceptCharset : httperr.h
  • KErrHttpEncodeAuthorization : httperr.h
  • KErrHttpEncodeBasicAuth : httperr.h
  • KErrHttpEncodeCacheControl : httperr.h
  • KErrHttpEncodeConnection : httperr.h
  • KErrHttpEncodeContentLength : httperr.h
  • KErrHttpEncodeContentType : httperr.h
  • KErrHttpEncodeCookie : httperr.h
  • KErrHttpEncodeCookie2 : httperr.h
  • KErrHttpEncodeDate : httperr.h
  • KErrHttpEncodeDefault : httperr.h
  • KErrHttpEncodeDigestAuth : httperr.h
  • KErrHttpEncodeHost : httperr.h
  • KErrHttpEncodeHostPort : httperr.h
  • KErrHttpEncodeIfMatch : httperr.h
  • KErrHttpEncodeIfModifiedSince : httperr.h
  • KErrHttpEncodeIfNoneMatch : httperr.h
  • KErrHttpEncodeIfUnmodifiedSince : httperr.h
  • KErrHttpEncodePragma : httperr.h
  • KErrHttpEncodeQValue : httperr.h
  • KErrHttpEncodeTransferEncoding : httperr.h
  • KErrHttpEncodeUserAgent : httperr.h
  • KErrHttpEntityHeaderMissingContentType : httperr.h
  • KErrHttpGeneralHeaderMissingHost : httperr.h
  • KErrHttpInvalidHeaderInRequest : httperr.h
  • KErrHttpMissingHeaderBase : httperr.h
  • KErrHttpPostReqBodyWithoutSizeOnHTTP10 : httperr.h
  • KErrHttpProtocolHandlerBase : httperr.h
  • KErrHttpProtTransactionNotInitialised : httperr.h
  • KErrHttpRedirectExceededLimit : httperr.h
  • KErrHttpRedirectNoLocationField : httperr.h
  • KErrHttpRedirectUseProxy : httperr.h
  • KErrHttpReqBuildErrorBase : httperr.h
  • KErrHttpRequestBodyMissing : httperr.h
  • KErrHttpRequestHasBody : httperr.h
  • KErrHttpResponseFailureBase : httperr.h
  • KErrHttpTraceReqWithoutMaxForwardHeader : httperr.h
  • KErrHttpUnknownParseState : httperr.h
  • KHttpDefaultRawChunkSize : CHeaderField.h
  • KHttpErrorBase : httperr.h
  • KHttpHeaderDecodeErrorBase : httperr.h
  • KHttpHeaderEncodeErrorBase : httperr.h
  • KHTTPMatchAnyEventUid : thttpevent.h
  • KHTTPUid : thttpevent.h
  • KHttpValueDecodeErrorBase : httperr.h
  • KMaxContentTypeSize : httpexampleclient.h
  • KMaxProxyAddrLen : WspTypes.h
  • KNwssResponseDataBufferSize : CNwssWspTrHndDataSupplier.h
  • KProtocolHandlerActivePriority : cprotocolhandler.h
  • KRespPsHttpInvalidHexChar : textmodestd.h
  • KRespPsHttpNoHeaderSep : textmodestd.h
  • KRespPsHttpNoStatCodeSep : textmodestd.h
  • KRespPsHttpNotAtZero : textmodestd.h
  • KRespPsHttpNoVersionSep : textmodestd.h
  • KRespPsNoLF : textmodestd.h
  • KSessionEventBaseStatus : thttpevent.h
  • KSessionWarningBaseStatus : thttpevent.h
  • KTransactionActivePriority : cprotocolhandler.h
  • KTransactionEventBaseStatus : thttpevent.h
  • KTransactionWarningBaseStatus : thttpevent.h
  • KUidFilterPluginInterface : CEComFilter.h
  • KUidProtocolHandlerPluginInterface : cprotocolhandler.h
  • KWspErrAccessPointNotSetUp : WspError.h
  • KWspErrBadRedirectedAddressData : WspError.h
  • KWspErrBearerNotSupported : WspError.h
  • KWspErrCouldNotCreateTransportHandler : WspError.h
  • KWspErrExpectingBodyData : WspError.h
  • KWspErrMissingHeader : WspError.h
  • KWspErrorBase : WspError.h
  • KWspErrRequestTooBig : WspError.h
  • KWspErrRequiredServicesNotSupported : WspError.h
  • KWspErrServiceNumberNotDefined : WspError.h
  • KWspErrSessionClosingOrSuspending : WspError.h
  • KWspErrSMSBearerNotInCommsDB : WspError.h
  • KWspErrStreamedRequestDataNotSupported : WspError.h
  • KWspErrTrailerHeadersNotExpected : WspError.h
  • KWspErrUnsupportedSendPrimitive : WspError.h
  • KWspPanicBadBearerProperty : WspPanic.h
  • KWspPanicBadBearerType : WspPanic.h
  • KWspPanicBadClientMessageSize : WspPanic.h
  • KWspPanicBadConenctionTimeout : WspPanic.h
  • KWspPanicBadMethodMOR : WspPanic.h
  • KWspPanicBadMethodState : WspPanic.h
  • KWspPanicBadMethodType : WspPanic.h
  • KWspPanicBadPortProperty : WspPanic.h
  • KWspPanicBadProxyAddressProperty : WspPanic.h
  • KWspPanicBadSecurityProperty : WspPanic.h
  • KWspPanicBadServerMessageSize : WspPanic.h
  • KWspPanicBadServiceNumberProperty : WspPanic.h
  • KWspPanicBadTrailerHeader : WspPanic.h
  • KWspPanicBadWspSessionTypeProperty : WspPanic.h
  • KWspPanicCommDBContainsBadData : WspPanic.h
  • KWspPanicDisconnectNotDone : WspPanic.h
  • KWspPanicIllegalSessionState : WspPanic.h
  • KWspPanicLDTNotSuppoted : WspPanic.h
  • KWspPanicMethodAlreadyActive : WspPanic.h
  • KWspPanicMethodsStillOutstanding : WspPanic.h
  • KWspPanicNoMoreMessageSpace : WspPanic.h
  • KWspPanicNoRequestDataReceived : WspPanic.h
  • KWspPanicNoResponseDataReceived : WspPanic.h
  • KWspPanicNotExpectingMoreRequestData : WspPanic.h
  • KWspPanicNotExpectingMoreResponseData : WspPanic.h
  • KWspPanicNoTrailerHeaders : WspPanic.h
  • KWspPanicResponseDataNotReleased : WspPanic.h
  • KWspPanicRxDataObjectNotReset : WspPanic.h
  • KWspPanicSessionNotInValidState : WspPanic.h
  • KWspPanicTransportHandlerAlreadyExists : WspPanic.h
  • KWspPanicTransportHandlerDoesNotExist : WspPanic.h
  • KWspPanicTxDataInInvalidState : WspPanic.h
  • KWspPanicTxDataObjectNotReset : WspPanic.h
  • KWtlsErrConfigurationFailed : WspError.h
  • KWtlsErrInvalidServerCert : WspError.h
  • KWtlsErrNegotiatedConfigRejected : WspError.h
  • KWtlsErrPhase1HandshakeFailed : WspError.h
  • KWtlsErrPhase2HandshakeFailed : WspError.h
  • KWtlsErrUntrustedServerCert : WspError.h
  • KWtlsMaxKeyIdLength : WspTypes.h

- p -

  • Panic() : WspPanic.h, textmodestd.h

- t -

  • THttpRxDataFlags : mtransporthndobs.h
  • THttpRxDataStat : mtransporthndobs.h
  • THTTPTextModeProtPanic : textmodestd.h
  • THttpTransportState : mtransporthndobs.h
  • TRespParseStat : CTextModeRxData.h
  • TSecureDialogPref : MSessionPropertiesProvider.h
  • TTcpCliPanicCode : CHttpTcpCli.h
  • TWspError : WspError.h
  • TWspPanic : WspPanic.h


Namespace Member Index

HTTP Transport Framework Internal Documentation Namespace Members

e | t

Here is a list of all namespace members with links to the namespace documentation for each member:

- e -

  • EAborting : Wap
  • EAcknowledgementHeaders : Wap
  • EAliasAddresses : Wap
  • EAllCapabilities : Wap
  • EAny : Wap
  • EChangedProxyInSuspendedSession : Wap
  • EClientMessageSize : Wap
  • EClientSDUSize : Wap
  • EClosing : Wap
  • ECompleting : Wap
  • EConfirmedPushFacility : Wap
  • ECongestion : Wap
  • EConnected : Wap
  • EConnectErr : Wap
  • EConnecting : Wap
  • EDisconnect : Wap
  • EExtendedMethods : Wap
  • EHeaderCodePages : Wap
  • EIP : Wap
  • ELargeDataTransfer : Wap
  • EMethodMOR : Wap
  • EMORExceeded : Wap
  • EMRUExceeded : Wap
  • ENetErr : Wap
  • ENull : Wap
  • ENullMethod : Wap
  • EOutOfMemory : Wap
  • EPeerReq : Wap
  • EPermanentRedirectedProxy : Wap
  • EProtocolOptions : Wap
  • EProtoErr : Wap
  • EPushFacility : Wap
  • EPushMOR : Wap
  • ERequesting : Wap
  • EResume : Wap
  • EResuming : Wap
  • ESConfirmedPush : Wap
  • ESConnect : Wap
  • ESDisconnect : Wap
  • EServerMessageSize : Wap
  • EServerSDUSize : Wap
  • ESessionResumeFacility : Wap
  • ESessionStateFailure : Wap
  • ESException : Wap
  • ESMethodAbort : Wap
  • ESMethodInvoke : Wap
  • ESMethodInvokeData : Wap
  • ESMethodResult : Wap
  • ESMethodResultData : Wap
  • ESMS : Wap
  • ESMS7 : Wap
  • ESPush : Wap
  • ESPushAbort : Wap
  • ESResume : Wap
  • ESSuspend : Wap
  • ESuspend : Wap
  • ESuspended : Wap
  • ESuspending : Wap
  • ETemporaryRedirectedProxy : Wap
  • EUnknownCapabilities : Wap
  • EUserDcr : Wap
  • EUserDcu : Wap
  • EUserPnd : Wap
  • EUserReq : Wap
  • EUserRfs : Wap
  • EWaiting : Wap
  • EWaiting2 : Wap
  • EWAPSMS : Wap
  • EWAPSMS7 : Wap
  • EWspConnectionLess : Wap
  • EWspConnectionOriented : Wap
  • EWtlsConfigurationFailed : Wap
  • EWtlsInvalidServerCert : Wap
  • EWtlsNegotiatedConfigRejected : Wap
  • EWtlsPhase1HandshakeFailed : Wap
  • EWtlsPhase2HandshakeFailed : Wap
  • EWtlsUntrustedServerCert : Wap

- t -

  • TWspBearer : Wap
  • TWspCapability : Wap
  • TWspMethodState : Wap
  • TWspPrimitive : Wap
  • TWspProtocolOptions : Wap
  • TWspReason : Wap
  • TWspSession : Wap
  • TWspSessionState : Wap


Page Index

HTTP Transport Framework Internal Documentation Related Pages

Here is a list of all related documentation pages:
  • Todo List


Todo List

Member CConnectionTimer::RunL()
add leaves

Class MConnectionTimerCallback
docing

Member CHeaderField::iParts
Is it worth this being a union?

Member CHeaderField::iRawData
Is it worth this being a union?

Class MWspCOMethodObserver
docing

Class CWspCOProtocolHandler
docing

Member CWspCOProtocolHandler::ConstructL()
leaves

Member CWspCOProtocolHandler::CreateWspTransportHandlerL()
docing @leave Leaves with KErrNotFound if the WSP transport handler cannot be found. Leaves with KErrNotSupported if the loaded WSP transport handler does not support Connection-Orientated Session Management facility and Method Invocation facility.

Member CWspCOProtocolHandler::SessionConnectL()
leaves

Member CWspCOProtocolHandler::SessionDisconnect(TWspReason aReason)
leaves

Member CWspCOProtocolHandler::SessionResumeL()
leaves

Member CWspCOProtocolHandler::SessionSuspend()
leaves

Member CWspCOProtocolHandler::UpdateNegotiatedCapabilitiesL()
leaves

Class CWspCOTransaction
docing

Member CWspCOTransaction::MethodAbort()
finish docing

Member CWspCOTransaction::MethodInvokeData()
finish docing

Member CWspCOTransaction::Suicide()
finish docing

Class CWspCOTxData
docing

Member CWspCOTxData::EncodeHeadersL(RHTTPHeaders aHeaders)
finish docing

Member CWspCOTxData::SetBodyDataL(MHTTPDataSupplier &aRequestBody)
finish docing

Member CWspCOTxData::SetHeaderDataL(RHTTPRequest aRequest)
finish docing

Member CWspCOTxData::SetRequestDataL()
finish docing

Member CWspCOTxData::SetSessionPropertyL(TInt aProperty, THTTPHdrVal aFieldValue)
docing

Member CWspCOTxData::UpdateBodyData()
finish docing

Class CWspHeaderUtils
docing

Class CWspPrimitiveSender
docing

Member CWspPrimitiveSender::RunL()
adds leaves

Member TWspError
docing

Member _LIT(KWspPanicCategory,"WSP-CO-PH")
docing


Graphical Class Hierarchy

HTTP Transport Framework Internal Documentation Graphical Class Hierarchy

Go to the textual class hierarchy


Alphabetical index

HTTP Transport Framework Internal Documentation Compound Index

A
THTTPHdrVal CNwssTransLookUpTable::CNwssTransLUTEntry CSubmissionDetails MWspCLPushInvoker
CAliasAddress THTTPHdrVal::TQConv MNwssWapServer
T
MWspCOMethodCallback
MHTTPAuthenticationCallback CHeaderCodec CNwssWspCOEventDispatcher CTCPClientFactory MWspCOMethodInvoker
CAuthenticationFilter CHeaderCodePage CNwssWspCOSession TTextHeaderUtils MWspCOMethodObserver
CAuthenticationFilter::TCredentials CHeaderField CNwssWspCOSession::TDelayedDisconnectPckg CTextModeDefaultCodec CWspCOProtocolHandler
CAuthenticationFilterInterface RHeaderField CNwssWspCOSession::TDelayedMethodAbortPckg CTextModeDefHdrReader MWspCOPushCallback
CAuthenticationFilterInterface::TAuthenticationParams CHeaderFieldParam CNwssWspSession CTextModeDefHdrWriter MWspCOPushInvoker
C
THeaderFieldParamIter CNwssWspSessionEventFilter CTextModeHeaderCodec CWspCORxData
TClientFilter CHeaderFieldPart CNwssWspTransactionEventFilter CTextModeHeaderReader MWspCORxDataCallback
MComposerObserver THeaderFieldPartIter CNwssWspTransportHandler CTextModeHeadersFilter MWspCOSessionCallback
MConnectInvokerCallback CHeaderReader CNwssWspTrHndDataSupplier CTextModeHeaderWriter MWspCOSessionInvoker
RHTTPConnectionInfo RHTTPHeaders TNwssWspTrHndPanic CTextModeHttpProt CWspCOTransaction
MConnectionInfoProvider CHeaders
P
CTextModeProtTransaction CWspCOTxData
CConnectionTimer CHeaders::THeaderFieldNamePair RHTTPPropertySet CTextModeRxData MWspCOTxDataCallback
MConnectionTimerCallback CHeaderWriter CProtocolHandler MTextModeTransportHandler CWspDefaultHdrReader
D
CHttpClient CProtTransaction CTextModeTxData CWspDefaultHdrWriter
MHTTPDataSupplier CHttpConnector TProxyInfo RHTTPTransaction CWspDefaultHeaderCodec
TDummyTransactionCallback CHttpEventHandler
R
CTransaction CWspExtendedMethods
E
CHttpExampleUtils CRedirectFilter MHTTPTransactionCallback MWspExtendedMethods
CEComFilter THttpLogger RHTTPRequest RHTTPTransactionPropertySet CWspHeaderCodec
THTTPEvent HTTPPanic CRequest MTransportHndObs MWspHeaderCodePages
TEventRegistration CHttpSocket TRequestComposer CTxData CWspHeaderCodePages
CExtendedMethod MHttpSocketObserver TRequestComposer::TChunkEncoder
U
CWspHeaderReader
F
HTTPStatus RHTTPResponse CUnknownCapability CWspHeaderUtils
TFCoreFiltersPanic CHttpTcpClient CResponse
V
CWspHeaderWriter
MHTTPFilter CHttpTcpReader TResponseParser CValidationFilter CWspPrimitiveSender
MHTTPFilterBase CHttpTcpServerLocation CRxData
W
MWspPrimitiveSenderCallback
RHTTPFilterCollection CHttpTcpWriter MRxDataObserver MWspAliasAddress CWspProxyInfoProvider
TFilterConfigurationIterator
M
S
MWspAliasAddresses MWspProxyInfoProvider
MHTTPFilterCreationCallback CHTTPManager MSecurityPolicy CWspAliasAddresses TWspRedirectedAddress
THTTPFilterHandle RHTTPMessage CSecurityPolicy CWspCapabilityInfo MWspSessionHeadersProvider
TFilterInformation CMessage CHTTPSession MWspCapabilityProvider CWspTransportHandler
THTTPFilterIterator
N
RHTTPSession MWspCapabilitySetter CWspTransportHandler::SInstantiationParams
TFilterRegistration CNwssConnectGuard THTTPSessionEvent MWspCapabilityViewer MWspUnknownCapabilities
THTTPFilterRegistration MNwssOomHandler MHTTPSessionEventCallback MWspCLMethodCallback CWspUnknownCapabilities
CHTTPFormEncoder MNwssSessionEventHandler TSessionFilterInfo MWspCLMethodInvoker TWtlsCipherSuite
H
MNwssTransactionEventHandler MSessionPropertiesProvider MWspCLPushCallback TWtlsKeyExchangeSuite
THTTPHdrFieldIter CNwssTransLookUpTable


Graph Legend

This page explains how to interpret the graphs that are generated by doxygen.

Consider the following example:

/*! Invisible class because of truncation */
class Invisible { };

/*! Truncated class, inheritance relation is hidden */
class Truncated : public Invisible { };

/* Class not documented with doxygen comments */
class Undocumented { };

/*! Class that is inherited using public inheritance */
class PublicBase : public Truncated { };

/*! A template class */
template<class T> class Templ { };

/*! Class that is inherited using protected inheritance */
class ProtectedBase { };

/*! Class that is inherited using private inheritance */
class PrivateBase { };

/*! Class that is used by the Inherited class */
class Used { };

/*! Super class that inherits a number of other classes */
class Inherited : public PublicBase,
                  protected ProtectedBase,
                  private PrivateBase,
                  public Undocumented
                  public Templ<int>
{
  private:
    Used *m_usedClass;
};
If the MAX_DOT_GRAPH_HEIGHT tag in the configuration file is set to 240 this will result in the following graph:

The boxes in the above graph have the following meaning:

  • A filled black box represents the struct or class for which the graph is generated.
  • A box with a black border denotes a documented struct or class.
  • A box with a grey border denotes an undocumented struct or class.
  • A box with a red border denotes a documented struct or class forwhich not all inheritance/containment relations are shown. A graph is truncated if it does not fit within the specified boundaries.
The arrows have the following meaning:
  • A dark blue arrow is used to visualize a public inheritance relation between two classes.
  • A dark green arrow is used for protected inheritance.
  • A dark red arrow is used for private inheritance.
  • A purple dashed arrow is used if a class is contained or used by another class. The arrow is labeled with the variable(s) through which the pointed class or struct is accessible.
  • A yellow dashed arrow denotes a relation between a template instance and the template class it was instantiated from. The arrow is labeled with the template parameters of the instance.