buildframework/helium/sf/python/pythoncore/setup.py
changeset 587 85df38eb4012
child 628 7c4a911dc066
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/buildframework/helium/sf/python/pythoncore/setup.py	Tue Apr 27 08:33:08 2010 +0300
@@ -0,0 +1,35 @@
+#============================================================================ 
+#Name        : .py 
+#Part of     : Helium 
+
+#Copyright (c) 2009 Nokia Corporation and/or its subsidiary(-ies).
+#All rights reserved.
+#This component and the accompanying materials are made available
+#under the terms of the License "Eclipse Public License v1.0"
+#which accompanies this distribution, and is available
+#at the URL "http://www.eclipse.org/legal/epl-v10.html".
+#
+#Initial Contributors:
+#Nokia Corporation - initial contribution.
+#
+#Contributors:
+#
+#Description:
+#===============================================================================
+import os
+from setuptools import setup, find_packages
+pyfiles = []
+for x in os.listdir('lib'):
+    if x.endswith('.py'):
+        pyfiles.append(x.replace('.py', ''))
+setup(
+    name = 'pythoncore',
+    version = '0.1',
+    description = "pythoncore",
+    license = 'EPL',
+    package_dir = {'': 'lib'},
+    py_modules = pyfiles,
+    packages = find_packages('lib', exclude=["*tests"]),
+    test_suite = 'nose.collector',
+    package_data = {'': ['*.xml', '**/*.xml', '*.pl']},
+    )